PTC/USER 2009

PTC/USER 2009
 PTC/USER 2009 Pro/ENGINEER Wildfire 5.0 Hands On Workshop WORKSHOP USE ONLY Please do not write notes in this book or remove from the workshop. It will be used by all participants. PTC/USER 2009 Table of Contents Interactive Modeling ...................................................................................... 3 U
U
Molded Part Design Efficiency ..................................................................... 16 U
U
Sheet Metal Design & Welding .................................................................... 22 U
U
Flexible Assembly ......................................................................................... 36 U
U
Simulation .................................................................................................... 46 U
U
Drawing Workflow and Efficiency ................................................................ 59 U
U
Pro/ENGINEER Manikin ................................................................................ 71 U
U
Tolerance Analysis ....................................................................................... 78 U
U
Pro/ENGINEER Wildfire Hands On Workshop Page 1 PTC/USER 2009 CAD Files The CAD files required for this tutorial can be download from this location: http://download.ptc.com/products/proe/wildfire5/tutorial/wf5_how_student_v2.zip
HU
U
Document Format & Printing This document is setup to be printed with (2) pages per sheet to minimize the total number of printed pages. If available, please setup your printer for multi‐page printing. Conventions Information is provided at the start of many tasks. Tips are provided along the way, with time‐saving or alternate techniques. Notes are provided with additional useful details, which may not be required to complete the tutorial. •
•
•
•
•
Menu commands are shown in Bold The comma character , is as a separator between commands Icons are shown in line with command text Keyboard keys are shown in Bold CAPS The left, middle and right mouse buttons are referred to as LMB, MMB, RMB Pro/ENGINEER Wildfire Hands On Workshop Page 2 PTC/USER 2009 Interactive Modeling 0B
This tutorial will cover some of the new sketcher, feature and edit functions in Pro/ENGINEER along with placement of User Defined Features (UDF) and the Model Properties dialog box. New Sketcher Functions 8B
1. File, Open , INTERACTIVE‐MODELING folder, select housing.prt, Open Actual exercise model color may be different to improve contrast in sketcher 1. Select Sketch , select the surface shown below (with the hole) as the sketch plane, Sketch, toggle on No Hidden Pro/ENGINEER Wildfire Hands On Workshop Page 3 PTC/USER 2009 New sketching tools can directly create a slanted rectangle and a slanted ellipse, providing flexibility and speed in feature creation. 2. Select the fly‐out arrow next to and select Slant Rectangle , sketch a slanted rectangle in the sketch plane, do NOT snap the rectangle to any references 3. Pick the fly‐out arrow next to and select Center and Axis Ellipse , start at mid‐point of the width, end at the corner as shown, LMB to finish the ellipse 4. Select Chamfer , select the adjacent entities for length and width as shown below, MMB to finish Pro/ENGINEER Wildfire Hands On Workshop Page 4 PTC/USER 2009 5. Hold Ctrl and select the chamfer and the adjacent entity shown, RMB, review all object‐action constraints, Equal Sketcher constraints and workflows are more flexible. There are shortcut menus, object‐action workflow, and a consolidated user interface. 6. Select Delete Segment , delete unnecessary sketch entities as shown Pro/ENGINEER Wildfire Hands On Workshop Page 5 PTC/USER 2009 In the follow tasks, make sure to use the fly‐out to select Geometry Centerline or Point. These are different than regular sketcher counterparts. Depending on how the sketch is used, they can produce datum features in the model. 7. Select the fly‐out arrow next to and select Geometry Centerline geometry centerline snapped to two corners as shown below , sketch a 8. Select the fly‐out arrow next to and select Geometry Point , sketch a point at any position inside the sketch, MMB to confirm 9. Select Done to finish sketch Pro/ENGINEER Wildfire Hands On Workshop Page 6 PTC/USER 2009 10.Toggle on Shading display Axis and Datum Point , Named View List , sketcher, toggle on Datum , review the datum axis and the datum point created in the Sketcher, toggle off Datum Axis and Datum Point 11.Pick Extrude , select the sketch just created, RMB on the depth control handle , Symmetric, change the depth to 1.00, MMB to finish 12.Toggle Axis Display
, note that the Geometry Point resulted in a Datum Axis, toggle off the Axis Display Pro/ENGINEER Wildfire Hands On Workshop Page 7 PTC/USER 2009 Undo/Redo 9B
Some operations will clear the stack. If you do not see the exact list as shown below, experiment with a few operations and/or the choices available. 1. Select the arrow next to 2. Select the arrow next Undo and select Undo: Sketch Redo and select Redo: Extrude Dynamic Edit 10B
You can use the Dynamic Edit command to edit features and immediately see the impact of dimensional changes on the model geometry. Use the 3D drag handles on the section to move the entire section. Note that constraints are enforced. Pro/ENGINEER Wildfire Hands On Workshop Page 8 PTC/USER 2009 1. Select Round , RMB on an intersection edge between the extrude feature and the box wall, Pick From List 2. Select the Intent Edges from list for two loops from intersection of extrusion and the base model, OK 3. Change the round radii to 0.12, MMB to confirm 4. Select the extrude feature just created in the Model Tree or in the graphics window, RMB Dynamic Edit, select 3D drag handle where the cursor points as shown below Pro/ENGINEER Wildfire Hands On Workshop Page 9 PTC/USER 2009 5. Move the entire feature towards the hole, review the dynamic changes 6. LMB on the graphic window to exit the dynamic edit Pro/ENGINEER Wildfire Hands On Workshop Page 10 PTC/USER 2009 Failure and Diagnostics In Pro/ENGINEER Wildfire 5.0, you can deal with failures now or later, and models can now be saved with failed features. “Failed” geometry is shown when possible. 1. Named View List , No_Resolve, select the BOSS_1 protrusion feature in the Model Tree, RMB Dynamic Edit, RMB in the graphics window, check Show/Hidden All Dims 2. Drag the dim R.13 control handle where the cursor points, dynamically change the cut narrower until the feature fails and becomes red, LMB in the graphics window to exit Pro/ENGINEER Wildfire Hands On Workshop Page 11 PTC/USER 2009 There is no resolve mode in Pro/ENGINEER Wildfire 5.0. You are given a warning and options to fix the failing feature(s). 3. Click OK to accept the result and we will fix the fails later on, review the failed features highlighted in the Model Tree 4. Select BOSS_1 feature in the Model Tree, RMB Edit Definition, click Placement in the dashboard, Edit…, drag and redefine the sketch until no intersected entities Dynamic Edit can be used again for this step 5. Select Done , confirm, review the resolved features Pro/ENGINEER Wildfire Hands On Workshop Page 12 PTC/USER 2009 User Defined Feature (UDF) 1B
You can place user‐defined feature (UDFs) using the new on‐surface coordinate system as a reference. You can preview the UDF geometry as it is being placed on the model, and also can see an immediate display of changes in variable dimensions and even specify additional rotations about the placement coordinate system 1. Toggle on Csys Display , Insert, User‐Defined Feature…, browse to INTERACTIVE‐MODELING folder and select boss_udf.gph, Open 2. Check View source model option, resize the BOSS_UDF_GP window, OK, pick the boss surface to specify the placement reference, toggle off Annotation display 3. Drag the two green placement handles to specify the location references 4. Drag the location handle and move, review the immediate udpates Pro/ENGINEER Wildfire Hands On Workshop Page 13 PTC/USER 2009 5. Select Variables tab, change the rib_instance from 3 to 6, Enter, preview the changes of UDF boss in the graphics window 6. Select Options, Adjustments tabs to review options, select Display , toggle off Csys Model Properties 12B
Model properties, such as materials, units, and accuracy, are located on a common Model Properties dialog box. This new dialog box also contains information on relations and parameters used in the model. 1. File, Properties, review all options of Model Properties 2. Select Change next to Material, RMB on the steel.mtl in the left column, Assign, OK, Close the Model Properties window Pro/ENGINEER Wildfire Hands On Workshop Page 14 PTC/USER 2009 3. Window, Close 4. File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 15 PTC/USER 2009 Molded Part Design Efficiency 1B
This tutorial will show some the new features and enhancements to assist in the design of cast and molded parts including geometry patterns, the new trajectory rib feature and enhancements to draft check analysis. Pattern Enhancements 13B
1. File, Open , PART‐MOLDED folder, gearbox.prt, Open 2. Select Hole 1 in the Model Tree, Pattern Pro/ENGINEER Wildfire Hands On Workshop Page 16 PTC/USER 2009 3. On dashboard, select Point from the drop‐down list for type, then the Use Points option. In the Model Tree select Datum Point 7012, MMB or
4. In Model Tree, select Chamfer 1, Pattern MMB or , ensure that the type is Reference, In the next step, it may be helpful to change the smart filter to Geometry. Refer to the Quick Reference card for guidance on this type of selection. 5. Select geometry using “surface and boundaries” technique. Pick top surface of the protrusion shown, then Shift+Pick the shell at base of the protrusion. 6. Edit, Geometry Pattern Geometry patterns make regeneration faster as compared to patterning the entire feature definition. Pro/ENGINEER Wildfire Hands On Workshop Page 17 PTC/USER 2009 7. Dashboard, Axis, select GEOMETRY_PATTERN_AXIS in Model Tree, enter 5 for number of pattern members, Angular Extent , enter 180, MMB or Trajectory Rib Tool 14B
1. In Model Tree, select sketch RIB1, pick Trajectory Rib 0.1 for the thickness, select Draft icon in the dashboard enter , Internal Rounds , External Rounds 2. Select Shape tab and enter 1 for the draft value, and 0.05 for internal rounds, and Two‐Tangent round, MMB or Pro/ENGINEER Wildfire Hands On Workshop Page 18 PTC/USER 2009 3. In Model Tree, select Trajectory Rib 1, Copy select sketch RIB2, 4. Paste , Paste , in the Model Tree, , in the Model Tree, select sketch RIB3, Pro/ENGINEER Wildfire Hands On Workshop Page 19 PTC/USER 2009 Draft Analysis 15B
1. Analysis, Geometry, Draft Surf:F27(SHELL) ,select GEARBOX.PRT in the Model Tree, Direction, Pro/ENGINEER Wildfire Hands On Workshop Page 20 PTC/USER 2009 2. At the bottom of the Color Scale select (options icon), Model Display, Verticals, review results,
3. Window, Close 4. File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 21 PTC/USER 2009 Sheet Metal Design & Welding 2B
This tutorial will show how to use some of the new functionality introduced for sheet metal part design and use the new Welding user interface to connect a welded subassembly. Sheet Metal 16B
This portion of the tutorial will show the user how to pattern a flat wall, mirror selections, and apply a reinforcement form to complete a sheet metal part. Use the Search box in the upper‐right corner of the File Open dialog box to dynamically filter the list. This makes it much easier to find a model from a large directory. 1. File, Open , FRC‐TEAM1690 folder, frc‐team1690‐robot.asm, Open 2. LMB pick plate_electronics.prt from Model Tree or graphics window, RMB Open Pro/ENGINEER Wildfire Hands On Workshop Page 22 PTC/USER 2009 3. LMB pick the Flat 8 feature as shown 4. Edit, Pattern 5. LMB pick attachment Edge:F20(Flat_7) as the direction reference 6. Flip the pattern direction 7. change the number of pattern members to 4 8. Set the member spacing to 70.6 Pro/ENGINEER Wildfire Hands On Workshop Page 23 PTC/USER 2009 9. Select from the dashboard or MMB 10.CTRL‐LMB pick Group MIRROR and Pattern 1 of Flat 8 from the Model Tree 11.Edit, Mirror 12.LMB pick datum plane MIRROR_REF from the Model Tree as the Mirror Plane Reference 13.Select from the dashboard or MMB Pro/ENGINEER Wildfire Hands On Workshop Page 24 PTC/USER 2009 14.Insert, Shape, Punch Form Tool 15.Open , FRC‐TEAM1690 folder, reinforcement_form.prt and place on Surf:F12(Wall Surface) 16.Drag the left most green drag handle to Edge:F43(Flat_7__2) – the top rear edge of the part 17.Drag the remaining green drag handle to Edge:F12(WALL SURFACE) Pro/ENGINEER Wildfire Hands On Workshop Page 25 PTC/USER 2009 18.Select the placement tab check the Add rotation about first axis and enter 180 degrees 19.Enter 200 for the offset value from the first reference and 125 for the second reference Pro/ENGINEER Wildfire Hands On Workshop Page 26 PTC/USER 2009 20.Ensure the yellow direction arrow is facing down or LMB the arrow 21.Select from the dashboard or MMB 22.LMB pick the WALL_EDIT feature from the Model Tree Pro/ENGINEER Wildfire Hands On Workshop Page 27 PTC/USER 2009 23.RMB Edit Definition 24.Move each of the side drag handles from the current value of 80 to 75 or type ‐75 25.Select the Relief tab from the dashboard 26.Check the Define each side separately box 27.Set the relief for side one as Obround 28.Set the relief for side two as Rectangular 29.Select from the dashboard or MMB Pro/ENGINEER Wildfire Hands On Workshop Page 28 PTC/USER 2009 30.Window, Close 31.Window, FRC‐TEAM1690‐Robot.asm Weld 17B
This portion of the tutorial will show the user how to leverage the new user interface to place multiple sets of fillet welds, apply material properties, combine annotations, and easily change the weld definition. 1. Expand CHASSI.ASM from the Model Tree, LMB pick LOWER_FRAME_WELD.ASM, RMB Open Pro/ENGINEER Wildfire Hands On Workshop Page 29 PTC/USER 2009 2. Application, Welding 3. Insert, Weld, Fillet Weld or select 4. LMB pick Surf:F5(EXTRUDE_1):FRAME_SIDE 5.
6.
7.
8.
RMB Side 2 LMB pick Surf:F5(EXTRUDE_1):BEAM_CROSS CTRL‐LMB pick Surf:F5(EXTRUDE_1):BEAM_CROSS – the opposite side CTRL‐LMB pick Surf:F5(EXTRUDE_1):FRAME_BACK Pro/ENGINEER Wildfire Hands On Workshop Page 30 PTC/USER 2009 9. Change the Weld Leg Length D to 12 10.RMB New Set 11.LMB pick Surf:F5(EXTRUDE_1):BEAM_CROSS 12.RMB Side 1 13.LMB pick Surf:F5(EXTRUDE_1):BEAM_CROSS 14.CTRL‐LMB pick Surf:F5(EXTRUDE_1):BEAM_CROSS – the opposite side 15.CTRL‐LMB pick Surf:F5(EXTRUDE_1):FRAME_BACK Pro/ENGINEER Wildfire Hands On Workshop Page 31 PTC/USER 2009 16.Select the Options tab and change the Weld Geometry Type to Light 17.Change the Weld Geometry Type back to Surface 18.Select Define for Weld Material 19.Select Define for Material and select AL6061, , Ok 20.Select Open and select FRC‐TEAM 1690 folder , frame.spwm, OK Pro/ENGINEER Wildfire Hands On Workshop Page 32 PTC/USER 2009 21.Select from the dashboard or MMB 22.Toggle on Annotation Display 23.LMB pick F9(1:Fillet Weld) Pro/ENGINEER Wildfire Hands On Workshop Page 33 PTC/USER 2009 24.CTRL‐LMB pick F10(2:Fillet Weld) 25.Edit, Weld, Combine or RMB Combine to consolidate both welds to the same annotation 26.Ensure Both Sides is selected 27.Select from the dashboard or MMB 28.Change the selection filter from Smart to Annotation Pro/ENGINEER Wildfire Hands On Workshop Page 34 PTC/USER 2009 29.LMB pick the weld value of 12 in the annotation 30.RMB Value enter 8 31.Select or MMB 32.Edit, Regenerate 33.Window, Close Pro/ENGINEER Wildfire Hands On Workshop Page 35 PTC/USER 2009 Flexible Assembly 3B
This tutorial will show how to create simplified representations on the fly, restructure components, copy‐n‐paste components to multiple locations and use the new explode animation. Simplified Representation On­the­Fly 18B
8. File, Open Define… , FRC‐TEAM 1690 folder, frc_team1690‐robot.asm, Open Rep…, 9. In the dialog box type frame for the simplified representation name, The dialog box and columns can be resized to simplify identification of desired objects. When selecting for RMB actions, pick the object name, NOT the checkbox. Selecting the checkbox will activate the default rule. 10. Expand the CHASSI.ASM, LMB LOWER_FRAME_WELD.ASM + Shift + first occurrence of MOTOR_SPROCKET.ASM, RMB Representation, Master Pro/ENGINEER Wildfire Hands On Workshop Page 36 PTC/USER 2009 11.At the upper‐right of the dialog box, try view options ‐ View, Show Active, Show Inactive, Show All 12.Select CIM_GEAR_ASM.ASM, RMB Representation, Master, OK Pro/ENGINEER Wildfire Hands On Workshop Page 37 PTC/USER 2009 13.In Model Tree, expand CHASSI.ASM and select LOWER_FRAME_WELD.ASM, Shift + MOTOR_SPROCKET.ASM , RMB Move to New Subassembly Pro/ENGINEER Wildfire Hands On Workshop Page 38 PTC/USER 2009 14.Type Frame_ASM for the name, OK 15.Copy From Existing, Browse, template.asm, OK, RMB Default Constraint, Pro/ENGINEER Wildfire Hands On Workshop Page 39 PTC/USER 2009 16.In the Model Tree, select and drag CIM_GEAR_ASM.ASM into newly created subassembly FRAME_ASM.ASM 17.FRAME_ASM.ASM, RMB Open, Master Rep, OK When restructuring, you must still be cognizant and careful about implications of parent/child and external references. Assembly Enhancements 19B
1. Assemble , FRC‐TEAM1690 folder, trailer_hitch.asm, Open, select In Window and Separate Window Pro/ENGINEER Wildfire Hands On Workshop Page 40 PTC/USER 2009 2. Model Tree(2) switch to Layer Tree 3. In Model Tree(2), ASSEMBLY_DATUMS, select F7(HITCH_PLANE) 4. In the FRAME_ASM.ASM layer, expand HITCH_ASM_DATUMS, expand FRAME_BACK.PRT, F19(HITCH_PLANE) Pro/ENGINEER Wildfire Hands On Workshop Page 41 PTC/USER 2009 5. In the TRAILER_HITCH.ASM layer, select F8(HITCH_ASM_AXIS_LEFT) 6. In the FRAME_ASM.ASM, select F20(HITCH_AXIS_LEFT), 7. Select to return to the Model Tree Copy and Paste with RMB to Multiple Locations 20B
1. Select 1_4_20BHCS_BOLT_NABA.PRT, Edit, Copy , Edit, Paste 2. Select BRIDGE_WHEEL_LEFT_OUT:Surf:F7(HOLE_1) for the insert surface 3. Select BRIDGE_WHEEL_LEFT_OUT:Surf:F5(EXTRUDE_1) for the mate surface Pro/ENGINEER Wildfire Hands On Workshop Page 42 PTC/USER 2009 4. RMB, New Location, on the other side of the frame, select BRIDGE_WHEEL_RIGHT_OUT:Surf:F7(HOLE_1), BRIDGE_WHEEL_RIGHT_OUT:Surf:F5(EXTRUDE_1), Explode Animation and Edit Position 21B
1. Select MOTOR_SPROCKET.ASM in the Model Tree, RMB Open 2. View Manager Properties , Explode Tab, Double‐click Default Explode, New, Enter, Pro/ENGINEER Wildfire Hands On Workshop Page 43 PTC/USER 2009 3. Edit Position , Translate , CRTL+ select the 3 SPACER_DENSO.PRT, grab and hold X‐axis, move up as shown below U
U
4. Rotate , select DENSO_PLATE.PRT, Edge:F5(EXTRUDE_1), grab and hold drag handle and move as shown below Pro/ENGINEER Wildfire Hands On Workshop Page 44 PTC/USER 2009 5. View Plane , select DENSO_WINDOW_MOTOR_2.PRT, grab and hold drag handle and move as shown below, 6. List, Edit, Save, OK, Double‐click Default Explode, Double‐click Exp0001 7. RMB, Uncheck Explode 8. Select Close from dialog box 9. Window, Close 10.File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 45 PTC/USER 2009 Simulation 4B
This tutorial will show how to set up one of the new mechanism connections for enhanced machine simulation, then setup, run, and analyze the results of a structural analysis of a model using Mechanica. Mechanism Belt Connection 2B
This portion of the tutorial will show the user how to set up a belt connection within mechanism mode. 1. File, Open , FRC‐TEAM1690 folder, frc‐team1690‐robot.asm, Open 2. View, View Manager or select Pro/ENGINEER Wildfire Hands On Workshop , double click Belts simplified rep, Close Page 46 PTC/USER 2009 3. Application, Mechanism 4. Insert, Belts or select 5. LMB pick Surf:F2(IMPORT_FEATURE):SPROCKET__CHAIN, Ctrl+LMB pick Surf:F5(REVOLVE_1):MIDDLE_SPROCKET, Ctrl+LMB pick Surf:F5(REVOLVE_1):MIDDLE_SPROCKET 6. Click and drag the white drag handle to untwist the third pulley Pro/ENGINEER Wildfire Hands On Workshop Page 47 PTC/USER 2009 7. Select from the dashboard or MMB 8. View, Orientation, Drag Components or select click and move any of the three pulleys (Observe the other pulleys moving through the belt connection) 9. MMB three times to close the drag window 10.Window, Close 11.File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 48 PTC/USER 2009 Mechanica Analysis 23B
This portion of the tutorial will show the user how to reuse a weld feature, automatically generate mid surface shells, work with heterogeneous units, and view the results after running the analysis. 1. File, Open , FRC‐TEAM1690 folder, search with keywords naba_left, naba_left.asm, Open the generic 2. Pick ANALYSIS.ASM from the Model Tree, RMB Open 3. Application, Mechanica 4. Insert, Connection, Weld or Select 5. Select Weld Feature from the Type drop down menu Pro/ENGINEER Wildfire Hands On Workshop Page 49 PTC/USER 2009 6. Select F5(1:Fillet Weld, Rod:WELDMAT001) 7. Select OK 8. Insert, Midsurface, Auto Detect Shell Pairs Pro/ENGINEER Wildfire Hands On Workshop Page 50 PTC/USER 2009 9. Select ANALYSIS.ASM from the Model Tree and enter 12 for the Characteristic Thickness. 10.Select Start 11.AutoGEM, Review Geometry 12.Select Apply from the simulation geometry window 13.Select Close 14. Insert, Pin Constraint or select the arrow next to 15.LMB pick Surf:F6(Extrude_1):MAZLEG_SIDE Pro/ENGINEER Wildfire Hands On Workshop and select Page 51 PTC/USER 2009 16.Select Fixed for both Angular Constraint
17.Select OK 18.Insert, Surface Region or select and Axial Constraint
LMB pick part MAZLEG_SIDE.PRT 19.RMB Define Internal Sketch 20.LMB pick Surf:F6(Extrude_1):MAZLEG_SIDE Pro/ENGINEER Wildfire Hands On Workshop Page 52 PTC/USER 2009 21.Click Sketch 22.Sketch, Circle, Center and Axis Ellipse or select the arrow next to and select 23.Click with the LMB once to define the center and a second time to define the radius and a third time to finish (This ellipse can be approximate) 24. 25.Select Surf:F6(EXTRUDE_1):MAZLEG_SIDE as the placement surface Pro/ENGINEER Wildfire Hands On Workshop Page 53 PTC/USER 2009 26.Select from the dashboard or MMB 27.Insert, Force/Moment Load or select , select the previously created surface region as the reference 28.Add a force of 800 N in the X direction and add a moment of 600 in lbf in the Z direction 29.Change the units for force to KN 30.Select the 800 Value Pro/ENGINEER Wildfire Hands On Workshop Page 54 PTC/USER 2009 31.RMB Convert to Unit, lbf Pro/ENGINEER Wildfire Hands On Workshop Page 55 PTC/USER 2009 32.Select Preview 33.Select Ok 34.Analysis, Mechanica Analysis/Studies 35.File, New Static 36.Select OK Pro/ENGINEER Wildfire Hands On Workshop Page 56 PTC/USER 2009 37.Select Run Select No for interactive Diagnostics 38.Once analysis has reached the complete status, Analysis, Results or select 39.Select Fringe for display type, and select Stress for the quantity 40.Select OK and Show 41.Insert, Results Window, select Analysis1, OK 42. Select Vector for display type and set the quantity to Displacement 43.Select Ok and Show Pro/ENGINEER Wildfire Hands On Workshop Page 57 PTC/USER 2009 44.Window, Swap 45.Window, Close 46.File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 58 PTC/USER 2009 Drawing Workflow and Efficiency 5B
Pro/ENGINEER includes many new enhancements for creating and working with 2D drawings and improved interaction with 3D drawings. •
•
•
•
•
•
Improved creation and display of 2D & 3D annotations Improved display and management of annotations Easy creation and manipulation of geometry annotation Enhanced user experience and productivity Enhanced capabilities and support for 2D documentation Enhanced capabilities and support for 2D print and plotting Task­Based User Interface 24B
1. File, Open
, FTC‐ROBOT folder, search with keywords ftc, ftc‐robot.drw, Open Now drawing commands are re‐organized into a ribbon‐style user interface. The new user interface (UI) is designed to display only those drawing commands which are appropriate for the current task. 2. Select Table tab, Annotate, Sketch, Review, Publish and review the ribbon‐style top level UI 3. Select Layout tab, hold Alt and select the balloon in the drawing Pro/ENGINEER Wildfire Hands On Workshop Page 59 PTC/USER 2009 Publish The print preview display considers the current printer configuration to determine line weights and styles, priorities and colors. The preview displays white background paper space and users have full control leveraging pan and zoom to assess preview display in the graphics window 1. Select Publish tab, click Preview , zoom in the plot preview to review what the printed output looks like before sending it to the printer, Close Preview 2. Check PDF option, Settings , check Solid Hidden Lines in Line style column, OK, Preview, in PDF reader, toggle on Pages , select page 1, page 2 and review the pages, open Bookmarks , select new_view_1, new_view_3 in the bookmarks list, review the details, Close Adobe Acrobat Reader 3. Window, Close Model Annotation Tool 25B
Selectable drawing objects appear in a tree hierarchy, the content of the Drawing Tree varies depending on the tab selected, simplifying the tree structure. Objects are highlighted in the graphics window when you select them from the graphics window or the Drawing Tree 1. File, Open , DETAILING folder, fan_cover.drw, Open 2. Annotate, expand Annotations of TOP_VIEW in the Drawing Tree, select Model:d642, Model:d643, review the corresponding highlighted dimensions in the graphics window Pro/ENGINEER Wildfire Hands On Workshop Page 60 PTC/USER 2009 The new options gives user more control over the tolerance display and allow the user to select the dimensions true significant digits 3. RMB the Model:d649 dim in the Drawing Tree, Properties, change Decimal Places to 2, Enter to preview update, check the Rounded Dimension Value option, change Tolerance mode from Nominal to Plus‐Minus, OK, review the updates of the dimension New Show Model Annotations tool for dimensions, GTOL’s, notes, surface finish, symbols and datums can select by view or by feature within a view, and annotations available to be shown will preview, you just select them to show in the drawing Pro/ENGINEER Wildfire Hands On Workshop Page 61 PTC/USER 2009 4. Select Show Model Annotations icon on the ribbon, select the thickness in the Front Cross Section view as shown, preview dimensions, check d891 which stands for the thickness of the part, OK, select the .10THICK and move it to empty area 5. Select Show Model Annotations icon, select the BOT_EXT_CUT feature from the Model Tree, preview the dimensions showing up, Cancel 6. Select Show Model Annotations icon, pick model edge as shown below, see the difference in what dimensions appear, Cancel Pro/ENGINEER Wildfire Hands On Workshop Page 62 PTC/USER 2009 7. Select Geometry Tolerance
Feature from the Insert ribbon, select
, Reference Type: 8. Select the hole feature in the Top view 9. Set Placement Type to As Free Note Pro/ENGINEER Wildfire Hands On Workshop Page 63 PTC/USER 2009 10. LMB place the Geometry Tolerance Annotation below the hole note, OK Sheet Tab & Hole Table 26B
Drawing sheets appear as tabs across the bottom of the graphics window. The new Hole Table automatically includes extrude and revolve cuts in the table 1. Click the hole_table tab at the bottom of the drawing area, RMB on hole_table tab to show all shortcut options 2. Review the Hole table Pro/ENGINEER Wildfire Hands On Workshop Page 64 PTC/USER 2009 3. Highlight STANDARD_HOLE_PATTERN, EXTRUDE_HOLE, REVOLVE_HOLE‐1 and REVOLVE_HOLE‐2 features in the Model Tree, and in the drawing review the corresponding highlighted holes created in different methods 4. Window, Close Combined View Tab 27B
1. File, Open , DETAILING folder, bracket.prt, Open, toggle on Annotation Display if necessary You can easily navigate between the combined states of a model without opening the View Manager. Combined or All states appear as tabs, each with a thumbnail preview, in the graphics window 2. Select View Manager , All, check Display combined views, Close 3. Move cursor to combined view tabs at the bottom of the graphics window, show the thumbnail preview of combined view Pro/ENGINEER Wildfire Hands On Workshop Page 65 PTC/USER 2009 4. Click Mbd‐00‐Front tab, Mbd‐01‐Bottom, Mbd‐02‐Left, Mbd‐03‐Right, Show_All combined view tabs to review the model information from different angles, RMB on Show_All view tab, preview all shortcut options, select Redefine, change Orientation to 3D‐Detail, Layer Visibility 28B
You can create layer visibility states from the View Manager, and you can toggle the display of all layer‐assigned content. 1. Select , select View Manager , Layers, double‐click Mbd‐00‐Front, Mbd‐01‐
Bottom, Mbd‐02‐Left, Mbd‐03‐Right, Show_All, and review the corresponding layers visibility changes in the Layer Tree 2. RMB on ANNOT_ALL_TBLOCK in the Layer Tree on the Navigator, Hide, Repaint 3. Create New Layer on View Manager, No to Modified State Save, input the name No_Titleblock, double click Show_All, then double click No_Titleblock, review the layer state changes Pro/ENGINEER Wildfire Hands On Workshop Page 66 PTC/USER 2009 Move Annotation to Plane 29B
1. Double click the Show_All layer state, change the global filter to Annotation, select the hole annotation at top right corner, RMB in the graphics window, Move to Plane 2. Select the top surface as showing, review the Z orientation update of the 3D annotation Pro/ENGINEER Wildfire Hands On Workshop Page 67 PTC/USER 2009 Target Datum Annotation 30B
1. Named View List , Datum_Target, Insert, Cosmetic, Designated Area, select the sketch circle, MMB to confirm 3. Select Datum Target Annotation , OK to Add Annotation, Name: D, check Geometry reference option, select the top surface of the part Pro/ENGINEER Wildfire Hands On Workshop Page 68 PTC/USER 2009 4. Select a point on the top surface to place the annotation 5. OK on Set Datum Tag dialog box, RMB on the graphics window, Flip 6. Select Add from the annotation definition dialog box, select Browse… to open defined symbol, double click single, select circareatgt.sym, Open, change Next leader type to On Surface, select the designated area, move the mouse away and MMB to confirm placement Pro/ENGINEER Wildfire Hands On Workshop Page 69 PTC/USER 2009 7. Select Variable Text tab, Pick Dimension, select the radii 25 of the designated area, OK, OK to close Datum Target Annotation Feature dialog box 8. Select the datum target annotation, RMB Select Reference 9. Window, Close 10.File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 70 PTC/USER 2009 Pro/ENGINEER Manikin 6B
Objective 31B
This tutorial will show how to access Pro/ENGINEER Manikin, place a manikin into a design assembly, position and define postures and run some simple human factors analysis. Insert Manikin 32B
The PTC Manikin library must be installed correctly to access the manikin specified below. This can be downloaded or ordered from the Technical Support Software Downloads page under Pro/ENGINEER. The ptc_maniking.asm included with this exercise has limitations. 1. File, Open , MANIKIN folder, working_zone.asm, Open 2. Select Insert, Manikin to assemble a Manikin 3. Select M_IT_50.ASM from the population database and select Open. The Manikin is added to your assembly; now move it near the workstation.
4. Saved View View 2 5. The Place Manikin dialog box defaults to a standing position and requires two references… •
First, the right foot needs to be placed. Select the location by clicking on the floor as indicated by the yellow circle below. Pro/ENGINEER Wildfire Hands On Workshop Page 71 PTC/USER 2009 Next, you will select a plane that the Manikin will face. Select the surface indicated below. •
6. Select OK in the Place Manikin dialog box 7. Saved View View 3 The left foot will interfere after initial placement; we will fix this in a moment. This interference allows the manikin to get close enough to the work cell equipment. Pro/ENGINEER Wildfire Hands On Workshop Page 72 PTC/USER 2009 Posture and Reach 3B
Now you need to apply an appropriate posture to the Manikin. 1. Select Manikin > Apply Posture 2. In the Macro folder, select the CARRYING_BOX.MPD posture and Apply 3. Toggle the Reach Envelope on; select Manikin, Reach Envelope 4. Saved View View 4 5. Toggle the reach envelopes off; select Manikin, Reach Envelope 6. Saved View View 5 Pro/ENGINEER Wildfire Hands On Workshop Page 73 PTC/USER 2009 In addition to applying postures to the Manikin, you can manipulate the Manikin into a desired position. You will use 2D drag to move the right hand and arm. 1. Select Manikin, Manipulate 2. In the Manikin Motion dialog box, select 2D Body Drag. Click the middle of the right hand once and slowly move the mouse upward. 3. When the hand is in place click once, then select Close in the Manikin Motion dialog box. Pro/ENGINEER Wildfire Hands On Workshop Page 74 PTC/USER 2009 Although this method is good for free‐hand manipulation of your manikin, in this example the Reach tool will provide placement with greater precision. 4. Toggle Point Display on 5. Select Manikin, Reach 6. The Reach dialog box requires three references… • First, select the middle of the right hand • Next, select the point shown in the image below • Finally, select the end plane of the component that the Manikin is reaching for 7. Select Close in the Manikin Motion dialog box. Vision 34B
Now you will have the manikin look at a point in the assembly. 1. Saved View View 6 2. Select Manikin, Look At 3. The Look At dialog box requires two references… •
Since your Manikin is the only one in this session it is automatically selected Pro/ENGINEER Wildfire Hands On Workshop Page 75 PTC/USER 2009 •
Select the point circled in the image below 4. Select Close in the Manikin Motion dialog box 5. Toggle Display Points points off 6. Toggle the Vision Cones on; select Manikin, Vision Cones Vision cones for manikins are available at any time. They represent… •
•
•
•
7. Saved View Peripheral vision (global vision) Binocular (the visual field that can be seen by both eyes) Optimal (operational zones) Accurate (reading zone) View 4 Pro/ENGINEER Wildfire Hands On Workshop Page 76 PTC/USER 2009 8. Toggle the vision cones off; Manikin, Vision Cones 9. Saved View View 6 You can also view your assembly from the Manikin’s viewpoint. 10.Toggle the Vision Window on; select Manikin, Vision Window 11.Toggle the vision window off; select Manikin, Vision Window 12.Saved View View 7 13.Window, Close 14.File, Erase, Not Displayed Pro/ENGINEER Wildfire Hands On Workshop Page 77 PTC/USER 2009 Tolerance Analysis 7B
The objective of this analysis is to determine whether it is possible to assemble the PCB into the assembly. The current assembly process specifies that the bottom screws are to be installed and tightened first. Next, the plug is snapped into holes in the PCB Then the PCB assembly is placed into the assembly and the top screws inserted and tightened. There should be a minimal gap between the plug and the pan, but an interference condition could prevent the ability to insert the screws into the PCB Open Model and Set the View 35B
1. File, Open , TOLERANCE‐ANALYSIS folder, circuit‐card.asm, Open 2. Saved View ISO Pro/ENGINEER Wildfire Hands On Workshop Page 78 PTC/USER 2009 Initiate Tolerance Analysis Measurement 36B
1. Analysis, Tolerance Study The Tolerance Analysis Manager dialog box lists all of the existing tolerance analysis measurements in this model. You can add, edit, and delete tolerance analysis measurements from this dialog box. 2. Select the Add icon in the Tolerance Analysis Manager dialog box. 3. Now you will need to select two entities… • First, select the inside vertical surface of the pan Surf:F1(FIRST FEATURE):PAN (see the figure below). • Select the hidden vertical surface of the plug Surf:F4(PROTUSION):REC‐
3PIN (see the figure below). Use Query Select or Pick from List. Pro/ENGINEER Wildfire Hands On Workshop Page 79 PTC/USER 2009 Restarting a Measurement If you make a mistake and you want to start over, you can right‐click in the Measurement Table view and select Restart Measure from the shortcut menu Select Dimensions 37B
Redisplaying the Candidate Dimensions During the dimension selection process, the candidate dimensions for the active part are automatically displayed. You can change active parts by clicking a new part. If you don’t see the expected dimensions, the wrong part may be the active part. In that case, click the part from which you need to select dimensions 1. Now you need to select four dimensions… A. First, select 146 +/‐ 0.1, the pan length B. Next, select 119.2, the basic locating dimension for the screw hole C. Then, select 0.2, the position tolerance for the hole pattern D. Last, select 3.5 +.1/‐0, the hole diameter Pro/ENGINEER Wildfire Hands On Workshop Page 80 PTC/USER 2009 If you accidentally select the wrong dimension, you don’t have to start over. During dimension selection, select Cancel in the Select menu. You have a number of cancel options (shown in the Pro/ENGINEER prompt area). Option 1 will undo the last selection and resume the selection process. 2. In the Select Option dialog box, select Selected Cylinder is a Hole, then hit OK 3. Saved View UNDERNEATH 4. Click the bottom screw; then select 3.4 +0/‐.1, the major diameter of the threads 5. In the Select Option dialog box, select Selected Cylinder is a Pin, then OK Pro/ENGINEER Wildfire Hands On Workshop Page 81 PTC/USER 2009 Explore the Tolerance Analysis Extension 38B
1. RMB Fit to Width in the Dimension Loop Diagram 2. Click the various objects in the Name column of Measurement Table. Then click the various objects in the Dimension Loop Diagram. Notice the cross‐highlighting between the two Resume the Dimension Selection Process 39B
1. Saved View ISO 2. Choose the Select Model or Dimension icon box Pro/ENGINEER Wildfire Hands On Workshop in the Tolerance Analysis dialog Page 82 PTC/USER 2009 3. Click the PCB to display the candidate dimensions for that part; then select 3.5 +0.1/‐0, the hole diameter 4. In the Select Option dialog box, select Selected Cylinder is a Hole, then OK 5. Now you need to select two dimensions… • First, select 25 +/‐ 0.2, the screw hole location • Next, select 7.1 +/‐ 0.2, the plug hole location Pro/ENGINEER Wildfire Hands On Workshop Page 83 PTC/USER 2009 6. Click the Plug to display the candidate dimensions for that part 7. Now you need to select two dimensions… • First, select 8.8, the basic locating dimension for the snap fit • Next, select 0.2, the position tolerance for the snap fit Pro/ENGINEER Wildfire Hands On Workshop Page 84 PTC/USER 2009 Specify Measurement Limits 40B
1. Click Cancel in Select dialog box to pause the selection process 2. Rename the analysis to Fit_Clearance by typing in the text field at the bottom of the Tolerance Analysis dialog box 3. Under the Goal heading in the Tolerance Analysis dialog box select Limit. Enter an upper value of 1.0 and a lower value of 0.0 Modify the Interface Properties 41B
Whenever the last feature of one part and the first feature on the following part are a pin and hole, the application creates a pin/hole interface. By default, the pin is assumed to be centered in the hole. However, the clearance between the pin and the hole is often an important consideration in a tolerance analysis, so you have a number of options for how to represent that interface: centered right (tangent), left (tangent), or floating First, consider the screw in the pan. The screw is inserted into the hole and tightened down in the standoff, so the screw is randomly located within the clearance of the hole. This situation is best represented with the float option 1. Select Float from the Attachment column for Pan/Screw below Pan Pro/ENGINEER Wildfire Hands On Workshop Page 85 PTC/USER 2009 • With the Float command, the application introduces a variable that represents the random variation of the location of the pin in the hole. Notice that a double‐arrow in the Dimension Loop Diagram indicates that this interface is floating Now, consider the screw in the PCB. In this case, the screws are inserted into the holes and loosely threaded into the standoffs. Before the screws are tightened, the PCB can slide left or right until a hole comes in contact with a screw. Since we are trying to predict the probability of fit for this case, we should set the properties of this pin/hole interface to maximize the clearance between the plug and the pan. 2. Select Left from the Attachment column for Screw/PCB below Screw Pro/ENGINEER Wildfire Hands On Workshop Page 86 PTC/USER 2009 Notice that the vertical line joining the pin and hole in the dimension loop diagram is at the left tangent location. The PCB is pushed away from the interface that we are measuring (indicated by the dashed vertical lines) so that the PCB hole is touching the pin on the left side. Notice also that the nominal value of the measurement changes when you change the interface from centered to left tangent. Examine the Results 42B
1. Click the Results tab at the bottom of Tolerance Analysis dialog box to view the analysis results Pro/ENGINEER Wildfire Hands On Workshop Page 87 PTC/USER 2009 The Analysis Results view has two display regions. The left region shows a variation plot for the measurement. The variation plot shows the statistical variation plot and the worst‐case range for the measurement based on the specified tolerances for the dimensions in the dimension loop. The right region of the Analysis Results view is a tabbed display of contribution and sensitivity plots. For example, the Statistical Contribution plot shows the percent contribution of each dimension to the variance of the measurement. The results indicate that two of the dimensions from the PCB are the largest contributors (d266 and d43). Pro/ENGINEER Wildfire Hands On Workshop Page 88 PTC/USER 2009 2. Click the tolerance field for the d266 dimension in the PCB. Change the value to 0.1 and press the Enter key. Then Close the input dialog box. Repeat these steps for the d43 dimension in the PCB Notice that when you make a change to the tolerance, the results automatically update. You can continue to change the tolerance values until you get the desired measurement variation. Note that the actual Pro/ENGINEER dimension properties are not modified until you close the Tolerance Analysis Extension Powered by CETOL Technology interface and accept the changes. Pro/ENGINEER Wildfire Hands On Workshop Page 89 PTC/USER 2009 3. RMB Create Report in the Measurement Table, and Close The report is displayed in the Pro/ENGINEER browser. Click in the Tolerance Analysis Extension Powered by CETOL Technology window to save the tolerance analysis measurement feature, update the modified Pro/ENGINEER tolerances and close the application 4. Window, Close 5. File, Erase, Not Displayed Congratulations! You have completed the tutorials in this Hands On Workshop! Thank you for your participation and we look forward to having you attend another Hands On Workshop in the future. Pro/ENGINEER Wildfire Hands On Workshop Page 90 
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising