VRF lite for Dell Networking N-Series

VRF lite for Dell Networking N-Series
VRF lite for Dell Networking N-Series
Dell Networking Solutions Engineering
February 2016
r
SION
DR
draft
A Dell EMC Deployment and Configuration Guide
Revisions
Date
Description
Author
February 2016
Added BGP VRF Lite Section – Version 1.1
Sambhu Kalaga, Victor Teeter
January 2015
Initial Release - Version 1.0
Victor Teeter
Copyright © 2015 - 2017 Dell Inc. or its subsidiaries. All Rights Reserved.
Except as stated below, no part of this document may be reproduced, distributed or transmitted in any form or by any
means, without express permission of Dell.
You may distribute this document within your company or organization only, without alteration of its contents.
THIS DOCUMENT IS PROVIDED “AS-IS,” AND WITHOUT ANY WARRANTY, EXPRESS OR IMPLIED. IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE SPECIFICALLY
DISCLAIMED. PRODUCT WARRANTIES APPLICABLE TO THE DELL PRODUCTS DESCRIBED IN THIS DOCUMENT
MAY BE FOUND AT: http://www.dell.com/learn/us/en/vn/terms-of-sale-commercial-and-public-sector-warranties
Performance of network reference architectures discussed in this document may vary with differing deployment
conditions, network loads, and the like. Third party products may be included in reference architectures for the
convenience of the reader. Inclusion of such third party products does not necessarily constitute Dell’s recommendation of
those products. Please consult your Dell representative for additional information.
Trademarks used in this text: Dell™, the Dell logo, Dell Boomi™, PowerEdge™, PowerVault™, PowerConnect™,
OpenManage™, EqualLogic™, Compellent™, KACE™, FlexAddress™, Force10™ and Vostro™ are trademarks of Dell
Inc. EMC VNX®, and EMC Unisphere® are registered trademarks of Dell. Other Dell trademarks may be used in this
document. Cisco Nexus®, Cisco MDS®, Cisco NX-0S®, and other Cisco Catalyst® are registered trademarks of Cisco
System Inc. Intel®, Pentium®, Xeon®, Core® and Celeron® are registered trademarks of Intel Corporation in the U.S.
and other countries. AMD® is a registered trademark and AMD Opteron™, AMD Phenom™ and AMD Sempron™ are
trademarks of Advanced Micro Devices, Inc. Microsoft®, Windows®, Windows Server®, Internet Explorer®, MS-DOS®,
Windows Vista® and Active Directory® are either trademarks or registered trademarks of Microsoft Corporation in the
United States and/or other countries. Red Hat® and Red Hat® Enterprise Linux® are registered trademarks of Red Hat,
Inc. in the United States and/or other countries. Novell® and SUSE® are registered trademarks of Novell Inc. in the
United States and other countries. Oracle® is a registered trademark of Oracle Corporation and/or its affiliates. VMware®,
Virtual SMP®, vMotion®, vCenter® and vSphere® are registered trademarks or trademarks of VMware, Inc. in the United
States or other countries. IBM® is a registered trademark of International Business Machines Corporation. Broadcom®
and NetXtreme® are registered trademarks of QLogic is a registered trademark of QLogic Corporation. Other trademarks
and trade names may be used in this document to refer to either the entities claiming the marks and/or names or their
products and are the property of their respective owners. Dell disclaims proprietary interest in the marks and names of
others.
2
VRF lite for Dell Networking N-Series | version 1.1
Contents
1
Introduction ...................................................................................................................................................................5
2
Simple VRF Example ...................................................................................................................................................8
3
BGP on VRF lite .........................................................................................................................................................14
4
OSPF on VRF lite .......................................................................................................................................................40
5
VRF VRRP Configuration ...........................................................................................................................................48
Configuring the VRF VRRP Master ............................................................................................................................49
Configuring the VRF VRRP Backup ...........................................................................................................................50
Configuring Connecting Switches ..............................................................................................................................51
Validating VRRP Failover ...........................................................................................................................................51
6
Route Leaking ............................................................................................................................................................53
7
Reserving Routes .......................................................................................................................................................56
8
Troubleshooting ..........................................................................................................................................................57
Intermittent ping responses ........................................................................................................................................57
Pinging issues immediately after pasting a configuration ..........................................................................................57
Branch A Connectivity Issues .....................................................................................................................................57
Branch B Connectivity Issues .....................................................................................................................................58
3
A
Additional Resources .................................................................................................................................................59
B
Versions......................................................................................................................................................................59
C
Glossary of Terms ......................................................................................................................................................60
VRF lite for Dell Networking N-Series | version 1.1
Executive Summary
Virtual Routing and Forwarding (VRF) allows a physical layer 3 switch or router to be partitioned into
multiple Virtual Routers (VRs). VRF isolates the control and data planes in each VR so that traffic
does not flow across VRs, thus allowing multiple routing tables to co-exist within one physical L3
switch/router at the same time. Route leaking VRF routes to and from the global routing table
(consisting of ports that are not members of any VRF) is also supported, which allows traffic to flow
outside of the VRF. Dell Networking N3xxx and N4xxx switches running firmware version 6.2 or later
can take advantage of these features.
VRF Lite is VRF deployment without MPLS. There are several benefits to implementing VRF lite. The
ability to configure multiple VRs in a single switch/router reduces physical equipment required,
creating a sizable cost advantage. VRs also allow more efficient updates by requiring upgrades to
only a single switch/router instead of several. VRs also enable customers to test configurations on the
same equipment used in a proven production environment, making new additions easier to
implement.
This document provides instructions for and examples of deploying VRF lite on Dell N-Series
switches.
4
VRF lite for Dell Networking N-Series | version 1.1
1
Introduction
Dell Networking provides customers with the most efficient use of current networking equipment at the lowest
cost, while still providing today’s great new technologies focused around the explosive data growth in the
industry. The various application demands have driven the need for increased bandwidth, lower latency and
converged infrastructure in today’s networks. Dell EMC’s portfolio covers all these key areas to provide the
best in service and customer experience.
Today’s businesses find it difficult to keep pace with the changing networking and Enterprise landscape. With
limited resources, they must support a variety of devices that provide key business functions, deliver IT
services that are reliable and flexible, and provide discernible cost savings.
VRTX
WAN
Remote/Branch
Office
Internet
Dell Campus
Networking
Dell Data Center
Networking
Campus
Storage
Network
Dell
Servers
Dell Network
Controllers
and Security
Remote
Data Centers
Public Cloud
Dell
Storage
Data Center
Networking architecture overview
This document is designed as a supplement to the Dell N-Series User Guide and provides easy step-by-step
instructions to help users set up and configure Dell N-Series switches to use the VRF lite features. VRF lite is
VRF without Multiprotocol Label Switching (MPLS) support. Each VRF instance is a separate routing table
within the same layer3 switch. Each of these routing table instances are isolated from each other in a layer 3
domain, similar to how different VLANs are isolated from each other in layer 2 domain. By creating multiple
VRF instances, the restrictions of multiple overlapping address spaces is no longer an issue.
Note: Each VRF domain (instance) is a separate routing table
5
VRF lite for Dell Networking N-Series | version 1.1
The VRF Lite examples in this document use Dell Networking N3xxx and N4xxx switches. Any N-Series
switch that supports Layer 3 routing and is running firmware version 6.3 or later accepts the commands in
this paper for configuring VRF lite. As of this writing, the following N-Series models offer VRF lite:
N3024
N3048
N4064
N3024P
N3048P
N4032F
N3024F
N4032
N4064F
Note: N-Series switches that do not support Layer 3 routing (e.g. N2xxx) do not support VRF lite
Figure 2 illustrates the primary network topology represented throughout this guide. There are two branch
offices in this example, each with two N3xxx switches that require routes to each other, but isolation from the
other branch. An N4xxx 10GbE switch is located at the Main Office and is configured to use VRF to create
two virtual routers.
Branch B
Branch A
7
9
11
13
15
17
19
21
25
23
27
29
31
33
35
37
39
41
43
45
1
LNK 47 ACT
2
4
6
8
10
12
14
16
18
20
22
26
24
28
30
32
34
36
38
40
42
44
46
1
3
5
7
9
11
13
15
17
19
21
1
LNK 23 ACT
2
Stack No.
LNK
48 COMBO P
2
Stack No.
ACT
LNK
1
SFP+
2
2
4
6
8
10
12
14
16
18
20
22
24 COMBO P
LNK
ACT
LNK
ACT
1
SFP+
ACT
2
Dell N3024F
Dell N3048P
Ports 1 and 2 are in
Virtual Router 1 (VR1)
Ports 15 and 16 are in
Virtual Router 2 (VR2)
VR1
VR2
1
3
5
7
9
11
13
15
17
19
21
LNK 23 ACT
2
4
6
8
10
12
14
16
18
20
22
24
LNK
ACT
10G SFP+ MODULE
Dell N4032F
Main Office
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK 23 ACT
LNK
LNK
ACT
Dell N3024F
1
SFP+
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK 23 ACT
2
Stack No.
24 COMBO P
2
Stack No.
ACT
2
LNK
24 COMBO P
1
SFP+
ACT
2
Dell N3024F
VRF lite Example Topology
The N4xxx switch uses two VRs to route traffic between the two switches in Branch A (using VR1), as
well as between the two switches in Branch B (using VR2). Separate routing tables ensure that the two
branches are only aware of their own routes.
Split a single, layer 3 switch into two or more layer 3 switches to form a multi-tenancy state. Multitenancy is the principle that allows a single instance of software to operate on a device that services
6
VRF lite for Dell Networking N-Series | version 1.1
multiple groups, with each group sharing the software and hardware device. In the case of a layer 3
switch running VRF lite, each group has its own ports and configuration on the switch (including
routing tables) allowing for isolation of data, private user management, and other reserved
functionality. All VRs on the switch, however, still share the same physical components and resources
within the switch including memory, firmware, power supply, etc. This contrasts with multi-instance
designs, which use separate software and hardware on behalf of each group or tenant.
Considerations









Global route leaking is allowed from and to VRF instances. Route leaking is not allowed
between VRF instances.
Any static or dynamic route can be leaked or distributed to the default router interfaces
through static route commands.
Since each VR has its own routing table, IP addresses can overlap among different VRF
instances. Therefore, it is important to consider IP addresses when leaking routes.
Each L3 interface can only belong to one unique VRF instance.
Physical routers do not exchange VRF information that has only local significance.
N4XXX switches accept a maximum of 52 VRFs, while N3XXX switches accept a maximum
of 12 VRFs.
All VRF instances share the physical switch’s resources (loopbacks, routing table, ARP table
entries, Mbufs), but switch administration can subdivide and reserve these resources for
particular VRF instances.
VRF lite is VRF without MPLS support.
Any VRF instance may use any individual port.
VRF lite provides support for Border Gateway protocol (BGP) when using firmware version 6.3 or later.
VRF lite provides support for other protocols such as Open Shortest Path First (OSPF), Virtual Router
Redundancy Protocol (VRRP), IP Helper/DHCP Relay, IP Source Guard/DHCP Snooping, Static
routing, Internet Control Message Protocol (ICMP), Route leaking, Ping, Traceroute and SNMPv2/v3
when using firmware version 6.2 or later.
7
VRF lite for Dell Networking N-Series | version 1.1
2
Simple VRF Example
In this example, two branch offices that route traffic through the Main Office are directly connected.
Each branch has two N3xxx switches that require routes to each other, but isolation from the other
“competing” branch. The Main Office houses an N4xxx 10GbE switch configured to use VRF to create
two virtual routers (VRs). Each VR isolates the traffic for its associated branch.
Each branch is unaware of the IP subnets and routing table of the other branch and can therefore
overlap IP addresses without impairing to either network.
Branch A
7
9
11
13
15
19
21
25
23
27
29
31
33
35
37
39
41
43
45
6
8
10
12
14
16
18
20
22
26
24
28
30
32
34
36
38
40
42
44
46
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
17
19
21
LNK
48 COMBO P
1
SFP+
2
VR1
VR2
Te1/0/2
VLAN 11
9
11
13
15
17
19
21
1
LNK 23 ACT
3
5
7
9
11
13
15
17
19
21
LNK 23 ACT
2
4
6
8
10
12
14
16
18
20
22
24
6
8
10
12
14
16
18
20
22
24 COMBO P
Dell N3024F
LNK
ACT
Dell N4032F
Main Office
ACT
10G SFP+ MODULE
Te1/0/16
1
SFP+
1
3
5
7
9
11
13
15
1
LNK 23 ACT
2
LNK
4
ACT
2
VLAN 21
Stack No.
2
ACT
SFP+
Te1/0/15
1
LNK
7
LNK
1
VLAN 20
Te1/0/1
5
24 COMBO P
Dell N3024F
VLAN 10
3
2
Stack No.
ACT
Dell N3048P
1
1
LNK 23 ACT
2
Stack No.
4
Te1/0/1
1
LNK 47 ACT
LNK
2
Branch B
Te1/0/1
17
2
Te1/0/1
2
Stack No.
ACT
LNK
2
4
6
8
10
12
14
16
Dell N3024F
18
20
22
24 COMBO P
LNK
ACT
1
SFP+
ACT
2
Te1/0/1
A Simple VRF Configuration
Enter the following CLI commands to configure an initial VRF scenario like the one shown in Figure 3. The
following tables also provide explanations of each CLI command:
Note: The first five configuration files attached in the left margin of this document may be used to
copy and paste directly into each switch’s CLI. The files pertaining to this example are titled “SimpleVRF”. Click the paperclip icon to open and close the attachment list.
8
VRF lite for Dell Networking N-Series | version 1.1
N4032F (Main Office)
Description of Commands
Configure VR1 (Branch A) VRT
configure
vlan 10-11
exit
interface Te1/0/1
switchport access vlan 10
interface Te1/0/2
switchport access vlan 11
exit
< assign each VLAN to an interface for
VR1
ip vrf brancha
ip routing
exit
< create VR1 (brancha) and enable routing
interface vlan 10
ip address 192.168.10.1 /24
ip vrf forwarding brancha
< assign an IP address to the first VR1
interface
< put the VLAN interface into VR1
(brancha)
< assign an IP address to the 2nd VR1
interface
< put the VLAN interface into VR1
(brancha)
interface vlan 11
ip address 192.168.11.1 /24
ip vrf forwarding brancha
exit
exit
configure
vlan 20-21
exit
interface Te1/0/15
switchport access vlan 20
interface Te1/0/16
switchport access vlan 21
exit
ip vrf branchb
ip routing
exit
Configure VR2 (Branch B) VR
< create two VLANs for VR2
< assign each VLAN to an interface on
VR2
< create VR2 (branchb) and enable routing
interface vlan 20
ip address 192.168.20.1 /24
ip vrf forwarding branchb
< assign an IP address to the first VR2
interface
< put the VLAN interface into VR2
(branchb)
interface vlan 21
ip address 192.168.21.1 /24
ip vrf forwarding branchb
exit
< assign an IP address to the 2nd VR2
interface
< put the VLAN interface into VR2
(branchb)
ip routing
exit
9
< create two VLANs for VR1
VRF lite for Dell Networking N-Series | version 1.1
< enable routing globally across the
physical switch
Add a VLAN to each switch in Branch A and connect to the router.
Branch A (Top Switch)
Description of Commands
Configure the N3048P (Top
Switch) for Branch A
configure
vlan 10
exit
< create a VLAN for Branch A
interface vlan 10
ip address 192.168.10.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 10
exit
ip default-gateway 192.168.10.1
exit
< assign an untagged port to the VLAN
< set the default gateway to the IP
address of the Main Office interface
< ping the Main Office to verify connectivity
ping 192.168.10.1
10
VRF lite for Dell Networking N-Series | version 1.1
The commands in the following table , entered from the N4032F (Main Office) switch, also test connectivity.


Use this command to ping the brancha top switch: ping vrf brancha 192.168.10.2
Use this command to show VRF VLAN information: show ip route vrf brancha
Branch A (Bottom Switch)
Description of Commands
Configure the N3024F (Bottom
Switch) for Branch A
configure
vlan 11
exit
interface vlan 11
ip address 192.168.11.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 11
exit
< assign an untagged port to the VLAN
ip default-gateway 192.168.11.1
exit
ping 192.168.11.1
ping 192.168.10.2
11
< create another VLAN for Branch A
VRF lite for Dell Networking N-Series | version 1.1
< set the default gateway to the IP
address of the Main Office
< ping the Main Office to verify connectivity
< ping the top Branch A switch to verify
end-to-end connectivity
The commands from the following table, entered from the N4032F (Main Office) switch, also test connectivity.


Use this command to ping the brancha bottom switch: ping vrf brancha 192.168.11.2
Use this command to show VRF VLAN information: show ip route vrf brancha
Add a VLAN to each switch in Branch B and connect to the router.
Branch B (Top Switch)
Description of Commands
Configure the N3024F (Top
Switch) for Branch B
configure
vlan 20
exit
< create a VLAN for Branch B
interface vlan 20
ip address 192.168.20.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 20
exit
12
< assign an untagged port to the VLAN
ip default-gateway 192.168.20.1
exit
< set the default gateway to the IP
address of the Main Office
ping 192.168.20.1
< ping the Main Office switch to verify
connectivity
VRF lite for Dell Networking N-Series | version 1.1
The commands from the following table, entered from the N4032F (Main Office) switch, also test connectivity.


Use this command to ping the branchb top switch: ping vrf branchb 192.168.20.2
Use this command to show VRF VLAN information: show ip route vrf branchb
Branch B (Bottom Switch)
Description of Commands
Configure the N3024F (Bottom
Switch) for Branch B
configure
vlan 21
exit
< create another VLAN for Branch B
interface vlan 21
ip address 192.168.21.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 21
exit
< assign an untagged port to the VLAN
ip default-gateway 192.168.21.1
exit
< set the default gateway to the IP
address of the Main Office
ping 192.168.21.1
ping 192.168.20.2
< ping the Main Office to verify connectivity
< ping the top Branch B switch to verify
end-to-end connectivity
The following commands, entered from the N4032F (Main Office) switch, also test connectivity.


Use this command to ping the branchb bottom switch: ping vrf branchb 192.168.21.2
Use this command to show VRF VLAN information: show ip route vrf branchb
Note: Remember to save the configuration after verifying proper behavior.
13
VRF lite for Dell Networking N-Series | version 1.1
3
BGP on VRF lite
BGP is a large-scale routing protocol used to communicate routing information between autonomous systems
(ASs), which are well-defined, separately administered network domains. In this example, there is a main
office and a branch office, each of which is a separately administered network domain at a different location
and connected by customer-edge, layer 3, N4048 switch using BGP as external gateway protocol to the
provider edge router. Each office has three departments ( CEO, finance and IT), separately connected using
multiple layer 3, N3048 switches to the N4048 switch using OSPF as internal gateway protocol. The same
departments at different offices have to exchange routes with each other, but not with the other departments.
That is, the Main Office finance department has to exchange routes with the Branch Office finance
department and the Main Office IT department exchanges routes with the Branch Office IT department. Only
like-departments exchange routes between main and branch offices. However, CEO Office has to exchange
routes with Finance and IT departments, without IT and Finance exchanging routes with each other.
MAIN OFFICE
OSPF
VPN 1 (Finance – Main office)
OSPF
VPN 2 (IT -Main office)
Te1/0/1
7
9
11
13
15
8
10
12
14
16
17
19
21
23
25
27
29
31
20
22
24
26
28
30
32
33
35
37
39
41
43
36
38
40
42
44
45
LNK
ACT
48
COMBO P
6
18
34
46
3
5
7
9
11
13
2
4
6
8
10
12
14
15
17
19
21
LNK 23 ACT
18
20
22
24
1
2
Stack No.
ACT
LNK
1
SFP+
2
(.2)
Dell N3048P
1
2
Stack No.
4
Te1/0/1
1
47
LNK
2
(192.168.10.x)
(192.168.10.x)
(.1) Te1/0/15
(.1)
Te1/0/1
Customer Edge Device
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
LNK
23
LNK
1
ACT
ACT
SFP+
2
(.2)
OSPF
VPN 3 (CEO -Main office)
(.1)
VR5 Te1/0/24 VLAN 30
VR1 VR2
COMBO P
Dell N3024F
VLAN 20
OSPF
VLAN 10
16
Te1/0/1
1
3
5
7
9
11
13
2
4
6
8
10
12
14
15
17
19
21
LNK 23 ACT
18
20
22
24
1
ACT
2
Stack No.
LNK
LNK
ACT
ACT
24
(.1)
10G SFP+ MODULE
Dell N4032F
16
COMBO P
Dell N3024F
LNK
ACT
1
SFP+
2
(.2)
BGP
BGP
core
Provider Edge
Routers
BGP
BRANCH OFFICE
VPN 3 (CEO -Main office)
Dell N4032F
1
Customer Edge Device
9
11
13
15
17
19
21
6
8
10
12
14
16
15
17
19
21
LNK
23
18
20
4
6
8
10
12
14
VR3 VR4
22
24
COMBO P
LNK
ACT
1
SFP+
OSPF
16
18
20
22
24
3
5
7
9
11
13
2
4
6
8
10
12
14
15
17
19
18
20
21
LNK 23 ACT
22
24
1
2
OSPF
BGP on VRF lite
VRF lite for Dell Networking N-Series | version 1.1
16
COMBO P
LNK
ACT
1
SFP+
2
10G SFP+ MODULE
VR6 Te1/0/24
(.1)
(.1)
VLAN 31
Dell N3024F
OSPF
VLAN 21
VPN 2 (IT -Branch office)
Dell N3024F
1
3
5
7
9
11
13
2
4
6
8
10
12
14
15
(.2)
17
19
21
LNK 23 ACT
18
20
22
24
1
2
Stack No.
ACT
2
ACT
ACT
LNK
Te1/0/1
14
1
ACT
2
LNK
4
13
(192.168.11.x)
1
LNK 23 ACT
Stack No.
2
11
Te1/0/16
VLAN 11
VPN 1 (Finance – Branch office)
(.2)
Dell N3024F
7
9
LNK
(192.168.11.x)
5
7
Stack No.
Te1/0/2 (.1)
3
5
LNK
2
1
3
16
COMBO P
LNK
ACT
1
SFP+
ACT
2
Te1/0/1
OSPF
(.2) Te1/0/1
In this example, N4032 layer 3 switches achieve route exchanges within same department across different
offices by configuring BGP with different VR domains. Create six VRs (VR1, VR2, VR3, VR4, VR5 and VR6)
across the two layer 3 switches as shown in Figure 5. VR1 and VR3 share routing information between
themselves. Likewise, VR2 and VR4, VR5 and VR6 share their routing information.
Note: To simplify this in-lab validation, we have directly connected two customer-edge devices and enabled
BGP VRF lite. Provider-edge routers (that is, ISP) configuration is not in the scope of this document.
Provider-edge routers must support BGP VRF lite.
Each branch is unaware of the IP subnets and routing table of the other branch and can therefore can overlap
IP addresses without impairing either network. A route distinguisher keeps track of these overlapping IP
routes belonging to different branches. As the name implies, a route distinguisher distinguishes one set of
routes (one VRF) from another. The route distinguisher is a unique number prepended to each route within a
VRF to identify it as belonging to that particular VRF or branch. The route distinguisher is carried with traffic
along its route via Multiprotocol BGP (MP-BGP) when exchanging VPN routes with other PE routers. For
simplicity and route target validation, this example is designed to have non-overlapping IP addresses.
While route distinguishers maintain uniqueness among identical routes in different VRFs, route targets share
routes among different VRFs. Route targets applied to VRFs import and export routes among VRFs. The
CEO office applies route targets to its VRFs (VR5,VR6) to import routes from both the Finance (VR1,VR2)
and IT departments (VR3,VR4).
The following tables include CLI configurations for Branch Office, Main Office, Main Office Finance, Main
Office IT, Main Office CEO, Branch Office Finance, Branch Office IT and Branch Office CEO. The following
table also provides explanations of each CLI command.
OSPF inter-area routes are sent through IXIA to the following switches Finance branch (70.10.x.x), IT branch
(50.10.x.x) and CEO branch (40.10.x.x) connected to the Main Office and Finance branch (60.10.x.x) switch
connected to the Branch Office for validating this example. The show commands for IP routes on the
switches follow the configuration tables.
Note: Use the six configuration files attached in the left margin of this document to copy and paste
directly into each switch’s CLI. The files pertaining to this example are titled “BGP”. Click the
paperclip icon to open and close the attachment list. This method requires allowing 60 seconds
after pasting the final configuration before pinging across the network. Execute the show
commands after the 60 seconds delay.
15
VRF lite for Dell Networking N-Series | version 1.1
N4032F (Main Office Switch Configurations)
configure
vlan 10,12
exit
interface Te1/0/1
switchport access vlan 10
interface Te1/0/3
switchport mode trunk
switchport trunk allowed vlan 12
exit
ip vrf brancha
rd 100:1000
route-target export 100:1000
exit
interface vlan 10
ip vrf forwarding brancha
ip address 192.168.10.1 /24
ip ospf area 0
Configure VR1 ( Finance - brancha )
VR
< create two VLANs for VR1
< assign a VLAN to an interface for VR1
< configure the interface in trunk mode
< assign VLAN to an interface going to provider edge
routers in trunk mode
< create VR1 (brancha) and enable routing
< create route distinguisher
< export routes from brancha
< put the VLAN interface into VR1 (brancha)
< assign an IP address
< configure the VLAN in OSPF area
interface vlan 12
ip vrf forwarding brancha
ip address 192.168.12.1 /24
exit
< put the VLAN interface into VR1 (brancha)
< assign an IP address
ip routing
< enable IP routing
router ospf vrf "brancha"
router-id 7.7.7.7.1
redistribute bgp subnets
exit
< specify OSPF for brancha
< enable OSPF router-id
< redistribute BGP subnets in ospf
router bgp 100
bgp router-id 192.24.24.3
address-family ipv4 vrf brancha
< specify BGP for brancha
< enable BGP router-id
< enable address family ipv vrf-family ipv4 vrf
brancha
< enable neighbor with remote-as
neighbor 192.168.12.2 remote-as
200
redistribute connected
redistribute ospf
exit
exit
16
Description of Commands
VRF lite for Dell Networking N-Series | version 1.1
< enable redistribute-connected
< enable redistribute-OSPF
< exit
< exit
Configure VR2 (IT - branchb ) VRconfigure
vlan 20,22
exit
interface Te1/0/2
switchport access vlan 20
interface Te1/0/3
switchport trunk allowed vlan add
22
exit
ip vrf branchb
rd 100:2000
route-target export 100:2000
exit
interface vlan 20
ip vrf forwarding branchb
ip address 192.168.20.1 /24
ip ospf area 0
interface vlan 22
ip vrf forwarding branchb
ip address 192.168.12.1 /24
exit
router ospf vrf branchb
router-id 8.8.8.1
redistribute bgp subnets
exit
router bgp 100
address-family ipv4 vrf branchb
neighbor 192.168.12.2 remote-as 200
redistribute connected
redistribute ospf
exit
exit
17
VRF lite for Dell Networking N-Series | version 1.1
< create two VLANs for VR2
< assign a VLAN to an interface for VR2
< assign VLAN 22 to an interface going to provider
edge routers in trunk mode
< create VR2 (branchb) and enable routing
< create a route distinguisher
< export routes from branchb
< put the VLAN interface into VR2 (branchb)
< assign an IP address
< configure the VLAN OSPF area
< put the VLAN interface into VR2 (branchb)
< assign an IP address
TO
< specify OSPF for branchb
< provide a router ID
< select route redistribution source protocol
< specify BGP for branchb
< enable address family ipv vrf-family ipv4 vrf
branchb
< enable neighbor remote-as
< enable redistribute-connected
< enable redistribute-OSPF
Configure VR5 (CEO - branchc ) VR< create two VLANs for VR3
configure
vlan 30,32
exit
interface Te1/0/4
switchport access vlan 30
interface Te1/0/3
switchport trunk allowed vlan add
32
exit
ip vrf branchc
rd 100:3000
route-target import 100:1000
route-target import 100:2000
exit
interface vlan 30
ip vrf forwarding branchc
ip address 192.168.30.1 /24
ip ospf area 0
interface vlan 32
ip vrf forwarding branchc
ip address 192.168.12.1 /24
exit
router ospf vrf branchc
router-id 9.9.9.1
redistribute bgp subnets
exit
router bgp 100
address-family ipv4 vrf branchc
neighbor 192.168.12.2 remote-as 200
redistribute connected
redistribute ospf
exit
exit
18
VRF lite for Dell Networking N-Series | version 1.1
< assign a VLAN to an interface for VR2
< assign VLAN 22 to an interface going to provider
edge routers in trunk mode
< create VR5 (branchc) and enable routing
< create a route distinguisher
< import routes from brancha
< import routes from branchb
< put the VLAN interface into VR2 (branchc)
< assign an IP address
< configure the VLAN OSPF area
< put the VLAN interface into VR2 (branchc)
< assign an IP address
TO
< specify OSPF for branchc
< provide a router ID
< select route redistribution source protocol
< specify BGP for branchc
< enable address family ipv vrf-family ipv4 vrf
branchc
< enable neighbor remote-as
< enable redistribute-connected
< enable redistribute-OSPF
IP routes for brancha (Finance VRF instance) on the Main Office switch:
Note:
Inter-area routes (70.10.x.x) are distributed through IXIA into Main Office finance switch
Inter-area routes (60.10.x.x) are distributed through IXIA into Branch Office finance switch.
N4048_R192U24_MO#show ip route vrf brancha
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*7.7.7.1/32 [0/0] directly connected, loopback 0
B
*11.11.11.1/32 [20/0] via 192.168.12.2, 00h:27m:58s, Vl12
B
*60.1.1.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
B
*60.10.1.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
B
*60.10.2.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
B
*60.10.3.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
B
*60.10.4.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
B
*60.10.5.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
O
*70.1.1.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
O IA *70.10.1.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
O IA *70.10.2.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
O IA *70.10.3.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
O IA *70.10.4.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
O IA *70.10.5.0/24 [110/20] via 192.168.10.2, 00h:29m:59s, Vl10
C
*192.168.10.0/24 [0/0] directly connected, Vl10
B
*192.168.11.0/24 [20/0] via 192.168.12.2, 00h:27m:34s, Vl12
C
*192.168.12.0/24 [0/0] directly connected, Vl12
19
VRF lite for Dell Networking N-Series | version 1.1
IP routes for branchb (IT VRF instance) on the Main Office switch:
Note:
Inter-area routes (50.10.x.x) are distributed through IXIA into Main Office IT switch
N4048_R192U24_MO#show ip route vrf branchb
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*8.8.8.1/32 [0/0] directly connected, loopback 1
B
*12.12.12.1/32 [20/0] via 192.168.12.2, 00h:30m:25s, Vl22
O
*50.1.1.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
O IA *50.10.0.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
O IA *50.10.1.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
O IA *50.10.2.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
O IA *50.10.3.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
O IA *50.10.4.0/24 [110/20] via 192.168.20.2, 00h:20m:15s, Vl20
C
*192.168.12.0/24 [0/0] directly connected, Vl22
C
*192.168.20.0/24 [0/0] directly connected, Vl20
B
*192.168.21.0/24 [20/0] via 192.168.12.2, 00h:17m:13s, Vl22
IP routes for branchc (CEO VRF instance) on the Main Office switch:
Note: Inter-ospf area routes and Leaked routes are seen in VRF branchc instance
N4048_R192U24_MO#show ip route vrf branchc
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
B L *7.7.7.1/32 [200/0] via 26d:10h:26m, loopback 0
B L *8.8.8.1/32 [200/0] via 26d:10h:26m, loopback 1
20
VRF lite for Dell Networking N-Series | version 1.1
C
B
B
B
O
O IA
O IA
O IA
O IA
O IA
BL
BL
BL
BL
BL
BL
B
B
B
B
B
B
BL
BL
BL
BL
BL
BL
BL
C
BL
BL
BL
C
B
21
*9.9.9.1/32 [0/0] directly connected, loopback 2
*11.11.11.1/32 [20/0] via 192.168.12.2, 00h:31m:27s, Vl32
*12.12.12.1/32 [20/0] via 192.168.12.2, 00h:31m:27s, Vl32
*13.13.13.1/32 [20/0] via 192.168.12.2, 00h:31m:27s, Vl32
*40.1.1.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*40.10.0.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*40.10.1.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*40.10.2.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*40.10.3.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*40.10.4.0/24 [110/20] via 192.168.30.2, 00h:30m:41s, Vl30
*50.1.1.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*50.10.0.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*50.10.1.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*50.10.2.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*50.10.3.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*50.10.4.0/24 [200/0] via 192.168.20.2, 00h:21m:13s, Vl20
*60.1.1.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*60.10.1.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*60.10.2.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*60.10.3.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*60.10.4.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*60.10.5.0/24 [20/0] via 192.168.12.2, 00h:30m:54s, Vl32
*70.1.1.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*70.10.1.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*70.10.2.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*70.10.3.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*70.10.4.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*70.10.5.0/24 [200/0] via 192.168.10.2, 00h:33m:17s, Vl10
*192.168.10.0/24 [200/0] via 21d:01h:17m, Vl10
*192.168.12.0/24 [0/0] directly connected, Vl32
192.168.12.0/24 [200/0] via 00h:31m:27s, Vl12
*192.168.20.0/24 [200/0] via 00h:23m:04s, Vl20
*192.168.21.0/24 [200/0] via 192.168.12.2, 00h:18m:13s, Vl22
*192.168.30.0/24 [0/0] directly connected, Vl30
*192.168.31.0/24 [20/0] via 192.168.12.2, 00h:31m:27s, Vl32
VRF lite for Dell Networking N-Series | version 1.1
CLI commands in the following table configure the BGP VRF Lite on the Dell N4032F (Branch Office) switch.
The following table also provides explanations of each CLI command.
N4032F (Branch Office Switch Configurations)
Description of Commands
Configure VR3 (Finance - brancha
) VRconfigure
vlan 11,12
exit
< create two VLANs for VR3
interface Te1/0/1
switchport access vlan 11
exit
< assign a VLAN to an interface
interface Te1/0/3
switchport mode trunk
switchport trunk allowed vlan 12
exit
ip vrf brancha
rd 200:1000
route-target export 200:1000
exit
< create VR3 (brancha) and enable routing
< create a route distinguisher
< export routes from brancha
interface vlan 11
ip vrf forwarding brancha
ip address 192.168.11.2 /24
ip ospf area 0
< assign VLAN interface to VR3 (brancha)
< assign an IP address
< configure the VLAN in OSPF area
interface vlan 12
ip vrf forwarding brancha
ip address 192.168.12.2 /24
ip ospf area 0
exit
< put the VLAN interface into VR3 (brancha)
< assign an IP address
< configure the VLAN in OSPF area
ip routing
router ospf vrf "brancha"
router-id 11.11.11.1
redistribute bgp subnets
exit
router bgp 200
bgp router-id 192.23.2.2
address-family ipv4 vrf brancha
neighbor 192.168.12.1 remote-as 100
redistribute connected
redistribute ospf
exit
exit
22
< configure the interface in trunk mode
< assign VLAN to an interface going to
provider edge routers in trunk mode
VRF lite for Dell Networking N-Series | version 1.1
< enable routing globally across physical
switch
< specify OSPF for brancha
< provide a router ID
< select route redistribution source protocol
< specify BGP for brancha
< enable bgp router-id
< enable address family ipv vrf-family ipv4 vrf
brancha
< enable neighbor remote-as
< enable redistribute-connected
< enable redistribute-OSPF
Configure VR4 (IT - branchb) VR<configure
vlan 21,22
exit
interface Te1/0/2
switchport access vlan 21
interface Te1/0/3
switchport mode trunk allowed vlan add
22
exit
ip vrf branchb
rd 200:2000
route-target export 200:2000
exit
interface vlan 21
ip vrf forwarding branchb
ip address 192.168.21.2 /24
ip ospf area 0
interface vlan 22
ip vrf forwarding branchb
ip address 192.168.12.2 /24
exit
ip routing
router ospf vrf branchb
router-id 12.12.12.1
redistribute bgp subnets
exit
router bgp 200
address-family ipv4 vrf branchb
neighbor 192.168.12.1 remote-as 100
redistribute connected
redistribute ospf
exit
exit
23
VRF lite for Dell Networking N-Series | version 1.1
< create two VLANs for VR4
< put the interface to the other Main Office
switch into VLAN 22
< assign VLAN to an interface going to
provider edge routers in trunk mode
< create VR4 (branchb) and enable routing
< create a route distinguisher
< export routes from branchb
< put the VLAN interface into VR4 (branchb)
< assign an IP address
< configure the VLAN in OSPF area
< put the VLAN interface into VR2 (branchb)
< assign an IP address
< enable routing globally across the physical
switch
< specify OSPF for branchb
< provide a router ID
< select route redistribution source protocol
< specify BGP for branchb
< enable address family ipv vrf-family ipv4 vrf
branchb
< enable neighbor remote-as
< enable redistribute-connected
< enable redistribute-OSPF
Configure VR6 (CEO - branchc)
VR<configure
vlan 31,32
exit
< create two VLANs for VR6
interface Te1/0/4
switchport access vlan 31
< put the interface to the other Main Office
switch into VLAN 31
interface Te1/0/3
switchport mode trunk allowed vlan add
22
exit
< assign VLAN to an interface going to
provider edge routers in trunk mode
ip vrf branchc
rd 200:3000
route-target import 200:1000
route-target import 200:2000
exit
interface vlan 31
ip vrf forwarding branchc
ip address 192.168.31.2 /24
ip ospf area 0
exit
interface vlan 32
ip vrf forwarding branchc
ip address 192.168.12.2 /24
exit
ip routing
router ospf vrf branchc
router-id 13.13.13.1
redistribute bgp subnets
exit
router bgp 200
address-family ipv4 vrf branchc
neighbor 192.168.12.1 remote-as 100
redistribute connected
redistribute ospf
exit
exit
exit
24
VRF lite for Dell Networking N-Series | version 1.1
< create VR6 (branchc) and enable routing
< create a route distinguisher
< import routes from brancha
< import routes from branchb
< put the VLAN interface into VR4 (branchb)
< assign an IP address
< configure the VLAN in OSPF area
< put the VLAN interface into VR2 (branchb)
< assign an IP address
< enable routing globally across the physical
switch
< specify OSPF for branchc
< provide a router ID
< select route redistribution source protocol
< specify BGP for branchc
< enable address family ipv vrf-family ipv4 vrf
branchb
< enable neighbor remote-as
< enable redistribute-connected
< enable redistribute-OSPF
IP routes for brancha (Finance VRF instance) on the Branch Office switch:
Note:
Inter-area routes (70.10.x.x) are distributed through IXIA into Main Office finance switch
Inter-area routes (60.10.x.x) are distributed through IXIA into Branch Office finance switch.
N4000_R192U23_BO#show ip route vrf brancha
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
B
*7.7.7.1/32 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
C
*11.11.11.1/32 [0/0] directly connected, loopback 0
O
*60.1.1.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
O IA *60.10.1.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
O IA *60.10.2.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
O IA *60.10.3.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
O IA *60.10.4.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
O IA *60.10.5.0/24 [110/20] via 192.168.11.1, 00h:39m:25s, Vl11
B
*70.1.1.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*70.10.1.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*70.10.2.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*70.10.3.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*70.10.4.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*70.10.5.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
B
*192.168.10.0/24 [20/0] via 192.168.12.1, 00h:39m:20s, Vl12
C
*192.168.11.0/24 [0/0] directly connected, Vl11
C
*192.168.12.0/24 [0/0] directly connected, Vl12
25
VRF lite for Dell Networking N-Series | version 1.1
IP routes for branchb (IT VRF instance) on the Branch Office switch:
Note: Only Inter-ospf area routes which are redistributed through BGP are seen in VRF branchb instance.
N4000_R192U23_BO#show ip route vrf branchb
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
B
*8.8.8.1/32 [20/0] via 192.168.12.1, 00h:40m:27s, Vl22
C
*12.12.12.1/32 [0/0] directly connected, loopback 1
B
*50.1.1.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
B
*50.10.0.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
B
*50.10.1.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
B
*50.10.2.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
B
*50.10.3.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
B
*50.10.4.0/24 [20/0] via 192.168.12.1, 00h:30m:14s, Vl22
C
*192.168.12.0/24 [0/0] directly connected, Vl22
B
*192.168.20.0/24 [20/0] via 192.168.12.1, 00h:30m:47s, Vl22
C
*192.168.21.0/24 [0/0] directly connected, Vl21
IP routes for branchc (CEO VRF instance) on the Branch Office switch:
Note: Inter-ospf area routes and Leaked routes are seen in VRF branchc instance
N4000_R192U23_BO#show ip route vrf branchc
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
B
*7.7.7.1/32 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
B L *8.8.8.1/32 [200/0] via 192.168.12.1, 00h:40m:59s, Vl22
B
*9.9.9.1/32 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
26
VRF lite for Dell Networking N-Series | version 1.1
BL
BL
C
B
B
B
B
B
B
BL
BL
BL
BL
BL
BL
BL
BL
BL
BL
BL
BL
B
B
B
B
B
B
BL
C
BL
BL
B
C
27
*11.11.11.1/32 [200/0] via 26d:10h:35m, loopback 0
*12.12.12.1/32 [200/0] via 26d:10h:35m, loopback 1
*13.13.13.1/32 [0/0] directly connected, loopback 2
*40.1.1.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*40.10.0.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*40.10.1.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*40.10.2.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*40.10.3.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*40.10.4.0/24 [20/0] via 192.168.12.1, 00h:40m:05s, Vl32
*50.1.1.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*50.10.0.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*50.10.1.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*50.10.2.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*50.10.3.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*50.10.4.0/24 [200/0] via 192.168.12.1, 00h:30m:48s, Vl22
*60.1.1.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*60.10.1.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*60.10.2.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*60.10.3.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*60.10.4.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*60.10.5.0/24 [200/0] via 192.168.11.1, 00h:40m:55s, Vl11
*70.1.1.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*70.10.1.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*70.10.2.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*70.10.3.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*70.10.4.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*70.10.5.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*192.168.10.0/24 [200/0] via 192.168.12.1, 00h:40m:59s, Vl22
*192.168.12.0/24 [0/0] directly connected, Vl32
*192.168.20.0/24 [200/0] via 192.168.12.1, 00h:32m:39s, Vl22
*192.168.21.0/24 [200/0] via 00h:27m:51s, Vl21
*192.168.30.0/24 [20/0] via 192.168.12.1, 00h:40m:59s, Vl32
*192.168.31.0/24 [0/0] directly connected, Vl31
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Main office Finance switch and connect to the
Main Office using OSPF:
Main Office Finance Switch
Description of Commands
Configure the N3048 for Main
Office Finance department
configure
vlan 10
exit
< create a VLAN
interface vlan 10
ip address 192.168.10.2 /24
ip ospf area 0
exit
< assign an IP address to the VLAN
< configure the VLAN in OSPF area
interface Gi1/0/47
switchport access vlan 10
exit
router ospf
router-id 3.3.3.1
exit
ip routing
exit
ping 192.168.10.1
28
VRF lite for Dell Networking N-Series | version 1.1
< assign an untagged port to the VLAN
< enable default OSPF
< provide a router ID
< enable global ip routing
< ping the Main Office switch to verify
connectivity
IP routes for the Main Office finance switch:
Note:
Inter-area routes (70.10.x.x) are distributed through IXIA into Main Office finance switch
Inter-area routes (60.10.x.x) are distributed through IXIA into Branch Office finance switch.
N3048_R193U24_MOA#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*3.3.3.1/32 [0/0] directly connected, loopback 0
O E2 *11.11.11.1/32 [110/1] via 192.168.10.1, 00h:42m:54s, Vl10
O E2 *60.1.1.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
O E2 *60.10.1.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
O E2 *60.10.2.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
O E2 *60.10.3.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
O E2 *60.10.4.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
O E2 *60.10.5.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
C
*70.1.1.0/24 [0/0] directly connected, Vl70
O IA *70.10.1.0/24 [110/10] via 70.1.1.2, 21d:00h:38m, Vl70
O IA *70.10.2.0/24 [110/10] via 70.1.1.2, 21d:00h:38m, Vl70
O IA *70.10.3.0/24 [110/10] via 70.1.1.2, 21d:00h:38m, Vl70
O IA *70.10.4.0/24 [110/10] via 70.1.1.2, 21d:00h:38m, Vl70
O IA *70.10.5.0/24 [110/10] via 70.1.1.2, 21d:00h:38m, Vl70
C
*192.168.10.0/24 [0/0] directly connected, Vl10
O E2 *192.168.11.0/24 [110/1] via 192.168.10.1, 00h:42m:30s, Vl10
29
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Branch Office finance switch and connect to
the Branch Office using OSPF:
Branch Office Finance Switch
Description of Commands
Configure the N3048 for Branch
Office Finance department
configure
vlan 11
exit
< create a VLAN
interface vlan 11
ip address 192.168.11.1 /24
ip ospf area 0
< assign an IP address to the VLAN
< configure the VLAN in OSPF area
interface Gi1/0/47
switchport access vlan 11
exit
< assign an untagged port to the VLAN
router ospf
router-id 2.2.2.1
exit
ip routing
ping 192.168.11.2
ping 192.168.10.2
traceroute 192.168.11.2
< enable default OSPF
< provide a router ID
< enable global ip routing
< ping the Branch Office to verify
connectivity
< ping the Main office Finance switch to
verify end-to-end connectivity
< trace the route to see all hops
If the preceding ping commands fail, check each configuration. Refer to the Troubleshooting section for
additional assistance.
30
VRF lite for Dell Networking N-Series | version 1.1
IP routes for the Branch Office finance switch:
Note:
Inter-area routes (70.10.x.x) are distributed through IXIA into Main Office finance switch
Inter-area routes (60.10.x.x) are distributed through IXIA into Branch Office finance switch.
N3048_R193U22_BOA#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*2.2.2.1/32 [0/0] directly connected, loopback 0
O E2 *7.7.7.1/32 [110/1] via 192.168.11.2, 00h:48m:33s, Vl11
C
*60.1.1.0/24 [0/0] directly connected, Vl60
O IA *60.10.1.0/24 [110/10] via 60.1.1.2, 15h:31m:09s, Vl60
O IA *60.10.2.0/24 [110/10] via 60.1.1.2, 15h:31m:00s, Vl60
O IA *60.10.3.0/24 [110/10] via 60.1.1.2, 15h:31m:00s, Vl60
O IA *60.10.4.0/24 [110/10] via 60.1.1.2, 15h:31m:00s, Vl60
O IA *60.10.5.0/24 [110/10] via 60.1.1.2, 15h:31m:00s, Vl60
O E2 *70.1.1.0/24 [110/1] via 192.168.11.2, 00h:47m:42s, Vl11
O E2 *70.10.1.0/24 [110/1] via 192.168.11.2, 00h:47m:42s, Vl11
O E2 *70.10.2.0/24 [110/1] via 192.168.11.2, 00h:47m:42s, Vl11
O E2 *70.10.3.0/24 [110/1] via 192.168.11.2, 00h:47m:42s, Vl11
O E2 *70.10.4.0/24 [110/1] via 192.168.11.2, 00h:47m:42s, Vl11
O E2 *70.10.5.0/24 [110/1] via 192.168.11.2, 00h:47m:37s, Vl11
O E2 *192.168.10.0/24 [110/1] via 192.168.11.2, 00h:48m:33s, Vl11
C
*192.168.11.0/24 [0/0] directly connected, Vl11
31
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Main Office IT switch and connect to the Main
Office using OSPF:
Main Office IT switch
Description of Commands
Configure the N3048 for Main
Office IT department
configure
vlan 20
exit
interface vlan 20
ip address 192.168.20.2 /24
ip ospf area 0
exit
interface Gi1/0/47
switchport access vlan 20
exit
router ospf
router-id 4.4.4.1
exit
ip routing
ping 192.168.20.1
32
VRF lite for Dell Networking N-Series | version 1.1
< create a VLAN for Branch B
< assign an IP address to the VLAN
< configure the VLAN in OSPF area
< assign an untagged port to the VLAN
< enable default OSPF
< provide a router ID
<enable global ip routing
< ping the Main Office switch to verify
connectivity
IP routes for the Main Office IT switch:
Note: Inter-area routes (50.10.x.x) are distributed through IXIA into Main Office IT switch
N3024_R193U25_MOB#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*4.4.4.1/32 [0/0] directly connected, loopback 0
O E2 *12.12.12.1/32 [110/1] via 192.168.20.1, 00h:45m:47s, Vl20
C
*50.1.1.0/24 [0/0] directly connected, Vl50
O IA *50.10.0.0/24 [110/10] via 50.1.1.2, 16h:03m:07s, Vl50
O IA *50.10.1.0/24 [110/10] via 50.1.1.2, 16h:02m:58s, Vl50
O IA *50.10.2.0/24 [110/10] via 50.1.1.2, 16h:02m:58s, Vl50
O IA *50.10.3.0/24 [110/10] via 50.1.1.2, 16h:02m:58s, Vl50
O IA *50.10.4.0/24 [110/10] via 50.1.1.2, 16h:02m:58s, Vl50
C
*192.168.20.0/24 [0/0] directly connected, Vl20
O E2 *192.168.21.0/24 [110/1] via 192.168.20.1, 00h:42m:45s, Vl20
33
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Branch Office IT switch and connect to the
Branch Office using OSPF:
Branch Office IT switch
Description of Commands
Configure the N3048 for Branch
Office IT department
configure
vlan 21
exit
< create another VLAN for Branch B
interface vlan 21
ip address 192.168.21.1 /24
< assign an IP address to the VLAN
interface Gi1/0/47
switchport access vlan 21
exit
< assign an untagged port to the VLAN
router ospf
router-id 1.1.1.1
exit
ping 192.168.11.2
< enable default OSPF
< provide a router ID
< ping the Main Office to verify connectivity
< ping the top Branch B switch to verify
end-to-end connectivity
ping 192.168.10.2
< trace the route to see all hops
traceroute 192.168.21.2
If the preceding ping commands fail, check each configuration. Refer to the Troubleshooting section for
additional assistance.
34
VRF lite for Dell Networking N-Series | version 1.1
IP routes for the Branch Office IT switch:
Note: Inter-area routes (50.10.x.x) are distributed through IXIA into Main Office IT switch are received as E2
routes in Branch Office IT switch redistributed through BGP into OSPF area.
N3048_R193U23_BOB#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*1.1.1.1/32 [0/0] directly connected, loopback 0
O E2 *8.8.8.1/32 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.1.1.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.10.0.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.10.1.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.10.2.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.10.3.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *50.10.4.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
O E2 *192.168.20.0/24 [110/1] via 192.168.21.2, 00h:44m:54s, Vl21
C
*192.168.21.0/24 [0/0] directly connected, Vl21
35
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Main Office CEO switch and connect to the
Main Office using OSPF:
Main Office CEO switch
Description of Commands
Configure the N3048 for Main
Office CEO department
configure
vlan 30
exit
interface vlan 30
ip address 192.168.30.2 /24
ip ospf area 0
exit
interface Gi1/0/47
switchport access vlan 20
exit
router ospf
router-id 5.5.5.1
exit
ip routing
ping 192.168.30.1
< create a VLAN for Branch B
< assign an IP address to the VLAN
< configure the VLAN in OSPF area
< assign an untagged port to the VLAN
< enable default OSPF
< provide a router ID
< enable global ip routing
< ping the Main Office switch to verify
connectivity
IP routes for the Main Office CEO switch:
NOTE: Inter-area routes (50.10.x.x) are distributed through IXIA into Main Office CEO switch. There are also
routes redistributed by BGP from brancha and branchb.
8164_R193U34_MOCEO#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
No default gateway is configured.
C
*5.5.5.1/32 [0/0] directly connected, loopback 0
O E2 *7.7.7.1/32 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *8.8.8.1/32 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *11.11.11.1/32 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
36
VRF lite for Dell Networking N-Series | version 1.1
O E2 *12.12.12.1/32 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *13.13.13.1/32 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
C
*40.1.1.0/24 [0/0] directly connected, Vl40
O IA *40.10.0.0/24 [110/10] via 40.1.1.2, 03h:01m:34s, Vl40
O IA *40.10.1.0/24 [110/10] via 40.1.1.2, 03h:01m:34s, Vl40
O IA *40.10.2.0/24 [110/10] via 40.1.1.2, 03h:01m:34s, Vl40
O IA *40.10.3.0/24 [110/10] via 40.1.1.2, 03h:01m:34s, Vl40
O IA *40.10.4.0/24 [110/10] via 40.1.1.2, 03h:01m:34s, Vl40
O E2 *50.1.1.0/24 [110/1] via 192.168.30.1, 02h:52m:06s, Vl30
O E2 *50.10.0.0/24 [110/1] via 192.168.30.1, 02h:52m:06s, Vl30
O E2 *50.10.1.0/24 [110/1] via 192.168.30.1, 02h:52m:06s, Vl30
O E2 *50.10.2.0/24 [110/1] via 192.168.30.1, 02h:52m:01s, Vl30
O E2 *50.10.3.0/24 [110/1] via 192.168.30.1, 02h:52m:01s, Vl30
O E2 *50.10.4.0/24 [110/1] via 192.168.30.1, 02h:52m:01s, Vl30
O E2 *60.1.1.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *60.10.1.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *60.10.2.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *60.10.3.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *60.10.4.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *60.10.5.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.1.1.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.10.1.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.10.2.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.10.3.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.10.4.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *70.10.5.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *192.168.10.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
O E2 *192.168.20.0/24 [110/1] via 192.168.30.1, 02h:53m:58s, Vl30
O E2 *192.168.21.0/24 [110/1] via 192.168.30.1, 02h:49m:06s, Vl30
C
*192.168.30.0/24 [0/0] directly connected, Vl30
O E2 *192.168.31.0/24 [110/1] via 192.168.30.1, 03h:01m:34s, Vl30
37
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following table to add a VLAN to Branch Office CEO switch and connect to the
Branch Office using OSPF:
Branch Office CEO switch
Description of Commands
Configure the N3048 for Branch
Office CEO department
configure
vlan 31
exit
< create another VLAN for Branch B
interface vlan 31
ip address 192.168.31.1 /24
< assign an IP address to the VLAN
interface Gi1/0/47
switchport access vlan 31
exit
< assign an untagged port to the VLAN
router ospf
router-id 6.6.6.1
exit
ping 192.168.11.2
< enable default OSPF
< provide a router ID
< ping the Main Office to verify connectivity
< ping the top Branch B switch to verify
end-to-end connectivity
ping 192.168.10.2
< trace the route to see all hops
traceroute 192.168.31.2
If the preceding ping commands fail, check each configuration. Refer to the Troubleshooting section for
additional assistance.
IP routes for the Branch Office CEO switch:
Note: Inter-area OSPF IXIA routes injected in Main Office CEO switch are received as E2 routes in Branch
Office CEO switch redistributed through BGP into OSPF area. Routes imported by BGP from brancha and
branchb VRFs are also listed as E2 routes in this switch.
N4000_R193U33_BOCEO#show ip route
Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, K - Kernel S - Static
B - BGP Derived, E - Externally Derived, IA - OSPF Inter Area
E1 - OSPF External Type 1, E2 - OSPF External Type 2
N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2
S U - Unnumbered Peer, L - Leaked Route
* Indicates the best (lowest metric) route for the subnet.
38
VRF lite for Dell Networking N-Series | version 1.1
No default gateway is configured.
C
*6.6.6.1/32 [0/0] directly connected, loopback 0
O E2 *7.7.7.1/32 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *8.8.8.1/32 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *9.9.9.1/32 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *11.11.11.1/32 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *12.12.12.1/32 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *40.1.1.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *40.10.0.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *40.10.1.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *40.10.2.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *40.10.3.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *40.10.4.0/24 [110/1] via 192.168.31.2, 03h:04m:05s, Vl31
O E2 *50.1.1.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *50.10.0.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *50.10.1.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *50.10.2.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *50.10.3.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *50.10.4.0/24 [110/1] via 192.168.31.2, 02h:54m:48s, Vl31
O E2 *60.1.1.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *60.10.1.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *60.10.2.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *60.10.3.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *60.10.4.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *60.10.5.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.1.1.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.10.1.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.10.2.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.10.3.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.10.4.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *70.10.5.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
O E2 *192.168.10.0/24 [110/1] via 192.168.31.2, 03h:04m:58s, Vl31
O E2 *192.168.20.0/24 [110/1] via 192.168.31.2, 02h:56m:39s, Vl31
O E2 *192.168.21.0/24 [110/1] via 192.168.31.2, 02h:51m:51s, Vl31
O E2 *192.168.30.0/24 [110/1] via 192.168.31.2, 03h:04m:48s, Vl31
C
*192.168.31.0/24 [0/0] directly connected, Vl31
39
VRF lite for Dell Networking N-Series | version 1.1
4
OSPF on VRF lite
If multiple layer 3 switches connect switches in a branch, configure the VRs using OSPF so each switch
shares routing information with the other(s). In this example, two layer 3 switches separate each branch’s two
switches. Create four VRs (VR1, VR2, VR3, and VR4) across the two layer 3 switches as shown in Figure 5.
VR1 and VR3 share routing information while, VR2 and VR4 share routing information.
Branch A
7
9
11
13
15
19
21
25
23
27
29
31
33
35
37
39
41
43
45
1
LNK 47 ACT
2
Stack No.
LNK
2
4
6
8
10
12
14
16
18
20
22
26
24
28
30
32
34
36
38
40
42
44
46
ACT
48 COMBO P
Dell N3048P
1
SFP+
Branch B
OSPF
configured
on all VRs
Te1/0/1
17
2
(.2)
3
5
7
9
11
13
15
17
2
4
6
8
10
12
14
16
18
19
21
Main Office
Te1/0/2
(.1)
(192.168.11.x) VLAN 11
11
13
6
8
10
12
14
19
21
2
4
6
8
10
12
14
16
18
20
22
17
19
21
16
18
20
22
LNK
ACT
24 COMBO P
LNK
ACT
1
SFP+
2
ACT
2
(.2)
22
24
ACT
10G SFP+ MODULE
Dell N4032F
4032F
Dell
1
3
5
7
9
11
13
15
17
2
4
6
8
10
12
14
16
18
19
21
LNK 23 ACT
20
22
24
VR3 VR4
ACT
10G SFP+ MODULE
Te1/0/16
(.1)
Dell N3024F
1
LNK 23 ACT
24 COMBO P
1
LNK 23 ACT
VR2 and VR4
share routing
VLAN 22 (192.168.22.x) information
(directly
(.2)
Te1/0/15
connected)
20
(.2)
15
1
SFP+
1
3
5
7
9
11
13
15
17
(.2)
19
21
1
LNK 23 ACT
2
LNK
4
17
VLAN 21 (192.168.21.x)
Stack No.
2
15
LNK 23 ACT
LNK
9
13
Te1/0/16
(.1)
Dell N4032F
(.2)
Te1/0/1
7
11
(.1)
Te1/0/15
1
(192.168.12.x) VLAN 12
5
9
Dell N3024F
VR1 VR2
Te1/0/2
(.1)
3
7
LNK
LNK
1
5
VLAN 20 (192.168.20.x)
(.1)
Te1/0/1
Dell N3024F
3
Stack No.
(192.168.10.x) VLAN 10
VR1 and VR3
share routing
information
(directly
connected)
Te1/0/1
1
2
Te1/0/1
2
Stack No.
ACT
LNK
2
4
6
8
10
12
14
16
18
20
22
24 COMBO P
LNK
ACT
1
SFP+
ACT
2
Te1/0/1
OSPF on VRF lite
In this example, there are two branch offices. Each branch has two N3xxx switches that require routes to
each other but isolation from the other branch. This example shows two N4xxx routing switches at the Main
Office configured to use VRF lite to create two VRs on each. Each VR pair isolates the traffic for its branch.
Each branch is unaware of the IP subnets and routing table of the other branch and can therefore overlap IP
addresses without impairing either network. To avoid confusion in the example, this particular design does not
overlap IP addresses.
40
VRF lite for Dell Networking N-Series | version 1.1
Note: The configurations of the four branch switches do not change between the Simple VRF
example (Figure 3) and the OSPF example below (Figure 5).
Use the CLI commands in the following table to configure the VRs and OSPF on the top Dell 4032F (Main
Office) switch. The following table also provides explanations of each CLI command:
Note: Use the six configuration files attached in the left margin of this document to copy and paste
directly into each switch’s CLI. The files pertaining to this example are titled “OSPF”. Click the
paperclip icon to open and close the attachment list. This method requires allowing 20 seconds
after pasting the final configuration before pinging across the network.
N4032F (Main Office – Top Switch)
configure
vlan 10,12
exit
41
Description of Commands
Configure VR1 (Branch A) VR
< create two VLANs for VR1
interface Te1/0/1
switchport access vlan 10
< assign a VLAN to an interface for VR1
interface Te1/0/2
switchport access vlan 12
exit
< put the interface to the other Main Office
switch into VLAN 12
ip vrf brancha
ip routing
exit
< create VR1 (brancha) and enable routing
interface vlan 10
ip vrf forwarding brancha
ip address 192.168.10.1 /24
ip ospf area 0
< put the VLAN interface into VR1 (brancha)
< assign an IP address
< configure the VLAN OSPF area
interface vlan 12
ip vrf forwarding brancha
ip address 192.168.12.1 /24
ip ospf area 0
exit
< put the VLAN interface into VR1 (brancha)
< assign an IP address
< configure the VLAN OSPF area
exit
Configure VR2 (Branch B) VR-
configure
vlan 20,22
exit
< create two VLANs for VR2
interface Te1/0/15
switchport access vlan 20
< assign a VLAN to an interface on VR2
interface Te1/0/16
switchport access vlan 22
exit
< put the interface to the other Main Office
switch into VLAN 22
VRF lite for Dell Networking N-Series | version 1.1
ip vrf branchb
ip routing
exit
< create VR2 (branchb) and enable routing
interface vlan 20
ip vrf forwarding branchb
ip address 192.168.20.1 /24
ip ospf area 0
< put the VLAN interface into VR2 (branchb)
< assign an IP address
< configure the VLAN OSPF area
interface vlan 22
ip vrf forwarding branchb
ip address 192.168.22.1 /24
ip ospf area 0
exit
ip routing
< put the VLAN interface into VR2 (branchb)
< assign an IP address
< configure the VLAN OSPF area
< enable routing globally across the physical
switch
Enable OSPF on both VRFs<-C
OMMENT O
router ospf vrf brancha
network 192.168.0.0 255.255.255.0 area 0
router-id 192.168.0.253
redistribute connected
enable
exit
router ospf vrf branchb
network 192.168.0.0 255.255.255.0 area 0
router-id 192.168.0.252
redistribute connected
enable
exit
exit
42
VRF lite for Dell Networking N-Series | version 1.1
< specify OSPF for brancha
< configure IP address and OSPF router area
< provide a router ID
< select route redistribution source protocol
< enable OSPF administrative mode
< specify OSPF for branchb
< configure IP address and OSPF router area
< provide a router ID
< select route redistribution source protocol
< enable OSPF administrative mode
Use the CLI commands in the following table to configure the VRs and OSPF on the top Dell 4032F (Main
Office) switch. The following table also provides explanations of each CLI command.
N4032F (Main Office – Bottom Switch)
Description of Commands
Configure VR3 (Branch A) VRconfigure
vlan 11,12
exit
< create two VLANs for VR1
interface Te1/0/1
switchport access vlan 12
exit
< put the interface to the other Main Office
switch into VLAN 12
interface Te1/0/2
switchport access vlan 11
exit
< assign this VLAN to an interface for VR1
ip vrf brancha
ip routing
exit
< create VR1 (brancha) and enable routing
interface vlan 11
ip vrf forwarding brancha
ip address 192.168.11.1 /24
ip ospf area 0
< put the VLAN interface into VR1
interface vlan 12
ip vrf forwarding brancha
ip address 192.168.12.2 /24
ip ospf area 0
exit
< put the VLAN interface into VR1
(brancha)
< assign an IP address
< configure the VLAN OSPF area
(brancha)
< assign an IP address
< configure the VLAN OSPF area
exit
Configure VR4 (Branch B) VR<configure
vlan 21,22
exit
43
< create two VLANs for VR2
interface Te1/0/15
switchport access vlan 22
< put the interface to the other Main Office
switch into VLAN 22
interface Te1/0/16
switchport access vlan 21
exit
< assign this VLAN to an interface on VR2
ip vrf branchb
ip routing
exit
< create VR2 (branchb) and enable routing
VRF lite for Dell Networking N-Series | version 1.1
interface vlan 21
ip vrf forwarding branchb
ip address 192.168.21.1 /24
ip ospf area 0
interface vlan 22
ip vrf forwarding branchb
ip address 192.168.22.2 /24
ip ospf area 0
exit
ip routing
< put the VLAN interface into VR2
(branchb)
< assign an IP address
< configure the VLAN OSPF area
< put the VLAN interface into VR2
(branchb)
< assign an IP address
< configure the VLAN OSPF area
< enable routing globally across the
physical switch
Enable OSPF on both VRFs-
router ospf vrf brancha
network 192.168.0.0 255.255.255.0 area 0
router-id 192.168.0.251
redistribute connected
enable
exit
router ospf vrf branchb
network 192.168.0.0 255.255.255.0 area 0
router-id 192.168.0.250
redistribute connected
enable
< specify OSPF for brancha
< configure IP address and OSPF router area
< provide a router ID
< optionally, use route redistribute
command to enable OSPF on all interfaces
in the VRF
< enable OSPF administrative mode
< specify OSPF for branchb
< configure IP address and OSPF router area
< provide a router ID
< optionally, use route redistribute
command to enable OSPF on all interfaces
in the VRF
< enable OSPF administrative mode
exit
exit
The VR names brancha and branchb used above can be different from one physical switch to the next.
This example uses the same names on both N4032F switches to avoid confusion.
44
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following tables to add a VLAN to each switch in Branch A and connect to the
router. The following tables also provide explanations of each CLI command:
Note: The configurations of the following four branch switches do not change between the Simple
VRF example topology shown in Figure 3 and the OSPF example topology shown in Figure 5. The
same four configurations work in both scenarios.
Branch A (Top Switch)
Description of Commands
Configure the N3048P (Top
Switch) for Branch A
configure
vlan 10
exit
< create a VLAN for Branch A
interface vlan 10
ip address 192.168.10.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 10
exit
< assign an untagged port to the VLAN
ip default-gateway 192.168.10.1
exit
ping 192.168.10.1
45
VRF lite for Dell Networking N-Series | version 1.1
< set the default gateway to the IP address
of the Main Office interface
< ping the top Main Office switch to verify
connectivity
Branch A (Bottom Switch)
Description of Commands
Configure the N3024F (Bottom
Switch) for Branch A
configure
vlan 11
exit
< create another VLAN for Branch A
interface vlan 11
ip address 192.168.11.2 /24
< assign an IP address to the VLAN
interface Te1/0/1
switchport access vlan 11
exit
< assign an untagged port to the VLAN
ip default-gateway 192.168.11.1
exit
< set the default gateway to the IP address
of the Main Office
ping 192.168.11.1
ping 192.168.10.2
< ping the Main Office to verify connectivity
< ping the top Branch A switch to verify
end-to-end connectivity
< trace the route to see all hops
traceroute 192.168.10.2
If the preceding ping commands fail, check each configuration. Refer to the Troubleshooting section for
additional assistance.
46
VRF lite for Dell Networking N-Series | version 1.1
Use the CLI commands in the following tables to add a VLAN to each switch in Branch B and connect to the
router. The following tables also provide explanations of each CLI command:
Branch B (Top Switch)
Description of Commands
Configure the N3024F (Top
Switch) for Branch B
configure
vlan 20
exit
interface vlan 20
ip address 192.168.20.2 /24
interface Te1/0/1
switchport access vlan 20
exit
ip default-gateway 192.168.20.1
exit
< create a VLAN for Branch B
< assign an IP address to the VLAN
< assign an untagged port to the VLAN
< set the default gateway to the IP address
of the Main Office
ping 192.168.20.1
< ping the Main Office switch to verify
connectivity
Branch B (Bottom Switch)
Description of Commands
Configure the N3024F (Bottom
Switch) for Branch B
configure
vlan 21
exit
interface vlan 21
ip address 192.168.21.2 /24
interface Te1/0/1
switchport access vlan 21
exit
ip default-gateway 192.168.21.1
exit
ping 192.168.21.1
ping 192.168.20.2
< create another VLAN for Branch B
< assign an IP address to the VLAN
< assign an untagged port to the VLAN
< set the default gateway to the IP address
of the Main Office
< ping the Main Office to verify connectivity
< ping the top Branch B switch to verify
end-to-end connectivity
< trace the route to see all hops
traceroute 192.168.20.2
If the preceding ping commands fail, check each configuration. Refer to the Troubleshooting section for
additional assistance.
47
VRF lite for Dell Networking N-Series | version 1.1
5
VRF VRRP Configuration
When a default gateway router (Layer 3 switch) fails, all traffic directed toward it is lost until the failure is
corrected. Virtual Router Redundancy Protocol (VRRP) circumvents the failing router by providing a scheme
to dynamically elect a backup router, which helps minimize network down time. VRFs support VRRP as
shown in Figure 6. VRFs enable the configuration of several VRRP instances on two physical switches.
Main Office
VLAN 10
(192.168.10.x)
VR1
Te1/0/8 (.1)
Te1/0/15 (.1)
1
3
5
7
9
11
13
15
17
19
21
LNK 23 ACT
2
4
6
8
10
12
14
16
18
20
22
24
LNK
Dell N4032F
ACT
10G SFP+ MODULE
VRRP Master
Branch X
Te1/0/1 (.3)
External
Network
VLAN 11
(192.168.11.x)
VRRP
192.168.10.100
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK 23 ACT
2
Stack No.
LNK
Dell N3024F
24 COMBO P
LNK
ACT
1
SFP+
ACT
2
Te1/0/2 (.3)
VRRP Backup
Dell N4032F
1
3
5
7
9
11
13
15
17
19
21
LNK 23 ACT
2
4
6
8
10
12
14
16
18
20
22
24
Te1/0/8 (.1)
VR2
Te1/0/15 (.2)
VLAN 10
(192.168.10.x)
VRRP on VRF lite
In this example, a switch in Branch X uses redundant routers at the Main Office to connect to an external
network. If the master router at the Main Office goes offline, the backup router takes over. A “priority”
command distinguishes between the Master and Backup roles. Use the following CLI commands to configure
the master router (top) in the topology. The following table also provides explanations of each CLI command:
48
VRF lite for Dell Networking N-Series | version 1.1
Configuring the VRF VRRP Master
Note: Use the three configuration files attached in the left margin of this document to copy and
paste directly into each switch’s CLI. The files pertaining to this example are titled “VRRP”. Click the
paperclip icon to open and close the attachment list.
N4032F (Main Office – Top Switch)
Description of Commands
configure
vlan 10,11
exit
< create two VLANs
ip vrf branchx
ip routing
exit
< create VR1 (branchx)
< enabled routing in VRF
ip routing
ip vrrp
< enable IP routing globally
< enable VRRP globally
interface vlan 10
ip vrf forwarding branchx
ip address 192.168.10.1 255.255.255.0
vrrp 1
vrrp 1 mode
vrrp 1 ip 192.168.10.100
vrrp 1 priority 5
vrrp 1 accept-mode
exit
< configure VLAN interface
< make VRF member
< add IP address
< create VRRP instance using VRID 1
< set VRRP address
< set VRRP priority high to be master VR
< set to accept pings
interface Te1/0/15
switchport access vlan 10
exit
< configure physical interface
< add VLAN membership
interface vlan 11
ip vrf forwarding branchx
ip address 192.168.11.1 255.255.255.0
< create a VLAN for the external
network
< put the VLAN interface into the VR
< assign an IP address to the interface
interface Te1/0/8
switchport access vlan 11
exit
exit
49
VRF lite for Dell Networking N-Series | version 1.1
< assign a port to the VLAN
Configuring the VRF VRRP Backup
Use the commands in the following table to configure the second router (bottom) in the VRRP topology. The
following table also provides explanations of each CLI command:
N4032F (Main Office – Bottom Switch)
Description of Commands
configure
vlan 10,11
exit
< create VLAN
ip vrf branchx
ip routing
exit
< create VR2 (branchx)*
< enabled routing in VRF
ip routing
ip vrrp
< enable IP routing globally
< enable VRRP globally
interface vlan 10
ip vrf forwarding branchx
ip address 192.168.10.2 255.255.255.0
vrrp 1
vrrp 1 mode
vrrp 1 ip 192.168.10.100
vrrp 1 priority 2
vrrp 1 accept-mode
exit
interface Te1/0/15
switchport access vlan 10
exit
interface vlan 11
ip vrf forwarding branchx
ip address 192.168.11.1 255.255.255.0
interface Te1/0/8
switchport access vlan 11
exit
exit
< configure VLAN interface
< make it a VRF member
< add IP address
< create VRRP instance using VRID 1
(same as on the peer switch)
< set VRRP address (same as peer switch)
< set VRRP priority lower to be Backup VR**
< set to accept pings
< configure physical interface
< add VLAN membership
< create a vlan for the external network
< put the VLAN interface into the VR
< assign an IP address to the interface
< assign a port to the VLAN
Notes:
1. The VRs on the top and bottom switches can use the same or different names. Only the
local switch knows this name, which is not shared with the peer VRRP switch.
2. The VRRP priority determines which VR is the master router. Traffic initially routes
through this VR only.
50
VRF lite for Dell Networking N-Series | version 1.1
Configuring Connecting Switches
Switches connected to the two VRRP switches for routing redundancy are unaware of the VRRP and contain
no VRRP configuration themselves. They must however have two non-LAG connections, one to each of the
VRRP peer switches, to take advantage of the VRRP feature.
Use the commands in the following table to configure the Branch X switch as shown in VRRP topology. The
following table also provides explanations of each CLI command:
Branch X
Description of Commands
configure
vlan 10
exit
< create a VLAN for Branch B
interface vlan 10
ip address 192.168.10.3 /24
interface Te1/0/1
switchport access vlan 10
exit
< assign an IP address to the VLAN
interface Te1/0/2
switchport access vlan 10
exit
< assign second untagged port to the
VLAN
ip default-gateway 192.168.10.100
exit
ping 192.168.10.100
< assign first untagged port to the VLAN
< set the default gateway to the IP
address of the Main Office VRRP
address
< ping the Main Office switch to verify
connectivity
Validating VRRP Failover
Use the following commands to validate the VRRP configuration and failover functionality. It is best practice
to save that the configurations of all switches in this example before proceeding.
From the Branch X switch, create a continuous ping to the VRRP IP address using the following command:
ping 192.168.10.100 repeat 100
Reply From 192.168.10.100: icmp_seq = 0. time= 1217 usec.
Reply From 192.168.10.100: icmp_seq = 1. time= 2117 usec.
Reply From 192.168.10.100: icmp_seq = 1. time= 1778 usec.
If the 100 pings conclude before completing these tests, simply reenter the ping command.
While the ping is running and receiving ICMP replies, enter the following commands into the Master (Main
Office – top switch) to stop ping replies.
51
VRF lite for Dell Networking N-Series | version 1.1
Note: This command does not stop any traffic other than ping replies.
config
interface vlan 10
no vrrp 1 accept-mode
The ping replies should stop immediately and scrolling of the CLI should pause. This shows that VLAN 10
traffic is only going through the top switch of the Main Office. If there were VLAN 10 traffic also going through
the bottom switch of the Main Office, the ping replies would continue to scroll as they were received from that
switch.
Reloading the Master (using the reload command) causes the Backup VRRP switch to become active and
the ping from Branch X to resume.
copy running-config startup-config
reload
Ping replies start again on the Branch X CLI session. This time the backup VRRP switch replies.
While still pinging, enter the no vrrp 1 accept-mode command to the Backup so that once again, the
ping replies and scrolling stops.
Once the Master completely reloads, it resumes as the Master VRRP switch and resumes sending replies to
Branch X.
Note: After running this test, be sure to double-check that both Main offices switches have the
mode turned on to enable subsequent pinging.
accept-
Finally, test the routing portion of the example by pinging VLAN 11 from Branch X. Branch X is not a member
of VLAN 11, but can reach it through the routing switches in the VRRP. Use the command
ping 192.168.11.1 to verify connectivity to the next hop.
52
VRF lite for Dell Networking N-Series | version 1.1
6
Route Leaking
Administrators can leak any static or dynamic route within a VRF to the default router using static route
commands. When there are multiple VRFs on a switch, one or more are often required to leak routes. Route
leaking usually involves an entire VRF subnet, but can be individual IP addresses if necessary. Route leaking
can leak routes from a VRF to the default router and vice versa, but not from one VRF to another. Since the
IP addresses used on each VRF in a physical switch may overlap, it is important not to leak the same subnet
or range of addresses from two separate VRFs to the default router. Doing so would cause duplicate IP
addresses on the network.
Borrowing the Simple VRF Example and corresponding configurations starting on page 8, notice the Main
Office switch configurations include two VRs configured on the Main Office switch. Branch A (VR1) consists
of two VLANs, 10 and 11. VLAN 10 is the Marketing department VLAN, which now requires access to the
internet and must therefore leak its subnet to the default router connected to the internet. For bi-directional
traffic, the default router must also leak a subnet (VLAN 30) to VR1.
Internet
Branch A
7
9
11
13
15
Te1/0/1
17
19
21
25
23
27
29
31
33
35
37
39
41
43
45
1
LNK 47 ACT
2
Stack No.
LNK
2
4
6
8
10
12
14
16
18
20
22
26
24
28
30
32
34
36
38
40
42
44
46
ACT
48 COMBO P
1
SFP+
2
Branch B
Default
VR2
VR1
Router
Te1/0/1
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK 23 ACT
2
Stack No.
LNK
24 COMBO P
LNK
ACT
LNK
ACT
1
SFP+
ACT
2
Dell N3024F
Dell N3048P
VLAN 30
VLAN 10
VLAN 20
Te1/0/9
Te1/0/1
Te1/0/15
1
3
5
7
9
11
13
15
17
19
21
LNK 23 ACT
2
4
6
8
10
12
14
16
18
20
22
24
LNK
Te1/0/2
VLAN 11
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK
Dell N3024F
Route Leaking
53
VRF lite for Dell Networking N-Series | version 1.1
ACT
1
SFP+
1
3
5
7
9
11
13
15
17
19
21
2
4
6
8
10
12
14
16
18
20
22
1
LNK 23 ACT
2
Stack No.
LNK
Te1/0/16
VLAN 21
LNK 23 ACT
24 COMBO P
Dell N4032F
ACT
10G SFP+ MODULE
Te1/0/1
2
Stack No.
ACT
2
LNK
Dell N3024F
24 COMBO P
1
SFP+
ACT
2
Te1/0/1
To illustrate this example, the Default Router configuration on the Dell N4032F (Main Office) switch must add
VLAN 30. Use the following commands on the switch to create the VLAN:
config
vlan 30
exit
interface vlan 30
ip address 192.168.30.1 /24
exit
interface tengigabitethernet 1/0/9
switchport access vlan 30
exit
Before adding the first route leak, show the current routes of VR1 (brancha) using the following command
from the Main Office switch:
show ip route vrf brancha
C
C
*192.168.10.0/24 [0/1] directly connected,
*192.168.11.0/24 [0/1] directly connected,
Vl10
Vl11
Use the following commands to apply a default route to the brancha VRF table:
ip route vrf brancha 192.168.30.0 /24 vlan 30
Verify that the brancha VRF table now includes the default route:
show ip route vrf brancha
C
C
L
*192.168.10.0/24 [0/1] directly connected,
*192.168.11.0/24 [0/1] directly connected,
*192.168.30.0/24 [1/0] via 0.0.0.0,
Vl30
Vl10
Vl11
Before adding the other route leak, show the current route of the Default Router using the following command
from the Main Office switch:
show ip route
C
*192.168.30.0/24 [0/1] directly connected,
Vl30
Use the following commands to add a brancha VRF route to the default routing table:
ip route 192.168.10.0 /24 vlan 10
Verify the default route has been added to the brancha VRF table:
show ip route
L
*192.168.10.0/24 [1/0] via 0.0.0.0,
Vl10
C
*192.168.30.0/24 [0/1] directly connected,
54
VRF lite for Dell Networking N-Series | version 1.1
Vl30
To validate the configurations, ping VLAN 30 from the Branch A top switch. (A successful ping test
validates the configuration.) The Branch A bottom switch on VLAN 11 should fail the ping.
Note: The VLAN 30 interface must be up for a successful ping. Be sure a cable is plugged into the port and
that the port is up when pinging.
55
VRF lite for Dell Networking N-Series | version 1.1
7
Reserving Routes
The number of routes is limited on each physical switch and all VRFs on that switch much share those routes.
The number of routes a VRF uses is not reserved by default and is distributed on a first come, first serve
basis, posing a risk that some VRFs may run out of routes. For this reason, routes may be reserved to one or
more VRFs so other VRFs cannot use them. The commands below limit route distribution used in cases
where vital VRFs with potentially large routing tables run the risk of running out of routes. When a VRF
reaches the max limit, OSPF enters stub router mode, which denies static routing.
Users can configure a warning message when a VRF reaches a specified percentage of routes. Example
commands below configure a limitation and warning from the Main Office switch. Use the show command to
view the current configuration.
Use the following command to reserve routes for a particular VR and configure a warning after distributing 80
percent (for this example) of that maximum number of routes:
ip vrf brancha
maximum routes 1000
maximum routes warn 80
Use the following command to display the reserved routes for a particular VR:
show ip vrf brancha
VRF Identifier......................
Description.........................
Maximum Routes......................
Threshold...........................
Warning-only........................
56
VRF lite for Dell Networking N-Series | version 1.1
2
1000
80%
TRUE
8
Troubleshooting
This section provides tips on how to help alleviate problems often encountered when configuring the network.
Note: If cutting and pasting the configurations provided in this document, successful pinging across the
network can sometimes take up to 20 seconds after pasting the final configuration.
Intermittent ping responses
If using out-of-band (OOB) ports to manage switches, and only a few pings are getting responses between
the top and bottom switches of the same branch (Branch A or Branch B), check to see if the management
subnet has a default gateway set. Data traffic may be getting confused when default gateways are set.
Remove the default gateway and retry pinging.
If the configuration requires a management default gateway, a shutdown/no shutdown of the Main Office ports
that connect to the branches allows use of the OOB ports. Then retry pinging between the top and bottom
branch switches.
Pinging issues immediately after pasting a configuration
If the configurations were copied and pasted into the corresponding switch CLI, allow up to 20 seconds after
pasting the final configuration before pinging across the network.
Branch A Connectivity Issues
Run the following commands from the N4032F (Main Office) switches to test proper setup and connectivity to
either of the Branch A switches. Use these commands when the test ping from the Branch A switch fails.
See the N-Series User Guide and CLI Guide for more information on how to use each of these commands.







57
To ping the brancha top switch enter:
ping vrf brancha 192.168.10.2
To trace the route to the top switch enter:
traceroute vrf brancha 192.168.10.2
To ping the brancha bottom switch enter:
ping vrf brancha 192.168.11.2
To trace the route to the bottom switch enter:
traceroute vrf brancha 192.168.11.2
To show VRF VLAN information enter:
show ip route vrf brancha
To show VRF interfaces and states enter:
show ip vrf interfaces
To show OSPF neighbors enter:
show ip ospf neighbor vrf brancha
VRF lite for Dell Networking N-Series | version 1.1
Branch B Connectivity Issues
Run the following commands from the N4032F (Main Office) switches to test proper setup and connectivity to
either of the Branch B switches. Use these commands when the test ping from the Branch B switch fails.
See the N-Series User Guide and CLI Guide for more information on how to use each of these commands.







58
To ping the branchb top switch enter:
To trace the route to the top switch enter:
To ping the branchb bottom switch enter:
To trace the route to the bottom switch enter:
To show VRF VLAN information enter:
To show VRF interfaces and states enter:
To show OSPF neighbors enter:
VRF lite for Dell Networking N-Series | version 1.1
ping vrf branchb 192.168.20.2
traceroute vrf branchb 192.168.20.2
ping vrf branchb 192.168.21.2
traceroute vrf branchb 192.168.21.2
show ip route vrf branchb
show ip vrf interfaces
show ip ospf neighbor vrf branchb
A
Additional Resources
Support.dell.com focuses on meeting your needs with proven services and support.
DellTechCenter.com is an IT Community where you can connect with Dell EMC customers and Dell EMC
employees to share knowledge, best practices, and information about Dell EMC products and installations.
Referenced or recommended Dell EMC publications:
B

Dell Networking Support
- http://www.dell.com/support

Dell TechCenter (community forums and blogs for Dell EMC customers)
- http://delltechcenter.com

Dell Networking Whitepapers
- http://en.community.dell.com/techcenter/networking/p/guides

Dell Networking N3xxx User Guides and Firmware downloads
- http://www.dell.com/support/home/us/en/19/product-support/product/networking-n3000series/drivers

Dell Networking N4xxx User Guides and Firmware downloads
- http://www.dell.com/support/home/us/en/19/product-support/product/networking-n4000series/drivers
Versions
This document was compiled using the following components and versions.
59
Component
Firmware Version
Dell Networking N3xxx series, N4xxx series
6.3.0.0 firmware
VRF lite for Dell Networking N-Series | version 1.1
C
Glossary of Terms
Access Layer: The access layer is the layer of the network used by end users and end user devices to connect to the
network.
Bandwidth: Bandwidth specifies the amount of data that can be transmitted in a fixed amount of time. Typically expressed
in bits per second or multiples of bits per second (bits/s, kbits/s, Mbit/s, Gbit/s).
BGP: Border gateway protocol is a standardized exterior gateway routing protocol designed to exchange routing information
between different host gateways, the internet or autonomous systems.
CLI (Command Line Interface): Text-based telnet, secure shell (SSH), or serial type interface that is used for issuing
commands to a device.
DHCP (Dynamic Host Configuration Protocol): A network management protocol used to dynamically assign network
settings to devices connected to a network.
LLDP (Link Layer Discovery Protocol): LLDP is a vendor neutral protocol used to obtain and share information about
neighboring equipment.
MAC Address (Media Access Control address): A MAC address is a hardware specific address that uniquely identifies
each node of a network. MAC addresses are assigned typically by the vendors of network interface controllers (NIC) and are
stored in the hardware.
MPLS: Multiprotocol label switching is a scalable, protocol-independent transport based on label switching.
Multi-instance: A design that uses separate software and hardware for each customer, group or tenant. This contrasts with
multi-tenancy designs.
Multi-tenancy: The principle that allows a single instance of software to operate on a device that services multiple groups,
with each group sharing the software and hardware device. In the case of a layer 3 switch running VRF lite, each group has
its own ports and configuration on the switch, allowing for isolation of data, private user management, and other reserved
functionality. This contrasts with multi-instance designs.
OSPF: Open shortest path first is a standardized interior gateway routing protocol and is based on link state routing algorithm
(Dijkstra’s algorithm) for finding the shortest path between nodes within an autonomous system.
Route Leaking: Allows a VRF instance to pass traffic to and from a default router on the same physical switch.
VLAN (Virtual local area network, or Virtual LAN): VLANs are logical subgroups that are partitioned off a physical network
in order to create separate broadcast domains.
VR: A virtual router that is created on a layer 3 switch or router that supports VRF lite. Multiple virtual routers can be created
on the device and each VR has its own routing table.
VRF (Virtual Routing and Forwarding): Allows a physical layer 3 switch/router to be partitioned into multiple Virtual Routers
(VRs). The control and data plane are isolated in each VR so that traffic does not flow across VRs, thus allowing multiple
routing tables to co-exist within the same physical L3 switch/router at the same time.
VRID: The number given to identify all virtual routers that belong to the same VRRP group. It is assigned at the VLAN
interface configuration CLI.
60
VRF lite for Dell Networking N-Series | version 1.1
VRF lite: The implementation of VRF without MPLS support.
VRRP: Virtual Router Redundancy Protocol. This protocol provides participating hosts one or more backup routes on the
network in case a route fails.
61
VRF lite for Dell Networking N-Series | version 1.1
Support and Feedback
Contacting Technical Support
Support Contact Information
Web: http://Support.Dell.com/
Telephone: USA: 1-800-945-3355
Feedback for this document
We encourage readers of this publication to provide feedback on the quality and usefulness of this
deployment guide by sending an email to Dell_Networking_Solutions@Dell.com
About Dell EMC
Dell EMC is a worldwide leader in data center and campus solutions, which includes the manufacturing and
distribution of servers, network switches, storage devices, personal computers, and related hardware and
software. For more information on these and other products, please visit the Dell EMC website at
http://www.dell.com.
62
VRF lite for Dell Networking N-Series | version 1.1
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising