What is a FBD? - Altair Connect

What is a FBD? - Altair Connect
What is a FBD?
A Free Body Diagram (FBD) is used to analyze the forces and moments acting on a body.
In HyperMesh, you can create or edit FBDs using several tools that display in the tab area.
Each FBD tool displays on a separate tab, which opens when you activate that tool.
Free Body Diagram (FBD) utilities facilitate the extraction and post-processing of Grid Point
Force (GPFORCE) results. FBD extractions are typically utilized for breakout and/or submodeling analysis schemes, where balanced "free body" sub-cases are extracted from a coarse
grid model and applied to a fine grid sub-model for eventual optimization and/or analysis. FBD
is also used to extract cross-sectional resultant forces and moments (typically at the centroid of
a cross-section) for use in traditional strength calculations.
What is Resultant Force & Moment?
The Resultant Force and Moment (RF&M) utility extracts grid point force (GPFORCE) data for
user-defined cross-sections created via the Cross-section Manager.
The Resultant Force and Moment utility generates input data for shear and moment (VMT)
diagrams and/or to perform load-case screening with Potato plots in HyperView. Two utilities
available within HyperGraph also interact with data generated from the Resultant Force and
Moment utility.
Results can be output to load collectors for graphical review, a text summary table, and/or a
formatted .csv file, which can be loaded into traditional spreadsheet software packages.
Defining Cross-Sections
The FBD Cross-section Manager (CSM) utility creates and manages cross-section definitions
that are used within the Resultant Force & Moment utility.
This utility contains tools for defining cross-sections, which are defined by an element set, node
set, summation node, and a local result coordinate system. It also features semi-automatic
generation of element and node sets for defining cross-sections.
The FBD Cross-section Manager interface has two creation methods available for crosssection definition: manual and (semi-) automatic. The Advanced options section provides the
means to semi-automatically create cross-section element and node sets for beam-like
Proprietary Information of Altair Engineering, Inc.
structures with regular meshes. This auto-create cross-section capability requires a continuous
mesh with rows of nodes (of any orientation) to work properly. The mesh shouldn’t have any
discontinuities (holes, gaps, etc…) and must have identifiable rows of nodes, starting from the
selected nodes and progressing along the length of the selected elements.
GPFORCE output request
The Grid Point Force Balance table is the data around which all FBD-Forces and Resultant
Force and Moment utility calculations are performed. This output must be requested from the
solver for the node set(s) of interest. This can be done via the Solver Browser (View à
Broswers àHyperMesh à Solver)
1.
In the Solver Browser right click on Global Options à Edit Options. This will launch
the Load Steps: Global Options dialog box.
2.
Under the Output Requests tab, find GPFORCE in the left window pane.
3.
Specify the format for the GPFORCE output. The Free Body tools in HyperMesh
support the following GPFORCE formats for the listed solvers:
•
Abaqus: .odb
•
Ansys: .rst
•
OptiStruct/Nastran: .op2
Note: The above steps requests GPFORCES for all loadsteps. The same steps can also be
followed if only a few loadsteps need to be considered. t
Proprietary Information of Altair Engineering, Inc
Exercise 11a: Create cross-section definitions for Spar2.
1.
Load the Model file, 11a-FBD-CROSS_SECTIONS.hm.
Cross-section definitions are determined by the following criteria:
•
An element set that contains the nodes that define the cross-section and
determines which "side" the resultant force and moment vectors are to be
calculated. Only elements connected to the nodes that define the cross-section,
on one side or the other, need to be included in the element set. However,
additional elements can be included for visualization purposes with no effect on
the calculations.
•
A node set that defines the cross-section geometry.
•
A summation node that can be any node in the model or that can be
automatically set to the calculated centroid of the defined cross-section.
Centroidal calculations are performed using nodal coordinates that make up the
cross-section only, hence element thicknesses associated with the elements
attached to the section are not considered. As such, there could be slight
differences in the calculated centroid and the "true" centroid of the section if
thicknesses vary throughout the section or the section is overly idealized.
•
(Optional) A result system that defines the coordinate system for which the
resultant force and moment vectors are transformed into and output for the
selected cross-section(s).
2.
Open the FBD Cross-section Manager by selecting Post > Free Body > CrossSection from the pull down menu.
3.
In the FBD Cross-section Manager panel, click the arrow for Advanced options to
display the Auto create cross-section form.
You will use this form to create cross-sections along the length of Spar2.
Resultant force and moment extractions will be performed on these cross-sections to
obtain the necessary data to generate shear moment diagrams and potato plots. There
are two options to define cross-sections: a manual method and an advanced method.
The advanced method automates the creation of "continuous" cross-sections. The
advanced method will be used in this tutorial. See the online help for details about the
manual method.
Proprietary Information of Altair Engineering, Inc.
4.
Click Elements twice, and then select all elements that make up Spar2.
5.
Click proceed.
6.
Click Nodes twice, select the left-top (Node 83) and left-bottom nodes (Node 84) which
define the first cross-section for Spar2.
7.
Click proceed.
8.
In the Element set prefix field, enter Spar2_E and in Node set prefix, enter Spar2_N.
Since the cross-section manager utility creates the necessary element and node sets,
you must define a prefix string for both element and node sets. This string will be
appended by an incremental number to give each created set a unique name. Optional
Proprietary Information of Altair Engineering, Inc
input includes numbering offset which defines an initial number for which the appended
set numbers will begin.
9.
Verify that the Sets accumulate box is selected.
10.
Click Accept.
The spreadsheet populates with the definitions of the cross-sections generated by the
Auto create cross-sections utility.
10.
Click Advanced options to close the Auto create cross-sections form.
11.
Select the Display sections check box and then select any section in the spreadsheet
to review the selected cross-section.
The graphics area will be updated with the element set, node set, sum node, and result
system that define the selected cross-section. Optionally, if you select the Show model
check box, the entire model will be visible in the graphics area with the selected crosssection highlighted in red and the remainder of the model transparent.
Proprietary Information of Altair Engineering, Inc.
12.
Select the first cross-section in the spreadsheet (Spar2_E1; Spar2_N1), hold SHIFT,
and select the last cross-section (Spar2_E8; Spar2_N9) to select the cross-sections for
updating their result system.
To update any single or multiple cross-sections, select the cross-sections from the
spreadsheet using CTRL/SHIFT and then select Summation Node or Result System to
update these definitions for all selected cross-sections.
13.
Click Result System twice.
14.
Select the system located at the left-middle end of Spar2 (system 102), and click
proceed.
Note: You may have to display the Longeron2 system collector from the Model Browser
(Model tab) to display system 102.
All cross-sections update to result system 102. Note that system 102 has the x-axis
along the length of the spar, y-axis located at the neutral axis of the beam in the plane of
the web, and z-axis perpendicular to the web of the beam. Also note that the sum node
is set to the default centroid, which automatically calculates the centroid of each crosssection and at which the resulting resultant force and moment calculations will be
performed. The result system is the system for which all resultant force and moment
result vectors will be transformed into and output.
15.
Click Close to exit the FBD Cross-Section Manager utility.
Proprietary Information of Altair Engineering, Inc
Exercise 11b: Extract resultant force and moment data for all cross-sections of Spar2 for
all load cases.
1.
Open HyperMesh and load the model file, 11b-RESULTANT-FORCE-MOMENT.hm.
2.
From the menu bar, select Post > Free Body > Resultant Force and Moment to open
the Resultant Force and Moment tab.
3.
From the .op2 file browser, select FBD.op2.
The selected .op2 file loads into the HyperMesh database for use with all FBD utilities
until another .op2 file is selected. It also populates the Subcases list box with all
subcases in the selected .op2 file that contain Grid Point Force (GPFORCE) data.
4.
In the Loadsteps list, select all the loadsteps using the filter buttons on the top of the list
box or with CTRL/SHIFT.
5.
In the Cross-sections list, select all Spar2 cross-sections previously defined using the
filter buttons on the top of the list box or with CTRL/SHIFT.
6.
Review the following table for a description of the Output options for the resultant force
and moment utility.
Function
Description
Coordinate System
Defines the coordinate system used for output of node
locations (x,y,z) only. The coordinate system does not affect
the transformation of the resultant force and moment vector
results, which is defined by the result system on each crosssection definition.
Zero tolerance
Defines any number less than this number is set to zero for
numerical issues.
Create load collectors
Creates load collectors containing the results of the resultant
force and moment calculations so that the results can be
visualized in the graphics area as force and moment vectors.
Show summary table
Brings up a window with formatted results similar to the .csv
(comma separated) file. Use this output for quick checks of the
data without having to open an alternative spreadsheet or text
editor program.
Create .csv file
Creates a .csv file with the results of the resultant force and
moment calculations, which can be opened directly within
standard spreadsheet applications.
Create .fbd file
Creates an .fbd file with the results of the resultant force and
moment calculations, which can be directly read into
HyperGraph to create shear moment diagrams and potato
plots.
7.
Click Coordinate system twice.
Proprietary Information of Altair Engineering, Inc.
8.
Select coordinate system 102 which is located at left-middle end of Spar2, and then click
proceed.
Note: You may have to display the Longeron2 system collector from the Model
Browser (Model tab) to display system 102.
9.
Set Zero tolerance to 0.01.
10.
Activate the Create load collectors check box and optionally select a default color for
the created load collectors.
11.
Activate the Show summary table check box.
12.
Activate the Create .csv file check box, and click select from list. (
) to select an
existing .csv file (append data) or enter a new file name; in this case, enter
res_force_moment.csv.
13.
Activate the Create .fbd file check box, and click select from list. (
) to select an
existing .fbd file (append data) or enter a new file name; in this case, enter
res_force_moment.fbd.
By default, files are put into the HyperMesh start directory unless you specify another
directory or enter a file name.
14.
Click Accept to execute the resultant force and moment calculations on all selected
cross-sections for all selected subcases.
The Resultant Force and Moment Output Summary window displays the resultant
force and moment calculations (see the following image). For each cross-section, there
is a separate data block grouped by loadstep. The data block contains cross-section
nodal forces, moments, and the sum of those nodal forces and moments about the
defined sum node, in this case the calculated centroid of the cross-section. Note that
the sum of the moment components (Mx, My, Mz) for each node is not the direct sum, as
the (rXF) terms for the force resultant vector about the sum node must also be added to
each moment component appropriately. The sum of the forces components (Fx, Fy, Fz)
for each node is, however, the simple sum.
Proprietary Information of Altair Engineering, Inc
15.
(Optional) Open the .csv (comma separated) file directly with Microsoft Excel by using
Windows Explorer and double-clicking the file, res_force_moment.csv.
This file contains the same results as the summary table in the previous image, but is
available for import into standard spreadsheet or text editor programs.
16.
(Optional) Open the .fbd file, res_force_moment.fbd, in any standard text editor program.
By default, files are put into the HyperMesh start directory unless you specify another
directory or enter a file name.
This file contains the same results as the summary table in the previous image, but in a
compact format for use with HyperGraph in generating shear moment diagrams and
potato plots of resultant force and moment data for various cross-sections.
17.
Click Close to exit the Resultant Force and Moment utility.
Vector review of the Resultant Force and Moment results in the graphics area is covered
in the next step.
Proprietary Information of Altair Engineering, Inc.
Exercise 11c (Optional): Use FBD Results Manager to review resultant force and moment
vectors in graphics area.
1.
If continuing from Exercise 1, proceed; otherwise open HyperMesh and load the model
file, 11c-FBD-RESULTS-MANAGER.hm.
2.
From the menu bar, select Post > Free Body Results Manager to open the FBD
Results Manager tab.
3.
Click Element Set twice.
4.
Click set, and select Spar2_E2.
5.
Click proceed.
6.
In the FDB Results Manager window, activate the Show model check box to display
the entire model with the selected element set highlighted in red and all other elements
transparent. This feature will help you easily locate the element set within the model.
7.
For Results type, select Resultant Force and Moment.
This operation scans the database for available loadsteps with resultant force and
moment results and populates the Loadsteps: list box.
8.
For Loadsteps, select SUBCASE1.
This operation scans the database for available node sets with resultant force and
moment results and populates the Node sets: list box.
9.
For Node sets, select Spar2_N3.
This operation will scan the database for available force and moment vector results and
will enable the check boxes for those force and moment vectors which are available.
10.
For Display options, select Fy (shear—the results coordinate system had y-axis in the
plane of the web) and Mz (principal bending moment—the results coordinate system had
z-axis perpendicular to the plane of the web).
To determine the result coordinate system applied to a given cross-section of interest,
use the FBD Cross-Section Manager to review the defined cross-section. This
operation will show the element set, node set, results system, and sum node defined for
the selected cross-section. Optionally, select other force components to review their
magnitude and direction in the graphics area. Single or multiple force and moment
vector results can be displayed in the graphics area to facilitate data mining and
reporting.
11.
(Optional) Select Update load collector color and select color to change the color of
the selected load vectors.
The new color setting applies only to the load components selected and is saved in the
database. Therefore, this option can be used to recolor any single or multiple load
vectors for any FBD result.
12.
Click Accept to visualize the resultant force and moment vectors in the graphics area.
13.
(Optional) Continue to review resultant force and moment vectors following Steps 2-14
for additional cross-sections.
14.
Click Reset to clear the display and reset the form.
15.
Click Close to exit FBD Results Manager.
Proprietary Information of Altair Engineering, Inc
Proprietary Information of Altair Engineering, Inc.
Exercise 11d: Extracting Free Body Diagrams from Global Loads Model and Transferring
to Detailed Model as Boundary Conditions – Submodeling Techniques
1.
Load the model file, 11d-FREE-BODY- DIAGRAM.hm.
2.
From the menu bar select Post > Free Body > Force to open the FBD Forces tab.
3.
From the .op2 file: browser, select FBD.op2.
The selected .op2 file loads into the HyperMesh database for use with all FBD utilities
until another .op2 file is selected. It also populates the Subcases list box with all
subcases in the selected .op2 file that contain Grid Point Force (GPFORCE) data.
4.
In the Loadsteps list, select SUBCASE 9, SUBCASE 11, SUBCASE 14, and SUBCASE
16, which are the critical subcases.(use Ctrl key + left mouse button for multi select).
5.
In the Entity selection area, click Element Set twice.
6.
Click set, then select the Spar2 element set.
7.
Click proceed.
Elements that represent Spar2 are now displayed in the graphics area. To turn on
element shading, click Shaded Elements and Mesh Lines (
)
8.
Go to the Model tab and under the System Collector turn on visualization for
Longeron2 (System 102) by selecting the icon to the left of Longeron2.
9.
Go back to the FBD Forces tab click Result System twice.
10.
Select the system located at the left-middle end of Spar2 (Longern2, system 102 turned
on in step 8), and click proceed.
The result system is the system for which all free body force and moment result vectors
will be transformed into and output.
Proprietary Information of Altair Engineering, Inc
11.
Click Summation Node twice, select the left-bottom node (node 84), and then click
proceed.
This summation node is the node for which all free body force and moment vector
results will be summed about to generate a single equivalent resultant force and moment
vector. Note that for a free body (all loads), the summation about any point must be
zero. Therefore, this feature is typically used to verify that the extraction produced a free
body with zero summation. However, if a free body other than (all loads) is performed,
the selection of the summation node can be used to determine the equivalent resultant
force and moment vector for the extracted free body (applied load only or reaction loads
only) which in general will not be zero and can be of interest.
12.
For FBD type, select All Loads.
13.
For Zero tolerance, type 0.01.
14.
Activate Create load collectors and optionally select a default color for the created load
collectors.
15.
Activate Show summary table.
16.
Activate Create .csv file, browse to the desired location, and type fbd_force.csv.
17.
Click Accept to execute the FBD forces calculations for all selected subcases.
The FBD Forces Output Summary window displays the FBD forces calculations (see
following image). There is a separate data block grouped by loadstep. The data block
contains free body nodal forces, moments, and the sum of those nodal forces and
moments about the defined sum node. Note that the sum of the moment components
(Mx, My, Mz) for each node is not the direct sum as the (rXF) terms for the force
Proprietary Information of Altair Engineering, Inc.
resultant vector about the sum node must also be added to each moment component
appropriately. The sum of the forces components (Fx, Fy, Fz) for each node is,
however, the simple sum. In addition, the sum for a Free Body – All Loads result
should be, and is, zero about any sum node selected. You can verify this with the SUM
line at the bottom of each data block. For other FBD types, however, the sum about the
sum node may or may not be zero, depending on the selections.
Proprietary Information of Altair Engineering, Inc
Exercise 11e: Use FBD Results Manager to review FBD force vectors in graphics area.
1.
Open HyperMesh and load the model file, 11e-FBD-RESULTS-MANAGER.hm.
2.
From the menu bar, select Post > Free Body Results Manager to open the FBD
Results Manager tab.
3.
Click Element Set twice.
4.
Click set, then check Spar2.
5.
Click select.
6.
Click proceed.
7.
(Optional) Activate the Show model check box to display the entire model with the
selected element set highlighted in red and all other elements transparent. This feature
will help you easily locate the element set within the model.
8.
For Results type, select FBD Forces – All Loads.
This operation scans the database for available loadsteps with FBD Forces – All Loads
results and populates the Loadsteps list box.
9.
For Loadsteps, select SUBCASE 9.
This operation will scan the database for available force and moment vector results and
will enable the check boxes for those force and moment vectors that are available.
10.
For Display options, select Fy (shear—the results coordinate system had y-axis in the
plane of the web).
To determine the result coordinate system applied to a given cross-section of interest,
use FBD Cross-Section Manager to review the defined cross-section. This operation
will show the element set, node set, results system, and sum node defined for the
selected cross-section. Optionally, select other force components to review their
magnitude and direction in the graphics area. Single or multiple force and moment
vector results can be displayed in the graphics area to facilitate data mining and
reporting.
11.
(Optional) Select Update load collector color and select color to change the color of
the selected load vectors.
The new color setting applies only to the load components selected and are saved in the
database. Therefore, this option can be used to recolor any single or multiple load
vectors for any FBD result.
12.
Click Accept to make visible the FBD force vectors in the graphics area.
13.
(Optional) Continue to review FBD Forces – All Load vector results following steps 6 –
13 for additional loadsteps and force/moment components.
14.
Click Reset to clear the display and reset the form.
15.
Click Close to exit the FBD Results Manager utility.
Proprietary Information of Altair Engineering, Inc.
Proprietary Information of Altair Engineering, Inc
Exercise 11f (Optional): Use FBD Export Manager to export FBD Forces to .fem file.
1.
Open HyperMesh and load the model file, 11f-FBD-EXPORT-MANAGER.hm.
2.
From the menu bar, select Post > Free Body Export Manager to open the FBD Export
Manger tab.
3.
Click Element Set twice.
4.
Click set, then select Spar2.
5.
Click proceed.
6.
For Results type, select FBD Forces – All Loads.
This operation scans the database for available loadsteps with FBD Forces – All Loads
results and populates the Loadsteps list box.
7.
For Loadsteps, select SUBCASE 9, SUBCASE 11, SUBCASE 14, and SUBCASE 16.
8.
Check the options for Create appropriate loadsteps, and for Output file, browse to the
desired location and enter spar2_fbd_forces.fem.
9.
Click Add to Export.
This operation turns on the display of all load collectors associated with the currently
selected FBD result type for all selected loadsteps. Additional loadsteps can be selected
and accepted, which will append to the current display on each click of accept. In
addition, a new element set or FBD result type can be selected and appended to the
current display on each click of accept. To clear the display click Reset.
10.
Click Export.
This operation will export the currently displayed loads and all other associated/required
cards to the output file selected. This file can subsequently be imported into another
HyperMesh database (typically called the detailed model) and the loads contained
therein can be "attached" to the structure of the detailed model as boundary conditions
with the addition of a rigid body constraint. This process will be carried out in the next
step.
11.
Click Reset.
This operation clears the current display.
12.
Click Close to exit the FBD Export Manager utility.
13.
(Optional) From the File menu, click Save as > Model and save the HyperMesh
database as fbd_final.hm.
14.
From the menu bar, select File, then Exit to exit HyperMesh.
Proprietary Information of Altair Engineering, Inc.
Exercise 11g (Optional): Import FBD forces from .fem file into detailed model and solve.
Step 1: Open the HyperMesh model and import the solver deck.
1. Load the model file, 11g-SPAR2.hm.
2. From the menu bar, select File > Import > Solver Deck to open the Import tab.
3. Sel the File type: to OptiStruct, and then browse for file spar2_fbd_forces.fem.
4. Click Import.
This operation imports the free body loads from the global model into the detailed model
of Spar2. The next process is to "attach" the free body loads to the detailed model,
perform some clean-up operations, define new loadsteps with the free body loads and a
rigid body constraint, and solve the detailed model. This process will be accomplished in
the remainder of this step.
Step 2: Equivalence nodes and delete TempMass component.
1. From the menu bar, select Mesh > Check > Nodes > Equivalence to go to the Edges
panel.
The nodes of the imported loads are equivalenced with those of the detailed model
which are overlaying each other as a consequence of importing the free body loads.
2. Toggle the selector from comps to elems.
3. Click elems >> displayed.
4. Click preview equiv.
Eighteen nodes should be found, one at each load.
5. Click equivalence to combine nodes that were imported and attached to the loads with
those that are a part of the detailed mesh of Spar2.
Note that when the detailed Spar2 mesh was constructed, attention to where these
interface nodes were located was taken into account by placing fixed points on the
surfaces at these locations. The fixed points maintain a node at that location from the
automesher and thus guarantee that a node will exist where a load is located. This
method is only one of several potential methods. Other options could include importing
the loads which do not line up with any other nodes in the detailed mesh and then
connecting the loads to the detailed mesh with R-type elements (RBE2 or RBE3).
Several other possibilities could also exist and best methods and practices should be
considered depending on the problem type.
6. Click return to exit the Edges panel.
7. Click Delete
to open the Delete panel.
8. Click comps.
9. Select TempMass.
10. Click select.
11. Click delete entity to delete the TempMass component entity.
12. Click return to exit the Delete panel.
Proprietary Information of Altair Engineering, Inc
Step 3: Define a rigid body constraint
1. On the Model tab, select the LoadCollector folder, right-click to bring up the context
sensitive menu, and select Hide to remove all loads from the graphics area.
2. First we need to create a load collector for the rigid body constraint definition. From the
menu bar, select Collectors > Create > Load Collectors to open the Create Load
Collector dialog box.
3. In the Name field enter Const.
4. Select the color red.
5. Set the Card Image to none.
6. Click Close.
Note: this operation sets the current load collector to the newly created Const load
collector. The current load collector is the collector which any newly created load
(constrains in this case) are placed into
7. Now let’s assign an analysis system to the nodes for which the rigid body constraint will
be applied. From the menu bar, select Mesh > Assign > Node Analysis System to go
to the Systems: Assign subpanel.
8. Select the three nodes highlighted in the following image.
9. Click system.
10. Select system 102 on left-middle end (x-axis along length, y-axis along web, z-axis
normal to web).
Note: You may have to display the Longeron2 system collector from the Model
Browser (Model tab) to display system 102.
11. Click set displacement.
12. Click return to exit the Systems panel.
13. Finally we will assign a constraint to left-bottom node. From the menu bar, select BCs >
Create > Constraints to go to the Constraints panel.
14. Select the left-bottom node shown in the image above.
Proprietary Information of Altair Engineering, Inc.
15. Select dof1, dof2, and dof3. Make sure all other dofs are unselected.
16. Click create.
17. Select the left-top node.
18. Select dof1 and dof3. Make sure all other dofs are unselected.
19. Click create.
20. Select the right-bottom node.
21. Select dof3. Make sure all other dofs are unselected.
22. Click create.
23. Click return to exit the Constraints panel.
Step 4: Update the loadsteps for all four free body load cases
1. From the main menu, select the Analysis page and then loadsteps to go to the
LoadSteps panel.
2. Click name = and select SUBCASE 9.
3. Toggle type to linear static.
4. Select SPC, click =, and select Const load collector.
5. Click update.
6. Repeat steps for SUBCASE 11, SUBCASE 14, and SUBCASE 16.
Step 5: Define the Control Cards needed
1. From the menu bar, select Setup > Create > Control Cards to go to the Control Cards
panel.
2. Click FORMAT.
3. For number_of_formats enter 2, and then hit ENTER on the keyboard.
There are now two FORMAT buttons.
4. Click each FORMAT button and set them to HM and OUTPUT2, respectively. This
specifies the output file formats for HyperMesh .res (HM) and .op2 which can be used in
HyperView to post-process the results.
5. Click return.
6. Select next and then click GLOBAL_OUTPUT_REQUEST.
7. Click DISPLACEMENT and STRESS.
8. Click return to request displacement output for both output formats.
9. Click return to exit the Control Cards panel.
Proprietary Information of Altair Engineering, Inc
Step 6: Save the model, run the analysis and post process the results.
1. From the menu bar, select File > Save As > Model, and save the model as
spar2_analysis.hm.
2. From the Analysis page, click OptiStruct to run the model.
3. For run options, toggle to analysis.
4. For export options, toggle to all.
5. If –optiskip appears in the options field, clear the field.
6. Click Optistruct to export the solver deck and run the analysis in OptiStruct using the
bulk data format.
7. Once OptiStruct finishes, click return to exit the OptiStruct panel.
8. In the Post menu, click Deformed panel and review the results of the analysis.
9. Click Simulation = and select SUB9 – PosShear PosMoment PosT.
10. Click data type = and select Displacements.
11. Click deform to produce the deformed shape of Spar2 in the graphics area for the
selected simulation.
12. Click return to exit the Deformed panel.
13. In the Post menu, click Contour to go to the Contour panel and review the results of
analysis.
14. Click Simulation = and select SUB9 – PosShear PosMoment PosT.
15. Click data type = and select Von Mises Stress.
16. Select the legend subpanel.
17. Toggle find maximum to maximum = and enter 100000.
18. Click contour to produce the contour plot in the graphics area.
19. (Optional) Continue to use the contour panel to review additional results.
Proprietary Information of Altair Engineering, Inc.
20. Click return to exit the Contour panel.
21. (Optional) From the menu bar, select File > Save > Model.
22. From the menu bar, select File > Exit to exit HyperMesh.
Proprietary Information of Altair Engineering, Inc
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement