CosmosScope Calculator Reference Manual

CosmosScope Calculator Reference Manual
CosmosScope™
Calculator
Reference Manual
Version Y-2006.06, June 2006
Saber is a registered trademark of SabreMark Limited Partnership and is used under license.
2
Copyright Notice and Proprietary Information
Copyright © 2006 Synopsys, Inc. All rights reserved. This software and documentation contain confidential and proprietary
information that is the property of Synopsys, Inc. The software and documentation are furnished under a license agreement and
may be used or copied only in accordance with the terms of the license agreement. No part of the software and documentation may
be reproduced, transmitted, or translated, in any form or by any means, electronic, mechanical, manual, optical, or otherwise, without
prior written permission of Synopsys, Inc., or as expressly provided by the license agreement.
Right to Copy Documentation
The license agreement with Synopsys permits licensee to make copies of the documentation for its internal use only.
Each copy shall include all copyrights, trademarks, service marks, and proprietary rights notices, if any. Licensee must
assign sequential numbers to all copies. These copies shall contain the following legend on the cover page:
“This document is duplicated with the permission of Synopsys, Inc., for the exclusive use of
__________________________________________ and its employees. This is copy number __________.”
Destination Control Statement
All technical data contained in this publication is subject to the export control laws of the United States of America.
Disclosure to nationals of other countries contrary to United States law is prohibited. It is the reader’s responsibility to
determine the applicable regulations and to comply with them.
Disclaimer
SYNOPSYS, INC., AND ITS LICENSORS MAKE NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH
REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
Registered Trademarks (®)
Synopsys, AMPS, Cadabra, CATS, CRITIC, CSim, Design Compiler, DesignPower, DesignWare, EPIC, Formality, HSIM,
HSPICE, iN-Phase, in-Sync, Leda, MAST, ModelTools, NanoSim, OpenVera, PathMill, Photolynx, Physical Compiler,
PrimeTime, SiVL, SNUG, SolvNet, System Compiler, TetraMAX, VCS, and Vera are registered trademarks of Synopsys,
Inc.
Trademarks (™)
Active Parasitics, AFGen, Apollo, Astro, Astro-Rail, Astro-Xtalk, Aurora, AvanTestchip, AvanWaves, BOA, BRT,
ChipPlanner, Circuit Analysis, Columbia, Columbia-CE, Comet 3D, Cosmos, CosmosEnterprise, CosmosLE,
CosmosScope, CosmosSE, Cyclelink, DC Expert, DC Professional, DC Ultra, Design Advisor, Design Analyzer, Design
Vision, DesignerHDL, DesignTime, Direct RTL, Direct Silicon Access, Discovery, Dynamic-Macromodeling, Dynamic
Model Switcher, EDAnavigator, Encore, Encore PQ, Evaccess, ExpressModel, Formal Model Checker, FoundryModel,
Frame Compiler, Galaxy, Gatran, HANEX, HDL Advisor, HDL Compiler, Hercules, Hercules-II, Hierarchical Optimization
Technology, High Performance Option, HotPlace, HSIMplus, HSPICE-Link, iN-Tandem, Integrator, Interactive Waveform
Viewer, i-Virtual Stepper, Jupiter, Jupiter-DP, JupiterXT, JupiterXT-ASIC, JVXtreme, Liberty, Libra-Passport, Library
Compiler, Libra-Visa, Magellan, Mars, Mars-Rail, Mars-Xtalk, Medici, Metacapture, Milkyway, ModelSource, Module
Compiler, Nova-ExploreRTL, Nova-Trans, Nova-VeriLint, Orion_ec, Parasitic View, Passport, Planet, Planet-PL,
Planet-RTL, Polaris, Power Compiler, PowerCODE, PowerGate, ProFPGA, ProGen, Prospector, Raphael, Raphael-NES,
Saturn, ScanBand, Schematic Compiler, Scirocco, Scirocco-i, Shadow Debugger, Silicon Blueprint, Silicon Early Access,
SinglePass-SoC, Smart Extraction, SmartLicense, Softwire, Source-Level Design, Star-RCXT, Star-SimXT, Taurus,
TimeSlice, TimeTracker, Timing Annotator, TopoPlace, TopoRoute, Trace-On-Demand, True-Hspice, TSUPREM-4,
TymeWare, VCS Express, VCSi, Verification Portal, VFormal, VHDL Compiler, VHDL System Simulator, VirSim, and
VMC are trademarks of Synopsys, Inc.
Service Marks (SM)
MAP-in, SVP Café, and TAP-in are service marks of Synopsys, Inc.
SystemC is a trademark of the Open SystemC Initiative and is used under license.
ARM and AMBA are registered trademarks of ARM Limited.
Saber is a registered trademark of SabreMark Limited Partnership and is used under license.
All other product or company names may be trademarks of their respective owners.
Printed in the U.S.A.
CosmosScope Calculator Reference Manual, Version: Y-2006.06
CosmosScope Calculator Reference Manual
Chapter 1.
Programmable Waveform Calculator ........................................ 1-1
Opening and Closing the Calculator .......................................................... 1-1
General Calculator Operation .................................................................... 1-2
Entering Operands ................................................................................ 1-3
Basic RPN Operation............................................................................. 1-3
RPN Mode Example ......................................................................... 1-4
Two Operand Example..................................................................... 1-5
One Operand Example ..................................................................... 1-6
Basic Algebraic Operation..................................................................... 1-6
Two Operand Algebraic Example .................................................... 1-7
One Operand Algebraic Example .................................................... 1-7
Performing Waveform Calculations ...................................................... 1-8
Wave Extended Operation Button................................................... 1-8
Entering Complex Numbers.................................................................. 1-9
Complex Number - RPM Mode - Example ...................................... 1-9
Complex Number - Algebraic Mode - Example............................. 1-10
Entering Vectors, Matrices, and Arrays ............................................. 1-10
VMA Example................................................................................. 1-10
Using Constants................................................................................... 1-11
Constants Example ........................................................................ 1-12
Programming the Calculator............................................................... 1-13
Calculator Menus................................................................................. 1-15
File Menu ........................................................................................ 1-15
Edit Menu ....................................................................................... 1-16
Preferences Menu ........................................................................... 1-16
Help Menu ...................................................................................... 1-17
CosmosScope Calculator Reference Manual
4
Calculator Icons .................................................................................. 1-17
Calculator Extended Operation Buttons ............................................ 1-18
Misc Button..................................................................................... 1-18
VMA Menu...................................................................................... 1-19
Wave Button ................................................................................... 1-19
Cmplx Button ................................................................................. 1-21
Logic Button.................................................................................... 1-21
Trig .................................................................................................. 1-22
Stack................................................................................................ 1-23
Calculator Keypad ............................................................................... 1-23
Calculator Computer Keyboard Operation ........................................ 1-24
Index ......................................................................................................... Index-1
5
CosmosScope Calculator Reference Manual
Chapter
1
Programmable Waveform Calculator
The Programmable Waveform Calculator operates as an RPN (Reverse Polish
Notation) calculator or as an algebraic calculator. The calculator allows you to
perform operations on AIM language expressions and waveforms as well as on
numbers. The calculator can be programmed to perform custom operations or
a series of operations.
Opening and Closing the Calculator
The Calculator icon shown below is located in the Tool bar at the bottom of the
work surface.
To open or close the calculator
• Single click on the icon with the left mouse button.
CosmosScope Calculator Reference Manual
1-1
Chapter 1: Programmable Waveform Calculator
General Calculator Operation
The Programmable Waveform Calculator shown below is a resizable window
consisting of a Pulldown menu bar, an Icon bar, an Entry field, a Stack Register
display, Extended Operation buttons, and a basic calculator keypad.
Pulldown Menus
Icon Bar
Entry Field
Stack Display
Programmable Buttons
Extended Operation Buttons
Keypad
1-2
CosmosScope Calculator Reference Manual
General Calculator Operation
Entering Operands
The calculator keypad, your computer keyboard, and your computer numeric
keypad can all be used to input operands.
The Entry field is where numbers or waveforms appear and are evaluated
before being pushed onto the Stack Display. The contents of the Entry field are
always the same as that of the X-register.
The Stack Display is a scrollable list box that displays the stack registers.
There is no limit to the number of stack registers.
To copy any register onto the X-register
• Single click on the register with the left mouse button, and then single
click the middle mouse button.
Basic RPN Operation
The calculator is in rpn mode when the Input Mode icon displays rpn and the
enter button is visible in the lower right hand corner. Calculations are
executed after the operands have been entered onto the stack.
The X-register and the
Y-register
In RPN mode, the contents of the X-register and
the Y-register are not always displayed in the
same locations.
RPN Mode Example
Two Operand Operation
Two operand operations are performed on the
contents of the X-register and Y-register.
Two Operand Example
One Operand Operation
One operand operations are performed on the
contents of the X-register only.
One Operand Example
CosmosScope Calculator Reference Manual
1-3
Chapter 1: Programmable Waveform Calculator
RPN Mode Example
For example, the X-register will be the Entry field if only one operand has been
input and the Enter button has not been pressed.
Input 25
(The Entry field is the
X-register)
The X-register will be the Entry field and register one in the Stack Display if
only one operand has been input and the Enter button has been pressed.
Press enter
(The Entry field and
register one are the
X-register)
The X-register will be the Entry field, and the Y-register will be register one, if
a second operand is input and the Enter button has not been pressed.
input 6
(6 is the X-register, 25 is
the Y-register.)
The X-register will be the Entry field and register one in the Stack Display, and
the Y-register will be register two, if a second operand is input and the Enter
button has been pressed.
Press enter
(The Entry field and
register one are the
X-register, register two is
the Y-register)
1-4
CosmosScope Calculator Reference Manual
General Calculator Operation
Two Operand Example
For example, to calculate 25 - 6, execute (y - x) by following these steps:
Input 25
(25 is displayed in the
Entry field)
Press enter
(25 is pushed onto register
one)
input 6
(6 is displayed in the Entry
field)
Press (The subtraction operation
is performed on the two
operands and the result is
pushed onto register one)
CosmosScope Calculator Reference Manual
1-5
Chapter 1: Programmable Waveform Calculator
One Operand Example
For example, to calculate the inverse of 25 (=1/x), follow these steps:
Input 25
(25 is displayed in
the Entry field)
Press 1/x
(The inversion
operation is
performed on the
operand, and the
result is pushed
onto the X-register)
Basic Algebraic Operation
The calculator is in algebraic mode when the Input Mode icon displays alg, and
the = button is visible in the lower right hand corner of the keypad.
Calculations are executed after the = button is pressed.
1-6
Two Operand Operation
Two operand operations are performed in the
Entry field.
Two Operand Algebraic Example
One Operand Operation
One operand operations are performed in the
Entry field.
One Operand Algebraic Example
CosmosScope Calculator Reference Manual
General Calculator Operation
Two Operand Algebraic Example
For example, to calculate 25 - 6, follow these steps:
Input 25-6
(25-6 is displayed in the
Entry field)
Press =
(The subtraction operation
is performed in the Entry
field, and the result is
pushed onto the
X-register)
One Operand Algebraic Example
For example, to calculate the inverse of 25, follow these steps:
Press 1/x
(The operation with an
open bracket is displayed
in the Entry field)
Input 25
(25 is placed in the
operation bracket)
Press =
(The brackets are closed,
the inversion operation is
performed on the Entry
field, and the result is
pushed onto the
X-register)
CosmosScope Calculator Reference Manual
1-7
Chapter 1: Programmable Waveform Calculator
Performing Waveform Calculations
Calculations can be performed on waveforms as well as on numbers. Multiple
waveforms can be pasted into the calculator.
In rpn input mode, multiple waveforms will be pushed onto the stack, one
waveform per register. In alg mode, the waveforms will be pasted sequentially
in the Entry field.
The results of these calculations can be plotted in an open graph window by
single clicking on the Graph icon.
NOTE
When any previously graphed waveform is updated due
to an automatic plot action (such as Append) specified
in an analysis, all waveforms created by the calculator
that depend on that waveform are updated at the same
time.
To paste a waveform onto the Entry field
• Select the waveform in the Signal Manager or from a graph region.
• Place the mouse cursor in the Entry field, and single click the middle
mouse button.
To change the color of the waveform display
• Use the Preferences > Waveform Color menu item.
Wave Extended Operation Button
The Wave Extended Operation button contains menu items that only perform
operations on waveforms.
The FFT, IFFT, Limit X Range, Limit X and Y Range, Change X and Y View, Sample X
Axis, Histogram, Extract Member, and Swap Parameters menu items open dialog
boxes. Detailed instructions for filling out these dialog boxes are available by
pressing the Help button in each respective dialog box.
Invoking the following functions will cause the corresponding abbreviations to
appear in brackets [ ] in the Entry field:
1-8
Limit to finite values
[finitelimit ]
f(x)
[yvsx ]
Swap X and Y Axes
[xyswap ]
Reduce dimension
[flatten ]
CosmosScope Calculator Reference Manual
General Calculator Operation
The name of the file to be acted upon by the function must be placed within
the brackets, followed by a space, immediately after the function name. For
example, if the waveplot file is named filt_out, then in order to apply f(x) to
filt_out, first choose f(x) on the Wave menu, and then place filt_out in the
brackets, as follows:
[yvsx filt_out]
Entering Complex Numbers
Complex numbers are input in a different manner from natural numbers and
waveforms.
RPN Mode
In rpn mode, complex numbers can be entered into
the calculator by using the letter j after the
imaginary portion, or by using the j or complex
items from the Cmplx extended operation button.
Complex Number - RPM Mode - Example
Algebraic Mode
In algebraic mode, complex numbers can be
entered as a numeric string.
Complex Number - Algebraic Mode - Example
Complex Number - RPM Mode - Example
For example, to enter the complex number (25 + 2j), follow these steps:
Input 25, and Enter
(The real number 25 is
pushed onto the
X-register)
Input 2j+
or
Input 2, and then choose
complex from the Cmplx
menu
(The complex number 25 +
2j is pushed onto the
X-register)
CosmosScope Calculator Reference Manual
1-9
Chapter 1: Programmable Waveform Calculator
Complex Number - Algebraic Mode - Example
For example, to enter the complex number (25 + 2j), enter the numbers and
text followed by entering the equals sign (=). The number will be pushed onto
the X-register.
Entering Vectors, Matrices, and Arrays
Vectors, matrices, and arrays (vmas) are input in a different manner from that
of natural numbers and waveforms.
A vma can be entered into the calculator by using the AIM vma command. (For
details on this command refer to the AIM Command Reference Manual.)
Generally, the command is used in the following manner:
[vma vma_type list {vma values}]
vma type can be vector, matrix, diag, array3, array 4, -datatype complex,
-datatype real, or waveform.
vma values are the list of numbers that make up the vma. Each number must
be separated by a space.
The vma calculator operations are available under the Misc button with the
vma menu item. For details on these vma operations, refer to the AIM
Command Reference Manual.
VMA Example
For example, to calculate the average of 0, 1, 2, 3, 4, 5, 6, 7, 8,and 9 follow
these steps.
Input the vma string exactly
as shown on the right.
Press enter
(The vma string is converted
to an AIM representation
and pushed onto the
X-register).
1-10
CosmosScope Calculator Reference Manual
General Calculator Operation
Input the vma string exactly
as shown on the right.
Choose Misc >
vma > mean
(The average of the vector is
pushed onto the X-register).
Using Constants
The calculator provides a Constants dialog box containing a list of
mathematical and physical constants. You can also create your own set of
constants. The icon for constants is
.
To open the Calculator Constants dialog box
• Single click on the Constants icon. Mathematical constants are listed
under the math tab, physical constants are listed under the physical tab,
and any user created constants are listed under the user tab.
For additional information about any constant
• Select the constant with a single click and press the calculator Help
button.
To input a constant into the calculator
• Double click on the constant, or select the constant with a single click,
and press the OK button.
To create a User Constant
• Click on the User tab to display the User tab form.
• Single click the Add button. The Add User Constant dialog box opens
with instructions for creating a user constant with a custom Help
message.
The format for adding a constant is the constant name, constant value,
and a brief description of the constant (or whatever you choose to put in
the help text string).
(<name>=<value>;<help_text>).
CosmosScope Calculator Reference Manual
1-11
Chapter 1: Programmable Waveform Calculator
To save user-defined constants between sessions
• Click on the Cancel button to save your constant and close the Constants
dialog box.
• User-defined constants are treated as preferences. You must use the File
> Preferences > Save item.
To Delete a User Constant
• Select the constant and single click the Remove button.
Constants Example
To create a constant for the number of electrons in a coulomb (6.24 x
10 18 )
• Single click on the Add button.
• In the dialog box type the following:
coulomb=6.24E18;number of electrons
in a coulomb
• Single click the OK button to add the constant to the User list.
• Selecting the constant and clicking on the calculator Help button will
display the following:
coulomb: 6.24E+18, number of electrons
in a coulomb
1-12
CosmosScope Calculator Reference Manual
General Calculator Operation
Programming the Calculator
Buttons P1 through P6 can be programmed with user-defined menus
containing user-defined operations. These programmable buttons function
like the Extended Operation buttons. Each programmable button can contain
as many operations as you desire.
You can program or edit menus in the programmable buttons by using Edit
User Function dialog box.
To access the Edit User Function dialog box
• Click on the Function icon
located on the icon bar; or, use the File >
Add Function menu item.
To add a User Function
• Type in a new function name in the Name field.
• Input the operation you want the menu item to perform in the Equation
field. Operations must be written in the AIM language.
Valid equation examples are given below:
sin($x)
sin($x)+cos($x)
sin($x)+cos(exp($y))
deriv(log($x-$z-$signal))
$var1 + $var2
[Measure:Frequency $wf]+20
13/27
Your equations should adhere to the format of these examples.
CosmosScope Calculator Reference Manual
1-13
Chapter 1: Programmable Waveform Calculator
The dollar sign indicates an input to the function. Any number of inputs
may be specified. Any combination of letters and numbers may be used
for input names.
You may use any available AIM math function. AIM procedures may
also be used, as the [Measure:Frequency $wf]+20 example shows,
providing the procedure returns a number or a waveform.
• Choose the location of your new menu item in the Menu field. You can
place a new menu item under any button from P1 through P6. You can
also place multiple menus under a single button.
• Press the Add button to add the item to the calculator.
To save user-defined functions between sessions
• Press the Close button to save your information and exit the Edit User
Functions dialog box.
• User-defined functions are treated as preferences. You must use the File
> Preferences > Save item.
To close the dialog box without saving your program
• Press the Cancel button.
To delete a function
• Press the Remove button.
To edit an existing function
• Single click on the down arrow at the right of the Name field in the Edit
User Functions dialog box. A list of functions will be displayed.
• Select the function you would like to edit.
• Make changes in the Name and Equation fields or P1 - P6 buttons as
necessary
• Click on the Add and Close buttons to save changes.
1-14
CosmosScope Calculator Reference Manual
General Calculator Operation
Calculator Menus
File Menu
Allows you to manage preferences, add functions,
save waveforms to a file, and close the calculator.
Edit Menu
Cuts, copies and pastes items between the graph
window and the Entry field.
Preferences Menu
Allows you to select rpn or alg Input Mode, type of
display, degree of precision, operand numeric base,
and waveform color.
File Menu
Menu Item
Description
Preferences > Save
Saves precision, mode, constants and user
functions.
Preferences > Restore
Restores the previously saved set of preferences.
Preferences > Default
Sets preferences to default values:
precision = 6
mode = rpn,
notation = engineering,
base = decimal,
waveform color = blue.
User defined constants and functions are
retained.
Add Function
Opens the Add Function dialog box.
Save X
Saves the waveform in the X-register to a file.
Save Selected
Saves the selected waveforms in the stack display
to a file.
Save All
Saves all waveforms in the stack display to a file.
Close Window
Closes the calculator.
CosmosScope Calculator Reference Manual
1-15
Chapter 1: Programmable Waveform Calculator
Edit Menu
Menu Item
Description
Cut
Removes a selected object and moves it into
the clipboard.
Copy
Copies a selected object into the clipboard.
Paste
Pastes whatever is in the clipboard into the
Entry field.
Preferences Menu
1-16
Menu Item
Description
rpn
Converts to Reverse Polish Notation calculator
operation.
algebra
Converts to Algebraic calculator operation.
degrees
Performs trigonometric calculations in degrees.
radians
Performs trigonometric calculations in radians.
grads
Performs trigonometric calculations in grads.
engineering
Displays operands in engineering notation.
scientific
Displays operands in scientific notation.
fixed point
Displays operands in fixed decimal point
notation.
Precision >
Sets the number of digits displayed for floating
point numbers.
decimal
Displays operands as base 10.
octal
Displays operands as base 8.
hexadecimal
Displays operands as base 16.
Waveform Color ...
Opens the Draw Color Editor dialog box to
allow the customizing of waveform color.
CosmosScope Calculator Reference Manual
General Calculator Operation
Help Menu
Menu Item
Description
Help on Calculator
Opens online documentation.
About AimCalc
Displays the AimCalc version and copyright
information.
Calculator Icons
Icon
Description
Graph
Pastes the contents of the X-register into the active
graph window.
Up
Rolls the stack up by one register. The X-register
moves to the bottom of the stack, and the Y-register
moves to the top of the stack.
Down
Rolls the stack down by one register. The bottom
register moves to the top of the stack, and the
X-register contents are pushed onto the Y-register.
X:Y
Swaps the X and Y registers.
Clear X
Clears the X-register. The Y-register contents are
pushed onto the X-register.
Constants
Displays the Constants dialog box.
Add Function
Opens the Add User Function dialog box.
Input Mode
Toggles between Reverse Polish Notation calculator
operation and Algebraic calculator operation.
CosmosScope Calculator Reference Manual
1-17
Chapter 1: Programmable Waveform Calculator
Icon
Description
Trigonometric Mode
Toggles between degrees, radians, and grads for
trigonometric operations (RPN mode only).
Calculator Extended Operation Buttons
Misc Button
Performs various mathematical operations as well as
vector and matrix array operations.
vma Menu
Performs vector, matrix, and array operations. This
menu is selected from Misc button options.
Wave Button
Performs waveform operations.
Cmplx Button
Performs complex number operations.
Logic Button
Performs logical operations.
Trig Button
Performs trigonometric operations.
Stack Button
Manages the stack registers.
Misc Button
Operation
Description
abs
The absolute value of the X-register.
mod
x modulo y.
fmod
Floating point x modulo y.
ceil
Rounds off floating point values to the next highest integer.
floor
Rounds off floating point values to the next lowest integer.
round
Rounds off floating point values.
hypot
The square root of the sum of the square of the X-register and
the square of the Y-register.
vma
Opens Vector/Matrix/Array menu.
1-18
CosmosScope Calculator Reference Manual
General Calculator Operation
VMA Menu
Operation
Description
vmax
Returns the largest value of all of the elements in a vma
argument.
vmaxi
Returns the index for the largest value of all of the
elements in a vma argument.
vmin
Returns the smallest value of all of the elements in a vma
argument.
vmini
Returns the index for the smallest value of all of the
elements in a vma argument.
mean
Returns the mean value of all of the elements in a vma
argument.
sum
Returns the sum of all of the elements in a vma
argument.
var
Returns the computed sample variance of all the elements
in a vma argument.
variance
Returns the biased variance of all the elements in the
vma argument.
specvariance
Returns the spectral variance of all the elements in a
vector vma argument. The argument is assumed to be the
result of a Fourier transform.
Wave Button
Operation
Description
FFT
Opens the Fast Fourier Transform dialog box.
IFFT
Opens the Inverse Fast Fourier Transform dialog box.
Swap X and Y Axes
Swaps the x and y axes of the waveform in the
X-register.
Limit X Range
Limits the range of the x axis of the waveform in the
X-register.
CosmosScope Calculator Reference Manual
1-19
Chapter 1: Programmable Waveform Calculator
Operation
Description
Limit X and Y Range Limits the range of the x and/or y axes of the
waveform in the X-register.
1-20
Limit to Finite
Values
Limits the range of the x and/or y axes of the
waveform to finite values.
Change X and Y
View
Applies a view transform to the x and/or y axes of the
waveform in the X-register
Sample X Axis
Applies X-sampling to the waveform in the X-register.
f(x)
Creates a parametric function of y1 vs y2, with X as the
parameter for waveforms in the X-register and
Y-register.
Histogram
Converts the waveform in the X-register to a
histogram.
Extract Member
Extracts a single member from a multi-member
waveform in the X-register.
Swap Parameters
Swaps the waveform parameter order of the waveform
in the X-register.
Reduce Dimension
Reduces the dimension of the waveform in the
X-register by 1.
Group Delay
Creates a new waveform displaying Group Delay time.
Phase Delay
Creates a new waveform displaying Phase Delay time.
Concat
Takes the waveform in the X register and concatenates
it to the waveform in the Y register. If the waveforms
have the same name, the resulting waveform also has
that name. If the waveforms have different names, the
resulting waveform is named concat.
CosmosScope Calculator Reference Manual
General Calculator Operation
Cmplx Button
Operation
Description
J
Places a “j” onto the X-register to indicate a complex
number.
complex
Creates a complex number with the X-register as the
real part, and the y register as the imaginary part.
real
Places the real part of a number or waveform onto the
X-register.
imag
Places the imaginary part of a number or waveform
onto the X-register.
mag
Absolute magnitude.
db
Decibels.
phase
Phase of the X-register, always in radians, limited to
values between 0 and 2π.
cphase
Phase of the X-register, always in radians, with
unlimited bounds.
phasedeg
Phase of the X-register, always in degrees, limited to
values between 0 and 360.
cphasedeg
Phase of the X-register, always in degrees, with
unlimited bounds.
conjugate
Complex conjugate of the X-register.
polar
Converts a complex number to polar notation.
Logic Button
Operation
Description
y or x
OR the X and Y-registers (bitwise operation).
y and x
AND the X and Y-registers (bitwise operation).
y xor x
Exclusive OR the X and Y-registers (bitwise
operation).
not x
NOT the X-register (bitwise operation).
CosmosScope Calculator Reference Manual
1-21
Chapter 1: Programmable Waveform Calculator
Operation
Description
y<<x
Left shift the Y-register by the number of bits in the
X-register.
y>>x
Right shift the Y-register by the number of bits in the
X-register.
y<x
The X-register is set to 0 if the X-register is less than
the Y-register. Otherwise, it is set to 1.
y<=x
The X-register is set to 0 if the X-register is less than
or equal to the Y-register. Otherwise, it is set to 1.
y>x
The X-register is set to 0 if the X-register is greater
than the Y-register. Otherwise, it is set to 1.
y>=x
The X-register is set to 0 if the X-register is greater
than or equal to the Y-register. Otherwise, it is set to 1.
Trig
1-22
Operation
Description
sin
Sine of the X-register.
cos
Cosine of the X-register.
tan
Tangent of the X-register.
asin
Inverse sine of the X-register.
acos
Inverse cosine of the X-register.
atan
Inverse tangent of the X-register.
atan2
Inverse tangent of the X-register divided by the Y-register.
sinh
Hyperbolic sine of the X-register.
cosh
Hyperbolic cosine of the X-register.
tanh
Hyperbolic tangent of the X-register.
CosmosScope Calculator Reference Manual
General Calculator Operation
Stack
Operation
Description
Clear All
Clear all registers.
Clear Selected
Clear selected stack registers.
Clear X
Clear the first stack register.
Rename X
Rename the item in the X-register
Copy X
Copy waveform in the X-register. Specify new axis names
and units of scale.
Swap X and Y
Swap the first two stack registers.
Roll Up
Roll the stack up one register.
Roll Down
Roll the stack down one register.
Calculator Keypad
Button
Description
integ
Integrate the X-register.
deriv
Differentiate the X-register.
eex
Exponent 10x.
(
Left parentheses.
)
Right parentheses.
,
Comma, for multi-argument functions.
exp
Natural exponential.
lnx
The natural logarithm of the X-register.
/
The Y-register divided by the X-register.
10^x
The X-register raised to the power 10.
log10
Base 10 logarithm of the X-register.
*
The X-register multiplied by the Y-register.
x^2
The X-register squared.
CosmosScope Calculator Reference Manual
1-23
Chapter 1: Programmable Waveform Calculator
Button
Description
sqrt
The square root of the X-register.
+
The X-register plus the Y-register.
pow
The Y-register raised to the power of the X-register.
1/x
1 divided by X.
+/-
Change the sign of the X-register.
.
Decimal point.
-
The Y-register minus the X-register.
close
Close the calculator.
pi
Enter the value of π (3.14159266535898) onto the X-register.
<-
Backspace one character in the Entry field.
enter
In RPN mode only, evaluate the X-register and push the result
onto the stack.
=
In algebraic mode only, evaluate the X-register and push the
result onto the stack.
Calculator Computer Keyboard Operation
Many calculator operations can be performed from your computer work
station keyboard.
Key
Description
Return
Enter
Evaluates the X-register.
Numeric Keypad
Enters numerals and operands.
Up Arrow
Rolls the stack up.
Down Arrow
Rolls the stack down
Left Arrow
Moves the cursor to the left.
Right Arrow
Moves the cursor to the right.
Escape
Functions like the Cancel button in forms.
Help
Functions like the Help button in forms.
1-24
CosmosScope Calculator Reference Manual
General Calculator Operation
Key
Description
F1
Functions like the Help button in forms.
Tab
Moves to the next field in a form.
Delete
Clears selected register.
Back Space
Backspaces one character in the Entry field.
CosmosScope Calculator Reference Manual
1-25
Chapter 1: Programmable Waveform Calculator
1-26
CosmosScope Calculator Reference Manual
Index
B
Basic Algebraic Operation 1-6
Basic RPN Operation 1-3
L
Logic Button 1-21
M
C
Calculator Computer Keyboard
Operation 1-24
Calculator Extended Operation
Buttons 1-18
Calculator Icons 1-17
Calculator Keypad 1-23
Calculator Menus 1-15
Cmplx Button 1-21
Complex Number - Algebraic Mode Example 1-10
Complex Number - RPM Mode Example 1-9
Constants Example 1-12
Misc Button 1-18
O
One Operand Algebraic Example 1-7
One Operand Example 1-6
Opening and Closing the Calculator
1-1
P
Performing Waveform Calculations
1-8
Preferences Menu 1-16
Programming the Calculator 1-13
E
Edit Menu 1-16
Entering Complex Numbers 1-9
Entering Operands 1-3
Entering Vectors, Matrices, and
Arrays 1-10
R
RPN Mode Example 1-4
S
Stack 1-23
F
T
G
Trig 1-22
Two Operand Algebraic Example 1-7
Two Operand Example 1-5
File Menu 1-15
General Calculator Operation 1-2
H
U
Using Constants 1-11
Help Menu 1-17
CosmosScope Calculator Reference Manual
Index-1
Index
V
VMA Example 1-10
VMA Menu 1-19
W
Wave Button 1-19
Wave Extended Operation Button 1-8
Index-2
CosmosScope Calculator Reference Manual
BOOKSHELF
OVERVIEW
Saber® Examples User Guide
DESIGN - GENERAL
Saber® Sketch User Guide
Saber® Parts Gallery Reference Manual
Saber® Property Editor Reference Manual
DESIGN - SPECIFIC
Saber® Harness Quick Start
Saber® Harness User Guide
Saber® Sketch iQBus User Guide
SIMULATION
Saber® Quick Start
Saber® User Guide
Saber® Simulator Command Reference Manual
Saber® Simulator Guide Reference Manual
Saber® HDL Command Reference Manual
Saber® Netlist Options Reference Manual
Saber® Simulator Real Time (RT) Interface
User Guide
Synopsys Online Documentation
Y-2006.06
ANALYSIS
CosmosScope™ Reference Manual
CosmosScope™ MATLAB® Interface User Manual
Saber® Simulator Testify Quick Start
Saber® Simulator Testify User Guide
UTILITIES
CosmosScope™ Calculator Reference Manual
Saber® and CosmosScope™ Command Line Tool
User Guide
Saber® and CosmosScope™ Draw Tool User Guide
Saber® and CosmosScope™ Hotkeys User Guide
Saber® and CosmosScope™ Macro Recorder
User Guide
Saber® and CosmosScope™ Report Tool
Reference Manual
Saber® and CosmosScope™ StateAMS
Reference Manual
Saber® Design Browser Tool Reference Manual
Saber® Model Architect Tool User Guide
MODELING AND MODEL LIBRARIES
Saber® Library and Model User Guide
Saber® Managing Symbols and Models User Guide
Synopsys Online Documentation
Y-2006.06
Saber® MAST Language Reference Manual
Saber® MAST Language, Book 1, User Guide
Saber® MAST Language, Book 2, User Guide
AIM FOR CUSTOMIZATION
Saber® and CosmosScope™ AIM User Guide
Saber® AIM Reference Manual
INTEGRATION WITH THIRD-PARTY PRODUCTS
Saber® Frameway for Cadence Design
Framework II User Guide
Saber® Frameway for Mentor Graphics ePD
User Guide
Saber® Frameway for Mentor Graphics Falcon
Framework User Guide
Saber® Frameway Integrations Quick Start
Saber® Simulator Co-Simulation with ModelSim
Quick Start
Saber® Simulator Co-Simulation with ModelSim
User Guide
Saber® Simulator Co-Simulation with Verilog
User Guide
Saber® Simulink Co-Simulation Interface
User Guide
Synopsys Online Documentation
Y-2006.06
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement