Ion-editor User Manual
Copyright © 2008-2012 HyperSynth
www.HyperSynth.com
Rev 6.0
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
Table of Contents

Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Registration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 03)

Setting Up MIDI Connection. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Quick Start . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 06)

Request Patch . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 07)

Sysex Tools Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 07)

Tool Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
(Page 09)

Preset Manager . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
(Page 10)

Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .(Page 11)

Shortcut keys and Tips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 11)

MIDI Learn . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 12)

Wii Remote . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 12)

Appendix A - MIDI Implementation Chart . . . . . . . . . . . . . . . . . . .

Appendix B - MIDI CC Tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 14)

About ION/Micron OS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . (Page 16)
(Page 03)
(Page 04)
(Page 13)
2
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Installation
1) Right Click on the zip file “ion-editor_vX.X.zip” and select “Extract All” or “Extract here”. (Note:
you will receive instructions about how to download this file after ordering)
2) Move ion-editor_vX.X folder to your VST folder. (You must move the entire folder containing all
its files, if you only copy *.dll file the editor will not work properly)
How to run VST plug-in?
You need a VST host program to run a VST plug-in. After the installation the plug-in must appear in the
"instruments" menu of your host. If you need further information about adding plug-ins in your host please
take a look at the handbook of your host program.
How to run Standalone version?
Simply click on ion_editor_vX.X.exe. For quick access to *.exe file you can create a shortcut and move
it on your desktop.
If you want to run only the standalone version there is no need for step 2, you can place the extracted
folder everywhere you like and click on ion_editor_vX.X.exe.
 Registration
You can register VST or Standalone version, once one of them get registered another one will work too.
At first startup the “about window” will be displayed. Perform the following steps for registration:
1) Select your synth model using a switch in the bottom right corner of the screen.
2) Enter or paste your “Full Name” and “Serial number” in the text boxes (Use Ctrl + V or Shift +
Insert to paste characters/numbers easily).
3) Click on Activate button.
If the information is correct, “Successfully registered” message will be displayed and the editor will
automatically jump to front panel. (Activate button will be hidden after a successful registration)
If you face to “Invalid Serial Number” message you must recheck your name and serial or contact to
customer support.
2
3
1
3
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Setting Up MIDI Connection
Hardware Connections: You need two MIDI cables for setting up a two-way connection between your
synth and MIDI interface. However if you don’t need Request Patch/Save Sysex function one way
connection will be enough from your interface output to the synth MIDI Input.
Configuring Editor:
1)
2)
3)
4)
Select MIDI IN device which is connected to your synth MIDI Output.
Select MIDI OUT device which is connected to your synth MIDI Input.
Make sure that Channel number is set to CH:01.
Make sure that the cc32 is selected as bank select message.
1
4
2
3
Configuring ION:

Press the [global] button to enter Global mode.

Go to midi pgm change option and set it to program change. (If you cannot find that page you
must upgrade your OS)

Go to midi bank select option and set it to cc32. (By default editor sends cc32 as MIDI bank
message, but responds to both cc0/cc32. If you want to select cc0 the setting must be the same
in ION and editor)

Enable part a and make its panel active press edit part, go to midi channel and set it to 1. (By
default editor sends/receives data on channel 1. You can change this later but the channel
number must be the same in ION and editor)
4
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
Configuring Micron:

Press [config] to set the Micron’s global configuration options.

Using Control knob to select MIDI: channels option and set it to start at 1. (By default editor
sends/receives data on channel 1. You can change this later but the channel number must be the
same in Micron and editor)

Using Control knob to select MIDI: Pgm change option and set it to on (send+recv).

Press [program] to select program mode.
Testing MIDI Connections:
After doing above steps it is recommended to test your MIDI connections before using editor:
Testing MIDI IN:
1) Move M1/M2 or Pitch wheel on your synth while checking editor, editor’s wheels must follow the
movement.
2) Select different presets on your synth, the bank/program knobs must be changed on editor too.
1
2
If the above steps are done successfully so the MIDI IN connection is ok.
Testing MIDI OUT:
Select a program on your synth, play some notes while tweaking editor’s wheels or changing program
level knob on editor (top right corner). If you hear the sound variation the MIDI out connection is ok.
If your MIDI interface has indicator LED, It will be a useful tool for monitoring the connection.
5
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Quick Start
One of the basic features of the editor is the ability to create and send NRPN messages that are
recognized by Ion/Micron. Every time you tweak editor’s knobs or switches some specific MIDI messages
are generated and sent through MIDI out port. This MIDI messages are used to change the values in edit
buffer of the sound engine.
What is edit buffer? When you select a patch on your synth and start to change the sound’s parameters,
A copy of the patch is created in the memory that is called edit buffer. Your changes are not stored
directly in patch but in edit buffer and the original patch is still there unchanged unless you store that
patch manually. NRPN messages can only change the edit buffer so you must not worry about losing
your patch or mistakes in editing. Ion has 4 edit buffers (A, B, C, D) while Micron has only one edit buffer.
NRPN vs CC: NRPN has 14 bit resolution (16,384 steps) while CC has 7 bit (127 steps). NRPN can change
parameters more precisely if the device supports it. NRPNs occupy more MIDI bandwidth than CCs.
Which parameters can I change remotely via NRPNs?
As you see in the front panel of editor nearly all the parameters of sound-engine can be controlled, MOD
Matrix and Tracking Generator are located in the rear panel. For switching between the panels use
panel selector at the bottom right corner of the screen. Dual modes bring MOD Matrix in front panel for
easy access. A randomizer panel shows Randomizer module that can randomize some parameters of
editor. Every parameter of editor can be automated by your DAW. When the DAW plays your track the
recorded automations are reflected in editor and then through your synth:
Panel Selector
Front Panel
Rear Panel
Dual 2
Randomizer
6
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Request Patch
Request patch loads a patch from specific ION/Micron Memory location into the editor. Program name
and Category are stored in the patch. But a patch cannot be requested by its name, you must address it
by program number and bank number (fig.1-1). When you change your synth presets, the synth
automatically transmits the program and bank number out of its MIDI port. Editor receives this information
and sets the bank/program number, Only thing you must do is to click on the request patch button. You
can find request patch button in the tool bar under MIDI IN device selector (fig.1-1).
If you don’t want to touch your synth and want to select the patches remotely, you must know the
program and bank number of the patches for setting it in the editor:
How to find out the program and bank number in Micron? Hold down the [programs] button for a
second, and these numbers will appear on the display. Note that Micron lists its presets in alphabetical
order, bank and program numbers may not follow ascending order in a category!
Tip: Request patch is done by using system exclusive messages “Sysex”. Sysex messages are usually used
to transfer large amount of data between MIDI compatible audio gears. Patch name, category and all sound
related parameters can be sent out from your synth in sysex format and editor will convert them to a *.syx file
and save them in your HDD. The size of a standard Ion/Micron sysex file that contains one program is 434
bytes. Larger files may contain multiple programs, bank or operating system firmware. (Ion stores Program
number, bank number and edit buffer location in sysex while Micron ignores these data)
2
(fig.1)
1
 Sysex Tools Menu
Using this menu you get access to all Sysex operations that editor is capable of including load, send,
save and renaming of a sysex file (fig.1-2).
How to load a sysex patch from your HDD into the editor?
1) Open Sysex tools menu.
2) Select Load *.syx.
3) A window will be displayed and asked you for file location on your HDD. Select the file and click
on open button.
Here the patch is loaded into the editor, if you want the patch to be sent to your synth too you must do the
following steps:
1) Open Sysex tools menu.
2) Select Load and Send.
3) A window will be displayed and asked you for the file location on your HDD. Select the file and
click on open button.
7
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
4) After step 3 sysex file info pop up window will be displayed while showing some information
about the selected patch, if you click on send button it will be sent to your synth memory. OK
button will just close the window.
“Sysex file info” window is different in ion-editor mode (fig.2) and Micron-editor mode (fig. 3). In Ion
mode you can specify patch destination in banks even part (a,b,c,d) edit buffers. In Micron mode you
cannot see these options because Micron ignores program/bank number and the received patch will go to
comp category or a random category in Memory. If a patch with the same name was already there,
Micron replaces the new patch with the old one:
(fig.2) Ion-editor
(fig.3) Micron-editor
How to change the program name and category of a sysex file?
1) Open Sysex tools menu.
2) Select Change Program Name/Category.
3) A window will be displayed and asked you for the file location on your HDD. Select the file and
click on open button.
4) After step 3 “Rename *.SYX” pop up window will be displayed while showing program name and
category. Enter new program name in the text box and select new category using the category
selector then click on save button.
5) A window will be displayed and asked you for choosing the file path on your HDD. Select your
desired path, enter a name for the file then click on save button. (if you select the original file it
will be overwritten with new information)
4
4
8
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
How to save a Ion/Micron program from Memory as a sysex file?
1)
2)
3)
4)
Select the patch using program and bank knob on editor, or manually on your synth.
Open Sysex tools menu.
Select Save (Selected Program).
A window will be displayed and asked you for choosing the file path on your HDD. Select your
desired location and click on save button.
How to save editor program as sysex file?
1) Open Sysex tools menu.
2) Select Save (Editor Program).
3) A window will be displayed and asked you for choosing the file path on your HDD. Select your
desired location and click on save button.
It is recommended not to use this feature, unless you make sure about the amounts of available mod
slots in the current program (For more info please read “About ION/Micron OS” part of this manual).
These notes must be considered while using save (editor program):



It uses Ion/Micron hardware for decoding the patch so your synth must be turned on.
It overwrites the edit buffer.
Editor’s preset name is stored in sysex file as program name.
 Tool Bar
7
1
8
9
1
0
0
0
2
3
4
6
5
1) MIDI IN and MIDI out device selector
2) Bank Select message switch: allows you to designate which MIDI controller number the Ioneditor transmits as a Bank Select message. (must be set to cc32 in Micron mode)
3) Update mode switch: (explained in preset manager part)
4) Settings button: opens up settings window (explained in settings part)
5) Echo switch: “Echo: off” prevents Note-on/Note-off message transmission from editor’s MIDI IN
to the editor’s MIDI out. If it set to on and you play notes with your synth keyboard, all notes will
be triggered twice and you will hear overlapped attack stages.
6) Wii: (explained in Wii Remote part)
7) Preset manager: (explained in preset manager part)
8) All notes off: shuts off all eight voices like double-press of home button on ion or program button
on Micron.
9) Latch button: Only available in Micron mode, it enables/disables latch function of Micron. (latch
acts like sustain switch in Micron but it has a specific controller number)
Note: all Items that are pointed with red numbers are saved by editor every time you change them and
will be loaded at the next start up. These items are not stored by your DAW in the track. They are global
settings and the same between VST and standalone version.
9
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Preset Manager
2
1
3
6
4
5
7
Editor’s presets are stored and loaded by preset manager. Preset manager can store/load a bank
containing 128 presets. It is also connected to your VST host and updated when you open your project in
DAW.
Note that an editor’s preset is different from an Ion/Micron program or a sysex file. Editor saves the
presets and banks in TXT format:
1) Program name: Name of the current program that will be updated after request patch. If you
rename it manually, it won’t reflect in Ion/Micron.
2) Name button: This button renames the current preset.
3) Left & Right Arrow keys: increments/decrements the preset number in the bank.
4) Category: Sets the sound category in Micron.
5) File Menu: User can save and load editor’s presets and banks using this menu.
6) Update edit buffer: Transfers all NRPNs values to the edit buffer in regard to CH setting. If you
select a preset from the preset list it will be triggered automatically by the software (auto update).
7) Auto update/manual: enables/disable the auto update function of preset manager. Auto update
triggers “update edit buffer”’ at these situations:
 After selecting a new preset.
 After loading *.txt preset file.
 After plugin startup.
If you want to block sending all NRPNs to synth in these situations set it to manual.
Which parameters are stored in the editor’s preset?







All the parameters of Ion/Micron sound-engine in front and rear panel of editor excluding
randomizer module.
M1 and M2
Program and Bank numbers
Category
MIDI Channel
Panel selector
Program name
Which parameters can be automated by the VST host?
Pitch wheel + all parameters of the editor’s preset excluding panel selector.
How can I disable loading program/bank number and panel mode from presets?
If you want these items to be fixed all the time and not jump from one setting to another every time you
select a different preset in the bank or every time you load a different project in DAW with different
settings, Click on Settings button in tool bar, there are specific options for disabling each one.
10
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Settings
1
2
3
4
5
6
7
8
1) If set to Off, panel mode (front, rear, dual …) will not be loaded from preset at the startup or when
you change the preset number.
2) If set to Off, Program/Bank numbers will not be loaded from preset at the startup or when you
change the preset number.
3) Enables/Disables graphical readout (can be turned off for saving CPU while playing back
automations)
4) Skin Selector
5) Standalone Zoom level (note that if you right click on the GUI and change Zoom Level it does not
keep the zoom level at the next start up. The best place for changing zoom level is here in
settings window)
6) MIDI Controller Input: Sets the MIDI device which your secondary keyboard or MIDI controller is
connected to. “VST Input (Host)” forces the plug-in to receive CCs from your host.
7) Sets the MIDI channel of the Controller Input.
8) Resets all the CC# assignments to their default mapping.
 Shortcut keys and Tips





1
If you press shift key while tweaking a knob, the value will change more precisely. “Double
Click” and “Ctrl + Click” set the knob’s position to its default value.
Ion/micron mode: It is not recommended to switch between Ion and Micron modes while MIDI
out device is connected to your synth. Set MIDI out to “None” then switch between modes if it is
really needed. (fig. 4/5-1)
Full Screen and Zoom functions are only available in standalone version (fig. 4/5-2).
About window: By clicking over the editor’s logo about window will be displayed and show you
brief information about the software, current version and credits. (fig. 4/5-3)
Arp: shows/hides Arp edit page (Only in Ion mode). Sync button synchronizes ion tempo with
the VST host tempo. This parameter is dedicated to ion-editor and there is not such parameter in
ion. (fig. 6)
fig. 4
2
2
3
3
1
fig. 5
Fig. 6
11
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 MIDI LEARN
MIDI Learn function lets you remotely control most parameters of editor using Midi Continuous Controller
Data (Midi CC). In addition to the messages specified in the MIDI Implementation Chart, the following
MIDI CC messages in “MIDI CC Tables“ are recognized and affect their associated parameters. By
sending MIDI CC messages, you can change these parameters. You can override the default mapping as
listed in “MIDI CC Tables“ on demand by learning the controls to different CCs. MIDI learn can be
accessed by right clicking over the knobs or buttons. Before using MIDI learn you must select the MIDI
device that your hardware MIDI controller is connected to. MIDI learn device selector is located in
settings menu.
Learn a control on editor to an external controller:
1. Right Click on a knob, button or switch and select MIDI Learn.
2. Move the controller on your controller device which you want to learn to it.
If you want to disable the current or default mapping you should right click on the knob and select midi
forget.
 Wii Remote
Ion-editor allows you to receive input data from the Nintendo Wiimote + Nunchuck(optional) and convert
them to MIDI messages that are recognizable by Ion/Micron. At first Wiimote must be paired with your PC
via Bluetooth.
How to pair a Wiimote in Windows 7?
1)
2)
3)
4)
5)
6)
7)
8)
9)
Make sure that the Bluetooth dongle is connected to your USB port.
Hold 1 and 2 buttons on the Wiimote (do not release the buttons).
Go to Devices and Printers under the Control Panel and click Add a Device.
Select Nintendo RVL-CNT-01 and click Next.
Select Pair Without Using Code.
Wait for driver installation to be completed.
Run editor.
Click on Wii button in the toolbar of the editor.
Release 1 and 2 buttons on the Wiimote.
The process may be different for other operating systems. Once the Wiimote is paired the Wii button in
the toolbar gets blue and shows that the connection is live. By default Wiimote’s A button generates note
on/off message, + and - buttons transpose the octave of the current note.
Learn a control on editor to Wiimote or Nunchuck controller:
1. Right Click on a knob, button or switch and select Wii remote or Wii Nunchuck.
2. Select your desired controller from the sub menus.
Accel X, Y are raw acceleration data in the X-axis and Y-axis. You get the best result out of the Wiimote
movement and turn by linking to Accel X and Y. The infra red camera at the front of the Wiimote can
detect and track up to 4 IR dots. The X and Y positions of these dots are returned by BlobX X/Y. Note that
at least one Infrared source (an Infrared LED, Pen, Glove or a Candle) must be visible by IR camera for a
blob to be detected and tracked.
12
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Appendix A
MIDI Implementation Chart
Function
Txd
Rxd
1-16
1-16
x
x
0-127
1-16
1-16
Mode 1
x
0-127
o
o
x
o
o
o
o
x
o
o
o
o
o
o
System Exclusive
o
o
NRPNs
o
x
RPNs
x
x
x
x
x
x
x
x
o
x
x
x
x
x
x
x
x
x
x
x
Basic Channel
Mode
Note number
Velocity
Aftertouch
Default
Changed
Default
Changed
Sound range
Note On
Note Off
Keys
Channels
Pitchbend
Control Change
Program Change
System
Common
System Real
Time
Aux Messages
Actual No.
Song Position
Song Select
Tune Request
Clock
Commands
Local On/Off
All Notes Off
Act. Sensing
Reset
Remarks
Messages are always received on all
channels
OMNI Mode is always on
Txd = Transmits MIDI message
Rxd = Receives MIDI message
o = implemented
x = not supported
13
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 Appendix B
Parameter
m1 wheel
m2 wheel
osc3 waveform
osc3 shape
osc3 octave
osc3 semitone
osc3 fine tune
osc3 p wheel range
osc2 waveform
osc2 shape
osc2 octave
osc2 semitone
osc2 fine tune
osc2 p wheel range
osc1 waveform
osc1 shape
osc1 octave
osc1 semitone
osc1 fine tune
osc1 p wheel range
osc sync(Micron/Miniak)
osc sync(ion)
FM level
FM type(Micron/Miniak)
FM type(ion)
noise type
osc3 level
osc2 level
osc1 level
ring level
ext level
noise level
osc3 balance
osc2 balance
osc1 balance
ring balance
ext balance
MIDI CC Tables
CC#
1
2
3
4
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
25
26
117
117
27
28
29
30
31
33
34
35
36
37
39
40
Parameter
noise balance
filter2 type
filter2 freq hz
filter2 freq octave
filter2 res
filter2 keytrk
filter2 env
filter 2 offset
filter1 type
filter1 freq
filter1 res
filter1 keytrk
filter1 env
f1 >> f2
filter2 level
filter1 level
pre f level
filter2 pan
filter1 pan
pre f pan
pre filter signal
drive type
drive level
FX mix
FX balance
program level
lfo1 rate
lfo1 sync
m1 to lfo1
lfo2 rate
lfo2 sync
m1 to lfo2
s&h rate
s&h sync
s&h smoothing
unison(Micron/Miniak)
unison enable (ion)
CC#
41
42
43
43
44
45
46
47
48
74
71
49
50
51
52
53
54
55
56
57
58
59
60
8
61
7
62
63
64
66
67
68
70
75
76
79
79
14
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
Parameter
unison voices(ion)
unison detune
analog drift
porta time
porta(Micron/Miniak)
porta enable(ion)
porta trigger(ion)
porta type
mono/poly
P wheel mode
pitch env A
pitch env D
pitch env S
pitch env ST
pitch env R
pitch env A slope
pitch env D slope
pitch env R slope
filter env A
filter env D
filter env S
filter env ST
filter env R
filter env A slope
filter env D slope
filter env R slope
amp env A
amp env D
amp env S
amp env ST
amp env R
amp env A slope
amp env D slope
amp env R slope
ion arp on
ion arp latch
mod 1 level
mod 2 level
mod 3 level
mod 4 level
81
82
83
5
84
84
85
86
87
88
89
90
91
92
93
94
95
102
103
104
105
106
107
108
109
110
73
111
112
113
72
114
115
116
118
119
65
69
77
78
15
ion-editor Manual - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -HyperSynth
 About ION/Micron OS
For accessing all the editor’s features, It is recommended to upgrade your ION/Micron OS to the latest
version although the latest OS still has several MIDI related bugs and limitations. Latest OS version is
1.06 for ION and 1.1 for Micron. You can download the latest OS file from Alesis website and load it to
your synth. For more information about upgrading OS please read your synthesizer reference manual.
How to find out ION OS version?
Turn the Ion’s power on while holding both the [panel active a] and [panel active d] buttons.
Ion OS v1.06 bugs/limitations:

OSCs Wheel range (0-12): This parameter can be set only to “0” or “1” and the range between 212 cannot be set via NRPN.

Effect part-->LFO Rate: This parameter can be set when tempo sync is off but does not change
when sync is on.

Ion Master Tempo: The tempo value shown on main page (home) does not change when the
tempo is set by NRPN. But the tempo really changes behind on the Arp Edit page and it updates
correctly.

It is not possible to rename a program via NRPN. (only sysex)
How to find out Micron OS version?
Turn the Micron’s power on while holding both the [programs] and [setups] buttons.
Micron OS v1.1 bugs/limitations:

It is not possible to add modulation path in mod matrix via NRPN, User must add mods manually
or send a pre-added empty sysex file to memory before programming a new sound (the file is
located in plugin folder). This flaw also affects “update edit buffer” function and causes sound
difference when sending a preset to synth with number of mod paths more than available.

It is not possible to change tempo remotely.

It is not possible to change patterns/ sequences, setup/multi and rhythms via NRPN however you
can save/load them via sysex.

It is not possible to rename a program via NRPN. (only sysex)

Micron draws “OSC Waveshapes” wrongly or inverted, editor draws the correct waves.
Support info: If you encounter any problems, or you have suggestions for future revisions, don’t hesitate
to contact our technical support at: Support@hypersynth.com
Copyright © 2008-2012 HyperSynth
www.HyperSynth.com
16