MapSource for Bikers: Using the Garmin MapSource Program to

MapSource for Bikers: Using the Garmin MapSource Program to
MapSource for Bikers:
Using the Garmin MapSource Program to Enhance Your Use of a Garmin GPS
1) Course intro
a) What will be covered
b) Why is learning to use MapSource useful?
i) Example 1: BMW TCD club rides
ii) Example 2: GLDS dual sport rides
iii) Example 3: BMW TCD observation run
c) Caveat: use it or lose it
2) Intro to the Garmin MapSource program
a) ‘MapSource’ is the name of the mapping program.
i) ‘Documents’ that the MapSource program works with are the various mapping products,
like City Select (GPS V), City Navigator (Nuvis, Zumos, others), Roads and Recreation (eMap),
TOPO U.S. (topographic maps), BlueChart (marine charts)
ii) MapSource will work with all these different map products, but will display different things
and support different capabilities, dependent upon the ‘document’ (map product).
iii) MapSource program versions (6.13.7 my pick)
b) MapSource user interface
i) The main menu bar
ii) The toolbars
iii) The main window
iv) The user data tabs
v) The essential 5 tools from the ‘Tools’ toolbar – you’ll use these tools 99% of the time you’re
working in MapSource:
(1) The ‘Hand’ (pan) tool (shortcut key – ‘H’)
(2) The selection tool (shortcut key – ‘S’)
(3) The waypoint tool (shortcut key – ‘W’)
(4) The route tool (shortcut key – ‘R’)
(5) The zoom tool (shortcut key – ‘Z’)
vi) Two additional useful tools from ‘Tools’ toolbar:
(1) The distance measuring tool (shortcut key – ‘D’)
(2) The map selection tool (shortcut key – ‘M’)
vii) Moving the map window around
(1) , Ctrl- (move map up a little; a lot)
(2) , Ctrl- (move map down a little; a lot)
(3) , Ctrl- (move map left a little; a lot)
(4) , Ctrl- (move map right a little; a lot)
viii) Zooming map window in and out using keyboard
(1) ‘+’ key, zoom in
(2) ‘-‘ key, zoom out
ix) Two very useful editing keys
(1) Undo – Ctrl-Z (also Edit -> Undo from main menu)
(2) Redo – Ctrl-Y (also Edit -> Redo from main menu)
x) Main menu tools not available as toolbar buttons
Page 1 of 5
(1) View -> Go To Position… (lat & long) – Ctrl-T
(a) Demo – Dimitri’s Coney Island in Milford at N42 35.611 W83 36.345
(2) View -> Show Crosshair – Ctrl-H
(3) View -> Show MiniMap – Shift-Ctrl-M
(4) Utilities-> Celestial Information … – Ctrl-L
(5) Utilities-> Get Unit ID…
(6) Utilities-> Unlock Maps…
3) Working with routes
a) What ‘routing’ means in context of road routing GPSes (‘direct routing’ vs ‘auto-routing’)
b) Viewing a route – select route in user tab panel, or right-click on map, then choose ‘Show
Selected Route on Map’
c) Requires routing-capable maps
d) Factors which affect how routes are calculated
i) Edit -> Preferences -> Routing tab -> Calculation Style – faster time vs shorter distance
ii) Edit -> Preferences -> Routing tab -> Try to Avoid (route avoidances)
iii) Edit -> Preferences -> Routing tab -> Road Selection slider
e) Creating routes in MapSource
i) Set routing preferences as desired
ii) Select routing tool
iii) Click on route starting point (origin)
iv) Move map to destination and click
(1) Move map to destination using keyboard navigation keys
(2) Move map to destination using Find tool
f) Modifying the path of an existing route with additional intermediate route points, or ‘shaping
points’
i) Select select tool (the arrowhead)
ii) Left-click on the route once to select it – it will change color to indicate selection (yellow)
iii) Left-click the route where you want to change its path, then click and drag over to a location
where you want to force the route (‘rubber banding’).
iv) Add additional route points as needed to force the route to follow the path you want
g) Extending an existing route
i) Select select tool (the arrowhead)
ii) Left-click on the route once to select it – it will change color to indicate selection (yellow)
iii) Left-click on the end of the route once to extend it – the mouse cursor will change from the
simple arrowhead to an arrowhead plus the routing tool icon to show you that you’re in
route extension mode.
iv) Position the mouse cursor to the new desired route destination and click.
v) Press ‘Esc’ key to exit route extension mode. Mouse cursor reverts to arrowhead only.
h) Accessing and modifying route properties
i) Access route properties – right-click route in user data tabs route list, or select the route on
the map and right-click it. Choose ‘Route Properties…’ from the pop-up context menu
ii) Give your route a name of your choosing
(1) Clear the ‘Autoname’ checkbox.
(2) Type the name you want for your route in the ‘Name’ text box.
iii) Reversing a route’s path of travel
Page 2 of 5
i)
(1) In the route properties dialog box, click the button labeled ‘Invert’, or on the map select
the route, the right-click with the mouse cursor on the route, choose ‘Invert Route’ from
the pop-up context menu
iv) Recalculating a route
Creating a duplicate of an existing route (good for playing ‘what if?’)
i) Display user data tabs, if not displayed. Click on the Routes tab
ii) Locate route you want to duplicate in list of displayed routes and left-click it to select it
iii) Go up to main menu and choose Edit -> Duplicate Route. MapSource will create an exact
copy of the selected route and add it to the list of routes.
4) Working with tracks
a) The difference between tracks and routes
b) GPS track logs
c) Retrieving track logs from your GPS
i) Direct import from within MapSource
ii) Copy .GPX files with tracks to PC from GPS as a storage device
d) The tracks toolbar
e) Creating tracks
f) Editing tracks
i) Splitting tracks
ii) Joining tracks together
5) Working with files to save and later recall your routes and tracks.
a) Setting your preferred MapSource map files save/load location:
Edit -> Preferences -> File Location tab – Default File Location
b) File -> Save As…
c) Map file formats
i) .MPS – very early Garmin map file proprietary format. All versions, even older ones, of
MapSource can read .MPS formatted files.
ii) .GDB – later Garmin map file proprietary format
(1) Two versions, 2 and 3. Some programs can read version 2 .GDB files, but not ver 3
(a) MapSource version 6.1 or later required to read .GDB version 2 files
(b) MapSource version 6.12.2 or later required to read .GDB version 3 files
iii) .GPX – widely supported interchange format. Most mapping programs and utilities can read
and write .GPX formatted file. Supported in MapSource version 6.5 and later.
iv) .DXF – AutoCAD file format, export only (MapSource can’t read .DXF formatted files)
6) Building portable routes to share with other GPS users
a) Problems in making routes portable
i) Single biggest issue: differences between map data. Demonstration.
(1) Map data inaccuracies
(a) Out of date (Klinger Rd bridge over Mill Creek closed in Washtenaw county)
(b) Inaccuracies - incomplete (McCabe Rd SE of I-96/US-23)
(c) Inaccuracies – errors (Hadley Rd – R&R)
(2) Differences in road position depiction
ii) Different GPSes may calculate routes differently
iii) Route calculation options differences between source and destination
(1) Calculation style: fastest vs. shortest routing
Page 3 of 5
(2) Route avoidance options
(3) Road selection setting (prefer minor roads … prefer highways)
b) Guidelines for creating portable custom routes for distribution
i) Set routing preferences:
(1) Shortest routing
(2) Clear all applicable route avoidances
(3) Set road selection mid-point, or weight to ‘prefer minor roads’
ii) Create route using intermediate route points (‘shaping’ points)
(1) Don’t set shaping points at intersections where route changes course
(2) Use only as many shaping points as necessary to force the route where you want it
iii) Create a track which mirrors your route. Provides route recipient a reference for verifying
correct route calculation, as well as a ‘back up’ in case of route recalculation errors
iv) Save off map file with route(s) and track(s) (and, optionally, waypoints if used) in
appropriate format. .GPX file format the most portable choice. If you know your recipients
are Garmin MapSource users, then either (or better, both) .MPS and/or .GDB (version 2)
format.
v) Provide map file to users. Specify to map file recipients:
(1) What map product, both name and version, was used to create the route (e.g.,’ City
Navigator NT version 8’)
(2) Routing options used to create the route
(a) Calculation style: shortest vs. fastest
(b) Avoidance settings
(c) Road selection settings
7) Using portable routes provided by other GPS users
a) Launch your copy of MapSource and open the provided route map file
b) Where possible, use same map data as was used by route creator
c) Set routing options in MapSource to those used by the route creator (if provided).
d) RECALCULATE THE ROUTE! All bets are off if you don’t recalculate the route for YOUR map data.
Even if the map data you use is identical with the map data used by the route creator, this step
is still highly advisable.
e) Zoom in to highest zoom level on a route shaping point. Is the shaping point located directly on
the road as depicted in your map data? If not, click and drag shaping point so that it is located
directly on the road. Repeat for all shaping points. Route will recalculate automatically as you
reposition shaping points.
8) Working with multiple map products in MapSource and your GPS
a) Intro to working with multiple map products – why?
b) Demonstration of installing additional maps into MapSource
c) Working with multiple maps in MapSource
i) The map tile selection tool
ii) Maps from different products can be combined into a ‘mapset’
iii) Getting a mapset from MapSource into your GPS
(1) Download directly into GPS device memory
(2) For GPS that support memory cards, write map file out to the memory card in a memory
card reader/writer connected to your PC, then install memory card into GPS.
d) Working with multiple maps on your GPS device
Page 4 of 5
9) Managing your waypoints, routes and tracks using MapSource
a) Launch multiple copies of MapSource to copy and paste waypoint, route and track data
between map files.
b) Use MapSource to more easily manage the waypoint, route and track data on your GPS device
10) Some handy GPS and map utility programs and resources
a) MapSource class materials website: http://www.msu.edu/~fishbeck/GPSClassStuff/
b) WinGDB3
i) Automatically generate a track from a route.
ii) Many other functions
iii) Available at http://home.kpn.nl/ea.sackman/WinGDB3.50/SetupWinGDB3.exe
iv) Demonstration - converting a route into a track
(1) Select file with route to convert
(2) Choose output option (I like MapSource)
(3) Choose option to convert routes to tracks with all route points (option 11)
(4) Enable filter to limit track points to either 500 or 250
(5) Click Convert button
c) GPSBabel
i) Can convert to/from virtually any GPS file format
ii) Available from http://www.gpsbabel.org/
Page 5 of 5
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising