01/12/2013
Switching and Wireless – Chapter 6
Inter-VLAN Routing
15th November 2012
CCNA3-1
ITE I Chapter 6
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Public
Chapter 6
1
Introducing Inter-VLAN Routing
• Now that you know how to configure VLANs on a network switch, the
next step is to allow devices connected to the various VLANs to
communicate with each other.
• In a previous chapter, you learned that each VLAN is a unique broadcast
domain, so computers on separate VLANs are, by default, not able to
communicate. There is a way to permit these end stations to communicate; it
is called inter-VLAN routing.
• In this topic, you will learn what inter-VLAN routing is and the different
ways to accomplish inter-VLAN routing.
• In this chapter, we focus on one type of inter-VLAN routing using a separate
router connected to the switch infrastructure. We define inter-VLAN routing as
a process of forwarding traffic from one VLAN to another VLAN using a router.
• VLANs are associated with unique IP subnets on the network.
• When using a router to facilitate inter-VLAN routing, the router interfaces can be
connected to separate VLANs.
• Devices on those VLANs send traffic through the router to reach other VLANs.
• Inter-VLAN routing, then, is a process of forwarding traffic from one VLAN to
another VLAN using a router.
CCNA3-2
Chapter 6
1
01/12/2013
Introducing Inter-VLAN Routing
• Methods:
1. Traditional Inter-VLAN Routing.
2. Router-on-a-stick Inter-VLAN Routing.
3. Layer 3 Switch Based Inter-VLAN Routing.
Chapter 6
CCNA3-3
Introducing Inter-VLAN Routing
• Traditional Inter-VLAN Routing:
• One router interface per VLAN.
Internally Routed to
the proper subnet.
VLAN
Tag
removed
Tagged
VLAN10
CCNA3-4
VLAN30
Chapter 6
2
01/12/2013
Introducing Inter-VLAN Routing
• "Router-on-a-stick"
• However, not all inter-VLAN routing configurations require
multiple physical interfaces.
• "Router-on-a-stick" is a type of router configuration in which
a single physical interface routes traffic between
multiple VLANs on a network.
•
The router interface is configured to operate as a trunk
link and is connected to a switch port configured in trunk
mode.
•The router performs the inter-VLAN routing by accepting
VLAN tagged traffic on the trunk interface coming from the
adjacent switch and internally routing between the VLANs
using subinterfaces.
•The router then forwards the routed traffic-VLAN tagged
for the destination VLAN-out the same physical interface.
•
Subinterfaces are multiple virtual interfaces,
associated with one physical interface.
•Subinterfaces are configured for different subnets
corresponding to their VLAN assignment to facilitate logical
routing before the data frames are VLAN tagged and sent
back out the physical interface.
Chapter 6
CCNA3-5
Introducing Inter-VLAN Routing
• Router-on-a-stick Inter-VLAN Routing:
• One router interface for all VLANs. Internally Routed to
the proper subnet.
VLAN
Tag
removed
Tagged
CCNA3-6
Chapter 6
3
01/12/2013
Introducing Inter-VLAN Routing
• Layer 3 Switch Inter-VLAN Routing:
Some switches can perform Layer 3 functions,
replacing the need for dedicated routers to
perform basic routing on a network. Uses Switch
Virtual Interfaces (SVI) to retag the frame.
TagVLAN
removed
Tagged
(10)
Chapter 6
CCNA3-7
Interfaces and Subinterfaces
• Traditional Inter-VLAN Routing:
• Traditional routing requires routers to have multiple
physical interfaces to facilitate inter-VLAN routing.
• Each interface is also configured with an IP address for
the subnet associated with the particular VLAN that it is
connected to.
• In this configuration, network devices can use the router
as a gateway to access the devices connected to the
other VLANs.
CCNA3-8
Chapter 6
4
01/12/2013
Interfaces and Subinterfaces
Router tags
Traditional Inter-VLAN RoutingRouter
the frame
Responds
for VLAN 30
Routing table:
And switches it
172.17.10.0 – F0/0
to Port F0/1.
172.17.30.0 – F0/1
Tagged
Tag
Removed
VLAN 10
Chapter 6
CCNA3-9
Interfaces and Subinterfaces
Traditional Inter-VLAN Routing
CCNA3-10
Chapter 6
5
01/12/2013
Interfaces and Subinterfaces
• Traditional Inter-VLAN Routing:
• Traditional inter-VLAN
routing using physical
interfaces does have a
limitation.
• As the number of VLANs
increases on a network, the
physical approach of having one router interface per
VLAN quickly becomes hindered by the physical
hardware limitations of a router.
• Routers have a limited number of physical interfaces that
they can use to connect to different VLANs.
• It is very expensive to add an Ethernet Interface.
Chapter 6
CCNA3-11
Interfaces and Subinterfaces
• Router-on-a-stick Inter-VLAN Routing:
• Subinterfaces:
• Overcomes the hardware limitation of a router.
• Subinterfaces are software-based virtual interfaces that are
assigned to physical interfaces.
• Each subinterface is configured with its own IP address, subnet
mask, and unique VLAN assignment.
• Connected to a switch trunk link.
• Functionally the same as using the traditional routing model.
• Configuring Subinterfaces:
•
CCNA3-12
Similar to configuring physical interfaces.
1. Create the subinterface.
2. Assign it to a VLAN.
3. Assign an IP Address.
4. Enable the interface.
Chapter 6
6
01/12/2013
Interfaces and Subinterfaces
Router-on-a-stick Inter-VLAN Routing
Routing table:
172.17.10.0 – F0/0.10
172.17.30.0 – F0/0.30
Tagged
VLAN 30
Tagged
Tag
Tag
Removed
Removed
VLAN 30
10
Chapter 6
CCNA3-13
Router-on-a-stick Inter-VLAN Routing:
1) Create the subinterface:
•
The syntax for the subinterface is always the physical interface, followed by a
period and a subinterface number.
The subinterface number is configurable, but it is typically associated to reflect
the VLAN number.
•
R1(config)#interface [interface].nn
2) Assign it to a VLAN:
•
Before assigning an IP Address, the interface must to be configured to
operate on a specific VLAN using the proper encapsulation.
R1(config-subif)#encapsulation dot1q vlan-id
3) Assign an IP Address:
•
The IP Address assigned here will become the default gateway for that VLAN.
R1(config-subif)#ip address [address] [mask]
4) Enable the interface:
•
Subinterfaces are not enabled individually. When the physical interface is
enabled, all associated subinterfaces are enabled.
R1(config-if)#no shutdown
CCNA3-14
Chapter 6
7
01/12/2013
Interfaces and Subinterfaces
• Configuring Subinterfaces:
VLAN 10
VLAN 30
Enable Interfaces
Chapter 6
CCNA3-15
Interfaces and Subinterfaces
• Configuring Subinterfaces:
Planning!
CCNA3-16
Chapter 6
8
01/12/2013
Subinterface advantages and disadvantage
•
Port Limits
•Physical interfaces are configured to have one interface per VLAN. On networks with
many VLANs, using a single router to perform inter-VLAN routing is not possible.
•Subinterfaces allow a router to scale to accommodate more VLANs .
•
Performance
•Because there is no contention for bandwidth on physical interfaces, physical
interfaces have better performance for inter-VLAN routing.
•When subinterfaces are used for inter-VLAN routing, the traffic being routed competes
for bandwidth on the single physical interface. On a busy network, this could cause a
bottleneck for communication.
•
•
Access Ports and Trunk Ports
•Connecting physical interfaces for inter-VLAN routing requires that the switch ports be
configured as access ports. Subinterfaces require the switch port to be configured as a
trunk port so that it can accept VLAN tagged traffic on the trunk link.
Cost
•Routers that have many physical interfaces cost more than routers with a single
interface. Additionally, if you have a router with many physical interfaces, each interface
is connected to a separate switch port, consuming extra switch ports on the network.
•Financially, it is more cost-effective to use subinterfaces over separate physical
interfaces.
Chapter 6
CCNA3-17
Subinterface advantages and disadvantage
•
Complexity
• Using subinterfaces for inter-VLAN routing results in a less complex physical
configuration (less cables) than using separate physical interfaces.
• On the other hand, using subinterfaces with a trunk port results in a more complex
software configuration, which can be difficult to troubleshoot.
• If one VLAN is having trouble routing to other VLANs, you cannot simply trace the cable
to see if the cable is plugged into the correct port.
• You need to check to see if the switch port is configured to be a trunk and verify that the
VLAN is not being filtered on any of the trunk links before it reaches the router interface.
• You also need to check that the router subinterface is configured to use the correct
VLAN ID and IP address for the subnet associated with that VLAN.
CCNA3-18
Chapter 6
9
01/12/2013
Inter-VLAN Routing
Configuring Inter-VLAN Routing
(Putting It All Together)
Chapter 6
CCNA3-19
Configuring Inter-VLAN Routing
• Traditional Inter-VLAN Routing:
CCNA3-20
Chapter 6
10
01/12/2013
Configuring Inter-VLAN Routing
• Traditional Inter-VLAN Routing:
By default, Cisco routers are configured to route
traffic between the local interfaces. As a result,
routing does not specifically need to be enabled.
Chapter 6
CCNA3-21
Configuring Inter-VLAN Routing
• Traditional Inter-VLAN Routing:
CCNA3-22
Chapter 6
11
01/12/2013
Configuring Inter-VLAN Routing
• Router-on-a-stick Inter-VLAN Routing:
VLANs
Trunk in
Trunk
Native
VLAN
Interfaces
VLANs
Chapter 6
CCNA3-23
Configuring Inter-VLAN Routing
• Router-on-a-stick Inter-VLAN Routing:
VLAN 10
VLAN 30
Enable All
Subinterfaces
CCNA3-24
Chapter 6
12
01/12/2013
Inter-VLAN Routing
Troubleshooting Inter-VLAN Routing
Chapter 6
CCNA3-25
Switch Configuration Issues: Topology 1
•
When using the traditional routing model for inter-VLAN
routing, ensure that the switch ports that connect to the
router interfaces are configured on the correct VLANs.
•If the switch ports are not configured on the correct
VLAN, devices configured on that VLAN cannot connect
to the router interface, and therefore, are unable to route
to the other VLANs.
•
As you can see in Topology 1, PC1 and router R1
interface F0/0 are configured to be on the same logical
subnet, as indicated by their IP address assignment.
•However, the switch port F0/4 that connects to router
R1 interface F0/0 has not been configured and remains
in the default VLAN.
•Because router R1 is on a different VLAN than PC1,
they are unable to communicate.
•
To correct this problem, execute the switchport
access vlan 10 interface configuration command
on switch port F0/4 on switch S1.
CCNA3-26
Chapter 6
13
01/12/2013
Configuring Inter-VLAN Routing
VLAN 30 is working but VLAN 10
cannot Issues:
communicate with the
• Switch Configuration
router or VLAN 30.
Interface F0/4 is still in
the default VLAN.
switchport access vlan 10
Chapter 6
CCNA3-27
Switch Configuration Issues: Topology 2
• In Topology 2, the router-on-a-stick routing model
has been chosen. However, the F0/5 interface on
switch S1 is not configured as a trunk and
subsequently left in the default VLAN for the port.
•As a result, the router is not able to function
correctly because each of its configured
subinterfaces is unable to send or receive VLAN
tagged traffic.
•This prevents all configured VLANs from routing
through router R1 to reach the other VLANs.
• To correct this problem, execute the
switchport mode trunk interface
configuration command on switch port F0/5 on
switch S1.
•This converts the interface to a trunk, allowing
the trunk to successfully establish a connection
with router R1.
CCNA3-28
Chapter 6
14
01/12/2013
Configuring Inter-VLAN Routing
Each of the configured
• Switch Configuration
Issues: is unable to
subinterfaces
send or receive VLAN traffic.
Interface F0/5 is still in
the default VLAN.
switchport mode trunk
Chapter 6
CCNA3-29
Router Configuration Issues: Topology 1
• One of the most common inter-VLAN router
configuration errors is to connect the physical router
interface to the wrong switch port,
•placing it on the incorrect VLAN and preventing it
from reaching the other VLANs.
• As you can see in Topology 1, router R1 interface
F0/0 is connected to switch S1 port F0/9. Switch port
F0/9 is configured for Default VLAN, not VLAN10.
•This prevents PC1 from being able to communicate
with the router interface, and it is therefore unable to
route to VLAN30.
• To correct this problem, physically connect router R1
interface F0/0 to switch S1 port F0/4.
•This puts the router interface on the correct VLAN
and allows inter-VLAN routing to function.
•Alternatively, you could change the VLAN
assignment of switch port F0/9 to be on VLAN10.
This also allows PC1 to communicate with router R1
interface F0/0.
CCNA3-30
Chapter 6
15
01/12/2013
Configuring Inter-VLAN Routing
PC1 cannot communicate with the
• Router Configuration
Issues: and the router
router interface
cannot route to VLAN 30.
Switch port F0/4 is
for VLAN 10.
Switch port F0/9 is
Move the cable from F0/9 to F0/4.
assigned to the
default VLAN.
One of the most common
mistakes in Inter-VLAN routing.
Chapter 6
CCNA3-31
Router Configuration Issues: Topology 2
• In Topology 2, router R1 has been
configured to use the wrong VLAN on
subinterface F0/0.10,
•preventing devices configured on
VLAN10 from communicating with
subinterface F0/0.10.
• To correct this problem, configure
subinterface F0/0.10 to be on the correct
VLAN using the encapsulation dot1q 10
subinterface configuration mode
command.
•When the subinterface has been
assigned to the correct VLAN, it is
accessible by devices on that VLAN
and can perform inter-VLAN routing.
CCNA3-32
Chapter 6
16
01/12/2013
Configuring Inter-VLAN Routing
PC1 cannot
communicate with the
• Router Configuration
Issues:
router interface and the router
cannot route to VLAN 30.
Chapter 6
CCNA3-33
IP Addressing Issues: Topology 1
• For inter-VLAN routing to operate,each interface,
or subinterface, needs to be assigned an IP
address that corresponds to the subnet for which
it is connected.
• As you can see in Topology 1, router R1 has
been configured with an incorrect IP address on
interface F0/0.
• To correct this problem, assign the correct IP
address to router R1 interface F0/0 using the ip
address 172.17.10.1 255.255.255.0 interface
command in configuration mode.
•After the router interface has been assigned the
correct IP address, PC1 can use the interface as
a default gateway for accessing other VLANs.
CCNA3-34
Chapter 6
17
01/12/2013
Configuring Inter-VLAN Routing
• IP Addressing Issues:
PC1 cannot communicate.
Incorrect IP address for
subnet 172.16.10.0/24.
Incorrect
Incorrect IP
subnet
address
mask
forfor
subnet
subnet172.16.10.0/24.
172.16.10.0/24.
CCNA3-35
Chapter 6
18
Download PDF