Importing Other Microsoft Office Files

Importing Other Microsoft
Office Files
Title:
Importing Other Microsoft Office Files:
Version:
1.1
First edition: November 2004
Contents
Overview..........................................................................................................................................ii
Copyright and trademark information.........................................................................................ii
Feedback..................................................................................................................................... ii
Acknowledgments.......................................................................................................................ii
Modifications and updates.......................................................................................................... ii
Custom Dictionaries.........................................................................................................................1
AutoText Entries..............................................................................................................................2
AutoCorrect Entries......................................................................................................................... 3
Importing Other Microsoft Office Files
i
Overview
Overview
This chapter describes how to import custom dictionaries and AutoText entries from
Microsoft Office to OpenOffice.org. Currently the author knows no easy way of importing
Microsoft Office auto-correct entries into OpenOffice.org.
Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf
The Original Documentation is Importing Other Microsoft Office Files. The Initial Writer(s)
of the Original Documentation is/are Ian Laurenson © 2004. All Rights Reserved. (Initial
Writer contact(s): hillview@paradise.net.nz. The Initial Writer contact(s) is to report errors
in the documentation. For questions regarding how to use the software, subscribe to the Users
Mail List and post your question there: http://support.openoffice.org/index.html)
All trademarks within this guide belong to legitimate owners.
Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.
Acknowledgments
Thanks to the OOoAuthors team for proofreading this work, particularly Paul Miller and Jean
Hollis Weber.
Modifications and updates
Version
Date
1.0
27 October 2004
First published edition
1.1
1 November 2004
Corrected minor errors
Importing Other Microsoft Office Files
Description of Change
ii
Custom Dictionaries
Custom Dictionaries
Dictionaries are used when checking any document for spelling errors. Custom dictionaries
are enhanced dictionaries that may contain unique words or custom spelling of certain
entries.
OpenOffice.org does not provide a way of importing Microsoft Office custom dictionaries.
However, a macro has been developed for importing Microsoft Office custom dictionaries
into OpenOffice.org. A link for downloading the file can be found at
http://ooomacros.org/user.php#114694.
To import Microsoft Office custom dictionaries:
Create a new Dictionary:
1) Tools > Options... > Language Settings > Writing Aids > New.
2) Give the dictionary a name.
3) Optionally choose a language for the dictionary.
4) Click OK > OK.
Download the file that contains the macro:
1) In a web browser start at http://ooomacros.org/user.php#114694 and click on the link
for Download Import/Export Dictionary Words.
2) This should display a Source Forge page. Click on the latest link for this file. At the
time of writing, this is ImportExportDictionary1-1.zip.
3) Click on the icon
to the right of a mirror (typically choose one closest to you, but it
doesn’t really matter).
4) The browser should display a “save file” dialog,. Fill the dialog in, remembering
where you saved the file.
5) Unzip the file you saved in the previous step.
In Microsoft Word, locate where the custom dictionaries are stored:
1) Tools > Options... > Spelling & Grammar > Dictionaries
Typical location is:
C:\Windows\Application Data\Microsoft\Proof\CUSTOM.DIC
Import the dictionary:
1) In OpenOffice.org, open the file that contains the import/export macro (instructions for
downloading are above).
2) A confirmation dialog about running macros may be displayed. Click Run.
3) Click the Run Macro button (towards the top of the document).
Importing Other Microsoft Office Files
1
Custom Dictionaries
4) Either type in the location of the custom dictionary to be imported or click on the
... button and navigate to it.
5) Choose the dictionary to import the words into (instructions for creating such a
dictionary are above).
6) Click Import. Two dialogs will be displayed. The first says how many words the
dictionary currently holds and the second how many words the dictionary holds after
the import.
7) Click Close.
8) Close the file and the job is done.
AutoText Entries
AutoText is a feature that stores formatted text, text with graphics, tables and fields and
provides the means to easily insert the saved material into documents.
OpenOffice.org stores AutoText entries in XML files in specified folders. Microsoft Word
stores AutoText entries in template files, typically Normal.dot. To import the AutoText
entries from these Microsoft Word templates, follow these steps:
1) Locate the template. Typically templates are found in:
C:\Windows\Application Data\Microsoft\Templates.
2) Edit > AutoText. (or Control + F3).
3) Optionally create a new category: Click Categories... > type in name for new category
> choose the location for the new category > click New > OK.
4) Select the category into which the AutoText entries are to be imported.
5) AutoText > Import.
6) Navigate to and select the desired Microsoft Word template > click Open.
7) The AutoText entries should now be visible in the left list box of the dialog.
8) Click Close.
Importing Other Microsoft Office Files
2
AutoCorrect Entries
AutoCorrect Entries
AutoCorrect is a feature to automatically correct words as you type. You can add entries to
the AutoCorrect function to customize the way that OpenOffice.org operates.
The author has not been able to find a way of importing Microsoft Office AutoCorrect entries
to OpenOffice.org. A thread discussing this problem can be viewed at:
http://www.oooforum.org/forum/viewtopic.php?t=10248.
Information from that thread is copied below, because using this information it is reportedly
possible to import the “first hundred or so” entries.
There is a Word macro available from
http://word.mvps.org/FAQs/Customization/ExportAutocorrect.htm for creating a Word
document with the AutoCorrrect entries.
OOo AutoCorrect files are typically stored in ./user/autocorr/acorrXXXX.dat where XXXX
corresponds to the number for a given locale. These files are zipped and contain the file
DocumentList.xml, which looks like:
<block-list:block-list>
<block-list:block block-list:abbreviated-name="(C)" block-list:name="©"/>
<block-list:block block-list:abbreviated-name="yuor" block-list:name="your"/>
</block-list:block-list>
So it would not be too difficult to create a text file to look like this and to zip it into a
acorrXXXX.dat file.
Importing Other Microsoft Office Files
3