Using AutoCAD 2017 and Autodesk Inventor 2017

Tools for Design
Using AutoCAD 2017 and
Autodesk Inventor 2017
®
®
®
Hand Sketching, 2D Drawing and 3D Modeling
Randy H. Shih
SDC
P U B L I C AT I O N S
Better Textbooks. Lower Prices.
www.SDCpublications.com
Visit the following websites to learn more about this book:
Powered by TCPDF (www.tcpdf.org)
7-1
Chapter 7
Parametric Modeling Fundamentals
- Autodesk Inventor
♦ Create Simple Extruded Solid Models
♦ Understand the Basic Parametric
Modeling Procedure
♦ Create 2D Sketches
♦ Understand the “Shape before Size”
Approach
♦ Use the Dynamic Viewing Commands
♦ Create and Edit Parametric Dimensions
7-2
Tools for Design Using AutoCAD and Autodesk Inventor
Getting Started with Autodesk Inventor
Autodesk Inventor is composed of several application software modules (these modules
are called applications), all sharing a common database. In this text, the main
concentration is placed on the solid modeling modules used for part design. The general
procedures required in creating solid models, engineering drawings, and assemblies are
illustrated.
How to start Autodesk Inventor depends on the type of workstation and the particular
software configuration you are using. With most Windows systems, you may select
Autodesk Inventor on the Start menu or select the Autodesk Inventor icon on the
desktop. Consult your instructor or technical support personnel if you have difficulty
starting the software. The program takes a while to load, so be patient.
The tutorials in this text are based on the assumption that you are using Autodesk
Inventor’s default settings. If your system has been customized for other uses, contact
your technical support personnel to restore the default software configuration.
Parametric Modeling Fundamentals - Autodesk Inventor
7-3
The Screen Layout and Getting Started Toolbar
Once the program is loaded into the memory, the Inventor window appears on the screen
with the Get Started toolbar options activated.
 Note that the Get Started toolbar contains helpful
information in regards to using the Inventor
software. For example, clicking the What’s New
option will bring up the Internet Browser, which
contains the list of new features that are included in
this release of Autodesk Inventor.
 You are encouraged to browse through the general introduction available in the
Videos and Tutorials section.
7-4
Tools for Design Using AutoCAD and Autodesk Inventor
The New File Dialog Box and Units Setup
When starting a new CAD file, the first thing we should do is to choose the units we
would like to use. We will use the English (feet and inches) setting for this example.
1. Select the New icon with a single click of the leftmouse-button in the Launch toolbar.
 Note that the New option allows us to start a new
modeling task, which can be creating a new model or
several other modeling tasks.
2. Select the English tab in the New File dialog
box as shown. Note the default tab contains
the file options which are based on the default
units chosen during installation.
3. Select the Standard(in).ipt icon as shown. The different icons are templates for the
different modeling tasks. The idw file type stands for drawing file, the iam file type
stands for assembly file, and the ipt file type stands for part file. The ipn file type
stands for assembly presentation.
4. Click Create in
the Create New
File dialog box to
accept the selected
settings.
Parametric Modeling Fundamentals - Autodesk Inventor
7-5
The Default Autodesk Inventor Screen Layout
The default Autodesk Inventor drawing screen contains the pull-down menus, the
Standard toolbar, the Features toolbar, the Sketch toolbar, the drawing area, the browser
area, and the Status Bar. A line of quick text appears next to the icon as you move the
mouse cursor over different icons. You may resize the Autodesk Inventor drawing
window by clicking and dragging the edges of the window, or relocate the window by
clicking and dragging the window title area.
Quick Access Toolbar
The Ribbon
File Menu
Feature Toolbar Panel
Graphics
Window
Model
Browser
3D Indicator
Design Shares
on A360
Message or Single-line Help
•
The Ribbon is a new feature in Autodesk Inventor since the 2011 release; the Ribbon
is composed of a series of tool panels, which are organized into tabs labeled by task.
The Ribbon provides a compact palette of all of the tools necessary to accomplish the
different modeling tasks. The drop-down arrow next to any icon indicates additional
commands are available on the expanded panel; access the expanded panel by
clicking on the drop-down arrow.
7-6
•
Tools for Design Using AutoCAD and Autodesk Inventor
File Menu
The File menu at the upper left corner of the
main window contains tools for all filerelated operations, such as Open, Save,
Export, etc.
•
Quick Access Toolbar
The Quick Access toolbar at the top of the Inventor window allows us quick access to
file-related commands and to Undo/Redo the last operations.
•
Ribbon Tabs and Tool panels
The Ribbon is composed of a series of tool panels, which are organized into tabs labeled
by task. The assortments of tool panels can be accessed by clicking on the tabs.
•
Online Help Panel
The Help options panel provides us with multiple options to access online help for
Autodesk Inventor. The Online Help system provides general help information, such as
command options and command references.
Parametric Modeling Fundamentals - Autodesk Inventor
•
7-7
3D Model Toolbar
The 3D Model toolbar provides tools for creating the different types of 3D features, such
as Extrude, Revolve, Sweep, etc.
•
Graphics Window
The graphics window is the area where models and drawings are displayed.
•
Message and Status Bar
The Message and Status Bar area shows a single-line help when the cursor is on top of an
icon. This area also displays information pertinent to the active operation. For example,
in the figure above, the coordinates and length information of a line are displayed while
the Line command is activated.
7-8
Tools for Design Using AutoCAD and Autodesk Inventor
Mouse Buttons
Autodesk Inventor utilizes the mouse buttons extensively. In learning Autodesk
Inventor's interactive environment, it is important to understand the basic functions of the
mouse buttons. It is highly recommended that you use a mouse or a tablet with Autodesk
Inventor since the package uses the buttons for various functions.
•
Left mouse button
The left-mouse-button is used for most operations, such as selecting menus and
icons, or picking graphic entities. One click of the button is used to select icons,
menus and form entries, and to pick graphic items.
•
Right mouse button
The right-mouse-button is used to bring up additional available options. The
software also utilizes the right-mouse-button the same as the ENTER key, and is
often used to accept the default setting to a prompt or to end a process.
•
Middle mouse button/wheel
The middle-mouse-button/wheel can be used to Pan (hold down the wheel button
and drag the mouse) or Zoom (turn the wheel) realtime.
Allows quick Pan
and Zoom.
Brings up additional available
options. Also used to accept the
default option of a command, or
end a process.
Picks icons, menus,
and graphic entities.
[Esc] – Canceling Commands
The [Esc] key is used to cancel a command in Autodesk Inventor. The [Esc] key is
located near the top-left corner of the keyboard. Sometimes, it may be necessary to press
the [Esc] key twice to cancel a command; it depends on where we are in the command
sequence. For some commands, the [Esc] key is used to exit the command.
Parametric Modeling Fundamentals - Autodesk Inventor
7-9
Autodesk Inventor Help System
 Several types of help are available at any time
during an Autodesk Inventor session. Autodesk
Inventor provides many help functions, such
as:
•
Use the Help button near the upper right corner
of the Inventor window.
•
Help quick-key: Press the [F1] key to access
the Inventor Help system.
•
•
Use the Info Center to get information
on a specific topic.
Use the Autodesk Exchange to access
information on the Autodesk community
website.
7-10
Tools for Design Using AutoCAD and Autodesk Inventor
Data Management Using Inventor Project files
With Autodesk Inventor, it is quite feasible to create designs without any regard to using
the Autodesk Inventor data management system. Data management becomes critical for
projects involving complex designs, especially when multiple team members are
involved, or when we are working on integrating multiple design projects, or when it is
necessary to share files among the design projects. Autodesk Inventor provides a fairly
flexible data management system. It allows one person to use the basic option to help
manage the locations of the different design files, or a team of designers can use the data
management system to manage their projects stored on a networked computer system.
The Autodesk Inventor data management system organizes files based on projects. Each
project is identified with a main folder that can contain files and folders associated to the
design. In Autodesk Inventor, a project file (.ipj) defines the locations of all files
associated with the project, including templates and library files.
The Autodesk Inventor data management system uses two types of projects:
 Single-user Project
 Autodesk Vault Project (installation of Autodesk Vault software is required)
The single-user project is for simpler projects where all project files are located on the
same computer. The Autodesk Vault project is more suitable for projects requiring
multiple users using a networked computer system.
1. Click on the Get Started tab, with the leftmouse-button, in the Ribbon toolbar.
 Note the Get Started tab is the default panel
displayed during startup.
2. Click on the Projects icon with a single click of the left-mouse-button in the
Launch toolbar.
 The Projects Editor appears on the screen. Note that several options are available
to access the Editor; it can also be accessed through the Open file command.
Parametric Modeling Fundamentals - Autodesk Inventor
7-11
 In the Projects Editor: the Default project is available.
The Default project is automatically active by default, and the default project does not
define any location for files. In other words, the data management system is not used.
Using the default project, designs can still be created and modified, and any model file
can be opened and saved anywhere without regard to project and file management.
Setup of a New Inventor Project
In this section, we will create a new Inventor project for the chapters of this book using
the Inventor built-in Single User Project option. Note that it is also feasible to create a
separate project for each chapter.
1. Click New to begin the setup of a new project file.
7-12
Tools for Design Using AutoCAD and Autodesk Inventor
2. The Inventor project wizard appears on the screen; select the New Single User
Project option as shown.
3. Click Next to proceed with the next setup option.
4. In the Project File Name input box, enter Parametric-Modeling as the name of
the new project.
5. In the Project Folder input box, note the default folder location, such as
C:\Users\Documents\Inventor-Data\Parametric Modeling\ is displayed;
choose a preferred folder name as the folder name of the new project.
6. Click Finish to proceed with the creation of the new project.
Parametric Modeling Fundamentals - Autodesk Inventor
7-13
7. A warning message appears on
the screen, indicating the
specified folder does not exist.
Click OK to create the folder.
8. A second warning message appears on the screen, indicating that the newly
created project cannot be made active since an Inventor file is open. Click OK to
close the message dialog box.
•
The new project has been created and its name appears in the project list area as
shown in the figure.
9. Click Done to exit the Inventor Projects Editor option.
7-14
Tools for Design Using AutoCAD and Autodesk Inventor
The Content of the Inventor Project File
An Inventor project file is actually a text file in .xml format with an .ipj extension. The
file specifies the paths to the folder containing the files in the project. To assure that
links between files work properly, it is advised to add the locations for folders to the
project file before working on model files.
Leaving Autodesk Inventor
To leave the Application menu, use the left-mouse-button and click on Exit Autodesk
Inventor from the pull-down menu.
Parametric Modeling Fundamentals - Autodesk Inventor
7-15
Feature-Based Parametric Modeling
The feature-based parametric modeling technique enables the designer to incorporate
the original design intent into the construction of the model. The word parametric means
the geometric definitions of the design, such as dimensions, can be varied at any time in
the design process. Parametric modeling is accomplished by identifying and creating the
key features of the design with the aid of computer software. The design variables,
described in the sketches as parametric relations, can then be used to quickly
modify/update the design.
In Autodesk Inventor, the parametric part modeling process involves the following steps:
1. Create a rough two-dimensional sketch of the basic shape of the base feature
of the design.
2. Apply/modify constraints and dimensions to the two-dimensional sketch.
3. Extrude, revolve, or sweep the parametric two-dimensional sketch to create
the base solid feature of the design.
4. Add additional parametric features by identifying feature relations and
complete the design.
5. Perform analyses on the computer model and refine the design as needed.
6. Create the desired drawing views to document the design.
The approach of creating two-dimensional sketches of the three-dimensional features is
an effective way to construct solid models. Many designs are in fact the same shape in
one direction. Computer input and output devices we use today are largely twodimensional in nature, which makes this modeling technique quite practical. This method
also conforms to the design process that helps the designer with conceptual design along
with the capability to capture the design intent. Most engineers and designers can relate
to the experience of making rough sketches on restaurant napkins to convey conceptual
design ideas. Autodesk Inventor provides many powerful modeling and design tools, and
there are many different approaches to accomplishing modeling tasks. The basic principle
of feature-based modeling is to build models by adding simple features one at a time. In
this chapter, the general parametric part modeling procedure is illustrated; a very simple
solid model with extruded features is used to introduce the Autodesk Inventor user
interface. The display viewing functions and the basic two-dimensional sketching tools
are also demonstrated.
7-16
Tools for Design Using AutoCAD and Autodesk Inventor
The Adjuster Design
Starting Autodesk Inventor
1. Select the Autodesk Inventor option on the Start menu or select the
Autodesk Inventor icon on the desktop to start Autodesk Inventor. The
Autodesk Inventor main window will appear on the screen.
2. Select the Projects icon with a single click of the
left-mouse-button.
Parametric Modeling Fundamentals - Autodesk Inventor
7-17
3. In the Projects List, double-click on the Parametric-Modeling project name to
activate the project as shown.
•
Note that Autodesk Inventor will keep this activated project as the default project
until another project is activated.
4. Click Done to accept the setting and end the Projects Editor.
5. Select the New File icon with a single click of the
left-mouse-button.
•
Notice the Parametric-Modeling project name is
displayed as the active project.
6. Select the English tab as shown below. When starting a new CAD file, the first
thing we should do is choose the units we would like to use. We will use the
English setting (inches) for this example.
6. English
7. Standard.ipt
7. Select the Standard(in).ipt icon as shown.
8. Pick Create in the New File dialog box to accept the selected
settings.
7-18
Tools for Design Using AutoCAD and Autodesk Inventor
Sketch Plane – It is an XY monitor, but an XYZ World
Design modeling software is becoming more
powerful and user friendly, yet the system still
does only what the user tells it to do. When
using a geometric modeler, we therefore need
to have a good understanding of what its
inherent limitations are.
In most 3D geometric modelers, 3D objects
are located and defined in what is usually
called world space or global space. Although
a number of different coordinate systems can
be used to create and manipulate objects in a
3D modeling system, the objects are typically
defined and stored using the world space. The
world space is usually a 3D Cartesian
coordinate system that the user cannot change
or manipulate.
In engineering designs, models can be very complex, and it would be tedious and
confusing if only the world coordinate system were available. Practical 3D modeling
systems allow the user to define Local Coordinate Systems (LCS) or User Coordinate
Systems (UCS) relative to the world coordinate system. Once a local coordinate system
is defined, we can then create geometry in terms of this more convenient system.
Although objects are created and stored in 3D space coordinates, most of the geometric
entities can be referenced using 2D Cartesian coordinate systems. Typical input devices
such as a mouse or digitizer are two-dimensional by nature; the movement of the input
device is interpreted by the system in a planar sense. The same limitation is true of
common output devices, such as CRT displays and plotters. The modeling software
performs a series of three-dimensional to two-dimensional transformations to correctly
project 3D objects onto the 2D display plane.
The Autodesk Inventor sketching plane is a special construction approach that enables
the planar nature of the 2D input devices to be directly mapped into the 3D coordinate
system. The sketching plane is a local coordinate system that can be aligned to an
existing face of a part, or a reference plane.
Think of the sketching plane as the surface on which we can sketch the 2D sections of the
parts. It is similar to a piece of paper, a white board, or a chalkboard that can be attached
to any planar surface. The first sketch we create is usually drawn on one of the
established datum planes. Subsequent sketches/features can then be created on sketching
planes that are aligned to existing planar faces of the solid part or datum planes.
Parametric Modeling Fundamentals - Autodesk Inventor
7-19
1. Activate the Start 2D Sketch icon with a
single click of the left-mouse-button.
2. Move the cursor over the edge of the XY Plane in the graphics area. When the XY
Plane is highlighted, click once with the left-mouse-button to select the Plane as
the sketch plane for the new sketch.
•
The sketching plane is a reference location where two-dimensional sketches are
created. Note that the sketching plane can be any planar part surface or datum
plane.
3. Confirm the main Ribbon area is switched to the Sketch toolbars; this indicates
we have entered the 2D Sketching mode.
7-20
Tools for Design Using AutoCAD and Autodesk Inventor
Creating Rough Sketches
Quite often during the early design stage, the shape of a design may not have any precise
dimensions. Most conventional CAD systems require the user to input the precise lengths
and locations of all geometric entities defining the design, which are not available during
the early design stage. With parametric modeling, we can use the computer to elaborate
and formulate the design idea further during the initial design stage. With Autodesk
Inventor, we can use the computer as an electronic sketchpad to help us concentrate on
the formulation of forms and shapes for the design. This approach is the main advantage
of parametric modeling over conventional solid-modeling techniques.
As the name implies, a rough sketch is not precise at all. When sketching, we simply
sketch the geometry so that it closely resembles the desired shape. Precise scale or
lengths are not needed. Autodesk Inventor provides many tools to assist us in finalizing
sketches. For example, geometric entities such as horizontal and vertical lines are set
automatically. However, if the rough sketches are poor, it will require much more work
to generate the desired parametric sketches. Here are some general guidelines for creating
sketches in Autodesk Inventor:
•
Create a sketch that is proportional to the desired shape. Concentrate on the
shapes and forms of the design.
•
Keep the sketches simple. Leave out small geometry features such as fillets, rounds
and chamfers. They can easily be placed using the Fillet and Chamfer commands
after the parametric sketches have been established.
•
Exaggerate the geometric features of the desired shape. For example, if the
desired angle is 85 degrees, create an angle that is 50 or 60 degrees. Otherwise,
Autodesk Inventor might assume the intended angle to be a 90-degree angle.
•
Draw the geometry so that it does not overlap. The geometry should eventually
form a closed region. Self-intersecting geometry shapes are not allowed.
•
The sketched geometric entities should form a closed region. To create a solid
feature, such as an extruded solid, a closed region is required so that the extruded
solid forms a 3D volume.
 Note: The concepts and principles involved in parametric modeling are very
different, and sometimes they are totally opposite, to those of conventional computer
aided drafting. In order to understand and fully utilize Autodesk Inventor’s
functionality, it will be helpful to take a Zen approach to learning the topics presented
in this text: Have an open mind and temporarily forget your experiences using
conventional Computer Aided Drafting systems.
Parametric Modeling Fundamentals - Autodesk Inventor
7-21
Step 1: Creating a Rough Sketch
The Sketch toolbar provides tools for creating the basic geometry that can be used to
create features and parts.
1. Move the graphics cursor to the Line icon in the
Sketch toolbar. A Help-tip box appears next to the
cursor and a brief description of the command is
displayed at the bottom of the drawing screen:
“Creates Straight lines and arcs.”
2. Select the icon by clicking once with the leftmouse-button; this will activate the Line
command. Autodesk Inventor expects us to identify
the starting location of a straight line.
Graphics Cursors
Notice the cursor changes from an arrow to a crosshair when graphical input is
expected.
1. Left-click a starting point for the shape, roughly just below the center of the
graphics window.
2. As you move the graphics cursor, you will see a digital readout next to the cursor
and also in the Status Bar area at the bottom of the window. The readout gives
you the cursor location, the line length, and the angle of the line measured from
horizontal. Move the cursor around and you will notice different symbols appear
at different locations.
 The readout displayed next to the cursor is called the Dynamic Input. This option
is part of the Heads-Up Display option that is now available in Inventor. Note
that Dynamic Input can be used for entering precise values, but its usage is
somewhat limited in parametric modeling.
7-22
Tools for Design Using AutoCAD and Autodesk Inventor
3. Move the graphics cursor toward the right side of the graphics window and create
a horizontal line as shown below (Point 2). Notice the geometric constraint
symbol, a short horizontal line indicating the geometric property, is displayed.
Point 1
Point 2
Constraint
Symbol
Geometric Constraint Symbols
Autodesk Inventor displays different visual clues, or symbols, to show you alignments,
perpendicularities, tangencies, etc. These constraints are used to capture the design intent
by creating constraints where they are recognized. Autodesk Inventor displays the
governing geometric rules as models are built. To prevent constraints from forming, hold
down the [Ctrl] key while creating an individual sketch curve. For example, while
sketching line segments with the Line command, endpoints are joined with a Coincident
constraint, but when the [Ctrl] key is pressed and held, the inferred constraint will not be
created.
Vertical
indicates a line is vertical
Horizontal
indicates a line is horizontal
Dashed line
indicates the alignment is to the center point or
endpoint of an entity
Parallel
indicates a line is parallel to other entities
Perpendicular
indicates a line is perpendicular to other entities
Coincident
indicates the cursor is at the endpoint of an entity
Concentric
indicates the cursor is at the center of an entity
Tangent
indicates the cursor is at tangency points to curves
Parametric Modeling Fundamentals - Autodesk Inventor
7-23
1. Complete the sketch as shown below, creating a closed region ending at the
starting point (Point 1). Do not be overly concerned with the actual size of the
sketch. Note that all line segments are sketched horizontally or vertically.
Point 6
Point 5
Point 4
Point 1
Point 3
Point 2
2. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select
Cancel [Esc] in the pop-up menu, or hit the [Esc] key
once to end the Sketch Line command.
Step 2: Apply/Modify Constraints and Dimensions
As the sketch is made, Autodesk Inventor automatically applies some of the geometric
constraints (such as horizontal, parallel, and perpendicular) to the sketched geometry. We
can continue to modify the geometry, apply additional constraints, and/or define the size
of the existing geometry. In this example, we will illustrate adding dimensions to
describe the sketched entities.
1. Move the cursor to the Constrain
toolbar area; it is the toolbar next to the
2D Draw toolbar. Note the first icon in
this toolbar is the General Dimension
icon. The Dimension command is
generally known as Smart
Dimensioning in parametric
modeling.
7-24
Tools for Design Using AutoCAD and Autodesk Inventor
2. Move the cursor on top of the
Dimension icon. The Smart
Dimensioning command allows us to
quickly create and modify dimensions.
Left-click once on the icon to activate
the Dimension command.
3. The message “Select Geometry to Dimension” is displayed in the Status Bar area
at the bottom of the Inventor window. Select the bottom horizontal line by leftclicking once on the line.
3. Pick the bottom horizontal
line as the geometry to
dimension.
4. Pick a location below
the line to place the
dimension.
4. Move the graphics cursor below the selected line and left-click to place the
dimension. (Note that the value displayed on your screen might be different than
what is shown in the figure above.)
5. Accept the default value by clicking on the Accept
button as shown.
 The General Dimension command will create a length dimension if a single line is
selected.
Parametric Modeling Fundamentals - Autodesk Inventor
7-25
6. The message “Select Geometry to Dimension” is displayed in the Status Bar area,
located at the bottom of the Inventor window. Select the top-horizontal line as
shown below.
7. Select the bottom-horizontal line as shown below.
6. Pick the top line as the
1st geometry to dimension.
8. Place the dimension
next to the sketch.
7. Pick the bottom line
as the 2nd geometry to
dimension.
8. Pick a location to the left of the sketch to place the dimension.
9. Accept the default value by clicking on the Accept button.
 When two parallel lines are selected, the General Dimension command will create a
dimension measuring the distance between them.
10. On your own, repeat the above steps
and create additional dimensions
(accepting the default values created
by Inventor) so that the sketch
appears as shown.
7-26
Tools for Design Using AutoCAD and Autodesk Inventor
Dynamic Viewing Functions – Zoom and Pan
Autodesk Inventor provides a special user interface called Dynamic Viewing that
enables convenient viewing of the entities in the graphics window.
1. Click on the Zoom icon located in the Navigation bar
as shown.
2. Move the cursor near the center of the graphics
window.
3. Inside the graphics window, press and hold down the
left-mouse-button, then move downward to enlarge
the current display scale factor.
4. Press the [Esc] key once to exit the Zoom command.
5. Click on the Pan icon located above the Zoom command in the
Navigation bar. The icon is the picture of a hand.
 The Pan command enables us to move the view to a different
position. This function acts as if you are using a video camera.
6. On your own, use the Zoom and Pan options to reposition the
sketch near the center of the screen.
Modifying the Dimensions of the Sketch
1. Select the dimension that is at the bottom of the
sketch by double-clicking on the dimension
text.
1. Select this dimension
to modify.
2. In the Edit Dimension window, the current
length of the line is displayed. Enter 2.5 to set
the length of the line.
3. Click on the Accept icon to accept the entered
value.
 Autodesk Inventor will now update the profile with the new dimension value.
Parametric Modeling Fundamentals - Autodesk Inventor
7-27
4. On your own, repeat the
above steps and adjust the
dimensions so that the
sketch appears as shown.
5. In the Ribbon toolbar, click once with the left-mousebutton to select Finish Sketch in the Ribbon area to
end the Sketch option.
Step 3: Completing the Base Solid Feature
Now that the 2D sketch is completed, we will proceed to the next step: create a 3D part
from the 2D profile. Extruding a 2D profile is one of the common methods that can be
used to create 3D parts. We can extrude planar faces along a path. We can also specify a
height value and a tapered angle. In Autodesk Inventor, each face has a positive side and
a negative side; the current face we're working on is set as the default positive side. This
positive side identifies the positive extrusion direction and it is referred to as the face's
normal.
1. In the 3D Model tab, select the Extrude
command by clicking the left-mouse-button on
the icon as shown.
7-28
Tools for Design Using AutoCAD and Autodesk Inventor
2. In the Extrude edit box, enter 2.5 as the extrusion distance. Notice that the sketch
region is automatically selected as the extrusion profile.
3. Click on the OK button to proceed with creating the 3D part.
 Note that all dimensions disappeared from the screen. All parametric definitions are
stored in the Autodesk Inventor database and any of the parametric definitions can
be re-displayed and edited at any time.
Isometric View
Autodesk Inventor provides many ways to display views of the three-dimensional
design. Several options are available that allow us to quickly view the design to track the
overall effect of any changes being made to the model. We will first orient the model to
display in the isometric view by using the pull-down menu.
1. Hit the function key [F6] once to
automatically adjust the display
and also reset the display to the
isometric view.
 Note that most of the view-related
commands can be accessed in the
ViewCube and/or the Navigation
bar located to the right side of the
graphics window.
Parametric Modeling Fundamentals - Autodesk Inventor
7-29
 Dynamic Rotation of the 3D Block – Free Orbit
The Free Orbit command allows us to:
• Orbit a part or assembly in the graphics window. Rotation can be around the
center mark, free in all directions, or around the X/Y-axes in the 3D-Orbit
display.
• Reposition the part or assembly in the graphics window.
• Display isometric or standard orthographic views of a part or assembly.
The Free Orbit tool is accessible while other tools are active. Autodesk Inventor
remembers the last used mode when you exit the Orbit command.
1. Click on the Free Orbit icon in the Navigation bar.
 The 3D Orbit display is a circular rim with four handles and a center mark. 3D Orbit
enables us to manipulate the view of 3D objects by clicking and dragging with the
left-mouse-button:
Handle
Center Mark
•
Drag with the left-mousebutton near the center for free
rotation.
•
Drag on the handles to orbit
around the horizontal or
vertical axes.
•
Drag on the rim to orbit about
an axis that is perpendicular to
the displayed view.
•
Single left-click to align the
center mark of the view.
2. Inside the circular rim, press down the left-mouse-button and drag in an arbitrary
direction; the 3D Orbit command allows us to freely orbit the solid model.
3. Move the cursor near the circular rim and notice the cursor symbol changes to a
single circle. Drag with the left-mouse-button to orbit about an axis that is
perpendicular to the displayed view.
7-30
Tools for Design Using AutoCAD and Autodesk Inventor
4. Single left-click near the top-handle to align the selected location to the center
mark in the graphics window.
5. Activate the Constrained Orbit option by clicking on the associated icon as
shown.
 The Constrained Orbit can be used to rotate the model about axes in Model Space,
equivalent to moving the eye position about the model in latitude and longitude.
6. On your own, use the different options described in the above steps and
familiarize yourself with both of the 3D Orbit commands. Reset the display to the
Isometric view as shown in the above figure before continuing to the next section.
 Note that while in the 3D Orbit mode, a horizontal marker will be displayed next
to the cursor if the cursor is away from the circular rim. This is the exit marker.
Left-clicking once will allow you to exit the 3D Orbit command.
Exit marker
Parametric Modeling Fundamentals - Autodesk Inventor
7-31
Dynamic Viewing – Quick Keys
We can also use the function keys on the keyboard and the mouse to access the Dynamic
Viewing functions.
 Panning – (1) F2 and the left-mouse-button
Hold the F2 function key down, and drag with the left-mouse-button to pan the
display. This allows you to reposition the display while maintaining the same
scale factor of the display.
Pan
F2
+
MOUSE
(2) Press and drag with the mouse wheel
Pressing and dragging with the mouse wheel can also
reposition the display.
 Zooming – (1) F3 and drag with the left-mouse-button
Hold the F3 function key down, and drag with the left-mouse-button vertically on
the screen to adjust the scale of the display. Moving upward will reduce the scale
of the display, making the entities display smaller on the screen. Moving
downward will magnify the scale of the display.
Zoom
F3
+
MOUSE
(2) Turning the mouse wheel
Turning the mouse wheel can also adjust the scale of the
display. Turning forward will reduce the scale of the
display, making the entities display smaller on the screen.
Turning backward will magnify the scale of the display.
7-32
Tools for Design Using AutoCAD and Autodesk Inventor
 3D Dynamic Rotation – Shift and the middle-mouse-button
Hold the Shift key down and drag with the middle-mouse-button to orbit the
display. Note that the 3D dynamic rotation can also be activated using the F4
function key and the left-mouse-button.
Dynamic Rotation
Shift
+
MOUSE
Viewing Tools – Standard Toolbar
View Cube
Full Navigation
Wheel
Zoom All
Pan
Zoom
Free Orbit
Constrained Orbit
Look At
Zoom All – Adjusts the view so that all items on the screen fit inside the graphics
window.
Zoom Window – Use the cursor to define a region for the view; the defined region is
zoomed to fill the graphics window.
Zoom – Moving upward will reduce the scale of the display, making the entities display
smaller on the screen. Moving downward will magnify the scale of the display.
Pan – This allows you to reposition the display while maintaining the same scale factor
of the display.
Zoom Selected – In a part or assembly, zooms the selected edge, feature, line, or other
element to fill the graphics window. You can select the element either before or after
clicking the Zoom button. (Not used in drawings.)
Parametric Modeling Fundamentals - Autodesk Inventor
7-33
Orbit – In a part or assembly, adds an orbit symbol and cursor to the view. You can orbit
the view planar to the screen around the center mark, around a horizontal or vertical axis,
or around the X and Y axes. (Not used in drawings.)
Look At – In a part or assembly, zooms and orbits the model to display the selected
element planar to the screen or a selected edge or line horizontal to the screen. (Not used
in drawings.)
View Cube – The ViewCube is a 3D navigation tool that appears, by default, when you
enter Inventor. The ViewCube is a clickable interface which allows you to switch
between standard and isometric views.
Once the ViewCube is displayed, it is shown in one of the corners of the graphics
window over the model in an inactive state. The ViewCube also provides visual
feedback about the current viewpoint of the model as view changes occur. When the
cursor is positioned over the ViewCube, it becomes active and allows you to switch to
one of the available preset views, roll the current view, or change to the Home view of
the model.
1. Move the cursor over the ViewCube and notice the different
sides of the ViewCube become highlighted and can be
activated.
2. Single left-click when the front side is activated as shown. The
current view is set to view the front side.
3. Move the cursor over the counter-clockwise arrow of the
ViewCube and notice the orbit option becomes highlighted.
4. Single left-click to activate the counter-clockwise option as
shown. The current view is orbited 90 degrees; we are still
viewing the front side.
5. Move the cursor over the left arrow of the ViewCube and notice
the orbit option becomes highlighted.
6. Single left-click to activate the left arrow option as shown. The
current view is now set to view the top side.
7-34
Tools for Design Using AutoCAD and Autodesk Inventor
7. Move the cursor over the top edge of the ViewCube and notice
the roll option becomes highlighted.
8. Single left-click to activate the roll option as shown. The view
will be adjusted to roll 45 degrees.
9. Move the cursor over the ViewCube and drag with the leftmouse-button to activate the Free Rotation option.
10. Move the cursor over the home icon of the ViewCube and notice
the Home View option becomes highlighted.
11. Single left-click to activate the Home View option as shown.
The view will be adjusted back to the default isometric view.
Full Navigation Wheel – The Navigation Wheel contains tracking menus that are
divided into different sections known as wedges. Each wedge on a wheel represents a
single navigation tool. You can pan, zoom, or manipulate the current view of a model in
different ways. The 3D Navigation Wheel and 2D Navigation Wheel (mostly used in
the 2D drawing mode) have some or all of the following options:
Zoom – Adjusts the magnification of the view.
Center – Centers the view based on the position of the cursor over the wheel.
Rewind – Restores the previous view.
Forward – Increases the magnification of the view.
Orbit – Allows 3D free rotation with the left-mouse-button.
Pan – Allows panning by dragging with the left-mouse-button.
Up/Down – Allows panning with the use of a scroll control.
Walk – Allows walking, with linear motion perpendicular to the screen, through
the model space.
Look – Allows rotation of the current view vertically and horizontally.
3D Full Navigation Wheel
2D Full Navigation Wheel
Parametric Modeling Fundamentals - Autodesk Inventor
7-35
1. Activate the Full Navigation Wheel by clicking on the icon as shown.
2. Move the cursor in the graphics window and
notice the Full Navigation Wheel menu
follows the cursor on the screen.
3. Move the cursor on the Orbit option to
highlight the option.
4.
Click and drag with the left-mouse-button
to activate the Free Rotation option.
5. Drag with the left-mousebutton and notice the
ViewCube also reflects the
model orientation.
6. Move the cursor to the left side
of the model and click the
Center option as shown. The
display is adjusted so the
selected point is the new
Zoom/Orbit center.
7. On your own, experiment with
the other available options.
7-36
Tools for Design Using AutoCAD and Autodesk Inventor
Display Modes
•
The Visual Style in the View tab has
eleven display-modes ranging from
very realistic renderings of the model
to very artistic representations of the
model. The more commonly used
modes are as follows:
 Realistic Shaded Solid:
The Realistic Shaded Solid display mode generates a high
quality shaded image of the 3D object.
 Standard Shaded Solid:
The Standard Shaded Solid display option generates a shaded
image of the 3D object that requires fewer computer resources
compared to the realistic rendering.
 Wireframe Image:
The Wireframe Image display option allows the display of the
3D objects using the basic wireframe representation scheme.
 Wireframe with Hidden-Edges:
The Wireframe with Hidden-Edges option can be used to
generate an image of the 3D object with all the back lines
shown as hidden-lines.
Orthographic vs. Perspective
•
Besides the above basic display modes, we can also choose orthographic view or
perspective view of the display. Click on the triangle icon next to the display mode
button on the View toolbar, as shown in the figure.
 Orthographic
The first icon allows the display of the 3D object
using the parallel edges representation scheme.
 Perspective
The second icon allows the display of the 3D object
using the perspective, nonparallel edges, and
representation scheme.
Parametric Modeling Fundamentals - Autodesk Inventor
7-37
Disable the Heads-Up Display Option
The Heads-Up Display option in Inventor provides mainly the Dynamic Input
function, which can be quite useful for 2D drafting activities. For example, in the use of a
2D drafting CAD system, most of the dimensions of the design would have been
determined by the documentation stage. However, in parametric modeling, the usage of
the Dynamic Input option is quite limited, as this approach does not conform to the
“shape before size” design philosophy.
1. Select the Tools tab in the
Ribbon as shown.
2. Select Application Options in the options
toolbar as shown.
3. Pick the Sketch tab
to display the sketch
related settings.
4. In the Heads-Up
Display section, turn
OFF the Enable
Heads-Up Display
option as shown.
5. On your own, examine the other sketch settings that are available; switch On the
Grid lines, Minor grid lines and Axes options in the Display section.
6. Click Close to accept the settings.
7-38
Tools for Design Using AutoCAD and Autodesk Inventor
Step 4-1: Adding an Extruded Feature
1. Activate the 3D Model tab and select the Start 2D
Sketch command by left-clicking once on the icon.
2. In the Status Bar area, the message “Select plane to
create sketch or an existing sketch to edit” is displayed.
Autodesk Inventor expects us to identify a planar
surface where the 2D sketch of the next feature is to be
created. Move the graphics cursor on the 3D part and
notice that Autodesk Inventor will automatically
highlight feasible planes and surfaces as the cursor is on
top of the different surfaces. Pick the top horizontal face
of the 3D solid object.
2. Pick the top face of
the solid model.
 Note that the sketch plane is
aligned to the selected face.
Autodesk Inventor automatically
establishes a User-CoordinateSystem (UCS) and records its
location with respect to the part
on which it was created.
•
Next, we will create and profile another sketch, a rectangle, which will be used to
create another extrusion feature that will be added to the existing solid object.
3. Select the Line command by clicking once with the
left-mouse-button on the icon in the Sketch tab on the
Ribbon.
Parametric Modeling Fundamentals - Autodesk Inventor
7-39
4. Create a sketch with segments perpendicular/parallel to the existing edges of the solid
model as shown below.
5. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select
Cancel (ESC) in the pop-up menu to end the Line
command.
6. Select the General Dimension
command in the Sketch toolbar. The
General Dimension command allows
us to quickly create and modify
dimensions. Left-click once on the icon
to activate the General Dimension
command.
7. The message “Select
Geometry to Dimension”
is displayed in the Status
Bar area at the bottom of
the Inventor window.
8. Create the four
dimensions to describe
the size of the sketch as
shown in the figure.
7-40
Tools for Design Using AutoCAD and Autodesk Inventor
9. Create the two location
dimensions to describe the
position of the sketch relative
to the top corner of the solid
model as shown.
10. On your own, modify the two location dimensions to 0.0 and adjust the size
dimensions as shown in the figure below.
11. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select OK
in the pop-up menu to end the General Dimension
command.
12. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select
Finish 2D Sketch in the pop-up menu to end the
Sketch option.
Parametric Modeling Fundamentals - Autodesk Inventor
7-41
13. In the 3D Model tab select the Extrude command
by left-clicking on the icon.
14. In the Extrude pop-up window, enter 2.5 as the
extrude distance as shown.
15. Click on the direction icon and choose
direction 2 as shown.
16. Click on the OK button to proceed with creating the extruded feature.
7-42
Tools for Design Using AutoCAD and Autodesk Inventor
Step 4-2: Adding a Cut Feature
Next, we will create and profile a circle, which will be used to create a cut feature that will
be added to the existing solid object.
1. In the 3D Model tab select the Start 2D Sketch command
by left-clicking once on the icon.
2. In the Status Bar area, the message “Select plane to create
sketch or an existing sketch to edit.” is displayed. Autodesk
Inventor expects us to identify a planar surface where the
2D sketch of the next feature is to be created. Pick the top
horizontal face of the 3D solid model as shown.
 Note that the sketch plane is aligned to
the selected face. Autodesk Inventor
automatically establishes a UserCoordinate-System (UCS) and records
its location with respect to the part on
which it was created.
3. Select the Center point circle
command by clicking once with the
left-mouse-button on the icon in the
Sketch tab on the Ribbon.
4. Create a circle of arbitrary size on
the top face of the solid model as
shown.
Parametric Modeling Fundamentals - Autodesk Inventor
7-43
5. On your own, create and modify the dimensions of the sketch as shown in the
figure.
6. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select OK
in the pop-up menu to end the General Dimension
command.
7. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select
Finish 2D Sketch in the pop-up menu to end the
Sketch option.
8. In the 3D Model tab select the Extrude
command by clicking the left-mouse-button on
the icon.
9. In the Extrude pop-up control, the Profile
button is pressed down; Autodesk Inventor
expects us to identify the profile to be extruded.
7-44
Tools for Design Using AutoCAD and Autodesk Inventor
10. Click on the inside of the
sketched circle as shown.
11. Select the CUT option in the feature option
list to set the extrusion operation to Cut.
12. Set the Extents option to Through All as shown. The All option instructs the
software to calculate the extrusion distance and assures the created feature will
always cut through the full length of the model.
13. Click on the OK button to proceed with creating the
extruded feature.
Parametric Modeling Fundamentals - Autodesk Inventor
7-45
Step 4-3: Adding another Cut Feature
Next, we will create and profile a triangle, which will be used to create a cut feature that
will be added to the existing solid object.
1. In the 3D Model tab select the Start 2D Sketch command
by left-clicking once on the icon.
2. In the Status Bar area, the message “Select
plane to create sketch or an existing sketch to
edit.” is displayed. Autodesk Inventor expects
us to identify a planar surface where the 2D
sketch of the next feature is to be created. Pick
the vertical face of the 3D solid model next to
the horizontal section as shown.
7-46
Tools for Design Using AutoCAD and Autodesk Inventor
3. Select the Line command by clicking once with the
left-mouse-button on the icon in the Sketch tab.
4. Start at the upper left corner and create
three line segments to form a small triangle
as shown.
5. On your own, create and modify
the two dimensions of the
sketch as shown in the figure.
(Hint: create the angle
dimension by selecting the two
adjacent lines and place the
angular dimension inside the
desired quadrant.)
6. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select OK in
the pop-up menu to end the General Dimension
command.
7. Inside the graphics window, click once with the rightmouse-button to display the option menu. Select
Finish 2D Sketch in the pop-up menu to end the
Sketch option.
Parametric Modeling Fundamentals - Autodesk Inventor
7-47
8. In the 3D Model tab, select the Extrude
command by left-clicking the icon.
9. Select the CUT option in the feature option list
to set the extrusion operation to Cut.
10. Set the Extents option to To next face/body as
shown. The To Next option instructs the software to
calculate the extrusion distance and assures the
created feature will always cut through the proper
length of the model.
11. Click on the OK button to proceed with creating the
extruded feature.
7-48
Tools for Design Using AutoCAD and Autodesk Inventor
Save the Model
1. Select Save in the Quick Access toolbar, or you
can also use the “Ctrl-S” combination (hold
down the “Ctrl” key and hit the “S” key once) to
save the part.
2. In the Save As dialog box,
right-click once in the list
area to bring up the option
menu.
3. In the option list, select New
as shown.
4. In the second option list, select Folder to
create a subfolder.
5. Enter Chapter7 as the new folder
name as shown.
6. Double-click on the Chapter2
folder to open it.
7. In the file name editor box, enter Adjuster
as the file name.
8. Click on the Save button to save the file.
 You should form a habit of saving your work periodically, just in case something
goes wrong while you are working on it. In general, you should save your work at an
interval of every 15 to 20 minutes. You should also save before making any major
modifications to the model.
Parametric Modeling Fundamentals - Autodesk Inventor
7-49
Review Questions: (Time: 20 minutes)
1. What is the first thing we should set up in Autodesk Inventor when creating a new
model?
2. Describe the general parametric modeling procedure.
3. Describe the general guidelines in creating Rough Sketches.
4. What is the main difference between a rough sketch and a profile?
5. List two of the geometric constraint symbols used by Autodesk Inventor.
6. What was the first feature we created in this lesson?
7. How many solid features were created in the tutorial?
8. How do we control the size of a feature in parametric modeling?
9. Which command was used to create the last cut feature in the tutorial? How many
dimensions do we need to fully describe the cut feature?
10. List and describe three differences between parametric modeling and traditional 2D
Computer Aided Drafting techniques.
7-50
Tools for Design Using AutoCAD and Autodesk Inventor
Exercises: (All dimensions are in inches.)
1. Inclined Support (Thickness: .5)
2. Spacer Plate (Thickness: .125)
Parametric Modeling Fundamentals - Autodesk Inventor
3. Positioning Stop
4. Guide Block
7-51
7-52
Tools for Design Using AutoCAD and Autodesk Inventor
5. Slider Block
6. Circular Spacer
Download PDF