Paris Conversion Manager

the document system
Paris Conversion Manager
Technical Manual
© 1998 XLPrint/Laser Image Technologies Pty. Limited. All rights reserved.
This work is copyright. This manual and its accompanying software may not be reproduced by any means,
mechanical, electronic or otherwise, without the prior agreement and written consent of XLPrint Pty. Limited or
an appointed representative.
The Paris Conversion Manager Technical Manual
First Published, September 1998.
2nd Edition, October 1999
CD-ROM edition, April 2000
Paris Conversion Manager is an XLPrint Software product.
Paris is a trademark of XLPrint Pty. Limited, Sydney, Australia
This document may contain or refer to information and products protected by copyright or patents and does not
convey any license under the patent rights of XLPrint Pty. Limited nor the rights of others. All product names
used in this manual are trademarks of their respective owners.
The information in this document is provided for reference only. Names and data used in examples are fictitious
and are provided for explanatory purposes only.
Written and produced by XLPrint Software Pty. Limited,
Suite 401, 220 Pacific Highway,
Crows Nest,
Sydney, NSW, 2065, Australia.
Printed in Australia
2
The Paris Conversion Manager Technical Manual
CONTENTS
AB O U T T H E P AR I S C O N V E R S I O N M AN AG E R
6
−
P ARIS C ONVERSION M ANAGER S TART - UP WINDOW
7
−
P ARIS C ONVERSION M ANAGER M ENUS
8
−
C USTOMIZING THE D ISPLAY
9
−
P ARIS C ONVERSION M ANAGER T OOLS
11
−
U SING THE O PTIONS M ENU
12
Show Bitmaps .................................................................... 12
Au to-detect Rotation .......................................................... 12
Default Page Siz e .............................................................. 13
O n line Ad just .................................................................... 14
USING THE PARIS CONVERSION MANAGER
15
−
F OR OPTIMAL USE …
15
−
T HE JDL S TRUCTURE
15
−
JDE S IN THE JDL
15
How does the Paris Conv ersion M anager cope w ith JDEs
w ith the same name? ......................................................... 16
BEFORE YOU START…
17
CONVERTING JDLS
18
−
T HE JDL/JDE STRUCTURE
18
Selecting Jobs for Conv ersion ........................................... 19
The Paris Conversion Manager Technical Manual
3
Contents
−
The Paris Conversion Manager
U SING THE JDL/JDE C ONVERTER
20
Conv erting a JDL file ......................................................... 20
FONT ISSUES
−
25
F ONT HANDLING DIFFERENCES BETWEEN PRINTERS
25
Bitmap v s. Scaleable ......................................................... 25
−
X EROX F ONT N AMING C ONVENTIONS
26
−
D IFFERENCES IN P ARIS AND X EROX FONT NAMING CONVENTIONS
27
Sample of the Xfonts.ini file............................................... 28
Font orientation ................................................................. 29
−
X EROX L ICENSED FONTS
CONVERTING FONTS
30
31
−
L OAD THE FONT FILES
31
−
D ISPLAY THE FONTS IN THE C ONVERSION M ANAGER
32
−
G IVE THE FONT A NAME , STYLE AND SIZE
33
−
M AKE F ONT R ESIDENT
34
Setting the Resident Font details ....................................... 34
−
C ONVERTING FONTS WITH POSITIONS BELOW DECIMAL 32
35
For example: ..................................................................... 35
CONVERTING GRAPHICS
−
G RAPHIC DIFFERENCES
38
−
U SING THE G RAPHICS C ONVERTER
39
CONVERTING FORMS
−
4
38
U SING THE F ORMS C ONVERTER
The Paris Conversion Manager Technical Manual
41
42
The Paris Conversion Manager
CONVERTING CMES
−
U SING THE CME C ONVERTER
CONVERTING PDES
−
U SING THE PDE C ONVERTER
The Paris Conversion Manager Technical Manual
Contents
45
46
48
49
5
ABOUT
THE
PA R I S C O N V E R S I O N M A N A G E R
The Paris Conversion Manager has been developed primarily for users of Xerox
Metacode printers.
The Paris Conversion Manager contains a suite of conversion programs that take
as their input various Metacode printer resource types (JDL, FRM, FNT, LGO,
IMG, PDE and CME) and converts them to an internal Paris format. Also included
is the ability to convert Laserjet fonts (.FLJ) and Elixir (.ELX) forms.
Once converted, these jobs can be printed on any Paris supported device. This
combined with the support offered by Paris for DJDE datastreams protects the
considerable investment that existing Xerox centralized customers have in their
print applications.
0 WARNING!
Before starting the Paris Conversion Manager, if you have the Paris Designer
open, close it down!
The Paris Designer should not be active when starting the Paris Conversion
Manager. Both the Designer and the Conversion Manager use common resources
(FRMs, FNTs etc.). The Conversion Manager requires exclusive access to ALL
Paris resources.
The Paris Conversion Manager Technical Manual
6
The Paris Conversion Manager
P ARIS C ONVERSION M ANAGER S TART - UP WINDOW
The Paris Conversion Manager window is displayed below.
The tools provided are:
About/Help
Run
Remove All Previously Converted Resources
Clear Resource List
Save Active Document
Open Document
The Paris Conversion Manager Technical Manual
7
The Paris Conversion Manager
P ARIS C ONVERSION M ANAGER M ENUS
Menu
File
Edit
View
Options
Options
Use To:
Open
Display the Open dialogue which defaults to
the Paris/USR directory.
Save
Display the Save As dialogue to save a
converted file as a Converter Resource List
(*.CRL) file.
Run
Run the Conversion Manager.
Exit
Exit the Conversion Manager.
Clear
Clear the resource list from the Conversion
Manager dialogue.
Remove Prev.
Converted Resources
Remove previously converted resources from
the resource list.
Toolbar
Display or hide the Toolbar.
Status Bar
Display or hide the Status Bar.
Vert Grid
Display or hide the vertical grid.
Horz. Grid
Display or hide the horizontal grid.
3D Grid
Display or hide the 3D grid.
Show Bitmaps
Display bitmaps during FNT or IMG
conversion.
Auto-detect Rotation
Default Page Size
Online Adjust
Detect the orientation of a graphic when
converting IMGs
Set the default page size to be used in the
conversion
Set the value with which to adjust the offset
values specified in the JDL.
Help
8
About Paris
Conversion Manager
Display the program information, version
number and copyright.
Paris Conversion
Manager Help Topics
Display the Paris Conversion Manager Online Help Topics.
The Paris Conversion Manager Technical Manual
The Paris Conversion Manager
C USTOM IZING THE D ISPLAY
The Paris Conversion Manager Display window can be configured to suit your
preferences. Options include hiding or showing the Toolbar, Status Bar, Vertical
and/or Horizontal grid or having a 3D aspect.
In addition, each column can be resized horizontally.
Figure 1: Paris Conversion Manager with ToolBar, Status Bar,
Vertical and Horizontal Grids displayed
The Paris Conversion Manager Technical Manual
9
The Paris Conversion Manager
Figure 2: Paris Conversion Manager with ToolBar, Status Bar and 3D Grid displayed
10
The Paris Conversion Manager Technical Manual
The Paris Conversion Manager
P ARIS C ONVERSION M ANAGER T OOLS
Tool
Tool Name
Tool Action
Open
Open an existing document
Save
Save the active document
Clear List
Clear the Resource List
Remove All
Previously Converted
Resources
Remove all previously converted resources
from the Resource list
Run
Run the Conversion Manager
About/Help
Display Help, program information, Version
number and copyright
The Paris Conversion Manager Technical Manual
11
The Paris Conversion Manager
U SING THE O PTIONS M ENU
The Options Menu provides you with a number of choices when converting
resources.
Show Bitmaps
If the Show Bitmaps option is checked, when converting either FNTs or IMGs, the
bitmaps will be displayed. You would only turn this off if speed is an issue.
Auto-detect Rotation
When converting IMGs, if the Auto-Detect Rotation option is checked, the
orientation (either portrait or landscape) of the graphic is ascertained from the
IMG's header information.
Only portrait images are rotated (90 degrees anti-clockwise) and only if necessary.
Rotated images will appear upright in the Designer window. If not rotated, they
would appear to lay on their right side. Landscape images are not rotated.
12
The Paris Conversion Manager Technical Manual
The Paris Conversion Manager
If you right click the mouse on an IMG entry in the list, a pop up dialogue box will
be displayed. In this dialogue is a checkbox that allows the you to rotate the
graphic.
If the Auto-detect option in the Options Menu is checked, then the checkbox is
ghosted (i.e. you cannot override the rotation of the graphic).
If the Auto-detect option in the menu is not checked then you can choose to rotate
the graphic (the Rotate checkbox is available).
Default Page Size
The user uses this option to set the default page size to be used in the conversion
of JDLs, PDE's, and FRMs.
The Paris Conversion Manager Technical Manual
13
The Paris Conversion Manager
Online Adjust
Certain features in a JDL file require an Offset value to specify where it exists in
an input record. Examples of this are FONTINDEX, IDEN settings and PCC.
When data is converted from an online environment to a PC based environment,
the data is quite often changed, that is, bytes may be added/removed from the
beginning of the input record.
To allow the JDL conversion to cater for this scenario, you can specify a value
with which to adjust the offset values specified in the JDL. This saves you the
laborious task of working through the resultant ENV file and manually changing
the relevant values.
14
The Paris Conversion Manager Technical Manual
USING
THE
PARIS CONVERSION MANAGER
The Paris Conversion Manager allows you to take existing compiled centralized
JDLs (Job Descriptor Libraries) or any individual centralized resources and bring
them into the Paris system for conversion.
Although this manual has a focus on converting jobs (i.e. JDLs/JDEs), the
Conversion Manager is designed to make conversion of all resources easy,
including individual forms, fonts and other resources.
F OR OPTIM AL USE …
To optimize the use of the Paris Conversion Manager, the acceptable method is to
select all the resources called for in a particular application (JDL) and place them
in the Paris/USR directory. This is important so that during the conversion process
any resources requested are available.
This is best understood by reviewing the JDL structure.
T HE JDL S TRUCTURE
A JDL (Job Descriptor Library) is a library structure which can contain any
number of JDEs (Job Descriptor Entries, also called Jobs). The JDL has no
equivalent in Paris, however the JDE is the equivalent to a Paris environment
(.ENV).
JDE S IN THE JDL
The Xerox library structure allows the Xerox Metacode printer to have any
number of JDEs (Jobs) with the same name spread across different JDLs.
For example, you might have a JDL called JDL1 containing the JDEs INVOICE1
and INVOICE2 and another JDL called JDL2 which also contains JDEs called
INVOICE1 and INVOICE2. Because there is a two level naming convention this
does not cause any conflict on the printer.
A JDE can contain internal PDE’s or CMEs and call external resources such as
forms, fonts, graphics, CME’s and PDEs
The Paris Conversion Manager Technical Manual
15
Introduction to using the Paris Conversion Manager
How does the Paris Conversion Manager cope w ith
JDEs w ith the same name?
If you attempt to import two JDLs into the Paris Conversion Manager which
contain JDEs with the same name, during the conversion process, when the second
JDL tries to extract the JDE, you will receive a warning that the name already
exists on the system. You will be given the opportunity to give the JDE a new
name.
16
The Paris Conversion Manager Technical Manual
BEFORE
Y O U S TA R T …
Before you start the Paris Conversion Manager, place the JDL files and all the
associated resource files (PDE, CME, FRM, FNT, IMG) into the Paris/USR
directory of your Paris system.
When you start the Paris Conversion Manager, the Open dialogue will be
displayed which defaults to the Paris/USR directory.
0 WARNING!
Before starting the Paris Conversion Manager, if you have the Paris Designer
open, close it down!
The Paris Designer should not be active when starting the Paris Conversion
Manager. Both the Designer and the Conversion Manager use common resources
(FRMs, FNTs etc.). The Conversion Manager requires exclusive access to ALL
Paris resources.
The Paris Conversion Manager Technical Manual
17
CONVERT ING JDLS
The JDL/JDE converter allows you to take existing compiled Xerox centralized
Job Descriptor Library/Job Descriptor Entries (.JDL/JDE) and bring them into
Paris. From these files Paris creates an .ENV (Environment) which is stored in the
/Paris/ENV directory.
T HE JDL/JDE STRUCTURE
A Job Descriptor Library (JDL) as its name implies is a library structure which can
contain any number of Job Descriptor Entries (JDE) or Jobs. The JDE or Job is the
equivalent to a Paris environment. The JDL has no equivalent in Paris, in other
words Paris does not have a similar library structure.
The Xerox library structure allows the Xerox Metacode printer to have any
number of JDE’s (jobs) with the same name spread across different JDL’s.
For example:
You might have a JDL called JDL1 containing the JDE’s INVOICE1 and
INVOICE2.
Another JDL called JDL2 can also contain the INVOICE1 and INVOICE2.
Because there is a two level naming convention this does not cause any conflict on
the printer. If you attempted to import these two JDL’s into Paris, when the second
JDL tried to extract the JDE a warning would display informing you that the
environment already existed on the system. You must give the job a new name or
the existing environment will be overwritten.
The Paris Conversion Manager Technical Manual
18
Using the Paris Conversion Manager
Selecting Jobs for Conversion
As mentioned previously JDL’s can contain any number of JDE’s. During the
conversion process once the JDL has been selected and the conversion begins, the
converter scans the JDE list in the JDL and displays the ‘Select Job’s to Process’
dialogue. This lists all the JDE’s and allows you to select the individual JDE (or
JDE’s) that you wish to import.
If any resources are not found…
If, during the conversion, any resources (fonts, graphics, forms, CME’s or PDE’s)
that are requested by the JDE are not found on the system (that is, they have not
been previously converted or are not available for conversion), you can continue,
but the resultant .ENV may not be valid.
Importing DJDE called resources
It is important to remember that many Xerox Metacode printer applications use
DJDE’s extensively to call forms, fonts and so on. This information is not
contained in the JDE so it is important that you also import any DJDE called
resources into Paris before attempting to run the application.
The Paris Conversion Manager Technical Manual
19
Converting JDLs
U SING THE JDL/JDE C ONVERTER
Before you can begin the conversion process you need to copy the JDL’s/JDE’s
that you wish to import into Paris from the Xerox centralized printer onto the PC
running Paris. The files should be copied to the Paris/USR directory as this is the
default directory for the Select Files dialogue.
Converting a JDL file
☛
To convert a JDL file:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. Select the required file from the dialogue, then click on the Open button. The
JDL file is scanned and all the resources listed inside the JDL are displayed in
the Conversion Manager.
20
The Paris Conversion Manager Technical Manual
Using the Paris Conversion Manager
Ava i l a b l e / P r e v C o n ve r t e d :
If Available/Prev. Converted is displayed in the list, this indicates that the source
file is in the ..\USR directory but has already been converted using the name
indicated in the Resource Attributes column. It will not be passed through for
conversion.
Not available:
If Not Available is displayed, this indicates that the source file (TST8P.FNT) is
not in the ..\USR directory (as illustrated on the opposite page). The file will not be
passed through for conversion.
Invalid Family Name:
If Invalid Family Name is displayed for a font, in order to Run the Conversion
Manager you will need to give the font a family name, style and size.
The Paris Conversion Manager Technical Manual
21
Converting JDLs
Run tool
unavailable
Available/Prev
Converted:
Invalid Family Name:
If this is displayed for a font,
the Run tool will not be
available. In order to Run the
Conversion Manager you will
need to give the font a name.
Right click on the font to
display the Paris Conversion
Manager font dialogue and
enter a name in the Family
Name text field.
Indicates that the
source file is in the
..\Usr directory but
has already been
converted using the
name indicated in
the Resource
Attributes column.
It will not be passed
through for
conversion.
Not available:
Indicates that the
source file
(TST8P.FNT) is not in
the ..\Usr directory.
The file will not be
passed through for
conversion.
22
The Paris Conversion Manager Technical Manual
Using the Paris Conversion Manager
Giving the font a name, style and size
☛
To give the font a name, style and size:
1. Right mouse click on the font to display the Paris Conversion Manager font
dialogue.
2. Enter the font details in the Family Name, Font Style and Font Size text fields.
3. Click on OK.
The Paris Conversion Manager will display in the list the new name entered for the
selected font. Any other fonts with the same invalid family name will also be
changed.
The Run tool will now be available to convert the JDL.
NOTE: Refer to Font Issues on page 25 for more details.
The Paris Conversion Manager Technical Manual
23
Converting JDLs
Fonts with same
invalid family name
Right mouse
click on font to
display font
dialogue.
New name entered
Run tool
available
Both font names
changed
24
The Paris Conversion Manager Technical Manual
FONT ISSUES
The Paris Conversion Manager has been designed to make converting Xerox
centralized legacy fonts into Paris as simple as possible. Once in the Paris internal
format, these fonts can be used on Paris supported PCL and Postscript printers.
0 WARNING!
Because of Windows limitations legacy bitmap fonts cannot be printed to GDI
devices.
Before printing any converted legacy applications to a Windows GDI device you
must replace the bitmap fonts with either TrueType or Adobe PostScript fonts in
the Paris Designer system.
F ONT HANDLING DIFFERENCES BETWEEN PRINTERS
There are some very important differences in font handling between Paris and
Xerox centralized printers. It is important that these differences are clearly
understood before the conversion process is commenced.
Bitmap vs. Scaleable
Xerox Centralized fonts are Bitmap fonts, that is, a different set of bitmaps is
required for every pointsize, style, character set and orientation of every font.
Scaleable fonts, as the name implies, do not require a different font for every size,
style, character set and orientation, instead the font is calculated when needed.
Paris is able to use both Bitmap and Scaleable font technologies. Paris’s ability to
use scaleable font technologies is one of the main reasons why Paris does not
output to Xerox Metacode printers.
The Paris Conversion Manager Technical Manual
25
Font Issues
X EROX F ONT N AM ING C ONVENTIONS
There is no single naming convention for Xerox centralized fonts, one of the few
rules that applies is the use of a maximum of six (6) characters for the name.
Almost everything else regarding font naming is up to the person generating the
font. Because there are no rules or guidelines that have been enforced, a
proliferation of ad-hoc font names has resulted over the years.
The major reason for the lack of naming conventions across the Xerox laser
printing world is the availability of font creation and editing software from
companies such as Elixir, Lytrod and Intran. With these products, customers have
complete control over font naming and this has seen the rise of fonts with names
like FRED.FNT, BIGFONT.FNT or SIG1.FNT and so on.
Even within the major font families provided by Xerox and other Xerox printer
font providers there is an unusual diversity of naming conventions. What may be
the point size indicator in one font name may mean something completely different
in another font.
To further complicate the issue, because of historical limitations of printer memory
on the 9700/8700 printers, there are often several versions of the same font, some
with less characters and thus less memory requirements.
26
The Paris Conversion Manager Technical Manual
Font Issues
D IFFERENCES IN P ARIS AND X EROX FONT NAM ING
CONVENTIONS
Paris does not follow the Xerox 6 character naming conventions, instead it follows
the Family, Style and Size model used almost universally in the PC world.
As a result, it is necessary during the conversion process to give the font a family,
style and size. This does mean that font conversion cannot be totally automated but
once it has been done the result is that the old unstructured Xerox names are then
in an industry standard format.
It is very important that you plan the naming conventions you wish to use before
you begin bringing the fonts into the system.
To automate the process of converting standard fonts, XLPrint has developed a
library of Xerox standard 6 character font names and their corresponding family
size and style details. These details are stored in the Xfonts.ini file in the …\FNT
directory.
Xfonts.ini is a standard ASCII text file and will be expanded over time with
additional fonts. (See sample opposite.)
NOTE:
Xfonts.ini should only be edited/added under the guidance of your XLPrint
distributor
0 WARNING!
It is strongly advised that you do not attempt to use the original Xerox 6 character
name as the Paris family name.
Paris has been designed to work with a family, style and size model and its internal
data structures work far more efficiently if fonts are grouped into families.
Creating hundreds of family names can have the long term effect of slowing the
system down and negating the benefit of using sensible font naming conventions.
The Paris Conversion Manager Technical Manual
27
Font Issues
Sample of the Xfonts.ini file
[FontFamily]
LXerox 1200 A FMT1(LPF)=XXX
LXerox 1200 A FMT2(LPF)=XXX
LXerox 1200 A FMT3(LPF)=XXX
LXerox 1200 A FMT4(LPF)=XXX
LXerox 1200 A FMT5(LPF)=XXX
PXerox 1200 A FMT6(LPF)=XXX
PXerox 1200 A FMT7(LPF)=XXX
PXerox 1200 A FMT8(LPF)=XXX
LXerox 1200 A FMT9(LPF)=XXX
PXerox 1200 A FMT10(LPF)=XXX
PXerox 1200 A FMT11(LPF)=XXX
LXerox 1200 B FMT1(LPF)=XXX
LXerox 1200 B FMT5(LPF)=XXX
PXerox 1200 B FMT6(LPF)=XXX
PXerox 1200 B FMT8(LPF)=XXX
PXerox 1200 A FMT10(LPF)=XXX
LXerox 1200 C FMT1(LPF)=XXX
LXerox 1200 C FMT5(LPF)=XXX
PXerox 1200 C FMT6(LPF)=XXX
PXerox 1200 C FMT8(LPF)=XXX
OCR-A A FMT5(LPF)=XXX
OCR-A A FMT8(LPF)=XXX
OCR-B A FMT5(LPF)=XXX
OCR-B A FMT8(LPF)=XXX
Serified Courier 12 A FMT5(LPF)=XXX
Serified Courier 12 A FMT7(LPF)=XXX
Serified Courier 12 A FMT8(LPF)=XXX
Script A FMT5(LPF)=XXX
Script A FMT7(LPF)=XXX
Script A FMT8(LPF)=XXX
Titan A FMT5(LPF)=XXX
Titan A FMT8(LPF)=XXX
Titan B FMT5(LPF)=XXX
Titan B FMT8(LPF)=XXX
Titan C FMT5(LPF)=XXX
Titan C FMT8(LPF)=XXX
Prestige Elite A FMT7(LPF)=XXX
Prestige Elite B FMT7(LPF)=XXX
Prestige Elite C FMT7(LPF)=XXX
Artisan A FMT7(LPF)=XXX
Artisan B FMT7(LPF)=XXX
Artisan C FMT7(LPF)=XXX
Format01(LPF)=XXX
28
The Paris Conversion Manager Technical Manual
Font Issues
Font orientation
Unlike Xerox centralized fonts, where a different font is required for each
orientation, a single Paris font contains all four orientations. If two orientations of
the same font are loaded into the Conversion Manager both will be given the same
family, size and style. As a result, the second file will have the message ‘Family
Details already used’ displayed in the Remarks column.
When the fonts are sent through for conversion, only one Paris multi-orientation is
created, but during the conversion process both Xerox source font names are added
to the Paris internal fonts.ini file. If a job then asks for either of these fonts by the
original name, Paris is able to map the correct internal Paris font.
UN111D.FNT
UN111E.FNT
Different orientations of the same font.
1 screen font.
2 entries in fonts.ini, one for each orientation.
The Paris Conversion Manager Technical Manual
29
Font Issues
X EROX L ICENSED FONTS
Some Xerox centralized fonts are licensed and contain encryption information.
The Paris Conversion Manager is not capable of decoding the encryption and as a
result these fonts cannot be converted into Paris.
If you have Xerox encrypted licensed fonts that you wish to import into Paris you
must contact Xerox and ask them to provide you with un-encrypted versions of these
fonts.
30
The Paris Conversion Manager Technical Manual
CONVERT ING FONTS
Before you can begin the conversion process you need to copy the fonts that you
wish to import into Paris from the Xerox centralized printer onto the PC running
Paris. The files should be copied to the Paris/USR directory as this is the default
directory for the Open dialogue.
L OAD THE FONT FILES
☛
To convert the font files:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. From the Files of type drop-down menu, select FNT Files from the list. All the
.FNT files in the directory will be displayed in the dialogue.
3. EITHER:
Select the required files from the dialogue, then click on the Open button. Go
to Step 5.
OR:
In the File name text field type in the name or name range (e.g. Un1*.fnt) of
the font files you wish to convert, then click on the Open button.
The font files will be displayed in the Open dialogue. Go to Step 4.
The Paris Conversion Manager Technical Manual
31
Converting Fonts
D ISPLAY THE FONTS IN THE C ONVERSION M ANAGER
4. Select the required fonts from those displayed in the dialogue, then click on
the Open button again.
5. The resource manager then:
• Checks the fonts.ini file to see if the font has been previously converted,
• Checks the xfonts.ini file to see if the family name details exist.
When this has been done, the results are displayed in the Conversion
Manager.
32
The Paris Conversion Manager Technical Manual
Converting Fonts
G IVE THE FONT A NAM E , STYLE AND SIZE
If the font has not been previously converted, or is not found in the Xfonts.ini file,
Invalid Family Name will be displayed and the Resource Attributes will show the
family name as XXXXXXXX.
NOTE:
Refer to the previous sections Xerox Font Naming Conventions and Differences in
Paris and Xerox font naming conventions
☛
To give the font a name, style and size:
1. Right mouse click on the font to display the Paris Conversion Manager font
dialogue which allows you to enter in the details to be submitted to the
converter.
2. Enter the font details in the Family Name, Font Style and Font Size text fields.
3. Click on OK.
The Paris Conversion Manager will display in the list the new name entered
for the selected font. Any other fonts with the same invalid family name will
also be changed. The Run tool will now be available.
4. Click on the Run tool to convert the fonts.
The Paris Conversion Manager Technical Manual
33
Converting Fonts
M AKE F ONT R ESIDENT
If you are using Paris to print to a PCL printer that is using cartridge based fonts
(for example, a signature), the font needs to be described to Paris before it can be
accessed. (The font still needs to be converted so that a screen font can be
generated, but no printer version of the font is made.)
HP-PCL fonts are accessed by their characteristics rather than by name. In order to
achieve this you must fill in all the details in the Resident Font Details section of
the dialogue.
Setting the Resident Font details
☛
To set the Resident Font details:
1. Select the Make Font Resident checkbox. The Resident Font details section of
the dialogue will become available.
2. Enter the required details in the relevant fields, then choose OK. The font will
be displayed in the Paris Conversion Manager.
34
The Paris Conversion Manager Technical Manual
Converting Fonts
C ONVERTING FONTS WITH POSITIONS BELOW DECIM AL 32
During conversion, Paris remaps any font characters in positions below decimal 32
to available positions higher in the font. If there are no available character
positions (all the 256 available positions are used) then a message box is displayed
and the characters below decimal 32 will not be converted.
For example:
1. Select the font
1. Select a font and click on the Open button to display
the font in the Paris Conversion Manager.
The selected font will appear as illustrated below.
The Paris Conversion Manager Technical Manual
35
Converting Fonts
2. Display the font dialogue
2. Right mouse click on the font
to display the Font dialogue.
3. Give the font a name
3.
Enter a name for the
font then choose OK.
The Font Conversion
message ‘No Room to
Remap characters
below decimal 32 chars are ignored’ will
be displayed.
Choose OK.
The font will be
displayed in the
Paris Conversion
Manager with the
new name
36
The Paris Conversion Manager Technical Manual
Converting Fonts
4. Run the Converter
4.
Click on the Run button. The Font
Conversion message will again be
displayed and the characters will
not be converted.
The Paris Conversion Manager Technical Manual
37
CONVERT ING GRAPHICS
The Graphics converter allows you to take existing Xerox centralized graphic files
(.IMG’s) and bring them into Paris. From these files Paris creates an .LPG which
is stored in the /Paris/GRF directory.
Paris is also able to take in the Xerox .LGO logo files. Xerox .LGO’s are graphics,
normally small in size, stored in a font format. As many early Xerox printers did
not have the Graphics Handling Option (GHO) required to handle .IMG’s, the
LGO files were stored in a font format.
NOTE
Because LGO files are really fonts, during conversion the Paris font conversion
dialogue is displayed. (Refer to the section ‘Converting Fonts’ on page 31 for
details).
Once in the Paris internal format these graphics can be used on any of the Paris
supported PCL and Postscript printers.
G RAPHIC DIFFERENCES
There are some differences in the way Xerox Metacode printers and Paris handle
.IMG graphics. These involve the orientation of the graphic on the page.
Resources used in Paris do not have an orientation but are considered either
upright or rotated. For example, the same font can be used on a portrait or
landscape page.
Graphics are similar and normally would have an upright orientation that applies
equally to both portrait and landscape modes. This is different to Metacode
printers where graphics have an orientation, for example the same graphic can be
stored as two different files, one portrait, the other landscape.
Because of the way the scan lines flow on a Metacode printer the landscape
version of the graphic is naturally upright to Paris, portrait is not. As a result, when
importing a portrait IMG into Paris, you normally need to have the rotate option
activated so the resulting Paris graphic will appear upright.
The Paris Conversion Manager Technical Manual
38
Converting Graphics
U SING THE G RAPHICS C ONVERTER
Before you can begin the conversion process you need to copy the graphics that
you wish to import into Paris from the Xerox centralized printer onto the PC
running Paris.
The files should be copied to the Paris/USR directory as this is the default
directory for the Select Files dialogue.
☛
To convert the graphic files:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. From the Files of type drop-down menu, select IMG Files from the list. All the
.IMG files in the directory will be displayed in the dialogue.
3. Select the file(s) you wish to convert from the dialogue, then click on the Open
button. The file will be displayed in the Paris Conversion Manager.
The Paris Conversion Manager Technical Manual
39
Converting Graphics
4. In the Paris Conversion Manager, Right mouse click on the file to be converted
to display the Properties dialogue. This allows you to change the name and/or
rotate the graphic before conversion.
5. Choose OK when finished.
6. Click on the Run tool to submit the file for conversion.
40
The Paris Conversion Manager Technical Manual
CONVERT ING FORMS
The Forms converter allows you to take existing Xerox centralized form files
(.FRM’s) and bring them into Paris. It also is able to take in the Elixir .ELX format
but this may not work with some .ELX files.
If there is a problem with an .ELX conversion simply get the corresponding Xerox
.FRM. Paris creates a .FRM which is stored in the /Paris/FRM directory.
Once in the Paris internal format these forms can be used on any of the Paris
supported PCL and Postscript printers.
The Paris Conversion Manager Technical Manual
41
Converting Graphics
U SING THE F ORM S C ONVERTER
Before you can begin the conversion process you need to copy the forms that you
wish to import into Paris from the Xerox centralized printer onto the PC running
Paris.
The files should be copied to the Paris/USR directory as this is the default
directory for the Select Files dialogue.
☛
To convert the form files:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. From the Files of type drop-down menu, select FRM Files from the list. All the
.FRM files in the directory will be displayed in the dialogue.
3. Select the file(s) you wish to convert from the dialogue, then click on the Open
button.
The resource manager will scan the file and display both the form and all its
required files (fonts, images etc.) in the Paris Conversion Manager.
42
The Paris Conversion Manager Technical Manual
Converting Forms
4. Any fonts required in the form that are not in the …/USR directory are flagged
as ‘Not available’. In this case the form will still be converted but the
converter substitutes the standard Line Printer 9 font.
Substituted Line Printer 9 font
5. If you wish to substitute another font you can Right mouse click on the font
file to be converted to display the Font Properties dialogue and select a
substitute font. Choose OK when finished.
The Paris Conversion Manager Technical Manual
43
Converting Graphics
6. In the Paris Conversion Manager, to change the form name before conversion,
Right mouse click on the form to display the form Save File As dialogue.
7. Enter the new form name in the text field, then choose OK.
8. When finished, click on the Run tool to submit the file for conversion.
44
The Paris Conversion Manager Technical Manual
CONVERT ING CMES
CME’s can come into Paris in two ways, this is because CME’s can exist on Xerox
Metacode printers in two formats:
• A CME can be compiled as part of a JDL/JDE or,
• A CME can exist on its own as an externally compiled CME. Externally
compiled CME’s can be called separately, normally by DJDE.
The CME converter allows you to take existing externally compiled Xerox
centralized Copy Modification Entries (.CME’s) and converts them for use in
Paris. From these files Paris creates an .ELT (Event List Table) which is stored in
the /Paris/ENV directory.
The most common way CME’s are brought into the system are as part of a JDL.
CME’s brought in as part of a JDL/JDE conversion are absorbed into the Paris
environment and are therefore can be edited.
A compiled CME when brought into Paris is treated as an external file (as on the
Xerox Metacode printer) and cannot be edited in Paris. This method preserves
Xerox DJDE compatibility.
The Paris Conversion Manager Technical Manual
45
Converting CMEs
U SING THE CME C ONVERTER
Before you can begin the conversion process you need to copy the CME’s that
you wish to import into Paris from the Xerox centralized printer onto the PC
running Paris.
The files can be copied to the Paris/USR directory as this is the default directory
for the Select Files dialogue.
☛
To convert the CME files:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. From the Files of type drop-down menu, select CME Files from the list. All
the .CME files in the directory will be displayed in the dialogue.
3. Select the file(s) you wish to convert from the dialogue, then click on the Open
button. The selected files will be displayed in the Paris Conversion Manager.
46
The Paris Conversion Manager Technical Manual
Converting CMEs
4. In the Paris Conversion Manager, to change the CME name before conversion,
Right mouse click on the CME to display the Save File As dialogue.
5. Enter the new CME name in the text field, then choose OK.
NOTE:
Changing the name of an external CME can result in a DJDE job with a
MODIFY = [original CME name] failing to find the CME.
4. When finished, click on the Run tool to submit the file for conversion.
The Paris Conversion Manager Technical Manual
47
CONVERT ING PDES
Like CME’s, PDE’s can come into Paris in two ways. This is because PDE’s can
exist on Xerox Metacode printers in 2 formats.
• A PDE can be compiled as part of a JDL/JDE or,
• A PDE can exist on its own as an externally compiled PDE. Externally
compiled PDE’s can be called separately, normally by DJDE.
The PDE converter allows you to take existing externally compiled Xerox
centralized Page Descriptor Entries (.CME’s) and converts them in Paris. From
these files Paris creates a .PDF (Page Descriptor File) which is stored in the
/Paris/ENV directory.
The most common way PDE’s are brought into the system are as part of a JDL.
PDE’s brought in as part of a JDL/JDE conversion are saved as internal pagedefs.
The conversion of a PDE creates an external pagedef in Paris. Unlike external
CME’s, external pagedefs in Paris can be edited.
The Paris Conversion Manager Technical Manual
48
Converting PDEs
U SING THE PDE C ONVERTER
Before you can begin the conversion process you need to copy the PDE’s that you
wish to import into Paris from the Xerox centralized printer onto the PC running
Paris.
The files can be copied to the Paris/USR directory as this is the default directory
for the Select Files dialogue.
☛
To convert the PDE files:
1. Select ‘Open’ from the File menu to display the Open dialogue.
2. From the Files of type drop-down menu, select PDE Files from the list. All the
.PDE files in the directory will be displayed in the dialogue.
3. Select the file(s) you wish to convert from the dialogue, then click on the Open
button. The resource manager will scan the file and display both the PDE and
all its associated files in the Paris Conversion Manager.
The Paris Conversion Manager Technical Manual
49
Converting PDEs
4. In the Paris Conversion Manager, to change the PDE name before conversion,
Right mouse click on the PDE to display the Save File As dialogue.
5. Enter the new PDE name in the text field, then choose OK.
NOTE:
Changing the name of an external PDE can result in a DJDE job with a
FORMAT = [original PDE name] failing to find the PDE.
4. When finished, click on the Run tool to submit the file for conversion.
50
The Paris Conversion Manager Technical Manual
Download PDF