Lab 1.5.1 Introductory Lab 1 – Getting Started and Building Start.txt
Objective
This lab will introduce to the student the CCNP lab equipment and certain IOS features that might be
new. This introductory activity also describes how to use a simple text editor to create all or part of a
router configuration file. After creating a text configuration file, the student can apply that
configuration to a router quickly and easily by using the techniques described in this lab.
Equipment Requirements
This lab requires the following equipment:
•
•
A single router, preferably a 2600 series router, and a workstation running a Windows operating
system
One 3 1/2-inch floppy disk with a label
Preliminary
Modular interfaces
Cisco routers can come with a variety of interface configurations. Some models have only fixed
interfaces, meaning that the interfaces cannot be changed or replaced by the user. Other models
have one or more modular interfaces, allowing the user to add, remove, or replace interfaces as
needed.
Fixed interface identification, such as Serial 0, S0, Ethernet 0, and E0, may already be familiar.
Modular routers use notation such as Serial 0/0 or S0/1. The first number refers to the module and
the second number refers to the interface. Both notations use 0 as their starting reference, so S0/1
indicates that there is another serial interface S0/0.
Fast Ethernet
Many routers today are equipped with Fast Ethernet, 10/100 Mbps auto sensing interfaces. Fast
Ethernet 0/0 or Fa0/0 on routers with Fast Ethernet interfaces must be used.
The ip subnet-zero command
The ip subnet-zero command is enabled by default in IOS 12. This command allows the user to
assign IP addresses in the first subnet, called subnet 0. Because subnet 0 uses only binary zeros in
the subnet field, its subnet address can potentially be confused with the major network address. With
the advent of classless IP, the use of subnet 0 has become more common. The labs in this manual
assume that the student can assign addresses to the interfaces of the router using subnet 0. If any
routers are used that have an IOS earlier than 12.0, then the global configuration command, ip
subnet-zero, must be added to the configuration on the router.
No shutdown
Interfaces are shut down by default. A no shutdown command must be issued in interface
configuration mode when the interface is ready to be brought up.
1-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
Passwords
The login command is applied to virtual terminals by default. This means that in order for the router
to accept Telnet connections, a password must be configured. Otherwise, the router will not allow a
Telnet connection and will reply with the error message “password required, but none set”.
Step 1
Take a few moments to examine the router. Become familiar with any serial, BRI (ISDN), PRI
(ISDN), and CSU/DSU interfaces on the router. Pay particular attention to any connectors or cables
that are unfamiliar.
Step 2
Establish a HyperTerminal session to the router.
Enter privileged EXEC mode.
Step 3
To clear the configuration, issue the erase start command.
Confirm the command when prompted, answer “no” if asked to save changes. The result should look
something like the following:
Router#erase start
Erasing the nvram filesystem will remove all files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#
When the prompt returns, issue the reload command.
Confirm the command when prompted. After the router finishes the boot process, choose not to use
the Auto install feature, shown as follows:
Would you like to enter the initial configuration dialog? [yes/no]: no
Would you like to terminate autoinstall? [yes]: Å Press Enter to accept
default.
Press RETURN to get started!
Step 4
In privileged mode, issue the show run command.
While scrolling through the running configuration, note the following default configurations:
•
The version number of the IOS
•
The ip subnet-zero command, which allows the use of subnet 0
•
Each available interface and its name
Note: Each interface has the shutdown command applied to its configuration.
•
The no ip http server command, which prevents the router from being accessed by a
Web browser
•
No passwords are set for CON, AUX, and VTY sessions, as shown in the following:
line con 0
transport input none
line aux 0
2-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
line vty 0 4
Using Copy and Paste with Notepad
In the next steps, the copy and paste feature will be used to edit router configurations. A text file will
need to be created that can be pasted into the labs and used as a starting point for the router
configuration. Specifically, the student must build a login configuration that can be used with every
lab included in this manual.
Step 5
If necessary, issue the show run command again so that the console and vty line configurations
appear on the screen as follows:
line con 0
transport input none
line aux 0
line vty 0 4
!
end
Select this text and choose the copy command from HyperTerminal edit menu.
Next, open Notepad, which is typically found on the Start menu under Programs, Accessories.
After Notepad opens, select Paste from the Notepad Edit menu.
Edit the lines in Notepad to look like the following lines:
Note: The one-space indent is optional.
enable secret class
line con 0
transport input none
password cisco
login
line aux 0
password cisco
login
line vty 0 4
password cisco
login
This configuration sets the enable secret to class and requires a login for all console, AUX port, and
virtual terminal (Telnet) connections. The AUX port is usually a modem. The password for these
connections is set to cisco.
Note: Each of the passwords can be set to something else if so desired.
Step 6
Save the open file in Notepad to a floppy disk as start.txt.
Select all the lines in the Notepad document and choose Edit > Copy.
Step 7
Use the Windows taskbar to return to the HyperTerminal session, and then enter global configuration
mode.
From HyperTerminal Edit menu, choose Paste to Host.
Issue the show run command to see if the configuration looks okay.
3-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
As a shortcut, the contents of the start.txt file can now be pasted to any router before getting started
with a lab.
Other Useful Commands
To enhance the start.txt file, consider adding one of the following commands:
•
ip subnet-zero ensures that an older IOS allows IP addresses from subnet 0.
•
ip http server allows access the routers using a Web browser. Although this
configuration might not be desirable on a production router, it gives the user an HTTP server
for testing purposes in the lab.
•
no ip domain-lookup prevents the router from attempting to query a DNS when a word
that is not recognized as a command or a host table entry is input. This will save time if a
typo or misspelling of a command is made.
•
logging synchronous in the line con 0 configuration will return to a fresh line when
input is interrupted by a console-logging message.
•
configure terminal (config t) can be used in the file so that a command does not
need to be typed before pasting the contents of the file to the router.
Step 8
Use the Windows taskbar to return to Notepad and edit the lines so that they read as follows:
config t
!
enable secret class
ip subnet-zero
ip http server
no ip domain-lookup
line con 0
logging synchronous
password cisco
login
transport input none
line aux 0
password cisco
login
line vty 0 4
password cisco
login
!
end
copy run start
Save the file to the floppy disk so that no work is lost.
Select and copy all the lines, and then return to the HyperTerminal session.
Normally, the global configuration mode would be entered before pasting from Notepad. However,
because the configure terminal command was included in the script, it is possible to paste in
privileged mode.
If necessary, return to privileged EXEC mode. From the Edit menu, select Paste to Host.
After the paste is complete, the copy operation must be confirmed.
Use show run to see if the configuration looks okay.
4-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
Using Notepad to Assist in Editing
Understanding how to use Notepad can lessen typing and typos during editing sessions. Another
major benefit is that an entire router configuration can be done in Notepad, whether the user is at
home or at the office. This configuration can then be pasted to the console of the router when access
is available. In the next steps, the student will look at a simple editing example.
Step 9
Configure the router with the following commands:
Router#config t
Router(config)#router rip
Router(config)#network 192.168.1.0
Router(config)#network 192.168.2.0
Router(config)#network 192.168.3.0
Router(config)#network 192.168.4.0
Router(config)#network 192.168.5.0
Press Ctrl-sZ, and verify the configuration with the show run command. This configuration
enables RIP routing and specifies the networks that RIP will advertise to neighboring routers. What if
the routing protocol is to be changed to IGRP? With the no router rip command, RIP can easily
be removed. However, the network commands would still need to be typed. The next steps show
an alternative.
Step 10
Issue the show run command and hold the output so that the router rip commands are
displayed. Using the keyboard or mouse, select the router rip command and all network
statements.
Copy the selection.
Use the taskbar to return to Notepad.
Open a new document and paste the selection onto the blank page.
Step 11
In the new document, type the word no and a space in front of the word router.
Press the End key, and press Enter.
Type router igrp 100, but do not press Enter. The result should look like as follows:
Router(config)#no router rip
Router(config)#router igrp 100
Router(config-router)# network
Router(config-router)# network
Router(config-router)# network
Router(config-router)# network
Router(config-router)# network
192.168.1.0
192.168.2.0
192.168.3.0
192.168.4.0
192.168.5.0
Step 12
Select the results and copy them.
Use the taskbar to return to the HyperTerminal session.
While in global configuration mode, paste the results.
Use the show run command to verify the configuration.
5-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
Reflection
How could using copy and paste with Notepad be helpful in other editing situations?
__________________________________________________________________________
__________________________________________________________________________
__________________________________________________________________________
6-6
CCNP 2: Remote Access v 3.0 - Lab 1.5.1
Copyright  2003, Cisco Systems, Inc.
Download PDF