DT2x Data Transfer Kit

DT2x Data Transfer Kit
(for Alt15K/WD and miniAlt/WD)
Serial model
USB model
Which Data Tranfer Module did you receive?
The DT2 Data Transfer Kit is available with either Windows serial
(DB9 connector), Mac serial (mini DIN8 connector), or universal Mac/
Windows USB interface. Make sure you have the right model and
that your computer has the correct port before proceeding.
If you have either of the serial interface kits, you should skip the
following section on installing USB drivers and proceed directly to
the sections describing the use of the DT2 with your particular
altimeter model. If you have the USB interface kit, you need to install
USB drivers on your computer before the kit will be recognized.
Installing USB drivers (Mac OS8.5 - 9.22)
The Macintosh USB driver software should be installed before you
plug the USB data transfer module into your computer. If you do
plug the data transfer module into your Mac’s USB port before
installing the software, you will be presented with the following
dialog:
If you get this message you should click on “Cancel” and proceed to
the next step (installing the driver).
1
To install the driver, insert the PerfectFlite CD and open the “USB to
Serial Drivers” folder. Inside the “MacOS 8, 9” folder you will find
the driver file (the current version as of this writing is named
“USBSerialConverter_04036001”). Drag this file (NOT the backup
archive version ending in “.sit”) and drop it onto the active System
Folder on your hard disk and it will be automatically copied into the
Extensions folder inside your System Folder.
After the driver file has copied, you must restart your computer
before it will be recognized. After your computer has restarted you
can plug the USB data transfer module into your Mac’s USB port with
the included cable. If you have installed the driver properly you will
not get the “software not available” dialog shown on the previous
page.
Once you have installed the driver software, you can proceed to the
section in the manual describing the use of the data transfer software
2
with your particular altimeter model. Since you will be using the USB
port instead of a serial port, any references to serial ports and cables
will now refer to their USB counterparts. When you are instructed to
select the proper COM port, choose the item labeled
“USBHighSpeedSerialConverter”.
Installing USB drivers (Windows 98 - XP)
Insert the PerfectFlite CD and open the “USB to Serial Drivers” folder.
Inside the “Windows” folder you will find two zipped files: one
containing drivers for Windows 98 and ME, and the other containing
drivers for Windows 2000 and XP. Drag the appropriate file to your
hard disk and unzip the files into a new folder. Once the files have
been unzipped you should plug in the USB data transfer module.
When the USB module is plugged in, a message will pop up indicating that new hardware was found:
3
Shortly thereafter a window will pop up offering to find the needed
software on the internet. If it does, select the “No, not at this time”
option and move on to the next screen.
4
The Found New Hardware wizard will then need to know where to
find the software for the “USB <-> Serial” device. Select the “Install
from a list or specific location (Advanced)” option and click “Next”.
5
Click on the “Browse” button and select the folder that contains the
driver files that you unzipped earlier. Make sure this location is
included in the search and click “Next”:
Windows will install the necessary driver files and then indicate that
it has finished.
When the software for “USB <-> Serial” has been installed, the
computer will automatically move on to the second part of the driver
software (“USB Serial Port”). Follow the same procedure to install the
second part of the software, and when it is complete you will get a
message indicating that the hardware has been installed successfully.
6
Installing under other Windows operating systems (98, ME, 2K) is
similar. You can check for newer versions of the drivers online at
http://www.ftdichip.com/Drivers/VCP.htm.
Note: When running under some older versions of Windows you may
notice a significant pause when plugging in or unplugging the USB module.
Be patient, the computer has not “hung”. It may take up to 20 seconds
before normal operation is resumed.
Note: The USB transfer module installs itself as the next COM port after
any already existing COM ports or modems. You can confirm proper port
operation and numbering in the following manner: Run the data transfer
software without having the USB module plugged in and note the available
COM ports (if any). Exit the software and plug the USB module in. Start
the data transfer software again and check the list of available COM ports. A
new port number should be listed; this will be the port number for the USB
module and is the one that you should select.
You can now proceed to the section in the manual describing the use
of the data transfer software with your particular altimeter model.
Since you will be using the USB port instead of a serial port, any
references to serial ports and cables will now refer to their USB
counterparts.
7
Using the DT2 with the Alt15K/WD
Software Installation:
The enclosed CD contains software for Windows and Macintosh
operating systems. To install the software, simply copy the appropriate folder (“Alt15K Software for Macintosh” or “Alt15K
Software for Windows”) from the CDROM to your hard disk. A
sample data file is also included to provide a representation of a
typical flight’s data.
Setup and Transfer:
The Alt15K/WD will respond to the serial port at any point before the
“launch ready” chirp or at any point after a flight. Start by connecting
the included DB9 serial cable to your computer’s serial port and to
the 9 pin connector on the DT2 module, and then connect the four
wire cable from the DT2 module to the altimeter’s white data port
connector. Run the Alt15K DataCap program, and select the
appropriate serial port from the Altimeter>CommPort menu item.
After the proper port is chosen, you can select the Data>Acquire
menu item which will bring up a dialog box prompting you to turn
on the altimeter. Turn on the altimeter, which will begin to beep out
the last flight altitude (if you are connecting post-flight, the altimeter
8
will already be on). When you respond with the “OK” button the
data transfer process will commence and a progress indicator will
appear on screen.
When the transfer is complete, a graph of the altitude vs. time profile
of the flight will appear.
Clicking on the “X Zoom” button will allow you to view the entire
flight or zoom in on the first 15 or 30 seconds to examine the boost
characteristics of the flight.
9
The Data>Inspect menu item brings up a separate
window with the data arranged in tabular format
for inspecting individual data points.
The File menu provides the normal functions for
Saving, Opening, and Printing of individual data
runs. Data are saved in text format for easy import
into spreadsheet programs for further analysis.
Using the DT2 with the miniAlt/WD
Software Installation:
The enclosed CD contains software for Windows and Macintosh
operating systems. A sample data file is also included to provide a
representation of a typical flight’s data. To install the software, simply
copy the appropriate folder (“miniAlt Software for Windows”
or “miniAlt Software for Macintosh”) from the CDROM to
your hard disk.
Setup and Transfer:
As mentioned in the miniAlt/WD manual, the altimeter will only
respond to the serial port during the period before the continuity
check beeps begin and at any time after a flight. I/O through the
serial port is disabled as soon as the continuity check beeps start and
remains disabled until the end of the flight. This is to keep noise or
spurious commands from taking the altimeter out of flight mode and
entering command mode. If this were to happen, data acquisition
and event triggering would not occur.
To set up any desired features using the software, connect the DB9
serial cable between your computer’s serial port and the DT2 module,
and connect the four wire cable from the DT2 module to the
altimeter’s “Data” port. Run the DataCap program, and select the
appropriate serial port from the Altimeter>CommPort menu item.
10
With the proper port selected, turn on the altimeter, which will begin
to beep out its switch settings. At this point you can select the
Altimeter>Identify menu item, which will stop the beeping and
return a dialog box describing the model of altimeter and the revision
number of its firmware and transfer software. This will also confirm
proper communications with the altimeter.
The Altimeter>Test menu item allows you to test fire charges (or low
power lightbulbs) attached to the altimeter’s ejection charge terminals, and turn the audible continuity test on or off.
11
The Altimeter>Setup menu item allows you to enable telemetry
output during flight (sent to the Data port as output only at 9,600
baud) and a 1 second apogee delay for dual altimeter installations to
keep both apogee charges from firing simultaneously. You can also
select a new value for the Low Battery Alarm in this dialog. After
making any changes to the settings, click on the “Update” button to
send them to the altimeter.
The Data>Acquire menu item will download the last flight’s data
from the altimeter and plot it in the graphing window. Clicking on
the “X Zoom” button will allow you to view the entire flight or zoom
in on the first 15 or 30 seconds to examine the boost characteristics of
the flight.
The Data>Inspect menu item brings up a separate window with the
data arranged in tabular format for inspecting individual data points.
The File menu provides the normal functions for Saving, Opening,
and Printing of individual data runs. Data are saved in text format
for easy import into spreadsheet programs for further analysis.
12
Troubleshooting
“Altimeter Not Found” or “Error in data length” when attempting to
download data from altimeter:
• Check all cables to make sure they are connected correctly, seated
properly, and are the ones that were supplied with your kit.
• If you are using the serial module, make sure you are plugging it
into a serial port on the computer and not a similar looking port
instead (e.g. EGA monitor, S Video, etc).
• If you are using the USB module, make sure the USB drivers are
installed properly. When the USB cable is plugged in, a new port
should be listed in the transfer software. If it isn’t, then the USB
drivers are not installed properly.
• Make sure you have selected the appropriate COM port to match
the port you have the Data Transfer module connected to.
• Make sure you are trying to connect at the proper time: if the
altimeter is sounding continuity beeps (MAWD) or pre-launch chirp
(A15K), the download port will NOT be available.
• “Error in data length: 0” generally means that you have selected
the wrong port or have a cable connection problem. “Error in data
length: 2” is generally reported when you are selecting an internal
modem instead of the COM port that the altimeter is connected to.
Other errors:
• Check the “downloads” area of the PerfectFlite website to make
sure you are running the latest version of the software.
13
System Requirements
❏
Windows Serial Version
• PC with 9 pin serial port
• 64 meg RAM
• Windows 95, 98, 2000, ME, or XP
❏
Macintosh Serial Version
• Mac with 8 pin serial port
• 64 meg RAM
• Mac OS 7.1 to 9.22
❏
Universal Mac/Windows USB version
• Mac or PC with USB port
• 128 meg RAM
• Mac OS 8.5 to 9.22
or
• Windows 98, 2000, ME, or XP
Download PDF