StreamServe Persuasion SP4 Post-processor repository

StreamServe Persuasion SP4
Post-processor repository
User Guide
Rev A
StreamServe Persuasion SP4 Post-processor repository User Guide
Rev A
© 2001-2009 STREAMSERVE, INC.
ALL RIGHTS RESERVED
United States patent #7,127,520
No part of this document may be reproduced or transmitted in any form or by any means, electronic or
mechanical, for any purpose, without the express written permission of StreamServe, Inc. Information in this
document is subject to change without notice. StreamServe Inc. assumes no responsibility or liability for any
errors or inaccuracies that may appear in this book. All registered names, product names and trademarks of
other companies mentioned in this documentation are used for identification purposes only and are
acknowledged as property of the respective company. Companies, names and data used in examples in this
document are fictitious unless otherwise noted.
StreamServe, Inc. offers no guarantees and assumes no responsibility or liability of any type with respect to
third party products and services, including any liability resulting from incompatibility between the third party
products and services and the products and services offered by StreamServe, Inc. By using StreamServe
and the third party products mentioned in this document, you agree that you will not hold StreamServe, Inc.
responsible or liable with respect to the third party products and services or seek to do so.
The trademarks, logos, and service marks in this document are the property of StreamServe, Inc. or other
third parties. You are not permitted to use the marks without the prior written consent of StreamServe, Inc.
or the third party that owns the marks.
Use of the StreamServe product with third party products not mentioned in this document is entirely at your
own risk, also as regards the StreamServe products.
StreamServe Web Site
http://www.streamserve.com
3
Contents
About the Post-processor repository .............................................................5
Storing documents in the Post-processor repository...................................7
Configuring a Post-processor repository output connector ........................... 9
Specifying document trigger......................................................................... 10
Specifying variables to be used for post-processing documents ................. 11
Specifying metadata to be used for post-processing documents................. 11
Enabling compression of data stored in post-processing repository............ 11
Creating a Job Info file ................................................................................. 12
Retrieving documents from the Post-processor repository.......................13
Scheduling when to submit a query to retrieve documents .......................... 14
Opening a repository in the Post-processor Repository Tool....................... 15
Opening a repository in the Post-processor Repository Tool when a connection is established......................................................................................... 15
Creating a query........................................................................................... 15
Filtering stored jobs and documents ............................................................ 16
Configuring a Post-processor scheduler input connector ............................ 16
Configuring a Post-processor....................................................................... 17
Configuring Process links............................................................................. 17
Manually submitting a query to retrieve documents ...................................... 18
Opening a repository in the Post-processor Repository Tool....................... 19
Opening a repository in the Post-processor Repository Tool when a connection is established......................................................................................... 19
Creating a file query ..................................................................................... 20
Creating a HTTP post query ........................................................................ 20
Processing options....................................................................................... 21
Connection options for manually retrieving documents ............................... 21
Configuring a Post-processor....................................................................... 22
Configuring Process links............................................................................. 23
Adding and modifying metadata when manually submitting a query ........... 23
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
4
The Post-processor Repository Tool GUI reference .................................. 25
Connection list................................................................................................... 25
Job list ................................................................................................................ 25
Document list ..................................................................................................... 27
File menu ............................................................................................................ 28
Repository menu ............................................................................................... 28
Tools menu......................................................................................................... 28
Connections dialog box .................................................................................... 29
Open Location dialog box................................................................................. 29
Filters dialog box ............................................................................................... 29
Options dialog box ............................................................................................ 30
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
5
About the Post-processor
repository
You use the post-processing repository to store page-formatted documents
generated by one or more StreamServers. Documents stored in the postprocessing repository can be retrieved at a specific time or at repeated intervals.
You can view documents stored in the post-processing repository, and select
documents to be retrieved, using the Post-processor Repository Tool.
Post-processing repository scenario
A telecommunications company called Dosco has three subsidiaries providing
services for:
•
Fixed telephony
•
Mobile telephony
•
Internet connection
As many customers use services provided by more than one subsidiary, the
company wants to reduce costs by sending all the monthly invoices for each
customer in one envelope.
Each subsidiary uses StreamServe to retrieve data from their billing systems and
format the invoices.
The 5th of each month, the fixed telephony subsidiary takes data from their billing
system and produces page-formatted invoices, which are subsequently stored in
the post-processing repository. The customer ID is used to identify the invoice to
send to each customer, and is stored in the post-processing repository together
with the invoice.
The 7th of each month, the mobile telephony subsidiary produces billing
information for their customers and stores it in the same post-processing
repository as the fixed telephony subsidiary.
The 9th of each month, the internet providing subsidiary produces their billing
information and stores it the same way.
The 11th of each month, invoices that will be sent to customers with customer IDs
between 1000 and 1999 are printed. An operator at a centralized function at Dosco
uses the Post-processor Repository Tool to select the invoices with these
customer IDs, and submits the invoices to the printer.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
6
About the Post-processor repository
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
7
Storing documents in the Postprocessor repository
You use a Post-processor repository output connector to store data from
PageOUT Processes in the post-processing repository. You can use a separate
repository for storing resources, such as overlays and fonts. This resource
repository can be used as a common source for several document repositories.
See Configuring a Post-processor repository output connector on page 9.
Document trigger
Since the post-processing repository stores documents, you must specify the
variable, for example the customer ID, that triggers the creation of a new
document in the job.
See Specifying document trigger on page 10
Variables
Variables that are included in the PageOUT processes can be used when the
documents are post-processed. You must specify these variables when you store
documents in the post-processing repository, if you want to use them to create
statistics or for specifying sheet layout, labels or OMR marks.
See Specifying variables to be used for post-processing documents on page 11.
Metadata
Metadata are variables that associate the value of a variable to a specific
document. Metadata is stored along with the corresponding documents. You use
metadata to:
•
Identify the documents in the Post-processor Repository Tool.
•
Select documents to be printed or deleted.
•
Sort and bundle documents into envelopes.
See Specifying metadata to be used for post-processing documents on page 11.
Compressing data
If possible, you should compress jobs that contain many or large documents
before storing them in the post-processing repository. This keeps the repository
size down and enables documents to be retrieved faster. For smaller jobs it can be
more efficient not to compress the data. The data is compressed by default.
See Enabling compression of data stored in post-processing repository on page
11.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
8
Storing documents in the Post-processor repository
Job info file
A Job info file is a query file that specifies all documents within the job. When
you store the documents in the post-processing repository, you can
simultaneously create a Job info file. You can use the Job info file to for example
retrieve the stored job directly for printing via a Directory input connector.
See Creating a Job Info file on page 12.
Post-processing repository user authentication
If the post-processing repository is password protected, you must specify a user
name and password for accessing the repository. You can password protect a
repository using the StreamServe Repository Tool.
To be able to write to the post-processing repository, you must specify the user
name and password on the Post-processor repository output connector.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Configuring a Post-processor repository output connector
Storing documents in the Post-processor repository
Configuring a Post-processor repository
output connector
1
In the Platform window, create a Post-processor repository output
connector.
2
Click Driver and select the SDR driver.
3
Click Connector (Post-processor repository) and enter the appropriate
values.
Connector settings
Server
The host name or IP address of the server where the
document repository is located. If you use a repository in
local mode that is not available for other clients, enter
LOCAL
Alias/path
The alias name of the repository, or the path to the
repository. If the repository does not exist, it is created
the first time a job is sent for storage.
User name
The user name to access the post-processing repository.
If the post-processing repository is password protected,
you must define authentication settings in the Postprocessor Repository Tool, see Scheduling when to
submit a query to retrieve documents on page 14.
Password
The password to access the post-processing repository.
Resources server
The host name or IP address of the server where the
Resources repository is located. Used only if a separate
repository is used for the resources.
Resources alias/
path
The alias name of the Resources repository, or the path to
the Resources repository. Used only if a separate
repository is used for the resources.
Resources user
name
The user name to access the Resources repository.
Resources
password
The password to access the Resources repository.
Turn recovery on
Select this option to temporarily store all changes in the
post-processing repository until the documents are
completely stored in the repository files. This enables the
data to be recovered in case of a repository failure.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
9
10
Configuring a Post-processor repository output connector
Storing documents in the Post-processor repository
Connector settings
Keep repositories
open
Select to keep the post-processing repository open
between jobs. This can increase performance if many
small jobs are processed.
Note: If a repository is kept open in local mode, no other
StreamServer or Post-processor Repository Tool
can access the repository.
On lost repository
server connection
Select the method to reconnect to the repository in case
of failure. This option is only applicable when running
the repository in server mode. Reconnecting is only
possible if a job is not being processed and the Keep
repositories open option is selected.
Do not attempt recovery – The StreamServer will not
try to reconnect to the post-processing repository server.
Attempt recovery forever – The StreamServer will try
to reconnect to the post-processing repository server until
a connection is successfully established.
Attempt recovery a limited number of times – The
StreamServer will try to reconnect to the post-processing
repository until a connection is successfully established,
or until the maximum number of re-connection attempts
is reached.
Note: If the connection is lost while a job is being
processed, no re-connection attempt is made and
you must re-send the job.
Reconnection
attempts
If the StreamServer fails to reconnect when the maximum
number of attempts is reached, it will shut down.
Time between
attempts (s)
The number of seconds between the re-connection
attempts.
Enable metadata
indexing
Select to add indexes to the metadata values for the stored
documents. This can significantly increase the speed
when retrieving documents. However, the size of the
database increases, so for databases with many stored
documents and where a lot of metadata is used, it may be
less suitable to use metadata indexing.
Specifying document trigger
1
In the Runtime window, open the Runtime Output Connector Settings
dialog.
2
Click Document Trigger and enter a variable in the Document trigger
variable field.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Configuring a Post-processor repository output connector
Storing documents in the Post-processor repository
Specifying variables to be used for post-processing
documents
You can specify variables at Page Begin, Process Begin, Document Begin, and
Document End. When the documents are retrieved from the post-processing
repository, the variables are available at the corresponding level.
To specify variables
1
In the Runtime window, open the Runtime Output Connector Settings
dialog.
2
Click the level where the variable is used, for example Document Begin,
and select the Stored Variables tab.
3
Click Add new Item and enter the values. The variable can be any variable
defined in the Project.
4
Click OK.
Specifying metadata to be used for post-processing
documents
You can use any of the Process variables as metadata. Metadata can only be
specified on Document End level.
The variables that you will use for enveloping and sorting must be specified as
metadata when storing the documents.
To specify metadata
1
In the Runtime window, open the connector settings for the output
connector to be used.
2
Click Document End and Metadata Keys.
3
Click Add new Item and enter the values. The metadata key can be any
variable defined in the Project, for example the customer ID.
4
Click OK.
Enabling compression of data stored in postprocessing repository
1
In the Runtime window, open the connector settings for the output
connector to be used.
2
Click Job Begin and Device Driver Settings.
3
In the Compress data field, select whether to compress the data or not.
4
Click OK.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
11
12
Configuring a Post-processor repository output connector
Storing documents in the Post-processor repository
Creating a Job Info file
1
In the Runtime window, open the connector settings for the Post-processor
repository output connector to be used.
2
Click Job End.
3
In the Job info file field, specify a filename with a PPQ extension, for
example select.ppq. If you want to print the job immediately, you must
include the path to the input directory of the Project that retrieves the
documents from the post-processing repository.
4
Click OK.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
13
Retrieving documents from the
Post-processor repository
To retrieve documents stored in the post-processing repository, you use a query
that specifies the documents to be retrieved. The query is submitted to the Postprocessor, which retrieves the documents and forwards them to the output
connector.
You can either schedule when to submit a query to the Post-processor, or
manually submit a query.
You use the Post-processor Repository Tool to view and select the documents
stored in the post-processing repositories to be included in a query. Queries can
be stored in the resource set and used with a Post-processor scheduler input
connector. If you run the Post-processor Repository Tool as a stand-alone
application you must either export a query in text format and use it with a
Directory input connector, or in HTTP format with an HTTP input connector.
Selecting jobs and documents to be included in the query
The normal way to select what to include in a query is to apply filters. See
Filtering stored jobs and documents on page 16.
You can also manually select specific jobs and documents by clicking the
corresponding check box.
When you select a row representing the repository, the repository is high-lighted
and the jobs in the repository are displayed. When you select a row representing
the job, the job is highlighted and the documents within this job are displayed.
If you select a job (by clicking the check box to the left of the job), but no
documents within the job, all documents within this job are included in the query.
If you select a repository by clicking the check box to the left of the repository,
all jobs with their documents within that repository are included in the query
unless you check any jobs or documents.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
14
Scheduling when to submit a query to retrieve documents
Retrieving documents from the Post-processor repository
Scheduling when to submit a query to
retrieve documents
To schedule when to retrieve documents from the post-processing repository, you
specify a Post-processor query that is used at a specific time or at repeated
intervals. This is specified on the Post-processor scheduler input connector. You
must also configure a Post-processor to schedule when to retrieve the documents.
Post-processor query
The Post-processor query specifies the documents to retrieve. The query must be
stored as a resource in the resource set.
See Creating a query on page 15
Post-processor scheduler input connector
A Post-processor scheduler input connector retrieves the query and forwards it to
the Post-processor, either at a specific time or at repeated intervals.
See Configuring a Post-processor scheduler input connector on page 16
Post-processor
The Post-processor retrieves the documents specified in the query and sends them
to the output connector.
See Configuring a Post-processor on page 17
Specific Process and page settings
To use different Process and Page settings on the output connector, you must
create a link between the Post-processor and the Process that was used when
storing the documents in the post-processing repository.
If a specific Process name is matched when documents are processed in the Postprocessor, the settings for that Process are used on the Process Begin and Page
Begin levels.
Note: The name of the Process used when storing the documents must be
identical to the name of the Process link.
If no Process name is matched, the default Process link is used. You can not
remove the default Process link. The default Process link automatically connects
to the output connectors, which the Process links are connected to.
See Configuring Process links on page 17.
Output connector
You must specify Job output mode on the output connector.
You can select the output connector to use for the default Process link, based on
the name of the PPQ file sent to the Post-processor. You define the connector
selection method in the same way as in a StreamServe Job definition.
See the Design Center documentation.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Scheduling when to submit a query to retrieve documents
Retrieving documents from the Post-processor repository
Opening a repository in the Post-processor Repository
Tool
1
In the Resource set, right-click post-processor queries and select New
Resource > Post-processor query.
2
Double-click the query. The Post-processor Repository Tool opens.
3
In the Post-processor Repository Tool, select Repository > Open
Repository.
4
Click Add. The Open Location dialog opens.
5
Select Use local mode or enter the host name where the repository server is
located.
6
Enter the path to the repository. You can use an alias of the path to the
repository, see the Alias/Path option in Configuring a Post-processor
repository output connector on page 9.
7
Enter a connection name and click OK.
8
Select the connection and click Open. The repository is displayed in the
Post-processor Repository Tool.
Opening a repository in the Post-processor Repository
Tool when a connection is established
1
In the Resource set, right-click post-processor queries and select New
Resource > Post-processor query.
2
Double-click the query. The Post-processor Repository Tool opens.
3
In the Post-processor Repository Tool, select Repository > Open
Repository.
4
Select a connection and click Open. The repository is displayed in the Postprocessor Repository Tool.
Creating a query
1
Open the repository where the documents to retrieve are stored. See
Opening a repository in the Post-processor Repository Tool on page 15.
2
Use a filter to select what to be included in the query. See Filtering stored
jobs and documents on page 16.
3
Select the repositories, jobs, and documents to be included in the query by
clicking the check-box to the left of each repository, job, and document.
4
Select Tools > Options. The Options dialog opens.
5
Click Action and select the processing options. See Processing options on
page 21.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
15
16
Scheduling when to submit a query to retrieve documents
Retrieving documents from the Post-processor repository
6
Select if the status of the jobs and documents will be updated or not after
they are retrieved and processed.
7
Save the resource.
Filtering stored jobs and documents
You can apply filters to the job and document lists in the Post-processor
Repository Tool. Using one or more filters, only the jobs and documents matching
your selection will be included in the query and displayed in the job and document
lists. For example, you can apply a filter specifying a query to retrieve documents
with customer numbers between 1000 and 2000.
To create a filter for displaying specific jobs
1
In the Post-processor Repository Tool, select Tools > Define Filter. The
Filters dialog opens.
2
Add one or more filters in the Properties filters frame. See Filters dialog
box on page 29.
3
Click Apply to apply the selected filters to the job list.
To create a filter for displaying specific documents
1
In the Post-processor Repository Tool, select a connection, a job, and a
document.
2
Select Tools > Define Filter.
3
Add one or more filters in the Properties filters frame. See Filters dialog
box on page 29.
4
Click Apply to apply the selected filters to the document list.
To create a filter for displaying documents with specific metadata
1
In the Post-processor Repository Tool, select a connection, a job, and a
document.
2
Select Tools > Define Filter.
3
Add one or more filters in the Metadata filters frame.
4
Click Apply to apply the selected filters to the document list.
Configuring a Post-processor scheduler input
connector
1
In the Platform window, create a Post-processor Scheduler input
connector.
2
In the Post-Processor query field, select the resource name.
3
In the Spooling interval field, open the Scheduler Configuration dialog
box.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Scheduling when to submit a query to retrieve documents
Retrieving documents from the Post-processor repository
4
Specify the time or interval at which the query will be sent to the input
connector.
5
Click OK.
Configuring a Post-processor
1
In the Runtime window, right-click and select New Post-processor. A
Post-processor object is created with a default Process link.
2
Connect the output connector to the default Process link.
Configuring Process links
1
To link to a specific Process from the Post-processor, right-click the Postprocessor object and select Add Process Link.
2
Select the Message and the Process the Post-processor will link to.
3
Connect the Process link to an output connector.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
17
18
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
Manually submitting a query to retrieve
documents
To manually submit a query to the Post-processor, you must configure a Directory
or HTTP input connector and a Post-processor which retrieves documents from
the post-processing repository.
Post-processor query
You must create a query specifying the documents to retrieve. The query must
either be exported as a file or sent as a HTTP post to the input connector.
You use the Post Processor Repository Tool as a standalone application when you
create a query to be manually submitted to retrieve documents from the postprocessing repository.
To print all documents within a job, you can use a job info file, which you specify
when storing the job in the post-processing repository. See Creating a Job Info
file on page 12.
Using the Post-processor Repository Tool Export wizard, you can:
•
Export the query to a file.
See Creating a file query on page 20.
•
Export the query as an HTTP post to an HTTP input connector.
See Creating a HTTP post query on page 20.
Input connector
A Directory or HTTP input connector receives a query and forwards it to the Postprocessor. If you use a query file, you must use a Directory input connector. If you
use an HTTP query, you must use an HTTP input connector.
Note: You can not use an HTTPS input connector.
To configure an input connector, see the Design Center documentation.
Post-processor
The Post-processor retrieves the documents specified in a query and sends them
to the output connector.
See Configuring a Post-processor on page 22.
Process links
To use different Process and Page settings on the output connector, you must
create a link between the Post-processor and the Process that was used when
storing the documents in the post-processing repository.
If a specific Process name is matched when documents are processed in the Postprocessor, the settings for that Process are used on the Process Begin and Page
Begin levels.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
Note: The name of the Process used when storing the documents must be
identical to the name of the Process link.
If no Process name is matched, the default Process link is used. You can not
remove the default Process link. The default Process link automatically connects
to the output connectors, which the Process links are connected to.
See Configuring Process links on page 23.
Output connector
You must specify Job output mode on the output connector.
You can select the output connector to use for the default Process link, based on
the name of the PPQ file sent to the Post-processor. You define the connector
selection method in the same way as in a StreamServe Job definition.
See the Design Center documentation.
Adding and modifying metadata of retrieved documents
To select documents to be retrieved according to criteria other than shown in the
Post-processor Repository Tool, you can add or modify metadata associated with
the retrieved documents, see Adding and modifying metadata when manually
submitting a query on page 23.
Opening a repository in the Post-processor Repository
Tool
1
2
In the Windows Start menu, select All Programs > ... > StreamServe >
Utilities > Post-processor Repository Tool.
In the Post-processor Repository Tool, select Repository > Open
Repository.
3
Click Add. The Open Location dialog opens.
4
Select Use local mode or enter the host name of the repository server.
5
Enter the path to the repository. You can use an alias of the path to the
repository, see the Alias/Path option in Configuring a Post-processor
repository output connector on page 9.
6
Enter a connection name and click OK.
7
Select the connection and click Open. The repository is displayed in the
Post-processor Repository Tool.
Opening a repository in the Post-processor Repository
Tool when a connection is established
1
In the Windows Start menu, select All Programs > ... > StreamServe >
Utilities > Post-processor Repository Tool.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
19
20
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
2
In the Post-processor Repository Tool, select Repository > Open
Repository.
3
Select the connection and click Open. The repository is displayed in the
Post-processor Repository Tool.
Creating a file query
1
Open the repository where the documents to retrieve are stored, see
Opening a repository in the Post-processor Repository Tool on page 19.
2
Use a filter to select what to be included in the query. See Filtering stored
jobs and documents on page 16.
3
Select the repositories containing the filtered documents by clicking the
check box to the left of the connection name.
4
Select Tools > Export wizard.
5
Select File.
6
Browse to where you want to export the file and enter a path and file name,
for example c:\my_queries\my_query1.ppq
7
In the Processing options drop-down list, select the processing option for
the selected documents. Specify the processing options for the documents
included in the query. See Processing options on page 21.
8
Select if the status of the jobs and documents will be updated or not after
they are retrieved and processed.
9
Specify the repository connection options. See Connection options for
manually retrieving documents on page 21.
Creating a HTTP post query
1
Open the repository where the documents to retrieve are stored, see
Opening a repository in the Post-processor Repository Tool on page 19.
2
Use a filter to select what should be included in the query. See Filtering
stored jobs and documents on page 16.
3
Select the repositories containing the filtered documents by clicking the
check-box to the left of the connection name.
4
Select Tools > Export wizard.
5
Select HTTP.
6
Enter the URL and port number of the HTTP input connector used for
receiving the Post-processor query.
7
Specify the processing options for the documents included in the query. See
Processing options on page 21.
8
Specify the repository connection options. See Connection options for
manually retrieving documents on page 21
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
Processing options
Process selection
The documents will be processed. The status
Processed is displayed in the Post-processor
Repository Tool when the documents have been
retrieved.
Process selection and
mark for deletion
The documents will be processed. If the documents
are successfully processed, the status Deleted is
displayed in the Post-processor Repository Tool.
Process and delete
selection
The documents will be processed. If the documents
are successfully processed, they are deleted from the
repository. The job containing the documents is not
deleted even if all documents within it are deleted. If
jobs are selected they are deleted.
Process and delete
The documents will be processed. If the documents
selection, delete empty are successfully processed, they are deleted from the
jobs
repository. The job containing the documents is
deleted when all documents within the job are
deleted.
Delete selection
The documents will be deleted from the repository.
The job containing the documents is not deleted even
if all documents within it are deleted. If jobs are
selected they are deleted.
Delete selection, delete The documents will be deleted from the repository.
empty jobs
The job containing the documents is deleted when all
documents within the job are deleted.
Delete empty jobs
The selected jobs are deleted if they do not contain
any documents.
Connection options for manually retrieving documents
Keep repositories
open
Select this option to keep the post-processing repository
open between jobs. This can increase performance if
many small jobs are processed.
Note: If a repository is kept open in local mode, no other
StreamServer or Post-processor Repository Tool
can access the repository.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
21
22
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
On lost repository
server connection
Select the method to reconnect to the repository in case
of failure. This option is only applicable if the repository
is running in server mode. Reconnecting is only possible
when a job is not being processed and the Keep
repositories open option is selected.
Do not attempt recovery – The StreamServer will not
try to reconnect to the post-processing repository server.
Unlimited number of recovery attempts – The
StreamServer will try to reconnect to the post-processing
repository until a connection is successfully established.
Limited number of recovery attempts – The
StreamServer will try to reconnect to the Post-processor
repository until a connection is successfully established,
or until the maximum number of re-connection attempts
is reached.
Note: If the connection is lost while a job is being
processed, no reconnection attempt is made and
you must re-send the job.
Reconnection
attempts
If the StreamServer fails to reconnect when the maximum
number of attempts is reached, it will shut down.
Note: In order for reconnection to work properly,
recovery needs to be enabled for those queues and
SDR connectors that should reconnect. In
addition, the contries and condelay options
need to be set in the PPQ file. These options are
only added to the PPQ file if the Post-processor
Repository Tool is used to create the PPQ file.
PPQ file example:
<s-dbs action="process" update="all"
contries="-1" condelay="10">
where
is number of reconnection attempts.
condelay is time between reconnection
attempts.
contries
Time between
attempts (s)
The number of seconds between the reconnection
attempts.
Configuring a Post-processor
1
In the Runtime window, right-click and select New Post-processor. A
Post-processor object is created with a default Process link.
2
Connect the output connector to the default Process link.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
Configuring Process links
1
To link to a specific Process from the Post-processor, right-click the Postprocessor object and select Add Process Link.
2
Select the Message and the Process the Post-processor will link to.
3
Connect the Process link to an output connector.
Adding and modifying metadata when manually
submitting a query
You can add and modify metadata associated with documents that you retrieve
from the post-processing repository. For example, if information is available
about documents that was not available at the time the documents were stored in
the repository, you can add this information and associate it with the retrieved
documents.
To add or modify metadata, you must edit or create a new query file using a text
tool or configure an XMLOUT Process to generate the query file.
Note: Adding or modifying metadata when retrieving documents does not
change the metadata stored in the post-processing repository.
You use gmi tags to add or modify the metadata. The gmi tag has the following
syntax:
<gmi name="<name>" value="<value>" type="<str>" oper="<set>"/>
Where:
<name>
The metadata name.
<value>
The value used as metadata.
<type>
The metadata type, num or str
<oper>
add – adds new metadata to the document. If the metadata
already exists, it is not replaced with the new value.
replace
– replaces existing metadata
set – adds new metadata to the document. If the metadata
already exists, it is replaced with the new value.
You can add gmi tags on job level and on document level. On job level, you must
add the gmi tags directly after the jobset tag. On document level, you must add
the gmi tags directly after the docset tag.
Example 1
Post-processor query with gmi tags to generate metadata externally
<s-dbs action="process">
<database SERVER="LOCAL" name="my_repository" user=" " password="
">
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
23
24
Manually submitting a query to retrieve documents
Retrieving documents from the Post-processor repository
<jobset sel="ID=10">
<gmi name="zipcode" value=$zip type ="num" oper="set"/>
<docset sel="ID=23">
<gmi name="Key1" value=$key1 type="num" oper="add"/>
<gmi name="Key2" value=$key2 type="str" oper="replace"/>
</docset>
<docset sel="ID=124">
<gmi name="Key1" value=$key1 type="num" oper="add"/>
<gmi name="Key2" value=$key2 type="str" oper="set"/>
</docset>
</jobset>
</database>
/s-dbs>
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
25
The Post-processor Repository
Tool GUI reference
To select which columns to display in the lists, use the Tools > Options dialog.
Connection list
Connection list
Connection
A name that identifies the connection to the repository.
Server
The server where the post-processing repository is
located. LOCAL means the repository is opened in local
mode.
Alias/Path
The alias of or path to the post-processing repository. To
create an alias, see Configuring a Post-processor
repository output connector on page 9.
Description
A description of the connection. By default, it consists of
the alias or the path to the repository and the server where
the repository is located. For example
c:\my_repository on LOCAL
Job list
Job list
PP Job ID
The ID of the job used internally by the Post-processor.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
26
Job list
The Post-processor Repository Tool GUI reference
Job list
Status
The status of the job.
Stored – The job is stored in the post-processing
repository.
Processed – The job has been processed by the Postprocessor and sent to the driver.
Erroneous – The job contains an error.
Deleted – The job has been selected to be removed from
the post-processing repository.
Removed – The job has been deleted from the postprocessing repository.
Unknown – The job is either removed from the post-
processing repository or it is locked by another process.
Priority
The priority of the job.
Creation time
The time the job was created by the SDR driver.
Process time
The time the job has been processed by the Postprocessor and sent to the output connector.
Name
The name of the job. The name is generated by the
StreamServer.
Error
The error ID of the job. The error ID is generated by the
StreamServer if an error occurs during the job.
User
The user who created the job.
Job pages
The number of pages in the job. This number is
calculated when the job is created by the SDR driver, and
is not updated if you remove documents from the job
stored in the post-processing repository.
Strs ID
The ID of the StreamServe job that was stored by the
SDR driver in the post-processing repository.
Version
The version of the job.
Connection
The name of the connection to the database where the job
is stored.
Server
The name of the server where the post-processing
repository is located.
Alias/Path
The alias of or path to the post-processing repository.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Document list
The Post-processor Repository Tool GUI reference
Document list
Document list
PP Doc ID
The ID of the document. The ID is generated by the Postprocessor and is used to retrieve documents from the
post-processing repository.
PP Job ID
The ID of the job used internally by the Post-processor.
Status
The status of the document:
Stored – The document is stored in the post-processing
repository.
Processed – The document has been processed by the
Post-processor and sent to the driver.
Error – The document contains an error.
Deleted – The document has been selected to be removed
from the post-processing repository.
Removed – The document has been deleted from the
post-processing repository.
Unknown – The document is either removed from the
Post-processor repository or it is locked by another
process.
Priority
The priority of the document.
Creation time
The time the document was created by the SDR driver.
Process time
The time the document was processed by the Postprocessor and sent to the output connector.
Error
If the document has status Error, the ID of this error.
Pages
The number of logical pages in the document.
Res. Repository
The repository used for storing resources used in the
documents, see Configuring a Post-processor repository
output connector on page 9.
Res. Server
The server of the repository used for storing resources
used in the documents, see Configuring a Post-processor
repository output connector on page 9.
Connection
The name of the connection to the repository storing the
document.
Server
The server name of the repository storing the document.
Alias/Path
The alias or path to the repository storing the document.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
27
28
File menu
The Post-processor Repository Tool GUI reference
Document list
<Metadata>
One or several columns displaying metadata for the
document, if metadata exists. See Specifying metadata to
be used for post-processing documents on page 11.
File menu
New
Creates a new PPQ file for a connection to a postprocessing repository.
Open
Opens a PPQ file.
Save
Saves a PPQ file.
Save As
Saves a PPQ file and specify a name.
Exit
Closes the Post-processor Repository Tool.
Repository menu
Open repository
Opens a repository.
Close repository
Closes a repository.
Delete checked
items
Removes checked items from the repository.
Recover checked
items
Changes the status of checked items that have status
Deleted to Stored or – if the item has a value for the
Process time property – Completed.
Set authentication
Sets a user name and password for opening a selected
connection.
Tools menu
Define filter
Opens the Filters dialog box.
Apply filter
Applies the filters you have created.
Export wizard
Opens the Export wizard to export the Post-process query
you have created.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Connections dialog box
The Post-processor Repository Tool GUI reference
Export now
Exports the Post-process query you have created, without
using the wizard.
Options
Opens the Options dialog.
Connections dialog box
Contents
Name
The name of the connection.
Description
A description of the connection. It consists of an alias, or
the path to the repository and the server where the
repository is located. For example c:\my_repository
on LOCAL
Add
Opens the Open Location dialog box.
Remove
Removes a selected connection.
Open
Opens a selected connection in the Connections list.
Open Location dialog box
Open Location settings
Use local mode
The repository is opened in local mode on the local host.
Host name
The name of the remote host.
Alias/Path
The alias or the path to the repository.
Filters dialog box
Properties filters settings
Operator
If you are using more than one filter, selects if the filter is
applied together with the previous filter in the filter list
(AND), or if it is applied independently (OR).
Property
The property to be filtered.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
29
30
Options dialog box
The Post-processor Repository Tool GUI reference
Properties filters settings
Condition
The condition of the property-value combination.
Note: != means not equal to.
Value
The value of the property to be filtered.
Apply
Adds the filter to the filter list and applies the selected
filter to the jobs or documents list.
Add
Adds the filter to the filter list.
Group
Groups two or more filters if you are using both OR and
AND statements. See Example 2 on page 30.
Ungroup
Ungroups the selected filters.
Remove
Removes the selected filter.
Remove all
Removes all filters.
Metadata filters settings
Creates one or more filters for metadata values as for the Properties filters above.
Example 2
Grouped filter statements
Status = Stored AND (Creation time = Today OR Creation time = Today’1’)
Options dialog box
Used for: Selecting which properties to display for connections, jobs, and
documents.
Connection view tab
Used for selecting which connection properties to display.
Job view tab
Used for selecting which job properties to display, and how many jobs to list on
one page.
Document view tab
Used for selecting which document properties to display, and how many
documents to list on one page.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Options dialog box
The Post-processor Repository Tool GUI reference
Action tab
Used for selecting the document processing options, i.e. what to do with the
documents included in the query. The Action tab is only active when the Postprocessor Repository Tool is opened from the resource set.
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
31
32
Options dialog box
The Post-processor Repository Tool GUI reference
StreamServe Persuasion SP4 Post-processor repository User Guide Rev A
Download PDF