Getting Started with the LabVIEW Desktop Execution Trace Toolkit

Getting Started with the LabVIEW Desktop Execution Trace Toolkit
Getting Started with the
LabVIEW Desktop Execution
Trace Toolkit for Windows
™
Version 1.0
Contents
Overview ................................................................................................. 2
System Requirements.............................................................................. 2
Installing the Desktop Execution Trace Toolkit ..................................... 2
LabVIEW Platform DVDs............................................................... 2
LabVIEW Desktop Execution Trace Toolkit for Windows
Installation Media ......................................................................... 3
Launching the Desktop Execution Trace Toolkit ................................... 3
Completing a Trace Session.................................................................... 4
Opening a Trace Connection ........................................................... 4
Configuring a Trace Session............................................................ 4
Executing a Trace Session ............................................................... 5
Filtering a Trace Session.................................................................. 6
Saving or Exporting a Trace Session ............................................... 7
Comparing Trace Sessions............................................................... 7
Advanced Debugging Options ................................................................ 8
Related Documentation........................................................................... 9
Overview
The LabVIEW Desktop Execution Trace Toolkit for Windows is a
stand-alone application that acquires execution data from LabVIEW
applications that run on the desktop. The toolkit displays the data it
acquires, called trace data, as events in a table view that you can browse,
save, and compare to other collections of trace data. For each execution
event that occurs, the table view displays the type of event, the time the
event occurs, the VI in which it occurs, and any additional details that are
available.
You can use trace data to debug and optimize large LabVIEW applications,
including those with multiple loops, client-server architectures,
dynamically loaded VIs, and so on. The process of acquiring trace data
from a running application is referred to as executing a trace session.
This manual uses an example LabVIEW project to show you how to
configure, execute, and save trace sessions in which you acquire and
analyze data from a running LabVIEW application.
System Requirements
To run the Desktop Execution Trace Toolkit, National Instruments
recommends that your system meet the following requirements:
•
Windows Vista/XP/2000
•
LabVIEW 8.6.1 Base, Full, or Professional Edition, or later
•
512 MB of memory
•
Pentium 4 processor or equivalent (Pentium III or Celeron 600 MHz
minimum)
Installing the Desktop Execution Trace Toolkit
You can install the Desktop Execution Trace Toolkit from the
LabVIEW 8.6.1 or later Platform DVDs or from the LabVIEW Desktop
Execution Trace Toolkit for Windows installation CD.
LabVIEW Platform DVDs
You can install all of your LabVIEW products—including LabVIEW and
the Desktop Execution Trace Toolkit—using the LabVIEW 8.6.1 or later
Platform DVDs. Refer to the LabVIEW DVD Installation Instructions or
the LabVIEW Release Notes, which are available in your LabVIEW box,
for information about the LabVIEW Platform DVDs.
Desktop Execution Trace Toolkit
2
ni.com
LabVIEW Desktop Execution Trace Toolkit for Windows Installation
Media
Complete the following steps to install the Desktop Execution Trace
Toolkit from the LabVIEW Desktop Execution Trace Toolkit for Windows
installation media.
Some virus detection programs interfere with the installer. Disable any automatic
virus detection programs before you install. After installation, check your computer for
viruses and enable any virus detection programs you disabled.
Note
1.
Exit all programs before you run the Desktop Execution Trace Toolkit
installer.
2.
Log on as an administrator or as a user with administrator privileges.
3.
Insert the LabVIEW Desktop Execution Trace Toolkit for Windows
installation CD and follow the instructions that appear on the screen.
4.
Activate the Desktop Execution Trace Toolkit using the NI License
Manager.
Launching the Desktop Execution Trace Toolkit
After you install the Desktop Execution Trace Toolkit, you can launch the
toolkit in any of the following ways:
•
In the LabVIEW Project Explorer window, right-click My
Computer and select Trace Execution from the shortcut menu. This
method launches the toolkit and opens a trace connection to the
application instance of the project.
•
From a LabVIEW VI, select Tools»Profile»Trace Execution. This
method launches the toolkit and opens a trace connection to the
application instance in which you are developing the VI.
•
In Windows, select Start»All Programs»National Instruments»
LabVIEW Desktop Execution Trace Toolkit»LabVIEW Desktop
Execution Trace Toolkit.
© National Instruments Corporation
3
Desktop Execution Trace Toolkit
Completing a Trace Session
When you use the Desktop Execution Trace Toolkit to capture trace data
from a LabVIEW application, you are completing a trace session.
Opening a Trace Connection
To begin a trace session, you must open a trace connection between the
Desktop Execution Trace Toolkit and the LabVIEW application instance in
which the application you want to debug runs. Complete the following
steps to open an example project and open a trace connection to the
application instance of the project.
1.
In LabVIEW, select Help»Find Examples to launch the NI Example
Finder.
2.
Navigate to Toolkits and Modules»Desktop Execution Trace and
double-click Desktop Execution Trace Toolkit.lvproj to open the
example project.
3.
In the project, right-click My Computer and select Trace Execution
from the shortcut menu to launch the Desktop Execution Trace Toolkit
and open a trace connection to the project.
Configuring a Trace Session
After you open a trace connection, you can configure the types of execution
events you want to trace by selecting execution events to capture.
Complete the following steps to configure the trace session for the trace
connection you opened in the previous section.
Desktop Execution Trace Toolkit
1.
In the Desktop Execution Trace Toolkit, click the Configure button,
shown at left, to display the Configure Trace Session dialog box.
2.
Ensure that checkmarks appear in the checkboxes for the events you
want to trace. Selecting only the events you want to trace reduces the
amount of data the toolkit must process and that you must analyze. For
this example, you can use the default configuration.
3.
Click the OK button to apply the configuration settings and close the
Configure Trace Session dialog box.
4
ni.com
Executing a Trace Session
After you open a trace connection and configure the trace data you want to
acquire, you are ready to execute a trace session and capture the trace data.
Complete the following steps to execute a trace session.
1.
In the Desktop Execution Trace Toolkit, click the Start button, shown
at left, to begin tracing data.
2.
In the LabVIEW Project Explorer window, expand the Tests folder
and double-click Desktop Execution - Generate Trace Events.vi to
open the VI.
3.
Click the Run button to run the VI. The Desktop Execution Trace
Toolkit begins tracing the execution events that occur as the VI runs
and displays the events in the table view.
By default, the table view displays each event in the order it occurs, the
time each event occurs, the VI that triggers the event, the type of the
event, and details about the event. Right-click a column header to
select the columns you want to show or hide in the table view.
You can select an event from the table view to display additional details
about the event in the Event Details section at the bottom of the table.
4.
Click the buttons on the front panel of the Desktop Execution Generate Trace Events VI to see how the Desktop Execution Trace
Toolkit captures data about the type of event the button triggers. For
example, click the Load Dynamic VI button to see the events that
occur when the parent VI loads a subVI dynamically.
5.
(Optional) Double-click an event in the table view of the Desktop
Execution Trace Toolkit to highlight where the event occurs on the
LabVIEW block diagram.
6.
Click the Stop button on the front panel of the Desktop Execution Generate Trace Events VI to stop the VI.
7.
In the Desktop Execution Trace Toolkit, click the Stop button, shown
at left, to stop tracing data and complete the trace session.
If you are tracing an application that you expect to generate a large number
of events, you can improve performance by only displaying trace data in the
table view after the trace session is complete. Right-click the table view and
select Display Refresh Off from the shortcut menu to disable automatic
refreshing of the table view. In this mode, the table view waits until you
stop the trace session to display the trace data.
You also can improve performance by disabling table highlighting. By
default, the Desktop Execution Trace Toolkit highlights different event
types using different background colors for the event types. Select
Tools»Options to display the Options dialog box, and select Table
Highlight from the Category list to display the Table Highlight page.
© National Instruments Corporation
5
Desktop Execution Trace Toolkit
Place a checkmark in the Disable Highlighting checkbox and click the OK
button to disable table highlighting.
Filtering a Trace Session
Executing a trace session even on a small application can capture hundreds
of execution events. You can make the table view easier to read by filtering
the events that the table view displays. For example, you can filter events
that occur in specific VIs. Complete the following steps to filter VI events.
1.
Click the Start button to start a new trace session using the same
example project from the previous exercise.
2.
In LabVIEW, click the Run button to run the Desktop Execution Generate Trace Events VI.
3.
In the Desktop Execution Trace Toolkit, double-click the new trace
session that appears in the Trace Data view. A new tab appears in the
table view and displays trace data for the current trace session.
4.
In the Desktop Execution - Generate Trace Events VI, click the Load
Dynamic VI button to load the Strip Chart SubVI. In the table view of
the Desktop Execution Trace Toolkit, the VI column shows events
occurring in the Strip Chart SubVI.
5.
Click the Configure Filter button, shown at left, that appears at the top
right of the table view to display the Configure Displayed Events
dialog box. The Category list displays the different sources of trace
events.
6.
Without removing the checkmark from the checkbox next to the item,
select VIs from the Category list to display the VIs page of the dialog
box.
7.
In the VIs list, remove the checkmark from the Desktop Execution Strip Chart SubVI.vi checkbox and click the OK button to filter the
events that occur in the subVI. The table view updates so that the
filtered events no longer appear.
8.
Click the Stop button on the front panel of the Desktop Execution Generate Trace Events VI to stop the VI.
9.
In the Desktop Execution Trace Toolkit, click the Stop button to stop
tracing data and complete the trace session.
Filtering events prevents those events from appearing in the table view.
However, the Desktop Execution Trace Toolkit continues to trace filtered
events. You can use the Configure Displayed Events dialog box to specify
events to filter or display at any time. The table view updates to match
the new configuration settings each time you click the OK button in the
Configure Displayed Events dialog box. You also can click the Clear
Filter button, shown at left, to stop filtering events.
Desktop Execution Trace Toolkit
6
ni.com
Note If you do not want the Desktop Execution Trace Toolkit to trace a specific type of
event at all, you must deselect that event type in the Configure Trace Session dialog box
mentioned in the Configuring a Trace Session section.
Saving or Exporting a Trace Session
After you complete a trace session, you can save the session to view at a
later time. Select File»Save Trace or right-click the trace session name in
the Trace Data view and select Save Trace from the shortcut menu to save
the trace session. Select File»Load Trace to load a saved trace session.
The Desktop Execution Trace Toolkit saves trace sessions as trace tool data
(.ttd) files that the toolkit recognizes and can reload in the table view.
Only the Desktop Execution Trace Toolkit recognizes this file format.
However, you can export trace sessions to text (.txt) files that you can
view in any text editor. Right-click a display in the table view or a trace
session name in the Trace Data view and select Export Trace from the
shortcut menu to export a trace session to a text file.
You can use the General page of the Options dialog box to configure the appearance
of the text file. Select Tools»Options to display the Options dialog box, and select
General from the Category list to display the General page.
Tip
Comparing Trace Sessions
Each application instance in the Trace Data view has a default tab that
updates to show new trace data each time you execute a trace session.
However, you can split a single tab into multiple displays to display
multiple trace sessions on a single tab. Complete the following steps to
display the two trace sessions you completed in this chapter on one tab in
the table view.
1.
With either tab visible, right-click the table view and select Split
Display»Horizontal from the shortcut menu. The tab splits into two
displays.
2.
By default, a new display contains the same data as the display from
which you create it. Right-click one of the displays and select Clear
Display from the shortcut menu to clear the display.
3.
In the Trace Data view, select the trace session that does not currently
appear on the tab and drag it the display you cleared. The display
updates to show the data from that trace session.
You also can view multiple trace sessions at once by creating separate,
floating windows for tabs. After you create a floating window, you can
dock the window so it appears in a fixed location in the application window.
Right-click a tab name and select Float from the shortcut menu to display
the tab in a separate, floating window.
© National Instruments Corporation
7
Desktop Execution Trace Toolkit
Note
You cannot float the first or default tab for an application instance.
Grab the title bar of the floating window and drag the window to display
docking icons, shown at left. While dragging the window, move the cursor
over one of the docking icons and release the mouse button to dock the
window at the highlighted location.
Advanced Debugging Options
The Desktop Execution Trace Toolkit offers the following advanced
debugging options.
•
Tracing User-Defined Trace Events—If you install the Desktop
Execution Trace Toolkit on a computer with LabVIEW 8.6.1 or later,
the Generate User-Defined Trace Event function, shown at left,
appears on the Functions palette in LabVIEW. When this function
executes, the Event column of the Desktop Execution Trace Toolkit
table view displays a User Defined trace event. The Details column
displays any values you wire to the inputs of the function. For example,
if you execute a trace session on a LabVIEW application that writes a
string to a file, you can wire the string to the trace string input of the
Generate User-Defined Trace Event function. When the function
executes, the Details column of the table view displays the exact string
that the application writes.
Refer to the LabVIEW Help for more information about the Generate
User-Defined Event function.
•
Desktop Execution Trace Toolkit
Debugging LabVIEW Stand-Alone Applications and Shared
Library Files—You also can use the Desktop Execution Trace Toolkit
to debug stand-alone applications and shared library files that you
build using the LabVIEW Application Builder. Refer to the LabVIEW
Desktop Execution Trace Toolkit Help, accessible in the toolkit by
selecting Help»Launch Help, for information about debugging
LabVIEW built applications and shared library files.
8
ni.com
Related Documentation
The following document contains information that you may find helpful as
you use the Desktop Execution Trace Toolkit:
•
LabVIEW Desktop Execution Trace Toolkit for Windows Help—This
help file contains information about the Desktop Execution Trace
Toolkit environment, including views, menus, buttons, and dialog
boxes. This help file also includes step-by-step instruction for
completing trace sessions. In the toolkit, select Help»Launch Help to
access this help file.
•
LabVIEW Help—This help file contains information about LabVIEW
palettes, menus, tools, VIs, and functions. This help file also includes
step-by-step instructions for using LabVIEW features. In LabVIEW,
select Help»Search the LabVIEW Help to access this help file.
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni.com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products/technology,
refer to the appropriate location: Help»Patents in your software, the patents.txt file on your
media, or the National Instruments Patent Notice at ni.com/patents.
© 2008 National Instruments Corporation. All rights reserved.
372651A-01
Nov08
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising