section 4 ancnf windows based setup program reference

section 4 ancnf windows based setup program reference
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
The Windows based set-up program is menu driven, allowing the user to easily view data, alter setup variables or set machine timing (machine offset, timing signal locations, etc.), using a PC
running the Windows (95/98/ME/2000/XP/NT) operating system. The set-up variables are used to
configure and tune the M4500 to match the configuration and performance of the specific
necker/flanger (see section 2.4 – Tuning the HSL-ANCNF).
Note: The set-up program is an on-line communications program used to interface with the M4500
module. The data displayed and set in the windows is communicated directly to the module, while
in the “Online” edit mode. Therefore, prior to going online with the processor, make sure an RS232 cable is connected from the COM port on the computer to the “PROG” port on the M4500.
The variables displayed while in the “Online” edit mode are read directly from the processor. Data
is saved to a “Set-up Data” file (*.sdt) whenever changes are made to a parameter or if the data is
uploaded from the processor.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 27 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.1 GENERAL DESCRIPTION
Title Bar: At the top of the window is the “Title Bar”. The title bar is used to display the name of
the working “Set-up Data” file, as well as, the name of the active “Window”. The title bar is dark if
the window is active and grayed if another window is active. The color depends on the settings of
the Display Properties of the Control Panel.
Status Bar: At the bottom of the window is the “Status Bar”. The status bar is used to display
system messages, online or offline mode, as well as, the current time and date as set by the
operating system. The system messages panel displays general information about operation of the
system. The Online/Offline mode panel displays the status of the current set-up program mode of
operation. The mode of operation can be changed by simply double clicking the online/offline
mode panel.
Hot Keys: Hot keys are activated by holding down the “ALT” key and simultaneously pressing
the underlined letter of the desired function. Almost every function can be activated by either
pressing a series of hot keys or using the “TAB” key to move between fields.
Online/Offline Modes: The set-up program allows the user to make changes while “Online”
with the processor. The “Offline” mode is used to preset parameters prior to download. All
functions are available to the user while “Online”, however, specific “Online” functions are
disabled in the “Offline” edit mode.
Note: Offline changes can only be made by enabling “Offline Editing”, accessed under the “Edit”
menu.
Getting Help: The entire contents of the user’s manual is contained within the help file. Pressing
Ctrl+H will display the help file window. Pressing the F1 key will display the contents file. Hot
spots allow jumps to other topics to display additional information as desired. Selecting About
ANCNF from the Help menu will display a dialog box listing information about the current revision
of the setup program and how to obtain technical support.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 28 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.2 THE FILE MENU
The “File” menu allows the user to perform the following functions:
•
•
•
•
•
•
•
•
Create a “New” set-up “Data File”.
Open an existing “Data File”.
Save any changes made to the current “Data File” to disk.
Upload (save) Data from the Processor.
Download a SYSdev (.sdv) program to the processor
Download (restore) Data from the current set-up “Data File” to the processor
Print a Report of the current set-up parameters.
Exit the set-up program
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 29 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.2.1 THE SET-UP DATA FILE
The set-up “Data File” (.sdt) is a binary access file, designed for fast file I/O operation. When the
set-up program is first invoked, the default set-up parameters are loaded into memory. If changes
are made to any of the set-up parameters (either online or offline), as well as shift data, the user will
be flagged to “Save Changes” upon exit of the program.
Note: Any windows based “Set-up” program can open a set-up “Data File”, however, the data
tables will not be properly aligned. The user will be alerted to the problem if a set-up data file has
been created by either a different set-up program or a different revision of the software.
The set-up “Data File” is similar to that of a word processing file. When the program first starts a
default file is loaded and the user is able to make any changes as desired. The set-up program is
unaware of the settings and parameters that exist within the M4500. Therefore, to normalize the
set-up program with the processor, the user should define or open an existing file, then upload “All”
variables from the processor. This allows the user to either create a backup of the data or maintain
an existing file. The user can even open a data file for another necker/flanger, save the file to a new
name, make the necessary changes and simply download the new parameters to another processor.
The following functions can be accessed any time, from any set-up or display windows.
New: To create a “New” data file, select “New” from the “File” menu or press “Ctrl + N”. This
creates a completely new file, loaded with the default variables and the word “[unnamed]” is
displayed in the title bar. If any changes were made to the existing file, the user is prompted to save
changes to the existing file.
Open: To “Open” and existing data file, select “Open” from the “File” menu or press “Ctrl + O”.
This displays a dialog box allowing the user to select an existing data file to open. The name of the
file will be displayed in the title bar. If any changes were made to the existing file, the user will be
prompted to save any changes before terminating the program.
Save: To “Save” data file to disk, select “Save” from the “File” menu or press “Ctrl + S”. This
displays a dialog box allowing the user to select a folder and enter a name for the file. The user will
be notified if the file already exists and the extension “.sdt” will automatically be added to the file
name. If this is a “New” file, the user will be prompted to enter a file name.
Save As: To save the data file to a new name, select “Save As” from the “File” menu.. This
displays a dialog box allowing the user to select a folder and enter in a new name for the file. The
user will be notified if the file exists and the extension “.sdt” will automatically be added to the file
name.
Export Shift Data…: This function allows the user to export the shift data to a “Tab Delimited”
text file. This allows the user to easily use the shift data to produce production reports.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 30 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.2.2 UPLOAD (SAVE) DATA
The “Set-up” program allows the user set-up parameters, timing channel set-points and shift data
from the M4500 into a set-up “Data File”. This function is accessed from the “File”.
________________________________________________________________________________
4.2.3 DOWNLOAD PROGRAM
The “Set-up” program allows the user to “Download” any SYSdev program file to the M4500.
Note: To “Download” a SYSdev program to the processor, the program must be “Online”. If
“Online” mode cannot be achieved, program download will not be executed. If the program is
currently “Offline”, the user will be prompted to first go “Online”.
Once selected, and the set-up program “Online” with the processor, a dialog box will be displayed,
allowing the user to select the SYSdev file to download.
Note: Only the files with the “.sdv” file extension will be displayed. It is important to keep in
mind that only a valid M4500 PLC SYSdev file can be downloaded through the set-up program.
Care should be taken when selecting a program to download.
Once selected, a message box is displayed informing the user of the current program, revision and
checksum of the program loaded in the processor, as well as, that of the selected program.
The user must confirm their selection by clicking the “Yes” command button. After the user
confirms their choice, program download is initiated and the current program download address is
displayed. When program download is complete, the user is prompted to acknowledge. Control is
passed back to the main program and the set-up program remains in an “Online” edit mode.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 31 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.2.4 DOWNLOAD (RESTORE) DATA
The set-up program allows the user to download “Set-up” parameters, timing channel set-points
and shift data to the M4500 from the set-up “Data File”. This function is accessed from the “File”
menu.
Note: Only the values contained within the current data file are used. If the validity of the current
data file is questionable, review the data in an “Offline” mode prior to download.
________________________________________________________________________________
4.2.5 PRINT REPORT
The “Set-up” program allows the user to generate a “Report” printout of all the set-up parameters,
timing channel set-points and shift data. This function is accessed from the “File” menu.
At the top of each page, the report displays the name of the set-up file being printed. At the bottom
of each page is the date and time the data was uploaded, as well as the page number.
To printout a report of the settings contained in the set-up “Data File”, perform the following:
1) From the “File” menu, select “Print Report” or press “Ctrl + P”. If the user is currently
“Online” with the processor, the current values inside the processor will be automatically
uploaded.
2) The “Print Setup” dialog box will then be displayed, allowing the user to select a printer, as well
as, the paper size and orientation. Once the user selects “OK”, the report is generated and sent
to the specified printer device.
Note: This function makes use of the windows print manager, which allows the user to continue
with their work while the document is being printed.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 32 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.3 THE EDIT MENU
The “Edit” menu allows the user to perform the following functions:
•
•
Enable/Disable Offline Editing.
Set-up the Comm Port.
________________________________________________________________________________
4.3.1 ENABLE OFFLINE EDITING
This function allows the user to perform “Offline” editing on the currently loaded set-up data file.
This allows the user the ability to make any necessary changes to the set-up parameters while not
online with the processor.
If offline editing is not enabled, the user is only able to view the set-up parameters and shift data.
When the program is first invoked, the default setting is offline editing disabled. The user will need
to specifically select “Enable Offline Editing” from the edit menu (or press function key F2) to
enable/disable this feature.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 33 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.3.2 SETUP COMM PORT
This function allows the user to specify the serial communications port and rate to talk to the
M4500. The programming port of the M4500 is set to 9600 baud.
Once selected, a dialog box requesting the user to select a “Comm Port” and “Baud Rate” will be
displayed. The default setting is COM1 at 9600 baud.
In most cases the user will only need to specify the communications port and leave the baud rate at
9600. If communication problems occur, make sure there is a secure connection from the PC to the
PLC. Then check the Comm port. In most cases the user will only need to select a new Comm
port. If communication problems persist, there may be another program causing a conflict with the
port. Check the port configuration from the “Settings” folder.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 34 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.4 THE VIEW MENU
The “View” menu allows the user to perform the following functions:
•
•
•
View the “Target Board Interface”
View “Online” Data
View “Offline” Data
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 35 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.4.1 TARGET BOARD INTERFACE
This function allows the user to view fault codes, S3000 network communication error codes and
review the current “Ident” and “Revision” of the application program. This is accessed by the
“View” menu, by selecting “Target Board Interface”.
Once invoked, the set-up program will prompt the user to select a program to compare with the one
existing in the processor. Whether a program is selected or the user cancels, the setup program will
attempt to communicate with the M4500. If unsuccessful, a warning message will be displayed,
prompting the user to either “Retry” or “Cancel” the operation. If the operation is canceled and
communication with the processor cannot be established the system will be placed in an “Offline”
mode, however the “Target Board Interface” window will be displayed.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 36 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.4.2 VIEW ONLINE DATA
This function allows the user to place the set-up program in an “Online” mode with the processor.
This is accessed by the “View” menu, by selecting “Online Data” or by simply pressing the “F3”
function key.
Note: The program can be toggled between “Offline” and “Online” by simply double clicking on
the “Online” or “Offline” panel displayed in the status bar at the bottom of the window.
Once invoked, the set-up program will attempt to open the Comm port and communicate with the
M4500. If the set-up program is unsuccessful, a warning message will be displayed prompting the
user to either “Retry” or “Cancel” the operation. If the operation is canceled and communication
with the processor cannot be established the system will be placed in an “Offline” edit mode.
Note: Anytime while the set-up program is “Online” with the processor and communication is
interrupted, a warning message will be displayed, prompting the user to either “Retry” or “Cancel”
the operation.
________________________________________________________________________________
4.4.3 VIEW OFFLINE DATA
This function allows the user to place the set-up program in an “Offline” mode. This is accessed by
the “View” menu, by selecting “Offline Data” or by simply pressing the “F4” function key. This
allows the user to perform “Offline” editing. All values displayed in “Offline” edit mode reflect the
actual values contained in the currently loaded set-up data file.
Note: The program can be toggled between “Online” and “Offline” by simply double clicking on
the “Online” or “Offline” panel displayed in the status bar at the bottom of the window.
Once invoked, the set-up program will close the Comm port and cease communication with the
M4500.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 37 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.5 THE WINDOW MENU
The “Window” menu allows the user to select one of five different Display/Set-up windows to
modify set-up parameters, view shift data or receive feedback about the current status of the control
system.
Once a window menu item is selected, a check mark is placed next to the selected item and the
selected window is displayed with the name changed in the title bar of the main window.
Note: “Read” only variables are displayed in blue with a gray background. Any variables that can
be altered by the user are displayed in black with a white background. In most cases, a parameter
that can be changed by the user will have associated with it increment and decrement controls. The
user can either click on the desired parameter to adjust and enter in a new value, or use the
increment or decrement controls to change the value by 1 unit.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 38 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
_______________________________________________________________________________
4.5.1 THE MAIN DISPLAY WINDOW
The “Main Display” window is used to display the general state of the control system. This
window is selected from the “Window” menu.
The following is a list of the functions of the “Main Display” window.
Messages: The “Messages” display is continuously updated. It displays alarm and status
messages specific to the M4500, as well as, the current “Online” or “Offline” status of the set-up
program. By simply scrolling the display, the user is able to view all active alarm and status
messages. If no alarm or status messages are active, a default message is displayed.
Machine CPM: This display is only active while “Online” and displays the current speed of the
machine in “Cans Per Minute”.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 39 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
Current Shift Data: This data is the totals so far into the shift. This data is transferred to the “Last
shift” data when the end of shift input transfers from a “0” to a “1”. This can be at the end of either
an 8 or 12 hour shift or alternatively could be done at label changes such that the data collected
would be for label runs rather than complete shifts. This data cannot be reset either from this menu
or by the operator, only at the end of shift input transition. To exit back to the main menu, press
<ESC>.
1) Good Cans: This is the total number of good cans necked and flanged so far into the current
shift. This is essentially a can counter.
2) Total Jams: This is the total number of transfer jams for all stations of the machine.
3) Station #01 Jams thru Flanger Jams: This is the total transfer jams for each station. A
disproportionately high count for a particular station indicates a transfer jam problem for that
station.
Last Shift Data: The “Last Shift” data is identical to the current shift data except it is for the
previous 8 or 12 hour shift or previous label run, how ever the shift collection is set-up. This allows
data collection and diagnostics to take place automatically over a two shift period.
Jams Per Station Data: The number of transfer jams per station is provided to aid in the troubleshooting of a transfer jam problem with a particular station. The total number of jams for each
station since the last reset or end of shift is displayed. The user can reset these counts at any time by
clicking on the “Reset Jams/Station” button to aid in the trouble-shooting process.
Transfer Jam Alarms: The state of the station transfer jam alarm status is indicated here. If a
station is in alarm the text will display “ALARM”, otherwise the text will display “normal”. This
data is only available while the setup program is “Online”.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 40 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.5.2 THE SETUP PARAMETERS WINDOW
The “Set-up Parameters” window is used to view and adjust any of the set-up parameters. This
window is selected from the “Window” menu.
Number of Shifts (Stations 1 thru 10 and Flanger): This is the number of shifts from the
infeed screw sensor to the transfer sensor for each station. These numbers can be determined using
the calibration mode or they could be counted manually if desired. The range of values for these
numbers is 1 to 319. In addition, the transfer jam detection can be disabled by setting the “number
of shifts” for the respective station to “0”. This would be done on machines not equipped with all
stations.
Calibration Count (Stations 1 thru 10 and Flanger): These are the actual number of shifts
from the infeed screw sensor to the transfer sensor for each respective station. These numbers are
determined when the calibration is performed
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 41 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
Number of Missing Cans for Transfer Jam Alarm (Stations 1 thru 10 and Flanger):
These variables are the number of consecutive missing cans (once cans should be at the transfer
sensor for that station as set in the “Number of Shifts”) that will cause a transfer jam for each
respective station. Each station can be set independently. If the Number of missing cans is set to 4
for a particular station, a transfer jam will be generated when four or more consecutive missing cans
are detected at that station. If three or less consecutive missing cans occurred, the transfer jam
would not be generated.
Transfer Jam Enable: This allows the user to disable the jam detection for a particular station
without setting the number of shifts to “0”. Jam detection cannot be enabled if the number of shifts
to the station is set to zero.
Calibrate Number of Shifts (reset calibration counts): This is used to initiate the
calibration mode. The calibration mode automatically determines the “Calibration Count” registers.
See section 2.4.4 – Calibrate Number of Shifts to Stations for more details.
Auto Set Shifts (Shifts set to Calibration Counts): This selection copies the “Calibration
Count” registers to the “Number of Shifts” registers when selected. This would be done after the
calibration has been performed and the Calibration counts have been determined. This is the
quickest and easiest way to set the “Number of Shifts” variables.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 42 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.5.3 THE MACHINE TIMING WINDOW
The Machine Timing window is used to invoke the PLS programming command menus. From this
window, the user can view or adjust the following parameters:
•
•
•
•
•
Adjust Timing Channel set-points.
Set the resolver offset.
Clear or Recall a PLS timing channel.
View the current PLS configuration
Reset the PLS configuration to default settings.
In addition, the following parameters are displayed at the bottom of this window:
RPM: This is the current speed in “Revolutions per Minute” of the main crank resolver.
Position: This is the current “Position” in degrees of the main crank resolver.
Offset: This is the current resolver offset (set in degrees).
Scale: This is the scale factor of the resolver or the number of divisions in one revolution.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 43 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
Note: The General Timing Signal Locations section provides a complete description of each
timing channel signal.
Zeroing the Machine (setting the resolver offset): To set machine zero, perform the
following:
1) Connect an RS-232 SYSdev cable from the COM port on the computer to the “PROG” port on
the M4500.
2) From the “Window” menu, select “Machine Timing”.
3) From the “View” menu, select “Online Data”. The set-up program will attempt to communicate
with the processor and place the system into an “Online” mode of operation.
4) Observe the “Position” field at the bottom of the window. Verify that as the machine is rotated
forward, that the position increases linearly from 0 through 359 degrees. If not, swap the S1 and
S3 leads at the resolver connector on the M4500. Then, verify that the position does indeed
increase with forward movement.
5) Position the machine at machine.
6) Auto zero the resolver by entering “0” in the “Resolver Offset” field and clicking the “Set
Offset” command button. A message box will appear, prompting the user to confirm their
choice. Select “Yes” to set the resolver offset.
7) The M4500 will calculate the actual offset value required to make this the “0” position. The
new offset value will be displayed in the “Offset” field and the position will then read zero.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 44 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
Adjusting the Timing Channel Set-points: To set any of the timing signal set-points,
perform the following:
Note: Any changes made to the timing channel set-points will be saved as part of the setup data
file.
1) Connect an RS-232 SYSdev cable from the COM port on the computer to the “PROG” port on
the M4510.
2) From the “Window” menu, select “Machine Timing”.
3) From the “View” menu, select “Online Data”. The set-up program will attempt to communicate
with the processor and place the system into an “Online” mode of operation.
4) Set all channels per the section 6 – General Timing Signal Locations. Set-points for a particular
channel are either entered in the field or adjusted by using the increment/decrement controls.
Note: Only one set-point is used per channel.
5) If a channel needs to be “Recalled” or “Cleared”, enter the desired channel number into the
“PLS Channel” field. Click the “Recall Channel” command button to recall the set-points.
Click the “Clear Channel” command button the completely clear all set-points for the selected
channel.
Note: If a channel has been cleared or the “On” and “Off” set-points have the same setting, the
set-point will be displayed as “*****”.
Resetting the PLS Configuration: As an aid to the user the current PLS configuration is
displayed in the “PLS Configuration” tab of this window. The PLS configuration should only be
reset if a new module has been installed. To reset the PLS configuration, click the “Reset PLS
Config” command button. This function only resets the PLS configuration to the default settings.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 45 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.5.4 THE SERIAL COMMUNICATIONS WINDOW
The Serial Communications window is used to view the configuration and communication status of
the S4516 serial communications board (if installed). From this window, the user can view the
following:
•
•
S4516 configuration status.
S4516 serial communication status.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 46 -
SECTION 4
ANCNF WINDOWS BASED
SETUP PROGRAM REFERENCE
________________________________________________________________________________
4.5.5 THE I/O STATES WINDOW
The “I/O States” window is provided to display states of the inputs and outputs. The control
boards, the states of the timing channels, as well as states of the M4500 are shown. This includes
the interrupt inputs (IN0 and IN1), the analog I/O and the resolver. These values are displayed as
read by the M4500 processor.
HSL-ANCNF User’s Manual
SYSTEMS Electronics Group
- 47 -
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising