BIMx User Guide_For_AC17.book
GRAPHISOFT BIMx
for ArchiCAD 17
User Guide
GRAPHISOFT®
Visit the GRAPHISOFT website at http://www.graphisoft.com for local distributor and product
availability information.
GRAPHISOFT BIMx
for ArchiCAD 17
User Guide
Copyright © 2013 by GRAPHISOFT, all rights reserved. Reproduction, paraphrasing or
translation without express prior written permission is strictly prohibited.
Trademarks
ArchiCAD®
is a registered trademark of GRAPHISOFT.
All other trademarks are the property of their respective holders.
Contents
Contents
GRAPHISOFT BIMx _____________________________________________ 5
BIMx Workflow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Save ArchiCAD Model in BIMx Model Format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Opening a BIMx Project for Navigation and Editing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
Sharing the BIMx Model . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
BIMx: Notes on Model Size, Textures and Shadows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Limit “Extra” Model Content . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Texture Formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Alpha Channel Texture Effects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Shadows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Sun Shadow Artifacts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
BIMx Menu Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
FILE Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
SETTINGS Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .15
Render Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Background . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
Stereo View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
Transparency . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
View Cone . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Speed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Mouse Sensitivity . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Mouse Invert . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Units . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Additional Settings commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
GLOBAL ILLUMINATION Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Sample Falloff and Sample Accuracy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Lightmap quality . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
LAYERS Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
GALLERY Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Adding Camera Angles (positions) to your Project . . . . . . . . . . . . . . . . . . . . . . . . . 19
Recording Walk-through Clips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Editing the Gallery . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Using the Gallery . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
Gallery Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
CONTROLS Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
INFO Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
Components of Video RAM Usage on Mobile Devices . . . . . . . . . . . . . . . . . . . . . . . 22
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
3
Contents
BIMx Navigation Tools and Shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Fly Mode vs. Walk Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Info Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Map Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Measure Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Screenshot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Parallel View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Quit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
4
23
23
23
23
24
24
24
24
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
GRAPHISOFT BIMx
The GRAPHISOFT BIMx package is included in ArchiCAD 17.
GRAPHISOFT BIMx lets you create an interactive walk-through model out of your ArchiCAD
project. You or your clients can then explore this presentation in several ways:
• View and navigate the 3D model on your desktop or notebook computer (the same computer
that is running ArchiCAD).
• Save the model in BIMx Model (.bimx) format. The BIMx Model file is compatible with
BIMx applications for iPad and other mobile devices. It can also be viewed and navigated on
a desktop or laptop computer using the free BIMx viewer application, downloadable from
bimx.graphisoft.com.
• You can share the BIMx model at bimx.graphisoft.com. From the BIMx application, use File
> Share BIMx Model and follow the instructions.
Clients will experience a professional, 3D project presentation and will benefit from a real-time
exploration of the architectural design without having to install any architectural software.
Technical Requirements
•
•
Hardware/software requirements for GRAPHISOFT BIMx are the same as for ArchiCAD 17.
BIMx for ArchiCAD 17 is available for both MacOS and Windows in 64-bit versions only.
(The free downloadable BIMx Viewer package also includes a 32-bit version for Windows.)
• The BIMx file format for ArchiCAD 17 has changed since ArchiCAD 16. A BIMx project
created for ArchiCAD 17 cannot be read by BIMx for ArchiCAD 16.
• When you explore the BIMx model, performance may vary depending on the size of your
model and the memory capacity of your video graphics card. If you plan to work with large
models, make sure you are using a high-capacity video card.
You can find a list of recommended video cards at: http:/archicadwiki.com/Video_Cards
If your BIMx model is to be viewed on a mobile device, model size and device compatibility
requirements apply.
For more information on accessing the BIMx model using a mobile device, go to 
http://www.archicadwiki.com/BIMx/Workflow.
BIMx License Options
BIMx with FULL ArchiCAD AND Software Service Agreement (SSA)
•
•
•
•
Unlimited use of full BIMx functionality
Larger data storage limit for BIMx projects uploaded to the site
Option to password-protect uploaded BIMx projects
Option for private transfer of BIMx projects to clients using the site (hidden from public
access)
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
5
BIMx with FULL ArchiCAD but NO Software Service Agreement
• Unlimited use of full BIMx functionality
• Limited storage space on the site for your uploaded projects
• All uploaded projects are public (no option to password-protect or unlist them)
EDU Users
If you have an EDU license for ArchiCAD, you can use the full functionality of BIMx without a
BIMx license. However, your access to the BIMx site is limited in the following ways:
• Limited storage space on the site for your uploaded projects
• All uploaded projects are public (no option to password-protect or unlist them)
The following sections describe how to use GRAPHISOFT BIMx for ArchiCAD 17.
BIMx Workflow
BIMx: Notes on Model Size, Textures and Shadows
BIMx Menu Commands
BIMx Navigation Tools and Shortcuts
6
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Workflow
BIMx Workflow
The standard workflow between ArchiCAD and GRAPHISOFT BIMx is the following:
1. Create the BIM model in ArchiCAD, using appropriate surface textures and materials on the
building elements.
For tips on optimizing these, see BIMx: Notes on Model Size, Textures and Shadows.
2. Save the ArchiCAD model in BIMx Model (.bimx) format.
3. Open the BIMx model on your computer. Explore it using the render mode of your choice.
Fly-through or walk-through paths can also be defined and saved with the model.
4. If you want to make it available to others, the BIMx Model file is compatible with BIMx
applications for iPad and other mobile devices. It can also be viewed and navigated on a
desktop or laptop computer using the free BIMx viewer application, downloadable from
bimx.graphisoft.com.
5. You can also share the BIMx model at bimx.graphisoft.com. From BIMx, use File > Share
BIMx Model and follow the instructions.
Each of these topics is detailed below.
Save ArchiCAD Model in BIMx Model Format
Once the building model is created in ArchiCAD and the proper surface textures are applied, the
model is ready to save for GRAPHISOFT BIMx:
1. Open the project in ArchiCAD and check the consistency of the model and the surface
textures before starting the save process.
For tips on optimizing these, see BIMx: Notes on Model Size, Textures and Shadows.
Note: You cannot modify the 3D model and the surface materials in BIMx.
2. Open the 3D window (perspective or axonometric view).
3. Go to File > Save as command, and choose the BIMx file format.
4. Give a name to the file.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
7
BIMx Workflow
5. Click Options to bring up BIMx Export Options:
• Add cameras as separate gallery items: Each camera will launch a separate movie
• Create a single movie for the gallery: All gallery items will be played as a single movie
• Limit navigation to gallery items: Navigation of the resulting BIMx project will be
limited to just the views and clips you save to the Gallery (instead of the full project)
6. If you have checked Start BIMx after save in the Save dialog box, the GRAPHISOFT BIMx
application starts automatically and the exported model is loaded into the program’s memory.
Opening a BIMx Project for Navigation and
Editing
1. Start your BIMx application if it did not start automatically. You need a full BIMx license to
edit a project. However, you can also navigate the BIMx file without further editing.
2. Open the File menu and click on the Open command.
3. Select the preferred BIMx project file to open it.
4. Press the ESCAPE key on your keyboard to access the BIMx menus.
5. Now you can start to edit the BIMx project if needed. For example:
• initialize Global Illumination
• change layer visibility
• add cameras, save a fly-through path
To switch full-screen mode on and off on Windows, use F11.
See BIMx Menu Commands for more information.
8
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Workflow
Sharing the BIMx Model
You can share your BIMx model with other members of the BIMx community or with partners,
using GRAPHISOFT’s online model sharing service. All you need is to sign in once, using your
GRAPHISOFT account. If you don’t have an account yet, the Sign In dialog box directs you to
the registration website.
Follow these steps to share your BIMx model:
1. In the BIMx window, press the ESCAPE key on your keyboard to access the BIMx menus.
2. Click File.
3. From the commands at the right, click Share BIMx Model.
4. If you have not shared a BIMx model before, you are prompted to sign in.
Note: You don’t need to sign in again the next time you share a BIMx model; the
authentication occurs automatically. If you don’t want your program to remember your sign in
data, click Sign Out in the Share BIMx Model dialog box.
• The first time you sign in (if you have a commercial license), you will be prompted to
create a company account, and you will be the owner of the company account. Additional
individuals signing in from your company will be prompted to join the company account
(subject to approval by you as the owner).
• If your company already has a GRAPHISOFT account associated to your license, the Join
Account dialog appears: you must join that account before you can share your BIMx
model.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
9
BIMx Workflow
5. After sign in, the Share BIMx Model dialog box opens. Here, provide the model’s name and
description, as well as upload options (these options vary depending on your ArchiCAD
license type).
See BIMx License Options.
Note: You can later modify the uploaded model’s description and access parameters, by
logging in to your GRAPHISOFT account using a web browser.
6. If you wish, click Browse for Image and choose a file to use as the preview picture.
7. Click Share.
8. Once the upload is complete, a weblink appears that links you to the model’s web location.
You can provide this link to others, who can then download and view your model.
10
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx: Notes on Model Size, Textures and Shadows
BIMx: Notes on Model Size, Textures and
Shadows
These tips are intended for optimizing the ArchiCAD model before saving it in BIMx format.
If your BIMx model is going to be viewed on hand-held devices such as the iPhone, further
optimization of the model may be desirable to improve performance.
For more information, consult the BIMx page from GRAPHISOFT’s website at
http://archicadwiki.com/BIMx/Optimization.
Limit “Extra” Model Content
If you run into memory limits while creating the BIMx model (for example, during Global
Illumination initialization), try eliminating or reducing the following model components. This
will help optimize model size and improve BIMx performance:
• furniture (e.g. chairs)
• GDL objects (e.g. door handles)
• other objects originating from Add-Ons (e.g. trees, cars, people)
• other non-essential elements
Typically, such “extra” elements devour a great deal of memory. A single chair can require more
memory than all the walls in the project.
Texture Formats
BIMx supports the following surface texture formats: jpg, bmp, tif, tga, png, gif.
If a texture would fail to load for any reason, the object that uses it will be drawn with the material
color instead.
Alpha Channel Texture Effects
BIMx supports alpha channel texture effects with 32-bit tif, tga and bmp images. For the alpha
channel effects to be detected inside BIMx, you must enable transparency in the ArchiCAD
material/texture properties.
However, transparent objects are not necessary visualized using the correct display order - to do
so would put a big dent in your performance.
Shadows
Shadows in BIMx are rendered using the OpenGL ARB_shadow extension. It works by rendering
the scene, from the sun’s point of view, into a texture map. This texture map is then projected onto
the scene and OpenGL will determine whether a pixel is in shadow or not. Larger texture maps
will produce higher quality shadows. The maximum size is determined by your graphics card (the
graphics memory available and the maximum texture size allowed). Some graphics cards may
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
11
BIMx: Notes on Model Size, Textures and Shadows
have 256 MB on-board memory, but only allow a maximum texture size of 4096 x 4096. A
shadow texture is typically 24-bit.
• 8192x8192 shadow texture will consume 200 MB of video memory.
• 4096x4096 shadow texture will consume 50 MB of video memory.
• 2048x2048 shadow texture will consume 12.5 MB of video memory.
BIMx will automatically try to generate the largest possible shadow texture, starting with
8192x8192. Next, if this fails, it will try half that size, and so on.
The shadow’s altitude, azimuth (heading) and brightness are controlled via the BIMx Settings
menu.
See SETTINGS Menu.
To turn off the sun shadows, set sun shadow brightness to a value near zero.
Sun Shadow Artifacts
Depending on the amount of available video card memory and the (physical) size of your model,
the sun shadows may display artifacts. This is due to the fact that BIMx cannot fit the whole
model into the shadow map with good quality. Smaller models and more video graphics memory
will improve the result. Global Illumination produces better shadows, which however are static.
12
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Menu Commands
BIMx Menu Commands
This section explains the commands of the BIMx menu.
•
•
•
After you have saved the ArchiCAD model to BIMx, you will view and navigate the BIMx
model in the navigation window.
To access the BIMx menu, press the ESC key.
To return to the navigation window, press ESC again.
If You Are Using a Viewer
The BIMx model can also viewed and navigated on a desktop or laptop computer using the free
BIMx viewer application, downloadable from bimx.graphisoft.com. In this case (if no ArchiCAD
license is available), the following BIMx functions are NOT available:
•
•
All functions that involve actively modifying the model or saving the file in any form (e.g.
sharing it, recording a new camera path or adding a view to the gallery).
Global Illumination initialization. (However, if the BIMx model has already been initialized,
you can use the Global Illumination render mode.)
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
13
BIMx Menu Commands
Choosing among Menu Options
1. Click and hold on the option you want to change.
2. The available choices will then pop up.
3. Move your cursor over the options.
4. When the cursor is on the desired option, let go of the cursor to enable that option.
Editing Numerical Settings
If the setting you are editing is a numerical value (such as navigation speed), you can change the
value only by dragging the mouse left (to decrease the value) or right (to increase it.) You cannot
enter the values directly.
FILE Menu
The file menu includes the standard I/O functions of the program.
• The Open command opens a BIMx project for editing.
• The Save command saves the project in .bimx format. This format can be viewed in all types
of BIMx viewers, including iPad, iPhone and iPod Touch, in addition to the Desktop
Application.
• Share BIMx Model uploads the project to the BIMx site at bimx.graphisoft.com.
14
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Menu Commands
SETTINGS Menu
The Settings dialog stores all the parameters that are related to the BIMx model display and
navigation control.
Render Mode
Choose a Render Mode to display the BIMx model.
• Headlight: View the scene as with a lamp on your head
• Global Illumination: Available if you have calculated Global Illumination. (See tips below.)
• Black and White: Available if you have calculated Global Illumination. (See tips below.)
• Pixel lighting with SSAO: Advanced rendering method to give greater depth to the scene
• Unlit: Shows materials without lighting
• Gouraud: Shows materials with simple lighting
• Metal: Same as Headlight, but no materials
• Hidden Line: No shading. Displays the edges of scene geometry.
Some of these methods may not be available, depending on the graphics card you are using.
Tips for Choosing a Render Mode
•
•
•
•
The Global Illumination method gives you the most realistic view of the model. To access it,
you must first initialize the Global Illumination engine. (Go to the Global Illumination menu
and click Initialize.) This method may take some time, depending on the size of your model.
For extra large models, it may be desirable to use Pixel Lighting with SSAO until your model
is fully completed.
Note: The Black and White (Global Illumination) render option is also available after you
have calculated Global Illumination.
If you have rendered the model on your desktop using Global Illumination, the resulting
BIMx model, when viewed on a mobile device, can also be shown with Global Illumination.
Note that Global Illumination consumes additional memory, so the chance of failure also
increases with the size of the model. To avoid this, you should split an extra large model into
two or more parts and calculate global illumination for each part individually.
Pixel Lighting with SSAO is an advanced technique, without the calculation time required
by Global Illumination on large models. While not as sophisticated as Global Illumination, the
effect is similar, without needing the precalculation process. This method is not yet available
on mobile devices due to hardware limitations.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
15
BIMx Menu Commands
•
•
•
Pixel Lighting with SSAO is only available if your graphics card supports the OpenGL 2.0
standard. Typically, older-model laptops cannot benefit from this feature.
Headlight mode is a simpler rendering method than either Global Illumination or Pixel
Lighting, but it is available on all devices (with the possible exception of extremely old
computers).
On very old-model computers (provided they meet the minimum system requirements), the
Gouraud and Unlit render modes are guaranteed to be available.
Background
BIMx offers the following background options:
• SKY (default BIMx Sky image)
• WHITE
• GREY
• BLACK
• GRADIENT
In case you’d like to use custom skybox images, you have to replace the six .bmp files included in
the BIMx/Textures/Skybox folder.
Stereo View
BIMx can display the model in stereo view modes. The following methods are available:
• Left/Right
• RED/ CYAN
Note: You need special stereo view glasses to enjoy this BIMx feature.
• Quad Buffer: available only with NVIDIA drivers.
• OFF
Note: Stereo View options are not available if you are in Parallel view. (Click F8 to toggle
Parallel view.)
Transparency
Value range: 20-80
The transparency of all translucent surfaces in the model is controlled by this parameter. Higher
values result in less transparent surfaces.
View Cone
Value range: 10-120
16
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Menu Commands
Speed
Value range: 10-1000
This parameter defines the default speed of navigation. Higher numbers result in faster
movement.
Note that you can temporary increase the navigation speed by holding down the ‘SHIFT
button.
Mouse Sensitivity
Value range: 10-50
Mouse Invert
This option inverts the mouse navigation directions.
Units
The measured distances can be displayed in Metric or Imperial units
Additional Settings commands
The following parameters are available if you have turned on Sun Shadows (click F3). The
parameter value limits are shown in brackets.
Sun Altitude (10-80)
Sun Azimuth (0-360)
Sun Brightness (-100 - +100)
Sun Overbright (-100 - +100)
Sun Filtering: Turn on to improve quality of sun shadows.
Camera Height (600-2000)
Camera Radius (150-400)
Sunflare
This option displays the sun flare if the camera looks towards the sun.
Help Popups
If this option is activated, a help popup window will appear over some of the Settings menu’s
commands.
It also controls if the introduction help-popup is displayed at the center of the screen when
opening a BIMx model.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
17
BIMx Menu Commands
GLOBAL ILLUMINATION Menu
In order to be able to view the model in Global Illumination mode, you have to render the model
first.
1. Choose INITIALIZE to prepare the model for Global Illumination view.
Note: This function not available on the BIMx Viewer application.
2. Choose either Light View or Light All.
This option affects the length of the Global Illumination calculation process.
• LIGHT VIEW: Lights surfaces visible from the current camera viewpoint only.
• LIGHT ALL: Lights all surfaces.
Note: Initialization can be a lengthy process depending on the size of the model (number of
triangles), the computer hardware (RAM, Video RAM, processor, Video Card type) and the
Global Illumination options you choose. Initialization may fail if the model is too big, since
any single point on the model needs to be handled separately in the computer memory. The
more graphics memory you have, the larger model you can initialize.
Cancel the process by pressing ESC. You can resume the process later. Completely lit surfaces are
saved into project files and .exe files. When resuming the process, the starting point may roll back
a few percent from where you cancelled.
Sample Falloff and Sample Accuracy
These options affect the length of the rendering process and the quality of the resulting images.
If your Sample Falloff is lower than 1000-2000, try setting Sample Accuracy to LOW. This will
make shadow gradients less smooth and more pixelized, but will result in faster rendering.
Note: Changing sample falloff will invalidate any previously computed light.
18
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Menu Commands
Lightmap quality
This parameter has three values:
• Ultra
• Default
• Low
Ultra will provide more realistic lights and shadows in the final rendered model, however the
rendering process can be significantly slower in case of large models.
LAYERS Menu
The BIMx project preserves the layers of the original ArchiCAD model. Use the BIMx Layers
menu to control the visibility of the model layers, by checking the desired layer name boxes.
Note: Global illumination renders the current state of the model. Switching layer visibility
hides and shows elements, so you’ll have to recalculate the global illumination to show the
correct lighted model.
GALLERY Menu
The Gallery menu includes the commands with which you can add pre-recorded walk-through
clips and camera positions to your project.
See also If You Are Using a Viewer.
Adding Camera Angles (positions) to your Project
To add camera angles press F4
Note: This function not available on the BIMx Viewer application.
Recording Walk-through Clips
• To enter clip record mode: Press SHIFT+R.
• To start/stop recording: Click left mouse button.
• To exit clip record mode: Press SHIFT+R.
You must be in pause mode when exiting clip mode or you will lose that clip.
Both perspective mode and orthographic mode (F8) can be recorded.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
19
BIMx Menu Commands
Editing the Gallery
To change the order of the clips in the Gallery, press MOVE LEFT / MOVE RIGHT.
Using the Gallery
Click on any or all of the following three commands to set playback preferences.
• PLAY ON START will playback the sequence of clips as the self-executing file is started.
• PLAY ON IDLE will make playback start or continue “screensaver-style” - that is, after a
certain amount of idle time.
• Clips will playback in sequence if SEQUENCER is enabled (click “Sequencer” to enable it),
otherwise only the current clip will be played.
• LIMIT NAVIGATION TO GALLERY VIEWS: navigation of the resulting BIMx project
will be limited to just the views and clips you save to the Gallery.
Gallery Shortcuts
•
•
•
Click the image to jump into that position or to play that clip.
Press P to playback the current clip.
Press Shift+P to playback the sequence of clips from the top.
CONTROLS Menu
20
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Menu Commands
The CONTROLS menu displays the list of the basic navigation commands and their shortcuts for
the international keyboard. Most of these functions are self-explanatory and commonly used in
first-person shooter computer games (FPS).
Functions
Menu
Movement
Move Fast
Move Slow
Crouch
Jump
Lift
Lower
Fly Mode
Info Tool
Measure Tool
Outlines
Sun Shadows
Screenshot
Parallel View
Map Mode
Keyboard Shortcut
ESCAPE
W, S, A, D and the Arrow keys
SHIFT
CMD or CTRL
ALT
SPACE BAR
PAGE UP
PAGE DOWN
F
I
M
O
F3
F5
F8
BACKSPACE
For additional navigation shortcuts, see BIMx Navigation Tools and Shortcuts.
INFO Menu
The Info Menu shows basic information about the active project and your BIMx license:
•
•
•
•
Version: The version and build number of your BIMx application.
License Type: Type of your BIMx license (full, educational). It also displays whether you are
using the global illumination version of BIMx.
Source Model: The name of the ArchiCAD file saved to BIMx.
Number of Triangles: The models in BIMx are made of 3D triangles. The speed of the 3D
navigation and the memory usage by the BIMx application are strongly affected by the
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
21
BIMx Menu Commands
•
•
number of triangles in the 3D model. Please note that this value is approximately two or three
times that of the polygon count displayed in PolyCount add-on in ArchiCAD, due to the
different geometry calculation algorithms used.
RAM Usage: Displays the size of the RAM, in bytes, used by the project
Video RAM Usage: Displays the size of the Video RAM, in bytes, used by the project
Components of Video RAM Usage on Mobile Devices
This data refers to the Video RAM memory required to view the model on the supported iOS
mobile devices.
• Geometry: Based on the triangle count.
• Textures: The BIMx application for mobile devices automatically optimizes your textures to
a certain degree, but if your BIMx model is too large to be run on your mobile device, you can
try to reduce their size and complexity.
If you save your BIMx model using Global Illumination, additional video RAM memory is
required to handle the following two texture components:
• Global Illumination of Flat Surfaces: the illumination texture applied to flat surfaces; and
• Global Illumination of Curved Surfaces: the illumination texture applied to curved surfaces
You will notice that curved surfaces are less memory-intensive than the flat surfaces.
22
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
BIMx Navigation Tools and Shortcuts
BIMx Navigation Tools and Shortcuts
Fly Mode vs. Walk Mode
The F key toggles between Fly Mode and Walk Mode. The Walk Mode provides you with a more
realistic viewing experience including the following features:
• Opening recognition to distinguish the solid building structures such as walls, columns and
roofs from doors and windows during navigation.
• Gravity to keep the camera height stable over slabs, ramps or stairs.
• Holding down SHIFT and CONTROL at the same time will activate the light speed
navigation, which is ten times faster than running.
• Holding down the right mouse button while flying will make you stay on a fixed altitude. This
is useful when recording a fly-over above a building, for example.
• Holding down the right mouse button while walking will lock the view horizontally for a
perfectly straight perspective.
Info Tool
Pressing I during navigation activates the Info Tool. In this mode, the cursor’s shape changes to a
cross and the bounding box of the currently selected model element is highlighted. One click with
the mouse opens the Info palette, which shows basic information about the selected model
element. The following information is displayed in the Info Tool:
• Type – Element Type (e.g. Wall, Slab)
• ID
• Layer – Layer of the element in the ArchiCAD model
• Element parameters, as applicable – e.g. height, width, thickness, volume, structure (if
composite), slant, area, pitch. These values are taken from the ArchiCAD model element
parameters.
• Library Part Name (as applicable)
• Tags (inasmuch as the element has values filled out for these tags) - e.g. Position, Structural
Function
Note: These Info Tool data are only available if you are exploring a BIMx model saved from
ArchiCAD 16 or 17. (BIMx models saved from earlier ArchiCAD versions show only a
limited set of these data.)
Map Mode
This useful feature helps you to find your current position in the building during navigation. Press
BACKSPACE during navigation to project the corresponding section of the floor plan over the
current 3D view. Your current position and viewing direction is marked with an arrow. Use the
mouse wheel to zoom the map.
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
23
BIMx Navigation Tools and Shortcuts
Measure Tool
Press M to enable the measure tool. The three-dimensional distance from the camera to the world
point at the center is computed and displayed as View Distance. To measure the distance between
two three-dimensional points, click the left mouse button and pick two points. The resulting
distance is computed and displayed as Measured Distance.
Screenshot
Press F5 to print the current view to a 24-bit .bmp file. The image will have the same resolution as
your current viewport (your desktop resolution). The .bmp file will be saved with a unique name
into the BIMx\Screenshots\ folder, located in your User Documents folder. When screenshots are
created from a stand-alone BIMx viewer application, the images will be saved into the same
directory as the application.
Parallel View
Press F8 to enable the parallel view. Use the mouse to rotate the model and the mouse wheel to
zoom in/out. Hold down the right mouse button and move the mouse to pan over the model.
Note: Stereo View options (Settings menu) are not supported in Parallel view.
Quit
Hold down Z, then press ESC to quit.
24
GRAPHISOFT BIMx for ArchiCAD 17 User Guide
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising