Release Notes - Pulse Secure
ESAP
Release Notes
Build
Published
Document Version
February’ 2017
1.0
Contents
Introduction
3
Interoperability and Supported Platforms
3
Noteworthy Changes
3
ESAP 3.0.7 and Pulse Connect Secure/ Pulse Policy Secure Compatibility Chart
3
Support has been added for the following products in ESAP3.0.7
4
Support has been removed for the following products in ESAP3.0.7
Error! Bookmark not defined.
Issues Fixed in ESAP3.0.7
6
Upgrade Issues in ESAP3.0.7
7
Known Issues/Limitations in ESAP3.0.7
7
Documentation
8
Documentation Feedback
8
Technical Support
8
Revision History
8
ESAP 3.0.7 Release Notes
Introduction
V2 Unified + V3 SDK Version: Mac and Windows 3.6.11098.2
V4 SDK Version: Windows 4.2.1009.0, Mac 4.2.804.0
V3V4 Adapter Version: Windows 4.2.984.0, Mac 4.2.134.0
Note: The SDK embedded in this ESAP version has been tested and qualified to interoperate with an extensive
list of endpoint security applications covering most products listed in the supported products list.
Interoperability and Supported Platforms
Please refer to the ESAP Supported Platforms Guide for supported versions of browsers and operating systems in
this release.
Noteworthy Changes

Pulse Secure introduced support for consuming the latest OPSWAT SDK Version 4 in 8.2R5 PCS and PPS 5.3 R5 PPS
release.
o OPSWAT SDK’s are bundled within our Endpoint Security Assessment Plugin (ESAP). From ESAP 3.0.3
onwards, OPSWAT V4 SDK for Windows and Mac are packaged alongside existing V2 and V3 SDKs.
o Uploading ESAP 3.0.3 or Later on PCS 8.2R4 and below or PPS 5.3R4 and below release will continue to
install and leverage the older Version 2 and Version 3 OPSWAT SDKs. There will be no change in the
functionality/usage on PCS 8.2R4 / PPS 5.3R4 and below release versions.
o Uploading ESAP 3.0.3 or later on PCS 8.2R5 PCS or PPS 5.3R5 releases, we will install OPSWAT V4 SDK
version along with V2 and V3 SDKs.
o On the PCS 8.2R5 and PPS 5.3R5 Admin UI, Administrators have a choice to select whether OPSWAT V3 or
V4 SDK will be consumed on the device running PCS 8.2R5 or PPS 5.3R5. Please refer to the section
“Activating the OPSWAT SDK Version” in the PCS 8.2R5 and PPS 5.3R5 Administration Guide available on
Techpubs website for more information.
ESAP 3.0.7 and Pulse Connect Secure/ Pulse Policy Secure
Compatibility Chart
This ESAP package can be installed on the following Pulse Connect Secure/ Pulse Policy Secure software versions.









SA 8.2Rx
SA 8.1Rx
SA 8.0Rx
SA 7.4Rx
SA 7.3Rx
SA 7.2Rx
SA 7.1Rx
SA 7.0Rx
SA 6.5Rx
© 2017 by Pulse Secure, LLC. All rights reserved
3
ESAP 3.0.7 Release Notes










UAC 5.3Rx
UAC 5.2Rx
UAC 5.1Rx
UAC 5.0Rx
UAC 4.4Rx
UAC 4.3Rx
UAC 4.2Rx
UAC 4.1Rx
UAC 4.0Rx
UAC 3.1Rx
Note1: The ESAP package may install and function without any errors on older releases. However, as the install
has not been tested, we recommend that it be used only on the above versions of software releases.
Note2: This ESAP package contains V2, V3 and V4 versions of OPSWAT SDK. From the above compatibility chart
V4 is applicable only for release above 8.2R5 and 5.3R5.
Support has been added for the following products in
ESAP3.0.7
V4 list of supported products:
Windows OS
AntiVirus Products
AVG AntiVirus Free (17.x)
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
McAfee AntiVirus Plus (19.x)
McAfee Internet Security (19.x)
McAfee LiveSafe – Internet Security (0.x)
Microsoft Forefront Client Security (1.x)
Firewall Products
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
McAfee AntiVirus Plus (19.x)
McAfee Internet Security (19.x)
McAfee LiveSafe – Internet Security (0.x)
Antispyware Products
AVG AntiVirus Free (17.x)
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
© 2017 by Pulse Secure, LLC. All rights reserved
4
ESAP 3.0.7 Release Notes
McAfee AntiVirus Plus (19.x)
McAfee Internet Security (19.x)
McAfee LiveSafe – Internet Security (0.x)
Microsoft Forefront Client Security (1.x)
HardDisk Encryption Products
Bitdefender Internet Security (10.x)
Bitdefender Internet Security (11.x)
Bitdefender Internet Security (12.x)
Bitdefender Internet Security (13.x)
Bitdefender Internet Security (15.x)
Bitdefender Internet Security (16.x)
Bitdefender Internet Security (17.x)
Bitdefender Internet Security (18.x)
Bitdefender Internet Security (19.x)
Bitdefender Internet Security (20.x)
Bitdefender Internet Security (21.x)
Bitdefender Internet Security (9.x)
Bitdefender Total Security (21.x)
V3 list of supported products:
Windows OS
AntiVirus Products
avast! Pro Antivirus (12.x)
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
Trend Micro Worry Free Business Security Agent (6.x)
Firewall Products
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
Antispyware Products
avast! Pro Antivirus (12.x)
Bitdefender Internet Security (21.x)
Bitdefender Total Security (21.x)
Trend Micro Worry Free Business Security Agent (6.x)
HardDisk Encryption Products
SafeGuard (8.x)
© 2017 by Pulse Secure, LLC. All rights reserved
5
ESAP 3.0.7 Release Notes
Mac OS
Antivirus Products
Symantec Endpoint Protection (14.x)
Antispyware Products
Symantec Endpoint Protection (14.x)
Issues Fixed in ESAP3.0.7
V3 List of OPSWAT issues fixed:
1. Need RTP, turn On SCAN, Signature Definition Update remediation actions to be supported for Norton AntiVirus (22.x)
(PRS-347503)
2. Hostchecker fails to detect RTP check for "Managed Antivirus 5.3.28.761"(PRS-348045)
3. Need to Add support for BitDefender Internet Security Antivirus 21.x (PRS-348156)
4. Virus Signature Definition check failing with number of days for check point Endpoint Security Antivirus 8.x (8.7.770)
(PRS-347750)
5.
6.
7.
8.
Detection failing for Antivirus McAfee Endpoint Security Threat Prevention 10.2.0.619 in Windows 10 (PRS-346198)
Support to add Trend Micro Security Agent 19.1.2947 for V3 [PRS-348063]
Need to Add support for BitDefender Total Security Antivirus 21.x (PRS-348238)
Need RTP, turn On SCAN, Signature Definition Update remediation support for Symantec Endpoint Protection 14.X for
V3 and V4 SDK (PRS-347812)
9. firewall support for Symantec Endpoint Protection 14v (PRS-349165)
10. Add support for Sophos safeguard 8.x for HardDisk encryption detection (PRS-347388)
11. Need product support System Center Endpoint Protection 4.7.214.0 for
Scan/EnableRTP/GetLastScanTime/UpdateDefinitions (PRS-347931)
12. Symantec Endpoint Protection14.x for MAC for V4 (PRS-348664)
13. Need to Add support for BitDefender Internet Security Antivirus 21.x (PRS-348156)
14. Virus Signature Definition check failing with number of days for check point Endpoint Security Antivirus 8.x (8.7.770)
(PRS-347750)
V4 List of OPSWAT issues fixed:
1. Need RTP, turn On SCAN, Signature Definition Update remediation actions to be supported for Norton AntiVirus (22.x)
(PRS-347503)
2. Need to Add support for BitDefender Internet Security Antivirus 21.x (PRS-348156)
3. Virus Signature Definition check failing with number of days for check point Endpoint Security Antivirus 8.x (8.7.770)
(PRS-347750)
4. Support to add Trend Micro Security Agent 19.1.2947 for V4 [PRS-348063]
5. Need to Add support for BitDefender Total Security Antivirus 21.x (PRS-348238)
6. Need RTP, turn On SCAN, Signature Definition Update remediation support for Symantec Endpoint Protection 14.X for
V3 and V4 SDK (PRS-347812)
7. firewall support for Symantec Endpoint Protection 14v (PRS-349165)
© 2017 by Pulse Secure, LLC. All rights reserved
6
ESAP 3.0.7 Release Notes
8. Symantec Endpoint Protection14.x for MAC for V4 (PRS-348664)
9. Need to Add support for BitDefender Internet Security Antivirus 21.x (PRS-348156)
10. Virus Signature Definition check failing with number of days for check point Endpoint Security Antivirus 8.x (8.7.770)
(PRS-347750)
Upgrade Issues in ESAP3.0.7
OPSWAT:
1. “Spyware Terminator 3.x” is replaced with the correct name, “Spyware Terminator (AntiSpyWare) 3.x”
under list of available AntiSpyWare products. Upgrade from ESAP 2.1.7 or lower fails if an AntiSpyWare
policy is configured and “Spyware Terminator 3.x” is selected. To successfully upgrade to ESAP2.2.6 or
greater, unselect the product. After the upgrade, you can select “Spyware Terminator (AntiSpyWare) 3.x”.
This doesn’t result in any loss of functionality.
2. G Data Notebook 20.x is not supported in ESAP1.8.0 or greater. Upgrade from ESAP1.7.5 or lower fails if an
Antivirus or an Antispyware policy is configured and GData Notebook 20.x is selected. To successfully
upgrade to ESAP1.8.0 or greater, unselect the product.
3. G Data Internet Security 22.x of Firewall is renamed to G Data Firewall 22.x. Upgrade from ESAP 1.7.5 or
lower fails if a Firewall policy configured and G Data Internet Security 22.x is selected. To successfully
upgrade to ESAP1.7.6 or greater, unselect the product and select ‘G Data Firewall 22.x’. There is no loss of
functionality.
4. AntiSpyWare of Kaspersky Anti-virus for Windows Workstations 6.x is renamed to Kaspersky Anti-virus for
Windows Workstations 6.x [AntiSpyWare]. Upgrade from ESAP1.6.4 or lower fails if an Antispyware policy is
configured where “Require Specific Products” is checked and Kaspersky Anti-virus for Windows
Workstations 6.x is selected. To successfully upgrade to ESAP1.6.5 or greater, unselect the product and
select Kaspersky Anti-virus for Windows Workstations 6.x [AntiSpyWare]. There is no loss of functionality.
5. Upgrade from ESAP1.5.2 or older fails if a firewall policy is configured where “Require Specific Products” is
checked and McAfee Desktop Firewall (8.0) is selected. The upgrade doesn’t fail if McAfee Desktop Firewall
(8.0.x) is selected. To successfully upgrade to ESAP 1.5.3 or greater, unselect McAfee Desktop Firewall (8.0)
and select McAfee Desktop Firewall (8.0.x). This doesn’t result in any loss of functionality.
Shavlik:
1. The following note applies only to the patch assessment functionality. When upgrading ESAP from a 1.5.1 or
older release to the current release, the services on the SA or IC device needs to be restarted for the binaries
on the endpoint to be automatically upgraded. (470003, 491073)
Known Issues/Limitations in ESAP3.0.7
OPSWAT:
1. Remediation of Windows Firewall 8 in agentless mode requires administrative privileges and UAC should be
turned off. (958840, 845980)
© 2017 by Pulse Secure, LLC. All rights reserved
7
ESAP 3.0.7 Release Notes
2. Endpoint Protection 11.x/12.x is not performed when UAC is enabled or if the scan logs have been deleted
or if system scans has never been performed. (502783)
3. The password protection option in the Sunbelt Kerio Firewall product is not supported. (495041)
4. Remediation and detection of Windows Firewall 7 and Vista in agentless mode requires administrative
privileges and UAC to be turned off.
5. For Symantec Hosted Endpoint Protection 2.x installed on server operating systems,
GetLastFullSystemScanTime function will return either the last full system scan time or last quick system
scan time. Server operating systems include, Server 2008, Server 2008 R2, Server 2003 and XP x64.
6. FSRTP status for avast! Free Antivirus 7.x will not be detected until user manually configures FSRTP status at
least once. That is, user should turn off “File System Shield" and turn it on. (785223)
7. Signatures cannot be downloaded with Trend Micro Officescan Client 10.5 and 10.6. Therefore the
remediation functionality for failing the virus definition check is not supported for Trend Micro Officescan
Client 10.5 and 10.6. This is because the executable required to support this functionality is not bundled as
part of the TrendMicro product. (950123)
8. Microsoft’s API, will only report the drives which the system has access to. Therefore BitLocker Drive
Encryption to detect the drive, the drive should be in “unlock” state. (PRS-318680)
Documentation
Pulse Secure documentation is available at https://www.pulsesecure.net/techpubs.
Documentation Feedback
We encourage you to provide feedback, comments, and suggestions so that we can improve the documentation.
You can send your comments to techpubs-comments@pulsesecure.net.
Technical Support
When you need additional information or assistance, you can contact the Pulse Secure Global Support Center
(PSGSC):



Pulse Secure Global Support Center (PSGSC): 1-844 751 7629 (Toll Free, US)
All other Countries - https://www.pulsesecure.net/support/support-contacts call us at (408) 372-9600
For more technical support resources, browse the support website (http://www.pulsesecure.net/support).
Revision History
Table 1 lists the revision history for this document.
Table 1 Revision History
Revision
Description
1.0 – Feb 2017
Initial publication.
© 2017 by Pulse Secure, LLC. All rights reserved
8
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising