Fisheye offline rendering using 3D studio max

Fisheye offline rendering using 3D studio max
TNM091 - Media Production for Immersive Environments
Lab 2 – Offline rendering using Autodesk 3ds Max
The goal of this lab session is to test different methods for creating fisheye images in 3D studio max
and to preview these images.
1. Method 1: Ray tracing
Most fisheye renderers are using ray tracing to generate fulldome frames. This example will show
how to use the free Domemaster 3D lens shader for 3ds Max.
1.1 Getting started
1. Launch Autodesk 3ds Max Design 2014 x64.
2. When working with stereoscopic rendering the correct scale and units are very important. In
Customize->Units Setup… set the units to meters.
3. For a better overview create a four viewport layout by pressing the arrow button in the
lower left corner and select the four viewport view.
4. Open the Material Editor
.
5. To activate the lens shader in the rendering press the Render Setup button
.
1
TNM091 - Media Production for Immersive Environments
6. In the Render tab find the Camera Shaders group box and set the lens shader to Domemaster
Stereo Shader from the mental ray maps list.
7. Drag the lens shader to the Material Editor.
2
TNM091 - Media Production for Immersive Environments
8. 3D studio will ask if you want to create an instance or a copy. Choose instance.
9. This will create a map item in the material editor.
10. Double-click on the map to change its properties. The Norrköping Visualization Center dome
is 7.4 meters in radius and has a tilt of 27 degrees. Set the eye separation to 6 cm. For
compability with other domes and the fulldome standard keep the field of view at 180
degrees.
11. There are three camera positons; center for mono, left and right for stereo. Keep the center
camera active.
3
TNM091 - Media Production for Immersive Environments
12. Add a target camera to your scene. This camera will only be used to transform and animate
the “fisheye” camera. For getting a better preview set the field of view to something much
larger than the standard 40 degrees. You can always change the settings after creation in the
Modify tab.
13. To render from this camera change the view on one of the quadrants to the view from the
camera by clicking directly on the text.
14. Create some simple geometry in front of the camera.
15. Enter the Render Setup window and select the Common tab.
16. Set the output size to 1k by 1k (1024x1024).
4
TNM091 - Media Production for Immersive Environments
17. Lock the renderer to the camera quadrant and press render.
To get more interesting content you can download some 3D models from the Internet. Make sure
you scale them correctly to a realistic size.
1.2 Omni directional stereo
To understand the following steps better please have a look at this article.
1. In the Material Editor change the Camera to “Left” for the lens shader.
2. In order to set the maps that controls the users hear turn and eye separation first download
them here.
3. The separation map controls the mix between stereo and mono. Mono projection will be
used for the back of the dome since it’s not known if the audience will turn their head or tilt
it backwards.
5
TNM091 - Media Production for Immersive Environments
4. The turn map controls how much the users head is turned. Most of the audience are looking
straight forward and scanning the image by moving their eyes instead. In this case traditional
forward stereo will be used. When the audience is looking at objects on the sides of the
dome, they need to turn their head since humans don’t have so good vision in the periphery.
Also traditional forward stereo wouldn’t make any sense on the sides.
5. In the Material Editor load the maps above in the Domemaster Stereo Shader by either
clicking in the circles of the graphical representation or by entering the properties of the
shader.
6. Double-click on the Bitmap items and change mapping from texture to environ using screen
space mapping on both bitmaps (turn map and separation map).
6
TNM091 - Media Production for Immersive Environments
7. In the Render Setup choose save file in the output groupbox. End the filename with _L to
mark that it’s the left eye’s view. Render the frame.
8. Change the Domemaster Stereo Shader camera to right, change the output name so it ends
with _R and render. You will now have a complete stereo pair.
2. Preview
2.1 Creating an anaglyphic frame
Most monitors don’t have stereoscopic capabilities which makes it’s hard to preview stereoscopic
images. An old technique is to use color masking to separate the images and then use glasses with
color filters corresponding to the mask. Most common are Red and Cyan glasses. Creating an
anaglyphic 3d image can be done in any image editor but it’s a time consuming process. Better is to
use a command line tool like ImageMagick that can be used to batch all frames at once. In the files
you have downloaded there is a bat-file containing a script that converts two images into one
anaglyphic pair.
1. Open up the command prompt by pressing the window key + R and type cmd and hit enter.
2. Place the bat file (stereo.bat) to the same directory as your output images.
3. Browse your directory by using the cd command in the command prompt.
7
TNM091 - Media Production for Immersive Environments
4. Run the script by typing: stereo <left_file> <right_file> <out_file>. Example:
5. Now you should have and anaglyphic image.
2.2 Previewing using the Amateras Dome Player
Previewing fisheye images can be a bit tricky due to the fisheye lens distortion. By mapping the
fulldome image onto a 3D dome shape can sometimes be helpful.
1. Open the Amateras Dome Player from the start menu.
2. In the View tab set the same settings as for the Norrköping Visualization Center dome.
3. Open your frame or preview video by File->Open File…
4. Navigate by using the mouse and you can test different styles by View->Style.
5. Get familiar with the application because it might be useful during your project.
8
TNM091 - Media Production for Immersive Environments
3. Using standard cameras and stitch the images to a fisheye
Ray tracing is very time consuming process and sometime traditional rendering can be much faster.
This guide will show you how to set up 4 standard cameras to render 4 separate views and then
stitch these images to a fisheye using an external tool (stitcher).
9
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising