Wiley | 978-0-470-10089-9 | Datasheet | Wiley 3ds Max 9 Bible

Wiley 3ds Max 9 Bible
TE
RI
AL
Exploring the
Max Interface
MA
W
TE
D
ell, here we are again with a new version of Max, and the first question on the minds of existing users is “Did the interface change?”
The answer is a happy “very little.” Most serious users would rather
go through root canal surgery than have their user interface (UI) change, and
Autodesk has learned and respected this valued opinion by keeping the interface
changes to a minimum.
GH
As you look around the new interface, you’ll see that everything is still there but
that Max has a few new additions. You may find yourself saying, as you navigate
the interface, “where did that come from?” But, just like encountering a new
house in your neighborhood, over time you’ll become accustomed to the addition and may even meet some new friends.
CO
PY
RI
Why is the software interface so important? Well, consider this: The interface is
the set of controls that enable you to access the program’s features. Without a
good interface, you may never use many of the best features of the software or
spend a frustrating bit of time locating those features. A piece of software can
have all the greatest features, but if the user can’t find or access them, then the
software won’t be used to its full potential. Max is a powerful piece of software
with some amazing features, and luckily the interface makes these amazing features easy to find and use.
The interface’s purpose is to make the software features accessible, and in Max
you have many different ways to access the features. Some of these access methods are faster than others. This design is intentional because it gives beginning
users an intuitive command and advanced users direct access. For example, to
undo a command, you can choose Edit ➪ Undo (requiring two mouse clicks),
but as you gain more experience, you can simply click the Undo icon on the
toolbar (only one click); an expert with his hands on the keyboard can press
Ctrl+Z without having to reach for the mouse at all. All three of these methods
have the same result, but you can use the one that is easiest for you.
19
IN THIS CHAPTER
Learning the interface elements
Previewing the menu commands
Becoming familiar with the
toolbars
Using the Command Panel
Examining the Lower
Interface Bar
Interacting with the interface
Getting help
Part I
Learning the Max Interface
Has the Max interface succeeded? Yes, to a degree, but like most interfaces, it always has room for improvement, and we hope that each new version takes us closer to the perfect interface (but I’m still looking for
the “read my thoughts” feature). Autodesk has built a loophole into the program to cover anyone who complains about the interface — customization. If you don’t like the current interface, you can change it to be
exactly what you want.
CROSS-REF
Customizing the Max interface is covered in Chapter 5, “Customizing the Max Interface and
Setting Preferences.”
This chapter examines the latest incarnation of the Max interface and presents some tips that make the
interface feel comfortable, not cumbersome.
The Interface Elements
If you’re new to the Max interface, the first order of business is to take a stroll around the block and meet
the neighbors. The Max interface has a number of interface elements that neatly group all the similar commands together. For example, all the commands for controlling the viewports are grouped together in the
Viewport Navigation Controls found in the lower-right corner of the interface.
If all the details of every interface command were covered in this chapter, it would be an
awfully long chapter. So for those commands that are covered in more detail elsewhere,
I include a cross-reference to the chapter where you can find their coverage.
NOTE
The entire interface can be divided into five easy elements. Each of these interface elements, in turn, has
groupings of sub-elements. The five main interface elements are listed here and shown separated in
Figure 1.1:
n Menus: This is the default source for most commands, but also one of the most time-consuming
interface methods. The menus are found along the top edge of the Max window.
n Toolbars: Max includes several toolbars of icon buttons that provide single-click access to features. These toolbars can float independently or can be docked to an interface edge. The main
toolbar is the only toolbar that is visible by default.
n Viewports: Four separate views into the scene show the Top, Front, Left, and Perspective viewpoints.
n Command Panel: The major control panel located to the right of the four viewports, it has six
tabbed icons at its top that you can click to open the various panels. Each panel includes rollouts
containing parameters and settings. These rollouts change depending on the object and tab that is
selected.
n Lower Interface Bar: Along the bottom edge of the interface window is a collection of miscellaneous controls.
In addition to these default elements are several additional interface elements that aren’t initially visible
when Max is first loaded. These additional interface elements include the following:
n Floating toolbars: Several additional toolbars are available as floating toolbars. You access them
by choosing Customize ➪ Show UI ➪ Show Floating Toolbars or by selecting them from the toolbar’s right-click pop-up menu.
20
Exploring the Max Interface
n Quadmenus: Right-clicking on the active viewport reveals a pop-up menu with up to four panes,
referred to as a quadmenu. Quadmenus offer context-sensitive commands based on the object or
location being clicked and provide one of the quickest ways to access commands.
n Dialog boxes and editors: Some commands open a separate window of controls. These dialog
boxes may contain their own menus, toolbars, and interface elements. A good example of this interface element type is the Material Editor, which has enough controls to keep you busy for a while.
FIGURE 1.1
Max includes five main interface elements.
Menus
Main Toolbar
Viewports
Command Panel
Lower Interface Bar
21
1
Part I
Learning the Max Interface
Using the Menus
The pull-down menus at the top of the Max interface include most of the features available in Max and are a
great place for beginners to start. Several of the menu commands have corresponding toolbar buttons and
keyboard shortcuts. To execute a menu command, you can choose it from the menu with the mouse cursor,
click its corresponding toolbar button if it has one, or press its keyboard shortcut. You can also select commands using the keyboard arrows and press the Enter key to execute them.
The main menu includes the following options: File, Edit, Tools, Group, Views, Create, Modifiers, reactor,
Animation, Graph Editors, Rendering, Customize, MAXScript, and Help. Unlike some other programs,
these menu options do not disappear if not needed. The list is set, and they are always there when you
need them.
The menu bar is a little shorter in version 9 because the Character menu has been removed.
Also new is the additional information added to the title bar including the filename, Project
Folder, License, and Display method.
NEW FEATURE
If a keyboard command is available for a menu command, it is shown to the right of the menu item. If an
ellipsis (three dots) appears after a menu item, that menu command causes a separate dialog box to open.
A small black arrow to the right of a menu item indicates that a submenu exists. Clicking the menu item or
holding the mouse over the top of a menu item makes the submenu appear. Toggle menu options (such as
Views ➪ Show Ghosting) change state each time they are selected. If a toggle menu option is enabled, a
small check mark appears to its left; if disabled, no check mark appears.
CROSS-REF
A complete list of keyboard shortcuts can be found in Appendix C, “Max Keyboard Shortcuts.”
You can also navigate the menus using the keyboard by pressing the Alt key by itself. Doing so selects the
File menu, and then you can use the arrow keys to move up and down and between menus. With a menu
selected, you can press the keyboard letter that is underlined to select and execute a menu command. For
example, pressing Alt and then F (for File) and N (for New) executes the File ➪ New command; or you can
press Alt, use the down arrow to select the New command, and press the Enter key.
By learning the underlined letters in the menu, you can use the keyboard to quickly access
menu commands, even if the menu command doesn’t have an assigned keyboard shortcut. And
because you don’t need to stretch for the Y key while holding down the Ctrl key, underlined menu letters can
be faster. For example, by pressing Alt, G, and U successively, you can access the Group ➪ Ungroup menu
command. The keyboard buffer remembers the order of the letters you type regardless of how fast they are
keyed, making it possible to quickly access menu commands using the keyboard. Over time, you can learn
patterns to help you remember how to access certain menu commands, such as Alt, C, H, E for creating an
ellipse.
TIP
Not all menu commands are available at all times. If a menu command is unavailable, then it is grayed out,
as shown in Figure 1.2, and you cannot select it. For example, the Clone command is available only when
an object is selected, so if no objects are selected, the Clone command is grayed out and unavailable. After
you select an object, this command becomes available.
22
Exploring the Max Interface
FIGURE 1.2
All menus feature visual clues.
Disabled command
Keyboard shortcut
Submenu exists
Opens dialog box
Using the Toolbars
Now that you’ve learned the menu two-step, it is time for the toolbar one-step. The main toolbar appears by
default directly under the menus at the top of the Max window. Using toolbars is one of the most convenient ways to execute commands because most commands require only a single click.
Docking and floating toolbars
By default the main toolbar is docked along the top edge of the interface above the viewport, but you can
make any docked toolbar (including the main toolbar), a floating toolbar by clicking and dragging the two
vertical lines on the left (or top) end of the toolbar away from the interface edge. After you separate it from
the window, you can resize the floating toolbar by dragging on its edges or corners. You can then drag and
dock it to any of the window edges or double-click on the toolbar title bar to automatically dock the toolbar
to its latest location. Figure 1.3 shows the main toolbar as a floating panel.
If you right-click on any floating toolbar away from the buttons, you can access a pop-up menu that
includes options to dock or float the current toolbar, access the Customize UI window, or show or hide any
of the toolbars or the Command Panel. The main toolbar can be hidden with the Alt+6 keyboard shortcut.
FIGURE 1.3
The main toolbar includes buttons and drop-down lists for controlling many of the most popular Max functions.
23
1
Part I
Learning the Max Interface
CROSS-REF
You can customize the buttons that appear on any of the toolbars. See Chapter 5,
“Customizing the Max Interface and Setting Preferences.”
If you select the Customize ➪ Show UI ➪ Show Floating Toolbars menu command, several additional toolbars appear. These are floating toolbars. You also can make them appear by selecting them individually from
the toolbar right-click pop-up menu. These floating toolbars include Axis Constraints, Layers, reactor,
Extras, Render Shortcuts, Snaps, Animation Layers, and Brush Presets.
Using tooltips and flyouts
All icon buttons (including those found in toolbars, the Command Panel, and other dialog boxes and windows) include tooltips, which are identifying text labels. If you hold the mouse cursor over an icon button,
the tooltip label appears. This feature is useful for identifying buttons. If you can’t remember what a specific
button does, hold the cursor over the top of it and the tooltip gives you its name.
All toolbar buttons with a small triangle in the lower-right corner are flyouts. A flyout is a single toolbar button that expands to reveal additional buttons. Click and hold on the flyout to reveal the additional icons,
and drag to select one. Figure 1.4 shows the flyout for the Align button on the main toolbar.
FIGURE 1.4
Flyout menus bundle several toolbar buttons together.
NOTE
The General panel of the Preference Settings dialog box contains an option for setting the
number of milliseconds to wait before the flyout appears.
Learning the main toolbar
On smaller resolution screens, the main toolbar is too long to be entirely visible. To see the entire main toolbar, you need to set your monitor resolution to be at least 1280 pixels wide. To scroll the toolbar to see the
end, position the cursor on the toolbar away from the buttons, such as below one of the drop-down lists
(the cursor changes to a hand); then click and drag the toolbar in either direction. Using the hand cursor to
scroll also works in the Command Panel, Material Editor, and any other place where the panel exceeds the
given space.
TIP
The easiest way to scroll the main toolbar is to drag with the middle mouse button.
Toolbar buttons that open dialog boxes such as the Layer Manager, Material Editor, and Render Scene buttons are toggle buttons. When the dialog box is open, the button is highlighted yellow, indicating that the
dialog box is open. Clicking on a highlighted toggle button closes the dialog box. Corresponding menus
(and keyboard shortcuts) work the same way, with a small check mark appearing to the left of the menu
command when a dialog box is opened.
24
Exploring the Max Interface
Table 1.1 lists the controls found in the main toolbar. Buttons with flyouts are separated with commas.
TABLE 1.1
Main Toolbar Buttons
Toolbar Button
Name
Description
Undo (Ctrl+Z)
Removes the last performed command. You can set the levels
of Undo in the Preferences dialog box.
Redo (Ctrl+Y)
Brings back the last command that was undone.
Select and Link
Establishes links between objects.
Unlink Selection
Breaks links between objects.
Bind to Space Warp
Assigns objects to be modified by a space warp.
Selection Filter
drop-down list
Limits the type of objects that can be selected.
Select Object (Q)
Chooses an object.
Select by Name (H)
Opens a dialog box for selecting objects by name.
Rectangular Selection
Region, Circular
Selection Region,
Fence Selection
Region, Lasso Selection
Region, Paint Selection
Region (Ctrl+F to cycle)
Determines the shape used for selecting objects
with the mouse.
Window/Crossing Toggle
Specifies whether an object must be crossed or
windowed to be selected.
Select and Move (W)
Selects an object and allows positional translations.
Select and Rotate (E)
Selects an object and allows rotational transforms.
Select and Uniform Scale,
Select and Non-Uniform
Scale, Select and Squash
(R to cycle)
Selects an object and allows scaling transforms using
different methods.
continued
25
1
Part I
Learning the Max Interface
TABLE 1.1
Toolbar Button
26
(continued)
Name
Description
Reference Coordinate
System drop-down list
Specifies the coordinate system used for transforms.
Use Pivot Point Center,
Use Selection Center,
Use Transform
Coordinate Center
Specifies the center about which rotations are completed.
Select and Manipulate
Selects an object and allows parameter manipulation via
a manipulator.
Keyboard Shortcut
Override Toggle
Allows keyboard shortcuts for the main interface and the
active dialog box or feature set to be used when enabled.
Only main interface shortcuts are available when disabled.
Snap Toggle 2D,
Snap Toggle 2.5D,
Snap Toggle 3D (S)
Specifies the snap mode. 2D snaps only to the active
construction grid, 2.5D snaps to the construction grid or
to geometry projected from the grid, and 3D snaps to
anywhere in 3D space.
Angle Snap Toggle (A)
Causes rotations to snap to specified angles.
Percent Snap
(Shift+Ctrl+P)
Causes scaling to snap to specified percentages.
Spinner Snap Toggle
Determines the amount a spinner value changes with
each click.
Edit Named
Selection Sets
Opens a dialog box for creating and managing selection
sets.
Named Selection Sets
drop-down list
Lists and allows you to select a set of named objects.
Mirror Selected Objects
Creates a mirrored copy of the selected object.
Align (Alt+A),
Quick Align,
Normal Align (Alt+N),
Place Highlight (Ctrl+H),
Align to Camera,
Align to View
Opens the alignment dialog box for positioning objects,
allows objects to be aligned by their normals, determines
the location of highlights, and aligns objects to a camera
or view.
Layer Manager
Opens the Layer Manager interface where you can work
with layers.
Open Curve Editor
Opens the Function Curves Editor.
Open Schematic View
Opens the Schematic View window.
Material Editor (M)
Opens the Material Editor window.
Exploring the Max Interface
Toolbar Button
NEW FEATURE
Name
Description
Render Scene Dialog (F10)
Opens the Render Scene dialog box for setting rendering
options.
Render Type drop-down
list
Selects the area or objects to render.
Quick Render (Production),
Quick Render (ActiveShade)
Produces a quick test rendering of the current viewport
without opening the Render Scene dialog box.
The main toolbar has some slight changes in 3ds Max 9. The Keyboard Shortcut Override
Toggle has been moved to the main toolbar.
Using the Viewports
The four viewports make up the largest area of the entire interface and provide a way of viewing the objects
within the scene. Each of the viewports is configurable and can be unique from the others.
Understanding how to work with the viewports is vital to accomplishing tasks with Max, so
viewports have an entire chapter dedicated just to them — Chapter 2, “Controlling and
Configuring the Viewports.”
CROSS-REF
Using the Command Panel
If there is one place in Max, besides the viewports, where you’ll spend all your time, it’s the Command
Panel (at least until you’re comfortable enough with the quadmenus). The Command Panel is located to the
right of the viewports along the right edge of the interface. This is where all the specific parameters, settings, and controls are located. The Command Panel is split into six panels, each accessed via a tab icon
located at its top. These six tabs are Create, Modify, Hierarchy, Motion, Display, and Utilities.
You can pull away the Command Panel from the right window edge as a floating dialog box, as shown in
Figure 1.5, by clicking on the open space to the right of the tabbed icons at the top of the Command Panel
and dragging away from the interface edge. You can also dock it to the left window edge, which is really
handy if you’re left-handed. While it’s a floating panel, you can resize the Command Panel by dragging on
its edges or corners (but its width remains constant).
After you’ve pulled the Command Panel or any of the toolbars away from the interface, you can re-dock
them to their last position by double-clicking on their title bar. You can also right-click on the title bar to
access the pop-up menu of floating toolbars, but the pop-up menu also includes options to Dock (either
Left or Right for the Command Panel or Left, Right, Top or Bottom for toolbars) and Float.
27
1
Part I
Learning the Max Interface
FIGURE 1.5
The Command Panel includes six separate panels accessed via tab icons.
Create
Modify Motion
Display
Utilities
Hierarchy
Working with rollouts
Most of the controls, buttons, and parameters in the Command Panel are contained within sections called
rollouts. A rollout is a grouping of controls positioned under a gray, boxed title, as shown in Figure 1.6.
Each rollout title bar includes a plus or minus sign (a minus sign indicates that the rollout is open; a plus
sign shows closed rollouts). Clicking the rollout title opens or closes the rollout. You can also reposition the
order of the rollouts by dragging the rollout title and dropping it above or below the other rollouts.
NOTE
You cannot reposition some of the rollouts, such as the Object Type and the Name and Color
rollouts found in the Create panel.
Right-clicking away from the buttons in a rollout presents a pop-up menu where you can select to close the
rollout you’ve clicked in, Close All, Open All, or Reset Rollout Order. The pop-up menu also lists all available rollouts within the current panel with a check mark next to the ones that are open.
Expanding all the rollouts often exceeds the screen space allotted to the Command Panel. If the rollouts
exceed the given space, then a small vertical scroll bar appears at the right edge of the Command Panel. You
can drag this scroll bar to access the rollouts at the bottom of the Command Panel, or you can click away
from the controls when a hand cursor appears. With the hand cursor, click and drag in either direction to
scroll the Command Panel. You can also scroll the Command Panel with the scroll wheel on the mouse.
CROSS-REF
You can customize the Command Panel like the other toolbars. Customizing the Command
Panel is covered in Chapter 5, “Customizing the Max Interface and Setting Preferences.”
Increasing the Command Panel’s width
The Command Panel can also be doubled or tripled (or any multiple as long as you have room) in width
by dragging its left edge toward the center of the interface. The width of the Command Panel is increased at
the expense of the viewports. Figure 1.7 shows the Command Panel double its normal size.
28
Exploring the Max Interface
FIGURE 1.6
Open and close rollouts by clicking on the rollout title.
Opened rollout
Closed rollout
FIGURE 1.7
Increase the width of the Command Panel by dragging its left edge.
29
1
Part I
Learning the Max Interface
Tutorial: Rearranging the interface for lefties
I used to work for a company that required that all computers have the mouse to the left of the keyboard.
We swapped computers often, and the boss hated having to move the mouse to the other side of the keyboard (and you thought your work environment was weird). The reality is that some people like it on the
left and others prefer it on the right, and Max can accommodate both.
With the Command Panel on the right side of the interface, the default Max interface obviously favors righthanders, but with the docking panels, you can quickly change it to be friendly to lefties.
To rearrange the interface for lefties, follow these steps:
1. Click the Command Panel on the empty space to the right of the Utilities tab, and drag toward the
center of the interface. As you drag the Command Panel away from the right edge, the cursor changes.
2. Continue to drag the Command Panel to the left edge, and the cursor changes again to indicate
that it will be docked when released. Release the mouse button, and the Command Panel docks
to the left side.
3. For an even easier method, you can right-click on the Command Panel’s title bar and select
Dock ➪ Left from the pop-up menu.
Figure 1.8 shows the rearranged interface ready for all you southpaws.
TIP
To save the interface changes, use the Customize ➪ Save Custom UI Scheme menu. The
maxstart.cui file is loaded by default when Max is started.
FIGURE 1.8
Left-handed users can move the Command Panel to the left side.
30
Exploring the Max Interface
Using the Lower Interface Bar Controls
The last major interface element isn’t really an interface element but just a collection of several sets of controls located along the bottom edge of the interface window. These controls cannot be pulled away from the
interface like the main toolbar, but you can hide them using Expert Mode (Ctrl+X). These controls, shown
in Figure 1.9, include the following from left to right:
n Time Slider: The Time Slider, located under the viewports, enables you to quickly locate a specific frame. It spans the number of frames included in the current animation. Dragging the Time
Slider can move you quickly between frames. Clicking the arrow buttons on either side of the
Time Slider moves to the previous or next frame (or key).
n Track Bar: The Track Bar displays animation keys as color-coded rectangles with red for positional keys, green for rotational keys, and blue for scale keys. Parameter change keys are denoted
by gray rectangles. Using the Track Bar, you can select, move, and delete keys. The button at the
left end of the Track Bar is the Open Mini Curve Editor button. It provides access to the animation function curves.
n Status Bar: The Status Bar is below the Track Bar. It provides valuable information, such as the
number and type of objects selected, transformation values, and grid size. It also includes the
Selection Lock Toggle, Transform Type-In fields, and the value of the current Grid size.
n Prompt Line: The Prompt Line is text located at the bottom of the window. If you’re stuck as to
what to do next, look at the Prompt Line for information on what Max expects. To the right of the
Prompt Line is the Communication Center button for setting how often Max looks for updates.
The Prompt Line also includes buttons for adding and editing Time Tags, which are used to name
specific animation frames.
n Key Controls: These controls are for creating animation keys and include two different modes —
Auto Key (keyboard shortcut, N) and Set Key (keyboard shortcut, '). Auto Key mode sets keys for
any changes made to the scene objects. Set Key mode gives you more precise control and sets
keys for the selected filters only when you click the Set Keys button (keyboard shortcut, K).
n Time Controls: Resembling the controls on an audio or video device, the Time Controls offer an
easy way to move through the various animation frames and keys. Based on the selected mode
(keys or frames), the Time Controls can move among the first, previous, next, and last frames
or keys.
n Viewport Navigation Controls: In the lower-right corner of the interface are the controls for
manipulating the viewports. They enable you to zoom, pan, and rotate the active viewport’s view.
NEW FEATURE
The Communication Center button on the Prompt Line is new to 3ds Max 9. It sets how often
Max polls for updates via the Web.
31
1
Part I
Learning the Max Interface
FIGURE 1.9
The Lower Interface Bar includes several sets of controls.
Track Bar
Time Slider
Prompt Line
Status Bar
Key Controls Time Controls
Viewpoint Navigation Controls
Interacting with the Interface
Knowing where all the interface elements are located is only the start. Max includes several interactive features that make the interface work. Learning these features makes the difference between an interface that
works for you and one that doesn’t.
Gaining quick access with the right-click quadmenus
Quadmenus are pop-up menus with up to four separate sections that surround the cursor, as shown in
Figure 1.10. Right-clicking in the active viewport opens these quadmenus. The contents of the menus
depend on the object selected.
Many of the real pros use quadmenus extensively. One reason is that they can access the commands from the mouse’s current location using a couple of clicks without having to go all the
way to the Command Panel to click a button.
TIP
Clicking with the left mouse button away from the quadmenu closes it. For each menu, the last menu item
selected is displayed in blue. To quickly access the blue menu item again, simply click the gray-shaded bar
for the quadrant that contains the blue menu item. Using Customize ➪ Customize User Interface, you can
specify which commands appear on the quadmenus, but the default options have just about everything
you need.
If you press and hold the Alt, Ctrl, and Shift keys while right-clicking in the active viewport, you can access
specific sets of commands; Shift+right-click opens the Snap options, Alt+right-click opens Animation commands, Ctrl+right-click opens a menu of primitives, Shift+Alt+right-click opens a menu of reactor commands,
and Ctrl+Alt+right-click opens a menu of rendering commands.
32
Exploring the Max Interface
FIGURE 1.10
Quadmenus contain a host of commands in an easily accessible location.
Understanding the button color cues
Max’s interface uses color cues to help remind you of the current mode. When a button is yellow, it warns
that it has control of the interface. For example, if one of the select buttons on the main toolbar is selected, it
turns yellow and any dragging in the viewport affects the object; however, if one of the Viewport Navigation
Control buttons is selected, it turns yellow and dragging the viewport changes the view. Knowing what the
current mode is at all times can keep you out of trouble.
Right-clicking in the active viewport exits any Viewport Navigation mode that has control and
returns control to the most recent transform tool. Right-clicking in one of the inactive viewports keeps the focus where it is and makes that clicked viewport active.
TIP
Another common button color is red. When either the Auto Key or Set Key buttons are depressed, they
turn red. The edge of the active viewport being animated along with the Time Slider also turns red. This
reminds you that any modifications will be saved as a key.
Toggle buttons are buttons that can be turned on and off. Example toggle buttons include the Snap buttons.
When a toggle button is enabled, it also turns yellow. Toggle buttons highlighted in blue are non-exclusive,
but they notify you of a mode that is enabled, such as the Key Mode Toggle or the Affect Pivot Only button.
CROSS-REF
All interface colors can be customized using the Customize User Interface dialog box that is
discussed in Chapter 5, “Customizing the Max Interface and Setting Preferences.”
33
1
Part I
Learning the Max Interface
Using drag-and-drop features
Dialog boxes that work with files benefit greatly from Max’s drag-and-drop features. The Material Editor,
Background Image, View File, and Environmental Settings dialog boxes all use drag and drop. These dialog
boxes let you select a file or a material and drag it on top of where you want to apply it. For example, with
the Maps rollout in the Material Editor open, you can drag a texture image filename from Windows Explorer
or the Asset Manager and drop it on the Map button. You can even drag and drop Max files from Windows
Explorer into the Max interface to open them.
Controlling spinners
Spinners are those little controls throughout the interface with a value field and two small arrows to its right.
As you would expect, clicking the up arrow increases the value and clicking the down arrow decreases the
value. The amount of the increase or decrease depends on the setting in the General tab of the Preference
Settings dialog box. Right-clicking on the spinner resets the value to its lowest acceptable value. Another way
to control the spinner value is to click the arrows and drag with the mouse. Dragging up increases the value,
and dragging down decreases it.
The effect of the spinner drag is shown in the viewport if the Update During Spinner Drag menu option is
enabled in the Views menu. If the cursor is located within a spinner, you can press Ctrl+N to open the
Numeric Expression Evaluator, which lets you set the value using an expression. For example, you can set a
spinner value by adding numbers together as you would using a calculator. An expression of 30+40+35 sets
the value to 105.
CROSS-REF
Chapter 32, “Animating with Constraints and Controllers,” covers the Numeric Expression
Evaluator in more detail.
Understanding modeless and persistent dialog boxes
Many dialog boxes in Max are modeless, which means that the dialog box doesn’t need to be closed before
you can work with objects in the background viewports. The Material Editor is an example of a modeless
dialog box. With the Material Editor open, you can create, select, and transform objects in the background.
Other modeless dialog boxes include the Material/Map Browser, the Render Scene dialog box, the Video
Post dialog box, the Transform Type-In dialog box, the Display and Selection Floaters, and the various
graph editors. Pressing the Ctrl+~ keyboard shortcut closes all open dialog boxes. Pressing the same keyboard shortcut again reopens the dialog boxes that were previously closed.
Another feature of many, but not all, dialog boxes is persistence, which means that values added to a dialog
box remain set when the dialog box is reopened. This feature applies only within a given Max session.
Choosing the File ➪ Reset command button or exiting and restarting Max resets all the dialog boxes.
Getting Help
If you get stuck, Max won’t leave you stranded. You can turn to several places in Max to get help. The
Help menu is a valuable resource that provides access to references and tutorials. The User Reference and
MAXScript Reference are comprehensive help systems that work like a Web browser. The Tutorial command
loads the tutorials, which offer a chance to gain valuable experience.
34
Exploring the Max Interface
When Max first loads, users are greeted with a Welcome Screen, shown in Figure 1.11, that includes seven
Essential Skills Movies. These simple movies explain the basics of working with Max. The Welcome Screen
includes a link to Area, which is the Autodesk community site. After viewing the videos, you can disable the
Show this dialog at startup option to prevent the Welcome Screen from appearing next time you start Max.
You can access the Welcome Screen at any time using the Help menu.
CROSS-REF
The Welcome Screen with its helpful video clips is new to 3ds Max 9.
FIGURE 1.11
The Welcome Screen includes video clips that show the basic skills for working with Max.
The Help ➪ Data Exchange Solutions menu opens a Web page that explains how to use the FBX format to
exchange files with other software packages. The next set of help menu commands applies to users with 3ds
Max subscriptions. They let you access various e-Learning lessons, submit and view support requests, and edit
your subscription profiles. All of these commands require that you enter your subscription contract number.
The Hotkey Map displays an interactive interface for learning all the keyboard shortcuts. Additional Help
presents help systems for any external plug-ins that are loaded. The 3ds max on the Web options (Online
Support, Updates, Resources, Partners, and Training) automatically open a Web browser and load the
Autodesk Support Web pages or look for updates.
The Activate 3ds Max command lets you enter an activation number to authorize the software. The License
Borrowing option lets you borrow and return the current Max license for use on another computer. The
About 3ds Max command opens the About dialog box. This dialog box displays the serial number and current display driver.
35
1
Part I
Learning the Max Interface
Browser-based reference guides
The New Features Guide, User Reference, MAXScript Reference, and Tutorials are Web browser-based help
interfaces. An organized list of topics is available in the left navigation pane, as shown in Figure 1.12, and
the right includes a pane where the details on the selected topic are displayed. Across the top are five toolbar buttons used to control the interface. The Hide button hides the left navigation pane, the Back and
Forward buttons move between visited pages, the Print button prints the information in the right pane,
and the Options button displays a pop-up menu of options.
FIGURE 1.12
The User Reference includes panels for viewing the index of commands and searching the reference.
Above the left navigation pane are five tabs that open separate panels when selected. The Contents panel
displays a list of topics; the Index panel lists all topics alphabetically; the Search panel includes a text field
where you can search for specific keywords; the Favorites panel keeps a list of bookmarks to topics you
add to the list; and the Query panel lets you type a question and query for answers.
Throughout the textual descriptions, keywords linked to other related topics are highlighted in blue and
underlined.
Online help
The Web offers many sites that can also help, and Max links to the Online Support, Updates, Resources,
Partners, and Training pages on the Autodesk site from the Help ➪ 3ds max on the Web menu. Selecting
either of these menu commands automatically opens a Web browser and loads the Autodesk Web pages.
36
Exploring the Max Interface
Summary
You should now be familiar with the interface elements for Max. Understanding the interface is one of the
keys to success in using 3ds Max. Max includes a variety of different interface elements. Among the menus,
toolbars, and keyboard shortcuts, several ways to perform the same command exist. Discover the method
that works best for you.
This chapter covered the following topics:
n The interface elements
n Viewing and using the pull-down menus
n Working with toolbars
n Accessing the Command Panel
n Learning the lower interface controls
n Interacting with the Max interface
n Getting additional help
In this chapter, we’ve skirted about the viewports covering all the other interface elements, but in the next
chapter, we’re going to hit the viewports head-on.
37
1
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising