Chapter 1: HyperMesh Introduction

Chapter 1: HyperMesh Introduction
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Chapter 1: HyperMesh Introduction
Getting Started
Opening and Saving Files
Working with Panels
Organizing a Model
Controlling the Display
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
HyperMesh Introduction: The User Interface
Pull Down
Menus
Toolbars
Graphics Area
Tab Area:
• Utility Menu
• Model Browser
• Mask By Config
• Etc.
Menu Pages
Panel
Main Menu
Status Bar
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Modern GUI Environment: Menu Bar
• Designed for “new” users to HyperMesh
• Easily navigate to Panels
• Process Based Workflow
• Action / Object / Method Architecture
• Action: Create, Edit, Delete, etc…
• Object: on which to Perform Action
• Method: by which to perform Action on
Object
• Each menu controls specific HM Entities
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Modern GUI Environment: Menu Bar
Some panels use
icons to represent
the subpanels
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Standard Toolbar
• File Management (New, Open, Save,
Import, Export, User Profile, Tcl/Tk Tools)
• Standard, User Defined and Model
View Controls (Zoom, Rotate, Pan)
• Not shown by Default, Customize from View Menu
• Quick Access to Common “Checks” ( Distance/Length, Mass Calc,
Edges/Features/Faces, Normals, Penetration and Element Check)
• Suggested Method for Creating/Editing Collectors
(Delete, Card Edit, Organize, Renumber)
• Not shown by Default, Customize from View Menu (Only on Win 32/64)
• BMP Image Capture System (Copy to Clipboard or File, Capture
Graphics Area, Capture Panel, Capture “free” Window, Capture Frame)
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display and Visualization Toolbars
• Display controls WHAT is shown
• Mask Tools
• Find
• Element/Load Handles
• Visualization controls HOW things are shown
• Color Modes
• Shading Modes
• 1D Beam Visualization
• New Visualization Tab
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
HyperMesh Introduction: The User Interface
• Graphics area – displays the model
• Toolbar – Gives access to commonly used tools via icons
• Pull Down Menu – places functionality into groups, accessible via pull downs
• Menu Pages – divides the main menu into groups based on function
• Main Menu – contains “panels” grouped in columns
• Panels – menu items / functions for interacting with HyperMesh
• Sub-panels – divides panel into similar tasks related to panel’s main function
• Command Window – lets the user type in and execute tcl commands
•
Available through the View drop down menu (turned off by default)
• Tab Area – contains the following tabs:
•
Solver, Model, Utility, Include, Import, Export, Connector, Entity State, etc.
• Status Bar – shows status of operations being performed
•
Indicates the “current” Include file, Component Collector, and Load Collector
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
File Operations
• General terminology:
•
•
•
•
Open : Loads a file into HyperMesh replacing the current session
Save : Saves the current session contents to the file name specified
Import : Loads a file into HyperMesh, merging with the current contents
Export : Saves data to the file name specified
• Generally refers to file types other than a HyperMesh binary file
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
File Operations: The File Pull-down Menu
• Open… : Loads a HyperMesh file into current session
•
Replaces the model in current HyperMesh session
• Save : Saves the model in current HyperMesh session
•
File browser prompts for directory and file name if one doesn’t exist
• Save As… : Opens file browser to specify directory and name to save current
session
• Import : Merges / combines files with the model in the current HyperMesh
session
•
•
Various types of files: HyperMesh, geometry (IGES, Step, etc.), finite element data
(OptiStruct, Radioss, Nastran, Abaqus, Ansys, LS-Dyna, etc.)
Opens the Import browser
• Export : Writes data in current HyperMesh session to non-HyperMesh files
types
•
•
IGES, OptiStruct, Radioss, etc.
Opens the Export browser allowing specification of directory and name
• Recent Files : A listing of HyperMesh files that have been worked on previously
•
Loads the file and replaces the model in the current session
• Recent Imports : A listing of files previously loaded into HyperMesh via Import
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Importing Geometry
• Import geometry data via:
• File > Import > Geometry drop-down menu
• Toolbar >
> Geometry
• Common types of geometry files supported:
• Unigraphics (NX2, NX3, NX4, NX5, NX6)
• UG Part Browser
• Import of *.prt files
• Requires an installation of
Unigraphics to be available
• CATIA (V4 & V5)
• import of *.model files
• CATIA V5 license required to
import V5 files
• Pro/ENGINEER (Wildfire 2.0 & 3.0)
• import of *.prt and *.asm files
• IGES
• Import of *.igs / *.iges files
• STEP
• import of *.stp files
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Custom Import
Import tab
• Complete control over FE import
• Import multiple geometry files
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Entity State Browser
Entity State Browser
•
•
•
•
•
Available for all entities
Removes inactive entities from any list in
the browser and panels
Removes inactive entities from display and
they cannot be turned on until made active
• Exception: Find brings inactive
entities back onto the screen too and
switches these entities to active
Removes inactive entities temporarily from
the "database“
Selection by “all” selects only active entities
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display Control  Viewing: Mouse Buttons
 Left mouse button
• +CTRL & drag for rotate
• +CTRL & click on entity to change center of
•
rotation
+CTRL & click in graphics area, off entities to
reset center to middle of screen
 Middle mouse button
• +CTRL & drag for zoom
• +CTRL & click for fit
 Right mouse button
• +CTRL & drag for pan
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Toolbars
Standard Views Toolbar
Previous
View
Fit
Bottom
Top
Right
Left
Front
Rear
Reverse
View
Isometric
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display Control  3D View Controls
Zoom In (+)
•Zoom in or out by dragging the mouse vertically
Zoom Out (-)
Circle Zoom (Z)
•Draw a circle (freeform) around the area to be
magnified
Dynamic Zoom (S)
•Zoom into the center of the screen
Dynamic Rotate
•Dynamically rotate the model about defined center
•Dynamically spin the model about a defined center
Dynamic Spin
Pan
Center
•Drag the model around in the graphics area
•Select a node/point to center of the model at that
point
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display Control  3D View Controls
Rotate Left
Rotate Right
Rotate Up
Rotate Down
Rotate Clockwise
Rotate Counter
Clockwise
•Rotate the model view Left or Right about an
imaginary vertical axis in the middle of the graphics
area
•Rotate the model view Up or Down about an
imaginary horizontal axis in the middle of the
graphics area
•Rotate the model view Clockwise or Counter
Clockwise about an imaginary axis coming out of the
graphics area
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display Control  Visualization: Surfaces
• Various surface shading options are available on the Toolbar:
Wireframe
Wireframe with Surf lines
Shaded with Surface edges
Shaded
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display and Visualization Toolbars
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Toolbars
Image Capture Toolbar
File /
Clipboard
Panel
Area
Graphics
Area
Frame
Area
Rectangle
Area
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: General Layout
• Panels often have sub-panels
• Accessed by radio buttons on the left side of the panel
• Panels generally work from left to right
• Example: Project / to plane sub-panel
1) What to do:
2) What to do it to:
3) How to do it:
4) Do the action:
Pick a sub-panel
for the function
to be used
Select entities that
will be affected
Give parameters
that define how
the function will
be executed
Execute the
function
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: General Layout
• Some sub-panels are organized in columns
• Each column is a different method
• Work from top to bottom in the relevant column
• Example: surface edit : trim with surfs/plane sub-panel
1) What to do:
2) Method to
use:
3) What to do
it to:
Pick a sub-panel
for the function
to be used
Work in the
appropriate
column
Select entities
that will be
affected
4) How to do it:
Give parameters
that define how
the function will
be executed
5) Do the
action:
Execute the
function
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: Selection
• Entity selectors
•
Control what and
how entities are
selected for a
function
Entity Type Button
Shows the type of entity
currently being selected
Entity Type Switch
Reset
Changes what type of
entity is being selected
Deselects all entities
for the selector
Cyan border
Indicates the selector is active (there can only be 1 active selector)
Clicking the entity type button when it is active accesses the “Extended Selection Menu”
•
Switches 
•
•
Text input fields 
•
•
Toggles 
•
•
•
Allows a choice of several options vis a pop-up
menu
•
Allows a choice between 2 options
No pop-up; button label simply changes
Reset 
•
Allows to reset the entities selection
•
Operate like text fields in most programs
Can use Ctrl + C and Ctrl + V to copy and paste
between fields
Double clicking on a text field that requires
numbers accesses the calculator
• Uses “reverse notation”
• Example: 1 + 1 = 2
1 <Enter> 1 + instead of 1 + 1 =
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: Extended Selection Menu
• Click an active selector to access the extended menu selection
• The extended menu selection offers
• Methods for selecting many entities at once
• Tools for modifying an existing selection
• Save an existing selection and retrieve it in any panel
• Multiple extended selection methods can be used on a selection
• Allows you to easily select exactly what you want
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: Overview
• Select entities with a window using Shift + mouse
• Left mouse drag – select entities
• Right mouse drag – unselect entities
• Left click – change window shape
•
•
•
•
•
•
Rectangle Inside
Rectangle Outside
Polygon Inside
Polygon Outside
Circle Inside
Circle Outside
• Entities are selected when
mouse button is released
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels: Direction Selection
• Used for input of directions or planes for a given function
• Planes can be selected from a vector (normal to the vector)
• Directions can be selected from a plane (normal to the plane)
Current Direction / Plane
Direction Switch
Options for what
direction is selected
Shows a selected axis or inputs for selecting
entities to define a direction / plane
Reset
Deselects the
selected nodes
Base
Edit
Select a node
to position a
selected plane
Double click to
access and enter
coordinates for N1,
N2, N3 and Base.
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Panels  Direction Selection: N1, N2, N3
• N1, N2, N3 direction option allows nodes to be selected to define either
a direction or a plane
• Select 2 nodes to define a direction (only N1 and N2)
• Select 3 nodes to define a plane (N1, N2, and N3)
Plane defined by N1, N2, N3
N3
N2
N1
N1
Direction is
normal to plane
Positive direction
is by “right hand
rule”
N2
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Display Control  Visibility: Mask Browser
 Mask Browser– Control of visibility by
entity type
• + : Displays / unmasks all of the
selected entity type
– Added to whatever is already
displayed
•
- : Switches off display or masks all of
the selected entity type
• 1 : Displays only the selected entity
type and switches off display of all
other entity types.
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: HyperMesh Entity Types
• Geometry
•
•
•
•
•
Points
Points
Lines
Lines
Surfaces
Solids
Connectors (used for welding)
Surfaces
Solids
• FE Model
Nodes
• Nodes
• Temp Nodes (marks a node with a small circle)
• Elements
Temp Nodes
Elements
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: HyperMesh Entity Types
• FE Loading
• Loads (constraints, forces, pressures, etc.)
• Equations (mathematical link between nodes)
Forces
Pressures
Constraints
• Contacts
• Group (defines contact between entities)
• Contact Surfs (defines a list of entities that can be
used as master or slave in a group)
Contact
Surface
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: HyperMesh Entity Types
• Coordinate Entities
• Systems (coordinate axes)
• Vectors
Vectors
Systems
• Reference Entities
• Sets (a simple list of a particular type of
entity)
• Blocks (a list of entities contained within a
box shape)
• 1D Element Cross Sections
• Beam Sections (cross sectional
properties for a property collector)
Beam Section
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: HyperMesh Entity Types
• Plotting
• Curves (X-Y data)
• Plots (a display of curves with axes)
• Output Requests
• Loadsteps (combinations of load collectors)
• Output Blocks (request output from an
analysis for certain entities)
Plot with a Curve
Titles
• Labels
• Titles (label for a displayed item)
• Tags (assigns a name to an entity)
Tags
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: Collectors
•
•
•
•
The HyperMesh model is organized using “collectors”
There are many types of collectors
Most entities in HyperMesh must be placed in a collector
Each collector type holds a specific type of entity
Collector Types
Can contain entity types:
Component
Elements, Points, Lines, Surfaces, Connectors
Multibody
Ellipsoids, Mbjoints, Mbplanes, Sensors
Assembly
Components, Multibodies, Assemblies
Load Collector
Loads, Equations
Material
Property
none (materials and properties don’t contain other entities but are
still treated as collectors)
System Collector
Systems
Vector Collector
Vectors
Beam Section Collector
Beam Sections
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: Collectors
• An entity can usually only belong to 1 collector of a given type
• Ex: an element can only be in 1 component collector
• Can create many collectors of the same type
• All entities in a collector are the same color
• Organization can be however the user desires
Component 4
Component 3
Component 1
Component 3
Component 2
1 component per part
Component 1
Component 2
Multiple components per part
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Toolbars
Collectors Toolbar
Assemblies
Materials
Load
Collectors
Delete Panel (F2)
Organize
Properties
Components
System Collector
and Options
Card Edit
Renumber
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: Collectors
• Model browser
• View collectors and assemblies in a
hierarchical tree format
• Create, delete, and rename collectors
• Edit collector attributes
• Organize collectors into assemblies
• Drag and drop
• Also available using toolbar “Collectors”
Right-Click on
Collector for
advanced
options
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: Collectors
• New entities are created in the “current collector”
• Creating a new collector automatically sets the current collector to that new
collector
• Model Browser used to change the current collector
• Organize panel can be used to move entities into a different collector
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Browsers
Model Browser
•
•
Complete Listing of all HyperMesh Entities in Model
Each “Collector” is expandable and lists all contained “Entities”
Component Browser
•
•
•
•
Lists All Components in Model
Colors Model “by Component”
Quickly Sort by Name, ID, Color, or Property
Display State Icons
•
•
•
Global Controls to Operate on all Components
•
•
•
•
Geom ON/OFF Single Picking
FE ON/OFF Single Picking
All
None
Reverse
Browser Modes
•
•
•
•
Graphics/Browser List Picking for:
Select
Show/Hide
Isolate
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Browser Modes – Select
Graphics Area
Browser Area
Add
Left mouse click
Left mouse click
Remove
Right mouse click
Ctrl + Left mouse click
Multiple
Shift + Left mouse click
Shift + Left mouse
click
(drag and select)
Advance Left mouse click + Wheel
-
Copyright © 2009 Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.
Model Organization: Tools
• Panels
• Collectors – Create new collectors
• Model Browser – Set the current collector for various entity types
• Organize – Move entities into a different collector than the one they are currently
contained in
• Rename – Change the name of an existing collector
• Reorder
• Collectors appear in a certain order when presented in a list to pick from
• Reorder allows the order the collectors appear in to be changed
• Delete – Delete entities or collectors
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement