VUI User Guide - Source III, Inc.

VUI User Guide - Source III, Inc.
V10.0 Software Bundle
Release 10.0
January 2015
VUI® User Guide [Release 10.0, revision 100]
Source III, Inc.
1 Introduction.............................................................................................................................................3
2 Installation...............................................................................................................................................4
2.1 VUI is included with VTRAN.........................................................................................................4
2.2 First Time Installation.....................................................................................................................4
2.3 Supported Platforms........................................................................................................................5
2.4 Updates............................................................................................................................................5
2.5 Requirements...................................................................................................................................5
3 Invoking VUI..........................................................................................................................................7
3.1 Running VUI for the First Time......................................................................................................9
3.2 Supported Formats........................................................................................................................10
4 VUI Forms............................................................................................................................................11
4.1 External Editors.............................................................................................................................12
4.2 Form Layout..................................................................................................................................13
4.2.1 Initial Setup Form..................................................................................................................13
4.2.2 OVF_Block Form..................................................................................................................13
4.2.3 PROC_Block Form...............................................................................................................15
4.2.4 TVF_Block Form..................................................................................................................15
4.2.5 Preview Form & Launching VTRAN®................................................................................15
4.2.6 Launching DFTView®..........................................................................................................17
4.3 Navigation and Validation.............................................................................................................19
5 Save/Restore Parameters.......................................................................................................................22
6 Advanced Features................................................................................................................................23
6.1 Context-Sensitive Help.................................................................................................................23
6.2 Field Input Restrictions.................................................................................................................25
6.3 Field Interactions...........................................................................................................................25
6.4 Pin Selection..................................................................................................................................27
7 Cyclizing VCD and EVCD Files..........................................................................................................28
VUI® User Guide [Release 10.0, revision 100]
7.1 Introduction...................................................................................................................................28
7.2 AUTO_ALIGN..............................................................................................................................31
7.3 ALIGN_TO_CYCLE....................................................................................................................34
7.4 Discussion.....................................................................................................................................36
VUI® User Guide [Release 10.0, revision 100]
1 INTRODUCTION
The VTRAN® program is designed to perform vector translations: reading in vector data from logic
simulators or ATPG tools and translating it into ATE test programs or formats for other EDA
environments. The application is text-based, reading instructions from an ASCII command file. With
the VTRAN® User Interface (VUI) we introduce a new utility to the vector translation toolkit – a
graphical user interface tailored specifically for generating VTRAN® command files. The VUI allows
the user to quickly generate valid command files and even run VTRAN ® directly from within the user
interface.
In addition, if you are also using Source III's graphical display tool DFTView ®, the VUI automatically
provides a convenient way to display the resulting vector output from VTRAN ® with a single click of
the mouse.
Although the VUI is geared towards the novice VTRAN® user, some basic knowledge of VTRAN® will
be useful. For example we will be discussing the various sections of the VTRAN ® command file (the
OVF, PROC and TVF blocks) and so some background will be useful.
VUI does provide an
introduction to VTRAN® via its Help menu, so at the very least we recommend you familiarize
yourself with the contents of that help section.
VUI® User Guide [Release 10.0, revision 100]
2 INSTALLATION
2.1 VUI is included with VTRAN
Since the VTRAN® 9.6.3 release, the VUI has been included in the VTRAN ® bundle. When you
download and install VTRAN®, you will find the VUI binary (called 'vui') automatically installed in
the $S3_ROOT directory.
The separate VUI bundle is still available and can be installed separately – this may be useful if, for
example, you have an older VTRAN ® package installed (although upgrading is always recommended!),
or if you wish to evaluate newer VUI releases separately from the main VTRAN® bundle.
2.2 First Time Installation
VUI is installed by simply copying the executable into the same directory where your VTRAN ®
executable resides. Make sure the copy is executable (chmod +x vui). Just select the binary that's
compatible with your system – you can choose from:
Linux32
(32-bit Linux)
Linux64
(64-bit Linux)
Solaris32
(32-bit/SPARC Solaris 8 or higher)
Solaris64
(64-bit/SPARC Solaris 8 or higher)
The simplest way to do this is to use the S3_ROOT environment variable (which was already defined
when you installed VTRAN®), for example:
cp Linux64/vui $S3_ROOT
chmod +x $S3_ROOT/vui
VUI® User Guide [Release 10.0, revision 100]
rehash
(this is required for C shell users only)
You should now be able to launch the VUI by simply typing:
vui
2.3 Supported Platforms
As indicated above, VUI is currently available for Linux (2.4 kernel or higher) running on 32-bit (i686)
and 64-bit (x86_64/amd64) processors, and for Solaris 8 or higher running on SPARC (32-bit and 64bit). The Linux versions have been tested on a variety of distributions including RedHat Enterprise
Linux, Fedora and Ubuntu.
2.4 Updates
From time to time Source III may provide updated VUI binaries (for example, if an update to VTRAN ®
provides support for a new statement not currently defined in VUI). If this occurs, simply copy the
updated binary we provide in the $S3_ROOT directory as you did for initial installation.
2.5 Requirements
The requirements for running VUI are minimal – any system which is configured to run VTRAN ® will
be sufficient. VTRAN® version 9.4 or higher is recommended. Although earlier versions will work in
many cases, VUI contains a number of parameters and statements specific to newer VTRAN ® releases.
VUI will still run if an older version of VTRAN® is detected, but a warning will be displayed to remind
users that a newer version is recommended. Similarly you can run VUI without VTRAN ® being
installed at all, in which case you can create and save command files but cannot run them through
VTRAN®, and other features will also be unavailable (e.g. listing the available pins in an input vector
VUI® User Guide [Release 10.0, revision 100]
file). Please note that running VUI in this way is not recommended.
You can verify your version of VTRAN ® at any time within VUI by displaying the “About Box”,
available from the Help menu.
DFTView® release 4.0 is required, but for best results we recommend upgrading to DFTView ® release
4.1.2 or higher (Section 4.2.6).
VCAP® release 2.3.1 or higher is required when using its integrated data analysis features during
cyclization of VCD and EVCD files (Section 7).
VUI® User Guide [Release 10.0, revision 100]
3 INVOKING VUI
The VTRAN® User Interface is typically launched without any command line arguments:
vui
This will launch the application and present you with an initial configuration form as shown here:
Begin by selecting the input and target formats you want, and select an input file and a name for your
output file(s).
You will notice that the INPUT_TIMING_FILE field is disabled while the
VUI® User Guide [Release 10.0, revision 100]
TARGET_TIMING_FILE field is enabled – these will only be active if the input or target format you
select requires it (for example, with the Verigy 93000 or Teradyne FLEX formats).
By default the VUI will assign a temporary directory for VTRAN ® to use. This will be a hidden
directory which will be automatically created as-needed in the current working directory, named
./.s3tmpdir. If you have set an S3_TMPDIR environment variable for VTRAN ® already, the VUI
will preferentially use this. You can blank out the TMPDIR field and VTRAN ® will then will write
temporary files in the current working directory. You may also change the default TMPDIR to
something else, for example /tmp. If you do specify an alternate temporary directory make sure that
any parent already exists and is writable, if not VUI will prevent you from continuing to the next page
until this is fixed (the temporary directory will be created if it doesn't already exist). (Refer to section
1.3.6.2, “Temporary Files” in the VTRAN® User Guide for additional information).
The choices you select on this page will then automatically customize each following form page to only
prompt for inputs related to the formats you choose. This whittles down the large pool of statements
and parameters that VTRAN® supports so that you need only be concerned with the appropriate ones.
In addition, where applicable the VUI will populate fields with appropriate default values on your
behalf, again the goal being to simplify the process of generating a command file for VTRAN ®. When
you have finished selecting the formats and other settings click the “Continue” button to display the
next form, the OVF Block.
Warning! If you continue on and set values and/or change defaults etc. on subsequent
form pages, please be aware that if you return to this page and change either format, VUI
will reset the entire application (all custom data entries will be lost). This operation is
required to purge any incompatible statements or parameters before reconfiguring each
form page (which now may well be different).
VUI® User Guide [Release 10.0, revision 100]
3.1 Running VUI for the First Time
The first time you run VUI, the Context-Sensitive Help window will automatically be displayed for
you. In addition the size and position of this window is stored in the preferences file when you exit the
VUI application (the preferences file can be found at ~/.sourceiii/vui.preferences, and note
that if you delete it, it will be re-created automatically for you the next time VUI runs). The VUI will
also “remember” if the Context-Sensitive Help window was visible the last you exited the application,
and if so it will re-display it for you.
It is highly recommended that you avail of this feature often to help you quickly access the information
necessary to understand the many options which the VUI forms provide.
You can also access the Context-Sensitive Help window (Section 6.1) any time from the applications
Help menu.
VUI® User Guide [Release 10.0, revision 100]
3.2 Supported Formats
VUI supports a subset of all the interfaces and formats which VTRAN ® can translate. If you don't see
your interface or format listed in the Initial Setup page on the VUI, then it is not supported as of yet.
We are busily adding support for additional interfaces, and each new VUI version we release will
support more. If you want to a specific VTRAN® interface which is not currently supported by the VUI
let us know at [email protected] and this will help us prioritize which interfaces to implement. A list
of currently-supported interfaces in the VUI is shown in this table – VUI will allow you to generate
command files to convert any of the listed input interfaces to any of the listed targets:
Input Interfaces
Target Interfaces
Advantest T2000
Advantest T2000
Chroma
Chroma
STIL
STIL
SVF
SVF
TDL_91
TDL_91
Teradyne Catalyst
Teradyne Catalyst
Teradyne FLEX
Teradyne FLEX/ultraFLEX/iFLEX
Teradyne J750
Teradyne J750/J750+
Toshiba TSTL2
Toshiba TSTL2
Verigy (HP) 93000
Verigy (HP) 93000
WGL
WGL
FSDB (Synopsys)
new!
EVCD
EVCD
VCD
VCD
Verilog Testbench
VHDL Testbench
VUI® User Guide [Release 10.0, revision 100]
4 VUI FORMS
The VUI forms allow the user to configure any statement or parameter which VTRAN ® supports.
However, the vast majority of these fields are optional and can remain empty. In addition, sensible
default values are provided wherever necessary, and novice users are encouraged to use these to their
advantage – simply select input and output files, provide the necessary file names, and use the provided
defaults to generate their your VTRAN® command files.
Each form in the VUI consists of a number of standard fields (input boxes, radio buttons, menus etc.).
In addition to these standard field types the multi-line text entry widget in VUI includes a green
“expand” icon just to the right:
If you click this icon a new, larger scrollable text editing window will appear. This window can be resized and is useful when entering potentially a lot of text. As soon as you close this window the
contents are transferred back into the original text widget.
VUI® User Guide [Release 10.0, revision 100]
4.1 External Editors
For finer control, VUI supports using an external text editor in place of this built-in editor (only
available for the multi-line input widgets as shown above).
To use an external editor set the
VUIEDITOR environment variable to the ASCII text editing program of your choice such as NEdit or
gVim. That editor will be launched in place of the test input window, and when you save and quit this
external editor your changes will be placed back into the original text widget. For example to use gVim
you would set your editor as follows:
export VUIEDITOR=gvim
(Bourne shell users)
setenv VUIEDITOR gvim
(C shell users)
-or-
VUI has been tested with various editors such as gVim, Emacs and NEdit. Make sure the editor you
wish to use is already installed in your system.
Note: This is not a Word Processor. Your external text editor must save output files in
plain ASCII text and must have a graphical user interface (e.g. gVim, or XEmacs).
If you wish to use a terminal-based editor, you can launch it inside an Xterm like so (note the required
quotes):
export VUIEDITOR='xterm -e vim'
(Bourne shell users)
setenv VUIEDITOR 'xterm -e vim'
(C shell users)
-or-
Note: Using an external editor is not currently recommended when using the VUI/VCAP
interface (Section ).
VUI® User Guide [Release 10.0, revision 100]
4.2 Form Layout
There are currently 5 separate form pages in the VUI. Each one has a specific function and together
they help the user build a valid VTRAN® command file.
4.2.1 Initial Setup Form
This form contains the fields discussed in the Invoking VUI section of the manual. The purpose of the
form is to allow the user to configure some global parameters which will impact the selections
available on subsequent pages. At any time the user can return to this page and change, for example
the name of the input file. Note that any changes to the input or target format will effectively reset the
form, as different fields and default values will be applied.
4.2.2 OVF_Block Form
This form corresponds to the OVF BLOCK section of the VTRAN ® command file. It contains all
applicable statements which can be inserted into the OVF BLOCK, and based on the declared input
format, the relevant input parameters will be displayed here also in a collapsible frame as shown here:
VUI® User Guide [Release 10.0, revision 100]
Fields which are fully incompatible with the selected input or target formats will not be displayed at all.
VUI® User Guide [Release 10.0, revision 100]
4.2.3 PROC_Block Form
Statements specific to the command file PROC BLOCK are represented on this form. No specific
input or target format parameters are to be found here, however the format you declare in the Initial
Setup form can change which fields are visible on this form.
4.2.4 TVF_Block Form
The form allows the user to set values for VTRAN ® statements specific to the TVF BLOCK section of
the command file. It also includes a collapsible frame similar to the OVF_Block form, this time
presenting the target parameters specific to the selected target format.
4.2.5 Preview Form & Launching VTRAN®
This final page presents a text window which displays the current command file and allows editing for
last-minute changes, as shown on the next page.
Note: It is important to note that while you can edit the contents of the preview window
before passing the resulting command file to VTRAN®, these changes are not propagated
back to the fields in the previous pages. For permanent changes go back to the
corresponding page in the VUI and set your changes there.
VUI® User Guide [Release 10.0, revision 100]
Below this preview you'll find a “Run VTRAN” button which will immediately pass the command file
as displayed, along with any input files you have configured, directly to VTRAN ®, and will display the
output of the VTRAN® run in a separate window (see next page):
VUI® User Guide [Release 10.0, revision 100]
A green status bar at the bottom of this window indicates that VTRAN ® ran successfully. If VTRAN®
encounters a problem during the translation this status bar will be shown in red, and the cause of the
error will be displayed.
4.2.6 Launching DFTView®
The VTRAN® results window will also present a “Display in DFTView” button, which becomes
enabled any time the VTRAN ® execution was successful and output file(s) were generated. For
supported target formats (currently STIL, WGL, Verigy 93000 and Teradyne FLEX), just click this
button to immediately display your translated vector file. If DFTView ® is not installed or not detected
by VUI, clicking on the “Display in DFTView” button will direct you to the Source III site for more
details on DFTView® and on how to get a copy for evaluation.
VUI® User Guide [Release 10.0, revision 100]
DFTView® is a vector file visualization application designed by Source III which provides a text view
of the vector file along with a corresponding waveform display by interfacing with nWave from
Springsoft (part of their Verdi system) or the open source GTKWave viewer. This screen shot shows a
successfully translated vector file displayed in DFTView® with GTKWave:
For more information consult the DFTView ® User Guide, available from the Source III website at
http://www.sourceiii.com/product-dftview.php
VUI® User Guide [Release 10.0, revision 100]
4.3 Navigation and Validation
Each page has a “Continue »” and “« Back” button displayed along the bottom for sequential
navigation between each form. Clicking “Continue »” on the OVF_Block page will advance to the
PROC_Block, and so on (you can also use the similarly-named menu entries from the Edit menu).
Before advancing to the next page however, the entries on the current page are first validated. If there
are any problems detected, a pop-up dialog box will alert the user to the problem, and a warning or
error icon will be displayed alongside the specific field in which the issue occurred. If just one single
error or warning is detected, details on the issue will be displayed immediately. For warnings, the
dialog box will present the option to “Cancel” and remain on the form to address the issue, or “Ok” to
disregard the warning and proceed. A single error is similarly displayed, except that you cannot
advance to the next form page until the error is addressed (in this case click the “Ok” button to dismiss
the error dialog).
VUI® User Guide [Release 10.0, revision 100]
When several errors and/or warnings are detected, each field is highlighted accordingly, and a summary
message is displayed. You can now dismiss the message as above, and now click on an error or
warning icon alongside any highlighted field to see details on that specific field. If all reported issues
are warnings (no errors) you can again click the “Ok” button in the initial pop-up and thereby ignore all
the warnings.
If you ignore a warning, you can navigate to the next form. If however you return to the form in which
the warning occurred, and again click the “Continue »” button, the warning(s) will again be displayed.
While warnings are not critical, they may well impact the final output from VTRAN ® and you are
encouraged to attempt to resolve them before launching VTRAN®.
VUI® User Guide [Release 10.0, revision 100]
VUI also provides a “direct navigation” feature – you may for example wish to skip the OVF_Block
and Proc_Block forms and go straight to configuring the TVF_Block form. You can jump directly to
your preferred page via the Edit menu – in the example above you would go to the main application
menu and select Edit→Configure TVF_Block.
Note that validation of the current form is still
performed as described above before switching to your selected form.
VUI® User Guide [Release 10.0, revision 100]
5 SAVE/RESTORE PARAMETERS
The most common work flow when using VUI is to launch the application, configure the parameters to
your specification, and then either launch VTRAN ® directly or save the command file and use it to
launch VTRAN® in the usual fashion, perhaps by moving the input files and command file to a batch
processing system. However this does not mean it is the only way to do things.
VUI provides a parameter save/restore feature. At any time you may elect to save the parameters you
have entered so far so that you can finish up and return to the application at a later time. The parameter
file you save will have a .vtparam extension automatically added to it. This file will contain the
current state of the VUI application – all the parameters and settings you have configured, and will also
keep track of which form was currently displayed when you save the parameters file. When you
restore this file, either via the File → Restore menu option, or by passing the parameter file to VUI on
the command line with
vui --param yourfile.vtparam
the VUI will be placed back into the exact same state as it was when you originally saved the parameter
file.
VUI® User Guide [Release 10.0, revision 100]
6 ADVANCED FEATURES
6.1 Context-Sensitive Help
VUI provides a context-sensitive help function within the application. From the main menu just select
Help → Context-Sensitive Help to open the help viewer. As you move your mouse in the main VUI
application window, any time the pointer moves over a form field, the relevant help information will be
displayed in the help viewer.
Note: at any time you can temporarily 'lock' your selection by holding down the Shift key while
VUI® User Guide [Release 10.0, revision 100]
moving your mouse. This allows you to move the mouse pointer away from the main application
window, for example to interact with the scroll bar in the help browser, without accidentally moving
over a different field and thereby changing the information in the help viewer.
You will see the
padlock icon change to “closed” and go red in color.
To keep the context-sensitive help entry locked top your desired entry, click the padlock icon (whether
already temporarily locked or not) and it will change to “closed” and go green in color. You can now
release the Shift key and navigate around in the VUI as much as you like – the entry will not be
updated until you click the padlock icon again to unlock it.
VUI® User Guide [Release 10.0, revision 100]
•
Black:
Updates to provide details on whatever field/control your mouse pointer is over
•
Red:
Temporarily “locked” to a specific entry until you release the <Shift> key.
•
Green:
Permanently “locked” to a specific entry until you clock on the icon to release it.
We strongly recommend that you regularly avail of the contextual help feature which will help you
understand the many VTRAN® statements and parameters supported by the VUI.
6.2 Field Input Restrictions
VUI understands what types of data can be provided for each VTRAN ® statement and parameter.
Using this information it will restrict certain fields, for example to only accept numerical values. If you
attempt to type a letter into such a field it will silently rejected.
6.3 Field Interactions
In a similar vein, VUI also maintains a matrix of VTRAN ® statements and parameters which are
incompatible. Depending on the field and the reason for this incompatibility you will see this effect in
one of two ways. In some instances setting a value in a field will disable or enable another related
field. For example, for most target formats, setting the -EXTENDED_HEADER field to “On” will
enable the USER_INFO field just below it, while setting it “Off” will disable the field (making it readonly so that it cannot be edited). When you see a field become grayed out you know it has been
disabled.
In other instances, a field can be locked to a certain value – the field remains active (not disabled) but
the contents are displayed in blue, In addition, a small padlock icon is displayed alongside the locked
field. Clicking on this padlock will reveal the reason why the field is locked (usually because of the
value of a different field). Locked fields cannot be edited:
VUI® User Guide [Release 10.0, revision 100]
VUI® User Guide [Release 10.0, revision 100]
6.4 Pin Selection
Some fields in the VUI forms use pin names, which can be entered by hand as with any other field.
However once you have specified an input file in the initial form page, you can at any time view the
pins declared in this input file by selecting Tools → Show Input File Pins from the application menu.
This will display a list of pins in the input file. If you choose, you can select one or more pins and
copy them (either via the Edit → Copy menu in the pin browser window, by right-clicking to get a
contextual menu and selecting “copy”, or by using the standard Ctrl-C shortcut). You may then paste
the selected pins directly into any compatible form field.
VUI® User Guide [Release 10.0, revision 100]
7 CYCLIZING VCD AND EVCD FILES
7.1 Introduction
VTRAN® supports translating event-based (print-on-change, or POC) format files (VCD and EVCD)
into cycle-based ATE formats. It collects state data from the original (E)VCD file, cyclizes it, applies
user-specified processing, maps state characters between the two formats, applies target timing, and
generates a Target Vector File. It is driven by a command file generated by the user with the optional
support of the timing analysis features of another Source III application named VCAP® (release 2.3.1
or higher required for these features).
Cyclization can use any one of four different approaches:
•
AUTO_ALIGN:
The Output Timing values are applied during the cyclization process; it uses the Output Timing
PINTYPE statements to automatically calculate the correct sample time for each signal in the
input POC file. The cycle parameter specifies the time step to which the vector data is to be
collapsed.
•
ALIGN_TO_CYCLE:
This command tells VTRAN® the number of print-on-change vectors associated with each
cycle-based vector in terms of time. VTRAN® looks for state data within each cycle using the
sample time specified for each signal. Separate (possibly different) sample times in the cycle
can be specified for each signal.
•
ALIGN_TO_SIGNAL:
This command tells VTRAN® to begin each cycle in terms of a specific transition type on a
reference signal. The sample (strobe) points for all signals are determined relative to this
VUI® User Guide [Release 10.0, revision 100]
transition. VTRAN® allows for the specification of separate (possibly different) sample times
in the cycle for each signal.
•
TEMPLATE_CYCLIZATION:
The POC vector patterns are cyclized with dynamically changing cycle types (timesets) such as
a init, run, and wait. It works by identifying (matching) predefined cycle types in the OVF,
collecting meaningful state data, and then integrating this with user defined test specifications
for final output in the TVF.
Tip: More information on each of these commands is available in the VTRAN ® User
Guide (Chapter 4). There are also several Application Notes on the Source III website at
http://sourceiii.com/support.php which provided detailed background and discussion on
this very topic of Cyclization of Print-on-Change Vectors.
With AUTO_ALIGN and ALIGN_TO_CYCLE, the vector analysis tool VCAP ® can be used to
determine suitable data to pass to VTRAN ®. It is run in a similar fashion to VTRAN ® – a command
file is prepared and passed to the application along with the input file to be analyzed. The VCAP
software bundle and User Guide are available from the Source III website.
The VUI streamlines this entire process by passing the correct parameters to VCAP ®, capturing the
results and then automatically preparing the correct AUTO_ALIGN or ALIGN_TO_CYCLE
parameters for you, along with the output timing PINTYPE statement. With a few mouse clicks you
can have your POC file analyzed and cyclized for you.
Depending on whether you select
AUTO_ALIGN or ALIGN_TO_CYCLE, the VCAP ® results will be presented slightly differently, and
different fine-tuning options will be available.
The following diagram shows how the VUI intergates VTRAN ®, VCAP® and DFTView® into an
organized workflow for successful cyclization of event-based input files:
VUI® User Guide [Release 10.0, revision 100]
VUI® User Guide [Release 10.0, revision 100]
7.2 AUTO_ALIGN
When you select AUTO_ALIGN in the PROC_Block form you will see a button labeled “Invoke
VCAP”. Click this button to configure and execute VCAP ® for you, and the results will be presented
like this:
VUI® User Guide [Release 10.0, revision 100]
The “Preview PINTYPE” panel shows the cycle based timing format observed by VCAP ® in the
original print-on-change simulation file, formatted as VTRAN-compatible PINTYPE statements. When
added to the VTRAN® command file, these statements will be used to specify the target tester program
timing. In this example, HOLDA, PCHK, PLOCK, ADS, and FERR are output signals of the device.
PINTYPE STB specifies the target test program strobe time. This value is based on the max rise delay
and max fall delay observed in the simulation source file on a per signal basis. "PINTYPE RZ CLK
@20,33" specifies a return-to-zero format on signal CLK with a rise time @ 20ns and a fall time @ 33
ns.
VUI® User Guide [Release 10.0, revision 100]
Supported PINTYPE formats include STB, NRZ, RZ, RO, RZ2X, RO2X, RZ4Z, and RO4X.
Bidirectional signals have 2 PINTYPE statements: one for output behavior and one for input behavior.
There is no need to provide additional information when using AUTO_ALIGN.
VTRAN®
automatically calculates the correct sample time for each signal from the PINTYPE statement.
It might be that the simulation data is inconsistent. For example, when an input signal behaves in a
non-return-to-zero manner but there is more than one 0→1 or 1→0 edge time. Signals of this type are
displayed in bold and displayed in the lower “Configure Pins” panel. When a signal is selected, VUI
highlights the signal and then lists every state transition observed on this signal in the simulation source
the pane titled "Configure Pins". You can click on a different transition to see it applied to the
corresponding PINTYPE statement in the upper panel. You can also fine-tune the timing parameters
for any individual PINTYPE entry by double-clicking on the timing number (highlighted in blue), and
then entering any timing value you wish.
You can right-click any PINTYPE statement to call up a contextual menu. In most cases you can reset
the values of the signal (only if edited, if the value hasn't been changed since VCAP ® has been run, this
option will be greyed out). You can also reset ALL changed PINTYPE statements from the contextual
menu.
In some cases the PINTYPE may show up as un unknown PINTYPE (UNK). VTRAN® will reject
these entries so you cannot use the data until you assign a PINTYPE yourself (again by right-clicking
on the PINTYPE statement of signal in question). Once you assign a PINTYPE, the entry will change
and present you with a template statement with the correct number of edge times, but all set to zero.
You must manually edit these by double-clicking each one, to set the desired timing.
Once everything is configured to your liking, click the “Apply VCAP Data” and the PINTYPE
information will be instantly transferred to the applicable field in the VUI main window, and you can
continue to the TVF_Block page and then to preview your final VTRAN ® command file and then click
the 'Run VTRAN' button to execute VTRAN. If DFTView ® is installed you can then click the 'Display
VUI® User Guide [Release 10.0, revision 100]
TVF' button to immediately view your translation results.
Tip: You'll notice that the “PINTYPE” field will contain an optimized form of what you
saw in the “Preview ALIGN_TO_CYCLE” pane, but rest assured the data will be the
same. This optimization matches pintypes and timing parameters and is applied to
ensure VTRAN® processed them as efficiently as possible. The PINTYPE data shown in
the screen shot above would include PINTYPE statements optimized to: PINTYPE STB
HOLDA @ 0; PINTYPE STB PCHK PLOCK ADS FERR @ 33; (extra white-space will be
included for clarity, but this will be ignored by VTRAN®).
7.3 ALIGN_TO_CYCLE
When using ALIGN_TO_CYCLE, the "Preview ALIGN_TO_CYCLE" pane is added to the VCAP ®
Analysis display as shown below. It contains a list of signals and where they are to be sampled relative
to the start of cycle. This data has been derived by the VUI VCAP ® Analysis tool from the PINTYPE
statements generated by VCAP® and is usually set to the beginning or middle of the active (pattern
driven) portion of the waveform. For example, CLK @ 26 comes from (20+33)/2, where 20 is the rise
edge and 33 is the falling edge of this RZ signal.
VUI® User Guide [Release 10.0, revision 100]
Signals with inconsistent behavior in the original simulation are bolded and their behavior is detailed in
the Observed Timing section. Unlike AUTO_ALIGN mode, this information is presented for reference
only, i.e. clicking on transitions in thie pane will not alter the PINTYPE statements, however you can
still update the individual times by double-clicking them to edit, and this applies to both “Preview
PINTYPE” and “Preview ALIGN_TO_CYCLE” panes.
As with AUTO_ALIGN, once everything is configured to your liking, click the “Apply VCAP Data” to
VUI® User Guide [Release 10.0, revision 100]
have the relevant VUI fields filled in with the final statements.
Tip: During the cyclization process you can (and indeed for VCD format files, must)
assign directions to all input, output and bidirectional pins using the
INPUTS/OUTPUTS/BIDIRS field in the VUI's OVF_Block page. Please note that this
may affect the number of soft miscompares (where one state value is an X or Z) you might
see in DFTView®. For best results try comparing files with similar treatment of
bidirectional signals: if your original EVCD file has merged bidirs, make sure your
output file is displayed in DFTView® with merged bidirs (Section 4.2.6). As this is the
more common configuration, note that when launching DFTView from the VUI, bidirs
will is most be cases be displayed as merged traces.
7.4 Discussion
While this chapter deals specifically with the VUI interface and how it integrates VCAP ® into the
cyclization workflow, the topic of cyclization is much more involved. The contexual help feature of
the VUI (Section 6.1) will help you understand the VCAP ® interface features of the VUI, but if you are
interested in learning more about cyclization and how the VTRAN® Tool suite can assist you, we
recommend you read the application notes which delve into these topics, freely available from the
support section of the Source III website.
The application note entitled VCD/EVCD-to-ATE Translations using VTRAN® Tool Suite gives a
detailed treatment not just of the VUI/VCAP ® features as described here, but of the entire process
including these features (http://www.sourceiii.com/notes-cyclize-VCD-ATE.html).
VUI® User Guide [Release 10.0, revision 100]
Source III, Inc.
3940 Park Drive, Suite 20-342
El Dorado Hills, CA 95762
(916) 941-9403
www.sourceiii.com
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement