Using the Help System Help Volume

Using the Help System Help Volume
Help Volume
© 1992-2000 Agilent Technologies. All rights reserved.
System: Help On Help
Using the Help System
The online help system is organized into topics that you display in a
help window on your screen. Help is directly accessible from tools, and
can be browsed or searched via index entries.
Within a Help Volume:
See Also
•
Choose an underlined hyperlink (see page 2) (active word or phrase)
within the help text.
•
Select a dash-underlined word such as trigger for the definition of a term.
•
Select the Search->Index (see page 10) pulldown in the help window to
search for a keyword in one or more help volumes.
•
Using Help- Table of Contents (see page 8)
•
Main System Help (see the Agilent Technologies 16700A/B-Series Logic
Analysis System help volume)
2
3
4
Contents
Using the Help System
1 Using the Help System
Using Help - Table Of Contents
References
8
8
Navigating the Help System
9
To List Previous Topics 9
To Return to the Home Topic 10
Searching for Index Entries 10
Search Volume Selection Dialog Box
13
Mouse Actions and Keyboard Commands
Help Menu Shortcut Keys
Printing A Help Topic
14
17
18
General Help Window 19
Quick Help Window 20
Help Error Messages
21
About Help Volumes
23
Glossary
Index
5
Contents
6
1
Using the Help System
7
Chapter 1: Using the Help System
Using Help - Table Of Contents
Using Help - Table Of Contents
•
“Navigating the Help System” on page 9
•
“Searching for Index Entries” on page 10
•
“Printing A Help Topic” on page 18
•
“General Help Window” on page 19
•
“Quick Help Window” on page 20
•
“Help Error Messages” on page 21
•
“About Help Volumes” on page 23
•
Other Help Resources (see the Agilent Technologies 16700A/B-Series
Logic Analysis System help volume)
References
For a list of available help resources, see Other Help Resources (see
the Agilent Technologies 16700A/B-Series Logic Analysis System
help volume)
8
Chapter 1: Using the Help System
Navigating the Help System
Navigating the Help System
To Return to a Previous Topic
The Backtrack command returns to the previous topic. You can revisit
each topic you have viewed.
1. Click the Backtrack button.
Or, choose Backtrack from the Navigate menu.
2. Repeat Backtrack to go back as many steps as you need.
NOTE:
The Backtrack command is available in a pop-up menu in a general help
window (see page 19).
To List Previous Topics
The History dialog box lists topics and help volumes that you have
displayed.
1. Select the History button.
Or, choose History from the Navigate menu.
2. Select the topic title or help volume name that you want to return to. You
may have to scroll the list of titles to find the one you’re looking for.
3. Repeat step 2 for as many topics as you want to revisit.
4. Select Close when you’re done.
9
Chapter 1: Using the Help System
Navigating the Help System
To Return to the Home Topic
The Home Topic command returns to the top-level topic, or the
beginning of the help volume.
•
NOTE:
Choose Home Topic from the Navigate menu.
Or, select the first title in the topic tree, which is the home topic. You may
need to scroll to the top of the list.
The Home Topic command is available in a pop-up menu in a general help
window (see page 19).
Searching for Index Entries
NOTE:
Selecting "All Volumes" will search the entire help system instead of just the
current volume.
10
Chapter 1: Using the Help System
Navigating the Help System
One or more help volume indexes can be searched using these steps:
1. Access the Index Search dialog by selecting the Search->Index pulldown
in the main help window.
2. To set a search pattern, select one of:
NOTE:
•
Complete Index - lists all the index entries found for the volume or
volumes you choose.
•
Entries with: - allows you to type a word or phrase to search for in the
index entries of the volume or volumes you chose. The search is not
case sensitive.
Since phrases may be difficult to match, use a single word when possible in
searching for index entries.
3. To set the scope of the search, select one of the following:
NOTE:
•
Current will search for index entries only in the volume you are
currently viewing.
•
All Volumes will search for index entries in all available help volumes.
•
Selected will search for index entries in the volumes that you have
selected in the Select Volumes... (see page 13) dialog. If you select
volumes and close the dialog box, the Select Volumes... button can be
used to reopen the list of your choices.
Entering a search pattern before selecting "All Volumes" (step 2 before step 3)
may result in a faster search.
4. Press Return or select Start Search
11
Chapter 1: Using the Help System
Navigating the Help System
The Index Display Area lists the index entries that were found.
Index entries use these prefixes:
•
(-) indicates all the entries are displayed. To shrink a list, select the
item. The (-) changes to a (+).
•
(+) indicates an entry can be expanded. For example, +2 indicates
there are two more entries. Select the item to display the additional
choices. The (+) changes to a (-).
5. Select an index entry to display the associated help topic in the main help
window.
NOTE:
Arrange the search dialog box on your screen so that it does not obscure the
main help window. As you select in the Index Search dialog box, the
corresponding topic will appear in the main help window.
12
Chapter 1: Using the Help System
Navigating the Help System
Search Volume Selection Dialog Box
The Search Volume dialog box lists help volumes available on your
system. You can select one or more volumes which then represent the
scope of your search. To deselect a volume, select the volume name
again.
From the Index Search dialog box, use the Select Volumes... button to
reopen the list of choices.
13
Chapter 1: Using the Help System
Mouse Actions and Keyboard Commands
Mouse Actions and Keyboard Commands
See also “Help Menu Shortcut Keys” on page 17
Mouse Actions
Action
Click mouse
button 1
Hold mouse
button 1 and
drag
Behavior
Selects a hyperlink and displays the content in the current
help window.
Copies selected text to the clipboard.
Control+button
1
Selects a hyperlink and displays the content in a new
window.
NOTE:
Shift+button 1
Same as above.
Alt+button 1
Same as above.
If your keyboard does not have an Alt key ask your system administrator to
identify the corresponding key or refer to your system documentation.
Keyboard Commands
To use your keyboard to display topics or to scroll data, first move the
window selection highlight to the appropriate area of the help window,
such as the topic tree or topic display area. Press the Tab key to move
the selection highlight forward. To move the highlight backward, press
Shift+Tab.
You can use these keyboard commands in the following help window
areas:
•
Topic Display Area
Key
14
Behavior
Chapter 1: Using the Help System
Mouse Actions and Keyboard Commands
Up Arrow or
Left Arrow
Move highlight to previous hyperlink
Down Arrow or
Right Arrow
Move highlight to next hyperlink
Control+/
Select entire topic
Control+&\
Deselect entire topic
Control+C
Copy selection to clipboard
Control+V
Paste selection to clipboard
Return
Display help topic for the selected hyperlink
Control+Return Display help topic for the selected hyperlink in a new
window
Shift+F10
•
Displays the pop-up menu
Help Window
Key
Behavior
Escape
Cancels an operation such as scrolling or resizing.
Otherwise, if there is no current operation, closes the help
window.
Alt key+Up
Arrow
Moves window to top of window stack.
Alt key+Down
Arrow
Moves window to bottom of window stack.
•
Buttons
Press Tab to move the selection highlight to the desired button and press
Return.
•
Vertical Scroll Bars
Key
Cursor Movement
Up Arrow
Scroll up
Down Arrow
Scroll down
Control+Up
Arrow
Scroll to top of list or topic
15
Chapter 1: Using the Help System
Mouse Actions and Keyboard Commands
Control+Down
Arrow
Scroll to end of list or topic
PageUp or
Previous
Scroll one screen up
PageDown or
Next
Scroll one screen down
•
Horizontal Scroll Bars
Key
Cursor Movement
Left Arrow
Scroll left
Control+Left
Arrow
Scroll to leftmost edge of data
Right Arrow
Scroll right
Control+Right
Arrow
Scroll to rightmost edge of data
16
Chapter 1: Using the Help System
Help Menu Shortcut Keys
Help Menu Shortcut Keys
Use these shortcut keys to activate Help menu commands:
NOTE:
Command
Shortcut Key
Print
Control+P
Close
Alt+F4
Copy
Control+C
Index
Control+I
Backtrack
Control+B
HomeTopic
Control+H
If your keyboard does not have an Alt key, ask your system administrator to
identify the corresponding key or refer to your system documentation.
17
Chapter 1: Using the Help System
Printing A Help Topic
Printing A Help Topic
You can print an individual topic, a Table of Contents and Index, or an
entire help volume. Printed topics are text-only.
1. Choose Print from the File menu.
( In a Quick Help window, select the Print button.)
•
Optional. Enter the number of copies to print (default is 1) and select
Return.
•
Optional. Select the paper size button to display your choices.
Letter
8.5 x 11 in
Legal
8.5 x 14 in
Executive
7.25 x 10.5 in
A4
210 x 297 mm
B5
182 x 257 mm
1. Choose the topic or topics to print.
18
•
Current Topic — prints only the displayed topic (the default)
•
Current and Subtopics — prints the current topic and any subtopics it
contains
Chapter 1: Using the Help System
Printing A Help Topic
•
Table of Contents and Index — prints the Table of Contents and Index
of the help volume
•
Entire Volume — prints all topics in the help volume, the Table of
Contents and Index
2. Select Print.
General Help Window
A general help window has a menu bar, a topic display area, and
optionally horizontal and vertical scroll bars.
Underlined text are hyperlinks which allow jumping to other topics.
A general help window has these Help Buttons:
Navigate>Backtrack
Returns to the previous topic.
right-click>Backtrack
Returns to the previous topic.
19
Chapter 1: Using the Help System
Printing A Help Topic
Navigate>HomeTopic
Navigate>History
Search->Index
Returns to the top level of the current volume.
Lists topics and help volumes that you visited and enables
you to redisplay a topic.
Opens a help index that you can search to find help on a
subject.
Quick Help Window
A quick help window is a streamlined help window. It has a topic
display area and one or more dialog buttons.
Button
Action
Close
Closes the quick help window
Backtrack
Goes to the previous topic
Print
Displays a Print dialog box
Help
Displays Help on the quick help window
20
Chapter 1: Using the Help System
Help Error Messages
Help Error Messages
•
If the Help System cannot find a help volume, it displays this message:
Possible causes are:
•
The application's help volume is not installed
•
Your desktop help search path does not include the directory where the
help volume has been installed.
Ask your system administrator to verify that the application's help
volume is properly installed and that your help search paths are set
correctly.
•
If the Help Viewer cannot find the ID of a help topic in a help volume, it
displays a message like this:
Possible causes are:
•
A hyperlink points to a topic that does not exist or whose ID has been
changed
•
A hyperlink points to a valid ID in another help volume that is not
installed
Ask your system administrator to verify that the application's help
volume is properly installed and that your help search paths are set
correctly.
21
Chapter 1: Using the Help System
Help Error Messages
•
If the run-time help volume (.sdl file) has an error, the Help Viewer
displays this message:
Possible causes:
•
The run-time help volume may be incomplete or contain an error.
Ask your system administrator to check the help volume.
22
Chapter 1: Using the Help System
About Help Volumes
About Help Volumes
The online help system is organized into many help volumes, each
containing several topics. The available system help volumes can be
viewed in the Select Volume... (see page 13) dialog in the “Searching
for Index Entries” on page 10.
Additional help volumes may be added to your system when optional
products or system upgrades are installed.
Hyperlinks (underlined, active words) can reference topics in the same
volume or a separate volume. A hyperlink to a separate volume is called
a cross-volume link. It is not obvious that you have taken a crossvolume link. However, if you have taken a cross-volume link then the
Hometopic command will return to the top of the new volume, not the
original volume.
23
Chapter 1: Using the Help System
About Help Volumes
24
Glossary
absolute Denotes the time period
or count of states between a captured
state and the trigger state. An
absolute count of -10 indicates the
state was captured ten states before
the trigger state was captured.
acquisition Denotes one complete
cycle of data gathering by a
measurement module. For example,
if you are using an analyzer with
128K memory depth, one complete
acquisition will capture and store
128K states in acquisition memory.
analysis probe A probe connected
to the target microprocessor. It
provides an interface between the
signals of the target microprocessor
and the inputs of the logic analyzer.
Also called a "preprocessor".
analyzer 1 In a logic analyzer with
two machines, refers to the machine
that is on by default. The default
name is Analyzer<N>, where N is
the slot letter.
analyzer 2 In a logic analyzer with
two machines, refers to the machine
that is off by default. The default
name is Analyzer<N2>, where N is
the slot letter.
arming An instrument tool must be
armed before it can search for its
trigger condition. Typically,
instruments are armed immediately
when Run or Group Run is selected.
You can set up one instrument to arm
another using the Intermodule
Window. In these setups, the second
instrument cannot search for its
trigger condition until it receives the
arming signal from the first
instrument. In some analyzer
instruments, you can set up one
analyzer machine to arm the other
analyzer machine in the Trigger
Window.
asterisk (*) See edge terms,
glitch, and labels.
bits Bits represent the physical logic
analyzer channels. A bit is a channel
that has or can be assigned to a label.
A bit is also a position in a label.
card This refers to a single
instrument intended for use in the
Agilent Technologies 16600A-series
or 16700A/B-series mainframes. One
card fills one slot in the mainframe. A
module may comprise a single card or
multiple cards cabled together.
channel The entire signal path from
the probe tip, through the cable and
module, up to the label grouping.
click When using a mouse as the
pointing device, to click an item,
position the cursor over the item.
25
Glossary
Then quickly press and release the
left mouse button.
clock channel A logic analyzer
channel that can be used to carry the
clock signal. When it is not needed
for clock signals, it can be used as a
data channel, except in the Agilent
Technologies 16517A.
context record A context record is
a small segment of analyzer memory
that stores an event of interest along
with the states that immediately
preceded it and the states that
immediately followed it.
context store If your analyzer can
perform context store
measurements, you will see a button
labeled Context Store under the
Trigger tab. Typical context store
measurements are used to capture
writes to a variable or calls to a
subroutine, along with the activity
preceding and following the events. A
context store measurement divides
analyzer memory into a series of
context records. If you have a 64K
analyzer memory and select a 16state context, the analyzer memory is
divided into 4K 16-state context
records. If you have a 64K analyzer
memory and select a 64-state
context, the analyzer memory will be
divided into 1K 64-state records.
26
count The count function records
periods of time or numbers of state
transactions between states stored in
memory. You can set up the analyzer
count function to count occurrences
of a selected event during the trace,
such as counting how many times a
variable is read between each of the
writes to the variable. The analyzer
can also be set up to count elapsed
time, such as counting the time spent
executing within a particular function
during a run of your target program.
cross triggering Using intermodule
capabilities to have measurement
modules trigger each other. For
example, you can have an external
instrument arm a logic analyzer,
which subsequently triggers an
oscilloscope when it finds the trigger
state.
data channel A channel that
carries data. Data channels cannot be
used to clock logic analyzers.
data field A data field in the pattern
generator is the data value associated
with a single label within a particular
data vector.
data set A data set is made up of all
labels and data stored in memory of
any single analyzer machine or
instrument tool. Multiple data sets
can be displayed together when
Glossary
sourced into a single display tool. The
Filter tool is used to pass on partial
data sets to analysis or display tools.
debug mode See monitor.
delay The delay function sets the
horizontal position of the waveform
on the screen for the oscilloscope and
timing analyzer. Delay time is
measured from the trigger point in
seconds or states.
demo mode An emulation control
session which is not connected to a
real target system. All windows can
be viewed, but the data displayed is
simulated. To start demo mode,
select Start User Session from the
Emulation Control Interface and
enter the demo name in the
Processor Probe LAN Name field.
Select the Help button in the Start
User Session window for details.
deskewing To cancel or nullify the
effects of differences between two
different internal delay paths for a
signal. Deskewing is normally done
by routing a single test signal to the
inputs of two different modules, then
adjusting the Intermodule Skew so
that both modules recognize the
signal at the same time.
don’t care For terms, a "don’t care"
means that the state of the signal
(high or low) is not relevant to the
measurement. The analyzer ignores
the state of this signal when
determining whether a match occurs
on an input label. "Don’t care" signals
are still sampled and their values can
be displayed with the rest of the data.
Don’t cares are represented by the X
character in numeric values and the
dot (.) in timing edge specifications.
dot (.) See edge terms, glitch,
labels, and don’t care.
double-click When using a mouse
as the pointing device, to double-click
an item, position the cursor over the
item, and then quickly press and
release the left mouse button twice.
drag and drop Using a Mouse:
Position the cursor over the item, and
then press and hold the left mouse
button. While holding the left mouse
button down, move the mouse to
drag the item to a new location. When
the item is positioned where you
want it, release the mouse button.
Using the Touchscreen:
Position your finger over the item,
then press and hold finger to the
screen. While holding the finger
down, slide the finger along the
screen dragging the item to a new
27
Glossary
location. When the item is positioned
where you want it, release your
finger.
edge mode In an oscilloscope, this
is the trigger mode that causes a
trigger based on a single channel
edge, either rising or falling.
edge terms Logic analyzer trigger
resources that allow detection of
transitions on a signal. An edge term
can be set to detect a rising edge,
falling edge, or either edge. Some
logic analyzers can also detect no
edge or a glitch on an input signal.
Edges are specified by selecting
arrows. The dot (.) ignores the bit.
The asterisk (*) specifies a glitch on
the bit.
emulation module A module
within the logic analysis system
mainframe that provides an
emulation connection to the debug
port of a microprocessor. An E5901A
emulation module is used with a
target interface module (TIM) or an
analysis probe. An E5901B emulation
module is used with an E5900A
emulation probe.
emulation probe The stand-alone
equivalent of an emulation module.
Most of the tasks which can be
performed using an emulation
module can also be performed using
28
an emulation probe connected to
your logic analysis system via a LAN.
emulator An emulation module or
an emulation probe.
Ethernet address See link-level
address.
events Events are the things you
are looking for in your target system.
In the logic analyzer interface, they
take a single line. Examples of events
are Label1 = XX and Timer 1 > 400
ns.
filter expression The filter
expression is the logical OR
combination of all of the filter terms.
States in your data that match the
filter expression can be filtered out or
passed through the Pattern Filter.
filter term A variable that you
define in order to specify which
states to filter out or pass through.
Filter terms are logically OR’ed
together to create the filter
expression.
Format The selections under the
logic analyzer Format tab tell the
logic analyzer what data you want to
collect, such as which channels
represent buses (labels) and what
logic threshold your signals use.
Glossary
frame The Agilent Technologies
16600A-series or 16700A/B-series
logic analysis system mainframe. See
also logic analysis system.
gateway address An IP address
entered in integer dot notation. The
default gateway address is 0.0.0.0,
which allows all connections on the
local network or subnet. If
connections are to be made across
networks or subnets, this address
must be set to the address of the
gateway machine.
glitch A glitch occurs when two or
more transitions cross the logic
threshold between consecutive
timing analyzer samples. You can
specify glitch detection by choosing
the asterisk (*) for edge terms under
the timing analyzer Trigger tab.
grouped event A grouped event is
a list of events that you have
grouped, and optionally named. It can
be reused in other trigger sequence
levels. Only available in Agilent
Technologies 16715A, 16716A, and
16717A logic analyzers.
held value A value that is held until
the next sample. A held value can
exist in multiple data sets.
immediate mode In an
oscilloscope, the trigger mode that
does not require a specific trigger
condition such as an edge or a
pattern. Use immediate mode when
the oscilloscope is armed by another
instrument.
interconnect cable Short name for
module/probe interconnect cable.
intermodule Intermodule is a term
used when multiple instrument tools
are connected together for the
purpose of one instrument arming
another. In such a configuration, an
arming tree is developed and the
group run function is designated to
start all instrument tools. Multiple
instrument configurations are done in
the Intermodule window.
intermodule bus The intermodule
bus (IMB) is a bus in the frame that
allows the measurement modules to
communicate with each other. Using
the IMB, you can set up one
instrument to arm another. Data
acquired by instruments using the
IMB is time-correlated.
internet address Also called
Internet Protocol address or IP
address. A 32-bit network address. It
is usually represented as decimal
numbers separated by periods; for
example, 192.35.12.6. Ask your LAN
administrator if you need an internet
address.
29
Glossary
labels Labels are used to group and
identify logic analyzer channels. A
label consists of a name and an
associated bit or group of bits. Labels
are created in the Format tab.
line numbers A line number (Line
#s) is a special use of symbols. Line
numbers represent lines in your
source file, typically lines that have
no unique symbols defined to
represent them.
link-level address Also referred to
as the Ethernet address, this is the
unique address of the LAN interface.
This value is set at the factory and
cannot be changed. The link-level
address of a particular piece of
equipment is often printed on a label
above the LAN connector. An
example of a link-level address in
hexadecimal: 0800090012AB.
local session A local session is
when you run the logic analysis
system using the local display
connected to the product hardware.
logic analysis system The Agilent
Technologies 16600A-series or
16700A/B-series mainframes, and all
tools designed to work with it.
Usually used to mean the specific
system and tools you are working
with right now.
30
machine Some logic analyzers allow
you to set up two measurements at
the same time. Each measurement is
handled by a different machine. This
is represented in the Workspace
window by two icons, differentiated
by a 1 and a 2 in the upper right-hand
corner of the icon. Logic analyzer
resources such as pods and trigger
terms cannot be shared by the
machines.
markers Markers are the green and
yellow lines in the display that are
labeled x, o, G1, and G2. Use them to
measure time intervals or sample
intervals. Markers are assigned to
patterns in order to find patterns or
track sequences of states in the data.
The x and o markers are local to the
immediate display, while G1 and G2
are global between time correlated
displays.
master card In a module, the
master card controls the data
acquisition or output. The logic
analysis system references the
module by the slot in which the
master card is plugged. For example,
a 5-card Agilent Technologies 16555D
would be referred to as Slot C:
machine because the master card is
in slot C of the mainframe. The other
cards of the module are called
expansion cards.
Glossary
menu bar The menu bar is located
at the top of all windows. Use it to
select File operations, tool or system
Options, and tool or system level
Help.
message bar The message bar
displays mouse button functions for
the window area or field directly
beneath the mouse cursor. Use the
mouse and message bar together to
prompt yourself to functions and
shortcuts.
module An instrument that uses a
single timebase in its operation.
Modules can have from one to five
cards functioning as a single
instrument. When a module has more
than one card, system window will
show the instrument icon in the slot
of the master card.
module/probe interconnect cable
The module/probe interconnect cable
connects an E5901B emulation
module to an E5900B emulation
probe. It provides power and a serial
connection. A LAN connection is also
required to use the emulation probe.
monitor When using the Emulation
Control Interface, running the
monitor means the processor is in
debug mode (that is, executing the
debug exception) instead of
executing the user program.
panning The action of moving the
waveform along the timebase by
varying the delay value in the Delay
field. This action allows you to
control the portion of acquisition
memory that will be displayed on the
screen.
pattern mode In an oscilloscope,
the trigger mode that allows you to
set the oscilloscope to trigger on a
specified combination of input signal
levels.
pattern terms Logic analyzer
resources that represent single states
to be found on labeled sets of bits; for
example, an address on the address
bus or a status on the status lines.
period (.) See edge terms, glitch,
labels, and don’t care.
pod See pod pair
pod pair A group of two pods
containing 16 channels each, used to
physically connect data and clock
signals from the unit under test to the
analyzer. Pods are assigned by pairs
in the analyzer interface. The number
of pod pairs avalaible is determined
by the channel width of the
instrument.
31
Glossary
point To point to an item, move the
mouse cursor over the item, or
position your finger over the item.
preprocessor See analysis probe.
primary branch The primary
branch is indicated in the Trigger
sequence step dialog box as either
the Then find or Trigger on
selection. The destination of the
primary branch is always the next
state in the sequence, except for the
Agilent Technologies 16517A. The
primary branch has an optional
occurrence count field that can be
used to count a number of
occurrences of the branch condition.
See also secondary branch.
probe A device to connect the
various instruments of the logic
analysis system to the target system.
There are many types of probes and
the one you should use depends on
the instrument and your data
requirements. As a verb, "to probe"
means to attach a probe to the target
system.
processor probe See emulation
probe.
range terms Logic analyzer
resources that represent ranges of
values to be found on labeled sets of
bits. For example, range terms could
32
identify a range of addresses to be
found on the address bus or a range
of data values to be found on the data
bus. In the trigger sequence, range
terms are considered to be true when
any value within the range occurs.
relative Denotes time period or
count of states between the current
state and the previous state.
remote display A remote display is
a display other than the one
connected to the product hardware.
Remote displays must be identified to
the network through an address
location.
remote session A remote session is
when you run the logic analyzer using
a display that is located away from
the product hardware.
right-click When using a mouse for
a pointing device, to right-click an
item, position the cursor over the
item, and then quickly press and
release the right mouse button.
sample A data sample is a portion of
a data set, sometimes just one point.
When an instrument samples the
target system, it is taking a single
measurement as part of its data
acquisition cycle.
Sampling Use the selections under
Glossary
the logic analyzer Sampling tab to tell
the logic analyzer how you want to
make measurements, such as State
vs. Timing.
secondary branch The secondary
branch is indicated in the Trigger
sequence step dialog box as the Else
on selection. The destination of the
secondary branch can be specified as
any other active sequence state. See
also primary branch.
session A session begins when you
start a local session or remote
session from the session manager,
and ends when you select Exit from
the main window. Exiting a session
returns all tools to their initial
configurations.
skew Skew is the difference in
channel delays between
measurement channels. Typically,
skew between modules is caused by
differences in designs of
measurement channels, and
differences in characteristics of the
electronic components within those
channels. You should adjust
measurement modules to eliminate
as much skew as possible so that it
does not affect the accuracy of your
measurements.
state measurement In a state
measurement, the logic analyzer is
clocked by a signal from the system
under test. Each time the clock signal
becomes valid, the analyzer samples
data from the system under test.
Since the analyzer is clocked by the
system, state measurements are
synchronous with the test system.
store qualification Store
qualification is only available in a
state measurement, not timing
measurements. Store qualification
allows you to specify the type of
information (all samples, no samples,
or selected states) to be stored in
memory. Use store qualification to
prevent memory from being filled
with unwanted activity such as noops or wait-loops. To set up store
qualification, use the While storing
field in a logic analyzer trigger
sequence dialog.
subnet mask A subnet mask blocks
out part of an IP address so that the
networking software can determine
whether the destination host is on a
local or remote network. It is usually
represented as decimal numbers
separated by periods; for example,
255.255.255.0. Ask your LAN
administrator if you need a the
subnet mask for your network.
symbols Symbols represent
patterns and ranges of values found
on labeled sets of bits. Two kinds of
33
Glossary
symbols are available:
•
•
Object file symbols - Symbols
from your source code, and
symbols generated by your
compiler. Object file symbols may
represent global variables,
functions, labels, and source line
numbers.
User-defined symbols - Symbols
you create.
Symbols can be used as pattern and
range terms for:
•
Searches in the listing display.
•
Triggering in logic analyzers and
in the source correlation trigger
setup.
•
Qualifying data in the filter tool
and system performance analysis
tool set.
system administrator The system
administrator is a person who
manages your system, taking care of
such tasks as adding peripheral
devices, adding new users, and doing
system backup. In general, the
system administrator is the person
you go to with questions about
implementing your software.
target system The system under
test, which contains the
microprocessor you are probing.
34
terms Terms are variables that can
be used in trigger sequences. A term
can be a single value on a label or set
of labels, any value within a range of
values on a label or set of labels, or a
glitch or edge transition on bits
within a label or set of labels.
TIM A TIM (Target Interface
Module) makes connections between
the cable from the emulation module
or emulation probe and the cable to
the debug port on the system under
test.
timer terms Logic analyzer
resources that are used to measure
the time the trigger sequence
remains within one sequence step, or
a set of sequence steps. Timers can
be used to detect when a condition
lasts too long or not long enough.
They can be used to measure pulse
duration, or duration of a wait loop. A
single timer term can be used to
delay trigger until a period of time
after detection of a significant event.
time-correlated Time correlated
measurements are measurements
involving more than one instrument
in which all instruments have a
common time or trigger reference.
timing measurement In a timing
measurement, the logic analyzer
samples data at regular intervals
Glossary
according to a clock signal internal to
the timing analyzer. Since the
analyzer is clocked by a signal that is
not related to the system under test,
timing measurements capture traces
of electrical activity over time. These
measurements are asynchronous
with the test system.
trigger Trigger is an event that
occurs immediately after the
instrument recognizes a match
between the incoming data and the
trigger specification. Once trigger
occurs, the instrument completes its
acquisition, including any store
qualification that may be specified.
tools A tool is a stand-alone piece of
functionality. A tool can be an
instrument that acquires data, a
display for viewing data, or a postprocessing analysis helper. Tools are
represented as icons in the main
window of the interface.
trigger sequence A trigger
sequence is a sequence of events that
you specify. The logic analyzer
compares this sequence with the
samples it is collecting to determine
when to trigger.
toolbox The Toolbox is located on
the left side of the main window. It is
used to display the available
hardware and software tools. As you
add new tools to your system, their
icons will appear in the Toolbox.
tool icon Tool icons that appear in
the workspace are representations of
the hardware and software tools
selected from the toolbox. If they are
placed directly over a current
measurement, the tools automatically
connect to that measurement. If they
are placed on an open area of the
main window, you must connect them
to a measurement using the mouse.
trace See acquisition.
trigger specification A trigger
specification is a set of conditions
that must be true before the
instrument triggers.
workspace The workspace is the
large area under the message bar and
to the right of the toolbox. The
workspace is where you place the
different instrument, display, and
analysis tools. Once in the workspace,
the tool icons graphically represent a
complete picture of the
measurements.
zooming In the oscilloscope or
timing analyzer, to expand and
contract the waveform along the time
base by varying the value in the s/Div
field. This action allows you to select
specific portions of a particular
35
Glossary
waveform in acquisition memory that
will be displayed on the screen. You
can view any portion of the waveform
record in acquisition memory.
36
Index
A
accelerator keys, 17
B
backtrack command, 9
button, backtrack, 9
button, history, 9
button, home topic, 10
C
command, backtrack, 9
command, history, 9
command, home topic, 10
command, print, 18
E
error messages, 21
F
find system info, 10
G
general help window, 19
M
menu, help pop-up, 9
mouse, actions in help windows, 14
P
pop-up menu, 9
print command, 18
printing, help topics, 18
Q
quick help window, 20
S
search help index, 10
selection, with keyboard, 14
shortcut keys, 17
T
text, selecting with keyboard, 14
topics, selecting with keyboard, 14
W
window, general help, 19
window, quick help, 20
H
help, index search volume
selection, 13
help, pop-up menu, 9
help, printing topics, 18
help, shortcut keys, 17
history command, 9
home topic command, 10
K
keyboard commands, 14
keyboard selection, 14
keyboard, selecting topics, 14
37
Index
38
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising