Diapositive 1 - Mri

Analyse qualitative et quantitative d’images 2, 3 et 4D

Utilisation de Metamorph, Huygens (HRM) et Imaris

Volker Baecker

Sylvain de Rossi

Julien Cau

Remerciements : Julien Bellis (images Imaris).

Analyse qualitative et quantitative d'images 2, 3 et 4D

I Metamorph Display Elements

II Metamorph Measurements

III Deconvolution with Huygens

And HRM

VI 3D display and measurements with Imaris

File format

Stack manipulation

Movie creation

Image dimensions and calibration

Intensity measurements

Object identification

Velocity measurements

Deconvolution examples

Deconvolution made simple

When should deconvolution be used?

The deconvolution parameters and HRM configuration

Simple 2D display tools for 3D/4D stacks

Creating isosurfaces and using specific display tools

3D measurements (volumes, intensities, directions)

V Undersampling and oversampling

1

Metamorph Menus

To open, save, batch save or batch open images

To deal with Regions of Interest (ROI)

You will find here any item associated with image presentation

Functions associated with data log of measurements

For advanced users

For any distance or intensity measurement

To filter, ratio, substract any image and project a XYZ/XYt stack,

To manage multiple image stacks (XYZ or XYt)

To copy/paste images or display

Open an image

2

2- in E\- MRI -\Formation\MMImages\depth open the following images

(shift select all of them) :

2

Image depth (ii)

Inspect the scales of the 8, 12 or 16 bits images.

Change de A value by clicking on Any change?

Click on the info icon

Image info

Camera parameters

Image size and depth

Metadata

(microscope configuration)

3

Binning and image size

Image size is divided by 4, 9 or 16 with binning 2, 3 or 4 bin 1x1 bin 2x2

Resolution drops with binning in this example, 1pixel=102nm with 1x1

1pixel=204nm with 2x2 binning.

Zoom in and zoom out

Alternately click onto the magnifying glass, then use the mouse wheel

4

Image Depth and Intensity histogram (i)

For monochrome images, the A value indicates that the maximum value here

On the Y axis of the histogram is 2 A

In this case 4095 (the range of the

2

12

=

4096 values is from 0 to 4095)

Most abundant pixels=background

Number of pixels

8 bits versus 12 bits images

8 bits (0-255 grey levels)

Storage requirement/pixel:1 bytes

The eye is only sensitive to 80 different grey levels. 6 (0-63) to 7 bits (0-127) are necessary to encode all distinguishable grey levels. 8 bits is sufficient for publication.

12 bits (0-4095 grey levels)

Storage requirement/pixel: 2 bytes

4096 grey level offer a much finer intensity

Resolution. 12 bits images are therefore better suited for intensity measurements

Objects with different real intensities may be visualized as having the same intensity

Intensity

The probability 2 objects with different real

Intensities are visualized with the same

Intensity is low

5

Intensity

8bits stack is a pile of Z planes of the same object.

Play with the slider to see the 35 planes

Image stacks

To create a stack use

File>Open Special>build stack>user defined

Build a stack : user defined

To create with the User Defined option,

1

1-click on Select directory and select E\- MRI -\Formation\MMImages\depth

2

2- Select files in the left hand side window then click on Append.

You control the order of the images (e.g. you may first click on Z000, then Z003 and then Z001. The

Resultant stack will be in the same order.

You can stack any images, provided they have the same size and depth.

6

Build a stack : Numbered names

Serial files (Z Stack or timelapse) are often numbered. You may use File>Open Special>Build Stack> Numbered names to open all of them in a row.

Click on First Image, select it then select the last image.

To skip files (say for instance, if your timelapse interval is 5 minutes, but you only want to select files every 10 minutes),

You can increase the « Increment Name By » item (in your case, 2)

Build a stack : Quick

As users usually select all the acquired files from a file series, a shortcut function one can use is

File>Open Special>Build Stack>Quick. Alternatively, use the Ctrl+Q keys.

Then select the first file and click OK

7

B

2

Batch selection :

Click on clear all,

Select first (low) and last

(high) planes, plane interval (step size) then click on select

1

8

Stack modification

You may remove planes either by :

-Selecting those you wish to remove

(then select Stack>remove plane and see

A

below)

- Selecting those you wish to keep.

Select Stack>Keep plane then follow

B

Select plane then click remove

A

Check to duplicate the removed plane in a new image window

Specify whether the selected planes are copied into an untitled stack or whether the planes are deleted from the original stack

Manual selection (check, uncheck)

1

3

Stack gallery

3

Change here the plane order

2

Control here the gallery geometry

4

Select to draw white (255 if 8bits,

4095 if 12 bits, 65535 if 16 bits) lines between planes

5

To add the plane # label, check draw

Sequence number and configure it (Seq.

color, type, pos. and font)

Stack gallery of a mosaic acquisition

3

1

s\stack\DNA.stk

Select zigzag horizontal (the way this mosaic was acquired)

Open E\- MRI -

\Formation\MMImage

2

Select Stack>Montage

4

Check stitch image and enter the % overlap value used for mosaic acquisition

(10%)

Resultant stitched image

Display issues :Changing the look-up table (LUT)

Intensity in a monochrome image is encoded from 0 to 255, 4095 or 65535. Whatever the display might be, pixel intensity stays the same. For convenience purpose, the relationship between pixel intensity and screen intensity can be change. One can decide pixel intensity value 0 will be displayed on the screen as pure black monochrome (ie a variation of one color, white, red, etc).

Duplicate as displayed

You may quickly copy a monochrome image display as a color image using the « duplicate as displayed function »

1

Select edit>duplicate>As displayed or click the dupicate as displayed icon

2

Select the source image and then click OK

Show Histogram

Select Show histogram or click the Icon

1

2

To emulate a HiLo Lut, scroll the blue bar

(and inspect background homogeneity).

On mouse click, real maximum

Displayed value is indicated

10

Display issues : autoscale

Autoscale is a smart display mode that sets for any 12, 14 or 16bits image:

- Pure black of the screen (value indicated as on the histogram) for the lowest pixel intensity of the image

- Pure white of the screen (value indicated as on the histogram) for the highest pixel intensity of the image

On mouse click, real maximum

Displayed value is indicated

As a consequence :

-Only the used intensities are displayed

-The display is different from one image to another and therefore no visual comparison is possible.

- within a stack (3D or timelapse) the display is adjusted from plane to plane.

Display issues : autoscale

Autoscale can be calculated on the basis of pixel intensities of a subset of the image.

Open E:\- M R I -\Formations\MMimages\autoscale\12bitsstack

1

1- select the draw a rectangle region in the region toolbox, draw a region of interest over a dim zone of the image

2

2- select the arrow to deselect the draw region tool

On mouse click, real maximum

Displayed value is indicated

11

3

3- left click the icon, and select « scale within Active Region option », observe the result.

Display issues : scale image

Open the Scale image Menu by either :

-selecting

Display>Scale

Image,

- clicking on the icon and selection

Scale image

- clicking on this icon

Display issues : 8 bit copies

As the eye is not sensitive to more than 100 grey levels, for display purposes and for convenience when using any other image software (Paint, Photoshop), 12bits to 16bits images can be converted as 8bits copy.

Batch 8 bits conversion (original images are overwritten !)

1

2

3

4

5

Click on Copy

Select to transfer the filename. Be aware than saving this copy with the transfered name will overwrite the original 12-16bits image.

To copy the entire stack rather than the selected plane, check this box

12

1

Display issues : keeping a unique display mode to the whole stack

Move the slider and observe that the overall displayed intensity is not modified

2

uncheck

4

Move the slider again and observe

3

Enter any value here. It is recommended to enter the entire stack min and max values

To visually compare two different images, proceed the same way, with the same low scale and high scale values.

Working with 8bits or 24bits color images

1

Open E:\- M R I -

\Formations\MMimages\combine\channel1 et channel2

Open the Display>Adjust

Digital contrast Menu

2

Select the image to modify and choose whether you want to modify the selected plane only or the whole stack (all planes)

3

Change Brightness, Contrast and

Gamma and observe the resultant curve

4

To fix the changes click on fix contrast.

Note that you will then convert the pixel intensities that will be change for the displayed intensities. To observe this, scroll the mouse on the image, see for a couple of (X,Y) coordinate the intensity value (here (324,28)=0), then change the display, click on Fix contrast and observe the intensity for the same coordinates.

5

13

Changing the contrast of 8 to 16bits

(+ 24 to 48bits color) images

You may change the contrast to better discriminate dim fluorescent objects over the background

1

Invert contrast by choosing the Display>Contrast shortcuts>Invert Contrast function. Alternatively hit the Ctrl+I keys.

2

3

If contrast if fixed, the pixel values are going to be modified accordingly

Z stack synchronisation

To navigate simultaneously through 2 Z stacks without using the 2 sliders,

1

Open the Stack>Select

Plane window.

2

Select the 2 stacks

14

3

Scroll or click on the play buttons

Making a single stack out of 2 stacks

1

select

2

!

If working with 12/16 bits images, the resultant stack

(same depth) may not properly display one or another half (due to highly different max or min values of the original stacks).

It is thus recommended to 8 bit or color the stacks.

A

To view a movie, open the Stack>movie window

This movie is Metamorph specific

B

Movies

To build an .avi or .mov movie, open the

Stack>make movie window

1

select

Full screen mode

(hit any key to escape)

3

Set the play preferences

2

1

Select

3

Enter the play preference =

30*(Wanted movie duration in secondes/number of selected planes)

4

Select movie format

Then click on save

2

Select planes to be displayed/saved in the movie

.mov files are uncompressed, .avi are compressed using a compression codec

Select a compression codec. Cinepak (1st in the list) usually gives a fairly good result

4

2

15

1

select

Merging n channels (i)

Resultant merged stack

2

Select components

Select

3

Select color image depth

(24 recommended)

6

5

4

Select RGB source images/stacks

For stacks select plane option

!

If working with 12 or 16 bits images, result is source display sensitive

Channel1 and Channel2 source stacks

1

Open E:\- M R I -

\Formations\MMimages\combine\ch1_2.stk

Color combine options (i)

Source stack with plane1=channel1 and plane2=channel2 Resultant merged stack

2

select

Select

3

Combines into RGB a 2-3 plane stack

1

2

16

Copies a monochrome image/stack as a color image/stack

1

select

4

Uncheck Autobalance and change the channel’s weights

Merging n channels (ii)

2

For 2 fluorescence channels select 3

3

Select

Channel1 and Channel2 source stacks

Preview

!

If working with 12 or 16 bits images, result is source display sensitive

Overlay of a single stack

1

Select the stack by clicking on the blue title bar

2

Select images from stack and the number of channels/planes

3

Preview

Source stack with plane1=channel1 and plane2=channel2

4

Change here the overall overlay brightness

For fluorescence only images, select No gray

17

Working with transmission and fluorescence images

1

Open E:\- M R I -

\Formations\MMimages\regions\GFP.stk et PH.stk

2

Select 2 for a WB image+ one fluorescent channel

3

Set

Preview

Selection of Regions Of Interest (ROI)

1

Select the rectangular Region tool

2 Draw a ROI on one of the images

!

3

Select Regions>Transfer Regions

Check to erase any region in the target destination

The active region is the region blinking. To activate a region select the arrow in the region toolbar

18 and click on the ROI

4

5

Use to duplicate a ROI on a single plane (Ctrl+D shortcut)

1

2

ROI Duplication

Use to duplicate a ROI on a whole stack (Ctrl+D+shift shortcut)

!

If no region is active (blinking) or if there is no region at all, the whole image are duplicated

Display and digital Zoom (i)

1

Select Display>Set

Image Zoom

2

Inspect the image geometry after changing the (display) set zoom value

19

Display and digital Zoom (ii)

Enter 200% as stretch values, click OK and inspect the resultant image size

2

Select

Display>Stretch and mirror

Without closing the first zoomed image, check the interpolate when stretching and click OK

3

1

3

Select

Measure>Calibrate distances

Select the Setup tab

4

Select the edit units/pix option

6

20 the region in the second stretched image, duplicate them and inspect them with a 400% display zoom

Calibrating an image (i)

1

Open E:\- M R I -

\Formations\MMimages\measure\ calibrateDNA and calibrate reelin images

5

Click on new, enter a name then click on new again

8 Click on done

7

Enter the calibration with the following formula :

Camera element size (um) x binning

Mag (objective)xMag(tube lens)

2

Observe the image is uncalibrated

Calibrating an image (ii)

1

Select the apply tab

2

3

Click on apply to all open images

Select a calibration

4 Observe the image is calibrated

Calibrating an image (ii)

1

Select Display>Graphics>

Calibration Bar

2

Enter here in um the size of the desired scale bar + bar thickness

3

4

Set color (for pure white in autoscaled images, enter the max pixel value

Check if you wish a bar size label.

Be aware images are usually downsized for

!

Up to six object classes (bright, dim nuclei for instance) may be counted simultaneously

To enlarge the image do not use the magnifying glass but rather the mouse wheel

2

Counting objects manually

3

Left click with the appropriate class selected

1

Select the Measure>Manually count object function

Introduction to data logging

Choose DDE for direct transfer to excel (! Data not saved)

2

1

Select Log>Open Data log or click the Open Log Icon

6

Hit F9 icon, Log count button or F9 key

Check, click and configure to transfer coordinates of each click

7

3

Configure data sheet

Left click with the appropriate class selected

Object count

4

Click

Manual count

Resultant excel data log to be saved!

22

5

Check all meaningfull parameters to be transfered

Intensity inspection

Resultant image

Select

Measure>Segm ented Histogram

1

Intensity classes

(bins)

Click (area and relative area values are automatically logged)

3

2

Either select a number of intensity classes (bins) and click auto-configure

2’

Or enter Low and high pixel intensity value for a new class and click add

Intensity measurement

1

Select Measure>Show Region

Statistics

3

Draw a ROI to refine measurements

Click

Check

2

5

Compare

Uncheck

4

Log

6

23

Integrated/area average/Std. Dev.

Sum of intensities of all pixels

Threshold for measurements

1

3

Set upper threshold value

2 Set lower threshold value

6

Compare

5

Check

4

Select inclusive (all non orange pixels are taken into account for measurements

4

Multiple region or plane measurements (i)

1

Open E:\- M R I -

\Formations\MMimages\measure\stackGFP

3 Select all planes

2

Select Measure>Region Measurements

6

5

In configure tab tick all items to be measured

Check if threshold are used

24

Multiple region or plane measurements (ii)

8

Data may be viewed in the Measurement tab or logged

Draw ROIs

7

9

Set the right type of graph (series=curves/regions, histogram or scatterplot, and configure X and Y axis

Multiple region or plane measurements (iii)

Mitosis

10

Graph settings may be changed by clicking on the arrow and selecting Graph settings

25

Multiple region or plane measurements (iv)

11

Graph coordinates may be fastly displayed and logged using the bottom arrow and Show graph Data function

Select

Measure

>linescan

3

Measurements on a linear region

1

Open E:\- M R I -

\Formations\MMimages\measure\linescan

2

Draw a curved line region along a structure of interest

Distance along the line

4

26

Increase the scan width to increase the thickness of the line. For each X coordinate along the line, the n pixels are averaged (here n=9)

Combining an image and a graph

1

Select bottom arrow and

Copy graph to image

Select position

2

3

Click

3

Select Measure> integrated morphometry analysis

Select classify to define objects from the thresholded image 4

Tick the parameters that are going to be used to filter objects

Select teach or change Low and

High Filter range values

5

6

Classify objects

1

Open E:\- M R I -

\Formations\MMimages\measure\countnuclei

Object mask (yellow=manually selected objects, green=objects with parameters within ranges).

2

Threshold image to isolate nuclei (more or less, fused nuclei may be separated later on)

7 Select typical objects

27

Separating fused objects

1

Select a line region tool

3

Select Measure cut objects or hit the F7 key to separate the objects

Draw a line region to separate 2 fused objects

2

Selection after object separation and Filters reset

Measurements of classified objects (i)

1

Select measuring

3

Click

4

Select summary

Tick the parameters that are going to be used to measure objects

2

Summary of the measurements per selected « measuring » parameters.

These values may be logged into a Log/DDE file

28

Measurements of classified objects (ii)

1

Select objects

Point out an object.

The selected object is displayed as yellow and the corresponding measurements are highlighted

3

2

Select Find

3

Alternatively highlight a measurement and the corresponding object will be displayed in the image window as yellow

Measurements of classified objects (iii)

1

Select histogram or scatter plot

2

Set

Histogram may be modified/saved as usual using the bottom arrow

4

3

Move the red bars and hit the

« set filter Range from… » to modify the classification filter range and refine selection

29

1

Select Region>create regions around objects

Object to region transformation

Velocity measurements

1

Open E:\- M R I -

\Formations\MMimages\measure\neuron

2 Select Apps>Track points

Click on add track

4

Click here to set interval

3

6

At each click, the image’s plane is updated. To stop a track, click on done.

30

Velocity measurements using kymographs

1

1

regions around objects

2

Draw a line of interest

4

Click on create

5

Draw a line on the kymograph and observe velocity

3

Select a line width and a mode

A kymograph is an image made of the line of interest (X dimensions) plotted for each timepoint (Y dimension)

The epifluorescence microscope

Fluorescence microscopy

- specimen marked with dye that emits light of one wavelength while being stimulated by light of another wavelength

- specimen has to be in focal distance

- to image 3d specimen, the specimen is moved compared to the objective, thus creating a stack images.

Microscope types

Ɣ widefield whole specimen bathed in light

Ɣ confocal image is constructed point by point to keep out out-of-focus light

Ɣ two photon two photons needed to stimulate emission, similar effect as confocal

31

Image from microscope

Example: 2d widefield

After deconvolution

(same levels)

Immunostaining of whole mount drosophila Embryo

Rabbit Anti-PC/ Anti-rabbit Cy5

Image from microscope

Example: 3D widefield

After deconvolution

32

Image from microscope

Example: 3D confocal

After deconvolution

Drosophila Embryo

Mathieu Gabut and

Example: 2-photon time series

Image from microscope After deconvolution

33

The acquired image is not the “real” image

• Images are degraded due to the limited aperture of the objective

• Deconvolution can be used to get an image nearer to the real object by using knowledge of the imaging process and the properties of the microscope

• Deconvolution can be used for all kinds of fluorescence microscope images: 2D, 3D, time series, widefield, confocal, 2 photon

Sources of image degradation

• Noise

• Blur

– Can be handled by image restoration

• Scatter

– random distribution of light due to heterogenous refrection index within specimen

• Glare

– random distribution of light that occurs within the optical train of the microscope

34

Causes of image degradation: Noise

Causes of image degradation: Noise

• Where does the noise come from ?

– random fluctuations in the signal intensity due to variation of the incident photon flux (photon shot noise)

– interfering signals from electronic system of the captor device

35

Causes of image degradation: Blur

Causes of image degradation: Blur

• Where does the blur come from ?

– contributions of out-of-focus light to the imaging plane

– diffraction

• a result of the interaction of light with matter

• diffraction is the bending of light as it passes the edge of an object

36

How does deconvolution work

• Image restoration

– Get rid of noise

• assume random noise with Poisson distribution

• remove it

– Get rid of blur

• Compute real image from sample

• by applying a model of how the microscope degraded the image

The point spread function

• Point spread function (psf)

– Model of how one point is imaged by microscope

– Experimental

• acquired by taking an image of

„point like objects“ - beads

– Theoretical

• computed from the microscope and captor parameters

37

• acquired image = real image convolved with psf

• Convolution is an integral that expresses

– amount of overlap of functions as g is shifted over f.

i x f x ' g x x ' dx'

i(x) : aquired image f(x) : object function g(x) : point spread function

– N pixel => O(N*N) operations to compute it

Convolution

Fourier Transform (FT)

F

f x e

i 2

x dx

Ɣ

Signal can be represented as sum of sinoids

Ɣ

FT transforms from spatial to frequency domain 38

Convolution theorem

i x f x ' g x x ' dx'

<=>

i(x) : aquired image f(x) : object function g(x) : point spread function

*

I F G

I fourier transform of i

F fourier transform of f

G fourier transform of g

Object function

FT

FT can be computed in

O(n* log n) inverse FT

FT psf

Object function convolved with psf

Deconvolution

i x f x ' g x x ' dx'

<=>

I F G

• Deconvolution: find the object function f for a given image i and psf g

• Unfortunatly it is not practicable to compute

– G has zeros outside certain regions

• Setting F zero for these would create artefacts

F

I

G

– In practice there is noise

• N/G would amplify noise

I F G N

39

• It's not possible to reconstruct the real object function

Deconvolution algorithms

• Solution: find an algorithm that computes a function f' so that

• f' estimates f as good as possible

• works in the presence of noise

• Different deconvolution algorithms exist

• In general best for fluorescent microscopy:

– (Classical) Maximum Liklihood Estimation - MLE

Maximum Likelihood Estimation (MLE)

• Tries to optimise f' iteratively

• The basic principal is (but there's more to it)

• g(i|j) : psf - the fraction of light from true location j that is observed in pixel i

Fraction of light from pixel j that hits other pixels

f new , j f old , j i i i k g i j g j k f old , k

Richardson and Lucy

R-L Iteration

40

Fraction of light from other pixels that hits pixel j

0,3

A B C D

0,2 1 0,2

1

Numerator realign my light to me

1 C3 + 0.1 C4 + 0.2 B3

0,1

2 psf 6 5

3

Denominator: get rid of foreign light that hit me

1 C3 + 0.3 C4 + 0.2 B3

3 4 4 3

4 image

5 * [ 5*1 / (5*1 + 0.3*4 + 0.2*6) + 0,1*4 / (5*1 + 0.3*4 + 0.2*6) + 0,2*6 / (5*1 + 0.3*4 + 0.2*6) ]

5 * [5 / 7.4 + 0.4/7.4 + 1.2/7.4]

5 * [(5 + 0.4 + 1.2)/7.4]

5 * [6.6 /7.4]

5 * 0.891891

4.459459

fraction of light lost

f new , j f old , j i i i g i j g j k f old , k k

New estimate last estimate aquired image last estimate fraction of light from others

Summary and conclusions

ᇄ image from microscope is degraded, it contains noise and blur blur can be described as a convolution of object function and psf image nearer to the object function can be obtained by image restoration yielding higher resolution and better contrast

MLE is a deconvolution algorithm approriate for fluorescent microscope images imaging process is not finished finished without deconvolution do it whenever high quality images are needed

41

Huygens Remote Manager (HRM): a MRI tool to ease deconvolution

runs in your web browser

you can store and reuse parameter settings

you can apply parameter settings to multiple images

runs in batch mode

easy to use

uses huygens2 professional as processing backend

• The alternative is to use huygens2 directly

• more features available

(measurements, different algorithms and parameters)

• images visible

HRM architecture fileserver - thot webserver apsara queue manager king huygens personal

Settings database

• get an account at MRI - www.mri.cnrs.fr

First steps to use HRM

• create your personal folder on thot

• create folder imagesBrutes for your source images

• create folder imagesHuygens for the result images

• copy your images into imagesBrutes you can use sub-folders

Step 1 : login

– enter username and password from your mri account

– press the login button

HRM login

43

Create new parameter setting

• Step 2: choose a parameter setting

– Create a new parameter setting that recapitulates the conditions of image acquisition.

– enter a name for your setting

– press „create new setting“

– name should be meaningful

– Name of microscope, filter, etc. used

• The ? open a help text for an item

Create new parameter setting: Image format

A-

Is the file format capable of storing multiple channels in one file?

Or is there one file per channel?

what file format is it?

for multi channel: how many channels are in the file?

Bwhat is the image geometry?

XYZ stack, volume image, 3d

XY - time time series of 2d images

XYZ - time time series of stacks, 4d tiff single

2d tiff image, single slice

44

Create new parameter setting

Microscope parameters (i)

• microscope type

– widefield and multipoint confocal

• work with ccd camera

– single point confocal and two photon

• work with photomultiplier tube (PMT)

– different point spread functions

• if you don't know

– Look at the help page for the location where you made the image

Create new parameter setting

Microscope parameters (ii)

• Numerical aperture

– measure of ability to gather light and resolve fine specimen detail at a fixed object distance

– higher magnification doesn't yield higher resolution, higher NA does

• Maximal value written on objective

• Can't be larger than the the refractive index n of the medium

NA nsin

45

Create new parameter setting

Microscope parameters (iii)

Sampling theorem

Ɣ

Imaging converts an analog signal into a digital signal

Ɣ

When converting an analog signal into a digital signal the sampling theorem applies

Nyquist-Shannon sampling theorem

“the sampling interval must not be greater than one-half the size of the smallest resolvable feature of the optical image”

Ɣ sampling at nyquist rate means using exactly this interval

Ɣ sampling interval is the pixel size in our image

x

4 NA

Create new parameter setting

NA vs Critical sampling distance

46

Undersampling and oversampling under sampling

Ɣ loss of information

Ɣ aliasing artefacts over sampling

Ɣ higher computation times and

Ɣ storage requirements longer acquisition times, photobleaching.

Create new parameter setting

Microscope parameters (iv)

• Excitation and emission wavelength

• fluorescent dye absorbs light of one wavelength and emits light of another wavelength

• filter cubes are used to ensure that only light of a wanted wavelength passes.

– exitation and emission wavelengths depend on the cube used

• Ex GFP 473nm

• Em GFP 525nm

47

Create new parameter setting

Microscope parameters (v)

• The objective magnification used

– determines the pixel size in the image

– ccd camera

• Pixel size = ccd element size / magnification

(eventually modified by other parameters)

– photomultiplier

• pixel size depends on resolution and magnification

Create new parameter setting

Microscope parameters (vi)

• Refractive index n of the objective medium

– oil 1,51500

– water 1,33810

– air 1,00000

• Should match the refractive index of the sample medium

– Otherwise

• Magnification error in axial direction

• Spherical aberration (psf deteriorates with increasing depth)

48

Create new setting: Microscope parameters (vii)

• Cmount factor

– adaptor that attaches the camera to the microscope

– might contain additional optic that changes the overall magnification and therefore the pixel size

– value is 1 if no additional optic present

• Tube factor

– the tube might contain additional optics to change the tube length

– this changes the overall magnification

– and therefore the pixel size

ps ccd obm cmf tf

Create new parameter setting

Microscope parameters (viii)

• sample medium

• refractive index n

– default (all media for example water) 1,33810

– liquid Vectashield (not polymerized) 1,49000

– 90-10 (v:v) glycerol - PBS ph 7.4 1,49000

– prolong antifade 1,4

• limits the NA and therefore the possible resolution

49

Create new parameter setting

Captor parameters (i)

• size of the unitary ccd captor

• image sensor of the camera

– ccd – charge coupled device

– diodes that convert light into electrical charge

• property of the camera

– Coolsnap 6450 nm

– Micromax6700 nm

Ɣ

Ɣ

For photomultiplier the pixel size is asked see table in help pages

• Binning

• take nxn elements as one

• more light per pixel

• higher signal to noise ratio

• lower resolution

Create new parameter setting

Captor parameters (ii)

ps

50

ccd bin obm cmf tf

• in case of XZY

– z step size

• in case of time series

– time interval

Create new parameter setting

Captor parameters (iii)

Create new parameter setting pinhole parameters (confocal)

• in case of confocal

– pinhole radius

– pinhole

• keep out of focus light

– pinhole either fixed or adjustable

– Backprojected radius in nm

• Size of pinhole as it appears in the specimen plane

r b r phys m system m obj

– size should match airy disk (2d psf) size

51

6.66 for LSM510

Copying, editing or deleting a parameter setting

• setting is saved to database

• to create similar setting

– copy and edit

• to use existing

– select in list

– press „ok“

Create new task setting

• Step 3 : choose a task setting

• Same management for task setting

– operations to perform

– parameters for the operations

52

Create new task setting: style of processing

• style of processing

• What do you want to do

– full restoration (incl. deconvolution)

– remove noise as preprocessing or own operation

– remove background as own operation

Create new task setting: step versus volume

• Style of processing

– step

• process image slide by slide

– converts stack into time series for processing

– converts result back into stack

– volume

• use 3d information

– step combined

• do step processing

• followed by volume processing with fixed parameters

53

Create new task setting

Full restoration parameters

Signal/noise ratio

• signal/noise ratio

– the ratio of signal intensity to noise intensity

– high noise case

• can be measured in the image

– Single photon hit intensity

S

N

» find low intensity voxels from one photon hit

– add values – substract background

– Max voxel value

» value of brightest voxel

maxVoxelValue singlePhotonHitIntensity

– low noise case

• single photon hits can´t be seen

• rough guess is sufficient

Create new task setting

Full restoration parameters

Background offset

• background offset

– empty regions should be black

– but contain some light in reality

– substract mean background to see object clearly

rb huygens

100 rb

hrm

– -30 in huygens becomes 70 in hrm

54

Create new task setting

Full restoration parameters

• number of iterations

– too low

• optimal restoration not yet achieved

– too high

f new , j

• takes longer to compute

• some signal may be removed

– Usually between 30-70

f old , j i i i k g i j g j k f old , k

• create job for all parameter combinations

• up to 4x4x4 = 64 jobs per image

• use with care

Create new task setting: ranges

55

Fixed Huygens 2 parameters used with HRM

- signal / noise ratio

- iterations

- search for background: near objects

- background per channel

- bleaching correction: if possible

Modifiable parameters

Fixed parameters

- quality change threshold: not implemented, not used

- iteration mode: best quality

- padding mode: fully padded parent

Select images

Step 4 : select images to run the operation on tip concerning series

- time series

stack in tiff series format

The series files end with numbers

Only the first file of a series is shown

Don´t let files not belonging to series end with numbers

56

Create job

• Select output file format

– 8 bit tiff

– 16 bit tiff

– ims

(imaris)

– Ics

• check all parameters are correct

• Click on create job

You can see jobs queued and running

– up to 4 jobs are started in parallel

– jobs not started yet can be deleted a text file containing the parameters is saved with the image

To avoid confusion between different jobs on the same data result image names are made unique

The job queue

57

Summary and conclusions

• deconvolution should be used to obtain high quality images

• for all kind of fluorescent microscope images

• parameters of the imaging system have to be entered to create a model of the image degradation

• with huygens remote manager

– doing deconvolution is easy

– parameter sets can be saved, reused and managed

– parameter sets can be applied to many images in the same time

• huygens2 can be used directly if necessary

Opening a series

1

Select File>Open or click the open icon

2

Point out the E:\- M R I -

\Formations\ImarisImages\Min

_CryptTotal-

09\Series000_z000_ch00

Don’t double click or click OK !

3

58

Once the file is highlighted in blue, click the settings button

2

Check opening settings

In pre-V6.0 version, you may click this to automatically detect file naming

4

Check file dimensions

1

Inspect file name :

Files are saved with an organized naming

Rule. In this case

Series[timepoint]_Z[plane]_Ch[channel].tif

ie TZC

V5.0

Select the right naming sequence

TZC

2

V6.0

Subsampling

File series are sometimes huge (here 612MB) and are difficult to handle with Imaris

It may be judicious to downsize them or subsample them.

Select a subsampling factor.

For instance a Z=2 means every even plane is skipped.

Changing X, Y and Ch factor is usually not desirable unless acquisition sampling is incorrect

2

Use the CROP yellow box to select a crypt or set X and Y limits (50-915 and 152-793)

4

Click the resampling open

1

5

Inspect resampled size

3

Use the Z and T sliders (here 1 timepoint only) to inspect the stack (all channels are displayed with the same color) then outside limits are then greyed out)

Slice Display mode

2

Select view>Slice or the click the slice icon

1

To start with basic functions of

Imaris, select empty

File geometry

1 Select Edit>Image properties

Data depth

File geometry in pixels

2

Check and modify X, Y and Z calibration

Ie voxel size. The Z calibration is equal to the Z

Step used during acquisition. For display purpose it may be interesting to increase this step by a factor of 5. Be aware that any measurements will be then biased.

60

1

Select the Channel n menu

Channel colors

2

You may change the channel name here

3

Select a channel color

Display and zoom options

B

A

D

C

Click to generate the map above

D

Click/reclick to enter/exit the full screen mode C

Select to adapt image size to window size B

Click here to have a 1 image pixel:1 screen pixel zoom (ie no digital zoom)

A

61

Display adjustment window

1

Open the Edit>Show display adjustment window

Changing a channel’s display

3

Slide the min and max arrows or change the range values

Select a channel by clicking the panel

(clicking on Channel1 will open the channel color window)

1

Inspect the channel histogram 2

62

Saving a .ims file

1

Select file>Save as or click the Save as icon

2

Save as an .ims 5.5 or more file

(below is imaris classic that can be opened by all imaris versions)

Crop 3D after file opening

Alternatively, you may subselect a ZOI of the image using the Edit>Crop3D and

Resample 3D functions. This is not recommended for big (>100MB) files

3

Select Edit>Crop3D

1

Select Edit>Resample3D

2

To remove every uneven plane enter

15 then click OK

4

Use the Yellow box or change the X, Y,

Z limits as in

Resampling Open

63

Opening color series sequentially

1

Open E:\- M R I -\Formations\ImarisImages\DNA\DNAZ000.tif, set this channel’s hue as blue

2 Select Edit>Add Channel option and select

E:\- M R I -

\Formations\ImarisImages\CTR\ga mmatubulin_Z000.tif, set a red hue in Display adjustment window

3 Select Edit>Add Channel option and select

E:\- M R I -

\Formations\ImarisImages\Actin\acti n_Z000.tif, set a green hue in

Display adjustment window

Check the channels to delete

2

1 Open the Edit>delete Channel option

Deleting channels

64

The slice menu

3

To translate image : hold the right mouse button, then drag

2

To zoom in or out hold mouse wheel

1

Use the slider to navigate within the stack

4

Select the scale bar end and move it to change the bar size

[channel1 intensity] [channel2 intensity] [channel3 intensity] at

(X, Y, Z coordinates in um)

Data depth conversion

1

Select Edit>Change data type

2

Select :

For a 12bits image with min=32 and max=3200 :

Source = levels from

0 to 255, with min=1 max=199

Data= levels from 0 to

255 with min=0 to max=255

65

Flip and Rotate image

1

Select Image processing>Flip or Image Processing>Rotate

2

Select axis

Image smoothing in 3D – Median Filter

1

Select Image processing>Smoothing

>Median Filter

2

Select 3D kernel size

Observe change (apply) then click OK

66

Image smoothing in 3D – Gaussian Filter

1

Select Image processing>Smoothing

>gaussian Filter

2

Select Filter width

Observe change (apply) then click OK

Threshold cutoff : all pixel lling in this part are set to a defined intensity value

Threshold issues

1

Select either Baseline substraction or threshold cutoff

1

Select a channel and a threshold value. Set value for threshold cutoff.

3

Observe changes

Baseline= the whole histogram is shifted to 0

67

Measurements in slice display mode

Select the measurement point selection method : line=distance between 2 points polygon=aggregated distances between n points

1

2

Define measurements points (in any planes) and observe distance

Easy 3D & Maximum Intensity Projection (MIP)

1

Change the Basic Display mode to Easy3D

2

Any display may be saved as an image file using the snapshot menu

68

XY view

X

Y

Section display mode

1

Select View>Section

YZ view

Z

Z (XY plane)

Selection

(white line)

Y

Y (XZ plane)

Selection

(white line)

Y (XZ plane)

Selection

(white line)

Z

X

XZ view

1

Select extended

Slide the yellow line to increase the slice thickness

2

Extended section

MIP Mean Blend

Select the display mode for the relevant view (YZ here)

3

69

Mean/MIP projection on a plane selection

Sliding the yellow extended lines in XZ or YZ selection in the Z direction allows MIP on selected planes

Image gallery

1

Select View>Gallery or Gallery in the basic display icon

3

Select planes (with the help on Ctrl and Shift keys)

2

Set Columns number

4

Click on select to see a gallery restricted to the selected images

70

Surpass – Volume Display Mode

1

Exit the basic display mode and select surpass display mode

Hold mouse left button to rotate, mouse wheel to translate, and mouse left button+wheel to zoom in and out

A

Objects properties area

2

Click on the volume icon

Select navigate

3

B

Objects area

C

View area

Orthoslice display mode

3

Select the orthoslice orientation

2

1

Click on the orthoslice icon

Uncheck Volume

Orthoslice display mode and MIP

4

Set the extended section thickness

Using orthoslices

Orthoslices and orthoslices combinations are convenient tools to navigate trough a very large data set

72

Clipping plane Display option

Choose select and click on the middle rod to set the clipping plane to the required position

2

1

Click the clipping plane icon

Click on the smaller diameter rod to rotate the clipping plane

3

The clipping plane cuts away objects on one side of the plane. Object must be placed behind the clipping plane

2

Object definition using isosurface

Select a channel and threshold intensities

1

3

4

Select smooth data set and

Set filter width

Deselect resample data set if not necessary (resample is used to facilitate viewing of large data sets)

Click the isosurface icon

5

Click on rebuilt to modify the isosurface parameters

1

Select the isosurface object in the objects area

2

3

Export either as a coma separated value file or export to excel

Select the statistics tab

Measurements

1

Select the isosurface object in the objects area

Splitting one object into n objects

2

Click on split

4

To select an object, either choose the Select mode and click on the image or select one Surface00n.T1 in the

Group Iso_Txxx folder

74

3

Restrict the number of objects adequately

Highlightening an object for display purposes

2

In the color tab, change the object’s aspect

1

Select one object to be displayed differently

2

Select a slice view

Manually drawing of a 3D ROI (i)

3

Select a vertice drawing mode

4

Draw a contour on a slice

2

Click the contour icon

5

Change slice and draw as many 2D contours as necessary to outline the whole volume

The contour surface allows the user to extract a 3D object by manually drawing the object contours on 2D slice

75

Manually drawing of a 3D ROI (ii) vertices can be moved by clicking on them while holding down the shift key and simultaneously dragging the left button

6

9

Click the create button

7

vertices can be inserted by holding down the shift key and clicking or double clicking with the left button on the line between vertices

8

Vertices can be deleted by holding down the ctrl key and dble clicking the left mouse button

You may change the size of the contours and the vertices by selecting it and repeatedlyt press the + and – key on the numerical keypad

1

ct the isosurface ect in the objects area

2

3

Automatic spot detection in 3D (i)

Select the target channel

Set the minimum diameter (based on preconceptions)

4

Using the spot quality diagram and the spot display in the view area, set quality threshold

1

Automatic spot detection in 3D (ii)

Use the spot orthoslices display mode to navigate through the data set

2

Shift+left click to manually delete or add a point

Spot statistics

1

Use the spot statistics tab to see and export the measurements

77

3D movies- Quicktime VR

To create a navigatable movie (QVR) of any 3D scene, click the

Quicktime VR button, set file path and click save

1

Custom-made movies (i)

1

Click the animation button

2

Select navigate option. For each desired key frame (blue vertical bars), set the right view and click on add.

Arrange frames by sliding them in the frame box

3

78

Custom-made movies (ii)

2

Set

Setting window

3

Click

1

Click the settings button

Save as movie window

4

Enter name and set movie format

7

Click

6

Set

5

Set frame rate (maximum meaningful

Frame rate is 30/s). The animation is 100 frames

Select channels for colocalization

2

1

Select

Colocalization

1D histogram

3

1D histogram

Set thresholds above background

2D scatterplot

5

Set

79

6

Click

Colocalization statistics

4

Mask with a third channel if necessary. You may also use this to define colocalization channel thresholds (below threshold is greyed out)

Colocalization principle

5

Measurements in 3D

Autodepth module helps to position measurement points with respect to channel intensity or objects

Set point and line display option

2

3

Set

1

Click the

Measurement

Points icon

4

To add a new point choose the select mode, hold the shift key and left click

80

Editing a point position in 3D

1

Click the Edit tab

2

hold the shift key and left click on the object then drag it.

1

Select channels

Intensity profile along a 3D line

1

Select the intensity tab

81

Measurements combinations

82

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement