Desktop Studio
Desktop Studio: A tour
Intellicus Web-based Reporting Suite Version 4.5
Enterprise
Professional
Smart Developer
Smart Viewer
©Intellicus Technologies
info@intellicus.com
www.intellicus.com
Copyright © 2009 Intellicus Technologies
This document and its content is copyrighted material of Intellicus Technologies.
The content may not be copied or derived from, through any means, in parts or
in whole, without a prior written permission from Intellicus Technologies. All
other product names are believed to be registered trademarks of the respective
companies.
Dated: - May 2009.
Acknowledgements
Intellicus acknowledges using of third-party libraries to extend support to the
functionalities that they provide.
For details, visit: http://www.intellicus.com/acknowledgements.htm .
Intellicus Desktop Studio: A Tour
i
Contents
Introduction to Intellicus Desktop Studio .............................4
Operating Modes ......................................................................................... 4
Launching Intellicus Studio........................................................................... 4
The Intellicus Studio window ........................................................................ 6
Menus ........................................................................................................ 9
Toolbars................................................................................................... 13
Working with Reports ......................................................... 16
Choosing to create a new report on Welcome… dialog box .....................16
Choosing to opening a pre-designed report on Welcome… dialog box .......16
Using the Report Wizard ............................................................................ 17
Report type...................................................................................18
SQL Source ...................................................................................19
Fields...........................................................................................20
Group ..........................................................................................21
Totals ..........................................................................................22
Style ...........................................................................................23
Sub Reports ..................................................................................24
When wizard is reloaded ............................................................................ 25
Creating Report without using Wizard .......................................................... 26
Creating SQL Reports......................................................................26
To refresh metadata caching ............................................................27
Data from Multiple Data Sources .......................................................28
Creating Report Using XML data source ..............................................28
Working with Layout Editor ................................................ 30
Components of a Layout Editor ................................................................... 30
Explorer Window ............................................................................30
Fields Window ...............................................................................30
Layout Pane (Layout Window) ..........................................................31
Properties List ...............................................................................31
Working with Sections ............................................................................... 31
Creating Sections ...........................................................................31
Deleting Sections ...........................................................................33
Arranging Section Groups ................................................................33
Designing a Report Layout ......................................................................... 34
Types of Field Controls ....................................................................34
How to set Viewers .........................................................................36
How to Preview ..............................................................................36
Intellicus Desktop Studio: A Tour
ii
General Options ........................................................................................ 38
Report Properties Dialog box ...................................................................... 39
Template ......................................................................................41
Intellicus Desktop Studio: A Tour
iii
Introduction to Intellicus Desktop Studio
Introduction to Intellicus Desktop Studio
Intellicus Desktop Studio (Or Intellicus Studio as it is generally referred as) is
report design tool of Intellicus web-based reporting solution.
Report designed in Intellicus is like template used to store report-design and
database related information. This is then read by Report Server to generate
actual reports with data.
Operating Modes
Intellicus works in two operating modes:
•
Security Enabled: In this mode, you need to login using user name and
password allotted to you to launch Intellicus Studio and work in it.
•
Security Disabled: This mode is activated when Intellicus Report Server is
running in this mode. In Security Disabled mode, there is no concept of user
name and password.
Intellicus Studio will start just like any other
application.
While working in Intellicus Studio with security enabled, tasks you can do using
Intellicus Studio will depend on the access privileges given to you.
When working in Intellicus Studio with security disabled, you will be able to
access all of the functionalities of Intellicus Studio.
Launching Intellicus Studio
You can launch Intellicus Studio by clicking Start > Program Files > Intellicus >
Studio.
When Intellicus Studio works with security enabled, upon launching Intellicus
Studio, you are presented with the Login dialog box.
Figure 1: Login dialog box
The information to be provided is:
•
Organization: From the available options in the drop down box, select the
organization under which the Login Name allotted to you is created.
Intellicus Desktop Studio: A Tour
4
Introduction to Intellicus Desktop Studio
•
Login Name: Specify the login name.
•
Password: Specify the password associated with the login name that you
have specified.
After specifying the information, click OK to proceed.
On successful login,
Intellicus Studio will start and Welcome dialog box will appear.
Important: Intellicus Studio needs to be online with Intellicus Report
Server. Intellicus Studio communicates with Intellicus Report Server on a
specific IP and port number. If it does not find server running at that IP
or Port, instead of launching Intellicus Studio, Report Engine
Configuration dialog box will open.
Figure 2: Report Engine configuration dialog box
If this happens, provide the IP and port (at which server is listening) in
IP/Name and Port respectively and click Test to check if Studio is able to
communicate with the server.
Upon successful test, Test connection
successful! Message will appear. Click OK.
Figure 3: Successful test
Intellicus Studio will automatically get launched and its window will appear.
Intellicus Desktop Studio: A Tour
5
Introduction to Intellicus Desktop Studio
The Intellicus Studio window
Given below is a sample of Intellicus Studio’s window having a report opened in
it.
Figure 4: Intellicus Studio Main Window
Like any other Desktop application, Intellicus Studio Window
toolbars, status bar and the area where other panes open.
has
menus,
Document area of Studio is divided in:
•
Explorer Pane
•
Fields List
•
Properties Pane
•
Report Design area
Intellicus Desktop Studio: A Tour
6
Introduction to Intellicus Desktop Studio
Explorer pane
Lists in a tree view, the components placed on the canvas.
Figure 5: Explorer Pane
When you select a field in Explorer pane, respective field gets selected on the
canvas too.
Fields list
Lists the fields that can be placed on the report.
Figure 6: Fields List
This list contains fields (coming from database tables, or xml file), user
parameters selected for the report, Formulas as well as system parameters.
Properties pane
Displays list of properties and the values of properties related to the control selected
from canvas.
Intellicus Desktop Studio: A Tour
7
Introduction to Intellicus Desktop Studio
Figure 7: Properties pane
The list displays only those properties that are applicable for the selected control.
Description of the selected property is available at the bottom of the list. The list can be
arranged by the order (ascending order or descending order of property name) or
arranged in groups.
Layout pane
This is the area where canvas is located. Report controls are placed on canvas.
Detailed description of report design area is covered in later chapters.
Intellicus Desktop Studio: A Tour
8
Introduction to Intellicus Desktop Studio
Menus
Intellicus Menu bar has the following options:
Figure 8: Intellicus menu bar
Options under File Menu
File menu includes options for file operations about the report file.
•
New: Use this option to open a new report. Click XML to open a report that
will get data from an XML source.
Click SQL that will get data from a
database.
•
Open: To open an existing report (.irl file).
•
Close: To close the open report file.
•
Save: To save the report format file.
•
Save As: To save the open report file at a specific location with same or
different name.
•
Print Preview: To preview the report.
•
Page Setup: To carryout print related settings.
•
Dashboard page setup: To set the page dimensions when the report will be
used on a dashboard.
•
Import: To import a crystal report in Intellicus.
•
Exit: To exit from Intellicus Studio.
File menu also contains recent file list.
Options under Edit Menu
Edit menu includes options having commands to assist in editing a report.
•
Sub Report: To get the Create a Sub-Report from.. dialog. To get the
dialog, place sub report control on report layout and then click this option.
•
Undo: To Undo the last action.
•
Cut: To remove the selected object from its existing location (to be placed at
some other location).
•
Copy: To copy the selected object from its existing location (to be placed at
some other location).
•
Paste: To place the object that was copied or cut earlier.
Intellicus Desktop Studio: A Tour
9
Introduction to Intellicus Desktop Studio
•
Delete: To delete selected (one or more) objects.
•
Delete Section: To delete selected section.
Options under View Menu
View menu includes command options about controlling the view of the
application in terms of elements that are visible on screen and the way they are
visible on the screen.
•
Design: To switch over to Design View from the Preview.
•
Preview: To preview the report being designed.
•
Properties: To hide / show properties list.
•
Explorer: To make the Explorer window disappear and appear.
•
Fields: To make the Fields window disappear and appear.
•
Refresh Fields: To refresh the field list.
making changes in an SQL query.
•
Full Screen: To get a full screen view for Layout Editor. To come back to
Normal View, right click on a report band, and click the Full Screen option.
This option is not available for while previewing a report.
•
Grid: To toggle between making a grid visible or Invisible.
•
Toolbars: A mouse hover on this option opens a sub menu with options for
Standard, Format, Status Bar and Toolbox. A click on an option will make the
corresponding toolbar visible / invisible.
You may click this option after
Options under Insert Menu
This menu includes command options that are used to insert an object / control
into an open report.
•
Section: Use this sub menu to insert a Report Header/Footer, a Page
Header/Footer and Group Header/Footer in the report. Click its option ReArrange Groups to rearrange groups.
•
Controls and Object related menu options: This includes options to insert
Label, Field, Checkbox, Page Break, Line, Shape, Image, Frame and a Rich
Text Box in the report layout.
•
Sub Report: Use this option to insert a sub-report in the report layout.
•
CrossTab: Use this option to insert a cross-tab control on the report layout.
•
Chart: Use this option to insert a chart control on the report layout.
•
Caption: Use this option to insert caption of the field whose associated
caption is not present.
Intellicus Desktop Studio: A Tour
10
Introduction to Intellicus Desktop Studio
•
Summary Field: Use options under this sub-menu to select and insert a
summary field on all the group footers.
•
Date/Time: Use this option to insert a Date / Time control on the report
layout.
•
Page Numbers: Use this option to insert page number control on the report
layout.
Options under Format Menu
Format Menu includes options to work with formatting and look & feel aspects of
a report.
•
Align: Use this sub menu to align selected controls to Left, to Center, to
right, towards top, middle or bottom or align with the grid.
•
Size: Use this sub menu to re-arrange all the selected controls to have the
Same Width, Same Height or both.
•
Horizontal Spacing: Use this sub menu to set horizontal spacing among two
or more selected controls, as Equal, Increase, Decrease.
•
Vertical Spacing: Use this sub menu to set vertical spacing among two or
more selected controls, as Equal, Increase, Decrease.
•
Paint Properties: To apply format properties to selected control(s).
•
Bring to Front: Use this menu option to bring the selected control to front.
This control will overlap all other controls.
•
Send to Back: Use this menu option to bring the selected control to back.
All other controls will overlap this control.
•
Styles: Use this menu option to get Styles dialog box.
•
Conditional Formatting: Use this menu option to get Conditional Formatting
dialog box.
•
Notifications: Use this menu option to get Notifications dialog box.
•
Hyperlink: Use this menu option to get Hyperlink Options dialog box.
•
Lock Layout: To lock all the controls on the report to their respective
locations. This is a menu option with toggle effect.
Options under Tools Menu
Following options are available under Tools menu.
•
Connections: Use this menu option to set database connection for the open
report.
Intellicus Desktop Studio: A Tour
11
Introduction to Intellicus Desktop Studio
•
Parameters: If the report needs one or more run time parameters at run
time, use this menu option to get Parameters dialog box. Setup parameter
information on this dialog box.
•
Parameters Form Layout: Use this option to open Parameters Form
Layout dialog and specify layout details for Input Parameters Form (IPF).
IPF opens at runtime when a report having user-parameter is executed.
•
SQL Editor: When the report being developed gets data from an SQL source,
use this menu option to get SQL Editor dialog box. Setup SQL related details
on this dialog box.
•
Scripting: Use this option to open Script Editor.
•
Formula Fields: Use this option to open Formula Fields dialog box.
•
Conditions: Use this option to open Conditions dialog box to design report
conditions.
•
XML Source: When the report being developed gets data from an XML
Source, use this menu option to get XML Source dialog box. Setup SML
related details on this dialog box.
•
Report Properties: Opens Report Properties dialog box.
•
Options: Opens a dialog box to specify system and custom design.
Server, Window and Help menus
Server Menu
The server menu has three options:
•
Upload Report: To upload a report to the report server.
•
Download Report: To download a report (.irl file) from the Intellicus report
server.
Window Menu
Using Intellicus Studio, you can work with more than one report at a time. The
options under Window menu provide options to have those report files differently
in the application window. The options are,
•
Tile Horizontally: Place all open reports one below other.
•
Tile Vertically: Place all open reports side by side.
•
Cascade: To place all open report over each other in cascading fashion. This
way only the topmost report is visible. Title bar of all the report is visible. A
title bar can be clicked to bring it to front.
•
Close All: To close all the report files.
Intellicus Desktop Studio: A Tour
12
Introduction to Intellicus Desktop Studio
It also has one option for each of the opened report.
Help Menu
•
Help: To launch Online Help of Intellicus Studio.
•
About: To know about the version of the Intellicus Studio that you are using.
Toolbars
Intellicus Studio provides four types of toolbars to work with. You can use the
toolbar buttons as a shortcut for doing the routine tasks. However, these options
are also available in the menu.
Standard Toolbar
Buttons available on the standard toolbar are:
•
(New Report): To start work on a new report layout.
image will open a new SQL based report layout.
report layout, click
icon, click XML.
•
(Open Report): To open an existing report layout.
•
(Save Report): To save the open (active) report layout.
•
A click on the
To open a new XML based
(Save Report As): To save the open report layout at a specific location
with same or different name. If you are saving the open report layout for the
first time, even if you click
•
button, Save As dialog box will open.
(Upload): To upload the open report layout to the server with which
Intellicus Studio is connected.
•
(Download): To download a report layout from the server with which
Intellicus Studio is connected.
•
(Report Wizard): To open Report Wizard dialog box.
•
(Page Setup): To open Report Settings dialog box.
On this dialog box,
you can do page dimension, printer selection, grid settings and style related
settings.
•
(Dashboard Pagesetup): To set the page dimensions when the report
will be used on a dashboard.
•
(Report Properties): To open Properties dialog box.
On this dialog box
you can Engine (server), summary information, Security etc. related settings.
Intellicus Desktop Studio: A Tour
13
Introduction to Intellicus Desktop Studio
•
(Cut): To cut the selected control(s).
•
(Copy): To copy the selected control(s).
•
(Paste): To paste the selected control(s) on the selected section.
•
(Delete): To delete the selected control(s).
•
(Undo): To undo actions taken on Report Layout form.
•
(Connection): To set the default connection with database.
•
(Parameters): To open parameter dialog box.
•
(Parameters Form Layout): To open Parameters Form dialog box.
•
(SQL Editor): To open SQL Editor dialog box.
•
(Formula Fields): To place a summary function in group-footer section(s).
Click the
button to get options for all the summary function, followed by
selecting a function from the options available.
•
(Scripting): To open Script Editor dialog box.
•
(Conditions): To open Conditions dialog box.
•
(Refresh Field List): To refresh the Fields window.
Format toolbar
•
(Styles): To open Styles dialog box.
•
(Conditional Formatting): To open Conditional Formatting dialog box.
•
(Notifications): To open Notifications dialog box.
•
(HyperLink): To open Hyperlink Options dialog box.
•
(Align): To align all the selected controls with respect to the one that
was selected last.
•
(Size): To adjust the size of selected controls. By default, a click on the
button will affect width.
Click
to get a list of options.
Size will be made
equal with that of the control that was selected last.
•
(Vertical Spacing): To adjust vertical spacing among selected controls.
By default, a click on the button will increase vertical spacing. Click
button
to get a list of options.
Increase or decrease of spacing will move the
controls downwards and upwards respectively.
Intellicus Desktop Studio: A Tour
14
Introduction to Intellicus Desktop Studio
•
(Horizontal Spacing): To adjust horizontal spacing between selected
controls. By default, a click on the button will increase horizontal spacing.
Click
to get a list of options. Increase of decrease of spacing will move the
controls towards right and left respectively.
•
(Paint Properties): To apply format properties to selected control(s).
•
(Bring To Front): To bring the selected control front.
•
(Send To Back): To push the selected control to back.
•
(Lock Layout): To fix the control where they are.
Toolbox
•
(Select): To return to selection mode.
•
(Label): To select Label control.
•
(Line): To select Line control.
•
(Shape): To select shape control.
•
(Frame): To select Frame control.
•
(Image): To select Image control.
•
(Page Break): To select page break control.
•
(Rich Text Box): To select Rich Text Box control.
•
(Sub-Report): To select a sub-report control.
•
(Cross-tab): To select a cross-tab control.
•
(Chart): To place a chart control.
•
(Add Groups): To add a group. It will insert a group header, group footer
and also create summary fields in respective sections for all the numeric
fields available at that time in detail section.
•
(Re-Arrange Groups): To get a dialog box for re-arrangement of groups.
•
(Caption): To insert caption in header section (as the field name) for a
field selected in detail section.
•
(Summary Field): To place summary fields on all the group footers.
Intellicus Desktop Studio: A Tour
15
Working with Reports
Working with Reports
When you launch Intellicus Studio, Welcome to Intellicus Studio dialog box
appears immediately after opening the main window.
Figure 9: Welcome Dialog Box
On this dialog box, you can decide to do any of the following:
•
To create a new report
•
To work on any of the pre-designed reports
Choosing to create a new report on Welcome… dialog box
Under Create, click New Report option. Under Source, select SQL if the data
for report will come using an SQL.
Select XML if the data for report will come
from an XML.
To start designing the report with help of wizard, click (select) Use Wizard
checkbox. Click OK to close the dialog box and open a blank report or Wizard
depending on selection.
Choosing to opening a pre-designed report on Welcome… dialog box
Under Open, select Existing Report to open a report that was already created.
Double-click the report if it is available in the list or double-click Browse… to
browse and select the report.
On Welcome… dialog box, click OK after selecting the report.
report opens in Intellicus Studio.
Intellicus Desktop Studio: A Tour
The selected
16
Working with Reports
Using the Report Wizard
The report wizard provides an easy-to-use tabbed interface to create a report.
Your report is simple tabular report of one having a lot of components on it, it is
always a good idea to start designing a new report using the report wizard.
A report that does not have chart, cross-tab or sub-report component can be
entirely designed using Wizard. If a report has chart, cross-tab or sub-report
component then it is a nice idea to use Wizard for some of the activities.
The report wizard provides the following tabs:
•
Report Type: To specify report title and layout related information.
•
SQL Source: To specify SQL related information (for SQL based reports).
•
Fields: To specify the fields to be placed on the report.
•
Groups: To specify group related information.
•
Totals: To specify summary (totals) related information.
•
Style: To specify Styles (pre set formatting) related information.
•
Sub Reports: To specify and provide sub report related information.
Intellicus Desktop Studio: A Tour
17
Working with Reports
Report type
Report title and layout related information is specified on this tab.
Figure 10: Report Wizard
•
Title of Report: Specify the title of the report.
at the top of the report.
•
Report Layout: This defines how fields (controls) will be placed on the
report. Select Simple if you want free-form placement of controls on report.
Select Tabular if you want auto-placement of fields on report in one row per
record on report. Select Form if you want to auto-place fields one below
other.
Intellicus Desktop Studio: A Tour
This information will appear
18
Working with Reports
SQL Source
Specify your SQL related information on this tab.
Figure 11: SQL Source Tab
•
Connection..: To get a dialog box to set the database connection. Using this
connection, Intellicus Studio will receive database information for report
design and preview.
•
Parameters..: You need to specify user parameters if the report will need
values at run time from the user. Click this button to open Parameter dialog
box and setup parameter details.
•
SQL Editor: Using SQL Editor you can construct simple queries by drag and
drop method.
•
Select Query: If you already have a query object that you want to use to get
data from, select it from Select Query drop down box. This drop down box
displays only those query objects that are using default connection or
selected connection.
Intellicus Desktop Studio: A Tour
19
Working with Reports
Fields
Specify the fields to be added into the report from the selected database.
Figure 12: Fields Tab
The list on the left side has Report fields (they have come from SQL), Formula
Fields (if there are any) Parameter Fields (if there are any), and system
parameters.
Select a field and click Add to shift selected field on the right. Click Add All to
select all the fields of the type (Report Fields, Formula fields, etc). To remove a
field from selected fields list (fields on the left side), select that field and click
Remove. To remove all the fields, click Remove All.
Click Formula button to open the dialog box to create a new formula.
Select a field and click movement keys on the right to shift the field up (left) or
down (right).
Intellicus Desktop Studio: A Tour
20
Working with Reports
Group
Specify your grouping preferences on this tab. Grouping is done on fields listed
under the Report Fields.
Figure 13: Group Tab
From the fields listed under the Report Fields, select the one on which you
want grouping, and click the Add button. The field will appear on the right under
Group By.
For every group select the New Page check box if you want this group to start
from next page. To set a group as major or minor, select a field and shift it
upwards (major) or downwards (minor) using the arrow keys.
To remove grouping on a field, select the field and click the Remove button.
Intellicus Desktop Studio: A Tour
21
Working with Reports
Totals
On Totals tab, you specify your preferences for summary totals.
Figure 14: Totals Tab
Select a field that you want to total up, and click the Add button. The field
appears on the right side. Select a Summary Function to be applied on the field.
For the selected field, also specify the level at which you want the total to
appear.
To specify the level at which the summary should appear, select a level under
Level pane.
•
Grand Total: Select this if you want the total to appear on Report footer (at
the end of the report).
•
Page Total: Select this if you want the total to appear on page footer (at the
end of the page).
•
Group Totals: Select check box for group total of respective group.
Intellicus Desktop Studio: A Tour
22
Working with Reports
Style
Add style effects, page numbering, and border to the report.
Figure 15: Style Tab
•
Gradient Effect: Group headers are given different shades (dark to light) of
the selected color. Select the color to be used for gradient effect from the
Select Color button.
•
Indent Group: Each group is placed slightly inside (right side) of the higherlevel group.
•
Border: Border is added.
•
Page Numbers: Add page number in footer.
Click the Select Color button to get color palette. The color for gradient effect
can be selected either from color available in the palette or can be created using
the Define Custom Colors button.
You can also select a pre-defined template from the Apply Template drop down
list, to be used for creating the report.
Intellicus Desktop Studio: A Tour
23
Working with Reports
Sub Reports
Add a sub report (if any) to the report.
Figure 16: Sub Reports Tab
To create a sub report using SQL, select ‘New Report’ and choose the ‘Source’ as
SQL. For creating report layout using XML, select ‘New Report’ and choose the
‘Source’ as XML.
To open an existing report you can choose from the list of the most recently
opened reports, or browse for other reports by selecting ‘Browse…’ on Create a
sub report from dialog box.
Tip: To design a report, if you do not want to use the Report Wizard,
click the Blank Report button.
Note: When a sub-report is created using wizard, page header and page
footer section will not be added. Page totals and Grand total fields will
not be added in the list-box on Totals tab.
Intellicus Desktop Studio: A Tour
24
Working with Reports
When wizard is reloaded
If you have reloaded the wizard, meaning, if wizard was used for this report and
you have once again opened the wizard, some of the functionalities will NOT be
available. They are:
•
Data Source
•
Sub-reports
•
Style
•
Blank button
Following functionalities will be available:
•
Change in fields
•
Grouping
•
Total
Query Object
Query object’s name will not appear (the query will appear). If query object is
changed, a warning message appears and the fields (available previously) are
replaced by those made available through new query object.
Style Tab
The check boxes on Style Tab will be re-set as clear. As a result of this, the
styles will not be applied on the report. To continue with the style that you
specified while using the wizard for the 1 st time, you need to select (check)
those checkboxes each time wizard is reloaded.
Control Properties
Properties set for control is re-set when wizard is reloaded.
Intellicus Desktop Studio: A Tour
25
Working with Reports
Creating Report without using Wizard
Creating SQL Reports
To create an SQL report layout, you need to configure the database connectivity.
This will enable you to retrieve data from the desired tables.
Set the Database Connectivity
All database related tasks in a report can be performed only after setting a
database connection for the current report. Each report opened in the Intellicus
Studio has its own connection. To open the Database Connections dialog, from
menu, select Tools > Connections.
toolbar.
You can also click
button from the
Figure 17: Connecting to a Database
The dialog box lists the connections setup in Intellicus Report Server.
entry in the list, following information is displayed:
For each
•
Name: Unique name to identify the connection.
•
Valid: A tick indicates that the connection was valid when Desktop Studio
was launched.
•
Runtime: A tick indicates that user credentials for the database server will
be asked at runtime. If you try to set this connection for the report, you will
be required to provide user credentials now also.
•
Connect String: String that will be used to get connected with the database
server.
•
Set for all Sub Reports: If this check box is selected (checked) all the sub
reports (if any) of this report will use this connection.
Name, Valid, Runtime and Connect String are read-only.
This dialog box lists the connection strings that have been configured earlier.
Intellicus Desktop Studio: A Tour
26
Working with Reports
Note: Database connections are configured using the Web Interface.
Now,
Figure 18: Connect to dialog box
1. Select the connection by clicking in the first column of the corresponding
row. The entire row gets selected.
2. Click the Set button.
3. Click OK to save the changes and close the dialog box. If the connection
set has a tick in Runtime column, then Connect To dialog box will
appear. Specify user credentials and click Connect to go ahead.
Database Connection dialog box is closed and the connection is set as the
active database connection for the report.
To refresh metadata caching
Metadata is cached at the time of launching Desktop Studio.
metadata manually,
To refresh the
1. Select the data connection for which metadata needs to be refreshed.
2. Click Refresh Schema button.
3. Click Yes on the confirm refresh dialog box to proceed.
When you click Yes, a request is sent to the report server to get the metadata
information for the selected database connection.
Important: You need to have super administrator privileges to be able
to manually refresh the schema.
Intellicus Desktop Studio: A Tour
27
Working with Reports
Data from Multiple Data Sources
Generally a report gets its data from one connection (data source). However, a
report may get data from multiple data sources. You may use different SQLs
(but same data connection) to get data for different components of a report.
You can use separate query as well as data connection for:
•
A chart component
•
A cross-tab component
•
A sub report
For more information, please refer to the respective chapters.
Creating Report Using XML data source
Select XML as the source data for the report from the Welcome dialog box. On
doing this, the Layout Editor will be displayed on the screen. Now, click the
option XML Source from Tools menu.
Figure 19: Specifying XML Source
Select Design Source and Runtime Source:
•
If the file is stored locally or on network drive, specify the path and name of
file in File.
•
If the file is stored on Internet / Intranet location, specify its URL.
If the file is stored as a column on a database, select the database from
DataBase dropdown box, select XML Column and specify SQL. Click the Verify
button to verify the SQL.
Select the Record Pattern. That will act as a root. Click OK, and the fields will
appear in the Fields window.
Intellicus Desktop Studio: A Tour
28
Working with Reports
Figure 20: Field List
in the Fields window. This indicates the
Also, you will notice a red arrow
data that you chose from the XML Source dialog box. These fields can be
dragged and dropped on respective section of the report.
The ‘Xpath’ value at the bottom of the Fields window indicates the path to the
chosen value.
When you drag a value from the Field List window to the report layout area, you
need to provide the displayed ‘Xpath’ value in the ‘DataField’ property of
Properties list.
Figure 21: DataField Value
Note: All operations performed in the report layout pane are similar for
both SQL generated report and XML generated report; the only difference
is the method of selecting data for the report.
This will be followed by other activities of report designing.
Intellicus Desktop Studio: A Tour
29
Working with Layout Editor
Working with Layout Editor
This chapter provides you information on designing your report using the GUI
(Graphical User Interface). The Layout Editor provides you with a facility to
design a report using simple report generation tools. You can add fields and
sections to your report, use formatting features and parameters to generate
simple and complex reports using SQL or XML. You can also modify or delete the
performed actions.
Components of a Layout Editor
The various components of Layout Editor are:
Explorer Window
The Explorer window displays all the sections and their controls in a hierarchy. If
you select any value in this window, that value will get selected in the layout
pane.
Click ViewÆ Report Explorer to show/ hide this window.
Figure 22: The layout editor
Fields Window
The field window displays all the fields from the selected tables, along with the
defined parameters if any.
In order to update the fields listed in this window, you need to click Refresh
Field List button or from View menu, click Refresh Field List option to get the
updated values displayed in this window. You can simply drag the fieldnames
from this window to the report layout pane.
When you drag a field from Fields List, Intellicus will also place its caption in
the header section.
Intellicus Desktop Studio: A Tour
30
Working with Layout Editor
Click View > Fields to show / hide this window.
Layout Pane (Layout Window)
The layout pane contains the broad sections under which the fields will be
arranged. To add fields to this pane drag the fields into this pane from the field
window. You can also insert parameter values, and field controls to this pane.
To change any properties of the added controls (fields), click that control and
change its properties from the Properties list.
Properties List
You can modify/ view the property set for the controls / sections on the layout
pane for each selected object.
Click View > Properties List to show/ hide this window.
Working with Sections
There are three sections in a report:
•
Report Header/ Footer
•
Page Header/ Footer
•
Group Header/ Footer
Creating Sections
A section is a defined area of a report, which contains report elements. Each
section has a specific repeating nature. A printed report generally has heading
sections that may be displayed only on the first page, or on every page, or as a
heading for each group. These display options may also be used for footer
sections.
Figure 23: Creating Sections
You can create a section by one of the following methods:
•
Right-click on the section name and choose a section under the Insert option
•
Select Insert > Section > <Select Section>
Intellicus Desktop Studio: A Tour
31
Working with Layout Editor
Note: Group can be formed on a calculated field also. For example, if a
calculated field CLASS gives you value “First”, “second” or “third”, you
can group the records by CLASS, where all the records having value of
CLASS as “First” will appear together.
On performing any of the options the selected section will be added to the field
layout pane.
To create a blank group (section)
1. Click the header of the Detail section.
2. Create a section using any of the methods specified above.
A blank group header and footer appear.
To create sections based on field (to group)
1. Select the field from detail section by which the group (section) is to be
created.
2. Use any of the above methods to create a group.
A group (section) is created and group summary fields are placed for each of the
numeric field in the detail section.
To create multiple sections (groups)
1. Select the fields by which you want to create groups.
2. Use any of the above methods to create groups.
Groups will be created in the order of selection of the fields.
For example, a report needs to be grouped by Department and under
Department, by Grade. To achieve this grouping, select Department followed by
Grade.
Figure 24: Inserting groups – summary fields are also placed
For each group, Intellicus will automatically place summary fields of all the
numeric fields in the detail section. These fields will be placed under respective
field in detail section and will move horizontally if respective field in detail
section is moved.
Intellicus Desktop Studio: A Tour
32
Working with Layout Editor
Note: You can change the summary function applied on a group
summary field, from properties list.
Deleting Sections
You can delete a section by one of the following methods:
1. Right-click on the section name and choose Delete Section or,
2. Click the section header and from Edit menu, click Delete Section
option.
Arranging Section Groups
You can reorder the groups added as sections in the report layout pane. To do
this:
•
Right-click on a section and select Re-Order Sections menu item. On doing
this a Group order dialog box will appear.
•
You can rearrange the sections by click and drag method. Press the OK
button to confirm the rearrangement.
The dialog box given on the next page shows the drag-and-drop method for
rearranging sections.
Figure 25: Reordering Groups
Intellicus Desktop Studio: A Tour
33
Working with Layout Editor
Designing a Report Layout
Designing a report layout involves inserting field controls, objects, and report
components to the report layout page.
Types of Field Controls
A control is a field that you add to the layout pane. It may be a database field,
calculated field, display field, parameter (system, report) field, or a control. A
broad division for the controls is as under:
Label
A Label is used to display static text such as, titles and option
button text.
A Field control is used to accept data from the user. It is the
default control that Intellicus defines when you drag fields from
the Fields list window.
A check box control displays an empty or checked box on the
report.
A page break control breaks the report from the location it is
placed. Remaining information is printed on the next page.
Field
Check box
Page
Break
Note: If you place a field in any of the footer sections, it is auto-set as a
summary field.
Analytical Controls
Chart
Cross-tab
To place a chart on your report.
To place a cross-tab (also known as grid or matrix) control on the
report.
Graphic Controls
These controls enhance the appearance of the report.
Line
Shape
Image
This control draws a straight line.
This control draws a rectangle. It can be changed to ellipse and
rounded rectangle.
This control places an image file on the report. For example, a
corporate logo.
Other Controls
Frame
RTF
SubReport
This control is used to group the controls placed on it. This is to
handle all the controls as one control.
This control places a Rich Text Formatted control on the report.
This control places a report in the report being designed.
Intellicus Desktop Studio: A Tour
34
Working with Layout Editor
Controls can be placed within a frame:
•
Label
•
Field
•
Checkbox
•
Image
•
Line
•
Shape
•
Rtf
Controls that cannot be placed within a frame:
•
Chart
•
Cross-tab
•
Page Break
•
Sub report
After having created the report you can preview the report to see how it would
print on paper. For previewing a report, Intellicus provides two viewers to
choose from:
•
JVISTA
•
CVISTA
Generally you can view reports using CVISTA as Intellicus Studio’s default
Viewer for report preview. View reports using JVISTA viewer (Intellicus Viewer),
when in actual scenario reports will be viewed in Intellicus Viewer.
Intellicus Desktop Studio: A Tour
35
Working with Layout Editor
How to set Viewers
Choice of viewer to be used for preview is set from Options dialog box.
Tools menu, click Options > Custom Design tab.
From
Figure 26: Setting the viewer choice for Report Preview
1. In Viewer drop down box, select the viewer.
2. If you have selected JVISTA, specify the path of JRE.
3. Click OK to save the changes and close Options dialog box.
How to Preview
When a report needs to be previewed,
1. Select the Preview tab on the main window. This will generate the output
of the report for preview.
2. You will be prompted for report parameters (if defined) before generating
the report.
3. After the Preview page is displayed, click the Refresh button on the
standard toolbar. This will refresh the values that have since changed in the
fields, if any.
When viewed in CVISTA
When you preview a report in CVISTA, the report will appear on Preview Tab.
Figure 27: Report Preview Toolbar when report viewed in CVISTA
Use of buttons is given below in the order of the appearance of buttons from left
to right.
Intellicus Desktop Studio: A Tour
36
Working with Layout Editor
•
Table of contents: This will be displayed when the report contains grouping
options. This will display a tree-like structure containing the group heading as
the main branch.
•
Search: To search for a text on report output.
•
Open: To open a previously saved report output.
•
Save: To save the opened report output.
•
Print Report: To print the open report output using printers setup with the
workstation where Intellicus Studio is running. When you click this button,
Print dialog box appears for you to specify print preferences before you
actually print the report.
•
Print Report Direct: To print the open report output using the default
printer setup with the workstation where Intellicus Studio is running.
•
Print At Server: To print report using any of the printers installed on the
machine running Intellicus Server. Printer selection and other preferences
are specified using Print At Server dialog box.
•
Arrow buttons: To reach to the 1 st page, the previous page, the next page
and the last page.
•
Cancel: To cancel report generation.
•
Report Export: To export open report in other formats. Clicking a button
will export it in respective formats, namely pdf, html, MS Excel, CSV and
text. Based on the export format selected, you may be given a dialog box to
provide required information. You can click the last button to get a screen to
select report type and then go ahead with report export.
Figure 28: Select the report format and continue
Select a report format, provide values if it asks for, and click Continue to
proceed with report export.
Intellicus Desktop Studio: A Tour
37
Working with Layout Editor
When viewed in JVISTA
When a report is viewed in JVISTA, it opens in a new window. It also has all the
functionalities that are available on the CVISTA’s toolbar.
Figure 29: Report Preview Toolbar when report viewed in JVISTA (Intellicus Viewer)
For detailed description on what you can do on JVISTA viewer (Intellicus Viewer)
please refer to the document ViewingReportsInJVista.pdf.
General Options
Custom Design tab on Options dialog box is used to carryout tasks related to
Studio configuration (Global settings).
These settings remain applicable to
Studio irrespective of open reports.
To get this dialog box, click Tools > Options > Custom Design tab.
Figure 30: Options > Custom Design
•
Place Labels with TextBoxes: Select this check box to place labels in
respective header section while placing Fields.
•
Enable Autolink Foreign Key: On SQL Editor, when you select two tables
which are already joined by Primary Key - Foreign Key elations in the
database, Intellicus can create a line indicating the join and also, respective
condition is added in WHERE clause of the query. To do this, select this
check box.
•
Import Crystal Report Script: During import of a Crystal report file, you
can import scripts written in crystal report.
Select this to import these
scripts.
•
Maximum File Listing: Specify the number of file names to be listed. These
are the names that appear as options under File menu.
Intellicus Desktop Studio: A Tour
38
Working with Layout Editor
•
SQL Maximum Rows: Specify the maximum number of rows that you want
to appear under Result tab of parser of SQL Editor.
•
Viewer: Select the viewer to be used for preview.
JVista and CVista.
•
JRE Path: Select path of Java Runtime Engine if you select JVista as Viewer.
Available options are
Report Properties Dialog box
tool-button or menu Tools > Report Properties to open Properties
Click
dialog box. On this dialog box you can specify:
•
Data Connection
•
Report summary
•
View Statistics
•
Layout information
Source Connection
From the Engine tab you can define the database (connection) to be used to
fetch data for the report / sub report.
You can choose from the following options available in this dialog:
Figure 31: Connection
Use Parent’s: This option will appear (and in selected state) when you are
working for a sub-report. This is applicable for sub-report.
Use Engine Default: This option will use the connection, which was marked as
default on Database Connections dialog. This option will appear as default
selected by default when you are working with a report that is not a sub report.
Intellicus Desktop Studio: A Tour
39
Working with Layout Editor
Use Named: Select this option to provide the named (configured) connection to
fetch data for the report. This will override the default connection.
Report summary and Statistics
Using the Summary tab you can specify report summary information.
Figure 32: Sub Report Summary Tab
Simply enter the information (text) relevant to the report in this tab.
On Statistics tab you can view report statistics.
Intellicus Desktop Studio: A Tour
40
Working with Layout Editor
Template
On this tab, you can select if to use alternate background color and alternate
foreground (text) color in the report.
Figure 33: Color and layout mode
A report becomes easier to read if rows of report are printed in alternate colors.
Intellicus provides three report layouts: Simple for freeform fields arrangement,
Tabular for list like (one line per row, with no space between fields), and Form
arrangement having one field below other.
Intellicus Desktop Studio: A Tour
41
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising