Chapter 12: Configuring FlexConnect

Chapter 12: Configuring FlexConnect
CH A P T E R
12
Configuring FlexConnect
This chapter describes FlexConnect and explains how to configure this feature on controllers and access
points. It contains the following sections:
•
Information About FlexConnect, page 12-1
•
Configuring FlexConnect, page 12-4
•
FlexConnect Access Point Groups, page 12-9
Information About FlexConnect
FlexConnect is a solution for branch office and remote office deployments. It enables customers to
configure and control access points in a branch or remote office from the corporate office through a wide
area network (WAN) link without deploying a controller in each office. There is no deployment
restriction on the number of FlexConnect access points per location. The FlexConnect access points can
switch client data traffic locally and perform client authentication locally when their connection to the
controller is lost. When they are connected to the controller, they can also send traffic back to the
controller.
FlexConnect is supported only on the 1130AG, 1240AG, 1142 and 1252 access points and on the 2000
and 4400 series controllers, the Catalyst 3750G Integrated Wireless LAN Controller Switch, the Cisco
WiSM, the Controller Network Module for Integrated Services Routers, and the controller within the
Catalyst 3750G Integrated Wireless LAN Controller Switch. Figure 12-1 illustrates a typical
FlexConnect deployment.
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-1
Chapter 12
Configuring FlexConnect
Information About FlexConnect
Figure 12-1
FlexConnect Deployment
This section contains the following topics:
•
FlexConnect Authentication Process, page 12-2
•
FlexConnect Guidelines, page 12-4
FlexConnect Authentication Process
When a FlexConnect access point boots up, it looks for a controller. If it finds one, it joins the controller,
downloads the latest software image from the controller and configuration information, and initializes
the radio. It saves the downloaded configuration in non-volatile memory for use in standalone mode.
A FlexConnect access point can learn the controller IP address in one of the following ways:
•
Note
If the access point has been assigned an IP address from a DHCP server, it discovers a controller
through the regular CAPWAP discovery process [Layer 3 broadcast, over-the-air provisioning
(OTAP), DNS, or DHCP option 43.]
OTAP does not work on the first boot out of the box.
•
If the access point has been assigned a static IP address, it can discover a controller through any of
the CAPWAP discovery process methods except DHCP option 43. If the access point cannot
discover a controller through Layer 3 broadcast or OTAP, we recommend DNS resolution. With
DNS, any access point with a static IP address that knows of a DNS server can find at least one
controller.
•
If you want the access point to discover a controller from a remote network where CAPWAP
discovery mechanisms are not available, you can use priming. This method enables you to specify
(through the access point command-line interface) the controller to which the access point is to
connect.
When a FlexConnect access point can reach the controller (referred to as connected mode), the controller
assists in client authentication. When a FlexConnect access point cannot access the controller, the access
point enters standalone mode and authenticates clients by itself.
Cisco Prime Network Control System Configuration Guide
12-2
OL-25451-02
Chapter 12
Configuring FlexConnect
Information About FlexConnect
Note
The LEDs on the access point change as the device enters different FlexConnect modes. See the
hardware installation guide for your access point for information on LED patterns.
When a client associates to a FlexConnect access point, the access point sends all authentication
messages to the controller and either switches the client data packets locally (locally switched) or sends
them to the controller (centrally switched), depending on the WLAN configuration. With respect to
client authentication (open, shared, EAP, web authentication, and NAC) and data packets, the WLAN
can be in any one of the following states depending on the configuration and state of controller
connectivity:
•
central authentication, central switching—In this state, the controller handles client
authentication, and all client data tunnels back to the controller. This state is valid only in connected
mode.
•
central authentication, local switching—In this state, the controller handles client authentication,
and the FlexConnect access point switches data packets locally. After the client authenticates
successfully, the controller sends a configuration command with a new payload to instruct the
FlexConnect access point to start switching data packets locally. This message is sent per client.
This state is applicable only in connected mode.
•
local authentication, local switching—In this state, the FlexConnect access point handles client
authentication and switches client data packets locally. This state is valid in standalone mode and
connected mode.
Local authentication is useful where you cannot maintain the criteria a remote office setup of
minimum bandwidth of 128 kbps with the roundtrip latency no greater than 100 ms and the
maximum transmission unit (MTU) no smaller than 500 bytes. In local switching, the authentication
capabilities are present in the access point itself. Thus local authentication reduces the latency
requirements of the branch office.
Note
Local authentication can only be enabled on the WLAN of a FlexConnect access point that is in
local switching mode.
Local authentication is not supported in the following scenarios:
– Guest Authentication cannot be done on a FlexConnect local authentication enabled WLAN.
– RRM information is not available at the controller for the FlexConnect local authentication
enabled WLAN.
– Local radius is not supported.
– Once the client has been authenticated, roaming is only be supported after the WLC and the
other FlexConnects in the group are updated with the client information.
•
authentication down, switching down—In this state, the WLAN disassociates existing clients and
stops sending beacon and probe responses. This state is valid only in standalone mode.
•
authentication down, local switching—In this state, the WLAN rejects any new clients trying to
authenticate, but it continues sending beacon and probe responses to keep existing clients alive. This
state is valid only in standalone mode.
When a FlexConnect access point enters standalone mode, WLANs that are configured for open, shared,
WPA-PSK, or WPA2-PSK authentication enter the “local authentication, local switching” state and
continue new client authentications. Other WLANs enter either the “authentication down, switching
down” state (if the WLAN was configured to central switching) or the “authentication down, local
switching” state (if the WLAN was configured to local-switch).
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-3
Chapter 12
Configuring FlexConnect
Configuring FlexConnect
When a FlexConnect access point enters standalone mode, it disassociates all clients that are on centrally
switched WLANs. For 802.1X or web-authentication WLANs, existing clients are not disassociated, but
the FlexConnect access point stops sending beacons when the number of associated clients reaches zero
(0). It also sends disassociation messages to new clients associating to 802.1X or web-authentication
WLANs. Controller-dependent activities such as 802.1X authentication, NAC, and web authentication
(guest access) are disabled, and the access point does not send any Intrusion Detection System (IDS)
reports to the controller. Furthermore, most Radio Resource Management (RRM) features (such as
neighbor discovery; noise, interference, load, and coverage measurements; use of the neighbor list; and
rogue containment and detection) are disabled. However, a FlexConnect access point supports dynamic
frequency selection in standalone modes.
Note
If your controller is configured for Network Access Control (NAC), clients can associate only when the
access point is in connected mode. When NAC is enabled, you need to create an unhealthy (or
quarantined) VLAN so that the data traffic of any client that is assigned to this VLAN passes through
the controller, even if the WLAN is configured for local switching. After a client is assigned to a
quarantined VLAN, all of its data packets are centrally switched.
The FlexConnect access point maintains client connectivity even after entering standalone mode.
However, once the access point reestablishes a connection with the controller, it disassociates all clients,
applies new configuration information from the controller, and reallows client connectivity.
FlexConnect Guidelines
Keep the following guidelines in mind when using FlexConnect:
•
A FlexConnect access point can be deployed with either a static IP address or a DHCP address. In
the case of DHCP, a DHCP server must be available locally and must be able to provide the IP
address for the access point at bootup.
•
FlexConnect supports a 500-byte maximum transmission unit (MTU) WAN link at minimum.
•
Roundtrip latency must not exceed 300 milliseconds (ms) between the access point and the
controller, and CAPWAP control packets must be prioritized over all other traffic. In cases where
you cannot achieve this, you can configure the access point to perform local authentication. See the
“FlexConnect Authentication Process” section on page 12-2 for more information about
FlexConnect local authentication using local authentication and local switching.
•
The controller can send multicast packets in the form of unicast or multicast packets to the access
point. In FlexConnect mode, the access point receives multicast packets only in unicast form.
•
FlexConnect supports CCKM full authentication but not CCKM fast roaming.
•
FlexConnect supports a 1-1 network address translation (NAT) configuration. It also supports Port
Address Translation (PAT) for all features except true multicast. Multicast is supported across NAT
boundaries when configured using the Unicast option.
•
VPN, IPsec, L2TP, PPTP, Fortress authentication, and Cranite authentication are supported for
locally switched traffic, provided that these security types are accessible locally at the access point.
Configuring FlexConnect
To configure FlexConnect, you must follow the instructions in this section in the order provided. This
section contains the following topics:
Cisco Prime Network Control System Configuration Guide
12-4
OL-25451-02
Chapter 12
Configuring FlexConnect
Configuring FlexConnect
•
Configuring the Switch at the Remote Site, page 12-5
•
Configuring the Controller for FlexConnect, page 12-6
•
Configuring an Access Point for FlexConnect, page 12-8
•
Connecting Client Devices to the WLANs, page 12-9
Configuring the Switch at the Remote Site
To prepare the switch at the remote site, follow these steps:
Step 1
Attach the access point that is enabled for FlexConnect to a trunk or access port on the switch.
Note
Step 2
The following sample configuration shows the FlexConnect access point connected to a trunk
port on the switch.
See the sample configuration that follows to configure the switch to support the FlexConnect access
point.
In this sample configuration, the FlexConnect access point is connected to trunk interface FastEthernet
1/0/2 with native VLAN 100. The access point needs IP connectivity on the native VLAN. The remote
site has local servers/resources on VLAN 101. A DHCP pool is created in the local switch for both
VLANs in the switch. The first DHCP pool (NATIVE) is used by the FlexConnect access point, and the
second DHCP pool (LOCAL-SWITCH) is used by the clients when they associate to a WLAN that is
locally switched. The bolded text in the sample configuration illustrates these settings.
Note
The addresses in this sample configuration are for illustration purposes only. The addresses that
you use must fit into your upstream network.
ip dhcp pool NATIVE
network 10.10.100.0 255.255.255.0
default-router 10.10.100.1
!
ip dhcp pool LOCAL-SWITCH
network 10.10.101.0 255.255.255.0
default-router 10.10.101.1
!
interface FastEthernet1/0/1
description Uplink port
no switchport
ip address 10.10.98.2 255.255.255.0
spanning-tree portfast
!
interface FastEthernet1/0/2
description the Access Point port
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,101
switchport mode trunk
spanning-tree portfast
!
interface Vlan100
ip address 10.10.100.1 255.255.255.0
ip helper-address 10.10.100.1
!
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-5
Chapter 12
Configuring FlexConnect
Configuring FlexConnect
interface Vlan101
ip address 10.10.101.1 255.255.255.0
ip helper-address 10.10.101.1
end
Configuring the Controller for FlexConnect
This section provides the procedure for configuring the controller for FlexConnect. The controller
configuration for FlexConnect consists of creating centrally switched and locally switched VLANs. This
procedure uses the following three WLANs as examples.
WLAN
Security
Switching
Interface Mapping (VLAN)
employee
WPA1+WPA2
Central
management (centrally switched
VLAN)
employee-local
WPA1+WPA2 (PSK) Local
101 (local switched VLAN)
guest-central
Web authentication
management (centrally switched
VLAN)
Central
To create a centrally switched WLAN, follow these steps. In our example, this is the first WLAN
(employee).
Step 1
Choose Configure > Controllers.
Step 2
Click the desired controller in the IP Address column.
Step 3
Choose WLANs > WLAN Configuration to access the WLAN Configuration page.
Step 4
Choose Add a WLAN from the Select a command drop-down list, and click Go.
Note
Cisco access points can support up to 16 WLANs per controller. However, some Cisco access
points do not support WLANs that have a WLAN ID greater than 8. In such cases, when you
attempt to create a WLAN, you get a message that says “Not all types of AP support WLAN ID
greater than 8, do you wish to continue?”. Clicking OK creates a WLAN with the next available
WLAN ID. However, if you delete a WLAN that has a WLAN ID less than 8, then the WLAN
ID of the deleted WLAN is applied to the next created WLAN.
Step 5
If you want to apply a template to this controller, choose a template name from the drop-down list. The
fields populate according to how the template is set. If you want to create a new WLAN template, click
the click here link to be redirected to the template creation page (see the “Configuring WLAN
Templates” section on page 10-21).
Step 6
Modify the configuration parameters for this WLAN. In our employee WLAN example, you must choose
WPA1+WPA2 from the Layer 2 Security drop-down list.
Step 7
Be sure to enable this WLAN by selecting the Status check box under General Policies.
Cisco Prime Network Control System Configuration Guide
12-6
OL-25451-02
Chapter 12
Configuring FlexConnect
Configuring FlexConnect
Note
If NAC is enabled and you created a quarantined VLAN for use with this, make sure to select
it from the Interface drop-down list under General Policies. Also, select the Allow AAA
Override check box to ensure that the controller validates a quarantine VLAN assignment.
Step 8
Click Save to commit your changes.
Step 9
Follow these steps to create a locally switched WLAN. In our example, this is the second WLAN
(employee-local).
a.
Follow the substeps in Step to create a new WLAN. In our example, this WLAN is named
“employee-local.”
b.
Click a WLAN ID from the original WLAN page to move to a WLANs edit page. Modify the
configuration parameters for this WLAN. In our employee WLAN example, you need to choose
WPA1+WPA2 from the Layer 2 Security drop-down list. Make sure you choose PSK
authentication key management and enter a preshared key.
Note
Make sure you enable this WLAN by selecting the Admin Status check box. Also, make sure
you enable local switching by selecting the FlexConnect Local Switching check box. When you
enable local switching, any FlexConnect access point that advertises this WLAN is able to
locally switch data packets (instead of tunneling them to the controller).
Note
For FlexConnect access points, the interface mapping at the controller for WLANs configured
for FlexConnect local switching is inherited at the access point as the default VLAN tagging.
This can be easily changed per SSID and per FlexConnect access point. Non-FlexConnect access
points tunnel all traffic back to the controller, and VLAN tagging is dictated by each interface
mapping of the WLAN.
c.
Step 10
Click Save to commit your changes.
Follow these steps if you also want to create a centrally switched WLAN that is used for guest access.
In our example, this is the third WLAN (guest-central). You might want to tunnel guest traffic to the
controller so that you can exercise your corporate data policies for unprotected guest traffic from a
central site.
a.
Follow the substeps in Step to create a new WLAN. In our example, this WLAN is named
“guest-central.”
b.
In the WLANs Edit page, modify the configuration parameters for this WLAN. In our employee
WLAN example, you must choose None from the Layer 2 Security and Layer 3 Security drop-down
lists on the Security tab, select the Web Policy check box, and make sure Authentication is
selected.
Note
If you are using an external web server, you must configure a preauthentication access control
list (ACL) on the WLAN for the server and then choose this ACL as the WLAN
preauthentication ACL.
c.
Make sure you enable this by selecting the Status check box.
d.
Click Save to commit your changes.
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-7
Chapter 12
Configuring FlexConnect
Configuring FlexConnect
e.
If you want to customize the content and appearance of the login page that guest users see the first
time they access this, follow the instructions in the “Configuring a Web Authentication Template”
section on page 10-67.
f.
To add a local user to this WLAN, choose Configure > Controller Template Launch Pad.
g.
Choose Security > Local Net Users from the left sidebar menu.
h.
When the Local Net Users page appears, choose Add Template from the Select a command
drop-down list, and click Go.
i.
Unselect the Import from File check box.
j.
Enter a username and password for the local user.
k.
From the Profile drop-down list, choose the appropriate SSID.
l.
Enter a description of the guest user account.
m.
Step 11
Click Save.
See the “Configuring an Access Point for FlexConnect” section on page 12-8 to configure two or three
access points for FlexConnect.
Configuring an Access Point for FlexConnect
This section provides instructions for configuring an access point for FlexConnect.
To configure an access point for FlexConnect, follow these steps:
Step 1
Make sure that the access point has been physically added to your network.
Step 2
Choose Configure > Access Points.
Step 3
Choose which access point you want to configure for FlexConnect by clicking it in the AP Name list.
The Access Point Detail page appears.
The last field listed in the Inventory Information group box indicates whether this access point can be
configured for FlexConnect. Only the 1130AG and 1240AG access points support FlexConnect.
Step 4
Verify that the AP Mode field displays FlexConnect. If it does not, continue to Step 5. If FlexConnect is
showing as supported, skip to Step 9.
Step 5
Choose Configure > AP Configuration Templates > Lightweight AP or Autonomous AP.
Step 6
Choose which access point you want to configure for FlexConnect by clicking it in the AP Name list.
The Lightweight AP Template Detail page appears.
Step 7
Select the FlexConnect Mode supported check box. Enabling this configuration allows you to view all
profile mappings.
Note
Step 8
If you are changing the mode to FlexConnect and if the access point is not already in
FlexConnect mode, all other FlexConnect parameters are not applied on the access point.
Select the VLAN Support check box and enter the number of the native VLAN on the remote network
(such as 100) in the Native VLAN ID text box.
Cisco Prime Network Control System Configuration Guide
12-8
OL-25451-02
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
Note
By default, a VLAN is not enabled on the FlexConnect access point. When FlexConnect is
enabled, the access point inherits the VLAN ID associated to the WLAN. This configuration is
saved in the access point and received after the successful join response. By default, the native
VLAN is 1. One native VLAN must be configured per FlexConnect access point in a
VLAN-enabled domain. Otherwise, the access point cannot send and receive packets to and from
the controller. When the client is assigned a VLAN from the RADIUS server, that VLAN is
associated to the locally switched WLAN.
Step 9
Click the Apply/Schedule tab to save your changes.
Step 10
The Locally Switched VLANs section shows which WLANs are locally switched and provides their
VLAN identifier. Click the Edit link to change the number of VLANs from which a client IP address is
obtained. You are then redirected to a page where you can save the VLAN identifier changes.
Step 11
Click Save to save your changes.
Step 12
Repeat this procedure for any additional access points that need to be configured for FlexConnect at the
remote site.
Connecting Client Devices to the WLANs
Follow the instructions for your client device to create profiles that connect to the WLANs you created
in the “Configuring the Controller for FlexConnect” section on page 12-6.
In our example, you create three profiles on the client:
1.
To connect to the “employee” WLAN, you create a client profile that uses WPA/WPA2 with
PEAP-MSCHAPV2 authentication. When the client becomes authenticated, it gets an IP address
from the management VLAN of the controller.
2.
To connect to the “employee-local” WLAN, you create a client profile that uses WPA/WPA2
authentication. When the client becomes authenticated, it gets an IP address from VLAN 101 on the
local switch.
3.
To connect to the “guest-central” WLAN, you create a profile that uses open authentication. When
the client becomes authenticated, it gets an IP address from VLAN 101 on the network local to the
access point. After the client connects, the local user types any HTTP address in the web browser.
You are automatically directed to the controller to complete the web-authentication process. When
the web login page appears, enter the username and password.
To see if data traffic of the client is being locally or centrally switched, choose Monitor > Devices >
Clients.
FlexConnect Access Point Groups
FlexConnect enables you to configure and control access points in a branch or remote office from the
corporate office through a wide area network (WAN) link without deploying a controller in each office.
There is no deployment restriction on the number of FlexConnect access points per location, but you can
organize and group the access points per floor and limit them per building, because it is likely the branch
offices share the same configuration.
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-9
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
By forming access point groups with similar configurations, a procedure such as CCKM fast roaming
can be processed more quickly than going through the controller individually. For example, to activate
CCKM fast roaming, the FlexConnect access points must know the CCKM cache for all clients that
could associate. If you have a controller with 300 access points and 1000 clients that can potentially
connect, it is quicker and more practical to process and send the CCKM cache for the FlexConnect group
rather than for all 1000 clients. One particular FlexConnect group could focus on a branch office with a
small number of access points so that clients in the branch office could only connect to and roam between
those few access points. With the established group, features such as CCKM cache and backup RADIUS
are configured for the entire FlexConnect group rather than being configured in each access point.
All of the FlexConnect access points in a group share the same WLAN, backup RADIUS server, CCKM,
and local authentication configuration information. This feature is helpful if you have multiple
FlexConnect access points in a remote office or on the floor of a building and you want to configure them
all at once. For example, you can configure a backup RADIUS server for a FlexConnect group rather
than having to configure the same server on each access point. Figure 12-2 illustrates a typical
FlexConnect group deployment with a backup RADIUS server in the branch office.
Figure 12-2
FlexConnect Group Deployment
This section contains the following topics:
•
FlexConnect Groups and Backup RADIUS Servers, page 12-10
•
FlexConnect Groups and CCKM, page 12-11
•
FlexConnect Groups and Local Authentication, page 12-11
•
Configuring FlexConnect Groups, page 12-11
•
Auditing a FlexConnect Group, page 12-13
FlexConnect Groups and Backup RADIUS Servers
You can configure the controller to allow a FlexConnect access point in standalone mode to perform full
802.1x authentication to a backup RADIUS server. You can configure a primary RADIUS server or both
a primary and secondary RADIUS server.
Cisco Prime Network Control System Configuration Guide
12-10
OL-25451-02
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
FlexConnect Groups and CCKM
FlexConnect groups are required for CCKM fast roaming to work with FlexConnect access points.
CCKM fast roaming is achieved by caching a derivative of the master key from a full EAP authentication
so that a simple and secure key exchange can occur when a wireless client roams to a different access
point. This feature prevents the need to perform a full RADIUS EAP authentication as the client roams
from one access point to another. The FlexConnect access points need to obtain the CCKM cache
information for all the clients that might associate so they can process it quickly instead of sending it
back to the controller. If, for example, you have a controller with 300 access points and 100 clients that
might associate, sending the CCKM cache for all 100 clients is not practical. If you create a FlexConnect
group comprising a limited number of access points (for example, you create a group for four access
points in a remote office), the clients roam only among those four access points, and the CCKM cache
is distributed among those four access points only when the clients associate to one of them.
Note
CCKM fast roaming among FlexConnect and non-FlexConnect access points is not supported.
FlexConnect Groups and Local Authentication
You can configure the controller to allow a FlexConnect access point in standalone mode to perform
LEAP or EAP-FAST authentication for up to 20 statically configured users. The controller sends the
static list of usernames and passwords to each FlexConnect access point when it joins the controller.
Each access point in the group authenticates only its own associated clients.
This feature is ideal for customers who are migrating from an autonomous access point network to a
lightweight FlexConnect access point network and are not interested in maintaining a large user database
nor adding another hardware device to replace the RADIUS server functionality available in the
autonomous access point.
Note
This feature can be used in conjunction with the FlexConnect backup RADIUS server feature. If a
FlexConnect group is configured with both a backup RADIUS server and local authentication, the
FlexConnect access point always attempts to authenticate clients using the primary backup RADIUS
server first, followed by the secondary backup RADIUS server (if the primary is not reachable), and
finally the FlexConnect access point itself (if the primary and secondary are not reachable).
Configuring FlexConnect Groups
To configure FlexConnect groups, follow these steps. If you want to apply a FlexConnect template to
multiple controllers, see the template instructions in the “Configuring FlexConnect AP Groups
Templates” section on page 10-40.
Step 1
Choose Configure > Controllers.
Step 2
Choose a specific controller by clicking the desired IP address.
Step 3
From the left sidebar menu choose FlexConnect > FlexConnect AP Groups. The established
FlexConnect AP groups appear.
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-11
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
Step 4
The Group Name column shows the group names assigned to the FlexConnect access point groups. If
you want to add an additional group, choose Add FlexConnect AP Group from the Select a command
drop-down list.
or
To make modifications to an existing template, click a template in the Template Name column. The
General tab of the FlexConnect AP Groups Template page appears.
Note
To delete a group name, click the group name you want to remove and choose Delete
FlexConnect AP Group from the Select a command drop-down list.
The Template Name field shows the group name assigned to the FlexConnect access point group.
Step 5
Choose the primary RADIUS authentication servers for each group. If a RADIUS authentication server
is not present on the controller, the NCS-configured RADIUS server does not apply.
Note
You must configure the RADIUS server configuration on the controller before you apply
FlexConnect RADIUS server configuration from the NCS.
Step 6
Choose the secondary RADIUS authentication servers for each group. If a RADIUS authentication
server is not present on the controller, the NCS-configured RADIUS server does not apply.
Step 7
If you want to add an access point to the group, click the FlexConnect AP tab.
Step 8
An access point Ethernet MAC address cannot exist in more than one FlexConnect group on the same
controller. If more than one group is applied to the same controller, select the Ethernet MAC check box
to unselect an access point from one of the groups. You should save this change or apply it to controllers.
Step 9
If you want to enable local authentication for a FlexConnect group, click the FlexConnect
Configuration tab. The FlexConnect Configuration tab appears.
Note
Step 10
Make sure that the Primary RADIUS Server and Secondary RADIUS Server parameters are set
to None on the General tab.
Select the FlexConnect Local Authentication check box to enable local authentication for this
FlexConnect group. The default value is unselected.
Note
When you attempt to use this feature, a warning message indicates that it is a licensed feature.
Step 11
To allow a FlexConnect access point to authenticate clients using LEAP, select the LEAP check box.
Otherwise, to allow a FlexConnect access point to authenticate clients using EAP-FAST, select the
EAP-FAST check box.
Step 12
Perform one of the following, depending on how you want protected access credentials (PACs) to be
provisioned:
Step 13
•
To use manual PAC provisioning, enter the key used to encrypt and decrypt PACs in the EAP-FAST
Key text box. The key must be 32 hexadecimal characters.
•
To allow PACs to be sent automatically to clients that do not have one during PAC provisioning,
select the Auto Key Generation check box.
In the EAP-FAST Authority ID text box, enter the authority identifier of the EAP-FAST server. The
identifier must be 32 hexadecimal characters.
Cisco Prime Network Control System Configuration Guide
12-12
OL-25451-02
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
Step 14
In the EAP-FAST Authority Info text box, enter the authority identifier of the EAP-FAST server in text
format. You can enter up to 32 hexadecimal characters.
Step 15
In the EAP-FAST Pac Timeout text box, specify a PAC timeout value by entering the number of seconds
for the PAC to remain viable in the edit box. The valid range is 2 to 4095 seconds.
Note
To verify that an individual access point belongs to a FlexConnect group, click the Users
configured in the group link. It advances you to the FlexConnect AP Group page, which shows
the names of the groups and the access points that belong in it.
Auditing a FlexConnect Group
If the FlexConnect configuration changes over a period of time either on the NCS or the controller, you
can audit the configuration. The changes are visible on subsequent screens. You can choose to
synchronize the configuration by refreshing the NCS or the controller.
Cisco Prime Network Control System Configuration Guide
OL-25451-02
12-13
Chapter 12
Configuring FlexConnect
FlexConnect Access Point Groups
Cisco Prime Network Control System Configuration Guide
12-14
OL-25451-02
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement