MotionGIF Help File - User Guide
© 2000-2010 Wisdom Software Inc. All rights reserved. Designated trademarks and brands are the
property of their respective owners.
Notice of Non-Liability
Wisdom Software Inc. and the authors assume no liability for errors or omissions, or for damages, resulting
from the use of this Manual or the information contained in this Manual.
Table of Contents
CHAPTER 1: INTRODUCTION
Getting Started
Frequently Asked Questions (FAQ)
Easy Guide
Technical Support
04
04
05
13
20
CHAPTER 2: MOTIONGIF BASICS
21
User Interface
Main Frame Window
Frame List - Selection & Deletion
Background
Library
Property Sheet
Toolbox
21
22
23
25
26
27
28
CHAPTER 3: MOTIONGIF FILES & FRAMES
Creating a New MotionGIF File
Frame Navigation
Adding/Duplicating Frames and More
Adding Frame Transition
Animation Preview
Creating an Animated GIF File
Exporting to HTML File
Print and Preview
CHAPTER 4: OBJECT BASICS
Creating an Object
Selecting Objects and Formatting
Deleting Objects
Undo and Redo
Fill and Line Color
© 2000-2010 Wisdom Software Inc. All rights reserved.
29
29
30
30
31
32
31
32
33
34
34
36
37
37
38
2
CHAPTER 5: OBJECT & IMAGE EDITING
Changing Object Properties
Selection Pointer (Hand)
Images, Importing and Editing
Text Object
Rectangle Object
Ellipse Object
Line/Arrow Object
Polyline Object
Brush Object
Rotation
Zooming
CHAPTER 6: REGISTRATION & LICENSING
Registration Benefits
How to Order
License Agreement
Distribution of Unlicensed Copy
About Wisdom Software
© 2000-2010 Wisdom Software Inc. All rights reserved.
39
39
39
40
44
45
45
46
46
47
50
51
52
52
52
54
55
56
3
CHAPTER 1: INTRODUCTION
An all-in-one and fast GIF animation creator!
MotionGIF 4 is an all-in-one, user-friendly and feature-rich software to create great looking animated GIF
files. It offers a very easy way to quickly create GIF animation for your Web pages.
With MotionGIF 4, you can create scalable, vector-based drawing objects as well as adding photos and
pictures. With an array of time-saving productivity tools, animation creation is just a few clicks away.
By drag & drop images from your hard drive or from the Internet, with your choice of adding animation
transition, your animated GIF will be created in no time.
KEY FEATURES
Easy to use, create exactly what you want GIF animation
MotionGIF combines drawing, painting and animation in one easy-to-use program to save your time and get
your job done with a minimum cost.
High productivity, time saving animation features
With 48 built-in visual effects, including fade and dissolve, it's just a few clicks, your animation is done. GIF
transparent color is also supported!
You can create your own library of objects and reuse them in any other MotionGIF file just drag & drop.
Background is a new layer to be used to appear in all frames.
High quality
All drawing objects can be translucent, and all images can have adjustable transparency to blend in. Text
quality is also improved and as well the enhanced image editor provides many image processing features.
Affordable
At $19.95 US, MotionGIF offers high price-performance value compared to other comparable products in the
industry.
Getting Started
System Requirements
•
•
Pentium 665MHz PC or higher
Windows 98/NT4/2000/ME/XP/2003/Vista and Windows 7 (compatible with 64-bit systems)
© 2000-2010 Wisdom Software Inc. All rights reserved.
4
Installation
•
Run SetupMotionGIF.EXE for self-extracting, automated installation.
Un-installing
•
Uninstall from your Windows Control Panel, Add/Remove Programs.
- Or -
•
Run Uninstall from the MotionGIF program menu.
Frequently Asked Questions (FAQ)
Before reporting any problems, please check this list, and the updated list at http://www.wisdomsoft.com/,
to see if there is a solution already.
Order / Purchase Questions
1.
2.
3.
4.
5.
6.
7.
8.
9.
What is an unlicensed copy? What does 'licensed' mean?
What are the ways to order?
Why PayPal?
I ordered online an hour ago. Where is my license key?
I faxed or mailed my order. How can I find out the status?
I need to install on more than one PC or on the network. How does the multi-license work?
How to determine how many licenses are needed for my organization?
What do I do if my computer crashed and I need a new copy of the software?
When installing a newer version, should I remove the old copy?
MotionGIF 4 Questions
Operations
•
•
•
•
•
•
•
•
•
How to make an image transparent?
What is a translucent object, and how to change the properties?
How to select more than one object?
How to select more than one frame?
How to change the frame display time?
How to add objects to a library file?
How to add frame transition effects?
Can I copy objects from MotionGIF file A to file B?
How to add a return (newline) in a Text object?
Importing / Editing images
•
•
•
How come some pictures cannot be drag & dropped from the browser? How do I import?
Where do I set the transparent color?
Why is that an MGF file has a big file size?
Animation / HTML
•
How do I add an animated GIF file to an HTML page?
© 2000-2010 Wisdom Software Inc. All rights reserved.
5
•
My GIF doesn't animate. How to troubleshoot?
Other
•
•
•
•
Where are the sample and library files after installation?
What are the known issues concerning MotionGIF?
How is a backup file named?
How to add a shortcut of MotionGIF on the desktop?
Order / Purchase Answers
1. What is an unlicensed copy? What does 'licensed' mean?
Our software products are sold in a "try before you buy" fashion. An unlicensed copy of our software may be used only for the
purposes of evaluating the software. You can make as many copies of the unlicensed copy of the software; give exact copies of the
original unlicensed copy to anyone; and distribute the unlicensed copy of the software in its unmodified form via electronic means.
There is no charge for any of the above.
Using unlicensed copy of a product after the evaluation period is in violation of federal and international copyright laws.
A licensed copy of the software may be used for an unlimited amount of time. For each installed instance of the software, a
separate license is required.
When a product is licensed, as a registered user, you will receive:
•
A license key that will remove all "Unregistered" stamps in the software, and unlock the features locked in the unlicensed
copy. This license key will be emailed to you, or mailed in the CD-ROM package.
•
The benefit to have free upgrades for all future minor releases downloaded from our web site. For example, if you
register MotionGIF 4, you can get a free upgrade for 4.1, 4.2.
•
Free technical support by email, FAX, or through the mail for 3 months.
2. What are the ways to order?
You can order your license in any one of the following ways,
•
•
•
•
•
•
Order online with your credit card. You can select to pay through PayPal or other online order services.
Order by fax or telephone with your credit card information.
Mail order with your check, money order in US or Canadian dollars.
Corporate Purchase orders for multiple licenses.
Bank wire transfer.
If none of the above options is available to you, you may send us a registered mail with your cash payment in US or
Canadian dollars.
Note: Registered mail with cash is at your own risk. We are not responsible for any lost mails.
© 2000-2010 Wisdom Software Inc. All rights reserved.
6
3. Why PayPal?
PayPal protects your financial information with industry-leading security and fraud prevention systems. When you use PayPal, your
financial information is not shared with the merchant. Once your payment is complete, you will be emailed a receipt for this
transaction and your license key is issued real-time.
If you prefer other means of ordering, we are also happy to serve you.
4. I registered an hour ago. Where is my license key?
If you order through the PayPal or Wisdom Software secure website, the license key is emailed to you automatically the minute the
credit card payment is approved.
If you order through RegSoft.com, the license key is emailed to you after we receive an email notice. That is within 12 hours.
If the email address is not correct or for any reason you don't find the license key in your email for a day, please email us at
[email protected] with your name and which program you bought, so we can check your order manually.
5. I faxed or mailed my order. How can I find out the status?
Please contact [email protected] and provide your name, email address and the date you sent in your order. Note that for
mailed orders with checks, your license key will not be sent until the check clears the bank.
6. I need to install on more than one PC or on the network. How does the multi-license work?
A single license does not allow you to install the software on the network or used by more than one PC. It allows you to install on
one PC only. The multi-license is an economical way of buying program licenses for a number of users for your organization,
network, small business or family PCs. Upon purchasing a multi-license, your multi-license key will be sent to you.
A Multi-license key is a file issued by Wisdom Software to permit the number of licensed installations. It also entitles you to future
upgrades of all licensed copies.
7. How to determine what multi-license is needed for my organization?
The number of multi-license is determined by the number of installations per user and per PC. That is, if 10 users use a PC with
different logins, a 10 user multi-license is required to install for these 10 users. Also, if there is only one person uses 5 PCs, a 5
user multi-license is required. If the 10 users are accessing all 5 PCs, a 50 user (5x10) multi-license is required.
If it is installed on a network server, the total number of client PCs, plus one for the server is required.
© 2000-2010 Wisdom Software Inc. All rights reserved.
7
8. What do I do if my computer crashed and I need a new copy of the software?
Download the software again and use the license key you already have to unlock it on the new computer. If you lost your license
key, email us your order information with your name and email address and approximate purchase date. We will send the license
key after verifying the sale.
9. When installing a newer version, should I remove the old copy?
Yes. We recommend that you uninstall the old version before installing the new version.
Uninstall is built-in with all our applications. You can click Start | Programs, point to the program's group, find and click Uninstall to
remove the application.
MotionGIF 4 Answers
Operations
How to make an image transparent?
Every image in MotionGIF there is a property called "Opacity". Opacity has a range of 0 to 100. 0 means completely transparent
and 100 means completely non-transparent. Any value between 0 to 100 will be transparent and blended.
Press "Alt" and "Enter" to show the Property Sheet. The Opacity property value can be changed in Property Sheet.
What is a translucent object, and how to change the properties?
For a drawing object, rectangle, circle, line, brush line, if the "Drawing Style" property is set to "Translucent", the object will be
show in the translucent mode.
Press "F4" to show the Property Sheet. You can find the "Drawing Style" property and choose between "Opaque" and
"Translucent".
How to select more than one object?
Hold down the Ctrl key and click the objects you need to select.
The first selected object handle color is blue, and the other following objects are green. Formatting is based on the first selected
object.
© 2000-2010 Wisdom Software Inc. All rights reserved.
8
How to select more than one frame?
Frame List shows all the frames. If Frame List is not visible,
•
Click the Frame List button on the Standard toolbar
- Or -
•
Press Shift+F1
In Frame List,
To select non-sequential frames, hold down the Ctrl and click frames to add one by one.
To select a series of frames, hold down the Shift key and click the start and end frame.
How to change the frame display time?
Doing either of the following will show the frame property sheet. You can change the display time in the Display Time field.
•
Double-click the frame where there is no underlying object
- Or -
•
Double-click a frame in the Frame List window.
When Property Sheet is shown, clicking a frame in the Frame List window will display the frame properties in Property Sheet.
How to add objects to a library file?
1. Select your objects (hold down Ctrl for multi-selection), or group them together so they are in one group.
2. Hold down Alt and drag the selected objects onto the library window. Then drop the objects.
3. A new object icon should be created in the library. You may change the name by clicking the name below the icon. You can
then just drag the object from the library and add to any frame.
Refer to Easy Guide for more.
How to add frame transition effects?
Adding frame transitions is an easy way to add visual effects to animate your frames. They are frame size images added
between two frames to show the frame transition. There are 48 built-in effects to choose from with speed options.
To add frame transition effects,
© 2000-2010 Wisdom Software Inc. All rights reserved.
9
•
Since new frames are inserted before the current frame, make sure the target frame is the current frame, and click the
Insert Frame Transition button on the Standard toolbar.
- Or -
•
Choose Insert Frame Transition from the Animation menu.
After pressing the Insert button in the Frame Transition dialog, new frames will be inserted before the current frame to show the
transition from the previous frame to this one.
Since the inserted frames contain only fixed images, they are less flexible. It's recommended that you finish the previous and
target frame completely before adding frame transition effects.
Can I copy objects from MotionGIF file A to file B?
Yes. In just two steps,
1. In MotionGIF file A, select the objects you need to copy (hold down Ctrl for multi-selection), and press Ctrl+C, or choose Copy
from the Edit menu.
2. Open file B by clicking the Open button on the toolbar or choose Open... from the File menu. Go to the frame you want to
have the objects copied, and press Ctrl+V. Or choose Paste from the Edit menu.
How to add a return(newline) in a Text object?
Hold down the Shift key and press Enter when editing a text object.
Importing / Editing images
How come some pictures cannot be drag & dropped from the browser? How do I import?
If a picture has an Hyperlink set, such as jumping to another page when clicked, the picture cannot be drag & dropped. You can
right-click the picture to save or, capture it using the ScreenHunter way.
To import,
(1) Right-click the picture and choose Properties from the browser pop-up menu. In the Properties box, highlight the
Address:(URL) part and press Ctrl+C.
(2) In MotionGIF, click the Image tool button. In the Open File dialog box, click the File name field to set the focus. Then, press
Ctrl+V to paste the address.
(3) Click Open to import.
Where do I set the transparent color?
GIF file transparent color can be set through the Animation properties dialog box.
To set GIF transparent color,
•
Click
- Or -
•
Choose Animation Properties from the Frame menu
on the Standard toolbar
© 2000-2010 Wisdom Software Inc. All rights reserved.
10
Set the GIF transparent color in the dialog box.
If High quality zooming for images is checked, the image may not be transparent even if the color may look close to the
transparent color.
Note: After the transparent color is set, all images, shapes with the same color will be transparent (you can't see anymore). For
example, if the transparent color is white, you will not see the white color anymore. If it's a red color, you will not see red in
images and shapes.
Why is that an MGF file has a big file size?
Since a GIF file only contains fixed images, saving the working file in the MGF file format allows you to retain all the object
information contained in your animation.
When an image is imported to MotionGIF, say a JPEG file, it is converted to a bitmap file internally. This is because MotionGIF
provides the ability to edit any image bit-by-bit. Using Image Editor, double-clicking the image, you can edit any part of the
image.
After editing is complete, you can create an animated GIF file. All images are converted to a small, high quality GIF file.
Animation / HTML
How do I add an animated GIF file to an HTML page?
Adding an animated GIF file to an HTML page is no different than adding any image.
Adding an animated GIF file to your HTML page is no different than adding any image. In FrontPage 2000, for example, these
are the steps,
1.
2.
3.
4.
In the Frame view, position the insertion point where you want to insert an image.
Click Insert Picture .
Click File.
Browse to the GIF image and then select the file.
My GIF doesn't animate. How to troubleshoot?
Here are the steps may be helpful to troubleshoot,
1.
In MotionGIF, check to see the animation is looped.
Click the 'Animation Properties' button on the toolbar
-OrChoose 'Animation Properties' in the Animation menu.
Choose 'Repeat forever' in the 'Animation looping' section if you want the GIF keep looping.
2.
Preview in Internet Explore.
Click the 'Preview in Internet Explore' button on the toolbar
-OrChoose 'Preview in Internet Explore' in the Go menu.
The previewed image is the same GIF that will be shown in Internet Explore when it's published on the Internet.
3.
Check the final GIF and HTML file in Internet Explore.
© 2000-2010 Wisdom Software Inc. All rights reserved.
11
After your final GIF is created, you can drag your final GIF file and drop on Internet Explore to view the result.
For the HTML file, you can double-click the MotionGIF generated HTML file to view as a Web page. Also, you can use
any text or HTML editor to confirm the code where the GIF is loaded in the HTML file.
Other
Where are the sample and library files after installation?
Sample and library files are copied to a sub-folder called "SamplesXXX" found in the folder where the main program is
installed. The "XXX" will be the version number.
To load a sample, choose Open... from the File menu, and locate the .MGF (MotionGIF File) file in the folder.
To open a library file, choose Open Library... from the Tools menu, and locate the .MGL (MotionGIF Library) file in the folder.
What are the known issues concerning MotionGIF?
Please refer to the list online.
How is a backup file named?
When the "Automatically take a backup of the original .MGF file before saving" checkbox on the Options/General tab is checked,
MotionGIF will automatically take a backup of the original file before saving.
The backup file name format is,
(original file name)_backupXXX.mgf
where "_backupXXX" is added to the original file name. XXX is a sequential number starting from 1.
How to add a shortcut of MotionGIF on the desktop?
If you don't want to find the program and manually make it, you can reinstall MotionGIF and check "Add a Shortcut to Desktop"
in the "Destination Location" dialog box. If you reinstall in the same directory, all MotionGIF settings will not be changed.
If that cannot be done for any reason, you can always do it manually by these easy steps,
To add a shortcut on the desktop
1. Click the Windows Start button, find and highlight MotionGIF in the menu (don't click).
2. Right-click and choose 'Create Shortcut' from the menu. A new MotionGIF (2) menu item should be added to the menu.
3. Highlight the newly created menu item, drag it and drop on your desktop.
To add in the Startup group
1. Using the above steps to create a shortcut on desktop.
2. Copy the shortcut to the following folder according to your OS,
(For Win95/98) {your windows folder}\Start Menu\Programs\StartUp
(For WinNT) {your windows folder}\Profiles\All Users\Start Menu\Programs\Startup
© 2000-2010 Wisdom Software Inc. All rights reserved.
12
(For Win2000/XP) {your windows drive C or D}:\Documents and Settings\{your profile}\Start Menu\Programs\Startup.
Easy Guide
This is a step-by-step guide to walk you through different scenarios. For other questions and answers, please check out the FAQs
frame.
1. 5 easy steps to create your animated GIF
2. Library guide
3. Adding animated GIF to an HTML page
4. Frame list guide - navigation, selection & deletion
1. 5 easy steps to create your animated GIF
MotionGIF is an all-in-one, user-friendly yet powerful and feature-rich tool to create great looking animated GIF files for
your Web pages. There are many ways and scenarios to use MotionGIF effectively. Here is a 5 step example to create an
animated GIF file.
[Step 1. Create a new MotionGIF file]
Run MotionGIF and create a new file by clicking the New MotionGIF File button on the toolbar or choosing New... from the
File menu. In the New MotionGIF File dialog, choose the frame size of the animation and repeat times when played (you
can change later). The new file is created with one frame.
© 2000-2010 Wisdom Software Inc. All rights reserved.
13
[Step 2. Add objects and images]
The toolbox works in a 'pick-a-tool-and-draw-an-object' fashion. To draw a freehand brush line, for example, you can
pick the brush tool, and draw a brush line. Double-click the created object to show Property Sheet and change its
properties. Use the image tool to import an image or create a new one. You can also double-click any image to edit in
Image Editor.
© 2000-2010 Wisdom Software Inc. All rights reserved.
14
[Step 3. Add and duplicate frames]
You can add a new frame by clicking the Add New Frame button on the toolbar or choose from the Animation menu. Or,
simply duplicate a frame by clicking the Duplicate Frames button. In the newly added frame, change or draw new objects
and images. Frame List is an easy way to lookup and manage frames.
© 2000-2010 Wisdom Software Inc. All rights reserved.
15
[Step 4. Add frame transition (optional)]
You can add frame transition as an visual effect by clicking the Insert Frame Transition button on the toolbar or choose
from the Animation menu.
[Step 5. Preview and publish]
To view the animation instantly, click the Preview button on the toolbar or choose from the Go menu. You also can play it
in the Web browser by clicking the Preview in Internet Explorer button on the toolbar.
To save the animation to an animated GIF file, choose Save As/GIF File from the File menu. You can add the newly
© 2000-2010 Wisdom Software Inc. All rights reserved.
16
created animated GIF to your HTML page the same way as you add any image file.
These are the only steps you need to create your own animation for your web. There are more features and options not
mentioned here. See the rest of the help file and explore more...
© 2000-2010 Wisdom Software Inc. All rights reserved.
17
2. Library guide
Library files contain objects that you can use in any MotionGIF file and any frame just a matter of drag & drop.
Open/Create a library File
Choose Open Library... from the Tools menu to open a .MGL (MotionGIF Library) file. When the Library window is shown
you can right-click the window and choose Open or Create from the menu.
To add objects to a Library
1. Make sure the Library window is visible and select the objects (hold down the Ctrl key for multi-selection) in the frame.
2. Hold down the Alt key and drag the selected objects to the Library window and drop. A new icon is create for the
library object. You can rename the icon.
To add an library object to a frame
Drag the library object and drop it in the main window.
3. Adding animated GIF to an HTML page
Adding an animated GIF file to your HTML page is no different than adding any image. In FrontPage 2000, for example,
these are the steps,
1.
2.
3.
4.
In the Frame view, position the insertion point where you want to insert an image.
Click Insert Picture.
Click File.
Browse to the GIF image and then select the file.
4. Frame list guide - navigation, selection & deletion
Frame List is a list of snapshots of all frames in the current MotionGIF file. It provides an easy way to manage frames.
To show/hide Frame List,
•
Click the Frame List button on the Standard toolbar
© 2000-2010 Wisdom Software Inc. All rights reserved.
18
•
•
- Or Choose Frame List from the View menu
- Or Press Shift + F1.
You can scroll through the list and click on any frame to work on.
To select a frame
•
•
Click the frame you need in the Frame List
- Or Press Shift + Left/Right Arrow keys to navigate
To select more than one frame
To select non-sequential frames, hold down the Ctrl key and click a frame to add one by one.
To select a series of frames, hold down the Shift key and click the start and end frame.
To duplicate frames
Press the Duplicate Frames button
on the toolbar to duplicate selected frames.
To delete selected frames
Press the Delete Frames button
on the toolbar to delete the selected frames.
© 2000-2010 Wisdom Software Inc. All rights reserved.
19
Technical Support
We provide free email technical support. Please email to [email protected]
Registered users can send email to [email protected] with your name and email address
included. Registered users have high priority in the support queue.
© 2000-2010 Wisdom Software Inc. All rights reserved.
20
CHAPTER 2: MOTIONGIF BASICS
User Interface
MotionGIF combines draw, paint and animation in one easy-to-use program to save your time and make
your work easy.
© 2000-2010 Wisdom Software Inc. All rights reserved.
21
Main Frame Window
Main Frame Window is the actual work area of a MotionGIF file. It shows the current frame all the time. If you
change to another frame, the new frame will be shown in the window.
The frame size is displayed in a rectangle. Outside the frame is shown in gray. If the frame and background
color are transparent, a check will be shown.
To change the frame properties,
Frame properties are changed through Property Sheet. To show Property Sheet if it's not visible,
•
•
•
•
Double-click a point where there is no underlying object
- Or Double-click a frame in Frame List window.
- Or Choose Object Properties from the Object menu
- Or Press Alt + Enter
If Property Sheet is visible, single click the above will update the property sheet.
To change the Grid Settings,
Choose Grid Settings from the View menu.
To change the frame size and animation properties,
Animation properties including frame size can be changed through the Animation Property dialog.
•
•
Click the Animation Properties button on the Standard toolbar
- Or Choose Animation Properties from the Frame menu
© 2000-2010 Wisdom Software Inc. All rights reserved.
22
Frame List - Selection & Deletion
Frame List is a list of snapshots of all frames in the current MotionGIF file. It provides an easy way to
manage frames.
© 2000-2010 Wisdom Software Inc. All rights reserved.
23
To show/hide Frame List,
•
•
•
Click the Frame List button on the Standard toolbar
- Or Choose Frame List from the View menu
- Or Press Shift + F1.
You can scroll through the list and click on any frame to work on.
To select a frame
•
•
Click the frame you need in the Frame List
- Or Press Shift + Left/Right Arrow keys to navigate
To select more than one frame
To select non-sequential frames, hold down the Ctrl key and click a frame to add one by one.
To select a series of frames, hold down the Shift key and click the start and end frame.
To duplicate frames
Press the Duplicate Frames button
on the toolbar to duplicate selected frames.
To delete selected frames
Press the Delete Frames button
on the toolbar to delete the selected frames.
© 2000-2010 Wisdom Software Inc. All rights reserved.
24
Background
Background is a layer behind all frames. It works the same way as a frame does. That is, it can have all kind
of objects too. One file has one common background which appears on all the frames.
You can add commonly used images, shapes to the background. So, no need to add one-by-one on each
frame.
Note: Diagonal lines indicate the background editing mode. When editing the background layer, all frame
individual frame objects will not be visible.
To edit / toggle the background,
Click
- Or -
on the Standard toolbar,
© 2000-2010 Wisdom Software Inc. All rights reserved.
25
Choose Background from the View menu.
- Or Press F4.
Library
A Library file is a file that contains pre-made objects that can be reused in any MotionGIF file and any frame
just a matter of drag & drop. A library file is saved with the extension MGL (MotionGIF Library file).
You can create your own library files, such as stamps, shapes, pointers, clipart, callouts, and arrows.
To show/hide Libraries,
Click the Library button on the Standard toolbar
- Or Choose Library from the View menu
- Or Press Shift + F3
To add objects to a library,
1. Make sure the library to which you want to add is the current one by clicking on the library title.
2. Select your objects (hold down the Ctrl key for multi-selection), or group them together so they are in
one group.
3. Hold down the Alt key and drag the selected objects onto the library window. Then drop the objects.
4. A new object icon should be created in the library. You may change the name by clicking the name
below the icon. You can then just drag the object from the library and add to any frame.
To open an existing library file,
1. Right-click the library window, and choose Open Library....
© 2000-2010 Wisdom Software Inc. All rights reserved.
26
- Or Choose Open Library... from the Tools menu
2. Find and click on an MGL file to open.
To create a library file,
1. Right-click on the library window, and choose New Library.
- Or Choose New Library from the Tools menu
2. Add objects to the library, and assign the file name in the Save dialog.
Property Sheet
Property Sheet lists all the properties of the currently selected object or multiple objects.
To show/hide Property Sheet,
Click the Property Sheet button on the Standard toolbar
- Or Choose Object Properties from the Object menu
- Or Press Alt + Enter
- Or Double-click the selected objects
To change a property,
Click the item you need to change and type or select a value.
© 2000-2010 Wisdom Software Inc. All rights reserved.
27
Toolbox
Toolbox contains a series of icons, each representing a specific tool.
The currently selected tool is displayed highlighted. The toolbox works in a 'pick-a-tool-and-draw-an-object'
fashion. To draw a freehand brush line, for example, you can pick the brush tool, and draw a brush line.
See the Object and Image Editing section for details.
© 2000-2010 Wisdom Software Inc. All rights reserved.
28
CHAPTER 3: MOTIONGIF FILES AND FRAMES
Creating a New MotionGIF File
A MotionGIF file is a file with the extension .MGF (MotionGIF File), which is a working file for creating your
animated GIF files.
To create a new file,
•
•
Choose New from the File menu
- Or Press Ctrl+N
In the New MotionGIF File dialog, choose the frame size of the animation and repeat times when played (you
can change later), and the default display time for each frame. The default display time will be used for new
frames, and you can also change it later for each frame.
When a new file is created, the first frame is automatically added to the file.
© 2000-2010 Wisdom Software Inc. All rights reserved.
29
Frame Navigation
Frames can be navigated through menu, navigation buttons or Frame List.
To go to a frame,
•
•
•
•
In the Frame List window, find the frame you want to go, click the frame.
- Or From the Go menu, choose Next Frame/ Previous Frame/First Frame/Last Frame.
- Or Press Shift + arrow keys
- Or Click the navigation buttons on the toolbar.
Note: Menu and navigation buttons will be enabled only if there are frames to be navigated.
Adding / Duplicating New Frames and More
To add a new frame,
•
•
•
Click the Add New Frame button
on the Standard toolbar
- Or Press Ctrl + Insert
- Or Choose Add New Frame from the Animation menu
To duplicate a frame,
•
•
Click the Duplicate Frames button
on the Standard toolbar
- Or Choose Duplicate Frames from the Animation menu
To duplicate multiple frames,
1. Select the frames you want to duplicate in Frame List.
To select non-sequential frames, hold down the Ctrl key and click a frame to add one by one.
To select a series of frames, hold down the Shift key and click the start and end frame.
2. Press the Duplicate Frames button
on the Standard toolbar, or from the Animation menu.
Duplicated single page will be added after the current page, and multiple pages will be added after the last
page.
© 2000-2010 Wisdom Software Inc. All rights reserved.
30
To change a frame's display time,
Each frame has a display time when it's animated. It can be changed through Property Sheet.
Doing either of the following will show the frame property sheet. You can change the display time in the
Display Time field.
•
•
Double-click the frame where there is no underlying object
- Or Double-click a frame in the Frame List window.
When Property Sheet is shown, clicking a frame in the Frame List window will display the frame properties in
Property Sheet.
Adding Frame Transition
Adding frame transitions is an easy way to add visual effects to animate your frames. They are frame size
images added between two frames to show the frame transition. There are 48 built-in effects to choose from.
To add frame transition effects,
•
Since new frames are inserted before the current frame, make sure the target frame is the current
•
on the Standard toolbar.
frame, and click the Insert Frame Transition button
- Or Choose Insert Frame Transition from the Frame menu.
After pressing the Insert button in the Frame Transition dialog, new frames will be inserted before the current
frame to show the transition from the previous frame to this one.
Since the inserted frames contain only fixed images, they are less flexible. Although you can delete transition
frame at any time, it's recommended that you finish the previous and target frame completely before adding
frame transition effects.
© 2000-2010 Wisdom Software Inc. All rights reserved.
31
Effect – Choose an effect from the Effect list.
Speed – Assign how fast the frame transition effect will be.
Animation Preview
You can preview the animation instantly by the built-in player.
To preview,
•
Press F5
- Or -
•
Click the Preview button on the Standard toolbar
- Or Choose Preview from the Go menu
•
Creating an Animated GIF File
To save the animation to an animated GIF file,
Choose Save as GIF File from the File menu.
You can add the newly created animated GIF to your HTML page the same way as you add any image file.
To add an animated GIF file to you HTML page using FrontPage 2000,
Adding an animated GIF file to your HTML frame is no different than adding any image. In FrontPage 2000,
for example, these are the steps,
1.
2.
3.
4.
In Frame view, position the insertion point where you want to insert an image.
Click Insert Picture.
Click File.
Browse to the GIF image and then select the file.
Exporting to HTML File
To export to an HTML file that uses the GIF file,
Choose Export to HTML File from the File menu.
© 2000-2010 Wisdom Software Inc. All rights reserved.
32
You can open the HTML file by any text or HTML file editor to copy/paste, or change the GIF file name to
add a file path if you need.
Print and Preview
To preview a printed frame,
1. Choose Print Preview from the File menu to display the Preview dialog box.
2. Click Zoom In to enlarge.
To print,
1. Choose Print... from the File menu and change the options.
2. Press OK to print.
© 2000-2010 Wisdom Software Inc. All rights reserved.
33
CHAPTER 4: OBJECT BASICS
Creating an Object
A frame can contain many objects. All drawing objects are scaleable.
To add an object,
1. Choose a tool from the toolbox.
2. Place the mouse in the frame window and find a start point.
3. Press down the left mouse button and drag to the size of your choice and release.
The new object default values will be used to create the new object.
To change the new object default values,
1. Click the Options button on the Standard toolbar
- Or Choose Options from the Tools menu
2. Click on the Default New Object Values tab and assign the values and click OK.
When creating an object, only items applicable to the object will be used as the default.
© 2000-2010 Wisdom Software Inc. All rights reserved.
34
To add objects from a library file,
1. Open a library file ( from the Tools menu, or right-click the library window ).
2. Drag an object from the library to the frame and drop at the point of your choice.
3. You may repeat the step 2, drag & drop as many as you like.
© 2000-2010 Wisdom Software Inc. All rights reserved.
35
Selecting Objects and Formatting
To select one object,
Using the selection tool - hand, single click an object to make the object selected.
To select more than one object,
Hold down the Ctrl key and click an object
To select more than one object in an area,
1. Choose the selection tool (hand) from Toolbox.
2. Position the pointer where you want the area to begin, press the left mouse button, and drag to the
point where you want the area to end. You will see a square is drawn when you drag the mouse.
3. Release the mouse button to end the area.
To select all objects in a frame,
•
•
Press Ctrl + A
- Or Choose Select All from the Edit menu
To move objects,
1. Select the objects
2. Drag the selected objects to a new location.
- Or Press the left and right arrow keys to move.
To format objects,
Formatting objects includes alignment, spacing and centering. The first selected object handle color is blue,
and the other following objects are green. Formatting is based on the first selected object.
© 2000-2010 Wisdom Software Inc. All rights reserved.
36
1. Select more than one object
2. Choose a format action from the Object menu.
Deleting Objects
To delete objects,
1. Select the objects you want to delete. See Select Objects on how to select.
2. Press the Delete key
- Or Choose Delete from the Edit menu
Undo and Redo
MotionGIF provides a multi-level Undo/Redo feature to make the design more enjoyable. You can use 10
level Undo/Redo for each frame.
Undo - undoes any changes made to a frame.
Redo - reapplies editing actions that have been undone.
To undo an action,
•
•
Press Ctrl + Z
- Or Choose Undo from the Edit menu
To redo an previously undone action,
•
•
Press Ctrl + Y
- Or Choose Redo from the Edit menu
Note: Undo/Redo only applies to the current frame. The history will be cleared when going to another frame.
Fill and Line/Border Color
Fill Color - currently selected objects' background color.
Line Color - currently selected objects' line color.
You can change the object properties in Property Sheet.
© 2000-2010 Wisdom Software Inc. All rights reserved.
37
You can select a color from the standard web color panel (6X6X6 Cube) by clicking the color you want. The
screen tip number is formatted as
# WebColor Red, Green, Blue ( 0 - 255)
© 2000-2010 Wisdom Software Inc. All rights reserved.
38
CHAPTER 5: OBJECT AND IMAGE EDITING
Changing Object Properties
To change the properties of an object,
1. Select the object.
2. Double click the object
- Or Right-click and choose Object Properties from the menu
- Or Choose Object Properties from the Object menu
3. Change the properties in Property Sheet.
Selection Pointer (Hand)
It is the on-screen indicator that moves when you move the mouse. It selects objects to make the objects
"selected".
Please see Selecting Objects for multiple selections.
© 2000-2010 Wisdom Software Inc. All rights reserved.
39
Images, Importing and Editing
You can import and create new images by using the image tool, and you also can edit the image using the
powerful Image Editor.
To import an image,
You can import an image file and insert it to anywhere of your choice. Image files supported are,
Bitmap files
JPEG files
PNG files
GIF files (including animated GIF)
TIFF files
TARGA files
PCX files
Portable Greymap
DIB
RLE files
Metafile
Enhanced Metafile
Icons
Cursors
Animation Cursors
.BMP
.JPG, .JPEG, .JPE
.PNG
.GIF
.TIF, .TIFF
.TGA
.PCX
.PGM
.DIB
.RLE
.WMF
.EMF
.ICO
.CUR
.ANI
Drag & drop - you can drag an image file from your desktop, Explore or Web browser and drop it directly on
the frame. The dropped image will appear on the top-left of the frame with the original image size.
- Or Use preview
1. Select the Image tool from the Toolbox.
2. Choose an image file to import.
To edit an image,
© 2000-2010 Wisdom Software Inc. All rights reserved.
40
1. Double-click the image. (when the "Edit image when double-clicked" checkbox is checked in the
Options/General).
- Or Select the image and show the property sheet. Click the Image field.
There are two ways in MotionStudio to change the image transparency.
(1) Transparent Color. Every image can have a "Transparent Color". Once a transparent color is
picked, say white, anywhere on the image with this color, white in this case, will be 100% transparent.
This can be used to create 100% transparent animation.
Press "Alt" and "Enter" to show the Property Sheet.
E.g.
© 2000-2010 Wisdom Software Inc. All rights reserved.
41
(2) Opacity. Every image has a property called "Opacity". Opacity has a range of 0 to 100. 0 means
completely invisible and 100 means completely visible. Any value between 0 to 100 will be
translucent and blended.
© 2000-2010 Wisdom Software Inc. All rights reserved.
42
Note: "Transparent Color" and "Opacity" are mutually exclusive. That is, if a Transparent Color is
picked, there is no effect on Opacity anymore.
2. The image editor features a wealthy collection of tools for you to edit your image.
3. Click OK in Image Editor to save the changes.
© 2000-2010 Wisdom Software Inc. All rights reserved.
43
Text Object
To add a text object to a frame,
1. Select the Text tool from Toolbox.
2. Click and drag to specify where the text is to start and end, and then type your text. You can either
enter text on-the-spot by pressing Enter or, in the Text field in Property Sheet.
Tip: To enter a return in the text, hold down the Shift key and press Enter.
Note: Only the text with a True-type font can be rotated. If a multi-line text object is rotated, only the first line
is shown.
Translucent Label
By choosing "Translucent" Drawing Style, and a Fill Color on Property Sheet, object will have translucent
effect.
© 2000-2010 Wisdom Software Inc. All rights reserved.
44
Rectangle Object
To add a Rectangle object,
1. Select the Rectangle tool from Toolbox.
2. Position the mouse pointer where you want one corner of the rectangle, and drag to the opposite
corner diagonally.
3. Release the mouse
A rectangle will be created with the default values set on the 'Default New Object Values' tab in the Options
dialog box.
Ellipse Object
To add an Ellipse object,
1. Select the Ellipse tool from Toolbox.
© 2000-2010 Wisdom Software Inc. All rights reserved.
45
2. Position the mouse pointer where you want one corner of the shape, and drag to the opposite corner
diagonally.
3. Release the mouse
If you drag & drop the tool from the toolbox, an ellipse will be created with the default values set on the
Default New Object Values tab in the Options dialog.
Line/Arrow Object
To add a Line object,
1. Select the Line tool from Toolbox.
2. Position the mouse pointer where the line starts, and drag to where the line ends.
3. Release the mouse
To add arrows to the line, select an Arrowhead with arrows in Property sheet.
Polyline Object
To draw a polyline,
© 2000-2010 Wisdom Software Inc. All rights reserved.
46
1. Select the Polyline tool from Toolbox.
2. Position the pointer where you want the line to start, press the left mouse button, and drag to the
spot where you want the line to go.
3. One left mouse click makes a middle point. Press the right mouse button or, double click the left
mouse button to terminate the line.
To edit polyline points,
You can add/move any editing point of a polyline. Please see Brush Object for the details.
Brush Object
The Brush tool is a freehand brush line tool which can be used to draw a line in any color and width (1- 100
pixels).
To draw a brush line,
1. Select the Brush tool from Toolbox.
2. Specify the starting point of the line.
3. Press the left mouse button to start and drag to draw the line in any direction freely.
4. After the line is drawn, all editing points are shown by default. (You can change this default in
Options/General.)
© 2000-2010 Wisdom Software Inc. All rights reserved.
47
To edit a brush line,
1. Select the brush line object.
2. Press
down on the Layout toolbar to show all editing points
- Or Right-click and toggle Edit Polyline Points in the menu
3. To move an editing point: Place the mouse over the editing point until the move point cursor
appears.
To add a new point: Place the mouse over the point where you want the new point added until the
cursor
appears.
To delete a point: Hold down the Shift key and place the mouse over the point until the cursor
appears.
4. Press the left button to move/add/delete the point.
To change the default values for a new object,
1. Click the options button
on the Standard toolbar,
- Or Choose Options from the Tools menu.
2. On the General tab, check/uncheck "Show editing points right after a polyline, brush or pen object is
created".
© 2000-2010 Wisdom Software Inc. All rights reserved.
48
2. On the Default New Object Values tab, select the Border / Line color and width for new objects. Then,
click OK
© 2000-2010 Wisdom Software Inc. All rights reserved.
49
Rotation
Rotation features are supported for drawing objects, such as Text, Rectangle, Ellipse....
To rotate an object,
1. Select the object you want to rotate.
2. Click
on the Layout toolbar. The tracker handles will be changed to circles.
- Or Right-click and toggle Rotate/Free Rotate from the context menu.
3. Drag any round handle to rotate freely to the angle you need. Then, release the mouse.
© 2000-2010 Wisdom Software Inc. All rights reserved.
50
4. Click
again to return to the normal mode.
- Or Right-click and toggle Rotate/Free Rotate from the context menu.
Note: You can type in an angle to rotate directly in the rotation combo on the Layout toolbar or in Property
Sheet.
Zooming
MotionGIF provides free zoom from 10% to 1000%.
To change the zoom ratio,
Select the zoom ratio from the zoom combo box on the Layout toolbar.
- Or Type the ratio in the ratio combo box.
- Or Choose Zoom In/Out in the View menu
To change the zoom ratio to 1:1,
Click
on the Layout toolbar.
- Or Type 100 in the ratio combo box.
- Or Choose Zoom to 1:1 in the View menu
© 2000-2010 Wisdom Software Inc. All rights reserved.
51
CHAPTER 6: REGISTRATION AND LICENSING
Registration Benefits
As a registered user, you will receive:
•
•
•
A license key that will remove all "Unregistered" stamps in the software, and unlock all features that
are locked in the trial period. This license key will be emailed to you, or mailed in the CD-ROM
package.
The benefit to have free upgrades for all future minor releases downloaded from our web site. For
example, if you register 4.0, you can get a free upgrade for 4.1, 4.2.
Free technical support by email with high priority, FAX, or through the mail, for one months.
Please see more on ordering FAQ.
How to Order
Price List
-- License Key
-- Multi-license file
-- CD-ROM
SINGLE LICENSE
When purchasing without the CD-ROM, a license key will be
emailed to you immediately after your order is processed.
PRICE
US$19.95
MotionGIF 4
SINGLE UPGRADE LICENSE
After receiving your order, a manual checking against our database will take
place in the next 48 hours. The new license key will be emailed to you after
the process if you're a registered user.
US$9.95
MotionGIF 4 upgrade from 3.x and earlier
MULTI-LICENSE
A Multi-license key is a file issued to unlock and
permit the number of licensed installations.
MotionGIF 4, 2-14 licenses (each)
MotionGIF 4, 15-49 licenses (each)
MotionGIF 4, 50-199 licenses (each)
PRICE
(Save 20% )
(Save 40% )
(Save 50% )
© 2000-2010 Wisdom Software Inc. All rights reserved.
PRICE
US$16.00
US$12.00
US$10.00
52
MotionGIF 4, 200-499 licenses (each)
(Save 60% )
PRODUCT CD-ROM AND SHIPPING
After your license key is emailed to you immediately, a CD-ROM is shipped by
air in 3 days.
Product CD-ROM and shipping
•
•
•
US$8.00
PRICE
US$15.00
All taxes are included in the prices.
All prices are subject to change. Visit our website for the latest information.
For private label/OEM offers and other volume discount rates, please email
[email protected] or contact us for details.
Shop Online
Safe, Easy and Fast.
You can use your credit card to order online at http://www.wisdom-soft.com for immediate license key
delivery 24x7, or place your order through online order services such as RegSoft, RegNow.
Telephone Orders
•
•
Telephone orders with your credit card.
Please have your credit card (Visa/MasterCard/AMEX) ready.
Monday to Friday 9:00AM to 5:00PM Pacific Time
Fax Orders
•
•
•
Print out the supplied order form included in the program group.
Fax the completed order form.
Your license key is sent via email.
Mail Orders
•
•
•
Please make your check or money order payable to Wisdom Software Inc.
Print out and complete the order form included in the program group.
Shipping is air mail worldwide.
Corporate Purchase Orders
We take corporate purchase orders for multi-licenses.
Bank Wire Transfer
•
•
•
We take direct bank wire transfer to our bank account as payment.
Please send your order by fax or email, indicating the payment will be bank wire transferred.
For our bank account information, click to contact us. [email protected]
© 2000-2010 Wisdom Software Inc. All rights reserved.
53
Cash Order
Although not recommended, if none of the above options is available to you, you may send us a registered
mail with your cash payment in US or Canadian dollars.
Note: Registered mail with cash is at your own risk. We are not responsible for any lost mails.
Wisdom Software License Agreement
NOTICE TO USER It is important that you read this document before using the enclosed software (the
"Software"). By using the Software, you agree to be bound by the terms of this Agreement. This is a legal
document between you (the "User") and Wisdom Software ("Wisdom").
Software License
LICENSE GRANT. Wisdom grants User a non-exclusive, non-transferable, limited license to use the
Software with compatible equipment.
COPYING. This software is licensed for use on a single computer in a single location. Any copying of the
software is prohibited.
OTHER RESTRICTIONS. User may not loan, lease, distribute or transfer the Software or copies thereof, nor
reverse engineer or otherwise attempt to discern the source code of the Software.
Warranty
DISCLAIMER. THE SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF PERFORMANCE OR
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. USER BEARS ALL RISK RELATING
TO THE USE OF THE SOFTWARE.
LIMITATION OF LIABILITY. In no event will Wisdom, its suppliers and distributors be liable for any lost
profits or other damages, including direct, indirect, incidental, special, consequential or any other type of
damages, arising out of this Agreement or the use of the Software licensed thereunder, even if Wisdom has
been advised of prior possibility of such damages.
General Provisions
GENERAL PROVISIONS. Neither this Agreement nor any part or portion hereof shall be assigned,
sublicensed or otherwise transferred by User. Should any provision of this Agreement be held to be void,
invalid, unenforceable or illegal by a court, the validity and enforceability of the other provisions shall not be
affected thereby. Failure of a party to enforce any provision of this Agreement shall not constitute or be
construed as a waiver of such provision or of the right to enforce such provision.
Distribution of Unlicensed Copy
Provided that you verify that you are distributing the unlicensed copy (check the About dialog box) you are
hereby permitted to make as many copies of the unlicensed copy of this software and documentation as you
© 2000-2010 Wisdom Software Inc. All rights reserved.
54
wish; give exact copies of the original unlicensed copy to anyone; and distribute the unlicensed copy of the
software and documentation in its unmodified form via electronic means.
There is no charge for any of the above.
© 2000-2010 Wisdom Software Inc. All rights reserved.
55
About Wisdom Software
Company Overview
Wisdom Software's mission is to make your digital life easier, more exciting and
successful through software.
Founded in 1997, Wisdom Software has produced creative graphics software in the
PC world designed to fulfill our mission. Dedicated to use the latest technology,
Wisdom Software solutions provide the edge you need to succeed either
professionally or personally.
Over 5 million copies of our products were downloaded in the year 2007 alone. With
users spanning from individuals, small businesses to multinational corporations
including governments and educational institutions, Wisdom Software has users in
countries all over the world.
Product Family
Screen Recording and Capture Solutions
• AutoScreenRecorder
An easy-to-use and powerful screen recording software.
•
ScreenHunter
A total screen capture solution.
Interactive Multimedia Experience
• MotionStudio
An all-in-one, easy multimedia authoring software to make interactive
desktop animation EXE files and auto-run CD.
•
MotionGIF
An all-in-one, easy and feature-rich animated GIF creator for Web
animation.
Contact
Please visit www.wisdom-soft.com for detailed contact information.
© 2000-2010 Wisdom Software Inc. All rights reserved.
56
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement