Configuration Tool User`s Guide
National Fire Incident Reporting
System
(NFIRS 5.0)
Configuration Tool User's Guide
NFIRS 5.0 Software Version 5.3
Prepared for:
FEMA
Round Hill, VA 20142
Prepared by:
Verizon Federal Incorporated
P.O. Box 309
Round Hill, VA 20142
CONFIGURATION TOOL GUIDE
NFIRS 5.0
TABLE OF CONTENTS
1.
INTRODUCTION: ............................................................................................................................... 3
2.
USER OPTIONS TAB: ........................................................................................................................ 4
2.1
2.2
2.3
2.4
2.5
FILE IMPORTING:.................................................................................................................. 5
DATA VALIDATION: ............................................................................................................... 5
PERFORMANCE CONTROL: ................................................................................................... 6
INCIDENT FILE DELIMITER:.................................................................................................... 7
SHOW SECONDS:................................................................................................................. 7
3.
FORMS TAB: ....................................................................................................................................... 8
4.
THE ADVANCED TAB ....................................................................................................................... 9
4.1
4.1.1
4.1.2
4.1.3
4.1.4
4.1.5
OFF-LINE ACCESS: .............................................................................................................. 9
CONFIGURATION FOR ACCESS 97 ....................................................................................... 10
CONFIGURATION FOR ACCESS 2000 AND ACCESS 2002 (XP) - NEW USERS........................ 11
OFF-LINE USERS: VISUAL FOXPRO 6.0 SETUP ................................................................... 12
OFF-LINE USERS: MS SQL SERVER 7.0 OR MS SQL SERVER 2000 SETUP ....................... 13
PREVIOUS VERSION 5.0 USERS OF VISUAL FOXPRO 6.0 OR MS SQL SERVER 7.0 .............. 15
4.2
4.3
4.4
4.5
4.6
ON-LINE MODE:................................................................................................................. 15
NEGOTIATE FIREWALL ........................................................................................................ 16
PROXY AUTHORIZATION: .................................................................................................... 16
CACHE APPLICATION DATA:................................................................................................ 17
EVENT LOGGING LEVEL ...................................................................................................... 17
5.
THE TRANSACTIONS TAB ............................................................................................................ 18
6.
SAVING USER CONFIGURATIONS ............................................................................................. 18
7.
INDEX: ................................................................................................................................................. 19
JANUARY 2004
2
CONFIGURATION TOOL GUIDE
NFIRS 5.0
1. Introduction:
The Configuration Tool User’s Guide provides comprehensive documentation of the
Configuration Tool components available to the user. The Guide facilitates user control of
the NFIRS Client Suite and enables the user community to quickly and efficiently begin
using the Configuration Tool. The Guide is intended for new users of NFIRS 5.0
Software Version 5.3 as well as users updating from previous versions.
The Configuration Tool provides the user the capability to specify the import location of
data files, whether to run against an On-Line or Off-Line database, the address of the
firewall (if present in the user’s network), and whether data encryption is to be utilized.
The user may open the Tool by clicking the Start button…Programs…NFIRSv53
…Configuration Tool, or from the Data Entry Tool Menu bar click on Tools…Client
Configuration Tool. No Internet Connection is required to open this tool.
The Configuration Tool contains four tabs that enable the user to navigate the available
screens: the User Options Tab, the Forms Tab, the Advanced Tab. Each tab provides
specific functionality and options to the User. To view a tab, single click on desired Tab
heading. Note: The Transactions Tab is not activated at this time.
The User Options Tab provides the user options of importing data to a database or flat
file, to accept invalid records during import, and overwrite existing incidents during import.
The user has the ability to set import performance control for Off-Line, On-Line-network
or On-Line-modem, set the batch size during the import of data, set the delimiter, and
specify whether to show seconds in times’ display or not. The user makes the
appropriate selections using the check boxes and drop down menus.
Most configuration changes that affect imports can be made dynamically from within the
Data Entry Tool. Refer to the specific component’s section for compete details. For
example, the access mode cannot be changed dynamically. The user must exit the
Configuration Tool for the change from Off-Line access to On-Line access to occur.
The Forms Tab lists the available Client GUIs (modules) which the user sees displayed
on their computer and uses to enter their incident information. The available forms are
Basic, Fire, Structure, Civilian Casualty, Fire Service Casualty, EMS Casualty, Wildland,
HazMat and Arson.
The Advanced Tab provides the user the ability to specify the Off-line or On-Line access
mode, specify the database type, set firewall configuration, enter HTTP or Socks firewall
Internal IP address and Port, Cache Application Data, and set the Event Logging level.
Instructions for Off-Line users of the NFIRS 5.0 Software Version 5.3 who must specify
the Database Type and verify configuration information before using the Data Entry Tool
in the Off-Line mode, are included in separate sections in the Advanced Tab section fo
this document.
With the release the USFA NFIRS 5.0 Version 5.3 client software, CORBA and its
components, which handled the communication protocol in previous versions, have been
removed. The NFIRS 5.0 Version 5.3 communication protocol uses HTTPS over port
443, an industry standard protocol which is much more robust. This change requires
users to upgrade to Version 5.3 after its release, before logging into the National
Database.
The following sections describe in detail the appearance and function of the Configuration
Tool components.
JANUARY 2004
3
CONFIGURATION TOOL GUIDE
NFIRS 5.0
2. User Options Tab:
The User Options Tab (diagram 2.0) provides several options to assist the user make
an accurate Import / Export or Conversion of data. The user can choose from the
following options: to import data to a Database or Flat File, Accept Invalid Records
During Import, Overwrite Existing Incidents During Import, Import Performance Control
for Off-Line, On-Line-Network or On-Line-Modem. The user can set the Batch Size during
the import/export of data, set the Incident File Delimiter, and choose whether to Show
Seconds or not. The options are provided in check boxes and/or drop down menus.
The user will not necessarily change or reset every option available each time they use
NFIRS 5.0, but it is recommended that users review User Options settings before new
data import tasks, or when troubleshooting data import issues.
Most users operate the tool with the default settings shown in Diagram 2.0 below. If
changes are made to settings, click the Save button in the lower left corner before
clicking OK or closing the screen.
Diagram 2.0
JANUARY 2004
4
CONFIGURATION TOOL GUIDE
2.1
NFIRS 5.0
File Importing:
The File Importing check boxes provide the user the option to import data to a
Database or to a Flat File (Diagram 2.1.0). The Import to Database option is for
importing data to a database; either an Access 97, Access 2000, Access 2002,
Visual FoxPro 6.0 or MS SQL Server 7.0, MS SQL Server 2000, an Oracle
database, or to the National Database. Importing to a flat file runs the data
through the validation process and creates log files detailing the validation
process.
To specify an option, click on the check box next to the desired import location.
Diagram 2.1.0
The user may locate the log files for an import by double clicking on the “out”
folder that is created during the import process. The out folder location defaults to
the NFIRSv53 root directory, or the location where the original import file is
stored. To access the out folder from the Validation Tool window, click the View
File button.
Note: The out folder will not exist until the first data import takes place. For
details, see the Import/Export (Section 5.1) in The Data Entry/Validation Tool
User’s Guide.
If the data file is on a 3 ½ floppy disk, it is recommended the data file be saved to
the PC’s hard drive before the import process.
The log files created during an import are:
Filename.err
Filename.log
Filename.bad
filename.txt
2.2
A listing of the validation errors
A file listing the validation process
A listing of all the bad transactions
(critical or fatal)
A replication of the original file
Data Validation:
Two check boxes facilitate incident validation: Accept Invalid Records During
Import and Overwrite Existing Incidents. Data validation checks take place
during manual incident entry and during data imports. (See the Data
Entry/Validation Tool Users Guide posted on the NFIRS 5.0 Web site). During
data import processing, the user is provided the option to accept data that has
JANUARY 2004
5
CONFIGURATION TOOL GUIDE
NFIRS 5.0
not passed data validation (failed a validation check) by checking the Accept
Invalid Records During Import checkbox (diagram 2.2.0). If Accept Invalid
Records During Import checkbox is not checked, imported data not passing
validation will not be imported to the database or the flat file and instead will be
written to a separate file with the extension “.bad".
Upon successful installation, the Accept Invalid Incidents Upon Import is checked
by default.
Note: Improper data such as alpha data in a numeric field is never allowed.
Diagram 2.2.0
The Overwrite Existing Incidents check box provides the user the option to
overwrite existing incidents during the import of data. If the box is checked,
during the import of the data, incidents with the same Key Information in the
database (Local or National database) will be overwritten with the data that is
being imported. Upon successful installation, this box is checked by default.
2.3
Performance Control:
The user may select the connection performance during the import of data by
choosing the Import Performance Control for Off-Line, On-Line-Network or
On-Line-Modem. By specifying the performance control, the user is establishing
the optimum connection to the database used to import data to the database.
Thus, if the user is working on-line using a modem connection and importing
incidents to the National Database, the On-Line Modem setting provides three
connections to the database. When the user is working off-line and is importing
data to a local database, the Off-Line setting provides one connection.
Note: The Import Performance Control default setting is Off-Line Modem, which
most users will find sufficient for importing.
Batch Size specifies to the application how many transactions are to be bundled
together and then imported to the database. The default setting is Medium.
JANUARY 2004
6
CONFIGURATION TOOL GUIDE
2.4
NFIRS 5.0
Incident File Delimiter:
If the user chooses to import from a flat file, the option of an Incident File
Delimiter is provided (diagram 2.4.0). Field delimiters are symbols placed
between fields that enable software to differentiate between the fields. The
Incident File Delimiter defaults to the ^ sign (caret). If another delimiter is
chosen, it must be a symbol that will not appear in the data file in order to prevent
failed data loads.
To change the setting, highlight the symbol displayed in Incident File Delimiter
box and type in desired character, or highlight the symbol displayed and press
Delete. Type in desired character.
Diagram 2.4.0
2.5
Show Seconds:
The Show Seconds option enables the user to specify a higher level of incident
reporting precision by designating to the degree of seconds vice hours and
minutes (diagram 2.5.0).
Seconds may always be entered in any time field. If Show Seconds is set to “No”
then a field will only show seconds if it is not equal to zero. If Show Seconds is
set to “Yes” then the affected window will always show seconds precision.
Check the box to show seconds or uncheck not to show seconds equal to zero.
Diagram 2.5.0
JANUARY 2004
7
CONFIGURATION TOOL GUIDE
NFIRS 5.0
3. Forms Tab:
The Forms Tab (diagram 3.0) lists the available Client GUIs (modules) which the user
sees displayed on their computer when using the NFIRS application to enter their
incident information. The available forms are Basic, Fire, Structure, Civilian Casualty,
Fire Service Casualty, EMS Casualty, Wildland and Hazmat, Personnel, Arson and Fire
Department header.
Note: Modifying the class name of the Client GUIs will result in the user being unable to
open a module, and/or an exception message will occur and the user will be unable to
open the module.
Diagram 3.0
JANUARY 2004
8
CONFIGURATION TOOL GUIDE
4.
NFIRS 5.0
The Advanced Tab
The third tab on the NFIRS Configuration Tool is the Advanced Tab (diagram 4.0).
Configuration options under the Advanced Tab include specifications for Off-Line or OnLine Access to a database, ODBC Data Source and Driver Name, database type,
communications protocol, firewall address, cache application data and logging level.
After successful installation, Off-line users setting up a local database will need to open
the Configuration Tool and check the Off-Line Access box to specify the mode, verify the
Database Type and enter configuration information, if necessary, in the On-Line Access
area. An Internet connection will be required for Off-line users in order to perform initial
User Injection, Remote Synchronization, and send incidents to the National Database.
Instructions for each database type are included in the sections listed below.
Diagram 4.0
4.1
Off-Line Access:
The first check-box on the Advanced Tab is Off-Line Access. When the user checks the
Off-Line Access check box, they are specifying that FD and incident information they
enter and save will be saved to a local database (on the User's PC). NFIRS 5.0 Software
Version 5.3 provides options for the local database applications: Access 97, Access
2000, Access 2002 (XP), Visual FoxPro 6.0, MS SQL Server 7.0, and MS SQL Server
2000. The database program the user selects must be on the PC prior to installing NFIRS
5.0 Software Version 5.3.
JANUARY 2004
9
CONFIGURATION TOOL GUIDE
NFIRS 5.0
The Oracle 7.3x or 8.3x database (diagram 4.1.0) options are for remote use only.
When Off-Line Access is checked, the ODBC Data Source Name must be specified.
Users using Access 97, 2000, or 2002 will use the default name: jdbc:odbc:nfirsodbc53
(as shown in Diagram 4.0).
When Off-Line Access is checked, the ODBC Driver Name must be specified, and will
default to the description of the manufacturer. Users using Access 97, Access 2000, or
2002 do not have to change the default name (shown in Diagram 4.0).
If the local database requires a database username and password, click the Set DB User
button. When clicked, a pop-up window will appear where the user can specify
username and password. Note: The username defaults to Scott. Most users will NOT
need to set the database password.
The default Database Type is Access 97 (an Access 97 database will be installed during
Typical installation). The Off-Line user must specify the database application that will be
used as the local (Off-Line) database engine.
Reminder: Off-Line users must have the database program of their choice installed on
the PC prior to the installation of NFIRS 5.0 Software Version 5.3. The default Database
Type is Access 97. Users of NT, Windows 2000, and XP must be logged to the PC as its
system administrator to install the NFIRS software.
It is recommended that users upgrading from Microsoft Office 97 to Microsoft Office 2000
perform the upgrade of the office suite first, and then install the database program they
choose to use for their local NFIRS 5.0 database, followed by NFIRS 5.0 Client Software.
Regular database maintenance is recommended to maintain optimum performance of the
local database. Access Users will find complete steps for the procedure to compact the
Access database in the Data Entry Tool Users Guide or at the Tutorial Page,
http://www.nfirs.fema.gov/tutorial.htm. FoxPro and MS SQL Server users should follow
the database maintenance procedures as recommended by the manufacturers of the
program.
Section 4.1.1 provides setup instructions for Access 97 Off-Line users.
Section 4.1.2 provides setup instructions for Access 2000 and Access 2002 (XP) OffLine users.
Section 4.1.3 provides instructions for Visual FoxPro 6.0 local database setup.
Section 4.1.4 provides instructions for MS SQL Server 7.0 and MS SQL Server 2000
local database setup.
The Data Entry Tool Users Guide provides complete information on the User Injection
and data entry.
4.1.1 Configuration for Access 97
After successful installation of the NFIRS 5.0 software Version 5.3, users who
have Access 97 on the PC must open the Configuration Tool and click on the
Advanced Tab. Check the Off-Line Access box. Proceed to initial User Injection.
Users behind a firewall or using a proxy server will need to enter configuration
information in the On-Line Access section of the Advanced Tab before
proceeding with Initial User Injection. For complete details on User Injection, refer
to the Data Entry Tool Users Guide.
JANUARY 2004
10
CONFIGURATION TOOL GUIDE
NFIRS 5.0
Users of Previous Software Version 5.2.3, 5.2.1, 5.1, 5.0 or Version 4.0
Users of the previous NFIRS 5.0 Software Versions 5.2.3, 5.2.1, 5.1, 5.0, or 4.0
who have fire department and incident data saved to their Access 97 local
database (Named: NfirsdataV523.mdb , NfirsdataV521.mdb, NfirsdataV51.mdb,
NfirsdataV5 or NfirsdataV4.mdb) can move the database into the new Software
Version 5.3 Database folder after successful installation. Users will begin by
making a back up copy of the Versions 5.2.3, 5.2.1, 5.1, 5.0, or Version 4.0 local
database. The user will then install the NFIRS 5.0 Software Version 5.3, and
move the old database to the new Version 5.3 Database folder and rename it to:
NfirsdataV53.mdb.
Remote Synchronization is required to update the Off-Line database with rules
and codes from the National Database. When beginning the Remote Synch
process, the user will be prompted to “Apply Schema Changes?” Click Yes to
proceed with the User Injection/ Remote Synchronization process. The Data
Entry Tool User's Guide provides complete instructions.
4.1.2 Configuration for Access 2000 and Access 2002 (XP) - New Users
Users with Access 2000 or Access 2002 (Access XP) on the PC will need to
complete the installation of the NFIRS 5.0 Software Version 5.3, specify the OffLine access mode, and then convert and rename the database before specifying
the Database Type on the Advanced Tab. After the database has been
converted and renamed, the user can proceed with initial User Injection.
To set up the Access 2000 or Access 2002 database for local use:
1. After successful installation, open Windows Explorer and locate the
NFIRSv53 root directory. Open the Database folder.
2. Double click on the NfirsdataV53.mdb. The Access program will open.
3. The user will be prompted to Convert Database. Click Yes or OK to convert
database. (or, open the Access program, from the Tools menu select
Database Utilities…Convert database option. In the directory window that is
displayed, locate the NFIRSv53 database: NfirsdataV53.mdb).
4. A directory window will appear. In this window, the user must specify the
location to save the converted (new) database. Specify the
NFIRSv53\Database folder in the NFIRSV53 root directory as the location to
save the converted database.
5. Accept the default name (db1.mdb) for the converted database.
6. When the database is finished being converted, click on the X in the upper
right corner to close the database. Close the Access program. The user will
be returned to Windows Explorer.
7. Using Windows Explorer, rename the original NfirsdataV53.mdb database
(suggestion: empty97NfirsdataV53.mdb).
8. Rename the database that was created in the converting process to
NfirsdataV53.mdb (must be exact. If the PC does not show file extensions for
known file types, name it: NfirsdataV52).
9. From the Start menu, open the NFIRSv53 Configuration Tool and go to the
Advanced Tab.
JANUARY 2004
11
CONFIGURATION TOOL GUIDE
NFIRS 5.0
10. In the Off-Line section, check the Off-Line access box.
11. In the Off-Line section in the Database Type drop down box, select the
Access version used when converting the database file. Note: On-Line
configuration information, if necessary, may be entered at this time.
If the error message is displayed: "There is a mismatch between Data Source,
Driver and Database Type," click OK. Verify the Access program version on the
PC is the same as the selected Database Type on the Advanced Tab. Verify that
the default database has been converted and is located in the
NFIRSv53\Database folder. Verify the user was logged in as the PC’s system
administrator. If the Database Type still cannot be saved, contact the NFIRS
Support Center at: [email protected]
Before closing the Configuration Tool, verify the Off-line Access box is checked.
Click Save and exit the Configuration Tool. Proceed with initial User Injection.
Access 97 users who wish to upgrade to Access 2000 or 2002
The following steps are recommended to Off-Line users of the previous NFIRS
5.0 Software Versions 5.2.3, 5.2.1, 5.1, 5.0, or Version 4.0 who have data saved
to an Access 97 database and would like to upgrade to another Access version.
If reports are saved to the NFIRSv523 Reports folder, move the folder to another
location on the hard drive. If the Data Cleansing Tool was used to run scripts on
the Off-Line database and the user wishes to retain the history of when the
scripts were run, copy or move the Version 5.2.3 file named:
AllDatabasePatches.obj to another location on the hard drive.
1. Make a back up copy of the Access 97 database, NfirsdataV53.mdb (NOT
.ldb) or previous version NFIRS database and save it to the hard drive or zip
disk.
2. Completely remove the NFIRSv53 program.
3. Perform the upgrade to Access 2000, or to the office suite which includes
Access 2000.
4. Install NFIRS 5.0 Software Version 5.3.
5. Move the previous version database file into the new NFIRSv53 database
folder, convert it to the necessary Access version (see steps for converting
the database) and rename the file: NfirsdataV53.mdb (if file extensions do
not show on the PC, name it: NfirsdataV53)
6. Perform User Injection/Remote Synchronization.
Version 5.2.3 Off-Line Data Cleansing Tool Users: To retain the history of the
scripts run in the Version 5.2.3, move the AllDatabasePatches.obj into the
NFIRSv53 folder, and overwrite the file that exists.
4.1.3 Off-Line Users: Visual FoxPro 6.0 Setup
Users who wish to select Visual FoxPro 6.0 as the Off-Line database engine
must have the program on the PC prior to installation of NFIRS 5.0 software
Version 5.3. The user will import the schema to the Visual FoxPro and create the
local database, assign a new ODBC data source to the database, perform User
Injection/Remote Synchronization to populate the new database with application
JANUARY 2004
12
CONFIGURATION TOOL GUIDE
NFIRS 5.0
data and user and department information from the National Database. Visual
FoxPro 6.0 is intended for the Off-Line mode only, therefore the On-Line
Reporting Tool included in the Client Suite will not be available to the user to
generate statistical reports on the data saved to the Visual FoxPro 6.0 database.
1. Obtain the zip file containing the Visual FoxPro 6.0 schema
("NFIRSFoxPro.zip"), available on the NFIRS Download Software Page).
2. Unzip and save the files to a directory of your choice.
3. Start Microsoft Visual FoxPro 6.0.
4. Under the FoxPro File menu, select Open.
5. Locate the folder containing the unzipped FoxPro files, and select the
nfirsproject.pjx file.
6. You will be prompted to make the new directory the home directory for the
new FoxPro database, which is suggested.
Complete the following steps to create an ODBC source for the new Visual
FoxPro 6.0 database.
1. From the Start menu, select Settings...Control Panel.
2. Double click on the ODBC Data Sources 32 bit icon. The icon may be
named differently on NT machines.
3. In the ODBC Data Sources Administrator window, click on the System DSN
Tab.
4. Click on the Add button. The Create New Data Source window will be
displayed.
5. Select the Microsoft Visual FoxPro Driver.
6. Enter a Data Source Name and Description. For Example: MyVFPServer
7. Click Finish. Close the Control Panel.
8. From the Start menu, select the NFIRSv53 Configuration Tool and click on
the Advanced Tab.
9. If configuration information is necessary for On-Line Access, check the OnLine Access box and enter the information. Click Save.
10. Check the Off-Line Access box before exiting the Configuration Tool.
Rename the ODBC driver to point to Visual FoxPro 6.0:
1. In the Database Type drop down box, select Visual FoxPro 6.0.
2. Replace the odbc driver name (in the top text field) with the one you just
created. Example: jdbc:odbc:MyVFPServer
3. Click Save, and exit the Configuration Tool.
4.
Proceed with User Injection (Refer to the Data Entry Tool Guide for complete
information).
4.1.4 Off-Line Users: MS SQL Server 7.0 or MS SQL Server 2000 Setup
Users who wish to use MS SQL Server 7.0 or MS SQL Server 2000 as the Off-Line
database engine must have Microsoft SQL Server Version 7.0 or MS SQL Server 2000
installed on the PC prior to installation of NFIRS 5.0 software Version 5.3.
JANUARY 2004
13
CONFIGURATION TOOL GUIDE
NFIRS 5.0
The user must first import the schema to the MS SQL Server 7.0 or 2002 and create the
local database, and then assign a new ODBC data source to the database. To complete
the setup, User Injection/Remote Synchronization must be performed to populate the
new database with application data, user and department information from the National
Database. MS SQL Server 7.0 (or MS SQL Server 2000) are intended for local use only,
which means the NFIRS 5.0 On-Line Reporting Tools cannot be used against it.
Import the schema to the MS SQL Server 7.0 (or 2000) database using these
steps:
1. Create a new database using the SQL Enterprise Manager (EM).
2. From the EM, under the Tools menu select SQL Server Query Analyzer.
3. When the Query Analyzer launches, go the combo box at the top-right and
select your database name.
4. Click the "Open" icon (second icon from left on top of window).
5. Select the .sql file that contains the schema, which is usually named
"NFIRSSQLServerSchema.sql".
6. Press F5 to execute the script.
7. Select the .sql file that contains the table updates, which is usually named
"SQLServerTableUpdates.sql".
8. Press F5 to execute the script.
9. Quit the Query Analyzer.
10. The new schema is now found under "tables" for the new database, which
can be viewed in the Enterprise Manager.
Create an ODBC source for this new SQL Server database.
1. Select Start...Settings...Control Panel
2. Open the ODBC Data Sources-32 bit. This may be named differently on
different versions of NT.
3. Click on the System DSN Tab.
4. Click on Add button. The Create New Data Source window will be displayed.
5. Select SQL Server.
6. Fill in the following information in the DNS Configuration window:
a. Screen 1: Enter name for your SQL Server NFIRS Database and the SQL
Server name on which it resides.
b. Screen 2: Select the “With Windows NT authentication using network
login ID” radio button for SQL Server Authenticity. Leave other settings as
default.
c. Screen 3: Select the “Change the default database to” check box and
then select your newly created SQLServer NFIRS database from the drop
down list below the box. Leave other settings as default.
d. Screen 4. Leave settings as default.
7. From the Start Menu, launch the NFIRS Configuration Tool.
JANUARY 2004
14
CONFIGURATION TOOL GUIDE
NFIRS 5.0
8. Select Online Access and verify all On-line configuration info is correct.
9. Select Offline Access.
10. In the Database Type drop down box, select your version of MS SQL Server
(7.0 or 2000)
11. Replace the ODBC Data Source Name (in the top text field) with the one you
just created. This will now look similar to "jdbc:odbc:MySqlServerDB" Verify
the ODBC Driver name is: sun.jdbc.odbc.JdbcOdbcDriver
12. Verify the Off-Line Access box is selected. Save and exit the Configuration
Tool. Proceed with User Injection.
4.1.5 Previous Version 5.0 Users of Visual FoxPro 6.0 or MS SQL Server 7.0
Visual FoxPro 6.0, MS SQL Server 7.0 or 2000 Off-Line Users who have fire
department and incident data saved locally from NFIRS 5.0 Version 5.3 can
follow the steps below.
1. Install NFIRS 5.0 Version 5.3.
2. After successful installation, in the Configuration Tool's Advanced Tab, name
the ODBC Data Source the same as it appears in the ODBC Data Source
Administrator.
3. In the Configuration Tool's Advanced Tab, select the Database Type.
4. Click Save and exit.
5. Perform Remote Synchronization: open the Data Entry Tool, leave the OffLine login screen fields blank and click OK.
6. When prompted "Apply Schema Changes? ...Would you like to apply the
schema changes now?" click Yes.
7. Proceed with the Remote Synch process.
4.2
On-Line Mode:
The second check-box in the Advanced Tab is On-Line Access. When the OnLine Access box is checked, the user must have an Internet connection
established before logging in. On-Line access mode enables the user to
communicate with the National Database. In Version 5.3, On-Line access is the
default mode.
When the On-Line access box is selected, the user is communicating to the data
source with HTTPS (Hypertext Transfer Protocol Secure ). In Version 5.3,
CORBA and its components, which handled the communication protocol in
previous versions, have been removed. The NFIRS 5.0 Version 5.3
communication protocol uses HTTPS over port 443, an industry standard
protocol which is much more robust.
This change requires users of previous USFA NFIRS 5.0 software to upgrade to
Version 5.3 after its release, before logging into the National Database.
JANUARY 2004
15
CONFIGURATION TOOL GUIDE
NFIRS 5.0
The third check box in the Advanced Tab is Use Compression. Version 5.3 of
the Data Entry Tool allows the user to compress the data portion of the
communications. The default setting is checked. Over slow (i.e., dial-up) lines,
compression can improve the communication speed. Compression will require
extra processing on both ends to compress and uncompress the data. If the Use
Compression check box is checked, the Data Entry Tool sends its data
compressed. If the data sent to the NFIRS service is compressed, the data
returned is compressed as well.
4.3
Negotiate Firewall
The third check-box in the Advanced Tab is Use Proxy Server (diagram 4.3.0).
User sites that employ an HTTP firewall must specify the internal IP address of
that firewall and its internal HTTP port.
To locate the PC’s IP address and port, open the browser. Netscape users
should click on Edit from the Menu bar and select Preferences. Click on the plus
sign (+) next to Advanced to extend the tree, and click on Proxies. If Manual
Proxy Configuration is checked, click on View. Write down the HTTP internal IP
address and the port. Internet Explorer users should click on View from the
Menu bar and then Internet Options. Click on the Connections Tab and locate
the Proxy Server. Write down the HTTP internal IP address and the port.
When the user selects Use Proxy Server, the address of the Proxy IP Address
(or Host Name ) and Proxy Port Number must be specified. Enter the IP
address (Or Host Name) and Proxy Port Number port in the respective fields in
the NFIRS Configuration Tool and click the Save button to save the settings.
User sites that don’t employ an HTTP firewall must leave the HTTP Firewall
check-box blank.
In most cases, if the user is a dial-up client through an Internet Service Provider
(ISP), the Use Proxy Server checkbox and fields will be left blank.
Diagram 4.3.0
4.4
Proxy Authorization:
The fourth check-box on the Advanced Tab is for Use Proxy Authorization,
(diagram 4.4.0). Only if the Use Proxy Server checkbox is checked, the Use
Proxy Authorization field will be enabled. If the user must authenticate identity
when negotiating a firewall request, Use Proxy Authorization box must be
checked. The name for the firewall account must be entered in the Use Proxy
Authorization Name, the Use Proxy Authorization Password must be entered,
JANUARY 2004
16
CONFIGURATION TOOL GUIDE
NFIRS 5.0
and an entry to Confirm Proxy Auth Password must be entered. Contact the
Firewall Administrator at the site for specific information.
Diagram 4.4.0
4.5
Cache Application Data:
The fifth check-box in the Advanced Tab is Cache Application Data (diagram
4.5.0), the function of which is unchanged from Version 5.3.When the Cache
Application Data box is checked, the NFIRS tools cache application data locally
rather than continually make requests across the network. Caching results in
reduced network traffic and increased performance of the NFIRS client suite. As
shown in Diagram 4.5.0, the Clear and Cache Now buttons are active when
Cache Application Data check box is checked. In order to make the buttons
active; the NFIRS Data Entry/Validation tool must be active. The Clear button
clears – deletes the cache (locally), and the Cache Now button caches
everything (locally).
Diagram 4.5.0
4.6
Event Logging Level
The different levels of logging are used to generate information that is used by
support personnel in the event of application concerns. The Event Logging
Level drop down box (diagram 4.6.0) allows the User to choose from four levels
of logging; Exception Only, Normal, Debug, and Debug-Low. The default is
Exception Only logging.
Some levels of logging, such as Debug-Low may generate large files (perhaps
up to several megabytes) whereas logging only Exceptions will generate small
log files. Log files are recycled; i.e., whenever the application is restarted, the old
log files are overwritten.
To change the selection, click on the drop down menu and highlight desired
logging level.
JANUARY 2004
17
CONFIGURATION TOOL GUIDE
NFIRS 5.0
Diagram 4.6.0
5.
The Transactions Tab
At this time, the Transactions Tab functionality is not available.
6.
Saving User Configurations
When the user has completed configuration choices, the user can save the modifications
and go on to another tab, :cancel without saving modifications, or click OK to save
settings and exit (diagram 6.0). If the user makes modifications to the Configuration Tool
but does not want to save the changes, click Cancel. A pop-up window will appear
prompting the user Exit NFIRS Configuration Tool? Yes, No, or Cancel (diagram 6.1). If
the user clicks on Yes, the Configuration Tool will exit without saving configuration
modifications. If the user clicks on No or Cancel, the user returns to the previous screen.
If the user wants to save configuration modifications, click on the Save button and go to
the next tab in the Configuration Tool, or OK to save and exit.
Diagram 6.0
Diagram 6.1
JANUARY 2004
18
CONFIGURATION TOOL GUIDE
NFIRS 5.0
7. Index:
Internal HTTP Port.................................................16
IP address ...............................................................16
A
address ..................................................................... 9
Advanced Tab .......................................................... 9
L
B
Local Access....................................................... 9, 10
log files ......................................................................5
logging level..............................................................9
Batch Size................................................................. 6
M
C
MS SQL Server 7.0................................................13
cache application data ............................................ 9
Cache Application Data............................................ 17
Cache Now button ................................................. 17
communications protocol........................................ 9
N
Negotiate Firewall ....................................................16
NFIRS Configuration Tool.......................................3
D
O
data encryption......................................................... 3
data files.................................................................... 3
Data Validation..................................................... 5, 7
Diagrams
Cache Application Data.................................... 17
Exit Configuration Tool ..................................... 18
Forms Tab ............................................................ 8
HTTP Firewall .................................................... 16
Import location ..................................................... 5
Incident File Delimiter ......................................... 7
Incident Validation............................................... 6
Saving Configurations ...................................... 18
Show Seconds..................................................... 7
User Options Tab ................................................ 4
ODBC Data Source Name....................................10
Offline (performance control)..................................6
Off-Line Access ........................................................9
On-Line Access ......................................................15
Online-Modem ..........................................................6
Online-Network.........................................................6
Overwrite Existing Incidents ...................................6
P
Performance Control ...............................................6
R
E
Remote Access ......................................................15
reporting precision ...................................................7
Event Logging Level.............................................. 17
S
F
Saving User Configurations..................................18
Set DB User button................................................10
Show Seconds..........................................................7
File Importing............................................................. 5
firewall ................................................................. 3, 16
firewall address ........................................................ 9
flat file import ............................................................ 5
forms.......................................................................... 8
Forms Tab ................................................................ 8
U
User Options Tab.....................................................4
H
V
HTTP ....................................................................... 15
Hypertext Transfer Protocol ................................. 15
Visual FoxPro 6.0...................................................12
I
Import Performance Control................................... 6
Incident File Delimiter.............................................. 7
JANUARY 2004
19
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement