Best of Open Source Software
20 top apps
The best of open
source software
This book is full of exceptional open source software, but that’s just the tip of a
large iceberg. Here are some highlights awaiting the open source adventurer.
D
espite this book being full to the brim with open
source software, there are still plenty of
applications we haven’t mentioned. This is our
opportunity to cover just a few we think are the
most useful. But this doesn’t mean we’ve exhausted all the
tools we’re interested in either. One of the best things
about Linux is choice, and there is just so much software to
choose from. If you take a look at the Synaptic package
manager, the tool used for installing extra stuff, you’ll find it
Kino
The tool to use when you want to edit your
own movies for YouTube and even DVD.
T
After you’ve
imported your
videos, the timeline
is the place where
you can edit their
order.
hanks to digital cameras usually having the ability to
record movies as well as take photos, video editing is a
prerequisite for a desktop computer. Both Apple’s OS X
and Microsoft’s Windows bundle video editing applications,
and this has helped make video editing technology
mainstream. Websites like YouTube and MySpace wouldn’t be
half as popular if you couldn’t watch something. Kino is the
Linux equivalent to the video editing applications you find
bundled with other operating systems. It attempts to be easy
enough for the beginner to use while still being powerful
enough to create professional results.
After installation,
Kino can be found
lurking in the Sound &
Video menu. The first
thing you need to do is
get video into the
application. Kino’s
native format is DV –
the raw stream of video
that many digital video
recorders generate. You
can import your video
directly from your
FireWire device by
switching to the
‘Capture’ page and
pressing record. Most
contains thousands of tools, utilities, applications and
games. You could spend weeks trawling through them all.
But there are many more projects than those with official
recognition from Ubuntu. If you look at a site such as
Sourceforge.net, a hub for open source projects, you’ll find
over 173,000 registered projects, most of which will work
with Linux. There’s no quality control, but it just goes to
show how active the open source community is and why
Linux is a portal to a whole new way of thinking.
Importing videos
One of the main problems you’re likely to encounter while
dealing with audio and video files within Linux is compatibility.
You may find that files you pull on to your machine from other
systems don’t work. Windows Media is the main culprit, but
Apple’s QuickTime can also cause problems, as can any of the
plethora of formats commonly used online. Even MP3 playback
can cause problems. This is because all these formats are
proprietary, and decoding them so that they work on Linux is a
legal grey area in some parts of the world. You can avoid these
problems by using open formats such as Ogg Vorbis for audio
and Ogg Theora for video, but sooner or later you’ll need to work
with a proprietary format. For video, the answer is to install a
package called FFMPEG from the Synaptic package manager.
Applications such as Kino will then be able to convert most of
your files to an open format when you open them. This is the
next best thing to a native solution.
devices will work. If you’d rather import your movies by hand,
you can add video content from the File > Open requester,
after which all imported video will appear in the timeline
window. This is where you can re-order each sequence, placing
clips into the correct order. If you need to edit larger segments,
then the ‘Trim’ window can be used to create cut points,
putting new clips back into the timeline. You can also add
effects in the FX window, examples include blurring video or
forcing a sepia colour on everything. The FX window is also
where you find transitions that can be used to fade from one
clip to another. Just select the transition from the drop-down
menu, followed by the start and end point in your movie for the
transition and click ‘Render’. When you finish editing your
masterpiece, the Export window can send your movie to your
digital video recorder, a raw DV file or an MPEG that can be
burned on to a DVD.
104 Linux starter pack
LXFS13.bestof 104
14/4/08 20:02:42
20 top apps
Audacity
Professional-grade audio editing on your Linux desktop.
Y
ou may have come across Audacity before. It’s an
audio file editor that’s as adept at trimming your latest
podcast as it is adding fade-outs to an MP3. Like its
proprietary counterparts, it can be used to add real-time
effects, mix audio, record from your soundcard’s inputs and
analyse audio. It’s a tool box for audio editing, and it should be
the first app you try if you need to do anything with sound files.
Audacity is launched from the Applications > Sound &
Video menu. By default, Audacity will configure itself to use
your sound card for input and output. This means you can
make a recording by pressing the large red record button, and
Audacity will record whatever is connected to your sound card.
If you need to change the input, switching from line-in to a
microphone for instance, this can be changed from the Edit >
Preferences > Audio I/O window. If there is sound entering
Audacity, the level meters above the small microphone icon
will start to bounce, and it’s this sound that will be recorded.
Audacity can load WAV, AIFF, MPEG, Ogg Vorbis and Flac file
formats from the File > Open requester, and you can load
more than one at the same time by using the Ctrl key to select
those you want to load. Each file will load into a separate
instance of the editor.
need to select a region of the file to edit. Just left click and drag
your mouse across the area you want to edit. If you want to
trim the beginning of an audio file, for example, left click and
drag the mouse across the area you want to trim and select
‘Cut’ from the edit menu. You can add effects to any selected
region from the Effects menu. If you want to mix two files
together, add a stereo track from the Tracks > Add New menu
and use Import from the File menu to add a new audio file to
those tracks. Pressing Play now will mix all the tracks together,
and you can save a copy of the mix from the File > Export
menu. Finally, if you want to change the volume of your audio
file over time, use the Envelope Tool from the toolbar. This lets
you draw a curve across the waveform that will be used to
either amplify or decrease the volume of the audio at that
point. When you’ve finished editing, save your audio file into
your favourite format.
Quick tip
You can install
hundreds of other
effects by searching
for ‘LADSPA plugin’
in the Synaptic
package manager.
These are compatible
with all Linux audio
applications and cover
everything from chorus
effects to reverb.
Close to the edit
The main area of the Audacity editor displays an amplitude
waveform for the current section of audio. This is exactly the
same as many other audio editors. The peaks and troughs in
the image represent high and low amplitude in the audio, with
the two tracks representing the left and right channel of a
stereo recording. If your audio is mono, you’ll only see a single
track. Press the green Play button in the toolbar to hear the
sound your audio makes. The level meters above the tiny
speaker icon in the toolbar will start to bounce, and a cursor
will scroll across the waveform view to show you which part of
the image is creating the sound you can hear. You can zoom
into and out of the waveform using the magnifying glass in the
toolbar, and when you want to stop playback, either hit the
space bar or press the stop button. To do any editing, you first
Audacity can run on Windows and OS X, and is the best free
tool you can find for audio editing.
Step by step: Make music louder
1
Select waveform Load the audio file you
want to boost, and select the entire file
either by double-clicking on the waveform or
pressing Ctrl+A on your keyboard.
2
Squeeze the sounds The effect used to
boost audio is called compression. Select
this from the Effect menu, move the threshold to
-20dB and click on OK.
3
Save output Compression differs from
normalisation because it only boosts the
quiet parts of the signal. When you’re happy with
the results, save the louder file.
Linux starter pack 105
LXFS13.bestof 105
14/4/08 20:02:43
20 top apps
Blender
3D modelling and rendering environments normally cost a fortune –
Blender is free and can compete on quality and specification.
T
he story behind Blender’s open source renaissance is a
good one. It started life as a proprietary piece of
software designed to compete with the likes of
SoftImage, LightWave and 3D Studio. The company that
developed Blender went bankrupt in 2002, but the creditors
agreed to release the source code in return for ¤100,000. In
mid-July of that year a campaign was started, asking people to
donate funds to free Blender. Two months later Blender was
saved, and the source code was released under the terms of
the GPL – free for all to use and modify. Since then, Blender
has gone from strength to strength. Thanks to its open licence,
many people now contribute to its development, and the
massive community flocks to blender.org with each new
release. Blender has many advanced functions for the CGI
artist, including Nurbs, Bezier curves, metaballs, particles and
digital sculpting. The ray tracing element responsible for
generating the final image can be replaced, and many people
use the photo-realistic Yafray as a substitute. The images that
can be produced are breathtaking.
The Blender user interface is bewildering, for beginners and
experts alike, so don’t let that put you off using it.
My first render
But there is a cost, and that’s complexity. Blender has one of
the most convoluted and complex user interfaces we’ve ever
come across. This is a real shame, because you don’t
necessarily need to be a CGI expert to get usable results. It just
takes a little effort to learn the basics. When you first launch
Blender from the Applications > Graphics menu, the window
that appears is confusing. The main view is split into two, with
the top area showing a top-down view of the scene, and the
lower area dedicated to buttons and panels.
Things become clearer if you select ‘Camera’ from the View
menu. This will switch the main display to the view from the
in-scene camera, and by default it’s looking at a cuboid in the
centre of the scene. Press F12 and the scene is rendered. A
window will appear with a properly lit rendition of the scene.
Close the render and return to the main window. Make sure
the cube is selected by looking for the pink coloured frame. If it
isn’t, make sure Object Mode is selected on the toolbar in the
middle of the screen, and right click on the cube. If you look
closely at the cube in the middle of the window, you should be
able to see three coloured arrows pointing in different
directions. These arrows point in one of the three planes –
green for the Y axis, blue for the Z axis and red for the X axis.
You can move the cube in any of these axes by left-clicking the
corresponding arrow and dragging your mouse. You can also
move the cube freely in the visible axes with a right-click and a
drag of the mouse. Press S to scale the cube; press R to rotate
it. The axis of rotation is dependent on the current view. If you
switch to the side view (press 3 on the number pad), for
example, you can rotate the cube around the X axis. Switch to
the top view (7 on the number pad) and you can rotate it
around the Z axis.
Textures
This frame is taken from an animated short film called
‘Elephants Dream’, a movie created almost entirely using
Blender and other open source software.
If you don’t like the grey colour our cube currently has, switch
to the material view with the F5 key. Find three colour sliders in
the middle panel, and you should be able to dial a more
appropriate colour from here. Using textures, you can change
how the surface of objects. With the cube selected, press F6 to
open the Textures panel. Under the drop down menu labelled
‘Texture Type’, select Stucci. The texture preview will fill with a
texture that looks a little like the surface of the moon through a
telescope. You can change the colour of the texture by
switching to the ‘Colors’ tab and pressing on the Colorband
button. Press F12 again and you’ll see this texture mapped
onto the surface of the cube. There are hundreds of texture
combinations, and you can layer one on top of another. If
you’re after something realistic, try the Image texture type and
use your own photos. You can also find texture libraries online
so that you don’t need to recreate everything by hand. If all
this seems a little overwhelming, don’t worry – if you’re able to
persevere, the end results can be stunning.
106 Linux starter pack
LXFS13.bestof 106
14/4/08 20:02:46
20 top apps
Ardour
Turn your Linux box into a multi-track recording studio.
A
rdour is a multi-track recording application that’s more
than up to the task of recording live performances.
Development of Ardour is part sponsored by the SAE
Institute, one of the largest educators of audio engineers in the
world. As a result, Ardour can be considered a professionalgrade solution, and is capable of recording and mixing large
projects, as well satisfying modest home studio requirements.
If you want to see what it’s capable of, why not invite your old
bandmates over and give it a go?
If you’ve ever used an application such as Cubase or Logic,
Ardour’s main window should look familiar. Audio tracks can
be added to the empty section with the audio for each track
stretching as blocks to the right. By default, there’s only one
track, which is labelled ‘master’. This track represents the
output on your sound card. To add further tracks, right-click on
the light grey border to the left and below the master track,
and select Stereo or Mono as a channel configuration. If you
have a sound card with more than one input, you can change
the input used for each track from the mixer window. From the
Windows menu, select Show Mixer. This window mimics the
functionality of a hardware mixing console typically found in
recording studios. From the mixer view, you can change the
volume of each track, as well as add effects and route the
audio from one track to another. To change the input source
for each of your new tracks, click on the small ‘input’ button
underneath the track name. The popup menu will let you
choose your sound card’s other inputs.
Go back to the main Ardour window. To record the sound
coming into your sound card, record-enable each track you
want to use by clicking on the red circle in each track before
pressing the large red button at the top of the window. If you
need a click track, press the Click button and adjust the tempo
of the project by double-clicking on the Tempo strip. As you
record, Ardour will generate blocks of waveform data that
correspond to each track. If you’d rather use pre-recorded
music than record your own, you can import music by rightclicking in the track and selecting ‘Insert Existing Audio’.
Choose the audio file you want from the file requester and
Ardour will automatically add it to your project and insert it
into the current position in the selected track.
If you want to add effects to your audio, make sure you’ve
installed the LADSPA plugin packages from Synaptic then
right-click on the black space above the channel in the mixer
view. Select New Plugin from the pop-up menu, and you’ll be
presented with the list of plugins. From here you can add any
plugin with one click, and you’ll be returned to the mixer view.
Double-click on the plugin to open the editing window, and
click on ‘Bypass’ to enable it. You can change effect
parameters as the audio plays, but you might want to click on
S in the track view, as this solos the track, muting the others.
When you’re happy with your mix, the final step is the
mixdown. This is selected from the File > Export menu, and it
will generate a final audio file that includes all the effects as
well as your mix settings. Share this file to become famous.
Ardour is capable
of recording and
mixing dozens of
tracks at once,
which is a far cry
from the simple
days of four-track
recording.
Step by step: Track automation
1
A is for auto Automation is the ability to
record mixer slider movements, as well as
other parameters, directly into your project.
Automation options appear when you click on a
track’s A button.
2
Drag the fader Select Fader from the
automation menu. A track will appear for
the fader data. Select Write from the top-right
button, and any fader moves you make in the mixer
will be recorded.
3
Draw a curve You can automate almost
everything. Try adding an effects plugin to
the track and select a parameter from the
automation pop-up menu. Use manual mode
to draw automation by hand.
Linux starter pack 107
LXFS13.bestof 107
14/4/08 20:02:47
20 top apps
Stellarium
Thanks to Linux, you can gaze at the stars even without windows.
Quick tip
If you don’t know your
longitude and latitude,
many websites now
offer a Google Maps
modification that give
you the details you
need when you simply
click on a map.
S
tellarium is a desktop planetarium. It’s the virtual
equivalent of one of those domed theatres where the
stars and constellations are projected on to the internal
surface of the dome. Like the theatre, Stellarium is a projection
of the night sky, but instead of using a dome it uses your
screen. When you start Stellarium from the Applications >
Education menu, the first thing you have to do is set your
current location. After the application has loaded, and you’ve
been suitably impressed by the super-realistic view, click on
the small spanner icon in the bottom-left toolbar. This is the
configuration panel, and you need to click on the Location tab.
The window will now show a map of the world so you can
locate your nearest city. This window hides one of Stellarium’s
best features. Hold down the left mouse button and drag the
cursor across the map. The Stellarium display in the
background will update immediately with the local view. It’s
Stellarium is the best way of learning what all the
constellations are without getting either frostbite or insomnia.
fascinating to watch the sunlight and stars shift location as
your mouse shuttles across the surface of the globe. It’s worth
putting in your coordinates as any error in your location will be
translated to time differences in the main view.
It’s full of stars
Close the configuration window to return to the main view.
Depending in the time of day, you’ll either see a beautifully lit
field with very few stars, or the night sky with strange
silhouettes on the horizon. Stellarium uses a real image to
draw the ground, as well as atmospheric effects that
approximate overhead visibility. You can turn both of these
features off from the bottom-left toolbar by clicking on the
icon of the sky (labelled ‘atmosphere’), and a similar icon with
an additional tree (labelled ‘ground’). Similarly, you can enable
and disable other features from the same toolbar, including
constellation lines and images, as well as labels for most
objects in the night sky. The small toolbar in the bottom-right
of the window accelerates time. This makes it easy to see the
passage of time on the night sky, as well as switch from day to
night without difficulty.
Apart from displaying the view from your garden, Stellarium
can also display many of the objects you’d typically find in a
telescope. To find Saturn, for example, click on the magnifying
glass in the toolbar. In the window that appears, type ‘saturn’.
The display will then rotate and zoom into the yellow giant. The
location of Saturn’s rings and moons are correct, and you can
zoom in and out with the middle mouse button. You can also
see the current phase of the moon in the same way, as well as
all the other planets in the night sky with images for them all.
Stellarium features accurate images of many nebulae, most of
them freely provided by the Faulkes telescopes in Hawaii and
Australia. Try a search for the Pleiades or M110 to see some
great examples. Not only is Stellarium a great tool for
discovering the night sky from your desktop, it’s also the
perfect tool for planning a night’s viewing – just remember a
blanket, in case it’s chilly out.
Solar Eclipse: Cornwall 11/08/99
1
Set the date To show off a little of
Stellarium’s power, set your location to
Plymouth on 11 September 1999 at 9:00 am, and
switch back to the main view.
2
Zoom in Centre in on the moon using the
search function. Click on the moon and
press space to keep it centred, and zoom just
enough to see both celestial bodies at once.
3
Forget the clouds Gradually move the time
forward and watch the last total eclipse in
the UK unfold before your eyes. Only this time, the
weather doesn’t get in the way.
108 Linux starter pack
LXFS13.bestof 108
14/4/08 20:02:49
20 top apps
Miro
If you have broadband, Miro lets you choose from hundreds of free
online TV channels and download and store your videos in one place.
I
n a world where online entertainment is increasingly
commercialised and locked down, Miro is a breath of fresh
air. It’s an open source media player. But what makes Miro
so different from most other media players is that it’s
hardwired to the internet. In technical terms, Miro uses the
same RSS feeds you use to keep up to date with the news, but
instead of news, Miro subscribes to content tuned for video. If
you’ve ever subscribed to a podcast in Apple’s iTunes software,
you’ll already be familiar with the technology. Miro does the
same for video. Miro needs to be installed through Synaptic,
after which you can find tucked away in the Applications >
Sound & Video menu. When first launched, Miro downloads
the latest RSS feeds for all the channels its subscribed to by
default. The front page that you see is the ‘Miro Guide’, an
edited front-end to many of the new channels. It constantly
updates with news from the Miro world – the internet TV
equivalent to the electronic programme guide you find on
many modern televisions. You can see each channel listed on
the left panel sorted into categories. The blue number to the
right of each channel is the number of new videos posted on
that channel. Green numbers are the number of new and
downloaded videos that area ready to watch.
client is also uploading chunks of the file to other users
without the same bits as you. It’s a process known as peer-topeer downloading, because the other Miro users you’re
connected to are your ‘peers’. You may have heard of
BitTorrent in reference to illegal software, but this is purely
because the same protocol is used by people who share files
they don’t have permission to share. With Miro, all the content
is perfectly legal, and BitTorrent is a legitimate and highly
efficient method of getting the data to everyone.
Channel hopping
Clicking on one of the channels will open the list of videos
currently available. Along with the title, there’s normally a brief
synopsis on what the video is about. If you find one that
interests you, click on the blue down arrow near the video
thumbnail. This will add the video to the download queue. The
clever thing about Miro is that it uses the BitTorrent protocol to
download the files. This is a great way to share the burden of
hosting and downloading files, and is partly the reason why
Miro and its content is free. When you download a file, you’re
actually downloading the data from other Miro users, grabbing
pieces from people who already have the same file. The Miro
Depending on the speed of your internet connection, you may
need to wait a short while for your selected videos to
download. You can check on their progress from the
‘Downloading’ channel on the left. When each download
completes, it will be placed in the ‘New’ folder, and a green digit
will show how many new videos there are to watch, as well as
which channel the video originated from. Clicking on either of
these green numbers will open the video list for that channel,
and from there you can play your downloaded movie.
The best part about Miro is that it can download videos
according to your criteria, and do so automatically. If you find a
channel or RSS feed you like, for instance, you can download
all videos posted to that channel automatically. From the blue
‘Auto Download’ bar at the top of the channel list, just select
‘New – Get Only New Videos’, and Miro will do the downloading
for you in the background. This is great if you want to leave
Miro running overnight, because it means you’ll have
everything ready to view when you log in to your machine in
the morning. By default, videos will be removed automatically
after ten days. If you want to keep a video, press on the ‘Keep’
button on the video strip after it has been downloaded. The
video will then be appended to your Library, and you can also
add any other video files you may have on your hard drive and
use Miro as an all-encompassing media player. LXF
Miro is the gateway to a world of online entertainment. There’s
even a programme guide with reviews of popular downloads.
You can search and download movies from YouTube, as well as
many other online video sites.
BitTorrent
Linux starter pack 109
LXFS13.bestof 109
14/4/08 20:02:51
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising