User manual for the Land Use Change Impact Asessment tool LUCIA

User manual for the Land Use Change Impact Asessment tool LUCIA

User manual for the

Land Use Change Impact Asessment tool LUCIA

Simon Hörhold, Carsten Marohn

Institute for Agroecology and Plant Production in the Tropics and Subtropics

University of Hohenheim

2012

Preface

This manual gives a step-by-step introduction to the Graphical User Interface of the LUCIA model and some hints for troubleshooting. It has been produced on request of our students as a guide for the modules 3801-420 (Crop Production Systems), 3801-460

(Ressourcennutzung) in Hohenheim and Integrated Watershed Modelling (SAIWAM course at Chiang Mai University). It is supposed to serve as a hands-on introduction that complements the model documentation, but spares out the underlying theory. We are grateful for any comments that help improving the usefulness of this document.

University of Hohenheim November 2012

Table of Contents

Preface............................................................................................................................................................. 2

1 .Download and Installation............................................................................................................................ 5

1.1 .Installation of PCRaster for Windows...................................................................................................5

1.2 .Installation of LUCIA............................................................................................................................ 5

2 .Before launching the user interface............................................................................................................. 6

3 .Starting the Graphical User Interface of LUCIA...........................................................................................7

3.1.1 .Creating a new profile.................................................................................................................. 7

3.1.2 .Open an existing Profile............................................................................................................... 8

3.1.3 .Structure of the GUI..................................................................................................................... 9

4 .Model Parametrisation............................................................................................................................... 11

4.1 .Main menu......................................................................................................................................... 11

4.2 .Maps.................................................................................................................................................. 11

4.2.1 .Land cover change.................................................................................................................... 13

4.2.2 .Map editing................................................................................................................................ 13

4.2.3 .Test point map........................................................................................................................... 14

4.2.4 .Map manipulation using The Nutshell........................................................................................15

4.2.5 .Converting PCRaster maps to ASCII files and vice versa..........................................................16

4.3 .Land cover and Soil tabs................................................................................................................... 17

4.3.1 .General hints for table entries.................................................................................................... 17

4.3.2 .Management.............................................................................................................................. 18

4.3.3 .Land cover................................................................................................................................. 20

4.3.4 .Assimilates and NPK concentrations in plants...........................................................................21

4.3.5 .Plant quality............................................................................................................................... 22

4.3.6 .Present vegetation..................................................................................................................... 23

4.3.7 .Soil under Land use................................................................................................................... 23

4.3.8 .Plant impact............................................................................................................................... 23

4.3.9 .Litter initialisation....................................................................................................................... 23

4.3.10 .Soil types................................................................................................................................. 23

4.4 .Weather............................................................................................................................................. 24

4.5 .Defining outputs and running the model............................................................................................26

5 .Modelling (building scenarios)................................................................................................................... 27

5.1 .Adding and removing scenarios......................................................................................................... 28

5.2 .Scenario building............................................................................................................................... 28

5.3 .Analysing outputs.............................................................................................................................. 30

6 .Problems & Solutions................................................................................................................................. 32

6.1 .GUI does not open due to missing User Permission.........................................................................32

6.2 .Map legends and table entries do not match.....................................................................................32

6.3 .Loading Land cover / Soil defaults does not work..............................................................................33

6.4 .PCRaster runtime error I.................................................................................................................... 33

6.5 .PCRaster runtime error II................................................................................................................... 33

6.6 .LUCIA error message on closing the GUI..........................................................................................34

6.7 .No permission to save results............................................................................................................ 34

6.8 .A scenario cannot be saved............................................................................................................... 35

6.9 .Crops are not growing........................................................................................................................ 35

6.10 .Perennials are no growing after land cover / use change................................................................35

6.11 .There is no erosion where it was expected!.....................................................................................35

6.12 .Erosion rates appear to be tremendous...........................................................................................36

6.13 .How to reset / erase output parameters or planting dates?.............................................................37

6.14 .The simulation is very slow.............................................................................................................. 37

6.15 .The LUCIA GUI is not opening......................................................................................................... 37

6.16 .Aguila interface looks different than the one in this manual.............................................................38

Glossary.......................................................................................................................................................... 39

1 . Download and Installation

1.1 . Installation of PCRaster for Windows

Download the installation file from the PCRaster web site

1

and double-click it. On the

opening window agree to the EULA and choose whether you want to make PCRaster available for all user-accounts on your computer or only for the account you are using.

Finally select the directory where PCRaster should be installed and the Start Menu folder

(Figure 1). PCRaster will now be installed and ready to use.

Figure 1 :Installation process of PCRaster

A Linux version of PCRaster is also available 2 , but has not yet been tested for LUCIA.

1.2 . Installation of LUCIA

First download the program LUCIA and a training dataset 3 . Unzip the .7z files using

WinRAR or a similar unzipping program (right-click, open with -> WinRAR).

1 http://pcraster.geo.uu.nl/download/PCRaster-3.0.0-beta-091201.exe

2 http://pcraster.geo.uu.nl/download/

3 https://lucia.uni-hohenheim.de/software

Figure 2 : The unzipped installation file

Start the application and proceed to identify the place where you want to install LUCIA to.

Follow the instructions and finish by clicking “Install” (Figure 3).

Figure 3 : Installation process for LUCIA

2 . Before launching the user interface

A few set up changes may be needed to set up your system in the best way for LUCIA. If you are working on a computer with language settings other than English, you will need to

change the language format in your system (Figure 4):

ON a windows XP or 7 machine, go to the control panel and select “Time, Language and

Region”. Click on “Region and Language” and change the format to (any) English system.

In the numbers settings rider set the decimal symbol to “.” (point).

Figure 4 : Change the language settings in Windows XP to English

3 . Starting the Graphical User Interface of LUCIA

Opening LUCIA, you will first be asked to select an existing profile or to create a new one

(Figure 5). In this manual, the term Profile stands for one catchment. All maps

characterising this catchment must have the same coordinates, projection, pixel size and shape (as is the case for a mapset in a GIS system). Within one catchment different scenarios can be generated that cover changes in land use, management or weather, among others. For a correct profile implementation check chapter 3 (Starting LUCIA).

Figure 5 : Opening LUCIA for the first time, identification of an existing profile

If LUCIA has not been installed on your computer before, you have to create a new profile, otherwise you may browse and select an existing one.

3.1.1 . Creating a new profile

To create a new profile it is assumed that your data (e.g. the downloaded training dataset or a set of maps and weather data) have been stored in one common folder, which has been named accordingly.

In the GUI click on “Create new” and, once you are asked by the GUI to ”Select the

directory that contains your model input data”, select the data folder. Next you will be prompted to name your scenarios – for now one scenario with a meaningful name will be sufficient.

You are then asked to identify the folder where your PCRaster applications are installed

(usually C:\PCRaster\apps or C:\Program_Files\PCRaster\apps – it is not necessary to browse to the .exe files inside the apps folder). This is necessary, because the LUCIA GUI needs to call PCRaster software to modify maps and to run the model. Usually LUCIA identifies the PCRaster directory by itself. If not, browse manually to the correct directory as well as the paths for Aguila, MapEdit etc, all of which can be found in the

PCRaster\apps folder.

If everything is done correctly, LUCIA will start and you will see the start-up window (Figure

6).

Figure 6 : Start-up window of the LUCIA GUI

If the GUI does not open correctly, you might try again identifying the correct profile.

3.1.2 . Open an existing Profile

To start LUCIA using an existing Profile, simply find the application and double click it. You

will be asked to select your Profile (Figure 7). Do so by browsing to the folder that contains your dataset. This folder must contain a folder named “.settings” (Figure 8), otherwise it

will not be found by the GUI. This implies that changes to the folder structure should preferably not be made in the File Manager, but in the LUCIA GUI.

Figure 7 : Select an existing profile

Apart from the .settings folder, the Profile stores all Scenarios in separate folders.

Figure 8 : Finding the correct folder, containing your dataset

The folder .settings might be hidden in your File Manager: To display hidden folders in the

File Manager, go to any folder, click “Organize” → “Folder-options” → Choose the tab

View” and change the setting for hidden folders (Figure 9).

Figure 9 : Display hidden folders in the File Manager

After loading settings and maps, you should see the start-up window (Figure 10). If not, try

again identifying the correct profile.

Figure 10 : Start-up window of LUCIA GUI

3.1.3 . Structure of the GUI

The GUI facilitates changing different maps, land use and soil related parameters, such as the agricultural management practices and different types and characteristics of land cover and soil. You also have the option to visualize and edit (e.g. for modeling purposes)

meteorological weather data. All of these operations could also be executed separately on the Windows shell.

On the right hand side of the GUI (Figure 10) explanations on running LUCIA simulations

are given. On the left hand side (Figure 11) a tree structure shows the different tabs the

GUI is subdivided into. Figure 11 shows two scenarios, BanTat_SAIWAM_2012, a

baseline, which describes the catchment name and context in which the scenario was used, and Fallow rotation, which differs from the baseline in land cover change. We will

see later (5.1), how further scenarios can be added to an existing Profile.

Every scenario has the same number of tabs (Maps, Management etc), where you can change data. Tabs can have sub-tabs which allow you to change further details. For example the sub-tab Land cover change of the tab Maps allows you to change land cover maps for each year you want to model.

Figure 11 : Structure of tabs in the LUCIA GUI

To open scenarios or tabs, click on the small + sign or arrow to the left of the respective tab. The different options will be discussed in detail in the following chapters.

Every tab contains a short explanation on its meaning and hints how to fill it. Reading these explanations thoroughly will help a first-time user to avoid unnecessary difficulties.

4 . Model Parametrisation

4.1 . Main menu

Figure 12 shows the main options provided by the GUI (symbols from left to right): Saving

a Profile (1), run a scenario, which includes generating look-up tables (2), generate lookup tables without running the model (3) and find more information about LUCIA (4) on local resources and in the web. These include the Documentation (concepts), this User Manual and information on the project as well as some useful software tools. The Show Default button displays which parameters have been set to default values.

Figure 12 : Main menu of the LUCIA GUI

The text menu on top contains additional commands. Menu File leads to various scenario

related operations (5.1) and allows to switch between watersheds (here in the sense of

Profiles). Model offers an option for developers to export look-up tables with parameter names as headers, which can be useful for debugging. The Mailing options are under development and not active at this stage; they will be used to control the WebGUI, a tool to send the data filled into the GUI to a fast server for processing the simulation runs.

4.2 . Maps

Under the index tab “maps” you need to identify several maps, which will be used by the

model as input parameters (Figure 13). These show soils, catchment area, lakes,

topography (Digital Elevation Model – DEM), local drain direction (LDD) and the test points for which model outputs are reported. Maps can be displayed (1) using the Aguila

software

4

. For land cover or soil maps, legends displayed in Aguila will be updated once

modifications are made to the class denominations in the respective tabs. However, these changes will only become effective after restarting the GUI. Values of grid cells in the maps can be modified using Mapedit (2). However, Mapedit and PCRaster are not fully compatible. Also, Mapedit does not preserve legend entries after editing a map. These can be renewed through the respective tabs in the GUI. More details on map editing are

4 Aguila is developed independently of PCRaster, the latest version can be downloaded from http://pcraster.sourceforge.net/

described under 4.2.2.

Maps edited or copied into the data folder after opening the GUI can be loaded into the dataset using the Reload maps button in the right lower corner of the Maps tab. Maps from other locations in the file system can be copied into the data set clicking Copy single map.

Figure 13 : The LUCIA Map tab and the DEM opened in Aguila (upper) and Mapedit (lower)

Excursion: Map data types in PCRaster

In PCRaster six different map formats are used, namely Boolean, scalar, nominal, ordinal, directional and ldd.

A Boolean map format has only two options, true or false. This is for example the case with the map lakes.map, where a pixel can either have a lake or not. Scalar formats

display continuous or linear data, e.g. elevation in Figure 13. Nominal values differentiate

qualitative or classification characteristics. This is the case for the land cover or soil maps which distinguish vegetation or soil classes. Ordinal scales include a ranking between the classes as would be the case with plot preferences for cultivation. Directional or vector formats have a magnitude and a direction as it is the case in LUCIA with ldd.map which represents the water flows within the catchment.

For more information on the data types see the PCRaster manual

5

.

5 PCRaster manual: http://pcraster.geo.uu.nl/documentation/pcrman/x181.htm#secdatbasemaptype

4.2.1 . Land cover change

The Map tab contains a sub-tab “Land cover change” (Figure 14). This tab allows

changing land cover types between years. New maps can be added or deleted and modified here. Defining only one land cover map stands for continuous land use without changes. If less maps than simulation years are defined, the former will be looped.

Figure 14 : The Land Cover Change tab in the LUCIA GUI

4.2.2 . Map editing

Figure 15 highlights a selection of those software features mostfrequently used for

maipulating land cover maps. Values of individual cells are changed clicking symbol (1) and selecting the cell with the mouse. Multiple selection is possible. The new value is entered in field (3) and the change executed clicking button (4). Likewise, areas can be selected using the tools displayed to the right of the single cell icon. Ranges of values can be selected clicking on icon (2) and edited as described above.

Cell values are dsiplayed at the bottom of the Maedit window when moving the mouse

over the respectuive cell. In Figure 15, these parts are magnified; X and Y coordinates of

the cell, column and row number and the values (here: Land cover class 6) are shown.

Mapedit is an external software for PCRaster and not fully compatible in every aspect. It is recommended that modifications made to map values through Mapedit be saved after each edit, not only when finishing an entire map. Edited maps should be checked in Aguila to reassure that all cells have the expected values.

Figure 15 : Major features of Mapedit software

4.2.3 . Test point map

Another map that usually requires user edits is the Test point map. Model outputs of a given parameter can be reported either as map series (shown as animated maps) – which requires large disk space and slows down simulations – or as time series for a selection of cells in the landscape. Test points are those cells for which time series outputs are

generated as line graphs with the parameter value on the y and time on the x axis ( Figure

16).

Figure 16 : Standardised Water stress [dimensionless] over ten years simulation time (3650 days)

A selection of time series for strategically located can be more meaningful and easier to interpret than a map series. For hydrological parameters, the catchment outflow may be an important test point and the Test point position in relation to slope and local drain direction

matters . Another option is distributing test points across soil classes or land uses ( Figure

17). In the latter case has to consider that land use may change over time.

Figure 17 : The Test points.map displayed in the Map tab using Aguila

In summary a sufficient number of points distributed wisely is crucial for interpreting the simulation well, while too many points may result in confusing visualisation.

As the in-built PCRaster softwares timeplot and Aguila allow only limited post-processing, it may be useful to export time series into a spreadsheet application. For LUCIA the Rapid

Data Tool assists in exporting (5.3).

Technically, to add test points or change the arrangement of the current points, click “Edit

map” in the LUCIA GUI and remove a Test point by selecting it and assigning it the value 0

(= no test point). If you want to add a new test point, select a point with the value 0 and assign it an integer value > 0. When deleting or adding test points, check for a complete sequence of numbers. Missing values in a sequence (e.g. 1,2,3,6,7,8,9 leaving out 4 and

5) may lead to errors when executing your model.

4.2.4 . Map manipulation using The Nutshell

For our Test point example it might also be helpful to overlay maps with the ldd.map

(showing the directional water flow). You can do so by opening The Nutshell, a User

Interface for PCRaster applications developed by V. v. Jetten at ITC 6 . As can be seen from

the screenshot below (Figure 18), the Nutshell combines a command line (top left quarter),

a file manager (lower left) and a text editor with special highlighting options for PCRaster syntax (right half, overlayed by Aguila map). Apart from the PCRaster apoplications pcrcalc, oldcalc, aguila and legend, The Nutshell provides Mapedit as own software. The map shows land cover overlaid by the LDD, which may help in selecting Test points. To

6 http://www.itc.nl/lisem/nutshell

display this overlay, both single maps were copied into on folder, the file manager was used to navigate to this folder, the green circle was clicked to set the working directory to this folder and finally, the command displayed in the console was typed:

aguila landcover.map + ldd.map

Figure 18 : Screenshot of a combined land cover and LDD map opened in The Nutshell

4.2.5 . Converting PCRaster maps to ASCII files and vice versa

If mapedit repeatedly fails to produce the results you intend, you can convert any

PCRaster map to an ASCII file using the following command in Nutshell:

map2asc example.map example.asc

where map2asc calls the required software, example.map is your PCRaster source map and example.asc is the name of the resulting file after conversion; the latter has to be defined by the user as it does not exist. The resulting ASCII files can now be edited it in a

GIS or text editor and then be reconverted into PCRaster again. This is done through the following command:

asc2map -m -9999 --clone clone.map example.asc example.map

where -m -9999 defines the value of missing values (here -9999), --clone defines a template of the new map containing number of rows and columns, cell size, file type and other information. It is recommended to use an existing map of the same shape and cell size for this purpose. Quantum GIS provides a GDAL interface which allows direct export of raster data to PCRaster.

4.3 . Land cover and Soil tabs

All following Land Cover (including Management) and Soil tabs refer to the land cover and soil classes defined in the Map tabs in a way that each row in the following parameterisation tables refers to one class in the respective maps. Each table column

referes to one parameter. In Figure 19 values entered for all parameters in the Maize row

will apply to all maize pixels in the map.

Figure 19 : Parameter values in the Land cover tab and their corresponding spatial distribution

4.3.1 . General hints for table entries

LUCIA requires initial values for a range of parameters, which are entered into data tables in the tabs. Each of these tabs will be converted into a look-up table that can be read by pcrcalc, the engine of PCRaster.

The following explanations should facilitate data entry. Information on unknown parameters can be retrieved hoovering with the mouse over the respective column header.

A tool tip (Figure 20) will inform the full parameter name, its unit, permitted range and

default values.

Be aware that defaults are just meant to avoid model crashes. As the GUI does not know the plants results of default parameters are lonely of limited use!

Figure 20 : a) Tool tip explaining meaning, unit and range of a parameter. b) Activated field

Data can be entered either by typing into a selected table field or using the up / down arrows on the right side or using the up / down arrows on the keyboard. The tab key can be used to jump horizontally between fields.

4.3.2 . Management

Choose the Management tab (Figure 21) to define the overall management system for

different crops. For detailed options on burning, fertilizer and manure application more information can be entered for selected land cover types in the Management sub-tabs

Burn, Fertilizer or Manure (for further explanation of the sub-tabs see sections

4.3.2.1to4.3.2.2).

In a first instance Profile related settings need to be defined in the top left corner. These include the simulation period in days, geographic latitude (can be entered in degrees or radians; this parameter is relevant to calculate day length) and pixel length in metres.

Land cover specific parameters include tick boxes defining

✗ whether a plant is annual (not perennial),

✗ whether there is present biomass on the pixel before the simulation starts (e.g. old growth forest),

✗ whether a plot is burned or ploughed before planting,

✗ whether fertilizer and manure are applied.

Dates of planting (up to three per year) and of slashing (in case of LUC from a perennial vegetation type to any other vegetation) can be determined as well. The options Irrigation and Terrestrial are not activated.

Figure 21 : Management tab showing magnified Profile related settings (top) and data entry for the second planting date of paddy rice (bottom)

4.3.2.1 . Burning

The Burn sub-tab shows only those land cover types selected in the main Management tab. Users can define the date of burning, how effectively the plot is burned ('cold' superficial or longer lasting fires), whether, when and how much firewood is collected before burning. The latter affects ashes remaining on the field and CO

2

emissions.

4.3.2.2 . Fertilizer and Manure application

For land covers selected in the Management tab, fertilizer types, application dates and

amounts can be defined in the Fertilizer tab (Figure 22). On the left tab side, fertilizer types

can be defined regarding their N, P and K contents (in decimal percent). To this end, fertilizers can be added (+ button) and names (e.g. typical brands) entered.

On the right tab side, land cover specific information is entered for up to six applications per year: Fertilizer type is chosen from a drop-down menu and the amount of total fertilizer given. The amounts of individual nutrients are calculated in the GUI.

Figure 22 : The Fertilizer sub-tab

Manure application follows the same principles, but only three applications per year are possible. In contrast to mineral fertilizer, manure is not immediately plant available, but needs to undergo decomposition processes first. For this reason C, polyphenol and lignin contents need to be entered in addition to N, P and K contents.

4.3.2.3 . Physiological stress

This tab has been designed for experimental testing of potential plant growth. Water and nutrient constraints can be adjusted artificially to learn about growth conditions and stress factors. The default value 0 represents natural conditions, given by soil properties etc. The value 1 represents unconstrained growth. Values in between are proportional, e.g. N constraint = 0.3 stands for 30% of the daily demand being available, irrespective of the soil's actual N reserves.

4.3.3 . Land cover

Under Land cover, physiological characteristics of the vegetation types are defined. Find out about the spatial arrangement of each land cover by checking the landcover.map in the Land cover change tab.

The sub-tabs Litter initialisation and Plant quality, which contain expert settings

7 , are

locked / unlocked for data entry from this tab (Figure 23, top).

7 Sensitive parameters, which are not easy to determine – change only if you know what you are doing.

Figure 23 :Land cover tab, highlighted options to add / remove land covers, load / save defaults and tick boxes to unlock sub-tabs.

Land cover types can be added or removed in the Land cover tab (Figure 23, bottom left).

Be aware that rows deleted in the Land cover tab, which refer to land covers present in any land cover map called at any time during the simulation will lead to a run time error.

Entries can be made on single parameters, or entire vegetation types can be loaded at once using defaults: Select the row under consideration.

Load a default land cover type: A collection of parameterised land cover types is available for loading certain vegetation types where own data are missing.

Save own data as default: Own entries for single land cover types can be saved as defaults for future use. Make sure to select a meaningful name that is not in use.

4.3.4 . Assimilates and NPK concentrations in plants

Parameters in the Assimilates tab have in common that they relate to photosynthesis and that they are development dependent, i.e. they change during the physiological development stages of a plant. Development depends on temperature sums, that is degrees air temperature above a plant-specific minimum within a plant species specific

range per day 8 . Plant development starts with a value of D = 0 at germination and species

specific temperature sums are needed to reach flowering stage (D = 1) and maturity (D =

2) on a dimensionless range from 0 to 2 9 .

8 At a plant specific minimum temperature for growth of 10°C and a maximum of 42°C, a day with 18°C air temperature would be counted as 8 degreedays, or air temperature – minimum temperature.

9 More information on modelling concepts is given in the LUCIA documentation at http:\\lucia.uni-hohenheim.de

All parameters in this tab are decisive for biomass growth and yields. First, partitioning of carbohydrates to different plant parts is regulated. The value for the parameter Root

allocation ( dimensionless between 0 and 1) determines the proportion of assimilates allocated to the root every day. This ratio changes with the development stages of a plant and is usually high during the seedling stage to decrease towards maturity in annual plants. The remainder of 1 – Root allocation goes to the shoot, where allocation to leaves, woody parts (stems) and fruits / tubers add up to 1. The user enters only values for leaf and harvestables and stems are calculated in the GUI.

Further parameters in this tab are the maximum assimilation rate AMD, a sensitive parameter determining potential plant growth, and Specific Leaf Area SLA, describing leaf area per mass.

Figure 24 : Assimilates tab and pop up window for visualisation of cardinal points

All values are given for two cardinal points of development stages. The GUI provides a

visualisation to aid parameterisation (Figure 24).

In the Plant NPK tab macronutrient concentrations in the roots, leaves, stems and harvestables are development dependent as explained above. These values together with biomass determine the nutrient demand of a plant stand.

4.3.5 . Plant quality

Characteristics of plants relevant for decomposition are parameterized here. This includes lignin and polyphenol concentrations in different plant parts as these substances slow down microbial break up of plant substrate. Remobilisation describes the ability to return

nutrients back to plant storage places before leaf litter is shed. Edits to this tab can only be made once the Expert settings option in the Land cover tab is ticked.

4.3.6 . Present vegetation

For vegetation that exists before the simulation begins, such as old growth forests, a rough initial estimate of biomass and leaf area index can be derived from different estimation methods in this tab. Destructive measurements, allometric and two age-based equations can be chosen for a first approximation of standing biomass. Depending on the estimation method, different (green) fields need to be filled in the upper part of the tab. In the lower part biomass is calculated based on these parameters – these (pink) cells cannot be edited. As LAI is a very rough estimate at plant stand level, its value can be manually overwritten. LAI from the Present vegetation tab overrules initial LAI in the Land cover tab.

4.3.7 . Soil under Land use

Parameters in the Soil under land use tab are actually soil parameters, which are in the

Land cover section, because they depend more on vegetation (particularly litter) than on soil genesis and thus change within shorter time horizons. Active and slow litter pools are describe in the LUCIA documentation. The SOM multiplier has been added here for experimental purposes.

4.3.8 . Plant impact

Plant canopy as protection against erosion is parameterised here on an empiric dimensionless scale. BD Impact stands for loosening or compacting influence of land covers on Bulk Density and is also dimensionless (with values below 1 indicating a loosening effect and above 1 stand for compaction.

4.3.9 . Litter initialisation

Edits to this tab can only be made once the Expert settings option in the Land cover tab is ticked. In this tab, amounts of Surface litter, topsoil litter and subsoil litter and their respective concentrations of N, P, K and lignin are quantified. These values refer to plant parts incorporated into the soil, where they release nutrients. Lignin contents are relevant for litter decomposition rates.

4.3.10 . Soil types

Soils in LUCIA consist of two horizons, so most values need to be defined for top- and

subsoil separately. Soil chemical and physical parameters are quantified in the upper part

of the tab (Figure 25) for every soil defined in the soil map (see Map tab). These are

mostly standard parameters from profile descriptions. K sat

parent describes saturated hydraulic conductivity of the soil below the second horizon defined for LUCIA. Θ (Theta) stands for actual water contents as a proportion of total pore volume. P and K weathered describes the daily amounts of these nutrients released from the parent material.

Regarding addition and removal of classes as well as loading or saving default values, the soil tab works in the same way as the Land cover tab.

Figure 25 : Soil tab in the LUCIA GUI

Hydrological parameters are estimated in the lower part of the tab (Figure 25) based on

empirical equations derived from user entries on SOM, bulk density, stone contents and texture. The hydrological parameters are crucial and sensitive for water infiltration into the soil and thus also for run-off and erosion. Parameters calculated from the routines by

S

AXTON AND

R

AWLS

(2006) cannot be edited in the GUI. If field measurements exist that do not match the estimates we recommend to adjust texture accordingly (which does not interact with other parameters).

The Soil tab contains a tick box to activate the Soil Organic Matter (SOM) sub-tab. In the

SOM tab decomposition constants according to the CENTURY concept (P

ARTON ET AL

.

1987) as well as C:N and C:P ratios of different litter and SOM pools are defined.

4.4 . Weather

Datasets of daily values for five parameters (air temperature, ET0 10 , rainfall, soil

10 Reference evapotranspiration, a theoretical value for evapotranspiration above a standardised even grass surface.

temperature, radiation) for the entire simulation period are required. Weather data are

entered into the table on the left tab side and visualised on the right side (Figure 26).

Figure 26 : Weather tab in the GUI

The best way to enter large amounts of weather data is by loading a time series file – a tab delimited text file consisting of two columns, time step (day) and weather data.

Alternatively, copying from a spreadsheet or single data entries are possible.

To load time series (.tss) files Click on load weather data (Figure 27, left), then select the

appropriate .tss file and confirm. You need to check once again that the data set is entered

into the correct GUI column (Figure 27, right).

Figure 27 : Data entry in the weather tab

4.5 . Defining outputs and running the model

LUCIA does not report all possible parameters, but only a user defined selection. To create outputs, select parameters by clicking on one of the buttons in the column Parameter ion

the left side of the Output tab (Figure 28).

Figure 28 : Output tab

A pop-up window will open showing a list of all potential output parameters. At the top, a pre-selection can be made showing only parameters of one group (Hydrology, Plant, Soil

Organic matter, Soil fertility) or known names can be typed into the search field (Figure

29).

Figure 29 : Selecting output parameters

Deselecting defined outputs is done by right-clicking on the parameter button.

Several outputs can be displayed for each parameter by ticking the buttons to the right of

the parameter name (Figure 30). Time series for the Total catchment or for the Test points

will show line graphs, while Map series will produce animated maps for yearly (Y), monthly

(M), daily (D) intervals or rain events > 30 mm (Erosion). Note that the creation of daily maps may significantly increase model run time.

Figure 30 : Selecting the appropriate output type for a parameter

Click the green sign in the main menu to run the model. Run time depends on your machine's processor and memory, simulation period and number of outputs selected. After the model run, time series can be opened clicking on the respective Show button.

Map series can be animated in Aguila under the File menu (Figure 31) at various

animation intervals.

Figure 31 : Displaying animated maps in Aguila

It may be helpful to change the scale to analyze magnitudes of your outputs; this can be done in Aguila right-clicking on the legend and selecting “Edit draw properties”.

All reported maps can be deleted using the Delete all maps button. This might be useful in order to reset a scenario, e.g. if input parameters are changed.

5 . Modelling (building scenarios)

So far, we have only looked at the baseline. Departing from a calibrated and validated baseline alternative scenarios can be implemented in the GUI (e.g. Fallow rotation in

Figure 32). All scenarios contain an identical list of options as the baseline, that is maps,

management, land cover, soil, weather and output.

Figure 32 : Scenarios displayed in the GUI

5.1 . Adding and removing scenarios

To add scenarios, two options are possible, creating a new scenario or copying an existing one. Where scenarios differ only in few parameter values, we recommend to copy the baseline and then modify it:

Go to File and Copy Scenario or use the short-cut Ctrl+Shift+C. You will be asked to identify the scenario to be copied. Select the source folder of the scenario to be copied

(usually the baseline), and assign the new scenario a meaningful and easily distinguishable name. The GUI will now close and reopen automatically.

To create a new scenario, select Create new scenario in the File menu. The result will not contain any entries.

Scenarios are deleted selecting Delete scenario in the File menu.

5.2 . Scenario building

The following self explaining slides from a LUCIA presentation show how a baseline and alternative scenarios are deducted from a research question and related hypothesis

(Figure 33), how a model a consecutively parameterised, calibrated and validated (Figure

34), and how both processes are linked (Figure 35) to run comparative scenarios in a

validated model.

S c e n a r i o b u i l d i n g

D e f o r e s t a t i o n a n d m a i z e m o n o c r o p p i n g i n u p l a n d s c a u s i n g s o i l e r o s i o n

P r o b l e m s t a t e m e n t /

R e s e a r c h q u e s t i o n a ) S e d i m e n t l o a d s i n r i c e p a d d i e s s i g n i f i c a n t l y h i g h e r i f u p l a n d s a r e d e f o r e s t e d c o m p a r e d t o f o r e s t e d u p l a n d s ; b ) M i t i g a t i o n t h r o u g h c r o p r o t a t i o n p o s s i b l e

H y p o t h e s e s

S c e n a r i o d e v e l o p m e n t

A r e a , l a n d u s e h i s t o r y , d i f f e r e n c e s i n l a n d u s e ( f o r e s t , b u s i n e s s a s u s u a l , m a i z e – c a s s a v a ) a n d m a n a g e m e n t

B a s e l i n e

A l t e r n a t i v e s c e n a r i o s

S e d i m e n t l o a d s u n d e r f o r e s t < < r o t a t i o n < m a i z e

C o m p a r a t i v e

I n t e r p r e t a t i o n

T e s t h y p o t h e s i s

S A I W A M 2 0 1 2 , I n t e g r a t e d W a t e r s h e d M o d e l l i n g

E n t e r i n g i n p u t d a t a i n t o t h e m o d e l :

M a p s , w e a t h e r , s o i l , p l a n t p a r a m e t e r s

M e a s u r e m e n t s a n d e s t i m a t e s

F i n e - t u n i n g t h e s y s t e m : A d j u s t i n g v a l u e s o f i n p u t p a r a m e t e r s t o f i t t h e m o d e l t o m e a s u r e d o u t p u t s

T e s t i n g t h e c a l i b r a t e d s y s t e m u s i n g a n i n d e p e n d e n t d a t a - s e t

M o d e l p a r a m e t e r i s a t i o n

F i t

M o d e l c a l i b r a t i o n

N o f i t

F i t

M o d e l v a l i d a t i o n

N o f i t

V a l i d a t e d b a s e l i n e

M o d e l l i n g p r o c e s s

P r o b l e m s t a t e m e n t /

R e s e a r c h q u e s t i o n

H y p o t h e s e s

C a l i b r a t i o n

P a r a m e t e r i s a t i o n

B a s e l i n e

S c e n a r i o d e v e l o p m e n t

V a l i d a t i o n

A l t e r n a t i v e s c e n a r i o s

P a r a m e t r i s e

V a l i d a t e d b a s e l i n e

C o m p a r a t i v e m o d e l r u n s

I n t e r p r e t a t i o n

S A I W A M 2 0 1 2 , I n t e g r a t e d W a t e r s h e d M o d e l l i n g

Figure 35 : Comparative scenario runs using a validated model

5.3 . Analysing outputs

The recommended way to compare scenarios is by looking at single parameters for

individual Test points (Figure 36). Time series reported from PCRaster come as tab delimited text files, which can be opened in spreadsheet applications 11 .

Figure 36 : Comparison of the parameter Soil carbon stocks over time across different scenarios

Another option for time series export is the Rapid Data Assessment tool developed for

11 Usually all data will be opened in the first column; they can be separated using the Text to columns option in the Data menu of the spreadsheet application (selecting Delimited and Tab as separator, merging consecutive separators).

LUCIA by Jonatan Müller, which can be downloaded from the LUCIA website.

6 . Problems & Solutions

If you should encounter any problems or you have further questions, and cannot solve them on your own or with the help of this manual, please write us at https://lucia.unihohenheim.de/85491 . If a question refers to a software error you encountered, please send the error message as well.

6.1 . GUI does not open due to missing User Permission

After installing LUCIA under Windows 7, you might encounter this error message and

LUCIA won’t open up after clicking OK.

Figure 37 : Windows 7 error message on missing permission

This error is Windows 7 related. You may need to log on as administrator, install LUCIA or save your data elsewhere on the hard disk.

6.2 . Map legends and table entries do not match

Table rows in the Land cover and Soil tabs are dynamically linked to legend entries in the

Land cover and Soil map. If one of both is changed after the GUI has been closed (as is the case when maps are exchanged or edited outside the GUI), this leads to a mismatch.

Figure 38 : LUCIA prompt to harmonize legend and table entries

You will be asked separately for each scenario to change one of both data. This can be done one by one or changing all entries at once (Yes / No to all).

6.3 . Loading Land cover / Soil defaults does not work

In order to load or save default soil or land cover types, the respective table row needs to be selected first.

Figure 39 : LUCIA error: No soil type selected to load default

6.4 . PCRaster runtime error I

In Figure 40 LUCIA reports a PCRaster run time error occurring in one of the first lines of

the lucia.txt script. This happens if one or more drop down menu fields for map selection in the Land cover tab have been left blank or an incorrect data type has been chosen (e.g. a boolean type like the area map and a scalar or nominal one have been confused).

Figure 40 : PCRaster runtime error message due to missing maps

The GUI does not check plausibility of maps, so make sure data types are correct. To easily check map types, use The Nutshell.

6.5 . PCRaster runtime error II

LUCIA displays the PCRaster runtime error (click on show details to learn more) shown in

Figure 41.

Figure 41 : PCRaster runtime error due to lut exported with headers

To solve this, click on Model → Expert settings in the main menu and disable the option

“Build luts with header”.

6.6 . PCRaster runtime error III

PCRaster error report: File 'rubber.lut': No such file or directory.

Some versions contain a rubber module, which has not yet been implemented in the GUI and needs to find data directly from a look-up table. Please send an email to the LUCIA team (under http://lucia.uni-hohenheim.de

), we will send you the file.

6.7 . PCRaster runtime error IV

This may be solved by moving the project folder to another directory.

6.8 . LUCIA error message on closing the GUI

The following kind of error message (Figure 45) can be ignored, because the error is under

control.

Figure 42 : LUCIA error message upon closing the GUI

If you are interested what happened in the background, consult the log file in the LUCIA installation folder (if the message appears cryptic, send it to us).

6.9 . No permission to save results

PCRaster starts normally, but crashes, usually at timestep 129, when outputs ought to be

saved from memory to disk. The following error message pops up (Figure 43).

Figure 43 : pcrcalc Error message on missing permission to save files

Solution: Close *.out files you may have opened for exporting data to spreadsheets.

6.10 . A scenario cannot be saved

Scenario names must be unique. If the name you are trying to choose is already in use

(Figure 44), the scenario cannot be saved. Please choose a different scenario name.

Figure 44 : LUCIA error: Scenario name in use

6.11 . Crops are not growing

There are several possible reasons for this. First: Do you mean no growth (biomass) or no harvest (fruit/tubers)? Make sure you report the appropriate parameter.

Then, try to grow the crop without water and nutrient restrictions: Management tab, subtab Physiological stress. Set everything for the land use under scrutiny to 1 (=no restrictions). If this improves the growth rates reset the stress factors to 0 one after the other, always reporting growth. It will help to report also N, P, K and water stress to learn about the temporal occurrence of the stressors – perhaps a later planting date (well within the rainy season) might help...

If nutrients and water are not the limiting factors, try photosynthetic capacity AMD in the

Land cover tab, sub-tab Assimilates. This will almost certainly change your results, but make sure what you entered is realistic (consult literature).

6.12 . Perennials are not growing after land cover / use change

Usually they do, but less than expected. Try unlimited NPK and water supply and

PlantDensity (in the LandCover tab). Else try increasing LAIini.

6.13 . Weather data cannot be entered correctly

When creating a new project and adding weather data from existing projects, this may happen. A work-around for this is to copy the data from the folder original maps, not from one of the scenario folders.

6.14 . There is no erosion where it was expected!

Report rainfall, is there enough? Report infiltration and deep infiltration, surface runoff and overflow – is all water going into the soil?

Look into the timing of rainy season and plant cover (leaf area index, LAI) considering that plant cover effectively reduces soil erosion. Check also how much mulch is on the soil.

In case of line graph outputs, check where your test points are located (what is the slope at the test points? If they are located on a mountain top you will find nearly no erosion

compared with the catchment outlet). Figure 45 gives an example of test point

assemblages. To produce a 3-D map as shown, type in The Nutshell:

Aguila -3 dem.map + testpoints.map

Figure 45 : Locations of Test points displayed on a 3D map

6.15 . Erosion rates appear to be tremendous

First of all, when you report erosion, this means you see the sediment load that passes through the test point. This includes sediment coming from uphill AND sediment that was created within this pixel. Alternatively, you may look into soil loss, which is erosion – deposition (can be positive or negative) or into topsoil depth, which shows thickness of the topsoil.

Convert [Mg/ha] into cm soil (assume bulk density = 1 Mg/m³) – are the rates still high?

In case of line graph outputs, check where your test points are located. If you e.g. placed a

test point at the catchment outlet (Figure 46) it will report all sediment leaving the

catchment, which is usually relatively high. This is also true for the main flows within the catchment.

Figure 46 : Catchment outlet in upper right corner. Black lines illustrate flows within the catchment towards the outlet

6.16 . How to reset / erase output parameters or planting dates?

Reducing outputs that slow down the model or removing planting dates in the

Management tab can be done by right-clicking on the respective field.

6.17 . The simulation is very slow

There are many possible reasons for this. If the runs used to be faster before (i.e. no hardware limitations), the number of time steps or of output maps selected may be a cause. Running scenarios on external hard disks can also slow down simulations as data need to be exchanged between both hard disk and computer. Resource-intensive open applications like office software, run-time anti virus settings, or CPU intensive applications may compete with PCRaster (check the task manager to see which process is blocking

how much CPU and memory capacity).

6.18 . The LUCIA GUI is not opening

The GUI may be opening slowly, depending on the number of scenarios etc. However, if there is no reaction after some minutes, one of the maps may be corrupted. This can happen, if maps have recently been edited in Mapedit. If you suspect that this is the case,

1. Verify whether the map is the reason: Open the land cover maps and other recently edited maps in Aguila through the Nutshell. Note which of the maps cannot be opened.

2. Convert the map(s) to ASCII and back to PCRaster format: For the example of a corrupted map landcover02.map, the commands are as follows: map2asc landcover02.map landcover02.asc

asc2map -m-9999 –clone landcover01.map landcover02.asc landcover02.map

The first command converts the PCRaster file into ASCII. It is advisable to open this ASCII file in a text editor (cautious with large files), look for anomalies and check the values for missing pixel values (usually along the margins of the map - -9999 or 1e31 are values often used).

The second command converts the ASCII file back to PCRaster. First the value for missing values is defined (here -9999), then the clone map, which is a map of the same dimensions and number type as the one to be produced, in this case landcover01.map.

Last, the source and target files are typed.

6.19 . Aguila interface looks different than the one in this manual

Please download the recent version from http://pcraster.sourceforge.net/ . Don’t forget to set the path correctly!

Glossary

Aguila Visualization software for raster maps and timeseries data of PCRaster

Alternative scenario Scenario varying from the Baseline in one or more parameter values, used for comparison

Baseline Scenario representing state as is or current practice for comparison to alternative scenarios

Calibration

GUI

K sat

Fine-tuning model parameterisation to fit existing (measured) output data

Graphical User Interface to facilitate data entry into LUCIA, visualisation of input and output data and command execution in

PCRaster

Saturated hydraulic conductivity; parameter describing potential water infiltration under saturated soil conditions in [mm d

-1

]

LUCIA

Look-up table

Mapedit

Nutshell

Land Use Change Impact Assessment; landscape model for assessing impacts of land use change and management on soil productivity and fertility, biomass production, watershed functions and environmental services in small mountainous catchments.

Emphasis on matter flows in the landscape that connect upland and lowland areas.

Table containing arrayed information (per land cover or soil class) for various parameters. Each tab in the GUI corresponds to a lookup table text file that is read by pcrcalc once the model is running.

Software used to edit maps

Parametrisation

PCRaster

User interface to navigate between files, edit PCRaster scripts, run

PCRaster commands and edit and run PCRaster maps and their legends and properties

The process data entry needed to run a model

Software that combines GIS and programming language; used to construct spatio-temporal environmental models, mainly applied in

Scenario

Test point(s)

Validation environmental modelling.

Describes a situation under certain assumptions and changes in parameters

Pixel(s) within the catchment for which outputs of a model run are reported

Assessing the accuracy of model predictions using an independent dataset

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement