Benutzerhandbuch CBT Manager - T.Ostermeier Softwareentwicklung

Benutzerhandbuch CBT Manager - T.Ostermeier Softwareentwicklung
Benutzerhandbuch CBT Manager
15.11.05
Benutzerhandbuch CBT Manager
Benutzerhandbuch CBT Manager __________________________________________ 1
1 Einleitung _______________________________________________________________ 2
1.1 Installation der Server Komponente ____________________________________________ 2
1.2 Installation von Clients _______________________________________________________ 2
1.3 Installation von Updates ______________________________________________________ 2
2 Infoportal ________________________________________________________________ 2
2.1 Einloggen___________________________________________________________________ 2
2.2 Statusanzeige________________________________________________________________ 3
2.2 Auswahlmenüs im Infoportal __________________________________________________ 3
2.3 Navigation im Menü__________________________________________________________ 3
2.4 Portalrechte_________________________________________________________________ 4
2.5 Neuen Bericht anlegen ________________________________________________________ 4
2.6 Bericht bearbeiten ___________________________________________________________ 4
2.7 Untermenü anlegen __________________________________________________________ 4
2.8 Neuen Eintrag hinzufügen_____________________________________________________ 4
2.9 Eintrag ändern ______________________________________________________________ 4
2.10 Suche _____________________________________________________________________ 5
2.11 Präsentation starten _________________________________________________________ 5
3 Persönliche Seiten _________________________________________________________ 5
3.1 Offene Trainings_____________________________________________________________ 5
3.2 Erledigte Trainings __________________________________________________________ 5
3.3 Alle Trainings _______________________________________________________________ 5
3.4 Trainingsinfos _______________________________________________________________ 5
3.5 Trainingswiederholung _______________________________________________________ 6
3.6 Training durchführen ________________________________________________________ 6
4 Admin Menü _____________________________________________________________ 7
4.1 Stammdaten ________________________________________________________________ 8
4.2 Stammdaten Dialoge _________________________________________________________ 8
4.3 Zuordnungs Dialoge_________________________________________________________ 10
4.4 Trainings __________________________________________________________________ 11
4.5 Reports ___________________________________________________________________ 14
4.6 Präsentation konfigurieren ___________________________________________________ 16
4.7 Exportieren ________________________________________________________________ 16
4.8 Importieren ________________________________________________________________ 16
Seite 1
Benutzerhandbuch CBT Manager
15.11.05
1 Einleitung
Dieses Handbuch soll eine Hilfestellung zur Bedienung des CBT Managers darstellen. Es
umfasst sowohl eine Beschreibung der Funktionen zur Anwendung als auch zur
Administration.
1.1 Installation der Server Komponente
Der CBT Manager kann entweder als Einzelplatzversion auf einem Arbeitsplatz oder als
Netzwerkversion für den simultanen Zugriff mehrerer Benutzer installiert werden. In beiden
Fällen ist zunächst die Installation des Server Installationspakets erforderlich.
1.1.1 Einzelplatzversion
Führen Sie das Server Installationspaket wie Sie es von anderen Anwendungen gewohnt sind
aus und installieren Sie den CBT Manager in einem Verzeichnis Ihrer Wahl.
1.1.2 Netzwerkversion
Starten Sie das Server Installationspaket zunächst wie bei der Einzelplatzversion. Bei der
Auswahl des Installationsverzeichnisses wählen Sie ein Netzlaufwerk und dort ein
Verzeichnis, auf das alle zukünftigen Nutzer Zugriff haben. Anschließend fahren Sie wie
gewohnt mit der Installation fort.
1.2 Installation von Clients
Führen Sie das Client Installationspaket auf den für die Client Installation vorgesehenen
Arbeitsstationen aus. Bei der Wahl des Installationsverzeichnisses wählen Sie das selbe
Verzeichnis auf dem Netzlaufwerk, das Sie zur Installation der Server Komponente
verwendet haben.
1.3 Installation von Updates
Führen Sie das Update Installationspaket auf einer beliebigen Arbeitsstation aus. Bei der
Wahl des Installationsverzeichnisses wählen Sie das selbe Verzeichnis auf dem Netzlaufwerk,
das Sie zur Installation der Server Komponente verwendet haben. Da bei Updates ggf. die
Datenbankstruktur verändert wird darf während der Installation des Updates keine weitere
Instanz (Client/Server) des CBT Managers am laufen sein. Nach erfolgreicher Installation des
Updates starten Sie den CBT Manager wie gewohnt.
2 Infoportal
Ein Teil des CBT Managers ist das Infoportal. Dieses wird sofort nach Start des Programms
angezeigt, allerdings ist der Funktionsumfang solange sich kein Nutzer eingeloggt hat auf die
Ansicht freigegebener Elemente eingeschränkt.
2.1 Einloggen
Durch Klick auf den Button „Einloggen“ wird der Dialog zur Anmeldung an das System
eingeblendet. Geben Sie hier Ihren Namen beginnend mit dem Nachnamen ein. Nach der
Eingabe von drei Zeichen wird das System sofern vorhanden bereits einen Vorschlag für den
Anmeldenamen unterbreiten. Sind Sie mit dem Vorschlag einverstanden, so geben Sie Ihr
Passwort ein, bei der ersten Anmeldung entspricht es Ihrem Vornamen. Sind Sie mit dem
Namensvorschlag des Systems nicht einverstanden tippen Sie einfach weiter bis Ihr Name
vollständig angezeigt wird.
Seite 2
Benutzerhandbuch CBT Manager
15.11.05
Nach dem ersten Login wird Sie das System auffordern, Ihr Passwort zu ändern. Geben Sie
dazu Ihr altes sowie ein neues Passwort an. Wiederholen Sie das neue Passwort um
Tippfehlern vorzubeugen. Sie können Ihr Passwort übrigens später immer wieder ändern.
Falls Sie Ihr Passwort vergessen haben sprechen Sie den Administrator des CBT Managers
an, dieser kann es auf Ihren Vornamen zurücksetzen.
2.2 Statusanzeige
Direkt nach dem Login, aber auch immer wieder dann wenn ein etwas langwierigerer Prozess
startet wird folgende Statusanzeige eingeblendet:
Die Statusanzeige zeigt an, dass und was im Hintergrund abläuft. Der Prozentanzeige können
Sie entnehmen, wie weit der Prozess fortgeschritten ist.
2.2 Auswahlmenüs im Infoportal
Das Infoportal und deren Auswahlmenüs dienen der Ablage von Reports, der
Bekanntmachung von Dokumenten sowie als Startzentrale für Programme.
2.3 Navigation im Menü
Nach dem Login werden zunächst Ihre persönlichen Seiten aufgebaut und angezeigt. Die
persönlichen Seiten sind in das Infoportal integriert und werden in Kapitel 3 ausführlich
beschrieben.
Nach Klick auf den Schritzug „Hauptmenü“ befinden Sie sich im Hauptmenü des Infoportals.
Dieses ist die Startzentrale für alle Aktivitäten rund um das Infoportal.
In der Mitte des Bildschirms befinden sich Schriftzüge, z.B. Archiv, Handbuch etc. Vor
diesen Schriftzügen befinden sich Symbole mit folgender Bedeutung:
· Ordner: Dieser Schriftzug verweist auf ein Untermenü
· Ordner mit Pfeil nach oben: Verweis auf das darüberliegende Menü wenn Sie sich in
einem Untermenü befinden
· Blatt Papier: Ein Report, den Sie direkt im Infoportal bearbeiten können
· Schmetterling: Ein externes Dokument. Dieses wird in einem externen Programm z.B.
MS Word, Internet Explorer angezeigt.
· Blitz: Start eines externen Programms
Die soeben beschriebenen Aktionen werden nach Klick auf das Symbol oder den Schriftzug
aufgerufen.
Über den Verweisen befindet sich die Titelzeile - sie zeigt an wo Sie sich gerade befinden.
Rechts oben neben der Titelzeile wird zusätzlich Ihr Name angezeigt, so dass Sie immer
sehen können, ob Sie noch an das System angemeldet sind.
Unter den Verweisen befinden sich Buttons zum Ausführen der später beschriebenen
Aktionen.
Seite 3
Benutzerhandbuch CBT Manager
15.11.05
2.4 Portalrechte
Auf sämtliche Elemente des Infoportals können folgende Rechte vergeben sein:
- Lesen
- Schreiben
- Ausführen
Die Rechte können in beliebiger Kombination vergeben sein. Ob bzw. wie auf ein Element
des Infoportals zugegriffen werden kann hängt allerdings nicht nur von den Portalrechten,
sondern auch von den persönlichen Rechten ab. Eine Erläuterung der persönlichen Rechte
finden Sie in Kapitel 4.2.3
2.5 Neuen Bericht anlegen
Durch den Button „Neuen Bericht verfassen“ wird ein leeres Dokument angezeigt. Dieses
wird beim Sichern unter dem einzugebenden Titel in dem Menü abgelegt, in dem Sie sich
gerade befinden. Das kann sowohl das Hauptmenü als auch eines der Untermenüs sein.
Beachten Sie, dass der Button „Neuen Bericht verfassen“ nur dann angezeigt wird, wenn Sie
dazu berechtigt sind im aktuellen Menü einen Bericht abzulegen.
2.6 Bericht bearbeiten
Nach Anzeige eines Berichts erscheint der Button "Bearbeiten" unterhalb des Textes. Nach
einem Klick auf diesen wird das Textfeld editierbar, der Button "Bericht sichern" erscheint.
Durch Betätigung dessen werden die Änderungen gesichert. Die Anzeige der Buttons ist
hierbei abhängig von den Rechten des Berichts als auch von Ihrem Berechtigungslevel.
2.7 Untermenü anlegen
Sofern die Rechte es gestatten wird der Button „Untermenü anlegen“ angezeigt. Dieser ruft
den Dialog zur Anlage eines Untermenüs im aktuellen Menü auf.
2.8 Neuen Eintrag hinzufügen
Hier können Sie ein neues Dokument, Report oder Programm in das Infoportal einbinden. Im
entsprechenden Dialog gibt es Eingabefelder für Titel und Pfad. Mit "Ziel suchen" definieren
Sie das Zieldokument. Möchten Sie ein Programm einbinden, so geben Sie die ausführbare
Datei des Programms hier an.
Der Titel wird zunächst automatisch aus dem Dateinamen generiert. Diesen können Sie
jedoch manuell Ihren eigenen Wünschen anpassen. Die ursprüngliche Datei wird bei dieser
Aktion nicht umbenannt.
2.9 Eintrag ändern
Sofern Sie persönlichen Rechte zur Änderung von Einträgen haben werden neben den
Einträgen im Menü bis zu vier Buttons angezeigt.
Die Symbole der Buttons rechts neben den Verweisen haben folgende Bedeutung:
· Stift: Den Namen oder das Ziel dieses Verweises ändern
· X-Symbol: Diesen Verweis aus dem Infoportal entfernen
· Hand, die ein Blatt in einen Ordner schiebt: Diesen Verweis verschieben
· Pfeil nach oben: Verweis eine Position nach oben verschieben
· Pfeil nach unten: Verweis eine Position nach unten verschieben
Seite 4
Benutzerhandbuch CBT Manager
15.11.05
2.10 Suche
Mit der Suche ist es möglich, alles zu finden, was sich im Infoportal befindet. Berichte
können Sie im Text sowie im Titel nach dem Suchbegriff durchsuchen. Alle anderen
Verweise können Sie durch Suche im Titel finden. Falls erforderlich können Sie die Suche auf
das Hauptmenü, das Archiv oder den Dokumenttyp einschränken.
2.11 Präsentation starten
Die Präsentation startet entweder automatisch wenn des Infoportal bzw. der gesamte CBT
Manager länger nicht benutzt wird oder durch Klick auf den Button "Präsentation starten".
Die Präsentation läuft bis sie durch Tastatureingabe, Mausklick oder -bewegung abgebrochen
wird. Das Verhalten der Präsentation ist abhängig von den im Adminmenü vorgenommen
Einstellungen.
3 Persönliche Seiten
Die persönlichen Seiten sind ein spezieller Bereich des Infoportals. Da sie für jeden
Anwender individuell sind und in Abhängigkeit der Verfügbaren bzw. zugeordneten oder
absolvierten Trainings immer anders sind, müssen sie nach der Anmeldung sowie bei jeder
Änderung, z.B. dem Absolvieren eines Trainings neu erzeugt werden. Damit jeder Nutzer
Änderungen mitbekommt und somit immer aktuelle persönliche Seiten hat werden selbige
auch dann immer neu aufgebaut, wenn sie über den Button „Persönliche Seiten anzeigen“
aufgerufen wurden. Nutzen Sie dieses Feature, wenn Ihr Trainer Ihnen ein neues Training
zugeordnet hat und dieses noch nicht angezeigt wird.
3.1 Offene Trainings
Dieses ist die erste Seite, die dem Login erscheint. Sie zeigt, welche Trainings Ihnen aktuell
zugeordnet sind. Dabei symbolisiert das Buch ein per sofort verfügbares Training, das
Infosymbol gibt an, dass dieses Training in Zukunft ansteht.
3.2 Erledigte Trainings
Im Menü „Erledigte Trainings“ werden noch einmal alle Trainings aufgelistet, die Sie bisher
absolviert haben. Durch Klick auf die einzelnen Schriftzüge erscheint eine Anzeige mit
weiteren Information.
3.3 Alle Trainings
Diese Seite zeigt ausnahmslos alle dem System bekannten Trainings an. Schauen Sie sich
hier Informationen zu den Training an oder buchen Sie ein Training, das Ihnen aktuell nicht
zugeordnet ist.
3.4 Trainingsinfos
Das Infosymbol verweist immer auf eine Seite mit allen Informationen zu diesem Training.
3.4.1 Aktuelles Training
Ist Ihnen das Training aktuell zugeordnet, so zeigt die Infoseite u.a. an seit wann dies der Fall
ist und wann nach Erledigung die nächste Wiederholung des Trainings ansteht
3.4.2 Absolvierte Trainings
Haben Sie das Training bereits absolviert wird zusätzlich Erledigungstermin und falls
vorhanden das Ergebnis und Bestätigungen durch Trainer und Absolvent angezeigt. Haben
Seite 5
Benutzerhandbuch CBT Manager
15.11.05
Sie das Training mehrmals absolviert sehen Sie weitere Ergebnisse durch Blättern mit den
„<“ und „>“ Buttons.
3.4.3 Training buchen
Sofern Ihnen das Training noch nicht zugeordnet ist erscheint der Button „Training buchen“
auf der Infoseite. Durch Betätigung dessen ordnen Sie sich dieses Training zu, abhängig vom
Aktivierungsdatum ist es allerdings ggf. erst zu einem späteren Zeitpunkt absolvierbar.
3.5 Trainingswiederholung
Nach Erledigung eines Trainings wird Ihnen das Training abhängig von den Einstellungen des
Trainings sofort wieder zugeordnet. Das Training ist dann allerdings noch nicht aktiv.
Mögliche Reaktivierungzeiten sind entweder fix angegeben oder bestehen in einer immer
wiederkehrenden Periode. Eine Kombination von beidem ist ebenfalls möglich.
3.6 Training durchführen
Wird ein Training mit dem Buchsymbol angezeigt ist es zur Durchführung frei. Klicken Sie
auf das Training um die einzelnen Arbeitsschritte zu sehen.
3.6.1 Dokumente lesen
Ein Training kann beliebig viele Trainingsdokumente enthalten. Diese sollten sofern noch
nicht bekannt gründlich durchgelesen werden.
3.6.2 Fragen beantworten
Um den Trainingserfolg zu messen kann im Training eine Befragung enthalten sein. Diese
wird durch die drei Fragezeichen angezeigt. Wurde die Befragung bestanden ändert sich die
Farbe des Symbols.
3.6.2.1 Normale Befragung
Die Fragen können durch Aktivierung der Kontrollkästchen als korrekt markiert werden.
Klicken Sie dazu mit der Maus auf die Kästchen oder geben Sie mit der Tastatur die Zahlen 14 ein. Mit dem Button „Fertig“ bestätigen Sie die Eingabe. Die nächste Frage erscheint
automatisch, sobald eine Frage beantwortet wurde.
3.6.2.2 Simultane Befragung mehrerer Mitarbeiter
Zur simultanen Befragung wählen Sie vor dem Start im Menü „Mitarbeiter“ die gewünschte
Anzahl Teilnehmer aus. Verlauf: Eine Frage wird gestellt. Jeder Mitarbeiter hat eine
Aktivationstaste. Wer diese zuerst betätigt, darf die Frage beantworten. Nur eine Antwort pro
Mitarbeiter und Frage ist möglich. Antwortet ein Mitarbeiter falsch, so wird ihm der
Fragenwert abgezogen. Insofern die anderen Mitarbeiter noch nicht geantwortet haben, dürfen
sie es mit einer verbesserten Chance versuchen. Simultane Befragungen werden am Ende
nicht bewertet und sind ausschließlich zu Trainingszwecken vorhanden.
Die Aktivationstasten sind:
Mitarbeiter 1: Q
Mitarbeiter 2: B
Mitarbeiter 3: P
Seite 6
Benutzerhandbuch CBT Manager
15.11.05
3.6.2.3 Highscores:
Die Highscores werden nach jedem vollendeten Durchgang automatisch aktualisiert. Die
Highscores können über den Menüpunkt "Extras" jederzeit betrachtet werden.
Sobald eine Fragendatenbank wenigstens einmal absolviert wurde, wird auch eine
Highscoreliste automatisch angelegt.
In den Tabellen ist Platz für 50 Highscores. Die Highscores können sich im positiven, aber
auch im negativen Bereich befinden.
3.6.2.4 Verlauf
Nach Betätigung das Start Buttons erscheint die erste Frage, nehmen mehrere Mitarbeiter an
der Befragung teil müssen sich diese ggf. noch anmelden.
Die Fragen können entweder durch Anklicken der Buttons oder Eingabe der entsprechenden
Zahl beantwortet werden.
Nach Erreichen der voreingestellten Fragenanzahl oder wenn alle Fragen einmal vorkamen
endet das Spiel mit einer Mitteilung über die Punkte und den Trainingserfolg.
3.6.3 Trainingserfolge bestätigen
Bei Trainings ohne Trainingsdokumente bzw. Befragung kann es erforderlich sein den
Trainingserfolg selbst bzw. durch den Trainer bestätigen zu lassen. Diese Variante bietet sich
vor allem bei praktischen und Fahrzeugtrainings an. Zur Bestätigung des Training klicken Sie
einfach auf den Schriftzug und bestätigen den Erfolg mit Ihrem Passwort. Ihr Trainer kann
jetzt ebenfalls an Ihrer Arbeitstation das Training bestätigen oder aber aus dem Adminmenü
mehrere Bestätigungen en bloc vornehmen.
3.6.4 Fahrzeugtrainings
Fahrzeugtrainings werden mit dem Sportwagensymbol angezeigt. Fahrzeugtrainings können
ein oder mehrere Fahrzeuge beinhalten. Diese Fahrzeuge werden nach Abschluss des Training
dem Absolventen zugeordnet.
3.6.5 Bearbeitungsschritte
Die verschiedenen Bearbeitungsschritte der Trainings sind in folgender Reihenfolge
abzuarbeiten:
1.
2.
3.
4.
Dokumente (Texte, Bilder, Videos, etc.)
Befragungen
Bestätigung des Mitarbeiters
Bestätigung des Trainers
4 Admin Menü
Der Button zum Aufruf des Admin Menüs wird dann angezeigt, wenn Sie mindestens für eine
Aktion des Admin Menüs die erforderlichen Rechte besitzen. Der Aufbau des Admin Menüs
erfolgt entsprechend Ihrem Berechtigungslevel. Bei Auslieferung des CBT Managers existiert
ein Anwender mit allen Rechten. Die Kennung ist:
Name: Admin
Seite 7
Benutzerhandbuch CBT Manager
15.11.05
Passwort: admin
Es wird empfohlen nach Anlage eines realen Administrators und der Vergabe der AdminRechte auf diesen den Anwender Admin zu löschen.
4.1 Stammdaten
Die Stammdaten beinhalten alle Informationen die im CBT Manager benötigt werden, aber in
der Regel nur einmal erfasst und eher selten geändert werden.
4.2 Stammdaten Dialoge
Für
·
·
·
·
·
Mitarbeiter
Funktionen
Berechtigungen
Fahrzeuggruppen
Fahrzeuge
gibt es einheitliche Verwaltungdialoge. Diese Dialogen starten immer mit der Auswahl
·
·
·
·
Hinzufügen
Ändern
Entfernen
Einsehen
Falls erforderlich wählen Sie ein Objekt zur Bearbeitung, Einsicht, Löschung aus der Liste,
die direkte Eingabe des Objekts in das Listenelement ist ebenfalls möglich. Bei Hinzufügen,
Ändern und Einsehen wird das gewählte Objekt bzw. ein leeres in einer dem Objekt
entsprechenden Eingabemaske angezeigt.
Das Sichern und das Zuordnen von anderen Objekten ist nur dann möglich, wenn Sie die
Pflichtfelder ausgefüllt haben. Pflicht ist in der Regel der Name bzw. die Bezeichnung des
Objekts. Sinnvollerweise sind hier eindeutige Namen zu wählen.
4.2.1 Mitarbeiterdialog
Im Mitarbeiterdialog sind sämtliche Felder Pflichtfelder. Nach Anlage eines Mitarbeiters
erhält dieser als Initialpasswort seinen Vornamen. Das Passwort ist dann nach der ersten
Anmeldung des Mitarbeiters zu ändern. Hat ein Mitarbeiter sein Passwort vergessen so kann
es hier auf den Vornamen zurückgesetzt werden.
4.2.2 Funktionen
Funktionen dienen der Gruppierung von Mitarbeitern, nur das Kürzel ist eine Pflichtangabe.
Funktionen vereinfachen die Rechtevergabe, Zuordnung von Trainings und erlauben eine
bessere Einschränkung der Datenbasis bei der Erstellung von Reports.
4.2.3 Rechte
Rechte können Mitarbeitern als auch Funktionen zugeordnet werden. Nach Installation des
Infoportals gibt es zunächst die Berechtigungslevel „Admin“ und „Mitarbeiter“ wobei
„Admin“ Vollzugriff auf das gesamte System bedeutet und „Mitarbeiter“ ein Beispiel für
Seite 8
Benutzerhandbuch CBT Manager
15.11.05
eingeschränkte Rechte darstellt. WICHTIG: Stellen Sie sicher, dass immer wenigstens ein
Anwender über das Recht verfügt die Rechte zu ändern. Anderenfalls kann es passieren, dass
Sie sich selbst vom System aussperren. Sollte es dennoch dazu kommen treten Sie mit
Thorsten Ostermeier
Softwareentwicklung
Kreuzstr. 21
60435 Frankfurt
Tel.: 069 63 19 79 31
Email: [email protected]
HP: http://www.trekkieland-software.com
in Kontakt.
Im folgenden werden die Berechtigungslevel bzw. deren Bedeutung erläutert.
4.2.3.1 Menü
Hinter der Lasche „Menü“ verbergen sich sämtliche Rechte, die das Infoportal betreffen. Die
drei Spalten „eigene“, „freigegebene“, „alle“ beziehen sich immer auf den Besitzer bzw. auf
das Freigabelevel der Elemente. Ist kein Haken gesetzt, so darf der Anwender die Aktion
überhaupt nicht durchführen. Ist der erste Haken gesetzte, so ist die Aktion in bzw. auf eigene
Objekte im Infoportal gestattet. Der zweite weitet den Zugriff auf freigegebene Objekte aus.
Der dritte erteilt schließlich Vollzugriff. Dieser Vollzugriff bedeutet jedoch nicht, dass der
Anwender sofort schreibgeschütze Elemente ändern darf, vielmehr ist es ihm jetzt gestattet
das Schreibrecht auf das Objekt zu erteilen und anschließend die Änderung durchzuführen.
4.2.3.2 Stammdaten
Für alle Stammdaten gibt es die Rechte
· Einsehen
· Hinzufügen
· Ändern
· Löschen
Manche Kombinationen sind möglicherweise nicht sinnvoll, so brauchen Sie zum Ändern
auch das Recht einsehen, grundsätzlich gibt es jedoch keine Einschränkung in der
Kombination der Rechte.
4.2.3.3 Zuordnungen
Für alle Zuordnungen gibt es die Rechte
· Einsehen
· Ändern
Bei den Zuordnungen spielt es keine Rolle, in welche Richtung die Zuordnung läuft.
4.2.3.4 Allgemein
Es folgt eine kurze Beschreibung der allgemeinen Rechte:
· Reports erzeugen: Anzeige und Benutzung des Reports-Dialogs. Im Reports-Dialog
werden keine weiteren Rechte abgefragt da diese mit eingeschränkten Rechten nicht
sinnvoll erzeugt werden können.
· Daten importieren: Ebenfalls ohne weitere Rechteabfrage. Achtung, durch Importieren
können Daten überschrieben werden, auch die Rechte
Seite 9
Benutzerhandbuch CBT Manager
·
·
·
·
·
15.11.05
Daten exportieren: Wie der Import ohne weitere Rechteabfrage. Achtung, durch
Exportieren können sämtliche Daten eingesehen werden.
Den Frageneditor bedienen: Anlegen und Bearbeiten von Fragedatenbanken
Die Präsentation konfigurieren
Trainingserfolge bestätigen: Gilt sowohl für die Einzelbestätigung als auch für die
Bestätigung en bloc
Das Programm beenden
4.2.4 Fahrzeuge
Bei den Fahrzeugen ist die Nummer einziges Pflichtfeld und zugleich der Schlüssel zu den
anderen Objekten
4.2.5 Fahrzeuggruppen
Fahrzeuggruppen fassen Fahrzeuge zusammen, so dass Letztere in der MF-Matrix
Mitarbeitern besser zugeordnet werden können.
4.2.6 Rechte für Gäste
Um auch Personen, die keine Benutzerkennung haben erweiterte Funktionalitäten zu
gewähren gehen Sie wie folgt vor:
1. Legen Sie eine Funktion "Gast" an und aktivieren Sie dabei das Häkchen bei "Diese
Funktion zur Berechtigung von Gästen verwenden"
2. Klicken Sie auf "Fertig!"
3. Legen Sie eine neue Berechtigung "Gastrecht" an und aktivieren Sie die für die Gäste
gewünschten Rechte
4. Klicken Sie auf "Funktionen"
5. Setzen Sie ein Häkchen bei "Gast" und klicken Sie auf "Fertig!"
4.3 Zuordnungs Dialoge
In den Eingabemasken der Stammdaten Dialoge befinden sich neben den eigentlichen
Eingabefeldern Buttons mit den Namen anderer Objekte. Klicken Sie auf diese Buttons, um
dem aktuell in Bearbeitung befindlichen Objekt ein oder mehrere Objekte vom Typ der
Aufschrift des Buttons zuzuordnen. Folgende Zurordnungen sind auf diese Weise möglich:
Ausgangsobjekt
Mitarbeiter
Funktionen
Berechtigungen
Fahrzeuggruppen
Fahrzeuge
Trainings
Zugeordnete Objekte
Berechtigungen
Trainings
Fahrzeuge
Funktionen
Mitarbeiter
Berechtigungen
Mitarbeiter
Funktionen
Fahrzeuge
Fahrzeuggruppen
Mitarbeiter
Trainings
Mitarbeiter
Fahrzeuge
Dokumente
Seite 10
Benutzerhandbuch CBT Manager
15.11.05
Fragendatenbank
Das Ausgangsobjekt ist abhängig vom Ziel der Zuordnungen auszuwählen.
Beispiel 1:
Sie möchten Manfred Mustermann alle Fahrzeuge zuordnen, die er momentan führen darf. Da
das ziemlich viele sind öffnen Sie den Stammdaten Änderungsdialog für Manfred
Mustermann und klicken hier auf Fahrzeuge. Im Zuordnungsdialog erscheint jetzt eine
Auswahl aller Fahrzeuge, wählen Sie hier die Zielfahrzeuge.
Beispiel 2:
Sie haben ein neues Fahrzeug dazu bekommen und möchten dieses jetzt einigen Mitarbeitern
zuordnen, die bereits aufgrund von Vorkenntnissen für dieses Fahrzeug qualifiziert sind.
Öffnen Sie dazu den Stammdaten Dialog für Fahrzeug und klicken Sie nach Eingabe der
Fahrzeugdaten auf den Button „Mitarbeiter“. Im Zuordnungsdialog erscheint jetzt eine
Auswahl aller Mitarbeiter, wählen Sie hier die Zielpersonen.
Auf diese Weise ist es selbst ohne Spezialdialoge möglich jede Zuordnung komfortabel
einzugeben. Um bei Fahrzeugen, Trainings und Mitarbeiter Zuordnungen noch ein gewisses
extra an Eingabekomfort und Übersicht zu erhalten nutzen Sie die später beschriebene MTbzw. MF- Matrix.
4.3.1 MF-Matrix
In der MF-Matrix können Sie Mitarbeitern bequem Fahrzeuge zuordnen. Um einzusehen, was
hinter einem Mitarbeiter bzw. Fahrzeug steckt klicken Sie auf den Namen bzw. auf die
Nummer. Zur simultanen Zuordnung vieler Fahrzeuge gleicher Art wählen Sie als Matrixart
„Fahrzeuggruppen“ aus.
4.4 Trainings
Im CBT Manager werden Trainings ähnlich verwaltet wie die Stammdaten Objekte.
4.4.1 Trainings verwalten
Der Dialog zur Verwaltung der Trainings ist etwas umfangreicher als die anderen Dialoge,
Pflichtfelder sind Trainingsbezeichnung und Aktivierungsdatum. Ein Training kann beliebig
viele Trainingsdokumente und falls es ein Fahrzeugtraining ist auch beliebig viele Fahrzeuge
enthalten.
Möchten Sie, dass dieses Training nach Erledigung wieder eingestellt wird wählen Sie ein
Reaktivierungsdatum oder eine Reaktivierungsperiode aus. Eine Kombination von beidem ist
ebenfalls möglich. Aktivieren Sie „Reaktivierungsdatum fix“ wenn Sie möchten, dass sich
die Reaktivierungsperiode auf das Aktivierungsdatum bzw. falls angegeben das
Reaktivierungsdatum bezieht. Deaktivieren Sie das fixe Reaktivierungsdatum, so wird die
Aktivierungsperiode auf das individuelle Erledigungsdatum aufgeschlagen.
Sofern eine Befragung die Trainingsergebnisse bestätigen soll, wählen Sie eine
Fragendatenbank aus. Anderenfalls lassen Sie das Feld „Fragen Datenbank“ einfach leer.
Mit „Bestanden ab“ geben Sie eine Mindesterfolgsquote an, beovr das Training als erfolgreich
absolviert gilt und mit „Anzahl Versuche“ wie oft es die Mitarbeiter versuchen dürfen.
Seite 11
Benutzerhandbuch CBT Manager
15.11.05
Das Feld „Trainer“ gibt an, wer der Ansprechpartner für das aktuelle Training ist. Unabhängig
davon was Sie hier angeben kann das Training jedoch von jedem Anwender mit dem Recht
„Trainings bestätigen“ bestätigt werden. So ist sichergestellt, dass wenn ein Trainer mal nicht
verfügbar ist das Training dennoch bestätigt werden kann.
4.4.2. Frageneditor
Der Frageneditor ermöglicht es Ihnen Fragendatenbanken zur Prüfung der
Trainingsergebnisse anzulegen. Zu jeder Frage können Sie 2-4 Antworten eingeben, nicht
benötigte Antwortfelder lassen Sie einfach leer.
Des weiteren haben Sie die Möglichkeit zu den Fragen Grafiken einzubinden. Diese werden
an die Fragendatenbank gekoppelt und bleiben auch dann erhalten, wenn die original Grafik
verschoben oder gelöscht wird.
4.4.2.1 Fragen Laden:
Zu Beginn Ihrer Arbeit mit dem Frageneditor mag es vielleicht nützlich sein, zunächst eine
bestehende Fragendatenbank zu laden, um mit dem Programm besser vertraut zu werden.
Dies ist über den Button "Laden" oder über das Menü "Datei", "Laden" möglich.
Beim Laden ist zu beachten, dass ungesicherte Fragen, die Sie möglicherweise zuvor
eingegeben haben verloren gehen.
4.4.2.2 Neue Frage eingeben:
Um eine neue Frage einzugeben betätigen Sie den Button "Neue Frage eingeben". Die Felder
"Frage" und "1. Antwort" bis "4. Antwort" sind jetzt leer und sind mit Ihrer neuen Frage bzw.
den Antworten zu füllen.
Anschließend markieren Sie die richtigen Antworten. Das kann eine, mehrere, alle oder aber
auch keine sein. Der Frageneditor als auch die Befragung sind kompatibel zu älteren
Fragendatenbanken, in denen nur eine Antwort korrekt sein konnte.
Schließlich können Sie noch festlegen, wie viele Punkte die aktuelle Frage wert sein soll. Der
standard Wert ist eins, es kann zwischen Werten von eins bis 1000 entweder über die Liste
oder durch eine Tastatureingabe frei gewählt werden. Der Punktwert ist rein informativ und
hat keinen Einfluss auf den für das Bestehen der Befragung erforderlichen Prozentwert.
Sind Sie fertig mit der Eingabe Ihrer Frage, können Sie die nächste eingeben, eine andere
verändern oder Ihre Fragen sichern.
4.4.2.3 Frage bearbeiten:
Wählen Sie zunächst eine Frage zur Bearbeitung. Dies ist durch vorwärts oder rückwärts
blättern , die Suche sowie durch eine Direktwahl möglich. Für die Direktwahl müssen Sie sich
allerdings an die Nummer der gesuchten Frage erinnern. Zur tatsächlichen Bearbeitung
editieren Sie die Textfelder.
Sie können wahlweise auch die aktuelle Frage löschen und neu eingeben. Um alle Fragen zu
löschen betätigen Sie den Button "Neu".
4.4.2.4 Sichern:
Wenn Sie keine Fragen mehr eingeben oder bearbeiten möchten, schließen Sie Ihre Arbeit
durch Sichern der Fragendatenbank ab. Haben Sie Ihre Fragen noch nie gesichert, so wird in
jedem Fall ein Dialogfenster erscheinen, das Sie aufordert der Fragendatenbank einen Namen
zu geben.
Seite 12
Benutzerhandbuch CBT Manager
15.11.05
Wurden die aktuellen Fragen bereits gesichert oder geladen, so wird das aktuelle Fragenarchiv
durch "Sichern" überschrieben, durch "Sichern unter" können Sie Ihre Fragen dagegen unter
einem neuen Namen sichern.
4.4.3 MT-Matrix
Die MT-Matrix ermöglicht Ihnen eine einfache Zuordnung von Trainings zu Mitarbeitern. Sie
können die Matrix einschränken auf
· Trainingsarten
· Mitarbeiter
· Trainings
· Funktionen
In der Funktionssicht gelten die Zuordnungen jeweils für alle Mitarbeiter, denen die
betroffene Funktion zugeordnet ist.
Klicken Sie auf einen Mitarbeiter, eine Funktion oder ein Training um die Detaildaten
einzusehen. Halten Sie den Mauszeiger über eines dieser Elemente und der komplette Name
wird eingeblendet.
4.4.3 Bestätigungen
Falls Sie als Trainer mehrere Bestätigungen en bloc durchführen möchten, starten Sie den
Dialog zur Vergabe der Bestätigungen direkt aus dem Admin Menü. Zunächst erscheint jetzt
eine Auswahlliste von Mitarbeitern und Trainings. Wählen Sie hier den Mitarbeiter dessen
Trainings sie bestätigen möchten oder das Training, dessen Absolventen die Bestätigungen
erhalten sollen.
Als nächstes erscheint ein Dialog, der den Zuordnungsdialogen ähnlich ist. Hier sind alle
unter den von Ihnen angegebenen Kriterien noch offenen Trainingsbestätigungen aufgelistet.
Aktivieren Sie die Kontrollkästen bei denen, die Sie bestätigen möchten.
4.4.4 Befragungen freischalten
Hat ein oder mehrere Mitarbeiter alle Versuche eine Befragung zu absolvieren aufgebraucht
so kann der Trainer die Befragung wieder freischalten. Dazu benötigt der Trainer das
Bestätigungs Recht.
Aus dem Admin Menü gelangen Sie über „Befragungen freischalten“ zunächst in einen
Auswahldialog. Hier geben Sie an, für wen bzw. welche Trainings Sie freischalten möchten.
Durch Klick auf „Befragungen freischalten“ erscheint entsprechend Ihrer Auswahl ein neuer
Dialog mit allen Mitarbeitern und deren zugeordneten Trainings bei denen die Versuche die
Befragung zu absolvieren aufgebraucht sind.
Aktivieren Sie jetzt die Checkboxen:
· Versuche zurücksetzen setzt die verbrauchten Versuche des Mitarbeiters auf Null zurück.
Der Mitarbeiter kann die Befragung erneut so oft durchführen wie im Training angegeben.
· Ein neuer Versuch gestattet dem Mitarbeiter genau einen neuen Versuch, unabhängig
davon was im Training angegeben ist. Schafft es der Mitarbeiter mit diesem Versuch nicht
die Befragung zu bestehen so können Sie ihm erneut einen Versuch geben.
Seite 13
Benutzerhandbuch CBT Manager
15.11.05
4.5 Reports
Über die Reports lassen sich alle Daten bzw. Beziehungen zwischen Mitarbeitern und
Trainings übersichtlich darstellen. Abhängig vom Zweck der Auswertung wählen Sie
zunächst einen Report aus.
4.5.1 Einstellungen
Es ist nicht immer sinnvoll eine Auswertung über die gesamte Datenbasis zu fahren. Folgende
Einschränkungen sind möglich:
4.5.1.1 Zeitraum
Aktivieren Sie das Kontrollkästchen „Zeitraum wählen“, um die Einschränkung über einen
Zeitraum zu aktivieren. Geben Sie den Zeitraum mit Start- und Enddatum an, die angezeigten
Daten gelten inklusive, bei der Ermittlung der Datenbasis wird der Zeitraum mit dem
Erledigungsdatum der Trainings verglichen.
4.5.1.2 Historie
Es kann sein, dass Mitarbeiter ein Training bereits mehrmals absolviert haben und sich somit
mehrere Einträge in der Historie befinden. Aktivieren Sie „Erledigte Trainings komplett“
wenn Sie alle Einträge der Historie im Report aufgelistet haben möchten. Anderenfalls wird
lediglich der zuletzt hinzugekommene Eintrag berücksichtigt.
4.5.1.3 Stammdaten
Folgende Einschränkungen auf die Stammdaten Objekte sind möglich:
· Mitarbeiter
· Funktionen
· Trainings
· Trainingsart
Alle Einschränkungen sind miteinander kombinierbar. Haben Sie zu viele Einschränkungen
aktiviert kann es passieren, dass nur sehr wenig bzw. gar keine Werte im Report enthalten
sind.
4.5.2 Freie Überschrift und Daten
Diese Felder können Sie mit freiem Text Ihren individuellen Bedürfnissen entsprechend
belegen. Die hier eingegebenen Daten erscheinen als Überschrift in den HTML-Reports. Falls
Sie keine eigenen Daten auf dem Report haben möchten lassen Sie diese Felder leer.
4.5.3 Sicherungsort
Standardmäßig werden die Reports im Reports-Verzeichnis im Stammverzeichnis des CBT
Managers abgelegt. Wünschen Sie einen anderen Sicherungsort so aktivieren Sie das
Kontrollkästchen „Sicherungsort wählen“
4.5.4 Anzeige der Reports
Falls Sie den Report sofort nach dem Erzeugen einsehen möchten aktivieren Sie „Nach dem
Erzeugen anzeigen“. Lassen Sie das Kontrollkästchen leer um die Reports ohne Anzeige zu
erzeugen.
4.5.5 Grafische Auswertung
Die grafische Auswertung soll einen kurzen Überblick über die Ergebnisse im Durchschnitt
vermitteln. Ist das zugehörige Kontrollkästchen nicht aktiviert wird sie nicht erzeugt.
Seite 14
Benutzerhandbuch CBT Manager
15.11.05
4.5.6 Format CSV oder HTML
Jeden der Reports können Sie als
· CSV - zum Import in Excel
· HTML - zur Ansicht im Internet Explorer bzw. zum Ausdruck
erzeugen lassen.
Klicken Sie auf einen der Buttons, CSV oder HTML, um den gewählten Report mit den
aktuellen Einstellungen zu erzeugen.
4.5.6.1 CSV Format
Die Reports im CSV Format haben folgenden Aufbau:
„Überschrift 1,Überschrift 2, ... ,Überschrift N“
„Daten 1, Daten 2, ... ,Daten N“
Die Daten können so direkt mit Excel geöffnet oder in Access importiert werden.
4.5.6.2 HTML Format
Die Daten im HTML Format beinhalten neben den reinen Daten zusätzliche
Formatierungsangaben zum Druck: Seitenumbrüche und Hintergrundfarbe in den
Überschriften. Um optimale Druckergebnisse zu erzielen aktivieren Sie im Internet Explorer
im Menü
„Extras -> Internetoptionen -> Erweitert -> Drucken
die Option „Hintergrundfarben und -Bilder drucken“.
4.5.7 Die Reports im Detail
Es folgt eine Übersicht der Reports und Anwendungsbeispiele
4.5.7.1 Ergebnisse pro Training
Dieser Report nimmt die Trainings als Ausgangspunkt. Das Training bzw. dessen
Eigenschaften erscheinen in der Überschrift, die Mitarbeiter und deren Ergebnisse werden
darunter aufgelistet. Dieser Report eignet sich besonders gut für Einschränkungen auf
Training oder Trainingsart. Wählen Sie ein Training, um alle Ergebnisse zu diesem Training
zu erhalten.
4.5.7.2 Historie pro Mitarbeiter
Hier stehen die Mitarbeiter im Mittelpunkt und somit in der Überschrift. Die einzelnen
absolvierten Trainings werden jeweils darunter mit Ergebnis und Erledigungsdatum
aufgelistet. Wenn Sie eine Ergebnisübersicht für einen Mitarbeiter oder Mitarbeiter einer
Funktion haben möchten empfiehlt sich dieser Report.
4.5.7.3 Erledigte und zugeordnete Trainings im Gesamtüberblick
Ist der MT-Matrix ziemlich ähnlich. Zeigt jedoch zusätzlich an, wie oft die Trainings bereits
absolviert wurden und ermöglicht den Druck bzw. die Weitergabe der Daten. Dieser Report
ist immer dann eine gute Wahl, wenn Sie in einer Übersicht sehen möchten, wer welches
Training bereits absolviert hat bzw. wer noch nicht.
4.5.7.4 Bearbeitungsstand der Trainings
Dieser Report gibt alle offenen Trainings nebst dazugehöriger Bearbeitungsschritte pro
Mitarbeiter aus. Er gibt einen Überblick, wie weit die Mitarbeiter sowohl im einzelnen, als
auch durch die grafische Darstellung im gesamten mit den Trainings sind. Dabei wird die
Anzahl der bearbeiteten Bearbeitungsschritte in diesem Report nie auf die Gesamtanzahl in
Seite 15
Benutzerhandbuch CBT Manager
15.11.05
einem Training enthaltener Bearbeitungschritte kommen, da in dem Moment wo ein Training
komplett ist der Status von Offen auf Erledigt gesetzt wird.
4.6 Präsentation konfigurieren
Im Dialog zur Konfiguration der Präsentation können Sie folgende Optionen einstellen:
· Autostart: Gibt an, ob die Präsentation nach einer definierbaren Nichtbenutzungszeit
des CBT Managers automatisch starten soll. Um den CBT Manager während der
Abwesenheit des eingeloggten Benutzers zu schützen sollte diese Option aktiviert seit.
· Einblendezeit: Damit legen sie fest, wie lange die einzelnen Reports eingeblendet
werden sollen. Die Einblendezeit kann fest oder von der Textmenge abhängig sein.
· Reports: Hier können Sie angeben, ob Reports aus dem Hauptemenü und/oder dem
Archiv präsentiert werden sollen. Untermenüs werden immer mit einbezogen.
· Beenden: Die Präsentation lässt sich durch verschiedene Aktionen beenden, legen Sie
hier fest wie. Die Option „passwortgeschützt“ sollte aktivert sein, so dass der CBT
Manager während der Abwesenheit des Nutzers geschützt ist. Möchte ein anderer als
der aktuell eingeloggte Benutzer die Präsentation beenden, so ist dies durch Eingabe
von Name und Passwort ebenfalls möglich. Der zuvor eingeloggte Benutzer wird in
diesem Fall vom System abgemeldet.
4.7 Exportieren
Beugen Sie Datenverlust vor oder geben Sie Datenteile einer Installation an eine andere
weiter. Mit Exportieren werden folgende Daten in ein Zip-File ausgelagert:
· Dokumente
· Reports
· Menüstruktur
· Fragendatenbanken
· Einstellungen
· Stammdaten und Trainings
Beim Exportieren werden Kopien der ausgewählten Elemente erzeugt, die Originaldaten
bleiben unverändert erhalten.
4.8 Importieren
Alles, was Sie exportiert haben können Sie entweder in der selben oder in einer anderen
Installation wieder importieren. Beachten Sie, dass Dokumente, Reports, Menüstruktur und
Fragendatenbanken den bestehenden Daten hinzugefügt werden. Einstellungen, Stammdaten
und Trainings ersetzen evtl. vorhandene Bestände! Es wird empfohlen diese vor dem Import
durch Exportieren zu sichern.
Seite 16
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement