Installationshandbuch

Installationshandbuch
FileMaker
®
Installation und neue Funktionen
für FileMaker Pro 9 und FileMaker Pro 9 Advanced
© 2005-2007 FileMaker, Inc. Alle Rechte vorbehalten.
FileMaker, Inc.
5201 Patrick Henry Drive
Santa Clara, California 95054, USA
FileMaker ist eine Marke von FileMaker, Inc., eingetragen in den USA und anderen Ländern.
Das Dateiordner-Logo und ScriptMaker sind Marken von FileMaker, Inc. Alle anderen Marken
sind Eigentum der jeweiligen Besitzer.
Die FileMaker-Dokumentation ist urheberrechtlich geschützt. Sie dürfen diese Dokumentation ohne
schriftliche Genehmigung von FileMaker weder vervielfältigen noch verteilen. Diese Dokumentation
darf ausschließlich mit einer gültigen, lizenzierten Kopie der FileMaker-Software verwendet werden.
Alle in den Beispielen erwähnten Personen und Firmen sind rein fiktiv und jegliche Ähnlichkeit mit
bestehenden Personen und Firmen ist rein zufällig. Die Danksagungen und Urheberrechtshinweise finden
Sie im entsprechenden Dokument, das mit der Software geliefert wurde. Die Erwähnung von Produkten
Dritter dient nur zur Information und stellt keine Empfehlung dar. FileMaker, Inc. übernimmt keine
Verantwortung für die Leistung dieser Produkte. Weitere Informationen finden Sie auf unserer Website
unter www.filemaker.com.
Edition: 01
Inhalt
Kapitel 1
Bevor Sie beginnen
5
Über dieses Handbuch
Registrierung und Kundendienst
Update-Benachrichtigung
Über den Lizenzschlüssel
Aktivieren Ihrer FileMaker-Software
Hardware- und Software-Anforderungen
Anforderungen für Windows
Anforderungen für Mac OS
Netzwerkanforderungen
Anforderungen für Web-Publishing
Anforderungen für andere Funktionen (Windows)
Anforderungen für andere Funktionen (Mac OS)
Funktionen, die unter Mac OS X nicht unterstützt werden
Funktionen, die unter Windows nicht unterstützt werden
Öffnen von Dateien aus früheren Versionen
Aktualisieren des Anwenderwörterbuchs
Installieren unter einer Volumen-Lizenz
5
6
6
7
8
9
10
10
10
11
11
12
12
12
12
12
13
Kapitel 2
Installieren von FileMaker Pro unter Windows
15
Installationshinweise
Installieren von FileMaker Pro
Installieren von FileMaker Pro über die Befehlszeile
Speicherort von Dateien auf der Festplatte
Deinstallieren, Ändern oder Wiederherstellen von FileMaker Pro
Ändern der Cache-Größe in FileMaker Pro
Die nächsten Schritte
15
16
17
18
18
18
20
4 | Inhalt
Kapitel 3
Installieren von FileMaker Pro unter Mac OS
23
Installationshinweise
Installieren von FileMaker Pro
Speicherung von Dateien auf Ihrer Festplatte
Installieren der ODBC-Treiber unter Mac OS X
Ändern der Cache-Größe in FileMaker Pro
Die nächsten Schritte
23
24
24
25
25
26
Kapitel 4
Neue Funktionen
29
Neue Funktionen in FileMaker Pro 9
Neue Funktionen in FileMaker Pro 9 Advanced
29
32
Kapitel 1
Bevor Sie beginnen
Willkommen bei Ihrer FileMaker®-Software. Mit FileMaker können Sie
Informationen einfach und effizient verwalten.
Über dieses Handbuch
Dieses Handbuch Installation und neue Funktionen beschreibt die
Installation von FileMaker Pro 9 bzw. FileMaker Pro 9 Advanced auf
Ihrem Windows- oder Mac OS-Computer und stellt Ihnen die neuen
Funktionen der Software vor.
Hinweis In diesem Handbuch bezieht sich „FileMaker Pro“ sowohl auf
FileMaker Pro als auch auf FileMaker Pro Advanced. Ausgenommen ist
die Beschreibung von Funktionen, die spezifisch für
FileMaker Pro Advanced sind.
Das FileMaker Pro Benutzerhandbuch gibt Ihnen grundlegende
Informationen, damit Sie direkt produktiv arbeiten können. Wenn Sie
FileMaker Pro noch nie verwendet haben, arbeiten Sie den FileMaker Pro
Lehrgang durch, um die wichtigsten Funktionen kennen zu lernen. Details
und umfassende schrittweise Anweisungen finden Sie in der FileMaker Pro
Hilfe.
Das FileMaker Pro Advanced Entwicklerhandbuch beschreibt zusätzliche
Funktionen in FileMaker Pro Advanced, einschließlich Funktionen wie
das Anpassen von Menüs, das Kopieren und Importieren von Tabellen,
die Datenbank-Design-Reports, Feld-, Variablen- und Ausdruckskontrolle
über die Datenanzeige und die QuickInfos.
Hinweis Wenn sich eine Funktion oder Vorgehensweise nur auf eine
bestimmte Plattform bezieht, beziehen sich auch die entsprechenden
Anweisungen und Abbildungen auf die entsprechende Plattform. Wenn
Funktionen oder Vorgehensweisen auf beiden Plattformen ähnlich sind, wird
nur eine Abbildung angezeigt, die sich auf Windows oder Mac OS bezieht.
6 | Bevor Sie beginnen
Registrierung und Kundendienst
Bitte nehmen Sie sich einen Augenblick Zeit, Ihr Produkt während
der Installation zu registrieren. Durch die Registrierung Ihrer Software
haben Sie ggf. Anspruch auf Upgrade-Angebote und weitere
Kundendienstleistungen. Folgen Sie den Anweisungen, um Ihre
Registrierungs- und Produkt- sowie weitere Informationen anzugeben.
Wenn Sie die FileMaker Pro-Testversion verwenden, müssen Sie Ihre
Software vor der Verwendung registrieren.
Sie können sich auch auf der FileMaker-Website unter
www.filemaker.de/register registrieren. Oder Sie wählen in
FileMaker Pro Hilfe > Jetzt registrieren. In beiden Fällen müssen
Sie sich mit einem gültigen Lizenzschlüssel registrieren.
Informationen zu technischem Support und Kundendienst finden Sie
unter www.filemaker.com/intl.
Um auf Ressourcen der FileMaker-Website wie vorgefertigte Lösungen
und die FileMaker Knowledge Base zuzugreifen, wählen Sie Hilfe >
Learning Center.
Wenn Sie keinen Internet-Zugang haben, finden Sie weitere
Informationen im FileMaker-Service-Verzeichnis, das mit der
Software geliefert wird.
Update-Benachrichtigung
FileMaker Pro 9 prüft alle sieben Tage automatisch auf SoftwareUpdates. Wenn Sie über eine Internet-Verbindung verfügen, können Sie
die Update-Webseite aufrufen und die Updater-Software herunterladen.
Sie können das Update später durchführen, indem Sie Hilfe > Downloads
und Updates wählen.
Hinweis Diese Funktion installiert nicht die Software für Sie. Sie benötigen
eine Internet-Verbindung, um auf die Updater-Software zuzugreifen und sie
herunterzuladen.
Über den Lizenzschlüssel | 7
Um Update-Benachrichtigungen auszuschalten, führen Sie eine der
folgenden Aktionen aus:
1
1
Wählen Sie im Dialogfeld „Update-Benachrichtigung“
Nicht automatisch nach Updates suchen und klicken Sie auf Ja.
Windows: Wählen Sie Bearbeiten > Einstellungen. Mac OS: Wählen
Sie FileMaker Pro > Einstellungen. Deaktivieren Sie Automatisch alle 7
Tage auf Updates prüfen im Register Allgemein. Um UpdateBenachrichtigungen wieder einzuschalten, aktivieren Sie diese
Option.
Wenn Sie die Update-Benachrichtigung deaktivieren, wird das Dialogfeld
„Update-Benachrichtigung“ nicht angezeigt.
Über den Lizenzschlüssel
Die FileMaker-Software wird mit einem eindeutigen 35-stelligen
alphanumerischen Lizenzschlüssel ausgeliefert. Verlieren Sie den
Lizenzschlüssel nicht. Wir empfehlen, den Lizenzschlüssel für den Fall,
dass Sie die Software neu installieren müssen, an einem sicheren Ort
aufzubewahren.
Sie finden Ihre(n) Lizenzschlüssel auf der Rückseite der CD-Hülle.
Wenn Sie Ihre Software elektronisch bezahlt haben, haben Sie eine
E-Mail mit einem Link zu einer PDF-Datei mit Ihrem Lizenzschlüssel
erhalten. Sie müssen einen gültigen Lizenzschlüssel eingeben, um die
Software zu aktivieren. Weitere Informationen finden Sie im folgenden
Abschnitt, „Aktivieren Ihrer FileMaker-Software“.
Der Lizenzschlüssel stellt die Einhaltung des Endbenutzer-Lizenzvertrags
sicher, der die Verwendung einer (1) Kopie der Software auf jeweils
einem Computer gestattet (weitere Informationen entnehmen Sie dem
Software-Lizenzvertrag). Wenn der Lizenzschlüssel ungültig ist oder
bereits eine mit demselben Lizenzschlüssel installierte Version der
Anwendung im Netzwerk läuft, zeigt FileMaker Pro eine Fehlermeldung
an: „FileMaker Pro wird von der maximalen Anzahl lizenzierter Benutzer
verwendet. Weitere Informationen finden Sie in Ihrer SoftwareDokumentation im Abschnitt über den Lizenzschlüssel.“
8 | Bevor Sie beginnen
Wenn diese Fehlermeldung angezeigt wird, haben Sie einen
Lizenzschlüssel eingegeben, der bereits verwendet wird. Um
FileMaker Pro auf mehreren Computern zu installieren, benötigen Sie
einen eindeutigen Lizenzschlüssel für jeden Benutzer oder eine VolumenLizenz. Sie müssen für jeden Computer eine Kopie von FileMaker Pro
lizenzieren.
Aktivieren Ihrer FileMaker-Software
Die FileMaker Pro-Software verwendet Online-Aktivierungstechnologie,
um sicherzustellen, dass Sie und Ihr Unternehmen eine echte Kopie von
FileMaker-Software einsetzen. Die Aktivierung hilft, FileMaker, Inc. vor
der unbefugten Distribution von Software zu schützen.
Für
Vorgehensweise in FileMaker Pro
Aktivieren von
Klicken Sie im Dialogfeld „FileMaker-Aktivierung“
FileMaker Pro beim Start auf Aktivieren.
Gekaufte Software später Klicken Sie im Dialogfeld „FileMaker-Aktivierung“
aktivieren
auf Später aktivieren.
Gekaufte Software
innerhalb der
Aktivierungsfrist
aktivieren
Wählen Sie Hilfe > Aktivieren. Klicken Sie im Dialogfeld
„FileMaker-Aktivierung“ auf Aktivieren.
Testsoftware aktivieren
Klicken Sie beim Start auf Lizenzschlüssel im Dialogfeld,
geben Sie Ihren Lizenzschlüssel ein und klicken Sie auf
Aktivieren. Oder wählen Sie während der Verwendung
der Software Hilfe > Aktivieren. Geben Sie im Dialogfeld
„FileMaker-Aktivierung“ Ihren Lizenzschlüssel ein und
klicken Sie auf Aktivieren.
Deaktivieren der
FileMaker Pro-Software
Wählen Sie Hilfe > Deaktivieren.
Wenn Sie Ihre Software per Telefon aktivieren, können
Sie sie auch nur per Telefon deaktivieren.
Hardware- und Software-Anforderungen | 9
Die Aktivierung für Testversionen und gekaufte Software unterscheidet
sich. Als Testbenutzer haben Sie Zeit (in der Regel 30 Tage), bevor Sie
für die Software zahlen müssen. Während des Testzeitraums können Sie
jederzeit für die Software zahlen und sie dann aktivieren, indem Sie beim
Start den Lizenzschlüssel eingeben. Nach Ablauf des Testzeitraums
müssen Sie für die Software zahlen und sie sofort aktivieren, um sie
weiter zu verwenden.
Gekaufte Software können Sie später aktivieren. Dies wird als
Aktivierungsfrist bezeichnet. FileMaker Pro gibt Ihnen einen Zeitraum
(in der Regel 30 Tage) für die Aktivierung der Software. Jedes Mal, wenn
Sie die Software starten, wird das Dialogfeld „Aktivierung“ angezeigt,
das die verbleibende Aktivierungsfrist angibt und Sie auffordert, Ihre
Software zu aktivieren.
Nach dieser Aktivierungsfrist müssen Sie die Software aktivieren, um sie
weiter zu verwenden. Testversionen besitzen keine Aktivierungsfrist.
Wenn Sie nicht über eine Internet-Verbindung verfügen, können Sie die
Aktivierung Ihrer Software per Telefon vornehmen. Wenden Sie sich
unter der Rufnummer, die Sie im Service-Verzeichnis finden, an den
Kundendienst von FileMaker. Unter www.filemaker.de/activation
finden Sie aktuelle Informationen und Rufnummern.
Nach der Aktivierung der Software können Sie die Aktivierung
deaktivieren und auf einen anderen Computer übertragen. So können
Sie FileMaker Pro auf einem anderen Computer ausführen. Wenn Sie
aus einem beliebigen Grund FileMaker Pro deinstallieren müssen,
deaktivieren Sie die Software vor der Deinstallation.
Weitere Informationen zur Aktivierung finden Sie unter „Aktivieren Ihrer
FileMaker-Software“ in der FileMaker Pro Hilfe.
Hardware- und Software-Anforderungen
Wichtig Zum Zeitpunkt der Drucklegung dieses Handbuchs hat FileMaker,
Inc. FileMaker Pro 9 mit den unten aufgeführten Windows- und Mac OSBetriebssystemen getestet. FileMaker Pro kann möglicherweise nicht mit
neueren Versionen dieser Betriebssysteme ausgeführt werden. Weitere
Informationen zu neueren Betriebssystemen finden Sie unter
www.filemaker.de.
10 | Bevor Sie beginnen
Um FileMaker Pro zu installieren und zu verwenden, benötigen Sie die
folgende Mindestausstattung und Software:
Anforderungen für Windows
1
1
1
Windows Vista Home, Business oder Ultimate: Pentium III
800 MHz oder schneller mit 512 MB RAM
Windows XP SP2: Pentium III 500 MHz oder schneller mit
256 MB RAM
Grafikkarte mit SVGA (800x600) oder höherer Auflösung und
passenden Monitor
Anforderungen für Mac OS
1
1
1
1
Macintosh-Computer mit PowerPC G3-Prozessor oder schneller,
oder Intel-basierter Macintosh-Computer
256 MB Arbeitsspeicher
Mac OS X Version 10.4.8
QuickTime 6.4 bis 7 Software (verfügbar unter www.apple.com, falls
es in Ihrer Mac OS-Version nicht enthalten ist)
Hinweis Mac OS-Plugins, die für PowerPCs erstellt wurden, müssen als
Universal Binaries neu kompiliert werden, um direkt ausgeführt zu werden,
wenn FileMaker Pro auf Intel-basierten Mac-Computern ausgeführt wird.
Als Universal Binaries können Anwendungen direkt sowohl auf PowerPCals auch auf Intel-basierten Macintosh-Computern ausgeführt werden.
Wenn Sie Plugins von früheren FileMaker Pro-Versionen besitzen, die Sie mit
FileMaker Pro 9 auf einem Intel-basierten Macintosh verwenden möchten,
können Sie FileMaker Pro so einstellen, dass die Software unter Rosetta
ausgeführt wird. Wählen Sie im Finder FileMaker, wählen Sie Ablage >
Information und wählen Sie die Option Mit Rosetta öffnen.
Netzwerkanforderungen
Wenn Sie FileMaker Pro-Dateien mit anderen Computern in einem
Netzwerk gemeinsam nutzen möchten, müssen Sie den Netzwerktyp
kennen. FileMaker Pro 9 unterstützt das TCP/IP-Netzwerkprotokoll.
Anforderungen für Web-Publishing | 11
Wenn Sie nicht sicher sind, welches Netzwerkprotokoll auf dem
Computer installiert und im Einsatz ist, fragen Sie vor Installationsbeginn
Ihren Netzwerkadministrator.
Für die Verbindung zu einem Netzwerk benötigt Ihr Computer ferner eine
Netzwerkkarte und die erforderliche Software.
Anforderungen für Web-Publishing
Zur Veröffentlichung einer Datenbank im Web über FileMaker Pro
Instant Web Publishing benötigen Sie einen Host-Computer mit Internetoder Intranet-Zugang über TCP/IP.
Wichtig Für den Zugang zum Internet wird ein Internet-Anbieter (ISP
Internet service provider) benötigt. FileMaker Pro stellt kein Internetkonto
zur Verfügung.
Anforderungen für andere Funktionen (Windows)
Für einige der Funktionen von FileMaker Pro für Windows wird
zusätzliche Software benötigt.
Funktion
Software-Anforderungen
Scriptschritt „E-Mail
senden“
MAPI-kompatibler E-Mail-Client
Telefonnummernwahl
Rufnummernwähler oder andere TAPI-kompatible
Software
ODBC-Funktionen
Microsoft Data Access Components (MDAC)
Version 2.8 SP1 (Windows XP) oder Windows DAC 6.0
(Windows Vista). MDAC-Software können Sie über die
Microsoft-Website unter www.microsoft.com
aktualisieren.
Der Zugriff auf externe Datenquellen mit FileMaker Pro
als Client-Anwendung erfordert für die von Ihnen
verwendete Datenquelle Treiber Dritter
Weitere Informationen zur Verwendung von ODBC
finden Sie unter www.filemaker.de/support/technologies.
Einfügen von
QuickTime-Movies
und -Bildern
QuickTime 6-Software (verfügbar unter
www.apple.com)
12 | Bevor Sie beginnen
Anforderungen für andere Funktionen (Mac OS)
Für einige der Funktionen von FileMaker Pro für MAC OS X wird
zusätzliche Software benötigt.
Funktion
Software-Anforderungen
Scriptschritt „E-Mail
senden“
Microsoft Entourage oder Mac OS X Mail als E-Mail-Client
ODBC-Funktionen
Der Zugriff auf externe Datenquellen mit FileMaker Pro als
Client-Anwendung erfordert für die von Ihnen verwendete
Datenquelle Treiber Dritter
Weitere Informationen zur Verwendung von ODBC finden
Sie unter www.filemaker.de/support/technologies.
Funktionen, die unter Mac OS X nicht unterstützt
werden
Unter Mac OS X unterstützt FileMaker Pro folgende Scriptschritte nicht:
Telefonnummer wählen, Objekt einfügen, DDE Execute senden,
Verknüpfung aktualisieren.
Funktionen, die unter Windows nicht unterstützt
werden
Unter Windows unterstützt FileMaker Pro folgende Scriptschritte nicht:
AppleScript ausführen, Sprechen.
Öffnen von Dateien aus früheren Versionen
FileMaker Pro 9 kann Dateien öffnen, die mit früheren Versionen
von FileMaker Pro erstellt wurden. Informationen finden Sie in der
FileMaker Pro Hilfe.
Aktualisieren des Anwenderwörterbuchs
Wenn Sie einem Anwenderwörterbuch in einer Vorgängerversion
von FileMaker Pro Wörter hinzugefügt haben, können Sie dies mit
FileMaker Pro 9 verwenden. Informationen über das Konvertieren
eines Anwenderwörterbuchs finden Sie in der FileMaker Pro Hilfe.
Installieren unter einer Volumen-Lizenz | 13
Installieren unter einer Volumen-Lizenz
Wenn Sie mehrere Kopien von FileMaker Pro unter einer VolumenLizenz installieren oder wenn Sie eine unsichtbare Installation vornehmen
wollen, können Sie den Vorgang automatisieren. Verwenden Sie die
Datei „Assisted Install.txt“ auf der FileMaker Pro-CD bzw. in Ihrem
elektronischen Download, um die normalen Installationsdialogfelder
zu umgehen. Weitere Informationen finden Sie im Handbuch
Netzwerkinstallation für FileMaker Pro und FileMaker Pro
Advanced. Weitere Informationen zur Volumen-Lizenzierung finden
Sie unter www.filemaker.de.
14 | Bevor Sie beginnen
Kapitel 2
Installieren von FileMaker Pro
unter Windows
Bevor Sie mit dem Installationsvorgang beginnen, beenden Sie andere
geöffnete Programme und speichern Sie Ihre Arbeit. Die neuesten
Informationen zu FileMaker Pro finden Sie auf der CD in der Datei
„Bitte Lesen“ oder auf der Website unter www.filemaker.de.
Installationshinweise
Bevor Sie FileMaker Pro installieren, lesen Sie sich folgende Hinweise
durch:
1
1
1
1
1
1
Um FileMaker Pro zu installieren, benötigen Sie Administratorrechte.
Wenn auf dem Computer ein Virenschutzprogramm ausgeführt wird,
beenden Sie es, bevor Sie FileMaker Pro installieren, und starten Sie
es danach erneut.
Bei der Installation von FileMaker Pro wird das Lizenzvertragsfenster
angezeigt. Lesen Sie den Software-Lizenzvertrag. Wenn Sie den
Bestimmungen des Lizenzvertrags zustimmen, klicken Sie auf
Ich akzeptiere... und anschließend auf Weiter.
Standardmäßig wird FileMaker Pro in diesem Ordner installiert:
C:/Programme/FileMaker/FileMaker Pro 9
Während der Installation können Sie ein anderes Laufwerk oder einen
anderen Ordner auswählen.
Standardmäßig wird FileMaker Pro Advanced in diesem Ordner
installiert: C:/Programme/FileMaker/FileMaker Pro 9 Advanced
Während der Installation können Sie ein anderes Laufwerk oder
einen anderen Ordner auswählen.
Sie können auch festlegen, ob alle Programmfunktionen (Vollständig)
oder nur ausgewählte Teile des Programms installiert werden
(Benutzerdefiniert). Sie können z. B. festlegen, dass bestimmte
Funktionen nicht installiert werden, um weniger Speicherplatz
zu belegen.
16 | Installieren von FileMaker Pro unter Windows
1
1
Zu Beginn der Installation wählen Sie die Sprachversion für
FileMaker Pro aus. Die Standardauswahl entspricht der Sprache
Ihres Betriebssystems. Eine vollständige Installation installiert
nur die Sprachversion, die Sie auswählen. Sie können zusätzliche
Sprachversionen installieren, indem Sie die manuelle Installation und
dann weitere Sprachpakete aus der Liste der unterstützten Sprachen
auswählen.
Vor der Installation eines Upgrades oder eines Software-Updates
durchsucht die FileMaker-Software alle Festplatten und Volumes,
die mit dem System verbunden sind, nach früheren Versionen. Diese
Suche kann einige Minuten dauern, wenn Sie mehrere Laufwerke oder
Volumes besitzen.
Installieren von FileMaker Pro
Sie müssen das Installationsprogramm verwenden, um FileMaker Pro
zu installieren. Sie können FileMaker Pro nicht installieren, indem Sie
Dateien auf die Festplatte ziehen.
Wenn Sie eine Installationsprotokolldatei erstellen möchten, in der
Registrierungseinträge und der Pfad aller installierten Dateien aufgelistet
werden, müssen Sie FileMaker Pro über die Befehlszeile installieren.
Weitere Informationen finden Sie unter „Installieren von FileMaker Pro
über die Befehlszeile“ auf Seite 17.
So installieren Sie FileMaker Pro auf der Festplatte:
1. Legen Sie die CD in das CD- oder DVD-Laufwerk ein und öffnen Sie das
FileMaker-CD-Fenster. (Wenn Sie die Software online gekauft haben,
wechseln Sie zum Installationssymbol.)
2. Klicken Sie auf das Installationssymbol.
Hier klicken, um
die Anwendung
zu installieren.
Klicken, um den
Inhalt der CD
anzuzeigen.
Klicken, um zu
beenden.
Der InstallShield-Assistent von FileMaker Pro wird angezeigt.
Installieren von FileMaker Pro über die Befehlszeile | 17
3. Installieren Sie FileMaker Pro, indem Sie den
Bildschirmanweisungen folgen.
Detaillierte Informationen zu Installationsproblemen finden Sie unter
„Installationshinweise“ auf Seite 15.
4. Wenn die Installation abgeschlossen ist, klicken Sie auf Fertig stellen.
Am Ende der Installation wird ein Produktregistrierungsfenster
angezeigt.
Installieren von FileMaker Pro über die Befehlszeile
So installieren Sie FileMaker Pro über die Befehlszeile und erstellen eine
Installationsprotokolldatei:
1. Legen Sie die CD in das CD- oder DVD-Laufwerk ein.
(Wenn Sie die Software online gekauft haben, können
Sie diesen Schritt überspringen.)
2. Öffnen Sie ein Befehlsfenster.
3. Geben Sie Folgendes in das Befehlsfenster ein:
E:\Files\setup.exe /v"/Lr
C:\FMP9InstallLog.txt"
wobei E: das CD- oder DVD-Laufwerk ist. Wenn Ihr CD- oder DVDLaufwerk eine andere Laufwerkskennung verwendet, geben Sie
diesen Buchstaben statt des E ein.
4. Folgen Sie den Bildschirmanweisungen.
Die Datei „FMP9InstallLog.txt“ wird im Stammverzeichnis Ihrer
Festplatte gespeichert. Sie können sie mit WordPad oder einem
Textverarbeitungsprogramm anzeigen.
Hinweis Wenn Ihr CD- oder DVD-Laufwerk nicht Laufwerk E zugeordnet
ist, ersetzen Sie den Buchstaben durch den Buchstaben, der Ihrem Laufwerk
zugeordnet ist.
18 | Installieren von FileMaker Pro unter Windows
Speicherort von Dateien auf der Festplatte
Das Installationsprogramm von FileMaker Pro kopiert Dateien in
verschiedene Ordner auf der Festplatte, abhängig von den ausgewählten
Installationsoptionen und dem Betriebssystem. Wenn Sie die Installation
über die Befehlszeile ausgeführt und eine Installationsprotokolldatei
angegeben haben, können Sie diese Datei, in der der Speicherort jeder
Datei aufgelistet wird, anzeigen.
Deinstallieren, Ändern oder Wiederherstellen von
FileMaker Pro
Über die Option „Software“ in der Windows XP-Systemsteuerung bzw.
der Windows Vista-Systemsteuerung „Programme und Funktionen“
können Sie FileMaker Pro deinstallieren, fehlende oder beschädigte
Dateien ersetzen oder die Installation von Funktionen ändern. Weitere
Informationen finden Sie in der Windows Hilfe.
Hinweis Durch die Deinstallation werden von Ihnen erstellte Dateien
nicht gelöscht, außer sie haben den gleichen Namen wie Beispiel- oder
Vorlagendateien (Starter-Lösungen), die mit FileMaker Pro installiert
wurden.
Wenn Sie FileMaker Pro ändern oder wiederherstellen, werden Sie
möglicherweise dazu aufgefordert, Ihren Lizenzschlüssel einzugeben.
Hinweis Deaktivieren Sie FileMaker Pro, bevor Sie die Software
deinstallieren. Weitere Informationen hierzu finden Sie unter „Aktivieren
Ihrer FileMaker-Software“ auf Seite 8.
Ändern der Cache-Größe in FileMaker Pro
FileMaker Pro unterhält einen internen Cache für Teile Ihrer Datenbank.
Je nach Speicherkonfiguration des Computers können Sie die CacheGröße anpassen, um die Leistung zu optimieren.
Sie sollten eine Erhöhung der Cache-Größe in Erwägung ziehen, wenn
Sie Folgendes planen:
1
1
Arbeiten mit einer großen Datenbankdatei
gleichzeitiges Arbeiten mit mehreren Datenbankdateien
Ändern der Cache-Größe in FileMaker Pro | 19
1
1
1
Hosten von Datenbankdateien
Verwendung einer Datenbankdatei, die viele Grafiken enthält
Einfügen einer großen Grafik in eine Datenbankdatei
Verringern Sie die Cache-Größe, wenn Sie mehrere Anwendungen
gleichzeitig ausführen möchten und begrenzter Arbeitsspeicher (RAM)
installiert ist.
Hinweis Wenn Sie die Cache-Größe in FileMaker Pro erhöhen oder
verringern, erhöhen und verringern Sie auch die Speichermenge, die
für die Ausführung von FileMaker Pro erforderlich ist.
Weitere Informationen zur Speicherverwaltung finden Sie in der
Dokumentation, die mit Ihrem Computer geliefert wurde.
So ändern Sie die von FileMaker Pro verwendete Cache-Größe:
1. Wählen Sie in FileMaker Pro im Menü Bearbeiten > Einstellungen.
Das Dialogfeld „Einstellungen“ wird angezeigt.
20 | Installieren von FileMaker Pro unter Windows
2. Klicken Sie auf das Register Speicher.
3. Geben Sie in das Feld Datei-Cache festlegen auf eine Zahl ein und
klicken Sie dann auf OK.
Beim nächsten Start von FileMaker Pro wird die neue Cache-Größe
verwendet.
Die nächsten Schritte
Nachdem Sie FileMaker Pro installiert haben, können Sie sofort
mit der Anwendung arbeiten. Hier finden Sie einige Vorschläge
zu weiterführenden Informationen in der Dokumentation:
1
1
Wenn Sie noch nicht mit Datenbanken vertraut sind, lesen Sie
Kapitel 2, „Verwenden von Datenbanken“, und Kapitel 3, „Erstellen
von Datenbanken“, im FileMaker Pro Benutzerhandbuch, um sich
über grundlegende Datenbankkonzepte zu informieren.
Wenn Sie FileMaker Pro noch nicht kennen, arbeiten Sie die
Lektionen im FileMaker Pro Lehrgang durch. Die PDF-Datei und die
Beispieldatei für den Lehrgang befinden sich im Ordner „Lehrgang“
innerhalb des Ordners „Deutsch Extras“.
Die nächsten Schritte | 21
1
1
Wenn Sie FileMaker Pro bereits kennen, lesen Sie Kapitel 4, „Neue
Funktionen“ dieses Handbuchs, um sich über neue Funktionen von
FileMaker Pro 9 und FileMaker Pro 9 Advanced zu informieren.
Wenn Sie Benutzer von FileMaker Pro Advanced sind, lesen Sie das
FileMaker Pro Advanced Entwicklerhandbuch und die FileMaker Pro
Hilfe.
22 | Installieren von FileMaker Pro unter Windows
Kapitel 3
Installieren von
FileMaker Pro unter Mac OS
Bevor Sie mit dem Installationsvorgang beginnen, beenden Sie andere
geöffnete Programme und speichern Sie Ihre Arbeit. Die neuesten
Informationen zu FileMaker Pro finden Sie auf der CD in der Datei
„Bitte Lesen“ oder auf der Website unter www.filemaker.de.
Installationshinweise
Bevor Sie FileMaker Pro installieren, lesen Sie sich folgende Hinweise
durch:
1
1
1
1
1
Wenn auf dem Computer ein Virenschutzprogramm ausgeführt wird,
beenden Sie es, bevor Sie FileMaker Pro installieren, und starten Sie
es danach erneut.
Bei der Installation von FileMaker Pro wird das Lizenzvertragsfenster
angezeigt. Lesen Sie den Software-Lizenzvertrag. Wenn Sie den
Bestimmungen des Lizenzvertrags zustimmen, klicken Sie auf
Akzeptieren.
Während der Installation können Sie zwischen der Installation aller
Programmdateien (Einfache Installation) und der Installation von
Teilen des Programms (Manuelle Installation) wählen. Sie können z. B.
festlegen, dass bestimmte Funktionen nicht installiert werden, um
weniger Speicherplatz zu belegen.
Bei einer einfachen Installation wird FileMaker Pro in der
Sprache Ihres Betriebssystems installiert. Sie können zusätzliche
Sprachversionen installieren, indem Sie die manuelle Installation und
dann weitere Sprachpakete aus der Liste der unterstützten Sprachen
auswählen.
Vor der Installation eines Upgrades oder eines Software-Updates
durchsucht die FileMaker-Software alle Festplatten und Volumes,
die mit dem System verbunden sind, nach früheren Versionen. Diese
Suche kann einige Minuten dauern, wenn Sie mehrere Laufwerke oder
Volumes besitzen.
24 | Installieren von FileMaker Pro unter Mac OS
Installieren von FileMaker Pro
Sie müssen das Installationsprogramm verwenden, um FileMaker Pro
zu installieren. Sie können FileMaker Pro nicht installieren, indem Sie
Dateien auf die Festplatte ziehen.
So installieren Sie FileMaker Pro auf der Festplatte:
1. Legen Sie die CD in das CD- oder DVD-Laufwerk ein und öffnen Sie
das FileMaker-CD-Fenster. (Wenn Sie die Software online gekauft
haben, können Sie diesen Schritt überspringen.)
2. Suchen und doppelklicken Sie auf das Symbol des FileMaker Pro 9 -
Installationsprogramms.
Symbol des FileMaker Pro 9Installationsprogramms
3. Wenn Sie dazu aufgefordert werden, geben Sie den Benutzernamen
und das Passwort des Mac OS-Administrators ein.
4. Installieren Sie FileMaker Pro, indem Sie den Bildschirm-
anweisungen folgen.
5. Klicken Sie auf Beenden, um das Installationsprogramm zu beenden.
Während die Installation abgeschlossen wird, wird das Dialogfenster
zur Produktregistrierung angezeigt.
Speicherung von Dateien auf Ihrer Festplatte
Das Installationsprogramm von FileMaker Pro kopiert Dateien in
verschiedene Ordner auf der Festplatte, abhängig von den ausgewählten
Installationsoptionen und dem Betriebssystem. Nach Abschluss der
Installation können Sie im FileMaker Pro 9-Ordner die Installationsprotokolldatei anzeigen. In dieser Datei wird der Installationsort jeder
Datei aufgeführt. Sie können sie mit TextEdit oder einem
Textverarbeitungsprogramm anzeigen.
Installieren der ODBC-Treiber unter Mac OS X | 25
Installieren der ODBC-Treiber unter Mac OS X
Die FileMaker Pro ODBC-Unterstützung ermöglicht Ihnen, Daten aus
anderen Anwendungen auf Ihrem Computer oder über ein Netzwerk,
z. B. aus Oracle-Datenbanken, zu importieren. Weitere Informationen zur
Verwendung von ODBC einschließlich Links zu Treiberherstellern finden
Sie unter www.filemaker.de/support/technologies.
Ändern der Cache-Größe in FileMaker Pro
Mac OS X weist den Anwendungen Speicher dynamisch nach Bedarf zu.
Es gibt keine Möglichkeit, FileMaker Pro eine bestimmte Speichermenge
zuzuweisen. Sie können jedoch die Größe des FileMaker Pro-Cache
anpassen.
Sie sollten in Erwägung ziehen, die Cache-Größe zu erhöhen, wenn Sie
Folgendes planen:
1
1
1
1
1
Arbeiten mit einer großen Datenbankdatei
gleichzeitiges Arbeiten mit mehreren Datenbankdateien
Hosten von Datenbankdateien
Verwendung einer Datenbankdatei, die viele Grafiken enthält
Einfügen einer großen Grafik in eine Datenbankdatei
Verringern Sie die Cache-Größe, wenn Sie mehrere Anwendungen
gleichzeitig ausführen möchten und begrenzter Arbeitsspeicher (RAM)
installiert ist.
26 | Installieren von FileMaker Pro unter Mac OS
So ändern Sie die von FileMaker Pro verwendete Cache-Größe:
1. Wählen Sie in FileMaker Pro im Menü FileMaker Pro > Einstellungen
und klicken Sie auf das Register Speicher.
2. Geben Sie in das Feld Datei-Cache festlegen auf eine Zahl ein und
klicken Sie dann auf OK.
Beim nächsten Start von FileMaker Pro wird die neue Cache-Größe
verwendet.
Die nächsten Schritte
Nachdem Sie FileMaker Pro installiert haben, können Sie sofort
mit der Anwendung arbeiten. Hier finden Sie einige Vorschläge
zu weiterführenden Informationen in der Dokumentation:
1
1
Wenn Sie noch nicht mit Datenbanken vertraut sind, lesen Sie
Kapitel 2, „Verwenden von Datenbanken“, und Kapitel 3, „Erstellen
von Datenbanken“, im FileMaker Pro Benutzerhandbuch, um sich
über grundlegende Datenbankkonzepte zu informieren.
Wenn Sie FileMaker Pro noch nicht kennen, arbeiten Sie die
Lektionen im FileMaker Pro Lehrgang durch. Die Lehrgang-PDFDatei und die Beispieldatei befinden sich im Ordner „Lehrgang“
innerhalb des Ordners „Deutsch Extras“.
Die nächsten Schritte | 27
1
1
Wenn Sie FileMaker Pro bereits kennen, lesen Sie Kapitel 4, „Neue
Funktionen“ dieses Handbuchs, um sich über neue Funktionen von
FileMaker Pro 9 und FileMaker Pro 9 Advanced zu informieren.
Wenn Sie Benutzer von FileMaker Pro 9 Advanced sind, lesen
Sie das FileMaker Pro Advanced Entwicklerhandbuch und die
FileMaker Pro Hilfe.
28 | Installieren von FileMaker Pro unter Mac OS
Kapitel 4
Neue Funktionen
Dieses Kapitel gibt Ihnen einen Überblick über die neuen Funktionen
und Verbesserungen in FileMaker Pro 9 und FileMaker Pro 9 Advanced.
Wenn nichts anderes vermerkt ist, finden Sie weitere Informationen zu
diesen Funktionen in der FileMaker Pro Hilfe.
Neue Funktionen in FileMaker Pro 9
Sharing und gemeinsame Nutzung
1 Unterstützung für externe SQL-Datenquellen (ODBC) – Zeigen Sie
Daten aus SQL-Tabellen an, greifen Sie auf sie zu und verwenden Sie
sie. Zum Beispiel können Sie eine Tabelle aus einer externen SQLDatenbank in das FileMaker Pro-Beziehungsdiagramm hinzufügen.
1
1
1
Ergänzungsfelder – Fügen Sie ungespeicherte Formel- und
Statistikfelder zu SQL-Datenquellentabellen (ODBC) innerhalb
von FileMaker Pro hinzu. Verwenden Sie dann diese Felder in
FileMaker Pro-Layouts, -Scripts, -Suchen, -Sortierungen, -Joins und Exporten, ohne Daten aus einer externen Tabelle zu ändern. Mit dieser
Funktion können Sie SQL-Tabellen erweitern. Zum Beispiel können
Sie Ergänzungsfelder verwenden, um aggregierte Daten aus einer
externen Datei anzeigen, wie Sie Statistikfelder verwenden würden,
um aggregierte Daten anzuzeigen, die in FileMaker Pro-Dateien
gespeichert sind.
E-Mail-Links zu gemeinsam genutzten Datenbanken – Wählen Sie
den neuen Menüeintrag Datei (Windows) bzw. Ablage (Mac OS) > Link
senden, um eine E-Mail mit URL-Links zu gemeinsam genutzten
FileMaker Pro-Datenbanken zu senden. Verwenden Sie diese
Funktion für gemeinsam genutzte Peer-to-Peer- oder von
FileMaker Server bereitgestellte Datenbanken.
Höhere Zahl von Peer-to-Peer-File-Sharing-Benutzern – Nutzen Sie
Dateien gemeinsam mit bis zu 9 Benutzern gleichzeitig über
FileMaker Pro-Netzwerk-Sharing.
30 | Neue Funktionen
Berichterstellung und Analyse
1 Bedingte Formatierung – Legen Sie Formatierungsregeln basierend
auf Bedingungen fest, die Sie mit dem neuen Menübefehl Format >
Bedingt angeben, und weisen Sie bedingte Formate Daten in Feldern,
Layouts oder textbasierten Schaltflächen zu. Zum Beispiel können Sie
überfällige Rechnungen rot anzeigen.
1
1
An PDF anhängen – Hängen Sie mit dieser neuen Scriptschritt-Option
neue Daten an eine bestehende PDF-Datei an. Fügen Sie zum Beispiel
sich ergänzende Daten einem als PDF-Datei gespeicherten Bericht
hinzu.
Aktualisierte Etikettenunterstützung – Verwenden Sie neue und
aktualisierte Avery-Etikettengrößen im Assistenten für neues
Layout einschließlich beliebter Versandetikettenformate.
Verbesserungen der Bedienerfreundlichkeit
1 Neues Fenster „FileMaker-Direktstart“ – Beginnen Sie, FileMaker Pro mit
diesem neuen Dialogfeld zu verwenden und kennen zu lernen. Das Fenster
„FileMaker-Direktstart“ bietet eine zentrale Stelle, an der Sie Dateien
erstellen, bestehende Dateien auf Ihrem Computer oder auf RemoteComputern im Netzwerk öffnen und auf die elektronische FileMaker ProDokumentation zugreifen können.
1
1
1
1
Online-Update-Benachrichtigung – Erhalten Sie Benachrichtigungen,
wenn Software-Updates über das Internet verfügbar sind. (Weitere
Informationen hierzu erhalten Sie in „Update-Benachrichtigung“ auf
Seite 6.)
Automatische Größenänderung von Layoutobjekten – Geben Sie an,
wie sich Layoutobjekte dynamisch entsprechend der Änderung der
Fenstergröße anpassen. Wenn Sie Fenster in der Größe ändern, ziehen
sich Daten auf einem Formular zusammen oder strecken sich im
Seitenansichtsmodus und im Ausdruck.
Verbessertes Registerfeld-Steuerelement – Verwenden Sie neue
Einstellungsfunktionen für Registerfelder, um das Standardregister
und die Registerbreite auf einem Formular einzustellen.
Verbesserter Web Viewer – Zeigen Sie Optionen für Status und
Meldungen im neuen Fortschrittsbalkenbereich an und stellen Sie
sie ein.
Neue Funktionen in FileMaker Pro 9 | 31
1
1
1
1
1
1
Infoschaltflächen – Über direkte Links gelangen Sie aus folgenden
Dialogfeldern direkt zu kontextsensitiven Hilfethemen, um weitere
Informationen zu ihnen zu erhalten: „Web Viewer-Einrichtung“,
„Tasteneinstellung“, „Formel angeben“ und „Assistent für neues
Layout“.
Verbessertes Hilfe-Menü – Greifen Sie auf die Produktdokumentation
zu, registrieren oder aktivieren Sie FileMaker Pro, übertragen Sie die
Aktivierung auf einen anderen Computer, senden Sie FileMaker Ihr
Feedback u. v. m. direkt aus dem Menü Hilfe.
Überarbeitetes Datei- bzw. Ablage-Menü – Der frühere Menübefehl
Datei (Windows) bzw. Ablage (Mac OS) > Definieren ist jetzt der
Menübefehl Datei (Windows) bzw. Ablage (Mac OS) > Verwalten.
Die Dialogfelder „Verwalten“ ersetzen die Dialogfelder „Definieren“.
Um zum Beispiel Felder einer Datenbank hinzuzufügen, verwenden
Sie das Dialogfeld „Datenbank verwalten“.
Verbessertes Rückgängig/Erneut – Mehrfaches Rückgängigmachen
im aktiven Feld oder Layouttextobjekt.
Verbesserte Rechtschreibprüfung – Steuern Sie die visuelle
Darstellung der Rechtschreibprüfung für einzelne Felder.
Verbesserte Werkzeugleiste – Verwenden Sie neue und
verbesserte Schaltflächen in der Werkzeugleiste wie „Ausrichten“
(Layoutmodus), „Datensätze als Excel speichern“ und „Datensätze
als PDF speichern“.
Scripts
1 Mehrere Scriptbearbeitungsfenster – Öffnen Sie mehrere
Scriptbearbeitungsfenster gleichzeitig.
1
1
Funktionen zur Scriptorganisation – Erstellen Sie Gruppen und Filter,
um eine große Anzahl von Scripts zu verwalten und nach Scripts zu
suchen.
Kopieren und Einfügen von Scripts – Sie können ganze Scripts und
Scriptschritte aus einer Datei kopieren und sie in der gleichen oder
einer anderen Datei einfügen.
32 | Neue Funktionen
Funktionen und Scriptschritte
1 Funktion „Hole(HostAnwendungVersion)“ – Gibt die Version von
FileMaker Pro oder FileMaker Server zurück, die auf dem Computer
läuft, der die aktuelle Datenbank bereitstellt.
1
1
1
1
1
Funktion „Hole(TemporärerPfad)“ – Gibt den Pfad zu dem
temporären Ordner zurück, den FileMaker Pro auf dem Computer
des aktuellen Benutzers verwendet.
Funktion „Selbst“ – Gibt den Inhalt des Objekts zurück, in dem die
Formel definiert ist.
Funktion „Arccos“ — Gibt den Arcuscosinus einer Zahl zurück.
Funktion „Arcsin“ — Gibt den Arcussinus einer Zahl zurück.
Scriptschritt „Rückgängig/Erneut“ – Kehrt die zuletzt in der Datei
ausgeführten Aktionen um bzw. stellt sie wieder her oder wechselt
zwischen ihnen.
Neue Funktionen in FileMaker Pro 9 Advanced
1 Erweiterter Script-Debugger – Debuggen Sie Scripts mit
beschränktem Zugriff bei der Anmeldung und Authentifizierung
aus dem Script-Debugger heraus, wählen Sie mehrere Scriptschritte,
zeigen Sie die letzten Scriptfehlerergebnisse an und verknüpfen Sie
mit dem Script-Debugger direkt mit der Hilfe für weitere
Informationen.
1
1
Erweiterte Datenanzeige – Verwenden Sie das neue Register Aktuell,
um Feld- oder Variablendaten im aktuellen Script anzuzeigen und
eingeschränkte Daten in der Datenanzeige bei Anmeldung und
Authentifizierung anzuzeigen.
PHP-Site-Assistent-Link – Wählen Sie Werkzeuge > PHP-Assistenten
starten, um direkt mit dem PHP-Site-Assistenten zu verknüpfen.
(PHP-Tools sind Teil des FileMaker Server-Produkts. Weitere
Informationen finden Sie in der FileMaker Server-Dokumentation.)
Neue Funktionen in FileMaker Pro 9 Advanced | 33
1
Verbesserter Datenbank-Design-Report – Dokumentieren Sie Ihre
Datenbanklösung einschließlich neuer Funktionen wie Scriptgruppen,
externer SQL-Datenquellentabellen, neuer Funktionen u. v. m.
(Weitere Information finden Sie in der FileMaker Pro Advanced DDR
XML Output Grammar, das unter www.filemaker.de/downloads
verfügbar ist.)
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement