MHS Überweisung 2

MHS Überweisung 2

MHS Überweisung 2

Benutzerhandbuch

Kompakt-Edition

Mathias Harbeck Software

Die Informationen im vorliegenden Buch werden ohne Rücksicht auf einen eventuellen Patentschutz veröffentlicht.

Warennamen, Handelsnamen, Gebrauchsnamen etc. werden ohne Gewährleistung der freien Verwendbarkeit benutzt.

Bei der Zusammenstellung der Texte, Abbildungen und Quellcodes wurde mit größter Sorgfalt vorgegangen. Trotzdem können Fehler nicht vollständig ausgeschlossen werden. Der Herausgeber/Autor kann für fehlerhafte Angaben und deren Folgen weder eine juristische Verantwortung noch irgendeine Haftung übernehmen.

Für Verbesserungsvorschläge und Hinweise auf Fehler ist der Autor sehr dankbar.

MHS Überweisung 2 - Benutzerhandbuch

Autor: Mathias Harbeck

1. Release, Oktober 2009

Dieses Werk ist urheberrechtlich geschützt.

Alle Rechte, auch die der Übersetzung, des Nachdrucks und der Vervielfältigung des Buches oder

Teilen daraus, vorbehalten. Kein Teil des Werkes darf ohne schriftliche Genehmigung des Autors in irgendeiner Form (Fotokopie, Mikrofilm oder einem anderen Verfahren), auch nicht für die

Zwecke der Unterrichtsgestaltung, reproduziert oder unter Verwendung elektronischer Systeme verarbeitet, vervielfältigt oder verbreitet werden.

Kontakt:

Mathias Harbeck

Küstersweg 22

21079 Hamburg [email protected]

(siehe auch Kapitel 4.1)

Inhaltsverzeichnis

Einleitung 5

Konventionen in diesem Buch 7

1 Installation/Deinstallation 9

1.1

Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

9

1.1.1

Der erste Start . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

13

1.2

Deinstallation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

16

1.2.1

Manuelle Deinstallation (bei Bedarf) . . . . . . . . . . . . . . . . .

17

2 Datensicherung 21

3 PlugIns 23

3.1

PlugIn-Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

23

3.2

PlugIn-Deinstallation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

24

3.3

PlugIn-Kurzvorstellungen . . . . . . . . . . . . . . . . . . . . . . . . . . .

25

3.3.1

Bedrucken des freien Bereichs . . . . . . . . . . . . . . . . . . . . .

25

3.3.2

Statistik-PlugIn . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

26

4 Kontakt, Updates und Support 27

4.1

Kontakt . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

27

4.2

Updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

27

4.3

Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

28

4.4

Bestellung/Vollversion . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

28

5 Glossar 29

4

Einleitung

Im März/April 1999 entstand das Programm MHS Überweisung – eine Ausfüllhilfe für

Überweisungsformulare im Format DIN A4, die ich in erster Linie geschrieben hatte, weil es mich ärgerte, dass ich für fast jedes im Handel erhältliche Formular ein eigenes Programm oder eine eigene Vorlage installieren und erlernen musste. MHS Überweisung sollte es ermöglichen, nahezu alle erhältlichen Standard-Überweisungsformulare zu bedrucken – egal, wo sich der Überweisungsträger oder der Beleg befanden.

Das Programm wurde seither konsequent weiterentwickelt. Seit Mitte 2009 steht es in einer neuen, vollständig überarbeiteten Fassung zur Verfügung, welche die Erfahrungen aus gut 10 Jahren, verschiedene Kundenwünsche sowie die gestiegenen Anforderungen bzgl. der

Formularunterstützung in sich vereint.

Diese Version 2 setzt – wie auch schon die vorherige Version – zur Information und Anleitung des Benutzers auf eine einfach bedienbare Oberfläche und passende Informationen in der mitgelieferten Hilfedatei. Dennoch zeigt die Erfahrung, dass für manche Themen eine etwas ausführlichere Beschreibung hilfreich sein kann; dieses Werk soll dies bewerkstelligen.

Das vorliegende Handbuch basiert auf der Version 2.0 beta 4 vom Oktober 2009 (lässt sich aber aufgrund der geringen funktionellen Unterschiede i.d.R. auf alle 2.0x Versionen anwenden).

Mathias Harbeck Oktober 2009

6

Konventionen in diesem Buch

Einige wenige Konventionen haben sich in diesem Buch festgesetzt, die zum besseren

Verständnis kurz erwähnt werden sollen:

Die Schaltfläche Jetzt drucken...

Kursiv gesetzte Texte markieren meist die Beschriftung von Menüs, Schaltflächen,

Optionen o.ä. im Programm.

Menü Extras→Eigenschaften

Pfeile werden zur Markierung von Aktionsfolgen verwendet, in der Regel innerhalb von Menüs. Im obigen Beispiel würden Sie also das Menü Extras öffnen und dort den

Menüpunkt Eigenschaften suchen.

Strg+N

Im Zusammenhang mit Tastenkombinationen oder Hotkeys wird häufig diese Notation verwendet, um zu zeigen, daß sowohl die Strg-Taste als auch die Taste N gleichzeitig gedrückt werden müssen.

Erklärungen zu einigen gängigen und weniger gängigen Begriffen, die im Text verwendet werden, finden Sie im Glossar ab Seite 29.

8

1 Installation/Deinstallation

Zur Installation von MHS Überweisung 2 benötigen Sie einen PC mit Windows XP oder

Vista (32/64bit). Auf der Festplatte benötigt das Programm ca. vier Megabyte an Platz, als Bildschirm-Auflösung wird mindestens 800x600 bei 16bit Farbtiefe erwartet. Besondere

Ansprüche an die Hardware hat das Programm nicht – sofern Sie bisher mit Ihrem Computer halbwegs flüssig arbeiten konnten, wird dort auch MHS Überweisung funktionieren.

Ein korrekt installierter (DIN A4-)Drucker ist allerdings zwingende Voraussetzung zum

Betrieb des Programms.

Sie erhalten das Programm im Internet auf der mhsoft-Website unter einer der folgenden

Adressen: http://www.mhsoft.de

http://www.harbeck-software.de

http://www.mathias-harbeck-software.de

Sie finden es jeweils im Bereich Shareware.

Außerdem finden Sie das Programm ggf. in einigen Shareware- und Freeware-

Verzeichnissen im Internet (und im Verzeichnis der Shareware Autoren VEreinigung; SaVE; www.s-a-ve.com). Auch kann es gelegentlich vorkommen, dass das Programm in Zeitschriften erwähnt wird bzw. auf Heft-CDs mitgeliefert wird.

1.1

Installation

Das Programm wird mit einem Installationsprogramm ausgeliefert.

Bitte denken Sie daran, dass grundsätzlich alle systemfremden Dateien (insbesondere ausführbare Dateien) Viren enthalten können. Selbstverständlich kommt auch auf Anbieterseite ein aktueller Virenscanner zum Einsatz, jedoch kann dies keinen hundertprozentigen

Schutz gewährleisten. Es wird daher dringend empfohlen, vor der Installation die Dateien mit einem Virenscanner zu prüfen.

Es wird im folgenden vorausgesetzt, daß Sie mit der grundlegenden Bedienung Ihres

Windows-Betriebssystems vertraut sind. Andernfalls wird dringend empfohlen, dies vor der Installation in Ihrem eigenen Interesse nachzuholen.

10 Installation/Deinstallation

Besorgen Sie sich zunächst die aktuelle Version des Programms und speichern Sie sie auf Ihrer Festplatte. In Version 2.0 lautete der Dateiname I-BANK200.EXE, dies kann jedoch je nach Quelle variieren (einige Shareware-Archive verwenden aus internen Gründen eigene Dateinamen). Rufen Sie die Datei auf (im Explorer mittels Doppelklick). Nach einer

Sicherheitsabfrage folgt der Einleitungsdialog des Installationsprogramms (siehe Abb. 1.1).

Abbildung 1.1: Startbildschirm des Installationsprogramms

Dieser informiert zunächst nur über die üblichen Installations-Hinweise. Klicken Sie auf den Button Weiter > und Sie gelangen zur nächsten Seite, auf der Ihnen die Readme-

Datei des Programms angezeigt wird. Lesen Sie sich diese bitte in Ruhe durch – dort sind neben allgemeinen Hinweisen zur Installation und Deinstallation auch noch ein paar weitere

Hinweise gesammelt.

Die Datei finden Sie später im Installations-Verzeichnis von MHS Überweisung (als

README.TXT). Sobald Sie die Inhalte zur Kenntnis genommen haben, klicken Sie bitte erneut auf Weiter >. Auf der nun folgenden Seite (Abb. 1.2) können Sie das Installations-

Verzeichnis von MHS Überweisung angeben, als Vorgabe dient C:\Programme\MHS Überweisung 2.

Als Installationsverzeichnis wird vom Installationsprogramm per Vorgabe C:\Programme\MHS Überweisung 2\ vorgeschlagen. C:\Programme ist auf vielen Systemen der

Standard-Ort für neue Software. Auf Ihrem System kann dies unter Umständen anders sein. In diesem Fall oder auch dann, wenn Sie selbst ein anderes Verzeichnis wünschen, geben Sie bitte den gewünschten Pfad an.

1.1 Installation

Abbildung 1.2: Auswahl des Installationsverzeichnisses

Falls Sie von Version 1 aktualisieren, dann beachten Sie bitte, daß Version 2 nicht in das gleiche Verzeichnis wie die alte Version installiert werden sollte. Bitte installieren Sie die Software in ein neues, leeres Verzeichnis. Die Daten der alten Version können/müssen bei Bedarf nach der Installation manuell direkt aus der neuen Version heraus importiert werden.

Wenn Sie Ihre Wahl getätigt haben, klicken Sie wieder auf Weiter >. Nun können Sie wählen, in welchem Ordner des Windows-Startmenüs das Programm seine Icons ablegen soll. Über das Optionsfeld unter der Liste können Sie auch angeben, daß Sie keinen Eintrag im Startmenü möchten (falls gewünscht).

Auf der nächsten Seite (Abb. 1.3) können Sie dann noch eine Verknüpfung zum Programm auf Ihrem Windows-Desktop anlegen lassen. Dies ermöglicht Ihnen dann später den direkten Zugriff auf das Programm vom Desktop aus. Empfehlenswert ist dies z.B. dann, wenn Sie planen, das Programm häufiger einzusetzen bzw. zu starten.

Die Folgeseite enthält eine kurze Aufstellung der erfassten Daten. Installationsziel,

Startmenü-Ordner und zusätzliche Optionen werden hier noch einmal präsentiert, damit

Sie abschließend die Korrektheit dieser Daten prüfen können. Durch einen Klick auf Installieren starten Sie dann die Installation.

Nun wird ein Balken eingeblendet, der Ihnen den Fortschritt der Installation anzeigt.

Sobald diese abgeschlossen ist, erscheint die in Abb. 1.4 dargestellte Seite.

Falls Sie MHS Überweisung gleich starten möchten, lassen Sie das angezeigte Optionsfeld

(MHS Überweisung jetzt starten) aktiviert. Klicken Sie auf Fertigstellen zum Beenden der

Installation.

Nun wurde MHS Überweisung erfolgreich auf Ihrem PC installiert. Zur Nutzung ist kein

Neustart notwendig, das Programm lässt sich sofort starten.

11

12 Installation/Deinstallation

Abbildung 1.3: Zusätzliche Aufgaben

Abbildung 1.4: Installation beendet

1.1 Installation

1.1.1

Der erste Start

Nachdem Sie das Programm erfolgreich installiert haben, ist es nun an der Zeit, es auch zu starten. Der erste Start konfrontiert Sie mit einigen zusätzlichen Gegebenheiten, auf die dieser Abschnitt etwas näher eingehen wird.

Zum Start des Programms rufen Sie einfach die Datei UEBERWEISUNG.EXE im Installationsverzeichnis von MHS Überweisung auf bzw. verwenden den entsprechenden Eintrag im Windows-Startmenü.

13

Abbildung 1.5: Erst-Konfiguration (programmbezogen)

Nach kurzer Zeit erscheint der Erst-Konfigurationsbildschirm für die programmbezogene

Konfiguration (siehe Abb. 1.5). Hier legen Sie für die komplette Programminstallation (also auch für ggf. vorhandene andere Benutzer) fest, wo das Programm zum einen seine Daten und zum anderen seine Konfiguration ablegt. Zur Wahl stehen jeweils:

• Installationsverzeichnis

Bei dieser Variante werden alle Dateien im Programmverzeichnis (üblicherweise

C:\Programme\MHS Überweisung 2\) abgelegt (das Verhalten entspricht damit jenem von Version 1 des Programms). Konfiguration bzw. Daten

1 werden hierbei aus einer Quelle geladen, d.h. alle Benutzer verwenden gleiche Daten bzw. Einstellungen.

• Windows-Benutzerverzeichnis

Bei dieser Variante werden alle Dateien im Profilverzeichnis des Benutzers (üblicherweise C:\Dokumente und Einstellungen\-angemeldeter Benutzer-

\Anwendungsdaten\mhsoft\MHS Überweisung\ bzw. dem entsprechenden Ordner auf Ihrem System) abgelegt. Konfiguration bzw. Daten

1 werden hierbei für jeden

Benutzer separat geladen, d.h. alle Benutzer verwenden eigene Daten bzw. Einstellungen.

1 soweit nicht ein anderes als das Vorgabe-Speichersystem verwendet wird, welches ggf. die Daten anderweitig (z.B. in einer Datenbank) speichert

14 Installation/Deinstallation

• Windows-Benutzerverzeichnis (alle)

Bei dieser Variante werden alle Dateien im Profilverzeichnis für „All Users“ (üblicherweise C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\mhsoft\MHS

Überweisung\ bzw. dem entsprechenden Ordner auf Ihrem System) abgelegt. Konfiguration bzw. Daten

1 werden hierbei aus einer Quelle geladen, d.h. alle Benutzer verwenden gleiche Daten bzw. Einstellungen.

Nach Abschluss dieser Einstellungen (und bei der Speicherung der Konfigurationsdaten im Windows-Benutzerverzeichnis außerdem jedes Mal, wenn ein Benutzer das Programm zum ersten Mal startet) können Sie danach noch benutzerspezifische Programmeinstellungen vornehmen. Sie können an dieser Stelle jedoch auch abbrechen, alle Einstellungen können später direkt im Programm ebenso vorgenommen werden (ggf. jedoch nicht so kompakt zusammengefasst).

Abbildung 1.6: Erst-Konfiguration (benutzerbezogen)

Zunächst kann hier konfiguriert werden, welche Formulare im Hauptfenster angezeigt werden sollen (siehe Abb. 1.6). Normalerweise arbeitet das Programm mit allen acht derzeit angebotenen Formulare, wenn Sie aber bestimmte Formulare normalerweise nicht verwenden, können Sie diese an dieser Stelle ausblenden. Natürlich ist dieser Vorgang später wieder änderbar; in den Programmeinstellungen auf der Seite „Formulare“ finden Sie die entsprechende Auswahlmöglichkeit. Hier ist obendrein auch die Möglichkeit vorhanden, die angezeigten Formulare umzusortieren.

Auf der nächsten Seite können Sie ein paar Einstellungen zum Ausdruck und zum

Eingabeverhalten vornehmen (siehe Abb. 1.7). Im oberen Bereich des Fensters können

Sie grob die Druckaufteilung festlegen – wählen Sie hier einfach die Aufteilung, die Ihren

Formularen am nächsten kommt. In den Programmeinstellungen können Sie später die einzelnen Felder noch detailliert feinjustieren.

1.1 Installation

Abbildung 1.7: Erst-Konfiguration (benutzerbezogen, Teil 2)

Der Dialog sieht derzeit nur Einstellungsmöglichkeiten für DIN A4-Formulare vor. Für alle anderen Formulargrößen belassen Sie am besten einfach die Vorgabe (links oben) wie gehabt und nehmen die Justierung später in den Programmeinstellungen vor.

Über „Das Formular enthält einen Beleg“ können Sie festlegen, ob eine Kopie der Eingaben oberhalb bzw. unterhalb des eigentlichen Formular gedruckt werden soll, weil sich dort ein entsprechender Beleg befindet, oder nicht.

Darunter – unter der Überschrift „Druckweise“ – haben Sie die Möglichkeit, festzulegen, ob beim Druck eingegebene Texte buchstabenweise auf die Kästchen der Formulare aufgeteilt werden sollen oder nicht.

Grundsätzlich erfolgt zur Vereinfachung die Angabe der genannten Daten für alle Formulare in einem Dialog, alternativ können Sie aber auch für jedes der acht Formulare die Einstellungen separat festlegen. Deaktivieren Sie in diesem Fall einfach die Checkbox

„Diese Einstellungen für die anderen Formulare übernehmen“ und sie haben nun auf 7 zusätzlichen (von den angezeigten Optionen her identischen) Seiten die Möglichkeit, die

Einstellungen für jedes Formular individuell vorzunehmen.

Als nächstes erscheinen auf der letzten Seite des Dialogs noch ein paar wichtige Hinweise, um deren Kenntnisnahme gebeten wird. Nach der Lektüre klicken Sie auf den Button Fertig.

Nun werden Ihnen die Lizenzbedingungen des Programms präsentiert – diese enthalten einige Hinweise zum Programm, die Sie unbedingt beachten sollten.

Nachdem Sie den Text durchgelesen haben, können Sie über die beiden Buttons darunter entscheiden, ob Sie das Programm starten möchten oder ob Sie mit den Bedingungen nicht

15

16 Installation/Deinstallation

Abbildung 1.8: Lizenzbedingungen einverstanden sind und das Programm nicht nutzen möchten.

Übrigens: den Dialog mit den Nutzungsbedingungen können Sie auch später wieder aufrufen - wählen Sie dazu im Hauptmenü des Programms Hilfe→Vollversion→Lizenz-

Informationen).

Haben Sie sich dafür entschieden, die Lizenzbedingungen anzunehmen, so erscheint jetzt das Hauptfenster des Programms.

1.2

Deinstallation

Das Deinstallationsprogramm finden Sie am gewohnten Ort in der Systemsteuerung

(Startmenü→Systemsteuerung→Software→Auswahlpunkt Programme ändern oder entfernen (i.d.R. schon aktiviert); vgl. Abb. 1.9.).

Abbildung 1.9: Windows XP Softwaredialog

Suchen Sie nun MHS Überweisung 2 in der Liste und rufen Sie die Deinstallationsroutine

1.2 Deinstallation auf. Nach dem Aufruf erscheint eine ausführliche Meldung, die Sie darüber aufklärt, wie die Deinstallation ablaufen wird.

Beachten Sie bitte, dass bei der Deinstallation im Idealfall alle Dateien gelöscht werden

– auch die ggf. von Ihnen angelegten Konten-Datenbanken, Verlaufsdatenbanken, Einstellungen etc. Falls Sie diese behalten möchten, sollten Sie diese, wie in Kapitel 2 (Datensicherung, S. 21) in diesem Buch beschrieben, vor der Deinstallation sichern.

Nach einem Klick auf den Button Ja wird die Deinstallation gestartet, was bei erfolgreicher Ausführung mit einer entsprechenden Meldung quittiert wird. Im Idealfall sollte jetzt nichts mehr von MHS Überweisung übrig sein.

17

Abbildung 1.10: Deinstallations-Hinweis

Sollten Sie das Programm so eingestellt haben, dass es Einstellungen und/oder Daten nicht im Installationsverzeichnis ablegt, so müssen Sie je nach gewähltem Ablageort entweder in

C:\Dokumente und Einstellungen\-angemeldeter Benutzer-\Anwendungsdaten\mhsoft\

MHS Überweisung\ oder in

C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\mhsoft\MHS Überweisung\ manuell die dort abgelegten Dateien löschen, da dies das Deinstallationsprogramm derzeit nicht beherrscht.

1.2.1

Manuelle Deinstallation (bei Bedarf )

Wenn Sie aus irgendeinem Grund auf das Installationsprogramm verzichten möchten/müssen, dann finden Sie in diesem Verzeichnis ein paar Informationen zum Vorgehen.

In der Regel genügt es zur Deinstallation des Programms, das Installationsverzeichnis und die darin enthaltenen Dateien zu löschen.

18 Installation/Deinstallation

Dies gilt natürlich nur, sofern Sie dort keine weiteren, nicht zum Programm gehörende Dateien abgelegt haben. Andernfalls sollten nur die nachfolgend genannten Dateien gelöscht werden. Ferner lagern dort natürlich auch Ihre eigenen Dateien (Konten-Datenbank, „Getätigte Ausdrucke“-Datenbank, Einstellungen etc.). Falls Sie diese behalten möchten, sollten

Sie diese, wie im Kapitel 2 (Datensicherung, S. 21) beschrieben, vor der Deinstallation sichern.

Das Programm besteht aus folgenden Dateien:

• UEBERWEISUNG.EXE

• UEBERWEISUNG.CHM

• UEBERWEISUNG.TIP

• UEBERWEISUNG.BLZBIC

• README.TXT

• FILE_ID.DIZ

• BLZ.DAT

• BLZ.TXT

• BIC.DAT

• BIC.TXT

• HISTORY.TXT

• BESTELLFORMULAR.PDF

• ABFRAGEN.DAT

• MHSDB.DLL

• STORAGE\FILESTORAGE.DLL

• STORAGE\FILESTORAGE.CHM

Des Weiteren werden zur Laufzeit u.U. noch die folgenden Dateien angelegt:

• ABFRAGEN.INI

• BACKUP.ZIP

• BIC.OLD

• BLZ.OLD

• DRUCKVORLAGE1.RTF *

• DRUCKVORLAGE2.RTF *

1.2 Deinstallation

• EINZAHLER.DAT * **

• EMPFAENGER.DAT * **

• HISTORY.DAT * **

• TEXTBAUSTEINE.DAT *

• LOG.TXT

• LOG.TXT.1

• UEBERWEISUNG.LD

• UEBERWEISUNG.DAT

• UEBERWEISUNG.INI *

• UEBERWEISUNG.CFG

Mit * markierte Einträge werden abhängig vom gewählten Speicherort für Benutzerbzw. Konfigurationsort ggf. nicht im Installationsverzeichnis abgelegt, sondern je nach Wahl entweder in

C:\Dokumente und Einstellungen\-angemeldeter Benutzer-\Anwendungsdaten\mhsoft\

MHS Überweisung\ oder in

C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\mhsoft\MHS Überweisung\

Zusätzlich mit ** markierte Einträge hängen vom zum Einsatz kommenden Speichersystem ab. Das standardmäßig mitgelieferte dateibasierte Speichersystem verwendet die hier aufgeführten Dateien. Beim Einsatz von anderen Speichersystemen können andere Dateien an anderen Orten relevant sein, konsultieren Sie in diesem Fall bitte die mitgelieferte

Dokumentation.

Das Programm selbst legt i.d.R. keine Daten in der Windows-Registrierung ab – nach dem Löschen der Dateien ist also bereits alles notwendige zur Deinstallation getan. Jedoch werden vom Installationsprogramm Einträge an den von Windows hierzu vorgesehenen

Orten vorgenommen, um Installation/Deinstallation des Programms zu ermöglichen.

19

20 Installation/Deinstallation

2 Datensicherung

Es wird dringend empfohlen, daß Sie Ihre Daten (Programm-Konfiguration, Konten-

Datenbanken, bisher gedruckte Überweisungen etc.) von Zeit zu Zeit (je nach Nutzungsintensität) sichern. Denn Fehler – ob nun im Programm, in den genutzten Windows-

Komponenten/-Funktionen oder ausgelöst durch externe Fehlerquellen – können leider nie hundertprozentig ausgeschlossen werden.

Folgende Dateien enthalten Ihre Daten:

• EMPFÄNGER.DAT

Konten-Datenbank Empfänger

1

• EINZAHLER.DAT

Konten-Datenbank Einzahler

1

• HISTORY.DAT

Datenbank “Getätigte Ausdrucke“

1

• UEBERWEISUNG.INI

Konfiguration des Programms (benutzerspezifisch)

• UEBERWEISUNG.CFG

Konfiguration des Programms (programmspezifisch)

• TEXTBAUSTEINE.DAT

Textbaustein-Datenbank

• DRUCKVORLAGE1.RTF

benutzerspezifische Druckvorlage

• DRUCKVORLAGE2.RTF

benutzerspezifische Druckvorlage

Je nach beim ersten Start von MHS Überweisung gewähltem Speicherort finden Sie die meisten dieser Dateien:

• im

Installationsverzeichnis von MHS Überweisung, üblicherweise C:\Programme\MHS Überweisung 2\

1 soweit nicht ein anderes als das Vorgabe-Speichersystem verwendet wird, welches ggf. die Daten anderweitig (z.B. in einer Datenbank) speichert

22 Datensicherung

• in

C:\Dokumente und Einstellungen\-angemeldeter Benutzer-\Anwendungsdaten\mhsoft\MHS Überweisung\ (bzw. dem entsprechenden Ordner auf Ihrem

System)

• C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\mhsoft\MHS

Überweisung\ (bzw. dem entsprechenden Ordner auf Ihrem System)

Sofern Sie Änderungen an der Bankleitzahlendatenbank vorgenommen haben, sollten

Sie auch die Datei BLZ.DAT im Installationsverzeichnis sichern (für die BIC-Datenbank gilt ähnliches, hier heißt die Datei BIC.DAT).

3 PlugIns

MHS Überweisung unterstützt PlugIns – das sind als Windows-DLLs ausgelieferte Erweiterungen für das Hauptprogramm, die zusätzliche Funktionen einbringen sollen. In diesem

Abschnitt erfahren Sie näheres zu Installation und Deinstallation. Außerdem finden Sie in

Abschnitt 3.3 eine kurze Vorstellung der verfügbaren PlugIns.

3.1

PlugIn-Installation

Die Installation eines PlugIns ist im Prinzip relativ einfach. Es gibt zwei verschiedene

Installationswege, die im nachfolgenden erläutert werden.

Laden Sie sich zuvor die aktuelle Version des PlugIns herunter. Wichtig dabei ist, daß das PlugIn für MHS Überweisung geeignet sein muß

1 und das Ihre Version von MHS

Überweisung mit der beim PlugIn angegebenen Mindestanforderung übereinstimmt.

Installationsvariante 1 In allen bisherigen Programmversionen kann das PlugIn in der Form pluginXX.dll daherkommen (wobei das XX für eine zweistellige Zahl zwischen

00 und 99 steht) und im Programmverzeichnis abgelegt werden. Zugehörige Dateien verwenden die gleiche Grund-Benennung, jedoch natürlich mit abweichender Datei-Endung

(z.B. pluginXX.ini für die Konfigurationsdatei).

Installationsvariante 2 Alternativ kann das PlugIn unter beliebigem Namen (lediglich die Endung muss .dll sein) im Unterverzeichnis „plugins“ des Programmverzeichnisses abgelegt werden. Für zugehörige Dateien gilt die gleiche Regelung wie beim vorherigen

Verfahren.

Für beide Varianten gilt: Sollte eine Datei mit dem Dateinamen des PlugIns, dass Sie gerade installieren wollen, bereits existieren, so müssen Sie den Dateinamen eines der beiden

PlugIns lediglich ändern

2

. Beachten Sie bei Installationsvariante 1 bzgl. des neuen Namens bitte die oben genannten Konventionen.

MHS Überweisung erkennt beim nächsten Start das neue PlugIn und lädt es. Beachten

Sie bitte die jeweilige Anleitung zum PlugIn, hier wird in der Regel erklärt, wie das PlugIn konfiguriert und benutzt werden sollte.

1

Es gibt ein paar PlugIns, die nur für spezielle Anwendungen geschrieben wurden – so ist z.B. die

Business-Paket-Erweiterung explizit nur mit MHS Post-Formular lauffähig.

2

Entpacken Sie das PlugIn dazu zunächst in einen temporären Ordner, ändern dort den Namen sowie die Namen der zugehörigen Dateien und kopieren das PlugIn dann in den Zielordner.

24 PlugIns

Mehrfach-Installation

Theoretisch ist es problemlos möglich, ein und dasselbe PlugIn mehrfach zu installieren – erstellen Sie dazu einfach eine Kopie der zum PlugIn gehörenden Dateien (alle mit gleicher PlugIn-Nummer bzw. gleichem Namensanfang) und passen Sie die PlugIn-

Nummer (bzw. den Dateinamen) so an, daß der Dateiname mit keinem bestehenden

PlugIn mehr kollidiert.

3.2

PlugIn-Deinstallation

Zur Deinstallation ist es hilfreich, den Dateinamen zu wissen. Dieser kann (bei nur einem installierten PlugIn) trivial sein, er kann Ihnen auch so direkt bekannt sein oder Sie finden ihn wie folgt heraus:

Starten Sie das Programm. Wählen Sie im Menü PlugIns die Option Installierte Plug-

Ins... (siehe Abb. 3.1).

Abbildung 3.1: Das PlugIns-Menü

Es erscheint nun das Fenster aus Abb. 3.2.

Abbildung 3.2: PlugIns-Übersicht mit Installationspfad für das zweite PlugIn

Hier sind alle installierten PlugIns gelistet. In der ersten Spalte finden Sie den Namen des PlugIns, dahinter die Version, dann den Dateinamen, dann eine unverbindliche Empfehlung, mit welchem Programm das PlugIn genutzt werden sollte und abschließend die

Lizenz, mit der Sie das PlugIn nutzen. Und über den letzten Button können Sie sich den

About-Dialog des PlugIns anzeigen lassen. Sollte ein Text mal nicht ganz in das Fenster passen, halten Sie den Mauszeiger einen Augenblick auf das Feld. Es wird Ihnen dann der gesamte Text in einem kleinen Tooltip-Fenster angezeigt (siehe Demonstration in Abb.

3.2).

3.3 PlugIn-Kurzvorstellungen

Relevant für unseren Zweck ist nun Spalte 3 (Dateiname). Dort können Sie ablesen, welches PlugIn sich in welcher Datei versteckt. In unserem Fall ist das PlugIn zum Bedrucken der Vorgabequittung unter C:\Programme\MHS Überweisung\plugin02.dll gespeichert.

Per Vorgabe sollten alle PlugIns ihre Daten in Dateien ablegen, deren Namen mit dem

Dateinamen (ohne Endung) des PlugIns übereinstimmen oder mit diesem beginnen (also die Konfigurationsdatei für obiges Beispiel z.B. in plugin02.ini). Entsprechend sieht auch der Verzeichnis-Auszug aus:

25

Abbildung 3.3: Verzeichnisansicht mit den PlugIn-Dateien (markiert)

Sobald Sie den PlugIn-Dateinamen ermittelt haben, können Sie, wie eben schon angedeutet, alle zum PlugIn gehörenden Dateien identifizieren und löschen (dies ist in der Regel nur dann vollständig möglich, wenn Sie MHS Überweisung zuvor beenden!). Im hier gezeigten Beispiel (Abb. 3.3) müßte man also z.B. die vier markierten Dateien löschen (eben alle, die mit plugin02 beginnen).

3.3

PlugIn-Kurzvorstellungen

Sämtliche der im folgenden vorgestellten PlugIns finden Sie im Internet unter folgender

Adresse: http://www.mhsoft.de

3.3.1

Bedrucken des freien Bereichs

Auf vielen Formularen, speziell den Vordrucken für Überweisungen, sind leere, nicht bedruckte Bereiche vorhanden. Gerade bei Überweisungsvordrucken ist es in einigen Fällen sinnvoll, diesen Bereich z.B. für Hinweise oder Ergänzungen zu nutzen. Dieses PlugIn hilft

Ihnen dabei.

26 PlugIns

Ihre Texte können Sie bequem über RTF-Dateien (RichText-Format) einbauen – entweder im eingebauten Editor (mit beinahe WYSIWYG-Darstellung und Verfügbarkeit der wichtigsten Funktionen) oder in Ihrem bevorzugten Editor/Ihrer bevorzugten Textverarbeitung.

Über spezielle Schlüsselwörter können Sie die Einträge des Hauptfensters automatisch einfügen lassen - somit ist eine Serienbrief-artige Funktion möglich.

Der Druckbereich läßt sich auf dem Ausdruck relativ genau positionieren – und den Text samt Ersetzungen können Sie sich auf Wunsch vor dem Ausdruck nochmals (für spezielle

Änderungen oder zur Kontrolle) anzeigen. Auf Wunsch läßt sich das PlugIn auch temporär abschalten.

Sie können das PlugIn auch für mehrere Zwecke verwenden – dazu gibt es einen Datei-

öffnen-Dialog, mit dem Sie jederzeit eine andere Datei laden können. Als zusätzliche Hilfestellung sind die Originaldatei (pluginXX.rtf) sowie die zehn zuletzt verwendeten Dateien per Kontextmenü abrufbar.

3.3.2

Statistik-PlugIn

In der Vergangenheit gab es von Benutzern des Hauptprogramms MHS Überweisung 1 öfter den Wunsch, die Verlaufsdatenbank des Programms stärker nutzen zu können. Ein hervorstechender Wunsch betraf die Möglichkeit, die enthaltenen Daten auswerten zu können.

Dieses PlugIn stellt diese Funktionalität – auch für Version 2 – bereit.

Das PlugIn ermöglicht zunächst eine Grundanalyse der gespeicherten Daten – wieviel

Überweisungen wurden gespeichert, welche Summe an Beträgen wurde dabei (insgesamt, in diesem Monat, in dieser Woche) übermittelt etc. Weiterführend besteht dann die Möglichkeit, sich die Überweisungen summiert nach Empfängern oder Einzahlern ausgeben zu lassen – auf Wunsch auch eingeschränkt auf einen bestimmten Zeitbereich.

4 Kontakt, Updates und Support

Von Zeit zu Zeit kann es vorkommen, dass Sie weitere Informationen benötigen, Fragen haben oder Updates suchen. In den nachfolgenden Kapiteln finden Sie entsprechende Informationen.

4.1

Kontakt

Sie erreichen den Autor per Post unter folgender Adresse: mhsoft

Mathias Harbeck Software

Küstersweg 22

21079 Hamburg

Deutschland

Per Fax:

Homepage:

E-Mail:

++49 40 / 764 11 104 http://www.mhsoft.de oder http://www.harbeck-software.de oder http://www.mathias-harbeck-software.de

MHS Überweisung finden Sie im Bereich Shareware der Homepage.

[email protected] oder [email protected] oder [email protected]

Wichtig: Beratung und Support per Telefon wird nicht angeboten!

4.2

Updates

Auf der mhsoft-Homepage finden Sie Informationen zu sämtlichen bisherigen Updates und natürlich die Möglichkeit, das neueste Update herunterzuladen. Für eine schnelle Prüfung,

28 Kontakt, Updates und Support ob Ihre Version des Programms noch aktuell ist, können Sie die Funktion Nach Programm-

Updates suchen im Menü Hilfe→Im Internet verwenden.

4.3

Support

Ebenfalls auf der Homepage finden Sie Listen mit häufigen Fragen und Antworten sowie Übersichten über bisherige Updates. Die zuvor genannten Seiten sind auch über die

Funktion Support im Menü Hilfe→Im Internet des Programms erreichbar.

4.4

Bestellung/Vollversion

Die Shareware-Version von MHS Überweisung soll es Ihnen ermöglichen, die Software vor dem Kauf ausgiebig zu testen. Sofern Ihnen das Programm gefällt und Sie es weiter einsetzen wollen, müssen Sie spätestens nach Ablauf der 30 Tage des Testzeitraums die Vollversion bestellen. Bis dahin erinnert Sie ein Countdown am Ende des Programms (und ggf.

beim Start) daran. Ansonsten ist keine Einschränkung der Shareware-Version gegenüber der Vollversion vorhanden, es wird daher dringend empfohlen, die Testmöglichkeit vor dem

Kauf auszunutzen!

Wenn Sie das Programm bestellen möchten, bietet Ihnen das Programm folgende Möglichkeiten:

• Bestell-Assistent

Im Programm ist ein Bestell-Assistent integriert, der Sie ganz einfach durch den Bestellprozess führt und am Ende ein fertig ausgefülltes Bestellformular auf dem Drucker ausgibt, welches Sie dann per Post oder Fax absenden können. Wählen Sie dazu im

Menü Hilfe→Vollversion den Menüpunkt Bestell-Assistent aus oder klicken Sie im

Shareware-Countdown auf die Schaltfläche Bestell-Assistent. Der Bestell-Assistent besitzt verschiedene Vorzüge (u.a. Format-Unabhängigkeit, Unterscheidung Liefer-

/Rechnungsadresse sowie die Bestellmöglichkeit von Mehrplatz-Lizenzen), sodass dessen Verwendung (oder alternativ die Online-Bestellung, siehe unten) empfohlen wird.

• PDF-Bestellformular

Bei Problemen mit dem Bestell-Assistent können Sie aber natürlich auch das beiliegende Bestellformular verwenden. Dieses liegt als Bestellformular.pdf (lesbar mit den meisten PDF-Readern und mit einem neueren Adobe Acrobat Reader auch am PC ausfüllbar) im Installationsverzeichnis des Programms (normalerweise C:\Programme\MHS Überweisung 2\) bereit.

• Online-Bestellung

Sie können das Programm natürlich auch online bestellen: Unter der Adresse http://www.mhsoft.de/go.php?bestellen (bzw. einer der in Kapitel 4.1 genannten

Adressen) finden Sie die Bestellmöglichkeit für die mhsoft-Shareware-Programme.

Die Online-Bestellung ist auch direkt vom Programm aus zugänglich, wählen Sie hierzu im Menü Hilfe→Im Internet die Funktion Online-Bestellung.

5 Glossar

In diesem Buch verwende ich einige Begriffe, die vielleicht dem einen oder anderen nicht geläufig sind. Um nicht bei jeder Erwähnung den Begriff neu definieren zu müssen, habe ich diese hier zusammengefasst:

Auswahlfeld

Auswahlfelder (engl. Radiobuttons) werden in der Regel gruppiert eingesetzt und ermöglichen die Auswahl genau einer Option.

nicht gewählte Option gewählte Option (“aktiviert“)

Browser

→ Web-Browser

Button

→ Schaltfläche

Buttonleiste

Auch Toolbar; Bezeichnung für eine Zeile aus graphischen → Schaltflächen, die als eine

Art Menü-Ersatz den schnellen Zugriff auf Kommandos per Mauszeiger erlauben.

Checkbox

→ Optionsfeld

Hotkey

Gängige Bezeichnung für eine Taste oder Tastenkombination, die eine bestimmte Aktion in einem Anwendungsprogramm auslöst. Z.B. ist es unter Windows üblich, mit der Taste

(dem Hotkey) F1 die Kontexthilfe eines Programms oder von Windows selbst zu öffnen

(der Hotkey spart also den Umweg über irgendwelche Menüs). Häufig bestehen Hotkeys aus Tastenkombinationen; so erzeugt die Kombination Strg-Taste und N-Taste (gleichzeitig gedrückt; oft notiert als Strg+N) in vielen Programmen ein neues Dokument.

InnoSetup

Seit Version 1.5 setze ich dieses Installationsprogramm für MHS Überweisung ein. Das frei erhältliche Programm bietet sowohl eine moderne Oberfläche als auch umfangreiche

Konfigurationsmöglichkeiten. Weiterführender Link: http://www.innosetup.org

Internet-Browser

→ Web-Browser

Kontextmenü

Als Kontextmenü bezeichnet man das Menü, das Windows anzeigt, wenn Sie auf ein Element mit der rechten Maustaste klicken. Es läßt sich in der Regel außerdem mit der auf

Windows-Tastaturen vorhandenen Kontextmenü-Taste (rechts von der rechten Windows-

30 Glossar

Taste) aufrufen. Im Kontextmenü werden meist Befehle angezeigt, die direkt auf dem jeweiligen Element ausführbar sind (die also im Kontext Sinn ergeben).

Optionsfeld

Ein Optionsfeld (engl. Checkbox) ist ein Eingabefeld in Kästchenform, mit dem Sie eine bestimmte Option ein- oder ausschalten können.

eingeschaltete Option (“aktiviert“) ausgeschaltete Option

Radiobutton

→ Auswahlfeld

Registerseite

Viele (Konfigurations-)Dialoge verwenden zur Strukturierung das bekannte Registerreiter-

Design, bei dem Inhalte auf mehreren Seiten verwaltet werden, die über sogenannte Registerreiter aufgerufen werden können. Die nachfolgende Abbildung zeigt zur Verdeutlichung einen Ausschnitt:

Registrierung

→ Windows-Registrierung

Registry

→ Windows-Registrierung

Schaltfläche

Die Schaltfläche (engl. Button) ermöglicht es, durch einfaches Anklicken eine bestimmte

Aktion auszuführen. Schaltflächen werden häufig in Dialogen, z.B. zum Schließen des Dialogs oder zum Speichern der Einstellungen, verwendet. Die nachfolgende Abbildung zeigt eine Schaltfläche:

Update

Unter einem Update verstehe ich normalerweise eine Aktualisierung der Software innerhalb einer Hauptversionsnummer (bei einer Versionsnummer x.y wäre x die Hauptversionsnummer und y die Nebenversionsnummer; Beispiel also Update von 1.1 auf 1.2). Nebenbei: Der

Begriff Patch wird hier oftmals Synonym verwandt (obwohl es allgemein als eher kleinere

Fehlerbehebung begriffen wird; im Prinzip besteht ein Update aus verschiedenen Patches).

Upgrade

Ein Upgrade stellt eine Aktualisierung der Software dar, bei der die Hauptversionsnummer

(→ Update) verändert wird (also z.B. 1.5 auf 2.0).

Web-Browser

Ein Web-Browser ist ein Programm, das den Zugriff und die Darstellung von Seiten des

World Wide Webs ermöglicht. Einige bekannte Internet-Browser sind z.B. der Microsoft

Internet Explorer, Netscapes Navigator/Communicator, Opera und Mozilla.

Windows-Registrierung

Seit Windows 95 verwendet Microsoft zur Speicherung der meisten betriebssystem- und programmspezifischen Daten einen zentralen Ort, die Windows-Registrierung. Hierein sollen alle Programme ihre Einstellungen speichern, Dateiverknüpfungen vornehmen und Informationen zur Deinstallation speichern.

MHS Überweisung kommt weitestgehend ohne Einträge in der Windows-Registrierung aus und lässt sich dadurch nahezu beliebig verschieben und bei Bedarf auch auf einen anderen Computer verschieben. Lediglich das Installationsprogramm legt zur Deinstallation

Informationen in der Windows-Registrierung ab.

ZIP, ZIP-Archiv

ZIP ist ein verbreitetes Datenkompressionsformat, bei dem Dateien in einem Archiv zusammengefasst und dabei zusätzlich in der Größe verringert werden. Unter Windows gibt es etliche Programme, um diese Dateien zu entpacken (z.B. WinZip (www.winzip.de)),

Windows XP enthält zudem eine integrierte ZIP-Funktion.

31

Index

→, 7

Analyse, 26

Backup, 21

Begriffserklärung, 29

Benutzerverzeichnis, 13

Benutzerverzeichnis (alle), 14

Bestellung, 28

BIC.DAT, 22

BLZ.DAT, 22

Datensicherung, 21

Deinstallation, 16

Manuelle, 17

Der erste Start, 13

DRUCKVORLAGE1.RTF, 21

DRUCKVORLAGE2.RTF, 21

EINZAHLER.DAT, 21

EMPFÄNGER.DAT, 21

Erst-Konfiguration, 13

Glossar, 29

HISTORY.DAT, 21

Installation, 9

Installationsverzeichnis, 13

Kontakt, 27

Konventionen, 7

Lizenzbedingungen, 13

Mehrfach-Installation, 24

PlugIns, 23

Bedrucken des freien Bereichs, 25

Deinstallation, 24

Installation, 23

Statistik-PlugIn, 26

Shareware, 28

Statistik, 26

Support, 28

TEXTBAUSTEINE.DAT, 21

Typographische Konventionen, 7

UEBERWEISUNG.CFG, 21

UEBERWEISUNG.INI, 21

Updates, 27

Vollversion, 28

Windows-Benutzerverzeichnis, 13

Windows-Benutzerverzeichnis (alle), 14

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement