Installieren von Scia Engineer

Installieren von Scia Engineer
Handbuch
Installationshandbuch
Scia Engineer
Die in diesem Dokument enthaltenen Informationen können jederzeit ohne
vorherige Ankündigung geändert werden. Dieses Dokument darf im Ganzen
oder auszugsweise nur mit vorheriger, schriftlicher Genehmigung des
Herausgebers vervielfältigt, veröffentlicht oder in einem Datenbank- bzw.
Retrieval-System gespeichert werden, sei es elektronisch oder durch
mechanisches Fotokopieren. Scia ist nicht für direkte oder Folgeschäden
verantwortlich, die sich aus Ungenauigkeiten der Dokumentation und/oder
Software ergeben.
© Copyright 2011 Nemetschek Scia nv. Alle Rechte vorbehalten.
Scia Engineer
Release:
Handbuch:
Revision:
Scia Engineer 2011
Installationsleitfaden
06/2011
Nemetschek-Scia-Niederlassungen
Zentrale Belgien
Tschechische Republik
Slowakei
Nemetschek Scia nv
Industrieweg 1007
B-3540 Herk-de-Stad
Telefon: +32 13 55 17 75
Fax: +32 13 55 41 75
E-Mail: [email protected]
Scia CZ, s.r.o.
Slavickova 1a
638 00 Brno
Telefon: +420 545 193 526
Fax: +420 545 193 533
[email protected]
Scia SK, s.r.o.
Topol’ová 8
SK - 010 03 Žilina
Telefon: +421 415 003 070-1
Fax: +421 415 003 072
[email protected]
Kundendiensttelefon
CAE (Scia Engineer)
Tel.: +32 13 35 03 10
Kundendienst-E-Mail:
[email protected]
Scia CZ, s.r.o.
Thákurova 3
160 00 Prag 6
Telefon: +420 224 322 425
Fax: +420 224 322 288
[email protected]
Spanien
CAD (Allplan)
Tel.: +32 13 35 03 15
CIM (SCIA•Steel)
Tel.: +32 13 35 03 20
think project!
Tel.: +32 13 35 03 15
Österreich
Scia Datenservice Ges.m.b.H
Dresdnerstrasse 68/2/6/9
A-1200 Wien
Telefon: +43 1 7433232-11
Fax: +43 1 7433232-20
[email protected]
Support
Tel.: +43 1 7433232-12
E-Mail: [email protected]
Brasilien
Scia Group Branch Office
Rua Funchal, 418 - 35º andare
Vila Olímpia - E-Tower
São Paulo, SP 04551-060,
Brasilien
Telefon: +55 11 3521-7232
Fax: +55 11 3521-7070
[email protected]
MP Scia INGENIERIA sl
C/La Fuente 25 A
ES-28710 El Molar (Madrid)
Telefon: +34 627559030
[email protected]
Finland
Nemetschek Scia Finland
Halsuantie 4
00420 Helsinki
Tel.: +358 207 - 698 678
Fax: +358 207 - 698 699
[email protected]
Schweiz
Scia Group Branch Office
Dürenbergstr. 24
CH-3212 Gurmels
Telefon: +41 26 341 74 11
Fax: +41 26 341 74 13
[email protected]
Frankreich
Scia France SARL
Centre d’affaires Objectif
2, rue Louis Armand
F-92661 Asnières Cedex
Telefon: +33 1.46.13.47.00
Fax: +33 3.28.33.28.69
[email protected]
Deutschland
Scia Software GmbH
Emil-Figge-Straße 76-80
D-44227 Dortmund
Telefon: +49 231/9742586
Fax: +49 231/9742587
[email protected]
Niederlande
Nemetschek Scia bv
Kroonpark 10
NL- 6831 GV Arnhem
Telefon: +31 26 320 12 30
Fax: +31 26 320 12 39
[email protected]
VAE
Nemetschek Scia ME
Dubai Silicon Oasis HQ Building
P.O. Box 341041, Dubai, VAE
Telefon: +971 4 5015744
Fax: +971 4 5015777
[email protected]
USA
Nemetschek Scia
7150 Riverwood Drive
Columbia, MD (USA)
Telefon: +1 410-290-5114
Fax: +1 410-290-8050
[email protected]
Scia Engineer
Inhaltsverzeichnis
Inhaltsverzeichnis .......................................................................................... 4
1.
Einführung ............................................................................................... 1
1.1
Willkommen.................................................................................... 1
1.2
Systemanforderungen ................................................................... 1
1.2.1 Hardware............................................................................... 1
1.2.2 Software ................................................................................ 2
2.
Das richtige Kapitel für Ihre Installationsvariante ................................ 3
3.
Lokale Installation, lokaler Schutz ........................................................ 4
4.
3.1
Installieren des Sentinel-Dongles ................................................ 4
3.1.1 Installieren der Sentinel-Treiber ............................................ 4
3.1.2 Anbringen des Sentinel-Dongles ........................................... 4
3.1.3 Prüfen des Sentinel-Dongles................................................. 4
3.2
Installieren von Scia Engineer ...................................................... 6
3.3
Aufrufen von Scia Engineer ........................................................ 14
3.3.1 Scia Engineer wird gestartet. .............................................. 14
3.3.2 Scia Engineer startet nicht sofort ........................................ 14
3.3.3 Kontrolle der Version ........................................................... 16
3.4
Erweitern der Dongle-Lizenz....................................................... 17
3.5
Gebrauch mehrerer Dongle ........................................................ 18
Lokale Installation, Netzwerkschutz .................................................... 19
4.1
Aktualisierung eines bestehenden FlexNet Netzwerk-Schutzes20
4.2
Installieren des neuen FlexNET-Netzwerkschutzes.................. 21
4.2.1 Installieren des FlexID-Netzdongles auf dem Server .......... 22
4.2.2 Installieren des FlexNET-Netzwerkschutzes ....................... 22
4.2.3 Aktivierung der Lizenzdatei ................................................. 22
4.2.4 Konfigurieren des FlexNET-Servers .................................... 25
4.2.5 Konfiguration des FlexNet-Servers für alle Versionen......... 27
4.2.6 Server setup ........................................................................ 28
4.2.7 Deaktivieren der Lizenzdatei ............................................... 28
4.3
Installieren von Scia Engineer auf den Arbeitsplatzrechnern . 29
Scia Engineer
4.4
5.
6.
Aufrufen von Scia Engineer ........................................................ 37
4.4.1 Scia Engineer wird gestartet. .............................................. 37
4.4.2 Scia Engineer startet nicht sofort ........................................ 37
4.4.3 Aktualisierungen aussuchen ................................................. 40
Serverinstallation .................................................................................. 41
5.1
Aktualisierung eines bestehenden FlexNet Netzwerk-Schutzes42
5.2
Installieren des neuen FlexNET-Netzwerkschutzes.................. 43
5.2.1 Installieren des FlexID-Netzdongles auf dem Server .......... 43
5.2.2 Installieren des FlexNET-Netzwerkschutzes ....................... 44
5.2.3 Aktivieren der Lizenzdatei ................................................... 44
5.2.4 Konfigurieren des FlexNET-Servers .................................... 46
5.2.5 Konfiguration des FlexNet-Servers für alle Versionen......... 48
5.2.6 Server setup ........................................................................ 49
5.2.7 Deaktivieren der Lizenzdatei ............................................... 50
5.3
Neue Netzinstallation von Scia Engineer .................................. 50
5.4
Stille Installation .......................................................................... 51
5.5
Lokale Ordner .............................................................................. 51
Deinstallieren von Scia Engineer ........................................................ 52
6.1
Deinstallation mit Windows-Systemsteuerung ......................... 52
6.2
Deinstallation ohne Windows-Systemsteuerung ...................... 54
6.1 Deinstallation mit Windows-Systemsteuerung
6.2 Deinstallation ohne Windows-Systemsteuerung
Scia Engineer
1. Einführung
1.1 Willkommen
Willkommen in der Installationsanleitung zu Scia Engineer. Scia Engineer
ist ein unter Windows XP, Windows Vista und Windows 7 laufendes
Berechnungsprogramm mit einem großen Anwendungsgebiet: von
Nachweisen für einfache Rahmen bis zur fortgeschrittenen Planung und
Bemessung komplexer Projekte mit Stahl, Beton, Holz usw.
Das Programm ermöglicht das Berechnen von 2D- und 3D-Rahmen
einschließlich der Profilnachweise und Verbindungsprüfungen von
Stahlkonstruktionen. Außer Rahmen werden auch Plattenstrukturen und
erweiterte Betonberechnungen unterstützt.
Dieses Handbuch leitet Sie durch das Installieren der Anwendung.
Lesen Sie zuerst das zweite Kapitel. Darin erfahren Sie, in welchem Kapitel
die Anleitungen für die unterschiedlichen Installationsvarianten von Scia
Engineer zu finden sind.
Die Installationsvarianten werden in den Kapitel 3, 4 und 5 erläutert.
Abschließend wird in Kapitel 6 auch die Deinstallation besprochen.
1.2 Systemanforderungen
Zum Installieren von Scia Engineer muss Ihr System folgende Anforderungen
erfüllen:
1.2.1 Hardware
Prozessor
RAM
Grafikkarte
Freier Speicherplatz auf
Festplatte für die Installation
Minimale Auflösung
Pentium IV, 3 GHz
(empfohlen: CoreDuo2 ab 3 GHz)
2 GB (empfohlen: > 4 GB)
256 MB, OpenGL-fähig
5 GB
1280 x 800
1
Scia Engineer
1.2.2 Software
Einzelplatz-Installation
Windows 2003 Server
windows XP 32/64 Bit
Vista 32/64 Bit
Windows 7 32/64 Bit
FlexNET
(Netzwerkschutz)
Sie sollten das letzte Service Pack
für das Betriebssystem installieren. SP3 für
Windows XP
Sie sollten das letzte Service Pack
für das Betriebssystem installieren. SP3 für
Windows XP
Windows XP 32 bit
Windows Vista 32/64 bit
Windows 2008 server 64 bit
Windows 7 – 32/64 bit
Allplan
Scia Engineer 2011.0 ist zu folgenden
Versionen kompatibel: Allplan_v2011
Allplan_v2010
Allplan_v2009
Sie müssen Allplan vor Scia Engineer
installieren, da ansonsten die korrekte
Installation des Allplan-Patches nicht immer
möglich ist.
Revit
Scia Engineer 2011.0 ist zu folgenden
Versionen kompatibel:
Revit 2008
Revit 2009
Die Revit-Schnittstelle ist online verfügbar:
www.scia-online.com/revit
Etabs
Scia Engineer 2011.0 ist mit folgender Version
kompatibel:
Etabs 9.2
IFC
Scia Engineer 2011.0 ist mit folgender Version
kompatibel:
IFC version 2x3
SDNF
Scia Engineer 2011.0 ist mit folgenden
Versionen kompatibel: Version 2.0 and Version
3.0
Tekla
Scia Engineer 2011.0 ist mit folgenden
Versionen kompatibel:
Tekla version 15,16 and 17-32bit
2
Scia Engineer
2. Das richtige Kapitel für Ihre
Installationsvariante
Dieses Handbuch beschreibt drei verschiedene Installationsvarianten für Scia
Engineer:
•
LOKALE INSTALLATION, LOKALER SCHUTZ (Kapitel 3)
Scia Engineer wird auf dem Arbeitsplatzrechner installiert. Der
Schutz wird ebenfalls auf dem Arbeitsplatzrechner installiert.
•
LOKALE INSTALLATION, NETZWERKSCHUTZ (Kapitel 4)
Scia Engineer wird auf den Arbeitsplatzrechnern installiert, der
Schutz wird auf einem Netzwerkserver installiert.
•
SERVER-CLIENT-INSTALLATION (Kapitel 5)
Scia Engineer wird zusammen mit dem Schutz auf einem
Netzwerkserver installiert.
3
Scia Engineer
3. Lokale Installation, lokaler Schutz
3.1 Installieren des Sentinel-Dongles
Wenn Sie einen Hardwareschutz gewählt haben, müssen Sie folgende
Schritte durchführen:
-
Installieren der Sentinel-Treiber
-
Anbringen des Sentinel-Dongles
3.1.1 Installieren der Sentinel-Treiber
Der Sentinel-Treiber dient als Schnittstelle zwischen Scia Engineer und dem
Sentinel-Dongle.
Wählen Sie im Menü Installation & Software der Installations-DVD die
Option Lokaler Schutz und anschließend Sentinel-Treiber installieren.
Befolgen Sie die Anleitungen auf dem Bildschirm.
Sie können die Sentinel-Treiberinstallation auch manuell starten, indem Sie
die Datei X:\Tools\Sentinel\Sentinel Protection Installer 7.*.exe aufrufen (X
steht für den DVD-ROM-Laufwerksbuchstaben, * für die Programmversion).
Hinweis
Wenn bereits eine ältere Version des Sentinel-Systemtreibers oder des
Sentinel-Installationsprogramms auf dem Computer installiert ist, muss die
ältere Version über die Systemsteuerung deinstalliert werden, bevor die
neue Version installiert werden kann.
3.1.2 Anbringen des Sentinel-Dongles
Der Sentinel-Hardwareschutz ist für die parallele Schnittstelle und USBAnschlüsse verfügbar. Bringen Sie den Dongle an einem freien Anschluss an.
Den Schutz für die parallele Schnittstelle sollten Sie bei ausgeschaltetem
Computer anbringen.
3.1.3 Prüfen des Sentinel-Dongles
Sie können Sentinel SuperPro Medic verwenden, um zu prüfen, ob der
Sentinel-Dongle korrekt installiert wurde.
3.1.3.1 Installieren von Sentinel SuperPro Medic
1. Öffnen Sie im Windows-Explorer den Ordner X:\Tools\Sentinel\ (X steht
für den Laufwerksbuchstaben des DVD-ROM-Laufwerks).
4
Scia Engineer
2. Rufen Sie die Datei SuperProMedic.exe auf und folgen Sie den
Anleitungen auf dem Bildschirm.
3. Standardmäßig wird SuperPro Medic im Ordner C:\Programme\Rainbow
Technologies\SuperPro\Medic installiert.
3.1.3.2 Prüfen des Sentinel-Dongles
1. Öffnen Sie im Windows-Explorer den Ordner C:\Programme\Rainbow
Technologies\SuperPro Medic.
2. Führen Sie die Datei SuperProMedic.exe aus. Die Anwendung „SuperPro
Medic“ wird gestartet.
3. Oben rechts in SuperPro Medic wird die installierte Sentinel-Treiberversion
angezeigt. Wenn keine Version angezeigt wird, müssen Sie die SentinelInstallation erneut ausführen (siehe oben).
4. Wählen Sie im Feld Server Name/IP oder Modus die Option
STANDALONE.
5. Klicken Sie dann auf Suche SuperPro, um nach korrekt installierten
Sentinel-Dongles zu suchen. Ein Dialogfeld zeigt die Anzahl gefundener
Hardwareschlüssel an.
6. Wenn keine Sentinel-Dongle gefunden werden, klicken Sie auf Medic
sagt, um weitere Informationen zur Problemsuche zu erhalten.
5
Scia Engineer
Wenn SuperPro Medic mindestens einen Sentinel-Dongle anzeigt, ist dieser
korrekt an einem USB- oder Parallelanschluss angebracht und der SentinelTreiber wurde korrekt installiert.
3.2 Installieren von Scia Engineer
1. Legen Sie die Installations-DVD von Scia Engineer in das DVDLaufwerk des Computers. Der Startbildschirm wird automatisch
geöffnet. Wählen Sie eine Sprache für das Hauptmenü. Das
Hauptmenü erscheint.
Wählen Sie im Hauptmenü die Option Installation & Software.
2. Wählen Sie im Menü Installation und Software die Option Scia
Engineer installieren.
6
Scia Engineer
Hinweis
Wenn der Startbildschirm nicht automatisch erscheint, können Sie die
Installation manuell über den Windows-Explorer aufrufen. Starten Sie dazu
die Datei X:\Setup\DISK1\Setup.exe (X steht für den Laufwerksbuchstaben
des DVD-Laufwerks).
3. Wählen Sie im Menü Setup-Typ die Option Einzelplatzinstallation.
4. Wählen Sie im nun angezeigten Dialogfeld die Setup-Sprache:
Die hier gewählte Sprache wird auch für die Hilfedateien von Scia
Engineer eingestellt.
5. Das Begrüßungsfenster der Installation wird geöffnet. Klicken Sie zum
Fortfahren auf Weiter.
7
Scia Engineer
6. Geben Sie im Dialog Benutzerinformationen Benutzer- und
Firmennamen ein. Der Firmenname wird automatisch in SciaEngineer-Dokumenten verwendet.
Klicken Sie zum Fortfahren auf Weiter.
7. Wählen Sie im Dialog Zielpfad wählen den Ordner, in dem die
Dateien installiert werden sollen. Normalerweise wird der Zielordner im
Ordner „Programme“ angelegt. Wir empfehlen Ihnen, die Vorgabe zu
übernehmen.
Klicken Sie zum Fortfahren auf Weiter.
8
Scia Engineer
8. Im Dialog Setup-Typ können Sie die gewünschte Installationsvariante
auswählen.
Klicken Sie zum Fortfahren auf Weiter.
Hinweis
Bei Auswahl von „Standard“ werden NICHT alle Sprachmodule installiert,
sondern nur die gewählte Sprache und Englisch. Wenn Sie weitere
Sprachen installieren möchten, müssen Sie den Punkt „Benutzerdefiniert“
wählen.
Um eine andere Sprache für die Programmumgebung von Scia Engineer
wählen zu können, müssen zwei Voraussetzungen erfüllt sein:
-
Die gewünschte Sprache muss installiert sein.
-
Das erforderliche Sprachmodul muss im Dongle oder auf dem
Server aktiv (freigeschaltet) sein.
Um Plug-ins für Scia Engineer zu installieren, müssen Sie diese in der
benutzerdefinierten Installationsvariante auswählen.
Folgende Plug-ins stehen zur Verfügung: Plug-in für Tekla Structures,
Plug-in für Revit Structure, CADS RC Link Designer, BS2000, PipelineAssistent, Verbundbalken, Verbundstützen, Arcelor-MittalKassettenbalken.
9
Scia Engineer
9. Im Dialog Lizenz-Voreinstellungen müssen Sie nun die
Schutzeinstellungen festlegen.
•
Wählen Sie Nur Dongle.
•
Aktivieren Sie die Option Lizenz aktivieren, wenn Setup beendet.
Dadurch wird die Lizenzdatei automatisch aktualisiert.
•
Tragen Sie die sechsstellige Dongle-Nr. ein.
o Bei USB-Dongles beginnt diese Ziffernfolge mit 55.
o Bei Dongles für die parallele Schnittstelle ist diese
Ziffernfolge nur 4 Zeichen lang. Tragen Sie in diesem Fall für
die ersten beiden Stellen „50“ ein, damit die Nummer
sechsstellig ist. So wird aus 1111 die Nummer 501111.
Dongle
Donglenummer
550791
552430
10
Scia Engineer
505228
506305
• Aktivieren Sie auch die Option “Load licence from online Scia
storage”. Mit dieser Funktion wird die neue Lizenz für den Dongle
im Internet gesucht und automatisch erneuert.
• Wenn Sie die Nummer nicht kennen oder der Dongle nicht an den
PC angeschlossen ist, können Sie das Programm auch ohne die
Nummer installieren. Deaktivieren Sie in diesem Fall die Option
Lizenz aktivieren, wenn Setup beendet
Klicken Sie zum Fortfahren auf Weiter.
Hinweis
Wenn Sie einen Dongle in Verbindung mit einer FlexNET-Netzlizenz
verwenden, können Sie zwischen den Optionen „Erst Dongle, dann
Floating-Lizenz“ und „Erst Floating-Lizenz dann Dongle“ wählen.
10. Im Dialog Standardeinstellungen der Anwendung legen Sie die zu
verwendende Staatsnorm fest.
11
Scia Engineer
Wählen Sie die gewünschte Voreinstellung für die Staatsnorm.
Klicken Sie zum Fortfahren auf Weiter.
11. Das abschließende Fenster fasst die gewählten Einstellungen
zusammen. Klicken Sie zum Starten der Installation auf Weiter.
12. Nach dem Installieren wird gemeldet, dass Scia Engineer erfolgreich
installiert wurde. Klicken Sie zum Beenden der Installation auf Fertig
stellen.
12
Scia Engineer
Hinweis
Wenn die Benutzerkontensteuerung (UAC) aktiviert ist, erscheint am Ende
der Installation folgende Meldung:
Wählen Sie „Diesen Treiber trotzdem installieren“, um die Installation
abzuschließen.
Achtung
Zum Ausführen von Scia Engineer sind normale Benutzerrechte
ausreichend. Es werden keine Administratorrechte benötigt.
13
Scia Engineer
Allerdings muss der Benutzer über Lese- und Schreibrechte für den
Benutzerordner von Scia Engineer verfügen:
Windows XP: C:\Dokumente und Einstellungen\#BENUTZER#\ESA**
Windows Vista, Windows 7: C:\USERS\#BENUTZER#\ESA**
Dabei steht ** für die Versionsnummer und #USER# steht für den
Anmeldenamen des Benutzers.
3.3 Aufrufen von Scia Engineer
Doppelklicken Sie auf die Verknüpfung Scia Engineer 2011.0, um das
Programm aufzurufen.
3.3.1 Scia Engineer wird gestartet.
Wenn der Schutz erfolgreich aktualisiert wurde, startet Scia Engineer
direkt und die Installation ist abgeschlossen.
3.3.2 Scia Engineer startet nicht sofort
Ansonsten wird die folgende Meldung angezeigt. Befolgen Sie dann die
nachstehenden Schritte, um den Schutz zu aktualisieren.
1. Scia Engineer kann ohne passenden Schutz nicht ausgeführt werden.
Klicken Sie auf Einstellungen, um den Schutz zu aktualisieren.
2. Das Programm für die Schutzeinstellungen erscheint:
14
Scia Engineer
Aktivieren Sie Nur Dongle und klicken Sie auf Lizenzdatei importieren.
Die Lizenz wird nun automatisch vom Scia-Lizenz-Server heruntergeladen
und die folgende Nachricht erscheint:
Drücken Sie OK zum schließen der Nachricht.
3. Öffnen Sie jetzt die neue LIC-Datei xx.lic (xx steht für die Donglenummer)
und klicken Sie auf Öffnen.
Bemerkung
-
Automatischer Import des LIC files vom Scia –Lizenz-Server ist nur
möglich, wenn der Dongle aufgesteckt ist und eine Verbindung zum
Internet besteht.
Import des LIC files kann nur durchgeführt werden, wenn auf dem
Installationsordner Schreiberechte zur Verfügung stehen. (siehe auch
Bemerkungen zuvor).
-
Es ist möglich den Pfad zum Lizenzordner, in dem die Lizenz importiert
werden soll, manuell anzupassen. Drücken Sie hierzu in der Setup-DialogKopfzeile die rechte Maustaste:
Wählen Sie [Erweiterte Einstellungen...]
15
Scia Engineer
und nun wird der Pfad zum Lizenzordner angezeigt.
Wenn Sie ein Editions- oder Dynamik-Paket von Scia Engineer nutzen,
dann haben Sie neben der Sciaxxx.lic-Datei auch eine Sciaxxx.e2c-Datei. In
diesem Fall müssen beim Importieren der Lizenz beide Dateien in einem
Ordner abgelegt sein. Wenn Sie die Lizenz von der DVD importieren, dann
sind die Dateien bereits in einem Ordner.
3. Wenn die Lizenz erfolgreich importiert wurde, dann kann eine Liste der
kommerziellen Module in dem “Ausrollen”-Dialog im Setup-Dialog eingesehen
werden.
4. Klicken Sie erneut auf OK, um die Schutzeinstellungen zu schließen.
5. Normal startet Scia Engineer 2011.0 automatisch. Wenn das Programm
nicht startet dann doppelklicken Sie bitte auf die Verknüpfung Scia Engineer
2011.0 um das Programm aufzurufen.
6. Wenn der Schutz erfolgreich aktualisiert wurde, startet Scia Engineer direkt
und die Installation ist abgeschlossen.
3.3.3 Kontrolle der Version
Aus Scia Engineer heraus ist es möglich, über Hilfe->Aktualisierungen
aussuchen sich die neueste Version herunterzuladen.
Es ist auch möglich diese Option auszustellen unter:
HKEY_CURRENT_USER\Software\SCIA\Esa\11.0\Admin\Settings\EnableUp
dateMenu = 0
16
Scia Engineer
3.4 Erweitern der Dongle-Lizenz
Beim Erneuern der Lizenz wird diese ersetzt. Dieses Ersetzen ist notwendig:
a) wenn eine neue Version von Scia Engineer installiert wurde
b) wenn sich die Zusammensetzung der Module geändert hat
c) wenn neue Module hinzugefügt wurden
Um die Lizenz zu erneuern:
1. Öffnen Sie den Lizenzeinstellungen(in Windows unter “Start
>Programme> Scia Engineer 2011.0 > Lizenzeinstellungen”)
2. Klicken Sie auf [Lizenz importieren]
3. Folgende Meldung erscheint beim erfolgreichen importieren der Lizenz:
-
Note
Automatischer Import des LIC files vom Scia –Lizenz-Server ist nur
möglich, wenn der Dongle aufgesteckt ist und eine Verbindung zum
Internet besteht.
Import des LIC files kann nur durchgeführt werden, wenn auf dem
Installationsordner Schreiberechte zur Verfügung stehen. (siehe auch
Bemerkungen zuvor).
-
Es ist möglich den Pfad zum Lizenzordner in den die Lizenz importiert
werden soll manuell anzupassen. Drücken Sie hierzu in der Setup-DialogKopfzeile die rechte Maustaste:
Wählen Sie [Erweiterte Einstellungen…]
17
Scia Engineer
und nun wird der Pfad zum Lizenzordner angezeigt.
3.5 Gebrauch mehrerer Dongle
Es ist möglich soviel Dongles gleichzeitig zu nutzen, wie an den Arbeitsplatz
angeschlossen werden können. Die ID-Nr. aller angeschlossenen Dongles
werden im Setup-Dialog angezeigt:
In der Liste der verfügbaren Module werden nun die Module aller Dongles
angezeigt, die auch gleichzeitig genutzt werden können.
Hinweis
[Import Lizenz-Datei] kann mit mehreren aufgesteckten Dongles
durchgeführt werden Es ist möglich Dongles mit unterschiedlicher
Zeitbeschränkung zu nutzen. Im Falle, dass kommerzielle Module mehrfach
vorhanden sind, wird die mit der längsten Zeitlimitierung genutzt.
18
Scia Engineer
4. Lokale Installation, Netzwerkschutz
Dieses Kapitel beschreibt das Verfahren zum Installieren eines Lizenzservers.
Scia Engineer wird lokal auf den Arbeitsplatzrechnern installiert – lediglich die
Lizenz wird auf dem Server liegen.
Die Netzlizenz kann auf einem beliebigen Computer im Netz installiert
werden. Es muss sich dabei nicht um den Domänen- oder File-Server
handeln. Für jedes autorisierte Modul kann eine andere Anzahl von Lizenzen
vorhanden sein, die gleichzeitig gestartet werden können. Beim Aufrufen von
Scia Engineer kann der Anwender bestimmen, welche Module in der Sitzung
genutzt werden und welche für andere Anwender zur Verfügung stehen
sollen.
Scia Engineer nutzt einen FlexNET-Netzwerkdongle als Schutz für
Netzwerklizenzen. So kann die Lizenz problemlos zwischen Computern
ausgetauscht werden, ohne dass jeweils eine neue Lizenzdatei erforderlich
ist.
Die Installation umfasst folgende Schritte:
•
Installieren oder Erneuern des FlexNET-Netzlizenzschutzes auf dem
Server
•
Installieren von Scia Engineer auf den Arbeitsplatzrechnern
Es wird empfohlen die neueste Version von FlexNet zu installieren. Diese
finden Sie auf der folgenden Seite: http://www.scia-online.com/update/sciaengineer.php
Achtung
In diesem Kapitel werden 2 Möglichkeiten beschrieben die
Netzwerkinstallation für Scia Engineer bzgl. des FlexNet-NetzwerkSchutzes durchzuführen
-
4.1. Erneuern eines vorhandenen FlexNET Netzwerk-Schutzes
-
4.2. Installation eines neuen FlexNet Netzwerk-Schutzes
Welche Version Sie von LMTools nutzen: Gehen Sie in LMTools auf “Hilfe > Über”und die Version wird angezeigt
-
Sollte die Version mindestens v11.8 sein, so muss nur der
Schutz von Scia Engineer erneuert werden. Gehen Sie zu
Kapitel 4.1.
19
Scia Engineer
-
Sollte die Version älter als v11.8 sein, so muss der FlexNetSchutz von Scia Engineer neu installiert werden. Gehen Sie zu
Kapitel 4.2.
Achtung
Wenn Sie den FlexNet -Netzwerkschutz auf einem neuen Server
installieren, dann müssen zuvor die Module von dem alten Server zum
Scia-Aktivierungs-Server zurückgegeben werden, um diese dann auf dem
neuen Server aktivieren zu können. (Siehe auch Kapitel 4.2.6).
4.1 Aktualisierung eines bestehenden FlexNet NetzwerkSchutzes
Ein Update eines Netzwerkschutzes bedeutet, dass die Lizenz erneuert
wird. Dies ist notwendig:
a) Wenn eine neue Version/Patch von Scia Engineer installiert wurde
b) Wenn sich die Anzahl der Lizenzen geändert hat
c) Wenn neue Zusatzmodule erworben wurden
Hinweis
Ein Update des Lizenzfiles(*.*.lid) ist nur möglich, wenn die neueste
Version von FlexNET installiert wurde. Dies können Sie kontrollieren,
unter: “LMTools -> Help -> About”:
Diese Version sollte identisch zu v11.8 sein, wie weiter oben gesagt.
Ist die Version älter als v11.8, dann gehen Sie bitte zu Kapitel 4.2.
Installation eines neuen FlexNET-Schutzes”.
1. Führen Sie den FlexNET Aktivierungsmanager aus. Diesen finden Sie
standardmäßig unter:
"C:\Programme\SCIA\FlexNET\ActivationUtility\ActivationUtility.exe"
20
Scia Engineer
Hinweis
Es ist nicht möglich den Lizenzfile via Remote oder Proxy-Server zu
aktivieren.
2. Wählen Sie Ihre Lizenznummer und klicken [Lizenz erneuern].
3. Die Lizenz wurde erneuert. Kicken Sie: [Schließen]
4. Bitte fahren Sie mit Kapitel 4.3 “Installation von Scia Engineer auf dem
Arbeitsplatzrechner“ fort.
4.2 Installieren des neuen FlexNET-Netzwerkschutzes
Hinweis
Wenn eine ältere Version von FlexNet installiert ist, das muss die Lizenz
deaktiviert werden, bevor FlexNet entfernt wird! Für diesen Vorgang lesen
Sie zuerst Kapitel 4.2.6
Mit dieser Installation wird die neueste Version von FlexNET und LMTools
auf dem Server installiert (Version 11.8). Wenn eine ältere Version von
LMTools installiert ist, dann muss diese zuvor entfernt werden.
Nach dieser Installation der Version 11.8 ist es nicht mehr möglich mit dem
Patch 2010.0.78 von Scia Engineer zu arbeiten. Alle anderen Patches von
Scia Engineer sind mit der LMTools-Version aber kompatibel.
Die Installation des Schutzes auf dem Server umfasst folgende Schritte:
•
Installieren von FlexID
•
Installieren des FlexNET-Netzlizenzschutzes auf dem Server
•
Aktivieren der Lizenzdatei
•
Konfigurieren des FlexNET-Servers
21
Scia Engineer
4.2.1 Installieren des FlexID-Netzdongles auf dem Server
Damit der FlexID-Dongle korrekt funktioniert, muss der benötigte Treiber
installiert werden.
1. Wählen Sie im Menü Installation & Software der Installations-DVD
die Option Floating-Lizenz und anschließend FlexID-Treiber
installieren. Sie können den Treiber auch manuell installieren, indem
Sie die Datei X:\Tools\FlexNet\FlexidInstaller.exe aufrufen (X steht
für den Laufwerksbuchstaben des DVD-Laufwerks).
2. Befolgen Sie die Anleitungen auf dem Bildschirm. Wählen Sie im
Dialog Funktionen wählen eine der folgenden Optionen:
- Paralleldongle: Flexid 8
- USB-Dongle: Flexid 9
3. Nachdem die Installation abgeschlossen ist, müssen Sie den Server
neu starten.
4. Bringen Sie den FlexID-Dongle an einem freien Anschluss des Servers
an. Den Schutz für die parallele Schnittstelle sollten Sie bei
ausgeschaltetem Server anbringen.
4.2.2 Installieren des FlexNET-Netzwerkschutzes
1. Wählen Sie im Menü Installation & Software der Installations-DVD
die Option Floating-Lizenz und anschließend FlexNet installieren.
Sie können den Treiber auch manuell installieren, indem Sie die
Datei X:\Tools\FlexNetSetup\Setup.exe aufrufen (X steht für den
Laufwerksbuchstaben des DVD-Laufwerks).
2. Befolgen Sie die Anleitungen auf dem Bildschirm zum Installieren
von FlexNet.
3. Normalerweise wird FlexNet im Ordner
C:\Programme\SCIA\FlexNet installiert.
4.2.3 Aktivierung der Lizenzdatei
1. Stecken Sie den FlexID-Dongle an den Server.
2. Überprüfen Sie Sie über lmtools.exe, ob der Dongletreiber installiert ist.
Dieser wurde korrekt installiert, wenn der FlexID-Dongle in dem Registerblatt
System Settings angezeigt wird. Standardmäßig ist dies in
C:\Programme\Scia\FlexNet installiert.
22
Scia Engineer
Hinweis
Der FlexID-Dongle wird via Remote oder Proxy-Server nicht angezeigt.
3. Die Lock ID befindet sich in einer .lid-Datei auf der DVD. Hier sind
die Authorisierungs-Codes die FlexNet benötigt, hinterlegt.
Wählen Sie im Menü Installation & Software der Installations-DVD
die Option Floating-Lizenz und anschließend SCIA-Aktivierungstool
starten. Sie können den Treiber auch manuell installieren, indem Sie
die Datei X:\Tools\ActUtility\ActivationUtility.exe aufrufen (X steht
für den Laufwerksbuchstaben des DVD-Laufwerks).
4. Führen Sie die Datei ActivationUtility.exe aus.
Klicken Sie auf LockID lesen.
Die LockID wird in einer LID-Datei (SCIAxxxxxx.lid) gespeichert (xx
steht für die Donglenummer). Diese Nummer ist auch auf dem Dongle
angegeben:
23
Scia Engineer
Dongle
Datei:
SCIA630505.lid
Die Daten aus dieser Datei und das Vorhandensein des Dongles am
Server dienen zum Erstellen einer LIC-Datei. Diese LIC-Datei wird in
FlexNET benötigt, um Scia Engineer zu starten.
Wählen Sie die korrekte LID-Datei und klicken Sie auf Öffnen.
5. Die Nummer der Lizenzdatei wird im FlexNET-Aktivierungstool
angezeigt.
Markieren Sie die Nummer und klicken Sie auf Lizenz aktivieren.
Hinweis
Es ist nicht möglich die Lizenz via Remote oder Proxy-Server zu aktivieren.
24
Scia Engineer
6. Der Kreis vor der Lizenznummer wird grün, sobald die Lizenzdatei
aktualisiert ist.
Klicken Sie auf Schließen.
4.2.4 Konfigurieren des FlexNET-Servers
Ab der Version Version 2010.0 wird für den Netzwerkschutz das FlexNET
benötigt. In Versions vor 2010.0 (2009.0, 2008.1, Esa Prima Win, …) wurde
FlexLM anstatt FlexNET benutzt.
Achtung
Mit dieser Installation funktionieren nur Versionen ab 2010.0 auf den
Arbeitsplatzrechnern. Wenn ältere Versionen genutzt werden sollen (z.B.
2009.0, 2008.1, Esa Prima Win…), dann ist es nötig mit dem nächsten Kapitel
“Konfiguration des FlexNET Servers für alle Versionen” fortzufahren.
1. Öffnen Sie in Windows-Explorer den Ordner
C:\Programme\SCIA\FlexNET
2. Führen Sie die Datei lmtools.exe aus.
25
Scia Engineer
3. In dem Registerblatt „Config Services“ sehen Sie den Pfad zum
Lizenzfile.
Hinweis
Die Datei SCIA_Software.lic wird beim Aktualisieren der Lizenzdatei über
das FlexNET-Aktivierungstool erzeugt. In der Voreinstellung verwendet die
Datei den TCP-Port 27000.
Wenn Sie einen anderen TCP-Port verwenden möchten (z. B. 7282), können
Sie die Datei (C:\Programme\SCIA\FLEXnet\SCIA_Software.lic) in einem
Editor öffnen und die Portnummer ans Ende der ersten Zeile anfügen.
Der Vendor-Daemon nutzt in der Voreinstellung zufällige, freie Ports für die
Kommunikation mit dem Clientrechner. Der Lizenzserver-Administrator
kann aber auch einen festen Port einstellen. Ändern Sie dazu den Eintrag
„VENDOR SCIA“ in (beispielsweise) „VENDOR SCIA PORT=7283“.
Die Datei SCIA_Software.lic ist über eine Prüfsumme gegen alle anderen
Änderungen geschützt. Solche Änderungen führen dazu, dass die
Lizenzdatei unbrauchbar wird.
4. Öffnen Sie das Register Start/Stop/Reread (Starten/Anhalten/Neu
lesen).
5. Wählen Sie den neu angelegten Lizenzmanager (FlexNET SCIA).
6. Klicken Sie auf Start Server (Server starten).
Der Lizenzserver ist nun gestartet und kümmert sich um die Lizenzen.
26
Scia Engineer
4.2.5 Konfiguration des FlexNet-Servers für alle Versionen
Achtung
Mit der Standardinstallation von FlexNet funktionieren nur Versionen ab
2010.0 auf dem Arbeitsplatzrechner. Wenn Sie ältere Versionen
benutzen(z.B. 2009.0, 2008.1, Esa Prima Win…), dann ist es notwendig
folgende Schritte zu beachten in diesem Kapitel zu beachten.
Wenn Sie Scia Engineer nur ab Version 2010.0 benutzen, dann können Sie
dies überspringen.
1. Öffnen Sie LMTools (C:\Programme\Scia\FlexNet)
2. Kopieren Sie die alte .dat-Datei nach C:\Programme\Scia\FlexNet. Normal
ist diese .dat-Datei im Verzeichnis C:\FlexLM. Diese Datei benötigen Sie für
Versionen 2009.0 und älter von Scia Engineer.
3. Öffnen Sie die .dat-Datei
4. In dieser .dat-Datei ist „scia.exe“ in der zweiten Reihe (Standard:
C:\FlexLM\Scia.exe):
5. Löschen Sie die Adresse des alten „scia.exe“-file:
6. Erneuern Sie den FlexNet Scia Service und ändern Sie den Pfad zur
Lizenzdatei in den Pfad zur .dat-Datei:
27
Scia Engineer
7. Gehen Sie sicher, dass die Optionen „Start Server at Power Up „ and „Use
Services eingeschaltet sind.
8. Gehen Sie in das Registerblatt Start/Stop/Reread
9. Klicken Sie auf Reread Licence file
10. Klicken Sie auf Start Server (Eine Bestätigungsmeldung „Server Start
Successful“ erscheint).
In einigen Fällen muss der Lizenz-Server neu gestartet werden, aber Sie
können vor dem Neustart die Neukonfiguration durchführen.
Sie können das nächste Kapitel überspringen und mit der Installation von Scia
Engineer fortfahren.
4.2.6 Server setup
Bei Servern mit einer älteren Windows-Version als Windows 7, sollten die
genutzten Ports (standard: 27000) geöffnet werden.
Bei Nutzung von Windows7-Servern ist es nicht nötig die korrekten Ports zu
öffnen, aber die genutzten Programme für die Scia-Egineer-Lizensierung
sollten hinzugefügt werden. So sollten folgende Programme für eine
Verbindung mit einem Windows 7 Server hinzugefügt werden: lmgrd.exe,
scia.exe und lmtools.exe
4.2.7 Deaktivieren der Lizenzdatei
Wenn Sie die Lizenzdatei auf einem neuen Server verwenden wollen, dann
müssen Sie die Datei zuerst auf dem alten Server deaktivieren, bevor Sie diese
auf dem neuen Server aktivieren können. Folgen Sie dazu diesen Schritten:
28
Scia Engineer
1. Öffnen Sie in Windows-Explorer den Ordner
C:\Programme\SCIA\FlexNET\ActivationUtility
2. Führen Sie die Datei ActivationUtility.exe aus.
3. Markieren Sie die Nummer der Lizenzdatei und klicken Sie auf Lizenz
zurückgeben.
4. Klicken Sie auf Schließen.
4.3 Installieren von Scia Engineer auf den
Arbeitsplatzrechnern
1. Legen Sie die Installations-DVD von Scia Engineer in das DVDLaufwerk des Computers. Der Startbildschirm wird automatisch
geöffnet. Wählen Sie eine Sprache für das Hauptmenü. Das
Hauptmenü erscheint.
Wählen Sie im Hauptmenü die Option Installation & Software.
2. Wählen Sie im Menü Installation und Software die Option Scia
Engineer installieren.
29
Scia Engineer
Hinweis
Wenn der Startbildschirm nicht automatisch erscheint, können Sie die
Installation manuell über den Windows-Explorer aufrufen. Starten Sie dazu
die Datei X:\Setup\DISK1\Setup.exe (X steht für den Laufwerksbuchstaben
des DVD-Laufwerks).
3. Wählen Sie im Menü Setup-Typ die Option Einzelplatzinstallation.
4. Wählen Sie im nun angezeigten Dialogfeld die Setup-Sprache:
30
Scia Engineer
Die hier gewählte Sprache wird auch für die Hilfedateien von Scia
Engineer eingestellt.
5. Das Begrüßungsfenster der Installation wird geöffnet. Klicken Sie zum
Fortfahren auf Weiter.
6. Geben Sie im Dialog Benutzerinformationen Benutzer- und
Firmennamen ein. Der Firmenname wird automatisch in SciaEngineer-Dokumenten verwendet.
Klicken Sie zum Fortfahren auf Weiter.
7.
Wählen Sie im Dialog Zielpfad wählen den Ordner, in dem die
Dateien installiert werden sollen. Normalerweise wird der Zielordner im
Ordner „Programme“ angelegt. Wir empfehlen Ihnen, die Vorgabe zu
übernehmen.
31
Scia Engineer
Klicken Sie zum Fortfahren auf Weiter.
8. Im Dialog Setup-Typ können Sie die gewünschte Installationsvariante
auswählen.
Klicken Sie zum Fortfahren auf Weiter.
Hinweis
Wenn eine Standard-Installation gewählt wird, dann werden nicht alle
Sprachmodule installiert, sondern nur Englisch und die
Installationssprache. Wenn weitere Sprachen installiert werden sollen,
32
Scia Engineer
dann muss die Benutzerdefinierte Installation gewählt werden, wo Sie
diese auswählen können.
Um andere Sprachen für Scia Engineer anwählen zu können, müssen zwei
Voraussetzungen erfüllt sein:
-
Die Haupt-Sprache muss installiert sein
-
Die benötigten Sprachen müssen auf dem Dongle oder Server
lizensiert sein
Wenn Sie weitere Scia Engineer Plug-ins installieren wollen, dann
müssen Sie auch diese in der Benutzerdefinierten Installation anwählen.
Folgende Plug-ins stehen zur Verfügung, Tekla Structures plug-in, Revit
Structure plug-in, CADS RC Link Designer, BS2000, Pipeline Wizard,
Composite Beam, Composite Column, Arcelor Mittal-Cellular beams.
9. Im Dialog Lizenz-Voreinstellungen müssen Sie nun die
Schutzeinstellungen festlegen.
•
Wählen Sie Nur Floating-Lizenz.
•
Tragen Sie den korrekten Pfad zum Lizenzserver ein:
o z. B. [email protected]
o Die Zahl 27000 gibt den TCP-Port an. Die Vorgabe lautet
27000, aber Sie können in der Lizenzdatei einen anderen
Port eintragen (siehe Kapitel 4.2.4).
o Ersetzen Sie SERVER durch den Namen des Lizenzservers.
Klicken Sie zum Fortfahren auf Weiter.
33
Scia Engineer
Hinweis
Wenn Sie einen Dongle in Verbindung mit einer FlexNET-Netzlizenz
verwenden, können Sie zwischen den Optionen „Erst Dongle, dann
Floating-Lizenz“ und „Erst Floating-Lizenz dann Dongle“ wählen.
10. Im Dialog Standardeinstellungen der Anwendung legen Sie die zu
verwendende Staatsnorm fest.
Wählen Sie die gewünschte Voreinstellung für die Staatsnorm.
Klicken Sie zum Fortfahren auf Weiter.
11. Das abschließende Fenster fasst die gewählten Einstellungen
zusammen. Klicken Sie zum Starten der Installation auf Weiter.
34
Scia Engineer
12. Nach der Installation erscheint einen Meldung, dass Scia Engineer
erfolgreich installiert wurde. Bestätigen Sie diese mit [Fertig stellen].
35
Scia Engineer
Hinweis
Wenn die Benutzerkontensteuerung (UAC) aktiviert ist, erscheint am Ende
der Installation folgende Meldung:
Wählen Sie „Diesen Treiber trotzdem installieren“, um die Installation
abzuschließen.
Achtung
Zum Ausführen von Scia Engineer sind normale Benutzerrechte
ausreichend. Es werden keine Administratorrechte benötigt.
Allerdings muss der Benutzer über Lese- und Schreibrechte für den
Benutzerordner von Scia Engineer verfügen:
Windows XP: C:\Dokumente und Einstellungen\#BENUTZER#\ESA**
Windows Vista, Windows 7: C:\USERS\#BENUTZER#\ESA**
Dabei steht ** für die Versionsnummer und #USER# steht für den
Anmeldenamen des Benutzers.
36
Scia Engineer
4.4 Aufrufen von Scia Engineer
Doppelklicken Sie auf die Verknüpfung Scia Engineer 2011.0, um das
Programm aufzurufen.
4.4.1 Scia Engineer wird gestartet.
Wenn der Schutz erfolgreich aktualisiert wurde, startet Scia Engineer
direkt und die Installation ist abgeschlossen.
4.4.2 Scia Engineer startet nicht sofort
In diesem Fall wird die folgende Meldung angezeigt. Befolgen Sie dann die
nachstehenden Schritte, um den Schutz zu aktualisieren.
1. Scia Engineer kann ohne passenden Schutz nicht ausgeführt werden.
Sie können die Schutzeinstellungen durchführen und Scia Engineer
anschließend starten oder das Programm schließen.
Klicken Sie auf Einstellungen, um die Schutzeinstellungen
durchzuführen.
2. Das Lizenz-Setup erscheint:
Aktivieren Sie die Option Nur Floating-Lizenz und tragen Sie den
korrekten Pfad zum Lizenzserver ein:
z. B. [email protected]
37
Scia Engineer
Die Zahl 27000 gibt den TCP-Port an. Die Vorgabe lautet 27000,
aber Sie können in der Lizenzdatei einen anderen Port eintragen
(siehe Kapitel 4.2.4 [3]).
Ersetzen Sie SERVER durch den Namen Ihres Lizenzservers.
Klicken Sie auf Anwenden/Aktualisieren.
38
Scia Engineer
3. Die verfügbaren kommerziellen Module werden angezeigt:
4. Klicken Sie auf OK, um die Schutzeinstellungen zu schließen.
5. Doppelklicken Sie auf die Verknüpfung Scia Engineer 2011.0, um
das Programm aufzurufen.
6. Wenn der Schutz erfolgreich aktualisiert wurde, startet Scia
Engineer direkt und die Installation ist abgeschlossen.
39
Scia Engineer
4.4.3 Aktualisierungen aussuchen
In Scia Engineer ist es möglich nach einer eventuellen, aktuellen Version zu
suchen, unter: Hilfe -> Aktualisierungen aussuchen
Diese Option kann in der Registry am Arbeitsplatzrechner deaktiviert werden:
HKEY_CURRENT_USER\Software\SCIA\Esa\11.0\Admin\Settings\EnableUp
dateMenu = 0
40
Scia Engineer
5. Serverinstallation
Diese Kapitel beschreibt die Schritte Scia Engineer und den Schutz auf dem
Server zu installieren.
Dieser Vorgang besteht aus folgenden Schritten:
•
Installation oder Update des FlexNet Sever-Schutzes
•
Installation von Scia Engineer auf dem Server
•
Installation von Scia Engineer als Typ: Arbeitsplatzrechner auf dem PC
Es wird empfohlen die neueste FlexNet Version installiert zu haben. Diese
findne Sie unter folgendem Link: http://www.scia-online.com/update/sciaengineer.php
Achtung
In diesem Kapitel werden 2 Möglichkeiten beschrieben die
Netzwerkinstallation für Scia Engineer bzgl. Des FlexNet-NetzwerkSchutzes durchzuführen
-
5.1. Erneuern eines vorhandenen FlexNET Netzwork-Schutzes
-
5.2. Installation eines neuen FlexNet-Netzwerk-Schutzes
Welche Version Sie von LMTools nutzen: Gehen Sie in LMTools auf “Hilfe > Über” und die Version wird angezeigt
-
-
Sollte die Version mindestens v11.8 sein, so muss nur der
Schutz von Scia Engineer erneuert werden. Gehen Sie zu
Kapitel 5.1.
-
Sollte die Version älter als v11.8 sein, so muss der FlexNetSchutz von Scia Engineer neu installiert werden. Gehen Sie zu
Kapitel 5.2.
Achtung
Wenn Sie den FlexNet-Netzwerkschutz auf einem neuen Server installieren,
dann müssen zuvor die Module von dem alten Server zum SciaAktivierungs-Server zurückgegeben werden, um diese dann auf dem neuen
Server zu aktivieren. (Siehe auch Kapitel 5.2.6).
41
Scia Engineer
5.1 Aktualisierung eines bestehenden FlexNet NetzwerkSchutzes
Ein Update eines Netzwerkschutzes bedeutet, dass die Lizenz erneuert
wird. Dies ist notwendig:
a) Wenn eine neue Version/Patch von Scia Engineer installiert wurde
b) Wenn sich die Anzahl der Lizenzen geändert hat
c) Wenn neue Zusatzmodule erworben wurden
Hinweis
Ein Update des Lizenzfiles (*.*.lid) ist nur möglich, wenn die neueste
Version von FlexNET installiert wurde. Dies können Sie kontrollieren,
unter: „LMTools->Hilfe->Über“:
Diese Version sollte identisch zu v11.8 wie weiter oben gesagt.
Ist die Version älter als v11.8, dann gehen Sie bitte zu Kapitel 4.2.
Installation eines neuen FlexNet-Schutzes.
1. Führen Sie den FlexNet Aktivierungsmanager aus. Diesen finden
Sie standardmäßig unter: „C:\Program
Files\Scia\FlexNet\ActivationUtility\ActivationUtility.exe”
Hinweis
Es ist nicht möglich den Lizenzfile via Remote oder Proxy-Server zu
aktivieren.
42
Scia Engineer
2.Wählen Sie Ihre Lizenznummer und klicken [Lizenz erneuern]
3.Die Lizenz wurde erneuert. Kicken Sie: [Schließen]
4. Bitte fahren Sie mit Kapitel 4.3 “Installation von Scia Engineer auf dem
Arbeitsplatzrechner“ fort.
5.2 Installieren des neuen FlexNET-Netzwerkschutzes
Hinweis
Wenn eine ältere Version von FlexNet installiert ist, das muss die Lizenz
deaktiviert werden, bevor FlexNet entfernt wird! Für diesen Vorgang lesen
Sie zuerst Kapitel 4.2.6
Mit diese Installation wird die neueste Version von FlexNet und LMTools
auf dem Server installiert (Version 11.8) Wenn eine ältere Version von
LMTools installiert ist, dann muss diese zuvor entfernt werden.
Nach dieser Installation der Version 11.8 ist es nicht mehr möglich mit dem
Patch 2010.0.78 von Scia Engineer zu arbeiten. Alle anderen Patches von
Scia Engineer sind mit der LMTools-Version aber kompatibel.
Die Installation des Schutzes auf dem Server umfasst folgende Schritte:
•
Installieren von FlexID
•
Installieren des FlexNET-Netzlizenzschutzes auf dem Server
•
Aktivieren der Lizenzdatei
•
Konfigurieren des FlexNET-Servers
5.2.1 Installieren des FlexID-Netzdongles auf dem Server
Damit der FlexID-Dongle korrekt funktioniert, muss der benötigte Treiber
installiert werden.
Wählen Sie im Menü Installation & Software der Installations-DVD die
Option Floating-Lizenz und anschließend FlexID-Treiber installieren.
Sie können den Treiber auch manuell installieren, indem Sie die Datei
X:\Tools\FlexNet\FlexidInstaller.exe aufrufen (X steht für den
Laufwerksbuchstaben des DVD-Laufwerks).
1. Befolgen Sie die Anleitungen auf dem Bildschirm. Wählen Sie im
Dialog Funktionen wählen eine der folgenden Optionen:
- Paralleldongle: Flexid 8
- USB-Dongle: Flexid 9
43
Scia Engineer
2. Nachdem die Installation abgeschlossen ist, müssen Sie den Server
neu starten.
3. Bringen Sie den FlexID-Dongle an einem freien Anschluss des
Servers an. Den Schutz für die parallele Schnittstelle sollten Sie bei
ausgeschaltetem Server anbringen.
5.2.2 Installieren des FlexNET-Netzwerkschutzes
1. Wählen Sie im Menü Installation & Software der Installations-DVD
die Option Floating-Lizenz und anschließend FlexNet installieren. Sie
können den Treiber auch manuell installieren, indem Sie die Datei
X:\Tools\FlexNetSetup\Setup.exe aufrufen (X steht für den
Laufwerksbuchstaben des DVD-Laufwerks).
2. Befolgen Sie die Anleitungen auf dem Bildschirm zum Installieren von
FlexNet.
3. Normalerweise wird FlexNet im Ordner
C:\Programme\SCIA\FlexNet installiert.
5.2.3 Aktivieren der Lizenzdatei
1. Stecken Sie den FlexID-Dongle an den Server.
2. Überprüfen Sie Sie über lmtools.exe ob der Dongletreiber installiert ist.
Dieser wurde korrekt installiert, wenn der FlexID-Dongle in dem
Registerblatt System Settings angezeigt wird. Standardmäßig ist dies in
C:\Programme\Scia\FlexNet installiert.
Hinwies
Der FlexID-Dongle wird via Remote oder Proxy-Server nicht angezeigt.
3. Die Lock ID befindet sich in einer .lid-Datei auf der DVD. Hier sind
die Authorisierungs-Codes die FlexNet benötigt hinterlegt.
Wählen Sie im Menü Installation & Software der Installations-DVD
die Option Floating-Lizenz und anschließend SCIA-Aktivierungstool
44
Scia Engineer
starten. Sie können den Treiber auch manuell installieren, indem Sie
die Datei X:\Tools\ActUtility\ActivationUtility.exe aufrufen (X steht
für den Laufwerksbuchstaben des DVD-Laufwerks). Evtl. steht auch
Button auf dem Desktop zur Verfügung.
4. Führen Sie die Datei ActivationUtility.exe aus.
Klicken Sie auf LockID lesen.
Die LockID wird in einer LID-Datei (SCIAxxxxxx.lid) gespeichert (xx
steht für die Donglenummer). Diese Nummer ist auch auf dem Dongle
angegeben:
Dongle
Datei:
SCIA630505.lid
Die Daten aus dieser Datei und das Vorhandensein des Dongles am
Server dienen zum Erstellen einer LIC-Datei. Diese LIC-Datei wird in
FlexNET benötigt, um Scia Engineer zu starten.
Wählen Sie die korrekte LID-Datei und klicken Sie auf Öffnen.
5. Die Nummer der Lizenzdatei wird im FlexNET-Aktivierungstool
angezeigt.
45
Scia Engineer
Markieren Sie die Nummer und klicken Sie auf Lizenz aktivieren.
Hinweis
Es ist nicht möglich die Lizenz via Remote oder Proxy-Server zu aktivieren.
6. Der Kreis vor der Lizenznummer wird grün, sobald die Lizenzdatei
aktualisiert ist.
Klicken Sie auf Schließen.
5.2.4 Konfigurieren des FlexNET-Servers
Aber der Version Version 2010.0 wird für den Netzwerkschutz FlexNET
benötigt. In Versions vor 2010.0 (2009.0, 2008.1, Esa Prima Win, …) wurde
FlexLM anstatt FlexNET benutzt.
Achtung
Mit dieser Installation funktionieren nur Versionen ab 2010.0 auf den
Arbeitsplatzrechnern. Wenn ältere Versionen genutzt werden sollen, (z.B.
46
Scia Engineer
2009.0, 2008.1, Esa Prima Win, …), dann ist es nötig mit dem nächsten
Kapitel“Konfiguration des FlexNET Servers für alle Versionen“ fortzufahren
1. Öffnen Sie in Windows-Explorer den Ordner
C:\Programme\SCIA\FlexNET
2. Führen Sie die Datei lmtools.exe aus.
3. In dem Registerblatt „Config Services“ sehen Sie den Pfad zum
Lizenzfile.
Hinweis
Die Datei SCIA_Software.lic wird beim Aktualisieren der Lizenzdatei über
das FlexNET-Aktivierungstool erzeugt. In der Voreinstellung verwendet die
Datei den TCP-Port 27000.
Wenn Sie einen anderen TCP-Port verwenden möchten (z. B. 7282), können
Sie die Datei (C:\Programme\SCIA\FLEXnet\SCIA_Software.lic) in einem
Editor öffnen und die Portnummer ans Ende der ersten Zeile anfügen.
Der Vendor-Daemon nutzt in der Voreinstellung zufällige, freie Ports für die
Kommunikation mit dem Clientrechner. Der Lizenzserver-Administrator
kann aber auch einen festen Port einstellen. Ändern Sie dazu den Eintrag
„VENDOR SCIA“ in (beispielsweise) „VENDOR SCIA PORT=7283“.
47
Scia Engineer
Die Datei SCIA_Software.lic ist über eine Prüfsumme gegen alle anderen
Änderungen geschützt. Solche Änderungen führen dazu, dass die
Lizenzdatei unbrauchbar wird.
4. Öffnen Sie das Register Start/Stop/Reread (Starten/Anhalten/Neu
lesen).
5. Wählen Sie den neu angelegten Lizenzmanager (FlexNET SCIA).
6. Klicken Sie auf Start Server (Server starten).
Der Lizenzserver ist nun gestartet und kümmert sich um die Lizenzen.
5.2.5 Konfiguration des FlexNet-Servers für alle Versionen
Achtung
Mit der Standardinstallation von FlexNet funktionieren nur Versionen ab
2010.0 auf dem Arbeitsplatzrechner. Wenn Sie ältere Versionen
benutzen(z.B. 2009.0, 2008.1, Esa Prima Win…) dann ist es notwendig
folgende Schritte zu beachten in diesem Kapitel zu beachten.
Wenn Sie nur ab Version 2010.0 benutzen, dann können Sie dies
überspringen.
1. Öffnen Sie LMTools (C.\Programme\Scia\FlexNet)
2. Kopieren Sie die alte .dat-Datei nach
„C:\Programme\Scia\FlexNet“. Normal ist diese .dat-Datei im Verzeichnis
C:\FlexLM. Diese Datei benötigen Sie für Versionen 2009.0 und
älter von Scia Engineer.
3. Öffnen Sie die .dat-Datei
4. In dieser .dat-Datei ist „Scia.exe“ in der zweiten Reihe (standard:
C:\FlexLM\Scia.exe:
48
Scia Engineer
5. Löschen Sie die Adresse des alten „Scia.exe file.
6. Erneuern Sie den FlexNet Scia Service und ändern Sie den Pfad zur
Lizenzdatei in den Pfad zur .dat-Datei:
Gehen Sie sicher, dass die Optionen „Start Server at Power up“ and Use
Services“ eingeschaltet sind.
7. Gehen Sie in das Registerblatt Start/Stop/Reread
8. Klicken Sie auf Read Licence file
9. Klicken Sie auf Start Server (Eine Bestätigungsmeldung „Server
Start Successful“ erscheint).
In einigen Fällen muss der Lizenz-Server neu gestartet werden, aber Sie
können vor dem Neustart die Neukonfiguration durchführen.
Sie können das nächste Kapitel überspringen und mit der Installation von Scia
Engineer fortfahren.
5.2.6 Server setup
Bei Servern mit einer älteren windows-Version als Windows 7, sollten die
genutzten Ports (standard: 27000) geöffnet werden.
Bei Nutzung von Windows7-Servern ist es nicht nötig die korrekten Ports zu
öffnen, aber die genutzten Programme für die Scia-Egineer-Lizensierung sollten
49
Scia Engineer
hinzugefügt werden. So sollten folgende Programme für eine Verbindung mit
einem Windows 7 Server hinzugefügt werden: lmgrd.exe, scia.exe und
lmtools.exe
5.2.7 Deaktivieren der Lizenzdatei
Wenn Sie die Lizenzdatei auf einem neuen Server verwenden wollen, dann
müssen Sie die Datei zuerst auf dem alten Server deaktivieren, bevor Sie diese
auf dem neuen Server aktivieren. Folgen Sie dazu diesen Schritten:
1. Öffnen Sie in Windows-Explorer den Ordner
C:\Programme\SCIA\FlexNET\ActivationUtility
2. Führen Sie die Datei ActivationUtility.exe aus.
3. Markieren Sie die Nummer der Lizenzdatei und klicken Sie auf Lizenz
zurückgeben.
4. Klicken Sie auf Schließen.
5.3 Neue Netzinstallation von Scia Engineer
Dieses Kapitel beschreibt das Verfahren zum Installieren von Scia Engineer
im Netz. Dabei wird Scia Engineer vollständig auf dem Server installiert. Die
Anwendung kann von jedem Arbeitsplatzrechner aus gestartet werden.
1. Prüfen Sie, welches Betriebssystem auf den Arbeitsplatzrechnern
vorliegt.
2. Erstellen Sie sich einen Ordner auf dem Server und kopieren Sie dort
den Disk1-Ordner von der Installations-DVD hinein. Ändern Sie den
Namen des Ordners in „Scia“.
3. Installieren Sie Scia Engineer auf dem Server, indem Sie den Ordner
Server//Scia öffnen und folgenden Befehl ausführen: SETUP.EXE
/v"INSTALLATION=server"
Sie müssen den Zielpfad eingeben, zum Beispiel
Z:\Programme\Scia\Engineer 2009.0
Während dieses Schritts werden vier Warnmeldungen des
Betriebssystems angezeigt.
4. Stellen Sie eine Verbindung zwischen Arbeitsplatzrechner und dem
freigegebenen Ordner Z:\ auf dem Server her.
5. Installieren Sie Scia Engineer auf dem Arbeitsplatzrechner, indem Sie
den Ordner Z:\Disk1 öffnen und folgenden Befehl ausführen:
SETUP.EXE /v"INSTALLATION=client"
Sie werden aufgefordert, den Netzwerkinstallationsordner (aus
Schritt 3) anzugeben.
50
Scia Engineer
Für diesen Schritt sind Administratorrechte erforderlich!
Achtung! Sie können KEINE Client-Installation auf demselben
Computer ausführen, auf dem die Serverinstallation ausgeführt wurde.
Die Scia-Engineer-Plug-ins werden NICHT installiert.
6. Ab jetzt kann jeder Anwender (ohne besondere Rechte) Scia Engineer
auf diesem Arbeitsplatzrechner ausführen. Allerdings muss das
Netzlaufwerk dem in Schritt 2 verwendeten, entsprechen.
5.4 Stille Installation
So führen Sie eine stille Installation auf dem Arbeitsplatzrechner durch:
1. Starten Sie die Installation auf dem ersten Arbeitsplatzrechner über den
Befehl Setup.exe /L1033 /v"INSTALLATION=client" /r.
2. Im Ordner C:\WINDOWS dieses Rechners wird die Datei Setup.iss
erzeugt. Diese Datei enthält alle Informationen für die stille Installation.
Kopieren Sie die Datei Setup.iss in den Ordner Z:\Disk1.
3. Auf allen weiteren Arbeitsplatzrechnern können Sie die stille Installation
über den folgenden Befehl starten:
Setup.exe /L1033 /v"INSTALLATION=client" /s
5.5 Lokale Ordner
Sie sollten den Ordner TEMP (für temporäre Dateien während der
Berechnung) lokal auf dem Arbeitsplatzrechner verwenden, nicht auf dem
Server. Wählen Sie dazu in Scia Engineer den Befehl Einstellungen >
Optionen > Verzeichnisse.
Auch Projektordner, Vorlagenordner, Benutzerblöcke usw. können auf dem
Arbeitsplatzrechner liegen.
51
Scia Engineer
6. Deinstallieren von Scia Engineer
6.1 Deinstallation mit Windows-Systemsteuerung
Scia Engineer kann wie jede andere Windows-Anwendung auch deinstalliert
werden:
1. Wählen Sie Start > Systemsteuerung und dort Software.
2. Eine Liste der installierten Anwendungen wird angezeigt. Wählen Sie
Scia Engineer und klicken Sie auf Ändern/Entfernen.
3. Wählen Sie im angezeigten Dialog die Option Programm Entfernen.
4. Klicken Sie zum Starten der Deinstallation auf Weiter.
Nachdem die Deinstallation abgeschlossen ist, verbleiben einige
Einstellungen in der Registrierdatenbank von Windows. Diese können Sie
manuell löschen. Das Löschen der Einträge ist eventuell erforderlich,
wenn Probleme mit einer neuen Installation auftreten.
1. Öffnen Sie den Dialog Ausführen über Start > Ausführen …
2. Geben Sie regedit ein und klicken Sie auf OK.
Für diesen Schritt benötigen Sie Administratorrechte!
52
Scia Engineer
3. Der Registrierungs-Editor erscheint.
4. Navigieren Sie zu den folgenden Schlüsseln und löschen Sie diese
über die Schaltfläche Löschen.
HKEY_CURRENT_USER\Software\SCIA\ESA\*
HKEY_LOCAL_MACHINE\Software\SCIA\ESA\*
Dabei steht * für die Versionsnummer.
5. Schließen den Registrierungs-Editor über Datei > Beenden.
Nachdem die Deinstallation abgeschlossen ist, verbleiben Ordner auf der
Festplatte. Sie können diese Ordner löschen:
32-Bit-Computer: C:\Programme\SCIA\ESA**
64-Bit-Computer: C:\Programme (x86)\SCIA\Engineer**
Auch die folgenden Ordner verbleiben auf der Festplatte und können gelöscht
werden:
Windows XP:
C:\Dokumente und Einstellungen\#BENUTZER#\ESA**
C:\Dokumente und Einstellungen\#BENUTZER#\Eigene
Dateien\ESA**
Windows Vista und Windows 7: C:\Users\#BENUTZER#\ESA**
C:\Users\#BENUTZER#\Documents\Esa**
** zeigt die Software-Versionsnummer an.
Achtung
Diese Ordner können Sie im Windows-Explorer löschen. Der erste Ordner
kann Projekte enthalten – vergewissern Sie sich also, ob diese gelöscht
werden können.
53
Scia Engineer
6.2 Deinstallation ohne Windows-Systemsteuerung
Es kann evtl. vorkommen, dass sich Scia Engineer nicht über die
Systemsteuerung deinstallieren lässt. In diesem Fall ist Scia Engineer nicht in
der Programm-Liste aufgeführt.
Dieses Problem kann bei jedem windowsbasierten Programm auftreten.
Um SCia Engineer einfach zu deinstallieren, führen Sie bitte folgende Schritte
durch:
Gehen Sie auf Start->Ausführen/Suchen
In dem nun geöffneten Dialog geben Sie nun folgenden Befehl ein:
msiexec /x {A987CA63-95E7-47E5-AA08-38C0D84BB03C}
Dieses bewirkt die gleiche Deinstallation wie über die Systemsteuerung.
54
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement