Installationsanleitung

Installationsanleitung
ARCWAY Cockpit
Client-Installation
ARCWAY AG
Alt Moabit 90b
D-10559 Berlin
Tel. +49.30.8009783-0
Fax +49.30. 8009783-100
E-Mail [email protected]
ii
RECHTLICHE HINWEISE
Bitte senden Sie Fragen zum ARCWAY Cockpit oder Kommentare zu diesem Dokument an:
Kundensupport
ARCWAY AG
Alt Moabit 90b
10559 Berlin
+49.30.8009783.333
© 2004 - 2008 ARCWAY AG. Alle Rechte vorbehalten.
DIESES PRODUKT ENTHÄLT VERTRAULICHE INFORMATIONEN UND GESCHÄFTSGEHEIMNISSE DER ARCWAY AG. DIE
NUTZUNG, VERBREITUNG UND/ODER REPRODUKTION IST OHNE VORHERIGE UND AUSDRÜCKLICHE ERLAUBNIS DER
ARCWAY AG UNTERSAGT.
DIE EINSICHT IST LIMITIERT AUF AUTORISIERTE PERSONEN.
DIE NUTZUNGBESTIMMUNGEN DIESES PRODUKTS SIND IN DEN BEDINGUNGEN DES ABKOMMENS MIT DER ARCWAY AG
ÜBER BENUTZERLIZENZEN EINZELN GEREGELT.
DER INHALT DIESES DOKUMENTS IST OHNE JEDE GEWÄHR.
DIESE PUBLIKATION KANN UNGENAUIGKEITEN UND TYPOGRAPHISCHE FEHLER ENTHALTEN.
ARCWAY AG behält sich das Recht vor, dieses Dokument ohne vorherige Ankündigung zu verändern oder zu entfernen.
ARCWAY und Cockpit sind Marken- oder registrierte Produktnamen der ARCWAY AG.
Java ist ein Produkt von Sun Microsystems, Inc.
Eclipse ist ein Produkt der Eclipse Foundation, Inc.
Microsoft, Windows, Windows 2000, Windows XP, Windows 2003 Server MS Word, MS Excel, MS Project sind Produkte
der Microsoft Corporation.
MS SQL Server 2000 ist ein Produkt der Microsoft Corporation.
DB2 ist ein Produkt der IBM Corporation.
Linux ist eine registrierter Produktname von Linus Torvalds.
Fedora ist ein Produkt von Red Hat, Inc.
Mandrake ist ein Produkt der Mandrakesoft S.A.
SUSE ist ein Produkt der SUSE AG, einer Gesellschaft von Novell.
Adobe SVG Viewer ist ein Produkt von Adobe Systems.
Alle in diesem Dokument genannten Marken- und Produktnamen sind Eigentum der jeweiligen Eigentümer.
Dokument 0003-V3-DE vom 7. März 2008
iii
Inhalt
Systemvoraussetzungen ......................................................................... 5
Standardinstallation ............................................................................... 5
Konfigurieren des Servers ......................................................................................................7
Installieren des Clients in ein bestehendes Eclipse ................................... 7
Schritt 1 – Starten des Eclipse Update-Managers ......................................................... 8
Schritt 2 – Installieren der ARCWAY Cockpit- Features ................................................ 9
Schritt 3 – Starten der Cockpit-Hauptansicht .............................................................10
Erweitern des Clients um zusätzliche Module........................................ 10
iv
Installation des Cockpit
Clients
Die Installation von ARCWAY Cockpit ist einfach und unkompliziert. Der Client ist eine EclipseInstallation, welche mit ARCWAY Cockpit Plug-ins erweitert wird. Eclipse ist eine offene,
erweiterbare, integrierte Entwicklungsumgebung (IDE) und Werkzeugplattform. Weitere
Informationen zu Eclipse erhalten Sie unter www.eclipse.org.
Systemvoraussetzungen
PROZESSOR
ARBEITSSPEICHER
FESTPLATTENPLATZ
BILDSCHIRMAUFLÖSUNG
PLATTFORM
SOFTWARE
1 GHZ X86 PROZESSOR EMPFOHLEN
MINDESTENS 256 MB, EMPFOHLEN
512 MB
200 MB
MINDESTENS 1024 X 768,
EMPFOHLEN 1280 X 1024
GETESTET AUF WINDOWS 2000 UND
WINDOWS XP;
PRINZIPIELL AUF ALLEN WINDOWS PLATTFORMEN
FÜR EXPORTE/IMPORTE BENÖTIGT:
 MICROSOFT EXCEL 2000 ODER
HÖHER
 MICROSOFT PROJECT 2000
ODER HÖHER
 MICROSOFT WORD 2000 ODER
HÖHER
Standardinstallation
In dieser Installationsanleitung wird davon ausgegangen, dass Sie ARCWAY Cockpit auf einem
Computer mit den Betriebssystemen Microsoft Windows 2000 oder XP installieren wollen.
Sie können den Client als Systemadministrator oder als normaler Windows-Benutzer
installieren. Wenn Sie den Client als Systemadministrator installieren, so wird er für alle Nutzer
installiert. Wenn Sie den Client als Windows-Benutzer ohne Administrationsrechte installieren,
so wird er nur für diesen Windows-Benutzer installiert.
Zur Installation des ARCWAY Cockpit-Clients legen Sie bitte die Produkt-CD in ein CD-ROMLaufwerk ein und öffnen die Datei index_de.html, die sich im Wurzelverzeichnis des
Laufwerks befindet. Klicken Sie auf Client Installation und warten Sie auf den
Ladevorgang des Installationsprogramms. Wählen Sie zunächst die zu installierenden
Komponenten aus. Der Punkt „zusätzliche Komponenten“ listet Komponenten des ARCWAY
Cockpit auf die optional installiert werden können. Standardmäßig wird keine dieser
Komponenten installiert. Wählen Sie diese je nach Bedarf aus (siehe Abblidung Zusätzliche
Komponenten). Das Installationsprogramm fragt Sie anschliessend nach dem Zielverzeichnis
und erstellt eine Programmgruppe sowie ein Desktop-Symbol für den ARCWAY CockpitClient.
Abb. 1 Zusätzliche Komponenten
Nach Beenden der Installation starten Sie bitte den ARCWAY Cockpit-Client mit einem
Doppelklick auf das ARCWAY Cockpit-Symbol auf Ihrem Desktop.
6
Konfigurieren des Servers1
Wenn Sie den ARCWAY Cockpit-Client zum ersten Mal in Betrieb nehmen, sind noch keine
Server konfiguriert.
Zum Anlegen einer Verbindung zu einem Server klicken Sie auf den Knopf „Neue
Serververbindung“ im Fenster des Projekt-Navigators. Es öffnet sich der Dialog (siehe Abb.
Serververbindung anlegen), zum Anlegen des neuen Servers. Den Server Namen können Sie
frei wählen. Als URL müssen Sie die URL angeben unter der der Cockpit-Server zu erreichen ist.
Wenn Sie die URL des Servers nicht kennen, fragen Sie bitte den Systemadministrator, der den
Server installiert hat. Wiederholen Sie die letzten Schritte für jeden Server, den Sie konfigurieren
möchten.
Abb. 2 Serververbindung anlegen
1
Die Konfiguration des Servers ist nur in der Client/Server-Variante nötig
7
Installieren des Clients in ein bestehendes Eclipse
Um den ARCWAY Cockpit-Client abweichend von der Standardinstallation in eine bestehende
Eclipse-Installation zu integrieren, muss die bestehende Installation auf einer der unten
aufgeführten Eclipse-Versionen basieren und die Anforderungen für die voreingestellte ClientInstallation erfüllen.
Unterstützte Eclipse-Version:

Eclipse 3.3.1
In diesem Abschnitt wird beschrieben, wie Sie eine bestehende Eclipse-Workbench zu einem
ARCWAY Cockpit-Client ausbauen können, indem Sie den Eclipse Update-Manager benutzen,
um entsprechende “Eclipse Features” und “Eclipse Plug-ins” hinzuzufügen. Zu diesem Zweck
enthält die Cockpit-CD eine XML-Datei in der alle so genannten „Eclipse Update Sites“
gespeichtert sind. Diese sind die Installationsquelle für den Eclipse Update-Manager.
Schritt 1 – Starten des Eclipse Update -Managers
Um den Cockpit Client zu installieren, müssen Sie zuerst Eclipse starten. Klicken Sie dann bitte
in
Eclipse
auf
den
Menüeintrag
Hilfe->Software-Updates->Suchen
und
Installieren um den Eclipse Update Manager zu starten.
Klicken Sie auf Neu zu installierende Features suchen und dann auf Weiter.
Klicken Sie nun bitte auf die Schaltfläche Sites importieren.. und wählen Sie bitte die
Datei update_site_bookmarks.xml auf der Produkt CD aus. Schließen Sie daraufhin den
Dialog. Nun werden alle Update Sites angezeigt.
8
Die von ARCWAY empfohlenen Module sind bereits markiert. Sie können nun Module, die Sie
zusätzlich installieren wollen markieren oder mit einem Klick auf Fertig stellen das
Update starten. Der Eclipse Update Manager wird sich umgehend mit den Updateseiten
verbinden und die auf den Seiten verfügbaren Features erfragen.
Schritt 2 – Installieren der ARCWAY Cockpit- Features
Wählen Sie alle Suchergebnisse aus und klicken Sie auf Weiter.
Klicken Sie erneut auf Weiter und Sie gelangen zu einer Seite, auf der Sie die
Lizenzvereinbarungen einsehen können. Bitte bestätigen Sie, dass Sie die Lizenzvereinbarungen
gelesen und akzeptiert haben und klicken Sie auf Weiter.
Klicken Sie nun auf die Schaltfläche Fertig stellen und die Installation beginnt. Nach der
Installation wird Eclipse Ihnen empfehlen, das Programm neu zu starten. Bitte starten Sie
Eclipse neu.
9
Hinweis:
Abhängig von den Einstellungen in Ihrem Firmennetzwerk können die
gewählten Features unter unter Umständen nicht von der Updateseite
heruntergeladen werden. Dann müssen Sie Ihre Proxyeinstellungen vor dem
Update in Eclipse manuell konfigurieren, Wählen Sie dazu in Eclipse den
Menüeintrag Fenster > Benutzervorgaben. Im Benutzervorgabendialog
wählen Sie Allgemein > Network Connections. Geben Sie hier
Ihren HTTP-Proxy an. Informationen dazu bekommen Sie von Ihrem
Systemadministrator oder aus den Internet-Einstellungen Ihres Browsers.
Schritt 3 – Starten der Cockpit-Hauptansicht
Damit ist die Installation erfolgreich abgeschlossen! Um Cockpit benutzen zu können, müssen
Sie die Cockpit Hauptansicht aktivieren. Bitte wählen Sie im Eclipse Hauptmenü
Fenster->Perspektive öffnen->Andere.... Nun erscheint ein Dialog, der alle
verfügbaren Perspektiven auflistet. Wählen Sie die Perspektive „Übersicht“, welche mit dem
ARCWAY Cockpit Logo gekennzeichnet ist. Abhängig von der Art der Nutzung, empfiehlt es
sich
weitere ARCWAY Cockpit spezifische Perspektiven zu öffnen: „Modellierung“,
„Anforderungsmanagement“, „Offene-Punkte-Verwaltung“.
Erweitern des Clients um zusätzliche Module
Sie könn en einen installierten Client um zusätzliche Module erweitern.
Hierzu müssen Sie folgendermaßen verfahren: Öffnen Sie ARCWAY Cockpit und wählen Sie
den Eintrag Hilfe  Software Updates  Suchen und installieren aus dem
Hauptmenü.
Klicken Sie auf Neu zu installierende Features suchen und dann auf Weiter.
Klicken Sie nun auf die Schaltfläche Neue ferne Site. Geben Sie im Feld Name den
Namen des Moduls an und im Feld URL den Link für die Updateseite des Moduls das
nachinstalliert werden soll und bestätigen Sie Ihre Eingabe.
Nun können Sie die soeben eingegebene Updateseite markieren und mit einem Klick auf
Fertig stellen die Installation des gewünschten Moduls starten.
Der Update Manager wird sich umgehend mit der Updateseite verbinden und die auf der Seite
verfügbaren Features erfragen. Wählen Sie hier alle Features aus, die Sie installieren möchten
und klicken Sie auf Weiter.
10
Sie gelangen zu einer Seite, auf der Sie die Lizenzvereinbarungen einsehen können. Bitte
bestätigen Sie, dass Sie die Lizenzvereinbarungen gelesen und akzeptiert haben und klicken Sie
noch zweimal auf Weiter.
Eclipse wird Sie warnen, dass die Features nicht digital signiert sind. Bitte klicken Sie hier auf die
Schaltfläche Installieren und die Installation beginnt. Nach der Installation wird Eclipse
Ihnen empfehlen, das Programm neu zu starten. Bitte starten Sie Eclipse neu.
Nach der Installation sollten Sie noch die neu installierten Sichten und Perspektiven in Ihrem
Cockpit öffnen. Wählen Sie dazu im den Eintrag Fenster  Perspektive öffnen 
Andere... aus dem Hauptmenü. Nun erscheint ein Dialog, der alle verfügbaren Perspektiven
auflistet. Wählen Sie hier die Perspektive für das Modul, das Sie soeben installiert haben.
11
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement