Winwedgeソフトウエア取扱説明書

Winwedgeソフトウエア取扱説明書
Software Wedge for Windows
取扱説明書
100706
MUNAZO Incorporated.
ムナゾヲ株式会社
〒658-0032 神戸市東灘区向洋町中6-9 KOBE FM
TEL078(857)5447 FAX078(857)5443
http://munazo.jp
E-mail : munazo@munazo.jp
品質保証規定
お客様がご購入された WinWedge ソフト(以下「本ソフトウェア製品」といいます)に関しては、以下の保証のみが適用されます。本ソフトウェア
製品の保証に関する事項は、ムナゾヲ株式会社を通じてのみ対処されるものとします。この保証規定は日本国内のみにて有効なものとしま
す。
1. 品質保証
(a)本ソフトウェア製品が付属の取扱説明書に従って実質的に動作しない場合または本ソフトウェア製品の媒体または取扱説明書に物理的な
瑕疵がある場合にお買い上げ後90日間に限り、本ソフトウェア製品に付随してムナゾヲ株式会社より提供されるハードウェアについては物
理的、または製造上の瑕疵がある場合にお買い上げ後1年間に限り、ムナゾヲ株式会社の判断に基づき、交換、修補または代金返還の
いずれかにより対応するものとします。
(b)上記項のいずれの対応も、お客様が本ソフトウェア製品の保証書とともに本ソフトウェア製品をムナゾヲ株式会社に返却された場合にのみ
提供されます。
(c)上記(a)項の事態が火災、地震、第三者による行為その他の事故、お客様の故意若しくは過失、誤用その他異常な条件下での使用にお
いて生じる等ムナゾヲ株式会社の責に帰さない理由により生じた場合、ムナゾヲ株式会社は、保証の責任を負わないものとします。なお、
以下に定める場合も保証の対象とはなりません。
z
お客様による入手後の輸送、移動、落下、その他の衝撃による故障
z
改造、不当な修理、その他の取扱いが適切でなかったことによる故障
z
ハードウェアに関わる部品の紛失
z
ハードウェアが接続されている他社製品の故障、不具合に起因する故障
(d)ハードウェアの保障期間満了後の障害、故障につきましては、ムナゾヲ株式会社の判断により、ムナゾヲ株式会社は有償にて修理をいた
します。
(e)交換または修補後の製品の保障期間は、元の保障期間の満了日または交換・修補された製品の引渡し後30日間の満了日のいずれか
遅く到来する日までとします。
(f)ムナゾヲ株式会社は、本ソフトウェア製品、本ソフトウェア製品の媒体または取扱説明書、本ソフトウェア製品に付随してムナゾヲ株式会社
より提供されるハードウェアに関して、商品性および特定の目的に対する適合性を含む本保証規定に規定されていないその他の保証を、
明示たると黙示たるとを問わず一切いたしません。
(g)法律上の請求の原因の種類を問わず、いかなる場合においても、ムナゾヲ株式会社およびその供給者は、この製品の使用または不使用
から生ずる本保証規定に規定されていないいかなる他の損害(逸失利益、事業の中断、事業情報の喪失またはその他の金銭的損害を
含むがこれらに限定されません)に関して、一切責任を負わないものとします。例えムナゾヲ株式会社がかかる損害の可能性について知
らされていた場合でも同様です。いかなる場合においても、本保証規定に基づくムナゾヲ株式会社の責任は、本ソフトウェア製品について
お客様が実際に支払った金額を上限とします。
2. 保証書
(a)ハードウェアには保証書が添付されていることがあります。以下の場合、保証書および本保証書規定は無効となり、適用されません。
z
保証書の提示がない場合
z
記入洩れのある場合
z
保証書を改竄した場合
(b)保証書の再発行はいたしておりません。本ソフトウェア製品と共に大切に保管なさってください。
MUNAZO Incoporated
ムナゾヲ株式会社
〒658-0032 神戸市東灘区向洋町中 6-9
KOBE FM
Phone 078-857-5447
Fax 078-857-5443
e-mail:[email protected]
http://munazo.jp
目次
目次 .................................................................................................................................................................................................. 3
システム条件 ................................................................................................................................................................................. 1
WEDGE SOFTWARE クイックガイド ........................................................................................................................................ 1
SOFTWARE WEDGE 基本設定例........................................................................................................................................ 2
メインメニュー................................................................................................................................................................................. 5
ファイルメニュー............................................................................................................................................................................ 6
SOFTWARE WEDGE 設定ファイル.......................................................................................................................................6
特定設定ファイルでのWEDGEの自動起動.........................................................................................................................7
モードメニュー................................................................................................................................................................................ 8
キーストローク・モード送信 ..........................................................................................................................................................8
DDEサーバーモード...................................................................................................................................................................10
キーストローク送信とダイナミック・データ・エクスチェンジ............................................................................................11
ポートメニュー ..............................................................................................................................................................................12
ポートセッティング・ダイアログボックス ................................................................................................................................13
ポート分析メニューオプション.................................................................................................................................................14
ディファインメニュー...................................................................................................................................................................16
INPUT DATE RECORD STRUCTURE...............................................................................................................................................16
TRANSLATION TABLE .....................................................................................................................................................................16
SERIAL OUTPUT STRINGS ..............................................................................................................................................................16
インプットデータ・レコード構造設定 .......................................................................................................................................17
レコード終端表示 .........................................................................................................................................................................18
SINGLE FIELD DATA RECORDS .....................................................................................................................................................20
MULTIPLE DELIMITED DATA FIELDS ............................................................................................................................................21
MULTIPLE FIXED LENGTH DATA FIELDS .....................................................................................................................................21
SPECIFYING FILTERS AND FIELD LENGTHS .................................................................................................................22
フィルタの選択..............................................................................................................................................................................23
フィールド長の設定.....................................................................................................................................................................23
PRE/POSTAMBLE キーストローク設定 (キーストローク送信モード) .....................................................................24
DDEコマンド設定 (DDE サーバーモード) ....................................................................................................................... 25
変換表........................................................................................................................................................................................... 28
シリアル・アウトプット・ストリング設定 .................................................................................................................................... 31
起動メニュー ............................................................................................................................................................................... 33
SOFTWARE WEDGE の起動 ................................................................................................................................................ 34
編集メニュー................................................................................................................................................................................. 35
終了メニュー................................................................................................................................................................................. 36
オンライン・ヘルプへのアクセス............................................................................................................................................ 37
システム条件
WinWedgeの32ビットバージョンは Windows 95, 98, ME, NT, 2000, XP
Excel2000 以上に対応しています
WinWedgeは 2MBのハードディスク空き容量と 16MB以上の空きメモリを必要とします。
Wedge Software クイックガイド
Wedge Software を活用いただく為に必要な基本的・最小限のステップにつき、以下ご説明いたします。
このセクションは、Wedge Software のセットアップに必要なステップの概略であり、マニュアルの全体の要約
ではありませんのでご留意下さい。
2 ページの、Wedge Software 基本設定例の項もご参照下さい。
ステップ1.Mode Menu 中の2つのオプションの内(キーストローク又は DDE)から1つを選び、ウエッジが、
入力してくるシリアルデータをお客様の他の Windows プログラムに転送する方法を選択して下さい。この2つ
のモード詳細説明については 8 ページのモードメニュー項をご参照下さい。
ステップ2.Port Menu 中の Settings option を開き、Serial Communication Setting を選択し、パラメータ
が、お客様が使用中のシリアル機器にマッチするようにして下さい。このシリアル・コミュニケーション・パラメ
ータの選択が終わりましたら、Port Menu から Analyze Option を開き、お客様のシリアル機器から、サンプ
ルデータをいくつか伝送し、正しいシリアル・コミュニケーション・パラメータが使われているかをテストし、お客
様のシリアル機器からのデータの構造を確認して下さい。
より詳細な情報については、12 ページのポートメニューの項をご参照下さい。
ステップ3.Define Menu から “Input Data Record Structure” を開いて下さい。いくつかのダイアログボッ
クスが表示されます。このダイアログボックスで、先ず Wedge に入力されてくるシリアルデータの構造を設定
し、次に、使おうとしているアプリケーション・プログラムにデータをパスする前に、それらの入力データや追加
データ、キーストローク又はデータへの DDE コマンドを解析し、フィルタをかける方法を設定します。
Wedge は、多くの異なったデータを取り扱う為の色々なオプションを有していますので、16 ページの入力デ
ータレコード構造設定の項も読まれることを強くお勧めします。
ステップ4.お客様のお使いの機器に、お客様の PC からのデータ又はコマンドを送り返す必要がある場合、
31 ページのシリアルアウトプットストリングの項を参照下さい。
ステップ5.最終ステップは、Software Wedge の起動です。この時点での設定をセーブしたい場合、File
Menu から “Save” を開いて下さい。Wedge を起動するには、Activate Menu から “Test Mode” を開き
ます。詳細は 33 ページ、メニューの起動の項をご参照下さい。
注記:Software Wedge は Activate Menu 中のオプションの1つを開いて起動させないと、作動しません。
1
Software Wedge 基本設定例
バーコードリーダー、電子秤および計測器として
この章では、バーコードリーダーや、デジタル・カリパーや電子秤などの単純な計測器用に Wedge を使用す
る場合の基本的セッティング手順を説明致します。
お客様の機器からウインドウズのアプリケーションにデータを直接読み込む為の Wedge の設定方法は以下
の通りです。この説明例は、データを取り込もうとしているアプリケーションはスプレッドシートであり、機器から
の連続読み取りを、スプレッドシートのコラム中に表示させるという想定です。
お客様の機器の取り扱い説明書で、使用されているシリアルコミュニケーション・パラメータが何かを確認下
さい。この例の場合、機器がデータを 9600 ボーで伝送し、Even Parity, Seven Data bit 及び 1 Stop bit を
使用しているという前提です。
ステップ1.機器をCOM1又はCOM2につないで、電源オンにし、
Software Wedge をランさせて下さい。
ステップ2.Wedge 中の ”PORT” メニューから “Settings” オプ
シ ョ ン を 開 き 、 コ ミ ュ ニ ケ ー シ ョ ン ・ パ ラ メ ー タ COM 1 ( 又 は
COM2),9600 ボー、Even parity ,7 Data bit, 1Stop bit,Flow Control
はダイアログボックスから ”None” を選択し、OK ボタンをクリックし、
メインメニューに戻ります。
ステップ3.“PORT” メニューから “ANALYZE” を開き、Analyze
画面中の Input Buffer 欄に、機器からのサンプル読み込みを伝送し
て下さい。このステップは2つの目的があり、1つは、コミュニケーショ
ン・パラメータは間違いないか、機器は正しく接続され、データを伝送
しているかのチェックであり、もう1つは、機器からのデータの構造を知
ることです。
データが Input Buffer 中に表示されたら、すべてのキャラクタをチェックし、区切り文字等の記号は受信され
ているか、キャリッジ・リターンやライン・フィードのような特殊文字はあるか、又読み取りも何回か行なって、
各読み取りが同じような構造になっているかも確認して下さい。
バーコードリーダー、カリパー、電子秤のようなシンプルな機器は、キャリッジ・リターンやキャリッジリターン・ラ
インフィードのついた単純な数字や短いデータストリングを伝送します。キャリッジ・リターンは音符マークで示
され、ラインフィードの場合は三角形の中に丸の入ったマークで示されます。
2
機器からのデータチェックし、データが正しく受信できていることを確認できたら、 “Quit” ボタンをクリックし、
メインメニューに戻って下さい。
ステップ4.データを Windows プログラムに直接読み込みたい場合、
最も簡単な方法は、Wedge がシリアルデータを、キーボード上でタイ
プ入力されたかのように、キーストロークに変換できるようにすることで
す。Mode Menu から ”Send Keystrokes To…” を開いて下さい。
アプリケーション・タイトルバー・テキスト及び・コマンドラインを入力する
ダイアログボックスが表示され、ここで Wedge が、すべてのキーストロ
ークを送るべきアプリケーションを確認します。
このケースは、データが入力されたとき、Wedge がそのデータを、入力フォーカスを持ったすべてのアプリケ
ーションに送るという場合です。従って “Application Title Bar Text” 及び “Command Line” の2つは正
しく入力されていなければなりません。図示されているように、この2つがブランクになったままだと、データが
シリアルポートから入力されてきたとき、Wedge は入力フォーカスのついたすべてのアプリケーションにキース
トロークを送ることになります。これらの2つの入力がすんだら、OKボタンをクリックしてメインメニューに戻って
下さい。
ステップ5.次のステップでは、シリアル機器から受信するデータの構造を設定します。この例では、データを
スプレッドシートに送り、カーソルを各読み取りごとに1セル下げ、データ読み取りの最後で “ENTER” の
キープレスを行うように Wedge に指示しなければなりません。
この為には、DEFINE メニューから “Input Data record Structure”
を開き、最初に、画面左に表示されるダイアログボックスで、機器から
伝送される個々のデータレコード最後のデータを判別する為のイベント
を設定します。
各データレコードはキャリッジリターンで終わる短いストリングのテキストで
構成されているので、この場合 “Carriage return or CrLf Received”
を “End of Record Event” として指定し、これが終わったら
”Continue…” ボタンを押し、次に進んで下さい。
次に現れるダイアログボックスが、各データレコードの全体的な
“Structure” を決める為のオプションです。このサンプルでは、データは
単一のフィールドから成っていますので、“Single Field Data record”
を選択し、”Continue” ボタンをクリックして下さい。
3
次 の ダ イ ア ロ グ ボ ッ ク ス 中 で 、 カ ー ソ ル を 、 ” Field Postamble
Keystrokes” と書かれているテキストボックス中に持ってきて、
”Keystroke List” のボタンをクリックして下さい。
キーストローク・リストが表示されたら、このリスト中をスクロールダウ
ンし、”Enter” の文字が強調されたらOKボタンをクリックして下さ
い 。 そ う す る と 、 ” {Enter} ” の 文 字 が ” Field Postamble
Keystrokes” のテキストボックス中に表示されます。もし、数字デ
ータを伝送する機器を使用中で、Wedge が数字以外のキャラクタ
をすべて取り除きたいという場合は、フィルターリストから
”Numeric” を選択して下さい。そして最後に ”OK” ボタンをクリ
ックし、メインメニューに戻って下さい。
これで、Software Wedge は希望通りに作動するように完全に設定できました。ここで FILE メニューから
”Save” を選択し、この設定をセーブして下さい。この設定ファイルに使用する機器に関連付けた名前を付
けておかれるといいでしょう。例えば、機器が電子秤の場合、BALANCE.CFG というようにです。
ステップ6.Wedge の設定が終わったら、ACTIVATE メニューから ”Test Mode” を開き起動させて下さい。
Wedge を起動させると、”Input Data Field” というテキストボックスの入った画面が開き、Wedge は準備完
了であることを示しています。
ステップ7.Wedge をランさせたままで、スプレッドシートを開き、データを表示したいというセルにカーソルを
動かし、機器からの読み取りを指示して下さい。すべてが正しく稼動していれば、 ”Enter” をキープレスす
るだけで、キーボード上でタイプインしたかのようにデータが表示されます。
4
メインメニュー
Software Wedge を起動したら、下記 ”Main Menu” が表示されます。
このメインメニュー・タイトルバーは、今セットアップモード中であることをしめしており、同時に又、今選択され
ている設定ファイル名を表示しています。Software Wedge を使用するには、使用する個々のシリアル機器
に合わせてそれを設定しなければいけません。
メインメニューから色々なオプションを選択し Wedge を設定、それが終わったら、“Activate” メニュー中の
オプションの1つを選択し、起動させて下さい。
6つのメインメニュー・オプションとその機能は次の通りです。
File
― 設定ファイルを開いたり・セーブしたり、Software Wedge の終了用です。
6 ページのファイルメニューもご参照下さい。
Mode
―Software Wedge からのシリアル・インプットデータの転送方法を選択、及び
場合によってはデータを受信すべきアプリケーションを特定するために使用。
8 ページのモードメニューの項参照下さい。
Port
―すべてのシリアルポート・コミュニケーション・パラメータの選択とテスト用。
12 ページ、ポートメニューの項参照下さい。
Define
―Define Menu は、Wedge を、お客様の特定のアプリケーション用にカスタマイズすることを可
能にします。異なったいくつかのサブメニューが、インプットデータ・レコードの構造を設定し、
入力データ、データ入力中に出されるカーソルナビゲーション・キーストローク又は DDE コマン
ド、及びシリアルデータ・ストリングに対して出される指示内容の解析を行います。
16 ページのディファイン・メニュー をご参照下さい。
Activate
―既存の設定で Software Wedge の起動を行います。Software Wedge は、このメニュー中
の起動オプションを開かないと起動しません。又このメニューにはいくつかのエントリーがあり、
起動した時の画面の表示も含め、このメニューで Wedge のもつ追加機能を制御します。
33 ページ、起動メニューの項をご参照下さい。
Help
―Software Wedge に対するオンラインヘルプを提供します。
37 ページのオンラインヘルプへのアクセスをご参照下さい。
5
ファイルメニュー
Software Wedge メインメニューから ”File” を開くと、下記のようなサブメニューが表示されます。
サブメニューのオプション及びその機能は以下の通りです。
New
―現在ロードされている設定ファイルをアンロードし、Wedge をそのデフォルト設定にリセットしま
す。
Open
―ダイアログボックスが開き、以前にセーブされている Wedge 設定ファイルの選択を可能にし
ます。
Save
―既存の Wedge 設定ファイルに対する変更をセーブします。
Save As
―ダイアログボックスを開き、既存の設定に固有のファイル名をつけてセーブします。
Exit
―Wedge の終了
Software Wedge 設定ファイル
Software Wedge を、特定のシリアル機器及び特定のアプリケーション・プログラム使用用に設定する場合、
既存設定を後に又再ロードできるようにディスクファイルにセーブして下さい。設定をディスクファイルにセー
ブしておけば、又設定を新たにし直す必要はなくなります。次回 Wedge を特定の機器で使わなければなら
ない時は、単に Wedge を走らせ、以前にセーブした設定ファイルを開き、Wedge を起動させるだけです。こ
れで、Wedge を使う度に設定しなければならない面倒を回避出来ます。
”File” メニュー中の最初の4つのオプションは、設定ファイルをセーブしたり、ロードしたりする為のもので
す。
6
特定設定ファイルでのWedgeの自動起動
Software Wedge は次のシンタックスを使い、1つのオプショナルのコマンドライン引数をサポートしています:
WinWedge.exe.filename で、そのファイルネームは以前にセーブされた Software Wedge 設定ファイルの事
です。
ファイルネームが,Wedge を立ち上げるために使うコマンドライン上で示されると、その指定の設定ファイルが
ロードされ、Wedge はその設定を使い自動的に Wedge 自身を起動させます。ファイルネームは、有効な
Software Wedge 設定ファイルの名前でなくてはならず、ファイルネーム拡張子が付き、又ドライブやファイ
ル用のダイレクトリ・パスを持った完全なファイルでなければいけません。
ファイルネーム拡張子 ”SW1” は、すべての Software Wedge 標準版設定ファイルに対するデフォルト・フ
ァイルネーム拡張子です。Wedge インストレーション・プログラム (SETUP.EXE) は、ファイルネーム拡張
子 ”SW1” と,実行可能なプログラム ”WinWedge.exe. ” との間の関連付けを自動的に行います。これ
で Software Wedge 設定ファイルを立ち上げることが可能になり、このファイルはファイルネーム拡張子 ”
SW1” を持っており、設定ファイルを開き・Wedge を起動してという Wedge 立ち上げプロセスを経ることなく
直接立ち上げることが出来ます。
例えば、Wedge 用に設定ファイルを作り・セーブして、ファイルマネジャー又は Windows エクスプローラの中
の設定ファイルネーム上でダブルクリックするだけで、Windows は自動的に Software Wedge を立ち上げ、
選択された設定を使い起動させます。
Windows 立ち上げ時の Wedge 自動起動
Windows 立ち上げ時に、特定の設定ファイルで Software Wedge を自動的にロードし起動するには、
Windows ファイルマネジャーを開き、Software Wedge 設定ファイルを選択、そのファイルをプログラムマネ
ジャーにドラッグし、”Startup”プログラムグループに落とし込むと、Software Wedge プログラムのアイコンが
Startup グループの中に表示されます。これで、Windows を立ち上げるときはいつでも Wedge が自動的にロ
ードされ、選択した設定ファイルで起動するようになります。
Windows95では、エクスプローラを開き、セーブされた Software Wedge 設定ファイル選択、その設定ファ
イルを ”Startup” のフォルダにドラッグし・落とし込むことで、同じ機能を実行できます。”Startup” フォル
ダは通常、”Win95” 又は ”Windows” フォルダのどちらかにある ”Start Menu” フォルダ内の
”Programs” フォルダ内にあります。
7
モードメニュー
Software Wedge は2つのモードのうちの1つで作動し、そのモードがシリアル機器から入力されるデータを他
のアプリケーションプログラムに転送する方法を指定しています。Wedge はデータをキーストロークに変換し、
そのキーストロークを直接他のアプリケーション送り、データを転送するか、又はダイナミック・データ・エクスチ
ェンジ(DDE)を使い、DDE をサポートしているアプリケーションにデータをパスするかのどちらかです。アプリケ
ーションが DDE をサポートしているかどうかを知るには、メインメニュー中の ”Paste Link” 又は ”Paste
Special” コマンドで解ります。これらは通常は ”Edit” メニュー中のオプションです。
Mode メニューの中では2つの選択ができます。それは ”Send Keystrokes To….” 及び ”DDE Server”
のいずれかで、これは入力されるデータを直接他の Windows アプリケーション・プログラムに転送することを
可能にするものです。この2つのモードはそれぞれに固有の利点があり、どちらのモードを使うかという選択は、
データを送ろうとするアプリケーションプログラムの能力によります。もし、そのアプリケーションが DDE をサポ
ートしていなければ ”Send Keystroke” を選択したほうがいいでしょう。
11 ページのキーストローク送信とダイナミックデータ・エクスチェンジの項をご参照下さい。
キーストローク・モード送信
”Send Keystroke Mode”中では、Software Wedge が入力シリアルデータをキーストロ-クに変換して、そ
れらのキーストロークを指定されたアプリケーションに直接送ります。
バーコードリーダーや電子秤及びゲージやメーターのような計測器などのシンプルな機器で Wedge を使う場
合、”Send Keystroke Mode”が一番便利です。
モードメニューから ”Send Keystrokes To…” を開くと、ダイアログボックスが表示されます。そのダイアロ
グボックスで、キーストロークデータを受け取るべきアプリケーション・プログラムを指定します。Software
Wedge は、キーストロークをウインドウズにあるノートパッドに送るようにあらかじめ設定されていますが、これは
どのアプリケーションにでも送れるように変更が可能です。アプリケーションのタイトルバーテキスト(プログラ
ム・メインメニューのタイトルバー中にある)を開くか、又はウインドウズでプログラムを立ち上げるために使うコ
マンドラインを指定するかのいずれかで出来ます。タイトルバー・テキストだけを指定する場合は、アプリケー
ションはアイコンとしてランしているか又は Wedge がデータを送る前のウインドウズ下でランしているかでなか
ればならず、アプリケーションのコマンドラインのみを特定すると、データを送る前に、Wedge が自動的にアプ
8
リケーションを立ち上げます。
”Send Keystrokes” モード下で Software Wedge を起動した後、シリアル機器からデータが受信した場合
は常に Wedge がデータを指定されたアプリケーションに送ろうとします。
Wedge のロジックは、先ず指定されたタイトルバー・テキストでアプリケーションをサーチし、もし既にそのアプリ
ケーションがランしている場合、Wedge がそのアプリケーションを起動してキーストロークをアプリケーションに
送る前に、そのアプリケーションは入力フォーカスを持つことになります。指定されたタイトルバー・テキストの
画面が見つからないとき、又はタイトルバー・テキストを指定していない時は、Wedge は指定されたコマンドラ
インを使いプログラムをランさせようとします。これがうまくいったら、次に Software Wedge は、そのプログラ
ム作動開始後、アプリケーションからタイトルバー・テキストを検索し、そのアプリケーションの画面を探し出し
ます。
タイトルバー・テキストを指定した場合、完全なタイトル名を入力する必要はなく、テキストのサブ・ストリングを
使うことが出来ます。例えば、データをMicrosoft・エクセルに送るには、タイトルバーテキストに ”Excel”
と特定するだけです。タイトルバーに ”Excel” を含んだプログラムは他に何もランしていない限り、Wedge は
エクセルの画面を間違いなく見つけることが出来るはずです。タイトルバーテキスト及びコマンドラインの両方
を、上又は下のコラム内で指定できます。
注記: コマンドライン又は画面のタイトルバーテキストを指定しないと、Wedge はシリアル機器からデータが
入力されてきた場合、アプリケーションが入力フォーカスを持っているがどうかに関係なく、どんなア
プリケーションにもキーストロークを送ります。言い換えれば、Wedge が2つ目のキーボードのようにな
るという事です。この場合、カーソルがどこにあろうと、アプリケーションがフォーカスを持っているか否
かに関係なくデータ入力が可能故、Wedge をこのような使い方をしがちです。もし、Wedge 自身がフ
ォーカスを持っていれば、データが入力された時、Wedge はデータを他のプログラムに送ろうとせず、
単にデータを表示するだけになるでしょう。
テック・チップ
Windows のアプリケーションのあるものは、同じタイトルバーテキストで1種類以上の画面を持っているものが
あります。従って、Wedge がキーストロークを送るべき正しい画面を必ずしも常に発見できるとは限りません。
正しいアプリケーション・タイトルバー・テキスト又はコマンドラインを間違いなく指定したにも拘わらず、Wedge
がキーストロークをそのアプリケーションに送ることが出来ない場合、これらを一旦消去し、Wedge を起動して、
入力フォーカスを立ち上げるか、又は Wedge がデータを送ろうとするアプリケーションにスイッチし、カーソル
を、データを入力しようとする場所に持ってきて下さい。
9
DDEサーバーモード
Wedge が DDE サーバーモードにある時は、Wedge は、 入力シリアルデータをキーストロークとして他のアプ
リケーションに送る替わりに、DDE をサポートしている他のウィンドウズのアプリケーションが、入力データを
DDE リンクを通して取り込むことを可能にします。Mode Menu から ”DDE Server” を開くと、DDE アプリケー
ションネームと DDE トピックを入力するダイアログボックスが表示されます。Wedge は又、シリアルデータを他
のアプリケーションにパスするだけではなく、機器からの各入力を受信した後に、他のプログラムに DDE コマン
ドを出すように設定することも可能です。DDE コマンドは、Wedge からデータを受信しているプログラムに、マク
ロやサブ・ルーティンをランさせたり、又はチャートやグラフをアップデートさせたりする場合にも使われます。
このダイアログボックス中で入力する情報は、そのコマンドが送られるアプリケーションの為に、DDE コマンドプ
ロセッサを確認する為に用いられます。
注記:この情報は、Wedge を設定して、DDE コマンドをアプリケーションに送ろうとする場合にのみ必要です。
そうでない場合、このダイアログボックスは消去して下さい。
25 ページの DDE コマンド設定(DDE Server Mode)の項もご参照下さい。
デフォルト・DDE アプリケーション・ネームは ”Excel” で、デフォルト DDE トピックは ”System” です。これら
は Microsoft Excel 用の正しいパラメータです。Microsoft Word 用 DDE アプリケーション・ネームは
”WinWord”で、DDE Topic は又 ”System” です。MS Asccess 用は ”MSAccess” で DDE トピックは
Open Access Database です。他のアプリケーションの DDE コマンドプロセッサを見たい場合、オンラインヘル
プをご参照下さい。
注記:DDE コマンドをサポートするアプリケーションでは、アプリケーションの実行ファイルネームを普通、DDE
アプリケーションのネームとして使い、DDE トピックを ”System” と呼ぶことも普通に行われています。
10
キーストローク送信とダイナミック・データ・エクスチェンジ
DDE を使いデータをパスするより、キーストロークを他のアプリケーションに送るように設定する方が簡単であ
り、それが主たる利点です。キーストロークを送るために、データを受信するアプリケーションに特別なプログ
ラムは不要です。例えば、データをスプレッドシートに読む込むときに必要な事は、機器から読み取りデータ
が継続的に入力され、それがスプレッド・シートのコラムに表示される事です。キーストロークを送ることで、
Wedge を簡単に設定できます、つまり機器からの各入力データの後に ”Enter” 又は ”Down Arrow” の
キーストロークを送り、カーソルを1セル下に移動させると、次の入力をいつでも受け入れできる状態になりま
す。
24 ページのキーストローク設定(キーストローク・モード送信)の項もご参照下さい。
マイナーですが、キーストローク送信の不便な点は、データを受信しているアプリケーションはフォアグラウンド
にあって、Wedge がキーストロークをそのアプリケーションに送る時には、入力フォーカスを有していなければ
なりません、そうするとキーストロークを送る時は、バックグラウンド処理が出来ないという点にあります。ひと
つのアプリケーションから、他のアプリケーションへのキーストローク送信は、DDE を使うよりやや遅くなります。
一方、DDE では、受信アプリケーションが入力フォーカスを持つ必要はなく、すべてのデータ・トランスファー
は、フォアグラウンドで他のプログラムを動かしている間に、バックグラウンドで行われます。DDE で困ることの
1つは、Wedge からの(又は他の DDE サーバーからの)”Linked ”データは、常にお客様のアプリケーション
中の同じ位置にトランスファーされるという点です。スプレッドシートのコラム中に、連続したデータ読み込みを
受けるには、スプレッドシート中に入力を受信したら自動的にランするマクロを持たなければなりません。その
マクロの目的は、Wedge からのデータを即要求するか、又はリンクしたセルからの各新しいデータをコピーし
て、スプレッドシート中のコラムの下の部分に貼り付けるかのいずれかにあります。これを行う1つの方法は、
Software Wedge が、各入力の後に、スプレッドシートがマクロをランさせるような DDE コマンドを出すようにす
ることで、そのマクロがデータを要求するか又はリンク DDE データをコラム中にコピーします。
DDE の強力な機能は、DDE をサポートするアプリケーションがお互いに直接コマンドを送る事が出来、そのア
プリケーションと Software Wedge 間でのデータ収集処理が完全自動化出来るという点です。この為には、
アプリケーション中にプログラムがいくつか必要ですが、このプログラムを準備することで、非常に高度な機器
インターフェイスを構築することが可能となり、又すべての DDE オペレーションは、バックグラウンドで行われ
る為、1つのアプリケーションから他のアプリケーションにキーストロークを送るよりはるかに早く実行できます。
注記:Software Wedge は、自身のどんな DDE コマンド受け取り・プロセスする為にも”DDE Server Mode”
である必要はありません。Wedge は、たとえ ”Send Keystroke Mode” にあっても、DDE コマンド
を実行できます。この事は、Wedge が入力してくるデータをキーストロークとしてお手許のアプリケー
ションに送り返している間も、他のプログラムから Wedge へ DDE コマンドを送ることで、Wedge はシリ
アルポート通してのデータ送信の制御が可能と言うことです。
11
ポートメニュー
3つのオプションのポートメニューとその内容は下記の通りです。
Setting:
すべてのシリアルコミュニケーション・パラメータを選択するための(シリアルポート、ボーレ
ート、パリティ、データビット数、フローコン、トロール、ブザーサイズ等)ダイアログボックスを
表示します。
Analyze:
このオプションは、すべてのシリアルコミュニケーション・パラメータをテストし、シリアル機
器から受信したデータの構造・内容を一覧、分析する為のダイアログボックスを開きます。
この分析機能は、受信データの構造・内容を決定するのと同様に、お客様の PC とシリア
ル機器間のコミュニケーションリンクのテストに極めて有用です。Wedge を起動させる前
に、この機能を使い、Software Wedge とお客様の機器との間のコミュニケーションクリン
クをテストされることを強くお勧めします。
Beep On Input:
このオプションは、データを受信し、他のアプリケーションプログラムに転送しようとするとき
に、PC のスピーカーを鳴らすためのスイッチです。このオプションを開き、On/Off をトグル
し、”ON” にチェックマークを表示して下さい。
注記:Software Wedge は、コミュニケーションエラーが発生したら常にビープ音を鳴らします。これは、パリテ
ィエラー、フレーミングエラー、バッファオーバーランの時も同様です。もし、この ”Beep On Input” オ
プションにチェックマークがされていないのに PC が Wedge からデータを受信した時、ビープが鳴る場
合、考えられる原因は Wedge とシリアル機器との間でのコミュニケーションパラメータのミスマッチです。
なぜならば、Wedge はすべてのキャラクタを、コミュニケーションエラーが発生したときでも、有効なデ
ータとして扱うからで、コミュニケーション・パラメータにミスマッチがあっても、データを、正しいものであ
るかのように受信することもあり得ます(ビープ音が鳴り続ける場合、Wedge の設定が間違っている場
合です)。
12
ポートセッティング・ダイアログボックス
ポートセッティング・ダイアログボックスで、お使いの機器に必要なシリアル・コミュニケーション・パラメータを
選択することが出来ます。すべてのパラメータは、お使いのシリアル機器設定に正しくマッチしていなければ
なりません。
注記:ポートセッティング・ダイアログボックスで選択されたボーレート、パリティ、データビット及びストップビッ
ト値は常に、ウィンドウズ・コントロールパネルの ”Port” からセットされたこれらのどんなパラメータ
値より優先します。従って、コントロールパネルでこれらのパラメータをセットする必要はありません。
ポートセッティング・ダイアログボックスにあるバッファーサイズ・オプションで、受信バッファのサイズを指定す
ることが可能で、この値は 128 から 32000 バイトの範囲です。デフォルト・バッファサイズは 512 バイトですが、
ほとんどの簡単な機器はこれで充分です。フローコントロールなしに多量のデータの入力が必要な場合、デ
ータの紛失を避けるには、バッファサイズを増やしておかなければならないでしょう。
Software Wedge は、”Opto-RS”オプションと同様に、標準ソフトウエア(Xon/Xoff)及びハードウエア
(RTS/CTS)フローコントロールの両方をサポートしています。
Opto-RS オプションは、Wedge に計測器の Trimos-Sylvac ラインとの互換性を持たせる為に準備されたも
ので、これらの機器には、RTS ラインを低く保持するのに必要な特殊な光ケーブルインターフェイスが使われ
ています。
注記:Software Wedge は COM9 までをサポートしていますが、ウインドウズ 3.x は COM1 から COM4 をサポ
ートしているだけです。COM5 及びそれ以上にアクセスするには、使用しようとするシリアルアダプタのメ
ーカーが供給する特殊な COM ドライバが必要です。
13
ポート分析メニューオプション
このオプションは、ポートセッティング・ダイアログボックスで設定したシリアルポートセッティングをテストする為
のダイアログボックスを表示します。”Port Analyze” ダイアログボックスでは、シリアル機器から受信したデ
ータを一覧又は分析することが出来、この機能は、お客様が特定のアプリケーション用に Wedge を設定する
時に非常に役に立ちます。このオプションを開き、ポートセッティング・ダイアログボックスで選択したシリアル
ポートが使える状態であれば、下記のボックスが表示されます。
”Port Analyze” ダイアログボックスのタイトルバーは、現在アクティブになっているコミュニケーション・パラメ
ータを示しています(この場合、シリアルポート、ボーレート、パリティ、データビット、ストップビットです)。
”Input Buffer” テキストボックスは、シリアル機器から受信したすべてのキャラクタを表示し、キャラクタは表
示可能な ASCII キャラクタを用いて表され、又挿入されているコントロールコードも表示されます(キャリッジリ
ターンは音符で、ASCII は笑い顔で表示される等です)。インプットバッファ中のキャラクタの意味を判読し、
”Output” テキストボックスに入れるべきキャラクタを選択する手助けとして ASCII チャートが利用できます。
”Input Buffer” テキストボックスのすぐ上の右側に、”Total Byte Count” という名前のコラムがありますが、
ここにはインプットバッファにあるすべてのキャラクタの数が示されます。
”Clear Input” ボタンは、インプットバッファ中のデータをすべて消去し、トータルバイトカウントをゼロにリセット
する時に使います。Software Wedge の標準版にあるインプットバッファ・テキストボックスは一度に最高
255のキャラクタを表示できます。
14
自動分析機能は、Software Wedge がインプット・データレコードの構造を描き出すものです。シリアルデータ
の解析と振り分けが出来るように、Wedge を設定することも可能ですが、そのためにはまず、データの構造が
どうなっているかを知ることが必要です。インプットバッファ中にデータがある時に ”Analyze” ボタンを押す
と、Software Wedge が大まかなデータレコード構造を提示して、そのレコード構造を使い Wedge に、自動分
析機能を事前設定にするかを問い合わせてきます。
注記:自動分析機能は、必ずしもその処理能力が優れているとはいえないので、Software Wedge を事前
設定には使わない方がいいかもしれません。インプットレコード構造は、必要な場合、どんな方法でで
も、いつでも自由に決めることが出来ます。
17 ページ、インプットデータ・レコード構造設定の項も、ご参照下さい。
インプットバッファ中のデータを一覧する時は、データのどの部分を見たいかは、マウス又はカーソルコントロ
ールキーを使って選択出来ます。この場合、インプットバッファ中に選択したキャラクタの開始バイト位置
が、”Start Position” の欄に、選択したデータのバイト数が ”Byte Count” の欄に表示されます。この機
能で、インプットデータ中の特定のデータフィールドの長さ計測が出来ます。
インプットバッファからのデータを、ウインドウズのクリップボードにコピーするには、コピーしたいデータを選択し、
コントロール(Ctrl)キーを押したままで、インサート(Insert)キーを押して下さい。
”Output” と書かれたフレームの中に、テキストボックスと ”ASCII Chart”, ”Send”, ”DTR~”という3つの
ボタンがあります。テキストボックスはアウトプット・バッファで、そこでシリアル機器に送るテキストを入力でき
ます。多くの機器は、それらにコマンド・ストリングやコントロール・コードを送り、データ読み取りを要求すると
いったようなことは可能です。データをタイプし、アウトプット・テキストボックス内で直接で編集することも出
来ますし、ASCII チャートから特定のキャラクタや、アウトプット・テキストボックスに入れるべきコントロールコ
ードを選択することも出来ます。その ASCII チャートを開くには ”ASCII Chart” ボタンを押して下さい。アウ
トプットバッファー・テキストボックスにあるデータを送るには、”Send” ボタン上をマウスでクリックして下さい。
アウトプットバッファをクリアにするには、アウトプット・テキストボックス中のすべてのテキストをマウス又はコン
トロール(Ctrl)キーで選択し、Delete キーを押して下さい。
”DTR~”と書かれたボタンは、Data Terminal Ready Line Toggle ボタンのことで、このボタンを押すと、シリア
ルポート DTR ラインを約100ms の間、切断します。シリアル機器のあるものは DTR ラインのトグルを、データ
の要求だと解釈するものもあります。Sylvac ブランドのカリパスやゲージは、DTR ラインのトグリングを、機器を
データ読み取りのために起動させる1つの方法として使っています。
注記:Analyze 画面にデータ入力中にビープ音がなる場合、それは使用しているシリアルコミュニケーション
パラメータが間違っているからです。
15
ディファインメニュー
DEFINE メニュー中の3つのオプションとその機能は以下の通りです。
Input Date Record Structure
シリアル機器から受信するデータの基本構造を設定する為のいくつかのダイアログボックスを表示します。そ
のダイアログボックスでは、Wedge が、入力されるデータを他のアプリケーションに転送する前に、分析し・ふ
るいわけを行う方法を設定することも出来ます。入力データレコード構造を設定する時に、各入力フィールド
にデータやキーストロークを追加したり、各フィールドの入力の際に出される DDE コマンドを特定することも可
能です。17 ページのインプツト・データ・レコード構造設定の項もご参照下さい。
Translation Table
オプションの Translation Table を開き、Software Wedge がキーストローク送信モードの時に、キャラクタをキ
ーストロークに転換するか、又は DDE サーバーモードになっている時に、キャラクタを他のキャラクタに転換
する為の Translation Table を表示します。
転換は、Wedge が入力されるデータレコードを分析し・ふるいわけを行った後、そのデータを他のアプリケー
ションに転送する直前に行なわれます。30 ページの変換表の項もご参照下さい。
Serial Output Strings
Serial Output Strings オプションは、Software Wedge がシリアル機器に戻すべきキャラクタ・ストリングをあら
かじめ設定しておくための画面を開きます。アウトプットストリングのあるものは、最大 20 までの ”Button
Controlled” アウトプットストリングや1つの ”Timer Controlled” アウトプットストリングのように設定すること
が出来ます。31 ページのシリアルアウトプット・ストリング設定の項もご参照下さい。
16
インプットデータ・レコード構造設定
ほとんどの機器は、ある程度事前設定されたレコード構造の形で、データを伝送し、そのレコードには1つ又
は複数のパート、又はデータフィールドを含んでいます。Software Wedge は、お客様固有の機器からのデ
ータの構造や、データのどの部分がお客様のアプリケーションにとって重要か・どの部分は無視していいかを
決定する方法を持っていませんので、Wedge を起動する前に、先ずこれらのパラメータを決めねばなりませ
ん。”DEFINE” メニュー中の Input Data Record Structure オプションは、データを他のアプリケーションに
送る前に、先ずお客様のデータのレコード構造を決め、そして Wedge が各レコード内の個々のデータフィー
ルドを分析し・ふるいわける方法を設定します。又このオプションで、日付や時間、カーソル・ナビゲーション・
キーストローク又はデータに対する DDE コマンドを追加することが可能です。インプット・データレコード構造を
設定するには、各データレコード終わりを示すイベントで始まるいくつかの基本的なディスクリプターを決めな
ければなりません。”DEFINE” メニューから Input Data Record Structure を開くと、下記のダイアログボック
スが表示されます。
17
レコード終端表示
”The End Of Record Event” オプションで、各インプットデータ・レコードの終端示すイベントを選択すること
が出来ます。Software Wedge はその選択された End Of Record Event が現れるまでは、いかなるデータも
他のアプリケーションには転送しません。
従って、各シリアルデータレコードの終わりを、常に間違いなく指示する End Of Record Event を選択する必
要があります。
もし各データレコードがキャリッジ・リターン又はキャリッジリターン・ラインフィードで終わるのであれば、オプショ
ンで ”Carriage Return 又 Crlf Received” を選択しなければなりません。
注記:このオプションを選択すると、キャリッジリターンやラインフィード・キャラクタは、インプットデータから自
動的に除外されます。
入力されてくるシリアルデータは、必ずしも決まった長さのストリングで伝送されてくるとは限りません。又各デ
ータレコードの終わりにキャリッジリターンはないが、データがインプットとインプットの間に常に時間のずれがあ
るバーストで送られてくる場合は、Time Delay Between Records を選択しなければなりません。
多くのタイプのバーコードスキャナは、この方法でデータを伝送します。
このオプションを選んだら、新しいデータレコードの着信と、次のデータの着信までの時間の間隔の最小値
(1/18 秒刻み)を入力しなければなりません。この場合、あり得る最も少ない時間のずれを設定し、それでイ
ンプットデータ・レコードの終端部を正確に把握します。このように ”Time Delay Between Records” オプ
ションを選択すると、Wedge が、すべてのシリアルデータを、シリアルポートに入ってくるデータがなくなるまで、
読み込むことが出来るようになり、この設定した時間のずれをオーバーしたら、すべてのデータレコードの受
信完了と判断します。
注記:時間のずれをあまり大きな値で設定すると、2つ又は3つの別々のインプットが1つの長いインプットとし
て解釈されるという事も起きるというリスクがあります。
Windows に組み込まれている時計は、常に正確というわけではありませんので、インプット間の時間ずれとし
て設定した値テストしてみる必要があります。バーコードや磁気ストライプリーダーなどの簡単な機器の場合、
ほとんどの場合は3クロックチックのデフォルト値で、充分です。
18
機器から伝送されるデータレコードが、常に1つ又はそれ以上の決まった長さのデータフィールドの決まった
バイト数で構成されている場合、オプションは ”Fixed Number Of Byte Received” を選択して下さい。この
オプションを選ぶと下記ダイアログが表示されますのでデータレコードの絶対レコード長を入力して下さい。
14 ページの、ポート分析メニュー・オプションの項もご参照下さい。
19
Carriage Return 又は Crlf Received あるいは Time Delay Between Rrecords のいずれかを End Of Record
Event として選択した場合、下記のダイアログボックスでデータの為の ”record structure” を選択しなけれ
ばなりません。
3つのあり得るレコード構造およびその個々の意味は次の通りです。
Single Field Data Records
Single Field Data Record とは、個々のデータレコードは単一のデータのまとまりとして扱われ、そのデータにつ
いては解析を行う必要がないレコードであるという意味です。
注記:1つのシングル・データフィールドの最大長は 255 バイトです。
注記:シリアル機器の中には、非常に複雑で・規則性がなく、Software Wedge で解析して、いくつかのフィー
ルドに分割しなければいけないような出力を行うものがあります。
この種の機器の場合、機器からのすべての出力を1つのシングル・データフィールドとして設定し、アプリケー
ション能力(例えば、エクセルの場合のマクロ言語のような)を活用して、Wedge より受信されるデータを解析
する方がより容易です。
11ページ、キーストローク送信とダイナミックデータ・エクスチェンジの項もご参照ください。
20
Multiple Delimited Data Fields
The Multiple Delimited Data Field レコード構造とは、2つ又はそれ以上のフィールドからなるデータレコードで、
各レコード内で区切り文字の位置に基づいて解析しなければいけないようなデータです。例えば、データレコ
ード:1,90,123.19,98765<Cr>は、コンマで区切られた4つのフィールドと、レコードの最後にあるキャリッジ・リ
ターンからなっています。
このオプションを選択したら、下記のダイアログボックスで、データフィールドを分ける為に用いる区切り文字
及び、1つのシングルデータレコードに含まれるデータフィールドの最大数を設定しなければなりません。
Software Wedge は最大40までのデータフィールドを持っているデータレコードまでをサポートしています。1
つのレコードで、その設定した数以上のフィールドを受信した場合、そのオーバーした部分のデータは切り捨
てられます。受信したフィールドの数が、設定数以下の場合、その残りのフィールドの部分は空のままです。
17 ページの、インプットデータ・レコード構造設定の項もご参照ください。
注記:Multiple Delimited Data Field オプションが選択されていると、全ての区切り文字は、入力データからは
除外され、各データフィールド部分としては表示されません。
Multiple Fixed Length Data Fields
各データフィールドの長さに基づいてデータレコードを解析する必要がある場合、レコード構造として、Multiple
Fixed Length data Fields を選択しなければなりません。
このオプションを使うと、各データフィールドに含まれる正確な長さ(キャラクタ数)を後で設定することが出来
ます。このオプションは、常に各データフィールドが決まったバイト数を含んでいるような場合にのみ、使いま
す。End of Record Event として ”Fixed Number of Bytes Received” を選択したときは、このオプション
がデフォルトです。
21
Specifying Filters and Field Lengths
End of Record Event を設定し、シリアル機器から伝送されてくるデータの基本的レコード構造を選択した
ら、”Input Record Definition Editor” ダイアログボックスが表示されます。このダイアログボックスは、各デ
ータフィールドに適用するフィルタや決まった長さのフィールドに対し、各フィールドのインプットの長さを設定
するものです。
又このダイアログボックスで、record Preamble や field Postamble を設定することが可能で、これらはデータ
転送用に選択するモードによって、その果たす機能は異なります。
キーストローク送信モード下では、record Preamble 及び field Postamble は、各データフィールドが他のプロ
グラムに送られる前又は後に出される追加のキーストロークです。
DDE サーバーモード中では、始点及び終点は DDE コマンドであり、メニューモードから “DDE Server” を開
いたとき、DDE Command Target Application として設定したアプリケーションに対して出されるものです。
下記の項も参照下さい。
24 ページ:Pre/Postamble キーストローク設定(キーストローク送信モード)
10 ページ:DDE サーバーモード
25 ページ:DDE コマンド設定 (DDE サーバーモード)
注記:Input Record Definition Editor 画面中には、いくつかのコントロールつまみが表示されていません、あ
るいは選択されたレコード構造、又は選択されたデータ転送モードによっては下記の例とは異なるボタ
ン表示になっている場合もあります。
22
ダイアログボックスの下半分は、インプットレコード中の各データフィールドに適用される ”Input Filter” を設
定するためのものです。各データフィールドが決まったバイト数で構成されているような場合、フィールド
”Length” も設定しなければなりません。
”Field”のタイトルついた所は、現在のデータフィールドの数を示しており、そのフィールドに対してフィルタ、長
さ、及び Field Postamble を設定します。
データレコードが1つ又はそれ以上のデータフィールドからなっている場合、ダイアログボックス中に ”Next
Field” と “Previous Field” の2つのボタンが表示されます。これらのボタンは、各データフィールドに対
するパラメータで前後にスクロールさせて使います。
フィルタの選択
各データフィールドに適用される ”Filter” には、None, Ignore 及び Numeric の3つの選択があります。
None は、現在のフィールド用のデータには、フィルタが適用されないという意味で、全てのキャラクタを受信、
受け入れられることになります。
Numeric は、全てのアルファベット文字やコントロールコードにはフィルタがかけられフィルタを通さず有効な
データとして受け取られるのは、0123456789-のみということです。Numeric フィルタは,数値をスプレッドシ
ートに読み込む際に特に有用です。リーディングスペースや非数字文字は、データがラベルとして解釈され
ることにもなります。
Ignore フィルタを選択すると、データは受け取られず、全てのフィールドは切り捨てられます。このフィルタは、
アプリケーションが必要としないデータフィールドを無視し取り除く為に使われます。
フィールド長の設定
”Length” のテキストボックスは、1つの特定のフィールドに対して受信される正確なデータバイト数をこのボ
ックスで設定する為です。このテキストボックスは、”End Of Record Event” として ”Fixed Number of
Bytes Received” か、又はレコード構造として ”Multiple Fixed Length Dat Field” のいずれかを選択し
た場合にのみ表示されます。フィールドの長さはこのようにして、インプットレコードにある個々のデータフィー
ルドの正確なバイト数を設定します。フィールドの長さは 1 から 255 バイトの範囲です。”End Of Record
Event” として ”Fixed Number of Bytes Received” を選択すると、入力される全フィールドの長さの総
計は、前の項で設定した ”Input Data Record Length” の合計に等しくなるはずです。
Input Record Definition Editor 画面の左・中ほどにある( ”Bytes Defined” というラベルの)2つのボックス
は、データレコードのレコードの長さの合計と同じくすべての設定されたフィールドの長さの合計を表示します。
この情報は、End Of Record Event が ”Fixed Number of Bytes Received” の場合にのみ表示されま
す。
23
Pre/Postamble キーストローク設定 (キーストローク送信モード)
Software Wedge がキーストローク送信モードの時、Input Record Definition Editor 画面には ”Record
Preamble Keystroke” というタイトルのテキストボックスが表示されます。インプットデータフィールドに関連
している ”Field Postamble Keystrokes” を設定することも出来ます。Preamble と Postamble キーストロ
ークは、各データフィールドが他のウインドウズのアプリケーションに送られる前又は後に、Wedge が出す追加
のキーストロークです。それらのキーストロークは、特にカーソルナビゲーションキーストロークをアプリケーショ
ンに送り、シリアルデータが送られるべきところに送られるようにするものです。
”Record Preamble Keystroke” は、シリアル機器からの最初のデータフィールドがアプリケーションプログ
ラムに転送される直前に出されるキーストロークです。例えば、preamble キーストロークで、最初のデータフィ
ールドがアプリケーションに転送される直前にそのアプリケーション中の特定の位置に、カーソルを動かすこと
が出来ます。
”Field Postamble Keystroke” は、個々のデータフィールドに対しそのデータと一緒に出されるキーストロ
ークで、通常キーストロークデータを受信しているアプリケーションの場所を教える為に使われます。例えば、
機器からスプレッドシートに送り込まれるデータを読み取りたい場合及び、連続した読み取りを、1つのコラム
に入力させたい場合、{DOWN}矢印キープレスからなる Field Postamble Keystroke を設定する事が出来ま
す。これにより、機器からのデータ読み取りが終わったら、スプレッドシート中でカーソルを下のセルに動かし
ます。キーボード上で、マニュアルタイプでデータを入力するとき使うキーボードのように、Record preamble
や Field Postamble キーストロークを設定するものです。
Record preamble や Field Postamble キーストロークを設定するときは、45ページのキーストローク・マクロル
ールの項にあるルールに従って下さい。
preamble や postamble キーストロークを編集するときは、Keystroke List と書かれているボタンで、個々の
キーストロークをメニューから選択することが出来ます。キーストロークリスト中のすべてのキーストローク
は,Software Wedge keystroke Macro Rule に準じたものです。Keystroke List に従ってキーストロークを入
力するには、Record Preamble 又は Field Postamble Keystrokes テキストボックス中のいずれかで、マウスを
クリックし、”Keystroke List”ボタンをクリックして下さい。キーストロークリストが表示されたらリスト中で、求め
るキーストロークのところまでスクロールし、OK ボタンをクリックして下さい。Preamble や Postamble キースト
ロークを設定するときは、いくつのキーストロークでも希望するだけ入力することが出来ます。
Preamble や Postamble キーストローク・マクロには、日付・時間のスタンプ機能も入っています。
24
DDEコマンド設定 (DDE サーバーモード)
DDE サーバーモード中で Software Wedge を使うときは、下記のような Input Record Definition Editor 画
面が表示されます。
上記のダイアログボックス中のすべてのコントロールは、Record Preamble Keystroke および Field Postamble
Keystrokes をサポートする代わりに、ダイアログボックスで Record Preamble DDE Command 及び Field
Postamble DDE Command を入力することが出来るという点を除けば、Wedge が ”Send Keystroke
Mode”にある場合と同じです。DDE をサポートするほとんどのアプリケーションは、他のアプリケーションプログ
ラムで使用できるコマンドで構成されている DDE Command 言語をもサポートしています。これらのコマンドは
特定のアプリケーションに固有のもので、その内容はオンラインヘルプをご参照下さい。
例えば、エクセルでは、DDE コマンドの幅広い選択が可能で、それらは他の Windows のアプリケーションにも
対応しています。事実、エクセルは Excel Function Reference 中にリストされている機能名のすべてを、有効
な DDE コマンドとして有しています。
エクセルは、”RUN(reference) ” と呼ばれる機能をサポートしており、それはエクセルマクロシート中で(シ
ート中ではマクロ又はサブルーチンは、”Reference” の名前で引用されている)説明されているどんなマクロ
又は VBA サブルーチンでもランさせるために使用できます。MySub という名前のエクセル VBA サブルーチ
ンを創り、[RUN(“MySub”)]のコマンドを入力すると、フィールドに対するデータが Wedge から DEE 経由でエ
クセルに転送された後、すぐにサブルーチンの ”MySub” を実行します。
MicroSoftエクセルのようなプログラムと一緒に用いると、このコンセプトは非常に強力となります。Visual
Basic を含むすべてのエクセル・マクロ言語が使用でき、Wedge から受信するデータ上でほとんどすべての
オペーレーションが実行可能になり、これはチャートやグラフ機能、受信データに基づいた計算機能、又は
25
論理意思決定も可能であるという事でもあります。
最初のデータフィールドがアプリケーションに転送される直前に、設定された”Record Preamble DDE
Command”が出され、特定のフィールド用データ DDE 経由でアプリケーションに転送された直後には、“Field
Postamble DDE Command” が出されます。
ここでの主要なコンセプトは、新しいデータレコードをシリアルポートでつながった機器から受信した時に、
Wedge が他のアプリケーション・プログラムにコマンドを出すように設定することにあります。ほとんどすべての
場合、設定した最終のデータフィールドの後で DDE コマンドのシグナルを、他のアプリケーションに送るだけで
す。従ってここでの目標は、他のアプリケーションが、Wedge からのデータ先ず引っ張ってきて、そして、その
データで何かが出来るようにすることです。DDE コマンドを送るということは、単に
他のアプリケーションに新しいデータがあり、そのデータが次の新しいデータで書き換えられる前に、そのデー
タで何かをした方がいいのではないかということを知らせしめる手段の1つです。
DDE をサポートしている多くのアプリケーションは、新しいデータが、送信するための特別なコマンドが不要な
DDE 会話の形で、サーバーから受信される場合は、ある意味では
アプリケーションをプログラムする為の方法の1つを提供していることにもなります。
例えば、エクセルは2つの機能、”OnData( ) ” と ”SetLinkOnData( ) ” をサポートしており、これは、DDE
サーバーから新しいデータを受信したら常に、エクセルが特定のマクロを自動的にランさせるようにするため
のものです。
もう1つの例としては、Wedge からのデータフィールドを、Visual Basic アプリケーション中のテキストボックス
又は ”Wonderware`s InTouch” 中のタグに ”Hot Link” すると、テキストボックス又はタッグが、Wedge
が DDE データをアップデートする時は常に ”Change” イベントを自動的に受け取ることになります。
この ”Change” イベントは、新しいデータを受信するたびにランさせるサブルーチンやスクリプトを立ちげる
ために使用出来ます。マクロや”Change Event” データのサブルーチンを立ち上げたり、”OnData” タイプ
機能を使うことで、Wedge に, 他のアプリケーションに DDE コマンドを送り、何か他の作業をするように指示さ
せる必要はなくなります。
ほとんどすべてのケースで望ましい唯一のことは、Wedge 中で設定された最後のデータフィールドの後に
Single Field Postamble DDE Command を出すことでしょう。そのコマンドの主な目的は、他のアプリケーション
にマクロやサブルーチンをランさせることで、プログラム中のマクロやサブルーチンが、Wedge からデータを戻
すように要求し、データプロセスを開始します。
注記:DDE をサポートするアプリケーションのいくつかは、DDE 交信で新しいデータをサーバーから受け取った
時、アプリケーションをプログラムする方法の1つを提供します。例えば、エクセルは
”SetLinkOnData( ) ” や ”OnData( ) ” の2つの機能をサポートしており、それらは、エクセルが、
26
DDE サーバーから新しいデータを受け取ったら常に特定のマクロやサブルーチンを自動的にランさせ
る為に使用するものです。この機能で、Wedge が実際に Field Postamble DDE Command を出さなくと
も Field Postamble DDE Command が行うのと同じことが出来ます。言い換えれば、Wedge がマクロを
ランさせる為にコマンドを送る代わりに、他のアプリケーションが、DDE データの変更を感知出来るよう
にセットアップされ、データが変わったら、そのアプリケーションが自動的にマクロをランさせるということ
です。
注記:TAL Technology がウエブサイト:http:/www.taltech.com.を持っており、そこでは最もよく質問される問
い合わせに対する回答も含め、Software Wedge の基本情報とあわせて多くの DDE に関するケース
を参照していただけます。もし、特定のアプリケーションに関して何か疑問点・わからないことありました
ら、この私どものサイトを開き、”Technical Support” ページ を検索していただければ、解決するもの
と思います。
27
変換表
Software Wedge にある変換表で,データが他のアプリケーション・プログラムに転送される直前に、解析さ
れて、フィルタにかけられた後、シリアル機器から受信したキャラクタの変換が可能です。Define メニューか
ら “Translation Table” のオプションを開くと、下記画面が表示されます。
もし、Software Wedge が ”Send Keystrokes mode” の場合は、この変換表は、個々のキャラクタを特定
のキーストロークに変換する為に用いられます。RS232 のシリアルコネクションから伝送されてきたデータは
ASCII のキャラクタで構成されています。多くの ASCII キャラクタは、特定のキーストロークに対応しない為、こ
の場合、この変換表がその特定のキーストロークに対応するキャラクタリストを表示します。キャラクタを変換
するには、マウスで、変換する必要のあるキャラクタを選び、”Translate” ボタンをクリックするだけです。そ
うすると、下記のような ”Keystroke Selection” ダイアログボックスが表示され、これで特定のキーストロー
ク又はキーコンビネーションを選択します。
28
キーストローク選択の為のダイアログボックスには、すべてのキーストロークのリスト及び3つのチェックボックス
が含まれており、このチェックボックスで選択されたキーストロークに関連して使われるトグルキーの状態が解
るようになっています。
キーストロークリスト中では、先ず3つの選択(Ignore, Void Record &Null)を行いますが、これは実際のキ
ーストロークとは直接関係していませんが、選択するにはそれぞれ特別な理由があります。
キャラクタを Ignore に変換すると、Wedge がキャラクタをすべて無視します。Ignore に変換されたキャラク
タを受信したら、そのキャラクタは削除され、インプットデータ中のどこにも現れてきません。それはキャラクタ
が無視されたことで、データを決まった長さのデータレコード、又はデータフィールドに読み込む際に、そのキ
ャラクタそのものが存在しないものと判断されるからです。このようにして、データは Wedge に読み込まれて
いたとしても、Ignore がそのキャラクタをインプットデータ・ストリームから事実上、取り除くことになります。
キャラクタを Void Record に変換すると、Wedge はすべての現在の全てのレコードを無効にし、削除します。
Void Record に変換されたキャラクタが、インプットデータ・レコード中のどこかにある場合は、すべてのレコ
ードは完全に無視され、アプリケーション・プログラムには転送されません。例えば、各データレコードセットの
前に、常にヘッダーレコードを伝送する機器を持っており、そのような希望しないヘッダーレコードは取り除き
たいという場合を想定して下さい。もし、ヘッダーレコード中に常に現れるがデータレコード中にはどこにも現れ
ないというような特殊なキャラクタがある場合、”Void Record” に変換することで、そのヘッダーレコードを
削除することが出来ます。
キャラクタを Null に変換すると、そのキャラクタはインプットから除外されることになりますが、決まった長さの
データレコードやデータフィールドをプロセスするときはそのキャラクタ自身は,依然そこあるものとしてカウント
されます。
29
キーストロークと ASCII キャラクタは完全に違う2つの物です。多くの場合、キーストロークがキャラクタを作り
出しますが、ファンクションキーやナビゲーションキーのようなある種のキーには、特定の ASCII キャラクタとの
直接の相関関係はありません。もし、Wedge を ”DDE Server Mode” で使用中の場合、キャラクタをキー
ストロークに変換する為の変換表を使っても、意味がありません。何故ならば、DDE データは、キーストローク
ではなく、ASCII キャラクタで構成されているためです。従って、Wedge が DDE サーバーモードにあるときは、
変換表は、キャラクタを他のキャラクタに変換する為に使用して下さい。
変換表を使い、キャラクタをキーストロークに変換し、Wedge を DDE サーバーモードで起動させる場合は、
Wedge は最も似た論理キャラクタを使い、キーストローク変換を行います。例えば、あるキャラクタを”Enter”
というキーストロークに変換し、Wedge を DDE サーバーモードで起動させる場合、Wedge は、Enter キーの
代わりに ASCII 13(キャリッジリターンキャラクタ)を使います。
キャラクタを、キャラクタを創り出すキーストロークに変換する場合、Wedge がサーバーモードの時は、そのキ
ャラクタが変換に用いられます。キーストローク変換に、シフト(shift)・コントロール(control)・アルト(alt)キー
などの補助キーの使用を特定した場合、それらのキーは無視されます。
Wedge が ”Send Keystrokes” モードの時に、変換表中の ”Null“ に変換されたキャラクタは
”DDE Server”モードの時には、入力シリアルデータから削除されるでしょう。
もし、Wedge を DDE サーバーモードで使っていて、キャラクタを、キャラクタを創り出さない(カーソルナビゲー
ションキー等)キーストロークに変換する場合、そのキャラクタはそれを”Null”に変換する場合と全く同じよう
に扱われます。この場合の唯一の例外は、バックスペース(Back Space)・キーストロークに変換されるキャラ
クタの場合で、それが DDE サーバーモードの時は、ASCII 8 に変換されます。
30
シリアル・アウトプット・ストリング設定
Define メニューから ”Output String” を選ぶと、下記のようなダイアログボックスが表示されます。このダイ
アログボックスで、Acknowledgement String, Timer Controlled Output String そして、Software Wedge の
稼動中、機器に送られる最大20までの Controlled Output String を設定することになります。
”Acknowledgement String” はシリアル機器からの完全なデータレコードを受信した後に、シリアルポート
から自動的に送信されるキャラクタ・ストリングです。Acknowledgement Strings を送信する機能は、もともと
それらを必要とする機器を対象にしていたものですが、キャラクタ・ストリングを送信することでポーリングが出
来る機器に、データを頻繁に要望するための1つの方法としても用いられています。
”Timer Controlled Output String” は、データが決まったインターバルで自動的に伝送されるように設定
出来ます。タイマーのインターバル値は 50 から 99,999,999 ミリセカンドの間です。チェックボックスで、
Wedge が起動するとき、決められたインターバルでの自動アウトプットを初期設定でイネーブルにするかどう
か設定することが出来ます。この Timer Controlled Output String が設定されると、Software Wedge 画面
中のメニューで、決まったインターバルでの自動アウトプットをイネーブルにするかディセーブルにするかを設
定できます。
”Timer Controlled Output String” の典型的な使い方は、ポールに呼応してデータを伝送する機器と一
緒に使うことです。例えば、ほとんどの電子秤は、特定のキャラクタ・ストリングを送り、それが確認されない限
り読み取った重量情報を伝送しません。もし、一定期間継続的に秤からの重量情報読み取りをモニターした
いとしたら、”Timer controlled Output String” はこの機能を遂行するのには理想的なツールとなります。
31
注記:この時間のインターバルをゼロより大きい値で設定し、Timer Controlled Output String に何も設定しな
ければ、Wedge が、ストリングを伝送する代わりにそのインターバルで 100ms の間 DTR ラインをトグル
します。これは、決まったインターバルでの DTR ライン・トグリングに応答する機器をポールすることを
可能にします。
Software Wedge は 、 稼働 し て いる間 は シ リ ア ル 機 器 に 送 るこ と が 可 能な 最 大2 0 まで の ” Button
Controlled Output String” をあらかじめ設定することが出来ます。これらの ”Output String” (”String
1”から ”String 20” のように呼びます)は、それぞれのボタンと繋がっており、そのボタンは Wedge が起動し
たら、その画面中に表示されます。アウトプット・ストリング・ボタン上でマウスをクリックすると、そのストリングは
シリアルポートを通して、お手許の機器に送られます。ボタンを、ストリングにあわせて設定する時、個々のボ
タンに対し、それぞれのボタンの内容と目的が解るように ”Button Caption” を特定することも可能です。
例えば、電話番号とキャリッジ・リターンのついたストリング ”ATDT” を送ることで、モデムが電話番号をダイ
アルするように設定することが出来ます。この状況に対し、必要な ”ATDT” コマンドや電話番号、キャリッ
ジ・リターンを含んだアウトプット・ストリングを決め、そのボタンキャプションを ”Dial Phone” として設定する
ことが出来ます。そうすると、Software Wedge の画面中でそのキャプション ”Dial Phone” で、そのボタン
上をマウスでクリックすればいつも、ストリングがモデムに送られ番号をダイアルすることになります。(モデム
の電話を切るコマンドは、キャリッジ・リターンのついた”ATH”です)。
ボタンコントロール・アウトプット・ストリングは、プロンプト・ストリング送信、プログラミング指示の送信等を含むあ
らゆる種類の機能に使用出来ます。使用できるコマンドやプロンプトについての情報は、機器ユーザーマニュ
アルを参照下さい。
ボタンにキャプションをつけるには、アクセスキーとして使おうとするキャラクタのすぐ前のキャプション中に
”&” マークも含めることで,各ボタンにアクセスキーをアサインすることが出来ます。このキャラクタは、
Software Wedge が起動すると、ボタンキャプション中で下線付きの強調された形で現れます。Software
Wedge が起動しており、入力フォーカスがある間に、ALT キーと一緒にその下線の付いたキャラクタを押す
と、ボタン上でマウスをクリックするのと同じ効果を持ちます。例えば、ボタンキャプションを ”&SEND Data”
とすると、ボタンは、ALT+Sで、アクセスキーとして下記のように表示されます。
Send Data
アウトプット・ストリングを編集するには、ASCII チャートが利用でき、そのチャートから、キーボード上で入力で
きないキャラクタを(コントロールコードや、キャリッジ・リターン等)選択できます。
32
起動メニュー
“Activate”メニューには4つの入力方法があります。最初の2つは、”Test Mode” と ”Normal Mode” で、
意図した起動させる為の設定が終わった後で、Software Wedge を立ち上げる為に使います。これらのオプ
ションの1つを使って、シリアルの I/O 機能が実際に立ち上がる前に、Wedge を起動させねばなりません。こ
れらの2つのオプションとその違いは 34 ページの ”The Software Wedge の起動” の項での説明をご参照
下さい。
次の2つは ”ON/OFF” オプションで、それらを選択することでオン・オフを切り替えます。
(ON)を選択すると、各メニューの左にチェックマークが表示されます。
”Minimize On Activation” と ”Display DTR Toggle Button” は Software Wedge が起動しているとき表
示される画面の内容を制御します。”Minimize On Activation” のオプションは Wedge を最低必要な内容
でランさせるか、又は起動する際のアイコンとしてランさせます。Wedge は、最低必要な内容での立ち上げで
はあっても機能し続け、起動した後は画面に Wedge の表示が不要であれば、このオプションを選ぶと、表示
はされません。
7 ページの、”特定の設定ファイルでの Wedge の自動起動” の項もご参照下さい。
”Display DTR Toggle Button” オプションは、Wedge の起動後、Software Wedge 画面中にキャプション
の ”DTR~” と一緒にボタンが表示されることになります。このボタンは、シリアルポート Data Terminal Ready
ラインを 100ms の間トグルする為に使われます。
このアクションは、あるタイプのシリアル機器では、データレコード伝送要求を意味します。
33
Software Wedge の起動
Software Wedge は、Activate Menu から ”Test Mode”又は ”Normal Mode” のいずれかで起動しない
限り、いかなるシリアルデータも受け取りません。この2つのモードの違いは、”Test Mode” で Wedge を起動
した場合、Software Wedge のメインメニューに戻り、設定パラメータを変更することが出来ます。特定のアプ
リケーションと特定のシリアル機器を使って最初に Wedge を設定するときには、必ず Test Mode を選択しな
ければなりません。すべてが正しく動くようになるまでは、Test Mode で Wedge を起動した方がはるかに容易
です。
”Normal Mode”では、Wedge をすべて一旦終了して・再スタートさせ・設定を再ロードしない限り、初期設
定に帰り・いかなる設定パラメータをも変更することは出来ません。
Wedge を ”Normal Mode” で起動する時は、そのメインメニューやサブメニュー、ダイアログボックス、及び
セットアップコードは、Windows システムそのものを保全する為にメモリからアンロードされます。これは他の
アプリケーション・プログラムに必要なシステムメモリやその他のメモリやソフトを解放することで、全体のシス
テム能力・効率を保持・高めるのに役立ちます。
Software Wedge 画面
Wedge を Test, 又は Normal モードのいずれかで起動した場合、メイン・セットアップ・メニューは消え、下に
示した、又はこれに類似した画面が表示されます。この画面を ”Software Wedge Window” と呼びます。
この画面のタイトルバーはシリアルポートを示しており、そのシリアルポートを通して今 Wedge が設定・起動し
ているということです。
34
画面のメニューバーには3つのエントリー、つまり Edit, Quit, 及び About、があります。
この画面中の ”Input Data Field” (Input Data Field と言う名前のついたテキストボックス)や ”Serial
Output Button” (画面左)の数は、Wedge を設定した際に、前もって決めたデータフィールドの数に従って
います。
キャプション”DTR~”のついたボタンは ”Data Terminal Ready Button” と呼ばれ、起動メニュー中で
”Display DTR Toggle Button” が選択されているときにのみ表示されます。このボタンを押すと、シリアル
ポート”Data Terminal Ready Line”が、約 100ms の間 ”ON” から ”OFF” へトグルします。
注記:Software Wedge 画面は、そのオペレーションに影響を与えることなく、アイコンサイズに縮小すること
も可能です。画面を小さくすることで唯一の不都合は、設定したどの ”output string buttons” を押
すにも、都度そのアイコンを開かなければいけないという点です。
編集メニュー
エディットメニューに含まれているのは、Copy エントリーのみです。
この Copy コマンドで、インプット・データフィールドの内容を、Windows のクリップボードにコピーすることが出来
ます。データフィールドをコピーするには、コピーしたいデータフィールド・テキストボックス内でマウスをクリック
し、エディットメニューから ”Copy” を選択します。Software Wedge からコピーしたデータは、他のアプリケ
ーションに貼り付けるか又はリンク貼り付けのいずれかができます。
35
終了メニュー
”Quit”のメニューには2つの選択、”Suspend” と ”Quit”, があり、タイマーコントロール・ストリングが設定さ
れた場合は、更に3つ目として ”Enable/Disable Timed Output” が表示されます。
”Suspend” を選択すると Software Wedge のオペレーションを待機状態にし、Suspend メニューは
”Resume” に変わります。Software Wedge が待機状態にある間は、Wedge は現在待機中であることを示
す(S)が、タイトルバー中に表示されます(他のアプリケーションから、特殊な DDE コマンドを送り、待機状態や
再開指示することも可能です)。
Software Wedge を ”Test Mode” で起動した後で終了する場合、メインメニューに戻ります。Activate メニ
ューから ”Normal Mode” を選択して Wedge を起動する、又はコマンドライン上で設定ファイル名を指定し
て Wedge を起動した場合、Software Wedge はその動作をすべて同時に終了します。
7 ページの、”特定の設定ファイルでの Wedge の自動起動” の項もご参照下さい。
Enable/(Disable) Timed Output オプションは、設定されていたどんな ”Timer Controlled Output String”
をもオンしたりオフにしたりする為に使用されます。タイマー出力制御が設定されており、現在もイネーブルな
状態であれば、このオプションは ”Disable Timed Output” の表示となります。同様に、タイマー出力ストリ
ング制御が現在ディセーブルになっていると、このオプションは、再度イネーブルにすることが出来る
”Enable Timed Output” となります。(他のアプリケーションから Wedge に DDE コマンドを送りタイマー出力
制御をイネーブルにしたり、ディセーブルにすることも出来ます)
31 ページ、シリアルアウトプット・ストリング設定の項もご参照下さい。
36
オンライン・ヘルプへのアクセス
Software Wedge のメインメニューから、Help のサブメニューの ”Index” を開くとオンラインヘルプが利用出
来ます。このオプションが Windows ヘルプ・システムにアクセスし、Software Wedge 用に利用可能なヘルプ
項目別リストを表示します。オンラインヘルプはメインメユーからしかアクセス出来ず、Software Wedge が起
動された後ではアクセス出来ません。
37
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement