輝点計測ソフト 取扱説明書

輝点計測ソフト 取扱説明書
輝点計測
輝点計測ソフト
計測ソフト
取扱説明書
目次
はじめに
1
4
1.1
ソフトウェアの概要................................................................................................. 4
1.2
仕様 .......................................................................................................................... 5
1.3
ご質問・お問い合わせについて .............................................................................. 6
セットアップ
2
8
2.1
動作環境の確認........................................................................................................ 8
2.2
ソフトウェアのインストール、アンインストール方法.......................................... 8
2.3
ハードウェア USB キーの挿入...............................................................................11
基本的な使い方
3
13
3.1
輝点の計測方法...................................................................................................... 13
3.2
計測データの確認 .................................................................................................. 21
3.3
追跡データの作成 .................................................................................................. 25
3.4
追跡データの確認 .................................................................................................. 27
3.5
データの保存.......................................................................................................... 28
各部の機能
4
32
4.1
メニュー................................................................................................................. 32
4.2
ツールバー ............................................................................................................. 44
4.3
パレット Control 系............................................................................................ 47
4.4
【動画】ウィンドウ............................................................................................... 56
4.5
【Graph】パレット............................................................................................... 58
4.6
【Histogram】パレット........................................................................................ 60
4.7
【Trace Analysis】パレット................................................................................. 63
5
FAQ・トラブルシューティング
68
5.1
ハードウェア USB キー......................................................................................... 68
5.2
輝点選択・計測...................................................................................................... 69
5.3
その他 .................................................................................................................... 72
G-Count 取扱説明書
2
1
はじめに
G-Count 取扱説明書
3
1 はじめに
本ドキュメントは、輝点計測ソフトウェア「G-Count」の取扱説
明書です。本製品をご利用になる前にお読みください。
1.1 ソフトウェアの概要
「G-Count(ジーカウント)」は、1 分子観察等で得られた複数の
単輝点の計測に必要な機能を備えている動画解析ソフトウェア
です。二値化法、閾値法など の画像処理から、輝点カウント、
Intensity などのデータ解析までの一連の作業を、G-Count で行う
ことができます。
重み重心を求めるアルゴリズム(重心解析モード)と、楕円に
も対応した新開発の高速ガウシアンフィッティングアルゴリズ
ム(ガウシアンフィッティングモー ド)
、2 次元ガウシアンフィ
ッティングアルゴリズム(2 次元ガウシアンフィッティングモー
ド)によって、高速・高精度での全輝点自動計測が可能です。
特長
G-Count 取扱説明書
動画上の全ての輝点を計測し、1 フレーム毎の輝点数を自動
計測。
輝点計測には、重み重心を求めるアルゴリズムと、新開発
高速ガウシアンフィッティングアルゴリズム、2 次元ガウシ
アンフィッティングアルゴリズム、手動選択の 4 つを選択
可能。計測の高速化をサポートする Speedy を搭載。
輝点の計測フレーム範囲を指定可能。
得られた輝点情報から連続点を探索し、追跡データに変換
することができます。
全フレームにおける解析した全ての輝点を、1 枚の画像上に
投射できます(解析点のスポット表示)
。
輝点抽出の為に必要な画像処理を搭載。
輝点情報をデータベース化して保存することができるので、
後に様々な解析に利用できます。
背景光によらず計算が可能なため、照明斑の影響を受けに
くく、従来のような閾値法などの画像処理を必要としませ
4
ん(ガウシアンフィッティングモード)
。
輝点の強度、輝点の広がり、位置など、輝点の持つすべて
の情報を取得することができます(ガウシアンフィッティ
ングモード)。
パッケージ内容物
CD-ROM
ハードウェア USB キー(ドングル)
取扱説明書(本書)
ライセンス許諾契約書
リリース履歴
製品機能の更新情報等、製品に関しての最新情報については、
株式会社ジーオングストローム web サイトをご覧ください。
ご注意
本書で使用されている画像コピーの中には、現行バージョンの
製品とは一部異なっている場合がございます。
ハードウェア USB キーに貼付されているシールは、絶対に剥が
さないでください。
1.2 仕様
G-Count 取扱説明書
OS
Windows XP
CPU
Pentium Ⅲ以上を推奨
32bit を推奨
メモリ
320MB 以上の RAM を推奨
ハードディスク
7200rpm 以上の回転数を推奨
その他
National Instruments 社
LabVIEW ラ ン タ イ ム エ ン ジ ン
8.2.1
SafeNet 社
Sentinel System ドライバ
※「G-Count」の動作に必要です。
5
1.3 ご質問・お問い合わせについて
ご質問される前に
株式会社ジーオングストロームでは、最新の製品サポート情報
を Web サイトに公開しています。お問い合わせいただく前に、
株式会社ジーオングストローム Web サイトをご利用ください。
http://www.g-angstrom.com
ご質問方法
株式会社ジーオングストロームでは、弊社製品をご利用のお客
さまにサポートサービスを提供しています。お問い合わせの際
は、Web サイトのお問い合わせフォームをご利用ください。
Copyright (c) 2008 G-Angstrom. All Rights Reserved.
Microsoft®、Windows®は、米国 Microsoft Corporation の、米国、
日本およびその他の国における登録商標または商標です。
Pentium は、米国およびその他の国における、Intel Corporation
またはその子会社の商標または登録商標です。
National Instruments 、 NI 、 LabVIEW は 、 NationalInstruments
Corporation(米国ナショナルインスツルメンツ社)の商標です。
Sentinel は、米国 SafeNet 社の商標です。
その他、本ドキュメントに記載されている各社の社名、製品名
およびサービス名は、各社の商標または登録商標です。
G-Count 取扱説明書
6
2
セットアップ
G-Count 取扱説明書
7
2 セットアップ
セットアップに必要な環境、インストールやアンインストール
の方法
2.1 動作環境の確認
本書 1.2 の仕様をご確認いただき、動作環境の確認を行ってくだ
さい。
2.2 ソフトウェアのインストール、アンインストール方法
「G-Count」のインストール
本ソフトウェアをインストールするには、次の手順に従ってく
ださい。
1
CD-ROM を挿入します
CD-ROM ドライブに、本ソフトウェアデータディスクを挿入し
ます。
2
マイコンピュータを開きます
[スタート]ボタン→[すべてのプログラム]→[アクセサリ]
から[エクスプローラ]を選択して[マイコンピュータ]をダ
ブルクリックします。
G-Count 取扱説明書
8
3
CD-ROM を開きます
CD-ROM ドライブに、G-Count と表示されているのを確認して
ダブルクリックします。
4
setup.exe を起動
ファイルの一覧から、setup.exe をダブルクリックします。画面
の指示に従ってインストールを行います。
完了後、デスクトップへ[GCount へのショートカット]のアイ
コンが表示されます。
※インストール時には、ハードウェア USB キー(ドングル)を
PC から取り外してください。
※G-Count の使用には Microsoft® .NET Framework Version 2.0 が
必要です。ご使用の PC にインストールされていない場合、ファ
イ ル の 一 覧 か ら 、 [Files] フ ォ ル ダ を ダ ブ ル ク リ ッ ク し 、
dotnetfx.exe をダブルクリックします。Microsoft® .NET Framework
Version 2.0 を画面の指示に従ってインストールを行います。
5
G-Count 取扱説明書
LabVIEW Runtime Engine のインストール
9
ファイルの一覧から、[Files]フォルダをダブルクリックし、
LabVIEW_8.2.1_Runtime_Engine.exe を ダ ブ ル ク リ ッ ク し ま す 。
LabVIEW ランタイムエンジンを画面の指示に従ってインストー
ルを行います。
※インストール時には、ハードウェア USB キー(ドングル)を
PC から取り外してください。
6
Sentinel System Driver のインストール
ファイルの一覧から、Files フォルダをダブルクリックし、
Sentinel
System Driver Installer 7.4.0.exe をダブルクリックします。画面の
指示に従ってインストールを行います。
※インストール時には、ハードウェア USB キー(ドングル)を
PC から取り外してください。
「G-Count」のアンインストール
本ソフトウェアをアンインストールするには、次の手順に従っ
てください。
1
「スタート」→「プログラムのアクセスと既定の設定」→「プ
ログラムの変更と削除」を選択してください。
※お使いのコンピュータに現在インストールされているプログ
ラムの一覧が表示されます。
G-Count 取扱説明書
10
2
『G-Count』を選択して、削除してください。
※必要に応じて、作成したショートカットや関連付け設定を削
除してください。
2.3 ハードウェア USB キーの挿入
付属のハードウェア USB キー(ドングル)は、ソフトウェアのイ
ンストールを全て行った後に PC に挿入してください。
※挿入されていない場合、ソフトウェアを正常に起動すること
はできません。
※ハードウェア USB キー(ドングル)に貼付されているシールは
絶対に剥がさないでください。
※インストール時にはハードウェア USB キー(ドングル)を PC
から取り外し、setup.exe と Sentinel System Driver Installer
7.4.0.exe をインストール後に再度挿入してください。
G-Count 取扱説明書
11
3
基本的な
基本的な使い方
G-Count 取扱説明書
12
3 基本的な使い方
「G-Count」の起動方法、基本的な使い方
3.1 輝点の計測方法
基本的な操作の流れ
①起動
②動画読込
③範囲選択
④パラメータ設定
⑤計測実行
G-Count 取扱説明書
13
操作手順
計測準備
1 「G-Count」
Count」を起動します
起動します。
します。
G-Count アイコンをダブルクリックします。
2 動画を
動画をインポート(
インポート(読込)
読込)します。
します。
[ファイル]メニューから[AVI ファイルの
インポート]を選択し、動画ファイルをイン
ポートします。
POINT
読込 可能なフ ァイ ル
形式は非圧縮 AVI 形
式です。
POINT
■コントロールの整列
[ツールバー]メニュー→[コン
トロールの整列]をクリック
すると、パレットが整列して
表示されます。
G-Count 取扱説明書
14
操作手順
範囲選択
輝点の
輝点の選択方法は
選択方法は2種類あります
種類あります。
あります。
方法 1 全ての範囲を指定する方法
方法 2 部分的に指定する方法
※範囲指定をしただけでは、計測はおこなわ
れません。
選 択 方 法
方法 1 【ダブルクリックで
ダブルクリックで全範囲指定】
全範囲指定】
①[動画ウィンドウ]の[自動輝点選択]ボタン
をクリックします。
②[動画ウィンドウ]上でダブルクリックす
ると、全ての範囲を選択します。
方法 2 【ドラッグで
ドラッグで部分指定
部分指定】
指定】
①[自動輝点選択]ボタンをクリックします。
②左ドラッグして、
[動画ウィンドウ]の任意
の範囲を選択します。
G-Count 取扱説明書
15
操作手順
パラーメータ設定
アルゴリズムの
アルゴリズムの選択
輝点認識のアルゴリズムを下記から選択しま
す。
・Centroid
・Gaussian Fitting
・2D Gaussian Fitting
・Hand-selected
POINT
最適アルゴリズム
が不明な場合は、
Centroid を選択し、
先に Threshold を設
定します。
アルゴリズム選択の目安
■Centroid
背景と輝点の明度差が大きく、輝点が
円でない場合に使用します
■Gaussian Fitting
背景と輝点の明度差が少ないが、輝点
が明るく明らかな場合に使用します
■2D Gaussian Fitting
背景と輝点の明度差が少ないが、輝点
がノイジックな場合や正確性をあげ
たい場合に使用します
■Hand-selected
手動でデータを記録します
G-Count 取扱説明書
16
2D Gaussian
アルゴリズム
Centroid
Gaussian Fitting
輝点認識
重心位置の輝度
XY平面投影図利用
二次元ガウス関数
手動(マウス操作)
・計算が単純
・理想輝点でなくて
も、重心位置を計算で
きる
・ノイズが多い場合に
精度が低く、ROI の大
きさ、背景光で解が変
化する
・楕円形輝点近似に優
位
・照明班の影響を受け
にくく、画像処理せず
に解析可能
・輝点の強度、輝点の
広がり、位置を取得可
能
・ノイズに弱い
・高精度で解析可能
・照明班の影響を受け
にくく、画像処理せず
に解析可能
・輝点の強度、輝点の
広がり、位置を取得可
能
・反復法であるため、
計算に時間を有する
・マウスでクリックし
たポイントを記録
・認識できない輝点も
記録可能
背景光の影響
×
○
○
○
輝点形状
○
○
△
○
計算速度
○
△
×
×
ノイズ
×
△
○
○
位置精度
△
○
○
×
採用基準
背景と輝点の明度差
が大きく、輝点が円で
ない場合
背景と輝点の明度差
が少ないが、輝点が明
るく明らかな場合
・背景と輝点の明度差
が少ないが、輝点がノ
イジックな場合
・正確性をあげたい場
合
特徴
G-Count 取扱説明書
Fitting
HandHand-selected
selected
任意の位置を自由に
記録したい場合
17
Threshold の設定
POINT
ROI サイズは、輝点
の大 きさに合 わせ て
設定して下さい。計測
でき ない場合 には 、
ROI を少しずつ大き
くし ながら試 行し て
下さい。
POINT
最適なパラメータの
探索には、処理速度の速
い Centroic アルゴリズ
ム+One-image で大ま
かに行い、その後アルゴ
リ ズム を変 更しな が ら
調整します。
[ROI Size]スクロールバー
輝点検索や輝点計測の際に ROI サイ
ズを設定します。ROI Size が n の場
合、ROI の一辺の大きさは(2n+1)と
なります。ROI は Region Of Interest
を意味します。
ROI サイズは、輝点の大きさに合わ
せて設定して下さい。計測できない場
合には、ROI を大きく設定して下さ
い。
[FI-limit]スクロールバー
輝点検索や輝点計測の際に検出する
蛍光強度の閾値を設定します。FI は
Fluorescence Intensity を意味しま
す。
[Loop]スクロールバー
ガウシアンフィッティングアルゴリ
ズムの最大反復計算回数を設定しま
す。設定した最大反復計算回数内に解
が収束しない場合は輝点の追跡を停
止します。
G-Count 取扱説明書
18
操作手順 計測
輝点を
輝点を計測し
計測してデータを
データを記録し
記録します。
ます。
※記録できる計測データ数は最大で 999 です。
計 測 方 法
■方法 1 表示フレーム
表示フレームのみ
フレームのみ計測
のみ計測
【One Image ボタンで計測】
輝点選択後に[One Image]ボタンをクリック
して、インポートした動画のうち表示されて
いるフレームのみを計測します。
■方法 2 複数フレーム
複数フレーム計測
フレーム計測
【Multi-images ボタンで計測】
輝点選択後に、
[Multi-images]ボタンを押し
て、ダイアログボックスで指定したフレーム
を全て計測します。
※[All frames]チェックボックスオン時、
インポートした動画の全フレームを計測しま
す。チェックボックスオフ時、指定したフレ
ームを全て計測します。
■方法 3 手動で
手動で計測
[手動輝点選択ボタン]+【左ドラッグ+右ク
リック】
①[動画ウィンドウ]の[手動輝点選択]ボタン
をクリックします。
②[動画ウィンドウ]上で、左ドラッグしな
がらカーソルを動かし、輝点上で右クリック
して、輝点を選択します。選択と同時に自動
G-Count 取扱説明書
19
的にデータが登録されます。
※アルゴリズムが輝点と認識しない場合は選
択されません。
※[Hand-selected]を選択した場合は、左ド
ラッグ+右クリックした場所が無条件で輝点
として扱われます。
G-Count 取扱説明書
20
3.2 計測データの確認
各計測データの表示方法
フレームの
フレームの変更
[Histogram]パレットの[Frame #]テキスト
ボックスに動画のフレームナンバーを入力し
ます。指定したフレームのデータが表示され
ます
POINT
■[Histogram]ボタン
[Histogram]パレットを
表示します。
カウント数
カウント数の確認
[Histogram]パレットの[Total Counts]ラベ
ルで選択したフレームナンバーの総輝点数を
確認します。
平均値
平均値の確認
[Histogram]パレットの[Mean Value]ラベ
ルで選択したフレームナンバーの平均値を確
認します。
G-Count 取扱説明書
21
Single Image グラフの
グラフの切り替え
[Histogram]パレットの[Single Image グラ
フ]タブをクリックして[Single Image メイン
グラフ]を切り替えることができます。
時間変化グラフ
時間変化グラフの
グラフの切り替え
[Graph]パレットの[時間変化グラフ]タブを
クリックして[時間変化グラフ]を切り替える
ことができます。
POINT
■[Graph]ボタン
[Graph]パレットを表示
します。
POINT
[Graph]パレットはウィンドウ内の何もない場所
にドラッグして float 状態にした後に、サイズの変
更が可能です。
G-Count 取扱説明書
22
任意の XY 範囲を指定して表示する方法
輝点計測後、計測した範囲内の任意の範囲を選択することで、細かい範囲の輝点計測
データを確認できます。
①[動画ウィンドウ]の[輝点抽出]ボタンをク
リックします。
POINT
■[輝点抽出]ボタン
②[Histogram]パレットの[1-5]ボタンの任
意のボタンをクリックします。
③[動画ウィンドウ]上で左ドラッグして、任
意の範囲を選択します。
※計測した範囲内で、2 つ以上の計測データ
群を抽出する場合は、[Histogram]パレット
の[1-5]ボタンを切り替え、[動画ウィンドウ]
上で左ドラッグして、任意の範囲を選択しま
す。
G-Count 取扱説明書
23
④任意の範囲の計測データが[Extract グラ
フ]に表示されます。
POINT
[Histogram]パレットの
[Single Image グラフ]タ
ブ を ク リ ッ ク し て
[Extract グラフ]を切り替
えることができます。
⑤[Graph]パレットに抽出した範囲の[時間
変化グラフ]が表示されます。
⑥抽出したデータ群が複数の場合は、
[ Histogram ] パ レ ッ ト の [1-5] ボ タ ン 、
[Graph]パレットの[1-5]ボタンで表示させ
たいデータ群の番号をクリックします。
※[Graph]パレットの[1-5]ボタンの任意の
ボタンを再度クリックするとグラフを非表示
にできます。
G-Count 取扱説明書
24
3.3 追跡データの作成
計測したデータから追跡データを作成することができます。
①[Tracking Control]パレットで追跡アル
ゴリズムと各パラメータを設定します。
POINT
■[Tracking]ボタン
[Tracking Control]パレ
ットを表示します。
②[動画ウィンドウ]の[輝点抽出]ボタンを
クリックし、左ドラッグで任意の範囲を指定
します。
POINT
■[輝点抽出]ボタン
※輝点計測を行った範囲内の追跡データのみ
取得されます。
③[Tracking Control]パレットの[Tracking]
ボタンをクリックします。
G-Count 取扱説明書
25
④[Trace Analysis]パレットに追跡データ
が作成されます。
※輝点計測を行った範囲内の追跡データのみ
作成されます。
POINT
■[Trace]ボタン
[Trace Analysis]パレッ
トを表示します。
G-Count 取扱説明書
26
3.4 追跡データの確認
表示する輝点データの指定
[Data No.]で
No.]で指定
[Trace Analysis]パレットの[Data No.]ス
クロールバーを操作して、グラフを表示させ
たい追跡データのデータナンバーを選択しま
す。
動画ウ
動画ウィンドウで
ンドウで指定
①[追跡確認]ボタンをクリックします。
②[動画ウィンドウ]で、オレンジ色の ROI を
クリックします。
グラフの切り替え
[Trace Analysis]パレットの[サブグラフ]
をダブルクリックして[メイングラフ]を切り
替えます。
POINT
■グラフを拡大表示
メイ ングラフ でド ラ
ッグすると、指定した
範囲 を拡大表 示し ま
す。
G-Count 取扱説明書
27
3.5 データの保存
保存できるデータは下記のとおりです。
・計測データ(表示フレーム、全フレーム)
・追跡データ(任意の輝点、全輝点)
・画像データ(.bmp 形式)
・G-Count プロジェクト(.gcpx 形式)
計測データの保存~表示中のフレーム~
①[データ]メニューを選択します。
②[現フレームの輝点データを保存]を選択し
ます。
③保存ダイアログボックスに従って、CSV 形
式で保存します。
計測データの保存~全フレーム~
①[データ]メニューを選択します。
②下記のいずれかを選択します。
[全フレームの輝点データを保存]
各輝点データをフレーム毎に別のファイ
ルで保存します。
[時系列データを保存]
全フレームのデータを一つのファイルに
保存します
G-Count 取扱説明書
28
追跡データの保存~単一輝点データ~
①[DataNo.]テキストボックス r を修正し、保
存したい輝点データを表示します
②[Trace Analysis]パレットの[Save]ボタ
ンをクリックして保存します。
保存データ項目
Data No.
Frame No.
X Position(pixels)
Y Position(pixels)
X SD(pixels)
Y SD(pixels)
Intensity(A.U.)
追跡データの保存~全輝点~
[データ]メニュー→[トレースデータ]から目
的に応じて選択します。
全輝点データ保存方法の種類
【トレースの一括保存】
全データを輝点毎に別ファイルで保
存します
【全トレースを横並びに保存】
全データを横並びに保存します。
【全トレースを縦並びに保存】
全データを縦並びに保存します。
G-Count 取扱説明書
29
画像の保存
画像上で右クリックします。右クリックした
画像をビットマップ形式(.bmp)で保存します。
ビットマップ形式で保存できる画像
[Raw Data in ROI]
[GaussFit in ROI]
[Single Image グラフ]
[Extract グラフ]
[X-Y Position グラフ]
[X Position グラフ]
[Y Position グラフ]
[X SD グラフ]
[Y SD グラフ]
[Intensity グラフ]
[時間変化グラフ]
[動画ウィンドウ]
※[サブグラフ]は保存できません。
プロジェクトの保存
[ファイル]メニューから[名前を付けて保存]
を選択します。
POINT
■プロジェクトの保存
[Save PJ]ボタンをクリ
ックします。
G-Count 取扱説明書
30
4
各部の
各部の機能
G-Count 取扱説明書
31
4 各部の機能
メニュー、ツールボタン、マウス操作時の機能
4.1 メニュー
4.1.1
[ファイル]メニュー
ショートカットキー
■メニュー選択
[Alt]+[ ア ル フ ァ ベ ッ
ト]キーでメニューを
選択できます。アルフ
ァベ ットはメ ニュ ー
名の 右にカッ コ書 き
で記されています。
Ex.[ファイル]→[新規
作 成 (N)] の 場 合 、
[Alt]+[F]→[N]
[新規作成]
プロジェクトファイル(拡張子.gcpx)を新規作成します。
[プロジェクトを開く]
プロジェクトファイル(拡張子.gcpx)を開きます。
[上書き保存]
解析しているプロジェクトをプロジェクトファイル(拡
張子.gcpx)に上書き保存します。
[名前を付けて保存]
解析しているプロジェクトに名前を付けてプロジェクト
ファイル(拡張子.gcpx)に保存します。
[AVI ファイルのインポート]
動画ファイルをインポートします。
[AVI ファイルの保存]
表示している動画を保存します。
[AVI ファイルの復旧]
画像処理を行った AVI ファイルを、インポート時の状態
G-Count 取扱説明書
32
に戻します。
[G-Track1.2 へエキスポート]
解析しているプロジェクトを G-Track1.2(拡張子.gtp)形
式にエキスポートします。
[コンフィグを初期設定に戻す]
現在のパラメータ設定を初期設定に戻します。
[現在の設定をデフォルトにする]
現在のパラメータ設定をデフォルトに設定します。
[現在の設定を保存する]
現在のパラメータ設定をコンフィグファイル(拡張
子.cfg)に保存します。
[既存の設定を読み込む]
保存したパラメータ設定をコンフィグファイル(拡張
子.cfg)から読み込みます。
※読み込んだパラメータ設定は、コンフィグファイル(拡
張子.cfg)読込後、プロジェクトを新規作成すると適応さ
れます。
[最近使ったファイル]
最近使ったプロジェクトファイル(拡張子.gcpx)を開き
ます。
[アプリケーションの終了]
G-Count を終了します。
4.1.1.1 [一時ファイル]メニュー
[AVI と同じフォルダに設定]
一時ファイルをインポートした動画ファイル(AVI ファイ
ル)と同じフォルダに作成します。
[フォルダを変更]
一時ファイルを作成するフォルダを指定の場所へ変更し
ます。
G-Count 取扱説明書
33
4.1.2
[画像処理]メニュー
[明暗の反転]
動画の明暗を反転します。
[ゲインとオフセット]
動画のゲインとオフセットを調整します。ゲイン値とオ
フセット値を設定することができます。
[任意のインパルスフィルタ]
自ら作成したフィルターを利用できます。窓の大きさは、
「3」で固定されています。
G-Count 取扱説明書
34
4.1.2.1 [背景除去]メニュー
[二値化]
閾値と値を設定することにより、画像の輝度をニ値化し
ます。
[閾値法]
閾値より小さな値は、「0」とする処理を行います。
[移動閾値法]
ウィンドウを走査しながら、動的に閾値を設け、二値化
します。背景斑がある場合に有効です。窓の大きさと閾
値を設定することができます。
[差分法]
平滑化した画像(ローパス処理した画像)を元画像から差
し引くことで背景光を除去します。窓の大きさを設定す
ることができます。
4.1.2.2 [フィルター]メニュー
[平滑化]
画像を平滑化します。窓の大きさを設定することができ
ます。
[メディアンフィルタ]
ウィンドウを走査し、ウィンドウ内の中央値(最大値と
最小値の中間の値)を表示します。窓の大きさを設定す
ることができます。
[ノイズ除去]
ウィンドウの中央値を誇張しながら、平滑化を行います。
強度(強→弱)を設定することができます。窓の大きさ
は、「3」で固定されています。
G-Count 取扱説明書
35
4.1.2.3 [効果]メニュー
[シャーペン]
隣接するピクセルのコントラストの差を強めることでシ
グナルを強調します。強度(強→弱)を設定することが
できます。窓の大きさは、
「3」で固定されています。
[シャドウイング]
光が当たっているような視覚効果を示すフィルターです。
光の照射方向(右→左)を設定することができます。
[エッヂ検出]
画像のエッヂ部分を強調する効果を示すフィルターです。
強度(強→弱)を設定することができます。
4.1.2.4 [特殊]メニュー
[全フレーム平均値画像]
インポートした動画の、全てのフレームを足し合わせた
画像を作成します。輝点の滞在時間を明るさとして表現
し、画像化できるツールです。
※画像上で右クリックすることで、
[クリップボードにコ
ピー]、
[BMP 画像として保存]ができます。
[最大値画像]
それぞれのピクセルに全フレームにおけるピクセル最大
値を表示した画像を作成します。輝点の運動軌跡を画像
化できるツールです。
※画像上で右クリックすることで、
[クリップボードにコ
ピー]、
[BMP 画像として保存]ができます。
[時間移動平均]
指定したフレーム数毎に平均化された動画を作成します。
フレーム数を設定することができます。
G-Count 取扱説明書
36
4.1.3
[表示]メニュー
[画像サイズの初期化]
動画ウィンドウのサイズを初期化します。
[画像ウィンドウを外に出す]
動画ウィンドウを別ウィンドウで表示します。
[カウントした輝点を ROI で表示]
カウントした輝点を青色の ROI で表示します。
[追跡した輝点を ROI で表示]
追跡した輝点をオレンジ色の ROI で表示します。
[追跡した輝点の番号を表示]
追跡した輝点のデータナンバーを表示します。
[追跡したトレースを全て表示]
追跡した輝点のトレース画像を表示します。
[計算時画像を表示しない]
単輝点計測の場合に、画像表示を行わないことにより、
計算速度を改善します。また、複数輝点を自動検索する
場合には、検索過程の画像表示を行わないことにより、
計算速度を改善します。
4.1.4
[ツールバー]メニュー
[コントロールの整列]
各ウィンドウや各バーを整列させます。
[ツールバー]
G-Count 取扱説明書
37
ツールバーを表示します。
[コントロールツールバー]
コントロールツールバーを表示します。
[解析ツールバー]
解析ツールバーを表示します。
[ビューツールバー]
ビューツールバーを表示します。
[ステータスバー]
ステータスバーを表示します。
4.1.5
[コントロール]メニュー
[ビデオコントロール]
[Video Control]パレットを表示(非表示)します。
[輝点情報]
[Info Control]パレットを表示(非表示)します。
[メソッド]
[Method Control]パレットを表示(非表示)します。
[カウント条件設定]
[Count]パレットを表示(非表示)します。
[スケール]
[Scale Control]パレットを表示(非表示)します。
[メモ帳]
[Memo]パレットを表示(非表示)します。
G-Count 取扱説明書
38
4.1.6
[解析ダイアログ]メニュー
[時間変化グラフ]
[時間変化グラフ]を表示(非表示)します。
[各ヒストグラム]
[Single Image グラフ]
、
[Extract グラフ]を表示(非表
示)します。
[追跡トレース作製]
[Tracking Control]パレットを表示(非表示)します。
[追跡解析ウィンドウ]
[Trace Analysis]パレットを表示(非表示)します。
4.1.7
[データ]メニュー
[解析点をスポット表示]
取得した解析データより、輝点の所在フレームナンバー
を示す画像データを表示します。輝点の所在フレームが
前半だと赤色に近く、後半だと青色に近いグラデーショ
ンで表示されます。
※輝点計測を元に表示します。全フレーム、全範囲の[ス
ポット表示画像]を取得する場合は、全フレーム、全範
囲の輝点計測を行ってください。
※[スポット表示画像]上で右クリックすることで、
[ス
G-Count 取扱説明書
39
ケールバーの表示/非表示]、
[クリップボードにコピー]、
[BMP 画像として保存]ができます。
[現フレームの輝点データを消去]
表示されているフレームの計測データを消去します。
[全フレームの輝点データを消去]
全フレームの計測データを消去します。
[現フレームの輝点データを保存]
表示されているフレームの計測データを保存します。
[全フレームの輝点データを保存]
全フレームの計測データを保存します。
※記録されるデータ
・Area No
Area No は、表示されているデータの輝点抽出範囲
(Total,1,2,3,4,5)を示します。
・Method
Method は、計測時に用いたアルゴリズムを示しま
す。
(1= Centroid,2= Gauss Fitting,3= 2DGauss
Fitting,0= Hand-selected)
・Raw Intensity (a. u.)
Raw Intensity は、ROI 内の全ての Intensity 値の
合計値を示します。
・Center Intensity(a. u.)
Center Intensity は、選択アルゴリズムが Gauss
Fitting,2D Gauss Fitting の場合はガウス分布の
Intensity のピーク値を示し、選択アルゴリズムが
Centroid の場合には ROI 中心の値から背景光を差
し引いた値を示します。
・X Position(nm)
X Position(nm)は、各輝点の重心位置の X 座標位
置を示します。
(Hand-Selected 使用時、ROI の中
心の値となります)
・Y Position(nm)
Y Position(nm)は、各輝点の重心位置の Y 座標位
置を示します。
(Hand-Selected 使用時、ROI の中
心の値となります)
・X SD(nm)
G-Count 取扱説明書
40
X SD(nm) は 、 PSF( 点 像 分 布 関 数 : Point Spread
Function)の X 軸方向の SD(標準偏差)を示します。
Centroid,HandSelected 使用時は、ダミー値として
一定値が入ります。
・Y SD(nm)
Y SD(nm) は 、 PSF( 点 像 分 布 関 数 : Point Spread
Function)の Y 軸方向の SD(標準偏差)を示します。
Centroid,HandSelected 使用時は、ダミー値として
一定値が入ります。
[時系列データを保存]
時系列データを CSV 形式で保存します。
※記録されるデータ
・Time
時系列データのキー値を示します
※フレームナンバーから1を引いた値になります。
・Area No
Area No は、表示されているデータの輝点抽出範囲
(Total,1,2,3,4,5)を示します。
・Count
計測された輝点数を示します。
・Raw Intensity (a. u.)
Raw Intensity の平均値を示します
Raw Intensity は、ROI 内の全ての Intensity 値の
合計値を示します。
・Center Intensity(a. u.)
Center Intensity の平均値を示します
Center Intensity は、選択アルゴリズムが Gauss
Fitting,2D Gauss Fitting の場合はガウス分布の
Intensity のピーク値を示し、選択アルゴリズムが
Centroid の場合には ROI 中心の値から背景光を差
し引いた値を示します。
・Mean X position (nm)
X Position の平均値を示します
X Position(nm)は、各輝点の重心位置の X 座標位
置を示します。
(Hand-Selected 使用時、ROI の中
心の値となります)
G-Count 取扱説明書
41
・Mean Y potision (nm)
Y Position の平均値を示します
Y Position(nm)は、各輝点の重心位置の Y 座標位
置を示します。
(Hand-Selected 使用時、ROI の中
心の値となります)
・Mean X SD (nm)
X SD の平均値を示します
X SD(nm) は 、 PSF( 点 像 分 布 関 数 : Point Spread
Function)の X 軸方向の SD(標準偏差)を示します。
Centroid,HandSelected 使用時は、ダミー値として
一定値が入ります。
・Mean Y SD (nm)
Y SD の平均値を示します
Y SD(nm) は 、 PSF( 点 像 分 布 関 数 : Point Spread
Function)の Y 軸方向の SD(標準偏差)を示します。
Centroid,HandSelected 使用時は、ダミー値として
一定値が入ります。
[追跡できなかった輝点を除去]
追跡した輝点以外の ROI 表記を非表示にします。
4.1.7.1 [トレースデータ]メニュー
[トレースの初期化]
記録された追跡データ全てを初期化(削除)します。
[トレースの一括保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、Y Position(pixels)、X SD(pixels)、Y SD(pixels)、
Intensity(A.U.))を一括で保存します。
[全トレースを横並びに保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、 Y Position(pixels)、 X SD(pixels)、 Y
SD(pixels)、 Intensity(A.U.))を 1 つのファイル内に横並
びに保存します。
G-Count 取扱説明書
42
[全トレースを縦並びに保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、 Y Position(pixels)、 X SD(pixels)、 Y
SD(pixels)、 Intensity(A.U.))を 1 つのファイル内に縦並
びに保存します。
4.1.8
[ヘルプ]メニュー
[ヘルプを表示]
ヘルプを表示します。
[トピックの検索]
トピックを検索します。
[『GCount』のバージョン情報]
「G-Count」のバージョン情報を表示します。
G-Count 取扱説明書
43
4.2 ツールバー
4.2.1
【標準ツールバー】
①[New PJ]ボタン
プロジェクトファイル(拡張子.gcpx)を新規作成します。
②[Open PJ]ボタン
プロジェクトファイル(拡張子.gcpx)を開きます。
③[Save PJ]ボタン
解析しているプロジェクトをプロジェクトファイル(拡
張子.gcpx)に保存します。
④[Import]ボタン
動画ファイルをインポートします。
⑤[About]ボタン
「G-Count」のバージョン情報を表示します。
G-Count 取扱説明書
44
4.2.2
【コントロールツールバー】
①[Reset]ボタン
各ウィンドウや各パレットを整列させます。
②[Video]ボタン
[Video Control]パレットを表示(非表示)します。
③[Info]ボタン
[Info Control]パレットを表示(非表示)します。
④[Method]ボタン
[Method Control]パレットを表示(非表示)します。
⑤[Count]ボタン
[Count]パレットを表示(非表示)します。
⑥[Scale]ボタン
[Scale Control]パレットを表示(非表示)します。
⑦[Memo]ボタン
[Memo]パレットを表示(非表示)します。
4.2.3
【解析ツールバー】
①[Graph]ボタン
[Graph]パレットを表示(非表示)します。
②[Histogram]ボタン
[Histogram]パレットを表示(非表示)します。
③[Tracking]ボタン
[Tracking Control]パレットを表示(非表示)します。
④[Trace]ボタン
[Trace Analysis]パレットを表示(非表示)します。
G-Count 取扱説明書
45
4.2.4
【ビューツールバー】
①[SW All]ボタン
カウントした輝点を青色の ROI で表示します。
②[Speedy]ボタン
単輝点計測の場合に、画像表示を行わないことにより、
計算速度を改善します。また、複数輝点を自動検索する
場合には、検索過程の画像表示を行わないことにより、
計算速度を改善します。
③[Tracked]ボタン
追跡した輝点をオレンジ色の ROI で表示します。
④[SW Num.]ボタン
追跡した輝点のデータナンバーを表示します。
⑤[SW Trace]ボタン
追跡した輝点のトレース画像を表示します。
G-Count 取扱説明書
46
4.3 パレット
4.3.1
Control 系
【Video Control】パレット
①[▼]ボタン
[GAIN]スクロールバー、[OFFSET]スクロールバー、
[INVERSE]チェックボックス、
[COLORBAR]チェック
ボックス、
[VIDEO CONTROL]ダイヤルを表示(非表示)
します。
②[スピードコントロール]スライダ
動画の再生速度を Slow・High・中間の三段階で設定しま
す。
③[再生]ボタン
動画を繰り返し再生します。
④[停止]ボタン
動画の再生を停止します。
⑤[逆再生]ボタン
動画を繰り返し逆再生します。
⑥[GAIN]スクロールバー
動画のゲイン値を調節します。
※インポートした動画の、[動画ウィンドウ]への描画パ
ラメータを設定します。輝点計測時、及び解析時の値に
影響はありません。
⑦[OFFSET]スクロールバー
動画のオフセット値を調節します。
※インポートした動画の、[動画ウィンドウ]への描画パ
G-Count 取扱説明書
47
ラメータを設定します。輝点計測時、及び解析時の値に
影響はありません。
⑧[INVERSE]チェックボックス
チェックボックスオン時、動画の明暗を反転します。
※インポートした動画の、[動画ウィンドウ]への描画パ
ラメータを設定します。輝点計測時、及び解析時の値に
影響はありません。
⑨[COLORBAR]チェックボックス
チェックボックスオン時、動画の明暗を色相で表します。
※インポートした動画の、[動画ウィンドウ]への描画パ
ラメータを設定します。輝点計測時、及び解析時の値に
影響はありません。
⑩[VIDEO CONTROL]ダイヤル
[動画ウィンドウ]で表示されているフレーム位置を、ダ
イヤルを操作して移動します。動画は 2 ダイヤルにつき、
1 フレーム移動します。
※インポートした動画の、[動画ウィンドウ]への描画パ
ラメータを設定します。輝点計測時、及び解析時の値に
影響はありません。
G-Count 取扱説明書
48
4.3.2
【Info Control】パレット
①[X]、[Y]、[I]ラベル
動画の画像データから、黄色 ROI 中心の X 座標(X)、Y 座
標(Y)、蛍光強度(I)を取得し、表示します。
②[▼]ボタン
[Raw Data in ROI]3D グラフ、
[GaussFit in ROI]3D グ
ラフ、[X]、[Y]、[I]ラベル、[SD(X)]、[SD(Y)]ラベル、
[save]
ボタンを表示(非表示)します。
③[Raw Data in ROI]3D グラフ
[動画ウィンドウ]上黄色 ROI 内の X,Y,I を 3D 表示します。
④[GaussFit in ROI]3D グラフ
[動画ウィンドウ]上黄色 ROI 内の X,Y,I をガウシアンフィ
ッティングした結果を 3D 表示します。
[GaussFit in ROI]
3D グラフは、ROI 内の画像がガウシアンフィッティング
出来ない場合は表示されません。
⑤[X]、[Y]、[I]ラベル、[SD(X)]、[SD(Y)]ラベル
動画の画像データから、黄色 ROI 内のガウシアンフィテ
ィングにより得られたパラメータ(X 座標(X)、
Y 座標(Y)、
蛍光強度(I)、X 座標標準偏差(SD(X))、Y 座標標準偏差
(SD(Y))を取得し、表示します。ROI 内の画像がガウシ
アンフィッティング出来ない場合は表示されません。
⑥[save]ボタン
[Raw Data in ROI]3D グラフ[GaussFit in ROI]3D グラ
G-Count 取扱説明書
49
フの X 座標、
Y 座標、
蛍光強度データ(X,Y,I)を保存します。
[GaussFit in ROI]3D グラフのデータは、ROI 内の画像
がガウシアンフィッティング出来ない場合は保存できま
せん。
4.3.3
【Info Control】パレット 3D グラフ上でのマウス操作
[右クリック]
[Raw Data in ROI]3D グラフ、
[GaussFit in ROI]3D グ
ラフに表示されている画像をビットマップ形式(.bmp)で
保存します。
4.3.4
【Method Control】パレット
①[アルゴリズム]選択ボタン
輝点計測の際に使用するアルゴリズム(Centroid、Gauss
Fitting、2DGauss Fitting、Hand-selected)を切り替えます。
ガウス分布に従わない輝点にガウシアンフィッティング
を用いた場合([Gauss Fitting][2DGauss Fitting]選択時)、
位置精度が下がる場合がありますのでご注意ください。
各アルゴリズムの特徴・採用基準の目安は下記のとおり
です。
■Centroid
○アルゴリズム解説
・重心位置における中心の輝度を閾値として、輝点か否
かを判断
○特徴
・計算が簡単である為、処理速度が速い
・理想輝点でなくても、重心位置を計算できる
・ノイズが多い場合に精度が低く、ROI の大きさ、背景
光で解が変化する
G-Count 取扱説明書
50
○採用基準
・背景と輝点の明度差が大きく、輝点が円でない場合
■Gaussian Fitting
○アルゴリズム解説
・XY平面それぞれにおける投影図を利用し、重心位置
を計算
○特徴
・楕円形輝点近似に優位
・処理速度が速い
・照明班の影響を受けにくく、画像処理せずに解析可能
・輝点の強度、輝点の広がり、位置を取得可能
・ノイズに弱い
○採用基準
・背景と輝点の明度差が少ないが、輝点が明るく明らか
な場合
■2D Gaussian Fitting
○アルゴリズム解説
・二次元ガウス関数で近似
○特徴
・高精度での解析可能
・照明班の影響を受けにくく、画像処理せずに解析可能
・輝点の強度、輝点の広がり、位置を取得可能
・反復法であるため、計算に時間を有する
○採用基準
・背景と輝点の明度差が少ないが、輝点がノイジックな
場合
・正確性をあげたい場合
■Hand-selected
手動でデータを記録します。
②[BG Fixed]チェックボックス
[Gauss Fitting]、[2DGauss Fitting]選択時に使用できま
G-Count 取扱説明書
51
す。チェックボックスオン時、背景光のパラメータを固
定し、計算速度を改善します。
③[ROI optimization]チェックボックス
チェックボックスオン時、ROI の位置を最適化すること
により、輝点の誤認識確率を改善します。
④[Ref.BG]チェックボックス
チェックボックスオン時、ガウシアンフィッティングに
より得られたバッググラウンド値を排除して蛍光強度を
求めます。BG は、Back Ground を意味します。
4.3.5
【Count】パレット
①[ROI Size]スクロールバー
輝点検索や輝点計測の際に ROI サイズを設定します。ROI
Size が n の場合、ROI の一辺の大きさは(2n+1)となります。
ROI は Region Of Interest を意味します。
ROI サイズは、輝点の大きさに合わせて設定して下さい。
計測できない場合には、ROI を大きく設定して下さい。
②[FI-limit]スクロールバー
輝点検索や輝点計測の際に検出する蛍光強度の閾値を設
定します。FI は Fluorescence Intensity を意味します。
③[Loop]スクロールバー
ガウシアンフィッティングアルゴリズムの最大反復計算
回数を設定します。設定した最大反復計算回数内に解が
収束しない場合は輝点の追跡を停止します。
④[Stop]ボタン
G-Count 取扱説明書
52
インポートした動画の計測を中止します。
⑤[One image]ボタン
インポートした動画のうち表示されているフレームのみ
を計測し、計測データを記録します。
⑥[Clear]ボタン
記録した計測データのうち、表示されているフレームの
計測データのみを削除します。
⑦[Multi-images]ボタン
インポートした動画のうち指定したフレームを全て計測
し、計測データを記録します。
※[All frames]チェックボックスオン時、インポートし
た動画の全フレームを計測します。チェックボックスオ
フ時、指定したフレームを全て計測します。
⑧[All Clear]ボタン
記録した計測データを全て削除します。
4.3.6
【Scale Control】パレット
①[pixel]テキストボックス、
[frame]テキストボックス
解析に用いる動画のキャリブレーション値を入力します。
G-Count 取扱説明書
53
4.3.7
【Tracking Control】パレット
①[Init Data]ボタン
取得した全ての追跡データを消去します。
②[Tracking]ボタン
輝点を追跡し、追跡データを記録します。
③[▼]ボタン
[Radius]スクロールバー、[FI-limit]スクロールバー、
[Min # ]スクロールバー、
[Room]スクロールバー、
[ア
ルゴリズム]選択チェックボックス、
[Select all]ボタン
を表示(非表示)します。
④[Radius]スクロールバー
追跡データ取得の際の範囲(円)を設定します。範囲(円)の
直径は(2n+1)となります。(Radius=n)
Radius は、輝点の大きさに合わせて設定して下さい。追
跡できない場合には、Radius を大きく設定して下さい。
※追跡データの作成は、
「計測」したデータを基にして行
なわれます。
[Radius]値は、計測時に設定した[ROIsize]
設定値以下で設定してください。
⑤[FI-limit]スクロールバー
輝点検索や輝点追跡の際に検出する蛍光強度の閾値を設
定します。FI は Fluorescence Intensity を意味します。
G-Count 取扱説明書
54
⑥[Min # ]スクロールバー
輝点追跡の際のデータを記録するフレーム数を設定しま
す。指定したフレーム数未満の追跡データは記録されま
せん。
例)Min#を 4 に設定して解析を行った場合、4 未満の追
跡データは記録されません。
⑦[Room]スクロールバー
追跡対象輝点が消えた際に、指定したフレーム数以内で
輝点を再度認識した場合に同一輝点として追跡データを
取得します。
⑧[アルゴリズム]選択チェックボックス
追跡データ作成の元となる計測データの、作成時に使用
したアルゴリズム(Centroid、Gaussian、2D Gaussian、
Hand-selected)を選択します。
⑨[Select all]ボタン
ボタンをクリックすると、[Centroid]、[Gaussian]、[2D
Gaussian]、[Hand-selected]チェックボックスが全てオ
ンになります。
G-Count 取扱説明書
55
4.4 【動画】ウィンドウ
4.4.1
名称と機能
※本ソフトウェアをご使用の PC・ディスプレイの性能により、
格子状の縞模様が現れることがあります。これは、本ソフトウ
ェアの解析性能に影響を与えるものではございません。格子状
の縞模様は、動画を拡大することにより解消されます。
①[手動輝点選択]ボタン
輝点を計測する際、[動画ウィンドウ]上の任意の一輝点
を選択するために使用します。
②[自動輝点選択]ボタン
輝点を計測する際、[動画ウィンドウ]上の任意の範囲を
選択するために使用します。
③[輝点抽出]ボタン
輝点計測後に、計測範囲内の計測データを細かく確認す
る際、[動画ウィンドウ]上の計測範囲内で任意の範囲を
選択するために使用します。
また輝点を追跡する際、[動画ウィンドウ]上の任意の範
囲を選択するために使用します。
④[追跡確認]ボタン
任意の一輝点の追跡データを確認する際、[動画ウィンド
ウ]上の一輝点を選択するために使用します。
G-Count 取扱説明書
56
⑤[Frame #]スクロールバー
動画のフレームナンバーを、スクロールバーを操作して
選択します。
4.4.2
【動画ウィンドウ】内での ROI 表記
[青色の ROI]
[動画ウィンドウ]上で、計測データを記録した輝点上に
表示されます。ROI は Region Of Interest を意味します。
[オレンジ色の ROI]
[動画ウィンドウ]上で、追跡データを記録した輝点上に
表示されます。ROI は Region Of Interest を意味します。
4.4.3
【動画ウィンドウ】内でのマウス操作
[クリック]
[動画ウィンドウ]内をクリックすると、輝点と認識した
場合にのみ ROI により画像が選択されます。その際、ROI
内情報が[Raw Data in ROI]に表示されます。ROI 内の
画像がガウシアンフィッティング出来る場合は、マウス
アップ時に[GaussFit in ROI]にフィッティング結果が
表示されます。([Gaussian Fitting]、
[2DGaussian Fitting]
ボタンがオフ時でも表示されます。)
[右クリック]
[動画ウィンドウ]ショートカットメニューを表示します。
4.4.4
【動画ウィンドウ】ショートカットメニュー
①[スケールバーの表示/非表示]
[動画ウィンドウ]上のスケールバーの表示/非表示の切
り替えを行います。
②[クリップボードにコピー]
[動画ウィンドウ]に表示されている画像をクリップボー
ドにコピーします。
③[BMP 画像として保存]
[動画ウィンドウ]に表示されている画像をビットマップ
形式(.bmp)で保存します。
G-Count 取扱説明書
57
4.5 【Graph】パレット
4.5.1
名称と機能
①[時間変化グラフ]
計測した全フレームの計測データの時系列データ(Count、
Raw Intensity、Intensity、X、Y、X SD、Y SD)を表示し
ます。計測データの表示切り替えは[時間変化グラフ]
タブをクリックして行ないます。
②[TTL]ボタン
最初に計測した範囲内の輝点の計測データを表示します。
※[輝点抽出]ボタンで抽出した範囲の計測データは表
示されません。
③[1-5]ボタン
[輝点抽出]ボタンを使用して抽出した範囲の計測デー
タを表示します。
④[All]ボタン
ボタンをクリックすると、全ての[時間変化グラフ]が
表示されます。
⑤[/S]ボタン
[時間変化グラフ]の縦軸の単位を切り替えます。Count、
もしくは Count/Area(1/um~2)に切り替えることができま
す。
※[Intensity]は、選択アルゴリズムが Gauss Fitting,2D
Gauss Fitting の場合はガウス分布の Intensity のピーク値
の平均値を示し、選択アルゴリズムが Centroid の場合に
は ROI 中心の値から背景光を差し引いた値の平均値を示
します。
G-Count 取扱説明書
58
※背景光は、ROI の辺を使って、一次平面で取得します。
データとして取得していますが、記録はできません。
※[Raw Int]は、選択範囲内の輝点の[Raw Intensity 値-ROI
内の全ての Intensity の合計値]の平均値を示します。
4.5.2
[時間変化グラフ]上でのマウス操作
[ドラッグ]
[Graph]パレットの[時間変化グラフ]上をドラッグし
て範囲選択すると、選択範囲内のグラフを拡大すること
ができます。
[ダブルクリック]
[Graph]パレットの[時間変化グラフ]上をグラフ拡大
状態でダブルクリックすると、グラフを自動スケールす
ることができます。
[右クリック]
[Graph]パレットのショートカットメニューを表示し
ます。
4.5.3
【Graph]パレット ショートカットメニュー
①[BMP 画像として保存]
[時間変化グラフ]をビットマップ形式(.bmp)で保存
します。
G-Count 取扱説明書
59
4.6 【Histogram】パレット
4.6.1
名称と機能
①[Frame #]テキストボックス
記録された計測データのフレームナンバーを入力し、表
示されるフレーム毎の計測データを変更します。
②[Sync]チェックボックス
G-Count 取扱説明書
60
チェックボックスオン時、
[Frame #]テキストボックス
で選択データを変更した際に、[動画ウィンドウ]のフレ
ームが計測データの開始フレームと同期されて表示され
ます。
③[Current]ボタン
現在表示されているフレームの計測データを表示します。
④[▼]ボタン
[Extract グラフ]を表示(非表示)します。
⑤[Total Counts]ラベル
[Frame #]テキストボックスで指定したフレームの輝点
数を表示します。
⑥[Mean Value]ラベル
[Frame #]テキストボックスで指定したフレームの、計
測データ(X、Y、X SD、Y SD、Raw Intensity、Intensity)
の平均値を表示します。各データの切り替えは[Single
Image グラフ]タブをクリックして行ないます。
⑦[Single Image グラフ]
[Frame #]テキストボックスで指定したフレームの計測
データ(X、Y、X SD、Y SD、Raw Intensity、Intensity)
を表示します。各データの切り替えは[Single Image グラ
フ]タブをクリックして行ないます。
⑧[TOP][Left]
[Bottom][Right]ラベル
[輝点抽出]ボタンで抽出した範囲の座標軸を表示しま
す。
⑨[Counts]ラベル
[輝点抽出]ボタンで抽出した範囲の輝点数を表示しま
す。
⑩[Mean]ラベル
[輝点抽出]ボタンで抽出した範囲の、平均値を表示し
ます。
⑪[Extract グラフ]
[輝点抽出]ボタンで抽出した範囲の計測データ(X、Y、
X SD、Y SD、Raw Intensity、Intensity)を表示します。計
測データの表示切り替えは[Single Image グラフ]タブ、
及び[1-5]ボタンをクリックして行ないます。
G-Count 取扱説明書
61
4.6.2
[Single Image グラフ]上でのマウス操作
[ドラッグ]
[Histogram]パレットの[Single Image グラフ]上をド
ラッグして範囲選択すると、選択範囲内のグラフを拡大
することができます。
[ダブルクリック]
[Histogram]パレットの[Single Image グラフ]上をグ
ラフ拡大状態でダブルクリックすると、グラフを自動ス
ケールすることができます。
[右クリック]
[Histogram]パレットのショートカットメニューを表示
します。
4.6.3
[Extract グラフ]上でのマウス操作
[ドラッグ]
[Histogram]パレットの[Extract グラフ]上をドラッグ
して範囲選択すると、選択範囲内のグラフを拡大するこ
とができます。
G-Count 取扱説明書
62
[ダブルクリック]
[Histogram]パレットの[Extract グラフ]上をグラフ拡
大状態でダブルクリックすると、グラフを自動スケール
することができます。
[右クリック]
[Histogram]パレットのショートカットメニューを表示
します。
4.6.4
【Histogram】パレット ショートカットメニュー
①[BMP 画像として保存]
[Single Image グラフ]
、
[Extract グラフ]をビットマッ
プ形式(.bmp)で保存します。
4.7 【Trace Analysis】パレット
①[Data No.]テキストボックス
記録された追跡データのデータナンバーを入力します。
②[Data No.]スクロールバー
G-Count 取扱説明書
63
記録された追跡データのデータナンバーを、スクロール
バーを操作して選択し、表示される追跡データを変更し
ます。
③[▼]ボタン
[メイングラフ]、[サブグラフ]を表示(非表示)しま
す。
④[SYNC]チェックボックス
チェックボックスオン時、
[Data No.]スクロールバーで
選択データ変更時に、[動画ウィンドウ]の表示フレーム
が追跡データの開始フレームと同期されて表示されます。
⑤[Frame]チェックボックス
チェックボックスオン時、選択された追跡データの[動画
ウィンドウ]でのフレーム位置を、メイングラフでは赤色
の十字カーソルで、サブグラフ上では白色の十字カーソ
ルで表示します。
⑥[Centroid]チェックボックス
チェックボックスオン時、選択されている追跡データを
[動画ウィンドウ]上に緑色の十字カーソルで表示します。
⑦[Play]ボタン
ボタンをクリックすることにより、選択された追跡デー
タを追跡フレーム範囲内で繰り返し再生します。再度ボ
タンをクリックすると停止します。
⑧[メイングラフ]
選択された追跡データグラフを表示します。メイングラ
フをドラッグにより選択すると、選択範囲が拡大します。
メイングラフをダブルクリックすると自動スケールされ
ます。
⑨[Triming]ボタン
メイングラフに表示されている範囲の追跡データをトリ
ミング(抽出)します。メイングラフに表示されている範
囲のポイント数が[Tracking Control]の[Min #]で設定
した値未満の場合、実行することができません。
⑩[Copy]ボタン
メイングラフに表示されている範囲の追跡データをトリ
ミング(抽出)し、新しい追跡データとして追加します。
メイングラフに表示されている範囲のポイント数が
[Tracking Control]の[Min #]で設定した値未満の場合、
実行することができません。
⑪[Clear]ボタン
G-Count 取扱説明書
64
選択された追跡データを削除します。
⑫[Save]ボタン
選 択 さ れ た 追 跡 デ ー タ (Data No. 、 Frame No. 、 X
Position(pixels)、 Y Position(pixels)、 X SD(pixels)、 Y
SD(pixels)、 Intensity(A.U.))を保存します。
⑬[サブグラフ]
選択された追跡データの 6 種類のグラフを表示します。
[サブグラフ]上をダブルクリックすると、メイングラ
フに表示されます。
[X-Y グラフ]…選択された追跡データの X-Y Position
を表示します。
[ X Position グ ラフ ]… 選 択 さ れた 追 跡 データ の X
Position の時系列データを表示します。
[ Y Position グ ラ フ ]… 選 択 さ れ た 追 跡 デ ータ の Y
Position の時系列データを表示します。
[X SD グラフ]…[Gaussian]、
[2D Gaussian]チェック
ボックスオン時、選択された追跡データの X 軸における
標準偏差の時系列データを表示します。
[Gaussian]
、
[2D
Gaussian]チェックボックスオフ時には、X SD(pixels)は
「1」で固定されています。
[Y SD グラフ]…[Gaussian]、
[2D Gaussian]チェック
ボックスオン時、選択された追跡データの Y 軸における
標準偏差の時系列データを表示します。
[Gaussian]
、
[2D
Gaussian]チェックボックスオフ時には、Y SD(pixels)は
「1」で固定されています。
[Intensity グラフ]…選択された追跡データの蛍光強度
の時系列データを表示します。
4.7.1
【Trace Analysis】パレット ショートカットメニュー
ポイント
■メニュー表示
[Trace Analysis]パ
レッ トのグラ フ以 外
の場所を右クリック
①[データの初期化]
記録された追跡データ全てを初期化(削除)します。
G-Count 取扱説明書
65
②[データの一括保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、Y Position(pixels)、X SD(pixels)、Y SD(pixels)、
Intensity(A.U.))を一括で保存します。
③[全データを横並びに保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、 Y Position(pixels)、 X SD(pixels)、 Y
SD(pixels)、 Intensity(A.U.))を 1 つのファイル内に横並
びに保存します。
④[全データを縦並びに保存]
記録された全ての追跡データ(Data No.、Frame No.、X
Position(pixels)、 Y Position(pixels)、 X SD(pixels)、 Y
SD(pixels)、 Intensity(A.U.))を 1 つのファイル内に縦並
びに保存します。
4.7.2
[メイングラフ]上でのマウス操作
[ドラッグ]
[Trace Analysis]パレット[メイングラフ]上をドラッ
グして範囲選択すると、選択範囲内のグラフを拡大する
ことができます。
[ダブルクリック]
[Trace Analysis]パレット[メイングラフ]上をグラフ
拡大状態でダブルクリックすると、グラフを自動スケー
ルすることができます。
[右クリック]
[メイングラフ]ショートカットメニューを表示します。
4.7.3
[メイングラフ]ショートカットメニュー
①[BMP 画像として保存]
G-Count 取扱説明書
66
[メイングラフ]をビットマップ形式(.bmp)で保存し
ます。
4.7.4
[サブグラフ]上でのマウス操作
[ダブルクリック]
[Trace Analysis]パレットで、任意の[サブグラフ]を
ダブルクリックすると、メイングラフが切り替わります。
G-Count 取扱説明書
67
5 FAQ・トラブルシューティング
5.1 ハードウェア USB キー
5.1.1
ハードウェア USB キーが正しく動作しない
本ソフトウェアに付属のハードウェア USB キーが正しく起動し
ない場合、下記の手順で再インストールしてください。
注意
■メニュー選択
「G-Track」のハード
ウェア USB キー以外
に、センチネルシステ
ムド ライバを 使う ハ
ード ウェアを ご使 用
されている方は、それ
を利 用される ソフ ト
ウェ アのサポ ート へ
最新 版のドラ イバ と
の互 換性があ るか を
確認 してから イン ス
トールしてください。
1
CD-ROM ドライブに、本ソフトウェアデータディスクを挿入し
ます。
2
[スタート]ボタン→[すべてのプログラム]→[アクセサリ]
から[エクスプローラ]を選択して[マイコンピュータ]をダ
ブルクリックします。
3
CD-ROM ドライブに、G-Count と表示されているのを確認してダ
ブルクリックします。
G-Count 取扱説明書
68
4
ファイルの一覧から、Files フォルダをダブルクリックし、
LabVIEW_8.2.1_Runtime_Engine.exe をダブルクリックします。
LabVIEW ランタイムエンジンを画面の指示に従ってインスト
ールを行います。
※インストール時には、ハードウェア USB キー(ドングル)を
PC から取り外してください。
5.2 輝点選択・計測
5.2.1
輝点選択、計測時の速度が遅い
Speedy 設定にすることで速度が向上します。
注意
■Speedy 設定
Speedy では描画を行
いません。画面に変化
がありませんので、他
の操 作をしな いよ う
にご注意ください。
G-Count 取扱説明書
ビューツールバーの[Speedy]ボタンをクリックし、輝点を選択・
計測を実行してください。
69
5.2.2
手動で記録したい
[手動輝点選択]ボタンをクリック後、左ドラッグしながら任
意の輝点上で右クリックします。
POINT
■単輝点解除
一つ の輝点だ け解 除
したい場合は、左ドラ
ッグ しながら 選択 さ
れた 輝点上で 右ク リ
ックします。
5.2.3
※アルゴリズムが輝点と認識しない場合は選択されません。
※アルゴリズム[Hand-selected]を選択した場合は、右クリッ
クした場所が輝点として扱われます。
3D グラフの保存機能が動作しない
再度、[動画ウィンドウ]内をクリックし、ROI 内の情報をスキャ
ンします。
※[Raw Data in ROI]3D グラフ、
[GaussFit in ROI]3D グラフは、
[動画ウィンドウ]の[黄色の ROI]内の X,Y,I を 3D 表示します。
※計測実行直後など、[動画ウィンドウ]上に[黄色の ROI]が表示
されていない場合は、保存機能が動作しません。
5.2.4
保存したパラメータ設定が読み込めない
コンフィグファイル(拡張子.cfg)に保存したパラメータ設定は、
[ファイル]メニューの[既存の設定を読み込む]をクリック
し、コンフィグファイルを読み込んだ後、プロジェクトを新規
作成すると適応されます。
5.2.5
抽出時に取得するパラメータはどのような情報ですか?
輝点フィッティング時に下記パラメータを取得します。
a1 = ガウスのピーク値
a2,a3 = 中心座標
a4,a5 = SDx,SDy
a6-a8 = 背景光(一次関数)
[centroid]の計算時は下記のパラメータです。
a1 = 中心座標のピクセル値 - 背景光
a2,a3 = 中心座標
a4,a5; ダミー値
a6-a8 = 背景光(一次関数)
G-Count 取扱説明書
70
5.2.6
アルゴリズムの特徴、採用基準は?
各アルゴリズムの説明、特徴、採用基準は以下の通りです。
※取得されたデータが、輝点であるか否かの判断は、ご利用者
様ご自身でご確認ください。
■Centroid
○アルゴリズム解説
・重心位置における中心の輝度を閾値として、輝点か否かを判
断
○特徴
・計算が簡単である為、処理速度が速い
・理想輝点でなくても、重心位置を計算できる
・ノイズが多い場合に精度が低く、ROI の大きさ、背景光で解が
変化する
○採用基準
・背景と輝点の明度差が大きく、輝点が円でない場合
■Gaussian Fitting
○アルゴリズム解説
・XY平面それぞれにおける投影図を利用し、重心位置を計算
○特徴
・楕円形輝点近似に優位
・処理速度が速い
・照明班の影響を受けにくく、画像処理せずに解析可能
・輝点の強度、輝点の広がり、位置を取得可能
・ノイズに弱い
○採用基準
・背景と輝点の明度差が少ないが、輝点が明るく明らかな場合
■2D Gaussian Fitting
○アルゴリズム解説
・二次元ガウス関数で近似
○特徴
・高精度での解析可能
・照明班の影響を受けにくく、画像処理せずに解析可能
・輝点の強度、輝点の広がり、位置を取得可能
・反復法であるため、計算に時間を有する
○採用基準
・背景と輝点の明度差が少ないが、輝点がノイジックな場合
・正確性をあげたい場合
G-Count 取扱説明書
71
5.3 その他
5.3.1
G-Count と G-Track の違いについて
輝点計測(カウンティング)に特化したソフトウェアが G-Count、
輝点追跡に特化したソフトウェアが G-Track です。
設計コンセプト、用途と処理の流れは下記のとおりです
双方共通のコンセプト
・輝点を抽出し解析する際の手間を軽減し、ユーザーの時間節
約に役立てる。
・2 値化(閾値法)などの画像処理を行わない新しいアルゴリズム
により、細胞内など背景光に斑がある場合でも、粒子の像を抽
出できる。
・近似計算の反復数を、~十回程度にまで減少させ、計算スピ
ードを向上。
・上記により、網羅的輝点抽出が可能である。
輝点計測ソフト G-Count
○コンセプト
動画内における、輝点を全て抽出し、データベース化する。
○用途
・蛋白質 1 分子の個数解析、短い運動の解析、細胞のカウント
など。
・追跡対象が多く(~1000 個)、追跡時間がせいぜい~100 フレー
ムの場合に有効。
(画像を網羅的にスキャンするので、輝点が 1 点でも 100 点でも
計算スピードは変わらない)
○解析の流れ
動画内における、輝点を全て抽出し、データベース化する→フ
レーム毎の統計解析
↓
それを元に時間的に連続している輝点を繋げて行く(この動作で
追跡と同じ効果)
↓
解析
輝点追跡ソフト G-Track
G-Count 取扱説明書
72
○コンセプト
蛍光輝点(像)の位置をフレームを追って『追跡する』
。
○用途
・蛋白質 1 分子の運動解析、小胞輸送、細胞運動の追跡など。
・追跡対象が少なく(~100 個)、追跡時間が数百から数千フレー
ムに及ぶ場合に有効。
○解析の流れ
一つの蛍光像の運動を、追跡し、数値データとする
↓
それを何度も繰り返し、データ群を作る
↓
統計解析
G-Count 取扱説明書
73
(C)2008 G-Angstrom
平成21年5月20日改訂
本書の内容の一部、または全部を株式会社ジーオングストロームの許可なく複製、送信、
複写することを禁じます。
G-Count 取扱説明書
74
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement