IV設計支援ソフト IV-S30SP 取扱説明書

IV設計支援ソフト IV-S30SP 取扱説明書
改訂2.0版
2000年9月作成
IV用設計支援ソフト
形名
IV-S30SP
取 扱 説明書
<対応機種>
・IV-S30
(IV-S31M/S32M/S33M)
・IV-S20
このたびは、IV 用設計支援ソフト IV-S30SP をお買いあげいただき、まことにありがとうございます。
ご使用前に、本書をよくお読みいただき、本ソフトの機能/操作方法等を十分理解したうえ、正しくご使用
ください。
なお、本書は必ず保存してください。万一、ご使用中にわからないことが生じたとき、きっとお役に立ちます。
また、IV-S30/S20 には下記マニュアルがありますので、本書と共にお読みください。
・IV-S30
(IV-S31M/S32M/S33M)
・IV-S20
ユーザーズマニュアル(導入・ハード編)
ユーザーズマニュアル(機能・操作編)
導入マニュアル
ユーザーズマニュアル
ソフトバージョンについて
本書では、IV-S30SPのソフトバージョンがV2.10について記載しています。なお、バージョンアップ内容
(バージョンV2.00に対する追加機能)
は次のとおりです。
■ ソフトバージョンV2.10の追加機能
(V2.00に対して)
項 目
追加機能
コントローラ対応 IV-S31M/S32Mのソフトバージョンアップ(V1.15→V2.02)
による追加機能に対応
パラメータ変換
・IV-S31M/S32M
(V2.02)⇔ IV-S33Mのパラメータ変換機能を追加
・IV-S31M/S32M
(V2.02)⇔ IV-S31M/S32M
(V1.15以下)
のパラメータ変換機能を
追加
おねがい
・本書の内容および本ソフトウェアについては十分注意して作成しておりますが、万一ご不審
な点、お気付きのことがありましたらお買いあげの販売店、あるいは当社までご連絡くださ
い。
・本書および本ソフトウェアの内容の一部または全部を、無断で複製することを禁止していま
す。
・本書の内容および本ソフトウェアは、改良のため予告なしに変更することがありますので、
あらかじめご了承ください。
・本ソフトウェアを使用したことによるお客様の損害、および逸失利益、または第三者からの
いかなる請求につきましても、当社はその責任を負いかねますので、あらかじめご了承くだ
さい。
お客様へのお願い
弊社は別添の登録カードをご返却いただくことにより本契約書に同意いただいた方にのみ、本ソフトウェアを提供
致します。
ソフトウェア使用許諾契約書
お客様(以下、甲と言う)に対し、シャープマニファクチャリングシステム株式会社(以下、乙と言う)は本契約にもと
づき提供するソフトウェア(以下、本ソフトウェアと言う)使用に関する譲渡不能かつ非独占的な権利を下記条項により
承諾するものとし、お客様は下記条項にご同意いただくものとします。
1.使用許諾範囲
5.契約解除
甲は、本契約にもとづき使用許諾されたソフトウェア
1)乙は、甲が本契約のいずれかの条項に違反した時
を、対応動作環境
(裏面参照)
のパーソナルコンピュータ
は、甲に対し何等の通知、催告を行うことなく直ち
(以下、パソコンと言う)
1台のみで使用することができ
ます。
甲は、乙の書面による同意を得なければ、本契約によ
に解除することができます。
2)前号の場合、乙は甲によってこうむった損害を甲に
請求することができます。
る使用権の譲渡および第三者への許諾はできません。 3)甲は解約しようとする日の1ケ月前までに乙に書面
また本契約で定められている場合を除き、本ソフトウェ
で通知することによって本契約を解除することがで
アの全部または一部を印刷または複製することはできま
せん。
2.本ソフトウェアの複製
きます。
6.契約終了後の義務
甲は、前項によって本契約が終了した時は、1ケ月以
1)甲は、乙からパソコンに読み込み可能な形式で提供
内に乙から提供を受けた本ソフトウェアのオリジナル及
された本ソフトウェアの全部または一部を、下記の
びすべての複製物
(改良ソフトウェアを含む)
を破棄した
場合、パソコンに読み込み可能な形で1部まで複製
その旨を証明する文書を乙に送付するか、これらを甲の
することができます。
費用負担により乙に返還するものとします。但し、乙の
(1) 本ソフトウェアを予備のため保存する目的の場合。
(2) パソコンで甲が使用するため本ソフトウェアを改良
する場合。
書面による事前の承諾を得た場合は、甲は保存用の複製
物を1部保有することができます。
7.譲渡等の禁止
2)甲は、前号にもとづく複製物について保有数並びに
甲は乙の書面により事前の同意を得ることなく本ソフ
管理場所を記録するものとし、乙より問い合わせが
トウェアの全部または一部をいかなる形態においても第
あればこれに応ずるものとします。
三者に譲渡したり、転貸したり若しくは使用させたりす
3)甲が乙から提供された本ソフトウェアそのものはも
とより、甲が複製したソフトウェアも乙の所有物と
なります。但し、本ソフトウェアが記録されている
媒体は甲の所有物となります。
4)甲は、甲のみが使用する場合に限って、本ソフト
ウェアを改良すること並びに他のソフトウェアと組
み合せて、新たなソフトウェアを作ることができま
す。
5)甲は、乙から提供された取扱説明書等の印刷物を複
写できません。
3.著作権表示
甲は、本ソフトウェアのすべての複製物並びに改良ソ
フトウェアに本ソフトウェアの表示と同様の著作権表示
ることはできません。
8.秘密保持
甲は乙から提供された本ソフトウェアに関する情報及
びノウハウを公開若しくは第三者に漏洩しないものとし
ます。
9.限定保証
乙は本ソフトウェアに関して、いかなる保証も行いま
せん。従って、甲が本ソフトウェアを使用することに
よって如何なる損害が生じても乙は一切責任を負いませ
ん。但し、本ソフトウェアの提供後1年以内に乙が本ソ
フトウェアの誤りを修正したソフトウェアを発表した時
には、そのソフトウェアまたはそれに関する情報の提供
に最大の努力を払うことを唯一の責任とします。
をしなければなりません。
4.契約の有効期間
本契約の有効期間は、甲が本ソフトウェアを受け取っ
た日から解除、解約等によって本契約が終るまでとしま
〒581-8581 大阪府八尾市跡部本町4丁目1番33号
す。
電話(0729)91-0681
■ パソコンの動作環境
本ソフトは下記の動作環境を備えているパソコンで使用できます。
仕 様
項 目
パソコン
IBM PC/AT(互換機)
CPU
Pentium 90MHz以上(Pentium 133MHz以上を推奨)
オペレーティングシステム
Microsoft Windows 95/98
Microsoft Windows NT4.0
メモリ
32Mバイト以上(48Mバイト以上を推奨)
ハードディスク
30Mバイト以上の空きエリア
モニタ
SVGA以上(解像度 800×600ドット、256色以上)
推奨ディスプレイカラー High color(16ビット)
以上
CD-ROMドライブ
1台
RS-232Cポート
1ポート以上
マウス
Microsoftマウスまたは互換性のある
ポインティングデバイス
プリンタ
Windows 95/98/NT環境で使用可能なプリンタ
USBポート
推奨1ポート(Windows 98のみ USBをサポート)
Windowsは、米国Microsoft Corporationの登録商標です。
Pentiumは、米国Intel Corporationの登録商標です。
は
じ
め
に
セ ッ ト ア ッ プ
■ IV-S30編
第1章
メ
第2章
オ
プ
シ
ョ
ン
設
定
第3章
パ
ラ
メ
ー
タ
設
定
第4章
パラメータ、画像の読出/書込
第5章
フ
第6章
ド
第7章
デ
第8章
ユーザーメニューエディタ
第9章
コ
第10章
バ
第11章
■ IV-S20編
第1章
そ
の
他
の
機
能
メ
ニ
ュ
ー
構
成
第2章
通
第3章
品
種
別
条
件
の
設
定
第4章
ド
キ
ュ
メ
ン
ト
作
成
第5章
デ
第6章
第6章
第7章
第7章
パ
パラ
ラメ
メー
ータ
タ、
、画
画像
像の
の読
読出
出/
/書
書込
込
コ
コ マ
マ ン
ン ド
ド テ
テ ス
ス ト
ト
第8章
第8章
第9章
第9章
バ
バ
そ
そ
ニ
ュ
ァ
キ
イ
ュ
マ
構
ル
メ
ー
ン
操
ト
タ
ン
ー
ー
ジ
収
ド
ョ
作
テ
ン
信
ッ
設
ー
ー
ー ジ
ジ ョ
ョ
の
他
の
他
タ
作
成
集
ス
ア
成
ト
プ
定
収
ン
ン ア
ア ッ
ッ
の
機
の
機
集
プ
プ
能
能
目 次
はじめに ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ は・1∼3
〔1〕特長 1・1
〔2〕パソコンの動作環境 は・2
〔3〕システム構成 は・2
〔4〕製品構成 は・3
〔5〕ユーザーファイル は・3
セットアップ ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ セ・1∼8
〔1〕IV-S30SPのインストール セ・1
〔2〕Windows環境の設定 セ・5
〔3〕USBドライバのインストール
(IV-S30用を使用時) セ・6
【IV-S30
編】
0編
第1章 メニュー構成 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 1・1∼4
第2章 オプション設定 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 2・1∼4
2−1 通信設定 2・1
2−2 転送条件 2・3
2−3 バージョンアップ条件 2・4
第3章 パラメータ設定 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 3・1∼14
3−1 計測条件の設定 3・4
3−2 判定条件の設定 3・5
3−3 数値演算の設定 3・6
3−4 出力条件の設定 3・10
3−5 距離角条件の設定 3・13
第4章 パラメータ、画像の読出/書込 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 4・1∼5
4−1
4−2
4−3
4−4
4−5
読出し 4・1
書込み 4・2
照合 4・2
初期化 4・4
自己診断 4・5
第5章 ファイル操作 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 5・1∼2
第6章 ドキュメント作成 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 6・1∼4
6−1 ドキュメント作成(プロジェクトファイル)
6・1
6−2 ドキュメント作成(IV-S30 パラメータロード)
6・3
第7章 データ収集(計測結果/NG画像) ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 7・1∼5
目・1
第8章 ユーザーメニューエディタ ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 8・1∼9
8−1 起動方法 8・1
8−2 読出し 8・2
8−3 書込み 8・2
8−4 ユーザーメニュー初期化 8・3
8−5 タイトル編集 8・4
8−6 文字列編集 8・5
8−7 メニュー編集 8・6
8−8 ユーザーメニューの作成 8・7
8−9 運転画面の作成 8・8
8− 10 ファイル操作 8・9
第9章 コマンドテスト ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 9・1∼3
第10章 バージョンアップ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 10・1∼2
第11章 その他の機能・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 11・1∼3
〔1〕印刷 11・1
〔2〕メッセージ色の変更 11・1
〔3〕ズーム 11・2
〔4〕画像輝度の設定 11・2
〔5〕SMS Webページ 11・3
【IV-S20
編】
0編
第1章 メニュー構成 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 1・1∼5
第2章 通信設定 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 2・1
第3章 品種別条件の設定 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 3・1∼15
3−1 計測条件の設定 3・2
3−2 判定条件の設定 3・3
3−3 数値演算の設定 3・4
3−4 出力条件の設定 3・8
3−5 操作例
(位置ずれ計測)
3・11
第4章 ドキュメント作成 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 4・1∼4
4−1 ドキュメント作成(IV-S20 のパラメータ) 4・1
4−2 ドキュメント作成(ファイルデータ)
4・3
第5章 データ収集 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 5・1∼4
第6章 パラメータ、画像の読出/書込 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 6・1∼8
6−1 設定パラメータのセーブ
(保存) 6・1
6−2 設定パラメータの照合 6・3
6−3 設定パラメータのロード 6・4
目・2
6−4 画像の読出/書込 6・5
〔1〕画像(表示画像、メッセージ)の読出 6・5
〔2〕画像(表示画像)の書込(ロード) 6・7
第7章 コマンドテスト ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 7・1∼3
第8章 バージョンアップ ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 8・1∼2
第9章 その他の機能 ・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・・ 9・1∼2
〔1〕クリップボードへコピー 9・1
〔2〕メッセージ色の変更 9・1
〔3〕画像輝度の設定 9・2
目・3
はじめに
は
じ
め
に
は
IV-S30SP(以下、本ソフト)
は、小型画像センサカメラIV-S30/S20のデータ設定から検査結果の管理・分析ま
で、パソコンのWindows95/98/NT4.0画面上で行える設計支援ソフトです。
〔1〕機能
●ライン停止なしに品種別条件の設定/変更が可能なオフライン設定機能。
●設定パラメータを管理/保存できる自動ドキュメント作成機能。
●IV-S30/S20からパソコンへ計測結果を転送する計測データ収集機能。
●E-MAILやインターネット経由でのサンプル評価や複数台のIV-S30/S20へのデータコピーも簡単に行え
る設定データ・アップ/ダウンロード機能。
●取り込んだ画像をパソコンからプリントできる画像データ出力機能。
●機能アップやトラブル対策も簡単なIV-S30/S20バージョンアップ機能。
●ユーザー専用画面が作成可能なメニューカスタマイズ機能
(ユーザーメニューエディタ)。
●USBインターフェイスにより転送速度を大幅に向上。
(IV-S30でWindows98のみ)
●IV-S30SPには、IV-S30用とIV-S20用があり、相違点を下記に記載。
[IV-S30用とIV-S20用の機能相対表]
機能
IV-S30用
IV-S20用
パラメータの設定機能
・品種別条件
・グローバル条件
・基準画像
パラメータのロード/セーブ
ドキュメント作成機能
データ収集機能
ユーザーメニューエディタ機能
コマンドテスト機能
バージョンアップ機能
印刷
メッセージ色変更
ズーム
画像輝度変更
SMS Webページのリンク
○
○
○
○
○
○
○
○
○
○
○
○
○
○
○
○
○
×
○
○
○
○
×
○
○
○
○
×
○
×
は・1
はじめに
は
〔2〕パソコンの動作環境
本ソフトは下記の動作環境を備えているパソコンで使用できます。
仕 様
項 目
パソコン
IBM PC/AT(互換機)
CPU
Pentium 90MHz以上(Pentium 133MHz以上を推奨)
オペレーティングシステム
Microsoft Windows 95/98
Microsoft Windows NT4.0
メモリ
32Mバイト以上(48Mバイト以上を推奨)
ハードディスク
30Mバイト以上の空きエリア
モニタ
SVGA以上(解像度 800×600ドット、256色以上)
推奨ディスプレイカラー High color(16ビット)
以上
CD-ROMドライブ
1台
RS-232Cポート
1ポート以上
マウス
Microsoftマウスまたは互換性のある
ポインティングデバイス
プリンタ
Windows 95/98/NT環境で使用可能なプリンタ
USBポート
推奨1ポート(Windows 98のみ USBをサポート)
・Windowsは、米国Microsoft Corporationの登録商標です。
・Pentiumは、米国Intel Corporationの登録商標です。
〔3〕システム構成
● IV-S30に使用する場合
INPUT
X0
Y0
X1
Y1
X2
Y2
X3
Y3
X4
Y4
X5
Y5
X6
Y6
X7
Y7
VIDEO
CAMERA1
CAMERA2
COM +24V
READY COM
OUTPUT
0V
IV-S3*M
POWER
USB
RS232C/RS422
コントローラ:IV-S31M/S32M/S33M
(平面)
※1
USBケーブル
REMOTE
通信コネクタ
(USB)
通信コネクタ
(RS232C/RS422)
パソコン
本ソフト
IBM PC/AT
(互換機)
(IV-S30SP)
コントローラ
(側面)
※1
RS-232C通信ケーブル
※1 USBケーブルとRS-232C通信ケーブルは、本ソフトの付属品です。
配線図は、IV-S30ユーザーズマニュアル
(導入・ハード編)
の「パソコンとの配線」を参照願います。
は・2
はじめに
● IV-S20に使用する場合
IV-S20
INPUT
X0
X1
Y0
X2
Y1
X3
Y2
POWER
POWER
X4
Y3
X5
Y4
X6
Y5
Y6
C(+) +24V 0V
Y7 BUSY C(−)
OUTPUT
VIDEO CAMERA1
▼
CAMERA2
▼
RS232C/RS422
は
IV-S20本体
(上面)
REMOTE
IV-S20本体
(側面)
通信コネクタ
(RS232C/RS422)
パソコン
本ソフト
IBM PC/AT
(互換機)
(IV-S30SP)
※2
RS-232C通信ケーブル
※ 2 RS-232C 通信ケーブルは本ソフトの付属品です。
配線図はIV-S20ユーザーズマニュアルの
「パソコンとの配線」を参照願います。
〔4〕製品構成
・CD-ROM 1枚
・取扱説明書 1冊
・RS-232C通信ケーブル
(1.5m)1本
[コネクタ−−−9ピンD-subオス
(IV-S30/S20側)
+9ピンD-subメス
(パソコン側)]
・USBケーブル(3m)1本
・ユーザー登録カード 1枚
〔5〕ユーザーファイル
本ソフトで読出/書込の可能なユーザーファイルを示します。
拡張子
分 類
プロジェクトファイル
(IV-S30パラメータ)
apm
表示画像
bmp
コマンドテスト
tst
IV-S30/S20システムソフト
mot
ドキュメント/データ収集
csv
品種別設定条件
msr
グローバル条件
prm
基準画像
bmp
は・3
セットアップ
セ ッ ト ア ッ プ
アプリケーション・ソフトをパソコンに組み込んで使用できる状態にすることを「セットアップ」といいま
す。本章では、本ソフトのセットアップ手順を説明します。
なお、本ソフトはWindows 95/98/NTで動作しますが、ここではWindows 98で説明します。
セ
(注)
本ソフトのインストールは、ウィルスチェックプログラムを無効
(働かない状態)
にして行ってくださ
い。
〔1〕IV-S30SPのインストール
ラベル面を上にして
CD-ROMをセットする
1.Windows 98を起動して、IV-S30SPのCD-ROMを
パソコンのCD-ROMドライブにセットします。
(注)CD-ROMにはシール等を貼らないでください。
2.CD-ROMをセットしたCD-ROMドライブのアイコンをダブルクリックして開きます。
CD-ROMの中には、IV-S20用とIV-S30用のディレクトリがあります。
(下記参照)
IV-S20 編参照
IV-S30 編参照
・IV-S30 用を使用の場合
[IVS30SP]-[IVS30]を選択して、
「setup.exe」をダブルクリックします。⇨3. へ
・IV-S20用(日本語)を使用の場合
[IVS30SP]-[IVS20]-[JAPANESE]を選択して、
「setup.exe」をダブルクリックします。⇨4. へ
・IV-S20用(英語)を使用の場合
[IVS30SP]-[IVS20]-[ENGLISH]を選択して、
「setup.exe」をダブルクリックします。⇨4. へ
3.セットアップ対象のOSに、日本語または英語を選択してください。
以下、IV-S30 用を使用時の画面で説明します。
(IV-S20 用を使用時は、画面メッセージの「IV-S30SP」が「IV-S20SP」に変わります。
)
4.セットアッププログラムが起動し、セットアップ準備を始めます。
セットアップ準備が完了すると、右のダイアログ
ボックスが表示されます。
セ・1
セットアップ
5.
[次へ]ボタンをクリックすると、次のダイアログボックスが表示されます。
セ
6.インストール先のフォルダ
(ディレクトリ)
がそのままでよければ、
[次へ]
ボタンをクリックします。
インストール先を変更する場合は、
[参照]
ボタン
をクリックすると、
[ディレクトリの選択]
ダイア
ログボックスが表示されますので、ドライブ、
フォルダを指定し、[OK]ボタンをクリック後、
[次へ]ボタンをクリックします。
7.
[次へ]
ボタンをクリックすると、
[プログラムフォルダの選択]
ダイアログボックスが表示されます。
セ・2
セットアップ
8.プログラムフォルダがそのままでよければ、[次へ]ボタンをクリックします。
変更する場合は、新しいフォルダ名を入力するか、既存のフォルダリストから選択後、
[次へ]ボ
タンをクリックするとセットアップが開始されます。
セットアップが完了すると、次のダイアログボックスが表示されます。
9.
[完了]ボタンをクリックすると、セットアップ開始時の画面に戻ります。
セ・3
セ
セットアップ
10.本ソフトの起動は、Windows 98のスタートメニュー上の
[プログラム]
[Sms]
[IVS30SP]
のク
リックで行います。
セ
本ソフトが起動され、下記画面が表示されます。
・IV-S20用を使用時
(セ・1ページ参照)
11.本ソフトの終了は、メニューバーの
[ファイル]
[終了]
のクリックで行います。
・IV-S20用を使用時(セ・1ページ参照)
⇒ 終了確認のダイアログボックスが表示されます。
・[はい]をクリックすると本ソフトが終了します。
セ・4
セットアップ
・ボタンで終了するときは、ウィンドウの右上端の
をクリックします。
クリック
セ
⇒ 終了確認のダイアログボックスが表示されますので、
[はい]をクリックします。
〔2〕Windows環境の設定
1. タスクバーのメニューより[設定]→[コントロールパネル]を選択します。
2.[画面のプロパティ]
を開いて、
「ディスプレイの詳細」
の
「カラーパレット」と
「フォントサイズ」
を設
定してください。
フォントサイズは
「小さいフォント」に設定してください。
カラーパレットは
「256色以上」に設定してください。
セ・5
セットアップ
〔3〕USBドライバのインストール(IV-S30用を使用時)
1. コントローラ(IV-S31M/S32M/S33M)に電源を投入します。
セ
2. この状態で、USBケーブルを使用してパソコンとコントローラを接続すると
[新しいハードウェア
の追加ウィザード]ダイアログボックスが表示され、
「不明なデバイスが接続されました」
と表示さ
れます。
セ・6
セットアップ
3.[次へ]ボタンをクリックすると、検索方法の選択画面に切り替わります。
「使用中のデバイスに最
適なドライバを検索する
(推奨)」を選択して、[次へ]ボタンをクリックします。
セ
4. IV-S30SPのCD-ROMにUSBのデバイスドライバが入っています。
お使いのパソコンのCD-ROMドライブがEドライブの場合、検索場所の指定に
「E:¥driver」
と入力し
て、
「次へ」ボタンをクリックします。
5.「ivs30usb Device」と表示され、[完了]ボタンを押すと終了です。
セ・7
セットアップ
6. 確認のため
[コントロールパネル]
[システム]
からデバイスツリーを見ます。下図のようにIvs30usb
Deviceが表示されていれば、デバイスドライバの組み込みは完了です。
セ
セ・8
■ IV-S30編
第1章 メニュー構成
本ソフト(IV-S30用)を起動すると下記画面が表示されます。メニューバーの各メニューについてメニュー
構成を示します。
下記の
(1)∼(7)は次ページ以降の項目に対応しています。
IV-S30編
第 1 章 メ ニ ュ ー 構 成
1
(1)
(2)
(4)
(3)
・本ソフト
(IV-S30用)
を起動時の画面
1・1
(5)
(6)
(7)
第1章 メニュー構成
(1)ファイル
(F)
IV-S30編
(操作内容)
1
新規作成(N) Ctrl+N
新規にファイルを作成する
開く(O) Ctrl+O
保存された表示画像を開く(*.bmp/*.msr/*.prm)
表示画像を保存(S) Ctrl+S
表示画像のみファイル保存する
プロジェクトを開く(W)
コントローラのパラメータなどのプロジェクトファイルを開く
プロジェクトを保存(V)
コントローラのパラメータなどのプロジェクトファイルを保存する
名前をつけてプロジェクトを保存(E) コントローラのパラメータなどのプロジェクトファイルを別名で保存する
プロジェクトを閉じる(K)
コントローラのパラメータなどのプロジェクトファイルを閉じる
プロパティ(I)
プロジェクト名・機種名(IV-S31M/32M/33M等)
を表示する
ページ設定(U)
印刷ページの設定を行う
印刷(P) Ctrl+P
印刷する
終了(X)
IV-S30SPを終了する
(2)編集
(E)
切り取り
(T) Ctrl+X
(操作内容)
IV-S30SP上に表示された画像を切り取る
コピー
(C)Ctrl+C
IV-S30SP上に表示された画像をコピーする
貼り付け
(P)Ctrl+V
IV-S30SP上に表示された画像を貼り付ける
追加
(A)
品種別条件の品種の追加をする
削除
(D)
IV-S30SP上に表示された画像を消去する
1・2
第1章 メニュー構成
ツールバー(T)
(操作内容)
標準
ツールバーの表示/非表示を切り替える
表示画像
表示画像用ツールバーの表示/非表示を切り換える
ステータスバー(B)
ステータスバーの表示/非表示を切り替える
表示画像モニタ(M)
表示画像ウィンドウの表示/非表示を切り換える
パラメータリスト(P)
パラメータリストボックスの表示/非表示を切り換える
ズーム+(U)
表示画像をズームアップする
ズーム−(D)
表示画像をズームダウンする
ズーム比率(F)
25/50/75/100%の表示画像サイズを設定する
IV-S30編
(3)表示
(V)
1
100%、75%、50%、25%
表示画像輝度(B)
標準/1/2など、表示画像の輝度を切り換える
標準、1/2
メッセージ色(C)
メッセージの色を指定の色に変更する
黒、青、緑、シアン、赤、
マゼンタ、黄、白
(4)IV通信
(I)
IV転送(T)
(操作内容)
書き込み(W)
コントローラへパラメータ・表示画像などの書き込みを行います。
読み出し(R)
コントローラへパラメータ・表示画像などの読み出しを行います。
照合(V)
コントローラへパラメータ・表示画像などの照合を行います。
初期化(I)
コントローラへパラメータ・表示画像などの初期化を行います。
自己診断(S)
コントローラへパラメータ・表示画像などの自己診断を行います。
バージョンアップ(V)
コントローラのバージョンアップの設定を行います。
オプション(O)
通信・IV転送・バージョンアップ条件の設定を行う。
1・3
第1章 メニュー構成
IV-S30編
(5)ツール
(T)
1
(操作内容)
コマンドテスト
(T)
コントローラと通信テストを行う
データ収集
(D)
コントローラの計測実行データをパソコンに取り込み
データ集計を行う
ドキュメント作成(C)
IVパラメータ設定内容のドキュメントを作成する
ユーザーメニューエディタ(M)
IVのメニュー・文字を作成・変更する
(6)ウィンドウ
(W)
(操作内容)
重ねて表示(C)
ウィンドウ内のフォームを重ねて表示する
上下に並べて表示(H)
ウィンドウ内のフォームを上下に並べて表示する
左右に並べて表示(V)
ウィンドウ内のフォームを左右に並べて表示する
(7)ヘルプ
(H)
(操作内容)
目次
(C)
ヘルプの目次を表示する
トピックの検索(S)
ヘルプのトピックを検索する
SMS Webページ
(W)
SMSのホームページを開く
バージョン情報(A)
IV-S30SPのバージョン情報を表示する
1・4
第2章 オプション設定
パソコンとIV-S30間で通信する場合の通信設定・IV転送条件・バージョンアップ条件などを設定します。
・コントローラの機種設定については、5・2ページを参照願います。
2−1 通信設定
[IV通信]
メニューの[オプション]をクリックします。
IV-S30編
第 2 章 オプション設定
2
クリック
⇒[オプション]ダイアログボックスが表示されます。
■ シリアル通信
[通信方法]を
「シリアル」に設定し、その他の通信条件を設定してください。
(注:通信条件の内容は、IV-S30の
[システム条件]−[通信設定]に合わせてください。)
クリック
2・1
第2章 オプション設定
■ USB通信
IV-S30編
[通信方法]を
「USB」に設定し、その他の通信条件を設定してください。
2
クリック
USB転送 ・単独:局番指定したIV-S30のみ転送を行います。
・複数:USBケーブルで繋がっているIV-S30の全てに対して転送を行います。
2・2
第2章 オプション設定
2−2 転送条件
[オプション]ダイアログボックスの[IV転送条件]をクリックして、その他の転送条件を設定して
IV-S30編
ください。
2
[パラメータ]=IV-S30に設定されている全パラメータ
品種別条件:品種単位で設定している条件(計測条件等)
グローバル条件:全品種共通の設定条件(システム条件等)
基準画像:IV-S30に登録されている全基準画像
タイトル&文字列:IV-S30で使用されている全タイトルと文字列(この項目は転送に時間
を要するため、ユーザーメニューエディタでタイトル・文字列を変更
していない場合は、読み出さないことを推奨します。)
[グレー画像]=256階調
取込画像:運転画面で表示されている画像
前処理画像:濃度ムラ補正、2値画マスク処理後画像
回転画像:取込画像を回転補正された画像
ワークエリア:計測実行に使用する画像
・全画像/部分画像取込のどちらかを選択
[2値画像]
パターン表示:運転画面の計測実行されたサーチ領域などの枠線
文字表示:IV-S30の画面に表示された画像
2値画像:取込画像を2値化処理された画像
[NG画像]=IV-S30に取り込まれているNG画像
2・3
第2章 オプション設定
2−3 バージョンアップ条件
[オプション]ダイアログボックスの[バージョンアップ条件]
をクリックして、その他のバージョ
IV-S30編
ンアップ条件を設定してください。
2
[バージョンアップタイプ]
初期化無し:IV-S30の初期化を行わない
全初期化:IV-S30の初期化を行う
[転送プログラム]
ブート:IV-S30のブートプログラム
システム:IV-S30のシステムプログラム
2・4
第3章 パラメータ設定
第 3 章 パラメータ設定
品種別の条件(計測条件、判定条件、数値演算、出力条件など)を設定します。
・コントローラの機種設定については、5・2ページを参照願います。
■ 新規品種の追加
1. パラメータリストの
[品種別条件]タグをクリックし、[新規品種]メニューを右クリックして、
[追加]を
クリックします。
(ダブルクリックしても追加可能)
クリック
⇒[追加]ダイアログが表示されます。
2. 追加する品種番号を設定して、
[OK]ボタンをクリックします。
⇒ 新規の品種番号が追加されます。
3・1
IV-S30編
・オフラインでの設定/変更が可能です。
(生産ライン等の稼働中も、ラインを停止せずに設定/変更が可
能です。)
3
第3章 パラメータ設定
■ 計測条件の設定:計測0カメラ1(位置ずれ計測)の場合
1.[計測0カメラ1条件]
をダブルクリックします。
IV-S30編
ダブルクリック
3
⇒[計測0 カメラ1条件]ダイアログが表示されますので、[位置ずれ計測]
をクリックします。
クリック
2.「位置ずれ計測」
をクリックして[閉じる]ボタンをクリックします。
⇒「計測0カメラ1条件」
に「位置ずれ計測」が追加されます。
3.「位置ずれ計測」
の「計測条件」
をダブルクリックします。⇒ 次ページへ
ダブルクリック
3・2
第3章 パラメータ設定
IV-S30編
⇒ 位置ずれ計測の設定画面が表示されます。
3
3・3
第3章 パラメータ設定
3−1 計測条件の設定
[品種別条件]
タグのパラメータリストで[計測条件]をダブルクリックすると、
「計測条件」画面が
IV-S30編
表示されます。
■ 操作内容:位置ずれ計測
(2点サーチ)の場合
位置ずれ計測の設定画面
(前ページ)
で、登録条件の
[▼]
をクリックして、
「2点サーチ」
をクリックしま
す。
3
クリック
⇒「2点サーチ」用の「計測条件」画面が表示されます。
設定内容の詳細は、「IV-S30ユーザーズマニュアル」
を参照願います。
3・4
第3章 パラメータ設定
3−2 判定条件の設定
[品種別条件]
タグのパラメータリストで[判定条件]をダブルクリックすると、
「判定条件」画面が
表示されます。
IV-S30編
■ 操作内容:位置ずれ計測
(2点サーチ)の場合
パラメータリストの[判定条件]メニューをダブルクリックします。
3
ダブルクリック
⇒「2点サーチ」用の「判定条件」
画面が表示されます。
登録番号の設定部
モデル0の設定部
角度ズレの設定部
モデル1の設定部
設定内容の詳細は、「IV-S30ユーザーズマニュアル
(機能・操作編)」を参照願います。
3・5
第3章 パラメータ設定
3−3 数値演算条件の設定
[品種別条件]
タグのパラメータリストで[数値演算条件]をダブルクリックすると、
「数値演算」画
IV-S30編
面が表示されます。
■ 操作内容:位置ずれ計測の場合
パラメータリストの[数値演算条件]
メニューをダブルクリックします。
3
ダブルクリック
⇒ 位置ずれ計測の「数値演算条件」画面が表示されます。
・演算結果番号を選択し、登録を
「有」
に設定すると、数値演算の各設定
(種類、式、判定、出力)
を行え
ます。(次ページ参照)
3・6
第3章 パラメータ設定
数値演算の設定表で、下記①∼⑤の各設定欄をクリックすると、各々の設定内容が表示されます。
② 式の設定内容1−1
(種類が座標
[X]
、座標
[Y]
、ずれ
[x]
、ずれ
[y]
、一致度
[M]
、角度
[B]
のとき)
・角度
[B]
のとき、モデルは表示
されません。
② 式の設定内容1−2
(種類が数値演算
[NC]のとき)
② 式の設定内容1−3
(種類が定数[C]のとき)
③ 式の設定内容2
④ 上限/下限の設定内容
⑤ 出力の設定内容
設定内容の詳細は、「IV-S30ユーザーズマニュアル
(機能・操作編)の数値演算」を参照願います。
[設定例]
3・7
IV-S30編
① 種類の設定内容
3
第3章 パラメータ設定
設定例(前ページ)の演算結果N0を設定する手順を説明します。
(1)種類の設定
IV-S30編
1. 演算結果番号を
「0」に設定し、登録を「有」
に設定
2. 座標
[X]をクリック
3
(2)式の設定
1. 登録番号を
「0」に、モデル番号を「0」に設定し、[入力]をクリック
⇒ 式の設定内容が表示されます。
2.「+」をクリック
⇒ 00X0の右欄に、+が表示されます。
3. 1.∼2.を繰り返すことにより式を入力
次ページへ
3・8
第3章 パラメータ設定
前ページより
(3)上下限の設定
出力を判定するための上限値を設定します。
⇒ 表示が反転します。
クリック
2. 410を入力
3
(参考)
上下限値の▲/▼をクリックしても設定できます。
クリック
(4)出力の設定
出力先を指定します。
1.「Y」をクリック
2.「無」をクリック
IV-S30編
1. N0の上限の設定部をクリック
クリック
クリック
3・9
第3章 パラメータ設定
3−4 出力条件の設定
[品種別条件]
タグのパラメータリストで[出力条件]をダブルクリックすると、
「出力条件」画面が
IV-S30編
表示されます。
■ 操作内容:位置ずれ計測の場合
パラメータリストの[出力条件]メニューをダブルクリックします。
3
ダブルクリック
⇒ 位置ずれ計測の「出力条件」画面が表示されます。
入力信号の設定欄
論理シンボルの設定欄
出力信号の設定欄
・ページ番号を選択し、登録を
「有」に設定すると、出力条件の各設定を行えます。
設定内容の詳細は、「IV-S30ユーザーズマニュアル
(機能・操作編)のPC機能」を参照願います。
3・10
第3章 パラメータ設定
IV-S30編
[設定例]
上記の例を設定する手順を説明します。
1. ページ番号
「0」を選択し、登録を「有」
にクリック
3
2. 入力0の0列目をクリック
クリック
クリック
3. 対象となるパラメータの
[一致度M]を選択(クリック)
※(下記の参考)
4
3
4. 論理シンボルの
[ ]を選択(クリック)
⇒ 入力信号と論理シンボルが表示されます。
(参考)
・登録番号とモデル番号の▲/▼(上記※)をクリックして、登録番号とモデル番号(0∼1)を
設定します。
5. 1.∼4.と同様に、設定位置をクリック
(設定した欄の右隣に自動的にカーソルは移動)、論理シンボル
をクリック、対象となるパラメータをクリックを繰り返して入力部を作成します。
6. 入力0の出力列をクリック
クリック
3・11
第3章 パラメータ設定
7. 出力信号の出力番号を設定して入力をクリック
※1
← 下記の参考
IV-S30編
※2
クリック
3
⇒ 出力信号と補助リレーC000が表示されます。
(参考)
・補助リレーの▲と▼(※1)をクリックすると、補助リレー番号(0 ∼127)を設定できます。
また、リレー番号枠
(※2)
をクリックして
(番号表示が反転)
、リレー番号を入力しても設定でき
ます。
3・12
第3章 パラメータ設定
3−5 距離角条件の設定
[品種別条件]
タグのパラメータリストで[距離角条件]をダブルクリックすると、「距離角条件」画
■ 操作内容:位置ずれ計測の場合
1. パラメータリストの
[距離角条件]メニューをダブルクリックします。
IV-S30編
面が表示されます。
3
ダブルクリック
⇒ 位置ずれ計測の「距離角条件」画面が表示されます。
3・13
第3章 パラメータ設定
IV-S30編
2.[距離角条件]
ダイアログボックスで補助条件を設定します。
3
3. その他条件を設定します。
3・14
第4章 パラメータ画像の読出、書込
第 4 章 パラメータ、画像の読出/書込
IV-S30の設定パラメータ、画像
(表示画像・メッセージ・パターン)
をパソコンのファイルに保存できます。
また、設定パラメータのアップローディング/ダウンローディングも可能です。
・コントローラの機種設定については、5・2ページを参照願います。
4−1 読出し
IV-S30編
IV-S30の設定パラメータ・画像などをIV-S30からパソコンに読み出します。
1.[IV通信]
メニュー→[IV転送]→[読み出し]をクリックします。
クリック
⇒[読み出し]ダイアログボックスが表示されます。
2.[スタート]ボタンをクリックすると通信を開始します。
・転送条件や通信条件を設定・変更する場合は、
[オプション(O)]ボタンをクリックします。
(パラメータ・グレー画像を読み出す場合は、IV-S30を運転画面にしてください。)
⇒「第2章 オプション設定」
参照
3. 転送が終了すると
[転送完了]メッセージダイアログボックスが表示されます。
・[OK]ボタンをクリックすると転送を終了します。
4・1
4
第4章 パラメータ画像の読出、書込
4−2 書込み
IV-S30の設定パラメータ・画像などをパソコンからIV-S30へ書き込みます。
1.[IV通信]
メニュー→[IV転送]→[書き込み]をクリックします。
IV-S30編
クリック
4
⇒[書き込み]ダイアログボックスが表示されます。
2.[スタート]ボタンをクリックすると通信を開始します。
・転送条件や通信条件を設定・変更する場合は、
[オプション(O)]ボタンをクリックします。
⇒「第2章 オプション設定」
参照
3. 転送が終了すると
[転送完了]メッセージダイアログボックスが表示されます。
・[OK]ボタンをクリックすると転送を終了します。
4・2
第4章 パラメータ画像の読出、書込
4−3 照合
IV-S30の設定パラメータ・画像などをIV-S30とパソコン間で照合します。
クリック
⇒[照合]ダイアログボックスが表示されます。
2.[スタート]ボタンをクリックすると通信を開始します。
・転送条件や通信条件を設定・変更する場合は、
[オプション(O)]ボタンをクリックします。
⇒「第2章 オプション設定」
参照
3. 転送が終了すると
[転送完了]メッセージダイアログボックスが表示されます。
・[OK]ボタンをクリックすると転送を終了します。
4・3
IV-S30編
1.[IV通信]
メニュー→[IV転送]→[照合]をクリックします。
4
第4章 パラメータ画像の読出、書込
4−4 初期化
IV-S30の全初期化します。
IV-S30編
1.[IV通信]
メニュー→[IV転送]→[初期化]
をクリックします。
4
クリック
⇒[初期化]
ダイアログボックスが表示されます。
2.[スタート]ボタンをクリックすると通信を開始します。
・転送条件や通信条件を設定・変更する場合は、
[オプション(O)]ボタンをクリックします。
⇒「第2章 オプション設定」
参照
3. 転送が終了すると
[転送完了]メッセージダイアログボックスが表示されます。
・[OK]ボタンをクリックすると転送を終了します。
4・4
第4章 パラメータ画像の読出、書込
4−5 自己診断
IV-S30の自己診断を起動します。
クリック
⇒[自己診断]ダイアログボックスが表示されます。
2.[スタート]ボタンをクリックすると通信を開始します。
・転送条件や通信条件を設定・変更する場合は、
[オプション(O)]ボタンをクリックします。
⇒「第2章 オプション設定」
参照
3. 転送が終了すると
[転送完了]メッセージダイアログボックスが表示されます。
・[OK]ボタンをクリックすると転送を終了します。
4・5
IV-S30編
1.[IV通信]
メニュー→[IV転送]→[自己診断]をクリックします。
4
第4章 ファイル操作
第 5 章 ファイル操作
IV-S30の設定パラメータ・画像などをファイルに保存したり、保存されているデータをIV-S30SP上に読み出
IV-S30編
せます。
下記
[ファイル]メニューは、全てに共通します。
5
■新規作成
IV-S30SP上で開いている全てのパラメータを初期化します。
・[ファイル]メニューで、
[新規作成]をクリックします。
■開く
下記ファイルを開きます。
内容
ファイル拡張子
*.bmp
表示画像・基準画像などビットマップファイル
*.msr
品種別設定条件
*.prm
グローバル条件
・[ファイル]メニューで、
[開く]をクリックします。
⇒[開く]ダイアログボックスが表示されます。
■表示画像を保存
IV-S30SP上で開いている画像を保存します。
・[ファイル]メニューで、
[新規作成]をクリックします。
⇒[表示画像を保存]ダイアログボックスが表示されます。
■プロジェクトを開く
プロジェクト(*.apm)
ファイルを開きます。
・[ファイル]メニューで、
[プロジェクトを開く]をクリックします。
■プロジェクトを保存
[開く]の対象ファイル全てをプロジェクト(*.apm)に登録し、全てのデータを保存します。
・[ファイル]メニューで、
[プロジェクトを保存]をクリックします。
5・1
第5章 ファイル操作
■名前を付けてプロジェクトを保存
[開く]
の対象ファイル全てをプロジェクト
(*.apm)
に登録し、全てのデータの名前をつけて保存し
ます。
・[ファイル]メニューで、
[名前を付けてプロジェクトを保存]をクリックします。
■プロジェクトを閉じる
プロジェクト(*.apm)ファイルを閉じます。
IV-S30編
・[ファイル]メニューで、
[プロジェクトを閉じる]をクリックします。
■プロパティ
コントローラの機種、プロジェクト名を設定します。
1.[ファイル]メニューの[プロパティ]をクリックします。
5
クリック
2.[プロパティ]ダイアログボックスが表示されます。
(ソフトバージョン)
V1.15 以下
V2.01 以上
・機種を変更すると、自動的にプロジェクトのパラメータを変換します。
(注)プロジェクトファイルとは、IV-S30の全パラメータ管理ファイルのことです。
5・2
第6章 ドキュメント作成
第 6 章 ド キ ュ メ ン ト 作 成
設定パラメータの一覧表
(Excelなど)
を自動作成でき、ドキュメントの管理/保管に使用できます。
6−1 ドキュメント作成
(プロジェクトファイル)
パソコンのファイルに保存の設定パラメータをドキュメント作成する操作手順を説明します。
(1)IV-S30側の設定/操作
IV-S30を運転画面の状態にします。
(2)通信の設定
IV-S30編
IV-S30との通信設定を行います。
⇒「第2章 オプション設定」
参照
(3)ドキュメント作成画面の立上げ
1.[ツール]メニューで、
[ドキュメント作成]を選択します。
6
クリック
⇒[ドキュメント作成]ダイアログボックスが表示されます。
次ページへ
6・1
第6章 ドキュメント作成
前ページより
(4)プロジェクトファイルからのドキュメント作成
[ファイル]メニューの[プロジェクトファイルを開く]をクリックします。
IV-S30編
クリック
6
⇒[ファイルを開く]ダイアログボックスが開きます。
(5)ファイルの選択
[ドキュメント作成]ダイアログボックスで、ドキュメント作成を行いたいプロジェクトファイル
を選択します。(プロジェクトファイル:*.apm)
(6)ドキュメント作成の実行
ドキュメントしたい条件全てに、チェックマークを付けて、[ドキュメント作成]メニューをクリック
します。
⇒
[ファイル保存]
ダイアログボックスが開きますので、ドキュメント作成ファイル名を入力して
ください。(ドキュメント作成ファイル:*.csv)
6・2
第6章 ドキュメント作成
6−2 ドキュメント作成
(IV-S30パラメータロード)
IV-S30の設定パラメータのドキュメントを作成する操作手順を説明します。
(1)設定パラメータの読出
[IV転送]
メニューの[パラメータ読出]をクリックします。
クリック
IV-S30編
⇒[パラメータ読出]ダイアログボックスが表示されます。
(2)転送開始
[スタート]ボタンで、転送を開始します。
6
クリック
※
クリック
※ 通信設定を行う場合は、[IV転送]
メニューの
[通信設定]
をクリックするか、[パラメータ読出]ダイ
アログの[通信設定]ボタンをクリックします。
6・3
第6章 ドキュメント作成
[ドキュメントの作成例]
作成したドキュメント
(品種別条件)
のファイル
(拡張子 csv)
を、Excelで開いて作成した例を示します。
IV-S30編
<<< 品種番号 00 >>>
タイトル
SAMPLE
----- メイン -----
6
計測0 カメラ1
計測0 カメラ2
計測 1
計測 2
計測 3
位置ずれ計測
ナシ
ナシ
ナシ
ナシ
NG計測中止
位置補正:カメラ1
位置補正:カメラ2
無
補正無
補正無
----- 位置ずれ計測(カメラ 1) ----[計測プログラム別条件]
※登録番号
モード
<1点目>
計測ウィンドウ
0
2点サーチ
矩形
基準画像左上座標(X)
68
基準画像左上座標(Y)
基準画像右下座標(X)
基準画像右下座標(Y)
232
139
295
サーチエリア左上座標
サーチエリア左上座標
サーチエリア右下座標
60
224
サーチエリア右下座標
検出座標
147
303
中心
104
検出座標(X)
検出座標(Y)
画素圧縮
<2点目>
計測ウィンドウ
基準画像左上座標(X)
264
3
矩形
356
基準画像左上座標(Y)
基準画像右下座標(X)
基準画像右下座標(Y)
サーチエリア左上座標(X)
サーチエリア左上座標(Y)
232
427
295
348
224
サーチエリア右下座標(X)
サーチエリア右下座標(Y)
435
303
検出座標
検出座標(X)
検出座標(Y)
画素圧縮
中心
検出精度
標準
392
264
3
6・4
第7章 データ収集
第 7 章 デ ー タ 収 集(計測結果/NG画像)
IV-S30からパソコンに、計測結果/NG画像のデータを通信
(汎用シリアルIF)
で転送し、集計表を自動作成
できます。データ収集機能は、計測データの管理/保管、判定条件など設定データの収集に使用できます。
・コントローラの機種設定については、5・2ページを参照願います。
データ収集の操作手順を説明します。
(1)コントローラ側の設定/操作
1.[品種別入出力]メニューの「④シリアル出力」を「ブロック指定」に設定します。
運転画面で「計測条件」にカーソルを移動してSETキーを押す
⇒[計測条件]メニューで「入出力」にSET
①品種番号
00
(0∼63)無 有
運転 保存 ロック タイトル 総合数値 総合出力 入出力 システム
[品種別入出力] ①CCDトリガ
無 有(2値 平均濃度 グレーサーチ)
②CCDトリガ条件
(下位メニュー)
③シャッター速度
1/00060(1/30∼1/10000)
④シリアル出力
任意 ブロック指定
⑤シリアルブロック指定
ブロック00 計測0 カメラ1
2
運転 戻る ロック
2.「⑤シリアルブロック指定」で、データ収集を行うブロック番号等を指定します。
3.[入出力条件]メニューの「②シリアル出力」を設定します。なお、コントローラの機種によって、設
定が異なります。
運転画面で
「システム条件」
にカーソルを移動してSETキーを押す
⇒
[システム条件]
メニューで
「①入出力条件」
にSET
[システム条件]
①入出力条件
②通信設定
(下位メニュー)
(下位メニュー)
※1
[入出力条件]
①計測開始入力IF
②シリアル出力
③品種手動切換
④パラレル入力 X6
無 コンピュータ 汎用シリアル
無 有
64品種切換 基準登録(計測0 画像間演算)
総面積判定補正(00)外部入力
外部入力 画像出力カメラ切換 カメラ別計測 重ね合せ
無 Y0
画像取込終了 計測終了
⑤パラレル入力 X7
⑥ストロボ出力
⑦'READY'ON
運転
戻る
パラレル+汎用シリアル+USB CCDトリガ ※2
ロック
※1 IV-S33M、IV-S31M/S32M(ソフトバージョンV2.01以上)
の場合 ⇒「無」に設定
※2 IV-S31M/32M(ソフトバージョンV1.15以下)
の場合 ⇒「汎用シリアル」
に設定
4. IV-S30を運転画面の状態にします。
次ページへ
7・1
IV-S30編
[計測条件]
7
第7章 データ収集
前ページより
(2)データ収集画面の立ち上げ
[ツール]メニューの[データ収集]をクリックします。
クリック
IV-S30編
⇒[データ収集]ダイアログボックスが表示されます。
(3)通信設定
IV-S30とIV-S30SP[設定]
メニューの[通信設定]で、通信条件を設定します。
7
クリック
(4)サンプリング設定
1.[設定]メニューの[サンプリング設定]をクリックします。
クリック
⇒[サンプリング設定]ダイアログボックスが表示されます。
2. 使用用途に合わせて、下記画面のサンプリングデータ/サンプリング回数/データの加工を
設定してください。
「NG画像データ」は、通信方法(上
記)
が「USB」時に設定可能です。
サンプリング回数/データの加工は、サンプリングデータの「計測結果
データ」に関する設定です。
次ページへ
7・2
第7章 データ収集
前ページより
【サンプリングデータ】
・計測結果データ:計測実行した結果データを収集します。
・NG画像データ:NG画像を収集します。
(IV-S32M/S33Mの
「品種別システム」条件で、NG画登録を
「有」に設定してお
く必要があります。)
【データ加工】
計測結果データについて、サンプリングしたデータの加工方法を設定します。
・計測データ別にカウントする:計測結果の値毎に集計し、値と回数を出力します。
・計測順に並べる:サンプリングした順番に、計測結果を出力します。
(5)データ収集の条件設定
1.[セットアップ]
をクリックします。
IV-S30編
【サンプリング回数】
計測結果データについて、サンプリングする回数と方法を設定します。
・1000回:1000カウントまで収集できます。
・5000回:5000カウントまで収集できます。
・無制限:ハードディスクに保存します。(サンプリングスピードが遅くなります。)
7
クリック
⇒ IV-S30のパラメータを読み出し、データ収集可能条件を表示します。
2. データ収集する項目を選択(クリック)します。
次ページへ
7・3
第7章 データ収集
前ページより
(5)データ収集の実行
[開始]をクリックします。
IV-S30編
クリック
⇒ IV-S30SPは、データ取込可能状態になります。
(6)計測結果データの集計表作成、NG画像データの収集
7
1
2
1.[中止]をクリックします。
⇒ データ収集が中止されます。
2.[データ一覧表作成]をクリックします。
・
[ファイルを開く]
ダイアログボックスが表示されますので、データを保存するファイルの場所
とファイル名を指定してください。
・計測結果データは、収集したデータの集計ファイルが自動的に作成されます。
・データファイルの拡張子は、計測結果データが「csv」、NG画像データが「bmp」です。
留 意 点
・パソコンの処理スピードがIV-S30のデータ送信スピードより速いとき、データが脱落する
場合があります。
・リアルタイムチャートを表示すると、IV-S30SPの処理スピードが遅くなります。
7・4
第7章 データ収集
[データ収集の作成例]
データ収集機能で作成した計測結果データのファイル(拡張子 csv)を、Excel のグラフ作成機能を使
用して作成した例を示します。
(例)2値化による面積計測を行い、面積の判定条件の上下限を設定します。
データファイル(拡張子 csv)
0
1
1
2
1
5
13
38
40
12
2
1
0
1
0
1
1
5
14
33
43
39
31
18
2
5
3
1
0
0
0
面積
25000
25200
25400
25600
25800
26000
26200
26400
26600
26800
27000
27200
27400
27600
27800
28000
28200
28400
28600
28800
29000
29200
29400
29600
29800
30000
30200
30400
30600
30800
31000
Excelで表を作成
Excelでグラフを作成
下限
回数
0
1
1
2
1
5
13
38
40
12
2
1
0
1
0
1
1
5
14
33
43
39
31
18
2
5
3
1
0
0
0
IV-S30編
25000
25200
25400
25600
25800
26000
26200
26400
26600
26800
27000
27200
27400
27600
27800
28000
28200
28400
28600
28800
29000
29200
29400
29600
29800
30000
30200
30400
30600
30800
31000
7
上限
45
40
35
30
25
系列2
20
NG
15
OK
10
5
7・5
31000
30600
30200
29800
29400
29000
28600
28200
27800
27400
27000
26600
26200
25800
25400
25000
0
第8章 ユーザーメニューエディタ
第 8 章 ユーザーメニューエディタ
IV-S30の運転画面を作成/変更したり、ユーザー独自のメニューを作成/変更する機能です。文字列・タイ
トルの変更もできます。
・コントローラの機種設定については、5・2ページを参照願います。
8−1 起動方法
1.[ツール]メニューの[ユーザーメニューエディタ]をクリックします。
⇒ ユーザーメニューエディタ画面が立ち上がります。
IV-S30編
クリック
8
8・1
第8章 ユーザーメニューエディタ
8−2 読出し
IV-S30からメニュー・運転画面等を読み出します。
1.[ファイル]メニューの[転送]をクリックします。
IV-S30編
クリック
⇒ 転送画面が立ち上がります。
8
2.「転送条件」で
「読出し」
を選択し、「転送対象」で読み出したい条件にチェックマークを付けます。
「転送開始」ボタンをクリックするとIV-S30から転送対象データを読み出します。
8−3 書込み
IV-S30にメニュー・運転画面等を書き込みます。
1.[ファイル]メニューの[転送]をクリックします。(「8−2 読出し」参照)
⇒ 転送画面が立ち上がります。
2.「転送条件」で
「書込み」
を選択し、「転送対象」で読み出したい条件にチェックマークを付けます。
「転送開始」ボタンをクリックするとIV-S30へ転送対象データを書き込みます。
8・2
第8章 ユーザーメニューエディタ
8−4 ユーザーメニュー初期化
1.[ファイル]メニューの[転送]をクリックします。(「8−2 読出し」参照)
2.「転送条件」
で
「ユーザーメニュー初期化」
を選択し、
「転送開始」
をクリックするとIV-S30のユーザー
メニューを初期化します。
IV-S30編
⇒ 転送画面が立ち上がります。
8
8・3
第8章 ユーザーメニューエディタ
8−5 タイトル編集
タイトルとは、下記の例では【計測形状(モデル0)
】のことです。
計測形状
(モデル0) 矩形 横ライン 縦ライン
1. タイトルの変更をします。
タイトルタグをクリックしてタイトルリストを表示した後、タイトル文字を選択してダブルクリッ
IV-S30編
クします。
8
⇒[変更]ダイアログボックスが開きます。
2. 文字を直接変更・削除を行い、[OK]ボタンをクリックするとタイトルは変更されます。
■ 変更したいタイトル文字を検索したい場合
1.「編集」メニューの「検索」を選択します。
(または、タイトル上で“右クリック”を押し、ポップアッ
プメニューから検索を選択します。)
クリック
8・4
第8章 ユーザーメニューエディタ
⇒[検索タイトルリスト]
ダイアログボックスが開きます。
2. 検索したい文字を入力し、
「検索実行」ボタンをクリックすると検索します。
8−6 文字列編集
文字列とは、下記の例では【矩形】、【横ライン】、【縦ライン】のことです。
1. 文字列の変更をします。
文字列タグをクリックして文字列リストを表示した後、変更したい文字を選択してダブルクリッ
クします。
IV-S30編
計測形状
(モデル0) 矩形 横ライン 縦ライン
8
⇒ 文字の変更・削除・検索方法は、
「8−5 タイトル編集」参照
8・5
第8章 ユーザーメニューエディタ
8−7 メニュー編集
文字列とは、下記の例ではライン全てのことです。
計測形状
(モデル0) 矩形 横ライン 縦ライン
■ メニューから使用されているタイトル・文字列を変更する場合
IV-S30編
1. メニューリストからメニュー項目を選択すると、メニュー詳細リストにタイトル・文字列が表
示されます。
8
2. メニュー詳細のタイトル・文字列をダブルクリックすると変更ダイアログが開きます。
文字の変更・削除・検索方法は、
「8−5 タイトル編集」参照
8・6
第8章 ユーザーメニューエディタ
8−8 ユーザーメニューの作成
1.[ファイル]メニューの[ユーザーメニュー作成]をクリックします。
クリック
IV-S30編
⇒ ユーザーメニュー作成テーブルが表示されます。
8
2. メニューリストからユーザーに登録したいメニューを選択し、メニューテーブルへドラッグする
と貼り付け登録されます。
8・7
第8章 ユーザーメニューエディタ
8−9 運転画面の作成
1.[ファイル]メニューの[運転画面作成]をクリックします。
クリック
IV-S30編
⇒ 運転画面作成テーブルが表示されます。
8
2. ユーザーメニューを追加したい場合は、
[ファイル]
の
[ユーザーメニュー作成]
をクリックすると、
新しいメニューテーブルが表示されます。
・IV-S31Mの場合は2画面、IV-S32M/S33Mの場合は8画面が作成可能です。
8・8
第8章 ユーザーメニューエディタ
IV-S30編
3. エリアリストから運転画面に登録したいエリアを選択し、運転画面テーブルへドラッグすると貼
り付け登録されます。表示位置を変更できます。
8−10 ファイル操作
■ 新規作成
8
メニューエディタ上の全てのデータが初期化されます。
・「ファイル」メニューの「新規作成」をクリックします。
■ 開く
保存ファイルを開きます。
・「ファイル」メニューの「開く」をクリックします。
ファイル拡張子
*.str
*.ume
*.urm
*.fnt
8・9
内容
タイトル・文字列データ
ユーザーメニューデータ
運転画面データ
ユーザーフォントデータ
第9章 コマンドテスト
第 9 章 コ マ ン ド テ ス ト
コマンドテスト機能は、IV-S30とUSB/シリアル通信を行い、パソコンを立ち上げ時の通信確認に使用で
きます。
コマンドテストの操作手順を説明します。
(1)IV-S30側の設定/操作
1. IV-S30のシリアル出力
(入出力条件)を
「汎用シリアル」に設定します。
運転画面で
「システム条件」
にカーソルを移動してSETキーを押す
⇒
[システム条件]
メニューで
「1入出力条件」 にSET
[システム条件]
(下位メニュー)
(下位メニュー)
[入出力条件]
①計測開始入力IF
②シリアル出力
③品種手動切換
④パラレル入力 X6
無 コンピュータ 汎用シリアル
無 有
64品種切換 基準登録(計測0 画像間演算)
総面積判定補正(00)外部入力
外部入力 画像出力カメラ切換 カメラ別計測 重ね合せ
無 Y0
画像取込終了 計測終了
⑤パラレル入力 X7
⑥ストロボ出力
⑦'READY'ON
運転
戻る
パラレル+汎用シリアル+USB CCDトリガ
ロック
IV-S30編
①入出力条件
②通信設定
9
2. IV-S30を運転画面の状態にします。
(2)通信設定
IV-S30との通信設定を行います。
⇒「第2章 オプション設定」
参照
(3)コマンドテスト画面の立ち上げ
[ツール]
メニューの[コマンドテスト]をクリックします。
クリック
⇒[コマンドテスト]ダイアログボックスが表示されます。
次ページへ
9・1
第9章 コマンドテスト
前ページより
(4)コマンドテスト条件の設定
[コマンドテスト]
ダイアログボックスで、コマンドテスト条件(タイムアウト時間設定、チェック
サム、繰返回数)
を設定します。
SUM値
設定項目
内 容
IV-S30編
タイムアウト時間設定(○:10s) 通信タイムアウトの時間を秒単位で設定します。
チェックサム
9
自動 ⃝
チェックサムを自動的に計算し、コマンドに付加して
転送します。
手動
コマンド入力で、サムチェックも入力します。
(転送時、IV-S30SPは、付加しません。)
固定(@@)
チェックサムは無しになり、@@を付加して転送します。
繰返回数(○:1回)
送信データに入力したコマンドを、繰返回数で指定した
回数を転送します。
・⃝印はデフォルト(出荷時)設定です。
(5)シリアルコマンドの送信
[コマンドテスト]ダイアログボックスで送信データを入力して、[送信]をクリックを行います。
⇒ IV-S30へ送信データが転送され、レスポンスデータが受信データ欄に表示されます。
サムチェック
の値
送信データ
を入力
受信データ
の表示
クリック
次ページへ
9・2
第9章 コマンドテスト
前ページより
(6)ファイルの保存
・受信データをファイルに保存する場合
1.[ファイル]メニューの[開く]をクリックします。
⇒[ファイルを開く]ダイログボックスが表示されます。
・保存するファイル(拡張子 tst)を新規に作成する場合、フォルダを指定し、ファイル名を
入力後、[開く]をクリックします。
作成済のファイルに保存する場合、ファイルを選択して、
[開く]をクリックします。
IV-S30編
2.[ファイル]メニューの[保存]をクリックします。
9
9・3
第10章 バージョンアップ
第 10 章 バ ー ジ ョ ン ア ッ プ
IV-S30のシステムソフトを、パソコンからのダウンロードで容易にバージョンアップ
(機能向上)
できます。
・IV-S30のシステムソフトには、システムプログラム
(画像処理の設定/実行)
と、ブートプログラム
(プロ
グラムのローディング)
の2種類があります。バージョンアップの内容によっては、2種類とも変更が必
要となります。
(システムソフトの最新バージョン等については、当社の営業にお問い合わせ願います。)
バージョンアップの操作手順を説明します。
(1)準備
パソコンに適当なフォルダを作成し、次のソフトを入れます。
SXXYYY.mot システムプログラム
(XXは機種、YYYはバージョンにより変わります。)
BXXYYY.mot ブートプログラム
(2)通信の設定
IV-S30との通信設定を行います。
⇒「第2章 オプション設定」
参照
(3)IV-S30側の設定/操作
1. IV-S30に電源を投入します。
IV-S30編
・リモート設定キーの左キー
( )
と設定キー
(SET)
を同時に押した状態で、IV-S30コントローラ
に電源を投入します。
左キー
( )
設定キー
(SET)
10
⇒ モニタに、IV-S30のバージョンアップメニュー
(IVS3*M VERSION UP MENU)
が表示されます。
[IVS3*M VERSION UP MENU]
①IVS3*M SYSTEM RECEIVE(USB)
②IVS3*M SYSTEM RECEIVE(RS232C)
③BOOT RECEIVE(USB)
④BOOT RECEIVE(RS232C)
⑤RS232C BAUDRATE
⑥ALL INITIALIZE
⑦POWER ON RESET
RUN
RUN
RUN
RUN
115.2Kbps 19.2Kbps
RUN
RUN
2. バージョンアップメニューを選択します。
・
「①IVS3*M SYSTEM RECEIVE(USB)
」を上下キーで選択して、設定キー
(SET)
を押します。
(バージョンアップの内容により、「③BOOT RECEIVE
(USB)」も選択)
次ページへ
10・1
第10章 バージョンアップ
前ページより
(4)ファイルの選択
[IV通信]
メニューの[バージョンアップ]メニューをクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・ファイル(SXXYYY.mot)を選択して、[開く]をクリックします。
IV-S30編
クリック
(5)転送
[バージョンアップ]画面が立ち上がります。
10
⇒[オプション]ボタンを選択します。通信条件・バージョンアップ条件を設定します。
(2・1∼2・2、2・4ページ参照) [転送開始]
ボタンを選択すると、転送が開始されます。
(
[転送中止]
ボタンを選択すると、転
送を中止します。)
・転送が正常時には、IV-S30側のモニタに「≡ ON RECEIVE」が表示され、「≡」が点滅しま
す。
・通常、USBでは転送時間に20秒程度を要します。(注:RS-232Cの場合は、シリアル
Pentium266MHzでは10分程度を要します。)
・モニタの
「≡ ON RECEIVE」
表示が消えると、新システムプログラムがIV-S30のフラッシュ
メモリに書込完了となります。
(6)新バージョンでの実行
IV-S30のバージョンアップメニュー
(モニタに表示)
で、
「⑦POWER ON RESET」
を上下キーで選択
して、設定キー(SET)を押します。
[IVS3*M VERSION UP MENU]
①IVS3*M SYSTEM RECEIVE(USB)
②IVS3*M SYSTEM RECEIVE(RS232C)
③BOOT RECEIVE(USB)
④BOOT RECEIVE(RS232C)
⑤RS232C BAUDRATE
⑥ALL INITIALIZE
⑦POWER ON RESET
RUN
RUN
RUN
RUN
115.Kbps 19.2Kbps
RUN
RUN
⇒ IV-S30の電源がリセットされ、新バージョンのシステムプログラムでIV-S30が実行されます。
10・2
第11章 その他の機能
第 11 章 そ の 他 の 機 能
その他の機能として
「印刷」
、「メッセージ色の変更」
、
「ズーム」
、「画像輝度の設定」
、「SMS Webページ」
を
説明します。
〔1〕印刷
IV-S30SPの表示画像モニタに表示されている画像を印刷できます。
(操作手順)
1.[ファイル]メニューの[印刷]
をクリックします。
〔2〕メッセージ色の変更
表示画像のメッセージ色を8色より設定できます。画像とメッセージ色が同じ色の場合など、メッ
セージ色を変更するとメッセージを見易くできます。
・メッセージ色(8色)には黒、青、緑、シアン、赤、マゼンダ、黄、白があります。
(操作手順)
1.[編集]メニューの[メッセージ色]にカーソルを移動します。
2. 色を選択します。
変更する色を選択
(クリック)します。
(デフォルト設定:黒)
⇒ メッセージ色が変更されます。
11・1
IV-S30編
クリック
11
第11章 その他の機能
〔3〕ズーム
ズーム比率を変更する事によって、表示画像モニタの倍率を変更します。
(操作手順)
1.[表示]メニューの[ズーム比率]にカーソルを移動します。
2. 比率を選択します。
変更する比率を選択(クリック)します。(デフォルト設定:100%)
⇒ ズーム比率が変更されます。
IV-S30編
〔4〕画像輝度の設定
表示画像モニタの画像輝度を、
「標準(1/1)」または「1/2」に設定できます。
(操作手順)
1.[編集]メニューの[表示画像輝度変更]にカーソルを移動します。
11
2. 輝度を選択します。
「標準」または「1/2」
を選択(クリック)します。(デフォルト設定:標準)
⇒ 表示画像が選択した輝度に変更されます。
11・2
第11章 その他の機能
〔5〕SMS Webページ
お使いのパソコンがインターネットに接続できる環境である場合、デフォルトのWebブラウザが起
動し、シャープマニファクチャリングシステム株式会社のホームページに接続します。
(ホームページのアドレスは、裏表紙に記載しています。)
(操作手順)
IV-S30編
1.[ヘルプ]メニューの[SMS Webページ]
にカーソルを移動します。
11
11・3
■ IV-S20編
第1章 メニュー構成
第 1 章 メ ニ ュ ー 構 成
本ソフト(IV-S20用)を起動すると下記画面が表示されます。メニューバーの各メニューについてメニュー
構成を示します。
下記の
(1)∼(7)は次ページ以降の項目に対応しています。
(1) (2)
(3)
(4)
(5)
(6) (7)
IV-S20編
・本ソフト
(IV-S20用)
を起動時の画面
1
1・1
第1章 メニュー構成
(1)ファイル
(F)
(操作内容)
新規作成(N) Ctrl+N
新規にファイルを作成する
画像を開く(O) Ctrl+O
保存された表示画像を開く(*.bmp)
保存(S)
画像のみ(I)
表示画像のみファイル保存する
メッセージのみ(M)
メッセージのみファイル保存する
画像+メッセージ(A)
画像+メッセージをファイル保存する
画像読出(R)
表示画像(カメラ1)(1)
表示画像(カメラ1)をIV-S20から読み出す
表示画像(カメラ2)(2)
表示画像(カメラ2)をIV-S20から読み出す
メッセージ(M)
メッセージをIV-S20から読み出す
IV-S20編
画像書込(W)
1
表示画像(カメラ1)(1)
表示画像(カメラ1)をIV-S20に書き込む
表示画像(カメラ2)(2)
表示画像(カメラ2)をIV-S20に書き込む
通信設定(C)
IV-S20SPの通信条件を設定する
コマンドテスト(T)
IV-S20へ任意のシリアルコマンドを送る
印刷(P) Ctrl+P
印刷する
プリンタの設定(U)
プリンタの設定をする
終了(X) Ctrl+Q
IV-S20SPを終了する
(2)編集
(E)
表示画像削除
(D)
(操作内容)
IV-S20SP上に表示された画像を消去する
表示画像輝度変更
(B)
通常
(N)
表示画像の明るさを通常にする
1/2
(H)
表示画像の明るさを1/2にする
クリップボードへコピー
(C)
画像のみ
(I)
表示画像のみクリップボードへコピーする
メッセージのみ
(M)
メッセージのみクリップボードへコピーする
画像+メッセージ
(A)
表示画像とメッセージをクリップボードへコピーする
メッセージ色
(M)
黒
(B)、青
(E)、緑
(G)、
シアン
(C)、赤
(R)、
マゼンタ
(M)、黄
(Y)、
白
(W)
メッセージの色を指定の色に変更する
1・2
第1章 メニュー構成
(3)IVデータ設定保存(I)
(操作内容)
ファイル選択(F)
IV-S20の設定データを扱うファイルを選択する
ロード(L)
ファイル⇒IV
ファイルからIV-S20へ設定パラメータをロードする
ファイル⇒設定画面
ファイルから設定画面へ設定パラメータをロードする
設定画面⇒IV
設定画面からIV-S20へ設定パラメータをロードする
セーブ(S)
IV⇒ファイル
IV-S20からファイルへ設定パラメータをセーブする
設定画面⇒ファイル
設定画面からファイルへ設定パラメータをセーブする
IV⇒設定画面
IV-S20から設定画面へ設定パラメータをセーブする
照合(V)
ファイル⇔IV
ファイルとIV-S20の設定パラメータを照合する
ファイル⇔設定画面
ファイルと設定画面の設定パラメータを照合する
IV⇔設定画面
IV-S20と設定画面の設定パラメータを照合する
初期化(I)
IVS20
(I)
IV-S20を初期化する
設定画面(D)
設定画面を初期化する
IV-S20を自己診断する
ドキュメント作成(M)
設定データのドキュメントを自動作成する
データ収集(D)
IV-S20からの計測結果データを保存する
IV-S20編
IV自己診断(A)
1
1・3
第1章 メニュー構成
(4)品種別条件
(M)
(操作内容)
品種番号(0∼15)
品種番号を設定/変更する
タイトル登録
品種別にタイトルを設定する
計測0 カメラ1
無し
位置ずれ計測
位置補正 カメラ1
位置ずれ計測(カメラ1)の各種条件を設定/変更する
位置補正条件の設定/変更する
計測0 カメラ2
無し
位置ずれ計測
位置ずれ計測(カメラ2)の各種条件を設定/変更する
位置補正 カメラ2
計測1
一致度検査
一致度検査の各種条件を設定/変更する
の各種条件を設定/変更する
距離角度計測(グレー&エッジ) 距離角度計測(グレー&エッジ)
距離角度計測(重心)
距離角度計測(重心)の各種条件を設定/変更する
リード検査
リード検査の各種条件を設定/変更する
2値面積計測
2値面積計測の各種条件を設定/変更する
2値カウント計測
2値カウント計測の各種条件を設定/変更する
2値ラベリング計測
2値ラベリング計測の各種条件を設定/変更する
ポイント計測
ポイント計測の各種条件を設定/変更する
IV-S20編
計測2
1
(計測1と同様)
計測3
(計測1と同様)
総合数値演算
総合数値演算条件を設定/変更する
総合出力条件
総合出力条件を設定/変更する
システム・入出力
品種別のシステム・入出力条件を設定/変更する
NG計測中止
無
NGが発生しても計測を継続する
有
NGが発生すると、すべての計測を中止する
1・4
第1章 メニュー構成
(5)バージョンアップ
(V)
(操作内容)
ファイル選択
(S)
IV-S20をバージョンアップ用にファイルを選択する
転送:初期化無し
(W)
転送後、初期化せずにバージョンアップする
転送:計測条件初期化
(M)
転送後、計測条件のみ初期化してバージョンアップする
転送:全初期化
(A)
転送後、すべてを初期化後バージョンアップする
(6)ウィンドウ
(W)
(操作内容)
表示画像モニタ
(M)
表示画像画像部の表示/非表示を切り替える
オプション
(O)
全品種一覧表示
設定画面に全品種の品種別条件を表示する
品種別表示
設定画面に指定した1品種のみ品種別条件を表示する
ツールバー
(T)
ツールバーの表示/非表示を切り替える
ステータスバー
(S)
ステータスバーの表示/非表示を切り替える
重ねて表示
(C)
ウィンドウ内のフォームを重ねて表示する
上下に並べて表示
(H)
ウィンドウ内のフォームを上下に並べて表示する
左右に並べて表示
(V)
ウィンドウ内のフォームを左右に並べて表示する
(7)ヘルプ
(H)
トピックの検索
(S)
ヘルプのトピック検索画面を表示する
バージョン情報
(A)
IV-S20SPのバージョン情報を表示する
IV-S20編
(操作内容)
1
1・5
第2章 通信設定
第 2 章 通
信
設
定
パソコンとIV-S20間で通信する場合、本ソフトの
「通信設定」を設定してください
■ 通信を行うメニュー項目
パソコンとIV-S20間で通信を行う本ソフトのメニュー項目を示します。
IVデータ設定保存
ファイル
画像読出 表示画像(カメラ1)
ロード
表示画像(カメラ2)
メッセージ
セーブ
転送:初期化無し
設定画面 ⇒ IV
転送:計測条件初期化
IV ⇒ ファイル
転送:全初期化
IV ⇒ 設定画面
画像書込 表示画像(カメラ1)
表示画像(カメラ2)
バージョンアップ
ファイル ⇒ IV
照合
ファイル ⇔ IV
IV ⇔ 設定画面
初期化
IV-S20
IV自己診断
■ 通信設定の操作
データ収集
IV-S20編
1.[ファイル]メニューの[通信設定]をクリックします。
クリック
2
⇒[通信設定]ダイアログボックスが表示されます。
2. ポートを設定し、
[セット]をクリックします。
通信ポート
の設定
設定項目
デフォルト設定
通信速度
115.2 kbps
データ長
7
パリティ
偶数
ストップビット
2
ポート
1
クリック
・パソコンの通信ポートを設定します。
「ポート」
以外の設定項目は、デフォルト(出荷時)
設定で動作します。
2・1
第3章 品種別条件の設定
第 3 章 品 種 別 条 件 の 設 定
品種別の条件
(計測条件、判定条件、数値演算、出力条件など)を、
[品種別条件]
メニューの各項目をクリック
して設定します。
・オフラインでの設定/変更が可能です。
(生産ライン等の稼働中も、ラインを停止せずに設定/変更が可
能です。)
・設定内容の詳細は、「IV-S20ユーザーズマニュアル」
を参照願います。
■[品種別条件]メニュー
・
[計測0 カメラ2]も同様です。
・計測2、計測3も同様です。
設定する項目をクリックすると、各々の設定画面が表示されます。
■ 操作内容:位置ずれ計測の場合
[品種別条件]メニューの[計測0 カメラ1]
または[計測0 カメラ2]
をクリックして、[位置ずれ計測]
をク
リックします。
⇒ 位置ずれ計測の設定画面が表示されます。
IV-S20編
クリック
3
3・1
第3章 品種別条件の設定
3−1 計測条件の設定
[品種別条件]メニューで各計測プログラムをクリックすると、「計測条件」画面が表示されます。
■ 操作内容:位置ずれ計測(1点サーチ+1点エッジ)の場合
をクリックします。
1. 位置ずれ計測の設定画面
(前ページ)で、登録の「有」
クリック
⇒「1点サーチ」用の設定画面が表示されます。
2. モードの[▼]をクリックして、
「1点サーチ+1点エッジ」をクリックします。
クリック
IV-S20編
⇒「1点サーチ+1点エッジ」用の「計測条件」
画面が表示されます。
グレーサーチ
条件の設定部
3
エッジ検出条件
の設定部
設定内容の詳細は、「IV-S20ユーザーズマニュアル」
を参照願います。
3・2
第3章 品種別条件の設定
3−2 判定条件の設定
各計測プログラムの設定画面で
[判定条件]をクリックすると、
「判定条件」画面が表示されます。
■ 操作内容:位置ずれ計測(1点サーチ+1点エッジ)の場合
をクリックします。
位置ずれ計測の「1点サーチ+1点エッジ」設定画面
(前ページ)で、[判定条件]
クリック
⇒「1点サーチ+1点エッジ」用の「判定条件」
画面が表示されます。
登録番号の設定部
モデル0の設定部
モデル1の設定部
IV-S20編
角度ズレの設定部
3
設定内容の詳細は、「IV-S20ユーザーズマニュアル」
を参照願います。
3・3
第3章 品種別条件の設定
3−3 数値演算の設定
各計測プログラムの設定画面で
[数値演算]を選択(クリック)すると、「数値演算」画面が表示され
ます。
■ 操作内容:位置ずれ計測の場合
をクリックします。
位置ずれ計測の設定画面
(3・2ページ)で、[数値演算]
クリック
⇒ 位置ずれ計測の「数値演算」画面が表示されます。
各設定の内容を
表示する位置
IV-S20編
数値演算(N00
∼ 15)の設定表
3
・数値演算の各設定欄
(種類、下限/上限、出力、式)をクリックすると、各々の設定内容が表示されま
す。
(次ページ参照)
3・4
第3章 品種別条件の設定
数値演算の設定表で、下記①∼⑤の各設定欄をクリックすると、各々の設定内容が表示されます。
① 種類の設定内容
② 上限/下限の設定内容
③ 出力の設定内容
④ 式の設定内容1−1(種類が座標[X]、座標[Y]、角度ズレ[x]、角度ズレ[y]、一致度
[M]、角度ズレ[B]のとき)
・角度ズレ
[B]
のとき、モデル
は表示されません。
④ 式の設定内容1−2
(種類が数値演算
[NC]のとき)
④ 式の設定内容1−3(種類が定数[C]のとき)
②
③
④
⑤
④
⑤
IV-S20編
①
⑤ 式の設定内容2
3
設定内容の詳細は、「IV-S20ユーザーズマニュアル:第9章 数値演算」
を参照願います。
[設定例]
演算結果N01の設定手順を次ページで説明します。
3・5
第3章 品種別条件の設定
設定例(前ページ)の演算結果N01を設定する手順を説明します。
(1)種類の設定
1. N01の「種類」欄をクリック
クリック
⇒ 種類の設定内容が表示されます。
2. 座標
[X]をクリック
クリック
⇒ N01の「種類」欄に、[X]が表示されます。
(2)式の設定
1. N01の「式」欄をクリック
クリック
左端の N00 をクリックすると、
00000002.0 が表示されます。
⇒ 式の設定内容1が表示されます。
2.「登録」をクリック
クリック
IV-S20編
⇒ 0X0が表示されます。
3
3. 0X0の右欄をクリック
クリック
⇒ 式の設定内容2が表示されます。
4.「*」をクリック
クリック
⇒ 0X0の右欄に、*が表示されます。
5. *の右欄をクリックし、式の設定内容1の
「N」をクリック
⇒ *の右欄に、N0が表示されます。
表示
次ページへ
3・6
第3章 品種別条件の設定
前ページより
(3)上下限の設定
1. N01の「下限」欄または
「上限」欄をクリック
クリック
⇒ 上限/下限の設定内容が表示されます。
2. 上限の設定部をダブルクリック
ダブルクリック
⇒ 表示が反転します。
3. 410を入力して、
[Enter]キーを押す
⇒ 00000410.0が表示されます。
表示
(参考)
上下限値は桁数を選択
(クリック)
して、上/下限値欄の▲/▼をクリックしても設定できます。
② 上/下限値欄の▲/▼をクリック
(4)出力の設定
IV-S20編
① ▼をクリックして、桁数を
選択(クリック)
3
1. N01の「出力」欄をクリック
⇒ 出力の設定内容が表示されます。
2.「Y」をクリック
クリック
⇒ N01の「出力」欄に、Y0が表示されます。
表示
3・7
第3章 品種別条件の設定
3−4 出力条件の設定
各計測プログラムの設定画面で
[出力条件]をクリックすると、
「出力条件」画面が表示されます。
■ 操作内容:位置ずれ計測の場合
をクリックします。
位置ずれ計測の設定画面
(3・2ページ)で、[出力条件]
クリック
⇒ 位置ずれ計測の「出力条件」画面が表示されます。
入力信号
の設定欄
IV-S20編
論理シンボル
の設定欄
出力信号
の設定欄
3
上記画面でこの範囲を
クリックするとページ4
● ページ4の表示
が表示されます。
設定内容の詳細は、「IV-S20ユーザーズマニュアル:第10章 PC機能」
を参照願います。
3・8
第3章 品種別条件の設定
[設定例]
上記の例を設定する手順を説明します。
1. 入力0(ページ0)
の0列目をクリック
クリック
2. 論理シンボルの
[
]を選択(クリック)
クリック
3. 入力信号の
[一致度M]を選択(クリック)
※(下記の参考)
クリック
(参考)
・登録番号と一致度 M の▲/▼(上記※)をクリックすると、登録番号(0 ∼ 7)とモデル番号
(0 ∼ 1)を設定します。
IV-S20編
⇒ 入力信号と論理シンボルが表示されます。
3
4. 1.∼3.と同様に、設定位置をクリック、論理シンボルをクリック、入力信号をクリックを繰り返えし
て入力部を作成します。
5. 入力0の出力列をクリック
クリック
3・9
第3章 品種別条件の設定
6. 出力信号の
[補助リレーC]
をクリック
クリック
※2
※1
← 下記の参考
⇒ 出力信号と補助リレーC000が表示されます。
(参考)
・補助リレーCの▲と▼(※1)をクリックすると、補助リレー番号(0∼127)を設定できます。
また、リレー番号枠
(※2)
をダブルクリックして
(番号表示が反転)
、リレー番号を入力しても
IV-S20編
設定できます。
3
3・10
第3章 品種別条件の設定
3−5 操作例(位置ずれ計測)
品種別条件設定機能の使用例として、位置ずれ計測
(2点サーチ)の操作例を説明します。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)IV-S20SPを起動
⇒ セ・4ページ参照
(3)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(4)品種番号を指定
[品種別条件]メニューの[品種番号(0∼15)]をクリックします。
クリック
IV-S20編
⇒[品種設定]ダイアログボックスが表示されます。
クリック
3
・品種番号
(0∼15)を▼と▲で設定し、[設定]をクリックます。
(5)位置ずれ計測の設定画面を立ち上げ
[品種別条件]メニューで、
[計測0 カメラ1]
→[位置ずれ計測]をクリックします。
クリック
⇒ 位置ずれ計測の設定画面が表示されます。(次ページ参照)
次ページへ
3・11
第3章 品種別条件の設定
前ページより
・位置ずれ計測の設定画面
(6)表示画像の読出
IV-S20編
1.[ファイル]メニューで、
[画像読出]→
[表示画像(カメラ1)]をクリックします。
クリック
3
⇒[表示画像読出(カメラ1)]ダイアログボックスが表示されます。
2.[OK]をクリックします。
⇒ 表示画像が読み出されます。(次ページ参照)
次ページへ
3・12
第3章 品種別条件の設定
前ページより
・表示画像の読出例
(7)モードの設定
登録番号
の指定
クリック
⇒ モード(1点サーチ)の計測条件が表示されます。
次ページへ
3・13
IV-S20編
1. 登録番号
(0∼7)を▲と▼で指定し、登録の
「有」をクリックします。
3
第3章 品種別条件の設定
前ページより
2. モードの▼をクリックして、「2点サーチ」をクリックします。
クリック
⇒ モード(2点サーチ)の計測条件が表示されます。
基準画像
の設定枠
(実線)
IV-S20編
サーチエリア
の設定枠
(破線)
3
(8)基準画像の登録
1. 基準画像/サーチエリアの設定枠をマウスでドラッグし、位置を決めます。
・設定例
モデル0
の基準画像枠
モデル0
のサーチエリア枠
次ページへ
3・14
モデル1
の基準画像枠
モデル1
のサーチエリア枠
第3章 品種別条件の設定
前ページより
2.[登録]をクリック後、[表示]
をクリックします。
登録(モデル0)
表示(モデル0)
登録(モデル1)
表示(モデル1)
⇒ 画像が登録されていれば、画像が表示されます。
・再度、[表示]をクリックすると、画像が消えます。
● 計測条件をIV-S20にロードする場合
(9)ロードの実行
1.[IVデータ設定保存]メニューで、
[ロード]→[設定画面⇒IV]をクリックします。
クリック
書込が正常に完了すると、「データロード(設定画面→IV)完了」が表示されます。 IV-S20編
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
2.[IVデータ設定保存]
ダイアログボックスの[転送開始]
をクリックします。
⇒ 設定した計測条件がIV-S20に書き込まれます。
3
3・15
第4章 ドキュメント作成
第 4 章 ド キ ュ メ ン ト 作 成
設定パラメータの一覧表
(Excelなど)
を自動作成でき、ドキュメントの管理/保管に使用できます。
4−1 ドキュメント作成
(IV-S20のパラメータ)
IV-S20の設定パラメータのドキュメントを作成する操作手順を説明します。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)設定パラメータの読出
1.[IVデータ設定保存]
メニューで、
[セーブ]→[IV⇒設定画面]をクリックします。
クリック
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
2.[転送開始]をクリックします。
IV-S20編
クリック
⇒ IV-S20に設定しているデータが設定画面にセーブされます。
・データセーブが正常に完了すると、
[IVデータ設定保存]
ダイアログボックスが表示されま
す。
3.[OK]をクリックします。
クリック
次ページへ
4・1
4
第4章 ドキュメント作成
前ページより
(4)ドキュメント作成画面の立ち上げ
[IVデータ設定保存]
メニューの[ドキュメント作成]をクリックします。
クリック
⇒[ドキュメント作成]ダイアログボックスが表示されます。
(5)ファイルの選択
[ドキュメント作成]ダイアログボックスで、[ファイル]メニューの[開く]をクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・ドキュメントを作成するファイル
(拡張子 csv)
を新規に作成する場合、フォルダを指定し、
ファイル名を入力後、[開く]をクリックします。
IV-S20編
作成済のファイルにセーブする場合、ファイルを選択して、[開く]をクリックします。
(6)ドキュメント作成の実行
作成する品種と条件を選択(クリック)して、
[作成開始]をクリックします。
4
品種
の選択欄
条件
の選択欄
クリック
⇒ ドキュメントが自動的に作成され、作成が終了すると
[ドキュメント作成]
ダイアログボックス
が表示されます。
・このボックスの
[OK]をクリックします。(ドキュメントの作成例 → 4・4ページ参照)
4・2
第4章 ドキュメント作成
4−2 ドキュメント作成(ファイルデータ)
パソコンのファイルに保存の設定パラメータをドキュメント作成する操作手順を説明します。
(1)設定パラメータの保存ファイルを選択
[IVデータ設定保存]メニューの[ファイル選択]をクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・ドキュメントを作成するファイル(拡張子 apm)を選択して、[開く]をクリックします。
(2)設定パラメータの読出
1.[IVデータ設定保存]
メニューで、
[ロード]→[ファイル⇒設定画面]をクリックします。
クリック
IV-S20編
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
2.[転送開始]をクリックします。
4
クリック
⇒ ファイルデータが設定画面にロードされます。
以降のドキュメント作成手順は、
「6−1 ドキュメント作成
(IV-S20のパラメータ)
」
と同様です。
(4・2ページの(4)∼(6)を参照)
4・3
第4章 ドキュメント作成
[ドキュメントの作成例]
作成したドキュメント
(品種別条件)
のファイル
(拡張子 csv)
を、Excelで開いて作成した例を示します。
<<< 品種番号 00 >>>
タイトル
SAMPLE
----- メイン ----計測0 カメラ1
計測0 カメラ2
計測 1
計測 2
位置ずれ計測
ナシ
ナシ
ナシ
計測 3
NG計測中止
位置補正:カメラ1
位置補正:カメラ2
ナシ
無
補正無
補正無
----- 位置ずれ計測(カメラ 1) ----[計測プログラム別条件]
※登録番号
モード
0
2点サーチ
<1点目>
計測ウィンドウ
基準画像左上座標(X)
基準画像左上座標(Y)
矩形
68
232
139
IV-S20編
基準画像右下座標(X)
基準画像右下座標(Y)
4
295
サーチエリア左上座標
サーチエリア左上座標
サーチエリア右下座標
60
224
147
サーチエリア右下座標
検出座標
303
中心
検出座標(X)
検出座標(Y)
104
画素圧縮
<2点目>
3
計測ウィンドウ
基準画像左上座標(X)
基準画像左上座標(Y)
基準画像右下座標(X)
264
矩形
356
232
427
295
基準画像右下座標(Y)
サーチエリア左上座標(X)
サーチエリア左上座標(Y)
348
224
435
303
サーチエリア右下座標(X)
サーチエリア右下座標(Y)
検出座標
検出座標(X)
検出座標(Y)
画素圧縮
中心
検出精度
標準
392
264
3
4・4
第5章 データ収集
第 5 章 デ
ー
タ
収
集
IV-S20からパソコンに、計測結果データを通信
(汎用シリアルIF)で転送し、集計表を自動作成できます。
データ収集機能は、計測データの管理/保管、判定条件など設定データの収集に使用できます。
データ収集の操作手順を説明します。
(1)IV-S20側の設定/操作
1. IV-S20のシリアル出力
(入出力条件)を
「汎用シリアル」に設定します。
運転画面で
「設定画面」
にカーソルを移動してSETキーを押す
⇒
[設定メイン画面]
メニューで
「③入出力条件」
にSET
[入出力条件]
①計測開始入力IF:
③シリアル(出力):
(入力=パラレル)
④計測番号切換X5,X6
⑤パラレル入力X5:
⑥パラレル入力X6:
⑦状態出力:
⑧シリアル通信条件
⑨コンピュータリンク
⑩ゲイン・オフセット
⑪上位メニュー
パラレル 汎用シリアル CCDトリガ
無 コンピュータリンク 汎用シリアル
無 有
外部入力 基準画登録
(計測0)
外部入力 画像出力カメラ切換
BUSY READY
(下位メニュー)
(下位メニュー)
(下位メニュー)
2. IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)データ収集画面の立ち上げ
クリック
⇒[データ収集]ダイアログボックスが表示されます。
次ページへ
5・1
IV-S20編
[IVデータ設定保存]メニューの[データ収集]をクリックします。
5
第5章 データ収集
前ページより
(4)ファイルの選択
[データ収集]ダイアログボックスで、[ファイル]メニューの[開く]をクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・データ収集結果を保存するファイル(拡張子 csv)を新規に作成する場合、フォルダを指定
し、ファイル名を入力して[開く]をクリックします。
作成済のファイルに保存する場合、ファイルを選択して、
[開く]をクリックします。
(5)データ収集の条件設定
1.[セットアップ]
をクリックします。
クリック
IV-S20編
⇒ IV-S20の設定状態がロードされます。
2. データ収集する項目を選択(クリック)します。
5
次ページへ
5・2
第5章 データ収集
前ページより
(6)データ収集の実行
[開始]をクリックします。
クリック
⇒ IV-S20からデータ収集が開始されます。
(7)データ収集表の作成
①
②
1.[中止]をクリックします。
⇒ データ収集が中止されます。
2.[データ一覧表作成]をクリックします。
⇒ 対象データの集計ファイルが自動的に作成され、作成が正常に終了すると
「データ集計表作成
終了」が表示されます。
留 意 点
IV-S20編
・パソコンの処理スピードがIV-S20のデータ送信スピードより速いとき、データが脱落する
場合があります。
5
5・3
第5章 データ収集
[データ収集の作成例]
データ収集機能で作成したデータのファイル(拡張子 csv)を、Excel のグラフ作成機能を使用して作
成した例を示します。
(例)2値化による面積計測を行い、面積の判定条件の上下限を設定します。
データファイル(拡張子 csv)
25000
25200
25400
25600
25800
26000
26200
26400
26600
26800
27000
27200
27400
27600
27800
28000
28200
28400
28600
28800
29000
29200
29400
29600
29800
30000
30200
30400
30600
30800
31000
0
1
1
2
1
5
13
38
40
12
2
1
0
1
0
1
1
5
14
33
43
39
31
18
2
5
3
1
0
0
0
面積
25000
25200
25400
25600
25800
26000
26200
26400
26600
26800
27000
27200
27400
27600
27800
28000
28200
28400
28600
28800
29000
29200
29400
29600
29800
30000
30200
30400
30600
30800
31000
Excelで表を作成
Excelでグラフを作成
下限
回数
0
1
1
2
1
5
13
38
40
12
2
1
0
1
0
1
1
5
14
33
43
39
31
18
2
5
3
1
0
0
0
上限
45
30
25
系列2
20
NG
15
OK
10
5
5・4
31000
30600
30200
29800
29400
29000
28600
28200
27800
27400
27000
26600
26200
25800
0
25400
5
35
25000
IV-S20編
40
第6章 パラメータ、画像の読出/書込
第 6 章 パラメータ、画像の読出/書込
設定パラメータ、画像
(表示画像/メッセージ)
をパソコンのファイルに保存できます。また、設定パラメー
タのアップローディング/ダウンローディングも可能です。
・本機能は、ファイル保存した設定パラメータを電子メール等の送信により、遠隔地でのサンプル評価に
使用できます。また、設定パラメータの読出/書込により設定コピーの作成に使用できます。
■ 設定パラメータのロード/セーブ/照合
[IVデータ設定保存]メニューのロード/セーブ/照合を選択すると、下記項目の操作を行えます。
設定パラメータ
操作項目
本章の参照項目
ファイル ⇒ IV
ロード
6−3
ファイル ⇒ 設定画面
設定画面 ⇒ IV
IV ⇒ ファイル
セーブ
6−1
設定画面 ⇒ ファイル
IV ⇒ 設定画面
ファイル ⇔ IV
照合
6−2
ファイル ⇔ 設定画面
IV ⇔ 設定画面
■ 画像読出/画像書込
[ファイル]メニューの画像読出/画像書込を選択すると、下記項目の操作を行えます。
画 像
操作項目
本章の参照項目
表示画像(カメラ1)
画像読出
表示画像(カメラ2)
6−4〔1〕
メッセージ
画像書込
表示画像(カメラ1)
表示画像(カメラ2)
6−4〔2〕
6−1 設定パラメータのセーブ(保存)
IV-S20編
[IVデータ設定保存]メニューの「セーブ」を選択すると、下記の操作項目が表示されます。
6
セーブ
IV ⇒ ファイル
操作内容
IV-S20の設定パラメータを、パソコンのファイルにセーブします。
設定画面 ⇒ ファイル パソコンの設定画面のパラメータを、パソコンのファイルにセーブします。
IV ⇒ 設定画面
IV-S20の設定パラメータを、パソコンの設定画面にセーブします。
6・1
第6章 パラメータ、画像の読出/書込
IV-S20の設定パラメータを、パソコンのファイルにセーブ
(IV⇒ファイル)
する操作手順を説明します。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)ファイルの選択
[IVデータ設定保存]
メニューの[ファイル選択]をクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・設定パラメータをセーブするファイル
(拡張子 apm)
を新規に作成する場合、フォルダを指
定し、ファイル名を入力後、[開く]をクリックします。
作成済のファイルにセーブする場合、ファイルを選択して、[開く]をクリックします。
(4)全パラメータの保存
(セーブ)
1.[IVデータ設定保存]メニューで、
[セーブ]→[IV⇒ファイル]をクリックします。
クリック
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
IV-S20編
2.[転送開始]をクリックします。
6
クリック
⇒ IV-S20の全設定データが、指定ファイル
(上記で入力)に書き込まれます。
書込が正常に完了すると、[IVデータ設定保存]
ダイアログボックスが表示されます。
3.[OK]をクリックします。
クリック
6・2
第6章 パラメータ、画像の読出/書込
6−2 設定パラメータの照合
[IVデータ設定保存]メニューの「照合」を選択すると、下記の操作項目が表示されます。
照合
操作内容
ファイル ⇔ IV
パソコンのファイル(設定パラメータ)と、IV-S20の設定パラメータを照合
します。
ファイル ⇔ 設定画面
パソコンのファイル
(設定パラメータ)
と、設定画面の設定パラメータを照
合します。
IV ⇔ 設定画面
IV-S20の設定パラメータと、パソコンの設定画面の設定パラメータを照合
します。
パソコンのファイル
(設定パラメータ)
と、IV-S20の設定パラメータを照合
(ファイル⇔IV)
する操作手順
を説明します。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)ファイルの選択 「6−1」と同様です。→ 6・2ページ参照
(4)全パラメータの照合
クリック
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
2.[IVデータ設定保存]
ダイアログボックスの[転送開始]
をクリックします。
⇒ IV-S20の全設定パラメータと、パソコンの指定ファイルの内容が照合されます。
照合が正常に完了すると、[IVデータ設定保存]ダイアログボックスが表示され、[OK]をク
リックします。
6・3
IV-S20編
1.[IVデータ設定保存]
メニューで、
[照合]→[ファイル⇔IV]をクリックします。
6
第6章 パラメータ、画像の読出/書込
6−3 設定パラメータのロード
[IVデータ設定保存]
メニューの「ロード」を選択すると、下記の操作項目が表示されます。
ロード
ファイル ⇒ IV
ファイル ⇒ 設定画面
設定画面 ⇒ IV
操作内容
パソコンのファイルに保存の設定パラメータを、IV-S20にロードします。
パソコンのファイルに保存の設定パラメータを、パソコンの設定画面にロ
ードします。
パソコンの設定画面のパラメータを、IV-S20にロードします。
パソコンのファイルに保存の設定パラメータを、IV-S20にロード
(ファイル⇒IV)
する操作手順を説明し
ます。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)ファイルの選択 「6−1」と同様です。→ 6・2ページ参照
(4)全パラメータのロード
1.[IVデータ設定保存]メニューで、
[ロード]→[ファイル⇒IV]をクリックします。
IV-S20編
クリック
6
⇒[IVデータ設定保存]
ダイアログボックスが表示されます。
2.[IVデータ設定保存]
ダイアログボックスの[転送開始]
をクリックします。
⇒ パソコンの指定ファイル
(設定パラメータ)がIV-S20に書き込まれます。
書込が正常に完了すると、[IVデータ設定保存]ダイアログボックスが表示され、[OK]をク
リックします。
6・4
第6章 パラメータ、画像の読出/書込
6−4 画像の読出/書込
〔1〕画像(表示画像、メッセージ)の読出
[ファイル]メニューの「画像読出」を選択すると、下記の操作項目が表示されます。
画像読出
操作内容
表示画像(カメラ1) IV-S20の表示画像(カメラ1)を、パソコンの設定画面に読み出します。
表示画像(カメラ2) IV-S20の表示画像(カメラ2)を、パソコンの設定画面に読み出します。
メッセージ
IV-S20の表示メッセージを、パソコンの設定画面に読み出します。
IV-S20の表示画像
(カメラ1)
を、パソコンの設定画面に読み出し、パソコンのファイルに保存する操作
手順を説明します。
(1)IV-S20側の設定/操作
IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)表示画像の読出
1.[ファイル]メニューで、
[画像読出]→
[表示画像(カメラ1)]をクリックします。
⇒[表示画像読出(カメラ)]ダイアログボックスが表示されます。
IV-S20編
クリック
6
次ページへ
6・5
第6章 パラメータ、画像の読出/書込
前ページより
2.[表示画像読出(カメラ)]ダイアログボックスで[OK]をクリックします。
⇒ IV-S20のカメラ画像が転送されて、パソコンの画像表示エリアに表示されます。
(表示例)
(4)画像ファイル
(BMP形式)として保存
[ファイル]メニューで、
[保存]→[画像のみ]をクリックします。
クリック
⇒[ファイル名を付けて保存]ダイアログボックスが表示されます。
・画像ファイルを保存するファイル
(拡張子 bmp)
を新規に作成する場合、フォルダを指定し、
ファイル名を入力後、[保存]をクリックします。
IV-S20編
作成済のファイルに保存する場合、ファイルを選択して、
[保存]をクリックします。
⇒ 指定ファイルに画像ファイルが保存されます。
6
6・6
第6章 パラメータ、画像の読出/書込
〔2〕画像(表示画像)の書込(ロード)
IV-S20の運転画面条件で画像取込を
「無」
に設定すると、パソコンからIV-S20にロードした画像で計
測を処理できます。
・画像ファイルを通信で転送すると、遠隔地でのサンプル評価/トラブル調査に使用できます。
・市販のPHOTOSHOP/PAINT SHOP PROで画像を加工して、グレースケール8BITのBMPファイ
ルでIV-S20にロードすることも可能です。
[ファイル]メニューの「画像書込」を選択すると、下記の操作項目が表示されます。
画像書込
操作内容
表示画像
(カメラ1) パソコンの設定画面に表示の画像を、IV-S20(カメラ1)
に書き込みます。
表示画像
(カメラ2) パソコンの設定画面に表示の画像を、IV-S20(カメラ2)
に書き込みます。
パソコンに表示の画像をIV-S20
(カメラ1)に書き込む操作手順を説明します。
(1)IV-S20側の設定/操作
1. IV-S20の画像取込
(運転画面条件)を「無」に設定します。
運転画面で
「設定画面」
にカーソルを移動してSETキーを押す
[運転画面条件]
①モニタ出力:
②カメラ1&2:
③画像取込:
④メッセージ表示:
⑤パターン表示:
⑥2値画像表示:
⑦θ補正画像表示
⑧クロスカーソル表示:
⑨品種番号手動:
⑩上位メニュー
カメラ1 カメラ2 カメラ1&2
カメラ1=中 カメラ2=中
部分画像 全画像 無
有(数値結果有)有
(数値結果無)無
計測出力状態 無
有 無
有 無
無 有
無 有
2. IV-S20を運転画面の状態にします。
IV-S20編
⇒[設定メイン画面]
メニューで
「①運転画面条件」
にSET
6
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
次ページへ
6・7
第6章 パラメータ、画像の読出/書込
前ページより
(3)表示画像の書込
1.[ファイル]メニューで、
[画像書込]→
[表示画像(カメラ1)]をクリックします。
クリック
⇒[表示画像書込(カメラ)]ダイアログボックスが表示されます。
IV-S20編
2.[表示画像書込(カメラ)]ダイアログボックスで[OK]をクリックします。
⇒ パソコンに表示の画像がIV-S20
(カメラ1)に書き込まれます。
6
6・8
第7章 コマンドテスト
第 7 章 コ マ ン ド テ ス ト
コマンドテスト機能は、IV-S20とシリアル通信を行い、パソコンを立ち上げ時の通信確認に使用できます。
コマンドテストの操作手順を説明します。
(1)IV-S20側の設定/操作
1. IV-S20のシリアル出力
(入出力条件)を
「汎用シリアル」に設定します。
運転画面で「設定画面」にカーソルを移動してSETキーを押す
⇒[設定メイン画面]メニューで「③入出力条件」にSET
[入出力条件]
①計測開始入力IF:
③シリアル(出力):
(入力=パラレル)
④計測番号切換X5,X6
⑤パラレル入力X5:
⑥パラレル入力X6:
⑦状態出力:
⑧シリアル通信条件
⑨コンピュータリンク
⑩ゲイン・オフセット
⑪上位メニュー
パラレル 汎用シリアル CCDトリガ
無 コンピュータリンク 汎用シリアル
無 有
外部入力 基準画登録(計測0)
外部入力 画像出力カメラ切換
BUSY READY
(下位メニュー)
(下位メニュー)
(下位メニュー)
2. IV-S20を運転画面の状態にします。
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)コマンドテスト画面の立ち上げ
[ファイル]メニューの[コマンドテスト]をクリックします。
⇒[コマンドテスト]ダイアログボックスが表示されます。
IV-S20編
クリック
7
次ページへ
7・1
第7章 コマンドテスト
前ページより
(4)コマンドテスト条件の設定
[コマンドテスト]
ダイアログボックスで、コマンドテスト条件(タイムアウト時間設定、チェック
サム、繰返回数)
を設定します。
設定項目
10秒 ⃝
タイムアウト
時間設定 30秒
60秒
自動 ⃝
チェックサム 手動
内 容
レスポンスの待ち時間が10秒になります。
〃 30秒になります。
〃 60秒になります。
チェックサムを送信時、自動的に作成します。
入力者がチェックサムを計算し、送信データに直接添付
して送信します。
固定(@@)チェックサムは無しになり、@@を送信します。
繰返回数
1回 ⃝
通信エラーが発生しても、送信回数は1回で終了します。
2回
通信エラーが発生した場合、2回まで送信します。
3回
通信エラーが発生した場合、3回まで送信します。
その他
繰返回数を4回以上に設定できます。
・⃝印はデフォルト(出荷時)
設定です。
(5)シリアルコマンドの送信
[コマンドテスト]ダイアログボックスで送信データを入力して、「[Enter]キーを入力」または「[転
IV-S20編
送]
をクリック」を行います。
⇒ IV-S20へ送信データが転送され、レスポンスデータが受信データ欄に表示されます。
7
送信データ
を入力
サムチェック
の値
受信データ
の表示
クリック
(参考)[データクリア]
をクリックすると、送信データ/受信データ/SUM値の表示が消去され
ます。
次ページへ
クリック
7・2
第7章 コマンドテスト
前ページより
(6)ファイルのセーブ/ロード
・受信データをファイルに保存する場合
1.[ファイル]メニューの[ファイル選択]をクリックします。
⇒[ファイルを開く]ダイログボックスが表示されます。
・保存するファイル(拡張子 tst)を新規に作成する場合、フォルダを指定し、ファイル名を
入力後、[開く]をクリックします。
作成済のファイルに保存する場合、ファイルを選択して、
[開く]をクリックします。
2.[ファイル]メニューの[セーブ]をクリックします。
・受信データをファイルから読み出す場合
1.[ファイル]メニューの[ファイル選択]をクリックします。
⇒[ファイルを開く]ダイログボックスが表示されます。
読み出すフォルダ/ファイル名
(拡張子 tst)を選択します。
IV-S20編
2.[ファイル]メニューの[ロード]をクリックします。
7
7・3
第8章 バージョンアップ
第 8 章 バ ー ジ ョ ン ア ッ プ
IV-S20のシステムソフトを、パソコンからのダウンロードで容易にバージョンアップ
(機能向上)
できます。
・IV-S20のシステムソフトには、システムプログラム
(画像処理の設定/実行)
と、ブートプログラム
(プロ
グラムのローディング)
の2種類があります。バージョンアップの内容によっては、2種類とも変更が必
要となります。
(システムソフトの最新バージョン等については、当社の営業にお問い合わせ願います。)
バージョンアップの操作手順を説明します。
(1)準備
パソコンに適当なフォルダを作成し、次のソフトを入れます。
SVXXX.mot VXXXシステムプログラム (Xはバージョンにより変わります。)
BVXXX.mot VXXXブートプログラム
(2)通信の設定
IV-S20との通信設定を行います。
⇒「第2章 通信設定」
参照
(3)IV-S20側の設定/操作
1. IV-S20に電源を投入します。
・リモート設定キーの左キー
( )
と設定キー
(SET)
を同時に押した状態で、IV-S20本体に電源を
投入します。
左キー( )
設定キー(SET)
⇒ モニタに、IV-S20のバージョンアップメニュー
(IVS20 VERSION UP MENU)
が表示されます。
[IVS20 VERSION UP MENU]
①SYSTEM RECEIVE
RUN
②SYSTEM TRANSFER RUN
③BOOT RECEIVE
RUN
④BOOT TRANSFER
RUN
⑤ALL INITIALIZE
RUN
⑥POWER ON RESET
RUN
2. バージョンアップメニューを選択します。
・「①SYSTEM RECEIVE」を上下キーで選択して、設定キー(SET)を押します。
IV-S20編
(バージョンアップの内容により、「③BOOT RECEIVE」も選択)
8
次ページへ
8・1
第8章 バージョンアップ
前ページより
(4)ファイルの選択
[バージョンアップ]メニューの[ファイル選択]をクリックします。
クリック
⇒[ファイルを開く]ダイアログボックスが表示されます。
・ファイル(SVXXX.mot)を選択して、[開く]をクリックします。
(5)転送
[バージョンアップ]メニューの[転送:初期化無し]をクリックします。
クリック
⇒ 転送が開始されます。
・転送が正常時には、IV-S20側のモニタに「≡ ON RECEIVE」が表示され、「≡」が点滅しま
す。
・通常、Pentium266MHzでは転送時間に5分程度を要します。
・モニタの
「≡ ON RECEIVE」
表示が消えると、新システムプログラムがIV-S20のフラッシュ
メモリに書込完了となります。
(6)新バージョンでの実行
IV-S20のバージョンアップメニュー
(モニタに表示)
で、
「⑥POWER ON RESET」
を上下キーで選択
して、設定キー(SET)を押します。
[IVS20 VERSION UP MENU]
①SYSTEM RECEIVE
RUN
②SYSTEM TRANSFER RUN
③BOOT RECEIVE
RUN
④BOOT TRANSFER
RUN
⑤ALL INITIALIZE
RUN
⑥POWER ON RESET
RUN
IV-S20編
⇒ IV-S20の電源がリセットされ、新バージョンのシステムプログラムでIV-S20が実行されます。
8
8・2
第9章 その他の機能
第 9 章 そ の 他 の 機 能
その他の機能として
「クリップボードへコピー」
、
「メッセージ色の変更」
、
「画像輝度の設定」
を説明します。
〔1〕クリップボードへコピー
表示画像をWindows95/98のクリップボードにコピーできます。
・コピーした表示画像はExcel/Wordの
[編集]
→
[貼り付け]
をクリックすると、Excel/Wordの文書
に貼り付けできます。(Wordは米国Microsoft Corporationの登録商標です。)
(操作手順)
1.[編集]メニューの[クリップボードへコピー]にカーソルを移動します。
2. コピー対象を選択します。
「画像のみ」または「メッセージのみ」
、「画像+メッセージ」を選択(クリック)
します。
⇒ 選択した対象が、Windows95/98のクリップボードにコピーされます。
〔2〕メッセージ色の変更
表示画像のメッセージ色を8色より設定できます。画像とメッセージ色が同じ色の場合など、メッ
セージ色を変更するとメッセージを見易くできます。
・メッセージ色(8色)には黒、青、緑、シアン、赤、マゼンダ、黄、白があります。
・
「画像+メッセージ」
表示の場合、メッセージ色を
「白」
に設定してください。
(画像輝度は
「1/2」
に設定)
・メッセージのみ表示の場合、メッセージ色を
「黒」
に設定すると、クリップボード等への貼り付け
に利用できます。
IV-S20編
(操作手順)
1.[編集]メニューの[メッセージ色]にカーソルを移動します。
2. 色を選択します。
変更する色を選択
(クリック)します。
(デフォルト設定:黒)
⇒ メッセージ色が変更されます。
9・1
9
第9章 その他の機能
〔3〕画像輝度の設定
表示画像の輝度を、「通常(1/1)」または「1/2」に設定できます。
・
「画像+メッセージ」
表示の場合、画像輝度を
「1/2」
に設定してください。
(メッセージ色は
「白」
に設定)
(操作手順)
1.[編集]メニューの[表示画像輝度変更]にカーソルを移動します。
2. 輝度を選択します。
「通常」または「1/2」
を選択(クリック)します。(デフォルト設定:通常)
IV-S20編
⇒ 表示画像が選択した輝度に変更されます。
9
9・2
改訂履歴
版、作成年月は表紙の右上に記載しております。
版
作成年月
初 版
1999年9月
改訂2.0版
2000年9月
改 訂 内 容
ソフトバージョンアップ内容を反映
12・1
● 商品に関するお問い合わせ先
シャープマニファクチャリングシステム
(株)
首都圏営業部
中 部 営 業 部
豊 田 営 業 所
近 畿 営 業 部
広 島 営 業 所
〒162-8408
〒454-0011
〒471-0833
〒581-8581
〒731-0113
東
名
豊
大
広
京 都 新 宿 区 市 谷 八 幡 町 8 番
古 屋 市 中 川 区 山 王 3 丁 目 5 番 5
田 市 山 之 手 8 丁 目 124 番
阪府八尾市跡部本町4丁目1番33
島 市 安 佐 南 区 西 原 2 丁 目 13 番 地 4
地
号
地
号
号
(03)3235−7351
(052)332−2691
(0565) 29−0131
(0729) 91−0682
(082)875−8611
● 修理・消耗品についてのお問い合わせ先
シャープドキュメントシステム
(株)
札 幌 技術センター
仙 台 技術センター
宇 都 宮 技術センター
前 橋 技術センター
東京フィールド サポートセンター
横 浜 技術センター
静 岡 技術センター
名 古 屋 技術センター
金 沢 技術センター
大阪フィールド サポートセンター
岡 山 技術センター
広 島 技術センター
高 松 技術センター
松 山 技術センター
福 岡 技術センター
〒063-0801
〒984-0002
〒320-0833
〒371-0855
〒114-0012
〒235-0036
〒422-8006
〒454-0011
〒921-8801
〒547-8510
〒701-0301
〒731-0113
〒760-0065
〒791-8036
〒816-0081
札 幌 市 西 区 二 十 四 軒 1 条 7 丁 目 3 番 17 号
仙 台 市 若 林 区 卸 町 東 3 丁 目 1 番 27 号
宇 都 宮 市 不 動 前 4 丁 目 2 番 41 号
前 橋 市 問 屋 町 1 丁 目 3 番 7 号
(011) 641-0751
(022)288−9161
(028)634−0256
(027)252−7311
東 京 都 北 区 田 端 新 町 2 丁 目 2 番 12 号
(03)3810−9962
横 浜 市 磯 子 区 中 原 1 丁 目 2 番 23 号
静 岡 市 曲 金 6 丁 目 8 番 4
4 号
名 古 屋 市 中 川 区 山 王 3 丁 目 5 番 5 号
石 川 県 石 川 郡 野 々 市 町 字 御 経 塚 町 1096 の 1
(045)753−9540
(054)283−9497
(052)332−2671
(076)249−9033
大 阪 市 平 野 区 加 美 南 3 丁 目 7 番 1
9 号
(06)6794−9721
岡 山 県 都 窪
広 島 市 安 佐
高 松 市 朝
松
山
市
福 岡 市 博 多
(086) 292-5830
(082)874−6100
(087)823−4980
(089)973−0121
(092)572−2617
郡 早 島 町 大 字 矢 尾 8 2
南 区 西 原 2 丁 目 13 番 4
日 町 6 丁 目 2 番 8
高
岡
町 1 7 8 の
区 井 相 田 2 丁 目1
2番1
8
号
号
1
号
・上記の所在地・電話番号などは変わることがあります。その節はご容赦願います。
本 社
〒581-8581
大阪府八尾市跡部本町4丁目1番33号
● インターネットホームページによるシャープ制御機器の情報サービス
h ttp ://w w w .sh arp.co.jp/sms/
お客様へ……お買いあげ日、販売店名を記入されますと、修理などの依頼のときに便利です。
お買いあげ日
年 月 日
販 売 店 名
電話( ) 局 番
0MCTINSJS30SP
00J 0.1 A①
2000年9月作成
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement