Distribution Display Tool Help Volume

Distribution Display Tool Help Volume
Help Volume
© 1994-2002 Agilent Technologies. All rights reserved.
Display: Distribution Display
Tool
Using the Distribution Tool
The Distribution Tool displays an overview of program activity in a bargraph form. Each bar may represent a single value or a range of values.
The height of each bar represents the number of times the value
occurred during the measurement.
•
“Optimizing Program Execution” on page 18
•
“Checking the Number of Occurrences of a Data Value or Range” on
page 14
•
“Seeing Distributions of Multiple Acquisitions (Accumulate)” on page 22
•
“Zooming In and Out on the Distribution” on page 8
•
“Loading and Saving Distribution Configurations” on page 26
•
“Printing the Distribution to a File” on page 28
•
“Printing the Distribution Window” on page 27
See Also
“Seeing Measurement Results - Popup on Run” on page 29
“Choosing the Label for Distribution Display” on page 24
“Clearing the Data” on page 25
“Changing the Color of the Distribution” on page 23
“Turning Tabs On or Off in the Display Window” on page 30
Using the Analysis Tab (see the Agilent Technologies 16700A/B-Series
Logic Analysis System help volume)
Using the Mixed Signal Tab (see the Agilent Technologies 16700A/BSeries Logic Analysis System help volume)
Main System Help (see the Agilent Technologies 16700A/B-Series Logic
Analysis System help volume)
2
Using the Distribution Tool
Glossary of Terms (see page 33)
3
Using the Distribution Tool
4
Contents
Using the Distribution Tool
1 Using the Distribution Tool
Zooming In and Out on the Distribution
8
To Zoom In on an Area of the Distribution 8
To Zoom In on a Single Bin (Expand) 9
To Zoom Out after Zooming In (Undo Scaling) 10
To View the Entire Distribution (Full scale) 11
To Scale the Distribution to the Range of Values Present (Autoscale)
12
Checking the Number of Occurrences of a Data Value or Range
14
Example: Checking the Number of Occurrences of a Data Value or Range
Optimizing Program Execution
18
Example: Finding a Procedure That Executes Too Long
18
Seeing Distributions of Multiple Acquisitions (Accumulate)
Changing the Color of the Distribution
22
23
Choosing the Label for Distribution Display
Clearing the Data
14
24
25
Loading and Saving Distribution Configurations
Printing the Distribution Window
27
Printing the Distribution to a File
28
Seeing Measurement Results - Popup on Run
Turning Tabs On or Off in the Display Window
26
29
30
5
Contents
Including Comments on Screen Prints
Editing Colors
Glossary
Index
6
32
31
1
Using the Distribution Tool
7
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Zooming In and Out on the Distribution
NOTE:
When you zoom in and out on the distribution, the axes are automatically
rescaled.
“To Zoom In on an Area of the Distribution” on page 8
“To Zoom In on a Single Bin (Expand)” on page 9
“To Zoom Out after Zooming In (Undo Scaling)” on page 10
“To View the Entire Distribution (Full scale)” on page 11
“To Scale the Distribution to the Range of Values Present (Autoscale)” on
page 12
To Zoom In on an Area of the Distribution
1. Select the left edge of the area you want to zoom in on.
Read the data value from the Low Value field.
2. Select the area you want to zoom in on.
Read the upper data value from the High Value field.
3. Continuing scrolling until the upper value matches the upper bound of the
area of interest.
The distribution is now rescaled to display the area you selected.
8
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Zooming in on an area
To Zoom In on a Single Bin (Expand)
1. Select the bin you want to zoom in on.
Read the data value that is selected from the Low Value field.
2. Select Expand.
The bounds on the x-axis are now rescaled to the low value and high value
of the bin you expanded.
9
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Zooming in on a single bin
To Zoom Out after Zooming In (Undo Scaling)
1. Highlight the distribution display area.
2. Select Undo scaling from the shortcut menu.
10
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Zooming out
To View the Entire Distribution (Full scale)
The Full scale option scales the distribution to show the maximum
range of possible values based on the number of bits in the label. For
example, if an 8-bit label is displayed using Full scale, the distribution
will show values from 00 hex to FF hex.
1. Highlight the distribution display area.
2. Select Full scale from the shortcut menu.
11
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Zooming out to display the entire distribution
To Scale the Distribution to the Range of
Values Present (Autoscale)
The Autoscale option scales the distribution to show all of the data in
the current acquisition.
1. Highlight the distribution display area.
2. Select Autoscale from the shortcut menu.
The distribution is rescaled to display the full range of data values.
12
Chapter 1: Using the Distribution Tool
Zooming In and Out on the Distribution
Using Autoscale to rescale the distribution
13
Chapter 1: Using the Distribution Tool
Checking the Number of Occurrences of a Data Value or Range
Checking the Number of Occurrences of a Data
Value or Range
1. Zoom in (see page 8) on the distribution around the area of interest.
2. At the top of the distribution, read the total number of data points in the
range you zoomed in on.
You can also see what percentage of the total number of data points fall
within the range.
3. If necessary, continue to rescale the distribution (see page 8) to pinpoint
the area of interest.
4. For information about a particular bin, place the cursor on the bin and read
the details below the display.
Select here to see an
example (see
page 14)
Example: Checking the Number of
Occurrences of a Data Value or Range
1. A full-scale display shows all 65536 data points in the acquisition.
2. The distribution is rescaled to show activity in the range from 73 hex to 8B
hex.
14
Chapter 1: Using the Distribution Tool
Checking the Number of Occurrences of a Data Value or Range
There are 11460 data points, or hits, in the rescaled range (17.49% of
all hits recorded). The rescaled view shows how the data points are
distributed.
15
Chapter 1: Using the Distribution Tool
Checking the Number of Occurrences of a Data Value or Range
The "+" cursor lets you examine the detail of any single value in the
distribution. Value 7D recorded 2167 hits, which was 3.31% of all hits
recorded during the measurement.
16
Chapter 1: Using the Distribution Tool
Checking the Number of Occurrences of a Data Value or Range
17
Chapter 1: Using the Distribution Tool
Optimizing Program Execution
Optimizing Program Execution
The distribution measurement tool can detect procedures that
consume too much execution time. For example, you may have a
program that runs much longer than you expect. You make a
distribution measurement and find that one small range of address
space is used much more than any other. You see that this address
range contains an update subroutine. Now you can make a
measurement of that update subroutine and view it in a listing display
to see why it is running such a long time. Perhaps you find it is making
an excessive number of calls to another routine before it recognizes
that the called routine is active. You modify your code to correct this
problem, and thereby reduce execution time of your program.
1. Select the label (see page 24) that corresponds to your memory addresses.
This is typically label ADDR.
2. Zoom in (see page 8) on the distribution to view the address range of
interest.
•
The highest bars on the distribution represent addresses that occurred
most often.
•
The lowest bars represent addresses that occurred least often.
Select here to see an
example (see
page 18)
Example: Finding a Procedure That Executes
Too Long
This screen shows an address range of FFEE47F7 through FFF1B296.
This address range was involved in 92.39% of all activity measured
during program execution. You can see that only a small portion of the
address range actually was involved in program execution.
To zoom in on the active area:
18
Chapter 1: Using the Distribution Tool
Optimizing Program Execution
1. The cursor was placed on address FFEFE021 and the line was selected
2. The zoom window was dragged to address FFF07FE9 and released.
The selected range was shown full screen, as seen in the display following
this one.
This display shows several bars of different heights, indicating address
ranges where activity was recorded. The longest bar represents
address range FFF03929 through FFF03972. In that single address
range, 10,564 hits were recorded. This was 16.12% of all the hits that
were recorded in all address ranges combined during program
execution. Because so many hits were recorded in that one range, it
will be expanded to see if there might be something to be learned about
it.
19
Chapter 1: Using the Distribution Tool
Optimizing Program Execution
The address range FFF03929 through FFF03972 is expanded in the
following screen. The most active addresses within this range received
165 hits each. Perhaps if you looked in this address range, you would
find a subroutine that was called often by many different routines.
Perhaps, instead, you would find a subroutine that was looping within
itself and should not be representing this much activity.
To see the details of this address range, you could make a
measurement and view results using the listing tool. You could set up
the analyzer to trigger on address FFF03929 so you could see which
routines call this subroutine and whether or not it should be consuming
such a large percentage of the program execution.
You might make a second measurement with the analyzer, qualifying
only adddresses in the range FFF03929 through FFF03972. This would
use analyzer memory most efficiently because it would allow you to
capture only execution within this range of interest. Unfortunately,
using a measurement qualification like this might exclude the calls to
this address range that are generated by other routines.
20
Chapter 1: Using the Distribution Tool
Optimizing Program Execution
21
Chapter 1: Using the Distribution Tool
Seeing Distributions of Multiple Acquisitions (Accumulate)
Seeing Distributions of Multiple Acquisitions
(Accumulate)
The Accumulate function allows the Distribution tool to accumulate
data from a series of acquisitions. You can use this feature to measure
your system's behavior over a long period of time.
CAUTION:
Data acquired and displayed in accumulate mode will be lost if you rescale the
distribution, or if you select a different label to view distribution.
1. Select Accumulate at the bottom of the Distribution window.
2. Select the Run Repetitive icon.
3. Select the Stop icon when you have accumulated enough data.
The total number of data points accumulated is displayed in the upper
right-hand corner of the distribution area.
NOTE:
There is some latency between the continuous runs of the analyzer when it is
acquiring data. You may want to set up the analyzer to trigger and stop at the
same points in each acquisition so that each run captures the same states.
22
Chapter 1: Using the Distribution Tool
Changing the Color of the Distribution
Changing the Color of the Distribution
1. Select Options in the Distribution window menu bar, and select Color.
2. Choose the color you want, and select OK.
If the color you want is not shown, select Edit Colors (see page 32) to
create the color you want.
3. Select OK to accept your changes or Cancel to preserve the former
settings.
23
Chapter 1: Using the Distribution Tool
Choosing the Label for Distribution Display
Choosing the Label for Distribution Display
•
24
Select the label you want in the label list at the bottom of the Distribution
window.
Chapter 1: Using the Distribution Tool
Clearing the Data
Clearing the Data
•
Select Clear at the bottom of the Distribution window.
25
Chapter 1: Using the Distribution Tool
Loading and Saving Distribution Configurations
Loading and Saving Distribution Configurations
Distribution Tool settings can be saved to a configuration file along
with the tools connected to it, and loaded from a previously saved
configuration file.
NOTE:
•
Loading Configuration Files (see the Agilent Technologies 16700A/BSeries Logic Analysis System help volume)
•
Saving Configuration Files (see the Agilent Technologies 16700A/BSeries Logic Analysis System help volume)
The Load Configuration window can be accessed via File->Load
Configuration.
The Save Configuration window can be accessed via File->Save
Configuration.
26
Chapter 1: Using the Distribution Tool
Printing the Distribution Window
Printing the Distribution Window
The print windows operation enables you to print just the Distribution
tool window. Use this operation if you want a hardcopy or electronic
record of configurations and data currently displayed in the viewing
area of the Distribution window.
NOTE:
Only the currently displayed viewing area of the Distribution window is
printed. If any data or configuration fields appear offscreen, scroll the desired
data or configuration fields into the window's viewing area before printing.
1. Optional - configure the Print Option (see the Agilent Technologies
16700A/B-Series Logic Analysis System help volume) if desired.
Print Options include print destination, file format type, filename
autoincrement, and color/b&w; pixel mapping.
2. In the Distribution tool menu bar, select File, then select Print This
Window. The print output will be as configured in the Print Options in
step 1.
See Also
Print Option (see the Agilent Technologies 16700A/B-Series Logic
Analysis System help volume)
Printer Setup (see the Agilent Technologies 16700A/B-Series Logic
Analysis System help volume)
“Including Comments on Screen Prints” on page 31
27
Chapter 1: Using the Distribution Tool
Printing the Distribution to a File
Printing the Distribution to a File
This operation prints the Distribution Tool data to an ASCII file.
1. From the Distribution tool's menu bar Select File, then select Print to file.
2. Select the path and filename to print the data to. Use either the File
Selection dialog to build the directory path and filename, or enter the path
and filename directly into the text entry field.
3. Select Save. Filenames can only include the following alphanumeric
characters:
0-9, a-z, A-Z, (-), (_), (.), (/), ($), (:), and (+).
The following is an example of a stored print file:
Distribution(Distribution<1>) - 22 January 1998 (12:15:44)
C9
CA
CB
CC
CD
CE
CF
D0
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA
DB
DC
DD
DE
DF
28
-
C9
CA
CB
CC
CD
CE
CF
D0
D1
D2
D3
D4
D5
D6
D7
D8
D9
DA
DB
DC
DD
DE
DF
18
16
16
14
18
16
16
20
32
28
36
28
33
28
39
28
36
32
32
28
32
28
36
Chapter 1: Using the Distribution Tool
Seeing Measurement Results - Popup on Run
Seeing Measurement Results - Popup on Run
By default, measurement results do not pop up automatically when an
analyzer completes its run. If you wish to have a display of
measurement results pop up when a run is completed, do the following:
•
In the menu bar of the display tool, select Options, then select Popup on
Run and set to On.
29
Chapter 1: Using the Distribution Tool
Turning Tabs On or Off in the Display Window
Turning Tabs On or Off in the Display Window
The tabs in the display window give you quick access and visual
reference to all the capabilities in the display window. You may wish to
turn the tabs off to simplify display content.
•
30
In the menu bar of the display tool, select Options, then select Tabs and
set to On or Off.
Chapter 1: Using the Distribution Tool
Including Comments on Screen Prints
Including Comments on Screen Prints
When you have tabs turned on, you can also enter your own comments
on screen. This allows you to obtain a printed copy of your screen that
includes your comments.
•
Turn tabs on, (see page 30) and under the Tabs On option, select Stack
comments.
•
Enter the text you wish to see in the print of your display.
Each print can include multiple comment lines. If you need more than the
default two comment lines, resize the comment text window using the
sash.
31
Chapter 1: Using the Distribution Tool
Editing Colors
Editing Colors
To edit a color
1. Select a color to change.
2. Move the Color Edit sliders to obtain the desired colors.
The colors change in the display to show the result of your modifications.
3. Select Save to accept and use the new colors, and save them as the
powerup default colors.
Optional - Select Default to restore the original colors and save them as
the powerup default colors.
4. Select Close.
32
Glossary
absolute Denotes the time period
or count of states between a captured
state and the trigger state. An
absolute count of -10 indicates the
state was captured ten states before
the trigger state was captured.
acquisition Denotes one complete
cycle of data gathering by a
measurement module. For example,
if you are using an analyzer with
128K memory depth, one complete
acquisition will capture and store
128K states in acquisition memory.
analysis probe A probe connected
to a microprocessor or standard bus
in the device under test. An analysis
probe provides an interface between
the signals of the microprocessor or
standard bus and the inputs of the
logic analyzer. Also called a
preprocessor.
analyzer 1 In a logic analyzer with
two machines, refers to the machine
that is on by default. The default
name is Analyzer<N>, where N is
the slot letter.
analyzer 2 In a logic analyzer with
two machines, refers to the machine
that is off by default. The default
name is Analyzer<N2>, where N is
the slot letter.
arming An instrument tool must be
armed before it can search for its
trigger condition. Typically,
instruments are armed immediately
when Run or Group Run is selected.
You can set up one instrument to arm
another using the Intermodule
Window. In these setups, the second
instrument cannot search for its
trigger condition until it receives the
arming signal from the first
instrument. In some analyzer
instruments, you can set up one
analyzer machine to arm the other
analyzer machine in the Trigger
Window.
asterisk (*) See edge terms,
glitch, and labels.
bits Bits represent the physical logic
analyzer channels. A bit is a channel
that has or can be assigned to a label.
A bit is also a position in a label.
card This refers to a single
instrument intended for use in the
Agilent Technologies 16700A/Bseries mainframes. One card fills one
slot in the mainframe. A module may
comprise a single card or multiple
cards cabled together.
channel The entire signal path from
the probe tip, through the cable and
module, up to the label grouping.
click When using a mouse as the
33
Glossary
pointing device, to click an item,
position the cursor over the item.
Then quickly press and release the
left mouse button.
clock channel A logic analyzer
channel that can be used to carry the
clock signal. When it is not needed
for clock signals, it can be used as a
data channel, except in the Agilent
Technologies 16517A.
context record A context record is
a small segment of analyzer memory
that stores an event of interest along
with the states that immediately
preceded it and the states that
immediately followed it.
context store If your analyzer can
perform context store
measurements, you will see a button
labeled Context Store under the
Trigger tab. Typical context store
measurements are used to capture
writes to a variable or calls to a
subroutine, along with the activity
preceding and following the events. A
context store measurement divides
analyzer memory into a series of
context records. If you have a 64K
analyzer memory and select a 16state context, the analyzer memory is
divided into 4K 16-state context
records. If you have a 64K analyzer
memory and select a 64-state
context, the analyzer memory will be
34
divided into 1K 64-state records.
count The count function records
periods of time or numbers of state
transactions between states stored in
memory. You can set up the analyzer
count function to count occurrences
of a selected event during the trace,
such as counting how many times a
variable is read between each of the
writes to the variable. The analyzer
can also be set up to count elapsed
time, such as counting the time spent
executing within a particular function
during a run of your target program.
cross triggering Using intermodule
capabilities to have measurement
modules trigger each other. For
example, you can have an external
instrument arm a logic analyzer,
which subsequently triggers an
oscilloscope when it finds the trigger
state.
data channel A channel that
carries data. Data channels cannot be
used to clock logic analyzers.
data field A data field in the pattern
generator is the data value associated
with a single label within a particular
data vector.
data set A data set is made up of all
labels and data stored in memory of
any single analyzer machine or
Glossary
instrument tool. Multiple data sets
can be displayed together when
sourced into a single display tool. The
Filter tool is used to pass on partial
data sets to analysis or display tools.
debug mode See monitor.
delay The delay function sets the
horizontal position of the waveform
on the screen for the oscilloscope and
timing analyzer. Delay time is
measured from the trigger point in
seconds or states.
demo mode An emulation control
session which is not connected to a
real target system. All windows can
be viewed, but the data displayed is
simulated. To start demo mode,
select Start User Session from the
Emulation Control Interface and
enter the demo name in the
Processor Probe LAN Name field.
Select the Help button in the Start
User Session window for details.
deskewing To cancel or nullify the
effects of differences between two
different internal delay paths for a
signal. Deskewing is normally done
by routing a single test signal to the
inputs of two different modules, then
adjusting the Intermodule Skew so
that both modules recognize the
signal at the same time.
device under test The system
under test, which contains the
circuitry you are probing. Also known
as a target system.
don't care For terms, a "don't care"
means that the state of the signal
(high or low) is not relevant to the
measurement. The analyzer ignores
the state of this signal when
determining whether a match occurs
on an input label. "Don't care" signals
are still sampled and their values can
be displayed with the rest of the data.
Don't cares are represented by the X
character in numeric values and the
dot (.) in timing edge specifications.
dot (.) See edge terms, glitch,
labels, and don't care.
double-click When using a mouse
as the pointing device, to double-click
an item, position the cursor over the
item, and then quickly press and
release the left mouse button twice.
drag and drop Using a Mouse:
Position the cursor over the item, and
then press and hold the left mouse
button. While holding the left mouse
button down, move the mouse to
drag the item to a new location. When
the item is positioned where you
want it, release the mouse button.
35
Glossary
Using the Touchscreen:
Position your finger over the item,
then press and hold finger to the
screen. While holding the finger
down, slide the finger along the
screen dragging the item to a new
location. When the item is positioned
where you want it, release your
finger.
edge mode In an oscilloscope, this
is the trigger mode that causes a
trigger based on a single channel
edge, either rising or falling.
edge terms Logic analyzer trigger
resources that allow detection of
transitions on a signal. An edge term
can be set to detect a rising edge,
falling edge, or either edge. Some
logic analyzers can also detect no
edge or a glitch on an input signal.
Edges are specified by selecting
arrows. The dot (.) ignores the bit.
The asterisk (*) specifies a glitch on
the bit.
emulation module A module
within the logic analysis system
mainframe that provides an
emulation connection to the debug
port of a microprocessor. An E5901A
emulation module is used with a
target interface module (TIM) or an
analysis probe. An E5901B emulation
module is used with an E5900A
emulation probe.
36
emulation probe The stand-alone
equivalent of an emulation module.
Most of the tasks which can be
performed using an emulation
module can also be performed using
an emulation probe connected to
your logic analysis system via a LAN.
emulator An emulation module or
an emulation probe.
Ethernet address See link-level
address.
events Events are the things you
are looking for in your target system.
In the logic analyzer interface, they
take a single line. Examples of events
are Label1 = XX and Timer 1 > 400
ns.
filter expression The filter
expression is the logical OR
combination of all of the filter terms.
States in your data that match the
filter expression can be filtered out or
passed through the Pattern Filter.
filter term A variable that you
define in order to specify which
states to filter out or pass through.
Filter terms are logically OR'ed
together to create the filter
expression.
Format The selections under the
logic analyzer Format tab tell the
Glossary
logic analyzer what data you want to
collect, such as which channels
represent buses (labels) and what
logic threshold your signals use.
frame The Agilent Technologies or
16700A/B-series logic analysis system
mainframe. See also logic analysis
system.
gateway address An IP address
entered in integer dot notation. The
default gateway address is 0.0.0.0,
which allows all connections on the
local network or subnet. If
connections are to be made across
networks or subnets, this address
must be set to the address of the
gateway machine.
glitch A glitch occurs when two or
more transitions cross the logic
threshold between consecutive
timing analyzer samples. You can
specify glitch detection by choosing
the asterisk (*) for edge terms under
the timing analyzer Trigger tab.
grouped event A grouped event is
a list of events that you have
grouped, and optionally named. It can
be reused in other trigger sequence
levels. Only available in Agilent
Technologies 16715A or higher logic
analyzers.
held value A value that is held until
the next sample. A held value can
exist in multiple data sets.
immediate mode In an
oscilloscope, the trigger mode that
does not require a specific trigger
condition such as an edge or a
pattern. Use immediate mode when
the oscilloscope is armed by another
instrument.
interconnect cable Short name for
module/probe interconnect cable.
intermodule bus The intermodule
bus (IMB) is a bus in the frame that
allows the measurement modules to
communicate with each other. Using
the IMB, you can set up one
instrument to arm another. Data
acquired by instruments using the
IMB is time-correlated.
intermodule Intermodule is a term
used when multiple instrument tools
are connected together for the
purpose of one instrument arming
another. In such a configuration, an
arming tree is developed and the
group run function is designated to
start all instrument tools. Multiple
instrument configurations are done in
the Intermodule window.
internet address Also called
Internet Protocol address or IP
address. A 32-bit network address. It
37
Glossary
is usually represented as decimal
numbers separated by periods; for
example, 192.35.12.6. Ask your LAN
administrator if you need an internet
address.
labels Labels are used to group and
identify logic analyzer channels. A
label consists of a name and an
associated bit or group of bits. Labels
are created in the Format tab.
line numbers A line number (Line
#s) is a special use of symbols. Line
numbers represent lines in your
source file, typically lines that have
no unique symbols defined to
represent them.
link-level address Also referred to
as the Ethernet address, this is the
unique address of the LAN interface.
This value is set at the factory and
cannot be changed. The link-level
address of a particular piece of
equipment is often printed on a label
above the LAN connector. An
example of a link-level address in
hexadecimal: 0800090012AB.
local session A local session is
when you run the logic analysis
system using the local display
connected to the product hardware.
logic analysis system The Agilent
Technologies 16700A/B-series
38
mainframes, and all tools designed to
work with it. Usually used to mean
the specific system and tools you are
working with right now.
machine Some logic analyzers allow
you to set up two measurements at
the same time. Each measurement is
handled by a different machine. This
is represented in the Workspace
window by two icons, differentiated
by a 1 and a 2 in the upper right-hand
corner of the icon. Logic analyzer
resources such as pods and trigger
terms cannot be shared by the
machines.
markers Markers are the green and
yellow lines in the display that are
labeled x, o, G1, and G2. Use them to
measure time intervals or sample
intervals. Markers are assigned to
patterns in order to find patterns or
track sequences of states in the data.
The x and o markers are local to the
immediate display, while G1 and G2
are global between time correlated
displays.
master card In a module, the
master card controls the data
acquisition or output. The logic
analysis system references the
module by the slot in which the
master card is plugged. For example,
a 5-card Agilent Technologies 16555D
would be referred to as Slot C:
Glossary
machine because the master card is
in slot C of the mainframe. The other
cards of the module are called
expansion cards.
menu bar The menu bar is located
at the top of all windows. Use it to
select File operations, tool or system
Options, and tool or system level
Help.
message bar The message bar
displays mouse button functions for
the window area or field directly
beneath the mouse cursor. Use the
mouse and message bar together to
prompt yourself to functions and
shortcuts.
module/probe interconnect cable
The module/probe interconnect cable
connects an E5901B emulation
module to an E5900B emulation
probe. It provides power and a serial
connection. A LAN connection is also
required to use the emulation probe.
module An instrument that uses a
single timebase in its operation.
Modules can have from one to five
cards functioning as a single
instrument. When a module has more
than one card, system window will
show the instrument icon in the slot
of the master card.
monitor When using the Emulation
Control Interface, running the
monitor means the processor is in
debug mode (that is, executing the
debug exception) instead of
executing the user program.
panning The action of moving the
waveform along the timebase by
varying the delay value in the Delay
field. This action allows you to
control the portion of acquisition
memory that will be displayed on the
screen.
pattern mode In an oscilloscope,
the trigger mode that allows you to
set the oscilloscope to trigger on a
specified combination of input signal
levels.
pattern terms Logic analyzer
resources that represent single states
to be found on labeled sets of bits; for
example, an address on the address
bus or a status on the status lines.
period (.) See edge terms, glitch,
labels, and don't care.
pod pair A group of two pods
containing 16 channels each, used to
physically connect data and clock
signals from the unit under test to the
analyzer. Pods are assigned by pairs
in the analyzer interface. The number
of pod pairs available is determined
39
Glossary
by the channel width of the
instrument.
pod See pod pair
point To point to an item, move the
mouse cursor over the item, or
position your finger over the item.
preprocessor See analysis probe.
primary branch The primary
branch is indicated in the Trigger
sequence step dialog box as either
the Then find or Trigger on
selection. The destination of the
primary branch is always the next
state in the sequence, except for the
Agilent Technologies 16517A. The
primary branch has an optional
occurrence count field that can be
used to count a number of
occurrences of the branch condition.
See also secondary branch.
probe A device to connect the
various instruments of the logic
analysis system to the target system.
There are many types of probes and
the one you should use depends on
the instrument and your data
requirements. As a verb, "to probe"
means to attach a probe to the target
system.
processor probe See emulation
probe.
40
range terms Logic analyzer
resources that represent ranges of
values to be found on labeled sets of
bits. For example, range terms could
identify a range of addresses to be
found on the address bus or a range
of data values to be found on the data
bus. In the trigger sequence, range
terms are considered to be true when
any value within the range occurs.
relative Denotes time period or
count of states between the current
state and the previous state.
remote display A remote display is
a display other than the one
connected to the product hardware.
Remote displays must be identified to
the network through an address
location.
remote session A remote session is
when you run the logic analyzer using
a display that is located away from
the product hardware.
right-click When using a mouse for
a pointing device, to right-click an
item, position the cursor over the
item, and then quickly press and
release the right mouse button.
sample A data sample is a portion of
a data set, sometimes just one point.
When an instrument samples the
target system, it is taking a single
Glossary
measurement as part of its data
acquisition cycle.
Sampling Use the selections under
the logic analyzer Sampling tab to tell
the logic analyzer how you want to
make measurements, such as State
vs. Timing.
secondary branch The secondary
branch is indicated in the Trigger
sequence step dialog box as the Else
on selection. The destination of the
secondary branch can be specified as
any other active sequence state. See
also primary branch.
session A session begins when you
start a local session or remote
session from the session manager,
and ends when you select Exit from
the main window. Exiting a session
returns all tools to their initial
configurations.
skew Skew is the difference in
channel delays between
measurement channels. Typically,
skew between modules is caused by
differences in designs of
measurement channels, and
differences in characteristics of the
electronic components within those
channels. You should adjust
measurement modules to eliminate
as much skew as possible so that it
does not affect the accuracy of your
measurements.
state measurement In a state
measurement, the logic analyzer is
clocked by a signal from the system
under test. Each time the clock signal
becomes valid, the analyzer samples
data from the system under test.
Since the analyzer is clocked by the
system, state measurements are
synchronous with the test system.
store qualification Store
qualification is only available in a
state measurement, not timing
measurements. Store qualification
allows you to specify the type of
information (all samples, no samples,
or selected states) to be stored in
memory. Use store qualification to
prevent memory from being filled
with unwanted activity such as noops or wait-loops. To set up store
qualification, use the While storing
field in a logic analyzer trigger
sequence dialog.
subnet mask A subnet mask blocks
out part of an IP address so that the
networking software can determine
whether the destination host is on a
local or remote network. It is usually
represented as decimal numbers
separated by periods; for example,
255.255.255.0. Ask your LAN
administrator if you need a the
subnet mask for your network.
41
Glossary
symbols Symbols represent
patterns and ranges of values found
on labeled sets of bits. Two kinds of
symbols are available:
•
Object file symbols - Symbols
from your source code, and
symbols generated by your
compiler. Object file symbols may
represent global variables,
functions, labels, and source line
numbers.
•
User-defined symbols - Symbols
you create.
Symbols can be used as pattern and
range terms for:
•
Searches in the listing display.
•
Triggering in logic analyzers and
in the source correlation trigger
setup.
•
Qualifying data in the filter tool
and system performance analysis
tool set.
system administrator The system
administrator is a person who
manages your system, taking care of
such tasks as adding peripheral
devices, adding new users, and doing
system backup. In general, the
system administrator is the person
you go to with questions about
implementing your software.
42
target system The system under
test, which contains the
microprocessor you are probing.
terms Terms are variables that can
be used in trigger sequences. A term
can be a single value on a label or set
of labels, any value within a range of
values on a label or set of labels, or a
glitch or edge transition on bits
within a label or set of labels.
TIM A TIM (Target Interface
Module) makes connections between
the cable from the emulation module
or emulation probe and the cable to
the debug port on the system under
test.
time-correlated Time correlated
measurements are measurements
involving more than one instrument
in which all instruments have a
common time or trigger reference.
timer terms Logic analyzer
resources that are used to measure
the time the trigger sequence
remains within one sequence step, or
a set of sequence steps. Timers can
be used to detect when a condition
lasts too long or not long enough.
They can be used to measure pulse
duration, or duration of a wait loop. A
single timer term can be used to
delay trigger until a period of time
after detection of a significant event.
Glossary
timing measurement In a timing
measurement, the logic analyzer
samples data at regular intervals
according to a clock signal internal to
the timing analyzer. Since the
analyzer is clocked by a signal that is
not related to the system under test,
timing measurements capture traces
of electrical activity over time. These
measurements are asynchronous
with the test system.
tool icon Tool icons that appear in
the workspace are representations of
the hardware and software tools
selected from the toolbox. If they are
placed directly over a current
measurement, the tools automatically
connect to that measurement. If they
are placed on an open area of the
main window, you must connect them
to a measurement using the mouse.
toolbox The Toolbox is located on
the left side of the main window. It is
used to display the available
hardware and software tools. As you
add new tools to your system, their
icons will appear in the Toolbox.
tools A tool is a stand-alone piece of
functionality. A tool can be an
instrument that acquires data, a
display for viewing data, or a postprocessing analysis helper. Tools are
represented as icons in the main
window of the interface.
trace See acquisition.
trigger sequence A trigger
sequence is a sequence of events that
you specify. The logic analyzer
compares this sequence with the
samples it is collecting to determine
when to trigger.
trigger specification A trigger
specification is a set of conditions
that must be true before the
instrument triggers.
trigger Trigger is an event that
occurs immediately after the
instrument recognizes a match
between the incoming data and the
trigger specification. Once trigger
occurs, the instrument completes its
acquisition, including any store
qualification that may be specified.
workspace The workspace is the
large area under the message bar and
to the right of the toolbox. The
workspace is where you place the
different instrument, display, and
analysis tools. Once in the workspace,
the tool icons graphically represent a
complete picture of the
measurements.
zooming In the oscilloscope or
timing analyzer, to expand and
contract the waveform along the time
base by varying the value in the s/Div
43
Glossary
field. This action allows you to select
specific portions of a particular
waveform in acquisition memory that
will be displayed on the screen. You
can view any portion of the waveform
record in acquisition memory.
44
Index
A
Accumulate distributions, 22
Autoscale, distribution tool, 12
B
bar height, 2
bar height, distribution tool, 18
bin information, using with
distribution tool, 14
bins, distribution, 2
bins, height, 2
bins, width, 2
C
changing color in distribution tool,
23
choosing label for distribution
display, 24
Clear, 25
clearing the chart, 25
color, editing in waveforms, 32
colors, changing distribution tool,
23
comments on display printouts, 30,
31
continuous run, distribution tool,
22
D
data, choosing for distribution, 24
data, print to file, 28
display window pops up when run
completes, 29
distribution, using, 2
E
Edit Colors, 23
erasing data, 25
example measurements using
distribution tool, 14
example measurements,
distribution Accumulate, 22
example measurements,
distribution tool, 18
Expand, distribution tool, 9
F
finding procedures that execute
too long or too short, 18
Full Scale, distribution tool, 11
H
hardcopy, 27
height of bins, 2
hits, checking with distribution
tool, 14
L
label, choosing for distribution, 24
loading distribution configurations,
26
M
measurement examples,
distribution Accumulate, 22
measurement examples,
distribution tool, 14, 18
multiple acquisitions, distribution,
22
N
number of occurrences, checking
with distribution, 14
O
occurrences, checking with
distribution tool, 14
Options, distribution tool color, 23
P
print data to file, 28
printer, 27
printing windows, configurations,
27
procedure, checking with
distribution tool, 18
R
repetitive acquisition, distribution
tool, 22
S
saving distribution configurations,
26
T
tabs, turning on or off in display
window, 30
tool, distribution, 2
W
width of bins, 2
window, printing, 27
workspace, 27
Z
zoom in, distribution tool, 8
zoom in, distribution tool, single
bin, 9
zoom in, on a single bin, 9
zoom out, distribution tool, 8, 10
zoom out, distribution tool
autoscale, 12
zoom out, distribution tool, full
scale, 11
45
Index
46
Publication Number: 5988-9050EN
January 1, 2003
s1
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising