パソコン対応ソフト取扱説明書

パソコン対応ソフト取扱説明書
パソコン対応ソフト取扱説明書
第2版
ファイル拡張子一覧
プログラム(個別) プログラム(一括) ポジション パラメータ
aspg
aspa
aspt
aspm
シンボル
グローバルデータ
assm
asgd
ソフトウェア使用許諾契約書
この度は、パソコン対応ソフトをお買い上げ戴き、誠にありがとうございます。
本製品は、お客様が本契約書にご同意戴いた場合のみ、提供致します。本製品を開封する前に、
本契約書をお読みください。本契約書にご同意戴けない場合は、本製品を開封されずに弊社にご
返却戴ければ、代金をお返し致します(理由の如何に関らず開封された時点で本契約書に同意さ
れたものと看做します)。
株式会社 SUS(以下「甲」といいます)は、本契約書と共に提供するソフトウェア・プログラム
(以下「許諾ソフトウェア」といいます)を使用する非譲渡性の非独占的権利を下記条項に基づ
き許諾し、お客様(以下「乙」といいます)も下記条項に同意するものとします。
1.契約期間
本契約は、許諾ソフトウェアを乙が開封した時から発効し、乙が文書で甲に解約を申し入れるか、ま
たは第5項に規定により解約されるまで有効とします。
2.使用権
乙は、本契約に基づき実施許諾された許諾ソフトウェアを、機械読取可能な形で、単一のコンピュー
タ・システム(以下「システム」といいます)で使用することができます。他のシステムで許諾ソフト
ウェアを使用する時は、別途使用権を取得することが必要です。
乙は、甲の書面による事前の同意を得なければ、本契約による使用権、本契約の適用されるソフトウ
ェア、またはその他の品目を、譲渡したり、第三者に再使用権を許諾したり、または移転したりするこ
とはできません。本契約で明示されている場合を除き、許諾ソフトウェアの全体または一部を印刷また
は複製する権利は許諾されていません。
3.許諾ソフトウェアの複写
乙は、本契約書に基づき甲から提供された印刷物を、たとえその一部であっても複写することはでき
ません。甲から機械読取可能な形で提供された許諾ソフトウェアの複製は、バックアップを目的とする
場合に限定されます。
4.許諾ソフトウェアの保護
乙は、許諾ソフトウェアを、甲の事前の書面による同意を得ることなく、乙または甲の従業員以外の
いかなる者に対しても提供できません。
5.契約の解除
甲は乙において、本契約に定める事項に違反した時、及び本契約を継続しがたい重大な事由がある時
は、乙に対し何らかの事前の通知なしに直ちに本契約を解除できるものとします。
本契約が解除された場合、乙は契約が終了した日より10日以内に甲から受領した許諾ソフトウェア及
びその複写物をすべて廃棄するものとし、その旨を説明する文書を甲に送付するものとします。
6.保護範囲
甲は、許諾ソフトウェアに関するすべての仕様について、事前の通知なしに変更することができるも
のとします。また許諾ソフトウェアに関するいかなる保証も行わないものとします。また許諾ソフトウ
ェアの組込みにより、乙に損害が発生したとしても、乙は甲に対してその損害の賠償を求めることはで
きません。
ご
注
意
このソフトウェアの著作権は、株式会社SUSにあります。
このソフトウェア及びマニュアルの一部または全部を無断で使用、複製することはできません。
ソフトウェアは、コンピュータ1台につき1セット購入が原則になっております。
このソフトウェア及びマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。
このソフトウェア及びマニュアルを運用した結果の影響については、いっさい責任を負いかねますので
ご了承ください。
このマニュアルの表紙に記載の版数(Ver. または Edition)と、ソフトウェアの版数(Ver.)は全く一致
しておりませんので御了承ください。
このマニュアルに記載されている事柄は、将来予告なしに変更することがあります。
本ソフトウェアは、下表に示す Windows で動作します。従って、本ソフトウェアを御使用になる人は、
Windows の基本動作が出来ることが前提となります。
(ただし、本ソフトウェアには Windows は付いていません)。
使用ポート
RS-232C
USB
動作可能 Windows
型式
SA-D-P1S
SA-D-P1S-USB
Windows 98、Windows Me、Windows 2000、
Windows XP
Windows 98SE、Windows Me、Windows 2000、Windows XP
Microsoft、MS、MS-DOS、Windows、Windows3.1、Windows95、Windows98、WindowsNT、Windows2000、
Windows Me、Windows XP は、米国 Microsoft Corporation の登録商標です。
目 次
1.お使いになる前に …………………………………………………………………………………
1.1 ご使用に際して提供されるもの(製品構成)……………………………………………
1.2 ご準備していただくもの(動作環境) ……………………………………………………
1.3 本ソフトウェアのインストール ……………………………………………………………
1.3.1 SA用パソコン対応ソフトのインストール方法 …………………………………
1.3.2 USB 変換アダプタドライバソフトのインストール方法 ………………………
1.3.3 USBのCOMポートの変更方法 ……………………………………………………
1.4 コントローラとの接続 ………………………………………………………………………
1.5 本ソフトウェアの起動(オンライン接続)………………………………………………
2.データ保存方法 ………………………………………………………………………………………
2.1 出荷時の設定 バックアップバッテリ使用の場合………………………………………
2.2 バックアップバッテリを使用しない場合…………………………………………………
2.3 注意事項 ………………………………………………………………………………………
3.メニューウィンドウ ………………………………………………………………………………
3.1 メニューの説明 ………………………………………………………………………………
3.1.1 オンライン画面 ……………………………………………………………………
3.1.2 オフライン画面 ……………………………………………………………………
3.2 コマンドの説明 ………………………………………………………………………………
3.3 ツールバー説明 ………………………………………………………………………………
3.4 ツリービュー …………………………………………………………………………………
4.プログラム編集ウィンドウ ………………………………………………………………………
4.1 プログラム編集ウィンドウの項目説明 ……………………………………………………
4.2 プログラム保存、及び編集終了について ………………………………………………
4.3 プログラムのファイルへの一括保存について …………………………………………
4.4 プログラム実行 ………………………………………………………………………………
5.プログラムのコピー・移動・削除 ……………………………………………………………
5.1 プログラムのコピー / 移動ウィンドウ ……………………………………………………
5.2 プログラムのクリアウィンドウ ……………………………………………………………
6.ポジションデータ編集ウィンドウ ……………………………………………………………
6.1 ポジションデータ編集ウィンドウの項目説明 …………………………………………
6.2 ポジション保存、及び編集終了について ………………………………………………
7.ポジションデータのコピー・移動・削除 …………………………………………………
7.1 ポジションデータのコピー / 移動 …………………………………………………………
7.2 ポジションデータの削除 ……………………………………………………………………
1
1
2
3
3
7
14
16
17
20
20
21
22
23
23
23
24
25
34
36
37
37
44
46
48
49
49
51
53
53
60
63
63
65
8.パラメータ編集ウィンドウ ………………………………………………………………………
8.1 パラメータ編集ウィンドウの説明 …………………………………………………………
8.2 パラメータの保存及び編集終了について ………………………………………………
8.3 パラメータファイルの転送について ………………………………………………………
8.3.1 転送パラメータ種別選択 …………………………………………………………
8.3.2 デフォルト指定 ……………………………………………………………………
8.4 パラメータ(工場出荷時)初期化方法……………………………………………………
9.シンボル編集ウィンドウ …………………………………………………………………………
66
66
68
70
70
72
73
9.1 シンボルについて ……………………………………………………………………………
9.2 シンボル編集ウィンドウの説明 ……………………………………………………………
9.3 シンボルの保存及び編集終了について ……………………………………………………
75
75
76
78
10.モニタ …………………………………………………………………………………………………
81
11.コントローラメニュー補足 ……………………………………………………………………
11.1 ソフトウェアリセット ……………………………………………………………………
11.2 エラーリセット ……………………………………………………………………………
11.3 駆動源復旧要求と動作一時停止解除要求について ……………………………………
11.4 SEL グローバルデータバックアップ ……………………………………………………
11.5 制御定数テーブル管理情報 ………………………………………………………………
11.6 ポジショナモードの起動停止 …………………………………………………………
11.7 ポジショナモードの情報取得 …………………………………………………………
11.8 ポジショナモード管理情報 ……………………………………………………………
90
90
90
91
92
94
95
96
97
12.ツール …………………………………………………………………………………………………
98
付録
エラーレベル管理について …………………………………………………………………………… 100
SAパソコン対応ソフトエラー表 …………………………………………………………………… 101
1.お使いになる前に
1.1
ご使用に際して提供されるもの(製品構成)
本ソフトウェアの使用に際しましては、次のものが提供されていることをご確認ください。
本マニュアル
ソフトウェアの入った CD-ROM
ソフトウェアの使用許可契約(説明)書
外部接続ケーブル
パソコン対応ソフトの型式により、外部接続ケーブルは異なります。
下表に型式と外部接続ケーブルを示します。
型式
SA-D-P1S
接
続
形
態
1冊
1枚
1枚
1式
外部接続ケーブル
RS232C ケーブル
変換ケーブル
1本
1本
対応コントローラ
対応コントローラ
SA
RS232Cケーブル
RS232C ケーブルの場合、NEC 製コンピュータ御使用の際、一部機種においては、別途アダプタを必要と
する場合があります。
型式
SA-D-P1S-USB
接
続
形
態
外部接続ケーブル
USB ケーブル
ダミープラグ
1本
ダミープラグ
USBケーブル
対応コントローラ
SA
1
1.2
(
ご準備していただくもの(動作環境)
本ソフトウェアは、次のようなコンピュータ本体や周辺機器が必要です。
コンピュータ本体、及び適合するキーボード
Windows が動作するパーソナルコンピュータ *1、及び適合するキーボード。
(*1 パーソナルコンピュータ:以下、本書では「パソコン」と略記します)
メモリ
Windows を動作させるのに必要なメモリ容量に準じます。
ディスプレイ:VGA 以上
(XGA 以上を推奨)
マウス等ポインティングデバイス、及び適合するマウスドライバ
本ソフトウェアを快適に操作していただく為のマウス等ポインティングデバイス、及び適合するマウス
ドライバ。
W indows
Windows98、Windows 2000、Windows Me、Windows XP
CD-ROM ドライブ
ハードディスク
5 MB 以上の空き領域があるハードディスク。
(本ソフトは、ハードディスクにインストールして使用)
○シリアルポート:型式 SA-D-P1S
RS232C シリアルポート(9ピンのみ対応)
USB ポート:型式 SA-D-P1S-USB
プリンタ
パソコン本体に適合するプリンタ
2
)
1.3 本ソフトウェアのインストール
本ソフトは、パソコンのハードディスクにインストールして使用します。ここでは、本ソフトのインス
トール方法を説明します。
1.3.1 SA用パソコン対応ソフトのインストール方法
CD-ROM ドライブに本ソフトの CD-ROM を挿入します。
インストールするデータ選択画面(図 1.1)が表示されます。
インストールしたいデータをクリックします。
図 1.1 インストールするデータ選択画面
(表示画面はバージョン、CD 内のデータ等により異なることがあります)
※インストールするデータ選択画面(図 1.1)が表示されない場合の対応
CD-ROM を挿入しても、インストールするデータ選択画面(図 1.1)が表示されない場合は、下記の手
順に従って、インストールするデータ選択画面を表示させてください。
a. エクスプローラなどを使って、CD-ROM 内のフォルダなどの一覧を表示させてください。
図 1.2 が表示されます。
図 1.2 CD-ROM 内のフォルダなど一覧
b. 表示された を、ダブルクリックしますと、インストールするデータ選択画面(図 1.1)が表
示されます。
3
SA 用パソコン対応ソフトのインストール画面(図 1.3)に移ります。
[次へ]をクリックします。
図 1.3 インストール画面
ユーザ情報登録画面(図 1.4)が表示されますので、ユーザ情報を入力し、
[次へ]をクリックします。
図 1.4 ユーザ情報登録
4
SA用パソコン対応ソフトのインストール先を指定します(図 1.5)。
通常は、表示されたとおりでかまいません。
指定が終わったら、[次へ]をクリックします。
図 1.5 インストール先のフォルダ指定
インストールの準備が完了しました。
[インストール]をクリックすると、実際のインストール作業が 開始します。
図 1.6 インストールの準備
5
インストール処理中は、図 1.7 のような画面がでてきます。
図 1.7 インストール進行状況
インストールが完了すると、図 1.8 のような画面がでてきます。
図 1.8 インストール完了
インストールプログラムが終了すると、スタートメニューのプログラム(P)→ SUS→ SA →SA用パソ
コン対応ソフトという項目が表示され、その項目を選択することにより本ソフトが起動します。
CD-ROM を取り出してください。
プログラムを起動後、メニューの「ヘルプ」をクリックし、バージョンが、CD-ROM のバージョンと
なっているか確認してください。
なっていない場合は、再度、プログラムをアンインストールし、CD-ROM のプログラムをインストール
してください。
6
1.3.2
USB 変換アダプタドライバソフトのインストール方法
USB ポートを使用する場合は、USB 変換アダプタドライバソフトをインストールする必要があります。
[対応ソフト]
・ SA-D-P1S-USB(USB ケーブル付)
CD-ROM ドライブに本ソフトの CD-ROM を挿入します。
インストールするデータ選択画面(図 1.9)が表示されます。
「USB 変換アダプタ」をクリックします。
図 1.9
インストールするデータ選択画面
(表示画面はバージョン、CD 内のデータ等により異なることがあります)
ドライバのインストール先を聞いてきます。そのままでよければ「コピー」をクリックしてください。
変更したい場合は手入力、もしくは「参照」を押し、コピー先フォルダを設定してください。
コピー先フォルダ参照画面(図1.11)ではコピーしたい先のフォルダをクリックし、選択した後に「OK」
をクリックしてください。「OK」を押したらコピー先フォルダ参照画面(図 1.11)が消え、選択したフォ
ルダのパスがコピー先フォルダ指定画面(図 1.10)に表示されます。
図 1.10
コピー先フォルダ指定画面
図 1.11
コピー先フォルダ参照画面
7
コピー先に「IAI USB」
(コピーデータ)のフォルダが既に存在する場合、上書きするかを聞いてきます。
上書きしていい場合は「OK」を、コピーを中止したい場合は「キャンセル」をクリックしてください。
図 1.12 上書き確認画面
完了画面(図 1.13)が表示されます。
図 1.13 完了画面
完了画面(図 1.13)が表示されましたら、OK をクリックしてください。完了画面(図 1.13)が消えま
す。次にコピー先フォルダ指定画面(図1.10)の「キャンセル」をクリックしてください。コピー先フォ
ルダ指定画面(図 1.10)が消えます。
最後に、データ選択画面(図 1.9)の終了をクリックしてください。データ選択画面(図 1.9)が消えま
す。
CD-ROM を取り出してください。
8
次に、USB 変換アダプタを、パソコンのUSBポートに挿入します。
パソコンと SA コントローラを付属の USB ケーブルで、接続します。
注意:USB ケーブルで、パソコンとコントローラの USB ポートを直接、接続する場合は、接続するすべての
コントローラを 1 台づつ接続し、USB 変換アダプタドライバソフトで認識する必要があります。
から の手順を、接続するすべてのコントローラに対して実施してください。なお、COMポートは、
接続されるすべてのコントローラに対して、作成されます。
Windows で、「新しいハードウェアの検出ウィザード」が開きます。
「はい、今すぐおよびデバイスの接続時には毎回接続します(E)」をチェックします。
次へ(N)> をクリックします。
図 1.14 新しいハードウェアの検出ウィザード開始画面
「インストール方法選択画面」が開きます。
「一覧または特定の場所からインストールする(詳細)(S)」をチェックします。
次へ(N)> をクリックします。
図 1.15 インストール方法選択画面
9
「検索とインストールのオプション選択画面」が開きます。
「次の場所を含める(D)」をチェックします。
参照 をクリックして、「C:IAI USB」を探し、設定します。
次へ(N)> をクリックします。
図 1.16 検索とインストールのオプション選択画面
「IAI USB Composite Device」ドライバのインストールが開始されます。
途中に、インストールを続行するかどうか聞いてきます。
続行 をクリックします。
図 1.17 インストール続行確認画面
10
「IAI USB Composite Device」ドライバのインストール完了が表示され、ドライバのインストールが完
了します。
完了 をクリックします。
図 1.18 IAI USB Composite Device インストール完了画面
引き続き「インストール方法選択画面」が開きます。
「一覧または特定の場所からインストールする(詳細)(S)」をチェックします。
次へ(N)> をクリックします。
図 1.19 インストール方法選択画面
11
「検索とインストールのオプション選択画面」が開きます。
「次の場所を含める( D)」をチェックします。
参照 をクリックして、「C:IAI USB」を探し、設定します。
次へ(N)> をクリックします。
図 1.20 検索とインストールのオプション選択画面
「IAI USB to UART Bridge Controller」ドライバのインストールが開始されます。
途中に、インストールを続行するかどうか聞いてきます。
続行 をクリックします。
図 1.21 インストール続行確認画面
12
「IAI USB to UART Bridge Controller」ドライバのインストール完了が表示され、ドライバのインストー
ルが完了します。
完了 をクリックします。
図 1.22 IAI USB to UART Bridge Controller インストール完了画面
すべてのドライバのインストールが完了します。
Windowsのスタート→設定→コントロールパネルをクリックして、「コントロールパネル」を開きます。
「システム」をダブルクリックし、システムのプロパティを開きます。
「システム」の上にある「ハードウェア」をクリックして開きます。
「ハードウェア」の中の「デバイスマネージャ」をクリックして開きます。
「デバイスマネージャ」の「ポート(COM と LPT)」をダブルクリックして拡張します。
「デバイスマネージャ」の「ポート(COM と LPT)」中に、「IAI USB to UART Bridge Controller(COM?)」
が有れば、ドライバは正常にインストールされ、作動しています。
(注)COM? の番号は、挿入したCOM ポートの番号となります。
IAI USB to UART Bridge
Controller(COM?)
図 1.23 デバイスマネージャ画面
13
1.3.3 USB の COM ポートの変更方法
USB 変換アダプタドライバソフトのインストール作業で設定された COM ポートは、下記の手順で変更で
きます。
Windows のスタート→設定→コントロールパネルをクリックして、
「コントロールパネル」を開きます。
「システム」をダブルクリックして、システムのプロパティを開きます。
「システム」の上にある「ハードウェア」をクリックして開きます。
「ハードウェア」の中の「デバイスマネージャ」をクリックして開きます。
「デバイスマネージャ」の「ポート(COM と LPT)
」をダブルクリックして拡張します。
「IAI USB to UART Bridge Controller(COM?)
」をダブルクリックします。
(注)COM? は、変更前 COM ポートの番号です。
IAI USB to UART Bridge
Controller(COM?)
図 1.24 デバイスマネージャ画面
○「IAI USB to UART Bridge Controller(COM?)
」のプロパティ画面が表示されます。
プロパティ画面の「詳細設定(A)」をクリックします。
図 1.25 プロパティ画面
14
「COM? ポートの詳細設定画面」が表示されます。
「COM ポートの番号(P)
:」で、設定したい COM ポート No. に変更します。
変更後、OK をクリックします。
COM ポートの番号(P)
:
図 1.26 COM? ポートの詳細設計画面
「COM? ポートの詳細設計画面」が消えます。
「プロパティ画面」(図 1.25)で、OK をクリックしますと COM ポートが変更されます。
「デバイスマネージャ画面」
を消して、再度、表示させると、COM ポートの番号が変更されていること
が確認できます。
確認後、開いている「デバイスマネージャ画面」などをすべての画面を消します。
15
1.4 コントローラとの接続
上位システム
USB ケーブル
変換ケーブル
非常停止
スイッチ
イネーブル
スイッチ
DC24V 0V
電源 24V
図 1.27 SAコントローラ
16
パネルユニット
1.5 本ソフトウェアの起動(オンライン接続)
コントローラ及びパソコンの電源を OFF にして、付属の標準 RS232 ケーブル又は USB ケーブルなどに
て、コントローラとパ ソコンを接続します。
コントローラのモードスイッチを MANU 側にします。
本ソフトウェア起動時には、
‘セーフティ速度有効(安全速度制限あり)’の状態になっていま
す。そのため、パソコン対応ソフトからのプログラム起動による最高速度は直交軸の場合は、
250mm/sec 以下となります。プログラムの速度指令どおりに動作させるには、
‘ セーフティ
速度無効(安全速度制限なし)’の状態に変更する必要があります。
セーフティ速度有無の切替えは「3.3 ツールバー説明」を参照ください。
●
コントローラ及びパソコンの電源を投入し、Windows を起動します。
本ソフトを起動します。
アプリケーションを起動すると、最初に接続確認画面(図 1.28)が表示されます。
「通信ポート」 および 「ボーレート」 に表示されている一覧の中から、SA コントローラが接続されている
通信ポート(※ 1)とボーレートを選択し、【OK】ボタンをクリックします。
(※ 1)アプリケーションを起動した時点で使用可能な通信ポー
トのみ選択可能。
図 1.28 接続確認画面
17
接続後、複数プログラム同時起動許可、禁止設定画面(図 1.29)が表示されます。
マニュアルモード時、複数プログラム同時起動を禁止するか許可するかを設定し、[OK]ボタンを
クリックします。
[複数プログラム同時起動禁止(マニュアルモード時)
]
マニュアルモード時、複数プログラムの同時起動を禁止します。
[複数プログラム同時起動許可(マニュアルモード時)
]
マニュアルモード時、複数プログラムの同時起動を許可します。
図 1.29 複数プログラム同時起動許可、禁止設定画面
「次回から起動時にこの画面を表示しない」をチェックしている場合は、立上げ時、図 1.29 の画面は表
示されず、前回接続時の設定で接続します。
本チェックを外したいときは、環境設定(オンライン)画面(図 13.2)又は、環境設定(オフライン)
画面(図 13.1)で、
「接続時、複数プログラム同時起動の可否をチェックする」のチェックボタンをチェッ
クすれば、次回の立上げ時に、図 1.29 の画面が表示され、チェックを外すことができます。
環境設定(オンライン)画面、環境設定(オフライン)画面に付きましては、「12. ツール」を、ご参
照ください。
既に、複数プログラムが起動している場合に、[複数プログラム同時起動禁止(マニュアルモード時)]
を設定すると、警告メッセージが表示されます。
禁止する場合は、
[はい]ボタンを押し、全プログラムを停止してください。
図 1.30 警告メッセージ
コントローラとの接続確認が完了するとオンラインモードでアプリケーションが立ち上がります。
コントローラが認識できない場合または【CANCEL】ボタンをクリックした場合はオフラインモードと
なります。
(オフラインモードで起動した場合でも後述する 「再接続」 を行うことにより、オンラインモー
ドに移行することができます。
)
また、「次回から起動時にこの画面を表示しない」 がチェックされている場合、前回アプリケーション終了
時に使用されていた通信ポートおよびボーレートで自動的に接続確認処理が実行されます。
18
要注意事項
TP ポート(ティーチングコネクタ)のオープンに関して、サーボ非使用中・使用中により、
以下のようになります。
< MANU モード・サーボ非使用中>
OPEN 命令実行前
TP ポートの接続
パソコンソフトとの接続
OPEN 命令実行後
SEL プログラム接続への強制移行
(メッセージエラー)プログラムは実行中
OPEN 命令実行後の発生エラー:エラー No.A50「非 AUTO モード時 SCIF オープンエラー」
< MANU モード・サーボ使用中>
TP ポートの接続
OPEN 命令実行前
OPEN 命令実行後
パソコンソフトとの接続
パソコンソフトとの接続
(コールドスタートエラ ー)プログラムは終了
OPEN 命令実行後の発生エラー:エラー No.E89「非 AUTO モード時 SCIF オープンエラー(サーボ使用中)」
TP ポートのチャンネル No. を、次に示します。 0 ch ‘OPEN 0’
上記枠内
“要注意事項” は MANU モードかつ I/O パラメータ No.90 =2
(SUSプロトコル)以外
時についての記述です。
19
2 . データ保存方法
コントローラはフラッシュメモリを採用しているため、保存するデータによりバッテリバックアップに
よる保存領域とフラッシュメモリによる保存領域があります。
また、パソコンソフトまたはティーチングボックスからデータ転送を行っても下図のようにメモリに書込ま
れただけであり、電源 OFF またはコントローラリセットによりそのデータは消去されてしまいます。
確実に保存するためにも、保存しておきたいデータはフラッシュ書込みを行うようにしてください。
2.1
出荷時の設定 バックアップバッテリ使用の場合
(その他パラメータ No.20 =2
(バックアップバッテリ装着))
パソコン、ティーチング
ボックスでの編集データ
プログラム
パラメータ
(内容 1)
シンボル
スレーブカード
パラメータ
(内容 2)
電源 ON の間データを保持
リセットによりデータ消去
電源 OFF してもデータを保持
フラッシュ書込
転 送
フラッシュ
メモリ
メモリ
リセット読込
転 送
転 送
EEPROM
メモリ
リセット読込
転 送
※エンコーダ
パラメータ
転 送
メモリ
リセット読込
※エンコーダ
EEPROM
ポジション
転 送
バッテリ
バックアップ
メモリ
SEL グローバル
データ(内容 3)
エラーリスト
転 送
バッテリ
バックアップ
メモリ
フラッシュ書込
フラッシュ
メモリ
※エンコーダパラメータは、コントローラ内ではなく、アクチュエータのエンコーダ自身の EEPROM に記憶されて
おり、電源投入時またはソフトウェアリセット時にコントローラ内に読込まれます。
20
プログラム・ パラメータ・ シンボルは再起動時にはフラッシュメモリから読込ますのでフラッシュへの
書込みをしないとメモリのデータは編集前の元データとなってしまいます。
コントローラは常にメモリ(点線枠内)のデータに従い動作します。
(パラメータは除く)
内容1:下記内容2以外のパラメータ
I/O スロットカード・
(電源系カード) パラメータ
内容2:
内容3:フラグ、変数、ストリング、エラーリスト
2.2
バックアップバッテリを使用しない場合
その他パラメータ No.20 =0
(バックアップバッテリ非装着)
パソコン、ティーチング
ボックスでの編集データ
プログラム
パラメータ
(内容 1)
シンボル
ポジション
電源 ON の間データを保持
リセットによりデータ消去
電源 OFF してもデータを保持
フラッシュ書込
転 送
フラッシュ
メモリ
メモリ
リセット読込
転 送
スレーブカード
パラメータ
(内容 2)
転 送
EEPROM
メモリ
リセット読込
転 送
※エンコーダ
パラメータ
転 送
※エンコーダ
EEPROM
メモリ
リセット読込
SEL グローバル
データ(内容 3)
エラーリスト
転 送
メモリ
プログラム・ パラメータ・ シンボル・ ポジションは再起動時にはフラッシュメモリから読込ますのでフ
ラッシュへの書込みをしないとメモリのデータは編集前の元データとなってしまいます。
コントローラは常にメモリ(点線枠内)のデータに従い動作します。
(パラメータは除く)
注意:SEL グローバルデータはバックアップバッテリ非装着では保持できません。
21
2.3 注意事項
データ転送及びフラッシュ書込み時の注意事項
データ転送中及びフラッシュ書込み中は絶対に主電源をOFFしないでください。
データが失われコントローラが動作できなくなる場合があります。
パラメータをファイルに保存する際の注意事項
エンコーダパラメータは、アクチュエータのエンコーダ自身のEEPROMに記憶されています。
(他
のパラメータ種別とは異なり、コントローラ内のEEPROMではありません。)電源投入時またはソフ
トウェアリセット時に、エンコーダパラメータは、EEPROM からコントローラに読込まれます。
この為、アクチュエータ
(エンコーダ) 非接続状態で電源投入
(またはソフトウェアリセット) さ
れたコントローラのパラメータをファイルに保存した場合、このファイルに保存されるエンコーダパ
ラメータは無効な値となります。
パラメータファイルをコントローラに転送する際の注意事項
パラメータファイルをコントローラに転送する際、エンコーダパラメータはエンコーダのEEPROM
に転送されます。
(製造情報・機能情報は除く)
この為、アクチュエータ非接続状態で起動したコントローラから読み出したパラメータファイルを
コントローラに転送する場合、エンコーダの EEPROM には無効な値のエンコーダパラメータが書き
込まれてしまうことになります。
(アクチュエータが接続されているコントローラへの転送を行った
場合)
パラメータをファイルに保存する際には、アクチュエータを接続した状態で行ってください。
22
3.メニューウィンドウ
3.1 メニューの説明
3.1.1 オンライン画面
(1)プログラムモード
本ソフトが起動すると、コントローラのプログラムモードの場合は、図 3.1 に示されるメインの
ウィンドウが開かれ、メニューとツールバー上のアイコンが現れます。画面左側のツリービューは、メ
ニューの「表示(V)」→「ツリー表示(T)」の操作により表示できます(初期画面 :メインメニュー)。
メニュー
アイコン
ツリービュー
図 3.1 オンライン画面(プログラムモード時)
(注) プログラムモードとポジショナモードの2種類の選択が可能です。
選択は、その他パラメータ No.25「運転モード種別」に設定します。
詳細は、SAコントローラの取説をご参照ください。
23
(2)ポジショナモード
本ソフトが起動すると、ポジショナモードの場合は、図3.2に示されるメインのウィンドウが開かれ、
メニューとツールバー上のアイコンが現れます。画面左側のツリービューは、メニューの「表示(V)」
→「ツリー表示(T)」の操作により表示できます
(初期画面 : メインメニュー)。
メニュー
アイコン
ツリービュー
図 3.2 オンライン画面(ポジショナモード時)
ただし、ポジショナモード時は、メニュー及びツールバーにて、
「プログラム編集」、
「シンボル編集」 が出
来なくなります。アイコンも薄い表示になります。
「複数プログラム同時起動禁止」も表示されません。
3.1.2 オフライン画面
コントローラと接続せずに、本ソフトを起動した場合、図 3.3 の画面が表示されます。オフラインで操作
できない項目は、薄いアイコンになります。
図 3.3 オフライン画面
24
3.2 コマンドの説明
(1) ファイル
(F)
新規作成
(N)
SEL データを新規に作成します。
・プログラム
(S)
新規プログラムの編集ウィンドウを開きます。
・ポジション
(O)
新規ポジションデータの編集ウィンドウを開きます。
ポジショナモードの場合は薄い表示となり、操作できません。
・シンボル
(Y)
新規シンボルデータの編集ウィンドウを開きます。
ポジショナモードの場合は薄い表示となり、操作できません。
図 3.4 ターゲット選択ウィンドウ
ターゲット選択ウィンドウ(図 3.4)が表示され、コントローラタイプ・軸数(ポジション
データ作成時のみ選択が必要)を選択します。
※作成したデータは、ここで選択したターゲットに応じたファイル形式(冒頭ページサポート機
種一覧参照)でしか保存できません。
開く
(O)
ファイルに保存されているデータを読み込みます。
(注) ポジショナモード時、プログラムファイル / シンボル
ファイルは開けません。
開いた場合、ABB ファイルタイプエラーが表示されます。
図 3.5 ABB ファイルタイプエラー
25
閉じる
(C)
現在のアクティブなウィンドウを閉じます。
上書き保存
(S )
アクティブな編集ウィンドウのデータをファイルに上書き保存し
ます。
名前を付けて保存
(A)
アクティブな編集ウィンドウのデータをファイルに名前を付けて
保存します。
印刷設定(P)
印字フォント、プリンタの設定を行います。
印刷時の上側の余白
クリックすると、プリンタ設
領域を、指定します。
定画面が表示され、プリンタ
単位は、mm です。
の設定を行えます。
クリックすると、フォント設
定画面が表示され、印刷する
フォントの設定を行えます。
印刷時の左側の余白
メニューの表示
(V) →フォ
領域を、指定します。
ント
(F) のフォント設定画
単位は、mm です。
面と連動しています。いずれ
かで設定した値が、両方に反
図 3.6 印刷設定画面
映されます。
(注)再立ち上げを行った場合、設定は、下記のデフォルト値に戻ります。
・ 上マージン : 0(mm)
・ 左マージン : 10(mm)
・ フォント
: MS ゴシック
・ スタイル
:標準
・ サイズ : 10
最近使ったファイル
(D)
最近読み込んだファイルの履歴が表示され、
これらの中からファ
イル名を選択して読み込むことができます。
終了
(X)
26
アプリケーションを終了します。
(2) 編集
(E)
データを編集する際の補助作業を行います。
元に戻す
(U)
直近の 10 操作まで、操作を元に戻せます。
ただし、以下のいずれかの操作を行った時点で、元に戻せなくな
ります。
・ プログラム編集ウィンドウなどの編集画面上のデータをコント
ローラへ転送
・ プログラム編集ウィンドウなどの編集画面上のデータをファイ
ルへ保存
・ プログラム編集ウィンドウなどの編集画面を閉じる。
この機能が有効となる操作を、下表に示します。
入力
行挿入
行削除
カット
ペースト
プログラム編集ウィンドウ
○
○
○
○
○
ポジション編集ウィンドウ
○
−
−
○
○
シンボル編集ウィンドウ
○
−
−
○
○
パラメータ編集ウィンドウ
○
−
−
−
−
本操作を行うと、図 3.13 の警告画面が表示されます。
はい をクリックすると、1つ前の操作に戻ります。
図 3.7 警告
切り取り
(T)
編集ウィンドウのカーソル行のデータを切り取ります。
コピー
(C)
編集ウィンドウのカーソル行のデータをコピーします。
貼り付け
(P)
コピーまたは切り取ったデータを編集ウィンドウのカーソル行へ
貼り付けます。
検索(F)
次を検索
(S)
指定された文字列を検索します。
で指定された文字列をカーソル行の位置から再検索します。
(3) 表示
(V) 表示に関する設定を行います。
(「3.4 ツリービュー」を参照してください。)
ツリー表示
(T)
メイン画面左側のツリービューの表示を ON/OFF します。
フォント
(F)
画面に表示するフォントの設定を行います。
27
(4) プログラム
(S)
プログラムに関する操作を行います。
(オンラインモード時のみ有効)
(「4. プログラム編集ウィンドウ」を参照してください。)
編集(E)
選択されたプログラムをコントローラから読み出して編集を行い
ます。
コピー / 移動
(C)
プログラムのコピー / 移動(カット&ペースト)を行います。
クリア
(L)
プログラムのクリアを行います。
ファイルへ保存
(S )
選択された 1つのプログラムまたは全プログラムを一括してファ
イルに名前を付けて保存します。
全動作終了
(T)
実行中のプログラムおよび動作を全て終了させます。
(5)ポジション
(O)
ポジションデータに関する操作を行います。
(オンラインモード時のみ有効)
(「6. ポジションデータ編集ウィンドウ」を参照してください。)
編集
(E)
ポジションデータをコントローラから読み出して編集を行います。
コピー / 移動
(C)
ポジションデータのコピー/ 移動
(カット&ペースト)
を行います。
クリア
(L)
ポジションデータのクリアを行います。
(6) パラメータ
(P)
パラメータに関する操作を行います。
(オンラインモード時のみ有効)
(「8. パラメータ編集ウィンドウ」を参照してください。)
編集
(E)
パラメータをコントローラから読み出して編集を行います。
(7) シンボル
(Y)
シンボルデータに関する操作を行います。
(オンラインモード時のみ有効)
(「9. シンボル編集ウィンドウ」を参照してください。)
28
編集
(E)
シンボルデータをコントローラから読み出して編集を行います。
オールクリア
(C)
シンボルデータをオールクリアします。
(8)モニタ(M)
各種ステータス、グローバル変数、ポート状態等のモニタを行います。
(オンラインモード時のみ有効)(「10. モニタ」を参照してください。)
タスクステータス
(T)
タスクステータスモニタウィンドウを開きます。
システムステータス
(S)
システムステータスモニタウィンドウを開きます。
軸ステータス
(A)
軸ステータスモニタウィンドウを開きます。
入力ポート
(I)
入力ポートモニタウィンドウを開きます。
仮想入力ポート(N)
仮想入力ポートモニタウィンドウを開きます。
出力ポート
(O)
出力ポートモニタウィンドウを開きます。
仮想出力ポート(U)
仮想出力ポートモニタウィンドウを開きます。
グローバルフラグ(F)
グローバルフラグモニタウィンドウを開きます。
グローバル整数(L)
グローバル整数モニタウィンドウを開きます。
グローバル実数(R)
グローバル実数モニタウィンドウを開きます。
グローバルストリング
(G)
グローバルストリングモニタウィンドウを開きます。
エラー詳細情報(E)
エラー詳細情報モニタウィンドウを開きます。
メインメニューの
「モニタ(M)」→
「エラー詳細情報(E)」を
選択しますと、エラーリスト表示設定画面が表示されます。
エラーリスト表示数の設定後、
「O K」をクリックしますと、エ
ラー詳細情報画面が表示されます。
図 3.8 エラーリスト表示数設定画面
モニタリングデータ
(M)
モニタリングデータウィンドウを開きます。
接続しているコントローラが機能をサポートしている場合のみ
表示されます。
(9)コントローラ
(C)
ソフトウェアリセット、エラーリセット等、コントローラに対する操作を行います。
(「12. コントローラメニュー補足」を参照してください。)
再接続
(C)
コントローラとの通信再接続を行います。
通信可能な状態であれば、
オフラインモードからオンラインモー
ドへ移行することができます。
ボーレート変更(B)
コントローラとパソコン間の通信ボーレートを変更します。
オフライン作業
(通信ポートクローズ)
(O)
メッセージマネージャ通信切替え
(N)
将来拡張用
29
SEL グローバル
データバックアップ
ファイルへ保存
グローバルフラグ、グローバル整数型変数、グローバル実数型変
数、グローバルストリングスを保存できます。
コントローラへ転送
グローバルフラグ、グローバル整数型変数、グローバル実数型変
数、グローバルストリングスをコントローラに転送できます。
全データバックアップ
(X)
・ファイルへ保存
(S)
コントローラ内のプログラム、
ポジションのすべてのデータを保
・コントローラへ転送・ファイルを分割
(L) 転送・ 分割データ選択画面で、コントローラに転
送とファイル分割を選択できます。
図 3.9
転送・分割データ選択画面
(注)プログラムモード時に収集したファイルは、ポジショナモード時のコントローラには、転送
できません。また、同様に、ポジショナモード時に収集したファイルは、プログラムモード
時のコントローラには、転送できません。
異なったファイルを転送しますと、下記のメッセージが表示されます。
図 3.10
30
メッセージ
・コントローラ転送
保存した全データバックアップ
(プログラム、 ポジションなどの
すべてのデータ)を選択してコントローラに転送します。
(□をクリックして、 選択します。選択されたデータには、レ点
が付きます。)
※パラメータを転送する場合は、コントローラに書き込まれている
パラメータと軸パターンが一致していなければ、
転送できません。
・ファイル分割
保存した全データバックアップ
(プログラム、 ポジションなどの
すべてのデータ)をプログラム、ポジション、パラメータ、シン
ボルのデータに分割します。
ファイル分割をクリックしますと、プログラム、ポジション、パ
ラメータ、シンボルの順番に保存ファイルネームを付けて保存
してください。
ポジショナモード
マニュアルモードで且つポジショナモード時、使用できるモー
ドです。
起動
ポジショナモードを起動します。
停止
ポジショナモードを停止します。
(注)ポジショナモード時、起動状態の場合は、パラメータの変更、フラッシュ ROM の書込み
などができません。
本操作で、停止を行ってからパラメータの変更、フラッシュ ROM の書込みなどを行って
ください。
ポジショナモード
ポジショナモードのメンテナンス用情報(システムデータ)を
情報取得
取得できます。
31
フラッシュ ROM
書込み(W)
フラッシュROMデータエリアを消去した後、コントローラRAM
上に保存されているデータをフラッシュ ROM に書込みます。
全データ領域の書込みと選択データ領域書込みの選択が行えます。
・全データ領域の書込み:プログラム、シンボル、ポジション、パラメータの全データをフラッシ
ュROMに書込みます。
・選択データ領域書込み:選択されたデータ
(レ点付き)
のみフラッシュ ROM に書込みます。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書
き込む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行って
ください。
図 3.11 確認
メモリ初期化(I)
・グローバル変数・フラグ(V)
グローバル変数・フラグをゼロクリアします。
・パラメータ
(工場出荷時)
(S) 工場出荷時のパラメータに戻すことができます。
通常は、表示されません。パスワードを入れ、使用できる機能です。
(8.4 パラメータ(工場出荷時)初期化方法を参照ください。)
32
ソフトウェアリセット(R)
コントローラのソフトウェアリセットを行います。
エラーリセット(E)
コントローラのエラーリセットを行います。
駆動源復旧要求(P)
コントローラに対し、駆動源復旧要求をします。
動作一時停止解除要求(L)
コントローラに対し、動作一時停止解除要求をします。
ROM バージョン情報(V)
コントローラの各種 ROM バージョン情報を表示します。
制御定数テーブル
管理情報(Z)
制御定数のテーブル管理情報を示します。
ポジショナモード
管理情報
ポジショナモードについて、運転モードと管理番号を表示します。
メーカー用の情報です。
(10)ツール(T)
本アプリケーションに関する設定を行います。
環境設定(S)
アプリケーション実行時の設定を行います。
(11)ウィンドウ(W)
ウィンドウの表示方法を変更します。
重ねて表示(C)
表示されているウィンドウを斜めに少しずつずらして重なるよう
に並べます。
上下に並べて表示(V)
表示されているウィンドウを垂直方向に分割して並べます。
左右に並べて表示(H)
表示されているウィンドウを水平方向に分割して並べます。
すべてを最小化(M)
表示されているウィンドウをすべて最小化(アイコン化)しま
す。
すべてをウィンドウ化
最小化(アイコン化)されているウィンドウをすべてウィンドウ
化します。
アイコンの整列(A)
最小化(アイコン化)されているウィンドウを整列します。
(12)ヘルプ(H)
バージョン情報(A)
本アプリケーションのバージョン情報を表示します。
33
3.3 ツールバー説明
メイン画面上部(メニューの下)に設置されているツールバー(図 3.12)について説明します。
図 3.12 ツールバー
34
ファイルを開く
ファイル(F)
→
開く(O)と同じです。
上書き保存
ファイル(F)
→
上書き保存(S)と同じです。
プログラム編集
プログラム(S) →
編集(E)と同じです。
ポジション編集
ポジション(O)→
編集(E)と同じです。
パラメータ編集
パラメータ(P) →
編集(E)と同じです。
シンボル編集
シンボル(Y)
→
編集(E)と同じです。
入力ポートモニタ
モニタ(M)
→
入力ポート(I)と同じです。
仮想入力ポートモニタ
モニタ(M)
→
仮想入力ポート(N)と同じです。
出力ポートモニタ
モニタ(M)
→
出力ポート(O)と同じです。
仮想出力ポートモニタ
モニタ(M)
→
仮想出力ポート(U)と同じです。
グローバルフラグモニタ
モニタ(M)
→
グローバルフラグ
(F)と同じです。
グローバル整数変数モニタ
モニタ(M)
→
グローバル整数(L)と同じです。
グローバル実数変数モニタ
モニタ(M)
→
グローバル実数(R)と同じです。
グローバルストリング変数モニタ
モニタ(M)
→
グローバルストリング(G)と同じです。
全動作終了
プログラム(S) →
全動作終了(T)と同じです。
マニュアルモード時の安全速度制限の有無を切替えます。
[セーフティ速度有効]
・・・安全速度制限あり(プログラムやパラメー
タの設定と関係なく、最高速度は、直交軸の場合は、250mm/sec 以下
となります。)
[セーフティ速度無効]・・・安全速度制限なし
マニュアルモード時、複数プログラムの同時起動の許可、禁止を切替え
ます。
[複数プログラム同時起動禁止(マニュアルモード時)]
マニュアルモード時、複数プログラムの同時起動を禁止します。
[複数プログラム同時起動許可(マニュアルモード時)]
マニュアルモード時、複数プログラムの同時起動を許可します。
プログラムモード時は表示されます。
35
3.4 ツリービュー
メイン画面左側のツリービュー(図3.13)に表示されているアイテムをマウスでダブルクリックするこ
とにより、オンラインモード時のデータ編集ウィンドウ表示操作を簡潔に行うことができます。
メニューの表示(V) → ツリー表示(T)で表示をON/OFFすることができます。
コントローラの型式を表示します。
コントローラに保存可能な残ステップ数表示
既登録のプログラム
( )内は登録ステップ数
[ ]内はプログラム名(シンボル登録時)
未登録のプログラム
ポジションデータ編集アイテム
ポジション編集ウィンドウを開きます。
パラメータ編集アイテム
ダブルクリックしたパラメータ種別の編集
ウィンドウを開きます。
シンボル編集アイテム
ダブルクリックしたシンボル種別の編集
ウィンドウを開きます。
図 3.13 ツリービュー
36
4.プログラム編集ウィンドウ
4.1 プログラム編集ウィンドウの項目説明
(1)メニューからプログラム(S)→編集(E)と選択します。
(2)プログラム No. 選択ウィンドウが表示されますので、編集するプログラムを選択し、読込み をクリッ
クします。
シンボル編集で付けたプログラム名
総ステップ数2000以下となります。
図 4.1 プログラム No. 選択
(3)プログラム編集ウィンドウが表示され、このウィンドウには次の項目があります。
No.
B
E
N
Cnd *
Cmnd
Operand 1 *
Operand 2 *
Pst *
Comment
ステップ No. を表示します。
ブレークポイントを設定します。(オンライン編集時のみ)
ブレークポイントを設定したい行の「B」列をマウスでクリックします。ブレークポイ
ントが設定された行は「B」が表示されます。
ブレークポイントはソフトリセットを行うとすべて解除されます。
拡張条件を入力します。
入力条件の反転「N」を指定します。
入力条件を入力します。
SEL 命令語を入力します。
マウスでダブルクリックするかファンクションキーの[F1]を押すと、SEL コマンド
説明ウィンドウ(図 4.5)を表示することができます。
SEL 命令語には各命令語に関する説明が記述されています。このウィンドウから命令
語を選択してステップデータに入力することもできます。
操作1(オペランド 1)を入力します。
操作2(オペランド 2)を入力します。
出力部(オペランド 3)を入力します。
必要に応じてコメントを入力します。(MAX 半角 18 文字)
ダブルクリックすることにより、
既に入力されているコメント文の1部分だけを入力し
直すこともできます。
* F11 を押すと、入力条件・オペランドに入力されているシンボルを検索することができます。
37
図 4.2 プログラム編集
1行でも変更があった場合は、全ステップ No. が赤字で表示されます。
各行の任意の入力項目をマウスで右クリックするとポップアップメニューが表示されます。(図 4.3)
これらの各項目について説明します。
切り取り(T)
コピー(C)
貼り付け(P)
メニュー 編集(E) → 切り取り
(T)と同じ操作を行います。
メニュー 編集(E) → コピー
(C)と同じ操作を行います。
カーソルのある行全体をコピーします。
メニュー 編集(E) → 貼り付け
(P)と同じ操作を行います。
コピー又は切り取りしたステップデータをカーソルのある行に挿入します。
1 行挿入(I)
カーソル行に1行挿入します。
選択行削除(D)
選択されている範囲を削除します。
1 行コメント化(S)
カーソル行全体をコメント化(無効ステップ)します。有効ステップをコ
メント化した場合、下記の1行コメント解除により、元の有効ステップに
戻すことができます。
また、任意の文字列を入力して行全体をコメント文とした場合は、1行コ
メント解除を行うとその行は全てクリアされます。
1 行コメント解除(R) 1行コメント化された行を元に戻します。
図 4.3 ポップアップメニュー
38
プログラム編集ウィンドウでは、メニューの「編集(E)」→「元に戻す(U)」を実施すると直近の 10 操
作まで、操作を元に戻せます。
または、[Ctrl]+[Z]キーを押すと操作を元に戻せます。
ただし、以下のいずれかの操作を行った時点で、元に戻せなくなります。
・ 編集画面上のデータをコントローラへ転送
・ 編集画面上のデータをファイルへ保存
・ 編集画面を閉じる。
本操作を行うと、図 4.4 の警告画面が表示されます。
はい をクリックすると、1つ前の操作に戻ります。
図 4.4 警告
Cmnd 欄をダブルクリックまたは F1 キーを押すと SEL コマンド説明ウインドが開きます。編集時の参
考としてお使いください。
図 4.5 SEL コマンド説明
[F2]キーを押すことによりセル内のデータを部分的に変更することが可能です。
(例:“MOVP”→“MOVL”)
39
SEL コマンド説明ウィンドウ内で右クリックするとポップアップメニューが表示されます。
ステップデータに入力(I)
フォント(F)
並べ替え(S)
カーソル行の命令語をステップデータに入力します。
(プログラム編集ウィンドウのカーソル行に)
SEL コマンド説明のフォント設定
・アルファベット順
・命令種別順に並べ替えて表示します。
図 4.6 ポップアップメニュー
40
(4)このウィンドウには次のボタンがあります。
図 4.7 ボタン
名前をつけてファイルに保存
本ボタンをクリックすると、プログラムを
ファイルに名前をつけて保存します。
コントローラへ転送
本ボタンをクリックすると、文法上のエ
ラーチェック後、エラーが無ければプログ
ラムデータをコントローラへ転送します。
プログラムチェック
本ボタンをクリックすると、作成したプロ
グラムの文法上のエラー内容、オペランド
に関する情報を表示します。
印刷
本ボタンをクリックすると、プログラムを
印刷します。
実行
本ボタンをクリックすると、プログラムを
実行します。
編集中のプログラムを実行させるには、先
にプログラムをコントローラへ転送を行う
必要があります。
注意: パソコンの通信速度より、コントローラ
の処理速度が速い為、プログラム編集画
面上のカーソル位置と実際のアクチュ
エータの動作は必ずしも一致はしません。
1ステップ実行
本ボタンをクリックするごとに、プログラ
ムを1ステップずつ実行します。
一時停止
本ボタンをクリックすると、実行中のプロ
グラムを一時停止します。
終了
本ボタンをクリックすると、実行中のプロ
グラムを終了します。
ローカルフラグ表示
本ボタンをクリックすると、実行中のプロ
グラムのローカルフラグウィンドウを表示
します。
ローカル整数変数表示
本ボタンをクリックすると、実行中のプロ
グラムのローカル整数変数ウィンドウを表
示します。
ローカル実数変数表示
本ボタンをクリックすると、実行中のプロ
グラムのローカル実数変数ウィンドウを表
示します。
ローカルストリング変数表示
本ボタンをクリックすると、実行中のプロ
グラムのローカルストリング変数ウィンド
ウを表示します。
41
(5)プログラムチェック
作成したプログラムに SEL 言語文法上の誤りがないかチェックします。
プログラム編集ウィンドウの プログラムチェックボタンをクリックします。
エラーがある場合には、エラーリストが表示されます。
図 4.8 エラーリスト
エラーリストには、ステップ No.・オペランド・メッセージがあり、ダブルクリックすると該当する
エラー位置へカーソルが移動します。
編集中プログラムのオペランド(Cnd,Operand1・2,Pst)に関する情報を表示します。
図 4.9 オペランド情報
42
文法エラー
「メッセージ」(エラー内容)
変数 No. 使用状況
「変数 No.」
「変数種別」(整数・実数の判別。)
「スコープ」(グローバル・ローカルの判別。)
※ 変数 No. が間接指定されている場合、変数種別およびスコープは「(不明)」となります。
入力・出力・フラグ No. 使用状況
「ポート・フラグ No.」
「データ種別」(入力ポート No.・出力ポート No.・フラグ No. の判別。
)
「スコープ」(グローバル・ローカルの判別。)
※ポート・フラグ No. が間接指定されている場合、データ種別およびスコープは「
(不明)
」となります。
プログラム No. 使用状況
「プログラム No.」
タグ No. 使用状況
「タグ No.」(使用されているタグ No.)
「宣言 / ジャンプ」
サブルーチン No. 使用状況
「サブルーチン No.」
「宣言 / コール」
ポジション No. 使用状況
「ポジション No.」
軸 No. 使用状況
「軸 No.」
※
∼
の各 No. にシンボルが使用されている場合、その定義値が欄外に表示されます。
これらの情報は、プログラム編集ウィンドウ下部にリストとして項目別に表示され、項目をマウスでダ
ブルクリックすることにより、該当位置へカーソルを移動することができます。
また、リストをマウスで右クリックするとポップアップメニューが表示され、リストの非表示、レコー
ドの並べ替えを行うことができます。
43
4.2 プログラム保存、及び編集終了について
(1)編集中のプログラムデータをファイルに保存
プログラム編集ウィンドウの名前をつけてファイル保存ボタンをクリックします。
ファイル(F)→名前を付けて保存(A)と同様の動作となります。
(2)編集中のプログラムデータをコントローラに転送
編集中のプログラムデータをコントローラのメモリに保存します。 プログラム編集ウィンドウのコントローラへ転送ボタンをクリックします。
オンライン編集時のみ使用可能です。
プログラムにエラーがある場合は、エラー内容表示をします。
注意
この場合には、コントローラへの転送は行われません。
44
(3)フラッシュ ROM 書込み
コントローラへの転送が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表
示されます。
図 4.10
確認
フラッシュ ROM へ書込む項目(プログラムなど)をクリックして、レ点を入れてください。
はい(Y)
をクリック→メモリデータをフラッシュ ROM へ書込みます。
いいえ(N)をクリック→メモリデータをフラッシュ ROM へ書込みません。
リセット(電源再立上げ・ソフトウェアリセット)によりメモリデータは破
棄され、データをフラッシュROMより読み込みます。
(リセットされるまで、
コントローラは転送されたメモリデータに従い動作します。)
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
(4)プログラム編集の終了
プログラム編集中のウィンドウを閉じると、
‘編集中のデータをコントローラへ保存しますか?’と確
認メッセージが表示されます。
図 4.11
確認
はい(Y)
編集データをコントローラへ転送します。→(3)フラッシュ ROM 書込みへ続きます。
いいえ(N) 編集データを破棄して終了します。
キャンセル 終了を中止してプログラム編集ウィンドウに戻ります。
45
4.3 プログラムのファイルへの一括保存について
(1)全プログラムの一括保存
コントローラ内の No.1 ∼ 64 のプログラムを1つのファイルとして保存できます。
メニューのプログラム→ファイルへ保存をクリックします。
プログラム No. を選択するウィンドウの 一括保存 のボタンを押し、ファイル名と保存場所を指定
し保存します。
総ステップ数2000以下となります。
図 4.12
プログラム保存
(2)一括プログラムファイルを開く
メニューのファイル→開くをクリックします。
“ファイルを開く”ウィンドウで開くファイルを選択し、“開く”を押します。
プログラム No. を選択するウィンドウが表示されます。読込むプログラム No. を選択し 読込み ボ
タンを押します。
一括してコントローラへ転送する場合は コントローラに 一括転送 ボタン、一括ファイルより個別
のプログラムを1つずつ転送する場合はプログラム No. を選択し、コントローラに転送 ボタンで
ファイルをコントローラへ転送します。
総ステップ数2000以下となります。
図 4.13
プログラム転送(オンライン)
一括印刷 ボタン:全プログラム(ステップ数が0のプログラムは除く)を一括して印刷します。
印刷 ボタン:ボタン左側のリストで選択したプログラムのみを印刷します。
46
(3)一括プログラムファイルをコントローラへ転送する際の要注意事項
一括プログラムファイルを一括してコントローラへ転送する際は、既存の No.1 ∼ 64 のプログラム
は全てクリアされます。必要であれば、転送前に現在の全プログラムのバックアップをとっておき
ます。
一括プログラムファイル中にシンボルを使用したプログラムが含まれる場合、プログラム転送時に
その使用シンボルデータがコントローラのメモリ内に定義されていないとエラーとなります。この
場合、プログラムファイルはコントローラへは転送されないので、使用シンボルデータがファイル
として保存されている時は、先にそれを転送します。保存されていない場合は、シンボル編集画面
にて定義し、それをコントローラへ転送します。
その後、再度、プログラムファイルを転送します。
一括プログラムファイルにエラー箇所が含まれる場合は、エラー表示画面が表示され、コントロー
ラへの転送は行われません。この場合、エラー表示画面のエラー表示をダブルクリックしてエラー
を含むプログラムファイルの画面を開き、該当するエラーを修正した後、上書き保存を行います。
全てのエラーを修正後、再度、コントローラへの転送を行います。
はエラー箇所を含むプログラムファイルのリカバリーの方法として重要です。
(4)一括プログラムファイルの保存について
一括プログラムファイルから読込んだプログラムファイルを、一括プログラムファイルとして保存
する場合には、上書き保存(S)をクリックします。
個別のプログラムファイルとして保存する場合には、名前をつけて保存(A)をクリックします。
47
4.4 プログラム実行
プログラム編集ウィンドウより、プログラムを実行させることができます。
編集中のプログラムを実行させるには、プログラムをコントローラへ転送します。
注)コントローラへ転送後、フラッシュROM書込みを行わなくてもプログラムを実行させることができますが、電
源再立上・ソフトウェアリセットで消滅します。
実 行:
本ボタンをクリックすると、プログラムを実行します。
f 1 ステップ実行:本ボタンをクリックするごとに、プログラムを 1 ステップずつ実行します。
g 一時停止:
本ボタンをクリックすると、実行中のプログラムを一時停止します。
実行、1 ステップ実行ボタンで再開します。
h 終 了:
本ボタンをクリックすると、実行中のプログラムを終了します。
ブレークポイント:任意のステップで、一時停止させることができます。クリックする毎に、
‘B’が
表示 / 非表示を繰り返します。
注)ブレークポイントは電源再立上、ソフトウェアリセットでクリアされます。
e
e f g h
図 4.14
カーソル色
プログラム実行
緑:実行停止指示中
(ステップ運転による停止、
ブレークポイントによる停止、
一時停止ボタンによる停止、SSPG 命令による停止等)
赤:WAIT 部処理中
(TIMW,WTxx,WZxx,WRIT,READ, サーボ命令完了待ち等)
青:上記、緑・赤以外の状態
48
背景色
グレー:プログラム実行中
白:プログラム非実行中
5.プログラムのコピー・移動・削除
5.1 プログラムのコピー / 移動ウィンドウ
プログラムを他のプログラム No. にコピーまたは移動させる操作方法です。
(1)メニューからプログラム
(S)→コピー / 移動(C)と選択します。
(2)プログラムのコピー / 移動ウィンドウが表示されます。
コピー / 移動元 No.
コピー / 移動先 No.
総ステップ数2000以下となります。
図 5.1 プログラムのコピー / 移動
コピー元または移動元のプログラムをダブルクリックします。
次にコピー先または移動先のプログラムをクリックします。
コピーする場合にはコピーボタンを、移動する場合には移動ボタンをクリックしてください。
メモリ上での作業です。
キャンセル ボタンをクリックすると作業を中止します。
(3)フラッシュ ROM 書込み
コピーまたは移動が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表示さ
れます。
49
図 5.2 確認
フラッシュ ROM へ書込む項目(プログラムなど)をクリックして、レ点を入れてください。
・はい(Y) をクリック→メモリデータをフラッシュ ROM へ書込みます。
・いいえ(N)をクリック→メモリデータをフラッシュ ROM へ書込みません。
リセット(電源再立上げ・ソフトウェアリセット)によりコピーまたは移
動前の状態にもどります。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
50
5.2 プログラムのクリアウィンドウ
プログラムを削除する操作方法です。
(1) メニューからプログラム(S)→クリア(L)と選択します。
(2)プログラムクリアウィンドウが表示されます。
総ステップ数2000以下となります。
図 5.3 プログラム削除 削除するプログラムをクリックします。
マウスドラッグ又は「Ctrl」+「↑」「↓」キーで複数プログラムを選択可能です。
次にクリアボタンをクリックします。
(コントローラのメモリ上での作業です。) キャンセルボタンをクリックすると作業を中止します。
コントローラ内の全プログラムをクリアする場合には、オールクリアボタンをクリックします。
(3)フラッシュ ROM 書込み
削除が終了しますと、‘フラッシュ ROM へ書込みますか?’と確認メッセージが表示されます。
51
図 5.4 確認
フラッシュ ROM へ書込む項目(プログラムなど)をクリックして、レ点を入れてください。
・はい(Y) をクリック→メモリデータをフラッシュ ROM へ書込みます。
・いいえ
(N)をクリック→メモリデータをフラッシュ ROM へ書込みません。
リセット(電源再立上げ・ソフトウェアリセット)により削除前の状態に
もどります。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
52
6.ポジションデータ編集ウィンドウ
6.1 ポジションデータ編集ウィンドウの項目説明
(1)メニューからポジション
(O)→編集(E)と選択します。
(2)ポジションデータ編集ウィンドウが表示され、このウィンドウには次の項目があります。
共通ボタン
ポジションデータ
設定機能
(直交軸)
軸別ボタン表示(直交軸)
変更行のデータを赤字で表示します。
図 6.1 ポジションデータ編集(プログラムモード時)
53
ポジションデータ
図 6.2 ポジションデータ
No.(Name)
ポジション No. とポジション No. のシンボルを表示します。
F11 キーにより、シンボル編集ウィンドウを呼び出して、該当ポジション No. のシンボルを編
集することができます。また、シンボル編集ウィンドウ上で、F11 キーを押すことにより、該当
ポジションデータ編集位置に入力フォーカスを戻すことができます。
※ F11 キーでシンボル編集ウィンドウからポジションデータ編集ウィンドウへ入力フォーカス
を戻すことができるのは、ポジションデータ編集ウィンドウを開いている場合に限ります。
※シンボルの表示 / 非表示は、ツール環境設定ウィンドウにて切替えが可能です。
(切替え方法は「13.ツール」を参照してください。
)
ポジショナモード時は、ポジションデータのNo.にシンボルが表示されません。
図 6.3 ポジションデータ編集 (ポジショナモード)
54
Axis1
軸の位置を指定します。
設定範囲は− 99999.999 ∼ 99999.999 です。
Vel
速度を指定します。
設定範囲は1∼軸共通パラメータNo.21「運転速度MAX」です。
Acc
加速度指定します。
設定範囲は 0.01 ∼軸共通パラメータNo.22「加速度MAX」です。
Dcl
減速度を指定します。
設定範囲は 0.01 ∼軸共通パラメータNo.23「減速度MAX」です。
ポジション編集ウィンドウでは、メニューの「編集(E)」→「元に戻す(U)」を実施すると、行挿入、
行削除を除き、直近の 10 操作まで、操作を元に戻せます。
または、[Ctrl]+[Z]キーを押すと操作を元に戻せます。
ただし、以下のいずれかの操作を行った時点で、元に戻せなくなります。
・ 編集画面上のデータをコントローラへ転送
・ 編集画面上のデータをファイルへ保存
・ 編集画面を閉じる。
本操作を行うと、図 6.4の警告画面が表示されます。
はい をクリックすると、1つ前の操作に戻ります。
図 6.4
警告
55
共通ボタン
図 6.5 共通ボタン
名前をつけてファイルに保存
本ボタンをクリックすると、ポジションを名前をつけてファイルに保存します。
コントローラへ転送
本ボタンをクリックすると、ポジションをコントローラに転送します。
ポジションデータ更新
ポジションデータを書替える様なプログラムを実行した場合に、ポジションデータの表示を更
新します。
印刷
本ボタンをクリックすると、ポジションを印刷します。
ゝ
現在位置取り込み
本ボタンをクリックすると、
が表示されている時はカーソル位置のポジションNo.に現在
位置を読み込みます。(コントローラに転送はされていません。)
−方向ジョグ
サーボ ON 状態であれば、本ボタンを押している間、−方向にジョグ移動します。
+方向ジョグ
サーボ ON 状態であれば、本ボタンを押している間、+方向にジョグ移動します。
ゝ
移動
本ボタンをクリックすると
が表示されている時はカーソル位置のポジションNo.の位置に
移動します。
*変更したポジションデータがある場合は、先にコントローラへ転送してください。
56
ゝ
連続移動
本ボタンをクリックすると
が表示されている時はカーソル位置のポジションNo.の位置に
移動します。その後連続して次のポジションNo.の位置に移動を続けます。その後連続して次
のポジションNo.の位置に移動を続けます。
*変更したポジションデータがある時は、先にコントローラへ転送してください。
軸移動キャンセル
本ボタンをクリックすると、移動中の軸は停止します。
本ボタンの□に、レ点が設定されている場合は、軸別ボタン/設定を
行う画面(図 6.1)が表示されます。
設定されていない場合は、ポジションデータのみの表示となります。
図6.6
ポジションデータのみの画面
注)SA-D-C1Sは1軸用のコントローラです。
57
軸動作ボタン
軸番号
本ボタンの□にレ点
が設定されている場
合に動作します。
軸の現在の位置表示
エラーコード表示
図 6.7
軸別ボタン
本ボタンをクリックすると、軸がサーボONしていればサーボOFF、 サーボOFFしていればサ
ーボONします。
(サーボオン時、ボタンは水色となります。
)
本ボタンをクリックすると、軸がサーボONしていれば原点復帰を行います。
(原点復帰後は、ボタンは青色となります。
)
本ボタンをクリックすると、軸がサーボONしていればカーソル位置のポジションNo.のデータ
値に移動します。(移動中、ボタンは黄色となります。)
本ボタンを押している間、軸がサーボONしていればジョグ 前進移動 をします。
設定機能 Inc. 欄に数値(0.001 ~1)が入力されている場合にはインチング動作となります。
1クリックで1インチング距離移動します。
本ボタンを押している間、軸がサーボONしていればジョグ 後進移動 をします。
設定機能 Inc. 欄に数値(0.001 ~1)が入力されている場合にはインチング動作となります。
1クリックで1インチング距離移動します。
本ボタンをクリックすると、軸の現在値をカーソル位置のポジションNo.に取り込みます。
(コントローラに転送はされていません。
)
58
注)SA-D-C1Sは1軸用コントローラです。
設定機能
各種ボタンでアクチュエータを動作させる時のVel(速度)、Acc(加速度)、
Dcl(減速度)、Inc.(インチング距離)を設定します。
ポジションデータの Vel Acc または Dcl に数値が入力されている場合、そ
のポジション No. への移動はポジションデータの数値が優先されます。
図 6.8 速度、加速度、減速度、
インチング距離設定
図 6.9 ジョグボタン
これらのジョグボタンによるジョグ動作は原点復帰未完了軸に対しても有効ですが、この時の座標値は
意味を持ちませんので、ストロークエンドとの干渉には充分注意してください。
また、ジョグボタンは設定機能 Inc. 欄に数値(0.001 ∼1)が入力されている場合にはインチング用ボ
タンとなります。
インチング用ボタンを押しつづけるとジョグ動作に変わります。インチング用ボタンを押してから約1.6
秒後にジョグ動作に変わり、さらに押しつづけると、ジョグ速度が約1秒毎に
1→ 10 → 30 → 50 → 100[mm/sec]と変化します。
注意事項
動作中の軸に対して、操作ボタン受付可能状態中、ジョグ操作を行うとジョグ操作ボタンOFF時
に、軸の動作は打ち切られます。(次動作があれば、次動作に移ります。)
59
6.2 ポジション保存、及び編集終了について
(1)編集中のポジションデータをファイルに保存
ポジション編集ウィンドウの名前をつけてファイルに保存ボタンをクリックします。
ファイル(F)→名前を付けて保存(A)と同様の動作となります。
(2)編集中のポジションをコントローラへ転送
ポジション編集ウィンドウのコントローラへ転送ボタンをクリックします。
編集中のポジションデータをコントローラのメモリに保存します。
オンライン編集時のみ使用可能です。
60
(3)フラッシュ ROM 書込み
コントローラへの転送が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表
示されます。
図 6.10
確認
フラッシュ ROM へ書込む項目(ポジションなど)をクリックして、レ点を入れてください。
はい(Y) をクリック→ メモリデータをフラッシュ ROM へ書込みます。
いいえ(N)をクリック→ メモリデータをフラッシュ ROM へ書込みません。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
61
(4)ポイント編集の終了
ポイント編集ウィンドウを閉じると、
‘編集中のデータをコントローラへ保存しますか?’と確認メッ
セージが表示されます。
図 6.11
確認
はい
(Y) 編集データをコントローラへ転送します。→(3)フラッシュ ROM 書込みへ続きます。
いいえ
(N) 編集データを破棄して終了します。
キャンセル 終了を中止してポジション編集ウィンドウに戻ります。
62
7.ポジションデータのコピー・移動・削除
7.1 ポジションデータのコピー / 移動
(1)メニューからポジション(O)
→コピー / 移動(C)と選択します。
(2)ポジションデータ コピー / 移動ウィンドウが表示されます。
コピーする場合には: コピー / 移動元の先頭 No. と最終 No. を指定し、コピー / 移動先の先頭 No. を指定
します。
コピー のボタンをクリックします。
コピー/移動元で指定されたポジションをコピー/移動先で指定された場
所にコピーします。
移動する場合には: 移動 のボタンをクリックしてください。
コピー/移動元で指定されたポジションをコピー/移動先で指定された場所に移
動します。
総ポジション数1500以下の指定となります。
図 7.1 ポジションデータコピー / 移動
※ キャンセル ボタンをクリックすると作業を中止終了します。
(3)フラッシュ ROM 書込み
コピーまたは移動が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表示さ
れます。
63
図 7.2 確認
フラッシュ ROM へ書込む項目(ポジションなど)をクリックして、レ点を入れてください。
・はい(Y) をクリック→メモリデータをフラッシュ ROM へ書込みます。
・いいえ(N)をクリック→メモリデータをフラッシュ ROM へ書込みません。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
64
7.2 ポジションデータの削除
(1)メニューからポジション(O)→クリア(L)と選択します。
(2)ポジションデータ クリアウィンドが表示されます。
図 7.3 ポジションデータクリア
削除するポジションデータの先頭 No. と最終 No. を入力します。
クリア のボタンをクリックします。
キャンセル ボタンをクリックすると作業を中止終了します。
(3)フラッシュ ROM 書込み
削除が終了しますと、‘フラッシュ ROM へ書込みますか?’と確認メッセージが表示されます。
図 7.4 確認
フラッシュ ROM へ書込む項目(ポジションなど)をクリックして、レ点を入れてください。
・はい(Y) をクリック→メモリデータをフラッシュ ROM へ書込みます。
・いいえ(N)をクリック→メモリデータをフラッシュ ROM へ書込みません。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
65
8.パラメータ編集ウィンドウ
8.1 パラメータ編集ウィンドウの説明
(1)メニューからパラメータ(P)→編集(E)と選択します。
(2)パラメータ編集ウィンドウが表示されます。
適切なパラメータを選択し、その値を変更します。
なお、半透明になっている数値は参照のみの値なので変更することはできません。
名前をつけてファイルに保存
本ボタンをクリックするとパラメータデータに名前をつけてファイルに保存します。
コントローラへ転送
本ボタンをクリックするとパラメータデータをコントローラに転送します。
印刷
本ボタンをクリックすると、パラメータデータを印刷します。
図 8.1 パラメータ編集
※ 上記は、I/O パラメータが表示されていますが、項目をクリックするごとに、他のパラメー タを表示
します。
注意:ポジショナモード時、起動状態の場合は、パラメータの転送ができません。
停止を行ってからパラメータの変更、転送を行ってください。
停止は、メニューの「コントローラ」→「ポジショナモード」→「停止」をクリックすると実行さ
れます。
66
パラメータ編集ウィンドウでは、メニューの「編集(E)」→「元に戻す(U)」を実施すると、入力操作が、
直近の 10 操作まで元に戻せます。
または、[Ctrl]+[Z]キーを押すと操作を元に戻せます。
ただし、以下のいずれかの操作を行った時点で、元に戻せなくなります。
・ 編集画面上のデータをコントローラへ転送
・ 編集画面上のデータをファイルへ保存
・ 編集画面を閉じる。
本操作を行うと、図 8.2 の警告画面が表示されます。
はい をクリックすると、1つ前の操作に戻ります。
図 8.2 警告
67
8.2 パラメータの保存及び編集終了について
(1)編集中のパラメータデータをファイルに保存
パラメータ編集ウィンドの名前を付けてファイルに保存ボタンをクリックします。
ファイル(F)→名前を付けて保存(A)と同様の動作となります。
(2)編集中のパラメータデータをコントローラへ転送
編集中のパラメータデータをコントローラのメモリに保存します。
パラメータ編集ウィンドのコントローラへ転送ボタンをクリックします。
(3)フラッシュ ROM 書込み
コントローラへの転送が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表
示されます。
図 8.3 確認
フラッシュ ROM へ書込む項目(パラメータなど)をクリックして、レ点を入れてください。
はい(Y) をクリック→ メモリデータをフラッシュ ROM へ書込みます。
いいえ(N) をクリック→ メモリデータをフラッシュ ROM へ書込みません。
リセット
(電源再立上げ・ソフトウェアセット)によりメモリデータは破棄
され、データをフラッシュ ROM より読み込みます。
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
68
(4)コントローラ再起動(ソフトウェアリセット)
フラッシュ ROM 書込み後、
‘コントローラを再起動しますか?’と確認メッセージが表示されます。
はい(Y) 変更したパラメータを有効にします。
いいえ(N) 変更したパラメータを有効にしません。
変更したパラメータはコントローラ再起動(ソフトウェアリセット)または電源再投入
により有効になります。
図 8.7 確認
(5)パラメータ編集の終了
パラメータ編集ウィンドを閉じると、‘編集中のデータをコントローラへ保存しますか?’
と確認メッセージが表示されます。
図 8.8 確認
はい
(Y) 編集データをコントローラへ転送します。→ (3)フラッシュ ROM 書込みへ続きます。
いいえ(N) 編集データを破棄して終了します。
キャンセル 終了を中止してパラメータ編集ウィンドに戻ります。
・ パソコンソフトを購入されたお客様は、納入時、及び、組み込みシステム立ち上げ時パラメータをバッ
クアップする事をお勧めします。
※パラメータによるカスタマイズ項目が多い為、プログラムと同様の感覚でバックアップする事を
お勧めします。
69
8.3 パラメータファイルの転送について
ファイル化されているパラメータデータをコントローラへ転送する場合、パラメータ種別に注意してください。
出荷時、軸関連パラメータは、接続されるロボットの品種に合わせた値が設定されています。
軸関連パラメータは、軸別・ドライバカード・エンコーダの3種類です。
以前にカスタマイズされたパラメータファイルを流用される場合は充分注意してください。
注意:パラメータのフラッシュ ROM 書込み中、主電源 OFF などにより、パラメータデータが失われ
た場合は、全パラメータが初期値に書替えられます。
8.3.1 転送パラメータ種別選択
(1) ファイル ― 開く または ボタンを押して、転送対象のパラメータファイルを選択し、パソコン
ソフトに読み込み、パラメータ編集ウィンドウを開きます。
(2)パラメータ編集ウィンドウのコントローラへ転送ボタンをクリックします。
(3)転送パラメータ種別選択ウィンドウ(図 8.9)が表示されます。
70
図8.9
転送パラメータ種別選択ウィンドウ
① 転送パラメータリスト
以下の②~⑤の選択によりコントローラに転送されるパラメータが表示されます。
OK ボタンを押す前に、必ず転送するパラメータ種別を確認してください。
② 基本設定
□をクリックし、転送するパラメータ種別を選択します。(□にチェックが入ります)
選択されたパラメータ種別だけコントローラへ転送されます。
③ 詳細設定 - ロボット各軸関連 / 関連以外パラメータ転送選択
基本設定で選択されたパラメータのうち、ロボット各軸関連パラメータのみ転送するか、ロボット各
軸関連以外パラメータのみ転送するか、選択した全パラメータ転送するかを選択します。
以下の場合は、パラメータは転送されず、‘パラメータは転送されません’と警告メッセージが表示さ
れます。
・基本設定 でロボット各軸関連パラメータ(軸別・ドライバカード・エンコーダ)が1つも選択されてい
ない状態で、 詳細設定 - ロボット各軸関連/関連以外パラメータ転送選択 で「~ロボット各軸関
連パラメータのみ転送する」を選択している場合。
・基本設定 でロボット各軸関連パラメータ以外が1つも選択されていない状態で、
詳細設定 - ロボット各軸関連/関連以外パラメータ転送選択 で「~ロボット各軸関連パラメータ以
外のみ転送する」を選択している場合。
注)SA-D-C1Sは1軸用コントローラです。
71
8.3.2
デフォルト指定
パラメータ転送機能の詳細設定のうち、 詳細設定 - ロボット各軸関連/関連以外パラメータ転送選択
については、メニューからツール -> 環境設定より、デフォルト状態を設定することができます。
図 8.10
72
環境設定
注)SA-D-C1Sは1軸用コントローラです。
8.4 パラメータ(工場出荷時)初期化方法
(1)ツールバーの空白部(図 8.11 参照)を Ctrl ボタンを押しながらクリックすると、図 8.12 のようなパ
スワード入力画面が表示されます。
図 8.11 メニューバー
ツールバーの空白部を
Ctrl を押しながら右クリック。
図 8.12 パスワード入力画面
(2)表示されたパスワード入力画面にパスワード(5119)を入力すると、メモリ初期化メニューに「パラ
メータ(工場出荷値)」メニューが表示されます(図 8.13)。
※ 1 度入力したパスワードは、アプリケーション終了まで有効です。
図8.13 メニューバー(パラメータ初期化)
73
(3)
(2)で表示されたメニュー「パラメータ(工場出荷値)」を選択すると、図 8.14 のダイアログが表示
されますので、問題なければ「はい」をクリックしてください。
図 8.14 警告ダイアログ
(4)書替え完了後、パラメータをフラッシュ ROM に書込んでください。
注意:エンコーダパラメータは初期化されません。そのため、出荷時と異なるアクチュエータを
接続していた場合、予期せぬエラーを検出することがあります。
74
9.シンボル編集ウィンドウ
9.1 シンボルについて
変数No.フラグNo.等の数値をシンボルとして扱うことがでます。
(1) サポート範囲 シンボル化をサポートしている範囲は下記の通りです。
変数 No. フラグ No. タグ No. サブルーチン No. プログラム No. ポジション No. 入力ポート No. 出力ポート No . 軸 No. 定数
(2)シンボル記述規約
先頭文字:半角アルファベットまたは半角アンダースコア。
2文字目以降:アスキーコード 0x21 ∼ 0x7e のうち、キーボード入力可能な文字。
最大文字数:半角9文字。(注意:文字列リテラルは最大半角8文字。)
同一機能内での同一名シンボルは定義禁止。(プログラム異なるローカル同士は許可)
フラグ No./ 入力ポート No./ 出力ポート No. グループに同一名シンボルは定義禁止。
(プログラム異なるローカル同士は許可)
整数変数 No./ 実数変数 No. グループに同一名シンボルは定義禁止。
(プログラム異なるローカル同士は許可)
整数定数 / 実数定数グループに同一名シンボルは定義禁止。
(3) 定義数:MAX500
(4) コマンド内シンボル使用回数:文字列リテラルと合わせて MAX2000 回
※入力条件・操作1操作2・出力部全てをシンボル記述すると、1ステップで使用回数4となります。
75
9.2 シンボル編集ウィンドウの説明
(1)メニューからシンボル(Y)→編集(E)と選択します。
(2)シンボル編集画面が表示されます。
名前をつけてファイルに保存
本ボタンをクリックするとシンボルデータに名前をつけてファイルに保存します。
コントローラへ転送
本ボタンをクリックするとシンボルデータをコントローラに転送します。
印刷
本ボタンをクリックすると、シンボルデータを印刷します。
グローバル領域とローカル領域の選択を行います。 ローカル領域を選択した場合にはプログラムNo.を指定します。
図 9.1 シンボル編集
※上図は整数変数のシンボル編集画面ですが、項目をクリックするごとに他のシンボル編集画面を表示します。
(3) シンボル編集ウィンドウ内で右クリックすると、ポップアップメニューが表示され、切り取り
(T)/ コピー(C)/ 貼り付け(P)ができます。
切り取り(T)/ コピー(C)したデータはシンボル編集ウィンドウ内でのみ、貼り付け(P)
可能です。
(プログラム編集ウィンドウ、ポジションデータ編集ウィンドウ等、他の編集
ウィンドウへのペーストはできません。)
76
(4)シンボル編集ウィンドウ / プログラム編集ウィンドウ間では、シンボル文字列をドラッグ & ドロップ
することができます。
シンボル編集ウィンドウ上でシンボル文字列を[Ctrl]キーを押しながらドラッグし、プログラム編集
ウィンドウ上の「Cnd」/「Operand1」/「Operand2」/「Pst」の何れかのセルにドロップすることに
より、シンボル文字列をコピーすることができます。
また、その逆の操作(プログラム編集ウィンドウからシンボル編集ウィンドウへのドラッグ &
ドロップ)も可能です。
図 9.2 シンボル編集ウィンドウ
図 9.3 プログラム編集ウィンドウ
シンボル編集ウィンドウでは、メニューの「編集(E)」→「元に戻す(U)」を実施すると、入力操作
が、直近の 10 操作まで元に戻せます。
または、[Ctrl]+[Z]キーを押すと操作を元に戻せます。
ただし、以下のいずれかの操作を行った時点で、元に戻せなくなります。
・ 編集画面上のデータをコントローラへ転送
・ 編集画面上のデータをファイルへ保存
・ 編集画面を閉じる。
本操作を行うと、図 9.4 の警告画面が表示されます。
はい をクリックすると、1つ前の操作に戻ります。
図 9.4 警告
77
9.3 シンボルの保存及び編集終了について
(1)編集中のシンボルデータをファイルに保存
シンボル編集ウィンドの名前を付けてファイルに保存ボタンをクリックします。
ファイル(F)→ 名前を付けて保存(A)と同様の動作となります。
(2)編集中のシンボルデータをコントローラへ転送
編集中のシンボルデータをコントローラのメモリに保存します。
シンボル編集ウィンドウのコントローラへ転送ボタンをクリックします。
オンライン編集時のみ使用可能です。
78
(3)フラッシュ ROM 書込み
コントローラへの転送が終了しますと、
‘フラッシュ ROM へ書込みますか?’と確認メッセージが表
示されます。
図 9.5
確認
フラッシュ ROM に書込む項目(シンボルなど)をクリックして、レ点を入れてください。
はい(Y) をクリック→ メモリデータをフラッシュ ROM へ書込みます。
いいえ(N)をクリック→ メモリデータをフラッシュ ROM へ書込みません。
リセット(電源再立上げ・ソフトウェアセット)によりメモリデータは破棄
され、データをフラッシュROMより読み込みます。
(リセットされるまで、
コントローラは転送されたメモリデータに従い動作します。)
※フラッシュ ROM の書込み回数には制限があります。
(書込み回数、約 10 万回)全データを書き込
む以外は、
「選択データ領域を書き込む」を選択し、フラッシュ ROM の書込みを行ってください。
79
(4)シンボル編集の終了
シンボル編集ウィンドウを閉じると、
‘編集中のデータをコントローラへ保存しますか?’と確認メッ
セージが表示されます。
図 9.6
確認
はい(Y) 編集データをコントローラへ転送します。
いいえ(N) 編集データを破棄して終了します。
キャンセル 終了を中止してシンボル編集ウィンドウに戻ります。
80
10. モニタ
メニューのモニタより各種の現在のステータスを見ることが出来ます。
(1) タスクステータスモニタウィンドウ 実行されているプログラムの状態を表示します。
図 10.1 タスクステータス
No.:プログラム No.
Name:シンボル
Sts:タスク状態
内部 OS 管理上のタスク状態
・RDY (Ready)
:実行可能状態
・DMY (Dormant) :休止状態
・SUS (Suspend) :待ち状態
L:タスクレベル
Exec:実行中ステップ No.
T:実行停止指示中(ステップ運転による停止、ブレークポイントによる停止、一時停止ボタンによる停止、
SSPG 命令による停止等。)
W:WAIT 部処理中(TIMW,WTxx,WZxx,WRIT,READ, サーボ命令完了待ち等)
H:HOLD 入力
C:CANC 入力
Err:エラー No.
Prg. ∼:エラー詳細情報
(2)システムステータスモニタウィンドウ
現在の動作モードが表示されます。
(「MANUAL」、「AUTO」)
現在発生しているエラーの中で、最もレベルの
重いものが表示されます。
現在発生しているエラーの中で、最も新しいも
のが表示されます。
各種ステータスが表示されます。
図 10.2 システムステータス
81
ステータス3で、「運転モード」を確認できます。
図 10.3
図 10.4
プログラムモード時の表示
(3) 軸ステータスモニタウィンドウ
各軸の状態を表示します。
図 10.5
82
軸ステータス
注)SA-D-C1Sは1軸用コントローラです。
ポジショナモード時の表示
(4)入力ポートウィンドウ 仮想入力ポートウィンドウ 出力ポートウィンドウ 仮想出力ポートウィンドウ
各入出力のON/OFF 状態を表示します。 1:ON 0:OFF
図 10.6 入出力ポート
出力ポート・仮想出力ポートはダブルクリック又は「Ctrl」+「スペース」キーを押すことにより
1/0(ON/OFF)を切替えることができます。
ポジショナモード時は、シンボルなしの表示となります。
図 10.7 入出力ポート(シンボル表示なし)
83
入力ポートウィンドでは入力ポートデバッグフィルタが設定できます。
入力ポートデバッグフィルタとは、物理入力ポートの実入力状態に関係なく、任意の物理入力ポートをON
状態 /OFF 状態として認識させる機能です。
デバッグフィルタの設定は、入力ポートウィンドウのデバッグフィルタ設定パネル上に配置された以下の
4 つのボタンにより行います。(MANUAL モード時)
①[ON]ボタン
カーソル位置の入力ポートに ON フィルタを設定します。
設定されたポートは ON 状態として認識します。
②[OFF]ボタン
カーソル位置の入力ポートに OFF フィルタを設定します。
設定されたポートは OFF 状態として認識します。
③[CLR]ボタン
カーソル位置の入力ポートに設定されたデバッグフィルタを解除します。
④[ACLR]ボタン
全物理入力ポートのデバッグフィルタを一括解除します。
※ デバッグフィルタ有効期間中、ONフィルタまたはOFFフィルタが設定されているポートの状態(「0」、
「1」)は赤字で表示されます。(その他のポートは黒字で表示されます。)
デバックフィルタ設定パネル
ボタンは左から順に、
① ON フィルタ設定
② OFF フィルタ設定
③フィルタ解除
④全ポートフィルタ解除
OFF フィルタ設定済みポート
ON フィルタ設定済みポート
ポート No. 選択カーソル
(本図ではポート No.53 を
選択中)
図 10.8 入力ポートウィンドウ
[CLR]および[ACLR]ボタンクリック時、図 10.9の警告メッセー が表示されます。
メッセージの内容を十分確認した上で、「はい(Y)」(フィルタ解除実行)または「いいえ(N)」
(キャンセル)を選択してください。
84
図 10.9 警告メッセージ
注意事項
デバッグフィルタ解除、コントローラ動作モード(MANUAL、AUTO)切替えの瞬間にコント
ローラが認識する入力ポートの状態(ON/OFF)が変化します。
(1) フィルタ解除時
実入力状態
フィルタ種別
ON
OFF
ON
OFF
ON→OFF
OFF→ON
(2)MANUALモード → AUTOモード切替え時
実入力状態
フィルタ種別
ON
OFF
ON
OFF
ON→OFF
OFF→ON
(3) (MANUALモード→)AUTOモード → MANUALモード切替え時
実入力状態
フィルタ種別
ON
OFF
ON
OFF
OFF→ON
ON→OFF
※モード(MANUAL、 AUTO)の切替えではデバッグフィルタの設定は
クリアされません。AUTO → MANUAL 切替えにより、既設定のデバッ
グフィルタが再度有効となります。
入力ポートに割り当てられた機能がある場合は、その処理が実行されます。動作開始等、
十分に注意してください。
・ プログラム起動、軸原点復帰等、入力ポートに割り当てられた機能。
・ 入力条件による分岐を行っている SEL プログラム。
・ 入力ポートの状態を監視する命令を使用している SEL プログラム。
(WTON,WTOF,IN,INB,HOLD,CANC,JBWF,JBWN,JFWF,JFWN 等)
・ その他、入力ポートの状態を監視して実行される処理。
85
(5)グローバルフラグウィンドウ グローバル整数型変数ウィンドウ グローバル実数型変数ウィンドウ
グローバルストリンクウィンドウ
図 10.10 グローバル
グローバル変数の値を変更・代入することができます。
グローバルストリングの文字を変更・代入することができます。
グローバルフラグはダブルクリック又は「Ctrl」+「スペース」キーを押すことにより 1/0(ON/OFF)
を切替えることができます。
整数変数モニタでは、データ基数を 10 進数または 16 進数を選択できます。
(ウィンドウ上部のコンボボックスで選択します。)
図 10.11 10 進数表示
86
図 10.12 16 進数表示
(6) エラー詳細情報
メインメニューの「モニタ(M)」→「エラー詳細情報(E)」を選択しますと、エラーリスト表示
数設定画面が表示されます。
エラーリスト表示数の設定後、
「OK」をクリックしますと、エラー詳細情報画面が表示されます。
図 10.13
エラーリスト表示数設定画面
エラーが発生した場合にエラーコード、メッセージ等を表示します。
エラーリストをファイル化します。(CSV 形式)※
エラーリストを印刷します。
最新のエラーリストに更新します。
エラーリストをクリアします。
プログラムNo.
軸 No.
ステップ No.
ポジションNo.
Info. 1~ 4 は弊
社にてエラー原
因を解析する為
の情報です。
(内容はエラー
No. により異な
ります。
)
コントローラ電源投入後又はソフトウェアリセット後の時間
エラーメッセージ
エラーコード
数字が小さいほど、最新のエラーです。
図 10.14
エラー詳細情報
注)SA-D-C1Sは1軸用コントローラです。
87
システムメモリバックアップバッテリが装着されている場合はアラームリストの内容は、電源OFFしても
消去されません。消去する場合は、アラームリストクリア キーを押します。図 11.16 の警告が表示され、
「はい」を押すとアラームリストの内容が消去されます。
図 10.15 確認
※トラブル発生時、早期解決の為にファイル化したエラーリストを送付していただく場合があります。
本パソコン対応ソフトでは、エラーリストのファイルを開くことはできません。
88
(7)モニタリングデータ
軸の操作量、速度指令、フィードバックパルスを表示できます。データ種別で、表示したい項目を
選択します。
キーを押すことにより、取得したデータをファイル保存することができます。データは、数値
データとして CSV 形式で格納されます。
ファイル化します。(CSV 形式)
データの取込みを開始します。
データの取込みを停止します。
グラフのスケールを変更します。
モニタする対
象軸を選択し
ます。
パ
ル
ス
数
時
バッファリン
グはサンプリ
ング数となり
ます。
「その他パラ
メータ No.51」
で1サンプル
の周期を設定
できます。
間(msec)
軸の合成速度を表示します。(1
軸仕様のため、1軸の速度とな
ります。)
操作量 :速度、加速度、減速度から算出する台形又は三角パターンとなる原指令パルス
速度指令:コントローラからアクチュエータに指令する実指令パルス
フィードバックパルス:アクチュエータのエンコーダから送られて来る位置パルス
(フィードバックパルス)
図 10.16
モニタリングデータ
注)SA-D-C1Sは1軸用コントローラです。
89
11. コントローラメニュー補足
11.1 ソフトウェアリセット
コントローラを再立上げします。
フラッシュ ROM に書き込んでいないデータは消去されてしまいますので、注意してください。
メニューよりコントローラ(C)→ ソフトウェアリセット(R)をクリックします。
11.2 エラーリセット
メッセージレベルと動作解除レベルのエラーをリセットします。エラーの原因が取り除かれていなけれ
ば再エラーが発生します。
メニューよりコントローラ(C)→ エラーリセット(E)をクリックします。
90
11.3
駆動源復旧要求と動作一時停止解除要求について
(1)駆動源復旧要求
駆動源復旧要求が必要なケース
下記ケースに限り駆動源復旧要求が必要となります。
・任意の入力ポートを、駆動源遮断解除入力信号(専用機能)に指定し、
駆動源遮断要因発生→遮断要因解除後の復旧。
駆動源復旧要求方法
以下のいずれかの方法により、駆動源復旧要求を行うことができます。
・ 入力機能指定値‘17’を、入力ポート No. に対応した I/O パラメータ(No.30 ∼ 45、No.251 ∼
258)に設定します。
(SAコントローラ取扱説明書のI/O機能一覧表・I/Oパラメータ参照)
指定した入力ポート No. に ON エッジ入力。
・パソコンソフト、メニューより、コントローラ(C)→駆動源復旧要求(P)を実行
(2)動作一時停止解除要求
動作一時停止解除要求が必要なケース
下記、いずれかのケースに限り一時停止解除要求が必要となります。
・その他パラメータ No.10 を2(非常停止復旧種別=動作継続復旧(自動運転中時のみ))
に設定時、
自動運転中での非常停止→非常停止解除後の復旧(動作一時停止解除)
・その他パラメータ No.11 を2(デッドマン SW・イネーブル SW 復旧種別=動作継続復旧(自動運
転中時のみ))に設定時、自動運転中でのデッドマン SW による停止、またはイネーブル SW によ
る停止→停止解除後の復旧(動作一時停止解除)
・任意の入力ポートを、動作一時停止入力信号(専用機能)に指定します。入力機能指定値‘8’を、
入力ポート No. に対応した I/O パラメータ(No.30 ∼ 45、No.251 ∼ 258)に設定します。
(I/O 機
能一覧表・I/O パラメータ参照)
自動運転中での指定した入力ポート No. に OFF レベル入力(動作一時停止)→入力ポート No.ON
レベル入力後の復旧(動作一時停止解除)
動作一時停止解除要求方法
以下のいずれかの方法により、動作一時停止解除要求を行うことができます。
・任意の入力ポートを、動作一時停止解除信号(専用機能)に指定します。入力機能指定値‘7’を、
入力ポート No. に対応した I/O パラメータ(No.30 ∼ 45、No.251 ∼ 258)に設定します。
(I/O 機
能一覧表・I/O パラメータ参照)
指定した入力ポート No. に ON エッジ入力。
・パソコンソフト、メニューより、コントローラ(C)→動作一時停止解除要求(L)を実行
注意)
(1) 及び、
(2) のケースが重なっている場合では、まず、駆動源復旧要求を行った後、次いで、動
作一時停止解除要求を行う必要があります。
91
11.4 SEL グローバルデータバックアップ
ファイルへ保存
グローバルフラグ、グローバル整数型変数、グローバル実数型変数、グローバルストリングスを保存で
きます。
メニューより SEL グローバルデータバックアップ(G)→ファイルへ保存(S)をクリックします。
SEL グローバルデータバックアップ画面(ファイルに保存)が表示されます。
を押すと、保存されます。
図 11.1 SEL グローバルデータバックアップ画面(ファイルに保存)
92
コントローラへ転送
グローバルフラグ、グローバル整数型変数、グローバル実数型変数、グローバルストリングスをコント
ローラに転送できます。
メニューより SEL グローバルデータバックアップ(G)→コントローラへ転送 (L)をクリックします。
SEL グローバルデータバックアップ画面(コントローラへ転送)が表示されます。
エラーが発生した場合は、
「エラー詳細情報」タグにフォックスが移動し、エラー内容が表示されます。
図 11.2 SEL グローバルデータバックアップ画面(コントローラへ転送)
を押すと、SEL グローバル転送種別選択画面が表示されます。
転送する種別にレ点を付けて、ON をクリックすると、コントローラに転送されます。
図 11.3 SEL グローバル転送種別選択画面
93
11.5 制御定数テーブル管理情報
エンコーダ、モータの制御定数テーブルのバージョンを確認することができます。
メニューよりコントローラ(C)→制御定数テーブル管理情報(Z )をクリックします。
図 11.4 制御定数テーブル管理情報
94
11.6 ポジショナモードの起動停止
マニュアルモード且つポジショナモード時、起動を選択すると、パソコンからポジショナモードを起動
できます。
(7セグメントは、“PN ##”と表示されます。##はポジショナモード No. です。)
マニュアルで起動することにより、セーフティ速度での試運転や、入出力ポートなどのモニタができます。
メニューよりポジショナモード(O)→起動(E)をクリックします。
非常停止ボタンを押すか、図 11.5 画面の停止を押せば、ポジショナモードは停止します。
メニューよりポジショナモード(O)→停止(S)をクリックします。
図 11.5 ポジショナモードの起動、停止
注意:ポジショナモード時、起動状態の場合は、パラメータの変更、フラッシュROMの書込みなどが
できません。
本操作で、停止を行ってからパラメータの変更、フラッシュ ROM の書込みなどを行ってください。
95
11.7 ポジショナモードの情報取得
ポジショナモードのメンテナンス用情報(システムデータ)を収集できます。
システムデータ取得中のダイヤログ表示後、
「ポジショナモードシステムデータファイル」選択し、保存ス
イッチを押すと、システムデータが保存できます。
ポジショナモードに関するサポート問い合わせ時に使用します。
メニューよりポジショナモード(O)→ポジショナモード情報取得(G)をクリックします。
図 11.6 システムデータ取得中ダイヤグラム
図 11.7 システムデータ保存
96
11.8 ポジショナモード管理情報
ポジショナモードについて、運転モードと管理情報を表示します。
メーカー用の情報です。
管理情報タブ
・運転モード :指定されたポジショナモードを表示します。
・管理情報1、2:システムデータの管理情報を表示します。
詳細タブ
システムに設定されたシステムデータ個別の運転モード名と管理情報を表示します。
メニューよりポジショナモード管理情報(M)をクリックします。
図 11.8 ポジショナモード管理情報
管理情報タブ
図 11.9 ポジショナモード管理情報
詳細タブ
97
12. ツール
ツールには、環境設定の中に、設定とタイマーがあります。
(1)設定
プログラムエラーチェック時、シンボルチェックを行うかどうかの設定を行います。
本チェックを外した場合、シンボルに関する
エラーチェックを行いません。
チェックを外した場合、起動時に使用可能な
通信ポートをチェックしませんが、接続確認
ウィンドウで選択可能な通信ポートがCom1
∼ 256 に拡張されます。
ただし、選択された通信ポートが使用できない
場合「EC5:通信ポートオープンエラー」が
発生します。
チェックを外した場合、‘Cmnd’欄ダブル
クリック時、部分修正ができます。
図 12.1 設定(オフライン)
パラメータファイル転送時の種別詳細設定の
デフォルトを指定します。
チェックをつけた場合、変数・I/O ポート・フ
ラグモニタ・ポジションデータ編集ウィンド
ウにシンボルを表示します。
図 12.2 設定(オンライン)
98
環境設定画面で、保存方法を選ぶことができます。
・「常にフォーマット2で保存する。」
:常に拡張フォーマット(フォーマット2)で保存するこ
とができます。
・「保存フォーマットを選択可能にする。
」 :プログラムやポジションデータを保存する場合、通常
フォーマット(フォーマット1)又は、拡張フォーマッ
ト(フォーマット2)で保存するかを選択する画面が表
示され、保存方法を選択できます。
「常にフォーマット2で保存する。」
「保存フォーマットを選択可能にする。
」
のいずれかを選択。
図 12.3
設定
(2)タイマー
コントローラが各種のデータを照会しに行く時間を設定します。通常は変更する必要はありません。
図 12.4 タイマー
99
100
システム
エラー割付元
MAIN アプリ部
MAIN コア部
エラー No.
(HEX)
800 ∼ 88F
890 ∼ 8AF
BC0 ∼ BDF
BE0 ∼ BFF
C00 ∼ CCF
CD0 ∼ CDF
CE0 ∼ CEF
CF0 ∼ CFF
D00 ∼ D8F
D90 ∼ DAF
DB0 ∼ DCF
DD0 ∼ DDF
DE0 ∼ DFF
E00 ∼ E8F
E90 ∼ EBF
EC0 ∼ EDF
EE0 ∼ EFF
FF0 ∼ FBF
FC0 ∼ FCF
FD0 ∼ FDF
FE0 ∼ FEF
PC
TP
MAIN アプリ部
MAIN コア部
PC
TP
MAIN アプリ部
MAIN コア部
PC
PC
(アップデートツール)
TP
MAIN アプリ部
MAIN コア部
PC
TP
MAIN アプリ部
MAIN コア部
PC
TP
○
○
○
○
○
○
○
△(バッテリー
関連、フィール
ドバス関連等
は、エラーリス
ト登録)
○
○
「動作打切時 I/O 処理プロ
グラム」以外の全プログ
ラム解除(軸関連エラー
以外は、エラー発生瞬間
のみ解除要因)。
全 解 除
発生元プログラム解除
※但し、駆動源遮断必 「動作打切時 I/O 処理プロ
要エラー(初期化エ
グラム」以外の全プログ
ラ ー 、 電 源 エ ラ ー 等 ) ラム解除。
時、
「動作打切時I/O処理
プログラム」以外の全
プログラム解除。
発生元プログラム解除
(軸関連エラー以外は、エ
ラー発生瞬間のみ解除要
因)
。
表示(7SEG,
プログラム運転
エラーリスト エラー LED 出力
DISPLAY 等)
その他パラ No.4 =0時
その他パラ No.4 =1時
PC:パソコン対応ソフト、TP:ティーチングボックス
システム
ダウン
レベル
コールド
スタート
レベル
動作解除
レベル
AA0 ∼ ACF
AD0 ∼ AFF
B00 ∼ B9F
BA0 ∼ BBF
PC
TP
MAIN アプリ部
MAIN コア部
PC
8B0 ∼ 8DF
TP
8E0 ∼ 8FF
MAIN アプリ部
900 ∼ 93F
MAIN コア部
940 ∼ 97F
PC
980 ∼ 9AF
PC
9B0 ∼ 9BF
(アップデートツール)
メッセージ
TP
9C0 ∼ 9FF
レベル
フラッシュ ACKタイムアウト A00 ∼ A6F
MAIN コア部
A70 ∼ A9F
シーク
レット
レベル
エラー
レベル
付録
◎エラーレベル管理について
不可
不可
可
可
エラーリセット
電源再投入必要。
(CPU・
OS 的には実行不可能)
電源再投入必要。
(CPU・
OS 的には正常実行)
動作に支障のあるエ
ラー。このレベル以下の
軽度エラーは、外部アク
ティブコマンド(SIO・
PIO)時のオートリセッ
ト機能により、エラー解
除が試みられる。
状態表示、インプット
エラー等
メンテナンス用特殊エ
ラーレベル
備 考
101
サーボ OFF 状態の軸に対してジョグ操作が行われました。先にサーボ ON してください。
ジョグ・移動・連続移動時の加速度指定値が範囲を超えているか、不正な値がしていされて
コントローラの空ステップ数が不足しています。
非マニュアルモード時に、データ編集操作(書込み、コピー、移動、クリア等)が行われま
ファイルに保存されているデータ数(ステップ数、ポジション数等)が許容値を超えています。
オンライン編集中プログラムファイル転送禁止
オンライン編集中ポジションデータコピー・移動・クリア禁止
オンライン編集中ポジションデータファイル転送禁止
オンライン編集中パラメータファイル転送禁止
オンライン編集中シンボルデータクリア禁止
オンライン編集中シンボルデータファイル転送禁止
オンライン編集中メモリ初期化禁止
サーボ OFF 時ジョグ禁止
ジョグ・移動・連続移動加速度指定エラー
ジョグ・移動・連続移動減速度指定エラー
実行中プログラム編集不能エラー(PC)
空ステップ不足エラー(PC)
非マニュアルモード時データ編集禁止
ファイル読込みデータ数オーバー
982
983
984
985
986
987
988
989
98A
98B
98C
98D
98E
不正なボーレート値が指定されました。(接続確認、ボーレート変更時等)
データ送受信(読出し、書込み)中は、ファイルから読込んだデータをコントローラに転送
データ送受信中ファイルデータ転送禁止
990
991
することはできません。
ファイルへの書込みデータ数(ステップ数、ポジション数等)が許容値を超えています。
ファイル書込みデータ数オーバー
ボーレート指定エラー
98F
した。
た。編集対象プログラムの実行を終了させてから再試行してください。
実行中のプログラムに対して、書込み・コピー・移動・クリア等の編集操作が行われまし
います。加速度指定値を確認してください。
ジョグ・移動・連続移動時の減速度指定値が範囲を超えているか、不正な値がしていされて
います。加速度指定値を確認してください。
で、メモリ初期化操作を行いました。先にオンライン編集ウィンドウを閉じてください。
プログラム・シンボル・ポジションデータのオンライン編集ウィンドウを開いている状態
送操作が行われました。先にオンラインシンボルデータ編集ウィンドウを閉じてください。
オンラインシンボルデータ編集ウィンドウを開いている状態で、シンボルデータファイル転
が行われました。先にオンラインシンボルデータ編集ウィンドウを閉じてください。
オンラインシンボルデータ編集ウィンドウを開いている状態で、シンボルデータクリア操作
行われました。先にオンラインパラメータ編集ウィンドウを閉じてください。
オンラインパラメータ編集ウィンドウを開いている状態で、パラメータファイル転送操作が
転送操作が行われました。
先にオンラインポジションデータ編集ウィンドウを閉じてください。
オンラインポジションデータ編集ウィンドウを開いている状態で、ポジションデータファイル
を閉じてください。
ピー・移動・クリア操作が行われました。先にオンラインポジションデータ編集ウィンドウ
オンラインポジションデータ編集ウィンドウを開いている状態で、ポジションデータコ
に対象プログラムのオンライン編集ウィンドウを閉じてください。
オンライン編集中のプログラムに対して、プログラムファイル転送操作が行われました。先
ア操作が行われました。先にオンラインプログラム編集ウィンドウを閉じてください。
981
オンラインプログラム編集ウィンドウを開いている状態で、プログラムコピー・移動・クリ
特記事項
オンライン編集中プログラムコピー・移動・クリア禁止
エラー名称
980
エラー No.
(パソコン対応ソフト固有のエラーです。コントローラのエラーは SAコントローラ取扱説明書を参照ください。)
SAパソコン対応ソフトエラー表
102
座標 1・座標 2 有効軸パターン不整合エラー
座標 1・座標 2 有効軸パターン 0 時出力ポート / フラグ・エラー種別指定 簡易干渉チェックゾーン定義データに座標値が入力されていません。
995
996
座標系定義データのオンライン編集ウィンドウを開いている状態で、座標系定義データファ
機能未サポート拒絶エラー(PC)
入力データエラー
パスワードエラー
ファイル書込みエラー
運転モード時データ編集禁止エラー
フラッシュ ROM 書込み中データ書込み禁止
ファイルデータエラー
ジョグ・移動・連続移動速度過小エラー
ジョグ・移動・連続移動速度過大エラー
オフライン時データ送受信不可
原点復帰未完了時ティーチ禁止エラー
運転モード時メモリ初期化禁止エラー
99E
AA0
AA1
AA2
AA3
AA4
AA5
AA6
AA7
AA8
AA9
AAA
ださい。
No.21および現在選択されているパソコン対応ソフトのマニュアル動作種別)を確認してく
運転モード中にメモリ初期化操作が行われました。マニュアル動作種別(その他パラメータ
原点復帰を完了させてください。
原点復帰未完了状態の軸に対し、ティーチ(現在位置取り込み)操作が行われました。先に
ケーションをオンラインモードで起動し直してから、再試行してください。
コントローラとの通信が遮断されている為、データを送受信することができません。アプリ
ファイルから読出したデータに異常があります。
中はデータ編集操作を行うことはできません。
フラッシュ ROM 書き込み中にデータ書込み操作が行われました。フラッシュ ROM 書込み
ださい。
No.21および現在選択されているパソコン対応ソフトのマニュアル動作種別)
を確認してく
運転モード中にデータ編集操作が行われました。マニュアル動作種別(その他パラメータ
入力されたパスワードに誤りがあります。正しいパスワードを入力してください。
許容範囲外の値または許されない文字が入力されています。
未サポート機能です。
通信ソケット No. の指定に異常があります。
ポイントデータ数の指定に異常があります。
ポジション No. 指定エラー
ポート No. 指定エラー
ライトプロテクトデータライトエラー
プロテクト設定パラメータエラー
999
99A
99B
書込み禁止データに対して書込み、コピー、移動、クリア等の操作を行うことはできません。
プロテクト設定パラメータ(その他パラメータNo.36∼39)に不正な値が設定されています。
リードプロテクトデータリードエラー
99C
読出し禁止データに対して読出し、コピー、移動等の操作を行うことはできません。
モニタリング軸指定数オーバー
998
簡易干渉チェックゾーン定義データの座標1と座標 2 の指定軸パターンが一致していません。
イル転送操作が行われました。先にオンライン編集ウィンドウを閉じてください。
997
禁止エラー
オンライン編集中座標系定義データファイル転送禁止
994
サーボ OFF 状態では腕系変更を行うことができません。
クリアすることができません。先にオンライン編集ウィンドウを閉じてください。
サーボ OFF 時腕系変更禁止
993
座標系定義データのオンライン編集ウィンドウを開いている状態では、
座標系定義データを
特記事項
オンライン編集中座標系定義データクリア禁止
エラー名称
992
エラー No.
103
シンボル先頭文字エラー
シンボル文字列エラー
シンボル多重定義エラー
プログラム名多重定義エラー
エンコーダ種別エラー
モニタリング軸未選択エラー
ABD
ABE
ABF
AC0
AC1
AC2
ファイルオープンエラー
ABA
ファイルタイプエラー
ブレークポイント設定数オーバー
AB9
データ未入力
ブレークポイント設定数が設定可能数を超えています。
先に他のブレークポイントを解除し
ファイル読込みエラー
AB8
ABC
ファイルのフォーマットが異なるか、異常なデータが含まれています。
再原点復帰未完了エラー
AB7
ABB
原点復帰未完了状態の軸に対し移動・連続移動操作が行われました。先に原点復帰を完了さ
AB6
操作対象軸のエンコーダ ABS/INC 種別(軸別パラメータ No.38)等を確認してください。
同一プログラム名が多重に定義されています。
同一シンボルが多重に定義されています。
シンボル文字列に不正な文字が含まれています。
シンボルの先頭に許されない文字が使用されています。
データ入力必須項目にデータが入力されていません。データを入力してください。
ファイル種別異常です。ファイルの種類(拡張子)を確認してください。
確認してください。
ファイルを開くことができません。他のアプリケーションでファイルが使用されていないか
てから再試行してください。
行う際には必ず原点復帰を行う必要があります。
た。原点復帰完了・未完了に拘わらず、アブソリュートエンコーダ多回転データリセットを
再原点復帰未完了時にアブソリュートエンコーダ多回転データリセット操作が行われまし
せてください。
サーボ ON 状態での使用が禁止されているスレーブコマンドの発行操作が行われました。
原点復帰未完了時移動・連続移動禁止エラー
スレーブコマンド ID エラー
AB2
サーボ ON 時使用禁止スレーブコマンド発行エラー
スレーブコマンド ID 未入力エラー
AB1
AB5
スレーブデバイス No. エラー
AB0
原点復帰未完了状態での使用が禁止されているスレーブコマンドの発行操作が行われました。
スレーブデバイス No. 未入力エラー
AAF
使用禁止スレーブコマンド発行エラー
スレーブユニット種別エラー
AAE
認してください。
原点復帰未完了時使用禁止スレーブコマンド発行エラー
スレーブユニット種別未入力エラー
AAD
メータ No.21 および現在選択されているパソコン対応ソフトのマニュアル動作種別)を確
運転モード中にエラーリストクリア操作が行われました。マニュアル動作種別(その他パラ
確認してください。
AB3
運転モード時エラーリストクリア禁止エラー
AAC
パラメータ No.21および現在選択されているパソコン対応ソフトのマニュアル動作種別)を
運転モード中にフラッシュ ROM 書込み操作が行われました。マニュアル動作種別(その他
特記事項
AB4
運転モード時フラッシュ ROM 書込み禁止エラー
エラー名称
AAB
エラー No.
104
コントローラ未接続エラー
EC1
受信オーバーランエラー(PC)
受信伝文ストリング異常(PC)
EC0
EC9
有効軸無しエラー
ACF
受信バッファオーバーフローエラー(PC)(OS)
未サポートファイルエラー
EC8
ファイル未検出エラー
ACD
ACE
受信バッファオーバーフロー(PC)
シンボル未定義エラー
ACC
EC7
オンライン編集中 SEL プログラム・シンボル・ポジションデータ初期化禁止
ACB
サムチェックエラー(PC)
オンライン編集中パラメータ初期化禁止
ACA
EC6
入力値過小
AC9
ボートオープンエラー
入力値過大
AC8
EC5
シンボル定義数オーバー
AC7
受信タイムアウトエラー(PC)
データ送受信中ウィンドウクローズ禁止
AC6
受信レングスエラー(PC)
インチング距離過大エラー
EC3
時刻入力エラー
AC4
AC5
EC2
日付入力エラー
エラー名称
AC3
エラー No.
受信オーバーランが発生しました。「再接続」を行ってください。
受信バッファオーバーフローが発生しました。「再接続」を行ってください。
受信バッファ(PC)でオーバーフローが発生しました。「再接続」を行ってください。
通信異常です。ケーブルの接続、ショート、ノイズ等を確認してください。
認してください。
通信ポートをオープンすることができません。
通信ポートが使用可能な状態であることを確
通信異常です。ケーブルの接続、ショート、ノイズ等を確認してください。
通信異常です。ケーブルの接続、ショート、ノイズ等を確認してください。
があります。コントローラとの物理的な接続を確認してから、
「再接続」を行ってください。
通信確立が完了していないか、サポートされていないコントローラが接続されている可能性
ださい。
受信伝文に異常があります。 再接続を行っても解消しない場合は、メーカーに連絡してく
認してください。
編集・操作可能な有効軸がありません。有効軸パターン(全軸共通パラメータ No.1)を確
を確認してください。
アプリケーションがサポートしていない形式のファイルが指定されました。ファイルの種類
指定されたファイルが見つかりません。ファイル名を確認してください。
プログラムステップデータで未定義のシンボルが使用されています。
ン編集ウィンドウを閉じてください。
で、SEL プログラム・シンボル・ポジションデータ初期化操作を行いました。先にオンライ
プログラム・シンボル・ポジションデータのオンライン編集ウィンドウを開いている状態
ました。先にオンラインパラメータ編集ウィンドウを閉じてください。
オンラインパラメータ編集ウィンドウを開いている状態で、パラメータ初期化操作が行われ
保してから再試行してください。
シンボル定義可能数を超えています。先に他のシンボルを削除する等して、空きエリアを確
データ送受信中の編集ウィンドウを閉じることはできません。
送受信完了後に閉じてください。
(将来拡張用)
(将来拡張用)
特記事項
105
通信エラーが発生しました。「再接続」を行ってください。
サポートされていないコントローラが接続されています。
通信エラー(PC)(OS)
非サポート機種接続エラー
ECB
通信異常です。HUB、ケーブルの接続、ショート、ノイズ等を確認してください。
通信異常です。HUB、ケーブルの接続、ショート、ノイズ等を確認してください。
通信異常です。ケーブルが抜かれたか、切断された可能性があります。
指定したポート番号が他の接続で使用中の可能性があります。ポート番号を変更してください。
64 台以上のコントローラとコネクションした場合に発生します。
イーサネット受信タイムアウトエラー(PC)
コネクション切断エラー(PC)
ソケットエラー(PC)
サービスポート番号使用中(PC)
接続ソケット数オーバーエラー(PC)
ECD
ECE
ECF
ED0
ED1
ECA
ECC
特記事項
フレーミングエラーが発生しました。「再接続」を行ってください。
エラー名称
フレーミングエラー(PC)
エラー No.
MEMO
106
MEMO
107
13.09
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement