Xequence | MIDI Workstation

Xequence | MIDI Workstation

Quickstart Guide

© 2017 Seven Systems Cross-Platform Media Limited iPhone and iPad are trademarks of Apple Inc., registered in the U.S. and other countries.

Contents

Introduction

Features at a glance

Overview

Instruments

Arranger

Keyboard and Controllers

Drum Maps and Editing

Pianoroll

Metronome, Tempo and Time Signature

Recording

Song loop

Copying, linking, and looping parts

MIDI Input and Thru

MIDI File Import and Export

Managing files

Demo project

Example setups

24

26

27

30

14

18

21

23

32

34

35

36

8

11

3

4

7

Introduction

Welcome to Xequence!

Xequence is an advanced, linear MIDI sequencer and controller for iPhone & iPad. It can be used to record, edit and arrange notes and controller movements, both using other apps that support Virtual

MIDI / CoreMIDI (in effect, all of them), or external MIDI hardware like synthesizers, control surfaces etc.

It can also sync with other apps and devices using Ableton Link and can act as a MIDI Sync master, so that other apps or hardware can slave to Xequence, meaning that they run in perfect sync with it (they start when you press play in Xequence, they stop when you press stop, they move their song position if you move it in Xequence, etc.).

This guide only gives you an overview over important concepts and features in the app so that you can use it effectively and to its full potential. It does not document all available features.

For the rest, Xequence contains extensive in-app "hints" that pop up whenever you touch a button or area for the first time.

Features at a glance

HIGHLIGHTS:

Efficient User Interface for an amazing editing workflow on a mobile device

Scale-aware Keyboard and Pianoroll Editor: All input and editing respects the current instrument's scale

Over 70 scales in 10 categories included

Drum Maps and Pads, highly customizable (In-App Purchase)

MIDI File Import & Export (notes, controllers, program changes, track names, etc.)

Supports any time signature/BPM (fixed per song)

Extremely tight MIDI timing

MIDI In & Thru with re-channelization & re-routing to currently selected instrument

Ableton Link

MIDI Sync Master (Clock/Start/Stop/Continue/SPP) - other DAWs & pattern sequencers can run in accurate sync with Xequence, e.g. to use audio tracks, or an external drum machine. Several modes for maximum compatibility

Works perfectly with e.g. AUM / Gadget as hosts / sound generators, drum sequencers like Ruismaker, or Beatmaker 2 for synced audio tracks

ARRANGER:

Unlimited Parts

Up to 4 tracks (Unlimited Tracks via In-App Purchase)

64 Undo/Redo steps

Per-track non-destructive Swing & Delay (timeshift +/- 200 ms)

Any Track can be routed to any Instrument

Parts can be independent or linked (editing the original modifies all copies)

Part-based looping

Program changes

Selection tools: Marquee/Rectangle, Same Track, Same Instrument, Linked Parts, Invert, etc.

Editing tools: Create Copy, Create Linked Copy, Unlink, Split, Join, Convert loops to parts, etc.

All edits can be performed across multiple tracks and parts

Global clipboard, even across projects

Position/Length Handles at screen edges for efficient editing

PIANOROLL EDITOR:

256 Undo/Redo steps

Fully scale-aware

Relative or absolute grid: Snap Events to nearest grid line, or move by grid increments

Live Auditioning of all edits and mini keyboard keys on the left

Selection tools: Marquee/Rectangle, Same Note, Same Key, Same Beat Position, Invert, etc.

Editing tools: Copy, Legato, Quantize, Quantize Ends, Octave +/-, Flip H/V (mirror), Fill part with selection

Smart Draw mode: Touch to create, touch again to delete, drag up/down to transpose, drag left/right to change length

Note velocities can be edited just like controllers, see below:

CONTROLLER EDITOR:

256 Undo/Redo steps

Selection tools: Marquee/Rectangle, Same Beat Position, Invert

Selection modes: Add & Replace

Editing tools: Copy, Reduce, Quantize, Compress/Expand, Flip H/V (mirror), Ramp (various curves), Fill part with selection

Smart Draw mode

Note Velocities can be shown as controllers and edited with the same tools

KEYBOARD / CONTROLLER:

Fully scale-aware, very playable single or dual keyboards

Glide support

Freely adjustable key width

Velocity emulation option (via vertical position on key)

CCs (controllers) can be shown as touch ribbons next to the keyboard

All CCs can be controlled by sliding (ribbon), device rotation (up to three axes simultaneously), played like a button (sustain pedal, "trance gates"), or by touching the keys at different vertical positions. All highly configurable.

INSTRUMENTS:

Unlimited Instruments (an Instrument is a MIDI destination & channel)

3 definable CCs (Controllers) per Instrument (up to 12 via In-App Purchase)

Compatible with virtually ALL synths and hosts

VARIOUS:

Audio & MIDI Metronome

Note chasing (notes play even when playback starts in the middle)

Robust controller (CC) handling with backchasing (inside parts)

Perfect song looping, no dropouts/jitter at loop points iOS 11 Files app support (in "On My iPhone/iPad")

Ruler, either fixed or modal (hidden automatically to preserve screen space)

In-App hints for all important features

Overview

The following diagram gives you an overview about how MIDI routing between MIDI Input apps / controllers, tracks, instruments, and MIDI-capable instrument apps / hardware works.

Instruments

An instrument in Xequence represents a connection to something that actually produces sound, i.e. a synthesizer app like Poison-202, Animoog, Gadget. It can also control external MIDI synths or slave an external DAW to Xequence's clock.

Any time you want to add a new sound (timbre) to your project, you would create a new instrument.

Instruments have the following main settings:

MIDI Destination

Here you can select the app (or MIDI output) whose sounds you want to use for this instrument. This is saved with the project and when you reload it, all connections will automatically be remade, either at load or when the corresponding app is launched.

MIDI Channel (1-16)

For multi-timbral synths (apps or hardware that can produce multiple different sounds at once), each sound is assigned one of 16 channels. Select the same channel in your synth and in this menu. If you only use one sound in the synth app or it doesn't support multiple sounds, just leave both at 1 or set the synth to Omni.

Another use case for channels is AUv3 hosts like AUM: As AUM only appears as a single app in

Xequence, but can host multiple instruments, you would use channels to separately connect to them: In

AUM, enable the "AUM Destination" MIDI Source for the plugin, and in "Channel Filter", enable just one of the channels, for example, 3. Then in Xequence, select AUM as the MIDI destination, and channel 3. This way, you can host up to 16 separate instruments in AUM and create corresponding instruments in

Xequence.

Send Sync

Turn this on if (and only if) you want the timeline of an external DAW (for example, BeatMaker 2 — this is most useful if you want to use audio tracks in your project) or an external pattern sequencer / drum machine (for example, Ruismaker) to run in sync with Xequence.

Xequence sends the following sync information:

Start

Stop

Continue

Song Position Pointer

Clock

Note that if you want an external app to sync to Xequence, you have to create a "dummy" instrument for it (with the "Send Sync" option enabled) even if you do not use any of its sounds (if you do use some of its sounds, just turn "Send Sync" on in one of the instruments. Sync is not channelized, so if you use the same app for several instruments on different channels, if you turn on "Send Sync" for one of them, it will turn on for all of them.)

There are two modes:

Absolute: This is most compatible with DAWs or sequencers that have a real timeline. It will try to synchronize the absolute time of the destination app / device with Xequence, so both run exactly in parallel. This mode may not be compatible with loop-based apps or devices. For those, use

"Relative".

Relative: This starts the destination app / device on the nearest whole bar position, and does not care about absolute timeline position. This mode is most useful and compatible with loop-based apps or devices, like Ruismaker.

Controllers

Each instrument can have up to 3 controllers, also known as CCs (up to 12 via In-App Purchase). These can be used to modulate parameters like filter cutoff, pitch, etc. in apps or synths that support it (i.e., nearly all).

To switch to the next page of controllers, tap on the right arrow button.

As you will probably only use a very small subset of all available CCs for each instrument, you can set them up once here, and only those will be shown in the Keyboard and Controller editor views, so you don't have to scroll through a mile long list of all controllers (more than 100) each time. The little

"Keyboard" button decides if the corresponding controller will be available on the Keyboard screen when tapping the "CC" button there.

Many apps use the same controllers for similar things (e.g., CC 74 for "Filter cutoff"), so we have included a selection of "standard" controllers in the menu which work with many apps. However, please check in your corresponding app or synth what CCs it uses for what parameter.

If the CC you want to control from Xequence is not included in the menu (say, you use a drum synth which uses CC 88 for the "Pan" knob of the HiHat), you can tap the "#" button and enter the controller number (in this case, 88) manually.

Each controller has further options:

Name: Especially for non-standard controllers ("#"), you can enter a name of your own here (for example, "Kick Drum Pan"). This name will be used in all menus, buttons etc. that deal with that controller.

Centered: Enable this to have the controller centered around 0. Useful for Pitch Bend, Pan, etc.

Return: Enable this to have the controller automatically "bounce" back to zero after releasing it with your finger. This is most useful for the Pitch Bend controller.

Use of colors throughout Xequence

In Xequence, "colors belong to instruments", i.e., you can assign a color to each instrument, and that color will then be used for all user interface elements (tracks, pianoroll notes, keyboard keys, etc.) that affect that instrument.

For example, if you create an instrument for your bassline synth, and assign it the color "Blue":

All tracks that play that instrument will be blue

All parts on those tracks will be blue

Notes and controllers in the editors are shown in blue

If you call up the keyboard, keys will be in blue

The "Record" button will be blue as well if you have a track selected that is assigned to that instrument.

This always gives you a sense of context.

Arranger

Tracks

The Arranger uses tracks to separate the parts (some call them clips or patterns) for the different instruments.

For each instrument you create, you need at least one

track to contain the parts that have the notes and controllers that make up the song.

You can also create multiple tracks for the same instrument. This is very useful if you want to record both notes and controllers, as this way, you can keep them neatly separated: create one track for the notes, then create another track below it (the "+" button) for the first controller, another one for the second, etc.

Note: You can record both notes and controllers on the same track into the same parts and then switch between them in the Pianoroll / Controller editor, but this is not recommended as it is much easier to work with separate tracks.

Track settings

Title: On the left, tracks display the name of the target instrument. An additional title that is displayed to the right can be entered here. Useful, for example, if you want to use a track for controller data that controls filter cutoff in the target synth. You could set its title to "Cutoff" then.

Delay: If set, all notes and controllers on this track are shifted by this many milliseconds during playback. Useful for shifting claps or basslines slightly backwards in time, for example, or to adjust for latency of the synth / app on this track. Note: This setting does not modify the actual data, it just affects playback!

Swing: Performs swing quantization. Note: This setting does not modify the actual notes in the parts on the track, it just affects playback! You can change it as often as desired.

Target instrument: Select one of the buttons below to choose which instrument (which you previously configured in the "Instruments" screen) should be played by the data on this track. Multiple tracks can target the same instrument (for example, to keep notes and controllers for the same instrument neatly separated).

Mute / Solo

The "M" button mutes a track, i.e., its events won't be played back anymore. If the "S" button is active on one or more tracks, those tracks are soloed: only events on those tracks will be played back.

Scrolling the tracklist

We designed the Arranger so that you can only scroll vertically by swiping in the editor area on the right, not on the tracklist. This is on purpose: We wanted the "M" and "S" buttons to react instantly when tapped, however, in order to detect if a touch is meant to be a swipe (scroll) or a tap, Xequence would first have to wait until the finger is lifted or moved.

Editor

The editing area to the right of the tracklist contains your arrangement, i.e. all the parts (also called

patterns or clips) that make up the complete song. It is played from left to right.

Slide your finger across the editor to scroll.

Pinch with two fingers to zoom in or out.

Tap and hold to start rectangle / marquee select.

This will select all parts touched by a rectangle drawn with your finger. But see "Selection mode", below.

Double-tap in an empty area to select or deselect all parts (this can be changed to single-tap in Xequence's settings, but we chose double tap so that you don't accidentally erase your whole selection while adding multiple parts to the current selection in Selection

"Add" mode).

Tap a part to select or deselect it (the exact behavior depends on the Selection mode, see below).

Double-tap a part to open up the Pianoroll editor to edit its notes or controllers. You can also tap the toolbar button in the lower right corner instead.

Selection mode

There are two modes for selecting parts, using either tap or rectangle selection:

Add: Use for selecting multiple parts by tapping them in succession, or drawing multiple rectangles. Tapping an already selected part deselects it.

Replace: When selecting parts either by tapping or drawing a rectangle, all previously selected parts are always deselected first.

This is the mode that is probably more practical for most situations.

Program changes

Any number of program changes (instruction to another synth which preset to use) can be inserted per track.

To insert a program change:

Select a track by tapping its name in the track list.

Move the song position pointer to the position where you would like the program change to occur.

Tap the "+" button at the bottom left to open the

"Insert" menu.

Tap "Program change".

In the dialog, enter the program number.

To change the number of an already existing program change, just double-tap it as you would a regular part, or with the program change selected, tap the bottomright "Edit" button.

Program changes use backtracing just like controllers, i.e. when the song position changes, Xequence automatically searches for the nearest previous program change and sends it to the instrument.

Keyboard and Controllers

Xequence offers a configurable, scale-aware keyboard with over 70 included scales selectable from almost a dozen categories (a chromatic scale (all notes) and

"normal" mode with black keys are also included). It can be either single or dual and can be "velocity sensitive"

(tap a key's bottom for full velocity, or the top for nearly no velocity). Two velocity curves are available on the

Settings screen. The key size is freely adjustable using the "Width" slider.

The keyboard always controls the instrument of the currently selected Arranger track, or, if launched while in the Pianoroll / Controller editor, the instrument of the track whose part is being edited.

Scales

In music theory, scales are selections of notes that work well together and give off a certain "mood".

A full octave contains 12 semitones. Most scales, like the Major or Minor scales, contain only 7 of those, which work well together. There's also scales with less notes, like the Pentatonic scales, which contain only 5 notes.

There's 2 special options in the Scales menu:

Black keys: Disable scales altogether and display black and white keys instead (like on a traditional hardware keyboard or piano)

Chromatic: Also effectively disables scales, as the

chromatic scale is the scale which simply contains all notes (12 semitones).

Playing and editing drums

Xequence has sophisticated support for fully customizable drum pads and editing. You can try all editing features for free; however, to actually play the drum pads, a one-time In-App Purchase is required. Please see the dedicated "Drum Maps" chapter for more details.

Alternatively, if you would like to use and edit drums without drum maps, use the Chromatic scale, as it contains all notes and you're guaranteed not to "miss" any drum sounds your destination instrument / app might play on some note.

Glide, Scroll, and Lock

Two toggles in the bottom toolbar of the keyboard screen control the scrolling / gliding behavior of the keys:

Glide: When this button is enabled, sliding across the keyboard will play each key as soon as your finger slides over it, and releases it when your finger leaves it. Note: This mode is currently only available when there's a scale selected, i.e. it won't work with black keys. If it is not enabled, then sliding your finger across the keyboard will instead scroll it horizontally.

Lock: Enable this to prevent horizontal scrolling of the keyboard.

Controllers

All controllers of the current instrument that have the "Keyboard" toggle enabled can be shown to the left by tapping the "CC" button.

On iPad, you can choose to either display them vertically stacked (uses less screen space and you can

"twitch" them more easily), or next to each other (the "|||" button). Choose whichever mode is more usable in your situation. This setting is saved per instrument.

To move a controller, just touch it and then slide up or down (it will start from the current value, not the value where you first touched it). You can reset a controller to zero by double-tapping it. Controllers that have the "Return" option enabled will return to zero once you lift your finger.

Enhanced control modes

Xequence offers an unrivaled palette of advanced ways to use controllers while playing live, outlined below.

Device Motion Control

All controllers can also be moved by rotating your device. Enable this option by tapping on the menu button above the slider, and then tap the

"Landscape Phone" icon.

The first controller will be moved by rotating your device towards or away from you. If you enable Motion Control for more than one controller, the next axis that will be used is the "around the device itself" axis, and the next one would be the "tilt the device around its vertical center line" (if that makes any sense!).

Gate mode

A controller can also act like a button and thus be "played" like a keyboard key. Enable this mode by tapping the menu button above the slider, and then the "Pulse" icon.

In this mode, when tapping the slider anywhere, the controller will immediately jump to the value at that position (for example, if you tap it right at the top, it will jump to 127), and when you release your finger, it will jump back to the position it was at before activating Gate mode.

There's at least two use cases for this mode:

For emulating a Sustain pedal (set the controller to 0 in normal "Slide" mode, then switch to "Gate" mode and tap near the top to simulate the sustain pedal.)

For creating the proverbial "trance gates" (by using CC 7 / Volume).

Note that when recording in this mode, controller data is quantized according to the "Q" setting at the top (including the "Ends" toggle there), just like keyboard keys. Of course, you can turn "Q" to "Off" if you do not want quantization in this mode.

Key position mode

In this mode, touching a key will set the corresponding controller depending on the vertical position where you touched the key (or keys). This is done before playing the actual note, so the target synth has time to adjust the controller's value before playing the sound. This mode is very useful for synths that do not support mapping velocity to controllers, etc.

Key slide mode

In this mode, the controller can be moved by sliding your finger up and down on a key (or keys) after touching the key.

Key slide + position mode

This mode combines the previously mentioned two modes.

A general note on recording controller data

Currently, if you record controller movements live, existing controller data on the track / in parts is not automatically erased, but only new events are added instead. So, if you want to "overwrite" controller data you recorded previously, it is best to delete the corresponding parts (or events, if you record into the Controller Editor) first.

We plan to add a "Replace" recording mode in the future, which will automatically erase existing controller data as soon as you touch the controller slider or enable motion control.

Event chasing

Xequence automatically finds the nearest previous controller event in the part that is at the current song position, and uses that for displaying the slider and also sends it via MIDI. So, no matter what, when you

set the song position, you will always get correct controller values (event chasing only works inside parts for now, so if there is no part at the current song position, the controller value won't change.).

Drum maps and Editing

Xequence has a sophisticated drum map and editing system:

Up to 64 drum pads, in any desired layout (4x4,

8x8, 2x6 etc.).

Fully customizable layout, drums can be moved around by drag and drop.

Highly configurable velocity sensitivity, with various modes (maximum velocity at center / top / bottom) and velocity curves (these settings can be found on the "..." (Settings) screen at the top left).

Glide mode.

Preset system with a variety of factory presets for various drum machines and apps (Korg Gadget,

Ruismaker, etc.), and an unlimited number of user presets that can be added.

Various map processing features such as Flip, Compact etc.

Activating drum maps for an instrument

To switch into drums mode, select a track with an instrument that is assigned to a drum synth, go to the

Keyboard screen, tap the keyboard selector button in the lower left corner (it will either show a single or dual keyboard icon), and in the dropdown menu, select the top option (drum map icon).

Xequence will load the "General MIDI" map by default, which contains the 47 standard GM drums including their names and notes.

Map size

You can configure any map layout from 1x1 (a single large drum pad) to 8x8 (64 pads) and anything in between by tapping the number buttons on the right hand side of the bottom toolbar.

When you resize a map that already has drum pads assigned and the new map size is smaller than the previous one, Xequence will try to keep the visual layout and shrink the map size horizontally so that the existing pads stay centered, and vertically so that bottom pads stay at the bottom.

If this is not possible, there can be two scenarios: If in theory, the existing pads would be able to fit the new size (say, you have 35 drum pads and you select 6x6), but not with the current visual layout, then

Xequence will offer you to automatically compact the map so that all drum pads still exist, but without

their previous layout. Otherwise, say if you have 30 pads assigned, but the new map size is 3x3, then

Xequence will ask to discard those drum pads that cannot fit in the new size.

If you select a larger size, then existing pads will stay centered at the bottom, and new grid cells will be added at the top and/or to the left/right.

Editing the map

To start editing a map, activate Edit mode by tapping the "Edit" toggle at the bottom.

You can then:

Tap any pad or empty cell to edit or add a pad.

Each pad has a title and a note / octave. When selecting the drum note, Xequence will actually send the selected note via MIDI so you can find the correct drum without reading manuals. You can also clear a pad if you do not want anything to trigger at that cell position.

Tap and hold a pad to move it around. If you drop it on an already existing pad, the pads will swap positions.

Process ("Magic Wand") menu

This menu offers various features that affect the entire drum map:

Clear: Clears all pads, leaving an empty drum map.

Compact: Moves all assigned pads to the bottom, starting from the left and then going up in rows.

Fill: Can be used to automatically generate drum pads with ascending notes, starting from the selected root note (the entire existing drum map will be overwritten).

Flip H/V: Flips (mirrors) the drum map. Useful for changing between right-handed and left-handed use, etc.

Drum map presets

Xequence comes with a selection of preset drum maps that have the corresponding notes, labels and layout for various popular drum machines or synths (this will be enhanced in future updates).

Tap the "Maps" button in the lower left corner to choose a preset.

You can also save your own presets, which will be available in all Xequence projects. Just take an existing drum map, edit it as desired, and then tap "Save" in the Maps menu (you will be prompted for a name). You can also delete saved maps, and filter the list of maps.

To rename a map, just "Save" it under a new name, and then delete the old map.

Exchanging drum map presets between devices

Drum maps are stored in Xequence's Documents folder as ".xeqdrums" files. These can easily be copied between your various devices using the iOS Files app or iTunes File Sharing and will be automatically detected and added to the "Maps" menu by Xequence.

Pianoroll

Double-tap a part to open up the Pianoroll editor.

This editor lets you draw or edit notes (move, change lengths, transpose, etc.), their velocities (loudness), and controllers (CCs). Selecting and navigating around the view works the same as in the Arranger.

When you're done editing, just tap the checkmark button at the bottom right to exit the editor.

Grid

The editing grid can be changed by tapping on the button with the grid icon in the bottom toolbar. When moving notes or changing their length, movement will be constrained to this grid (for example, if it is set to "16", notes will move by 16th notes, and the length of notes will change in increments of 16th notes).

The "Rel" (relative) toggle changes how notes snap to the grid: normally, Xequence will make sure that all notes always stay on the selected grid no matter what. However, in "Rel" mode, notes will actually move in grid size increments, but not necessarily snap to the grid. So, for example, if you have a note that starts one 16th note away from the beginning of the part, and you have the grid set to "4", if you now move the note one increment to the right, it will actually end up one quarter note plus one

16th note from the beginning, not one quarter note.

Editing velocities and controllers

Tap the "note" button at the bottom left. A menu will pop up that shows all data types that can be edited:

Notes (note icon): The most often used mode, for drawing and editing notes themselves.

Velocities (down arrow icon): When tapped, this brings up the velocity editor. All notes that are currently selected (or all of them, if none were selected) will be shown as vertical bars. The higher bar, the higher the velocity. The usual editing tools can be used to draw or change velocities. If you have several notes that overlap at the same position (for example, in a chord), and you want to edit the velocity of only one of them (say, the top-most note), then just select it before entering velocity mode, and only that note's velocity will be shown.

Controllers (name and number): All controllers (CCs) that have been assigned to the current instrument can be edited here, including drawing, moving, and scaling the curves. Note that the only

"real" data is the thin bright lines. The "bar" that follows it is just a visual aid so that it is easier to see how long the last "real" event affects the controller value (namely, until it is again changed by next event).

Notes outside the current scale or drum map

When editing a part, only those notes (and "mini keyboard" keys) which are part of the instrument's scale are shown (for drum instruments, the equivalent applies). If you switch to another scale / drum map after already having recorded or drawn notes and the new scale / map doesn't contain all of the pitches of the existing notes, a warning dialog ("Wrong scale") will pop up, offering you to disable the scale (or you can switch to a different scale that does contain all used pitches).

Scale / key changes mid-song

You can of course use different keys or scales throughout the song, as the scale and key are merely an

"input mode" in the keyboard screen. However, you may encounter the aforementioned "Wrong scale" warning when opening the Pianoroll editor and some of the pitches in the edited part are not contained in the scale that is currently selected in the instrument (the scale selected in the keyboard screen is remembered per instrument).

To avoid having to switch scales and keys all the time for editing, you can just create one instrument per scale / key, and set each of them to the same MIDI destination and channel, but choose different scales / keys in the keyboard screen. For each scale / key you want to use throughout the song, also create a track and assign it to the matching instrument, and then just make sure to use the correct track for each scale / key. You can also name the instruments or tracks accordingly (for example,

"Bass E Maj" and "Bass D Maj") so that you see at a glance which track to use for recording.

Transposition

When transposing selected notes using the vertical handle, transposition is always scalar, i.e. all recorded notes always stay inside the current instrument's scale. For example, when you transpose one step upwards, one note might get transposed 1 semitone, while another might get transposed by 2, always ensuring that all transposed notes are still part of the scale.

Drum editing

If the instrument played by the part being edited is in "Drum map" mode, the corresponding drum names will be shown on the left instead of the note names.

Metronome, Tempo and Time Signature

Metronome

Xequence has a very flexible Metronome with two basic modes:

Audio: Audible clicks are generated and routed to the current default output. You can change the volume by tapping on the "Volume: 50%" button.

MIDI: In MIDI mode, the metronome does not produce a sound (click) by itself. Instead, it just sends

MIDI notes to a MIDI synth of your choice (you can select the metronome destination and channel in the

Settings screen). This gives you maximum flexibility by using another app for generating the metronome sound, which might let you choose different outputs, sounds etc.

Xequence always uses the root key of the current instrument for playing the metronome (if the instrument is in E, it will play E4 for bars and E3 for beats).

Tempo and Time Signature

The slider sets the project tempo in BPM. The "½" toggle can be used to temporarily set the tempo to half the displayed value, which can be very useful during recording in fast (e.g., EDM) music.

The next two dials set the time signature (upper dial

3, lower dial 4 = 3/4). All time signatures should work, but if you find a problem using a particular one, please let us know.

Recording

Press the Record button to start live recording. This will record:

Keys played on the Keyboard screen

Controller movements on the Keyboard screen, no matter by which kind of input mode (slider, motion, key position etc.) they might have been generated

Keys played in or notes sent from other apps if "MIDI

In" is enabled in Xequence's Settings, and the source app is enabled in the "Sources" panel or it is set to "Any"

Controllers sent from other apps. If the current Xequence instrument does not yet have a controller's

CC number set up, it will be added automatically if "Auto-add controllers" is enabled on the Settings screen (a list of detected new controllers will be shown after recording finishes).

Automatic quantization

Recorded notes will be quantized automatically according to the settings in the "Q" menu in the top toolbar (you can choose the "Off" option if you do not want quantization, or if you want to quantize manually later).

Recorded controllers will not be quantized, except if the controller is in "Gate" mode. You can always quantize controllers after recording them by using the "Magic Wand" menu in the Controller editor.

Recording into the Arranger

If you start recording while in the Arranger, or in the Keyboard screen and you previously had the

Arranger open, then a new part will be created on the currently selected track, and all events will be recorded into it. The part will be automatically trimmed, or deleted on stop if no events were recorded.

Recording into the Pianoroll

If you start recording while editing a part in the Pianoroll editor or had the Pianoroll editor open before switching to the Keyboard, then everything will be recorded into the currently open part. No new part will be created.

Recording from multiple MIDI sources simultaneously

Note that it is currently not possible to separate incoming MIDI from multiple sources. All sources will be merged onto the currently selected track.

Count-In and Metronome

If you press Record while Xequence is stopped, the song position will be moved backwards by one or more bars (configurable in the Settings screen) so you have time to prepare. Any events (notes, controller movements) that arrive while in count-in will only be recorded if you are recording into the

Arranger. If you're recording into the Pianoroll, events during count-in will be dropped.

If you enable the "Always during Count-In" option in the "Metronome" section under "MIDI / Recording" in

Settings, then the metronome will automatically be enabled during count-in so that you can "get into the rhythm" even if there isn't anything recorded yet to guide you.

Song loop

The Song Loop feature can be used to play a certain part of the arrangement over and over again. As soon as the loop's endpoint is reached, tt simply rewinds the song position to the loop's beginning. The looping is

"perfect", i.e., no timing offset or jitter when wrapping around.

The loop can be set in various ways:

Selection: If you are in the Arranger, this sets the loop points so that they encompass the currently selected parts. Probably the most used (and useful) option. If you are in the Pianoroll, this sets the loop points so that all currently selected notes or controllers are inside the loop. Very useful for quickly concentrating on a small part of the notes.

Part: If you're editing a part in the Pianoroll, this will set the loop points to encompass that part. Very handy if you just opened a part and decide to work on it more closely, as you don't have to exit, loop, and open it again.

Off: Clears the loop.

Notes about song looping

The loop points are always rounded to the nearest bar, so the length of the loop is always a whole number of bars.

Even if you change the selection later on, the loop points stay the same, i.e., they don't follow the selection.

If you want to loop an arbitrary part of the song (where there are no parts or not exactly where you want the loop), just use the Draw tool to quickly draw an empty part where you want the loop to be, then set the loop to "Selection", then delete the part again.

Copying, linking, and looping parts

Copying and linking parts

Please read this section carefully, as it is central to the way arranging in Xequence works:

Copy: The Copy parts button ("Plus" symbol) creates an independent copy of all currently selected parts, and places it at the end so that the beginning of the first copied part is at the end of the last selected part.

You can keep tapping this button to make various copies, one after another, but see below:

Copy and link: If you use the right button ("Chain" symbol), parts are copied just as well, but the notes and controllers inside them are linked to the original. That means that if you edit any of the copies in the Pianoroll or Controller editor, the original and all copies are also modified, and vice versa. This is probably the more useful option in most cases, as often, when you have a central hook or melody, you want to repeat it throughout the song in various places, but if you later decide to make a modification, it is enough to change one of the linked parts and you do not have to delete all the copies and copy them all over again.

All parts in the arrangement show a number on them, which is like a "group number" in that all linked parts show the same number. This lets you easily see at a glance which parts are linked to others.

Also, whenever you open a linked part in the Editor, a brief message "xx linked" will pop up, informing you of the fact that the edits you're about to do will affect several other parts as well.

Copying several linked parts

If you have several parts selected that share the same data (for example, three parts with number 77), and you use the "Copy" (not "Copy and link") button, then the new parts will be independent of the originals, however, they do still maintain their "linkedness" between each other. So, the three copied parts might then, for example, all have the number 78.

If you would like all of the copies be independent of all the others, see below.

Unlinking parts

If you later on decide that you do want to independently edit a linked part, you can select it and then choose "Unlink" from the "Magic Wand" menu. This will make all selected parts independent of all the others. For example, if you have three parts selected that all have the number 152, after using "Unlink", they might have the numbers 153, 154 and 155, so they are all independent.

Global clipboard

The global clipboard can be accessed by tapping the

"+" button at the bottom left to open the Clipboard and Insert menu.

This clipboard works even across projects so you can copy and paste parts from one project into another.

The following options are available:

Copy: Copies all currently selected parts into the clipboard. The selection can span multiple tracks.

Paste ("plus" symbol): Pastes all parts on the clipboard at the current song position (nearest bar).

The new parts are independent copies of the original parts and do not change when the originals change. If the parts on the clipboard are from the same project, they will be pasted to the same tracks they came from. If they are from a different project, they will be pasted onto the currently selected track and below. If not enough tracks are available, they will be created.

Paste ("chain" symbol): Same as above, however, if the parts on the clipboard are from the same project, the pasted parts will be linked to the original parts so modifying the originals will also change the new copies.

Looping parts

Parts in Xequence each have an invisible "Loop" switch which can be turned on or off for one or more parts by selecting them and then choosing "Loop on" or "Loop off" from the "Magic Wand" menu.

When a part's "Loop" switch is on:

The part repeats itself as if you had used the "Copy and link parts" feature on it various times.

It stops repeating either where it bumps into another part on the same track, or at the end of the song (which Xequence considers to be the end of the last part plus 64 bars). If it encounters another part midway through itself, it will be cut off.

The looped copies can't be selected (they're not "real"), however, they can be edited in the Pianoroll by double-tapping them (note however that all repetitions are still linked to the original: making changes to the notes or controllers in one of them will change all the others).

Usage examples

Looping parts is a very powerful feature, for example:

If you have a hihat line that continues the same through the entire song anyway. Just place one part at the beginning, select it, and tap "Loop on". No need to copy.

If you have a very short segment (i.e., 1 bar) of notes or controllers that you want to repeat many times, but don't want to keep tapping the "Copy parts" function till hell freezes over.

If you want to make changes to the rest of the arrangement later, but do not want to keep deleting and cloning repetitive parts in the process. Looped parts automatically adapt to the arrangement.

If you later on decide you want only a shorter segment of your idea to loop, you can just shorten the

"source" (original) part, and all the repetitions will also shorten (but still stay adjacent to each other).

If you want to try various ideas while recording, but do not want to "overwrite" your ideas on each

Song Loop iteration: Instead of using the Song Loop, just select those parts that you want to hear during recording, set them to "Loop on", and then keep recording linearly.

Ending the loop

As mentioned, looped parts stop looping when they hit another part on the same track. So, if your hihat line is supposed to end at some point, just draw a short empty part there, and you're done (see the red part in the image).

Converting loops to parts

If you decide you want to make changes to the repeated parts (delete some of them, move them, or edit the notes only in some of the parts), then you can use "Convert loops to parts". This will convert the loop into actual (but still linked to the original) copies. You can now move them around, delete some of them, etc.

Note, however, that these parts are still linked to the original, so editing the notes inside them will modify all converted parts and the original. If you want to change the data of only one single part of them, select it and then choose "Unlink" from the "Magic Wand" menu, which will make it a truly independent copy (it will also get assigned a new number, visible on the part).

MIDI Input and Thru

MIDI In

Xequence can receive MIDI data from other apps or hardware keyboards / controllers. This means that you can, for example:

Use a hardware keyboard instead of the integrated on-screen keyboard

Record notes from an Arpeggieator app like

StepPolyArp, or generative music tools like NodeBeat, into Xequence's Pianoroll

...and many other uses

For this to work, you would first need to enable MIDI Out in the other app, and, depending on the app, choose Xequence as the destination for MIDI Output. You might also need to enable "Background audio", again depending on the app, so that it stays active in the background when you switch back to

Xequence. If you use a class-compliant external keyboard or controller, it also depends on the particular device, but many work out of the box.

In Xequence, go to the Settings screen ("..." at the top left), and in "MIDI / Recording", enable "MIDI

In", and make sure the next button says "Sources: Any".

Now try sending notes or controllers from the other app or device. The "MIDI In" button should flash when you press keys or move controllers in the other app or device. You can also try to record notes or controllers into the Arrangement or Pianoroll, and check if they have been recorded correctly.

If you don't get any blinking or notes / controllers being recorded, try selecting the MIDI Source explicitly:

Explicitly setting the MIDI In Source

Some apps or devices need a different approach and you have to enable them explicitly as inputs in

Xequence.

To do that, go to the Settings screen again, and tap on

"Sources: Any". In the popup, your other app or device should have a button (which is deactivated). Activate it, and now again try sending notes from the other app or device and see if the MIDI In button blinks and events get recorded.

If this doesn't work either or your other app or device doesn't appear in the "Select MIDI sources" popup, please drop us a mail so we can investigate further!

Recording controllers (CCs) from external sources

Xequence can also record controller (knob, etc.) movements from external apps or devices. Controllers whose CC number has not yet been set up on the instrument of the track being recorded to will be added automatically to the instrument if "Auto-add controllers" is enabled on the Settings screen.

If that doesn't make any sense just yet, read on:

The screenshot shows an instrument that has controllers

(CCs) 74 and 7 set up. As far as Xequence is concerned, only those controllers exist which are actually set up in an instrument. However, as long as "Auto-add controllers" is enabled on the Settings screen,

Xequence will detect each new incoming controller that has not yet been set up on the instrument of the track being recorded to, and add it automatically.

A list of all newly detected controllers will be shown after recording finishes.

If you disable "Auto-add controllers", then "unknown" incoming controller data will simply be discarded.

MIDI Thru

MIDI Thru is a feature that lets you use Xequence as a central "hub" for your MIDI setup.

If you enable MIDI Thru, all MIDI notes and controllers that are received by Xequence are immediately forwarded to the instrument on the selected track, and thusly, to the MIDI destination configured in that instrument.

This means that if you setup your MIDI source (hardware MIDI keyboard, Arpeggiator app, etc.) to only send MIDI to Xequence and not to the actual synth apps or external synths, while enabling MIDI Thru in Xequence, you will never have to change any MIDI connection again, because your keyboard,

Arpeggiator etc. will always automatically play the instrument on Xequence's selected track.

Needless to say, Xequence will of course also record the notes received as well.

So, to recap:

Setup your MIDI source (hardware keyboard, Arpeggiator app, generative music tool etc.) to only send its MIDI Out to Xequence.

Enable MIDI In in Xequence, and either enable Sources: Any, or disable it and select your MIDI source explicitly, whichever works.

Enable MIDI Thru

Now, your external keyboard or app acts as the "Master controller" for all of the other synths/instruments configured in Xequence. Select a different track, and your keyboard plays that track's instrument. Boom!

MIDI File Import and Export

Xequence can import and export standard MIDI files (.mid), including notes, controllers, track names, program changes and information like BPM and time signature.

Importing a MIDI file

To import a MIDI file:

Put it into Xequence's Documents folder using the

Files app or iTunes File Sharing.

Go to the Settings screen ("..." button at the top left) and show MIDI files by enabling the MID button.

Select the file and tap "Load".

You can change various options for the import:

Controllers: If enabled, import controllers like

Volume, Pitch, Modulation, etc.

Separate track for controllers: If enabled,

Xequence will import the notes from each track in the

MIDI file onto one arranger track, and all controllers onto a separate arranger track. So, if the MIDI file has

8 tracks, 16 tracks will be created in Xequence. If you would like all data from each MIDI file track to be in a single part on a single track in Xequence, disable this option.

One track per controller: Xequence can also import each controller onto its separate arranger track, so that for example, Volume, Modulation and Pitch would each get their separate arranger track (in addition to notes). This can quickly yield a huge number of tracks as many MIDI files use a large amount of separate control change numbers. For example, when importing a MIDI file with 10 tracks, each with automation for Volume, Pan, Pitch, Effect

1 and Sustain, 60 tracks would be created in Xequence (one for notes and 5 for controllers, for each

MIDI file track).

Program changes: Import program changes as well. These are often a vital part of the data in MIDI files as most files are tailored towards General MIDI synths (like, for example, Roland Sound Canvas), with each of the program numbers calling up a standardized sound (for example, program 0 is always

"Piano").

Split by markers: Many MIDI files contain markers that separate the song into different parts (like verse, chorus etc.). Xequence can use these markers to split the parts it creates during import (note that MIDI files do not contain any other kind of information for splitting up the data into parts, so you may end up with one very long part for each track. This is a limitation in the MIDI format and not in

Xequence).

MIDI Destination for created instruments: Xequence automatically creates one instrument per

MIDI file track. It can automatically assign each of those to the destination you select here, which could for example be an app that is General MIDI capable (one example is Roland Sound Canvas).

Channels are also assigned automatically based on the information in the MIDI file.

When you tap "Import", Xequence loads the MIDI file as a new project (it does not append it to the currently open song). This way, you can first clean up the imported data as necessary, and then use

Xequence's Global Clipboard (described earlier in this manual) to copy and paste any number of parts from any number of tracks into another project, as desired.

Separation into parts

Note that the MIDI file format does not support splitting the data into parts, so most of the time, you will end up with one long part per track after import. Xequence tries its best to trim the created parts at the beginning and end and also split it according to "Markers" potentially stored in the MIDI file.

However, some manual cleanup will be required.

Exporting a project as a MIDI file

The currently open project can be exported as a MIDI file. For each of the project's instruments, one MIDI file track will be created. Only instruments which actually get used in the project (i.e., which have corresponding tracks with events on them) will be exported.

The following options are available when exporting:

Include track delay: When enabled, the "Delay" setting of each arranger track will be honored when exporting. Otherwise, the exported events will have the exact times as they appear in the pianoroll or controller editor.

Include track swing: Same as above, but applies to the "Swing" setting.

Only selected parts: When enabled, only the currently selected parts will be considered. Parts on all other tracks (and their corresponding instruments) will be skipped, and the resulting MIDI file will only contain the time range encompassed by the selection.

After export, the file will be placed in Xequence's "Documents" folder and can be accessed through the iOS Files app for use in other apps.

Managing files

Using the Files app

If your device is running iOS 11 or later, you can access and manage all of Xequence's files with the

Files app from your home screen.

After launching the Files app, tap on "On My iPhone" or "On My iPad", and then on "Xequence". You can freely move, copy and rename files / projects locally or between your devices.

Using iTunes File Sharing (iOS 10)

If your device is running iOS 10, you will have to use iTunes to manage your files / projects:

Connect your device to iTunes

Click on the device icon in iTunes (top left)

In the sidebar, select "File sharing"

On the right, in the "Apps" list, scroll down to Xequence (you may need to scroll down both the main window and the list itself)

On the far right, a list of all your Xequence files / projects should appear. You can now save them as a file ("Save to..."), or add files / projects you've saved earlier by clicking "Add..."

Please note that the user interface inside iTunes changes frequently, so we cannot guarantee that these instructions are always up to date.

Demo project

Xequence includes a Demo project with the fitting name "Alpha" (we actually used it during alpha testing!) which you can load from the "Project" tab in the Settings screen ("..." at the top left) so that you can quickly get a feel for the possibilities and handling in Xequence.

Of course, if you hit play, you won't hear anything or not what we intended, as Xequence doesn't have built-in synths.

However, the entire project was produced using sounds from Korg Gadget, and we have put the corresponding Gadget project online, which you can download, load into Gadget, and then actually fully work with the demo project.

The Gadget project is at: http://seven.systems/xequence/downloads/KorgGadgetDemoProject.zip

Loading the demo project into Gadget

Unfortunately, this is slightly complicated, however, it works!

Download the ZIP file

Extract the ZIP file, it will contain a single folder named "Alpha (Demo Edit).gdproj2"

Launch iTunes

Connect your iPhone / iPad

Click on the device icon in iTunes

Scroll down to the "iTunes File Sharing" section

Select Gadget

Click "Add..." in the bottom right corner

Navigate to where you extracted the ZIP file, and choose "Alpha (Demo Edit).gdproj2"

Launch Gadget on your iPhone / iPad

Tap on the little document icon in the upper left corner and then "Open"

"Alpha (Demo Edit)" should appear in the list. Tap it

Launch Xequence

Load "Alpha (Demo Edit)"

Press Play.

You should now actually hear the project as it was intended to sound.

Note: The Gadget project uses some synths which are In-App Purchases, so if you haven't bought those, you might have a few drums / sounds missing.

Example setups

Using just a single synth app: Poison-202

Launch Poison-202, and in its "Settings" menu:

Set "Virtual Midi In Port" to "Enabled".

Set "Background Audio" to "Enabled".

In Xequence, create a new instrument.

Tap "Select MIDI Destination", and then "Poison-202".

Create a track and assign it to the instrument, as described in the "Arranger" chapter.

Using a multi-timbral app with multiple MIDI channels and sounds: Korg

Gadget

Let's say you want to use three instruments from Gadget in Xequence, on three separate tracks:

Launch Gadget, and then:

In its settings menu (cogwheel), set "MIDI Input" to "Advanced"

Open "Other settings", you will be dropped into the system "Settings" app

Enable "Background Audio" there, and return to Gadget

Create three instruments, and for each, tap on the "All" button at the bottom left, and then in the

"MIDI Input" menu, choose "Gadget (Virtual Port)" as the Source

In "Ch. 1", assign each instrument its own separate channel, i.e., 1 to 3.

Back in Xequence, create three instruments

Set each instruments' MIDI Destination ("Select MIDI

Destination") to "Gadget"

The channels should be assigned automatically, but if not, assign the same channels you have assigned in

Gadget (1 to 3).

Create tracks and assign them to the instruments, as described in the "Arranger" chapter.

Using an Audio Unit Host to control multiple AU plugins: AUM

Let's say you want to use three separate instances of Poison-202 in AUM, on three separate tracks:

Launch AUM, and then:

Create three AUM channels

Tap the menu button at the upper left (=)

Under MIDI SOURCES, select "'AUM' Destination".

Below the "CHANNEL FILTER" menu, tap "NONE".

Now under "CHANNEL FILTER", select the MIDI channel you want to use (1 for the first AUM channel you created, 2 for the second, 3 for the third).

Back in Xequence, create three instruments

Set each instruments' MIDI Destination ("Select MIDI Destination") to "AUM"

The channels should be assigned automatically, but if not, assign the same channels you have assigned in

AUM (1 to 3).

Create tracks and assign them to the instruments, as described in the "Arranger" chapter.

Using an Arpeggiator app: StepPolyArp

This will let you use StepPolyArp to play and record any Xequence instrument, including recording the arpeggiated notes:

Launch StepPolyArp, tap its settings menu (the MIDI

Icon at the top right), and under "Midi out", select

"StepPolyArp Midi out" (not "Xequence Destination"!

Yes, we know (as always)).

Back in Xequence, go its settings menu (the "..." icon at the top left)

Switch to the "MIDI & Recording" tab and enable both

"MIDI In" and "MIDI Thru"

Tap "Sources: Any" (it may also say "Sources: 1" or similar), disable "Any" (if enabled), and enable

"StepPolyArp".

You can now go back to StepPolyArp, and whichever track is currently selected in Xequence, that track's instrument will automatically be played by

StepPolyArp, and its notes recorded, if you tap the

Record button.

Bonus tip: Syncing StepPolyArp to

Xequence

You can also use Xequence's MIDI sync feature to have StepPolyArp automatically play in time with

Xequence when you press keys in StepPolyArp, so that recordings are always in perfect sync.

To do that:

Go to the Instruments screen (MIDI Icon at the top left), and add a new instrument. Choose

StepPolyArp as the MIDI destination (it won't be used as a real instrument: you only add it so that

Xequence is aware of it and can sync it).

Enable "Send Sync" and choose "Relative" mode.

In StepPolyArp, go to the MIDI menu (MIDI icon in top right corner), then to "Sync", and enable

"Follow song position".

StepPolyArp will now acquire the BPM and relative song position from Xequence whenever you hit play, and play in sync with it.

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement