WAGOframe 取扱説明書

WAGOframe 取扱説明書

WAGOframe 取扱説明書

初版 2008 年 3 月 31 日

ワゴジャパン株式会社

1

1. 序説

FDT(Field Device Tool)はフィールド機器と制御システムとの間でデータを交換するためのイン

タフェース仕様で、ベンダやフィールドバスの種類に関わらず使用できます。

FDT はフレームアプ

リケーション、デバイス

DTM(Device Type Manager)、通信 DTM から構成されます。

−フレームアプリケーションは異なるベンダーのデバイス

DTM を統合することができます。また、

システム全体で一貫したコンフィグレーションを保証し、マルチユーザオペレーションならびに

クライアント

/サーバ・オペレーションを可能にします。画面上はメニューバー、ツールバー、ナ

ビゲーションツリーなどがあります。

WAGO はフレームアプリケーションとして WAGOframe

を用意しています。

−デバイス

DTM は機器メーカーが提供するソフトウェアコンポーネントで、機器固有のアプリケ

ーションソフトウェアが組み込まれています。プラグイン・ソフトウェアで、インストール後

FDT フレームで開き、実行します。ユーザはデバイス DTM を通してフィールド機器とやり取り

を行います。デバイス

DTM にはパラメータ設定とコンフィグレーションを組み込むことができ

ます。

−通信

DTM は通信の機能を提供するものです。ホストシステム固有のドライバとデバイス DTM

の間のインタフェースとなるものです。

2. インストレーション

1)

WAGOframe のインストール

以下の

CD を PC(Windows XP、Windows 200、Windows NT4.0/SP6)にインストールします。

759-370:WAGOframe V.1.0.1.0

手順: language(英語にする)を選択−WAGOframe Version 1.0.1.0 をクリック−Choose Setup

Language 画面で[U.S.]を選択後画面の指示に従うことにより WAGOframe がインストールされ

ます。

*必要に応じて

.NET Framework を先にインストールすることになります。

2)

DTM のインストール

使用

Device に応じた DTM をインストールします。

例:JUMPFLEX 用 DTM ファイル(=759-380)を WAGO Global サイトからダウンロードし

ます。

手順:

Service-Downloads-AUTOMATION の順にクリック後、759-380 ZIP ファイルをダウン

3. アプリケーション開始

1)通信ケーブルの接続

デバイスとの通信に用いられる通信手段(

RS232C、Profibus など)に応じて、PC とデバイス

間を指定された通信ケーブルで接続します。

2)アプリケーションの開始

WAGOframe アイコンをクリックするとデバイスの数に応じて以下のモードの選択画面が現れ

ます。

Point to Point Mode:1 個のデバイス、RS232C 経由

Expert Mode:複数のデバイス、フィールドバス経由

ここで、いずれかのモードを選び

Next ボタンを押します。

2

4. Point to Point Mode

1)

Action Section ダイアログ上で以下の選択画面が現れます。

Automatic device selection(online)=PC に接続した全てのデバイスを自動検出する

Manual device selection(offline)=デバイスカタログからデバイスのタイプを選ぶ

Open file=既存のファイルを開く

ここでは

Manual device selection を選択し、Next ボタンを押します。

2)以下のような

Communication Interface Selection 画面が現れます。

3)上記画面の

1. Select communication protocol リスト上で例として WAGO Service Jumpflex

を選び、

Configure Interface ボタンを押します。

* 対象のデバイスが見つからない場合は、当該

DTM をインストール後、Update ボタンを押

してデバイスカタログを更新します。

4)以下のダイアログが現れます。

左画面には選択した通信用

DTM で実行可能な機能が表示されます。右中央画面はパラメータ

設定用で、白抜きのボックスが変更できる箇所です。変更後

Apply ボタンを押します。ここで

は例として通信パラメータの設定画面が表示されています。

3

上記画面で

OK ボタンを押すと Communication Interface Selection 画面に戻ります。

5)

Next ボタンを押すと次の画面が現れます。

表示されたリストから実際に接続されたモジュールを選び

Next ボタンを押します。

6)

Device Address Setting ダイアログが現れますので、必要なアドレスを入れます。デフォルト

では

’0’で、ここではデフォルト値を利用します。

Next ボタンを押すとアドレスが設定され、’Set device DTM online?’のメッセージが出ますの

Yes ボタンを押します。次に’Upload device parameters?’メッセージが出ますので Yes ボタ

ンを押します。

7)以下のようなダイアログが現れます。

これは左画面において

Input を選択した画面と等価です。

4

8)左画面において

Analog output を選択すると次の画面になります。

10)前期各画面にてデバイス内の現在の設定パラメータ値を読み出すときは、

Read ボタンを押

します。一方、パラメータ値を変更したいときは、白抜きのボックスにおいて変更値を入力し

た後

Write ボタンを押すと、値が変更されます。

11)前記ダイアログの左画面にて

Measured value を選択すると、次のような画面が現れ、デバ

イスの現在値が表示されます。

5

12)前記ダイアログの左画面にて

Device data を選択すると、以下の画面が現れ、各パラメータ

を設定することができます。

6

Mode

このモードを選択すると、前回終了したときの状況に応じて以下のような画面が表示されます。

−左画面に

Network View が、右画面に Device Catalogue が表示されます。各画面は右上の

ピンマークをクリックすることにより閉じたり、再度開いたりすることができます。

Device Catalogue の中の Device Types、Vendors、Groups、Protocols において各項目また

は下位レベルの項目を選ぶことにより、表示されるデバイス名を絞ることができます。

−上記画面は以降のような各部分画面から構成されています。

① メニューバー

2)各メニューの説明」を参照。

② ツールバー

Network View:ツリー構造でプロジェクトファイル内のデバイスを表示します。

④ メッセージウィンドウ:

FDT モニタまたはエラーログのタブを選択することにより各々の

内容を表示します。

FDT モニタはアプリケーションと操作中 DTM の間の動作を監視しますのでトラブルシュ

ートに使用できます。

⑤ ステータスバー:ユーザに対して追加情報を提供します。

Child Window:デバイス固有のウィンドウ(DTM ユーザインタフェース)

Device Catalogue:右側にデバイスリストおよび左側にブラウザツリーが表示されます。

デバイスリストにはデバイス名、バージョン、日付、ベンダ名が入ります。

(2) 各メニューの説明

) File メニュー

New

新規のプロジェクトファイルを作成します。

Open

既存のプロジェクトファイルを開きます。

Save

現在作成中のファイルを上書き保存します。

7

Save As

現在作成中のファイルに名前をつけて保存します。

Import / Export

このメニュー上で以下のプルダウンメニューが出ます。

Import:MyNetwork を選択し Import をクリックすると、Import 元のファイルを要求す

る画面が出てきます。ここでファイル名を入力することにより

Import されます。

Export:MyNetwork 内の指定デバイスを選択し Export をクリックすると、以下のポッ

プアップ画面が出てきますので、指定のデータ項目を選んだ後

OK を押します。Export

先を選びファイル名を入力することにより、指定データが

Export 先に転送されます。

Info

プロジェクトに関したコメントを入力し、

OK を押せば内容を保存することができます。後

ほど必要に応じて

Info メニューをクリックし、読み出します。

Recent Files

最近使用したファイルにアクセスすることができます。

Exit

プロジェクトを閉じアプリケーションを終了します。

) Edit メニュー

Cut

選択項目を切り取りクリップボードに保存します。

Copy

選択項目をコピーしクリップボードに保存します。

Paste

クリップボードの内容を貼り付けます。

) View メニュー

View メニュー内の各項目に対し、チェックマークを ON/OFF することにより各項目の表示

/非表示を選択できます。

Full Screen

フレームアプリケーションをフルスクリーンで表示

Network View

Network View 画面の表示

Device Catalogue

Device Catalogue 画面の表示

Statusbar

Statusbar の表示

Error Log

Error Log タブの表示

FDT Monitor

FDT Monitor タブの表示

) Device メニュー

選択されたデバイスに適用できる一連の操作です。そのデバイスの状態に応じて動作が変わ

ります。例えば

”Go Online”メニューはそのデバイスがオフラインのときのみ適用可能です。

メニューの数はデバイスの種類やユーザのレベルによって異なります。

8

Add

Network View においてデバイスツリーに新しいデバイスを追加するときに用います。指定

したデバイスは選択した場所の子ノードとして追加されます。デバイスの追加はメニューか

Add をクリックするか、または Device Catalogue から指定デバイスをデバイスツリーに

ドラッグ&ドロップすることによっても実行できます。

例:

4)Add の操作例を参照。

Remove

デバイスツリーから指定デバイスを削除したいときに用います。デバイスを選択後

Delete

キーを押すことによって実行します。

Rename

名前を変更したいデバイスを選択し、右クリック後

Rename を選んでから内容を変更します。

Go Online

デバイスがオフラインのときに有効です。ツリー内のデバイスを選択後メニューから

Go

Online をクリックすると、文字が斜体になりデバイスはオンラインとなります。

Go Offline

デバイスがオンラインのときに有効です。ツリー内のデバイスを選択後メニューから

Go

Offline をクリックすると、文字が標準になりデバイスはオフラインとなります。

Upload Parameters

デバイスを選択後

Upload Parameters をクリックするとデバイス内のパラメータが PC に

転送されます。オフラインのときは自動的にオンラインになります。

Download Parameters

デバイスを選択後

Downpload Parameters をクリックするとプロジェクトファイル内のパ

ラメータがデバイスに転送されます。

Offline Parameter

デバイスを選択後メニューから

Offline Parameter をクリックすると、Child Window が開

き、オフラインでデバイス用のパラメータの設定ができます。変更されたパラメータはダウ

ンロードするまでは

PC 内にのみあります。この機能の有無は DTM の種類によって異なり

ます。

Online Parameter

デバイスを選択後メニューから

Online Parameter をクリックすると、Child Window が開

き、オンラインで直接デバイス用のパラメータの設定ができます。この機能の有無は

DTM

の種類によって異なります。

Compare

2 つのデバイス間のパラメータデータを比較するのに用いられます。この機能の有無は DTM

の種類によって異なります。

Configuration

DTM レベルでデバイスを選択後メニューから Configuration をクリックすると Child

Window が開き、Interface Setting 画面内で通信パラメータの設定ができます。この機能の

有無は

DTM の種類によって異なります。

Observe

デバイスの状態をモニタするのに用います。この機能の有無は

DTM の種類によって異なり

ます。

Diagnosis

デバイスの診断テストを実行するときに用います。この機能の有無は

DTM の種類によって

異なります。

Additional Functions

デバイスに応じて追加機能がある場合にメニューが出てきます。この機能の有無は

DTM の

種類によって異なります。

Channel Functions

デバイスによってはチャンネル単位の機能のあるものがあり、この場合チャンネル用のメニ

ューが出てきます。

Import / Export

このメニュー上で以下のプルダウンメニューが出ます。

Import:MyNetwork を選択し Import をクリックすると、Import 元のファイルを要求す

9

る画面が出てきます。ここでファイル名を入力することにより

Import されます。

Export:MyNetwork 内の指定デバイスを選択し Export をクリックすると、以下のポッ

プアップ画面が出てきますので、指定のデータ項目を選んだ後

OK を押します。Export

先を選びファイル名を入力することにより、指定データが

Export 先に転送されます。

Info

デバイス固有の情報(

Device Type Info、DTM Info など)が得られます。

) Tools メニュー

ユーザアカウント管理と一般オプションを設定・変更するのに用いられます。

Customize

アプリケーションで使用する

Toolbars や各 Command の表示/非表示の設定ができます。

Options…

メニューから

Options…を選択すると以下のダイアログが現れます。

General Options

General Options の左側+をクリックすると、Protected Mode と Language が現れます。

Protected Mode を選択すると以下のダイアログが現れます。アプリケーション作業中

にシステムが停止してしまった場合は自動的に

Protected Mode に移行します。

Protected Mode では、システムダウン前の DTM の内容がメーカーの調査用に保存され

ます。

10

ここで

”Detect accidental shutdown”をチェックすると、システムダウン後に Protected

Mode でアプリケーションを再開するタイミングを設定することができます。

Language をクリックすると、English または German を選択できます。

User accounts / passwords

User accounts/password の左側+をクリックし、Settings を選ぶと以下の画面が現れま

す。ここではユーザのレベルに応じた password の設定ができます。この機能の操作がで

きるのは

Administrator だけです。

−パスワードを変更したいユーザの欄にチェックを入れ、

Change password を押すと新

規または変更後のパスワードを入力できます。

11

New Password に新規パスワードをいれ、確認欄にも同じパスワードを入れ OK を押す

と設定されます。

−この後、次回

WAGOframe を立ち上げたときパスワード入力画面が出てきますので、作

業するユーザ名を選び、対応するパスワードを入力することによりアプリケーションがス

タートします。

−ユーザの種類としては以下のようなレベルがあります。

Observer:現在の作業内容を監視することのみ許されます。

Operaor:現在の作業内容を監視かつ管理することができます。デバイスの状態をチ

ェックし、デバイスが正常に動作するように値を修正できます。診断、ステータスの

監視、パラメータの変更などができます。

Maintenance Engineer:必要なメインテナンス操作が全てできます。例えば、デバイ

スの交換、設定、キャリブレーション、調整などが挙げられます。パラメータのダウ

ンロード、オンライン

/オフラインでパラメータの修正、デバイス固有のオンライン操

作、処理終了後に全パラメータをアップロードすることなどができます。

Planning Engineer:このレベルのユーザはスペシャリストに属し、全プロジェクト

を管理します。アプリケーションやインストールしたデバイス全てにアクセスするこ

とができます。

Administrator:エンジニアリング環境内で管理的な操作ができる権限があります。

Administrator のみが User Accounts の操作を行うことができます。

Tool Mode Assistant

通信用ハードウェアのパラメータを構築したり、デバイスの検出、選択などをするのに用

いる

”Tool Mode Assistant”機能の設定を行います。

Tool Mode Assistant の左側+をクリックすると Tool Mode Selection、Read Device、

Select Device、Open File が現れます。

Tool Mode Selection:

Tool Mode Assistant が動作する以下のモードの選択を行います。

Always ask at program start

−Point to Point Mode

−Expert Mode

Read Device:

Tool Mode Assistant の中で Read Device が行われるとき、以下の項目に関する動作を

選択できます。

Device Selection:デバイスが 1 個だけ検出された場合 Device Selection ページを表示

するかどうかを設定します。

Address Editing:Set Device Address ページを表示するかどうかを指定します。

Parameter Upload:デバイスからパラメータを取得するかどうかを指定します。

Select Device:

Tool Mode Assistant の中で Select Device が行われるとき、以下の項目に関する動作を

選択できます。

Address Editing:Set Device Address ページを表示するかどうかを指定します。

Connect Device:選択したデバイス DTM をオンラインにするかどうかを指定します。

Parameter Upload:デバイスからパラメータを取得するかどうかを指定します。デバ

イス

DTM がオンラインになっているときのみ可能です。

12

Open File:

Tool Mode Assistant の中でプロジェクトファイルが開かれるとき、以下の項目に関す

る動作を選択できます。

Connect Device:プロジェクトファイルがロードされたとき、デバイス DTM をオンラ

インにするかどうかを指定します。

Parameter Upload:デバイスからパラメータを取得するかどうかを指定します。デバ

イス

DTM がオンラインになっているときのみ可能です。

Frame Properties

Frame Properties の左側+をクリックすると、Frame Properties と Action KeyStrokes

が現れ、各々の内容を設定・変更できます。

Frame Properties:

以下のダイアログが表示されます。

Shutdown:

Ask On Close−デスクトップを閉じるとき、”Really quit”と聞いてきます。

Layout:

Restore Layout−デスクトップを閉じた後再開した場合、レイアウトを保存し復帰しま

す。

Menu Bar Visible−メニューバーおよびフレームウィンドウ枠を表示します。

Menus and Toolbars:

Show Tooltips−ツールバー・ボタン上にマウスを置いたとき、ヒントを表示します。

Show Keyboard Shortcuts in Tooltips−コマンドのヒントの中にキーボード・ショート

カットを表示します。

Menu Animation−サブメニューを開くのに用いるアニメーションを選択できます。

Reset Layout−メニューバー、ツールバー、ツールウィンドウのレイアウトを最初の形に戻

します。

(3) ツールバーの説明

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

1

New Project:新規のプロジェクトを開きます。

2

Open Project:既存のプロジェクトを開きます。

13

3

Save Project:現在のプロジェクトを保存します。

4

Bar Options:ここをクリックすると、Toolbars 以下の各項目の画面表示を ON/OFF できま

す。

5

Import DTMs:DTM を現在選ばれているツリーのノードにインポートします。

6

Export DTMs:プロジェクト全体の DTM を指定ファイルにエクスポートします。

7

Online/Offline:デバイスに対し接続、非接続を行います。

8

Download Parameters:パラメータを PC からデバイスに転送します。

9

Upload Parameters:パラメータをデバイスから PC に転送します。

10

Device Catalogue view:Device Catalogue の表示、非表示を行います。

11

Help Contents:オンラインヘルプの内容を表示します。

12

Help Index:オンラインヘルプの Index を表示します。

13

Contact support:WAGO サポート部門への送信メールを開きます。

14

Homepage:WAGO ホームページを開きます。

15

Generate Documentation:選択中のノード情報をブラウザに表示します。

(4) Add の操作例

Network View 内の MyNetwork にまだ Device が接続されていない場合

MyNetwork 上で右クリック後、Add をクリックします。

Device のリストが出てきますので、目的の Device Type を選び OK を押すと、MyNetwork

の下にツリー状に付加されます。

例:

Jumpflex を選んだ場合は以下のようになります。

−更に

MyNetwork 内の Device Type 上で右クリック後、Add をクリックするか、またはデバ

イスリストから目的のデバイスを選び、

MyNetwork 内の Device Type 上にドラッグ&ドロッ

プすると、そのデバイスがツリーに追加されます。

14

−上記のツリー内デバイスをダブルクリックすると、デバイス固有の

Child Window が現れま

す。

上図は

Child Window 部分を拡大、他の Window を縮小したところです。

15

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement