C-LOGGER ユーザーズガイド

C-LOGGER ユーザーズガイド
データロガーソフトウェア
ユーザーズガイド
はじめに
このたびは「C-LOGGER」をご利用いただき、ありがとうございます。本ソフトウェアのご使用にあたって
は、以下の「ソフトウェア使用許諾条項」および「注意事項」を必ずお読みください。また、本ソフトウェア
を正しく使用するために、本取扱説明書に書かれている内容は必ずお読みください。
■ ソフトウェア使用許諾条項
以下の各条項に同意される場合に限り、本ソフトウェアの使用を許諾するものとします。また、本ソフトウェアの使
用開始をもって、以下の各条項に同意されたものとさせていただきます。
1.
使用許諾
株式会社コンテック(以下「弊社」といいます。)は、お客様に対し、本使用許諾条項に定める条件のもとで、本
ソフトウェアの非独占的使用権を無償で許諾します。
2.
使用許諾の範囲
お客様は、バックアップ等、本ソフトウェアを使用するうえで最低限必要な本数に限り、本ソフトウェアを複製
することができます。本使用許諾条項で許された場合を除き、本ソフトウェアの全部または一部を使用、複製、
改変、翻案、加工その他の変更をできず、または第三者に貸与または譲渡できません。
3.
著作権
本ソフトウェアおよびマニュアル等の著作権は弊社が所有するものであり、お客様には、この使用許諾条項
により許諾される本ソフトウェアの使用権以外に何らの権利も発生しません。
4.
契約期間
本ソフトウェアの使用許諾は、お客様が本ソフトウェアのご使用を開始された時点から始まります。
5.
保証
弊社は、お客様に対し、本ソフトウェアに欠陥がないこと、その他本ソフトウェアに関して、いかなる保証も致し
ません。
6.
免責
弊社はいかなる場合も、本ソフトウェアに関連して生じた、お客様の逸失利益、特別な事情から生じた損害
(損害発生につき弊社が予見し、または予見し得た場合を含む)および第三者からお客様に対してなされた損
害賠償請求に基づく直接または間接の損害について、事由の如何を問わず一切責任を負いません。
7.
契約の解除
お客様が本使用許諾条項のいずれかに違反したときは、直ちに契約を解除し、本ソフトウェアおよびその複
製物をすべて破棄するものとします。
8.
その他
本ソフトウェアを日本国外に持ち出す場合には、日本国の輸出管理規則を遵守するものとします。
本ソフトウェアが実際に使用される国の如何に関わらず、本契約には日本国の法律が適用されるものとしま
す。
■ 注意事項
・
本書の内容の全部または一部を無断で転載することは、禁止されています。
・
本書の内容に関しては、将来予告なしに変更することがあります。
・
本書の内容については万全を期しておりますが、万一ご不審な点や記載もれなどお気づきのことがありまし
たら、お買い求めの販売店、または総合インフォメーションへご連絡ください。
・
MS、Microsoft、Windows、Excelは、米国Microsoft Corporationの各国における登録商標または商標です。そ
の他、本書中に使用している会社名および製品名は、一般に各社の商標または登録商標です。
目次
1 C-LOGGER について ..........................................................................................................................................................6
1−1 概要...............................................................................................................................................................................6
1−2 特徴...............................................................................................................................................................................6
1−3 お問い合わせについて..........................................................................................................................................8
2 ソフトウェアのインストール ................................................................................................................................................9
2−1 デバイスドライバのインストール........................................................................................................................9
2−2 診断プログラムの実行 ....................................................................................................................................... 13
2−3 アプリケーションのインストール ...................................................................................................................... 16
2−4 アプリケーションのアンインストール ............................................................................................................. 16
3 基本操作................................................................................................................................................................................ 18
3−1 C-LOGGER を起動する ..................................................................................................................................... 18
3−2 データ収集を行う .................................................................................................................................................. 19
3−3 データを観測する.................................................................................................................................................. 24
3−4 データを保存する.................................................................................................................................................. 27
3−5 データを EXCEL に転送する ............................................................................................................................ 29
4 画面構成................................................................................................................................................................................ 31
4−1 全体画面 .................................................................................................................................................................. 31
4−2 メニューバー............................................................................................................................................................ 32
4−3 ツールバー .............................................................................................................................................................. 34
4−4 ステータスバー....................................................................................................................................................... 35
4−5 ファイルビューア.................................................................................................................................................... 35
4−6 プロパティビューア ............................................................................................................................................... 37
4−7 YT ウィンドウ........................................................................................................................................................... 39
4−8 数値ウィンドウ........................................................................................................................................................ 41
5 使用方法................................................................................................................................................................................ 42
5−1 デバイスの選択 ..................................................................................................................................................... 42
5−2 収集条件の設定 ................................................................................................................................................... 43
5−3 収集の開始・停止 ................................................................................................................................................. 53
5−4 データの観測.......................................................................................................................................................... 54
5−5 データの保存・読み込み.................................................................................................................................... 56
5−6 印刷............................................................................................................................................................................ 58
5−7 オプション・カスタマイズ ..................................................................................................................................... 61
6 仕様 ......................................................................................................................................................................................... 67
7 付録 ......................................................................................................................................................................................... 68
7−1 Q&A ............................................................................................................................................................................ 68
7−2 メッセージ一覧 ....................................................................................................................................................... 69
7−3 参考データ............................................................................................................................................................... 71
C-LOGGER 取扱説明書
1.C-LOGGER について
1 C-LOGGER について
1−1 概要
C-LOGGER は CONTEC 製のアナログ入力ボードを使用して、簡単にデータ収集を
行うためのソフトウェアです。面倒なプログラミングは一切必要ありません。
1−2 特徴
・
高速サンプリング、高速データ描画
データ転送ロジックの最適化により、ハードウェアの持つサンプリングレートのス
ペックを最大限に引き出しています。PC 環境や使用するデバイスにも依存しま
すが、1 チャネルあたりで最大 500kHz の連続データ収集が可能です。
さらに、グラフ描画には CONTEC 独自のテクノロジを採用しており、大量のデータ
表示の際も動作が重くなることはありません。
・
多くの CONTEC アナログ入力ボードに対応
C-LOGGER は、マルチファンクションタイプの F シリーズや、大容量オンボードメ
モリ搭載型の EV シリーズ、低価格な L シリーズ等、多くのハードウェアをサポー
トしています。バス形式もカードバス、PCI、Low Profile PCI のラインナップを提供
しているため、幅広い用途で C-LOGGER をお使いいただけます。
・
マルチウィンドウ対応
収集データの観測に使用する YT ウィンドウと数値ウィンドウは、複数起動するこ
とができ、画面サイズも自由に変更することができます。また、表示するチャネル
の設定も、ウィンドウ毎に個別の設定が可能です。これにより、ユーザーの好み
に応じた使い方が可能になります。
・
高速 EXCEL 転送機能
データ収集中に、動的に EXCEL へのデータ転送を行います。
・
2種類のデータ形式に対応
- 6 -
C-LOGGER 取扱説明書
1.C-LOGGER について
収集データはバイナリと CSV、2種類の形式で保存することができます。バイナリ
形式は、ファイルサイズが小さく、高速な保存・読み込みを行うことができます。
CSV 形式はテキスト形式のため、エディタや EXCEL 等のアプリケーションで読み
込むことができます。
・
ウィザードで収集条件を簡単に設定
データ収集条件の設定はウィザードを使用して行います。対話形式のインターフ
ェースを使用して、簡単に収集条件の設定が行えます。また、設定した収集条件
はファイルへ保存することもできます。このファイルを読み込めば、同じ収集条件
ですぐに収集を開始することができます。
・
ファイルビューア、プロパティビューアにより直感的な操作が可能
収集したデータやファイルから読み込んだデータは、ファイルビューア上にツリー
表示されます。C-LOGGER は複数のファイルを読み込むことができ、各ファイル
はファイルビューア上で管理されます。ファイルや収集データに関する情報は、プ
ロパティビューアに表示されます。
・
長時間、大容量データ収集時には、ファイルへ自動保存
長時間のデータ収集、もしくは大容量のデータ収集を行う場合、収集データを自
動的にファイル保存することができます。
・
全体とズーム、2画面によるグラフ表示が可能
YT ウィンドウによるフラグ表示は、全体画面とズーム画面による2種類の表示が
可能です。収集された総データは全体画面に表示され、データの一部を詳細ま
で確認したい場合にはズーム画面を使用します。全体画面にはズーム画面の位
置を示すスコープが表示されており、2つの画面を使用することにより非常に高
い操作性能を実現しています。
・
豊富なカスタマイズ機能
データ観測のメインとなる YT ウィンドウは、細かなカスタマイズが可能です。
- 7 -
C-LOGGER 取扱説明書
1.C-LOGGER について
1−3 お問い合わせについて
このヘルプに記述されていない事柄または、異常な動作などについては、当社テク
ニカルインフォメーションセンターへお問い合わせください。なお、商品の性格上、口
頭ですと内容が把握しにくい場合がありますので、ご質問は FAX もしくはインターネ
ットフォームで状況をお知らせください。折り返しご連絡いたします。
特に、動作異常と思われる場合は、パソコンや他に使用しているデバイスなどのハ
ードウェア環境や、ドライバのバージョンなども関係する場合もございますので、詳し
くご記入ください。
お問い合わせ用フォーマット
E-Mail や FAX でのお問い合わせの際には以下の内容をご記入ください。
・貴社名
・所属
・お名前
・電話番号
・FAX 番号
・E-Mail アドレス※
・ご使用 OS※
・ご使用デバイス※
・デバイスのシリアル番号
・API-AIO(WDM)のバージョン※
・C-LOGGER のバージョン
・ご質問概要
・ご質問詳細
※付きの内容は、E-Mail で診断レポートを添付されている場合には不要です。
診断レポートの作成方法は「2−2 診断プログラムの実行」を参照してください。
C-LOGGER のバージョンは、メニューバーの「ヘルプ(H)」−「CLogger について
…(A)」コマンドで表示されます。
お問い合わせ連絡先
TEL:03-5628-9286
FAX:03-5628-9344
E-mail:[email protected]
- 8 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
2 ソフトウェアのインストール
2−1 デバイスドライバのインストール
C-LOGGER を使用する前に、アナログ入力ボード用のデバイスドライバをインストー
ルする必要があります。
注意
インストールされているデバイスドライバのバージョンが古い場合、C-LOGGER でエ
ラーメッセージが表示されます。この場合、デバイスドライバを最新のバージョンにア
ップデートしてください。ドライバは、以下の URL から入手可能です。
http://www.contec.co.jp/product/special/apipac/
■ ドライバのダウンロード
1.http://www.contec.co.jp/product/special/apipac/にアクセスします。
「実行環境(ランタイムのみ)」をダウンロードしてください。
- 9 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
2.ダウンロードしたファイルを実行し、適当な場所へ解凍します。
■ Windows XP でのインストール
注意
デバイスドライバのインストールは、Administrator 権限を持つユーザーで行ってくだ
さい。
1. ハードウェアをパソコンの拡張スロットに実装し、OS を起動します。
OS 起動後、自動的にハードウェアウィザードが起動します。
Windows Update へ接続するかどうかを聞かれた場合は、「接続しない」を選択し
てください。
2. ソフトウェアのインストールは「一覧または特定の場所から」行います。
- 10 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
3. インストールするドライバは、直接ファイルを指定します。
<API-PAC(W32)CD-ROM 内のドライバを使用する場合>
CD-ROM ドライブ\INF\WDM\AIO フォルダを指定します。
<ダウンロードしたドライバを使用する場合>
ファイルを解凍したフォルダ\INF\WDM\AIO フォルダを指定します。
- 11 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
■ Windows 2000 でのインストール
注意
デバイスドライバのインストールは、Administrator 権限を持つユーザーで行ってくだ
さい。
1. ハードウェアをパソコンの拡張スロットに実装し、OS を起動します。
2. ドライバの検索画面では、「デバイスに最適なドライバを検索する」を選択しま
す。
3. ドライバの検索場所のオプションでは、「場所を指定」を選択します。
4. インストールするドライバは、直接ファイルを指定します。
<API-PAC(W32)CD-ROM 内のドライバを使用する場合>
CD-ROM ドライブ\INF\WDM\AIO フォルダを指定します。
- 12 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
<ダウンロードしたドライバを使用する場合>
ファイルを解凍したフォルダ\INF\WDM\AIO フォルダを指定します。
2−2 診断プログラムの実行
診断プログラムを実行して、デバイスが正常にインストールされていることを確認し
てください。
1. エクスプローラーでマイコンピュータを右クリックし、プロパティを選択します。
「システムのプロパティ」で「ハードウェア」タブを表示し、「デバイスマネージャ」を
起動します。
2. 「CONTEC Devices」ツリーの下に、インストールしたデバイスが登録されていま
す。これをダブルクリックしてデバイスのプロパティを表示します。
- 13 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
3. プロパティページの「共通設定」タブを開き、診断ボタンをクリックします。
4. 診断プログラムでは、アナログ入力信号を簡易的に確認することができます。
- 14 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
5. 診断レポートを作成するには「診断レポート」ボタンをクリックします。
動作異常に関するお問い合わせの際には、診断レポートが必要になります。
6. 最後に、プロパティページで OK ボタンをクリックします。
注意
インストールされたデバイスにはそれぞれ個別の「デバイス名」という文字列が必要
です。この文字列は他のデバイス同士で重複していなければ何でも構いませんが、
プロパティページで OK ボタンをクリックするまで設定されません。デバイス名が設定
されていないと C-LOGGER から使用できませんので、ご注意ください。
- 15 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
2−3 アプリケーションのインストール
注意
API-PAC(W32)の CD-ROM に同梱される C-LOGGER のバージョンが古い場合があ
ります。新しいバージョンでは、機能追加や不具合の修正が行われていることがあり
ますので、なるべく最新バージョンの C-LOGGER をインストールしてください。最新の
C-LOGGER は、以下の URL から入手可能です。
http://www.contec.co.jp/clogger/
1. CLoggerInstaller.exe を実行します。
セットアップウィザードの指示に従ってインストールを完了してください。
2−4 アプリケーションのアンインストール
C-LOGGER のアンインストールは、コントロールパネルの「プログラムの追加と削
除」から行います。現在インストールされているプログラムから、「CONTEC Data
Logger」を削除します。
- 16 -
C-LOGGER 取扱説明書
2.ソフトウェアのインストール
- 17 -
C-LOGGER 取扱説明書
3.基本操作
3 基本操作
この章では、C-LOGGER の基本的な操作方法を、データ収集の手順に沿って解説し
ます。C-LOGGER のより詳しい解説に関しては、4章(画面構成)、5章(使用方法)
を参照してください。
3−1 C-LOGGER を起動する
「スタートメニュー」−「プログラム」−「CONTEC Data Logger」−「C-LOGGER」を選
択します。または、デスクトップに作成されているショートカットアイコンをダブルクリッ
クします。
C-LOGGER のショートカットアイコン
C-LOGGER 起動時の画面
- 18 -
C-LOGGER 取扱説明書
3.基本操作
3−2 データ収集を行う
■ デバイスの選択
はじめに、データ収集に使用するデバイスを選択します。メニューバーの「デバイス
(D)」−「選択(S)」を選ぶと、以下のデバイス選択ダイアログが起動します。画面左上
のコンボボックスから、データ収集に使用するデバイスを選択してください。
デバイス選択ダイアログ
デバイス選択ダイアログでは、各デバイスのチャネルに接続されている現在の信号
を、簡易的にモニタリングすることができます。画面左側のコンボボックスから、チャ
ネル、入力方式、レンジを変更することができます。
OK ボタンをクリックすると、使用するデバイスが確定します。
■ データ収集条件の設定
次に、データ収集条件の設定を行います。データ収集条件とは、データ収集を行うチ
ャネル数、変換速度などのデバイスに設定する条件や、EXCEL への転送を行うかど
うかなどの、ソフトウェア上の設定条件があります。
データ収集条件の設定はすべて、収集ウィザードと呼ばれる対話形式のインターフ
ェースを通じて行われます。メニューバーの「デバイス(D)」−「ウィザード(W)」を選択
し、収集ウィザードを起動します。
- 19 -
C-LOGGER 取扱説明書
3.基本操作
データ収集ウィザード:開始画面
収集条件はファイルからの読み込みにも対応していますが、ここではファイルを使用
しませんので、次へ進みます。
以下のようなチャネル設定画面が表示されます。このページでは、入力方式、デバ
イスのチャネルに関する設定などを行います。ウィザードではデフォルト値としてシン
グルエンド入力、チャネル 0 が設定されています。画面右側の追加ボタンをクリックし
て、チャネル 1 を追加します。これで、チャネル 0、チャネル 1 の計 2 チャネルを収集
することになります。
データ収集ウィザード:チャネル設定画面
- 20 -
C-LOGGER 取扱説明書
3.基本操作
次へをクリックし、サンプリング設定のページを表示します。ここではサンプリング回
数とサンプリングクロックの設定を行います。サンプリング回数のデフォルトは 1000
回ですが、10000 回に変更します。サンプリングクロックのデフォルトは 1msec ですの
で、これにより 10 秒間のデータ収集を行います。
収集ウィザードを使用した条件設定はこれ以降も続きますが、ここでは残りの設定
条件をすべてデフォルトのまま使用します。完了ボタンをクリックして収集ウィザード
を終了します。
- 21 -
C-LOGGER 取扱説明書
3.基本操作
■ ウィンドウの設定と確認
収集ウィザードを終了すると、C-LOGGER のウィンドウは以下のように変化します。
C-LOGGER の画面:収集ウィザード設定後
画面左上のウィンドウはファイルビューアと呼ばれるウィンドウで、収集ウィザードで
設定したファイルや、ハードディスクから読み込んだ収集ファイルがツリー上に表示
されます。今回ウィザードで設定した内容が、「新規ファイル1」という名前でファイル
ビューア上に追加されています。ファイルツリーの下にはチャネルのサブツリーが表
示されます。ウィザードで設定した「Channel 0」と「Channel 1」が表示されています。
画面左下のウィンドウはプロパティビューアと呼ばれるウィンドウで、ファイルやチャ
ネルに関連する情報が表示されます。プロパティビューアの表示内容は、ファイルビ
ューアで選択されているアイテムによって変化します。
- 22 -
C-LOGGER 取扱説明書
3.基本操作
画面右側に何も表示されていない部分があります。ここは YT ウィンドウや数値ウィン
ドウなどの子ウィンドウが表示されるエリアです。子ウィンドウは、収集データの観測
や解析などに使用されます。
ここでは、データ収集の観測用に YT ウィンドウを使用します。ファイルビューア内で
ファイル、またはチャネルアイテムを選択した状態で、メニューバーの「ウィンドウ
(W)」−「新規 YT ウィンドウ(Y)」を選択すると、以下のように YT ウィンドウが表示され
ます。
C-LOGGER の画面:YT ウィンドウ起動
■ データ収集の開始と停止
データ収集を開始するには、メニューバーの「デバイス(D)」−「収集開始」を選択しま
す。
収集中は、ファイルビューア内のファイルアイコンが赤く変化し、画面右下のステータ
スバーに表示されている円形のアイコンが緑色に変化します。各チャネルの収集デ
ータは、YT ウィンドウ内にグラフ表示されます。
データ収集最中に停止するには、メニューバーの「デバイス(D)」−「収集停止」を選
択します。
- 23 -
C-LOGGER 取扱説明書
3.基本操作
C-LOGGER の画面:データ収集中
3−3 データを観測する
収集データの観測には、YT ウィンドウや数値ウィンドウなどの子ウィンドウを使用し
ます。データ観測に関するほとんどの操作は、データ収集中でも同様に可能です。
■ YT ウィンドウ 全体画面とズーム画面
YT ウィンドウはグラフ部が2分割されており、上部のズーム画面と下部の全体画面
から構成されます。
全体画面
:収集データがすべて表示されます。
ズーム画面
:全体画面で拡大されたエリアのデータが表示されます。
全体画面にはスコープと呼ばれる四角形が表示されており、この四角形の内部がズ
ーム画面で表示されるエリアとなります。
YT グラフの横軸(T 軸)は時間で、縦軸(Y 軸)は電圧等のデータを表します。
- 24 -
C-LOGGER 取扱説明書
3.基本操作
YT ウィンドウ
T 軸や Y 軸の拡大を行うには、メニューバーの「表示(V)」−「YT グラフズーム」−「T
軸ズームイン」「Y 軸ズームイン」を選択します。縮小は「T 軸ズームアウト」「Y 軸ズー
ムアウト」です。
全体画面内のスコープにマウスを合わせると、マウスカーソルが十字に変化します。
この状態でマウスをドラッグすると、スコープの位置を移動することができます。
■ YT ウィンドウ アクティブチャネルの切り替え
YT ウィンドウ内で表示されるチャネルデータは、アクティブと非アクティブの 2 種類の
状態を持ちます。アクティブなチャネルは他の非アクティブなチャネルより太い線で
描画されます。また、プロパティビューアに表示されるチャネル情報は、現在アクティ
ブなチャネルの情報になります。
YT ウィンドウ画面右側にはチャネル名ラベルが表示されており、アクティブなチャネ
ルは長方形の背景色がグラフ線の色となります。非アクティブなチャネルの背景色
はグラフの背景色となります。現在アクティブなチャネルを、チャネル情報の長方形
をクリックすることで切り替えることができます。
- 25 -
C-LOGGER 取扱説明書
3.基本操作
Channel 0 がアクティブ
Channel 1 がアクティブ
クリックにより切り替え
■ YT ウィンドウ カーソルの使用
YT ウィンドウでは垂直カーソルを使用することができます。垂直カーソルは A、B の 2
種類が使用でき、表示/非表示の切り替えはメニューバーの「表示(V)」−「YT グラ
フカーソル」−「カーソル A」「カーソル B」で行います。
各カーソルは、マウスでドラッグすることにより移動できます。
カーソルの情報はプロパティビューアに表示されます。
垂直カーソル表示
カーソル A、B の情報は、プロパティビューアに表示されますが、ここには現在アクテ
ィブなチャネルのデータが表示されます。
- 26 -
C-LOGGER 取扱説明書
3.基本操作
■ 数値ウィンドウ
数値ウィンドウは、収集データを数値で観測するためのウィンドウです。数値ウィンド
ウには収集データの現在値のみが表示されているため、データ収集の最中に使用
します。データ収集後に表示しても意味はありません。
数値ウィンドウを起動するには、ファイルビューア内でファイル、またはチャネルアイ
テムを選択した状態で、メニューバーの「ウィンドウ(W)」−「新規数値ウィンドウ(V)」を
選択します。
数値ウィンドウ
3−4 データを保存する
■ ファイルへの保存
収集後のデータをファイルに保存するには、メニューバーから「ファイル(F)」−「名前
を付けて保存(A)」を選択します。ファイル保存ダイアログが表示されるので、ファイル
の種類から、バイナリ形式「CONTEC Logger Binary Data (*.clb)」を選択して保存しま
す。
- 27 -
C-LOGGER 取扱説明書
3.基本操作
ファイル保存ダイアログ
■ ファイルの読み込み
C-LOGGER で保存した収集データは、再度 C-LOGGER で読み込んで観測や解析を
行うことができます。
収集ファイルを読み込むには、メニューバーの「ファイル(F)」−「開く(O)」を選択しま
す。ファイル読み込みダイアログが表示されるので、ファイルの種類から、バイナリ
形式「CONTEC Logger Binary Data (*.clb)」を選択してファイルを読み込みます。
- 28 -
C-LOGGER 取扱説明書
3.基本操作
3−5 データを EXCEL に転送する
C-LOGGER はデータ収集を行いながら、同時に EXCEL へデータを転送する機能を
持っています。ここでは EXCEL 転送を行うための手順を解説します。
1.C-LOGGER を起動し、デバイスを選択します。(→P18, 19)
2.データ収集ウィザードを起動します。(→P19)
データ保存設定のページで、「エクセルに転送する」チェックボックスにチェックを
入れます。
データ収集ウィザード:データ保存設定画面
3.データ収集を開始します。(→P23)
EXCEL が起動し、自動的にデータ転送が開始されます。
データはスケール設定値で転送されます。
- 29 -
C-LOGGER 取扱説明書
3.基本操作
EXCEL 転送データ
- 30 -
C-LOGGER 取扱説明書
4.画面構成
4 画面構成
C-LOGGER の画面構成について説明します。
4−1 全体画面
メニューバー(→P32)
ツールバー(→P34)
ファイルビューア(→P35)
ステータスバー(→P35)
プロパティビューア(→P37)
- 31 -
数値ウィンドウ(→P41)
YT ウィンドウ(→P39)
C-LOGGER 取扱説明書
4.画面構成
4−2 メニューバー
■ 「ファイル(F)」メニュー
コマンド
説明
新規作成(N)
現在の収集条件でデータ収集用のファイルを作成しま
す。
開く(O)
収集データファイルを読み込みます。
上書き保存(S)
既存の収集データファイルを上書き保存します。
名前を付けて保存(A)
収集データに新しい名前を付けて保存します。
閉じる(C)
ファイルビューアで選択されているファイルを閉じます。
印刷(P)
選択されている YT グラフの内容を印刷します。
印刷プレビュー(P)
選択されている YT グラフの内容を印刷プレビューしま
す。
プリンタの設定(R)
プリンタのページ設定を行います。
最近使ったファイル
最近使った収集データファイルを読み込みます。
ア プ リ ケ ー シ ョ ン の 終了 C-LOGGER を終了します。
(X)
■ 「表示(V)」メニュー
コマンド
説明
ツールバー(T)
ツールバーの表示/非表示を切り替えます。
ステータスバー(S)
ステータスバーの表示/非表示を切り替えます。
ファイルビューア(F)
ファイルビューアの表示/非表示を切り替えます。
プロパティビューア(P)
プロパティビューアの表示/非表示を切り替えます。
YT グラフズーム
T 軸ズームイン
T 軸ズームアウト
Y 軸ズームイン
Y 軸ズームアウト
YT グラフズーム画面の拡大・縮小を行います。
横軸を 2 倍に拡大します。
横軸を 1/2 に縮小します。
縦軸を 2 倍に拡大します。
縦軸を 1/2 に縮小します。
YT グラフ T 軸単位
絶対時間
相対時間
YT グラフの時間軸表示を切り替えます。
収集開始時間を絶対時間として表示します。
収集開始時間を 0 として表示します。
YT グラフカーソル
カーソル A
YT グラフカーソルの表示/非表示を切り替えます。
カーソル A の表示/非表示を切り替えます。
- 32 -
C-LOGGER 取扱説明書
カーソル B
4.画面構成
カーソル B の表示/非表示を切り替えます。
YT グラフ自動スクロール
YT グラフズーム画面の自動スクロール機能 ON/OFF を
切り替えます。
YT ウィンドウオプション
YT ウィンドウオプションダイアログを表示します。
数値ウィンドウオプション
数値ウィンドウオプションダイアログを表示します。
メモリオプション
メモリオプションダイアログを表示します。
オプションの保存
各オプションの内容を保存します。
オプションのリセット
各オプションの内容をデフォルト設定に戻します。
言語
日本語
英語
表示する言語を切り替えます。
日本語で表示します。
英語で表示します。
■ 「デバイス(D)」メニュー
コマンド
説明
選択(S)
データ収集に使用するデバイスを選択します。
ウィザード(W)
データ収集ウィザードを起動します。
収集開始
データ収集を開始します。
収集停止
データ収集を停止します。
■ 「ウィンドウ(W)」メニュー
コマンド
説明
新規 YT ウィンドウ(Y)
選択されているファイルに対して、YT ウィンドウを起動し
ます。
新規数値ウィンドウ(V)
選択されているファイルに対して、数値ウィンドウを起動
します。
重ねて表示(C)
子ウィンドウを重ねて表示します。
横に並べて表示(H)
子ウィンドウを横に並べて表示します。
縦に並べて表示(V)
子ウィンドウを縦に並べて表示します。
アイコンの整列(A)
アイコン化されている子ウィンドウを整列します。
閉じる(O)
アクティブな子ウィンドウを閉じます。
すべて閉じる(L)
子ウィンドウを全て閉じます。
■ 「ヘルプ(H)」メニュー
コマンド
C-LOGGER について(A)
説明
C-LOGGER のバージョン情報を表示します。
- 33 -
C-LOGGER 取扱説明書
4.画面構成
4−3 ツールバー
よく使われるコマンドはツールバーとして用意されています。
■ 全般
ツールバー
説明
現在の収集条件でデータ収集用のファイルを作成します。
収集データファイルを読み込みます。
既存の収集データファイルを上書き保存します。
ファイルビューアで選択されているファイルを閉じます。
データ収集に使用するデバイスを選択します。
データ収集ウィザードを起動します。
データ収集を開始します。
データ収集を停止します。
子ウィンドウを重ねて表示します。
子ウィンドウを縦に並べて表示します。
子ウィンドウを横に並べて表示します。
選択されている YT グラフの内容を印刷します。
C-LOGGER のバージョン情報を表示します。
■ 子ウィンドウ
ツールバー
説明
選択されているファイルに対して、YT ウィンドウを起動します。
YT グラフズーム画面の横軸を 2 倍に拡大します。
YT グラフズーム画面の横軸を 1/2 倍に縮小します。
YT グラフズーム画面の縦軸を 2 倍に拡大します。
YT グラフズーム画面の縦軸を 1/2 倍に縮小します。
YT グラフの収集開始時間を絶対時間として表示します。
YT グラフの収集開始時間を 0 として表示します。
YT グラフカーソ A の表示/非表示を切り替えます。
YT グラフカーソ B の表示/非表示を切り替えます。
選択されているファイルに対して、数値ウィンドウを起動します。
- 34 -
C-LOGGER 取扱説明書
4.画面構成
■ 印刷プレビュー
ツールバー
説明
印刷プレビューの内容を印刷します。
前のページをプレビューします。
次のページをプレビューします。
印刷プレビューを閉じます。
4−4 ステータスバー
ステータスバーにはメニューの説明、デバイスの動作状態などが表示されます。
①
②
① メニューの説明が表示されます。
② 選択されているデバイスの名称と、デバイスの動作状態が表示されます。
4−5 ファイルビューア
■ ファイルビューア
ファイルビューアは、収集データを管理するためのウィンドウです。ファイルから読み
込んだ収集データや、収集ウィザードで作成された新規ファイルは、ファイルビュー
ア上にツリー形式で表示されます。
- 35 -
C-LOGGER 取扱説明書
4.画面構成
①
②
① ファイルツリー
ファイルから読み込んだ収集データはファイルツリーで表示されます。
C-LOGGER では、複数のファイルを読み込むことができます。
ファイルツリーの横にアスタリスク(*)が表示されている場合、ファイルが保存さ
れていないか、もしくはファイルの内容が編集されたことを意味します。
ファイルツリーには以下の 3 種類の状態があり、状態に応じてファイルアイコンの
色が変化します。
1.データ収集前
2.データ収集中
3.データ収集後
② チャネルツリー
収集データ内で使用されているチャネルが、ファイルツリーの下に表示されます。
ここに表示されるのはデバイスのチャネルに対応するチャネル名です。チャネル
名は収集ウィザードで設定しますが、ファイルビューア内でも名前を変更すること
ができます。
変更したいチャネル名をクリックした状態でもう一度クリックすると、以下のように
名前を編集することができます。
- 36 -
C-LOGGER 取扱説明書
4.画面構成
■ ポップアップウィンドウ
ファイルビューア内で右クリックすると、ポップアップウィンドウが表示されます。この
ウィンドウには、ファイルビューアに関連する内容のコマンドが用意されています。
コマンド
説明
新規 YT ウィンドウ(Y)
選択されているファイルに対して、YT ウィンドウを起動し
ます。
新規数値ウィンドウ(V)
選択されているファイルに対して、数値ウィンドウを起動
します。
上書き保存(S)
既存の収集データファイルを上書き保存します。
名前を付けて保存(A)
収集データに新しい名前を付けて保存します。
閉じる(C)
選択されているファイルを閉じます。
4−6 プロパティビューア
プロパティビューアは、ファイルやチャネルに関連する情報を表示するウィンドウです。
プロパテューアの表示内容は、ファイルビューアで選択されているアイテムによって
変化します。
■ ファイルビューアアイコン選択時
ファイルビューア内でファイルビューアアイコンが選択されている場合、プロパティビ
ューアには以下の情報が表示されます。
プロパティ
ファイル数
説明
C-LOGGER 内に読み込まれているファイル数を表示しま
す。
■ ファイルアイコン選択時
ファイルビューア内でファイルアイコンが選択されている場合、プロパティビューアに
は以下の情報が表示されます。
- 37 -
C-LOGGER 取扱説明書
4.画面構成
プロパティ
説明
<デバイス情報>
ファイル名
ファイル名(拡張子なし)が表示されます。
チャネル数
収集データ内の使用チャネル数が表示されます。
デバイス
データ収集に使用したデバイスの名称が表示されます。
分解能
収集データの分解能が、ビット単位で表示されます。
サンプリングクロック
収集データのサンプリングクロックが、usec 単位で表示さ
れます。
データ数
収集データの総データ数が表示されます。
開始時間
データ収集の開始時間が表示されます。
年/月/日 時:分:秒 ミリ秒 マイクロ秒
終了時間
データ収集の終了時間が表示されます。
年/月/日 時:分:秒 ミリ秒 マイクロ秒
■ チャネルアイコン選択時
ファイルビューア内でチャネルアイコンが選択されている場合、プロパティビューアに
は以下の情報が表示されます。
プロパティ
説明
<チャネル情報>
チャネル名
チャネル名が表示されます。
ハードウェアチャネル
ハードウェアの物理的なチャネル番号が表示されます。
レンジ
チャネルの入力レンジが表示されます。
スケール最大値
スケール変換の最大値を表示します。
スケール最小値
スケール変換の最小値を表示します。
<カーソル情報>
カーソル A 時間
YT ウィンドウでカーソル A を使用している場合、カーソル
位置の時間が表示されます。
年/月/日 時:分:秒 ミリ秒 マイクロ秒
カーソル A 値
YT ウィンドウでカーソル A を使用している場合、カーソル
位置のデータが表示されます。
カーソル B 時間
YT ウィンドウでカーソル B を使用している場合、カーソル
- 38 -
C-LOGGER 取扱説明書
4.画面構成
位置の時間が表示されます。
年/月/日 時:分:秒 ミリ秒 マイクロ秒
カーソル B 値
YT ウィンドウでカーソル B を使用している場合、カーソル
位置のデータが表示されます。
カーソル B-A 時間
YT ウィンドウでカーソル A、B を使用している場合、カー
ソル AB 間の差分時間が表示されます。
時:分:秒 ミリ秒 マイクロ秒
カーソル B-A 値
YT ウィンドウでカーソル A、B を使用している場合、カー
ソル AB 間のデータ差分値が表示されます。
4−7 YT ウィンドウ
■ YT ウィンドウ
YT ウィンドウは、横軸を時間で表示し、縦軸をデータで表示する 2 次元グラフです。
①
⑩
③
⑨
⑧
⑥
⑦
④
⑤
②
① ウィンドウタイトル
YT ウィンドウのタイトル文字列です。
- 39 -
C-LOGGER 取扱説明書
4.画面構成
② T 軸タイトル
T 軸のタイトル文字列です。
③ Y 軸タイトル
Y 軸のタイトル文字列です。
④ 全体画面
全ての収集データが表示されます。
⑤ T 軸目盛り
時間軸の目盛りが表示されます。
⑥ Y 軸目盛り
スケール変換された値が表示されます。スケール変換が未使用の場合は、電圧
レンジが表示されます。
⑦ スコープ
ズーム画面のエリアを表します。
⑧ ズーム画面
スコープに囲まれた範囲を表示します。
⑨ カーソル
データの解析に使用するカーソルです。
⑩ チャネル名ラベル
チャネルの名前を表示するラベルです。アクティブ/非アクティブの切り替えはこ
のラベルで行います。
■ ポップアップウィンドウ
YT ウィンドウ内で右クリックすると、ポップアップウィンドウが表示されます。このウィ
ンドウには、YT ウィンドウに関連する内容のコマンドが用意されています。
コマンド
説明
T 軸ズームイン
横軸を 2 倍に拡大します。
T 軸ズームアウト
横軸を 1/2 に縮小します。
Y 軸ズームイン
縦軸を 2 倍に拡大します。
Y 軸ズームアウト
縦軸を 1/2 に縮小します。
絶対時間表示
収集開始時間を絶対時間として表示します。
相対時間表示
収集開始時間を 0 として表示します。
カーソル A
カーソル A の表示/非表示を切り替えます。
カーソル B
カーソル B の表示/非表示を切り替えます。
YT グラフ自動スクロール
ズーム画面の自動スクロール機能 ON/OFF を切り替え
ます。
YT ウィンドウオプション
YT ウィンドウオプションダイアログを表示します。
- 40 -
C-LOGGER 取扱説明書
4.画面構成
オプションの保存
オプションの内容を保存します。
オプションのリセット
オプションの内容をデフォルトに戻します。
4−8 数値ウィンドウ
数値ウィンドウは、収集データを数値で観測するためのウィンドウです。
①
②
① チャネル名
チャネル名が表示されます。
② 値
収集データの現在値が、スケール変換された値で表示されます。スケール変換
が未使用の場合は、電圧レンジで表示されます。
- 41 -
C-LOGGER 取扱説明書
5.使用方法
5 使用方法
5−1 デバイスの選択
データ収集に使用するデバイスを選択します。デバイス選択ダイアログには簡易モ
ニタリングの機能が付いており、各チャネルの信号を確認することができます。OK ボ
タンをクリックすると、使用するデバイスが確定します。
メニュー
:「デバイス(D)」−「選択(S)」
ツールバー
:
①
⑥
②
③
④
⑤
デバイス選択ダイアログ
① デバイスの選択
データ収集に使用するデバイスを選択します。
② チャネルの選択
モニタリングを行うチャネルを選択します。ここでの設定はデータ収集とは関係あ
りません。
③ 入力方式の選択
モニタリング時の入力方式を選択します。ここでの設定はデータ収集とは関係あ
りません。
④ レンジの選択
モニタリング時の入力レンジを選択します。ここでの設定はデータ収集とは関係
ありません。
- 42 -
C-LOGGER 取扱説明書
5.使用方法
⑤ 電圧表示
指定されたチャネルに接続されている信号を数値表示します。
⑥ グラフ表示
指定されたチャネルに接続されている信号をグラフで表示します。
5−2 収集条件の設定
データ収集条件の設定を行います。設定はすべて、収集ウィザードと呼ばれる対話
形式のインターフェースを通じて行われます。
メニュー
:「デバイス(D)」−「ウィザード(W)」
ツールバー
:
■ 収集ウィザード開始
収集ウィザード開始ページでは、ウィザード中で条件設定を行っていくか、設定ファイ
ルを読み込んで使用するかを選択します。ウィザード中で条件設定を行う場合、その
まま次へ進みます。ファイルを読み込んで使用する場合、読み込んだ収集条件のま
まで収集を行う場合は完了ボタンを、収集条件をさらに変更したい場合には次へ進
みます。
①
②
- 43 -
C-LOGGER 取扱説明書
5.使用方法
① 収集条件ファイル読み込みボタン
ウィザードで設定した収集条件は、ファイルに保存することができます。収集条件
ファイルを読み込む場合、このボタンをクリックします。
② 収集条件ファイル表示
読み込んだ収集条件ファイルはここに表示されます。
■ チャネル設定
チャネル設定ページでは、収集に使用するチャネルの選択、入力レンジやスケール
変換等のチャネルに関する属性を設定します。
①
⑦
③
④
⑤
⑥
②
① 入力方式の選択
シングルエンド入力または差動入力を選択します。シングルエンド入力しか持た
ないデバイスの場合、差動入力の設定はできません。
② チャネル設定のリスト
現在設定されているチャネルの内容が表示されます。
・ シーケンス
チャネルの変換順序です。変換は 1, 2, 3, ・・・の順に行われます。
・ HW チャネル
ハードウェアの物理的なチャネル番号のことです。HW チャネルは 0 を先頭として
- 44 -
C-LOGGER 取扱説明書
5.使用方法
数えます。リスト内のアイテムをクリックすることにより、HW チャネルを変更するこ
とができます。チャネルシーケンスの変更に対応していないデバイスの場合、HW
チャネルを変更することはできません。
・ 名前
チャネルに付ける名前です。リスト内のアイテムをクリックすることにより、チャネ
ル名として任意の文字列を設定することができます。
・ レンジ
リスト内のアイテムをクリックすることにより、チャネルの入力レンジを選択します。
チャネル毎のレンジ設定ができないデバイスでは、いずれかのチャネルレンジを
変更すると全チャネルのレンジが変更されます。
・ スケール変換
スケール変換設定が表示されます。スケール変換を使用すると、デバイスの入
- 45 -
C-LOGGER 取扱説明書
5.使用方法
力レンジ(電圧)から、任意の物理量へ値を変換することができます。スケール変
換を行うには、スケール設定ボタンをクリックします。
③ チャネル追加ボタン
このボタンをクリックすることで、データ収集に使用するチャネルを 1 つずつ追加
します。このとき、チャネルはシーケンスの末尾に追加されます。チャネルのプロ
パティ(HW チャネル、名前、レンジ、スケール)は自動的に設定されますので、こ
れらの値は手動で変更してください。
④ チャネル削除ボタン
登録されているチャネルを削除します。リスト内で選択されているアイテムが削
除されます。このとき、シーケンスは自動的に調整されます。チャネルシーケンス
の変更に対応していないデバイスの場合、必ず最後のシーケンスのチャネルが
削除されます。
⑤ チャネルシーケンス移動ボタン
チャネルシーケンスを移動します。リスト内で選択されているアイテムは、1 つ上
に登録されているチャネルとシーケンスが入れ替わります。チャネルシーケンス
の変更に対応していないデバイスの場合、ボタンは使用できません。
⑥ チャネルシーケンス移動ボタン
チャネルシーケンスを移動します。リスト内で選択されているアイテムは、1 つ下
に登録されているチャネルとシーケンスが入れ替わります。チャネルシーケンス
の変更に対応していないデバイスの場合、ボタンは使用できません。
⑦ スケール設定ボタン
スケール変換の設定を行います。ボタンをクリックすると、スケール設定ダイアロ
グが起動します。
■ スケール設定
デバイスの入力レンジは通常±10V などの電圧ですが、スケール変換を行うことに
より、デバイスの入力レンジから、任意の物理量へ値を変換することができます。ス
ケール変換は、任意の電圧 2 点に対する値を設定することで行います。
- 46 -
C-LOGGER 取扱説明書
5.使用方法
例) デバイスのレンジが±5V、入力チャネルには圧力センサが接続されており、セ
ンサの出力電圧が 1∼5V で、圧力レンジが 0∼100kPa の場合
1点目のデータを 1.0(V)とし、スケール値を 0(kPa)とします。
2 点目のデータを 5.0(V)とし、スケール値を 100(kPa)とします。
これにより、収集データは電圧(V)から圧力(kPa)に変換されます。
①
②
③
③
④
④
① シーケンス表示
チャネル設定画面で追加されたチャネルのシーケンスが表示されます。
② スケール設定の有効/無効
チェックボックスへの ON/OFF 切り替えにより、スケール設定の有効/無効を切り
替えることができます。
③ データ設定
デバイスの入力レンジ(電圧レベル)での、任意の 2 点を指定します。
④ スケール設定
データ設定で指定した 2 点に対して、スケール変換後の値を設定します。
■ サンプリング設定
サンプリング設定ページでは、サンプリング回数とサンプリングクロックを設定しま
す。
- 47 -
C-LOGGER 取扱説明書
5.使用方法
①
②
③
① サンプリング回数の設定
サンプリング回数が有限か無限かを選択し、有限の場合サンプリング回数を設
定します。
② サンプリングクロックの設定
サンプリングクロックの値を設定し、単位を usec(マイクロ秒)、msec(ミリ秒)、
sec(秒)から選択します。小数点を含むような値を設定する場合は、1 つ低い単
位を使用してください。
例) 1.5msec を設定する場合→1500usec を設定
③ スキャンクロックの設定
スキャンクロックを設定します。
■ トリガ設定
トリガ設定ページでは、データ収集の開始条件を設定します。
- 48 -
C-LOGGER 取扱説明書
5.使用方法
①
②
③
④
⑤
⑥
① トリガなし
収集開始コマンドを実行するとすぐに収集が行われます。
② エッジトリガ
デバイスの外部トリガ入力により収集を開始します。トリガの入力方向として、立
ち上がりエッジまたは立ち下がりエッジを選択します。
③ レベルトリガ
指定チャネルに入力されるアナログ信号の値が条件成立することによって、収集
を開始します。開始トリガとして使用するチャネルを選択し、トリガ条件成立となる
レベルと信号の方向を設定します。
④ インレンジトリガ
- 49 -
C-LOGGER 取扱説明書
5.使用方法
インレンジ比較開始条件では、指定チャネルのアナログ信号がレベル 1 とレベル
2で設定された範囲内に入ると開始条件が成立します。アナログ信号が最初か
らインレンジ範囲内に存在する場合、開始条件はすぐに成立します。サンプリン
グ保持回数は、インレンジ比較成立後からサンプリング開始までに必要なサンプ
リング回数です。実際の変換は、サンプリング保持回数分のサンプリング時間が
経過した後に開始します。サンプリング保持回数分までに、アナログ信号がレベ
ル 1 とレベル2で設定された範囲を外れた場合、インレンジ比較開始条件は不成
立となります。
⑤ アウトレンジトリガ
アウトレンジ比較開始条件では、指定チャネルのアナログ信号がレベル 1 とレベ
ル2で設定された範囲外に外れると開始条件が成立します。アナログ信号が最
初からアウトレンジ範囲内に存在する場合、開始条件はすぐに成立します。サン
プリング保持回数は、アウトレンジ比較成立後からサンプリング開始までに必要
なサンプリング回数です。実際の変換は、サンプリング保持回数分のサンプリン
グ時間が経過した後に開始します。サンプリング保持回数分までに、アナログ信
号がレベル 1 とレベル2で設定された範囲に入った場合、アウトレンジ比較開始
条件は不成立となります。
⑥ 指定時間
収集開始コマンドを実行後、指定した時間が経過すると収集を行います。経過時
間は秒単位で指定してください。
■ データ保存設定
データ保存ページでは、収集データの自動保存に関する設定や EXCEL への転送設
定を行います。
- 50 -
C-LOGGER 取扱説明書
5.使用方法
①
②
① 自動保存
データ収集中にファイルへの自動保存を行う場合、ここにチェックを入れます。参
照ボタンでファイルを保存する場所を指定し、データ形式をバイナリまたはテキス
トから選択します。ファイル名は現在の時刻を元に、自動的に作成されます。
② EXCEL への転送
データ収集中にデータを EXCEL へ転送するには、ここにチェックを入れます。
■ 収集ウィザード終了
収集ウィザード終了ページでは、収集条件の一覧を確認でき、収集条件をファイル
に保存することもできます。完了ボタンをクリックすると、C-LOGGER に設定内容が
反映されます。キャンセルボタンをクリックすると、ウィザードでの設定内容が全て破
棄されます。
- 51 -
C-LOGGER 取扱説明書
5.使用方法
①
① 収集条件ファイル保存ボタン
ウィザードで設定した収集条件は、ファイルに保存することができます。ファイル
は拡張子が clc(CONTEC Logger Config)の、テキスト形式で保存されます。
■ その他
収集ウィザードは、前回設定された収集条件を記憶しており、2 回目以降のウィザー
ド実行では、前回設定された条件が表示されます。また、ウィザードはいつでも完了
することができます。
収集条件の設定には収集ウィザードを使用しますが、前回と同じ条件でデータ収集
を行いたい場合に度々ウィザードを実行するのは面倒です。このような場合には、メ
ニューバーの「ファイル(F)」−「新規作成(N)」を選択します。これは、記憶されている
収集条件に従ってファイルを作成するコマンドです。
■ ファイルビューアとの関係
収集ウィザードで収集条件の設定を行うと、ファイルビューアに新規ファイルが作成
されます。このファイルは C-LOGGER のメモリ上に作成されたファイルで、ディスクに
はまだ保存されていません。また、データ収集前の状態ですので、まだ収集データ
は存在しません。収集を開始することで、このファイルにデータが格納されていきま
- 52 -
C-LOGGER 取扱説明書
5.使用方法
す。
データ収集前の新規ファイルは、1 つしか作成することはできません。新規ファイル
が作成されている状態で再度収集ウィザードを起動すると、以下のメッセージボック
スが表示され、現在の設定を破棄してよいかどうかを聞いてきます。現在の設定を
破棄した場合、再度ウィザードで収集条件の設定を行ってください。
5−3 収集の開始・停止
データ収集の開始は以下のコマンドで行います。
メニュー
:「デバイス(D)」−「収集開始」
ツールバー
:
データ収集の停止は以下のコマンドで行います。
メニュー
:「デバイス(D)」−「収集停止」
ツールバー
:
■ ファイルビューアの状態
ファイルビューアのファイルには以下の 3 種類の状態があり、状態に応じてファイル
アイコンの色が変化します。
1. データ収集前
2. データ収集中
3. データ収集後
■ プロパティビューアの状態
データ収集を開始すると、プロパティビューアの開始時間プロパティの値が決定しま
す。また、データ収集中は定期的にデータ数プロパティと終了時間プロパティの値が
更新されます。データ収集が終了すると、終了時間プロパティの値が決定します。
- 53 -
C-LOGGER 取扱説明書
5.使用方法
■ ステータスバーの状態
ステータスバーでは、デバイスの動作状態が表示されます。
デバイス動作中
デバイス動作停止中
5−4 データの観測
収集データの観測には、YT ウィンドウや数値ウィンドウなどの子ウィンドウを使用し
ます。データ観測に関するほとんどの操作は、データ収集中でも同様に可能です。
YT ウィンドウ及び数値ウィンドウの基本的な使い方に関しては、「3−3 データを観
測する」を参照してください。
■ ファイルビューアと子ウィンドウ
YT ウィンドウや数値ウィンドウなどの子ウィンドウは、ファイルビューア内のファイル
に対して割り当てられます。複数のファイルに対して、それぞれの YT ウィンドウを使
用してデータの観測を行うことが可能です。また、1つのファイルに対して複数の YT
ウィンドウを使用して観測を行うような使い方もできます。
・あるファイルに対して YT ウィンドウを起動する
1. ファイルビューアで、YT ウィンドウを起動するファイルを選択します。
2. YT ウィンドウ起動コマンドを実行します。
- 54 -
C-LOGGER 取扱説明書
5.使用方法
メニュー
:「ウィンドウ(W)」−「新規 YT ウィンドウ(Y)」
ツールバー :
再度コマンドを実行すれば、そのファイルに対して複数の YT ウィンドウが起動さ
れます。
・複数のファイルに対して YT ウィンドウを起動する
1. ファイルビューアで、YT ウィンドウを起動するファイルを選択します。
2. YT ウィンドウ起動コマンドを実行します。
3. ファイルビューアで、別のファイルを選択します。
4. YT ウィンドウ起動コマンドを実行します。
■ YT ウィンドウの絶対時間と相対時間表示
YT ウィンドウの T 軸(時間軸)は、2 種類の表示方法から選択できます。
絶対時間:収集開始時間を絶対時間として表示します。
相対時間:収集開始時間を 0 として表示します。
- 55 -
C-LOGGER 取扱説明書
5.使用方法
絶対時間と相対時間の切り替えは、以下のコマンドで行います。
メニュー
:「表示(V)」−「YT グラフ T 軸単位」−「絶対時間」、「相対時間」
ツールバー
:
■ YT ウィンドウの自動スクロール
YT ウィンドウの自動スクロール機能を ON にすると、ズーム画面が常に新しい収集
データを表示するように、全体画面のスコープが自動的にスクロールします。自動ス
クロール機能の切り替えは、以下のコマンドで行います。
メニュー
:「表示(V)」−「YT グラフ自動スクロール」
ツールバー
:なし
■ YT ウィンドウのキーボード操作
YT ウィンドウでよく使用される機能は、キーボードからも行うことができます。
・ スコープの拡大/縮小
Alt + →
:横軸を 2 倍に拡大します。
Alt + ←
:横軸を 1/2 に縮小します。
Alt + ↑
:縦軸を 2 倍に拡大します。
Alt + →
:縦軸を 1/2 に縮小します。
・ カーソルの表示/非表示切り替え
Alt + A
:カーソル A の表示/非表示を切り替えます。
Alt + B
:カーソル B の表示/非表示を切り替えます。
・ ズーム画面のスクロール
←または→
:1データ分左右にスクロールします。
Shift + ←または→ :8 データ分左右にスクロールします。
Ctrl + ←または→ :64 データ分左右にスクロールします。
↑または↓
:1ビット分上限にスクロールします。
Shift + ↑または↓ :16 ビット分上限にスクロールします。
Ctrl + ↑または↓ :256 ビット分上限にスクロールします。
5−5 データの保存・読み込み
■ データ形式
収集後のデータは、以下の 2 種類の形式で保存することができます。
- 56 -
C-LOGGER 取扱説明書
5.使用方法
CSV
:データをカンマ(",")で区切って並べたファイル形式で、表計算ソフトやデ
ータベースソフトなど、他のアプリケーションとの汎用性が高いデータ形式
です。
バイナリ :C-LOGGER 専用のバイナリ形式のため、他のアプリケーションとの互換
性はありません。CSV 形式に比べるとファイルサイズは約1/3で、保存
と読み込みも高速に動作します。
■ データの保存
メニュー
:「ファイル(F)」−「上書き保存(S)」、「名前を付けて保存(A)」
ツールバー
:
収集データが新規保存される場合、ファイル保存ダイアログが表示されます。ファイ
ルの種類から、バイナリ形式「CONTEC Logger Binary Data (*.clb)」または CSV 形式
「CONTEC Logger Text Data (*.csv)」を選択します。
ファイル保存ダイアログ
■ ファイルの読み込み
メニュー
:「ファイル(F)」−「開く(O)」
ツールバー
:
C-LOGGER で保存した収集データは、再度 C-LOGGER で読み込んで観測や解析を
行うことができます。
収集ファイルを読み込むには、メニューバーの「ファイル(F)」−「開く(O)」を選択しま
す。ファイル読み込みダイアログが表示されるので、ファイルの種類から、バイナリ
形式「CONTEC Logger Binary Data (*.clb)」または CSV 形式「CONTEC Logger Text
Data (*.csv)」を選択します。また、拡張子が clb のバイナリファイルは C-LOGGER ア
- 57 -
C-LOGGER 取扱説明書
5.使用方法
プリケーションに関連付けされています。エクスプローラーなどからファイルをダブル
クリックすることで、C-LOGGER が起動してファイルの読み込みまで行います。
C-LOGGER はファイルのドラッグ&ドロップにも対応しています。C-LOGGER を起動
し、収集データファイルをドラッグ&ドロップすることでファイルを読み込むこともでき
ます。
5−6 印刷
■ 印刷
YT ウィンドウに描画された収集データを印刷することができます。
メニュー
:「ファイル(F)」−「印刷(P)」
ツールバー
:
- 58 -
C-LOGGER 取扱説明書
5.使用方法
①
① プリンタの選択
印刷を行うプリンタを選択します。
■ プリンタの設定
用紙のサイズや向きを設定します。
メニュー
:「ファイル(F)」−「プリンタの設定(R)」
ツールバー
:なし
- 59 -
C-LOGGER 取扱説明書
5.使用方法
①
②
① 用紙サイズ
印刷する用紙のサイズを選択します。
② 印刷の向き
印刷の向きを設定します。
■ 印刷プレビュー
印刷される内容をプレビューします。
メニュー
:「ファイル(F)」−「印刷プレビュー(P)」
ツールバー
:なし
- 60 -
C-LOGGER 取扱説明書
5.使用方法
5−7 オプション・カスタマイズ
■ YT ウィンドウオプション
YT ウィンドウのオプションダイアログでは、表示内容の変更やカスタマイズを行うこと
ができます。
メニュー
:「表示(V)」−「YT ウィンドウオプション」
ツールバー
:なし
YT ウィンドウオプションには、チャネル、全体、詳細の計 3 つの設定項目からなりま
す。
- 61 -
C-LOGGER 取扱説明書
5.使用方法
②
③
④
①
① 表示チャネルのリスト
データ収集に使用するチャネル一覧が表示されます。チェックボックスへの
ON/OFF により、YT ウィンドウ内でのチャネル表示/非表示を切り替えることがで
きます。
② ライン色の設定
グラフ描画に使用するライン色の変更を行います。
③ ドット表示の設定
ドット表示を有効にすると、収集データのサンプリング位置にドットを表示します。
ドット表示あり
ドット表示なし
④ アクティブチャネルの設定
ボタンをクリックすると、チャネルリストで選択中のチャネルがアクティブチャネル
に設定されます。
- 62 -
C-LOGGER 取扱説明書
5.使用方法
①
②
③
④
⑤
⑥
⑦
① 背景色
YT グラフの外側にあたる背景色を設定します。
② 文字列色
グラフタイトル、T 軸タイトル、Y 軸タイトルに使用される色とフォントを設定しま
す。
③ グラフタイトル
タイトルの表示/非表示と、タイトル文字列を設定します。
④ T 軸タイトル
タイトルの表示/非表示と、タイトル文字列を設定します。
⑤ Y 軸タイトル
タイトルの表示/非表示と、タイトル文字列を設定します。
⑥ グラフの 2 分割表示
グラフとして全体画面とズーム画面の 2 画面を使用するか、ズーム画面のみを
使用するかを設定します。
⑦ チャネル名ラベル
チャネル名ラベルの表示/非表示を切り替えます。
- 63 -
C-LOGGER 取扱説明書
5.使用方法
①
②
③
④
⑤
① グラフ背景色
YT グラフ内の背景色を設定します。
② グラフグリッド線色
グラフのグリッド(格子)線色を設定します。
③ カーソル色
カーソル色を設定します。
④ スコープ色
スコープ色を設定します。
⑤ 小数点以下桁数
Y 軸に表示される目盛りの、小数点以下の桁数を設定します。設定可能範囲は 0
∼5 です。
■ 数値ウィンドウオプション
数値ウィンドウのオプションダイアログでは、表示内容の変更やカスタマイズを行うこ
とができます。
メニュー
:「表示(V)」−「数値ウィンドウオプション」
ツールバー
:なし
- 64 -
C-LOGGER 取扱説明書
5.使用方法
①
②
③
① 文字列色
数値のフォントを設定します。(文字列色は黒固定です)
② 背景色
ウィンドウの背景色を設定します。
③ 表示チャネルのリスト
データ収集に使用するチャネル一覧が表示されます。チェックボックスへの
ON/OFF により、数値ウィンドウ内でのチャネル表示/非表示を切り替えることが
できます。
■ メモリオプション
メモリオプションでは、C-LOGGER 内で確保可能なメモリの最大値を設定します。メ
モリの最大値が大きいほど、長時間のデータ収集が可能になります。C-LOGGER で
確保するメモリを超えるデータ収集条件が設定された場合、C-LOGGER は全ての収
集データを保存することができません。メモリの上限を超えた場合、C-LOGGER は再
度メモリの先頭からデータを格納して行き、以前のデータは失われます。
(全ての収集データを保存するには、ファイルの自動保存を行う必要があります)
デフォルトでは確保する最大のメモリが 10×1,000,000 [WORD] (一千万点のデータ
- 65 -
C-LOGGER 取扱説明書
5.使用方法
に相当)に設定されています。
■ オプションの保存
YT ウィンドウ、数値ウィンドウ、メモリに関するオプション設定を保存します。
■ オプションのリセット
YT ウィンドウ、数値ウィンドウ、メモリに関するオプション設定をデフォルト設定に戻し
ます。
- 66 -
C-LOGGER 取扱説明書
6.仕様
6 仕様
項目
仕様
サポート OS
Microsoft
Microsoft
Microsoft
Microsoft
Windows
Windows
Windows
Windows
対応言語
日本語, 英語
推奨動作環境
Pentium4 1GHz 以上の CPU、512M バイト以上のメモリ
対応 EXCEL
EXCEL2000, EXCEL2002, EXCEL2003
サポートデバイス
アナログ F シリーズ
ADA16-32/2(PCI)F, ADA16-32/2(CB)F
アナログ EV シリーズ
AD12-16(PCI)EV, AD12-16U(PCI)EV
AD16-16(PCI)EV, AD16-16U(PCI)EV
アナログ L シリーズ
ADA16-8/2(LPCI)L, ADA16-8/2(CB)L
ADAI16-8/2(LPCI)L
AD16-64(LPCI)LA, AD16-16(LPCI)L
- 67 -
2000
XP Professional
XP Home Edition
Server 2003
C-LOGGER 取扱説明書
7.付録
7 付録
7−1 Q&A
Q1.C-LOGGER を起動すると、デバイスドライバのバージョンが古いというメッセー
ジが表示されてしまいます。
A1.デバイスドライバを最新バージョンにアップデートしてください。(→P9)
Q2.収集ウィザードで EXCEL への転送を設定しているのですが、転送されていませ
ん。
A2.EXCEL のバージョンを確認してください。EXCEL2000 以前のバージョンには対
応していません。
Q3.サンプリングクロックを高速にするとエラーが発生します。
A3.デバイスドライバの処理が間に合っていません。サンプリングクロックを遅くして
ください。
Q4.CSV 形式でファイル保存を行うと、C-LOGGER がロックします。
A4.CSV 形式でのファイル保存には時間がかかります。
Q5.C-LOGGER のソースコードはどこで手に入りますか?
A5.C-LOGGER のソースコードは公開しておりません。
Q6.CSV のデータを読み込むと C-LOGGER が強制終了します。
A6.C-LOGGER で保存した CSV ファイルを EXCEL などで読み込むと、ファイルの内
容が変更されます。変更されたファイルは C-LOGGER では読み込むことがで
きません。
Q7.EXCEL 転送中にエラーが発生して収集が停止します。
A7.サンプリングクロックが速すぎるため、EXCEL 転送が間に合っていません。サン
プリングクロックを遅くしてください。
Q8.サポート以外のデバイスでも動作可能ですか?
- 68 -
C-LOGGER 取扱説明書
7.付録
A8.API-AIO(WDM)でサポートされているデバイスならば動作する可能性はあります
が、サポート外のデバイスを使用した場合、発生する一切の現象に関してはお
客様の責任のもとで行ってください。
Q9.Windows 98 または Me でも動作可能ですか?
A9.動作する可能性はありますが、サポート外の OS を使用した場合、発生する一
切の現象に関してはお客様の責任のもとで行ってください。
Q10.どのくらい長時間の収集が可能ですか?
A10.C-LOGGER の仕様としては無限収集に対応していますが、実際にはハードデ
ィスクの空き容量に依存します。
Q11.AD コンバータの校正を C-LOGGER から行えますか?
A11.C-LOGGER では行えません。校正ユーティリティが、デバイスドライバと共に
インストールされていますので、こちらを使用してください。
スタートメニューの「ファイル名を指定して実行」から、「CAIOCAL」と入力します。
Q12.デバイス選択ダイアログに、インストールしたはずのデバイスが表示されませ
ん。
A12.デバイス名が設定されていない可能性があります。2−2の設定をもう一度、
ご確認下さい。
7−2 メッセージ一覧
■ デバイスドライババージョンチェックエラー
ハードウェアのデバイスドライバがインストールされていないか、またはバージョンが
古い場合、以下のエラーメッセージが表示されます。「2−1 デバイスドライバのイ
ンストール」を参考に、最新のデバイスドライバをインストールしてください。
- 69 -
C-LOGGER 取扱説明書
7.付録
■ メモリ確保エラー
C-LOGGER は、収集データの格納用に最大で約 200MB のメモリを使用します。メモ
リの確保でエラーが発生する場合、以下の対策が必要です。
・ 使用しないアプリケーションや常駐プログラムを終了し、使用可能メモリを増やし
てください。
・ メモリオプション(「5−7 オプション・カスタマイズ」)で、確保可能なメモリの最大
値を少なくしてください。
■ 収集ファイル読み込みエラー
C-LOGGER で読み込めない形式のファイルです。C-LOGGER で保存したファイル以
外のフォーマットは、読み込むことができません。また、拡張子が csv のファイルであ
っても、他のアプリケーションで作成、または変更されたファイルは読み込むことがで
きません。
■ EXCEL転送エラー
EXCEL 転送が間に合っていません。サンプリングクロックを遅くしてください。
■ オーバーフローエラー
デバイスドライバの処理が間に合っていません。サンプリングクロックを遅くしてくだ
さい。
- 70 -
C-LOGGER 取扱説明書
7.付録
7−3 参考データ
高速・長時間でのデータ収集が実現可能かどうかは、使用するデバイスや PC の性
能などに依存します。この章では、いくつかの条件でデータ収集を行い、無限サンプ
リング可能かどうかの測定を行っています。各表に記述されている値が、設定可能
なサンプリングクロック上限の目安になります。
■
・
・
・
・
・
共通条件
OS は Windows XP を使用
使用チャネル数は1チャネル
サンプリング回数は無限に設定
メモリサイズはデフォルトの 10×1,000,000 [WORD]
データ収集中は、YT ウィンドウを1つだけ起動
■ ADA16-32/2(PCI)F
収集条件
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 10usec
最大 7usec
テキストファイルへの自動保存
最大 500usec
最大 300usec
最大 6msec
最大 3msec
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 2usec
最大 2usec
テキストファイルへの自動保存
最大 4usec
最大 3usec
エクセルへの転送設定
最大 6msec
最大 3msec
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 10usec
最大 10usec
テキストファイルへの自動保存
最大 100usec
最大 100usec
最大 6msec
最大 3msec
エクセルへの転送設定
■ AD12-16U(PCI)EV
収集条件
■ AD16-64(LPCI)LA
収集条件
エクセルへの転送設定
- 71 -
C-LOGGER 取扱説明書
7.付録
C-LOGGER の使用メモリサイズを少なくすることによって、設定可能なサンプリング
クロックの上限は向上する場合があります。以下は、先ほどの共通条件からメモリサ
イズのみを変更したときの結果です。
■ 共通条件
・ メモリサイズは 1×1,000,000 [WORD]
■ ADA16-32/2(PCI)F
収集条件
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 4usec
最大 4usec
テキストファイルへの自動保存
最大 40usec
最大 30usec
エクセルへの転送設定
最大 6msec
最大 3msec
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 2usec
最大 2usec
テキストファイルへの自動保存
最大 4usec
最大 3usec
エクセルへの転送設定
最大 6msec
最大 3msec
Pentium 4 2.5GHz
512MB Memory
Athlon 64 4000+ 2.4GHz
1.0GB Memory
バイナリファイルへの自動保存
最大 10usec
最大 10usec
テキストファイルへの自動保存
最大 20usec
最大 20usec
エクセルへの転送設定
最大 6msec
最大 3msec
■ AD12-16U(PCI)EV
収集条件
■ AD16-64(LPCI)LA
収集条件
- 72 -
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement