StripExperiment 取扱説明書

StripExperiment 取扱説明書
StripExperiment 取扱説明書
suzuki
平成 20 年 1 月 14 日
1
目次
1
StripExperiment とは
2
2
操作手順
2.1 実行ファイルを作成する . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2
2
2.2
2.3
起動する . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3
3
2.4
2.5
2.6
動かしてみる . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
ファイルを読み込む
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
ストリップを作成する . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
速度を比較してみる
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
4
4
5
3
マウス操作の説明
5
4
ツリーウィンドウの説明
5
各メニューの説明
5
5.1
File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5.1.1 Open pcm file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5
6
5.1.2 Open obj file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5.1.3 Open 3ds file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
6
6
6
5.2.1
5.2.2
Display polygon line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Setting light parameter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
6
6
5.2.3
5.2.4
5.2.5
Reset coordinate . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Scaling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Separate color of strips . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
6
6
6
5.3
Create . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5.3.1 Create triange strip . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
6
6
5.4
Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5.4.1 About StripExperiment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
7
7
5
5.2
6
1
トライアングルストリップ作成のアルゴリズム
7
StripExperiment とは
ポリゴンで構成されている 3D モデルデータからトライアングルストリップを作成し、描画速
度を比較したりするソフトです。
現在は一種類のアルゴリズム (SGI アルゴリズム) からしかトライアングルストリップを作成す
る事しかできませんが、近い将来複数のアルゴリズムから選択できるように改良する予定です。
2
操作手順
2.1
実行ファイルを作成する
ダウンロードしてきた tar ファイルを解凍てください。そして作成されたディレクト
リに移動して
2
$ make
とコマンドしてください。
make に必要なパッケージは
libgtk2.0-dev
ユーザーインターフェース作成に必要です
gcc , g++
コンパイルするのに必要です
build-essetial
コンパイルするのに必要です
libglu1-mesa-dev
3D グラフィックス用のライブラリです
表 1: 必要なパッケージ
2.2
起動する
make を行ったディレクトリ上でコマンドプロンプトから
$ ./StripExperiment.elf
とタイプしてください。
2.3
ファイルを読み込む
ファイルメニューから選んでください。三種類のフォーマットが読み込めます。
pcm
日本の Adventure Project のフォーマットです。
obj
Wavefront 社のフォーマットです、一般的なフォーマットなので Web
上でフリーのデータがあります。
3ds
もっとも普及している 3DCG ソフト 3D Studio Max のフォーマッ
トです。Web 上でフリーのデータがたくさんあります。
3
sample というディレクトリに簡単な pcm データがありますので、開いてみてくだ
さい。
2.4
動かしてみる
マウスの右ドラッグで回転、左ドラッグで並行移動、スクロールで画面に垂直に並
行移動します。
2.5
ストリップを作成する
メニューの Create から Create triangle strip を選んでください。
次の図のように作成の進行度をあらわすプログレスバーが表示されます。
プログレスバーが消えたらストリップが完成です。
どのようなストリップができたのかを確認するにはメニュー Display から Separate
color of strip を選択をしてください。
4
速度を比較してみる
2.6
左のツリーウィンドウから attribute を選んでください、Draw Method の項目を展
開し、描画方法をダブルクリックで選んでください。
描画ウィンドウの fps が描画速度を表します。
fps とは 1 秒間に描画できている回数です。fps が高ければ高いほど描画が速いとい
うことです。
3
マウス操作の説明
マウス操作の説明です。
右ボタンを使ったドラッグで回転。左ボタンを使ったドラッグで並行移動。スクロールで画面
に垂直に並行移動します。
4
ツリーウィンドウの説明
ツリーウィンドウはタブによって切り替わります。hierarchy タブはモデルの階層情報を表し
ます。
attribute タブはモデルの色や描画方法の変更ができます。
5
各メニューの説明
5.1
File
ファイル読み込みのメニューがあります。
5
5.1.1
Open pcm file
Adventure project の pcm ファイルを読み込みます。
5.1.2
Open obj file
obj ファイルを読み込みます。
5.1.3
Open 3ds file
3D Studio Max の 3ds ファイルを読み込みます。
5.2
Display
表示に関するメニューが並びます。
5.2.1
Display polygon line
ポリゴンに線を描きます。
5.2.2
Setting light parameter
ライトパラメーターを設定するダイアログを表示します。
5.2.3
Reset coordinate
モデルの座標系をリセットします。
5.2.4
Scaling
モデルを拡大縮小します。
5.2.5
Separate color of strips
ストリップを色分けします。
5.3
Create
ストリップを作成するメニューがならんでいます。
5.3.1
Create triange strip
ストリップを作成します。
6
5.4
Help
ヘルプに関するメニューがあります。
5.4.1
About StripExperiment
ヘルプウィンドウを表示します。
6
トライアングルストリップ作成のアルゴリズム
現在実装しているのは SGI アルゴリズムと呼ばれる三角形を三方向にストリップ化したものを
伸ばし、それらを比較するものです。
7
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement