Enterprise Reporting Refresh Pack V9.1.2 - User Guide

Enterprise Reporting Refresh Pack 9.1.2
User Guide
1. INTRODUCTION
1.1. About this Guide
This guide is intended to provide all the information needed to start creating financial reports with your
configured Enterprise Reporting OLAP cube.
1.2. Intended Audience
This guide is for the user(s) in your organization who will be creating financial reports and require an
understanding of the Enterprise Reporting integration and OLAP cube.
1
2. INTEGRATION ARCHITECTURE OVERVIEW
Enterprise Reporting is a web-based financial reporting application integrated with your Elite Enterprise
system and connected through IBM Clarity 7. The integrated solution includes a multi-dimensional OLAP
cube pre-configured with your Elite GL account segments.
The integration layer comprises of a Data Mart and OLAP cube that is kept in synchronization with
Enterprise via an integration log table (ClarityIntegration) that is created in the Enterprise database. As
changes are posted in Enterprise, notification entries with Change Types are posted into this table to
indicate synchronization is required. The notification is sent to the Data Mart via SQL Server Service
Broker (real-time message queuing) or polling SQL job (near real-time).
2.1.
Cube Overview ......................................................................................................................... 3
2.1.1.
Dimensions....................................................................................................................... 3
2.1.2.
Measures ......................................................................................................................... 4
2.2.
Currency Conversions............................................................................................................... 5
2.2.1.
EGR .................................................................................................................................. 5
2.2.2.
Non-EGR Multi-Currency .................................................................................................. 5
2
2.1. Cube Overview
The Enterprise Reporting cube pre-configured with your account segments consists of the following
dimensions and measures.
2.1.1. Dimensions
The cube dimensions make up the metadata integration and provide the reporting views and filters for
your financial data in the cube.
GL Account Segments. Each account segment in your Elite GL account structure is a separate dimension
in the cube. The naming convention for the GL segments is DimX, where X = GL segment number. Each
dimension in the cube corresponding to your account segment will have a default hierarchy name = Elite
Segment Description.
Example GL Segments in Elite Enterprise
Segment Number Segment Description
1
Company
2
Location
3
Primary
4
Department
Example Cube Dimensions
Dimension Name Hierarchy Name
Dim1
Company
Dim2
Location
Dim3
Primary
Dim4
Department
GLType. This dimension is the General Ledger type identifier for your data. The types are pulled in
through the metadata integration from Elite Enterprise for the General Ledger Types and the Budget
Types. This includes the standard types such as U=Universal, C=Cash Based, A=Accrual Based and custom
types you have in Enterprise.
GLBook. This dimension is the General Ledger book identifier for your data. By default, two books are
pre-configured Cash and Accrual. In the metadata integration, by default, any standard types in Elite
(beginning with A, C or U) are automatically mapped to these two default book types. Custom types can
be manually added via the GL Book Types Control template in Application Console to create the linked
relationship to a book. You can reference GLBook dimension without referencing GLType based on this
linked relationship between the two dimensions.
Example linked dimensions
GL Type GL Book
A
Accrual
A1
Accrual
U
Accrual
C
Cash
U
Cash
3
Period. This dimension is for your fiscal periods. The dimension members are named P01 to P12
including YTD members P01 – YTD to P12 – YTD. When transaction summary data is loaded from Elite to
the Enterprise Reporting cube, the data is mapped to your fiscal periods where P01 = Start of your Fiscal
Month. By default, the period aliases are set as January to December. You can update the month aliases
based on your firm’s fiscal start month.
Year. This dimension is for your fiscal years. The cube has a 5 year rolling window to help maintain cube
performance as data is loaded to the cube pre-calculated with currency conversions. The 5 year window
is determined by your current fiscal year in Enterprise. For example, if your current fiscal year is 2011,
the cube will have the following years: 2006-2012 where Year 2006 opening period (OP) contains the
beginning balance of all historical years prior to the minimum year in the cube. When you close your
fiscal year in Enterprise, a year rollover in the integration will be executed updating range to 2007-2013
where prior minimum year 2006 is now rolled into Year 2007 opening period.
Scenario. This dimension by default has members Actual and Budget that you can use to filter the cube
data.
Currency. In the data integration, currency conversions are pre-calculated and loaded to the cube. The
data loads will convert your transactions in Elite automatically to your Firm Currency, to your Unit or
Company Currency and to reporting currencies that you can set up in the integration. This dimension is
used to filter the converted data by currency type or non-converted data by currency code (transaction
currencies).
Value. This dimension is the source identifier for your data. The default member value is “GL” (General
Ledger). If your Elite configuration is Non-EGR Multi-Currency, “GL” is concatenated with Year and
Period for restatements. Example member value is “GL201108” indicating which daily rate was used to
convert transactions from beginning of time to ending period for accounts with account translation
method ‘L’ (Last Day of the Month). See section on Currency Conversions for further details.
2.1.2. Measures
The cube measures make up the data integration and provide the reporting data for your financial
statements. Measures suffixed with “Inactive” are for historical restatements, specific to Non-EGR
Multi-Currency (see section on Currency Conversions).
Example measures include:
• Amount. Amounts based on your account normal balances for your Actuals and Budget data.
• Amount Inactive. Amounts based on your account normal balances for historical restatements.
• Debit. Debit value balances for your Actuals data.
• Debit Inactive. Debit value balances for historical restatements.
• Credit. Credit value balances for your Actuals data.
• Credit Inactive. Credit value balances for historical restatements.
• Trial Balance Amount. Trial balances (Debit minus Credit) for your Actuals data.
• Trial Balance Amount Inactive. Trial balances (Debit minus Credit) for historical restatements.
• Restated Amount. Calculated member that you can reference for restatements without having to
separately reference between Amount and Amount Inactive (specific to Non-EGR Multi-Currency).
4
2.2. Currency Conversions
Currency conversions in the data loads use the same conversion logic as the Elite Trial Balance.
2.2.1. EGR
The transactions are converted using the daily rate at the time of the transaction posted in the GL (using
the currency date). General journal spot rates or fixed rates are also applied in the currency conversion
logic and FX revaluations are included. Based on this currency conversion logic, transactions are
converted in the data load process to the Data Mart, providing a cube with data already converted and
requiring no on-the-fly conversions when you run a report.
Example cube data intersection:
Year
Period
GLType Currency Natural Company Location Scenario Value
Amount
2011
P03
A
FIRM
1000
1
000
Actual
GL
1000
This means transactions posted to March was converted to your Firm Currency using the daily period
ending rate 03/31/2011 since they were posted to the GL in March.
2.2.2. Non-EGR Multi-Currency
The transactions are converted based on the Account Translation Method for each account below.
General journal spot rates or fixed rates are also applied in the currency conversion logic.
• Account Translation Method: L = Last Day of Month. Restate transactions for the account from
beginning of time to end of specified period using the same period ending daily rate.
• Account Translation Method: A = Average, H = Historical. Convert transactions for the account using
the exchange rate at the time of each transaction.
Data is converted or “restated” into the Data Mart, such that data is pre-calculated and loaded to the
cube for faster retrieval performance as opposed to doing this restatement or conversion “on-the-fly”.
The restated data for each period ending rate is identified by the Value dimension: GL+Year+Period.
Example: GL201108 = all transactions from beginning of time to end of 2011 P08 is converted using the
same rate 08/31/2011 (for accounts with translation method = L). An “Active Restatement” is for your
current and prior period fiscal periods. A “Historical Restatement” is for periods earlier than prior period
up to two prior fiscal years.
Example cube data intersections if current fiscal year = 2011 and current fiscal period = P08:
Current Period Restatement
Year
Period GLType Currency Natural Company Location Scenario Value
Amount
2011
P03
A
FIRM
1000
1
000
Actual
GL201108 1000
This means transactions posted to March 2011 was converted to your Firm Currency using the current
period ending rate 08/31/2011 since this is a balance sheet account with translation method = “L”.
Prior Period Restatement
Year
Period GLType Currency Natural Company Location Scenario Value
Amount
2011
P03
A
FIRM
1000
1
000
Actual
GL201107 1050
This means the same transactions posted to March 2011 was converted to your Firm Currency using the
prior period ending rate 07/31/2011 since this is a balance sheet account with translation method = “L”.
5
Historical Restatement
Year
Period GLType Currency Natural Company Location Scenario Value
Amount
2008
P12
A
FIRM
1000
1
000
Actual
GL201005 5000
This means the transactions posted to December 2008 was converted to your Firm Currency using the
period ending rate 05/31/2010 since this is a balance sheet account with translation method = “L”.
6
3. CREATING FINANCIAL REPORTS
This section details on how to create reports specific to the Enterprise Reporting cube with Clarity Studio
7.2.1. For further details on creating a report, you can also reference the help in Clarity Studio.
3.1.
Download Center ..................................................................................................................... 8
3.2.
Create a Report from a Style .................................................................................................... 8
3.3.
Create a Report from a Blank Document .................................................................................. 9
7
3.1. Download Center
With Clarity Studio 7.2.1, the Quickstart feature is available where you can build a report from a style for
quicker report building.
When Enterprise Reporting is installed, pre-boxed styles are available for download and are preconfigured for your cube and your GL segments. An installer is provided with the download that will be
needed to run to install to your Application Data folder. Once installed, the styles are available from
Clarity Studio (New > Sample Styles) to start building a report from.
3.2. Create a Report from a Style
To start creating a financial report, you can do the following steps to create a report from a pre-boxed
style:
1. In Clarity, navigate to the Administration > Download Center menu.
2. Click on the Download button to download the Quickstart.zip file.
3. Unzip its contents to your desktop and run the ClarityStudioStyles-Setup.exe utility found in the
distributable package.
4. Open Clarity Studio 7.2.1 and go to Connections -> Manage Connections to set up the connection to
the Clarity Application Server.
5. To start using one of the pre-boxed styles, go to New- > Sample Styles -> Clarity_ENT (the name of
the Enterprise Reporting Database) and choose the financial statement style from which to create a
report.
6. Choose Open.
8
7. A window displays with the pre-set parameters grayed out:
The member specification for each dimension is displayed in the Filters, Columns, and Rows boxes.
Where the specifications can be edited, click on the dimension to access the Member selector. For
further details on this configuration window and the Quickstart feature, you can access the Clarity
Studio help.
If in the Task pane any validations checks are marked as failed (
), log into Clarity and navigate to
Application Console -> Sync OLAP Manager tool, to synchronize the dimensions in OLAP Manager to
match your current reporting cube and reflect in Clarity Studio when you refresh sources. You may also
need to clear the Clarity Studio cache and exit and go back into Clarity Studio.
8. Choose Finish.
9. The report is opened in Clarity Studio and can be further edited according to reporting needs.
10. Choose File > Save & Send > Publish to Server to publish the newly created report from style to
Clarity Server.
3.3. Create a Report from a Blank Document
To start creating a financial report from a blank document, a step-by-step example is provided in this
section.
1.
Open Clarity Studio 7.2.1 and go to File → New →New – Blank Document.
Laying out the report in the Excel
2. In the bottom-right-hand corner of the screen select the Excel View. This will maximize the Excel
tab.
3.
Format your excel file to match the following screen shot:
9
Creating the connection to the OLAP and relational databases
4. Change the view back to the split view, click on Data in the Navigation Pane.
5.
Right click on Data in the top of the Data pane and select Add Source.
6.
Add the Clarity and ClarityDB sources for the cube and relational database.
Creating OLAP Member Lists and Page Options- GL Book dimension
Notes:
In order to use a GL Type dimension member and have data return on the reports, the GL type must be
mapped to a GL Book. There are two default GL Books:
• Cash
• Accrual
In Enterprise Reporting, all the GL Types starting with:
•
C (for Cash) and U (for Universal) are mapped to the GL Book Cash
• A ( for Accrual) and U (For Universal) are mapped to the GL Book Accrual
Since the GL Book dimension is linked to the GL Type dimension, when building a report, the GL Type
dimension does not need to be specified in the Olap Data Map.
7.
Go to Data pane and add a new Olap member list for the GL Book dimension.
8.
Rename the query name from OlapMemberList1 to OlapMemberGLBook.
9.
Click on the GL Book row and column intersection.
10.
Right-click the All member located at the left in the Design pane and select Children
10
11. The result should resemble the following:
12. Navigate to the Document tab.
13. Click on the Page Options node and type Income Statement – Comparative in the caption field.
14. Right click on the Page Options node and click Add Page Option.
15. Change the name of the page option to PageOptionGLBook.
16. For the Prompt field, type in GL Book.
17.
Select the Dropdown display type.
18. In the List dropdown, select OlapMemberGLBook.
19. Check Visible checkbox.
20. Go to the Excel file, select cell C9 and click on Display in current cell.
21. Select Name or Caption as needed.
22. The page option design window should resemble the following:
11
Creating OLAP Member Lists and Page Options- Year dimension
23. Go to Data pane and add a new Olap member list for the Year dimension.
24. Change the Olap Member Name in the Query name field from OlapMemberList1 to
OlapMemberYear.
25. Right click the All member from the hierarchical view and choose Children.
12
26. Click on Document tab in the Navigation pane and add a new page option.
27. Change the name of the Page Option from PageOption1 to PageOptionYear.
28. For the Prompt type Year.
29. Select Dropdown display type.
30. In the List dropdown, select OlapMemberYear.
31. Select Visible checkbox.
32. Go to the Excel file, select cell C13 and click on Display in current cell.
33. Select Name or Caption as needed.
Creating OLAP Member Lists and Page Options- Period dimension
34. Go to Data pane and add a new Olap member list for the Period dimension.
35. Change the Olap Member Name in the Query name field from OlapMemberList1 to
OlapMemberPeriod.
36. Expand the Period dimension from the hierarchical view; double click on each month from January
to December.
37. The Olap Member List should resemble the following:
13
38. Click on Document tab in the Navigation pane and add a new page option.
39. Change the name of the Page Option from PageOption1 to PageOptionPeriod.
40. For the Prompt type Period.
41. Select Dropdown display type.
42. In the List dropdown, select OlapMemberPeriod.
43. Select Visible checkbox.
44. Go to the Excel file, select cell C12 and click on Display in current cell.
45. Select Name or Caption as needed.
Creating OLAP Member Lists and Page Options- Currency dimension
Notes:
You can configure your reports to show the Currency Type and Currency Code page options based on the
selected Unit by using the following SQL Server functions:
• For Currency Type : select list from dbo.fnc_Utility_GetCurrencyTypeList(‘unit_reference’)
• For Currency Code: select list from
dbo.fnc_Utility_GetCurrencyCodeList(‘unit_reference’,’currencyType_reference’,default)
• For the OLAP Currency page option you can use a similar MDX query: iif(
‘currencyType_reference’ = ‘Transaction Currencies’,
StrToMember('[Currency].[currencyCode_reference]'), StrToMember('[Currency].[
currencyType_reference ') )
46. Create a Unit Olap Member List and a Unit Page Option.
47. On the ClarityDB source add a new query named RelationalQueryCurrencyType.
14
48. Type the following select for the Currency Type: “Select list from
dbo.fnc_Utility_GetCurrencyTypeList('{PageOptions.PageOptionUnit.Key}')”
49. Navigate to the Code file and make sure that the relational query “RelationalQueryCurrencyType”
resembles the following:
50. Right-Click on RelationalQueryCurrencyType query and add a relational list.
51. Change the name of the relational list from RelationalList1 to RelationalListCurrencyType.
52. On the Key drop-down select the “list” field:
53. Go to the Navigation pane, click on Document tab and add a new page option.
54. Change the name of the page option from PageOption1 to PageOptionCurrencyType, for instance.
15
55. For the Prompt type Currency Type.
56. Select the Dropdown display type.
57. In the List dropdown, select RelationalListCurrencyType.
58. Check Visible.
59. Go to the Excel file, select cell C10 and click on Display in current cell.
60. Select Name or Caption as needed.
61. In the Dependencies section, add PageOptionUnit. The new page option should resemble the
following:
62. Navigate to the Data pane, right-click on the ClarityDB source and add a new query.
63. Change the name of the of the query name to RelationalQueryCurrencyCode.
16
64. Type in the following select: “select list from
dbo.fnc_Utility_GetCurrencyCodeList('{PageOptions.PageOptionUnit.Key}','{PageOptions.PageOption
CurrencyType.Key}',default)”
65. Navigate to the Code file and make sure that the relational query “RelationalQueryCurrencyType”
resembles the following:
66. Right-Click on RelationalQueryCurrencyType query and add a new relational list.
67. Change the name of the relational list from RelationalList1 to RelationalListCurrencyCode.
68. On the Key drop-down select the “list” field. Your relational list should resemble the following:
69. Go to the Navigation pane, click on Document tab and add a new page option.
70. Change the name of the page option from PageOption1 to PageOptionCurrencyCode, for instance.
17
71. For the Prompt type Currency Code.
72. Select the Dropdown display type.
73. In the List dropdown, select RelationalListCurrencyCode.
74. Check Visible.
75. Go to the Excel file, select cell C11 and click on Display in current cell.
76. Select Name or Caption as needed.
77. In the Dependencies section, add PageOptionUnit and PageOptionCurrencyType. The new page
option should resemble the following:
78. Go to the Navigation pane and select the Data tab.
79. Right-click on the Clarity database and add a new OLAP Member List for the Currency dimension.
80. Change the name of the query to OlapMemberCurrency.
81. Double-click Snippet located at the left and a Snippet button will appear on the currency dimension
item.
18
82. Click on the Snippet button and type in the following query:
“iif('{PageOptions.PageOptionCurrencyType.Name}' = 'Transaction Currencies',
StrToMember('[Currency].[{PageOptions.PageOptionCurrencyCode.Key}]'),
StrToMember('[Currency].[{PageOptions.PageOptionCurrencyType.Key}]') )”
83. In the Navigation pane go back to the Document tab and add a new page option called
PageOptionCurrency.
84. For the Prompt type Currency.
85. Select the Dropdown display type.
86. In the List dropdown, select OlapMemberCurrency.
87. Go to the Excel file, select cell C15 and click on Display in current cell.
19
88. Select Name or Caption as needed.
89. In the Dependencies section, add PageOptionCurrencyType and PageOptionCurrencyCode.
90. The page option should resemble the following:
Creating OLAP Member Lists and Page Options- Value dimension
Notes:
•
•
•
•
The Value dimension members vary based on the Enterprise setup.
For the EGR and Non-EGR Single Currency setups the Value dimension member to use is General Ledger
(GL). All the Actual and Budget data from Enterprise is stored in this member.
For the Non-EGR Multi-currency setup, the Actual and Budget data is not stored in General Ledger
member but in a “restatement” member with naming format GL+YEAR+PERIOD. Example: GL201101. See
the section on Currency Conversions.
When building reports for data in a Non-EGR Multi-Currency setup, recommendation is to use the
following queries for the Value dimension:
• If year and period can be selected:
StrToMember('[Value].[GL'+LEFT(RIGHT('year_reference',5),4)+LEFT(RIGHT('period_reference',3),
2)+']')
• Using the “Status” property to default to the current period: Filter
([Value].[Restatements].children, [Value].CurrentMember.Properties(“Status”)=”CP”)
91. Go the Navigation pane and add a new Olap Member List for Value dimension.
20
92. Change the query name to OlapMemberValue.
93. Double-click Snippet located at the left and a Snippet button will appear on the intersection of your
row and column.
94. Click on the Snippet button and type in the following query:
“StrToMember('[Value].[GL'+LEFT(RIGHT('{PageOptions.PageOptionYear.Key}',5),4)+LEFT(RIGHT('{Pa
geOptions.PageOptionPeriod.Key}',3),2)+']')”.
95. Go to the Document tab and add a new page option called PageOptionValue.
96. For the Prompt type Value.
97. Select the Dropdown display type.
98. In the List dropdown, select OlapMemberValue.
99. Go to the Excel file, select cell C14 and click on Display in current cell.
100. Select Name or Caption as needed.
101. In the Dependencies section, add PageOptionYear and PageOptionPeriod.
21
Setting up the Row Ranges
102. In the Document pane, select Row Ranges node.
103. Add the following Row Ranges:
Row Range Name Location Insert Additional Rows
RowRangeMeta
16:21
RowRangeR1
27:27
checked
RowRangeR2
31:31
checked
RowRangePageFilter
38:38
checked
Setting up the Column Ranges
104. In the Document pane, select Column Ranges node.
105. Add the following Column Ranges:
Column Range Name Location
ColumnRangeMeta
D:F
ColumnRangeC1
H:H
ColumnRangeC2
I:I
ColumnRangeC3
K:K
ColumnRangeC4
L:L
ColumnRangePageFilter
O:O
106. Your Document pane should resemble the following:
22
Mapping Data to Ranges
107. Switch to Data in the Navigation pane.
108. Right-click on the Clarity cube and select Add Olap map.
109. Rename the OlapDataMap1 to OlapDataMapMain.
110. Drag and drop Primary dimension to the Row Members window.
111. Drag and drop Year, Scenario and Period dimension to the Column Members window.
112. Drag and drop the remaining dimensions except GLType to the Page Filters window.
113. Your Olap Map should resemble the following:
Page Filters
114. Click on the Page Filter button to set the Page Members.
115. In the dropdowns for Row and Column Ranges, select ColumnRangePageFilter and RowRangeFilter.
116. Set the dimensions to filter on the following:
Dimension
Company
Filter On
{PageOptions.PageOptionUnit.Key}
23
GL Book
Currency
Value
Measures
{PageOptions.PageOptionGLBook.Key}
{PageOptions.PageOptionCurrency.Key}
{PageOptions.PageOptionValue.Key}
If Enterprise setup is Non-EGR Multi-Currency select Restated Amount,
otherwise select Amount.
117. Your Page Filters should resemble the following:
Column Members
118. Click on the Column Members node beneath OlapDataMapMain.
119. Select RowRangeMeta as Description Row and check Include Captions.
120. Create the following groups:
Group
Range
Year
Scenario
Period
Group1
ColumnRangeC1
{PageOptions.PageOptionYear.Key}
Actual
{PageOptions.PageOptionPeriod.Key}
Group2
ColumnRangeC2
{PageOptions.PageOptionYear.Key}
Budget
{PageOptions.PageOptionPeriod.Key}
Group
Range
Year
Scenario
Period
Group3
ColumnRangeC3
{PageOptions.PageOptionYear.Key}
Actual
[Period].[{PageOptions.PageOptionPeriod.
Name} - YTD]
Group4
ColumnRangeC4
{PageOptions.PageOptionYear.Key}
Budget
[Period].[{PageOptions.PageOptionPeriod.
Name} - YTD]
121. Click on the Row Members node beneath OlapDataMapMain.
122. Select ColumnRangeMeta as Description Row.
123. Check Include Captions, Include Properties and Supress missing rows.
124. Create the following groups:
24
Group
Range
Primary
Group1
RowRangeR1
Select children of Revenue
Group2
RowRangeR2
Select children of Expenses
Adding template tools
125. Click on Features.
126. Right-click Features and select Tools.
127. Add the following tools: Select Options, Open in Excel, Retrieve.
25
4. TRANSACTION DRILL REPORTS OVERVIEW
From your Financial Statements, you can navigate to multiple drill levels to view the transaction details
that make up your summarized data in the cube. Below is a schema of how the drill reports in Enterprise
Reporting are linked.
4.1.
Drill Levels.............................................................................................................................. 27
4.1.1.
Fact Amounts ................................................................................................................. 27
4.1.2.
GL Amount ..................................................................................................................... 28
4.1.3.
Subledger ....................................................................................................................... 28
4.1.4.
ELBS ............................................................................................................................... 29
4.2.
How to hook an OLAP Report to the First Level Drill ............................................................... 30
26
4.1. Drill Levels
Based on the available drill paths, this section details the purpose of each drill report and how to
navigate to it.
4.1.1. Fact Amounts
The Fact Amounts report can be accessed via the Drill – Fact Amount tool on a financial statement to see
the underlying Fact data.
The Drill - Fact Amount button on a financial statement
The layout of the Drill - Fact Amounts report
This first level drill from your selected cube data intersection on your OLAP report drills to the Fact table
which contains the converted summary data loaded from Enterprise to the Data Mart. This first link
retrieves against the Data Mart for retrieval performance and provides the ability to drill from a rollup
you created in Cube Manager.
27
4.1.2. GL Amount
The GL Amount report can be accessed via the Drill – GL Amount tool on a financial statement drilled to
Fact Amounts to see the underlying transactions.
The layout of the Drill - GL Amount report
This second level drill directly accesses the Enterprise database to retrieve your General Ledger Amount
Summary data based on the selected row you drilled from Fact Amounts.
4.1.3. Subledger
The Subledger report can be accessed via the Drill – Subledger tool on a financial statement drilled
through from Fact Amounts to GL Amount.
The layout of the Drill - Subledger report, with different types in the "Source" column
This third level drill directly accesses the Enterprise database to retrieve your Subledger detail data
based on the selected row you drilled from GL Amount.
28
The Source column displays the transaction type for each GL detail row:
• Source = "GJ" => General Journal Detail
• Source = "VO" => Voucher Detail
• Source = "CK" => Check Detail
You can drill to the Elite Billing System (ELBS) for a specific row for further detail by clicking on the “Drill
– ELBS” button. Based on which row you selected to drill on, the drill through will redirect to Matter
Detail, Check Detail or Voucher Detail drill report based on the Source column. For a GJ transaction,
Matter Detail is only available for drill if the transaction originated in the billing system; otherwise, an
informational message will popup indicating drill to Matter Detail is not available for this transaction.
4.1.4. ELBS
This fourth level drill provides detail including cost information from the ELBS system based on whether
you drilled from a GJ, Voucher or Check transaction from the Subledger report. From the Matter Detail
and Check Detail, you can also drill to the Voucher Detail report via the “Drill – Voucher Detail” button.
The Drill - Voucher Detail button on the Drill - Matter Detail report
The layout of the Drill - Voucher Cost Detail report
The Drill - Voucher Detail button on the Drill - Check Detail report
29
4.2. How to hook an OLAP Report to the First Level Drill
In order to link to the Enterprise Reporting custom drill, “Drill to Fact Amounts”, you can do the
following steps:
1. Load your OLAP report into Clarity Studio.
2. Go to the Features tab in the Navigation Pane.
3. Right-click on the Features node and choose "Linked Documents” from the contextual menu or from
the Navigation tab in the ribbon. If you do not see this feature, ensure that in File > Options >
Advanced > Show XML code editor and Show Advanced Pane are checked.
4. Fill in the fields in the Design section of Studio with the following values for the linked document:
a) Name: LinkFactAmounts
b) Open Link: in a new popup window
c) File: switch to the XML Code view and enter drill report location path like below:
<Features>
<LinkedDocuments Enabled="true">
<Rules>
<Rule Enabled="true" Name="LinkFactAmounts">
<Link Caption="Drill to Fact Amounts" DocumentType="Cpm65Doc" DocumentLocation="Reports/Clarity_ENT/Financial/General
Ledger/FACT Amounts.template" ImageLocation="images/document.gif" />
<Display NewTab="false" ExistingTab="false" PopupWindow="true" />
.....
d) Link Using: select the name of the OLAP data map used in the report. A list with two columns:
Target page options and Current link source will appear on the page. Fill in the values from the
"Current link source" column with the correct page options or dimensions.
30
Example of how the fields should be completed
5. In the "Advanced" tab of the Navigation Pane, go to the "Scripts" node and make sure that the file
"custom.js" has been added.
The custom.js script must be added to the report
6. Go to the Features tab in the Navigation Pane, add Tools, click Data category and check off Toolbox
Item “Drill – Fact Amount”.
7. Save the report.
31
Download PDF