Pengwyn Documentation
Release 1.0
Silica
October 03, 2016
Contents
1
Introduction
1.1 Platforms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.2 Hardware requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.3 How to connect the board . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2
Pengwyn SDK
2.1 Installing Virtual Machine . . . . . .
2.2 SDK Structure Overview . . . . . . .
2.3 Connect host PC to Pengwyn board .
2.4 Compile U-Boot, MLO and Kernel .
2.4.1
Build U-Boot & MLO . . .
2.4.2
Build the Kernel . . . . . . .
2.5 Filesystem . . . . . . . . . . . . . .
2.6 Copy the Operating System to the SD
2.7 Pengwyn Flash Memory . . . . . . .
2.8 Code Composer Studio V5 . . . . . .
2.8.1
Access Target File System .
2.8.2
SSH Terminal . . . . . . . .
2.8.3
Running the Debug Session .
3
4
3
3
3
4
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
7
7
11
12
14
14
15
15
16
18
19
21
22
23
Appendix
3.1 Opkg Basics . . . . . . . . . . . . . . . . . . . . . .
3.2 How to confgure a new project in CCS . . . . . . . .
3.2.1
Enabling CCS Capabilities . . . . . . . . . .
3.2.2
Toolchain configuration in CCS . . . . . . .
3.2.3
Starting your project . . . . . . . . . . . . .
3.2.4
Build your project . . . . . . . . . . . . . . .
3.2.5
Opening the Remote System Explorer View .
3.2.6
Configuring the Target Pengwyn Connection
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
25
25
25
25
26
28
29
33
33
Revision History
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
37
i
ii
Pengwyn Documentation, Release 1.0
Version 0.0.1A
Copyright (C)2016 Avnet Silica company
Date 06/11/13
Contents
1
Pengwyn Documentation, Release 1.0
2
Contents
CHAPTER 1
Introduction
This guide explains how to start developing with the Pengwyn in a few steps.
In the following chapters you will learn step by step how to install the SDK and connect the Pengwyn on the development computer.
This SDK runs under Ubuntu 10.4 LTS and it’s based on Sitara SDK.
After the host configuration you will see:
• how to compile the essential firmware: the bootloader and the kernel
• how to create a basic file system and save it on a sd-card.
• how use the development environment Code Composer Studio v5 for creating a basic project, compiling and
debugging it
Basic knowledge of Linux system, specifically Ubuntu, is required.
1.1 Platforms
Sitara SDK supports different platforms.
Platform
Pengwyn
SDK
5.06
PSP
04.06.00.09
U-Boot
2012.10
Kernel
3.2
Toolchain
Gcc4.5.3
Release Date
December 2012
You can get information about the other platforms at:kk
Platform
AM335xEVM
AM335x
StarterKit (SK)
Document EVM
Provider
AM335xEVM
http://www.ti.com/
http://processors.wiki.ti.com/index.php/AM335xStarterKitHardwareUsersGuide
http://www.ti.com/tool/tmdssk3358
1.2 Hardware requirements
• Pengwyn board
• Ethernet cable
• Mini-USB type B cable
• Windows or Linux Host PC with at least 1GB (2GB recommended) of RAM and 40GB of free hard drive space
3
Pengwyn Documentation, Release 1.0
1.3 How to connect the board
Connect the USB cable to the host PC.
Create an Ethernet connection between Pengwyn and the board, in the way that these devices will be on the same
LAN.
A possible configuration is showed below.
Linux System has been pre-flashed on the board.
If you turn on the Pengwyn and the display expansion board is connected the “Matrix Application Launcher v2” will
appear.
4
Chapter 1. Introduction
Pengwyn Documentation, Release 1.0
1.3. How to connect the board
5
Pengwyn Documentation, Release 1.0
6
Chapter 1. Introduction
CHAPTER 2
Pengwyn SDK
Contents:
2.1 Installing Virtual Machine
The development environment is provided as a Virtual Machine image.
To be able to start it you need first to install VirtualBox. Image has been created with VirtualBox version 4.2.6.
Go to:
https://www.virtualbox.org/wiki/Downloads
and download the version for Windows. You need also to download the Extension Pack.
Important: Make sure that the extension pack has the same version of virtual box.
Install the software with all the default options.
Launch the program and follow the following steps:
Tip: If you are using Linux click directly on .ova file and skip to point 3.
1. On the menu select: File → Import Appliance
7
Pengwyn Documentation, Release 1.0
2. Click on “Open appliance. . . ” button and select the iso file “PengwynSDK.ova”.
3. After opening the appliance, click on “Shared Folders” and select a folder to share with Windows.
4. If the host PC has only 1GB RAM go to “machine -> settings” menu and click on “System” tab and change
RAM to 512MB.
8
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
5. The ethernet card must be attached the LAN not the WLAN. To set the correct card, go to menu “machine ->
Settings”. Click on “Network” tab and select your LAN card. Click Ok button to apply your choice.
6. Click the icon “Start” button on the toolbar.
2.1. Installing Virtual Machine
9
Pengwyn Documentation, Release 1.0
7. Every time you connect the mini-USB from the PC to the card. On menu click Device → USB Devices → FTDI.
8. The default keyboard is set to USA layout.
If your keyboard layout is different, to change it, from the menu of Ubuntu:
go to “System -> preferences -> keyboard”.
Select “Layout” tab.
Click on “Add...” button.
Select your keyboard layout and press “add” button. Then select “USA” and click “Remove Button”.
10
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
Press “Close” button.
9. Open a terminal (ctrl + alt + t) and type the following command:
sudo usermod -a -G vboxsf pengwyn
User name is pengwyn, password is pengwyn.
Ubuntu will be launched with the Sitara SDK integrated ready to be used. No installation or other configuration is
required.
2.2 SDK Structure Overview
At the start of the Ubuntu desktop, there are three icons:
• “set local ip and install USBserial”: sets the local IP 192.168.0.20 and enables serial connection to the board
• Code Composer Studio v5: Eclipse based IDE used for both application & debug using gdbserver
• Link to ti-sdk-am335x-evm-05.06.00.00: link to the main directory that contains the Sitara Linux SDK
2.2. SDK Structure Overview
11
Pengwyn Documentation, Release 1.0
The Sitara SDK directory contains the code and tools used to develop for Sitara devices.
You will find the following folders:
bin: Contains the helper scripts for configuring the host system and target device. Most of these scripts are used by
the setup.sh script.
board-support: Contains the SDK components that need to be modified when porting to a custom platform. This
includes the kernel and boot loaders as well as any out of tree drivers.
docs: Contains various SDK documentation such as the software manifest and additional user’s guide. This is also the
location where you can find the training directory with the device training material.
Example-applications: Contains the sources of the TI example applications, as seen during the out-of-box demonstration.
filesystem: Contains the reference file systems. These include the smaller base file system as well as the full-featured
SDK file system.
host-tools: Contains the host side tools such as pinmux and flash tool.
linux-devkit: Contains the cross-compile toolchain and libraries to speed up the development for the target device.
Graphics_SDK_setuplinux_<version>.bin: This is the installer for the graphics SDK. The graphics SDK components
are used by the Sitara Linux SDK to provide additional demos and pre-built Qt libraries to accelerate various Qt
functions.
2.3 Connect host PC to Pengwyn board
For connecting the board click the icon “set local ip and install USBserial” and push “Run in Terminal” button. Enter
the password: pengwyn.
12
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
This script will set the IP address of the host pc to 192.168.0.20 and it will enable USB connection.
To check the configuration is correct use these commands:
ls /dev/ttyUSB*
ifconfig eth0
If all is ok you will see:
Open a terminal (ctrl + alt + t) and open Minicom with the following options:
minicom -w -s
If all works correctly you will se this screen:
Reset the board with the reset button on the board, located near the sd-card slot. You will see the startup of the
Pengwyn on the terminal.
At login insert: root and press enter.
Configure the IP address with the command:
2.3. Connect host PC to Pengwyn board
13
Pengwyn Documentation, Release 1.0
ifconfig eth0 192.168.0.101
Now the connection is completed.
2.4 Compile U-Boot, MLO and Kernel
This document covers the general use of U-Boot v2012.10 and the AMSDK on the following platforms:
am335x EVM am335x EVM-SK Pengwyn
Before starting to build the projects open a terminal (ctrl + alt + t) and go to the root folder of the SDK Sitara:
cd ti-sdk-am335x-evm-05.06.00.00
Type “cd ti-”, and press the “tab” key for autocompletion. Create a folder to copy once completed system images.:
cd board-support
In this folder you will find the projects that we’re going to compile.:
mkdir built-images
This folder will be used as destination for the built images.
2.4.1 Build U-Boot & MLO
Now go into the project U-Boot:
cd u-boot-2012.10-psp05.06.00.00
As TI is suggesting, we, as well, recommend keeping the object files separated when building. You can do this using
the following option parameter when invoking the make command:
O = object-directory
Where “object-directory” is the name of a folder you created for this purpose with:
mkdir object-directory
You can now compile the bootloader with the following commands:
rm -rf ./object-directory
export PATH="/home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/bin:$PATH"
make O=object-directory CROSS_COMPILE=arm-arago-linux-gnueabi- ARCH=arm pengwyn
When the compilation ends you will find the bootloader files in the directory of the object files:
• u-boot.img
• MLO
Copy these files to built-images folder:
cp MLO ../../built-images
cp u-boot.img ../../built-images
14
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
2.4.2 Build the Kernel
From ti-sdk-am335x-evm-05.06.00.00 directory, go to the folder for the development of the operating system:
cd board-support
In this folder there are the projects t we’re going to compile. Now go into the Kernel:
cd linux-3.2.0-psp05.06.00.08
export PATH="/home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/bin:$PATH"
make ARCH=arm CROSS_COMPILE=arm-arago-linux-gnueabi- uImage
When compilation finish do:
cd arch/arm/boot
There you will find the compiled kernel “uImage”, copy it to the folder you created previously (built-images):
cp uImage /home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/board-support/built-images
You do not need to copy the driver modules to the file system because the compiled kernel already includes them.
2.5 Filesystem
The operating system will use the filesystem in the directory:
/home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/targetNFS
Copy to this folder all the files you want in the distribution. In this tutorial we are not going to do any modification to
the filesystem.
The only change that was made was adding the logo showed during the startup of the board.
2.5. Filesystem
15
Pengwyn Documentation, Release 1.0
2.6 Copy the Operating System to the SD
The purpose of this section is to load the operating system on the board. There are several possible solutions to boot
Linux, for this tutorial we use a SD-CARD.
You need to copy to the SD-CARD: the bootloader (u-boot and MLO), uImage kernel and filesystem.
The first step is to be sure that the SD-CARD device is accessible from VirtualBox.
If your PC has a built-in slot for the SD-CARD, the VirtualBox probably will not detect it.
The solution is using an USB SD-CARD reader.
Connect the reader to your computer.
In the VirtualBox menu select Devices → USB Devices → “your adapter”.
Insert the card into the adapter.
If everything works Ubuntu will recognize the card and will appear in “/dev” folder the device sdd.:
ls /dev/sdd*
In ti-sdk-am335x-evm-05.06.00.00 directory in bin folder there is script file, create-sdcard.sh: launch it.:
cd /home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/bin
sudo ./create-sdcard.sh
The password for sudo is: pengwyn.
If everything goes well you will the drive appears as available and ready to write the image. Select The drive:
16
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
Unmount the drive as required by the script:
umount /dev/sddx
Where x is the number of device used.
Next the screen for partitioning the sd-card will appear. Select ‘y’.
Warning: Your sd-card will be formatted.**
Select 2 partitions and wait until the partitioning process ends.
Now you need choose the path where the image files are located.
Select 2 for custom boot and rootfs paths.
Press y key to continue. Type the path of the built-images folder.
2.6. Copy the Operating System to the SD
17
Pengwyn Documentation, Release 1.0
/home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/board-support/built-images
The script will display the files in the folder: MLO, uImage and u-boot.img.
Press y key to continue.
Finally provide filesystem location:
/home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/targetNFS
and confirm it with y key.
This operation will take minutes.
2.7 Pengwyn Flash Memory
This section will explain how to transfer the data from the sd-card to flash memory of Pengwyn.
Before going on you must have executed all steps explained in “Connect host PC to Pengwyn board” section. Minicom
must work correctly.
1. Remove J1 jumper and insert SD-CARD with prebuilt file
18
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
2. Reset with S1 button.
At the beginning, when you see with Minicom that u-boot procedure starts, press any key to stop it.
3. Erase and upload the FLASH memory with the commands:
nand erase.chip
run nandupdate
4. Reset board with S1 button. Start Linux operating system, at login enter user name:
root
the password is not required.
5. Create flash file system with the automated script:
./create_nand_fs.sh
.. image:: /_static/flash3.png
6. Shutdown linux with the command:
Shutdown -h now
7. Remove SD-CARD, insert jumper in J1 and reset the board with S1 button
The system now will restart from NAND flash with new operating system.
2.8 Code Composer Studio V5
2.8. Code Composer Studio V5
19
Pengwyn Documentation, Release 1.0
Code Composer Studio v5 is currently provided with the Sitara Software Development Kit.
It is based on Eclipse IDE and includes the Remote System Explorer plug-in that enable access the remote target
board. This software is already installed and configured in the SDK Pengwyn.
To launch it click the icon “Code Composer Studio v5” on the desktop and ap the Eclipse work environment will
appear.
The active project is helloWorld, which we’re going to compile and debug in this tutorial.
The workspace used is located in:
/home/pengwyn/workspace_v5_1
The project helloWorld is already configured to work with CCS5. If you want create a new project quickly, use this
project as template and modify the source code.
From the menu, click View → Project Explorer: the left panel will show the projects available in the workspace.
Open helloWold project and double-click on hello.c file.
To build the project go to Project → Build All.
Go to Window → Open Perspective → Other... → Remote System Explorer to open the Remote System Explorer
perspective.
If doesn’t work check Ethernet connection (read “Connect host PC to Pengwyn board” paragraph).
20
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
2.8.1 Access Target File System
Expand the Root node under Sftp Files node.
The remote system file tree should now show the root directory. You can navigate anywhere in the remote file system
down to file level.
Files can be dragged and dropped into the remote file tree. A context menu allows you to create, rename or delete files
and folders.
The local file system on the Linux host can also be accessed by expanding the Local node.
Navigate to the /home/root/ folder on your target board.
Now we’ll copy our executable to this /home/root target location. First switch back to CCS Edit perspective using the
upper right double arrow >>
In Project explorer window, open the Debug group. Select the executable helloWorld.exe, R-click → copy.
2.8. Code Composer Studio V5
21
Pengwyn Documentation, Release 1.0
Switch to Remote System Explorer perspective using the upper right double arrow >>. In the Remote Systems window,
R-click → paste will copy your executable to the Pengwyn /home/root directory.
2.8.2 SSH Terminal
To open an SSH Terminal view: right click the Ssh Terminals node under the Remote System → my_pengwyn and
select Launch Terminal from the context menu.
Type shell commands at the prompt in the terminal window.
Below is a sample command to print the current directory path and list its contents.
In the Console window, Print Working Directory confirm that the binary is there:
ls -l
Before you can run your program, you need to make it executable:
chmod 755 helloWorld.exe
Run your program:
./helloWorld.exe
22
Chapter 2. Pengwyn SDK
Pengwyn Documentation, Release 1.0
2.8.3 Running the Debug Session
Each time you start the debugger, you must first start the gdbserver program on the target.
Start gdbserver for the helloWorld project with a port number of 10000 (this port number must match the number that
was entered in the Debug Configuration).
At the target console command line, type:
gdbserver :10000 ./helloWorld.exe
Once started, you should see a response similar to below:
Go to Run → Debug Configurations, select “hello Debug” and click on Debug button
CCS will change to the CCS Debug perspective. The debug panel will show the running threads and their status. The
source code window will show the program halted at the first executable source code line in the main() function.
2.8. Code Composer Studio V5
23
Pengwyn Documentation, Release 1.0
The Variables window will show the local variables and their current values.
Like any debug enviroment, you can use breakpoints, use the debugger Step Over and Step Into command icons to
step through the source code.
To resume program execution, click the run → resume menu item.
24
Chapter 2. Pengwyn SDK
CHAPTER 3
Appendix
3.1 Opkg Basics
Opkg (Open PacKaGe Management) is a lightweight package management system. It is written in C and resembles
apt/dpkg in operation. It is intended for use on embedded Linux devices and is used in this capacity in the OpenEmbedded and OpenWrt projects.
• opkg list-installed command to know what packages are installed on the file system. For example use this
command with grep:
• opkg list-installed | grep -i name_packet
• opkg search name_packet show where are the files installed of the packet
• opkg whatdepends name_packet show what packets depend on the “name_packet” package
• opkg remove name_packet remove packages, there are important options:
– -force-depends This option will force the removal of the package but will leave any packages that depend
on this package installed
– -force-removal-of-dependent-packages This option will go up the dependency list and remove all packages
in the dependency chain
• opkg install name_packet install the packages
3.2 How to confgure a new project in CCS
Launch Code Composer Studio (aka CCS) using the icon on desktop of your Ubuntu Linux host.
When prompted for the workspace, keep the default one.
3.2.1 Enabling CCS Capabilities
Because we used a new workspace, capabilities need to be enabled to make perspectives selectable in the Window →
Open Perspectives list.
After opening CCS with a new workspace:
25
Pengwyn Documentation, Release 1.0
1. Open the Window → Preferences dialog box
2. Go to the General → Capabilities dialog box.
3. Click Enable All button. The result is shown below.
This enables all the perspectives in the Window → Open Perspectives → Dialog as shown below.
This is needed to make the C/C++ and Remote System Explorer plug-ins selectable.
Click on “Apply” then “OK”.
3.2.2 Toolchain configuration in CCS
Now let’s create Linux GCC project in CCSv5.
We need first to configure CCS to use the Arm Arago GCC toolchain which has been installed with the SDK, otherwise
our project type would use the generic GCC compiler.
All target-related options, typically used for ARM cross-compile (-march=armv7-a, -mtune=cortex-a8 and others),
must be specified in the build options before building the project.
We will use the Arago cross-compiler tools instead of the default gcc. The Arago binaries have a prefix that designates
the target and the type of output binary format (something like arm-arago-linux-gnueabi-g++).
Go to Window → Preferences → Code Composer Studio → Build → Compilers.
26
Chapter 3. Appendix
Pengwyn Documentation, Release 1.0
In the Discovered tools section, click on “ARM” then “GNU Tools”
Select Edit
In the Tool installation directory, type the following:
home/pengwyn/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi
Then click in any of the below empty boxes; the relative path will get filled in automatically as shown below. Leave
the default and click on OK.
Click on OK again to confirm the GNU Build-Tool settings.
Go back to the Preferences window, click on Apply and then OK.
3.2. How to confgure a new project in CCS
27
Pengwyn Documentation, Release 1.0
3.2.3 Starting your project
Select File → New → Project→Code Composer Studio →CCS project.
Type in my_Hello as project name.
Output type: Executable.
Change the ARM variant to Generic Cortex-A8 device.
Use the Basic Examples → Hello World project template.
Click Finish.
28
Chapter 3. Appendix
Pengwyn Documentation, Release 1.0
The my_Hello project will be created in your CCS workspace and added to the Project Explorer window (note that it
is in bold letters, meaning this is the active project).
Note: You can also add source files to the project by R-click on project and selecting “Add Files”.
3.2.4 Build your project
R-click on project name in CCS Project Explorer and select window → Build project.
Check the console view for successful build. . . The executable program my_Hello.exe will be created.
Now you need to copy it to the target filesystem.
3.2. How to confgure a new project in CCS
29
Pengwyn Documentation, Release 1.0
Go to Window → Open Perspective → Other... → Remote System Explorer to open the Remote System Explorer
perspective.
Now you need to establish a new connection with the Pengwyn.
For that you must run the New Connection Wizard. To open this, click on File → New → Other menu item.
In the dialog below, expand the Remote System Explorer folder, click on Connection and Next.
Select the Linux system type and click Next.
Next to “Host name” enter the IP address of your Pengwyn: 192.168.0.101
Use “my_pengwyn” as Connection name. Click on Next.
30
Chapter 3. Appendix
Pengwyn Documentation, Release 1.0
Check ssh.files and click Next.
Check processes.shell.linux and click Next.
Check ssh.shells and click Next.
3.2. How to confgure a new project in CCS
31
Pengwyn Documentation, Release 1.0
Check ssh.terminals and click Finish to complete the wizard.
32
Chapter 3. Appendix
Pengwyn Documentation, Release 1.0
3.2.5 Opening the Remote System Explorer View
In CCSv5 click the Window → Show View → Other menu item. In the Show View dialog select Remote Systems →
Remote Systems then OK.
This adds the Remote Systems view to the current perspective.
A Remote Systems panel appears in the CCS perspective. After a R-click → Detach on the Remote Systems panel
and moving it to the left side of the screen the CCS window will look like the screen capture below. The target
connection named My_Pengwyn is shown as a tree structure with branches for the various Remote System functions.
Communication with the target EVM uses a secure SSH connection.
• Sftp Files - Provides a drag and drop GUI interface to the target file system.
• Shell Processes - Provides a listing of processes running on the remote system and allows processes to be
remotely killed.
• Ssh Shells - Provides a Linux shell window for the remote system within CCS.
• Ssh Terminals - Provides a terminal window for the remote system within CCS.
3.2.6 Configuring the Target Pengwyn Connection
After the New Connection Wizard has been completed and the Remote System Explorer view has been opened, the
new connection must be configured to communicate with the target EVM.
R-click on the my_pengwyn node and select Properties from the context menu.
After the Properties window opens, click on Host. Change the Default User ID to root and click OK.
3.2. How to confgure a new project in CCS
33
Pengwyn Documentation, Release 1.0
Click the Window → Preferences menu item. Go to General → Network Connections
In the bottom part of the dialog box, in the Proxy Bypass section, click Add Host..., and add the IP address of target
board (192.168.0.101) and click Apply then OK.
The Remote System Explorer is now ready for use.
The first time the target EVM file system is booted a private key and a public key is created in the target file system.
Before connecting to the target EVM the first time, the public key must be exported from the target EVM to the Linux
host system.
To open the SSH connection, expand the ROOT node under the Sftp node.
34
Chapter 3. Appendix
Pengwyn Documentation, Release 1.0
When prompted for the password, click OK (no password).
A warning dialog box will appear: click Yes, and the public key will be exported to the Ubuntu host.
3.2. How to confgure a new project in CCS
35
Pengwyn Documentation, Release 1.0
36
Chapter 3. Appendix
CHAPTER 4
Revision History
Date
8th February 2013
11th February 2013
18th February 2013
Version
1.0
1.1
1.2
Revision
Initial Draft Version
Release Version
Corrections. Added Flash System section.
37