EDA Replication User Guide - Rocket Documentation Library

EDA Replication
User Guide
Version JAN2015
January 2015
DBT-JAN2015–EDAR-DG-01
Notices
Edition
Publication date: January 2015
Book number: DBT-JAN2015–EDAR-DG-01
Product version: Version JAN2015
Copyright
© Rocket Software, Inc. or its affiliates 1989-2015. All Rights Reserved.
Trademarks
Rocket is a registered trademark of Rocket Software, Inc. For a list of Rocket registered trademarks go
to: www.rocketsoftware.com/about/legal. All other products or services mentioned in this document
may be covered by the trademarks, service marks, or product names of their respective owners.
Examples
This information might contain examples of data and reports. The examples include the names of
individuals, companies, brands, and products. All of these names are fictitious and any similarity to
the names and addresses used by an actual business enterprise is entirely coincidental.
License agreement
This software and the associated documentation are proprietary and confidential to Rocket Software,
Inc. or its affiliates, are furnished under license, and may be used and copied only in accordance with
the terms of such license.
Note: This product may contain encryption technology. Many countries prohibit or restrict the
use, import, or export of encryption technologies, and current use, import, and export regulations
should be followed when exporting this product.
2
Corporate information
Rocket Software, Inc. develops enterprise infrastructure products in four key areas: storage, networks,
and compliance; database servers and tools; business information and analytics; and application
development, integration, and modernization.
Website: www.rocketsoftware.com
Rocket Global Headquarters
77 4th Avenue, Suite 100
Waltham, MA 02451-1468
USA
To contact Rocket Software by telephone for any reason, including obtaining pre-sales information
and technical support, use one of the following telephone numbers.
Country
Toll-free telephone number
United States
1-855-577-4323
Australia
1-800-823-405
Belgium
0800-266-65
Canada
1-855-577-4323
China
800-720-1170
France
0800-180-0882
Germany
08-05-08-05-62
Italy
800-878-295
Japan
0800-170-5464
Netherlands
0-800-022-2961
New Zealand
0800-003210
South Africa
0-800-980-818
United Kingdom
0800-520-0439
Contacting Technical Support
The Rocket Customer Portal is the primary method of obtaining support. If you have current
support and maintenance agreements with Rocket Software, you can access the Rocket Customer
Portal and report a problem, download an update, or find answers to in the U2 Knowledgebase.
To log in to the Rocket Customer Portal or to request a Rocket Customer Portal account, go to
www.rocketsoftware.com/support.
In addition to using the Rocket Customer Portal to obtain support, you can send an email to
u2support@rocketsoftware.com or use one of the following telephone numbers.
Country
Telephone number
North America
+1 800 729 3553
United Kingdom/France
+44 (0) 800 773 771 or +44 (0) 20 8867 3691
Europe/Africa
+44 (0) 20 8867 3692
Australia
+1 800 707 703 or +61 (0) 29412 5450
New Zealand
+0800 505 515
3
Contents
Notices................................................................................................................................................................................... 2
Corporate information......................................................................................................................................................... 3
Chapter 1: EDA Replication overview..................................................................................................................................5
Chapter 2: Getting started................................................................................................................................................... 6
Starting the EDA Replication Config tool................................................................................................................6
Creating U2 server definitions................................................................................................................................. 6
Viewing or editing advanced settings of a U2 server definition............................................................................ 6
Connecting to U2 servers.........................................................................................................................................7
Installing and updating the DBTools using the Eclipse Update Manager.............................................................8
XTOOLSUB................................................................................................................................................................. 8
Installing XTOOLSUB for UniData on Windows.......................................................................................... 9
Installing XTOOLSUB for UniVerse on Windows....................................................................................... 10
Installing XTOOLSUB for UNIX/Linux for UniData.................................................................................... 10
Installing XTOOLSUB for UNIX/Linux on UniVerse....................................................................................11
Installing XTOOLSUB on Windows............................................................................................................ 12
Chapter 3: Managing EDA Replication.............................................................................................................................. 14
Defining EDA Replication parameters................................................................................................................... 14
Configuring the Replication system...................................................................................................................... 14
Choosing files to replicate..................................................................................................................................... 15
Defining a data source........................................................................................................................................... 15
Defining an EDA data source connection............................................................................................................. 15
Synchronizing replication files.............................................................................................................................. 16
Creating default EDA schemas for the replicated files.........................................................................................16
Creating EDA schemas for selected attributes..................................................................................................... 16
Converting U2 files to EDA files............................................................................................................................. 16
Changing the schemas........................................................................................................................................... 17
4
Chapter 1: EDA Replication overview
EDA Replication is useful if you want to maintain an account from which you can create reports.
You can replicate your data to an SQL database in addition to keeping your data safely store in the
database. When you store your data in UniData or UniVerse, it is simultaneously replicated to Oracle,
IBM DB2, or Microsoft SQL Server. Use this replicated database for data mining or reporting while you
use UniData or UniVerse as your production workhorse.
To manage EDA Replication, use the EDA Replication Config tool. This tool enables you to edit EDA
map schemas, edit data source definitions, and convert UniData or UniVerse files to EDA files.
5
Chapter 2: Getting started
Starting the EDA Replication Config tool
Before you can manage EDA Replication, you must start the EDA Replication Config tool.
The EDA Replication tool must be running on a Microsoft Windows computer that is on the same
network as the server computer running UniData or UniVerse.
Make sure that UniData or UniVerse services are currently running on the server computer with EDA
enabled.
▪
On the taskbar of the Windows computer on which the EDA Replication Config tool is installed,
choose Start > All Programs > Rocket U2 > EDA Replication Config Tool
Creating U2 server definitions
To configure EDA Replication, you must create a U2 server definition that enables your computer to
connect to the U2 database server on which the accounts and data are stored.
Procedure
1.
2.
3.
4.
5.
To create a new U2 server connection, right-click the Servers node in the U2 Resource view, and
click New U2 Server.
In the Name field, enter a unique name to identify the U2 server definition. The name cannot
contain a slash (/) or backslash (\) character.
In the Host field, enter the name or IP address of the computer on which UniData or UniVerse is
running.
From the U2 database server options, select UniData or UniVerse.
Optional: To view or edit the protocol, port number, and other advanced settings defining
the connection, click Advanced, and see Viewing or editing advanced settings of a U2 server
definition, on page 6.
Tip: The default values for advanced settings work best in most situations. Alter these
settings only if necessary.
6.
To save the U2 server definition, click Finish.
Viewing or editing advanced settings of a U2 server
definition
On the advanced settings page of the server definition, you can view or edit the protocol, port number,
and other advanced settings that define the connection. You can also specify commands to run when
you connect to the U2 server.
The default values for advanced settings work best in most situations. Alter these settings only if
necessary.
6
Connecting to U2 servers
1.
2.
3.
4.
5.
6.
The Protocol Type field displays TCP/IP as the communications protocol used by the UniData
or UniVerse to access the internet. At this time, the only supported protocol is TCP/IP, and this
setting cannot be changed.
In the RPC Port # field, enter the port number of the UniRPC server running on the host. The
default port number is 31438.
In the RPC Service Name field, enter the name of the remote procedure call (RPC) service on the
system.
For UniData, the name is normally udcs; for UniVerse, the name is normally uvcs.
In the Login Account field, enter the full path to the account folder on the server running UniData
or UniVerse. You can enter just the account name if the account is defined in the UD.ACCOUNT or
UV.ACCOUNT hash file.
If you run a RetrieVe command, a saved paragraph, or a globally cataloged program every time
you connect to the U2 server, you can save time by entering the command in the U2 server
definition. To enter a command to run on connection, click Add in the Commands to Execute
group box.
In the Specify the session to run/debug your BASIC program on server side group box, enter
details for connecting to the server in a debug session.
a.
b.
c.
From the Protocol options, select the network protocol to use when you connect to the U2
server in a debug session: Telnet or SSH (Secure Shell).
In the Port Number field, enter the port number on which the Telnet or SSH service runs on
the server computer. The default Telnet port number is 23; the default SSH port number is
22.
If device licensing is supported on the server, select the Use Device License check box to
conserve license usage in the debug session.
While running or debugging BASIC programs, you may use multiple server connections
to browse files, check data, update records, or perform other tasks. If device licensing is
disabled, the debug session consumes one U2 license for each connection. With device
licensing enabled, the session consumes one U2 license and one device license for up to 10
connections from a single device.
Tip: If you are unable to establish a Telnet or SSH connection with the Use Device
License check box selected, clear the check box and try again.
7.
To save changes to advanced settings and return to the main page, click Finish.
Connecting to U2 servers
You must open a U2 server connection to work with the accounts stored on the associated UniData
or UniVerse (U2) database server computer. You can connect to any U2 server that is listed in the U2
Resource view.
1.
2.
3.
4.
5.
To start the Connect to a U2 Server wizard, double-click the name of the U2 server in the U2
Resource view.
In the User ID field, enter the administrator user name or the user name of a valid user on the
server computer running UniData or UniVerse.
In the Password field, enter the password for the administrator or user on the server computer.
To store the password for future connections, select the Remember me check box.
With this check box selected, Microsoft Windows stores the encrypted password on the client
computer.
If you are using a proxy server, select the Use Proxy Server check box.
7
Chapter 2: Getting started
In the Proxy Host field, enter the name or IP address of the computer on which the proxy
server is running.
b. In the Proxy Port field, enter the number of the port on which the proxy server listens for
communication from UniData or UniVerse.
To connect to the U2 server, click Connect.
When the connection is established, the U2 Resource view displays a tree view of the U2 accounts
and catalog programs on the U2 database server to which you are connected.
a.
6.
Installing and updating the DBTools using the Eclipse
Update Manager
You can update and install any of the U2 DBTools using the Update Manager in Eclipse.
Find the latest information about updates for U2 DBTools at http://updates.rocketsoftware.com/u2.
Procedure
1.
2.
3.
4.
5.
6.
Launch any U2 DBTools or base Eclipse installations (beginning with Galileo) on your computer.
From the Eclipse Help menu, select Help → Install New Software.
Click Add, enter a name for the site, such as U2 Update Site, and in the Work with field enter
http://updates.rocketsoftware.com/u2. Click OK.
Allow the repository to load and then expand the tree for U2 DBTools. Select the updates that you
want to apply. You can also choose to install any other U2 DBTools into your existing workspace.
Click Next and follow the installation wizard to complete the installation of updates.
Updates will take effect the next time an updated tool is launched.
Note: Only tools that are installed through separate InstallShield installations will appear on
the Start menu. Tools installed using the Eclipse Update Manager are installed as individual
perspectives in a single Eclipse instance. You can access the different perspectives by selecting
Window → Open Perspective and then selecting the appropriate tool.
Note: You can check for updates to the DBTools by selecting Help → Check for Updates. To use
this option, you must have previously defined the http://updates.rocketsoftware.com/u2 location
in the Install New Software dialog, as described in step 3.
XTOOLSUB
This topic describes the XTOOLSUB program and how to upgrade to the latest version of XTOOLSUB
on various operating systems.
Updating the XTOOLSUB Program
The XTOOLSUB program is a U2 database server-side BASIC program used by various U2 Client Tools.
This includes U2 DataVu, U2 Web DE, Basic Developer's Toolkit (BDT), Extensible Administration Tool
(XAdmin), Web Services Developer, and more. It also includes any tool that uses the U2 Resource View.
XTOOLSUB updates itself automatically. However, if something happens to the XTOOLSUB program
you can download the latest version from the public Tech Note site at:
https://u2tc.rocketsoftware.com/documentation/1410028.asp
8
Installing XTOOLSUB for UniData on Windows
The XTOOLSUB program contains several zip and tar files, and includes three or four files, depending
on the environment. The XTOOLSUB program is used by all the tools, but the other files included are
only used for the Basic Developer's Toolkit (BDT).
The XTOOLSUB_EXECPRE/XTOOLSUB_XPRE programs are for pre-execution functionality and
XTOOLSUB_EXECPOST/XTOOLSUB_XPST are for post-execution functionality. These programs are
discussed further in the related public Tech Note, BDT Extensibility Details. If you have added your own
code to the pre- and post-functionality, copy those modified programs to the older database versions
rather than the pre- and post- files located here.
The files included for UniData are:
▪
▪
▪
▪
XTOOLSUB
XTOOLSUB_EXECPRE
XTOOLSUB_EXECPOST
EDAMAPSUB (UniData 6.1 and lower)
The files included for UniVerse are:
▪
▪
▪
▪
XTOOLSUB
XTOOLSUB_XPRE
XTOOLSUB_XPST
EDAMAPSUB (UniVerse 10.3 and lower)
Do not catalog the EDAMAPSUB subroutine when using UDT 7.1 or UV 11.1 and higher. This program
already exists on those versions.
There is a difference between the databases because UniVerse's catalog environment is a type 1 file
and has a 14–character file name limit.
Only extract the file that is needed for the database server/version and OS type you are using.
The ...UX.tar (Unix) files come from AIX. You will need to run fnuxi/convcode if you use other UNIX/
Linux operating systems. Files are not included for all operating systems in order to avoid unnecessary
confusion. The files in the zip/tar files are the object code for the given programs; do not open them in
a text editor.
Note: Log in as a root or administrator user when doing these steps to avoid any permissions
errors. If an overwrite message occurs, select "yes" to overwrite the file in question.
Installing XTOOLSUB for UniData on Windows
The XTOOLSUB program is installed and updated automatically through the U2 DBTools updates.
However, if your version of XTOOLSUB somehow becomes unusable, you can install a new version.
Procedure
1.
2.
3.
4.
5.
Download the latest version of XTOOLSUB from the public Tech Note site at https://
u2tc.rocketsoftware.com/documentation/1410028.asp.
Copy the XTOOLSUB_UDT_NT.zip or XTOOLSUB_UDT_61_NT.zip file to a temporary directory on
your server (for example, c:\temp).
Extract the file to the c:\u2\ud##\sys\SYS_BP (where ## refers to the UniData major version. For
example, 61, 71, 72, etc.) directory using your preferred unzipping utility. If UniData is installed in
another location, change the path accordingly.
Log in to the sys account using telnet or execute a udt shell command in the sys directory on the
server.
Catalog the three XTOOLSUB programs, as follows:
9
Chapter 2: Getting started
▪
▪
▪
CATALOG SYS_BP XTOOLSUB FORCE
CATALOG SYS_BP XTOOLSUB_EXECPRE FORCE
CATALOG SYS_BP XTOOLSUB_EXECPOST FORCE
Note: If you are using UniData 6.1 or lower, also run the CATALOG SYS_BP EDAMAPSUB
FORCE command.
6.
Connect with your U2 client tool to the U2 database server.
Installing XTOOLSUB for UniVerse on Windows
The XTOOLSUB program is installed and updated automatically through the U2 DBTools updates.
However, if your version of XTOOLSUB somehow becomes unusable, you can install a new version.
Procedure
1.
2.
3.
4.
5.
Download the latest version of XTOOLSUB from the public Tech Note site at https://
u2tc.rocketsoftware.com/documentation/1410028.asp
Copy the XTOOLSUB_UV_NT.zip or XTOOLSUB_UV_103_NT.zip file to a temporary directory on
your server. For example, c:\temp.
Extract the file to the c:\u2\uv\BP.O directory using your preferred unzipping utility. If UniVerse is
installed in another location, change the path accordingly.
Log in to the UV home account via Telnet. The account name is UV or uv in the UV.ACCOUNT file.
Catalog the three XTOOLSUB programs, as follows:
▪
▪
▪
CATALOG SYS_BP XTOOLSUB FORCE
CATALOG SYS_BP XTOOLSUB_EXECPRE FORCE
CATALOG SYS_BP XTOOLSUB_EXECPOST FORCE
Note: You will receive a catalog error if you try to catalog all three programs on the same
command line.
6.
7.
If you are using UniVerse 10.3 or later, also run CATALOG BP *EDAMAPSUB FORCE command.
Connect with your U2 client tool to the U2 database server.
Installing XTOOLSUB for UNIX/Linux for UniData
The XTOOLSUB program is installed and updated automatically through the U2 DBTools updates.
However, if your version of XTOOLSUB somehow becomes unusable, you can install a new version.
The $UDTBIN referenced below is an environment variable pointing to your UniData bin directory, for
example, /usr/ud##/bin (where ##, is 61,71,72, etc.). If this variable is not set, then reference the full
path to the UniData bin directory in the commands.
Procedure
1.
10
Download the latest version of XTOOLSUB from the public Tech Note site at https://
u2tc.rocketsoftware.com/documentation/1410028.asp.
Installing XTOOLSUB for UNIX/Linux on UniVerse
2.
3.
Copy the XTOOLSUB_UDT_UX.tar or XTOOLSUB_UDT_61_UX.tar file to a temporary directory on
your server (for example, /tmp). If transferring using ftp, remember to use binary format.
Extract the file to the $UDTHOME/sys/SYS_BP directory.
a.
4.
To install using UniData 6.1 or earlier, the commands will be:
cd $UDTHOME/sys/SYS_BP
tar -xvf /tmp/XTOOLSUB_UDT_61_UX.tar
b. To install UniData 7.1 or later, the commands will be:
cd $UDTHOME/sys/SYS_BP
tar -xvf /tmp/XTOOLSUB_UDT_UX.tar
If you are using a non-AIX operating system, run the convcode command, as shown: $UDTHOME/
sys/SYS_BP: $UDTBIN/convcode .
Note: The convcode command includes a period at the end of the line. This will convert
everything in the SYS_BP file to the current format. All files report that they were converted,
but this is the default answer for convcode. The existing files should already be in the correct
format.
5.
6.
Change directories to the $UDTHOME/sys directory and then and execute the UDT command, as
shown:
a. CD $UDTHOME/sys
b. $UDTBIN/udt
Catalog the three XTOOLSUB programs, as follows:
▪
▪
▪
CATALOG SYS_BP XTOOLSUB FORCE
CATALOG SYS_BP XTOOLSUB_EXECPRE FORCE
CATALOG SYS_BP XTOOLSUB_EXECPOST FORCE
Note: If you are using UniData 6.1 or lower, also run the CATALOG SYS_BP EDAMAPSUB
FORCE command.
7.
Connect with your U2 client tool to the U2 database server.
Installing XTOOLSUB for UNIX/Linux on UniVerse
The XTOOLSUB program is installed and updated automatically through the U2 DBTools updates.
However, if your version of XTOOLSUB somehow becomes unusable, you can install a new version.
Procedure
1.
2.
3.
Download the latest version of XTOOLSUB from the public Tech Note site at https://
u2tc.rocketsoftware.com/documentation/1410028.asp
Copy the XTOOLSUB_UV_UX.tar or XTOOLSUB_UDT_UV_103_UX.tar file to a temporary directory
on your server (for example, /tmp). If transferring files using FTP, remember to use binary file
format.
Extract the file to the /usr/uv/BP.O directory. If UniVerse is installed in another location, change
the path accordingly. Use 'cat /.uvhome' to find the path if needed.
Note: `cat /.uvhome` references include single backward quotation marks. This command
retrieves the current value for the UniVerse home directory before running the command.
11
Chapter 2: Getting started
a.
5.
To install using UniVerse 10.3 or earlier, the commands to use are:
cd `cat /.uvhome`/BP.O
tar -xvf /tmp/XTOOLSUB_UV_103_UX.tar
b. To install using UniVerse 11.1 or later, the commands to use are:
cd `cat /.uvhome`/BP.O
tar -xvf /tmp/XTOOLSUB_UV_UX.tar
If you are using a non-AIX operating system, run the convcode command, as shown:
`cat /.uvhome`/bin/fnuxi XTOOLSUB*
Change directories to the UniVerse home directory and then and run the UV command, as shown:
6.
7.
a. cd `cat /.uvhome`
b. bin/uv
Click Escape to exit the menu.
Catalog the three XTOOLSUB programs, as follows:
4.
▪
▪
▪
CATALOG SYS_BP XTOOLSUB FORCE
CATALOG SYS_BP XTOOLSUB_EXECPRE FORCE
CATALOG SYS_BP XTOOLSUB_EXECPOST FORCE
Note: You will see a catalog error if you try to catalog all three programs on the same
command line.
8.
9.
If you are using UniVerse 10.3 or earlier, also run the CATALOG BP *EDAMAPSUB FORCE
command.
Connect with your U2 client tool to the U2 database server.
Installing XTOOLSUB on Windows
The XTOOLSUB program is installed and updated automatically through the U2 DBTools updates.
However, if your version of XTOOLSUB somehow becomes unusable, you can install a new version.
Procedure
1.
2.
3.
4.
5.
Download the latest version of XTOOLSUB from the public Tech Note site at https://
u2tc.rocketsoftware.com/documentation/1410028.asp
Copy the XTOOLSUB_UDT_NT.zip or XTOOLSUB_UDT_61_NT.zip file to a temporary directory on
your server (for example, c:\temp).
Extract the file to the c:\u2\ud##\sys\SYS_BP (where ## refers to the UDT major version, i.e. 61, 71,
72, etc.) directory using your preferred unzipping utility. If UniData is installed in another location,
change the path accordingly.
Log into the sys account using telnet or execute a udt shell command in the sys directory on the
server.
Catalog the three XTOOLSUB programs, as follows:
▪
▪
▪
CATALOG SYS_BP XTOOLSUB FORCE
CATALOG SYS_BP XTOOLSUB_EXECPRE FORCE
CATALOG SYS_BP XTOOLSUB_EXECPOST FORCE
Note: If you are using UniData 6.1 or lower, also run the CATALOG SYS_BP EDAMAPSUB
FORCE command.
12
Installing XTOOLSUB on Windows
6.
Connect with your U2 client tool to the U2 database server.
13
Chapter 3: Managing EDA Replication
Defining EDA Replication parameters
You must configure the parameters specific to EDA Replication.
1.
2.
3.
To define EDA Replication parameters, from the EDA Replication Config tool, select Configure
Replication Parameters.
To change the value of a configuration parameter, click the New Value column of the parameter
you want to change, then enter the new value for the parameter.
After you make your desired changes, click Save Changes.
Configuring the Replication system
You must define the system to which you want to replicate EDA data.
1.
From the EDA Replication Config tool, select Configure Replication System.
2.
From the Replication Systems list, select the system to which you want to replicate data.
This system should be the same system on which the EDA account resides.
In the System ID field, enter a unique name for the replication system.
The System ID can contain a combination of alphabetic characters, numbers, and any of the
following characters: ~ ! @ $ % ^ & * - + . / \.
In the Host Name field, enter the host name of the replication system location.
A system can have only one host name.
In the Version field, select the version of the U2 database running on the system location.
Select the DHCP check box if the local system has a dynamic IP address.
Select Yes for Auto Resume if you want to automatically synchronize and resume when the U2
database starts, or No if you want to manually synchronize.
In the Sync Interval field, enter or select the time interval, in minutes, in which the replication
system automatically synchronizes replication.
A value of 0 specifies manual synchronization. The sync interval applies only to those subscribing
groups that have deferred replication.
If you want to verify the subscribing system, select the Connect Authorization check box.
U2 Data Replication performs an authorization check when it receives a SYNC request from the
subscribing system.
In the Timeout field, enter or select the number of seconds to wait if no packets are received from
the system before suspending replication.
If the value of timeout is 0, no timeout occurs. We recommend not setting this value to less than 2
minutes.
If you want to execute a shell script on a UNIX platform or a batch program on a Windows
platform when an exception occurs, specify the full path to the script in the Exception Action
field, or click Browse to locate the path.
The account definition is automatically populated with the account you previously defined. To
define a different account to replicate EDA data, click Add.
Click Save Changes to save your settings.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14
Choosing files to replicate
Choosing files to replicate
You must create a replication group and then choose the files you want to replicate.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
From the EDA Replication Config tool, select Choose Files to Replicate.
If you have not previously defined a replication group, click Create from the Configure
Replication Group window.
In the Group ID field, enter a unique name for the subscribing group.
Open the Source Account list and select the source account from the list.
In the Level field, select the level of replication. For EDA Replication, you can only choose FILE.
In the Files area, click Add to select the files you want to publish.
If you do not want to publish the data portion of the file, clear the Data check box. If you do not
want to publish the dictionary portion of the file, clear the Dict check box.
To enable the ability to update the file on the subscribing system, select the Sub Writeable
column.
In the Distributions area, click Add to define replication distribution details.
In the System Name field, select the local system from the list.
Select the Replication mode you want to use.
Click Finish.
If you want this publishing group to automatically failover to a standby system, select the
standby system in the RFS Failover System field.
Set any of the configuration parameters necessary for your environment in the Configuration
area.
Click Save Changes.
Defining a data source
You must define a data source pointing to the external database to which you want to connect.
1.
2.
3.
4.
5.
After you connect to your U2 server, right-click EDA Data Sources, then click New EDA Data
Source.
In the Name field, enter a unique name to identify the external data source. The name cannot
contain a slash (/) or backslash (\) character.
In the DSN/Net Service/DB Alias field, enter the name of the external database to which you are
connecting. The name must be the data source defined in the ODBC Data Source Administrator.
From the Driver list, select the type of driver.
To define an EDA data source connection, click Add.
Defining an EDA data source connection
You must define a data source pointing to the external database to which you want to connect.
1.
2.
3.
4.
In the Login User ID field, enter the user ID on the external server.
In the Password field, enter the password corresponding to the user ID.
In the Re-enter Password field, type the password again for verification.
In the Hold Flag field, select YES if you want to maintain the connection on the external server
after a transaction commits. Select NO if you want to disconnect from the external server after
the transaction commits.
15
Chapter 3: Managing EDA Replication
5.
6.
In the Qualified Users field, enter the UniData or UniVerse user IDs of users who can access the
external server from the UniData or UniVerse account using the external login user ID you specify.
Separate the users by a pipe ("|") symbol. If all users can access the external account, enter an
asterisk ("*").
Click Test to test the connection to the external data source.
Synchronizing replication files
You must synchronize the files from the source account with the target account.
1.
2.
3.
Select the files from the source account that you want to synchronize with the target account.
Click Start File Synchronization.
Choose whether to overwrite existing files in the target account.
Creating default EDA schemas for the replicated files
You can create a default EDA schema for the files you selected, which maps each D-type attribute, or
select the attributes you want to map.
1.
2.
3.
4.
5.
6.
7.
Click Create EDA Schemas for the Replicated Files.
Select the files for which you want to create schemas.
Click Create EDA Schemas.
Select the data source for which you are creating the schema from the list.
Click OK.
EDA Replication pauses the database and maps each D-type attribute in the dictionary file.
If you want to view the schema that was created, click Open EDA Schemas.
Creating EDA schemas for selected attributes
You can select the dictionary attributes you want to map.
1.
2.
3.
4.
5.
6.
7.
8.
Click Create EDA Schemas for the Replicated Files.
Select the files for which you want to create schemas.
Click Create EDA Schemas.
Select the data source for which you want to create schemas from the Data Source list, or click
New Data Source to create a new data source.
Click Deselect All, then select the dictionary attributes for which you want to create a schema.
If you are creating schemas for multiple files, click the arrow next to the current file name to
advance to the next file.
Click Finish when you have selected all the dictionary attributes for which you want to create
schemas.
If you want to view the schema that was created, click Open EDA Schemas.
Converting U2 files to EDA files
You can convert the U2 file to an EDA file.
1.
16
Select the files you want to convert. Make sure you have synchronized the files before you convert
them.
Changing the schemas
2.
3.
4.
Add an attribute to the EDA Schema in the editor, as described in Creating EDA schemas for
selected attributes, on page 16.
Click Convert the U2 File to EDA File.
Select the type of conversion you want to use:
▪
▪
5.
Force – Drops existing tables before creating new ones
Verbose – Show detailed messages during the conversion process
Click EDA Convert.
The database suspends replication during the altering process, and the file is converted to an EDA
file.
Changing the schemas
You can alter or change existing schemas without having to reolad the existing tables.
1.
2.
3.
4.
5.
6.
Click Create EDA Schemas for the Replicated File.
Select the files for which you want to alter the schemas.
Click Open EDA Schemas.
Add the new dictionary to the EDA Map Schema and save the schema.
Click Convert the U2 File to EDA File.
Select the type of conversion you want to use:
▪
▪
7.
Force – Drops existing tables before creating new ones
Verbose – Show detailed messages during the conversion process
Click EDA Alter.
The database suspends replication during the conversion process, and the new attribute is
appended to the table without having to reload the table.
17
Download PDF