Arrangement, Alignment, and the Pathfinder Panel

HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
blind folio 85
7
Arrangement, Alignment,
and the Pathfinder Panel
How to…
■■ Change the order of objects
■■ Group and ungroup
■■ Copy and paste
■■ Align and distribute objects
■■ Use the Pathfinder Panel
■■ Work in Isolation Mode
A
s you create your illustrations, you may not necessarily draw the individual objects in the
order and configuration they ultimately need to be in. That’s where the tools in this chapter
come in. Here you’ll learn about arranging objects, aligning and distributing them, copying and
pasting, combining and dividing shapes with the Pathfinder panel, and how to work on individual
parts of larger images in Isolation Mode. We’ll also take a look at some of the tools that become
available on the Control panel when one or more objects are selected.
Tip
Remember, you can always use the rulers, artboard rulers, grids, guides, and smart guides
in the View menu to help with evenly positioning, aligning, and distributing objects on your
artboard.
Arranging Objects
In Illustrator, every path or shape is drawn separately, and each new one is positioned on top
of the last, as shown with the set of shapes in Figure 7-1. This overlapping of shapes is called the
stacking order, where the object at the top of the stack is the front-most object, closest to
ch07.indd 85
12/5/08 4:02:24 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
86
How to Do Everything: Adobe Illustrator CS4
the viewer. Fortunately, this ordering is completely flexible and
easy to change using the arrange options.
To illustrate, take a look at the objects in Figure 7-2. The
object on top needs to be sent further back in the stacking order
so all the objects that were drawn are visible.
One way to rearrange objects is by changing an object’s
stacking order through the options in the Arrange menu:
Figure 7-1 Objects are
stacked on top of each other
■■ Bring to Front Brings the selected object(s) to
the front (top) of the stacking order. Choose Object |
Arrange | Bring To Front, or press ctrl+shift+] (Win)
or cmd+shift+] (Mac).
■■ Bring Forward Brings the selected object(s) one step
forward in the stacking order. Choose Object | Arrange |
Bring Forward, or press ctrl+] (Win) or cmd+] (Mac).
■■ Send Backward Sends the selected object(s) one
step backward in the stacking order. Choose Object |
Arrange | Send Backward, or press ctrl+[ (Win) or
cmd+[ (Mac).
Before arrangement
■■ Send to Back Sends the selected object(s) to the
back (bottom) of the stacking order. Choose Object |
Arrange | Send To Back, or press ctrl+shift+[ (Win)
or cmd+shift+[ (Mac).
After arrangement
Figure 7-2 Change the
stacking order using the
Object | Arrange menu
■■ Send to Current Layer Sends the selected object(s) to
the currently selected layer in the Layers panel. Choose
Object | Arrange | Send To Current Layer.
Did You
Know?
Using the Context Menu
The Arrange menu options can also be accessed through the context menu by right-clicking
(Win) or ctrl+clicking (Mac) the desired object.
ch07.indd 86
12/5/08 4:02:25 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
87
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel Group and Ungroup
Figure 7-3 Grouped objects
Note
The fastest way to move and manipulate several objects at once
is to combine them into a single group. Groups can be created
from any two or more selected objects. Groups can also be
nested, or grouped with other objects or other groups, to help
you in the organization of your work. For example, the eyes of
the frog illustration in Figure 7-3 are grouped.
Once a group is created, selecting any of the objects in the
group with the Selection Tool selects the entire group. To select
a part of a group, use the Direct Selection or Group Selection
Tools, as described in Chapter 4.
To create a group, select the individual objects to be
grouped and choose Object | Group, or press ctrl+g (Win)
or cmd+g (Mac). To ungroup the objects in a selected group,
choose Object | Ungroup, or press shift+ctrl+g (Win) or
shift+cmd+g (Mac).
As the grouping takes place, the paths of grouped objects
are stacked in sequence in the same layer in the Layers panel.
When the selected objects come from different layers, the
grouping may inadvertently jumble their stacking order. If that
happens, you’ll need to rearrange the objects using the options
from the Object | Arrange menu.
Objects and groups can also be rearranged through the layer’s panel, which you’ll learn about
in Chapter 8.
Copy, Paste, Cut, and Clear
At the top of the Edit menu, you’ll find several commands to
help you cut, copy, paste, and clear objects on your artboard.
Use these commands to quickly make duplicates of your work
and rearrange them in the desired locations.
Copy and Paste
The Copy and Paste commands in the Edit menu work together
to help you create quick copies of any selection. Copied
selections are temporarily placed on the computer’s clipboard in
anticipation of being pasted.
ch07.indd 87
12/5/08 4:02:27 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
88
How to Do Everything: Adobe Illustrator CS4
Tip
Illustrator’s clipboard can also be used to copy objects and then paste them into other Adobe
applications, including Adobe Photoshop, Adobe InDesign, and Adobe GoLive.
In addition, when you paste, the object(s) being pasted
appear at the top of the stacking order for the entire document.
Use your mouse to select the Copy and Paste commands
from the Edit menu, or for faster results, use the keyboard
shortcuts by selecting the object(s) you’d like to copy and
pressing ctrl+c (Win) or cmd+c (Mac) to copy the selection
to Illustrator’s clipboard, and ctrl+v (Win) or cmd+v (Mac) to
paste a copy of the selection onto the center of the artboard.
Dragging Copies
For an even faster way of making copies use the click and drag
method:
1.Select the object(s) to be copied.
Figure 7-4 Duplicate by dragging
2.Hover your mouse over the selection
and press the alt (Win) or opt (Mac)
key. When the cursor turns into a double
arrow, as shown in Figure 7-4, keep
pressing the keyboard shortcut as you
drag the object(s) to pull a copy out of
the original.
Cursor changes
3.Still pressing the keyboard shortcut,
to drag a copy
release the mouse to add the copy in the
desired location. Then, release the keyboard shortcut.
The results
Paste in Front/Back
Included in the copy and paste section of the Edit menu are the
special Paste In Front and Paste In Back commands for quickly
moving objects in front or in back of one or more selected
objects after cutting or copying. When objects are pasted using
both commands, only the stacking order changes, while their
relative position on the artboard is maintained.
Paste in Front
1.Select the desired object(s).
2.Copy or cut the selection using the Edit | Copy or Edit |
Cut command.
ch07.indd 88
12/5/08 4:02:27 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
89
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel 3.Do one of the following:
■■ Choose Edit | Paste In Front.
■■ Press ctrl+f (Win) or cmd+f (Mac).
Paste in Back
1.Select the desired object(s).
2.Copy or cut the selection using the Edit | Copy or Edit |
Cut command.
3.Do one of the following:
■■ Choose Edit | Paste In Back.
■■ Press ctrl+b (Win) or cmd+b (Mac).
Cut and Paste
For times when you need to move an object instead of making a
copy of it, use the Cut and Paste method instead:
1.Select the object(s) you’d like to cut.
2.Press ctrl+x (Win) or cmd+x (Mac) to cut the selection.
3.Press ctrl+v (Win) or cmd+v (Mac) to paste the cut
selection onto the artboard at the top of the stacking
order.
To paste the cut object into a particular position within the stacking order, you can select the
object in front of, or in back of, where you’d like the pasted image to go and then choose one
of the paste commands. Paste and Paste In Front will paste in front of the selection, while
Paste In Back will paste in back of the selection.
Tip
Clear
To completely remove a selection from the artboard, select
the object(s) and choose Edit | Clear. Of course, you can also
use the Edit | Cut option, but that places the cut object(s)
temporarily on the clipboard until you replace the clipboard’s
contents by copying or cutting something else, so really it’s
more efficient to use the Clear command.
ch07.indd 89
12/5/08 4:02:27 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
90
How to Do Everything: Adobe Illustrator CS4
Did You
Know?
More Ways To Delete
Selections can also be deleted by pressing the delete (Win or Mac) or backspace (Win) key
on your keyboard.
Align and Distribute
The Align panel helps organize selected objects (including
groups, paths, and type) by aligning them relative to one
another, either along the object edges or selected anchor points.
To open the panel, select Window | Align. If you don’t see the
full panel, click the double-arrows next to the panel’s tab once
or twice until it completely expands.
Selected objects can be aligned and/
or distributed horizontally and vertically
Before alignment
along the selected objects’ centers, or
along their left, right, top, or bottom most
edges. Further, objects can be aligned and/
or distributed relative to the boundaries of
After vertical
top alignment
the entire selection, to a key object within
that selection, or to the artboard. Figure
7-5 shows a few objects before and after
vertically aligning their tops, and after
horizontally distributing them from
After horizontal
left distribution
the left.
Aligning or Distributing to a Selection
Follow these steps to use the Align panel:
Figure 7-5 Aligned and
distributed objects
1.Select the objects to be aligned and/or distributed.
2.Click the desired button on the Align panel to align
or distribute relative to the bounding box around the
selected objects:
■■ Align From left to right, these buttons are
Horizontal Align Left, Horizontal Align Center,
Horizontal Align Right, Vertical Align Top, Vertical
Align Center, and Vertical Align Bottom.
ch07.indd 90
12/5/08 4:02:28 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel Did You
Know?
91
Control Panel Align
& Distribute Buttons
When two or more objects are selected, the Align and Distribute buttons also appear on the
Control panel.
■■ Distribute From left to right, these buttons are
Vertical Distribute Top, Vertical Distribute Center,
Vertical Distribute Bottom, Horizontal Distribute
Left, Horizontal Distribute Center, and Horizontal
Distribute Right.
Aligning or Distributing to a Key Object
To align or distribute relative to a key (particular) object within
a set of selected objects, follow these steps:
1.shift+click to select all the objects, including the object
you wish to target as the key object.
Figure 7-6 Selecting a key
object and using alignment and
distribution
Before
ch07.indd 91
2.Release the shift key and click once on the previously
selected object that will be the key object. All the
objects remain selected; however, the key object will
now have a bolder outline, as shown in Figure 7-6. To
deselect the key object, choose Cancel Key Object from
the Align panel option menu, or simply click the key
object again.
3.Press the desired Align or Distribute button on the Align
panel or Control panel.
After
With key objects, you can also set the
exact distance between selected objects
when distributing them vertically or
horizontally. Start by shift+clicking to
select all the objects (including the key
object). Then, release the shift key and
click once on the key object to highlight
it. At the bottom of the Align panel, select
Align To Key Object from the Align
To menu and enter the desired distance
12/5/08 4:02:28 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
92
How to Do Everything: Adobe Illustrator CS4
between selected objects in the spacing value field. Lastly,
click the Vertical Distribute Space and/or Horizontal Distribute
Space button to distribute the selected objects by the specified
distance.
Aligning or Distributing to the Artboard
To align or distribute two or more selected objects relative to
the artboard, select the Align To Artboard option from the Align
To dropdown menu on the Align panel. This button is also
accessible from the same dropdown menu on the Control panel.
Tip
For a video on aligning and distributing objects, see www.adobe.com/go/vid0035.
The Pathfinder Panel
The Pathfinder panel contains two sets of powerful path editing
tools. The Shape Modes include four tools that combine or
create compound shapes, and the Pathfinders consist of six tools
that divide, trim, merge, crop, outline, and subtract from any set
of selected objects.
The Pathfinder options menu has a few options that may
be of interest to you. First, the Pathfinder Options dialog box
contains settings for temporarily adjusting how the tools on the
panel work. The settings in this dialog box automatically reset
each time you open Illustrator.
■■ Precision The number entered here sets the precision
of the pathfinder tools. The higher the number, the more
accurate the results, but accuracy does take longer to
process. For best results, leave the default setting at
0.028 and only increase if working with complex shapes.
■■ Remove Redundant Points When enabled, this
option deletes overlapping points or points that are close
together on the same path.
■■ Divide and Outline Will Remove Unpainted
Artwork Enabling this option will force Illustrator
to delete unpainted (objects with no stroke and no fill)
artwork, which sometimes result when using the Divide
and Outline tools.
ch07.indd 92
12/5/08 4:02:29 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel Figure 7-7 The Pathfinder panel’s
Repeat command
93
The second dialog box accessible through the panel’s
options menu is the Pathfinder Trap. Trapping is a process used
by print shops to prevent potential gaps between two adjoining
colors by creating a small area of overlap. Here you can adjust
the thickness, height/width, and tint reduction for the trap, as
well as options for trapping with process color or reverse traps.
The last option in the panel’s option menu is not a dialog
box, but rather a Repeat command that repeats the last
performed action when adding a new object to an existing
selected object or shape that has just been modified with one
of the Pathfinder panel’s tools. To illustrate, the two squares
in Figure 7-7 were first combined with the Pathfinder panel’s
Unite button. The third square was then added to the selection
before choosing the Repeat Add command from the panel’s
options menu, which resulted in the final shape.
Two shapes selected
Shapes combined
with Unite
Third shape added to
combined shape selection
Result of Repeat Add
Shape Modes
The Shape Modes buttons have been slightly modified in CS4.
In previous versions, the buttons would create compound
shapes from selected objects, where the original shapes would
be retained so each object within the compound shape could be
moved or edited with the Direct Selection tool, without breaking
the compound interaction, as in the example in Figure 7-8. Users
Figure 7-8 Compound shapes
could choose to leave the objects in the compound shape or
expand the objects into a single new shape by pressing
the Expand button.
Now, in CS4, the Shape Modes buttons
automatically create these expanded shapes, unless you
alt+click (Win) or opt+click (Mac) the buttons on the
panel to create compound shapes, which can then be
expanded into a single new shape, if desired, by clicking
the Expand button.
Compound shape
Repositioning object
within compound shape
ch07.indd 93
12/5/08 4:02:29 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
94
How to Do Everything: Adobe Illustrator CS4
To use the Shape Modes, select the desired objects on your
artboard and click one of the buttons on the Pathfinder panel:
■■ Unite Combines selected objects into a single new
object. The top-most object’s attributes define the
properties for the new shape.
■■ Minus Front Subtracts the top-most objects from the
bottom object in the selection.
■■ Intersect Creates a new shape by subtracting any parts
of the shapes within the selection that are not overlapping;
only the overlapping parts remain as a single shape.
■■ Exclude Creates a new shape by subtracting any
overlapping shapes within the selection. The resulting
shape is a grouped shape made up of the resulting
shapes. To move the individual pieces apart, ungroup the
shape first.
Figure 7-9 Objects combined
with Shape Modes: (A) Original, (B)
Unite, (C) Minus Front, (D) Intersect,
and (E) Exclude
■■ Expand Expands
compound shapes into
a single new shape.
Figure 7-9 illustrates how
each of these Shape Modes
buttons perform their tasks.
Tip
A
B
C
D
E
If you accidentally press the wrong button on the panel, undo the last command by pressing
ctrl+z (Win) or cmd+z (Mac) and try again.
Pathfinders
The Pathfinders are the path alteration tools that create new
shapes based on the overlapping shapes within a selection.
Figure 7-10 shows an original set of objects and how they look
when applied with each of the pathfinders.
To use the Pathfinders, select the desired objects and click
one of the buttons:
■■ Divide Divides all the overlapping shapes into individual
closed paths. The object can then be ungrouped and the
individual shapes rearranged or edited.
■■ Trim Removes strokes, if any, while cutting away any
parts of objects that are hidden by overlapping objects.
The resulting shapes may then be ungrouped for editing.
ch07.indd 94
12/5/08 4:02:30 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel A
B
C
E
F
95
Original shapes
Figure 7-10 Pathfinders applied
to a set of shapes: (A) Divide,
(B) Trim, (C) Merge, (D) Crop, (E)
Outline, and (F) Minus Back
D
■■ Merge Removes strokes, if any, as it merges objects
filled with the same color.
■■ Crop Cuts artwork at overlapping edges, removes
all strokes, and deletes any shapes behind the top-most
object. The resulting grouped object can be ungrouped
and edited.
■■ Outline Divides all selected objects into line segments
with a 1pt stroke and no fill, cutting the individual paths
where they intersect. The resulting grouped paths can be
ungrouped and edited.
■■ Minus Back Cuts away all artwork behind the topmost object. The resulting shape retains its original
stroke and fill attributes.
ch07.indd 95
12/5/08 4:02:30 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
96
How to Do Everything: Adobe Illustrator CS4
A similar set of Pathfinder options are available through the Effect | Pathfinder menu; however,
Note these effects can only be applied to groups, layers, or text objects. By contrast, the tools in the
Pathfinder panel can be applied to any combination of objects, groups, and layers. For more on
Effects, see Chapter 18.
Isolation Mode
When editing objects within a group, Illustrator automatically
goes into what’s called Isolation Mode, where the selected group
objects (or sublayers of an object made up of multiple layers)
become secluded so editing work can focus on just those objects
or object parts. The remaining work on the artboard becomes
temporarily inaccessible and appears slightly dimmed, like the
plate and background of the cake image seen in Figure 7-11,
allowing you to concentrate on the isolated objects without
disrupting the grouping.
Figure 7-11 Isolated art in
Isolation Mode
Entering Isolation Mode
To enter Isolation Mode, select the
desired artwork and do one of the
following:
■■ Double-click the grouped object
with the Selection Tool.
■■ Right-click (Win) or ctrl+click
Cake before isolation
Selected cake art in isolation
(Mac) the grouped object and select Isolate Selected
Group from the context menu.
■■ Click the Isolate Selected Group button on the Control
panel.
■■ Select Enter Isolation Mode from the Layers panel
options menu.
Tip
ch07.indd 96
To watch a video on working with selections in Isolation Mode, visit www.adobe.com/
designcenter/video_workshop/?id=vid0041.
12/5/08 4:02:31 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
97
CHAPTER 7: Arrangement, Alignment, and the Pathfinder Panel Exiting Isolation Mode
To exit Isolation Mode, do any of the following:
■■ Double-click an empty space of the artboard with the
Selection Tool.
■■ Right-click (Win) or ctrl+click (Mac) the grouped
object and select Exit Isolation Mode from the context
menu.
■■ Select Exit Isolation Mode from the context menu.
■■ Click the Exit Isolation Mode arrow button in the
Isolation Mode bar at the top of the document
workspace.
■■ Click the Exit Isolation Mode button on the Control
panel.
When deeply nested inside grouped objects in Isolation Mode, you may need to click the Back
One Level arrow button on the Isolation Mode bar at the top of the document workspace a
few times before the Exit Isolation Mode arrow button appears in its place, allowing you to
finally exit Isolation Mode.
Tip
ch07.indd 97
12/5/08 4:02:31 PM
HowTo-Color (8) / How to Do Everything: Adobe Illustrator CS4 / Jenkins / 310-7 / Chapter 7
blind folio 98
ch07.indd 98
12/5/08 4:02:31 PM