Gimp 2.8

Gimp 2.8
Dimitri Robert
Gimp 2.8
Débuter en retouche photo
et graphisme libre
Préface de Cédric Gémy
le
Nouvel n
e
édition
r
u
e
l
u
o
c
!
© Groupe Eyrolles, 2005, 2007, 2008, 2009 et 2013 pour la prŽ sente Ž dition,
ISBN : 978-2-212-12700-3
Table des matières
AVANT-PROPOS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Pourquoi utiliser Gimp plutôt que Photoshop ? • 1
Que trouverez-vous dans ce livre ? • 2
Liste des tutoriels • 4
Remerciements • 5
1. LES BASES DE L’INFOGRAPHIE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Que voulez-vous faire avec vos images ? • 10
Matricielles ou vectorielles ? • 11
Les images matricielles • 11
Les images vectorielles • 12
Gimp ou Inkscape ? • 15
Quelles dimensions ? • 16
La résolution : un lien entre le numérique et la réalité • 17
Comment gérer les couleurs ? • 19
La couleur, ses variations et sa perception • 19
RVB ou la lumière • 23
CMJN ou l’encre • 25
Les tons directs • 27
Conversion du RVB vers le CMJN • 28
Quels formats pour mes images ? • 31
JPEG : attention à la qualité ! • 31
PNG, pour les images simples • 33
GIF, un format désuet • 34
XCF, le format de travail de Gimp • 34
PSD, le format de travail de Photoshop • 35
Tiff, pour une impression de qualité • 35
EPS, pour les images vectorielles • 36
PDF, pour des documents de plusieurs pages • 36
OpenRaster, futur standard d’images matricielles ? • 37
P O C H E A C C È S L I B R E – G I M P 2 .8
WebP, le futur JPEG selon Google ? • 37
SVG, le standard vectoriel • 38
SLA, le format de Scribus • 38
Quels logiciels utiliser pour atteindre mon but ? • 39
En résumé • 41
2. PRÉSENTATION ET INSTALLATION . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Gimp, un logiciel libre • 44
Les possibilités et les limites du logiciel • 46
Installer Gimp • 48
Sous Windows • 48
Téléchargement • 48
Installation • 49
Sous Linux • 52
Sous Mac OS X • 54
Téléchargement • 54
Installation • 54
Installer des ressources supplémentaires • 55
Premier démarrage • 56
Le futur de Gimp • 58
En résumé • 59
3. DÉCOUVERTE ET ADAPTATION DE L’INTERFACE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Une interface plus souple • 62
La zone d’images • 63
La boîte à outils • 65
Choisir une couleur • 72
Les fenêtres ancrables • 75
Découvrez d’autres fenêtres ancrables • 78
Organisation et position des fenêtres ancrables • 80
Les menus fonctionnels • 81
Le menu Fichier • 81
Le menu Édition • 84
Le menu Sélection • 86
Le menu Affichage • 86
Le menu Image • 88
Le menu Calque • 90
Le menu Couleurs • 91
Le menu Outils • 91
Le menu Filtres • 91
Le menu Fenêtres • 92
Le menu Aide • 93
X
© Groupe Eyrolles, 2011
Table des matières
Définir ses préférences • 93
En résumé • 97
4. PREMIERS PAS AVEC GIMP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
Ouvrir une image • 100
Choisir une image dans la liste des fichiers • 100
Aperçu de l’image • 101
Accéder directement aux répertoires courants • 101
Filtrer par format • 102
Ouvrir depuis le Web • 103
Ouvrir en tant que calque • 103
Ouvrir une image vectorielle • 104
SVG • 104
PostScript, PDF • 106
Enregistrer une image • 107
Enregistrer différemment • 109
Exporter une image • 109
Choisir le format • 110
Exporter une image au format JPEG • 110
Redimensionner une image • 112
Dimensions et unités • 113
Interpolation • 113
Recadrer une image • 115
Agrandir la zone de travail • 115
Réduire l’image • 117
Manier le zoom • 121
Régler les niveaux de zoom • 121
Utiliser la loupe • 122
Passer par la boîte de dialogue Navigation • 123
Déplacer les calques et les sélections • 124
Pointer un calque • 125
Déplacer pixel par pixel • 126
Poser des guides • 126
Imprimer • 128
Scanner • 128
En résumé • 131
5. SÉLECTIONS ET DÉTOURAGE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
La sélection par forme simple • 134
Supprimer une sélection • 136
Redimensionner la sélection • 136
Tracer des carrés et des cercles • 137
© Groupe Eyrolles, 2011
XI
P O C H E A C C È S L I B R E – G I M P 2 .8
Tracer depuis le centre • 137
Options des sélections rectangulaire et elliptique • 138
Agir sur les sélections • 140
Le menu Sélection • 140
L’éditeur de sélection • 143
Combiner des formes • 145
Transformer et déformer le tracé de sélection • 152
Peindre le long de la sélection • 153
La sélection à main levée • 159
La sélection par couleur • 161
Le seuil de tolérance • 161
La sélection contigüe • 162
Sélectionner sur tout le calque • 164
Réussir un détourage • 166
L’extraction de premier plan • 167
Les ciseaux intelligents • 171
Peaufiner avec le masque rapide • 174
Utiliser un sujet détouré • 179
Enregistrer des sélections • 180
Comprendre les sélections • 182
En résumé • 185
6. CALQUES . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187
Qu’est-ce qu’un calque ? • 188
Décomposer l’image en plans • 188
Le principe de la superposition • 189
Manipuler les calques • 192
La fenêtre des calques • 192
Les menus des calques • 194
Les groupes de calques • 198
Identifier le calque actif • 199
Transparence et canal alpha • 201
La sélection flottante • 203
Créer des calques • 204
Un nouveau calque vierge • 205
Depuis une sélection flottante et le presse-papiers • 205
Depuis une nouvelle image • 206
Déplacer un calque d’une image à l’autre • 206
Les dimensions des calques • 206
Augmenter les dimensions du calque • 208
Réduire les dimensions du calque • 209
XII
© Groupe Eyrolles, 2011
Table des matières
Aligner et déplacer les calques • 210
Maîtriser le déplacement des calques • 210
Aligner les calques • 212
Utiliser habilement les masques de calque • 224
Le principe du masque • 224
Les propriétés du masque • 225
Initialiser le masque • 226
Le menu des masques • 229
En résumé • 239
7. INSÉRER DU TEXTE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 241
Insérer du texte • 242
Un calque pour le texte • 242
Modifier le texte • 245
Définir la zone de texte • 246
Les options de texte • 247
La boîte d’outils Texte • 249
Choisir une fonte (ou police) • 251
Transformer le texte en sélection • 253
Créer avec du texte • 254
En résumé • 263
8. LES OUTILS DE TRACÉ ET DE PEINTURE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 265
Les outils de dessin classiques • 266
Le crayon, le pinceau et l’aérographe • 266
La gomme • 268
Propriétés communes • 268
Le stylo-plume • 271
Les brosses • 272
Choisir une brosse • 272
La brosse « presse-papiers » • 276
Filtres et mots-clés • 279
Les dynamiques de brosses • 280
Comprendre le principe • 282
Définir une nouvelle dynamique • 284
Gérer des profils d’outils ou préréglages • 285
Créer un préréglage d’outil • 286
Utiliser un préréglage d’outil • 287
Remplissage de surface • 288
Remplir avec une couleur unie • 288
Remplir avec un motif • 290
Remplir avec un dégradé de couleurs • 291
© Groupe Eyrolles, 2011
XIII
P O C H E A C C È S L I B R E – G I M P 2 .8
Les différentes formes de dégradés • 293
En conclusion • 295
A. RACCOURCIS CLAVIER . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 297
Personnaliser les raccourcis • 297
Les raccourcis avec la souris et les touches de direction • 299
Les raccourcis clavier par défaut • 301
Activation des outils • 301
Menu Fichier • 303
Menu Édition • 304
Menu Sélection • 304
Menu Affichage • 305
Menu Image • 305
Menu Calque • 305
Fenêtres ancrables • 306
Menu Filtres • 307
Aide • 307
À la molette de la souris • 307
Aux flèches de direction • 308
B. SITES WEB À CONSULTER . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 311
Sites en français • 311
LinuxGraphic • 311
Libres à vous Scop • 312
Étude-Gimp.fr • 313
GimpFR • 313
Guide utilisateur de Gimp • 314
GIMPons • 314
Creationlibre • 315
Sites en anglais • 315
Gimp : le site officiel • 315
GIMP Plugin Registry : le dépôt de greffons • 315
GimpUsers.com : le site de la communauté Gimp • 316
Meet the GIMP ! : des tutoriels en vidéo • 316
GIMPStuff.org : matériels et matériaux pour Gimp • 316
Ramón Miranda et Gimp Paint Studio • 318
Gimp Magazine • 318
Trouver des images libres ? • 320
Des logiciels de graphisme complémentaires à Gimp • 320
Dessin matriciel et retouche d’images • 320
Dessin vectoriel • 321
Composition 3D • 321
XIV
© Groupe Eyrolles, 2011
Table des matières
Publication assistée par ordinateur • 321
Gestion de banque d’images • 321
Boîte à outils • 322
C. MODES DE FUSION DES CALQUES . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 325
D. FORMATS DE FICHIERS RECONNUS PAR GIMP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 333
Les formats propres à Gimp • 333
XCF • 333
Archives bzip et gzip • 333
XJT • 334
Brosse Gimp • 334
Motif Gimp • 334
Les formats vectoriels • 334
SVG (L) • 335
PDF • 335
PostScript et PostScript encapsulé • 335
Microsoft Windows Meta File (L) • 336
Les formats points • 336
Photoshop • 336
Paint Shop Pro (L) • 336
JPEG • 336
PNG • 336
GIF • 337
Art ASCII (E) • 337
Tableau HTML (E) • 337
Icônes Microsoft Windows • 337
Pixmap X et Bitmap X • 337
Tiff • 338
Windows BMP • 338
E. DOSSIERS ET FICHIERS DE GIMP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 341
F. RÉFLEXIONS SUR LES LICENCES ET LA PROTECTION DES ŒUVRES . . . . . . . . . . . . . . . . . . 345
Les licences et le droit • 345
Réflexions sur la protection d’une œuvre • 347
G. FAQ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 351
INDEX . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 353
© Groupe Eyrolles, 2011
XV
Avant-propos
Pourquoi utiliser Gimp plutôt que
Photoshop ?
Premièrement, Gimp est un logiciel libre, ce qui signifie que vous avez le
droit de l’utiliser sans condition. Personne ne vous demandera de payer
une licence pour l’utiliser ou pour avoir une mise à jour. De plus, il n’existe
pas de version édulcorée baptisée par exemple « Gimp Elements » : en utilisant Gimp, vous avez accès à toutes ses fonctionnalités.
Deuxièmement, Gimp est performant. Il répondra probablement à tous
vos besoins.
Oui mais, certains objecteront-ils...
• Il ne gère toujours pas correctement la décomposition en CMJN ! Certes,
mais est-ce vraiment son rôle ? Une lecture attentive du premier chapitre mettra à mal quelques préjugés. Ensuite, pour les cas où vous avez
vraiment besoin de produire des images en CMJN depuis Gimp, l’extension Separate+ vous sera d’un grand secours. Je ne vous ferai pas l’injure
de vous promettre que le CMJN sera correctement géré dans la
version 3.0, nul ne sait quand elle sortira.
• Il n’est pas adapté aux contraintes qualitatives des photographes
professionnels ! En effet, ne gérant qu’une profondeur de couleur de
8 bits, il perd une bonne partie des nuances des photos prises en
16 bits. La version 2.10 corrigera ce manque en gérant jusqu’à 32 bits et
sortira dans un délai beaucoup plus raisonnable que la version 3.0.
Gimp ne gère pas non plus les multiples formats bruts (Raw) des appa© Groupe Eyrolles, 2013
POCHE ACCÈS LIBRE – GIMP 2.8
reils photo. Ces formats garantissent une absence de traitement par
l’appareil photo et vous permettent de développer vos photos comme
dans un vrai laboratoire photo. Pour cet aspect-là, je ne saurai trop
vous conseiller d’utiliser un logiciel dédié tel que digiKam ou DarkTable,
tous deux libres, qui vous permettent également de gérer et de classer
vos collections de photos.
• Il ne gère pas les calques de fonction ! Il ne gérait pas non plus les groupes
de calques jusqu’à la présente version. Gimp est développé par des
bénévoles et évolue au fil des versions. De plus, les calques de fonction
offrent une certaine souplesse, mais ne sont pas indispensables.
• Il n’est pas comme Photoshop ! Non, c’est irréfutable. Pendant longtemps, Gimp a été développé pour répondre aux besoins de ses développeurs, pas pour copier Photoshop. Depuis quelques années, les
développeurs sont plus à l’écoute des utilisateurs, ce qui a pour effet
d’améliorer le logiciel. Les deux sont similaires dans leurs objectifs, sans
pour autant être des clones. D’ailleurs, Gimp Magazine dans son
numéro 3, a publié un comparatif intéressant et objectif sur les deux
logiciels. Il est traduit en français sur le site de LinuxGraphic : http://
www.linuxgraphic.org/wp/comparatif-gimp-photoshop/.
Ceux qui ne seront pas convaincus par cet argumentaire auront peut-être
tout intérêt a continuer leur chemin avec Photoshop. C’est leur droit et
chacun est libre de choisir, de continuer à payer des licences et mises à jour,
ou de ne pas être en règle et de craindre que la moindre mise à jour ne le
trahisse.
Choisir d’utiliser des logiciels libres, c’est aussi choisir la tranquillité.
Que trouverez-vous dans ce livre ?
Si vous avez lu l’une des précédentes éditions, le passage à la couleur
devrait vous enchanter autant que moi lorsque j’ai appris la nouvelle. Quel
plaisir de pouvoir vous montrer des photos en couleurs, et quel soulagement de ne plus avoir à travailler les contrastes pour faire apparaître ce
que les niveaux de gris avaient gommés !
2
© Groupe Eyrolles, 2013
Avant-propos
Mais ce changement n’est pas le seul. Sept ans se sont écoulés depuis la
première version de ce livre. En le relisant, je me faisais régulièrement la
réflexion que ce que j’avais écrit à l’époque (même si certains passages ont
été rafraîchis, enrichis au fil des trois rééditions) était aujourd’hui dépassé.
Loin de moi l’idée de renier les éditions précédentes ! En sept années, j’ai eu
le temps d’animer nombre d’ateliers et de formations sur Gimp, qui m’ont
apportés nombre de retours de la part de débutants. Cette expérience
acquise m’a amené à revoir entièrement la façon de présenter Gimp et son
utilisation.
Le livre que vous tenez entre les mains n’est pas une simple mise à jour de
l’édition précédente, mais une réécriture quasi complète. Bien sûr, il reste
quelques passages issus du passé, mais la majorité du contenu est nouvelle.
Ceci au prix d’un recentrage sur les bases de Gimp.
Les deux bases, selon moi indispensables pour être à l’aise avec Gimp, sont
les sélections et les calques. Elles sont détaillées dans les chapitres 5 et 6,
avec le but avoué de vous permettre de les maîtriser. À la lecture de ces
deux chapitres, sélections, calques et masques ne devraient plus avoir de
secret pour vous, vous ouvrant la voie de la retouche d’images et du photomontage.
Mais avant cela, le chapitre 4 vous permettra de réellement débuter avec
Gimp : vous apprendrez à redimensionner, pivoter, recadrer, déplacer puis
enregistrer et exporter vos œuvres.
Le chapitre 7, consacré à l’insertion de textes dans vos images, vous initiera à des pistes créatives qui peuvent être appliqués autrement qu’avec
du texte.
Dans le chapitre 8, vous apprendrez comment utiliser les outils de peinture
et de remplissage. Gimp 2.8 améliore les possibilités d’exprimer son art pictural, notamment grâce aux dynamiques de brosses. Mais ces outils peuvent
avoir d’autres usages que la peinture artistique. Une bonne connaissance
technique vous aidera pour les calques et les sélections.
Les outils de transformation ne bénéficient pas d’un chapitre dédié, mais
sont abordés rapidement dans d’autres chapitres. Les outils de couleur
sont les grands perdants de cette restructuration. Mais, comme toute
notion non détaillée, vous en trouverez une présentation rapide dans le
chapitre 3, consacré à l’interface de Gimp.
© Groupe Eyrolles, 2013
3
POCHE ACCÈS LIBRE – GIMP 2.8
Le chapitre 2 vous guidera dans l’installation de Gimp et d’éventuelles
extensions, porteuses de fonctionnalités supplémentaires.
Quant au premier chapitre, il est totalement nouveau. Il aborde des
notions essentielles lorsque l’on travaille avec des images numériques :
dimensions, résolution, couleurs (RVB, CMJN), formats d’image, etc. Il
replace également Gimp dans une chaîne graphique entièrement libre et
montre la nécessité d’utiliser conjointement d’autres logiciels tels qu’Inkscape (dessin vectoriel) et Scribus (publication assistée par ordinateur),
selon l’objectif que vous vous fixez.
Vous retrouverez, au sein de ces chapitres, de nombreux tutoriels (dont la
liste est donnée ci-après).
Enfin, les annexes du livre donnent d’autres informations utiles, telles la
liste des raccourcis clavier utilisables dans Gimp (annexe A), les différents
modes de fusion des calques (annexe C), les formats de fichier reconnus
par Gimp (annexe D), les noms des dossiers et fichiers utilisés par Gimp
(annexe E), mais aussi des ressources en ligne (annexe B) et quelques
réflexions sur les licences et la protection des œuvres (annexe F).
Aide Trouver rapidement les réponses aux questions que
vous vous posez !
En fin d’ouvrage, avant l’index alphabétique, vous trouverez une FAQ
(Frequently Asked Questions) qui vous permettra de retrouver facilement dans le livre les réponses aux questions que vous ne manquerez pas de vous poser en pratiquant Gimp.
Liste des tutoriels
Réaliser des sélections à partir de plusieurs formes géométriques, 146
Peindre des formes géométriques, 154
Isoler un ciel relativement uniforme, 162
Isoler les coquelicots, 164
Extraire le premier plan, 167
Détourer une jarre avec les ciseaux intelligents, 171
4
© Groupe Eyrolles, 2013
Avant-propos
Réaliser un détourage parfait, 177
Réaliser un fondu entre deux photos avec le masque rapide, 183
Insérer une nouvelle image en tant que calque, 196
Créer une composition à partir de plusieurs photos, 214
Réaliser une ombre portée soi-même, sans utiliser le filtre, 220
Réaliser un fondu entre deux photos avec un masque de calque ,227
Réaliser un détourage parfait avec un masque de calque, 230
Convertir une image en noir et blanc en conservant un élément en couleur, 232
Coloriser une image en noir et blanc, 234
Insérer une image dans le texte, 254
Mettre un texte le long d’un chemin, 257
Utiliser la brosse « presse-papiers », 276
Créer des raccourcis clavier pour faire varier la brosse, 278
Remerciements
Merci à Karine Joly pour ses qualités relationnelles, sa patience, ses relances
amicales. Merci à Muriel Shan Sei Fan pour les mêmes qualités et pour
m’avoir lancé dans le grand bain en 2005. Ma gratitude va également à
Matthieu, Anne-Lise, Aurélie, Gaël, Sophie, Éliza et Anne, qui ont contribué
aux éditions précédentes (dont il ne reste certes plus grand-chose, mais le
résultat actuel en découle) et enfin à Hind, et encore Gaël et Sophie pour
cette nouvelle édition.
Merci à Natalie, Murielle, Malaïa et tout mon entourage qui m’ont supporté, encouragé, mis une gentille pression et donné des idées, parfois
involontairement.
Un remerciement particulier à Cédric, Elisa, Alessandro, Louis, Vincent
(pour la licence Colibre), Alexis, Pierre-Yves, Bouthaïna, Christophe (et les
autres Framasoftiens) et tous ceux qui œuvrent pour démocratiser les logiciels libres de graphisme et pour les faire progresser.
© Groupe Eyrolles, 2013
5
POCHE ACCÈS LIBRE – GIMP 2.8
Surtout, merci aux développeurs et à tous les utilisateurs qui ont permis à
Gimp de devenir aujourd’hui un outil de référence au même titre que
Scribus, Firefox, Thunderbird et OpenOffice. Ce logiciel me procure toujours autant de plaisir.
Pour poursuivre l’aventure sur les chemins sinueux de Gimp, vous pouvez
me retrouver sur le site de Libres à vous Scop (http://libresavous.com), l’entreprise que j’ai cofondée et qui propose des formations à l’usage des logiciels
libres, mais aussi sur LinuxGraphic (http://linuxgraphic.org), site francophone
dédié aux logiciels de graphisme libres. J’ai renoncé à tenir un blog qui
ferait finalement doublon avec ces deux sites.
Toutefois, vous trouverez les photos utilisées dans cet ouvrage à l’adresse :
http://photos.gabian-libre.org
Vous pouvez également me suivre sur Twitter :
@DimitriLav (compte personnel) et @Libresavous (compte professionnel).
Dimitri Robert
6
© Groupe Eyrolles, 2013
chapitre
2
© Groupe Eyrolles, 2013
Présentation
et installation
Gimp, dédié à la création graphique,
est un logiciel libre. Vous pourrez
donc l’installer en toute liberté, que
vous soyez sur Linux, Windows ou
Mac OS X. Voyons de plus près
ce qu’il en est de ses possibilités
et de ses limites.
Sommaire
B
B
B
B
B
Gimp, un logiciel libre
Que faire ou ne pas faire avec Gimp
Installer Gimp et des ressources supplémentaires
Votre premier démarrage avec Gimp
Vers Gimp 2.10
© Groupe Eyrolles, 2013
POCHE ACCÈS LIBRE – GIMP 2.8
Après une introduction théorique sur l’infographie, abordons à présent le
vif du sujet. Nous commençons par une présentation de Gimp et de
l’usage que vous pourrez en faire. Ensuite, nous vous guidons dans son installation sur les trois principaux systèmes où Gimp peut élire domicile :
Linux, Windows et Mac OS X.
Gimp, un logiciel libre
Gimp est un acronyme signifiant GNU (Image Manipulation Program), soit en
français « programme de retouche d’images de GNU ». GNU est lui-même un
projet de système d’exploitation libre pourvu de tous les outils nécessaires au
travail sur ordinateur, communément nommé « Linux ». Initialement réservé
à la plate-forme GNU/Linux, Gimp est, depuis longtemps, disponible pour
Microsoft Windows (toutes versions à partir de Windows XP SP3) et Apple
Mac OS X à partir de la version Snow Leopard (10.6).
Gimp est un logiciel libre, publié sous licence GPL (General Public License).
Cela signifie que vous avez le droit de l’utiliser et de l’installer sur autant
d’ordinateurs souhaités (aucune limite au nombre de postes). Avec un
logiciel libre, c’est le droit d’utiliser qui est gratuit, contrairement à un logiciel propriétaire. À noter : on n’achète pas un logiciel, on paye juste pour
avoir le droit de l’utiliser, sous certaines conditions.
Les auteurs ne vous imposent aucune contrainte : vous êtes libre d’utiliser
Gimp ou non, de le télécharger librement et légalement depuis Internet, de
le diffuser autour de vous, gratuitement ou non.
Le code source (les instructions et procédures de fabrication du programme) sont disponibles. Vous pouvez donc modifier (ou faire modifier
si vous n’avez pas les compétences requises) Gimp pour améliorer un
point, corriger un défaut, contribuer à la documentation et à la traduction, mais aussi à d’autres usages spécifiques tels que le portage sur une
autre plate-forme. Par exemple, si le code source de Gimp n’avait pas été
libre, il n’y aurait peut-être pas eu de versions pour Windows et Mac OS X.
Vous pouvez ensuite diffuser vos propres modifications afin d’en faire profiter d’autres utilisateurs. Cependant, vous n’avez pas le droit d’interdire à
autrui ce qui vous est permis. Par conséquent, tous les utilisateurs sont à
égalité et disposent des mêmes droits.
44
© Groupe Eyrolles, 2013
2 – Présentation et installation
À noter Licence GPL
GPL signifie General Public License (licence publique générale). Vous
pouvez la consulter à l’adresse suivante (pas de version française
officielle) :
B http://www.gnu.org/licenses/gpl.html
Notez qu’il existe une traduction officieuse de la GPL, qui donne une
bonne idée de sa teneur :
B http://fsffrance.org/gpl/gpl-fr.fr.html
Présentation Wilber, la mascotte
Wilber (figure 2–1) fut créé par Tuomas Kuosmanen. Selon Wikipédia, il s’agirait d’un coyote ; d’autres sources parlent d’une souris...
Depuis, des artistes comme Simon Budig et Raphaël Quinet lui ont
offert des accessoires : entre autres, un chapeau de magicien, un casque de chantier, un béret, un pinceau dans la bouche et quantité
d’autres que vous pouvez retrouver sur le Net, dans le « kit de construction de Wilber ».
B http://www.gimp.org/about/
Wilber_Construction_Kit_XP.xcf.gz
Figure 2–1 Wilber, la mascotte de Gimp
© Groupe Eyrolles, 2013
45
POCHE ACCÈS LIBRE – GIMP 2.8
Les possibilités et les limites du logiciel
À l’origine, Gimp fut développé par Spencer Kimball et Peter Mattis, à
l’occasion d’un projet universitaire en 1995 : « Gimp est notre réponse au
manque actuel de logiciel libre de manipulation d’image (ou au moins à
prix raisonnable) pour Linux et Unix en général. »
Depuis, nombre de développeurs ont pris le relais et permis à Gimp
d’asseoir une solide réputation. Pourtant, aucune société ou fondation ne
finance ce projet, contrairement à d’autres exemples célèbres tels que
Firefox (fondation Mozilla), OpenOffice (fondation Apache) ou encore
Ubuntu (société Canonical).
Prononciation My name is GIMP!
Comment prononcer « Gimp » ? Quand je discute avec vous, chers
lecteurs, j’entends au moins trois façons de prononcer Gimp : « guimp », « ji-mp » ou « dji-mp ». Le Wiktionnaire (dictionnaire conçu
sur le modèle de l’encyclopédia Wikipédia) affirme que la pronociation est « gui-mp », soit en phonétique : [gimp].
B http://en.wiktionary.org/wiki/Gimp
Écriture Comment écrire GIMP ?
Longtemps, ce logiciel fut nommé « The GIMP ». Depuis 2007, ses
développeurs ont décidé que la graphie correcte serait « GIMP » :
tout en majuscules, sans point et surtout sans l’article « The ». On le
trouve cependant très souvent écrit « Gimp », selon la convention
de typographie française (mais pas seulement) qui veut qu’un acronyme (c’est-à-dire avec une prononciation syllabique, comme Unicef,
par exemple) s’écrive avec une majuscule au début, puis des minuscules, notamment lorsqu’il comporte au-delà de trois lettres. C’est le
choix éditorial qui a été fait dans cet ouvrage, au motif de contribuer
à la lexicalisation du mot tout en allégeant la lecture du livre.
Même si Gimp entre dans la même catégorie que des logiciels propriétaires comme Photoshop, Paint Shop Pro, peut-on considérer qu’ils sont
équivalents ? Stricto sensu, non. Mais l’on retrouve beaucoup de fonctions
communes dans Gimp et dans Photoshop. Et chacun des deux propose
des fonctions que l’autre n’a pas (encore).
46
© Groupe Eyrolles, 2013
2 – Présentation et installation
Pour un usage non professionnel, vous pouvez, sans hésiter, faire l’économie de la licence Photoshop et adopter Gimp. Pour un usage professionnel, Gimp répondra à vos besoins, dans la plupart des cas, pour peu
que vous preniez quelques nouvelles habitudes.
En pratique, pour passer de Photoshop à Gimp, la plus grande difficulté ne
réside ni dans les différences de fonctionnalités, ni dans le changement
d’habitudes, mais plutôt dans la volonté d’en changer. D’autant que Gimp
n’est pas incompatible avec un travail de qualité professionnelle, y compris
le passage chez l’imprimeur.
Gimp ne gère pas le CMJN. Dans le premier chapitre vous avez lu en quoi
consiste le procédé, quand il intervient et pourquoi il n’est pas du ressort
de Gimp de le gérer.
Du fait que vous travaillez sur un écran qui affiche des couleurs en RVB, la
conversion de RVB vers le CMJN devra, en cours de production, être réalisée le plus tard possible. En fait, ce sera au logiciel de mise en page, en
l’occurrence Scribus, de prendre en charge ce profil de couleur. Rappel
pour mémoire : Gimp n’est pas un logiciel de mise en page, mais essentiellement dédié à la retouche d’image et à la création graphique.
Toutefois, si vous envisagez de travailler seulement avec Gimp, sans passer
ensuite par un logiciel de mise en page, notez que la conversion de RVB
vers CMJN est de mieux en mieux gérée par les professionnels de l’impression. Et ce, sans forcément un supplément de coût. Discutez-en avec votre
imprimeur.
Et si vraiment vous souhaitez exporter en CMJN, essayez le plug-in Separate+. Certes, il n’est pas simple d’utilisation, mais permet l’export d’images
au format Tiff décomposées en CMJN.
À signaler : la gestion du CMJN serait prévue pour la version 3.0 de Gimp,
qui n’est pas encore programmée.
© Groupe Eyrolles, 2013
47
POCHE ACCÈS LIBRE – GIMP 2.8
Exemple Un magazine réalisé avec des logiciels libres
Le magazine Le Tigre est conçu avec Gimp, Inkscape, Scribus,
Apache OpenOffice et FontForge. Sans oublier tous les autres logiciels nécessaires au bon fonctionnement d’un ordinateur.
Entièrement réalisé avec des logiciels libres (y compris le système
d’exploitation Linux), ce magazine généraliste et indépendant est le
plus bel exemple, en termes de qualité professionnelle, du résultat
pouvant être obtenu avec des logiciels ne nécessitant pas de droits
d’utilisation payants.
B http://le-tigre.net
Installer Gimp
Gimp est conçu grâce à la bibliothèque GTK, un ensemble d’outils de programmation d’interfaces graphiques. De nombreuses applications utilisent
GTK (par exemple, Inkscape et l’environnement Gnome) ; d’autres logiciels
sont conçus à partir de QT, la bibliothèque à l’origine de l’environnement
KDE (Scribus, digiKam). Pour la petite histoire : GTK fut créée afin de concevoir Gimp. D’ailleurs, l’acronyme GTK signifie Gimp ToolKit.
Sous Windows
Pour utiliser Gimp 2.8,
Windows XP SP3 ou plus.
vous
devrez
disposer
d’une
version
Téléchargement
Téléchargez la dernière version de Gimp pour Microsoft Windows sur le
site http://gimp-win.sourceforge.net/stable.html.
À noter : nous vous conseillons vivement de compléter votre installation
avec l’aide en ligne, en l’occurrence le manuel d’utilisation intégré dans
Gimp. Dans ce but, vous devrez également télécharger le fichier
GIMP Help 2, qui contient notamment la version française. Vous pouvez
récupérer le manuel au format PDF ou HTML sur le site dédié à la
documentation : http://docs.gimp.org.
48
© Groupe Eyrolles, 2013
2 – Présentation et installation
Installation
Pour installer Gimp, vous devrez exécuter le programme gimp-2.8.4setup.exe. Le nom peut changer en fonction du numéro de version. Ici, la
version est 2.8.4.
Lors de l’installation d’un logiciel sous Windows, il faut généralement
valider un certain nombre d’écrans (figure 2–2).
1 Dans un premier temps, Windows vous demande d’autoriser le lancement du programme d’installation .
2 Après l’acceptation de la licence GPL , il vous sera proposé pour l’installation de Gimp, un répertoire par défaut . Vous pouvez, soit l’utiliser, soit en choisir un autre.
Figure 2–2 Installation de Gimp pour Windows : préliminaires
© Groupe Eyrolles, 2013
49
POCHE ACCÈS LIBRE – GIMP 2.8
Figure 2–2 Installation de Gimp pour Windows : préliminaires (suite)
3 Gimp propose plusieurs composants (figure 2–3). Vous souhaitez une
version française ? Le module Translations vous est donc indispensa-
ble. Si, au préalable vous avez installé GTK, ce dernier apparaîtra en
grisé dans cette liste.
4 Pour bénéficier des modules écrits en langage Python, vous devrez installer Python et PyGTK (version de GTK pour Python), puis cocher la
case GIMP Python Extension. Ce n’est pas obligatoire, mais vous pourrez
ainsi définir des associations entre des formats de fichier et Gimp. Par
exemple, si vous cochez GIMP image, il vous suffira, dans l’explorateur
de Windows, de double-cliquer sur un fichier XCF pour ouvrir automatiquement Gimp.
5 Un dernier écran vous montre un récapitulatif de vos choix. Validez
afin que s’effectue l’installation .
6 Enfin, l’aide en ligne contenue dans le fichier gimp-help-2-2.8.0fr-setup.exe, disponible en plusieurs langues, vous sera d’un précieux secours.
50
© Groupe Eyrolles, 2013
2 – Présentation et installation
Figure 2–3 Installation de Gimp pour Windows : validation
Sur le Web Obtenir Python
Pour télécharger l’interpréteur Python (logiciel capable d’exécuter
des scripts Python) et PyGTK :
B http://www.python.org/download/
B http://www.pygtk.org/downloads.html
© Groupe Eyrolles, 2013
51
POCHE ACCÈS LIBRE – GIMP 2.8
Ergonomie N’associez pas tous les types de fichiers avec Gimp
Nous vous déconseillons d’associer tous les formats d’image avec
Gimp. En effet, le plus souvent, on ouvre une image seulement pour
la regarder... et non la modifier. Aussi, laissez votre visionneur d’images ouvrir vos photos.
Sous Linux
La réputation de Gimp n’est plus à faire : ce logiciel figure dans toutes les distributions Linux. Par conséquent, il est vivement conseillé d’installer Gimp
via le gestionnaire de paquets de votre distribution. L’installation, la mise à
jour vers les nouvelles versions, ainsi qu’une éventuelle suppression sont
gérées et ne demandent que votre validation. Donc, nul besoin d’ouvrir
votre navigateur et d’aller chercher les archives à installer sur le site de Gimp !
En outre, lorsque vous demandez l’installation de Gimp, le gestionnaire
s’assure que GTK et d’autres bibliothèques nécessaires sont bien présentes.
À défaut, il installe tous les éléments manquants ou périmés. C’est ce qu’on
appelle la gestion des dépendances.
Figure 2–4 Choisissez les logiciels et composants à installer avec Synaptic.
52
© Groupe Eyrolles, 2013
2 – Présentation et installation
Sur la figure 2–4, vous trouverez un exemple avec Synaptic, une interface
pour le gestionnaire APT des distributions basées sur Debian, telles
qu’Ubuntu. De même, sur la figure 2–5, la « logithèque », autre interface
chapeautant APT et montrant les logiciels à installer de manière plus conviviale (mais pas forcément plus pratique).
Figure 2–5 Choisissez les logiciels et composants à installer dans la logithèque.
© Groupe Eyrolles, 2013
53
POCHE ACCÈS LIBRE – GIMP 2.8
Autre avantage : si vous demandez à votre gestionnaire d’installer Gimp, il
vous proposera l’installation de tous les composants nécessaires (par
exemple, gimp-data), ainsi que diverses options comme l’aide en ligne.
Sous Mac OS X
Pour fonctionner sous Mac OS X, Gimp, pendant longtemps, a requis la
présence de X11, l’interface graphique légendaire d’Unix. Pour plus de simplicité et d’efficacité, la version 2.8.2 inaugure une interface native
Mac OS X. À noter : Gimp 2.8.2 (et les versions suivantes) requiert
Mac OS X 10.6 (Snow Leopard) minimum.
Téléchargement
Sur le très sobre site http://gimp.lisanet.de, vous pourrez télécharger la dernière version de Gimp pour Mac OS X (ainsi que l’aide en ligne), en choisissant la version appropriée à votre système.
Installation
Lorsque vous ouvrez le fichier .dmg, celui-ci se comporte comme un périphérique virtuel. Le Finder vous affiche son contenu. Pour installer Gimp, il
suffit de cliquer sur l’icône GIMP, puis de la glisser sur le menu Applications
en bas à gauche.
Pour démarrer Gimp, cliquez simplement sur son icône dans le menu
Applications.
Attention Raccourcis avec Ctrl sous Mac OS X
La coutume veut que les raccourcis usuels sur PC comportant la touche Ctrl soient
les mêmes dans le monde Apple, mais avec la touche Pomme. Gimp déroge à la
règle. Dans un souci d’homogénéiser les versions des différentes plates-formes, les
raccourcis sont identiques. Aussi, en parcourant cet ouvrage, vous n’aurez pas à
remplacer Ctrl par Pomme, lorsqu’il sera fait mention de raccourcis.
54
© Groupe Eyrolles, 2013
2 – Présentation et installation
Installer des ressources supplémentaires
Gimp étant un logiciel extensible, il existe de nombreuses contributions
externes (non incluses dans le projet principal), de qualité variable, comme
toutes contributions externes. Mais, comme il s’en trouve du bon et de
l’utile, il serait dommage de s’en priver, si besoin est.
Un premier choix Installer des extensions packagées
Depuis longtemps, sous Debian et distributions dérivées, il existe des
extensions sous forme de paquets, tels gimp-data-extras et gimpplugin-registry. Le premier ajoute des ressources : brosses et motifs.
Le second, des plug-ins et scripts tels que Separate+, pour décomposer un
calque en CMJN, ou Liquid Rescale, pour étirer une image en préservant
certaines zones.
Depuis peu, outre des plug-ins et extensions, il est proposé pour Windows
un paquet contenant les ressources de Gimp Paint Studio, un programme
de Gimp axé sur la peinture numérique : pinceaux, gomme, formes... Malheureusement, il ne se met pas à jour tout seul.
B http://sourceforge.net/projects/gimpextensions/
Vous trouverez quasi tous les plug-ins existants pour Gimp sur le site
http://registry.gimp.org. Vous pourrez y utiliser la fonction de recherche (en
anglais) ou mieux, le nuage de tags (Content by tags).
Par exemple, pour installer le script « Auto rotate with a vector », qui vous
aide à pivoter un calque à partir d’un segment :
1 Inscrivez « auto rotate » dans le champ de recherche. La première
réponse est la bonne.
2 Sur la page d’Auto rotate with a vector, vous trouverez plusieurs liens. Il
s’agit, ici, d’un script écrit en Scheme (extension .scm), le premier langage utilisé pour étendre les fonctions de Gimp (les Script-Fus). Depuis,
on a également utilisé Perl (.pl) et Python (.py).
3 Téléchargez uniquement le fichier .scm le plus récent. Jetez un œil sur
la documentation pour savoir où le trouver dans le menu de Gimp et
comment l’utiliser.
© Groupe Eyrolles, 2013
55
POCHE ACCÈS LIBRE – GIMP 2.8
4 Enregistrez-le dans le dossier plug-ins de votre profil Gimp : .gimp2.8/plug-ins de votre dossier personnel, dont l’emplacement varie
selon votre système d’exploitation.
5 Relancez Gimp. Ainsi, vous pourrez utiliser le script Auto-rotate
comme expliqué dans la documentation.
À savoir Script ou plug-in ?
Quelle différence entre un script et un plug-in ? Côté utilisateur,
aucune. Techniquement, le plus souvent, vous trouverez les plug-ins
sous la forme de sources à compiler soi-même (sauf les cas cités plus
haut). Les scripts sont également fournis en tant que sources, mais
sont directement utilisables (Gimp se chargeant de les interpréter).
Dans votre profil Gimp, vous trouverez deux dossiers distincts :
scripts et plug-ins.
Premier démarrage
Le premier démarrage est plus long que les suivants, en raison de la création
de votre profil utilisateur. Celui-ci permettra d’enregistrer tous les paramètres
que vous modifierez dans Gimp : la position et l’ouverture des différentes
fenêtres, la liste des images ouvertes précédemment, vos brosses créées, etc.
Sur la figure 2–6, vous pouvez admirer celui de la version 2.8.
Figure 2–6 Écran d’accueil de Gimp 2.8
56
© Groupe Eyrolles, 2013
2 – Présentation et installation
Après le démarrage, trois fenêtres s’affichent :
• sur la gauche, la Boîte à outils, avec en-dessous la fenêtre d’options de
l’outil sélectionné ;
• à droite, un échantillon de fenêtres de dialogue proposant plein de
fonctionnalités utiles (brosses, fenêtre des calques, etc.) ;
• au centre, la fenêtre principale de Gimp, à savoir l’espace de travail pour
ouvrir ou déposer les images ; vous aurez donc toujours au moins une
fenêtre d’image. Et lorsque vous fermez la dernière, vous fermez également l’application.
Si vous êtes habitué à Photoshop, vous remarquerez, que Gimp ne propose
pas de fenêtre globale regroupant l’ensemble de l’application et les diverses
fenêtres ancrables. Et pour cause, Gimp n’a pas de « fond » : les fenêtres
ancrables, les images et la boîte à outils sont toutes des fenêtres séparées
que vous agencerez à votre gré. Sur la figure 2–7, observez à quoi ressemble Gimp avec une image ouverte.
Figure 2–7 Gimp en mode multifenêtre avec une image
Sans doute avez-vous entendu dire que désormais Gimp avait une interface monofenêtre ? Ce n’est pas tout à fait exact. En fait, vous avez le choix.
Si vous préférez une seule fenêtre, sélectionnez le menu Fenêtres>Mode
© Groupe Eyrolles, 2013
57
POCHE ACCÈS LIBRE – GIMP 2.8
fenêtre unique. Il vous faudra sans doute ajuster la largeur de la boîte à
outils, équilibrer les différentes parties, mais vous devriez obtenir un
résultat similaire à la figure 2–8.
Figure 2–8 Gimp en mode fenêtre unique
Le futur de Gimp
La version 2.10, déjà en chantier avant la publication de la 2.8, ne devrait
toujours pas gérer le CMJN. Donc, pas de faux espoirs. Cette fonctionnalité
est listée dans les projets, mais reste non prioritaire.
La version de développement intègre déjà un nouvel outil, dit de transformation unifié, qui regroupe les fonctions de mise à l’échelle, de cisaillement, de rotation, de perspective et de déplacement. En une étape, mais
via plusieurs manipulations, vous pourrez, sur un calque, une sélection ou
un chemin, effectuer plusieurs types de transformations.
Les photographes se réjouiront de savoir que la prochaine version gérera
une plus grande profondeur de couleur. En effet, jusqu’à présent, Gimp ne
gère que 8 bits par composante : soit 256 valeurs différentes de rouge, de
vert et de bleu. Or, le matériel photographique professionnel produit des
58
© Groupe Eyrolles, 2013
2 – Présentation et installation
photos dont la profondeur atteint 16 bits. Aussi, ceux qui souhaitent rester
dans « le libre » devront actuellement se rabattre sur des logiciels comme
digiKam et DarkTable. La version 2.10 de Gimp sera en mesure de gérer 16
et 32 bits de profondeur.
Les groupes de calques intègrent désormais la version 2.8 (voir chapitre 6).
Cependant, la possibilité d’appliquer un masque sur le groupe, et non sur
un calque unique, ne sera effective que dans la prochaine version.
Pour de plus amples informations sur l’évolution de Gimp, rendez-vous sur
le wiki : http://wiki.gimp.org/index.php/Roadmap.
En résumé
Windows, Mac OS X, Linux ! Quel que soit votre système, l’installation de
Gimp est aisée. En outre, ce logiciel libre étant extensible, vous avez la possibilité d’intégrer divers plug-ins ou ressources supplémentaires.
© Groupe Eyrolles, 2013
59
annexe
A
© Groupe Eyrolles, 2013
Raccourcis clavier
Comme toute application graphique qui se respecte, Gimp propose une multitude de raccourcis clavier pour accéder plus rapidement aux fonctionnalités
courantes, sans retourner sur la barre d’outils. Outre les classiques Ctrl+C,
Ctrl+V, Ctrl+X, tous les outils peuvent être activés par des raccourcis. Enfin,
presque tous... Pour la simple raison qu’un simple clavier ne suffirait pas à contenir toutes les fonctions de Gimp, ou alors il vous faudrait un brevet de pilote
de ligne pour toutes les retenir. La solution ? Les personnaliser.
Personnaliser les raccourcis
La première méthode consiste à passer par le menu Édition>Raccourcis
clavier.
Les raccourcis sont classés par thèmes :
• Fichier, Édition, Sélection, Affichage, Image, Calque, Outils, Fenêtres, Aide :
fonctions du menu éponyme ;
• Contexte : pour les fonctions, très nombreuses, destinées à des usages
très pointus et accessibles en fonction du contexte (c’est-à-dire de
l’outil actif). Par exemple : pour augmenter ou diminuer la taille de
brosse (d’un ou de dix pixels), pour modifier l’une des trois composantes RVB de la couleur de premier plan, etc. Les noms de ces fonctions ne
sont pas traduits en français et elles sont dépourvues de raccourcis clavier. À vous de les définir, si besoin ;
• Boîtes de dialogues : liste de toutes les fenêtres ancrables (y compris celles qui n’apparaissent pas dans le menu Fenêtres>Fenêtres ancrables).
© Groupe Eyrolles, 2013
POCHE ACCÈS LIBRE – GIMP 2.8
• Objet graphique : abstraction des calques et masques ;
• Canaux, Chemins : fonctions relatives à ces deux entités ;
• Masque rapide : fonctions habituellement accessibles via le bouton
situé dans le coin inférieur gauche de la zone d’images ;
• Greffons : permet d’adjoindre un raccourci clavier sur les greffons (plug-ins,
extensions, etc.) de votre choix.
Sélectionnez le raccourci que vous souhaitez modifier, puis inscrivez le
nouveau (figure A-1).
Figure A-1 Modifier les raccourcis clavier
298
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Il existe une seconde méthode plus souple et, pour l’instant, propre aux
applications développées avec GTK+, consistant à définir un raccourci
dynamiquement. Ouvrez, par exemple, le menu Couleurs, puis positionnez
(sans cliquer) la souris sur Inverser. Pressez ensuite la combinaison
Ctrl+Maj+I. Dès lors, le raccourci apparaît en face du nom (figure A-2), et
vous pourrez désormais l’utiliser.
Figure A-2 Définir un raccourci dynamiquement
Pour que cela fonctionne, vous devrez, dans les Préférences de l’interface,
cocher les cases Afficher les accélérateurs clavier (autre nom des raccourcis
clavier), Utiliser les raccourcis clavier dynamiques et Enregistrer à la sortie les
raccourcis clavier.
Si vous redéfinissez, via Édition>Raccourcis clavier, un raccourci déjà utilisé,
Gimp vous préviendra. En revanche, avec la méthode dynamique, il n’en
fera rien. Soyez donc prudent !
Les raccourcis avec la souris
et les touches de direction
Gimp permet d’attacher une multitude de fonctions aux événements liés à
la molette de la souris et aux flèches de direction, en les combinant avec les
© Groupe Eyrolles, 2013
299
POCHE ACCÈS LIBRE – GIMP 2.8
touches spéciales Ctrl, Alt et Maj. La configuration de ces raccourcis est possible par Édition>Préférences>Périphériques d’entrée>Contrôleurs d’entrée
(figure A-3). Ils sont classés par touche ou action de la souris. Attention, les
noms des fonctions sont ceux utilisés par Gimp en interne. Ils sont donc
moins évocateurs que leur équivalent en français. À manipuler avec
précaution !
Figure A-3 Raccourcis souris et touches de direction
300
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Attention, ces raccourcis ne sont utilisables que dans leur contexte. Ce dernier sera précisé dans les tableaux en fin d’annexe.
Les raccourcis clavier par défaut
Activation des outils
Activer l’outil
Raccourci
Sélection rectangulaire
R
E
F
U
Sélection elliptique
Sélection à main levée
Sélection de zones contiguës (baguette
magique)
Sélection par couleur
Ciseaux intelligents
Tracer un chemin (courbe de Bézier)
Récupère des couleurs (pipette)
Zoom avant et arrière
Mesure angles et distances
Déplacer
Déplacer la vue (activer temporairement)
Découper et redimensionner
Pivoter (rotation)
Étirer et réduire
Cisailler
Perspective
Retourner
Déformation interactive
Texte
© Groupe Eyrolles, 2013
Maj+O
I
B
O
Z
Maj+
M
Espace ou Ctrl + Clic du milieu
Maj+C
Maj+R
Maj+T
Maj+S
Maj+P
Maj+F
Maj+G
T
301
POCHE ACCÈS LIBRE – GIMP 2.8
Activer l’outil
Raccourci
Remplissage
Éclaircissement et assombrissement
Maj+B
L
N
P
Maj+E
A
K
C
Maj+U
S
Maj+D
Désaturer
Aucun
Balance des couleurs
Aucun
Ajuste teinte et saturation
Aucun
Colorier
Aucun
Luminosité et contraste
Aucun
Seuil
Aucun
Niveaux de couleurs
Aucun
Ajuster les courbes de couleurs
Aucun
Postériser (réduire le nombre de couleurs)
Aucun
Siox – extraire le premier plan
Aucun
Aligner les calques, les objets
Correcteur
Q
H
Clonage en perspective
Aucun
Couleurs par défaut
Échanger les couleurs
D
X
Action GEGL
Aucun
Diminuer la première* valeur
<
Dégradé
Crayon
Pinceau
Gomme
Aérographe
Calligraphie (stylo-plume)
Clonage
Flou et netteté
Barbouiller
302
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Activer l’outil
Raccourci
Ctrl+<
Augmenter la première valeur
>
Augmenter la première valeur dix fois plus Ctrl+>
Diminuer la deuxième valeur
[
Diminuer la deuxième valeur dix fois plus
Ctrl+[
Augmenter la deuxième valeur
]
Augmenter la deuxième valeur dix fois plus Ctrl+]
Diminuer la première valeur dix fois plus
* Les « première valeur » et « deuxième valeur » mentionnées dans le
tableau correspondent aux valeurs ajustables via une réglette dans la
fenêtre Options des outils. Pour le pinceau, par exemple, la première valeur
désigne l’opacité ; la deuxième, le facteur grossissant de la brosse. On peut,
bien sûr, affecter des raccourcis pour les troisième et quatrième valeurs.
Menu Fichier
Fonction
Raccourci
Nouveau
Ctrl+N
Ctrl+Maj+V
Ctrl+O
Ctrl+Alt+O
Ctrl+S
Ctrl+Maj+S
Ctrl+E
Ctrl+Maj+E
Ctrl+1, Ctrl+2 ... Ctrl+0
Ctrl+W
Ctrl+P
Ctrl+Q
Créer>Depuis le presse-papiers
Ouvrir
Ouvrir en tant que calques
Enregistrer
Enregistrer sous
Exporter vers/Écraser
Exporter
Récemment ouverts
Fermer une image
Imprimer
Quitter
© Groupe Eyrolles, 2013
303
POCHE ACCÈS LIBRE – GIMP 2.8
Menu Édition
Fonction
Raccourci
Annuler
Coller comme une nouvelle image
Ctrl+Z
Ctrl+Y
Maj+Ctrl+Z
Maj+Ctrl+Y
Ctrl+X
Ctrl+C
Ctrl+Maj+C
Ctrl+V
Ctrl+Maj+V
Couper (nommé)
Aucun
Copier (nommé)
Aucun
Coller en nommant
Aucun
Effacer
Suppr
Ctrl+ ,
Refaire
Annuler de force
Refaire de force
Couper
Copier
Copier visible
Coller
Remplir avec la couleur de premier plan
(PP)
Remplir avec la couleur d’arrière-plan (AP)
Remplir avec le motif
Ctrl+ .
Ctrl+ ;
Menu Sélection
Fonction
Raccourci
Tout sélectionner
Ctrl+A
Ctrl+Maj+A
Ctrl+I
Ctrl+Maj+L
Maj+O
Aucune
Inverser
Flottante
Par couleur (outil)
304
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Fonction
Raccourci
Depuis le chemin
Maj+V
Maj+Q
(Dés)Activer le masque rapide
Menu Affichage
Fonction
Raccourci
Zoom avant
+
1
`
Ctrl+Maj+J
Ctrl+J
F11
Ctrl+T
Ctrl+Maj+T
Ctrl+Maj+R
Zoom arrière
Zoom un pour un (100 %)
Revenir au zoom
Ajuster l’image dans la fenêtre
Ajuster la fenêtre à l’image
Plein écran
Afficher/Masquer la sélection
Afficher/Masquer les guides
Afficher/Masquer les règles
Menu Image
Fonction
Raccourci
Dupliquer
Ctrl+D
Ctrl+M
Alt+Entrée
Fusionner les calques visibles
Propriétés de l’image
Menu Calque
Les fonctions suivantes sont disponibles dans la fenêtre des calques.
© Groupe Eyrolles, 2013
305
POCHE ACCÈS LIBRE – GIMP 2.8
Fonction
Raccourci
Ctrl+H
Dupliquer le calque
Ctrl+Maj+D
Nouveau calque
Ctrl+Maj+N
Pile : Sélectionner le calque précédent (juste Page Haut
Ancrer le calque (la sélection sur le calque)
au-dessus)
Pile : Sélectionner le calque suivant (juste
au-dessous)
Page Bas
Pile : Sélectionner le calque du haut
Début
Fin
Ctrl+Maj+O
Maj+Alt+Clic gauche
Pile : Sélectionner le calque du bas
Décalage
Alpha vers sélection
sur la vignette du calque
Gestion des masques
Raccourci
Afficher/Appliquer le masque
Maj+Alt+Clic gauche
sur la vignette du masque
(Dés)activer le masque
Ctrl+Clic gauche
sur la vignette du masque
Fenêtres ancrables
Ouvrir et activer la fenêtre
Raccourci
Boîte à outils
Ctrl+B
Ctrl+G
Ctrl+L
Ctrl+Maj+B
Ctrl+Maj+P
Tabulation
Dégradés
Calques
Brosses
Motifs
Masquer les groupes de fenêtres
306
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Menu Filtres
Fonction
Raccourci
Répéter le dernier filtre (appliqué avec les
mêmes paramètres)
Ctrl+F
Réafficher le dernier filtre (ouvre la fenêtre
des paramètres)
Ctrl+Maj+F
Aide
Fonction
Raccourci
Aide (ouvre le manuel dans le navigateur
par défaut)
F1
Aide contextuelle (ouvre l’aide du prochain
objet pointé à la souris)
Maj+F1
À la molette de la souris
Si vous avez la chance de posséder une souris à deux molettes, n’hésitez
pas à utiliser l’axe horizontal.
Fonction
Raccourci
Sélectionner la police suivante/précédente
(outil de texte)
Ctrl+Alt+Maj+Haut/Bas
Sélectionner le dégradé suivant/précédent
(quel que soit l’outil)
Ctrl+Alt+Haut/Bas
Sélectionner le motif suivant/précédent
(quel que soit l’outil)
Alt+Maj+Haut/Bas
Sélectionner la brosse suivante/précédente
(quel que soit l’outil)
Ctrl+Maj+Haut/Bas
© Groupe Eyrolles, 2013
307
POCHE ACCÈS LIBRE – GIMP 2.8
Fonction
Raccourci
Déplacement de la vue d’un quart de fenêtre vers le haut/le bas de l’image (lorsque
l’image est plus grande que la fenêtre)
Haut/Bas
Déplacement de la vue d’un quart de fenêtre vers la gauche/la droite de l’image
Maj+Haut/Bas
Zoom avant/arrière
Ctrl+Haut/Bas
Aux flèches de direction
Fonction
Raccourci
Augmenter/Diminuer la première valeur de
l’outil de 10 unités
Alt+Haut/Bas
Augmenter/Diminuer la première valeur de
l’outil d’une unité
Alt+Gauche/Droite
Déplacement de la vue
Raccourci
Au bord haut/bas de l’image (lorsque l’image Ctrl+Haut/Bas
est plus grande que la fenêtre)
Au bord gauche/droit de l’image
D’un quart de fenêtre vers le haut/le bas de
l’image
Ctrl+Gauche/Droite
Maj+Haut/Bas
D’un quart de fenêtre vers la gauche/la droite Maj+Gauche/Droite
de l’image
Vers le haut/le bas de l’image (déplacement
fin)
Haut/Bas
Vers la gauche/la droite de l’image (déplacement fin)
Gauche/Droite
Les fonctions suivantes ne sont disponibles qu’après avoir activé l’un des
outils de sélection ou l’outil Déplacement (pas de manière temporaire).
308
© Groupe Eyrolles, 2013
A – Raccourcis clavier
Déplacement du calque, du chemin ou de Raccourci
la sélection
De 10 pixels d’écran vers le haut/le bas de
l’image
Maj+Haut/Bas
De 10 pixels d’écran vers la gauche/la droite
de l’image
Maj+Gauche/Droite
D’un pixel d’image vers le haut/le bas de
l’image (déplacement fin)
Haut/Bas
D’un pixel d’image vers la gauche/la droite de Gauche/Droite
l’image (déplacement fin)
© Groupe Eyrolles, 2013
309
annexe
D
© Groupe Eyrolles, 2013
Formats de fichiers
reconnus par Gimp
Gimp permet de gérer un grand nombre de formats d’images, aussi bien
en lecture (ouvrir un fichier) qu’en écriture (enregistrer). Dans la liste suivante, les formats marqués d’un (L) ne sont gérés qu’en lecture par Gimp,
tandis que ceux indiqués par un (E) ne concernent que l’écriture.
Les formats propres à Gimp
XCF
C’est le format natif de Gimp pour les images. Il permet de conserver
toutes les informations nécessaires au travail de l’image (hormis l’historique des modifications). Vous trouverez plus de précisions en fin de
chapitre 2.
Archives bzip et gzip
Elles correspondent au format XCF compressé par Gimp. Lorsqu’une image
est ainsi compressée (et non par une autre application), les gestionnaires
de fichiers peuvent quand même en afficher une vignette.
© Groupe Eyrolles, 2013
POCHE ACCÈS LIBRE – GIMP 2.8
XJT
Ce format compressé d’image est le pendant du XCF. Toutes les informations sont conservées. Cependant, chaque calque est compressé au format
JPEG, ce qui entraîne une dégradation. Si vous souhaitez des images occupant moins de place, essayez plutôt le XCF compressé.
Brosse Gimp
C’est le format pour les images dont la forme peut être utilisée par les
outils de peinture (voir chapitre 8). Signalons qu’il existe trois types de
brosses :
• les brosses classiques, créées à partir d’une seule image (extension .gbr
ou .gpb) ;
• les brosses animées, formées à partir de plusieurs calques (chaque calque contenant l’une des positions de l’animation, extension .gih) ;
• les brosses créées depuis l’éditeur de brosses de Gimp, portant l’extension *.vbr. Attention, ce format est géré uniquement par l’éditeur de
brosses.
Motif Gimp
Ce format s’applique aux images apparaissant dans la fenêtre Motifs, qui
sont utilisées par l’outil Remplissage (voir chapitre 8). Les fichiers portent
l’extension .pat.
Les formats vectoriels
N’étant pas un logiciel de dessin vectoriel, Gimp ne peut pas enregistrer
d’images vectorielles. Cependant, il est capable d’en comprendre certains
formats. Les images vectorielles sont converties en mode « points ». À
l’ouverture, Gimp vous demande les dimensions souhaitées pour votre
image. En effet, celle-ci n’est composée que de lignes et de courbes (donc,
334
© Groupe Eyrolles, 2013
D – Formats de fichiers reconnus par Gimp
d’équations mathématiques) ; elle n’a donc pas de dimensions et peut être
grossie à l’infini, au contraire d’une image faite de points.
SVG (L)
Ouvert et structuré (c’est un dérivé de XML), ce format est à privilégier
lorsque vous importez des images vectorielles. Gimp est même capable de
récupérer toutes les courbes dans des chemins. Une manière de manipuler
une image vectorielle avec Gimp !
À savoir Export en SVG
Gimp sait malgré tout exporter des chemins au format SVG. Depuis
la fenêtre des Chemins, faites un clic droit sur l’un des chemins, puis
sélectionnez Exporter le chemin. Vous pouvez alors exporter uniquement le chemin sélectionné ou tous les chemins. Le choix vous
est proposé en bas de la fenêtre d’export. Pensez à préciser vousmême l’extension .svg.
PDF
Format standard, universellement admis pour la diffusion de la documentation.
Outil Manipuler le format PDF
PdfTk est un ensemble d’outils permettant toutes sortes de manipulations sur vos fichiers PDF, dont la concaténation, la découpe en
fichiers d’une page, etc.
B http://www.accesspdf.com/pdftk/
PDFJam est un autre ensemble d’outils proposant des fonctionnalités parfois différentes. Ces deux kits sont complémentaires.
B http://www.warwick.ac.uk/go/pdfjam
PostScript et PostScript encapsulé
Ces deux formats, antérieurs au PDF, décrivent respectivement un document et une image en langage d’imprimante. Tout comme pour le PDF,
© Groupe Eyrolles, 2013
335
POCHE ACCÈS LIBRE – GIMP 2.8
Gimp est capable d’ouvrir des documents PostScript (extension .ps) de
plusieurs pages. À l’ouverture du fichier, vous choisissez lesquelles traiter
dans Gimp. Le PostScript encapsulé (.eps) implique que son contenu soit
une image. Lorsque Gimp enregistre une image dans l’un de ces deux formats, elle est inscrite en mode points et non vectoriel.
Microsoft Windows Meta File (L)
Format vectoriel de Microsoft, très répandu dans la suite Office. Très à la
mode, les « clip-arts » annihilent tout espoir de personnalité et d’originalité des documents qu’ils agrémentent.
Les formats points
Photoshop
Gimp lit et écrit le format de Photoshop (extension .psd).
Paint Shop Pro (L)
Gimp lit les fichiers produits par le logiciel de Jasc (extension .psp).
JPEG
Ce format compressé d’images en altère le contenu.
PNG
Format à compression non destructive.
336
© Groupe Eyrolles, 2013
D – Formats de fichiers reconnus par Gimp
GIF
Format d’image compressée, limitée à 256 couleurs ou aux niveaux de gris.
Il ne peut contenir qu’un seul niveau de transparence. Par ailleurs, il
s’applique aussi aux animations constituées de plusieurs images. Gimp
permet de les enregistrer : chacune des images est alors un calque, dont le
nom comporte la durée de chaque image (exprimée en millièmes de
secondes).
Art ASCII (E)
Gimp convertit les points de votre image en caractères, suivant leur intensité.
Tableau HTML (E)
Chaque point de l’image est converti en cellule d’un tableau HTML. Le
fichier engendré peut ensuite être visionné par votre navigateur. Attention,
les images volumineuses sont à proscrire.
Icônes Microsoft Windows
Ce format est utilisé principalement par les icônes sous Windows avec la
fameuse extension *.ico.
Pixmap X et Bitmap X
Ces deux formats sont très utilisés en environnement Unix, notamment
pour les icônes et les curseurs de souris. Directement intégrable dans un
programme en C, les pixmaps (extension .xpm) peuvent contenir jusqu’à
16 millions de couleurs, alors que les bitmaps (extension .xbm) n’en ont
que deux (littéralement, bitmap signifie « carte de bits », donc de valeurs
binaires).
© Groupe Eyrolles, 2013
337
POCHE ACCÈS LIBRE – GIMP 2.8
Tiff
Le Tiff est un conteneur plus qu’un format. À noter qu’il peut contenir des
chemins réalisés dans Gimp et utilisables dans Scribus, telle la forme de
contour pour l’habillage.
Windows BMP
Ce format d’image assez basique produit des fichiers lourds, même en utilisant la compression RLE (Run-Length Encoding). Mais le contenu n’est pas
dégradé. On le rencontre très rarement sur le Web, même si les navigateurs
sont capables de l’afficher.
338
© Groupe Eyrolles, 2013
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising