Granix 5.0 - Fisher UK Extranet

Granix 5.0 - Fisher UK Extranet
Manuel d’utilisation de
Granix
Granulométrie par analyse d’images
6e édition
Granix 5.0
novembre 2002
Sommaire
1. Vue d’ensemble de Granix
Principes et méthodes
Démarrage de Granix
La feuille de travail de Granix
Les menus
La barre d’outils
Les onglets, les pages et les documents
La barre d’état
Déroulement d’une session de travail
Préparation de l’appareil
Préparation de l’étude
L’analyse de l’échantillon
Exploitation des résultats
5
5
7
7
8
9
9
10
11
11
11
11
11
Protection des réglages
12
2. Préparation de l’appareil
13
Acquisition de l’image
Accès au contrôleur de platines
Étalonnage du système
Réglages du traitement d’image
Réglage de l’autofocus
3. Préparation de l’étude
Début de l’étude
Définition de l’exploration
Enregistrement d’une étude
Modèles et fichiers enregistrés
4. Mesure de l’échantillon
Mesure d’un champ
Mesure automatique de l’échantillon avec une platine motorisée
Contrôle des résultats
Options de présentation
5. Historique et cartographie
Exportation
6. Exploitation des résultats
Calcul de la granulométrie
Granix - manuel d’utilisation
13
13
14
14
15
16
16
17
18
18
20
20
21
21
21
23
24
25
26
page 3 / 34
Sommaire
Choix de la granulométrie
Classes de diamètre
Définition de valeurs normalisées
Critères de restriction
26
27
27
28
Options d’affichage de la courbe
Options de présentation des tableaux
Exportation
28
28
28
7. Mise en page et impression du rapport
30
8. Modes de fonctionnement sécurisés
33
Granix - manuel d’utilisation
page 4 / 34
1. Vue d’ensemble de Granix
Granix a été conçu pour être un outil de mesure puissant et complet, mais simple et rapide à
mettre en œuvre. Dans un environnement graphique convivial, il propose de riches fonctionnalités
de traitement d’image, et surtout une mesure de la granulométrie exceptionnellement rapide.
Granix prévoit l’accumulation d’un nombre illimité de champs d’analyse. Il permet de mesurer,
selon la norme NF X 11-696, la répartition des diamètres de particules les plus diverses : granulés,
poudres, sable, polymères, etc. La granulométrie est ensuite représentée graphiquement selon les
recommandations de la norme NF X 11-632. Les classes de valeurs peuvent être choisies selon
les normes ISO 565, NF X 11-501, ASTM E11, DIN 4188, BS410, GOST 3584, UNI 2331, JIS
Z8801.
Tout est mis en œuvre pour que l’utilisateur puisse exploiter les résultats fournis par Granix de la
façon la plus souple possible : une session de travail peut être enregistrée, et reprise
ultérieurement. Les graphiques et statistiques peuvent être exportés vers les logiciels de calculs
usuels, simplement par “copier / coller”. Enfin, images, représentations graphiques, liste des
valeurs et statistiques sont éditées sur imprimante.
Principes et méthodes
Bien que la compréhension des principes mis en œuvre ne soit pas indispensable pour utiliser
Granix, elle permet de cerner l’influence des quelques réglages ou des conditions expérimentales,
donc de mieux interpréter les résultats des analyses. On peut distinguer les quatre étapes
suivantes :
•
l’acquisition de l’image de l’échantillon
•
le traitement de cette image
•
la mesure proprement dite
Granix - manuel d’utilisation
page 5 / 34
•
l’expression des résultats
L’image de l’échantillon est transmise au système par une caméra vidéo, placée sur un dispositif
optique. La grande variété des systèmes optiques utilisables explique que l’on puisse aussi bien
mesurer des granulés de quelques millimètres que des micro-poudres composées de particules
inférieures au micron.
L’image obtenue ne contient aucune information physique : les particules seront identifiées par
leurs caractéristiques optiques, c’est-à-dire le plus souvent par leur teinte de gris. On pourra
mesurer de façon très fiable des granulés blancs placés sur un fond sombre, ou une poudre
éclairée par transmission, qui apparaît noire sur un fond clair. Certains cas plus difficiles peuvent
demander un soin accru lors de la mesure (particules de teintes hétérogènes) ou de l’interprétation
des résultats (amas).
On regroupe sous le nom d’acquisition le processus qui aboutit à l’apparition d’une image à
l’écran du micro-ordinateur, ainsi qu’un certain nombre de traitements dont le but est d’améliorer
la qualité de cette image.
Le traitement consiste à extraire de cette image l’ensemble des points qui définissent la phase à
mesurer. L’image est “seuillée”, c’est-à-dire que chaque point de l’image est affecté soit à
l’ensemble “particules”, soit à l’ensemble “fond”, en fonction de sa teinte de gris. Si l’ensemble
obtenu est imparfait, on lui fait subir un “filtrage”, dont le but est de le schématiser légèrement.
Ces opérations sont quasiment instantanées, et, une fois réglées, sont réalisées automatiquement
par Granix.
La norme NF X 11-696 présente plusieurs méthodes de mesure. Granix propose celle appelée
“Granulométrie par ouvertures”, dont le grand intérêt est de ne faire aucune hypothèse quant à la
forme des particules, ni même d’exiger l’individualisation de ces particules. La méthode s’applique
également à des phases non granulaires, bien qu’il soit alors difficile d’interpréter les résultats en
termes de diamètres.
Par son principe, la granulométrie par ouverture est tout à fait comparable au tamisage / pesage,
si l’on prend soin de souligner les deux différences suivantes :
•
Le tamisage mesure la plus grande dimension des grains, alors que la granulométrie par
ouverture mesure la plus petite.
•
Le tamisage est suivi d’une quantification en masse, alors que la granulométrie par ouverture
quantifie en phase. En admettant les grains sphériques, on peut déduire une quantification en
volume très corrélée avec celle fournie par le tamisage.
A l’issue de la mesure, Granix possède la phase présente dans des classes de diamètre très fines :
la largeur d’une classe est égale à la taille de 2 points élémentaires de l’écran. La seule
connaissance de la taille d’un pixel en unité réelle suffit pour exprimer la granulométrie sous la
forme d’un histogramme, d’un passant ou d’un refus cumulé.
De ces résultats peuvent être déduites de nombreuses valeurs statistiques qui caractérisent
l’échantillon étudié. De plus, la finesse de l’histogramme autorise le regroupement des classes
selon des tamis normalisés.
Pour plus d’information sur les principes mis en œuvre, on pourra consulter la norme “Granulométrie par analyse d’images” (NF X 11-696).
Granix - manuel d’utilisation
page 6 / 34
Démarrage de Granix
Un raccourci vers Granix est normalement accessible dans le groupe de programmes
“Microvision Instruments”, situé dans le menu “Programmes” du menu “Démarrer” de
Windows.
La feuille de travail de Granix
La feuille de travail est la fenêtre affichée lors du démarrage de Granix. On y trouve les éléments
standard de l’environnement Windows : la barre de titre (1) qui inclut la case de menu système (à
gauche), et les cases d’agrandissement et de réduction de la fenêtre (à droite); la barre de menus
(2) donne accès à toutes les fonctions du logiciel. Lorsque la feuille n’occupe pas tout l’écran, elle
peut être déplacée (en cliquant dans la barre de titre), ou déformée (en cliquant dans son cadre).
1
2
3
4
5
6
7
8
La feuiile de travail de Granix
La barre d’outils (3) contient quelques boutons pour accéder rapidement aux fonctions les plus
utilisées du logiciel.
A gauche de la feuille, des onglets (4) permettent d’afficher soit l’image vidéo, soit différents
Granix - manuel d’utilisation
page 7 / 34
documents représentatifs du travail en cours : un historique ou une cartographie des champs
mesurés, une représentation graphique et des tableaux statistiques, le rapport imprimé.
L’image vidéo ou le document occupent la plus grande partie de la feuille (5). Ils sont entourés de
règles (6), graduées en unités réelles, et de barres de défilement (7), actives lorsque le document
ou l’image sont plus grands que la fenêtre.
Dans le bas de la feuille de travail, la barre d’état (8) contient des informations relatives au
travail en cours.
Les menus
Ils donnent accès à toutes les fonctions de Granix. En voici un bref aperçu :
•
le menu ‘Fichier’ est consacré aux études : début d’une étude, enregistrement et réouverture
de l’étude; impression des résultats. Il permet également d’archiver, de charger ou d’imprimer
des images.
•
le menu “Edition” propose les fonctions classiques de “copier / coller”, qui permettent
d’échanger des images ou des documents entre plusieurs logiciels. On y trouve également
l’annulation d’une action, et l’accès au module d’annotation des images.
•
le menu ‘Image’ est consacré à la gestion de la vidéo : choix des sources, acquisition et
amélioration des images.
•
le menu “Mesure” regroupe les fonctions utilisées pendant une étude : étalonnage du système,
définition des caractéristiques de l’étude, réglages de l’analyse, prise des mesures.
•
le menu ‘Résultats’ permet de définir les méthodes de calcul des statistiques et de
représentation des résultats. On y trouve également des articles permettant d’afficher ces
documents dans des fenêtres toujours visibles.
•
le menu “Présentation” contient diverses options plus générales : personnalisation de
l’environnement et options de tracés des mesures.
•
menu ‘?’ : informations sur le logiciel Granix, et modes de fonctionnement sécurisés.
Granix - manuel d’utilisation
page 8 / 34
La barre d’outils
La barre d’outils offre un accès rapide à certaines fonctions et informations utilisées
fréquemment :
1
2
3
4
5
La barre d’outils de Granix
1. Fonctions vidéo d’usage courant (de gauche à droite) : ‘Acquisition’, ‘Figer l’image’,
‘Contraste automatique’.
2. Activation / désactivation du suivi des positions, lorsque le système est équipé d’une platine de
déplacement indexée ou motorisée.
3. Analyse du champ affiché, et déplacement entre les champs de mesure.
Avec un système manuel, sont actifs le bouton d’analyse et les boutons de déplacement entre
les champs, qui permettent d’afficher les mesures déjà effectuées.
Avec une platine de déplacement indexée, seul le bouton d’analyse est actif : les changements
de champ se font en déplaçant la platine.
Avec une platine motorisée, tous les boutons sont actifs. Les boutons de déplacement pilotent
la platine. Le bouton de gauche permet de définir une position initiale, pour effectuer ensuite
une analyse automatique de l’échantillon (bouton de droite)
4. Réglage des propriétés des documents affichés : définition des calculs de granulométrie,
mesures affichées dans les tableaux, mise en page du rapport.
5. Affichage ou masquage des différents documents créés par Granix (de gauche à droite) :
caractéristiques de l’étude, conditions expérimentales, vue d’ensemble, distribution
granulométrique, table des valeurs, statistiques.
Selon la page actuellement à l’écran, le document est affiché dans la page, dans une palette
distincte ou dans le rapport imprimé.
Les onglets, les pages et les documents
Les onglets situés à gauche de la fenêtre permettent d’afficher quatre pages représentatives de
l’étude en cours :
•
L’image vidéo temps réel est bien sûr la page la plus importante, qui permet d’observer
l’échantillon et d’y effectuer les mesures.
L’image vidéo et les tracés éventuellement superposés peuvent être enregistrés et imprimés,
Granix - manuel d’utilisation
page 9 / 34
par les options correspondantes du menu “Fichier”. Une partie de l’image peut être encadrée,
puis, par l’option “Copier” du menu “Edition”, transférée vers un autre logiciel.
•
La page “Exploration” présente un historique des champs mesurés : tous les objets tracés
sont représentés, superposés à l’image présente sous la caméra au moment de la mesure.
Lorsque le système est équipé d’une platine de déplacement indexée ou motorisée, l’historique
est remplacé par une cartographie de l’échantillon, dans laquelle les images et les mesures sont
tracées à leur position réelle.
La vue d’ensemble (historique ou cartographie) peut également être affichée dans une fenêtre
distincte, et incluse dans le rapport imprimé. Une partie de la vue d’ensemble peut être
encadrée, copiée, puis transférée vers un autre logiciel.
•
La page “Résultats” permet d’afficher trois documents distincts : la courbe représentative de
la granulométrie, les valeurs numériques de la distribution, des valeurs statistiques.
Ces trois documents peuvent être individuellement affichés dans une fenêtre distincte, inclus
dans le rapport, ou copiés vers un logiciel extérieur.
•
Le “Rapport” est une reproduction fidèle du document susceptible d’être imprimé. Il suit en
permanence les évolutions du travail en cours.
La mise en page du rapport est personnalisable : taille et contenu de l’en-tête et du pied de
page, intitulé et ordre des documents imprimés.
La barre d’état
La barre d’état est située tout en bas de la feuille. Elle regroupe quelques informations concernant
le travail en cours :
1
2
3
4
5
6
7
8
La barre d’état de Granix
1. Date du système.
2. Heure du système.
3. Grandissement dans lequel est affiché l’image vidéo ou la vue d’ensemble.
4. Nom de l’étalonnage actuellement appliqué.
5. Nom du fichier image éventuellement chargé.
6. Référence du produit analysé (ou nom du fichier “étude”, dans lequel sont enregistrées les
mesures)
7. Position du réticule, lorsque l’on clique dans une des règles graduées. Lorsque l’on utilise l’outil
Granix - manuel d’utilisation
page 10 / 34
d’encadrement, la taille de la zone sélectionnée est affichée ici.
8. Indicateur d’occupation de la mémoire du micro-ordinateur.
Déroulement d’une session de travail
Préparation de l’appareil
Lors de cette étape, on règle essentiellement :
•
l’acquisition de l’image vidéo et son cadrage : en s’aidant des options du menu “Image”, on
cherche à obtenir l’image à l’écran, dans laquelle les particules sont suffisamment contrastées.
•
l’étalonnage du système, opération qui consiste à établir l’équivalence entre une distance réelle
et sa longueur apparente à l’écran.
•
l’acquisition des particules : on regroupe sous ce nom les traitements d’image qui conduiront
l’appareil à détecter les objets dans l’image vidéo. Les traitements programmés sont résumés
dans une palette, que l’on affiche par le menu “Mesure”.
La préparation de l’appareil est présentée au chapitre 2. De nombreux aspects sont détaillés dans
le manuel de référence (l’acquisition vidéo au chapitre 4, l’étalonnage au chapitre 5, les
traitements au chapitre 6).
Préparation de l’étude
La préparation de l’étude consiste à indiquer au logiciel quelques caractéristiques de l’échantillon à
analyser, et, si le système est équipé d’une platine motorisée, la forme et la taille de la zone à
explorer.
Ces opérations sont décrites au chapitre 3.
L’analyse de l’échantillon
L’analyse peut être entièremement automatique, si le système est équipé d’une platine motorisée,
ou semi-automatique, dans le cas contraire. Plusieurs options permettent de surveiller le bon
déroulement de l’analyse, et déterminer le nombre de champs à mesurer. Ces options sont
décrites au chapitre 4.
Granix génère un historique des mesures, ou une cartographie de l’échantillon, décrits au
chapitre 5.
Exploitation des résultats
Cette étape finale consiste à définir la présentation des résultats, ainsi que la mise en page du
rapport de mesure.
Ces fonctions sont décrites aux chapitres 6 et 7.
Granix - manuel d’utilisation
page 11 / 34
Protection des réglages
Les réglages effectués lors des deux premières étapes sont fondamentaux, et déterminent la
validité des résultats des mesures. Il est possible d’interdire la modification de ces réglages, en
plaçant le logiciel dans un mode de fonctionnement sécurisé.
Les modes sécurisés sont décrits au chapitre 8.
Granix - manuel d’utilisation
page 12 / 34
2. Préparation de l’appareil
Acquisition de l’image
Les techniques d’acquisition des images vidéo sont décrites en détail dans le manuel de réference.
Les principales fonctions sont symbolisées par des boutons dans la barre d’outils :
Avec ce bouton, ou par l’option ‘Nouvelle image’ du menu ‘Image’, l’image est affichée
en temps réel.
Ce bouton applique une amélioration automatique du contraste de l’image. Un réglage
manuel doit être fait périodiquement, en agissant également sur le diaphragme de
l’objectif de la caméra : on y accède soit par l’option ‘Echelle de gris…’ du menu ‘Image’,
soit en cliquant sur ce bouton tout en maintenant la touche <Ctrl> enfoncée.
Il peut être utile de figer l’image par ce bouton, ou par l’option ‘Figer l’image’ : cela évite le
scintillement de l’image, notamment lorsque l’on utilise le zoom.
Accès au contrôleur de platines
Si une platine de déplacement indexée ou motorisée est installée, elle est contrôlée par un logiciel
indépendant. Les réglages nécessaires ont été effectués en atelier, ou lors de la mise en service de
l’apppareil.
Ce logiciel peut être affiché, via l’article “Afficher le contrôleur de platines” du menu “?” : le bouton
strié, en bas et à droite du panneau, donne accès à son menu, et aux réglages matériels; le
bouton rouge, en bas à gauche, ferme le panneau, inutile lors de l’utilisation normale de Granix.
Granix - manuel d’utilisation
page 13 / 34
Étalonnage du système
Une fois le cadrage effectué, les conditions optiques ne doivent plus être modifiées. Il reste à
indiquer au système la correspondance entre l’image vidéo et les distances réelles : c’est
l’étalonnage. Cette étape fondamentale conditionne la validité des mesures qui vont être prises.
Si toutes les études sont effectuées au même grandissement, on peut se contenter de vérifier
l’étalonnage visuellement, en observant une règle ou un micromètre, et en vérifiant que ses
graduations coïncident avec celles tracées à l’écran, autour de l’image.
Si l’on change parfois de grandissement, mais que l’on dispose d’un objectif avec un zoom à
encliquetage, il est possible de définir plusieurs étalonnages correspondant à ces positions. Ces
étalonnages sont présentés dans le sous-menu “Étalonnage” du menu “Mesure”.
Pour établir ces étalonnages, on utilise l’article “Définir”, au bas du sous-menu “Étalonnage” du
menu “Mesure”. La procédure est décrite en détail au chapitre 5 du manuel de référence.
Réglages du traitement d’image
Des réglages essentiels pour la fiabilité des résultats doivent être effectués avant de commencer
l’étude. Ils sont accessibles par l’article “Afficher les réglages” du menu “Mesure”. Une petite
fenêtre apparaît, présentant les étapes du traitement d’images. Les deux principales sont les
suivantes :
•
Le seuillage détermine les limites des particules mesurées, en fonction de leurs teintes. Pour
régler ces limites, on observe l’échantillon dans les conditions qui seront celles de la mesure.
C’est la seule étape indispensable.
•
Le filtrage est une opération fréquemment réalisée, mais facultative, qui consiste à modifier
l’image issue du seuillage pour corriger des éventuels défauts : petits trous, ou petits artefacts.
Résumé des réglages effectués
Bien que cela ne soit pas recommandé, ces réglages peuvent être modifiés en cours d’analyse. Ils
sont décrits en détail dans le chapitre 6 du manuel de référence.
Granix - manuel d’utilisation
page 14 / 34
Réglage de l’autofocus
Si les observations sont effectuées avec un microscope, et que celui-ci est équipé d’un axe de mise
au point motorisé (système motorisé trois axes), il est possible d’effectuer la focalisation
automatiquement pendant les analyses.
Cette opération nécessite un réglage, qui dépend de l’objectif choisi. L’article “Réglage de
l’autofocus…” est proposé dans le menu “Mesure”. Il affiche la boîte de dialogue ci-dessous :
Réglage de l’autofocus
Pour régler l’autofocus :
•
entrer dans la seconde zone de texte une distance de l’ordre de grandeur de la profondeur de
champ de l’objectif utilisé : elle définit le pas de l’analyse.
•
cliquer le bouton “Essai” : le système déplace l’axe de mise au point, et effectue une mesure à
chaque étape. Une courbe est tracée (en rouge), et le système se place à la position
correspondant au maximum de cette courbe.
•
si la courbe est large et aplatie, la position correcte risque d’être hors de la zone analysée :
augmenter le pas de l’analyse.
•
si la courbe est trop étroite, le système risque de rater la position correcte : diminuer le pas de
l’analyse.
Granix - manuel d’utilisation
page 15 / 34
3. Préparation de l’étude
Début de l’étude
Une étude se débute à l’aide de l’article ‘Nouvelle étude…” du menu ‘Fichier’. La boîte de dialogue
qui apparaît permet de saisir quelques informations :
Lorsque le système est équipé d’une platine de déplacement indexée ou motorisée, plusieurs
méthodes d’analyse de l’échantillon sont proposées.
En bas de la fenêtre, la case “conserver les images mesurées” permet d’associer l’image des
champs aux mesures effectuées. Ces images sont notamment affichées dans la vue d’ensemble.
Elles sont intégrées au fichier de l’étude.
Granix - manuel d’utilisation
page 16 / 34
Définition de l’exploration
Lorsque le système est équipé d’une platine motorisée, l’analyse de l’échantillon est entièrement
automatique. Il faut alors définir la forme et la taille de cet échantillon.
On utilise pour cela le cadre supérieur de la boîte de dialogue ci-dessous (article “Définir
l’exploration…” du menu “Mesure”) :
La zone ainsi définie peut être explorée de plusieurs façons différentes, grâce aux options des
deux autres cadres. On peut par exemple définir une exploration exhaustive de l’échantillon
(cocher les cases “Inclure les champs périphériques” et “Champs jointifs”), ou bien préférer une
analyse plus rapide (en définissant des champs disjoints, ou en laissant le système choisir des
champs de façon aléatoire).
Granix - manuel d’utilisation
page 17 / 34
la zone à analyser est représentée dans la page “Exploration”.
On peut ajuster sa taille et sa position avec la souris
Enregistrement d’une étude
Durant la prise des mesures, il est recommandé de procéder à l’enregistrement régulier des
valeurs mesurées. On utilise pour cela l’article “Enregistrer l’étude” du menu “Fichier”.
La première fois, cet article provoque l’affichage de la boîte de dialogue standard de Windows,
dans laquelle on indique un répertoire et un nom du fichier qui identifie l’étude (le suffixe “.gx” y
est automatiquement ajouté). Ce nom apparaît ensuite dans la barre d’état de Granix.
Lors des enregistrements suivants, le même fichier est utilisé, à moins que l’on en change
explicitement par l’article “Enregistrer sous…”.
Modèles et fichiers enregistrés
Il peut être utile de définir des modèles d’études, conservant notamment les réglages effectués.
Pour ce faire, on enregistre les informations préparées dans un fichier, grâce à l’article “Enregistrer
l’étude”.
Pour exploiter ce modèle :
•
ouvrir le fichier avec l’article “Ouvrir une étude…” (menu “Fichier”) : ceci restaure les réglages
effectués.
Granix - manuel d’utilisation
page 18 / 34
•
Saisir les caractéristiques propres à la nouvelle étude avec l’article correspondant du menu
“Mesure”.
•
Définir un nouveau fichier avec l’article “Enregistrer l’étude sous…” du menu “Fichier”.
Remarque : les fichiers modèles peuvent être protégés de tout remplacement accidentel : avec
l’explorateur de Windows, afficher les propriétés du fichier, et cocher la case “Lecture seule”.
Granix - manuel d’utilisation
page 19 / 34
4. Mesure de l’échantillon
Mesure d’un champ
L’analyse d’un échantillon consiste à mesurer un nombre de champs suffisamment important
pour que les résultats soit significatifs. La mesure d’un champ est très simple :
Dans un premier temps, on cadre le champ à analyser.
Dans un second temps, on déclenche la mesure, soit par l’article “Mesurer le champ” du
menu “Mesure”, soit en pressant la touche <F5>, soit en cliquant sur le bouton de la barre
d’outils. La boite de dialogue suivante apparaît :
La mesure prend quelques instants, sa durée exacte dépendant de la méthode d’analyse,
de la taille et du nombre de particules dans le champ.
Pour préparer le champ suivant, on utilise soit l’article du même nom du menu “Mesure”,
soit la touche <F3>, soit ce bouton de la barre d’outils.
Une bonne habitude de travail est d’enregistrer régulièrement les mesures effectuées, à l’aide de
l’article ‘Enregistrer’ du menu ‘Fichier’.
Granix - manuel d’utilisation
page 20 / 34
Mesure automatique de l’échantillon avec une platine motorisée
Déplacer l’échantillon vers le coin supérieur gauche du rectangle à analyser (ou le sommet
du cercle), et presser ce bouton : il définit la position du premier champ de l’exploration.
Cliquer ce bouton : l’exploration automatique commence.
Contrôle des résultats
A la fin de l’analyse d’un champ, les particules mesurées sont entourées de bleu.
L’article “Résultat de la mesure” du menu “Résultats” provoque l’affichage d’une petite palette
qui présente de façon synthétique l’histogramme mesuré sur le champ, ainsi que l’histogramme
cumulé sur l’ensemble de l’étude.
Dans le premier cas, la barre située sous l’histogramme permet de superposer à l’image les
contours des particules incluses dans une plage de taille.
Si les mesures ne sont pas satisfaisantes, le dernier champ peut être annulé (article ‘Annuler le
champ’ du menu ‘Edition’). Le cas se présente notamment après un mauvais cadrage, ou
lorsqu’une variation d’éclairage est intervenue, induisant un mauvais seuillage.
Les boutons fléchés de la barre d’outils permettent de se déplacer vers des champs mesurés
précédemment, pour vérifier la validité des mesures effectuées.
Options de présentation
L’article “Options des tracés…” du menu “Présentation” permet de changer la couleur qui délimite
les particules mesurées, et propose également le choix d’un motif de remplissage. L’emploi de
l’option “Tracés épais” n’est pas recommandée dans le cas de particules nombreuses ou
complexes, à moins de disposer d’un ordinateur rapide.
Granix - manuel d’utilisation
page 21 / 34
Granix - manuel d’utilisation
page 22 / 34
5. Historique et cartographie
La page “Exploration” présente un historique de tous les champs mesurés, représentés en
réduction. Le contour des particules mesurées est superposé à l’image qui était présente sous la
caméra au moment de la mesure, si la case “conserver les images mesurées” a été cochée lors de
la définition de l’étude.
Lorsque le système est équipé d’une platine qui transmet sa position au micro-ordinateur (platine
Granix - manuel d’utilisation
page 23 / 34
motorisée ou indexée), l’historique est remplacé par une cartographie de l’échantillon :
Le champ encadré est le champ “actif”, dont les données sont également affichées dans la page
“Vidéo”. Pour changer de champ actif, utiliser les options “Champ précédent” et “Champ
suivant” du menu “Mesure”, ou les boutons correspondant de la barre d’outils, ou cliquer sur le
champ désiré tout en pressant simultanément les touches <Majusc> et <Ctrl> du clavier.
La vue d’ensemble peut être affichée dans une fenêtre distincte, et ainsi rester visible même
lorsque l’on travaille sur les autres pages de Granix : on utilise pour cela l’option “Afficher dans
une fenêtre” du menu “Résultats”, ou son raccourci clavier, la touche <F12>.
Ce bouton de la barre d’outil symbolise la vue d’ensemble : il provoque son affichage
dans une fenêtre, comme la fonction précédente, sauf dans la page “Rapport” : il sert
alors à inclure la vue d’ensemble au rapport imprimé.
Exportation
•
Transformation de la vue d’ensemble en une image unique : activer l’outil “Encadrer” du
menu “Édition”, puis encadrer la zone voulue. L’option “Copier” permet de transférer la partie
encadrée vers un autre logiciel.
•
Enregistrement individuel des images mesurées : dans le menu “Fichier”, utiliser l’option
“Exporter”, puis le sous-menu “Images mesurées”.
Granix - manuel d’utilisation
page 24 / 34
6. Exploitation des résultats
La page “Résultats” présente trois documents :
•
La représentation graphique de la distribution granulométrique
•
Les valeurs numériques de cette distribution
•
Les valeurs statistiques caractéristiques.
Granix - manuel d’utilisation
page 25 / 34
La présence de ces trois éléments est facultative, et se choisit avec ces boutons de la
barre d’outils (ou les options correspondantes du menu “Résultats”).
Lorsque la page “Rapport” est affichée, ces mêmes boutons sont utilisés pour inclure ou
non les documents dans le rapport imprimé. Avec les autres pages, ils permettent
d’ouvrir des fenêtres distinctes. On peut ainsi effectuer les mesures dans la page vidéo,
tout en surveillant l’évolution de la courbe.
Calcul de la granulométrie
Granix propose de nombreuses méthodes de calcul, qui se définissent avec l’article “Propriétés de
la granulométrie…” du menu “Résultats”.
Les courbes et valeurs calculées dépendent fortement des méthodes choisies, qui sont présentées
ci-dessous.
Choix de la granulométrie
Granix quantifie les particules présentes dans chaque classe de diamètre par leur surface. C’est
pourquoi l’axe vertical du graphique utilise normalement cette grandeur.
En effectuant des hypothèses quant à la forme des grains, il est cependant possible d’exprimer la
granulométrie de la population (l’axe vertical du graphique) avec une grandeur différente de celle
de la mesure : en nombre, ou en volume.
La représentation en nombre fournit des résultats plus facilement interprétables par un être
humain. La représentation en volume fournit une granulométrie très corrélée avec celle obtenue
par la méthode du tamisage physique, car le poids de la matière est proportionnel à son volume.
Chaque méthode donne des valeurs d’histogramme, de passant et de refus différents. Ceci est
vrai aussi pour les valeurs statistiques. Il convient donc de la choisir judicieusement. On indique le
choix effectué avec le menu local “Quantification”, dans le premier cadre de la boîte de dialogue.
Granix - manuel d’utilisation
page 26 / 34
La valeur maximale que l’on peut indiquer dans le même cadre est appliquée à l’axe vertical du
graphique : elle n’a aucune influence sur les calculs effectués.
Classes de diamètre
Le second cadre de la boîte de dialogue permet de définir les classes de diamètres utilisées pour
l’histogramme. Trois possibilités sont offertes :
•
Représentation avec les classes de diamètres utilisées pour la mesure : cette option donne les
classes les plus fines possibles, mais elles coïncident rarement avec des valeurs usuelles.
•
Représentation avec des classes équidistantes : on définit uniquement la largeur de ces classes.
•
Représentation avec des classes normalisées, qui permet de fournir des résultats conformes à
des standard nationaux ou internationaux : un menu local permet de définir la liste des valeurs
(voir ci-dessous)
Le choix des classes de diamètre influence bien sûr la représentation graphique et le tableau des
valeurs, mais il n’a aucun effet sur les calculs statistiques, qui sont toujours effectués avec les
classes les plus fines.
La valeur maximale que l’on peut indiquer est appliquée à l’axe horizontal du graphique : elle n’a
aucune influence sur les calculs effectués.
Définition de valeurs normalisées
Le menu local permet de définir plusieurs séries de valeurs, correspondant par exemple à plusieurs
type de produits contrôlés. il permet également d’accéder à la boîte de dialogue grâce à laquelle on
définit une telle série :
La liste de gauche inclut les dimensions nominales des ouvertures de mailles de tamis de contrôle.
Cette liste est conforme à une norme nationale ou internationale, que l’on choisit avec le menu
local situé au dessus : ISO 565 (internationale), NF X 11-501(France), ASTM E11 (États-Unis),
DIN 4188 (Allemagne), BS410 (Royaume-Uni), GOST 3584 (Russie), UNI 2331 (Italie), JIS
Z8801 (Japon).
La liste de droite contient les valeurs choisies, qui seront appliquées à la représentation graphique.
La zone de texte située au dessus permet d’identifier la série par un nom : le nom du produit
Granix - manuel d’utilisation
page 27 / 34
auquel elle est destinée, par exemple.
Critères de restriction
La fenêtre “Propriétés du graphique…” permet de limiter la plage des mesures à prendre en
compte en fixant des critères de taille minimum et de taille maximum. Tous les résultats sont
recalculés pour tenir compte de ces limites, notamment les statistiques.
Options d’affichage de la courbe
Les options d’affichage de la courbe sont présentées à droite de celle-ci. Selon les cases
cochées, le graphique peut représenter simultanément :
- l’histogramme de répartition des particules par classes de diamètre,
- le passant cumulé,
- le refus cumulé,
- la loi normale de même moyenne et même écart-type,
- les limites de séparations correspondant aux valeurs présentées dans les statistiques,
- un quadrillage.
La dernière option permet de tracer les courbes avec un trait plus épais.
Options de présentation des tableaux
Les valeurs correspondant à l’histogramme de répartition, au passant cumulé et au refus cumulé
peuvent être incluses dans le tableau des valeurs associées. On utilise pour cela l’article “Propriétés
des tableaux…” du menu “Résultats”, et la boîte de dialogue ci-dessous :
Cette même boîte de dialogue permet de choisir la précision d’affichage des valeurs dans les
tableaux.
Exportation
Granix - manuel d’utilisation
page 28 / 34
Les trois documents peuvent être exportés vers un autre logiciel, en utilisant le presse-papiers :
cliquer sur la barre de titre de la courbe ou du tableau. Lorsque le cadre est coloré, sélectionner
l’option “Copier” du menu “Édition”. Activer le logiciel de destination, et coller à l’emplacement
voulu.
Granix - manuel d’utilisation
page 29 / 34
7. Mise en page et impression du rapport
La page “Rapport” présente le rapport de mesures exactement tel qu’il va être imprimé :
La mise en page de ce document est entièrement personnalisable : taille et contenu de l’en-tête et
du pied de page, ordre et intitulé des documents imprimés. On utilise pour cela l’article “Propriétés
du rapport…”, proposé par le menu “Résultats”.
Granix - manuel d’utilisation
page 30 / 34
Trois types d’en-tête sont proposés :
•
une en-tête standard, sans réglage, qui inclut automatiquement le nom du logiciel, suivi de la
référence de l’étude.
•
une en-tête personnalisée, dont on peut définir la hauteur, le titre et un logo, que l’on aura
préalablement placé dans le presse-papier.
•
une en-tête vide, pour imprimer le rapport sur du papier pré-imprimé. On ne règle alors que la
hauteur de l’espace à laisser libre.
Le pied de page peut inclure la référence du logiciel et une numérotation de page, ou laisser vide
une hauteur donnée, pour utiliser du papier pré-imprimé.
Définition de l’en-tête et du pied de page
Le second onglet sert à définir le contenu du rapport. La liste présentée permet de choisir les
documents à inclure au rapport, d’en fixer l’ordre et le titre :
Choix des documents imprimés
Granix - manuel d’utilisation
page 31 / 34
Ces boutons de la barre d’outils permettent d’inclure rapidement les documents correspondants
dans le rapport, sans ouvrir la boîte de dialogue :
Granix - manuel d’utilisation
page 32 / 34
8. Modes de fonctionnement sécurisés
Dans le cadre d’une utilisation de Granix en routine, il peut être intéressant de figer les réglages
effectués, pour éviter toute modification accidentelle. Granix prévoit les trois modes de
fonctionnement suivants :
•
le mode “Administration” est le mode de travail normal, dans lequel toutes les fonctions du
logiciel sont accessibles.
•
le mode “Opération” est un mode sécurisé, dans lequel toutes les opérations de routines sont
possibles. Par contre, les réglages ne sont plus accessibles : ils restent identiques à ceux
effectués en mode “Administration”.
•
le mode “Supervision” est un mode sécurisé, dans lequel les réglages restent accessibles, mais
sont consignés dans un fichier journal. Les accès aux fichiers sont restreints, et également
consignés dans le fichier journal. Ce mode est défini par un composant logiciel distinct, vendu
séparément.
Les modes de fonctionnement, présentés dans le menu “?”
L’article “Paramètres de sécurité…” permet à l’administrateur de définir le mode de démarrage du
logiciel, et de protéger ce choix par un mot de passe.
Granix - manuel d’utilisation
page 33 / 34
Granix - manuel d’utilisation
page 34 / 34
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising