Manuel d`utilisation Phonedit Signaix

Manuel d`utilisation Phonedit Signaix
Version 4.1.0.
07/05/2014
Manuel d’utilisation
Phonedit Signaix
AG, TW
LPL
ManuelPhonedit2014-05-07.docx
Manuel d’utilisation Phonedit Signaix
Auteurs
PHONEDIT SIGNAIX est un logiciel développé par le Laboratoire Parole et Langage, UMR 7309
CNRS-Université d’Aix-Marseille, Aix-en-Provence, France.
Conditions d’utilisation
PHONEDIT SIGNAIX est distribué gratuitement sous réserve d’acceptation de la licence d’utilisation
ci-après.
PHONEDIT SIGNAIX ® Copyright © 2014 by LPL. All rights reserved.
License Agreement
-----------------------------You should carefully read the following terms and conditions before using this software.
Your use of this software indicates your acceptance of this license agreement and warranty.
Conditions
------------------This software is free but IF YOU PUBLISH RESULTS OBTAINED USING PHONEDIT SIGNAIX, YOU
MUST MENTION THE USE AND ORIGIN OF THE SYSTEM.
You may not:
(a) transfer, assign, use, copy, distribute or modify the program, in whole or in part.
(b) decompile, reverse assemble or otherwise reverse engineer the program.
(c) remove or alter any of the copyright notices or other proprietary markings on any copies of the
program.
WARRANTY
--------------LPL does not warrant that the program will meet your requirements or that the operation of the
program will be uninterrupted, error free or will appear as described in any documentation.
The user must assume the entire risk of using the program.
2
Manuel d’utilisation Phonedit Signaix
Un suivi de versions a été mis en place et permet de consulter les
nouveautés. Se reporter à la fin du manuel : §8, p. 41
Table des matières
1.
2.
Installation de Phonedit Signaix...................................................................................................................................... 5
1.1.
Installation « standard » ........................................................................................................................................... 5
1.2.
Installation avec le dispositif EVA2 ........................................................................................................................... 5
TUTORAT .......................................................................................................................................................................... 6
2.1.
2.1.1.
2.1.2.
2.2.
Ouvrir un fichier unique ....................................................................................................................................... 6
Ouvrir plusieurs fichiers en même temps............................................................................................................. 6
Leçon 2 : manipulation de l’affichage du signal ........................................................................................................ 8
2.2.1.
Modifier la zone affichée ..................................................................................................................................... 8
2.2.2.
Sélection de zone ............................................................................................................................................... 9
2.2.3.
Organiser les fenêtres ....................................................................................................................................... 10
2.2.4.
Duplication de vue ............................................................................................................................................ 10
2.2.5.
Propriétés graphiques ....................................................................................................................................... 11
2.2.6.
2.3.
La copie d’images pour illustrer des documents ................................................................................................ 11
Leçon 3 : Ecoute et enregistrement du son ............................................................................................................ 12
2.3.1.
Ecoute du signal sonore .................................................................................................................................... 12
2.3.2.
Enregistrement de signal sonore avec une carte audio multimédia ................................................................... 12
2.3.3.
2.4.
Enregistrement multiparamétrique de signaux (avec EVA2) .............................................................................. 13
Leçon 4 : Prise de mesure ..................................................................................................................................... 15
2.4.1.
Le curseur de mesure ....................................................................................................................................... 15
2.4.2.
La saisie manuelle de valeurs dans le tableur intégré Excel .............................................................................. 16
2.4.3.
La barre d’outils des opérateurs mathématiques ............................................................................................... 17
2.5.
3.
Leçon 1 : Ouverture de fichiers ................................................................................................................................ 6
Leçon 5 : Annotation et étiquetage ......................................................................................................................... 18
2.5.1.
Création d’un fichier d’annotation ...................................................................................................................... 18
2.5.2.
Mise à jour d’un fichier d’annotation .................................................................................................................. 18
2.5.3.
Procédure simple d’annotation .......................................................................................................................... 18
2.5.4.
Réglage des paramètres d’affichage de l’annotation ......................................................................................... 20
2.5.5.
Procédure d’annotation multi-niveaux ............................................................................................................... 21
2.5.6.
Informations et description des niveaux d’annotation ........................................................................................ 21
2.5.7.
Génération automatique de marqueurs ............................................................................................................. 22
2.5.8.
Exportation des marqueurs ............................................................................................................................... 23
Modules externes ........................................................................................................................................................... 24
3.1.
Modification d’amplitude......................................................................................................................................... 25
3.2.
Pré-emphase ......................................................................................................................................................... 26
3.3.
Filtre à fenêtre glissante ......................................................................................................................................... 26
3.4.
Filtre récursif .......................................................................................................................................................... 26
3.5.
Intensité RMS (Root Mean Square) ....................................................................................................................... 27
3.6.
Détection F0 (pitch) avec la méthode AMDF .......................................................................................................... 28
3.7.
Détection de F0 (pitch) avec la méthode Peigne .................................................................................................... 28
3.8.
Détection de F0 en cycle à cycle............................................................................................................................ 28
3.9.
Détection de F0 multi-méthodes et multi-passes .................................................................................................... 28
3.10.
Modélisation de la mélodie (MOMEL) et resynthèse PSOLA .................................................................................. 28
3.11.
Spectre (Fast Fourrier Transform) .......................................................................................................................... 28
3
Manuel d’utilisation Phonedit Signaix
4.
5.
3.12.
Spectre LPC (Linear Prediction Coding)................................................................................................................. 28
3.13.
Spectrogramme (sonagramme) ............................................................................................................................. 28
3.14.
Données EPG ........................................................................................................................................................ 28
3.15.
Données EMA........................................................................................................................................................ 28
Configuration du logiciel ............................................................................................................................................... 29
4.1.
Composants .......................................................................................................................................................... 29
4.2.
Ressources linguistiques ....................................................................................................................................... 29
4.2.1.
Choix de la langue utilisée ................................................................................................................................ 29
4.2.2.
Modifier la traduction ......................................................................................................................................... 29
4.2.3.
Traduire dans une nouvelle langue ................................................................................................................... 30
4.3.
Modifier les raccourcis clavier ................................................................................................................................ 31
4.4.
Le répertoire de travail : une zone d’import/export permanente .............................................................................. 31
4.5.
Le format natif des signaux et données calculées .................................................................................................. 31
4.5.1.
Pourquoi un format natif ? ................................................................................................................................. 31
4.5.2.
Le format natif : fichier des données brutes + fichier texte descripteur ............................................................... 31
Ajout de plugins ............................................................................................................................................................. 35
5.1.
Architecture logicielle générale .............................................................................................................................. 35
5.2.
Conditions d’intégration des plugins dans Phonedit ............................................................................................... 35
5.2.1.
5.2.2.
5.3.
Formats d’entrée/sortie ..................................................................................................................................... 35
Déclaration dans le fichier de configuration des plugins .................................................................................... 35
Exécutables encapsulés dans un script shell ......................................................................................................... 37
6.
Utilisation des plugins en bash Cygwin........................................................................................................................ 39
7.
Dépannage ...................................................................................................................................................................... 40
8.
Suivi de versions ............................................................................................................................................................ 41
8.1.
Nouveautés 4.0.0.6 (2011-03)................................................................................................................................ 41
4
Manuel d’utilisation Phonedit Signaix
1. Installation de Phonedit Signaix
1.1. Installation « standard »
Télécharger la dernière version de ’PHONEDIT Signaix Setup.exe’ à l’adresse :
1. Ouvrir un explorateur Internet et aller sous
http://www.lpl-aix.fr/~lpldev/phonedit/download.html
2. télécharger Registration Key et noter le code en respectant la casse
3. télécharger ‘PHONEDIT Sigaix Setup.exe’
4. double clic sur ‘PHONEDIT Sigaix Setup.exe’
1.2. Installation avec le dispositif EVA2
Les utilisateurs qui souhaitent utiliser Phonedit pour des enregistrements multiparamétriques avec la
station EVA 2 doivent procéder de la façon suivante :
-
Installer Phonedit
-
Installer les pilotes de la carte Data Translation utilisée par EVA
-
Installer le logiciel SESANE ou tout au moins l’application d’enregistrement EvaRecorder.exe
(consulter le site SQLab : http://www.sqlab.fr/sesaneDownload.htm)
Pour effectuer des enregistrements multiparamétriques, se reporter au chapitre 2.3.3, p.13.
5
Manuel d’utilisation Phonedit Signaix
2. TUTORAT
2.1. Leçon 1 : Ouverture de fichiers
2.1.1. Ouvrir un fichier unique
Sélectionnez le menu "Fichier | Ouvrir" ou cliquez sur l'icône . Une boîte de sélection s'affiche.
Sélectionnez le type de fichiers puis un fichier audio.
Une fenêtre fille apparaît dans l'espace de travail de PHONÉDIT.
0.2
0.1
0.0
-0.1
-0.2
0
0min 2s 0ms
0min 4s 0ms
0min 6s 0ms
0min 8s 0ms
0min 10s 0ms
0min 12s 0ms
ms
0min 14s 0ms
Il est aussi possible d'utiliser la fonction "déplacer-déposer" (drag and drop) de windows:
- ouvrir phonedit
- ouvrir un explorateur de fichiers
- cliquer une fois sur le fichier à ouvrir, maintenir le bouton de la souris appuyé
- se déplacer vers la fenêtre phonedit et lâcher le bouton
2.1.2. Ouvrir plusieurs fichiers en même temps
Ouverture asynchrone de plusieurs fichiers
Il est possible d'ouvrir en même temps plusieurs fichiers non synchronisés (ex: 2 enregistrements
différents). Ceux-ci seront affichés avec des axes temporels non synchronisés.
Utiliser plusieurs fois la fonction
d'ouverture de fichier unique
comme ci-dessus.
6
Manuel d’utilisation Phonedit Signaix
Ouverture synchrone de plusieurs fichiers
Il est possible d'ouvrir en même temps plusieurs fichiers synchronisés (ex: fichier audio + egg + débits
d'air…). Ceux-ci seront affichés avec des axes temporels synchronisés.
Ouverture synchrone dès l'ouverture
Pour cela, lors de l'ouverture (Fichier Ouvrir), sélectionner plusieurs fichiers en utilisant la sélection
multiple (touche CTRL enfoncée avec clic souris)
Ouverture synchrone progressive
Si vous souhaitez ouvrir un fichier de façon synchrone à un fichier déjà affiché, sélectionnez le menu
"Fichier | Ouvrir Synchrone" ou cliquez sur l'icône . Une boîte de sélection s'affiche. Sélectionnez le
type de fichiers puis un fichier. Une fenêtre fille supplémentaire apparaît dans l'espace de travail de
PHONÉDIT.
Ouverture par glisser-déplacer (drag and drop)
PHONÉDIT prend en charge la fonction système faire glisser et déplacer (Drag and drop). Cette
fonction consiste à sélectionner un ou plusieurs fichiers dans le fenêtre de gestionnaire de fichiers et
faire glisser la sélection, en maintenant le bouton gauche de la souris, vers la fenêtre de PHONÉDIT.
Lorsque vous relâchez le bouton gauche de la souris, le logiciel ouvre automatiquement les fichiers
choisis.
7
Manuel d’utilisation Phonedit Signaix
2.2. Leçon 2 : manipulation de l’affichage du signal
2.2.1. Modifier la zone affichée
Pour modifier la zone affichée, plusieurs méthodes sont possibles:
A. Utiliser le menu "Affichage", horizontal, vertical…
1
B. Utiliser les raccourcis clavier (voir dans menu "Affichage"). Par défaut , les raccourcis sont:
Ctrl+E
pour vue complète avec échelles automatiques (horizont. et verti.)
'*' du pavé numérique
pour vue de toute la durée du signal
'+' du pavé numérique
pour zoom avant horizontal
'-' du pavé numérique
pour zoom arrière horizontal
Ctrl+'*' du pavé numérique pour échelle verticale automatique
Ctrl+'+' du pavé numérique pour zoom avant vertical
Ctrl+'-' du pavé numérique pour zoom arrière vertical
'flèche gauche'
pour visualiser la partie gauche
'flèche droite'
pour visualiser la partie droite
'flèche haut'
pour voir partie haute du signal
'flèche bas'
pour voir partie basse du signal
C. Utiliser les icones
Pour zoomer (voir une portion plus réduite)
Pour dézoomer (voir une portion plus large)
Pour augmenter la précision verticale (échelle des ordonnées)
Pour diminuer la précision verticale (échelle des ordonnées)
Pour remettre l'affichage automatique
2
Pour afficher la portion de signal à droite (possible uniquement si zoom temporel )
2
Pour afficher la portion de signal à gauche (possible uniquement si zoom temporel )
D. Utiliser les ascenseurs
Pour déplacer la portion
affichée.
Pour régler le zoom
2
E. Utiliser la méthode "déplacer-déposer" (possible uniquement si zoom temporel ) :
Cliquer sur le signal, maintenir le bouton appuyé, bouger la souris à gauche ou à droite puis
relâcher.
F. Utilisez la molette de la souris
 Mouvement de molette déplacement gauche ou droit
 Touche Shift + Mouvement de molette zoom horizontal avant ou arrière
 Touche Ctrl + Mouvement de molette changement de l’échelle des ordonnées
1
Ces raccourcis peuvent être individualisés en modifiant le fichier de configuration
RépertoirePhonedit\config\PhoneditStrings.FRA, voir la section [STRING_ACCEL]
2
Pour pouvoir "déplacer" la zone affichée, il faut auparavant avoir effectué un zoom avant. Si tout le signal est affiché, il est
impossible de visualiser la partie gauche ou droite de la zone affichée.
8
Manuel d’utilisation Phonedit Signaix

Clic simple sur la molette (sans la tourner)  recadrage automatique du signal
G. Utiliser les propriétés d'affichage : bouton droit sur le signal, menu "Propriétés"
Pour régler l'échelle verticale
Pour régler l'échelle horizontale (temps)
2.2.2. Sélection de zone
Pour sélectionner une partie de signal :
a. appuyez sur la touche Shift et la maintenir appuyée
b. cliquez sur le signal pour définir une borne de la sélection et maintenir le bouton appuyé
c. déplacez la souris jusqu’à l’autre borne et lâchez les boutons et touches
d. la zone sélectionnée apparaît en noir
Cette sélection peut être utile pour :
 zoomer directement sur cette zone : après avoir sélectionné la portion, cliquer sur
 écouter uniquement cette portion : après avoir sélectionné la portion, cliquer sur
 mesurer manuellement des durées
Position du début
de la sélection
Durée de la
sélection.
9
Manuel d’utilisation Phonedit Signaix
2.2.3. Organiser les fenêtres
Disposition des fenêtres
Il est possible d'arranger les fenêtres en utilisant le menu "Fenêtres", agencement, cascade,
minimiser, restaurer, fermer…
Système de pages
Une fois l'organisation des fenêtres correctes, il est possible de "mémoriser" temporairement (pendant
l'ouverture des fichiers) la position des fenêtres affichées en utilisant le menu "Fenêtre | Mémoriser
comme page" et en attribuant un numéro de page. Vous pouvez ainsi modifier la disposition des
fenêtres facilement (ex: affichage du signal audio + intensité sur la page 1, affichage du signal audio
+ egg + F0 sur la page 2, affichage du signal audio + débits d'air sur la page 3). Pour afficher une
autre page que celle actuellement visible, il suffit de sélectionner le menu "Fenêtre | Afficher page…"
si ces pages ont été auparavant mémorisées.
2.2.4. Duplication de vue
Il est possible de dupliquer une vue de façon à avoir un affichage global (vue 1) et un affichage plus
précis (vue 2). Pour cela, cliquez sur la vue à dupliquer et sélectionnez le menu "Affichage | Dupliquer
la vue". Une deuxième fenêtre apparaît. Tout changement dans la portion observée sur la première
fenêtre sera visualisé sur la seconde fenêtre.
10
Manuel d’utilisation Phonedit Signaix
2.2.5. Propriétés graphiques
Pour modifier les propriétés graphiques des signaux, cliquez avec le bouton droit sur la fenêtre de
signal puis sélectionnez le menu « Propriétés », onglet Motif
0.1
0.0
-0.1
0
500
1000
1500
2000
2500
3000
3500
ms
4000
Pour changer le fond
Pour changer les échelles et la grille
Pour changer la courbe
2.2.6. La copie d’images pour illustrer des documents
Le presse-papiers est un outil utile pour échanger des données et exporter des images d'une
application vers une autre. PHONÉDIT a été développé de manière à utiliser pleinement cet outil.
Lorsque vous utilisez le menu “ Edition | Copier ”, la courbe sélectionnée est stockée dans le pressepapiers sous forme d’image. Une boite de dialogue vous permet de proportionner la taille de l’image.
Après avoir copier l’image, sélectionnez le document (Word, Power Point…) dans lequel vous voulez
insérer l’image. Sélectionnez le menu « Collage spécial » de votre logiciel cible et essayez les
multiples formats d’image. En général, cette image est entièrement éditable à l'aide de l'éditeur
d'image vectoriel de votre choix, et peut être modifié ou annoté comme vous le désirez.
11
Manuel d’utilisation Phonedit Signaix
2.3. Leçon 3 : Ecoute et enregistrement du son
2.3.1. Ecoute du signal sonore
Pour écouter le son, cliquez sur l’icône
.
Pour n’écouter qu’une partie du signal, faites une sélection (voir § 2.2.2) et cliquez sur l'icône
.
Si vous avez placé un curseur de mesure, seule la partie à droite du curseur sera produite.
Il est possible de régler le volume d’écoute ou de couper la production sonore en utilisant les outils de
la barre d’icones.
Pour régler le volume.
Pour rendre muette la
production sonore
2.3.2. Enregistrement de signal sonore avec une carte audio multimédia
Pour enregistrer le signal sonore, cliquez sur l’icône
La fenêtre d’enregistrement apparaît.
Pour choisir la fréquence d’échantillonnage
Pour limiter la durée de l’enregistrement
(arrêt automatique si cette durée est atteinte)
Pour lancer l’enregistrement.
Pour contrôler le niveau.
Pour afficher le module de contrôle simple
Pour ouvrir le module de contrôle Windows
Pour sélectionner la source d’enregistrement.
Pour régler le volume d’enregistrement.
12
Manuel d’utilisation Phonedit Signaix
Pour arrêter l’enregistrement
2.3.3. Enregistrement multiparamétrique de signaux (avec EVA2)
Vérifier au préalable que l’installation est correcte (se reporter à 1.2, p.5)
Pour enregistrer avec Phonedit des données multiparamétriques du dispositif EVA2, sélectionner au
préalable le menu « Outils | Enregistreur | EVA »
Pour enregistrer les données, cliquez sur l’icône
La fenêtre d’enregistrement multiparamétrique apparaît. Sélectionnez les signaux à enregistrer puis
cliquez sur « Lancer »
Si vous souhaitez mémoriser une configuration :
1. Cliquez sur le bouton « Nouveau » puis donnez un nom à la configuration
2. Sélectionnez vos signaux
3. Cliquez sur le bouton « Sauver »
Lors du prochain enregistrement, choisissez votre configuration dans la liste.
13
Manuel d’utilisation Phonedit Signaix
14
Manuel d’utilisation Phonedit Signaix
2.4. Leçon 4 : Prise de mesure
2.4.1. Le curseur de mesure
Cliquez sur l'icône
courbe.
pour faire apparaitre le curseur de mesure. Déplacez le curseur le long de la
Notez que la valeur du signal à la position temporelle du curseur est affichée dans chaque fenêtre.
Pour faire disparaître le curseur de mesure, cliquez à nouveau sur l'icône
15
Manuel d’utilisation Phonedit Signaix
2.4.2. La saisie manuelle de valeurs dans le tableur intégré Excel
Pour activer le tableur, cliquez sur l’icône . Sauf problème d’installation, une feuille de type Excel
apparaît. Faites apparaître le curseur de mesure en cliquant sur l'icône
et positionnez le à
l’emplacement temporel souhaité.
Cliquez sur la fenêtre du signal où vous souhaitez prendre des mesures.
Tapez ‘X’ pour copier la valeur temporelle dans le tableur (ou menu Tableur | Copier vers tableur | X)
Tapez ‘Y’ pour copier la valeur du signal dans le tableur (ou menu Tableur | Copier vers tableur | Y)
Changez de fenêtre de signal si nécessaire.
Tapez ‘Y’ pour copier la valeur du signal dans le tableur (ou menu Tableur | Copier vers tableur | Y)
Pour changer de ligne dans le tableur, tapez ‘Return’ (ou menu Tableur | Saut de Ligne)
Dans la fenêtre du tableur, vous pouvez retrouvez toutes les fonctionnalités d’Excel :
Undo Couper Copier Coller Somme Tri Exporter les données Excel
Problème avec le tableur Excel. Que faire ?
Le tableur excel ne s'ouvre pas. La Dll Msowc.dll ne s'est pas identifiée.
Solution :
- exécuter une console en tant qu'administrateur
(menu démarrer | Accessoires | Invite de commande (bouton droit executer en tant qu'administrateur)
- taper la commande : regsvr32 "c:\prog…\phonedit\msowc.dll"
16
Manuel d’utilisation Phonedit Signaix
2.4.3. La barre d’outils des opérateurs mathématiques
Vérifier au préalable que la barre d’outils d’opérateurs mathématiques est affichée :
- Menu Affichage | Barre d’Outils | Opérateurs mathématiques
Pour utiliser ces outils :
1. Sélectionner la partie à
analyser (voir § 2.2.2, p.9)
2. Utiliser un opérateur
3. Le résultat s'affiche
4. Cocher si vous souhaitez que
les résultats soient copiés
automatiquement dans le
tableur intégré décrit ci-dessus.
: Durée de la sélection
: Moyenne sur les données de la sélection
: Valeur minimale
: Valeur maximale
: Intégrale (utile par exemple pour calculer des volumes à partir des débits d’air)
Remarque : pour faciliter la prise de mesures répétitives, la barre d’outils peut être détachée et placée
à un emplacement souhaité.
17
Manuel d’utilisation Phonedit Signaix
2.5. Leçon 5 : Annotation et étiquetage
2.5.1. Création d’un fichier d’annotation
1. Ouvrir un fichier audio
2. Sélectionner le menu « Marqueurs | Nouveau fichier d’étiquettes »
3. Attribuez un nom à ce fichier
Remarque : le fichier sera mis à jour automatiquement après chaque insertion, suppression,
changement d’étiquette. Il n’est donc pas nécessaire de sauvegarder les modifications.
En revanche, toute modification sera définitive.
4. Passez au § 2.5.3 ci-dessous
2.5.2. Mise à jour d’un fichier d’annotation
1. Ouvrir un fichier audio
2. Sélectionner le menu « Marqueurs | Ouvrir fichier d’étiquettes »
3. Choisissez le fichier d’annotation
2.5.3. Procédure simple d’annotation
Une fois un fichier d’annotation affiché à l’écran (voir ci-dessus),
1. Cliquez à l’intérieur de la fenêtre d’annotation pour sélectionner le niveau d’annotation (un
seul dans ce paragraphe)
2. Attribuez, si besoin, un nom à ce niveau d’annotation. Pour cela, cliquez avec le bouton droit
sur le niveau et sélectionnez le menu « Propriétés » puis l’onglet « Descripteur de niveau ».
Attribuez un nom. Cette étape est optionnelle.
Marqueur événementiel (position temporelle à durée nulle)
Pour créer une étiquette événementielle (position temporelle à durée nulle) :
1.
2.
3.
4.
Utilisez le marqueur de mesure (cf § 2.4.1) : icône
Placez le marqueur à l’emplacement souhaité
Sélectionnez le menu « Marqueurs | créer étiquette » (raccourci clavier : Shift+ L)
Donnez un nom à l’étiquette. Celle-ci apparaîtra automatiquement dans la fenêtre
d’annotation
18
Manuel d’utilisation Phonedit Signaix
Marqueur de zone (intervalle à durée non nulle)
Pour créer un marqueur de zone (intervalle à durée non nulle) :
1. Faites une sélection temporelle (cf § 2.2.2)
2. Sélectionnez le menu « Marqueurs | créer étiquette » (raccourci clavier : Shift+ L)
3. Donnez un nom à l’étiquette. Celle-ci apparaîtra automatiquement dans la fenêtre
d’annotation
Pour déplacer ou redimensionner un
marqueur de zone, cliquez sur la
bordure gauche.
Si vous déplacez la souris, l’intervalle
se déplacera en bloc (maintien de la
durée)
Si vous cliquez sur la poignée
gauche supérieure, vous modifierez
la bordure gauche.
Si vous cliquez sur la poignée droite
inférieure, vous modifierez la bordure
droite.
Vous
pouvez
aussi
ajuster
manuellement les paramètres de
l’intervalle en double cliquant sur la
frontière gauche de l’intervalle.
Ajustement de la position
Ajustement de la durée
19
Manuel d’utilisation Phonedit Signaix
2.5.4. Réglage des paramètres d’affichage de l’annotation
Pour
changer
la
couleur
l’épaisseur des étiquettes
et
Pour
verrouiller
l’annotation
(impossible de bouger alors une
étiquette)
Pour afficher les marqueurs sur la fenêtre de signal, cliquez avec le bouton droit sur la fenêtre de
signal et sélectionnez le menu « Afficher Marqueurs » puis niveau d’annotation.
20
Manuel d’utilisation Phonedit Signaix
2.5.5. Procédure d’annotation multi-niveaux
Pour ajouter un niveau d’annotation, sélectionnez le menu « Marqueurs | Nouveau niveau
d’annotation ». Attribuez un nom.
Un deuxième niveau apparaît.
La création d’étiquettes s’effectuera
sur le niveau d’annotation portant le focus.
L’affichage optionnel des étiquettes sur le signal
peut se paramétrer par niveau d’annotation.
Remarque : tous les niveaux d’annotation sont sauvegardés dans le même fichier
2.5.6. Informations et description des niveaux d’annotation
De façon optionnelle, vous pouvez renseigner les niveaux d’annotation.
Clic droit sur la fenêtre d’annotation, menu
« Propriétés », onglet Descripteur de niveau.
Attribuez une clé et une valeur
Validez l’information
Pour éditer, double cliquez sur le champ
Éditez-le et validez
Ces informations peuvent être utiles pour garder
une trace : qui a annoté ? comment ?...
21
Manuel d’utilisation Phonedit Signaix
2.5.7. Génération automatique de marqueurs
Il est possible de générer automatiquement une série de marqueurs. Pour cela :
- ouvrir un fichier de données
- ouvrir ou créer un fichier d’annotation
- créer un nouveau niveau d’annotation ou sélectionner un niveau existant
- utiliser le menu Marqueurs | Marqueurs automatique | marqueurs périodiques
Saisir l’origine temporelle
Saisir le n° du premier marqueur
Par exemple, sur cette figue, le Marqueur 0 est au
temps 0. Il est possible de proposer Marqueur 100
ième
au temps 450 ms si il correspond au 100
événement repéré à t=450 ms.
Saisir l’intervalle temporel entre deux marqueurs
consécutifs
Saisir la durée si nécessaire (peut être nulle si
événementiel).
22
Manuel d’utilisation Phonedit Signaix
2.5.8. Exportation des marqueurs
Format des données
Le fichier des marqueurs ci-dessus a la forme suivante :
[DSC_LEVEL_AA]
DSC_LEVEL_NAME="loriaphon"
[LBL_LEVEL_AA]
LBL_LEVEL_AA_000001="#" 748.500000 820.500000
LBL_LEVEL_AA_000002="k" 820.500000 924.500000
LBL_LEVEL_AA_000003="i" 924.500000 972.500000
LBL_LEVEL_AA_000004="l" 972.500000 996.500000
LBL_LEVEL_AA_000005="f" 996.500000 1084.500000
LBL_LEVEL_AA_000006="e" 1084.500000 1108.500000
LBL_LEVEL_AA_000007="S" 1108.500000 1220.500000
LBL_LEVEL_AA_000008="o" 1220.500000 1324.500000
LBL_LEVEL_AA_000009="a~" 1324.500000 1380.500000
LBL_LEVEL_AA_000010="f" 1380.500000 1452.500000
LBL_LEVEL_AA_000011="e" 1452.500000 1484.500000
LBL_LEVEL_AA_000012="l" 1484.500000 1612.500000
LBL_LEVEL_AA_000013="A" 1612.500000 1644.500000
LBL_LEVEL_AA_000014="d" 1644.500000 1708.500000
LBL_LEVEL_AA_000015="@" 1708.500000 1772.500000
LBL_LEVEL_AA_000016="d" 1772.500000 1836.500000
LBL_LEVEL_AA_000017="a~" 1836.500000 1860.500000
LBL_LEVEL_AA_000018="#" 1860.500000 138206.000000
[DSC_LEVEL_AC]
DSC_LEVEL_NAME=token
DSC_LEVEL_CORPUS=CID
DSC_LEVEL_SOURCE=LPL
DSC_LEVEL_SPEAKER=Alain Ghio
DSC_LEVEL_CONTENT=Tokens
DSC_LEVEL_OPERATOR=Zoé Wips
DSC_LEVEL_LASTMODIF_DATE=2010/01/13 23:45:15
DSC_LEVEL_SOFTWARE=Phonedit Application 4. 0. 0. 5
[LBL_LEVEL_AC]
LBL_LEVEL_AC_000001="qu'" 820.500000 924.500000
LBL_LEVEL_AC_000002="il" 924.500000 996.500000
LBL_LEVEL_AC_000003="fait" 996.500000 1108.500000
LBL_LEVEL_AC_000004="chaud" 1108.500000 1324.500000
LBL_LEVEL_AC_000005="en_fait" 1324.500000 1484.500000
LBL_LEVEL_AC_000006="là-dedans" 1484.500000 1860.500000
Importation des données dans un tableur Excel
1.
2.
3.
4.
5.
6.
Exécutez Excel
Fichier Ouvrir, sélectionner le fichier des marqueurs (de type *.mrk par défaut)
Lors du questionnement : « Type de données d’origine », choisir « Délimité »
Choisir les séparateurs : Tabulation, Autre (=)
Finir l’importation
Des colonnes contiendront le texte de l’étiquette, la position gauche puis la position droite
23
Manuel d’utilisation Phonedit Signaix
3. Modules externes
Liste des modules – Avril 2010
Exécutable
DataRawDesc.exe
DataSigevaToRaw.exe
DataWavToRaw.exe
DataRawDescToSigeva.exe
DataRawDescToWav.exe
WriteDescriptor.exe
LabelNative.exe
LabelSesane.exe
LabelTextGridPraat.exe
GetRiffInfo.exe
DataWsigPlusInfo.exe
DspLyapCoef.exe
DataExtract.exe
DataWaveToWavePlusInfo.exe
DataAmplify.exe
FilterEmphasis.exe
FilterMovingAverage.exe
FilterRecursive.exe
GetMarker.exe
DetectPause.exe
DspRmsIntensity.exe
SetDspRmsIntensity.exe
SetFilterRecursive.exe
Description
Lecture de fichier signal Raw
Lecture de fichiers EVA2 Sesane
Lecture de fichiers Wave
Sauvegarde au format EVA2 Sesane
Sauvegarde au format Wave PCM
Ecriture de fichier desc
Lecture des fichiers natifs d’étiquettes
Lecture des fichiers SESANE d’étiquettes
Lecture fichiers Praat d’étiquettes
Lecture des entêtes enrichis des fichiers Riff
(ex : wav)
Lecture des entêtes enrichis des fichiers
EVA2 Sesane
Calcul du Plus Grand Exposant de Lyapounov
Pour extraire une partie de signaux
Pour enrichir les entêtes de fichiers Wave
Pour amplifier (+/-), normaliser le niveau
Pré emphase des aigues
Filtre à fenêtre glissante
Filtre récursif
Extraction d’information sur les labels
Détection des pauses silencieuses
Calcul de l’intensité RMS
Settings DspRmsIntensity
Settings FilterRecursive
Type
Lecture signal
Lecture signal
Lecture signal
Ecriture signal
Ecriture signal
Ecriture signal
Lecture labels
Lecture labels
Lecture labels
GetInfo signal
GetInfo signal
GetInfo signal
Extraction signal
Transformation signal
Transformation signal
Transformation signal
Transformation signal
Transformation signal
GetInfo Labels
Analyse signal
Analyse signal
Settings
Settings
Pour effectuer une transformation ou une analyse, sélectionner le menu « Outils | Analyse »
Sélectionner le module
Vérifier les informations
Optionnel :
Changer les paramètres
Changer le nom de sortie
Exécuter
 Avec un paramétrage interactif
 Directement
24
Manuel d’utilisation Phonedit Signaix
3.1. Modification d’amplitude
NOM :
Signal Amplifier (DataAmplify.exe)
ACTION :
Modifie l’amplitude d’un signal
APPLIQUER SUR :
Signaux ondulatoires
PRESENTATION :
La fonction transforme le signal en modifiant l’amplitude de façon uniforme sur
toute la durée.
INSTRUCTIONS
D'UTILISATION :
La transformation démarre dés le lancement de la fonction.
PROPRIETES :
Il existe 2 méthodes d’amplification :

gain : la valeur du gain est la valeur en dB de l’amplification
ex : -gain 6  double l’amplitude, -gain -12  amplitude divisée par 4

normalize : la valeur de l’amplitude maximale du signal en dB
ex : -normalize 0  normalisation au max sans saturer
-normalize -6  normalisation au max/2
Remarque : les deux options sont exclusives
25
Manuel d’utilisation Phonedit Signaix
3.2. Pré-emphase
NOM :
Signal pre-emphasis (FilterEmphasis.exe)
ACTION :
Filtrage passe-haut rapide (+6 dB/oct)
APPLIQUER SUR :
Signaux ondulatoires.
PRESENTATION :
La fonction effectue un filtrage passe-haut rapide du type
z(n) = 1 – alpha.z(n-1)  +6 dB/oct
INSTRUCTIONS
D'UTILISATION :
La transformation démarre dés le lancement de la fonction.
Elle est généralement utilisée sur un signal de parole pour compenser la pente
de -6 dB/oct présente dans le spectre de la parole. Appliquer ce filtre permet de
rétablir un spectre à tendance « plate »
PROPRIETES :
Le coefficient alpha compris entre 0 et 1, détermine la fréquence de coupure du
er
1 ordre.
3.3. Filtre à fenêtre glissante
En cours de rédaction.
3.4. Filtre récursif
En cours de rédaction.
26
Manuel d’utilisation Phonedit Signaix
3.5. Intensité RMS (Root Mean Square)
NOM :
Intensité RMS
ACTION :
Calcule l'Intensité RMS d'un signal et l'affiche. L'Intensité RMS correspond à
l'amplitude moyenne d'un signal sur une durée déterminée appelée temps
d'intégration. Cette courbe peut être affichée en linéaire ou décibels.
APPLIQUER SUR :
Signaux acoustiques, électromyographiques.
PRESENTATION :
La fonction affiche la courbe d'intensité de manière synchronisée avec toutes
les autres courbes. L'axe horizontal représente le temps, et le vertical
l'Intensité.
INSTRUCTIONS
D'UTILISATION :
L'Intensité est calculée dés le lancement de la fonction.
Avertissement
Il est bien connu qu'il est possible de calculer le niveau d'intensité absolu d'un
son enregistré avec une carte son PC : le niveau d'intensité dépend du
microphone et du volume d'entrée. Comparer les intensités absolues de
différents signaux est hasardeux car un signal peut avoir été enregistré plus
bas qu'un autre... Seules les mesures relatives à l'intérieur d'un signal sont
adaptées (ex : l'intensité est plus basse de 20 dB à la fin qu'au milieu)
PROPRIETES :
Paramètres temporels
L'intensité RMS correspond à l'amplitude moyenne d'un signal. Cette mesure
est calculée sur une trame de signal dont la longueur est appelée “ temps
d'intégration ”. Une valeur de 10-20 ms est adaptée à la parole, mais dans le
cas d'une voix très basse, il est plus judicieux de fixer une valeur plus grande
(environ 50 ms).
En général, l'intensité est calculée sur une fenêtre de signal sans
chevauchement, ce qui signifie que le décalage entre trames est égal à la taille
de la fenêtre. Si vous voulez que les fenêtres se chevauchent, sélectionnez un
décalage inférieur à la durée de la trame.
Paramètres
d'amplitude
L'intensité RMS peut être affichée en valeurs linéaires ou en décibels. Comme
il s'agit d'une valeur en racine, ce qui correspond à une amplitude, la
transformation en décibels est : dB = 20. Log10(linéaire).
Avec un affichage en dB, sachant que la valeur absolue est flottante (voir
avertissement ci-dessus), il est possible de fixer une valeur arbitraire pour la
valeur maximale.
27
Manuel d’utilisation Phonedit Signaix
3.6. Détection F0 (pitch) avec la méthode AMDF
En cours d’intégration.
3.7. Détection de F0 (pitch) avec la méthode Peigne
En cours d’intégration.
3.8. Détection de F0 en cycle à cycle
En cours d’intégration.
3.9. Détection de F0 multi-méthodes et multi-passes
En cours d’intégration.
3.10.Modélisation de la mélodie (MOMEL) et resynthèse PSOLA
En cours d’intégration.
3.11. Spectre (Fast Fourrier Transform)
En cours d’intégration.
3.12. Spectre LPC (Linear Prediction Coding)
En cours d’intégration.
3.13. Spectrogramme (sonagramme)
En cours d’intégration.
3.14. Données EPG
En cours d’intégration.
3.15. Données EMA
En cours d’intégration.
28
Manuel d’utilisation Phonedit Signaix
4. Configuration du logiciel
4.1. Composants
Composants installés dans \Program Files\...\phonedit
Phonedit.exe
PhoneditLanguageManager.exe
Programme Principal
Gestion des ressources linguistiques
MMDiagMixer.exe
Programme de test Multimedia
MFC42D.DLL, MFCO42D.DLL
MSOWC.DLL
MSVCRTD.DLL
config/
templates/
plugins/
DLL Microsoft Foundation Class
DLL Excel
Microsoft C++ Runtime Library
REPERTOIRE de configuration
REPERTOIRE de modèles
REPERTOIRE des modules externes (plugins)
4.2. Ressources linguistiques
4.2.1. Choix de la langue utilisée
Il est possible de choisir différentes langues d’utilisation.
Pour cela, sélectionner le menu « Outils | Assistant pour la gestion des langues »
Choisir la langue.
Fermer l’assistant et Phonedit. La modification sera effective lors d’un nouveau démarrage du logiciel.
4.2.2. Modifier la traduction
Il est possible de modifier la traduction des menus et messages du logiciel.
Pour cela, sélectionner le menu « Outils | Assistant pour la gestion des langues »
Dans l’assistant pour la gestion des langues, choisir la langue
29
Manuel d’utilisation Phonedit Signaix
Choisir la langue.
Choisir le thème
Choisir l’item
Modifier
Valider
4.2.3. Traduire dans une nouvelle langue
Il est possible de traduire les menus et messages du logiciel. Pour cela, sélectionner le menu « Outils
| Assistant pour la gestion des langues »
Dans l’assistant pour la gestion des langues, sélectionner le menu « File | New »
Remplir les champs.
Traduire tous les items de la nouvelle langue (voir ci-dessus pour modifier la traduction)
30
Manuel d’utilisation Phonedit Signaix
4.3. Modifier les raccourcis clavier
Choisir la langue.
Choisir le thème
« ACCELerators »
Choisir l’item
Modifier
Valider
4.4. Le répertoire de travail : une zone d’import/export permanente
Le répertoire de travail de Phonedit est situé dans le répertoire temporaire de l’utilisateur.
Par exemple : C:\Documents and Settings\ghio\Local Settings\Temp\PhoneditWorkSpace
Ce répertoire est le réceptacle des données « natives » (signaux, résultats de calcul…) Ainsi, lors de
l’ouverture de signal, le fichier est copié dans ce répertoire et traduit au format brut avec descripteur
(voir plus loin). De même, lors d’une transformation ou d’une analyse, le résultat est stocké dans ce
répertoire. Il est donc possible à tout moment d’accéder aux données intermédiaires pour les éditer ou
les analyser avec un autre logiciel.
Pour accéder à ce répertoire de travail, sélectionner le Menu « Outils | Ouvrir l’espace de travail »
4.5. Le format natif des signaux et données calculées
4.5.1. Pourquoi un format natif ?
Pour faciliter les procédures de traitement, il est nécessaire de définir un format natif des données.
Ainsi, tout signal d’entrée sera systématiquement converti dans ce format natif. Ainsi, tous les modules
de traitement seront conçus pour accepter en entrée ce format natif (sans se préoccuper du format
originel des données) et fourniront les résultats dans ce même format standard. Des modules
d’écritures pourront ensuite transformer ces données en un autre format de sortie.
4.5.2. Le format natif : fichier des données brutes + fichier texte descripteur
La plupart des fichiers de données (ex : fichier wav) comporte un entête ou plusieurs entêtes parfois
complexes qui encodent les données et une partie incorporant les données proprement dites. Il peut
être complexe de lire et interpréter toutes les informations de telles structures. Par exemple, il faut
31
Manuel d’utilisation Phonedit Signaix
ième
savoir que le 12
octet de l’entête permet de connaître la fréquence d’échantillonnage, certaines
informations peuvent changer de position d’un fichier à l’autre…
Nous avons adopté un format plus universel. Le format de fichier natif adopté est sous la forme de 2
entités : un fichier binaire des données brutes (*.raw) auquel est associé un fichier texte descripteur
des données.
Le fichier des données est un fichier binaire brut contenant uniquement les données.
Le fichier descripteur est un fichier texte organisé décrivant les données.
Exemple de descripteur d’un fichier audio
[CODING]
CODING_version=ProfileDescriptor
2009/04/0213:31:29 ; datasigdef 2009/06/17-14:26:49
Version du codage
[SETTINGS]
DATA_NAME=Waveform
DATA_TYPE=temporal_serie
DATA_VAR_FORMAT=int16_intel
ACRONYM='wave'
DATA_COUNT=29879
SAMPLING_RATE=44100
Caractéristiques
Nom du signal
Type de signal
Format du binaire
Identité du signal
Nombre d’échantillons
Fréquence d’échantillonnage
[SCALE]
H_UNIT=ms
V_UNIT=
FLOAT_VALUE_AT_MAX=1.000000
SIGNAL_DYNAMIC=32767.000000
SIGNAL_ZERO=0
Facteurs d’affichage et d’échelles
Unité des abscisses
Unité des ordonnées
Valeur analogique à pleine échelle
Valeur numérique à pleine échelle
Valeur numérique du zéro
[INFO]
SOURCE=K:\signaux\bette.wav
SRC_RATE=44100
SRC_BITSPERSAMPLE=16
SRC_NCHANNELS=1
SRC_FORMATTAG=1
SRC_FORM=Ms Windows PCM | 44100 Hz | 16 bits mono
| 0.678 s | ...
COMMAND=DataWavToRaw.exe
-input
"K:\signaux\bette.wav"
-output
"C:\DOCUME~1\ghio\LOCALS~1\Temp\PhoneditWorkSpace
\bette.wav.raw"
Informations
Données originelles
Fréquence d’échantillonnage de la source
Nb de bits par échantillons de la source
Nb de canaux originels de la source
Format de fichier source (PCM, ADPCM…)
Caractéristiques générales
32
Ligne de commande pour obtenir les données
Manuel d’utilisation Phonedit Signaix
Exemple de descripteur d’un fichier aérodynamique calibré avec saisie des informations sur
le locuteur (SESANE EVA2)
[CODING]
CODING_version=ProfileDescriptor 2009/04/0213:31:29 ; datasigdef 2009/06/17-14:26:49
Version du codage
[SETTINGS]
DATA_NAME=Débit d'air oral
DATA_TYPE=temporal_serie
DATA_VAR_FORMAT=int16_intel
ACRONYM='oaf '
DATA_COUNT=87552
SAMPLING_RATE=6250
Caractéristiques
Nom du signal
Type de signal
Format du binaire
Identité du signal
Nombre d’échantillons
Fréquence d’échantillonnage
[SCALE]
H_UNIT=ms
V_UNIT=dm3/s
FLOAT_VALUE_AT_MAX=2.000000
SIGNAL_DYNAMIC=32767.000000
SIGNAL_ZERO=0
Facteurs d’affichage et d’échelles
Unité des abscisses
Unité des ordonnées
Valeur analogique à pleine échelle
Valeur numérique à pleine échelle
Valeur numérique du zéro
[INFO]
SOURCE=K:\signaux\ALXX0000.oaf
SRC_RATE=6250
SRC_BITSPERSAMPLE=16
SRC_NCHANNELS=1
SRC_FORMATTAG=1
SRC_FORM=Signal RIFF Wsig 'Débit d'air oral' |
6250 Hz | 16 bits mono | 14.008 s | Recorded by
EVA 2 v.3323
SPEAKER_NAME=Aubanel
SPEAKER_FIRST_NAME=Vincent
SPEAKER_GENDER=M
SPEAKER_AGE=26
CONTENT=Lecture de la chèvre
COMMENT=Vitesse rapide
KEYWORDS=FUMEUR
CREATION_DATE=2008-6-24
COPYRIGHT=(c) SQLab 1998
SOFTWARE=VELUMLEAKAGE
COMMAND=DataSigevaToRaw.exe -input
"K:\signaux\ALXX0000.oaf" -output
"C:\DOCUME~1\ghio\LOCALS~1\Temp\PhoneditWorkSpace
\ALXX0000.oaf.raw"
Informations
Données originelles
Fréquence d’échantillonnage de la source
Nb de bits par échantillons de la source
Nb de canaux originels de la source
Format de fichier source (PCM, ADPCM…)
Caractéristiques générales
Nom du locuteur
Prénom du locuteur
Sexe du locuteur
Age du locuteur
Contenu
Commentaires
Mots clés
Date d’enregistrement
Copyright
Logiciel
Ligne de commande pour obtenir les données
Remarque : pour obtenir la valeur calibrée analogique à partir des données binaires de type INT16 :
Valeur_FLT = FLOAT_VALUE_AT_MAX * (Valeur_INT16 - SIGNAL_ZERO) / SIGNAL_DYNAMIC
Exemple : si lecture binaire Valeur_INT16 = 8000 ,
Valeur_FLT = 2 * (8000 – 0) /32767 = 0.488 dm3/s
33
Manuel d’utilisation Phonedit Signaix
Exemple de descripteur d’un plugin de calcul d’intensité( DspRmsIntensity.exe)
[CODING]
CODING_version=ProfileDescriptor 2010/03/0918:18:41 ; datasigdef 2010/03/15-15:11:21
Version du codage
[SETTINGS]
DATA_NAME=RMS Intensity
DATA_TYPE=temporal_serie
DATA_VAR_FORMAT=float_intel
ACRONYM='int '
DATA_COUNT=68
FRAME_SIZE=10.000000
SAMPLING_PERIOD=10.000000
Caractéristiques
Nom du signal
Type de signal
Format du binaire
Identité du signal
Nombre de mesures
Taille de la trame d’analyse
Taille de la trame d’analyse
[SCALE]
H_UNIT=ms
V_UNIT=dB
Facteurs d’affichage et d’échelles
Unité des abscisses
Unité des ordonnées
[INFO]
SOURCE=K:\signaux\bette.wav
SRC_RATE=44100
SRC_BITSPERSAMPLE=16
SRC_NCHANNELS=1
SRC_FORMATTAG=1
CREATION_DATE=08/04/2010
SOFTWARE=DspRmsIntensity.exe 1. 0. 0. 1
COPYRIGHT=Copyright © 2007 - LPL
OPTIONS=-frameSizeMs 10 -frameStepMs 10 amplitude dB -dBmax 0
COMMAND=DspRmsIntensity.exe -input
"C:\DOCUME~1\ghio\LOCALS~1\Temp\PhoneditWorkSpace
\bette.wav.raw" -output
"C:\DOCUME~1\ghio\LOCALS~1\Temp\PhoneditWorkSpace
\bette.wav_Size=10_Step=10_Ampl=dB.rms" frameSizeMs 10 -frameStepMs 10 -amplitude dB dBmax 0
Informations
Données originelles
Fréquence d’échantillonnage de la source
Nb de bits par échantillons de la source
Nb de canaux originels de la source
Format de fichier source (PCM, ADPCM…)
Date de calcul
Logiciel
Copyright
Options
Ligne de commande pour obtenir les données
Remarque :
Les données étant codées en valeur float, il n’est pas nécessaires d’introduire un facteur d’échelles
comme dans l’exemple précédent.
34
Manuel d’utilisation Phonedit Signaix
5. Ajout de plugins
5.1. Architecture logicielle générale
Les plugins sont des modules externes qui vont être utilisés par le logiciel pour lire/écrire, transformer,
projeter, mesurer, étiqueter des données.
Un plugin est un exécutable qui s’exécute avec des paramètres en lignes de commande de type :
Plugin.exe –input inFile –output outfile –paramA val1 –paramB val2
PHONEDIT.exe
DataTrucToRaw.exe
(plugin de lecture)
Fichier
source
Plugin.exe
(plugin de traitement)
Fichier
natif
Fichier
résultat
s
Répertoire de travail
Architecture logicielle et principe des plugins
5.2. Conditions d’intégration des plugins dans Phonedit
5.2.1. Formats d’entrée/sortie
Les fichiers inFile doivent être au format natif car Phonedit.exe fournira un fichier natif en entrée du
plugin (cf schéma ci-dessus).
Les fichiers outFile doivent être au format natif car l’affichage graphique dans Phonedit.exe nécessite
un fichier de résultats au format natif (cf schéma ci-dessus)
5.2.2. Déclaration dans le fichier de configuration des plugins
Sélectionner le menu « Outils | Modules d’extension » pour ouvrir le fichier de configuration des
plugins. Chaque plugin est déclaré sous la forme :
[NOM_DU_PLUGIN]
APP_PROCESS=pluginZ.exe
INFO_A=ceci est un info
La syntaxe varie selon les types de plugins.
35
Manuel d’utilisation Phonedit Signaix
Plugins de lecture
[SIG_READER_PLUGIN_WAV]
APP_PROCESS=DataWavToRaw.exe
FILE_DESC=Wave files
FILE_MASK=*.wav
Plugins d’écriture
[SIG_WRITER_PLUGIN_WAV]
APP_PROCESS=DataRawDescToWav.exe
FILE_DESC=Wave files
FILE_MASK=*.wav
Plugins de traitement
[DSP_PLUGIN_IRMSDLG]
APP_PROCESS=DspRmsIntensity.exe
TITLE=RMS Intensity
PARAM_INPUT=-input
PARAM_OUTPUT=-output
PARAM_PROCESS=-frameSizeMs 10 -frameStepMs 10 -amplitude dB -dBmax 0
OUTPUT_EXTENSION=.rms
OUTPUT_SUFFIX_FNAME=_Size=@-frameSizeMs@_Step=@-frameStepMs@_Ampl=@amplitude@
Dans cet exemple, le plugin sera exécuté avec la ligne de commande suivante :
DspRmsIntensity.exe
-input "C:\...\PhoneditWorkSpace\bette.wav.raw"
-output "C:\…\PhoneditWorkSpace\bette.wav_Size=10_Step=10_Ampl=dB.rms"
-frameSizeMs 10 -frameStepMs 10 -amplitude dB -dBmax 0
Si dans la déclaration du plugin est déclarée la ligne suivante :
APP_GUI_SETTINGS=SetDspRmsIntensity.exe
Cela signifie qu’il existe un exécutable SetDspRmsIntensity.exe de type boite de dialogue qui permet
de paramétrer le module avec une interactivité plus visuelle. Le Bouton « Dialog » sera alors activé
dans la fenêtre de lancement des plugins.
36
Manuel d’utilisation Phonedit Signaix
5.3. Exécutables encapsulés dans un script shell
Pour transformer des exécutables en plugins compatibles Phonedit, il est possible d’encapsuler cet
exécutable dans un script shell.
Exemple d’encapsulation de l’exécutable /opt/mes_outils/bin/irms
#------------------------# Arguments analysis
#------------------------lcmd=$@
size=10.0
step=10.0
while test "X$1" != X
do
case $1 in
-in*) input="$2" ; shift 2 ;;
-out*) output="$2" ; shift 2 ;;
-f|-frameSize) size=$2 ; shift 2 ;;
-p|-frameStep) step=$2 ; shift 2 ;;
-help|-h|-sos|-aide) cmdhelp ; exit 0 ;;
-*)
errmsg="Unknown Argument $1" ; error; exit 1 ;;
esac
done
#------------------------# Input descriptor
#------------------------dsc_input=$input.dsc
if test ! -f "$dsc_input"
then
echo "Descriptor file $dsc_input non available" >/dev/stderr
exit 1
fi
sampling=$(GetSamplingRateFromDesc < "$dsc_input")
#------------------------# JOB
#-------------------------
cat $input | /opt/mes_outils/bin/irms
F$sampling f$size p$step > $output
#------------------------# Output descriptor
#------------------------fsize=$(stat -c%s "$output")
datacount=$(expr $fsize / 4)
{
echo "[CODING]"
echo "CODING_version="$cmdVersion
echo "[SETTINGS]"
echo "DATA_NAME=RMS Intensity"
echo "DATA_TYPE=temporal_serie"
echo "DATA_VAR_FORMAT=float_intel"
echo "ACRONYM='int '"
echo "DATA_COUNT="$datacount
echo "FRAME_SIZE="$size
echo "SAMPLING_PERIOD="$step
echo "[SCALE]"
echo "UNIT=dB"
echo "[INFO]"
echo "SOURCE="$input
echo "CREATION_DATE="$(date)
echo "SOFTWARE="$cmdName $cmdVersion
echo "COPYRIGHT=Copyright © 2007 - LPL"
echo "OPTIONS=-frameSizeMs "$size" -frameStepMs "$step
echo "COMMAND=" $cmdName $lcmd
} > $output.dsc
Pour que ce script soit exécuté, il est nécessaire qu’il le soit à travers un interpréteur bash. Il faut donc
insérer une ligne APP_INTERPRETER dans la déclaration du plugin :
37
Manuel d’utilisation Phonedit Signaix
[DSP_PLUGIN_IRMS_MES]
APP_PROCESS=MesIrms.sh
TITLE=MES RMS Intensity
PARAM_INPUT=-input
PARAM_OUTPUT=-output
PARAM_PROCESS=-frameSize 10.0 -frameStep 10.0
OUTPUT_EXTENSION=.mrms
OUTPUT_SUFFIX_FNAME=_Size=@-frameSize@_Step=@-frameStep@
APP_INTERPRETER=C:\cygwin\bin\bash.exe -l
Pour que cela fonctionne correctement, il est nécessaire de bien configurer les PATH des différents
environnements.
38
Manuel d’utilisation Phonedit Signaix
6. Utilisation des plugins en bash Cygwin
Il est possible d’utiliser les plugins en dehors d’une utilisation interactive graphique comme, par
exemple, dans l’environnement Cygwin, un émulateur Linux sous Windows.
Au préalable, dans le fichier .bash_profile, déclarer et exporter le PHONEDITPATH :
PHONEDITPATH=/cygdrive/c/Progra~1/phonedit/
export PHONEDITPATH
Dans le répertoire \bin, ajouter les commandes suivantes :
\bin\DataWavToRaw :
CMD="DataWavToRaw"
while test "X$1" != "X"
do
arg_u="$arg_u "\'"$1"\'
shift
done
echo "$CMD $arg_u" > /dev/stderr
eval $PHONEDITPATH/plugins/$CMD.exe -nodlgbox "$arg_u"
et rendre ces commandes exécutables.
Il est ensuite possible de faire des scripts automatiques sous cygwin :
Exemple de script pour normaliser en amplitude un ensemble de fichiers audio :
DIR_SRC="K:/signaux-projets/chloe/brut/"
DIR_TARGET="K:/signaux-projets/chloe/normalise/"
DIR_TMP="K:/signaux-projets/chloe/tmp/"
cd $DIR_SRC
for wav in *.wav
do
# transforme en raw
DataWavToRaw -input $DIR_SRC$wav -output $DIR_TMP$wav".raw"
#normalise
DataAmplify -input $DIR_TMP$wav".raw" -output $DIR_TMP$wav".norm" -normalize -1
# en wav
DataRawDescToWav -input $DIR_TMP$wav".norm" -output $DIR_TARGET$wav
done
39
Manuel d’utilisation Phonedit Signaix
7. Dépannage
En cours de rédaction.
40
Manuel d’utilisation Phonedit Signaix
8. Suivi de versions
8.1. Nouveautés 4.0.0.6 (2011-03)

Précisions sur utilisation avec dispositif EVA2 :
Installation avec le dispositif EVA2, §1.2, p.5
Enregistrement multiparamétrique de signaux (avec EVA2), §2.3.3, p.13

La barre d’outils des opérateurs mathématiques, § 2.4.3, p.17
41
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising